Prepare the Workbench

Before starting the tutorial, Eclipse must be properly set up for ProvideX development. The following is assumed:

  • You are starting with a new Eclipse installation using default settings.
  • You are familiar with the basic Eclipse Workbench mechanisms, such as views and perspectives.

If you are not familiar with the basic Workbench mechanisms, please review the Getting Started chapter of the Eclipse Workbench User Guide.

ProvideX Plug-in Configuration

  1. If you still see the Eclipse Welcome page, click the arrow icon to begin using the Eclipse workbench.

  2. Select the menu item Goto workbench preferences Window > Preferences... to open the workbench preferences.

  3. The ProvideX plug-in for Eclipse requires a local copy of ProvideX; ProvideX programs are the engine behind the plug-in.

    Select the Goto the ProvideX Configuration preference page ProvideX preference page.

    • Set the path to the ProvideX executable by clicking the Browse... button and specify the ProvideX executable to use.
    • Set the port to be used for the Listener port.
      The ProvideX plug-in for Eclipse uses a NTHOST-like connection to a process where a listener program is started. This allows for improved performance since there is no wait for the environment to be initialized. The listener application waits for Eclipse to send information about the next event to be processed. The listener will then start the execution of a helper application that will perform the requested task.

    Configure ProvideX preference page

  4. Select the Goto the ProvideX Builder preference page ProvideX > Builder preference page and review / adjust the preferences to the appropriate values for your environment.

    Be sure to enable the options:

    • Compile Files that have no extension, if you have any source files without file extensions
    • Copy ProvideX Data Files
    • Copy Resource Files

    Verify ProvideX Builder preference page

  5. Select the Goto the ProvideX Import/Convert preference page ProvideX > Import/Convert preference page and review / adjust the preferences to the appropriate values for your environment. Be sure to enable the preference Automatically convert ProvideX programs to text so ProvideX programs will be converted to text during the import step below.

    Configure ProvideX preference page

  6. Select the Goto the Workspace/Build preference page General > Workspace > Build preference page. Confirm that the Build automatically option is checked.

    Workbench preference page

  7. Select the Go to the Java editor preferenec page General > Editors > File Associations preference page. Confirm that the file types *.pvc, *.pvs, *.pvt, and *.pvw are associated with the ProvideX Editor. These file extensions should be preset; if there are other file extensions that are used for ProvideX programs, they can be added now.

    Java Editor preference page

  8. To associate a file type with an editor press the File Types, Add... button. The New File Type dialogue will appear - enter the file extension in the File Type field then click OK.

  9. Press the Associated Editors, Add... button. The Editor Selection dialogue will appear - scroll down and select the ProvideX Editor from the list then click OK.

  10. Click OK to save the preferences.

Next Section: Create a ProvideX Project - Existing Source Code


Create a ProvideX Project - Existing Source Code

The following instructions explain how to create a new ProvideX project using existing source code files.

We will use the source code for a Demonstration Application originally shipped with ProvideX v8.30. The is a simple business application developed to show case ProvideX and includes the following:

  • Source code for the sample programs

  • NOMADS panels

  • Sample report files

Getting the Application

Go to the Sage Plug-in update site to download a ZIP file containing the files for this sample application.

Creating the Project

  1. Inside Eclipse, select the menu item File > New > ProvideX Project to open the New ProvideX Project wizard.

    Create DemoApp Project

    On this page, type "DemoApp" in the Project name field then click Finish. The New ProvideX Project Wizard will create a project called "DemoApp" in the current workspace.

  2. The ProvideX project will initially contain the following resources:

    DemoApp Project - Project Explorer View

    • An input directory (the DemoApp project's input directory is called "src")

    • An output directory (the DemoApp project's output directory is called "compiled")

    • A ProvideX ini file. The project's ini file name is composed of "PVX" then the project name, followed by the extension ".ini". The DemoApp project's ini file is called "PVXDemoApp.ini"

    • There is also a hidden ".project" file used by Eclipse to tell the Workbench that this project is associated with the ProvideX plug-in.

  3. The ProvideX (or Sage 100) perspective should now be open.

    If the ProvideX (or Sage 100) perspective is not open, select the menu item Window > Perspective > Open Perspective > Other... Select either ProvideX or Sage 100 from the list, and click OK.

  4. Create a 'project.properties' file in the project root folder and add the following lines:

    #
# Set project-specific properties
# ============================================================================
UseLineNumberIncFromAI=true
#
# APPEND to existing property value
appendPreferenceS._CommonResourceFileExtensions=cs php pvr pvrlib xml xslt
#
# OVERRIDE property values
overridePreferenceB._extObserver_masStyleCheck=false
overridePreferenceB._extObserver_simpleStyleCheck=true

    This file is used by the plug-in to override or modify the the project properties and workbench preferences. This file will append to the list of file extensions used to identify resource files.

  5. Unpack the DemoApp ZIP file from the Sage 100 Plug-in Update Site into the root folder of the new project; the ZIP file contains a src folder.

  6. In the Project Explorer view, right click the DemoApp project and select Refresh from the pop-up menu to force Eclipse to update the project contents based on the files in the folder on disk.

    This will trigger a build on the project to compile all new files in the source folder; since the source folder was empty this will be the same as a full build.

Next Section: Create a ProvideX Project - Import Application Files


Create a ProvideX Project - Import Application Files

The following instructions explain how to create a new ProvideX project using existing application files.

Creating the Project

  1. Inside Eclipse, select the menu item File > New > ProvideX Project to open the New ProvideX Project wizard.

    Create Import App Project

    On this page, type "ImportApp" in the Project name field then click Finish. The New ProvideX Project Wizard will create a project called "ImportApp" in the current workspace.

  2. The ImportApp project will initially contain the following resources:

    ImportApp Project - Project Explorer View

    • An input directory (the ImportApp project's input directory is called "src")

    • An output directory (the ImportApp project's output directory is called "compiled")

    • A ProvideX ini file. The project's ini file name is composed of "PVX" then the project name, followed by the extension ".ini". The ImportApp project's ini file is called "PVXImportApp.ini"

    • There is also a hidden ".project" file used by Eclipse to tell the Workbench that this project is associated with the ProvideX plug-in.

  3. Set the Sage 100 perspective if it is not the current perspective, select the menu item Window > Perspective > Open Perspective > Other... Select Sage 100 from the list, and click OK.

  4. Select the Goto the ProvideX Builder/Options preference page ProvideX > Builder > Options preference page and review / adjust the preferences to the appropriate values for your environment. Be sure to enable the preference Automatically convert ProvideX programs to text so ProvideX programs will be converted to text during the import step below.

    Verify ProvideX Builder/Options preference page

  5. In the Project Explorer view, ensure that the ImportApp project is selected. Right click on the "src" folder and then select the menu item Import....

  6. The Import dialogue will appear. Expand General, select File System, and click Next.

    Import from Filesystem

  7. Click the Browse button next to the From directory field and browse to the application directory where the programs/files are located. As an example, I will select the "MAS90" folder from a local Sage 100 Standard installation:

    C:\Sage\Sage 100 Standard\MAS90

  8. In the Import wizard, select the folders to import. You can select a folder on the left pane to view the individual resources resources that you are importing in the right pane. You can deselect any resource(s) in the right pane you do not want to import at this time.

    Import hierarchy list

  9. Be sure that the From directory field is the top-most directory in your application that you do NOT want to include in the ImportApp project.

    The Into Folder field should indicate the ImportApp Project's source directory:

    "ImportApp/src"

    Once all information has been verified, click Finish.

    In the import progress indicator, notice that the imported resources are compiled as they are imported into the workbench. This is because the Build automatically option is checked on the Workbench preferences page and the Automatically convert ProvideX programs to text preference is enabled on the Builder/Options Preference page.

  10. All sub-folders selected in the left pane will be created in the project.

    Import hierarchy list

Next Section: Browse a ProvideX Project


Browse a ProvideX Project

This section begins by browsing the ProvideX programs, keyed files, and NOMADS libraries that comprise the new DemoApp project. The following instructions assume that you are familiar with the Navigator View. For more information on the Navigator View see Workbench User Guide > Getting started > Basic tutorial > Navigating Resources

Confirm the ProvideX perspective is open. The following views will be open in the Workbench:

  1. Project Explorer
  2. Outline
  3. Problems
  4. Console
  5. Properties
  6. Tasks
  7. NOMADS
  8. Embedded Dictionary
  9. Bookmarks

Building the Project

Prior to browsing the ProvideX project we need to make sure the project has been built. The build process is explained in detail in the section Building ProvideX Projects.

The DemoApp project's "src" directory is the project's input directory. All of the project's files (resources, programs, etc) will be added to and modified in this directory.

The DemoApp project's output directory is called "compiled". When a resource is built, the ProvideX builder scans the resource and compiles or copies it from the input directory to the output directory. For performance reasons a resource is typically only built when it has been changed. To force every resource in a project to be built regardless of its change status we must perform a clean build on the project.

  1. Select the menu item Project > Clean... to build the entire project.

  2. The Clean dialogue will appear; click Clean all projects so it is not checked.

  3. Select the DemoApp project and click OK to force every resource in the project to be (re)built.

Browsing the Project

Now that the project has been built, the output directory will contain every file found in the input directory. The ASCII text files containing ProvideX source code were compiled into ProvideX Program files. The project's data files, NOMADS libraries, and any other resources were examined and then copied to the output directory.

  1. In the Project Explorer view, select and expand the directory DemoApp > src > data.
  2. Select the client file and then examine the following views:

    Outline: Client to see the structural information about the data file.

    Properties view - Resource Information:

    Embedded Dictionary view - Embedded IO List Information:

  3. Select the next file in the data directory. All of the above views will change to reflect the information for the current file.

  4. In the Project Explorer view, select the ProvideX NOMADS library file: DemoApp > lib > App.en

    NOMADS view:

    This displays the Panels, Queries, and Popup Menus defined in the ProvideX library. To edit one of the library elements double click the Panel, Query or Popup menu.

  5. In the Project Explorer view, select the file: DemoApp > prog > RWuserlogic.pvc.pvt

    Outline view:

    Double clicking an Attribute, Function or Line Label in the Outline view will open the ProvideX editor with focus on the selected element.

Next Section: ProvideX Editor


Opening a ProvideX Editor

The following instructions are for opening and editing ProvideX programs. This section also explores some of the ProvideX editor features.

  1. Expand the project folder DemoApp > src > prog

  2. Double click menuevnt.pvc.pvt to open it in the ProvideX editor

    Notice the syntax highlighting. The following ProvideX elements are rendered in unique colors and text styles (bold, italic, etc):

    • Comments
    • Directives
    • Line Labels
    • Literals
    • Mnemonics
    • Operators
    • System Functions
    • System Variables

    The color and text style of each ProvideX element is specified on the Goto the Java editor preferenec page Window > Preferences > ProvideX > Editor preference page.

  3. Examine the Outline view. It displays an outline of the ProvideX program currently being edited. Selecting a file in the Navigator view or the ProvideX editor will cause the outline to change to reflect the new resource with focus. When a program file associated with the ProvideX editor is selected the Outline view will annotate each element with icons. Attributes, functions and line labels are displayed with the following icons:

    Attributes:

    Functions:

    Line Labels:

Next Section: Content Assist


Content Assist

Using Content Assist

In this section you will use content assist to call directives, methods and routines as well as view context information for ProvideX elements.

Open the DemoApp/src/prog/RWuserlogic.pvc.pvt file in the ProvideX editor. In the Outline view, double-click the On_Create Line Label to highlight the On_Create routine in the ProvideX editor.

When editing a file in the ProvideX editor, there are several triggers that will activate content assist.

  1. Add a new line at the beginning of the On_Create routine.

    Type the "?" character and pause. The completion proposal for the "?" character will appear. The completion proposal for the "?" character is a simple proposal with a brief description of the PRINT directive:

    Select the PRINT proposal and press the Enter key. The "?" character will be replaced by the ProvideX PRINT directive.

  2. Type a space and then a single quote ( ' ) character to begin a mnemonic followed by the letter "D". The completion proposal containing a list of matching ProvideX mnemonics will be displayed.

    Scroll through the mnemonics and select the 'DIALOGUE' mnemonic and pause...

    After a few seconds, you will see a completion proposal and the context information for the 'DIALOGUE' mnemonic.

    Press the Enter key to select the 'DIALOGUE' mnemonic. The ProvideX 'DIALOGUE' mnemonic will be inserted into the document and the argument list for the 'DIALOGUE' mnemonic will appear with opening and closing braces for the argument list.

    As you type, the current argument will be displayed in bold. To skip the optional arguments just use the right arrow key to move the cursor past the closing brace.

  3. Press Ctrl-Space to activate content assist for all ProvideX keywords.

    The following elements are annotated by icons in the content assist window:

    Directives

    System Functions

    System Variables

  4. On a new line, type:

    var$ = _obj'

    The content assist window will appear with a list of the attributes and functions declared in the current ProvideX class:

    Press the Enter key to insert a call to the Function 'GetUserVariable$(idx)

  5. Open the DemoApp/src/prog/menu.pvxsrc file in the ProvideX editor. On a new line, type:

    GOSUB or GOTO

    The content assist window will appear with a list of the program's Line Labels.

Retrieving Context Information

The context information displayed along side the completion proposal for ProvideX directives, system functions and system variables is available at anytime in the editor by simply highlighting the keyword and hovering over it.

  1. Select the keyword CALL and then use the mouse to hover over it. The context information for the CALL directive will appear:

Next Section: Identifying Problems in Code


Identifying Problems in Code

The following indicators can help to identify problems in your code. The build process is discussed in detail under Building ProvideX Projects. This section will focus on how error messages are associated with the ProvideX source code.

As a resource is (re)built, information will be updated to the Console view. This view will show a summary of the results of the build process; if there are errors in the source code this summary will include information about the number of errors found. Also, for each error found in the source file, an error line will be added to the Problem view and a marker will be placed in the vertical ruler of your source code.

Build Errors

To demonstrate this process...

  1. Open DemoApp > src > prog > outputpdf.pvc.pvt in the editor by double clicking the resource in the Navigator view.

  2. Add the following code at the end of the source listing:
    read (x0,err=BadRec)
    x1 = "an error"

  3. Click the Save button. The program is rebuilt and the problems found in the source code will be identified in several ways:
    • In the Problems view:
      • An error message "Error #26: Variable type invalid
      • A warning message Warning #123: The following statement labels cannot be located: BadRec
    • In the editor's vertical ruler, problem markers will be displayed near the affected lines; if the mouse hovers over any of these markers, the description text associated with that marker will display
    • The editor scroll-bar is also annotated with problem markers
    • The Console view will display a summary of all warnings/errors from the build process

  4. Click the close (X) button on the editor's tab to close the editor.

Filtering Errors

When a project contains many application programs, there may be occassions when there are several programs with errors or warnings. Eclipse allows the list of items reported in the Problems view to be filtered to reduce the number of items that are displayed to only those that match the filter criteria.

The mechanism for filtering items in the problem view is very different between the various releases of Eclipse. The following explanation describes the process for the 2020-03 release.

In the Problems view...

  • Press the drop-down button to access the menu and select 'Filters..' to create/maintain filters.

  • Create a new filter, click Rename, end enter a name of 'CurrentAppOnly'.

  • Select to limit the scope of the filter to 'On selected element and its children'.

  • Make this the active filter and disable any others.

Correcting Errors

Once the number of items in the Problems view has been reduced to a manageable number...

  • Select a problem in the list.
  • Open its context menu (right click), and select Go To Resource.
  • Or, double-click a problem in the list

The file is opened in the editor at the location of the problem.

Correct the problem in the editor...

  • Change the variable "X1" a string variable by adding the "$" character to the X1 variable. The modified line should be similar to:

    x1$ = "an error"

  • Click the Save button. The program is rebuilt and the problem indicators disappear.

Notes

You can configure how problems are indicated on the Goto the annotations preference page General > Editors > Text Editors > Annotations preference page.

Next Section: Using the Local History


Using the Local History

Recover Previous Version of File

In this section, the local history feature will be used to switch to a previously saved version of a ProvideX program.

  1. Open DemoApp > src > prog > outputpdf.pvc.pvxsrc in the editor from the Project Explorer view.

  2. Change the program by adding the following line:

    PRINT "Hello World"

    Save the file by pressing Ctrl+S.

  3. In the Project Explorer view, select and right click on DemoApp > src > prog > outputpdf.pvc.pvxsrc

  4. From the Context menu, select Replace With > Local History....

  5. In the Compare dialog, the history of revisions to the program is displayed.

    Below the list of revision dates is a compare pane that shows details of the differences between the selected history and the current state of the file.

    Double-click one of the dates in the list to see a comparison of the differences to the current version of the source file...

  6. Select the previous version, and click the Replace button.

Restore a Deleted File

Local history can also be used to restore a deleted file.

  1. Select DemoApp > src > prog > outputpdf.pvc.pvxsrc in the Project Explorer view, and from its context menu, select Delete.

  2. Right click the DemoApp project in the Project Explorer view.

  3. From its Context menu, select Restore from Local History....

  4. Select src/prog/outputpdf.pvc.pvxsrc in the Check files to restore.. pane.

  5. As before, the Local History.. pane shows the versions saved in the local history.

  6. In the Local History.. pane, select the earlier working version and then click Restore.

Next Section: General Build Concepts


General Build Concepts

Builders generate an output file from an existing resource. Eclipse uses unique builders for different types of projects. The ProvideX builder generates compiled (tokenized) ProvideX programs from ASCII source files. When a resource is built the ProvideX builder scans each resource and compiles or copies the resource from the project's input directory to the project's output directory. Files that contain ProvideX source code are compiled, other resources like data files, libraries, images, etc, are examined and copied to the output directory.

There are two kinds of builds:

  • Incremental build - only builds resources that have changed since the last build.

  • Clean build - deletes all of the files and folders in the output directory and builds every resource in the input directory, even if the resources have not changed.

There are two ways to perform a build:

  • Automatic builds are performed as resources are saved. Automatic builds are always incremental and always operate over the entire workspace. You can configure your preferences ( [image] Window > Preferences > General > Workspace > Build ) to perform builds automatically on resource modification.
  • Manual builds are initiated when you explicitly select a menu item or press the equivalent shortcut key. Manual builds can be either clean or incremental.

Incremental builds are obviously much faster than clean builds. Typically, clean builds are rarely required.

Next Section: Building the DemoApp Project


Builds

Building the DemoApp Project

The DemoApp project's "src" directory is the project's input directory. All of the project's files (resources, programs, etc) will be added to and modified in this directory.

The DemoApp project's output directory is called "compiled". When a resource is built the ProvideX builder scans it and compiles or copies it from the input directory to the output directory.

Note: You should never directly edit files in the output directory because the builder will delete these files and discard any changes you make without warning. All of your work is done in the input directory and the builder will copy, create directories, move, etc., the resource in the output directory.

Modify / Add / Delete Resources

Create, modify, and delete resources to see impact in the output folder of the project.

  1. In the Project Explorer view, select the DemoApp project's output directory: DemoApp > compiled.

  2. Right click the compiled folder and from the context menu select Delete. Click OK to confirm. The project now contains the source directory only.

  3. In the Project Explorer view, select DemoApp > src > prog > menuevnt.pvc.pvxsrc.

  4. Double click on menuevnt.pvc.pvxsrc to open the file in the ProvideX Editor

  5. Change the file in some way; e.g., add a comment to the end of the file

    ! A comment

  6. Save the file by typing Ctrl+S or select the File> Save menu item.

  7. The ProvideX builder will perform an incremental build and only the menuevnt.pvc file will be processed. The project's output directory was deleted in step 1 and 2 above so the ProvideX builder will create the output directory, any subdirectories required, and then the compiled menuevnt.pvc program.

  8. In the Navigator view, select the directory DemoApp/src/prog.

  9. Right click on the prog directory and from the context menu select New > Folder. The New Folder wizard dialogue will appear.

  10. Type "my_dir" in the Folder name field.

    Eclipse will create a new folder called "my_dir" in the DemoApp/src/prog directory and the ProvideX builder will create the directory DemoApp/compiled/prog/my_dir.

  11. Right click on the DemoApp/src/prog/menuevnt.pvc.pvxsrc file and from the context menu select Move...

  12. The Folder Selection dialogue will appear. Select the DemoApp/compiled/prog/my_dir directory.

    Eclipse will move the menuevnt.pvc.pvxsrc source file to the "my_dir" directory and do an incremental build.

  13. Perform a clean build to make sure the changes we've made to the input directory are reflected in the output directory. Select the menu item Project > Clean... to build the entire project.

  14. The Clean dialogue will appear; click Clean all projects so it is not checked.

  15. Select the DemoApp project and click OK to force every resource in the project to be built.

    Now that the project has been built, the output directory will contain every file found in the input directory, and the directory structure will match the input directory. The ASCII text files that contain ProvideX source code have been compiled into ProvideX Tokenized Program files. The project's data files, NOMADS libraries, and any other resources have been examined and then copied to the output directory.

Clean Up

In order to continue with this tutorial we must return the DemoApp project to its original state - we must move menuevnt.pvc.pvt back to DemoApp/src/prog and delete the DemoApp/src/prog/my_dir directory.

  1. Select the directory DemoApp/src/prog/my_dir.

  2. Right click the DemoApp/src/prog/my_dir folder and, from the context menu, select Delete. Click OK to confirm.

  3. Right click the DemoApp project and select Restore from local history...

  4. The Restore from Local History dialogue will appear. Select src/prog/menuevnt.pvc.pvxsrc item from the Check files to restore from local history list.

  5. Click the Restore button.

  6. Follow steps 13, 14, and 15 above to perform a clean build.

Next Section: Resources and ProvideX Source Code


Resources and ProvideX Source files

The ProvideX Builder differentiates files containing ProvideX source code that should be compiled from resources like images, HTML pages, data files, etc, that should just be copied to the output directory, by examining the file extension and the "resource" property of each file.

The Resource Property

Every file in a ProvideX project's input directory has four properties unique to ProvideX projects:

  • Resource: Files with the property checked will not be compiled

  • Password: A password for a ProvideX program file

  • Owner Code: An Owner Code for a ProvideX program file

  • Flags: The Owner Code flags for a ProvideX program file

Note: The Password and Owner Code properties will be examined in a later section.

If a file's Resource property is checked, then the ProvideX Builder does not attempt to build the file.

Files with the Resource property checked are examined by the ProvideX Builder. If the file is a ProvideX data file, the Builder extracts information regarding the file for the Outline, NOMADS, Properties, and Embedded Dictionary views and then copies it to the output directory.

If the Resource property is not checked, then the ProvideX Builder examines the extension of the file. If the file is associated with the ProvideX Editor then it will be compiled to the output directory. For more information on associating file extensions with the ProvideX Editor see Step #6 of the Preparing the Workbench section.

If the file is not marked as a resource, and it is not associated with the ProvideX Editor (e.g., a *.jpg or *.html file) then the builder will copy the file to the output directory.

Setting the Resource Property on a File

  1. In the Project Explorer view, select DemoApp > src > prog > menuevnt.pvc.pvxsrc.

  2. Right click on the menuevnt.pvc.pvxsrc file and from the context menu select Properties.

  3. The Properties for menuevnt.pvc.pvxsrc dialogue will appear. Select the ProvideX properties page from the list.

  4. Verify the Resource property is checked and click OK to save.

  5. In the Project Explorer view, double click DemoApp > src > prog > menuevnt.pvc.pvxsrc to open the file in the ProvideX Editor.

  6. In the ProvideX Editor add the following line near the beginning of the ON_CREATE routine:

    x = "An Error"

  7. Save the file by typing Ctrl+S or by selecting the menu item File > Save. The ProvideX builder will perform an incremental build and only the menuevnt.pvc.pvxsrc file will be processed.

  8. Examine the Problem view. Notice that the syntax error added to menuevnt.pvc.pvxsrc in Step 6 is not reported in the Problem view.

  9. Examine the Console view. The Console view indicates there were no errors because the menuevnt.pvc.pvxsrc resource was copied; the menuevnt.pvc.pvt resource was not compiled.

  10. In the Project Explorer view, double click DemoApp > compiled > prog > menuevnt.pvc to open the file that was copied by the ProvideX builder. The output file is exactly the same as the source file.

  11. In the Project Explorer view, select DemoApp > src > prog > menuevnt.pvc.pvt

  12. Right click on the menuevnt.pvc.pvt file and from the context menu select Properties.

  13. The Properties for menuevnt.pvc.pvt dialogue will appear. Select the ProvideX properties from the list.

  14. Uncheck the Resource property and then click OK to save.

  15. In the Project Explorer view, double-click DemoApp > src > prog > menuevnt.pvc.pvxsrc to open the file in the ProvideX editor.

  16. In the ProvideX Editor, right-click and choose ProvideX Build from the context menu. The builder will perform an incremental build and only the menuevnt.pvc.pvxsrc file will be processed.

  17. Examine the Problem view. Notice the syntax errors for menuevnt.pvc.

  18. Examine the Console view. The Console view now indicates the menuevnt.pvc program was compiled.

  19. Select the menu item Project > Clean... to build the entire project.

  20. The Clean dialogue will appear; click Clean all projects so it is not checked.

  21. Select the DemoApp project and click OK to force every resource in the project to be built.

  22. Examine the Console. The Console will indicate for every file in the project, whether the file was compiled or copied to the output directory.

Clean Up

To continue with this tutorial we must return the DemoApp project to its original state; i.e., we must fix the errors we added above to menuevnt.pvc.

  1. In the Navigator view, select and right click on DemoApp > compiled > Prog > menuevnt.pvc.

  2. From the context menu, select Replace With > Local History.

  3. In the Replace from Local History dialog, the history of the program is displayed. Below the history is a Compare pane that shows details of the differences between the selected history and the current state of the file. Select the original version of this file and click the Replace button.

Next Section: Running a Console


Running a Console

In this section, you will learn how to launch a ProvideX console for the current Project.

  1. In the Project Explorer view select the DemoApp project or a file in the project.

  2. Confirm the ProvideX Perspective is open.

  3. Click on the button on the toolbar to 'Run ProvideX Console' (look for the ProvideX icon).

    A ProvideX console will appear on top of the Workbench.

    Note:
    The ProvideX environment has been initialized and the work directory is set to the 'Output Directory' for the current project. The prefix list has NOT been set; a global variable %_AltProjectPrefix$ has been set and includes all of the folders in the current project. Also, any START_UP program that may be part of the project has NOT been executed.

  4. Type "PRINT LWD" into the ProvideX console to view the current working directory.

  5. Since there is a START_UP program for this project, type RUN "START_UP" to execute the initialization steps as defined for the DemoApp.

  6. In the ProvideX console, type LOAD "menu" to load the lead program for DemoApp.

  7. In the ProvideX console, type RUN to run the Demonstration Application.

Next Section: Launching a Program


Launching a Program

In this section, you will run learn how to run ProvideX programs from the Workbench. Prior to running the DemoApp please do a clean build and make sure there are no errors. For more information on building the project see Getting Started > Project Tutorial > Building ProvideX Projects > Build the DemoApp Project.

  1. From the Workbench toolbar, select Run > Run Configurations...

  2. The Run Configurations dialog opens. This allows you to configure how a program is launched, including its arguments, and other options.

  3. Right click the ProvideX Application from the list and select New Configuration.

  4. The ProvideX Application launch configuration dialogue will appear. The ProvideX launch configuration dialogue has four tabs:

    • Application
    • Arguments
    • Source
    • Common

The Application Tab

The Following fields reside on the Application tab (below the Name field): ProvideX project, ProvideX program to run, ProvideX Executable, and Working Directory.

  1. Enter "DemoApp" in the Name field.

  2. In the ProvideX project section, click the Browse button and select the DemoApp project.

  3. In the ProvideX program to run section, click the Search button. Browse to, and select, the menu program in the project's output directory (compiled\prog\menu)

    Note: Do not select the menu file in the input directory.

  4. Accept the default ProvideX Executable which will be the one that was selected for the workspace during the configuration of the ProvideX plug-in.

  5. In the Working Directory section, the default value will be the root directory for the workspace; simply add the name of the project output directory (DemoApp\compiled) to the end of the default value

  6. The Application tab is done, click Apply:

The Arguments Tab

The following fields reside on the Arguments tab: Program Arguments, Path to Ini file, and Window state./p>

  1. Select the Arguments tab.

  2. By default, the program will use the project's default ini file. The project's default ini file is found in the project's root directory. For more information on the default ini file see Project Tutorial > Creating a ProvideX Project. To specify an ini file, use the Search button. Browse to, and select, a ProvideX ini file located in any directory. This application will run with the default ProvideX ini file, so leave this field blank.

  3. Enter "-hd" in the Window state field so that the main window of ProvideX is hidden when the menu program is run.

  4. The Arguments tab is done. Click Apply.

  5. Click Run to run the menu program.

  6. Exit the ProvideX menu program.

  7. Examine the Eclipse Console view. Messages regarding the life cycle of the ProvideX program will be printed to the Console view.

  8. To re-run this program, press Ctrl + F11 or press the run icon [image] on the Workbench toolbar.

Next Section: Launching a Program in WindX


Launching a Program in WindX

In this section, you will run learn how to run ProvideX programs from the Workbench in the WindX thin client. Prior to running the DemoApp, please do a clean build and make sure there are no errors. For more information on building the project see Getting Started > Project Tutorial > Building ProvideX Projects > Build the DemoApp Project.

  1. From the Workbench toolbar select Run > Run Configurations...

  2. The Run Configurations dialog open. This allows you to configure how a program is launched, including its arguments and other options.

  3. Right click the WindX Client from the list of launch configurations and select New Configuration.

  4. The WindX Client launch configuration dialogue will appear. The WindX Client launch configuration dialogue has four tabs:

    • Application
    • Arguments
    • Client
    • Common

    Note: Three of the four WindX Client tabs are taken from the ProvideX Application launch configuration.

The Application Tab

The Following fields reside on the Application tab (below the Name field): ProvideX project, ProvideX program to run, ProvideX Executable, and Working Directory.

  1. Enter "WindX DemoApp" in the Name field.

  2. In the ProvideX project section, click the Browse button and select the DemoApp project.

  3. In the ProvideX program to run section click on the Search button. Browse to and select the menu program in the project's output directory; e.g., browse to the file: DemoApp\compiled\prog\menu

    Note: Do not select the menu file in the input directory.

  4. In the ProvideX Executable section, accept the default ProvideX executable which will be the same one that was selected during the configuration of the ProvideX plug-in.

  5. In the Working Directory section, the default value will be the root directory for the workspace; simply add the name of the project output directory (DemoApp\compiled) to the end of the default value

  6. When the Application tab is done, click Apply.

The Arguments Tab

The following fields reside on the Arguments tab: Program Arguments, Path to Ini file, and Window state.

  1. Select the Arguments tab.

  2. By default, the program will use the project's default ini file. The project's default ini file is found in the project's root directory. For more information on the default ini file see Project Tutorial > Creating a ProvideX Project. To specify an ini file use the Search button, browse to, and select a ProvideX ini file located in any directory. This application will run with the default ProvideX ini file so leave this field blank.

  3. Enter "-hd" in the Window state field so the main window of ProvideX session is hidden when the the menu program is run.

  4. The Arguments tab is done, click Apply.

The Client Tab

The following fields reside on the Client tab: ProvideX host and Port number for host.

  1. Select the Client tab.

  2. Simply check box beside the option Automatically launch ProvideX host locally on any free socket.

  3. The Client tab is done, click Apply.

  4. Click the Run button on the Eclipse WindX launch configuration dialogue.

  5. Exit the ProvideX menu program.

  6. Examine the Eclipse Console view. Messages regarding the life cycle of the ProvideX program will be printed to the Console view.

  7. To re-run this program, press Ctrl+F11 or press the run icon [image] on the Workbench toolbar.

Next Section: Simple Application


Simple Application

A Simple Application

A simple application can be created and maintained in a single ProvideX project in Eclipse. This project can be checked in to a repository in a version control system to maintain a history of the modifications made to the application.

For this type of application, it is usually very easy to create a command that can be used to run the application from within the Eclipse environment. In many cases, all that is required is to execute a specific program directly.

The application may require that each program (or task) be selected from a menu system that ensures the proper environment has been established. In this case, a more complex command will be required to start the menu program and specify the task associated with the source file that was modified.

See the section Running ProvideX Programs for information about creating and configuring the commands to execute a program in a project.

Next Section: Complex Application


Complex Application

A more complex application that is derived from a combination of different modules or "sub-applications" will be easier to manage by separating each module (or sub-application) into a different project in Eclipse. Each of these projects can be checked in to a repository in a version control system to maintain a history of the modifications made to the application.

In this scenario, the programs in each project may have dependencies on programs and files in other projects and may not execute in a stand-alone environment. For these applications, it is better to "link" each ProvideX Project to an existing application installation so that as each source file is modified and saved in the Eclipse environment an updated version of the program is copied to the application folder. This requires that the folder structure of each ProvideX project be the same as the existing application so that the updated program files get placed into the correct location.

See the ProvideX Builder documentation about the Output Folder Properties for an explanation of the steps required to setup this process.

This concludes the tutorial.
Return to Tutorial - Contents


ProvideX OOP Overview

Object Oriented Programming in ProvideX

The ProvideX language has been extended to support all of the key design principles of Object Oriented Programming (OOP).

The three basic principles of OOP are Encapsulation, Inheritance, and Polymorphism. These concepts provide a major part of the framework used to create and interact with objects. ProvideX OOP objects are defined through the use of classes. A class defines the name given to the object definition, as well as the object's properties and methods. Properties are the data portion of the object, consisting of fields or variables. Methods (or functions) are the actions that the object will perform. The defined properties/methods are accessible via the Apostrophe Operator.

Directives and Functions used to handle OOP mechanisms in ProvideX

DEF CLASS

Use the DEF CLASS directive in Object Oriented Programming (OOP) to declare the start of an object definition. It defines the name of the object and it can be used to override object creation and deletion logic.

class$ specifies the class name that will refer to this type of object. Class names are case-insensitive and forward/backward slashes are considered equivalent. Duplicate names are not allowed within the system. An object declared as UNIQUE will have a single instance created, and any subsequent attempt to create an instance returns the same object identifier and increments the object reference count by one.

By default, an object can have ON_CREATE and/or ON_DELETE logic defined. You can override this by specifying new label names for the creation/deletion logic via CREATE label and DELETE label clauses in the class definition. Normally, object creation/deletion logic is invoked when an object of this specific class is created/destroyed. That means, if you have ON_CREATE logic for an object A and object B inherits it, then the ON_CREATE for object A will not be executed on creation of object B. You can force creation and/or deletion logic to be executed on inheritance by including the keyword REQUIRED.

In terms of precedence, if an object inherits another object that has creation logic, the creation logic for the inherited object is performed first; e.g., if object C inherited object B which inherited object A, then the ON_CREATE in object A would be performed first, followed by object B's and finally object C's. (Deletion logic is performed in the opposite order).

PROPERTY

The PROPERTY directive is used in Object Oriented Programming to declare the properties that can be accessed by the application program. These properties can be treated like any other variable in the system and are accessible using the Apostrophe Operator.

LOCAL

The LOCAL directive is used to reassign variable names temporarily within a called procedure, without affecting the original contents (if any). In Object Oriented Programming (OOP), the LOCAL directive is similar to the PROPERTY directive, but is used to declare data that is only visible to processing logic within the object itself.

FUNCTION

The FUNCTION directive is used to declare a method for an object in Object Oriented Programming (OOP). Associated logic is to be called when the method is invoked.

LIKE

The LIKE directive is used in Object Oriented Programming (OOP) to inherit the properties from one or more other classes. All properties and methods are inherited from the specified classes.

STATIC

In Object Oriented Programming (OOP), the STATIC directive is used to create variables for use within an object at runtime -- basically, STATIC is used to extend the list of LOCAL properties. This allows for the dynamic creation of variables which are visible to operations within an object, yet which are not directly accessible to outside code.

DROP OBJECT

The DROP OBJECT directive is used in Object Oriented Programming to delete an object.

NEW( )

The NEW( ) function is used in Object Oriented Programming to create a new object based on a specified class name or an existing object (obj_id). If the class name already exists, then its definition is used. If it has not been defined previously, the system attempts to load the program class.pvc and execute/define the DEF CLASS within it (the DEF CLASS clause must be at the start of the program). If the system is unable to properly determine the class definition, an Error #90:"Unable to locate Object class definition" is generated.

REF( )

The REF ( ) function is used in Object Oriented Programming to control access to an object by incrementing or decrementing the reference count.

Apostrophe Operator

An apostrophe operator (tick) allows dynamic access to the properties and methods available for a given COM, OOP, or graphical object. While the syntax is generally the same for all object-oriented coding in ProvideX, the apostrophe operator can be used to read and alter properties, or execute methods, in a variety of different control and object types.


file_reader

Class file_reader

The is a simple class to read the contents of a file and will also handle any '#include' references found in the file.

Constructor

Open the specified file for reading and start a counter to keep track of the number of INLCUDE files that are referenced. The path_resolver object will be used to expand the name of each INCLUDE file.

Parameter | Description
inFile$ | The name of file to read
inPathResolver | A reference to an instance of a path_resolver class used to expand the name of include files.

Properties

LOCAL includeFileLimit=50
LOCAL FILE_EOF=1
LOCAL FILE_INCLUDE_LIMIT=2
LOCAL FILE_NOT_FOUND=12
PROPERTY _version$=CVS(MID(STP("$Revision: 2716 $", 2, "$"), 10), 3)
PROPERTY aTracker
Type Reference to obj_tracker

Methods

FUNCTION getEOF()

Get the end of file status

Returns A boolean that is set to TRUE (1) when end of data stream has been reached.
FUNCTION read$()

Read a line of text from the file.

Returns A string containing the text that was retrieved
FUNCTION setIgnoreIncludes(inBoolean)

Set a flag to disable processing of '#include' references

Parameter | Description
inBoolean | (0=False, 1=True)
Footer logo


header_entity

Class header_entity

This class is used to store build information that is defined within the beginning (header) of a source file.

Properties

PROPERTY _version$=CVS(MID(STP("$Revision: 2716 $", 2, "$"), 10), 3)

Methods

FUNCTION exists()
Returns A simple boolean (0=False, 1=True) to indicate that information was found in the source file.
FUNCTION getAuthor$()
Returns The value found after the '@Author' tag
FUNCTION getDate$()
Returns The value found after the '@Date' tag
FUNCTION getFlags$()
Returns The value found after the '@Flags' tag
FUNCTION getForceLineNumbers$()
Returns The value found after the '@ForceLineNumbers' tag
FUNCTION getLineNumberInc()
Returns The line number increment (if valid) found after the '@LineNumberInc' tag
FUNCTION getOutputFile$()
Returns The value found after the '@OutputFile' tag
FUNCTION getOwner()
Returns The value found after the '@Owner' tag
FUNCTION getPassword$()
Returns The value found after the '@Password' tag
FUNCTION setAuthor$(inAuthor$)

Store the value associated with the '@Author' tag

Parameter | Description
inAuthor$ | The remainder of the line after the tag
FUNCTION setDate$(inDate$)

Store the value associated with the '@Date' tag

Parameter | Description
inAuthor$ | The remainder of the line after the tag
FUNCTION setFlags$(inFlags$)

Store the value associated with the '@Flags' tag

Parameter | Description
inAuthor$ | The remainder of the line after the tag
FUNCTION setForceLineNumbers$(inBoolean$)

Store the value associated with the '@ForceLineNumbers' tag

Parameter | Description
inAuthor$ | The remainder of the line after the tag
FUNCTION setLineNumberInc$(aValue$)

Store the value associated with the '@LineNumberInc' tag if valid

Parameter | Description
inLineInc$ | The line number increment (a number between 1 and 25)
Returns The line number increment (if valid) found after the '@LineNumberInc' tag
FUNCTION setOutputFile$(inFile$)

Store the value associated with the '@OutputFile' tag

Parameter | Description
inAuthor$ | The remainder of the line after the tag
FUNCTION setOwner(inOwner)

Store the value associated with the '@Owner' tag

Parameter | Description
inAuthor$ | The remainder of the line after the tag
FUNCTION setPassword$(inPassword$)

Store the value associated with the '@Password' tag

Parameter | Description
inAuthor$ | The remainder of the line after the tag
Footer logo


keyed_collection

Class keyed_collection

A collection class to store references to objects using a unique name for each reference. This class uses a memory file to provide improved performance when managing the contents of the collection.

Properties

LOCAL hasAltKeys=TCB(29)>=7500000
PROPERTY count * Read Only *
PROPERTY _version$

Methods

FUNCTION add(entityID)

Add a new entity to the collection (use class name plus entity_ID as the key)

Parameter | Description
entityID | A reference to an entity object to add to the collection
Returns A simple value to indicate success (0=Failed, 1=Succeeded)
FUNCTION add(key$, entityID)

Add a new entity to the collection

Parameter | Description
key$ | The name (maximum length of 50 characters) to be used to access the entity
entityID | A reference to an entity object to add to the collection
Returns A simple value to indicate success (0=Failed, 1=Succeeded)
FUNCTION delete(entityID)

Delete an entity from the collection by ID

Parameter | Description
entityID | The ID of the entity to delete
Returns A simple value to indicate success (0=Failed, 1=Succeeded)
FUNCTION delete(key$)

Delete an entity from the collection by name

Parameter | Description
key$ | The name (maximum length of 50 characters) of the entity to delete
Returns A simple value to indicate success (0=Failed, 1=Succeeded)
FUNCTION item(key$)

Get the entity ID associated with the specified name

Parameter | Description
key$ | The name (maximum length of 50 characters) of the entity to locate
Returns A reference to the entity object
FUNCTION item(index)

Get the entity ID associated with the specified index (in order of creation)

Parameter | Description
index | The name of the entity to locate
Returns A reference to the entity object
FUNCTION item(index, sortOrder)

Get the entity ID associated with the specified index (in order of creation)

Parameter | Description
index | The name of the entity to locate
sortOrder | Specify the sort order to be used to retrieve the item
Returns A reference to the entity object
Allowed values for Sort Order
Value | Description
0 | Order created
1 | Sort by name (alphabetical sequence)
Footer logo


name_value_pair

Class name_value_pair

This class holds a name/value pair.

Constructor

Create a new name/value pair.

Parameter | Description
initname$ | The name of this data value.
InitValue$ | Initial String value (Optional)

Properties

PROPERTY _version$=CVS(MID(STP("$Revision: 2716 $", 2, "$"), 10), 3)

Methods

FUNCTION getName$()

Return the name associated with this data.

FUNCTION getValue$()

Return the data value for string data

FUNCTION setName(inName$)

Set the name

Parameter | Description
inName$ | The name to be assigned
FUNCTION setValue(inValue$)

Set the data value for string data

Parameter | Description
inValue$ | The value to be assigned
Footer logo


obj_tracker

Class obj_tracker

The is a simple class that can be used to track references to a class that is not unique.

Build Information

Forcelinenumbers false

Properties

No Properties

Methods

FUNCTION getTotal()
Returns The current total count for this tracker.
FUNCTION increment()

Increment the reference counter for this tracker.

Footer logo


path_resolver

Class path_resolver

The class will resolve (or expand) the name of the INCLUDE file based on the rules defined within this class. This is the abstract class that can be overridden for specific cases.

Build Information

Forcelinenumbers false

Known SubClasses

EclipsePathResolver

Properties

PROPERTY _version$=CVS(MID(STP("$Revision: 2716 $", 2, "$"), 10), 3)

Methods

FUNCTION resolve$(inSrcName$, inIncludeName$)

Resolve (or expand) the name of the INCLUDE file.

Parameter | Description
inSrcName$ | The name of file to source file
inIncludeName$ | The name of the include file
Returns The name of the INCLUDE file relative to the location of the SOURCE File.
Footer logo


program_reader

Class program_reader

The class will read a ProvideX program either from a source text file or tokenized program.

Constructor

Create a reference the to appropriate class to read the specified program file. This class will use either pvx_tokenized_reader or pvx_source_reader as necessary to allow reading either a tokenized program or a text file of the program source.

Parameter | Description
inFile$ | The name of file to read
inPassword$ | **Optional** The password to decrypt a tokenized program
inPathResolver | **Optional** A reference to a path_resolver class to expand the name of include files.

Properties

PROPERTY _version$=CVS(MID(STP("$Revision: 3010 $", 2, "$"), 10), 3)

class version

PROPERTY changeKeywords * Read Only *

Flag used to track whether keyword case change is enabled

PROPERTY convertLineLabels * Read Only *

Flag to track whether line label case change is enabled

Methods

FUNCTION getCreateObj$()
FUNCTION getCreateObj$(aPgmLine$)
FUNCTION getCreateObj$(aPgmLine$, aSepChar$)

Get the object instatiation(s) within the current program line

Parameter | Description
aPgmLine$ | (Optional) The program line to use (NULL value will use current program line)
aSepChar$ | (Optional) The character to use to separate each member of the list; if not set will default to a space.
Returns A string containing a aSepChar$ separated list of object instantiations
FUNCTION getEOF()

Get the end of file status

Returns A boolean that is set to TRUE (1) when end of data stream has been reached.
FUNCTION getHeaderInfo()

Get the build header information that was collected while reading the file.

Returns A reference to header_entity.
FUNCTION getKeywords$()
FUNCTION getKeywords$(aPgmLine$)
FUNCTION getKeywords$(aPgmLine$, aSepChar$)
FUNCTION getKeywords$(aPgmLine$, aSepChar$, aModLine$)

Get a (aSepChar$ separated) list of keywords used on the current program line

Parameter | Description
aPgmLine$ | (Optional) The program line to use (NULL value will use current program line)
aSepChar$ | (Optional) The character to use to separate each member of the list; if not set will default to a space.
aModLine$ | [out] the modified program line, after remarks adn literals are removed
Returns A list of keywords
FUNCTION getKeywordsPlus$()
FUNCTION getKeywordsPlus$(aPgmLine$)
FUNCTION getKeywordsPlus$(aPgmLine$, aSepChar$)

Get a (aSpeChar$ separated) list of keywords,mnemonics,labels used on the current program line

Parameter | Description
aPgmLine$ | (Optional) The program line to use (NULL value will use current program line)
aSepChar$ | (Optional) The character to use to separate each member of the list; if not set will default to a space.
Returns A list of keywords, mnemonics, and labels
FUNCTION getLiterals$()
FUNCTION getLiterals$(aPgmLine$)
FUNCTION getLiterals$(aPgmLine$, aSepChar$)

Get a (SEP separated) list of literals used on the current program line

Parameter | Description
aPgmLine$ | (Optional) The program line to use (NULL value will use current program line)
aSepChar$ | (Optional) The character to use to separate each member of the list; if not set will default to a space.
Returns A list of literals
FUNCTION getMnemonics$()
FUNCTION getMnemonics$(aPgmLine$)
FUNCTION getMnemonics$(aPgmLine$, aSepChar$)

Get a (aSepChar$ separated) list of mnemonics used on the current program line

Parameter | Description
aPgmLine$ | (Optional)The program line to use (NULL value will use current program line)
aSepChar$ | (Optional) The character to use to separate each member of the list; if not set will default to a space.
Returns A list of mnemonics
FUNCTION getRemarks$()
FUNCTION getRemarks$(aPgmLine$)
FUNCTION getRemarks$(aPgmLine$, aSepChar$)

Get remarks for the current program line

Parameter | Description
aPgmLine$ | (Optional) The program line to use (NULL value will use current program line)
aSepChar$ | (Optional) The character to use to separate each member of the list; if not set will default to a space.
Returns A the remarks
FUNCTION getSourceFileType()

Get the type of source file

Returns A code to indicate the type of file for the program
Program File type
Value | Description
1 | A text file
2 | A tokenized program file
FUNCTION getSourceText$()

Get the text as read from source file for current program line. The keywords may be changed based on the setting of the 'changeKeywords' property.

Returns A string containing the text from the source file with minimal processing.
Info

If the source file is not a text file, this method will return an error 13.

FUNCTION getStatementLabels$()
FUNCTION getStatementLabels$(aPgmLine$)
FUNCTION getStatementLabels$(aPgmLine$, aSepChar$)

Get a (aSepChar$ separated) list of statement labels used on the current program line

Parameter | Description
aPgmLine$ | (Optional) The program line to use (NULL value will use current program line)
aSepChar$ | (Optional) The character to use to separate each member of the list; if not set will default to a space.
Returns A list of labels
FUNCTION getVariables$()
FUNCTION getVariables$(aPgmLine$)
FUNCTION getVariables$(aPgmLine$, aSepChar$)

Get a list of variables referenced on the specified program line

Parameter | Description
aPgmLine$ | (Optional) The program line to use (NULL value will use current program line)
aSepChar$ | (Optional) The character to use to separate each member of the list; if not set will default to a space.
Returns A list of variables
FUNCTION hasLineNumbers()

The source file has line numbers. This value is based on the first line in the file since the program load will fail if the remainder of the source file does not use line numbers.

Returns A simple boolean value (0=False, 1=True)
FUNCTION read$()

Read the next program line from the data stream.

Returns A string containing the text that was retrieved
FUNCTION setBlockCommentsVisible(inBoolean)

Set a flag to control whether C-style block comments are returned to the controlling application. The default is to hide these comments.

Parameter | Description
inBoolean | (0=False, 1=True)
FUNCTION setChangeKeywords(useConversion)

Set the conversion rule to be used for replacing keywords in the source text when requested.

Parameter | Description
useConversion | The type of conversion applied to the keywords
Conversion rules for keywords
Value | Description
0 | No change (default)
1 | Force keywords to uppercase
2 | Force keywords to lowercase
3 | Use substitution table for keyword replacement (FUTURE)
FUNCTION setConvertLineLabels(doConvert)

Enable/Disable conversion of line labels as part of keyword conversion process

Parameter | Description
doConvert | Boolean value to enable/disable conversion of line labels
FUNCTION setIgnoreIncludes(inBoolean)

Set a flag to disable processing of '#include' references

Parameter | Description
inBoolean | (0=False, 1=True)
FUNCTION setStripLeadingWhiteSpace(inBoolean)

Set a flag to force stip of leading white space

Parameter | Description
inBoolean | (0=False, 1=True)
FUNCTION setStripLineNumbers(inBoolean)

Set a flag to strip the line number from program line

Parameter | Description
inBoolean | (0=False, 1=True)
FUNCTION setStripPvxDocTagInfo(inBoolean)

Set a flag to Enable/Disable the stripping of the document tag information

Parameter | Description
inBoolean | (0=False, 1=True)
Footer logo


properties_file

Class properties_file

This class is used to manage a properties file in memory. If a property file is specified as an argument to the constructor, it will be loaded into memory. Otherwise, an empty data structure is created.

All lines from the file are saved in memory, but only the lines that are in the format 'NAME=VALUE' will be used as a property name and value pair.

It is also possible to process all of the properties in a file using the built-in iterator as the following example demonstrates: coPropFile = new("properties_file", aPropFile$) coPropFile'iterator_init() WHILE coPropFile'iterator_has_next() oNVPair = coPropFile'iterator_get_next() IF oNVPair <> -1 { ! Get the Name and Value from the 'name_value_pair' object tagKeyword$ = oNVPair'getName$() tagValue$ = oNVPair'getValue$() ... } WEND

Constructor

Manage a properties file in memory.

Parameter | Description
aFile$ | (optional) The name of the INI or Properties file to be loaded into memory
aSeondaryPropFile$ | (optional) The name of a secondary INI or Properties file to be loaded into memory

Properties

PROPERTY thePropertyFile$ * Read Only *
PROPERTY num_properties * Read Only *

Methods

FUNCTION add_property(aName$, aValue$)

Add a property to memory structure; if already exists, this will overwrite the existing value

Parameter | Description
aName$ | The name of the property
aValue$ | The value of the property
Returns A simple boolean (0=false, 1=true) to indicate if the property was successfully updated
Info

Comments or blank lines can be added to "in-memory" property file structure by setting Name to "*" and value to an empty string or the comment line.

For example: Add a blank line: oProp'add_property("*", "") Add a coment line: oProp'add_property("*", "# A new comment line")

FUNCTION delete_property(aName$)

Delete a property

Parameter | Description
aName$ | The name of the property to delete
Returns A simple boolean (0=false, 1=true) to indicate that the property was deleted
FUNCTION has_property(aName$)

Check that a property exists

Parameter | Description
aName$ | The name of the property to test
Returns A simple boolean (0=false, 1=true) to indicate if the property exists
FUNCTION iterator_get_next()

Iterator: Get next property

Returns A 'NAME=VALUE' pair (name_value_pair) with the property information; if no properties remain, will return -1
FUNCTION iterator_has_next()

Iterator: Has next

Returns A simple boolean (0=false, 1=true) to indicate whether there is another property
FUNCTION iterator_init()

Iterator: Initialize

Returns A simple boolean (0=false, 1=true) to indicate initialzation was successful
FUNCTION load_file(propertyFile$)

load properties into the data structure from the specified property file

Parameter | Description
propertyFile | The name of the property file to load into memory
Returns A simple boolean (0=false, 1=true) to indicate that the property file was successfully loaded
FUNCTION read_property$(aName$)

Get the value of a property; will cancel any active iterator

Parameter | Description
aName$ | The name of the property to retrieve
Returns A string containing the value of the property
FUNCTION save_file()

write the data structure to the original property file - overwrite existing content

Returns A simple boolean (0=false, 1=true) to indicate that the property file was successfully updated
FUNCTION save_file(propertyFile$)

write the data structure to the specified property file - overwrite existing content

Parameter | Description
propertyFile | The name of the property file to update
Returns A simple boolean (0=false, 1=true) to indicate that the property file was successfully updated
Footer logo


pvx_build_log

Class pvx_build_log

Build Information

Forcelinenumbers false

Constructor

Capture errors and warnings for a program during the build process.

Parameter | Description
SourceFile$ | The source file that was processed
Destination$ | The output file (tokenized) program that was created

Properties

LOCAL logType=1
PROPERTY _version$=CVS(MID(STP("$Revision: 2716 $", 2, "$"), 10), 3)

Methods

FUNCTION getBuildCounts(errorCount, warningCount)

Get counts for errors and warnings

Parameter | Description
errorCount | The number of errors recorded
warningCount | The number of warnings that have been recorded
FUNCTION getErrorData(errorData$, errorCount)

Get the log information that has been captured

Parameter | Description
errorData$ | The information about the errors that have been logged
errorCount | The number of errors recorded
FUNCTION getWarningData(warningData$, warningCount)

Get the warnings that have been recorded

Parameter | Description
warningData | The information about the warnings that have been captured
warningCount | The number of warnings that have been recorded
FUNCTION get_Build_Log$()

Get the contents of the build log as a simple data stream (string).

FUNCTION isEmpty()

This method returns a boolean value (0=false, 1=true) to indicate if any issues have been recorded

FUNCTION record_Error(stmt_Num, src_Line, err_Num, err_Msg$, pgm_Line$)

Record information about an error found in the program source code

Parameter | Description
stmt_Num | Program line number (or projected line number) where error was found
src_Line | Source file line where error was found
err_Num | Error number
err_Msg$ | Error message text
pgm_Line$ | The actual program line that has the error
FUNCTION record_Error(stmt_Num, src_Line, err_Num$, err_Msg$, pgm_Line$)

Record information about an error found in the program source code

Parameter | Description
stmt_Num | Program line number (or projected line number) where error was found
src_Line | Source file line where error was found
err_Num$ | Error number/ID
err_Msg$ | Error message text
pgm_Line$ | The actual program line that has the error
FUNCTION record_Warning(err_Num, err_Msg$)
FUNCTION record_Warning(err_Num, err_Msg$, info$)

Record information about a warning that has been captured about the program

Parameter | Description
err_Num | Error number
err_Msg$ | Error message text
info$ | (Optional) Additional data associated with this warning
FUNCTION record_Warning(stmtNum, srcLine, warnID$, warnMsg$, pgmLine$)

Record information about a warning found in the program source code

Parameter | Description
stmtNum | Program line number (or projected line number) where warning was found
srcLine | Source file line where warning was found
warnID$ | warning number/ID
warnMsg$ | warning message text
pgm_Line$ | The actual program line for the warning
FUNCTION setErrorData(newErrorData$, newErrorCount)

Reset the build log data.

FUNCTION set_Warnings(warningData$, warningCount)

Set information about all warnings that have been captured for the program and retrieved using _OBJ'get_Warnings$()

Parameter | Description
warningData | The information about the warnings that have been captured
warningCount | The number of warnings that have been recorded
FUNCTION summarize_Errors()

Write a summary of the errors that have been recorded about the program

Footer logo


pvx_data

Class pvx_data

This class holds information about a single piece of information used by the plug-in. Each piece of information has three attributes: name, value and type. This class was called 'Ecipse_data' in previous versions of the plug-in.

Build Information

Forcelinenumbers false

Constructor

Create a new data object where a value can be stored and the data type can be set.

Parameter | Description
initKey$ | The name of this data value.
InitValue$ | Initial String value; the type is implied from this data value. (Optional) ** Only one value accepted String OR Numeric **
InitValue | Initial numeric value (Optional) ** Only one value accepted String OR Numeric **

Properties

PROPERTY _version$=CVS(MID(STP("$Revision: 2716 $", 2, "$"), 10), 3)
PROPERTY BOOLEAN_TYPE=1
PROPERTY STRING_TYPE=2
PROPERTY NUMERIC_TYPE=3
PROPERTY isBoolean * Read Only *
PROPERTY isNumeric * Read Only *
PROPERTY isString * Read Only *

Methods

FUNCTION getKey$()

Return the key (name) associated with this data.

FUNCTION getType()

Return the type of data

FUNCTION getValue$()

Return the data value for string data

FUNCTION getValue()

Return the data value for numeric data

FUNCTION setType(initType)

Set the data type

Parameter | Description
initType | A data type specified by referencing the corresponding property defined within this class.
FUNCTION setValue(inValue$)

Set the data value for string data

Parameter | Description
inValue$ | The value to be assigned
FUNCTION setValue(inValue)

Set the data value for numeric data

Parameter | Description
inValue | The value to be assigned
Footer logo


pvx_source_reader

Class pvx_source_reader

The class will read a source file for a ProvideX program. It uses a FileReader to read the lines from the file and concatenates them together to build the full program line.

Constructor

Open the ProvideX source file to be read.

Parameter | Description
inFile$ | The name of file to read
inPathResolver | **Optional** A reference to a path_resolver class to expand the name of include files.

Properties

LOCAL openBC$="/"+"*"
LOCAL closeBC$="*"+"/"
PROPERTY _version$=CVS(MID(STP("$Revision: 2797 $", 2, "$"), 10), 3)

Methods

FUNCTION getEOF()

Get the end of file status

Returns A boolean that is set to TRUE (1) when end of data stream has been reached.
FUNCTION getFirstLine$()

Get the unprocessed first line from the source file

Returns A string containing the data from the first line of the source file.
FUNCTION getSourceText$()

Get the unprocessed text as read from source file for current program line

Returns A string containing the text from the source file with minimal processing.
FUNCTION hasLineNumbers()

The source file has line numbers. This value is based on the first line in the file since the program load will fail if the remainder of the source file does not use line numbers.

Returns A simple boolean value (0 = False, 1 = True)
FUNCTION read$()
Returns A string containing the text for a single line read from the file

this will include line breaks appended to the end of the string so that the number of lines will match the original source file.

FUNCTION setBlockCommentsVisible(inBoolean)

Set a flag to control whether C-style block comments are returned to the controlling application. The default is to hide these comments.

Parameter | Description
inBoolean | (0 = False, 1 = True)
FUNCTION setIgnoreIncludes(inBoolean)

Set a flag to disable processing of '#include' references

Parameter | Description
inBoolean | (0 = False, 1 = True)
FUNCTION setStripLeadingWhiteSpace(inBoolean)

Set a flag to force stip of leading white space

Parameter | Description
inBoolean | (0 = False, 1 = True)
Footer logo


pvx_source_utility

Class pvx_source_utility

Properties

PROPERTY _version$=CVS(MID(STP("$Revision: 3009 $", 2, "$"), 10), 3)

class version

Methods

FUNCTION getKeywords$(aPgmLine$)
FUNCTION getKeywords$(aPgmLine$, aSepChar$)
FUNCTION getKeywords$(aPgmLine$, aSepChar$, aModLine$)

Get a (aSepChar$ separated) list of keywords used on the current program line

Parameter | Description
aPgmLine$ | [in] The program line to use
aSepChar$ | [in] (Optional) The character to use to separate each member of the list; if not set will default to a space.
aModLine$ | [out] the modified program line, after remarks adn literals are removed
Returns A list of keywords
FUNCTION getKeywordsPlus$(aPgmLine$)
FUNCTION getKeywordsPlus$(aPgmLine$, aSepChar$)

Get a (aSpeChar$ separated) list of keywords,mnemonics,labels used on the current program line

Parameter | Description
aPgmLine$ | The program line to use
aSepChar$ | (Optional) The character to use to separate each member of the list; if not set will default to a space.
Returns A list of keywords, mnemonics, and labels
FUNCTION getLiterals$(aPgmLine$)
FUNCTION getLiterals$(aPgmLine$, aSepChar$)

Get a (SEP separated) list of literals used on the current program line

Parameter | Description
aPgmLine$ | The program line to use
aSepChar$ | (Optional) The character to use to separate each member of the list; if not set will default to a space.
Returns A list of literals
FUNCTION getMnemonics$(aPgmLine$)
FUNCTION getMnemonics$(aPgmLine$, aSepChar$)

Get a (aSepChar$ separated) list of mnemonics used on the current program line

Parameter | Description
aPgmLine$ | The program line to use
aSepChar$ | (Optional) The character to use to separate each member of the list; if not set will default to a space.
Returns A list of mnemonics
FUNCTION getRemarks$(aPgmLine$)
FUNCTION getRemarks$(aPgmLine$, aSepChar$)

Get remarks for the current program line

Parameter | Description
aPgmLine$ | The program line to use
aSepChar$ | (Optional) The character to use to separate each member of the list; if not set will default to a space.
Returns A the remarks
FUNCTION getStatementLabels$(aPgmLine$)
FUNCTION getStatementLabels$(aPgmLine$, aSepChar$)

Get a (aSepChar$ separated) list of statement labels used on the current program line

Parameter | Description
aPgmLine$ | The program line to use
aSepChar$ | (Optional) The character to use to separate each member of the list; if not set will default to a space.
Returns A list of labels
FUNCTION getVariables$(aPgmLine$)
FUNCTION getVariables$(aPgmLine$, aSepChar$)

Get a list of variables referenced on the specified program line

Parameter | Description
aPgmLine$ | The program line to use
aSepChar$ | (Optional) The character to use to separate each member of the list; if not set will default to a space.
Returns A list of variables
Footer logo


pvx_tokenized_reader

Class pvx_tokenized_reader

The class will read a tokenized ProvideX program file and return a single program line for each read.

Build Information

Forcelinenumbers false

Constructor

Automatically convert the specified ProvideX program to a temporary text file and use file_reader to read it. The temporary file will be deleted when the class is destroyed.

Parameter | Description
inFile$ | The name of file to read
inPassword$ | **Optional** The password to decrypt a tokenized program
inPathResolver | **Optional** A reference to a path_resolver class to expand the name of include files.

Properties

PROPERTY _version$=CVS(MID(STP("$Revision: 2796 $", 2, "$"), 10), 3)

Methods

FUNCTION getEOF()

Get the end of file status

Returns A boolean that is set to TRUE (1) when end of data stream has been reached.
FUNCTION getSourceText$()

Get the text as read from source file for current program line. The keywords may be changed based on the setting of the 'changeKeywords' property.

Returns A string containing the text from the source file with minimal processing.
Info

If the source file is not a text file, this method will return an error 13.

FUNCTION read$()

Returns a string containing the text for a single line read from the file.

FUNCTION setBlockCommentsVisible(inBoolean)

Set a flag to control whether C-style block comments are returned to the controlling application. The default is to hide these comments.

Parameter | Description
inBoolean | (0=False, 1=True)
FUNCTION setIgnoreIncludes(inBoolean)

Set a flag to disable processing of '#include' references

Parameter | Description
inBoolean | (0=False, 1=True)
FUNCTION setStripLeadingWhiteSpace(inBoolean)

Set a flag to force stip of leading white space

Parameter | Description
inBoolean | (0=False, 1=True)
Footer logo


pvx_utility

Class pvx_utility

This is a simple class of utility methods that can be used throughout the software.

Properties

PROPERTY _version$=CVS(MID(STP("$Revision: 3060 $", 2, "$"), 10), 3)

Methods

FUNCTION copyFile(sourceFile$, destFile$, eraseOK)
FUNCTION copyFile(sourceFile$, destFile$, eraseOK, skipRefresh)

Copy file and optionally erase the original after the copy has completed. If this method is executed within the Eclipse plug-in context, the resource will also be refreshed so that Eclipse will be made aware of the file change.

Parameter | Description
sourceFile$ | The file to copy
destFile$ | The file to replace or create from the source file
eraseOK | A boolean flag to indicate if the source file should be deleted after the copy.
skipRefresh | Skip refresh of file in Eclipse workspace
FUNCTION createDirectory(aDirectory$, bCreateParent)

Create a directory

Parameter | Description
aDirectory$ | The directory to create
bCreateParent | Create parent directory if it does not exist? (0=false, 1=true)
Returns A boolean flag to to indicate success (0=Failed, 1=Succeed)
FUNCTION dumpPrefixLists$()

Dump Prefix List

Returns A string value containing the currently defined prefix lists
FUNCTION findText(aString$, aSearchText$)

Locate an occurrence of aSearchText$ in aString$ that does not appear within quotes.

Parameter | Description
aString$ | The string to be searched
aSearchText$ | The text to locate.
Returns The position of first occurrence.
FUNCTION getFileModTime$(aFile$)

Get the modification time stamp for a file

Parameter | Description
aFile$ | The full path to the file to be checked
Returns A string value containing the modification time stamp for the file in the format "YYYY/MM/DD HH:MM:SS"
FUNCTION getWorkDir$()

Get the user / system folder for temporary/work files

Returns The full path name of the directory/folder to use for work files
FUNCTION getWorkFile$(aNamePfx$)

Generate a name for a new work file (cannot exist) and use the Operating System default temporary directory.

Parameter | Description
aNamePfx$ | The start of the work file name.
Returns The full path name of a work file that can be created by the application.
FUNCTION getWorkFile$(aNamePfx$, aWorkDir$, aFileExt$)

Generate a name for a new work file (cannot exist) in the work directory specified.

Parameter | Description
aNamePfx$ | The start of the work file name.
aWorkDir$ | The directory where the work file will be created; if not set, will use the temporary directory for the OS
aFileExt$ | The file extension to be added to the file name (default is "tmp")
Returns The full path name of a work file that can be created by the application.
FUNCTION setFileModTime(aFile$, modTime$)

Set the modification time stamp for a file

Parameter | Description
aFile$ | The full path to the file to be checked
modTile$ | A string value containing the modification time stamp in the format "YYYY/MM/DD HH:MM:SS"
FUNCTION stripBlockComments$(inText$)
FUNCTION stripBlockComments$(inText$, inReplaceChar$)

Replace the contents of a C-style block comment with the specified replacement character.

Parameter | Description
inText$ | A block of text that is to have the block comments stripped.
inReplaceChar$ | (Optional) A character to be substituted for the block comment
Returns A block of text without the C-style block comments.
FUNCTION stripPvxDocHeaderInfo$(inText$)

Strip the ProvideX documentation header information.

Parameter | Description
inText$ | A block of text that may have the PvxDoc tag information stripped.
Returns A block of text without the PvxDoc tag information.
FUNCTION stripPvxDocTagInfo$(inText$)
FUNCTION stripPvxDocTagInfo$(inText$, inDocTag$)

Strip the ProvideX documentation tag information where the documentation prefix is '! *-' and allow stripping of the header tag information.

Parameter | Description
inText$ | A block of text that is to have the PvxDoc tag information stripped.
inDocTag$ | (Optional) The documentation tag to be removed.
Returns A block of text without the PvxDoc tag information.
FUNCTION stripStringLiterals$(inText$)
FUNCTION stripStringLiterals$(inText$, inReplaceChar$)

Replace the contents of a String Literal with the specified replacement character.

Parameter | Description
inText$ | A block of text tto be processed
inReplaceChar$ | (Optional) A character to be substituted for the String Literal
Returns A block of text without the StringLiterals
FUNCTION writeLogMessage(filenamePrefix$, msgText$)

Write a message to log file with name based on the specified prefix

Parameter | Description
filenamePrefix$ | A prefix for the log file name
msgText$ | text to write to the log file
Footer logo


pvxrequestclient

Class pvxrequestclient

This class is used to communicate request to the RequestManager which will pass the information to a dedicated worker process to take action.

Build Information

Forcelinenumbers false

Constructor

Open a connection to the RequestManager.

Parameter | Description
Request_Socket$ | Optional value for the socket to use to connect to the Request Manager. If this value is not set, ARG(1) will be used.

Properties

LOCAL MAJOR_EXIT$="z"
LOCAL MAJOR_RESTART$="Z"
LOCAL MAJOR_PRINT$="P"
LOCAL MAJOR_RESOURCE$="R"
LOCAL MAJOR_VIEW$="V"
LOCAL MAJOR_START$="S"
LOCAL MAJOR_DONE$="D"
LOCAL MAJOR_CLEAR$="C"
LOCAL ACTION_BUILD$="B"
LOCAL ACTION_CONSOLE_VIEW$="c"
LOCAL ACTION_COPY$="C"
LOCAL ACTION_DELETE$="d"
LOCAL ACTION_MARK$="m"
LOCAL ACTION_FIND_MARK$="f"
LOCAL ACTION_BOOK_MARK$="b"
LOCAL ACTION_MOVE$="M"
LOCAL ACTION_NONE$=" "
LOCAL ACTION_PROPERTY$="P"
LOCAL ACTION_REFRESH$="R"
LOCAL ACTION_STATUSBAR$="S"
PROPERTY _version$=CVS(MID(STP("$Revision: 2843 $", 2, "$"), 10), 3)
PROPERTY view_bookmarks$="org.eclipse.bookmarks"
PROPERTY view_embeddict$="com.pvx.ooadide.views.iolistview"
PROPERTY view_nomads$="com.pvx.ooadide.nomadslibview"
PROPERTY view_pvxoutline$="com.pvx.ooadide.pvcoutline"

Methods

FUNCTION addBookmark(aResource$, aResetFlag$, theData$)

Send a message to add a bookmark to a resource

Parameter | Description
aResource$ | The full path of the resource to rebuild.
aResetFlag$ | A boolean value to indicate existing file marks are to be reset
Data$ | The data to be used to mark the resource
FUNCTION addToSearchView(aResource$, aResetFlag$, theData$)

Send a message to mark the search view for a resource

Parameter | Description
aResetFlag$ | A boolean value to indicate existing file marks are to be reset
Data$ | The data to be used to mark the resource
FUNCTION clearBookmarks(aResource$)

Clear all bookmarks

Parameter | Description
aResource$ | The full path of the resource to rebuild.
FUNCTION finishedSearch()

Send a message to end a search

FUNCTION print(text$)

Print a message on the console view.

Parameter | Description
text$ | The text message to be displayed
FUNCTION resource_build(name$)

Send a message to trigger a rebuild of the specified resource.

Parameter | Description
name$ | The full path of the resource to rebuild.
FUNCTION resource_copy(from$, to$)

Send a message to copy a resource

Parameter | Description
from$ | The full path of the resource to be copied
to$ | The full path of the location where to copy is to be saved
FUNCTION resource_delete(name$)

Send a message to delete a resource

Parameter | Description
name$ | The full path of the resource to be copied
FUNCTION resource_mark(aResource$, aResetFlag$, theData$)

Send a message to mark errors and warnings for a resource

Parameter | Description
aResource$ | The full path of the resource
aResetFlag$ | A boolean value to indicate existing file marks are to be reset
Data$ | The data to be used to mark the resource
FUNCTION resource_move(from$, to$)

Send a message to move a resource

Parameter | Description
from$ | The full path of the resource to be copied
to$ | The full path of the location where to copy is to be saved
FUNCTION resource_property(name$, property$, value$)

Send a message to set a property for a resource

Parameter | Description
name$ | The full path of the resource to be affected.
property$ | The name of the property to be set
value$ | The value to be assigned to the property
FUNCTION resource_refresh(name$)

Send a message to refresh a list of resources.

Parameter | Description
name$ | The list of resources to be refreshed separated by "|"; each entry in the list is the full path to the resource (in the OS file system) to be refreshed.
FUNCTION restart()

Print a message on the console view.

Parameter | Description
text$ | The text message to be displayed
FUNCTION startSearch(findStr$)

Send a message to start a new search

Parameter | Description
findStr$ | The string to search for
FUNCTION statusbar_message(viewid$, msg$)

Print a message to the statusbar of a view

Parameter | Description
viewid$ | The id of the view
msg$ | the message to print to the statusbar
FUNCTION view_refresh(name$)

Send a message to refresh a view.

Parameter | Description
name$ | The name of the view to be refreshed. The possible values for this argument are listed in the following table.

The values for the view name are defined as properties of this class

Value | Description
thisClass'view_embeddict$ | Embedded data dictionary information.
thisClass'view_nomads$ | NOMADS library contents
thisClass'view_pvxoutline$ | Information about currently selected resource
Footer logo


com.pvx.pvxdoc.configUI

Class com.pvx.pvxdoc.configUI

This class contains the user interface logic for the PvxDocs configuration panels.

Constructor

The constructor for this class retrieves the data from the Eclipse Preference store. If the data does not exist, the default values that are hard-coded into this program will be used.

Inherits

*nomads

Properties

LOCAL prefPfx$="com.pvx.pvxdoc."
LOCAL builderDataLength=9
LOCAL formatDataLength=5
LOCAL dflt_headerData$="110101"
LOCAL dflt_builderData$="001011000"
LOCAL dflt_formatData$="23011"
LOCAL numSections=8
LOCAL dflt_sectionData$="Build Info|Constructor|Inherits|Sub-Classes|Properties|Methods|Properties Inherited from ...|Methods Inherited from ...|"
PROPERTY screen_id$="CONFIG"

Initial panel to be loaded for the configuration information

PROPERTY screen_lib$="com.pvx.pvxdoc.en"

The library for the panel definitions

Methods

FUNCTION getOption(inKeyword$)

This method is used by the PvxDoc generation process to check the options

Parameter | Description
inKeyword$ | [input, string] Keyword for option to retrieve
Returns the numeric value of the specified option
Option Keywords
Value | Description
chm_files | Create CHM file
content_type | Format of output (1=HTML, 2=CHM, 3=Wiki Export File)
CreateFolders | Create folder structure based on project
ExtDocDir | Create PvxDoc folder is outside of project
ExtDocSubDir | Create a project-specific sub-folder
IncludeLocal | Include information about local properties
Javascript | 0=Direct link to page, 1=Javascript in same page, 2=Javscript in frame
PropertyAssignment | Include Property/Local assignment of constant values
SetDateTime | Set modification date/time stamp of document file to match source file
ShowFolders | Use folder structure for navigation menu
SingleDoc | Create as single large HTML file
FUNCTION getSectionOrder$()

This method is used by the PvxDoc generation process to get the order of the document sections.

FUNCTION getValue$(inKeyword$)

This method is used by the PvxDoc generation process to get the value for the options (ExtDocDir, LogoFile).

Parameter | Description
inKeyword$ | [input, string] Keyword for option to retrieve
Returns the string value of the specified option
Option Keywords
Value | Description
chm_files | Create CHM file
ExtDocDir | External document folder location
FooterLogo | Full path to the logo file
FooterLogoAlign | Alignment of the logo file ((1=Left, 2=Center, 3=Right)
HeaderLogo | Full path to the logo file
HeaderLogoAlign | Alignment of the logo file ((1=Left, 2=Center, 3=Right)
HHC_Location | path to location of CHM Help compiler
Wiki_Parent_Dir | 'Path' to location in wiki where help files will be placed
FUNCTION showTag(inTag$)

This method is used by the PvxDoc generation process to check if a build information tag value is to be included in the generated document.

Returns A simple boolean (0=False, 1=True).
Footer logo


com.pvx.pvxdoc.createDocs

Class com.pvx.pvxdoc.createDocs

This class is the progress monitor displayed during the PvxDocs generation process.

Constructor

The constructor for this class sets control values used by the parent class to:

  • set the description for the process,
  • identify the setup object to be used to configure the process,
Parameter | Description
aSetup | reference to a *nomads object used to configure the document generation process

Inherits

com.pvx.util.progress

Properties

No Properties

Methods

FUNCTION enable_special(sLabel$, filePath$)

Method to enable the 'Special' button

Parameter | Description
sLabel$ | Label to display on button
filePath$ | Path to main file to open for the generated documentation

Properties inherited from: com.pvx.util.progress

_version$, theCaption$,theDescription$, screen_id$, screen_lib$

Methods inherited from: com.pvx.util.progress

checkCancel(), createLogFile(), disable_cancel(), enable_cancel(), enable_special(), writeLog(), writeLogFile(), b_close(), b_special(), disable_special(), doWork(), onExit(), PostLoad(), PreLoad(), setDescription(), updateView(), workDone()

Footer logo


com.pvx.pvxdoc.format_content

Class com.pvx.pvxdoc.format_content

This class is used to create the content for the PvxDocs generation process based on the format selected during setup.

Properties

LOCAL totalTemplateCodes=43
PROPERTY cBlankLine=1
PROPERTY cClassStart=2
PROPERTY cContentEnd=3
PROPERTY cContentStart=4
PROPERTY cListEnd=5
PROPERTY cListItem=6
PROPERTY cListStart=7
PROPERTY cNoContent=8
PROPERTY cNotesEnd=9
PROPERTY cNotesLine=10
PROPERTY cNotesStart=11
PROPERTY cParagraphClose=12
PROPERTY cParagraphEnd=13
PROPERTY cParagraphFull=14
PROPERTY cParagraphLine=15
PROPERTY cParagraphOpen=16
PROPERTY cParagraphStart=17
PROPERTY cRowEnd=18
PROPERTY cRowStart=19
PROPERTY cSectionBegin=20
PROPERTY cSectionEnd=21
PROPERTY cSubSectionBegin=22
PROPERTY cSubSectionEnd=23
PROPERTY cSubSectionWrap=24
PROPERTY cTableEnd=25
PROPERTY cTableHeading1=26
PROPERTY cTableHeading2=27
PROPERTY cTableStart=28
PROPERTY cTable2End=29
PROPERTY cTable2Row=30
PROPERTY cTable2RowB=31
PROPERTY cTable2RowC=32
PROPERTY cTable2Start=33
PROPERTY cWarningEnd=34
PROPERTY cWarningStart=35
PROPERTY cOListEnd=36
PROPERTY cOListItemEnd=37
PROPERTY cOListItemStart=38
PROPERTY cOListStart=39
PROPERTY cUListEnd=40
PROPERTY cUListItemEnd=41
PROPERTY cUListItemStart=42
PROPERTY cUListStart=43
PROPERTY contentType * Read Only *

Format of content to be generated

Value | Description
1 | HTML
2 | CHM (Windows Compiled HTML)
3 | Wiki text

Methods

FUNCTION getFormattedLine(inTemplateID, outFormattedLine$)
FUNCTION getFormattedLine(inTemplateID, outFormattedLine$, inSubstitute1$)
FUNCTION getFormattedLine(inTemplateID, outFormattedLine$, inSubstitute1$, inSubstitute2$)

Get formatted line (two substitution values)

Parameter | Description
inTemplateID | ID of template value to be used
outFormattedLine$ | Formatted line of text
inSubstitute1$ | (Optional) First subtitution value
inSubstitute2$ | (Optional) Second subtitution value
Returns A simple boolean (0=Failed, 1=Passed) to indicate failure to load template for content type
FUNCTION loadTemplate(inContentType)

Load the template for specified content type

Parameter | Description
inContentType | type of content to be used for formatting
Returns A simple boolean (0=Failed, 1=Passed) to indicate failure to load template for content type
Footer logo


com.pvx.pvxdoc.setupUI

Class com.pvx.pvxdoc.setupUI

This class is the user interface used to manage the setup information for the PvxDocs generation process

Constructor

Load the configuration information for the PvxDocs generation process.

Inherits

*nomads

Properties

PROPERTY screen_id$="SETUP"

Initial panel to be loaded for the configuration information

PROPERTY screen_lib$="com.pvx.pvxdoc.en"

The library for the panel definitions

Methods

FUNCTION getOption(inKeyword$)

This method is used by the PvxDoc generation process to check the option.

Parameter | Description
inKeyword$ | The keyword for the property to be checked
Returns A number representing the current value of the property; most of these options will return (0=False, 1=True) except as described in the table
Option Keywords
Value | Description
content_type | Format of output (1=HTML, 2=CHM, 3=Wiki Export File)
CreateFolders | Create folder structure based on project
ExitStatus | Exit status of document generation process (0=Cancel, 1=Completed)
Javascript | 0=Direct link to page, 1=Javascript in same page, 2=Javscript in frame
IncludeLocal | Include information about local properties
PropertyAssignment | Include property assignment information in addition to name and documentation
SetDateTime | Set modification date/time stamp of document file to match source file
ShowFolders | Use folder structure for navigation menu
SkipClasses | Skip classes with no documentation
StripText | Strip text from beginning of path for each file processed before adding to navigation menu
FUNCTION getValue$(inKeyword$)

This method is used by the PvxDoc generation process to get the value for the options.

Parameter | Description
inKeyword$ | The keyword for the property to be checked
Returns A string value of the property
Option Keywords
Value | Description
DocTopic | Topic to display for CHM file
ExtDocDir | Folder outside of project to place generated documentation files
Javadoc_Root | Relative path (to output folder) for Javadocs referenced in generated documenation
StripValue | Text to be removed from beginning of path for each file processed
Wiki_Parent_Dir | Path to parent page in Wiki Site for generated Wiki Export File
Footer logo


com.pvx.pvxdoc.wiki_export

Class com.pvx.pvxdoc.wiki_export

Create Wiki export file(s) from the specified wiki-text files; the size if each export file will be limited to approximately 400KB.

A navigation sidebar will be created if the parent page for this collection of pages is specified. The parent page and sidebar content will be placed into a separate export file.

Parameter | Description
aXmlFile$ | An XML file to create containing the wiki pages
ParentDir$ | The parent directory of this collection of pages in the Wiki
NavHeading$ | The heading to use on the Sidebar navigation menu

Properties

LOCAL NotSpecified
LOCAL ValueTypeAttribute
LOCAL SetModeParent
LOCAL DocRoot$="mediawiki"
LOCAL openBrace$
LOCAL maxExportFileSize=400000

Methods

FUNCTION AddPage(theFile$, aWikiPath$, aWikiFile$, ClassName$)

Add a wiki page to the export file

Parameter | Description
theFile$ | Full path to the file to read
aWikiPath$ | Path to the folder for the wiki file (sub-folder of page/article in Wiki)
aWikiFile$ | Simple name for page/article
ClassName$ | The name of the class
Returns A simple boolean (0=Failed, 1=Passed) to indicate success with reading file
FUNCTION setBuildRootPage(aBoolean)

Set boolean flag to control creation of the Root page for new content

Parameter | Description
aBoolean | A simple boolean (0=false, 1=true) to indicate that the Root page should be created
Returns A simple boolean (0=fail, 1=pass) to indicate the successful execution of the method
Info

This flag must be set before any pages are processed; otherwise, the method will fail.

Footer logo


ConfigAppserverActionListener

Class ConfigAppserverActionListener

Set the action to be performed for this listener.

Inherits

AbstractActionListener, EventManagerObserver

Properties

LOCAL theDescription$="Configure ProvideX Application Server"

Description to be used for tool in the list of Contributed Tools access from the ProvideX, Contributed Tools menu item

Methods

FUNCTION ActionPerformed(inActionEventID)

This method will be called when the 'Run' action is triggered from the contributed tools menu.

Parameter | Description
inActionEventID | This is a reference to [Java Class:eventmanager/ExtCommand]
FUNCTION Init()

Register this class as an event listener and add it to the list of contributed tools under the ProvideX menu item.

Properties inherited from: AbstractActionListener

theDescription$, theNotificationFlag, theToolShortname$

Properties inherited from: EventManagerObserver

theDescription$, theNotificationFlag, theToolShortname$, mustRefreshResource

Methods inherited from: AbstractActionListener

actionPerformed(), configPerformed(), getDescription$(), getEventNotificationFlag(), getToolShortname$(), hasConfigAction(), init()

Methods inherited from: EventManagerObserver

getDescription$(), getEventNotificationFlag(), getToolShortname$(), init(), initState(), update(), setCurrentSource(), updateSourceFile()

Footer logo


ConfigWebserverActionListener

Class ConfigWebserverActionListener

Set the action to be performed for this listener.

Inherits

AbstractActionListener, EventManagerObserver

Properties

LOCAL theDescription$="Configure ProvideX Web Server"

Description to be used for tool in the list of Contributed Tools access from the ProvideX, Contributed Tools menu item

Methods

FUNCTION ActionPerformed(inActionEventID)

This method will be called when the 'Run' action is triggered from the contributed tools menu.

Parameter | Description
inActionEventID | This is a reference to [Java Class:eventmanager/ExtCommand]
FUNCTION Init()

Register this class as an event listener and add it to the list of contributed tools under the ProvideX menu item.

Properties inherited from: AbstractActionListener

theDescription$, theNotificationFlag, theToolShortname$

Properties inherited from: EventManagerObserver

theDescription$, theNotificationFlag, theToolShortname$, mustRefreshResource

Methods inherited from: AbstractActionListener

actionPerformed(), configPerformed(), getDescription$(), getEventNotificationFlag(), getToolShortname$(), hasConfigAction(), init()

Methods inherited from: EventManagerObserver

getDescription$(), getEventNotificationFlag(), getToolShortname$(), init(), initState(), update(), setCurrentSource(), updateSourceFile()

Footer logo


ecCommon

Class ecCommon

This class provides several common methods to enable access to Eclipse information.

Properties

LOCAL pLookAndFeel$
PROPERTY StageActionPerformed=1
PROPERTY StageProcessPanel=2
PROPERTY StageTaskStart=3
PROPERTY cConsoleFont$

Default Fixed-width font (text plane / console)

PROPERTY cGraphicalFont$

Default Proportional font

Methods

FUNCTION ConfigGuiDisplay()
FUNCTION ConfigGuiDisplay(allowDialogueWindows)

Standard initialization of graphical environment for the view

Parameter | Description
allowDialogueWindows | A simple boolean to allow dialogue windows to display outside of Eclipse view (0=No, 1=Yes)
FUNCTION GetFontInfo(option$, name$, size)

Get information about the specified system font type

Parameter | Description
option$ | A single letter to identify the font type
name$ | Name of current font of specified type
size | Size of current font of specified type
Returns 0=No Font infomration found, 1=Found font information
Font Type Codes
Value | Description
G | Graphical Font
T | Text plane font
FUNCTION GetInfo$(option$)

Get information about the current Eclipse working environment

Parameter | Description
option$ | A single letter to identify the information required.
Returns The value for the requested information.
Information Codes
Value | Description
E | The current editor resource
N | The number of selected resources in the Navigator View
P | The current project
W | The workspace name
FUNCTION GetPath$(option$)

Get the specified path

Parameter | Description
option$ | A single letter code to identify the path
Returns The value for the path.
Path Identification Codes
Value | Description
O | The location of the output directory for the current project
P | The current project location
S | The location of the source directory for the current project
W | The location of the current workspace
FUNCTION GetWorkspaceRoot$()

Get Workspace Root Path

FUNCTION InitStage(stage)

Perform initialization steps for specified stage; will also check environment variable PP4E_CT_DEBUG for and initiate debug action(s)

Parameter | Description
stage | Contributed tool startup stage
Contributed tool Startup Stage
Value | Description
StageActionPerformed | 1 Action Performed method (in listener)
StageProcessPanel | 2 Process Panel (in ecCommon)
StageTaskStart | 3 Task startup (ecCommonStartup)
FUNCTION isPluginLoaded(aPluginID$)

Check to see if the MAS plug-in has been loaded aPluginID$ The ID of the dependent plug-in to be checked

Returns A simple boolean (0=false, 1=true) to indicate whether the dependent Plug-in has been loaded
FUNCTION OSisWindows()

A simple check to determine if application is executing on a MS-Windows operating system.

Returns A simple boolean to indicate that operating is MS-Windows
FUNCTION Prefs(option$, tag$, value$)

Access / modify preferences stored in the Eclipse Preference store

Parameter | Description
option$ | A code to indication the action to perform
tag$ | The preference (or preference prefix)
value$ | The value to be returned for a preference, or the value to set for the preference, or the maximum number for the preferences to be cleared
Returns See 'Action Code' table
Action Codes
Value | Description
C | Clear a series of preferences that are prefixed by TAG$ and include a numeric counter that starts at one. The return value will be the number of preferences that have been cleared
G | Get the value of the preference. The return value will be a 1 of there is a value.
S | Set the value of the preference. The return value will be a 1 if the assignment was successful.
FUNCTION processPanel(cUI$, cTitle$)
FUNCTION processPanel(cUI$, cTitle$, aDataRec$)

Standard mechanism to process a NOMADS panel in a view (in a separate process)

Parameter | Description
cUI$ | A NOMADS OOP class for the user interface
cTitle$ | The panel title
aDataRec$ | (Optional) A data record (SEP as field separator) to be seprated into variables and passed as arguments to the constructor of the class
FUNCTION Resource(option$, path$)

Get the location of the specified resource

Parameter | Description
option$ | A code to identify the view for the selected resource
path$ | The path of the selected resource is returned in this variable
Returns A simple boolean to indicate that the method succeeded
View Codes
Value | Description
E | The current resource loaded in the editor
N | The resource selected in the Navigator View
FUNCTION runProgram(aProgram$, cTitle$)
FUNCTION runProgram(aProgram$, cTitle$, aDataRec$)
FUNCTION runProgram(aProgram$, cTitle$, aDataRec$, aVarList$)

Standard mechanism to run a program within a view (in a separate process)

Parameter | Description
aProgram$ | The name of a program to execute
cTitle$ | The title for the application window
aDataRec$ | (Optional) A data record to be passed to application program
aVarList$ | (Optional) A list of variables to be assigned the values in aDataRec$
FUNCTION WorkFile$(prefix$, path$, ext$)

Get the name for a work file.

Parameter | Description
prefix$ | A prefix to be used when creating the name for the work file.
path$ | An optional path for the work file; if not specified, the operating system temporary directory will be used
ext$ | An optional file extension to be used for the work file; if none is specified, "tmp" will be used
Returns The full path name of a work file that can be created by the application.
Footer logo


ecCommonMethods

Class ecCommonMethods

An abstract class containing common methods to be inherited by Application/Contributed Tools UI class.

Known SubClasses

ecCommonUI

Properties

No Properties

Methods

FUNCTION MaskNumber$(value)

Get the masked string for a numeric value

Parameter | Description
value | Number to be formatted
Returns The number formatted using the mask "###,###,###,###,##0"
FUNCTION PercentStr$(dividend, divisor)

Get a per centage for two numnbers

Parameter | Description
dividend | the number to be represented as a per centage
divisor | the number to divide into divisor to get a per centage
Returns A per centage value calculated using formula: dividend / divisor
FUNCTION ReqClient(dest$, value$)
FUNCTION ReqClient(dest$, value$, path$)
FUNCTION ReqClient(dest$, value$, path$, overwrite)

Send information to Eclipse workbench

Parameter | Description
dest$ | Delivery destination for information - value must be "C"
value$ | Message to write to the console view
path$ | (Optional) Path to resource referenced by action
overwrite | (Optional) Overwrite existing value in Bookmark or Problem View (0 = False, 1 = True)
Destination Codes
Value | Description
B | Create a bookmark for resource in the bookmark view
C | Write a message to the console view
P | write an entry for resource to the Problem view
S | write an entry for resource to 'Classic Search' view
FUNCTION StringPad$(value$, length)
FUNCTION StringPad$(value$, length, justify$)

Pad a string to specified length with "." characters; if string value will be truncated if it is longer than specified length

Parameter | Description
value$ | String value
length | Length of padded string
justify$ | (Optional) Justification to be used (R = Right, L = Left)
Returns A string padded to specified length
FUNCTION StringSort$(value$)
FUNCTION StringSort$(value$, varName$)

Sort an alpha-numeric string, separated by commas, and remove duplicates

Parameter | Description
value$ | A comma-separated list of values to sort
varName$ | (Optional) Assign value to variable with this name
Returns A string containing a sorted list of the values with duplicates removed
Footer logo


ecCommonUI

Class ecCommonUI

Common UI interface to be used by Application/ContributedTools.

Inherits

*Nomads, ecCommonMethods

Known SubClasses

com.pvx.util.progress, com.pvx.util.toolsUI, ecDictUI, ecMsgLibUI, ecSearchLogViewUI, ecSearchUI

Properties

No Properties

Methods

FUNCTION LOCAL DropBoxAdd(ctlId, value$, varName$)

Add a row to dropbox

Parameter | Description
ctlId | NOMADS control ID of dropbox to update
value$ | Value to add to the dropbox
varName | Name of variable associated with NOMADS control
Returns A string containing the current selected value for the dropbox
FUNCTION LOCAL MessageBox$(message$)
FUNCTION LOCAL MessageBox$(message$, options$)
FUNCTION LOCAL MessageBox$(message$, options$, title$)

Display message box with specified message

Parameter | Description
message$ | The message to display
options$ | (Optional) Options to for message box
title$ | (Optional) Title to for message box
Returns The value corresponding to response selected by user
FUNCTION LOCAL NomadsProcess(*)

Start processing the NOMADS panel

FUNCTION LOCAL ProgressBarClose()

ProgressBar - Close active progress bar; if none active, do nothing

FUNCTION LOCAL ProgressBarInit(title$, x, y, width)

ProgressBar - Initialize

Parameter | Description
title$ | Short title to display to left of progress bar
x | Left-most position for progress bar area (must include space for title text)
y | Row where progress bar will appear in the current window
width | Width (number of columns) for the progress bar
FUNCTION LOCAL ProgressBarUpdate(work)

ProgressBar - Update per centage of work completed

Methods inherited from: ecCommonMethods

MaskNumber$(), PercentStr$(), ReqClient(), StringPad$(), StringSort$()

Footer logo


ecConstant

Class ecConstant

This is an abstract class with constants and common utility methods to be used by contributed tools to reduce duplication of code and to make code more readable.

Known SubClasses

com.pvx.util.progress

Properties

LOCAL isFALSE=0

Boolean Value - False

LOCAL isTRUE=1

Boolean Value - True

LOCAL isYES$="Y"

Yes/No Value - Yes

LOCAL isNO$="N"

Yes/No Value - No

LOCAL chkOFF$="0"

Checkbox Constants - Off

LOCAL chkON$="1"

Checkbox Constants - On

LOCAL chkGRAYED$="2"

Checkbox Constants - Grayed

LOCAL errOBJECT=200

Error Constant

LOCAL msgYES$="YES"

Message Constant - Yes

LOCAL msgNO$="NO"

Message Constant - No

LOCAL msgCANCEL$="CANCEL"

Message Constant - Cancel

LOCAL msgOK$="OK"

Message Constant - OK

LOCAL msgRETRY$="RETRY"

Message Constant - Retry

LOCAL msgABORT$="ABORT"

Message Constant - Abort

LOCAL msgIGNORE$="IGNORE"

Message Constant - Ignore

LOCAL msgNOTONFILE$="***Not on file***"

Message Constant - Not on File

LOCAL msgTIMEOUT$="TIMEOUT"

Message Constant - Timeout

LOCAL msgDISABLE=0

Message Constant - Disable

LOCAL msgACTIVE=1

Message Constant - Active

LOCAL retFAILURE=0

Return Value - Failure

LOCAL retSUCCESS=1

Return Value - Success

LOCAL retNEW=2

Return Value - New

LOCAL retWARNING=-1

Return Value - Warning

LOCAL retCANCEL=0

Return Value - Cancel

LOCAL retYES=1

Return Value - Yes

LOCAL retNO=2

Return Value - No

LOCAL typALPHANUM=1

Format Type - Alphanumeric

LOCAL typZEROFILL=2

Format Type - Zero-Fill

LOCAL typCHARNUM=3

Format Type - Alphanumeric plus special characters

LOCAL typMASTERNUM=4

Format Type - Alphanumeric plus special characters without dash

LOCAL typALPHANUMNF=5

Format Type - Alphanumeric plus subset of special characters allowed in file names

LOCAL typMASTERNUMC=6

Format Type -

LOCAL typALPHA$="AaBbCcDdEeFfGgHhIiJjKkLlMmNnOoPpQqRrSsTtUuVvWwXxYyZz"+" "

Format type allow characters - Alpha (includes accented characters)

LOCAL typNUMBERS$=" 0123456789"

Format type allow characters - Numeric plus space

LOCAL typALPHANUM$=typALPHA$+typNUMBERS$

Format type allow characters - Alphanumeric

LOCAL typALPHANUMNF$=typALPHANUM$+"!#$%&'()+, -.;=@[]^_`{}~"

Format type allow characters - Alphanumeric plus subset of special characters allowed in file names

LOCAL typCHARNUM$=typALPHANUM$+"!""#$%&'()*+, -./:;<=>?@[\]^_`{|}~"

Format type allow characters - Alphanumeric plus special characters

LOCAL typMASTERNUM$=SUB(typCHARNUM$, "-", $$)

Format type allow characters - Alphanumeric plus special characters without dash

LOCAL typMASTERNUMCLEN=7
PROPERTY LastErrorMsg$

Store text for the last error message for class

PROPERTY LastErrorNum$

Store message code or error number for the last error for class

Methods

FUNCTION LOCAL element$(string$, element)
FUNCTION LOCAL element$(string$, element, separator$)

Get specified element from string containing a list of values

Parameter | Description
string$ | [input, string] String containing list of values
element | [input, number] Number of element in list to retrieve
separator$ | [input, string] (Optional) Character used as separator for values in list (default is SEP)
Returns Value at position or empty string if fewer values in list
FUNCTION LOCAL isALPHA(val$)

Verify value contains only alpha characters

Parameter | Description
val$ | [input, string] String to verify
Returns TRUE if value is alpha, otherwise FALSE
FUNCTION LOCAL isALPHA(val$, extraChars$)

Verify value contains only alpha characters plus the list of extra characters

Parameter | Description
val$ | [input, string] String to verify
extraChars$ | [input, string] Extra characters to allow
Returns TRUE if value is alpha, otherwise FALSE
FUNCTION LOCAL isDATE(val$)

Verify value is a date

Parameter | Description
val$ | [input, string] String to verify
Returns TRUE if value is a date, otherwise FALSE
FUNCTION LOCAL isNUMERIC(val$)

Verify value is numeric

Parameter | Description
val$ | [input, string] String to verify
Returns TRUE if value is numeric, otherwise FALSE
FUNCTION LOCAL ParseString(sourceString$, result$)
FUNCTION LOCAL ParseString(sourceString$, result$, separator$)

Get next value from sourceString$

Parameter | Description
sourceString$ | [in/out, string] String containing list of values to parse
result$ | [out, string] Next value from the list
separator$ | [input, string] (Optional) Character used as separator for values in list (default is SEP)
Returns retSUCCESS(1) if value found, or retFAILURE (0) when no values remain in list
FUNCTION LOCAL ParseString(scanPos, sourceString$, result$)
FUNCTION LOCAL ParseString(scanPos, sourceString$, result$, separator$)

Get next value starting at specified position of sourceString$

Parameter | Description
scanPos | [in/out, number] Postion in sourceString to begin scan
sourceString$ | [in/out, string] String containing list of values to parse
result$ | [out, string] Next value from the list
separator$ | [input, string] (Optional) Character used as separator for values in list (default is SEP)
Returns retSUCCESS(1) if value found, or retFAILURE (0) when no values remain in list
FUNCTION LOCAL Position(string$, var$)
FUNCTION LOCAL Position(string$, var$, separator$)

Get position of specified element in string containing a list of values

Parameter | Description
string$ | [input, string] String containing list of values
var$ | [input, string] Value to locate in the list
separator$ | [input, string] (Optional) Character used as separator for values in list (default is SEP)
Returns Position of value in the list or zero value is not in list
FUNCTION LOCAL QUO$(val$)

Quote the value

Parameter | Description
val$ | [input, string] String to quote
Returns the new quoted string value
Footer logo


ecCreateDataInfo

Class ecCreateDataInfo

This contributed tool will generate the Outline View and Embedded Dictionary View information for the selected (in the Navigation View) ProvideX data files. This is an alternate method for creating this information in the case where the Builder Preference 'Build Data Files' has been disabled.

Inherits

AbstractActionListener

Properties

LOCAL theDescription$="Create ProvideX Data File Information"

Methods

FUNCTION actionPerformed(inActionEventID)

This method will be called when the action is triggered from the contributed tools menu.

Parameter | Description
inActionEventID | This is a reference to [Java Class:eventmanager/ExtCommand]

Properties inherited from: AbstractActionListener

theDescription$, theNotificationFlag, theToolShortname$

Methods inherited from: AbstractActionListener

actionPerformed(), configPerformed(), getDescription$(), getEventNotificationFlag(), getToolShortname$(), hasConfigAction(), init()

Footer logo


ecDictListener

Class ecDictListener

Listener class for Dictionary Viewer contributed tool.

Inherits

AbstractActionListener, EventManagerObserver

Properties

LOCAL cTitle$="Dictionary Viewer"
LOCAL cUI$="ecDictUI"

Methods

FUNCTION ActionPerformed(inActionEventID)

This method will be called when the 'Run' action is triggered from the contributed tools menu.

Parameter | Description
inActionEventID | This is a reference to [Java Class:eventmanager/ExtCommand]
FUNCTION GetDescription$()

This method is used to describe the purpose of this observer. The text will be placed on the observers preference page to describe the purpose of this observer. This description should be limited to no more than 80 characters.

FUNCTION Init()

Register this class as an event listener and add it to the list of contributed tools under the ProvideX menu item.

Properties inherited from: AbstractActionListener

theDescription$, theNotificationFlag, theToolShortname$

Properties inherited from: EventManagerObserver

theDescription$, theNotificationFlag, theToolShortname$, mustRefreshResource

Methods inherited from: AbstractActionListener

actionPerformed(), configPerformed(), getDescription$(), getEventNotificationFlag(), getToolShortname$(), hasConfigAction(), init()

Methods inherited from: EventManagerObserver

getDescription$(), getEventNotificationFlag(), getToolShortname$(), init(), initState(), update(), setCurrentSource(), updateSourceFile()

Footer logo


ecDictUI

Class ecDictUI

Dictionary Viewer user interface class

Inherits

ecCommonUI

Properties

LOCAL SCREEN_LIB$="ecPvxTools.en"
LOCAL SCREEN_ID$="dDictMain"

Methods

No Methods

Methods inherited from: ecCommonUI

DropBoxAdd(), MessageBox$(), NomadsProcess(), ProgressBarClose(), ProgressBarInit(), ProgressBarUpdate()

Footer logo


ecMsgLibListener

Class ecMsgLibListener

Listener class for Message Viewer contributed tool.

Inherits

AbstractActionListener, EventManagerObserver

Properties

LOCAL cTitle$="Message Library Viewer"
LOCAL cUI$="ecMsgLibUI"

Methods

FUNCTION ActionPerformed(inActionEventID)

This method will be called when the 'Run' action is triggered from the contributed tools menu.

Parameter | Description
inActionEventID | This is a reference to [Java Class:eventmanager/ExtCommand]
FUNCTION GetDescription$()

This method is used to describe the purpose of this observer. The text will be placed on the observers preference page to describe the purpose of this observer. This description should be limited to no more than 80 characters.

FUNCTION Init()

Register this class as an event listener and add it to the list of contributed tools under the ProvideX menu item.

Properties inherited from: AbstractActionListener

theDescription$, theNotificationFlag, theToolShortname$

Properties inherited from: EventManagerObserver

theDescription$, theNotificationFlag, theToolShortname$, mustRefreshResource

Methods inherited from: AbstractActionListener

actionPerformed(), configPerformed(), getDescription$(), getEventNotificationFlag(), getToolShortname$(), hasConfigAction(), init()

Methods inherited from: EventManagerObserver

getDescription$(), getEventNotificationFlag(), getToolShortname$(), init(), initState(), update(), setCurrentSource(), updateSourceFile()

Footer logo


ecMsgLibUI

Class ecMsgLibUI

Inherits

ecCommonUI

Properties

No Properties

Methods

No Methods

Methods inherited from: ecCommonUI

DropBoxAdd(), MessageBox$(), NomadsProcess(), ProgressBarClose(), ProgressBarInit(), ProgressBarUpdate()

Footer logo


ecSearchListener

Class ecSearchListener

Listener class for Super Search contributed tool.

Inherits

AbstractActionListener, EventManagerObserver

Properties

LOCAL cTitle$="Super Search"
LOCAL cUI$="ecSearchUI"

Methods

FUNCTION ActionPerformed(inActionEventID)

This method will be called when the 'Run' action is triggered from the contributed tools menu.

Parameter | Description
inActionEventID | This is a reference to [Java Class:eventmanager/ExtCommand]
FUNCTION GetDescription$()

This method is used to describe the purpose of this observer. The text will be placed on the observers preference page to describe the purpose of this observer. This description should be limited to no more than 80 characters.

FUNCTION Init()

Register this class as an event listener and add it to the list of contributed tools under the ProvideX menu item.

Properties inherited from: AbstractActionListener

theDescription$, theNotificationFlag, theToolShortname$

Properties inherited from: EventManagerObserver

theDescription$, theNotificationFlag, theToolShortname$, mustRefreshResource

Methods inherited from: AbstractActionListener

actionPerformed(), configPerformed(), getDescription$(), getEventNotificationFlag(), getToolShortname$(), hasConfigAction(), init()

Methods inherited from: EventManagerObserver

getDescription$(), getEventNotificationFlag(), getToolShortname$(), init(), initState(), update(), setCurrentSource(), updateSourceFile()

Footer logo


ecSearchLogViewUI

Class ecSearchLogViewUI

This class performs a search of resources in the workspace based on the parameters entered on the Super Search panel. Once the search has been initiated, the Supoer Search panel will be closed.

Inherits

com.pvx.util.progress, ecCommonUI

Properties

LOCAL EOL$=$0D0A$
LOCAL cRbSearch1$="Current &Project"
LOCAL cRbSearch2$
LOCAL cRbSearch3$="&Navigator Selections"
LOCAL cRbSearch4$="Working Se&t"
LOCAL cRbSearch5$="Entire &Workspace"
LOCAL cRbSearch6$="Previous Results - Complete Pro&grams"
LOCAL cRbSearch7$="Previous Results - Indi&vidual Lines"

Methods

No Methods

Properties inherited from: com.pvx.util.progress

_version$, theCaption$,theDescription$, screen_id$, screen_lib$

Methods inherited from: com.pvx.util.progress

checkCancel(), createLogFile(), disable_cancel(), enable_cancel(), enable_special(), writeLog(), writeLogFile(), b_close(), b_special(), disable_special(), doWork(), onExit(), PostLoad(), PreLoad(), setDescription(), updateView(), workDone()

Methods inherited from: ecCommonUI

DropBoxAdd(), MessageBox$(), NomadsProcess(), ProgressBarClose(), ProgressBarInit(), ProgressBarUpdate()

Footer logo


ecSearchUI

Class ecSearchUI

Inherits

ecCommonUI

Properties

LOCAL cRbSearch1$="Current &Project"
LOCAL cRbSearch2$
LOCAL cRbSearch3$="&Navigator Selections"
LOCAL cRbSearch4$="Working Se&t"
LOCAL cRbSearch5$="Entire &Workspace"
LOCAL cRbSearch6$="Complete Pro&grams"
LOCAL cRbSearch7$="Indi&vidual Lines"
LOCAL prnOPEN$=" ("
LOCAL prnCLOSE$=") "
LOCAL defaultMASKS$="*.pvc"+SEP+"*Bus.pvc"+SEP+"*UI.pvc"+SEP+"*Upd.pvc"+SEP+"*Rpt.pvc"+SEP+"*Svc.pvc"+SEP
LOCAL wordDELIMS$=" ~!@#$%^&*()_+`-={}[]|\:"";'<>, .?/"

Methods

No Methods

Methods inherited from: ecCommonUI

DropBoxAdd(), MessageBox$(), NomadsProcess(), ProgressBarClose(), ProgressBarInit(), ProgressBarUpdate()

Footer logo


PvxdocObserver

Class PvxdocObserver

This is an observer class that implements an external action to generate the PvxDocs for a selected folder or resource. The 'actionPerformed()' method will be initiated when the user selects this action.

Inherits

AbstractActionListener, EventManagerObserver

Properties

LOCAL theDescription$="Generate Class Documentation (PVX-DOCS)"
LOCAL theNotificationFlag=_pvxConstants'_ideNone

Methods

FUNCTION actionPerformed(inActionEventID)

This method will be called when the 'Run' action is triggered from the contributed tools menu.

Parameter | Description
inActionEventID | This is a reference to [Java Class:eventmanager/ExtCommand]
FUNCTION configPerformed(inActionEventID)

This method will be called when the 'Configure' action is triggered from the contributed tools menu.

Parameter | Description
inActionEventID | This is a reference to [Java Class:eventmanager/ExtCommand]
FUNCTION hasConfigAction()

This method is used to check whether a configuration action has been implemented.

Returns True (1) if a configuration action has been implemented
FUNCTION init()

Initialize an observer.

FUNCTION update(initPvxState)

The logic to be executed when the observer is triggered.

Parameter | Description
state | A reference to an object of class PvxState

Properties inherited from: AbstractActionListener

theDescription$, theNotificationFlag, theToolShortname$

Properties inherited from: EventManagerObserver

theDescription$, theNotificationFlag, theToolShortname$, mustRefreshResource

Methods inherited from: AbstractActionListener

actionPerformed(), configPerformed(), getDescription$(), getEventNotificationFlag(), getToolShortname$(), hasConfigAction(), init()

Methods inherited from: EventManagerObserver

getDescription$(), getEventNotificationFlag(), getToolShortname$(), init(), initState(), update(), setCurrentSource(), updateSourceFile()

Footer logo


set_copyright_year

Class set_copyright_year

This observer will change the value for copyright year prior to creating a new build of an application.

This program searches for '%(copyright-year)%' within the first 100 characters of the source file and will replace it with the current year. It will then create a temporary file to be used as an alternative source file which will be deleted during the PostProcess of the build by this same observer.

Inherits

EventManagerObserver

Properties

LOCAL theDescription$="Substitute modification year of source file for 'Copyright-year' tag"
LOCAL theNotificationFlag=_pvxConstants'_idePrePostProcess
LOCAL theToolShortname$="Set Copyright Year"

Methods

FUNCTION update(initPvxState)

The logic to be executed when the observer is triggered.

Parameter | Description
initPvxState | A reference to an object of class PvxState

Properties inherited from: EventManagerObserver

theDescription$, theNotificationFlag, theToolShortname$, mustRefreshResource

Methods inherited from: EventManagerObserver

getDescription$(), getEventNotificationFlag(), getToolShortname$(), init(), initState(), update(), setCurrentSource(), updateSourceFile()

Footer logo


set_mod_timestamp

Class set_mod_timestamp

This observer will set the modification timestamp of the output file to be the same as the source file.

This program uses the Eclipse IResource class to get and set the timestamps.

Inherits

EventManagerObserver

Properties

LOCAL theDescription$="Set modification timestamp of output file to be the same as source file"
LOCAL theNotificationFlag=_pvxConstants'_idePostProcess

Methods

FUNCTION update(initPvxState)

The logic to be executed when the observer is triggered.

Parameter | Description
state | A reference to an object of class PvxState

Properties inherited from: EventManagerObserver

theDescription$, theNotificationFlag, theToolShortname$, mustRefreshResource

Methods inherited from: EventManagerObserver

getDescription$(), getEventNotificationFlag(), getToolShortname$(), init(), initState(), update(), setCurrentSource(), updateSourceFile()

Footer logo


ShutdownEventManager

Class ShutdownEventManager

Inherits

AbstractActionListener, EventManagerObserver

Properties

LOCAL theDescription$="Shutdown ProvideX EventManager"
LOCAL theNotificationFlag=_pvxConstants'_ideNone

Methods

FUNCTION actionPerformed(inActionEventID)

This method will be called when the 'Run' action is triggered from the contributed tools menu

Parameter | Description
inActionEventID | This is a reference to [Java Class:eventmanager/ExtCommand]
FUNCTION init()

Register this event listener and add it to the list of contributed tools

Properties inherited from: AbstractActionListener

theDescription$, theNotificationFlag, theToolShortname$

Properties inherited from: EventManagerObserver

theDescription$, theNotificationFlag, theToolShortname$, mustRefreshResource

Methods inherited from: AbstractActionListener

actionPerformed(), configPerformed(), getDescription$(), getEventNotificationFlag(), getToolShortname$(), hasConfigAction(), init()

Methods inherited from: EventManagerObserver

getDescription$(), getEventNotificationFlag(), getToolShortname$(), init(), initState(), update(), setCurrentSource(), updateSourceFile()

Footer logo


simpleStyleCheck

Class simpleStyleCheck

This class is required on each client workstation to enable the StyleCheck capability that is included in the ProvideX plug-in in the class ecStyleCheck.

This class does not extend any of the standard functionality - it is used to define/load a group of style rules as the contributed tool 'simpleStyleCheck'.

Info

The 'masStyleCheck' class (included with the Sage 100 ERP Plug-in) is the same as this class except it is used to define/load a group of style rules as the contributed tool 'masStyleCheck'.

Inherits

ecStyleCheck

Properties

LOCAL styleRulesFile$

the value mid(pgn, 1, pos(dlm=pgn, -1)) + _obj'_Class$ + "_rules.txt" is used to derive the name of the rule file from the name of the style check class

LOCAL theDescription$="Simple rule-based Style Check"

Override Description

Methods

No Methods

Properties inherited from: ecStyleCheck

theDescription$, styleCheckName$, theNotificationFlag, lbSepChar$, _version$

Methods inherited from: ecStyleCheck

actionPerformed(), configPerformed(), getStyleCheckName$(), hasConfigAction(), init(), update(), loadRules(), writeRuleFile()

Footer logo


stripTrailing

Class stripTrailing

Properties

No Properties

Methods

FUNCTION processFile(theSrcFile$, altSrcFile$)

Scan source file and strip trailing white space from each source line

Parameter | Description
theSrcFile | The source file to be processed
altSrcFile | Alternate source file with the modified/updated content
Returns A simple boolean (0=False, 1=True) to indicate if any modifications were made
Footer logo


stripTrailing_build

Class stripTrailing_build

This class is used to strip trailing spaces (whitespace) from source files during the build process..

Inherits

EventManagerObserver

Properties

LOCAL theNotificationFlag=_pvxConstants'_idePrePostProcess

Register the events for this observer

LOCAL toolDescription$="Strip Trailing Whitespace"

Methods

FUNCTION getDescription$()

Get a description for this listener that will be used if this class doubles as an observer. This will be determined by the EventNotificationFlag.

Returns A string containing the description of this listener
FUNCTION update(state)

The logic to be executed when the observer is triggered during the normal event process in the ProvideX event manager. This logic will check the major and minor codes to determine the current event and then decide what action is to be performed.

Parameter | Description
state | A reference to an object of class PvxState

Properties inherited from: EventManagerObserver

theDescription$, theNotificationFlag, theToolShortname$, mustRefreshResource

Methods inherited from: EventManagerObserver

getDescription$(), getEventNotificationFlag(), getToolShortname$(), init(), initState(), update(), setCurrentSource(), updateSourceFile()

Footer logo


stripTrailing_Listener

Class stripTrailing_Listener

Inherits

AbstractActionListener

Properties

LOCAL theDescription$="Strip trailing white space"
LOCAL cTitle$="Strip Trailing White Space"
LOCAL cUI$="stripTrailing_UI"

Methods

FUNCTION actionPerformed(inActionEventID)

This method will be called when the action is triggered from the contributed tools menu.

Parameter | Description
inActionEventID | This is a reference to [Java Class:eventmanager/ExtCommand]

Properties inherited from: AbstractActionListener

theDescription$, theNotificationFlag, theToolShortname$

Methods inherited from: AbstractActionListener

actionPerformed(), configPerformed(), getDescription$(), getEventNotificationFlag(), getToolShortname$(), hasConfigAction(), init()

Footer logo


stripTrailing_UI

Class stripTrailing_UI

This observer will scan the source files selected in the Navigator view and remove all trailing white space from each source line.

Inherits

com.pvx.util.progress

Properties

LOCAL theCaption$="Strip Trailing Whitespace"

Set the caption for the user interface window

LOCAL theDescription$="Strip trailing white space"

Override Description

LOCAL theNotificationFlag=_pvxConstants'_idePrePostProcess

Override NotificationFlag

Methods

No Methods

Properties inherited from: com.pvx.util.progress

_version$, theCaption$,theDescription$, screen_id$, screen_lib$

Methods inherited from: com.pvx.util.progress

checkCancel(), createLogFile(), disable_cancel(), enable_cancel(), enable_special(), writeLog(), writeLogFile(), b_close(), b_special(), disable_special(), doWork(), onExit(), PostLoad(), PreLoad(), setDescription(), updateView(), workDone()

Footer logo


toolsListener

Class toolsListener

Inherits

AbstractActionListener, EventManagerObserver

Properties

LOCAL cTitle$="Tools - Encrypt Password"
LOCAL cUI$="com.pvx.util.toolsUI"
LOCAL theNotificationFlag=_pvxConstants'_ideNone

Methods

FUNCTION ActionPerformed(inActionEventID)

This method will be called when the 'Run' action is triggered from the contributed tools menu.

Parameter | Description
inActionEventID | This is a reference to [Java Class:eventmanager/ExtCommand]
FUNCTION GetDescription$()

This method is used to describe the purpose of this observer. The text will be placed on the observers preference page to describe the purpose of this observer. This description should be limited to no more than 80 characters.

FUNCTION Init()

Register this class as an event listener and add it to the list of contributed tools under the ProvideX menu item.

Properties inherited from: AbstractActionListener

theDescription$, theNotificationFlag, theToolShortname$

Properties inherited from: EventManagerObserver

theDescription$, theNotificationFlag, theToolShortname$, mustRefreshResource

Methods inherited from: AbstractActionListener

actionPerformed(), configPerformed(), getDescription$(), getEventNotificationFlag(), getToolShortname$(), hasConfigAction(), init()

Methods inherited from: EventManagerObserver

getDescription$(), getEventNotificationFlag(), getToolShortname$(), init(), initState(), update(), setCurrentSource(), updateSourceFile()

Footer logo


util_keyword_build

Class util_keyword_build

This class is used to scan the selected source file and replace the ProvideX keywords (directives, functions, system variables, and mnemonics). This class is a contributed tool used during the build process.

Inherits

EventManagerObserver

Properties

LOCAL theNotificationFlag=_pvxConstants'_idePrePostProcess

Register the events for this observer

Methods

FUNCTION getDescription$()

Get a description for this listener that will be used if this class doubles as an observer. This will be determined by the EventNotificationFlag.

Returns A string containing the description of this listener
FUNCTION update(state)

The logic to be executed when the observer is triggered during the normal event process in the ProvideX event manager. This logic will check the major and minor codes to determine the current event and then decide what action is to be performed.

Parameter | Description
state | A reference to an object of class PvxState

Properties inherited from: EventManagerObserver

theDescription$, theNotificationFlag, theToolShortname$, mustRefreshResource

Methods inherited from: EventManagerObserver

getDescription$(), getEventNotificationFlag(), getToolShortname$(), init(), initState(), update(), setCurrentSource(), updateSourceFile()

Footer logo


util_keyword_chg

Class util_keyword_chg

This class is used to scan the selected source file and replace the ProvideX keywords (directives, functions, system variables, and mnemonics).

Inherits

AbstractActionListener, EventManagerObserver

Properties

No Properties

Methods

FUNCTION actionPerformed(inActionEventID)

This method will be called when the action is triggered from the contributed tools menu.

Parameter | Description
inActionEventID | This is a reference to [Java Class:eventmanager/ExtCommand]
FUNCTION getDescription$()

Get a description for this listener that will be used if this class doubles as an observer. This will be determined by the EventNotificationFlag.

Returns A string containing the description of this listener
FUNCTION init()

Register this class as an event listener and add it to the list of contributed tools under the ProvideX menu item.

Properties inherited from: AbstractActionListener

theDescription$, theNotificationFlag, theToolShortname$

Properties inherited from: EventManagerObserver

theDescription$, theNotificationFlag, theToolShortname$, mustRefreshResource

Methods inherited from: AbstractActionListener

actionPerformed(), configPerformed(), getDescription$(), getEventNotificationFlag(), getToolShortname$(), hasConfigAction(), init()

Methods inherited from: EventManagerObserver

getDescription$(), getEventNotificationFlag(), getToolShortname$(), init(), initState(), update(), setCurrentSource(), updateSourceFile()

Footer logo


XMItoPvxAction

Class XMItoPvxAction

This is an example of a listener for an external action.

Build Information

Forcelinenumbers false

Inherits

AbstractActionListener, EventManagerObserver

Properties

No Properties

Methods

FUNCTION actionPerformed(inActionEventID)

This method will be called when the action is triggered from the contributed tools menu.

Parameter | Description
inActionEventID | This is a reference to [Java Class:eventmanager/ExtCommand]
FUNCTION getDescription$()

This method is used to describe the purpose of this observer. The text will be placed on the observers preference page to describe and should be limited to 80 characters (at most).

FUNCTION getEventNotificationFlag()

Get the flag that will be used to trigger the 'update()' method during execution of the built-in events for the plug-in.

If this observer is not a Post-process observer, the return value of this method should be set to one of the following values:

Value | Description
_pvxConstants'_ideNone | Do not register as an observer
_pvxConstants'_idePreProcess | Register as a Pre-Process observer
_pvxConstants'_idePrePostProcess | Register as both a Pre-Process and Post-Process observer.
_pvxConstants'_idePostProcess | Register as a Post-Process observer
FUNCTION init()

Register this class as an event listener and add it to the list of contributed tools under the ProvideX menu.

FUNCTION update(initPvxState)

The logic to be executed when the observer is triggered. This logic must check the major and minor codes to determine the current event and then decide what action is to be performed.

Parameter | Description
state | A reference to an object of class PvxState

Properties inherited from: AbstractActionListener

theDescription$, theNotificationFlag, theToolShortname$

Properties inherited from: EventManagerObserver

theDescription$, theNotificationFlag, theToolShortname$, mustRefreshResource

Methods inherited from: AbstractActionListener

actionPerformed(), configPerformed(), getDescription$(), getEventNotificationFlag(), getToolShortname$(), hasConfigAction(), init()

Methods inherited from: EventManagerObserver

getDescription$(), getEventNotificationFlag(), getToolShortname$(), init(), initState(), update(), setCurrentSource(), updateSourceFile()

Footer logo


XML_Convert

Class XML_Convert

This is a Post-Process observer that will convert ProvideX data files to/from XML. It will also be registered as a contributed tool and will be added to that list under the 'ProvideX' item on the menu bar.

Inherits

AbstractActionListener, EventManagerObserver

Properties

LOCAL theDescription$="Convert ProvideX keyed files to/from XML"
LOCAL theNotificationFlag=_pvxConstants'_idePostProcess

Methods

FUNCTION actionPerformed(inActionEventID)

This method will be called when the action is triggered from the contributed tools menu.

Parameter | Description
inActionEventID | This is a reference to [Java Class:eventmanager/ExtCommand]
FUNCTION update(initPvxState)

The logic to be executed when the observer is triggered. This logic must check the major and minor codes to determine the current event and then decide what action is to be performed.

Parameter | Description
initPvxState | A reference to an object of class PvxState

Properties inherited from: AbstractActionListener

theDescription$, theNotificationFlag, theToolShortname$

Properties inherited from: EventManagerObserver

theDescription$, theNotificationFlag, theToolShortname$, mustRefreshResource

Methods inherited from: AbstractActionListener

actionPerformed(), configPerformed(), getDescription$(), getEventNotificationFlag(), getToolShortname$(), hasConfigAction(), init()

Methods inherited from: EventManagerObserver

getDescription$(), getEventNotificationFlag(), getToolShortname$(), init(), initState(), update(), setCurrentSource(), updateSourceFile()

Footer logo


system

Class system

Info

*** Original code courtesy of J. Wilder - Megasys Hospitality Systems, Inc. ***

This class provides access to a number of system functions.

Properties

PROPERTY type$=SYS

OS type

Methods

FUNCTION copyfile(fromname$, toname$)

Issue a OS system call to copy a file.

Parameter | Description
fromname | The name of the file to be copied.
toname$ | The name of the new file to be created as a result of the copy.
FUNCTION makedir(path$)

Create a directory.

Parameter | Description
path$ | The name of the directory to be created.
FUNCTION makedirs(path$)

Create a directory and all parent directories that do not already exist.

Parameter | Description
path$ | The name of the directory to be created.
FUNCTION makeserial(name$)

Create a serial (text) file.

Parameter | Description
name$ | The name of the serial file to be created.
Footer logo


XPSOAPDOC

Class XPSOAPDOC

Info

*** Original code courtesy of J. Wilder - Megasys Hospitality Systems, Inc. ***

This class is to be used for the creation and parsing of SOAP version 1.0 documents. SOAP documents are nothing but XML documents with some predetermined elements for containing a header and body for the message.

Inherits

XPXMLDOC

Properties

PROPERTY SoapEnvelope * Read Only *

A reference to XPXMLTAG object for the 'soap:Envelope' element

PROPERTY SoapHeader * Read Only *

A reference to XPXMLTAG object for the 'soap:Header' element

PROPERTY SoapBody * Read Only *

A reference to XPXMLTAG object for the 'soap:Body' element

Methods

FUNCTION NewDocument()

This function overrides the 'XPXMLDOC' class to predefine the special SOAP tags

FUNCTION NewDocument(Import)

This function overrides the 'XPXMLDOC' class to automatically recognize the special SOAP tags

Properties inherited from: XPXMLDOC

Declaration$, SuppressDeclaration, Version$, Encoding$, Error$, XMLString$

Methods inherited from: XPXMLDOC

LoadEncodedString(), LoadFile(), LoadString(), NewDocument(), UTFDate$(), UTFDateTime$(), LongDateToJul(), ParseXML()

Footer logo


XPURL

Class XPURL

Info

*** Original code courtesy of J. Wilder - Megasys Hospitality Systems, Inc. ***

Properties

LOCAL True
PROPERTY URL$ * Read Only *
PROPERTY Port$

The TCP port number

PROPERTY Hostname$

The server hostname or IP address

PROPERTY Protocol$

Set to predefined protocol; or when processing an existing URL, this property will contain the results

PROPERTY Document$

The document that has been requested

Methods

FUNCTION SetURL(_url$)

Parse the URL and set the properties

Footer logo


XPWSDL

Class XPWSDL

Info

*** Original code courtesy of J. Wilder - Megasys Hospitality Systems, Inc. ***

Properties

LOCAL True
PROPERTY URL$ * Read Only *
PROPERTY ContentType$
PROPERTY WaitTime * Read Only *
PROPERTY Error$ * Read Only *
PROPERTY DebugLog
PROPERTY DebugLevel
PROPERTY soapRequest * Read Only *
PROPERTY soapResponse * Read Only *
PROPERTY soapComm * Read Only *
PROPERTY xmlRequest * Read Only *
PROPERTY xmlResponse * Read Only *
PROPERTY soapAction$ * Read Only *
PROPERTY wsdlRequest$ * Read Only *
PROPERTY NameSpace$ * Read Only *

Methods

FUNCTION ResetDocuments()
FUNCTION Send()
FUNCTION SetSoapAction(_ns$, _action$)
FUNCTION SetURL(_url$)
Footer logo


XPXMLATR

Class XPXMLATR

Info

*** Original code courtesy of J. Wilder - Megasys Hospitality Systems, Inc. ***

This is a sub-object of the XPXMLTAG object. It is used to hold information about a single tag element's attributes.

Properties

LOCAL True
PROPERTY Name$ * Read Only *

The attribute name

PROPERTY Text$ * Read Only *

The attribute text vaue

Methods

FUNCTION Parse$(_attributes$)

Parses through the string to pull out the attributes for an element

Parameter | Description
_attributes$ | The string that contains the attributes for an element
Returns The modified string value with the attribute information removed
FUNCTION SetName(_Name$)

Set the name of this attribute

FUNCTION SetText(_Text$)

Set the text of this attribute

Footer logo


XPXMLCOM

Class XPXMLCOM

Info

*** Original code courtesy of J. Wilder - Megasys Hospitality Systems, Inc. ***

This class provides a simple method for sending and receiving XML documents to a web server using the HTTP 1.0 protocol.

Properties

LOCAL crlf$=$0D0A$
LOCAL True
PROPERTY Hostname$

The destination hostname or IP address for this message

PROPERTY WebPage$

The web page to be accessed

PROPERTY Port$

The TCP port to be used

PROPERTY URL$ * Read Only *

The URL that will be accessed

PROPERTY ContentType$

The default is 'application/x-wwwform-urlencoded'

PROPERTY MessagePrefix$

An optional prefix string to be added to the transmit data XML document

PROPERTY MessageSuffix$

An optional suffix to be added to the transmit data XML document

PROPERTY WaitTime

The timeout (in seconds) for reply from the web server

PROPERTY Header$ * Read Only *

The formatted HTTP header data for sending the message

PROPERTY Data$ * Read Only *

The formatted HTTP data string for sending the message

PROPERTY ReplyHeader$ * Read Only *

The formatted HTTP header data of the received message

PROPERTY ReplyData$ * Read Only *

The formatted HTTP data string of the received message

PROPERTY Error$ * Read Only *

Error message (if any)

PROPERTY DebugLog

Set this to a file channel for a text file where the detailed communications log will be written

PROPERTY DebugLevel

Set this the level of detail (0-9) for the communications log

Methods

FUNCTION AddParameter(Parameter$, Value$)
FUNCTION ClosePort()
FUNCTION FormatPost(TransDoc)
FUNCTION OpenPort()
FUNCTION Receive(RecvDoc)
FUNCTION ResetParameters()
FUNCTION SendReceive(xmldoc)
FUNCTION SendReceive(TransDoc, RecvDoc)
FUNCTION SetURL(_url$)
FUNCTION Transmit(TransDoc)
Footer logo


XPXMLDOC

Class XPXMLDOC

Info

*** Original code courtesy of J. Wilder - Megasys Hospitality Systems, Inc. ***

This object is capable of creating new XML documents as well as parsing existing documents

for data elements. When creating a new XML document, you simply add the elements and the take the XMLString$ output as a formatted XML document

Unlike HTML, XML has no predefined elements and attributes. As the document author you are responsible for creating a meaningful document.

Programmer's Notes:

  • XML is case sensitive. That means that <Account> and <account> are references to different elements.
  • When presented, all attributes must be in quotes and all elements must have a starting and ending tag or explicitly indicate that they are empty elements.
  • XML elements must be properly nested
  • XML documents must have a single root element
  • XML Attribute Values Must be Quoted
  • Unlike HTML, white space is preserved. So no spaces would be removed from the string "Hello world."
  • CR / LF is Converted to LF. In XML, a new line is always stored as LF

Some helpful web sites:

  • http://msdn.microsoft.com/xml
  • http://www.xml.com
  • http://www.w3schools.com/xml/xml_syntax.asp

Understanding XML:

  • http://msdn.microsoft.com/xml/default.aspx?pull=/library/en-us/dnxml/html/understxml.asp
  • http://www.w3.org/2000/03/29-XML-protocol-matrix

Inherits

XPXMLTAG

Known SubClasses

XPSOAPDOC

Properties

PROPERTY Declaration$ * Read Only *

Defines the XML version and character encoding used in the document. It is the first line of the document.

PROPERTY SuppressDeclaration

Set to "True" to suppress the generation of the XML declaration at the beginning of the document. This is typically done when the document will be combined or embedded into another XML document.

PROPERTY Version$ * Read Only *

Version number from the XML Header

PROPERTY Encoding$ * Read Only *

Encoding from the XML Header

PROPERTY Error$ * Read Only *

If an error occurs while importing a file or string, this property will contain the description of the error.

PROPERTY XMLString$ * Read Only *

Use this property to pull the XML document back out of the object as a single string.

Methods

FUNCTION LoadEncodedString(_XMLString$)

Parse the XMLString$ variable as a complete XML document that has been encoded using the HTML escape sequences for <, >, ", and &. This is typically done when the XMLString$ is part of a payload for a SOAP element

Parameter | Description
_XMLString$ | The variable that contains the XML document to be parsed
Returns Will return True if parse is successful
FUNCTION LoadFile(_XMLDoc$)

Parse the XMLDoc$ file.

Parameter | Description
_XMLDoc$ | The name of a file to be parsed
Returns Will return True if parse is successful
FUNCTION LoadString(_XMLString$)

Parse the XMLString$ variable as a complete XML document.

Parameter | Description
_XMLString$ | The variable that contains the XML document to be parsed
Returns Will return True if parse is successful
FUNCTION NewDocument()

This method will initialize the object for creation of a new document.

FUNCTION NewDocument(Import)

This method will initialize the object for creation of a new document.

Parameter | Description
Import | Set to boolean true (1) to suppress automatic generation of common tags and comments. This is typically used only by internal object functions when importing an XML or SOAP document.
FUNCTION UTFDate$(JulianDate)

This function returns the specified date in the Universal Time Format: YYYY-MM-DD

Parameter | Description
JulianDate | The input date as a Julian numeric date. You may also send 0 (zero) to obtain the current system date.
Returns the specified date in the Universal Time Format: YYYY-MM-DD
FUNCTION UTFDate$(LongDate$)

This function returns the specified date in the Universal Time Format: YYYY-MM-DD

Parameter | Description
JulianDate | The input date as a as a standard long date format (YYYYMMDD). You may also send 0 (zero) to obtain the current system date.
Returns the specified date in the Universal Time Format: YYYY-MM-DD
FUNCTION UTFDateTime$(JulianDate)

This method returns the specified date and time in the Universal Time Format (UTF)

Parameter | Description
JulianDate | The date to be converted
Returns the specified date and time in the Universal Time Format (UTF): YYYY-MM-DDThh:mm:ss
FUNCTION UTFDateTime$(JulianDate, Time)

This method returns the specified date and time in the Universal Time Format (UTF)

Parameter | Description
JulianDate | The date to be converted
Time | The fractional time value to be used in the conversion
Returns the specified date and time in the Universal Time Format (UTF): YYYY-MM-DDThh:mm:ss
FUNCTION UTFDateTime$(LongDate$)

This method returns the specified date and time in the Universal Time Format (UTF)

Parameter | Description
LongDate$ | The date to be converted
Returns the specified date and time in the Universal Time Format (UTF): YYYY-MM-DDThh:mm:ss
FUNCTION UTFDateTime$(LongDate$, Time)

This method returns the specified date and time in the Universal Time Format (UTF)

Parameter | Description
LongDate$ | The date to be converted
Time | The fractional time value to be used in the conversion
Returns the specified date and time in the Universal Time Format (UTF): YYYY-MM-DDThh:mm:ss
FUNCTION LOCAL LongDateToJul(LongDate$)
FUNCTION LOCAL ParseXML(xml$)

Properties inherited from: XPXMLTAG

True, Name$, Text$, DecodedText$, Attributes, AttributeCount, Elements, ElementCount, CurrentElement, CurrentElementName$, LineSep$, XMLString$

Methods inherited from: XPXMLTAG

CreateAttribute(), CreateElement(), FindAttribute(), FindAttributeText$(), FindElement(), FindElementText$(), FindNextElement(), FindNextElementName$(), FindNextElementText$(), Parse$(), SetName(), SetText(), DecodeText$(), EncodeText$(), Init(), ReadAttributes()

Footer logo


XPXMLTAG

Class XPXMLTAG

Info

*** Original code courtesy of J. Wilder - Megasys Hospitality Systems, Inc. ***

This is a sub-object of the XPXMLDOC object. It is used to hold information about a single tag element and it's children and attributes.

Known SubClasses

XPXMLDOC

Properties

LOCAL True
PROPERTY Name$ * Read Only *

The tag name

PROPERTY Text$ * Read Only *

Optional text value associated with this tag

PROPERTY DecodedText$ * Read Only *

A decoded version of the 'Text$' property

PROPERTY Attributes * Read Only *

A reference to a [ProvideX Library Class:*obj/group] for the atrtibutes of this tag

PROPERTY AttributeCount * Read Only *

The number of attributes for this tag

PROPERTY Elements * Read Only *

A reference to a [ProvideX Library Class:*obj/group] for the child elements of this tag

PROPERTY ElementCount * Read Only *

The number of child elements

PROPERTY CurrentElement * Read Only *
PROPERTY CurrentElementName$ * Read Only *
PROPERTY LineSep$

The line separator character to be used when building the 'XMLString$' property. (Default is $0D0A$ - Carriage return / line feed)

PROPERTY XMLString$ * Read Only *

Use this property to pull the XML coding of this element and its children as a single string.

Methods

FUNCTION CreateAttribute(_Name$)

Create an attribute

Parameter | Description
_Name$ | The name of the attribute to be created
Returns the a reference to the [ProvideX Library Class:*obj/group] object that is created or ZERO if creation fails
FUNCTION CreateAttribute(_Name$, _Text$)

Create an attribute

Parameter | Description
_Name$ | The name of the attribute to be created
_Text$ | The text value to be set for the attribute
Returns the a reference to the [ProvideX Library Class:*obj/group] object that is created or ZERO if creation fails
FUNCTION CreateElement(_Name$)

Create a child element

Parameter | Description
_Name$ | The name of the element to be created
Returns the a reference to the [ProvideX Library Class:*obj/group] object that is created or ZERO if creation fails
FUNCTION CreateElement(_Name$, _Text$)

Create a child element

Parameter | Description
_Name$ | The name of the element to be created
_Text$ | The text value to be set for the element
Returns the a reference to the [ProvideX Library Class:*obj/group] object that is created or ZERO if creation fails
FUNCTION FindAttribute(_Name$)

Search for the first occurance of a specific attribute by name

Parameter | Description
_Name$ | The name of the attribute to find
Returns the a reference to the [ProvideX Library Class:*obj/group] object for the attribute or ZERO if not found
FUNCTION FindAttributeText$(_Name$)

Search for the first occurance of a specific attribute by name

Parameter | Description
_Name$ | The name of the attribute to find
Returns the Text$ value for the attribute found
FUNCTION FindElement(_Name$)

Search for the first occurance of a specific element by name

Parameter | Description
_Name$ | The name of the element to find
Returns the a reference to the [ProvideX Library Class:*obj/group] object for the element or ZERO if not found
FUNCTION FindElementText$(_Name$)

Search for the first occurance of a specific element by name

Parameter | Description
_Name$ | The name of the element to find
Returns the Text$ value for the element found
FUNCTION FindNextElement()
FUNCTION FindNextElement(_Name$)
FUNCTION FindNextElementName$()
FUNCTION FindNextElementText$()
FUNCTION FindNextElementText$(_Name$)
FUNCTION Parse$(_XMLText$)

Breaks the XMLText$ down into its elements and attributes.

Parameter | Description
XMLText$ | The string containing the XML document
FUNCTION SetName(_Name$)

Set the name of this tag

Parameter | Description
_Name$ | The name to be assigned to this tag
FUNCTION SetText(_Text$)

Set the taxt value for this tag

Parameter | Description
_Text$ | The text value to be assigned to this tag
FUNCTION LOCAL DecodeText$(_Text$)
FUNCTION LOCAL EncodeText$(_Text$)
FUNCTION LOCAL Init()
FUNCTION LOCAL ReadAttributes(_Name$)
Footer logo


com.pvx.ide.choosedictUI

Class com.pvx.ide.choosedictUI

Common class to select ProvideX data dictionary to use when there are several in a project

Constructor

Set the list of directories where ProvideX data dictionary files were found.

Parameter | Description
inDirList$ | LIst of directories where Provide dictionary files were found

Inherits

*nomads

Properties

PROPERTY screen_id$="choosedict"

Initial panel to be loaded for the configuration information

PROPERTY screen_lib$="com.pvx.ide.ui.en"

The library for the panel definitions

Methods

FUNCTION getOption(inKeyword$)

This method is used to check the options (ExitStatus).

FUNCTION getValue$(inKeyword$)

This method is used to get the value for the options (DictionaryFolder).

Footer logo


com.pvx.util.progress

Class com.pvx.util.progress

Abstract class to log progress of a contributed tool action; the information will be displayed in a view that will remain open until the user decides to close it.

Info

The sub-class initialization method must set the following variables which will be used to identify the panel. theCaption$, theDescription$ The sub-class initialization method can also enable the 'CANCEL' button on the "Progress Log" panel by calling the method: _obj'enable_cancel() The sub-class must implement a method to perform the task(s) associated with the contributed tool; this method will be executed once the ProcessLog panel has been loaded and initialized. This logic must be implemented in the method: doWork() If the sub-class has enabled the 'CANCEL' button, the tasks performed by the sub-class must check to determine if the user has pressed the 'CANCEL' button and then set a flag that will cause the processing to abort. This logic should be similar to the following example: isCancelled = _obj'checkCancel() The sub-class method can also disable the 'CANCEL' button on the "Progress Log" panel by calling the method: _obj'disable_cancel()

Inherits

ecCommonUI, ecConstant

Known SubClasses

com.pvx.pvxdoc.createDocs, ecSearchLogViewUI, ecStyleCheckRun, stripTrailing_UI

Properties

PROPERTY _version$=CVS(MID(STP("$Revision: 2997 $", 2, "$"), 10), 3)

class version

PROPERTY theCaption$, theDescription$

Set variables used to identify the panel View

PROPERTY screen_id$="PROGRESSLOG"

Set Panel / Library for Progress log

PROPERTY screen_lib$="com.pvx.util.en"

Methods

FUNCTION checkCancel()

Check for user pressing CANCEL button

Returns A simple boolean (0=False, 1=True) to indicate that the cancel button was pressed
FUNCTION createLogFile(aNamePfx$)
FUNCTION createLogFile(aNamePfx$, btnText$)

Create a temporary log file to be updated as the process executes; the log file will be deleted upon exit of task

Parameter | Description
aNamePfx$ | The start of the work file name.
btnText$ | (Optional)The text to use for the label of the 'Special' button when enabled at end of process
Returns A simple boolean (0=False, 1=True) to indicate that the log file was created
FUNCTION disable_cancel()

Method that can be executed by SUB-CLASS to disable the 'Cancel' button

FUNCTION enable_cancel()

Method that is executed as part if initialization in SUB-CLASS to enable the 'Cancel' button

FUNCTION enable_special(sLabel$)

Method to enable the 'Special' button

Parameter | Description
sLabel$ | Label to display on button
FUNCTION writeLog(aString$)
FUNCTION writeLog(aString$, aLogFile$)

Write text to progress log display and log file

Parameter | Description
aString$ | The text to update into the progress log; use SEP character at end of each line for multi-line messages
aLogFile$ | (Optional) The name of an existing log file to write the message
FUNCTION writeLogFile(aString$)
FUNCTION writeLogFile(aString$, aLogFile$)

Write text to log file only

Parameter | Description
aString$ | The text to write to the log file
aLogFile$ | (Optional) The name of an existing log file to write the message; if not included, will use the log file created by _obj'createLogFile() method
FUNCTION LOCAL b_close()

Method that is executed when the 'Close' button is pressed.

FUNCTION LOCAL b_special()

Method that is executed when the 'Special' button is pressed.

FUNCTION LOCAL disable_special()

Method that can be executed by SUB-CLASS to disable the 'Special' button

FUNCTION LOCAL doWork()

This method is called by the PostLoad() method from the com.pvx.util.progress class to perform work for this tool; this tool can use the WriteLog() method to show or update progress as the work is performed

Warning

*** Must be implemented in child class. ***

FUNCTION LOCAL onExit()

Clean-up required for this panel during exit.

FUNCTION LOCAL PostLoad()

NOMADS method that is accessed after the panel has been loaded

FUNCTION LOCAL PreLoad()

NOMADS method that is accessed before the panel is loaded

FUNCTION LOCAL setDescription(aCaption$, aDescription$)

Set description to be displayed for the log

Parameter | Description
aCaption$ | the value to be used for the caption of the view
aDescription | the value to be used to describe the work to be logged
FUNCTION LOCAL updateView()

update information in the view used to display the progress log

FUNCTION LOCAL workDone()

Method that is called to indicate that all work is completed for the task

Properties inherited from: ecConstant

isFALSE, isTRUE, isYES$, isNO$, chkOFF$, chkON$, chkGRAYED$, errOBJECT, msgYES$, msgNO$, msgCANCEL$, msgOK$, msgRETRY$, msgABORT$, msgIGNORE$, msgNOTONFILE$, msgTIMEOUT$, msgDISABLE, msgACTIVE, retFAILURE, retSUCCESS, retNEW, retWARNING, retCANCEL, retYES, retNO, typALPHANUM, typZEROFILL, typCHARNUM, typMASTERNUM, typALPHANUMNF, typMASTERNUMC, typALPHA$, typNUMBERS$, typALPHANUM$, typALPHANUMNF$, typCHARNUM$, typMASTERNUM$, typMASTERNUMCLEN, LastErrorMsg$, LastErrorNum$

Methods inherited from: ecCommonUI

DropBoxAdd(), MessageBox$(), NomadsProcess(), ProgressBarClose(), ProgressBarInit(), ProgressBarUpdate()

Methods inherited from: ecConstant

element$(), isALPHA(), isDATE(), isNUMERIC(), ParseString(), Position(), QUO$()

Footer logo


com.pvx.util.toolsUI

Class com.pvx.util.toolsUI

Inherits

ecCommonUI

Properties

PROPERTY _version$=CVS(MID(STP("$Revision: 2997 $", 2, "$"), 10), 3)

class version

PROPERTY screen_id$="Tool_Encrypt"

Initial panel to be loaded for the configuration information

PROPERTY screen_lib$="com.pvx.util.en"

The library for the panel definitions

Methods

No Methods

Methods inherited from: ecCommonUI

DropBoxAdd(), MessageBox$(), NomadsProcess(), ProgressBarClose(), ProgressBarInit(), ProgressBarUpdate()

Footer logo


ConsoleDebug

Class ConsoleDebug

This class is instantiated during the initialization of the Plug-in event manager and the ID is assigned to the variable '%_ConsoleDebug'. It provides methods to simplify the debugging of new logic within the framework used by the plug-in.

Build Information

Forcelinenumbers false

Constructor

Initialize the object, store the object references passed in, and create a reference to the PvxConstants.

Parameter | Description
initEventManager | A reference to the [Java Class:eventmanager/EventManager] object
initViewManager | A reference to the [Java Class:views/UIManager] object

Properties

PROPERTY _version$=CVS(MID(STP("$Revision: 2901 $", 2, "$"), 10), 3)

Methods

FUNCTION breakpoint()
FUNCTION breakpoint(ClearEvent)

Break into console mode. This method will also hide any active progress monitor ProgressMonitor.

Parameter | Description
ClearEvent | ** Optional ** A simple boolean (0=false, 1=true) to force a clear of any pending events for the Java event manager [Java Class:eventmanager/EventManager].
FUNCTION close_trace()

Close the trace file.

FUNCTION end_trace()

Stop the program trace. The trace file is NOT closed.

FUNCTION open_trace(to_file$)

Create (if necessary) and open a text file to be used to log information while debugging a class or extension.

Parameter | Description
to_file$ | The name of a text file to create/open for logging of trace information.
FUNCTION resume()

Restore the progress monitor if it was active and resume execution of the application.

FUNCTION start_trace()

Start a program trace to the trace file that must have already been openned.

FUNCTION write_trace(inText$)

Write a text message to the trace file.

Parameter | Description
inText$ | A string containing the text to be written to the trace file.
Footer logo


ecKeywordConversion

Class ecKeywordConversion

Properties

LOCAL toolDescription$="Keyword Conversion"
PROPERTY _version$=CVS(MID(STP("$Revision: 3093 $", 2, "$"), 10), 3)

Methods

FUNCTION convertSingleFile(theFile$, altSource$)

Perform keyword conversion on the specified file

Parameter | Description
theFile | The full path to the file to process
altSrcFile | Alternate source file with the modified/updated content
Returns A simple boolean (0=failed, 1=successful)
FUNCTION getLastFailure$()

Retrieve a text description of the last failure that occurred during the keyword conversion process

Returns A string containing a description of the failure
FUNCTION resourceInPvxEditor()

Perform keyword conversion on the resource loaded in the ProvideX editor

Returns A simple boolean (0=failed, 1=successful)
FUNCTION resourcesInNavView()

Perform keyword conversion on the resources selected in the navigation view

Returns A simple boolean (0=failed, 1=successful)
Footer logo


ecStyleCheck

Class ecStyleCheck

This is a special-purpose utility class that can used by developers to enable a style checker to be implemented as part of their development processes. This class does most of the work but is designed to be inherited by a developer-written class to allow developers to decide if this feature is useful and to also allow the developer to override the standard functionality to add hard-coded rules to the style check logic. This allows developers to implement style check logic that cannot be easily defined using the rules file information. A sample developer class has been included in the examples folder.

This utility class is written to be both a "contributed tool" and a "Build Post-Process" listener. When the class is triggered from the "Contributed Tools" menu, it will scan the resource that is selected in the navigation view. When triggered as part of the build process, it will scan the program that is getting processed for the build. In both cases, the source code of the program is checked against a pre-set list of style rules and any discrepancies are reported in the "Problem View".

When accessed as part of the build process, it will only report issues to the problem view. When accessed from the "Contributed Tool" menu, it can also automatically correct some of the issues that are discovered based on the information contained within the style rules.

Inherits

AbstractActionListener, EventManagerObserver

Known SubClasses

simpleStyleCheck

Properties

LOCAL theDescription$="ProvideX Style Check"

Description for this observer/contributed tool

LOCAL styleCheckName$="ecStyleCheck"

Short name for this observer/contributed tool

LOCAL theNotificationFlag=_pvxConstants'_idePostProcess

Register the events for this tool

LOCAL lbSepChar$=$09$
PROPERTY _version$=CVS(MID(STP("$Revision: 3093 $", 2, "$"), 10), 3)

class version

Methods

FUNCTION actionPerformed(inActionEventID)

This method will be called when the action is triggered from the contributed tools menu.

Parameter | Description
inActionEventID | This is a reference to [Java Class:eventmanager/ExtCommand]
FUNCTION configPerformed(inActionEventID)

This method will be called when the 'Configure' action is triggered from the contributed tools menu. The code required to implement the configuration action is normally implemented as one or more NOMADS panels that this method will execute.

Parameter | Description
inActionEventID | This is a reference to [Java Class:eventmanager/ExtCommand]
FUNCTION getStyleCheckName$()

Get the name for the style check class

Returns The name of the class
FUNCTION hasConfigAction()

This method is used to check whether a configuration action has been implemented.

Returns True (1) if a configuration action has been implemented
FUNCTION init()

Register this class as an event listener and add it to the list of contributed tools under the ProvideX menu.

FUNCTION update(state)

The logic to be executed when the observer is triggered during the normal event process in the ProvideX event manager. This logic will check the major and minor codes to determine the current event and then decide what action is to be performed.

Parameter | Description
state | A reference to an object of class PvxState
FUNCTION LOCAL loadRules(theRuleFile$)

Load the style rules from the developer properies file.

Parameter | Description
theRuleFile$ | The name of the properties file ti be loaded
FUNCTION LOCAL writeRuleFile(aRuleFile$, theRules$, isSecondaryFile)

save rules back to the rule file(s)

Parameter | Description
theRuleFile$ | The name of the properties file to write
theRules$ | The modified rules to write to the rule file
isSecondaryFile | A simple boolean (0=False, 1=True) to indicate a secondary rule file

Properties inherited from: AbstractActionListener

theDescription$, theNotificationFlag, theToolShortname$

Properties inherited from: EventManagerObserver

theDescription$, theNotificationFlag, theToolShortname$, mustRefreshResource

Methods inherited from: AbstractActionListener

actionPerformed(), configPerformed(), getDescription$(), getEventNotificationFlag(), getToolShortname$(), hasConfigAction(), init()

Methods inherited from: EventManagerObserver

getDescription$(), getEventNotificationFlag(), getToolShortname$(), init(), initState(), update(), setCurrentSource(), updateSourceFile()

Footer logo


ecStyleCheckEditUI

Class ecStyleCheckEditUI

User interface class used to maintain a style check rule

Inherits

*nomads

Properties

LOCAL lbSepChar$=$09$
PROPERTY screen_id$="EDIT_STYLE"

Panel/Library information for NOMADS

PROPERTY screen_lib$="com.pvx.util.en"

Methods

No Methods
Footer logo


ecStyleCheckRun

Class ecStyleCheckRun

Inherits

com.pvx.util.progress

Properties

LOCAL lbSepChar$=$09$
PROPERTY _version$=CVS(MID(STP("$Revision: 3093 $", 2, "$"), 10), 3)

class version

PROPERTY hasSecondaryRuleFile * Read Only *

A boolean to identify when there is a secondary rules file in the contributed tools folder

Methods

FUNCTION getRules$()

Get the rules loaded from the specifed rules file

Returns A string containing the rules that were loaded
FUNCTION getSecondaryRuleFilePath$()

Get the full path to the secondary rules file

Returns the full path to the secondary rules file
FUNCTION GetStyleCheckName$()

Get the name for the style check class

Returns The name of the class
FUNCTION loadRules(theRuleFile$)

Load the style rules from properies file; will load from a file in the same location as primary class; and then append any rules found in secondary file in Contributed tools folder

Parameter | Description
theRuleFile$ | The name of the properties file ti be loaded
FUNCTION ProcessFile(theFile$, currSrcFile$, resetMarks, updateOK)
FUNCTION ProcessFile(theFile$, currSrcFile$, resetMarks, updateOK, theStatus$)
FUNCTION ProcessFile(theFile$, currSrcFile$, resetMarks, updateOK, theStatus$, isPvxClass, retSrcFile$)

Process the selected (or current) source file against the style rules and update the problem view with any errors or warnings that are generated.

Parameter | Description
theFile$ | The name of the original source file to be processed against the style rules
currSrcFile$ | The name of the current source file to be processed against the style rules
resetMarks | A boolean flag to indicate whether the current problem view information for this file should be reset before applying the information created by the style check
updateOK | A boolean flag to identify if the source file can be updated as a result of processing the style rules
theStatus$ | (Optional) A string containing the results of the style check (Errors/Warnings)
isPvxClass | (Optional) A boolean flag to indicate if currect file is a ProvideX Class
retSrcFile$ | (Optional) Name of new source file created if option set to replace tags
FUNCTION ProcessNavViewSelections()

Process the selected (or current) source file against the style rules and update the problem view with any errors or warnings that are generated.

Properties inherited from: com.pvx.util.progress

_version$, theCaption$,theDescription$, screen_id$, screen_lib$

Methods inherited from: com.pvx.util.progress

checkCancel(), createLogFile(), disable_cancel(), enable_cancel(), enable_special(), writeLog(), writeLogFile(), b_close(), b_special(), disable_special(), doWork(), onExit(), PostLoad(), PreLoad(), setDescription(), updateView(), workDone()

Footer logo


ecStyleCheckUI

Class ecStyleCheckUI

This class is used by the configuration option for EC_StyleCheck contributed tool.

It is the logic that is used for the NOMADS panels used to configure the tool.

Constructor

The constructor for this class retrieves the data from the Eclipse Preference store. If the data does not exist, the default values that are hard-coded into this program will be used.

Parameter | Description
styleCheckName$ | - specify name of StyleCheck class

Inherits

*nomads

Properties

LOCAL prefPfx$="com.pvx.ecStyleCheckUI."
LOCAL lbSepChar$=$09$
PROPERTY _version$=CVS(MID(STP("$Revision: 2997 $", 2, "$"), 10), 3)

class version

PROPERTY rulesModified * Read Only *

This property indidcates whether the rules have been modified

PROPERTY screen_id$="CONFIG_STYLE"

Initial panel to be loaded for the configuration information

PROPERTY screen_lib$="com.pvx.util.en"

The library for the panel definitions

Methods

FUNCTION getOption(inKeyword$)

This method is used to read the options (AutoFix, Escalate).

FUNCTION getOption$(inKeyword$)

This method is used to read the options (RulesState).

Footer logo


ecUtility

Class ecUtility

Properties

PROPERTY _version$=CVS(MID(STP("$Revision: 3047 $", 2, "$"), 10), 3)

class version

Methods

FUNCTION getPath(pathID$)

Get a requested path for Eclipse workspace

Parameter | Description
pathID$ | An identified for the path
Returns The full path for the requested directory
Path Identification Codes
Value | Description
I | The plug-in install directory
O | The output directory for the current project
P | The root directory for the current project
S | The source directory for the current project
W | The workspace root directory
FUNCTION getSubFolders$(aFolder$)

Get a list of sub-folders for the specified folder.

Parameter | Description
aFolder | The parent folder
Returns A string containing a $0A$ separated list of sub-folders for the supplied parent folder.
FUNCTION isAutoBuilding()

Get the state of the 'Build Automatically' preference for the workspace

Returns A simple numeric boolean (0=false, 1=true)
FUNCTION isMessageLibrary(aFile$)

Determine if a file is a Message library

Parameter | Description
aFile$ | The full path the the file to be checked
Returns A simple numeric boolean (0=false, 1=true)
FUNCTION isNomadsLibrary(aFile$)

Determine if a file is a NOMADS library

Parameter | Description
aFile$ | The full path the the file to be checked
Returns A simple numeric boolean (0=false, 1=true)
FUNCTION setAutoBuilding(aBoolean)

Set the state of the "Build Automatically" preference for the workspace

Parameter | Description
aBoolean | A simple numeric boolean value (0=false, 1=true) to be assigned
Footer logo


ecWorkspaceResourceReader

Class ecWorkspaceResourceReader

This class provides a standard interface to the Eclipse Resource Manager to retrieve information about the current working environment and files in the source directory of each project in the workspace.

Parameter | Description
theSource | Source to be used for gathering the resources in the list
theFilter$ | *OPTIONAL* A simple DOS-style file mask
theType | *OPTIONAL* A numeric value to identify the type of files to be included in the list
Source Codes
Value | Description
0 | All resources in current workspace
1 | All resources in current project (based on selection in project explorer view)
2 | All resources selected in the project explorer view
3 | The resource loaded in the editor view
4 | All resources in current working-set
Type Codes (Add together for multiple types)
Value | Description
1 | Only source files for ProvideX programs
2 | ProvideX class definitions (*.pvc)
4 | Only NOMADS libraries
8 | Only Message libraries

Properties

PROPERTY _version$=CVS(MID(STP("$Revision: 2997 $", 2, "$"), 10), 3)

class version

Methods

FUNCTION getWorkspaceRoot$()

Get workspace root folder

FUNCTION project_getInfo(projectHandle, Name$, Location$)
FUNCTION project_getInfo(projectHandle, Name$, Location$, ProjPath$)

Get information about the project identified by the handle. The project name and full path will be updated into the corresponding arguments.

Parameter | Description
projectHandle | The handle to the resource for the project
Name$ | The name of the resource (no path)
Location$ | The operating system path for the resource
ProjPath$ | (Optional) The project path for the resource
Returns A simple boolean value to indicate success (1) or failure (0).
FUNCTION project_getNext()

Get a handle to the next project for the current workspace.

Returns A handle to the next project in the current workspace
FUNCTION resource_getCount()

Get the number of resources in the current selection source

Returns The number of selected resources
FUNCTION resource_getInfo(resHandle, Name$, Location$)
FUNCTION resource_getInfo(resHandle, Name$, Location$, ProjPath$)

Get information about the resource identified by the handle. The resource name and full path will be updated into the corresponding arguments.

Parameter | Description
resHandle | The handle to the resource
Name$ | The name of the resource (no path)
Location$ | The operating system path for the resource
ProjPath$ | (Optional) The project path for the resource
Returns A simple boolean value to indicate success (1) or failure (0).
FUNCTION resource_getNext()

Get a handle to the next resource in the list

Returns A handle to the next resource in the list
Footer logo


ProgressMonitor

Class ProgressMonitor

This class is used to display a progress bar to monitor the work performed to complete a task. It is a wrapper for the [Java Class:views/MonitorState] class.

Build Information

Forcelinenumbers false

Constructor

Get a reference to a ProgressMonitor from the [Java Class:views/UIManager] object

Parameter | Description
initName$ | The name for this task
initTotalWork | An integer for the units of work to be completed (Indeterminate = -1)

Properties

No Properties

Methods

FUNCTION done()

This method is used to indicate that the process has completed.

FUNCTION getName$()

Return the name of the task

FUNCTION getTotalWork()

Return the total amount of work to be performed for this task

FUNCTION getWorked()

Return the amount of work that has been recored up to this point in time

FUNCTION isActive()

Return true (1) if the initialization of the class was successful

FUNCTION isCancelled()

Return true (1) if the task has been cancelled

FUNCTION setDialogueVisible(initBool)

Show/hide the dialogue window that shows the progress bar

Parameter | Description
initBool | A boolean value (0=False, 1=True) to indicate the state to be set for the dialogue window
FUNCTION setPerCentageWorked(initPerCent)

Set the per centage of work that has been completed

FUNCTION setTaskDetail(initText$)

Update the task detail with a short description of the current activity

Parameter | Description
initText$ | A string variable that contains the description to be displayed
FUNCTION setTaskName(initTaskName$)

Set / Change the name of this task

Parameter | Description
initTaskName$ | A string varible that contains the new name for the task
FUNCTION setWorked(initWork)

Add to the units of work that have been completed. This value cannot be larger that the total work set for the task.

Parameter | Description
initWork | The total units of work that have been completed
Footer logo


AbstractActionListener

Class AbstractActionListener

Abstract class for 'ActionListener' classes.

Constructor

This is an abstract class for all event manager observers.

Parameter | Description
init_pvxConstants | A reference to PvxConstants object
initViewManager | A reference to [Java Class:views/UIManager] object

Known SubClasses

ConfigAppserverActionListener, ConfigWebserverActionListener, ecCreateDataInfo, ecDictListener, ecMsgLibListener, ecSearchListener, ecStyleCheck, PvxdocObserver, ShutdownEventManager, stripTrailing_Listener, toolsListener, util_keyword_chg, XMItoPvxAction, XML_Convert

Properties

LOCAL theDescription$

Description to be used for tool in the list of Contributed Tools access from the ProvideX, Contributed Tools menu item

LOCAL theNotificationFlag=_pvxConstants'_ideNone
LOCAL theToolShortname$

Methods

FUNCTION actionPerformed(inActionEventID)

This method will be called when the 'Run' action is triggered from the contributed tools menu. The code associated with this observer must be executed by this method; this code can be the logic for this method or can be in an external program that is accessable in the environment where this observer will be used.

Parameter | Description
inActionEventID | This is a reference to [Java Class:eventmanager/ExtCommand]
FUNCTION configPerformed(inActionEventID)

This method will be called when the 'Configure' action is triggered from the contributed tools menu. The code required to implement the configuration action is normally implemented as one or more NOMADS panels that this method will execute.

Parameter | Description
inActionEventID | This is a reference to [Java Class:eventmanager/ExtCommand]
FUNCTION getDescription$()

This method is used to describe the purpose of this observer. The text will be placed on the observers preference page to describe the purpose of this observer. This description should be limited to no more than 80 characters.

FUNCTION getEventNotificationFlag()

Get the flag that will be used to trigger the 'update()' method during execution of the built-in events for the plug-in.

If this observer is not a Post-process observer, the return value of this method should be set to one of the following values:

Value | Description
_pvxConstants'_ideNone | Do not register as an observer
_pvxConstants'_idePreProcess | Register as a Pre-Process observer
_pvxConstants'_idePrePostProcess | Register as both a Pre-Process and Post-Process observer.
_pvxConstants'_idePostProcess | Register as a Post-Process observer
FUNCTION getToolShortname$()

This method is used to get the short name of this observer.

Returns The short name for this observer
FUNCTION hasConfigAction()

This method must be implemented in the child class when a configuration action has been implemented.

Returns True(1) if a configuration has been implemented
FUNCTION init()

Register this class as an event listener and add it to the list of contributed tools under the ProvideX menu item.

Footer logo


AbstractReader

Class AbstractReader

Abstract class simple readers.

Build Information

Forcelinenumbers false

Properties

No Properties

Methods

FUNCTION read$()
Returns A string containing the text that was retrieved.
Footer logo


AbstractResourceBuilder

Class AbstractResourceBuilder

Abstract class for ResourceBuilder classes. These classes are used to export/import properties for all resources in a project or group of projects.

Build Information

Forcelinenumbers false

Known SubClasses

TextfileResourceBuilder, WorkspaceResourceBuilder

Properties

No Properties

Methods

FUNCTION add(name$, path$, childList$, propList)

Add a new property into object to be created. This method is a stub that will be over-ridden by the child classes.

Parameter | Description
name$ | The name of the resource.
path$ | The path to the resource within the project.
childList$ | A comma-separated list of children for this resource.
propList | A reference to [ProvideX Library Class:*obj/group] which is a collection of ResourceProperty
FUNCTION build()

Create the outut object from the information collected by the 'add()' method.

FUNCTION isCancelled()

Check the state of the process to see if the user has initiated a cancel request.

Returns A simple integer value to indicate that the process has been cancelled (0=False, 1=True).
FUNCTION setCancelled(initCancelled)

Set the flag to indicate that the process has been cancelled.

Parameter | Description
initCancelled | A simple integer value to indicate that the process has been cancelled (0=False, 1=True).
Footer logo


AbstractResourceReader

Class AbstractResourceReader

This is an abstract class is used to collect the properties for a resource.

Build Information

Forcelinenumbers false

Known SubClasses

WorkspaceResourceReader

Properties

No Properties

Methods

FUNCTION readResource(fullPath$)
Returns A reference to a PvxWorkspaceResource
Footer logo


domEntity

Class domEntity

This class will be used as temporary storage for the information that is gathered when building the DOM for a resource. Once the information has been collected, this object will be passed to the 'domManager'. Each object type that is added will include a referece to the line number of the declaration.

Build Information

Forcelinenumbers false

Constructor

Create a new object to store the properties of this resource.

Parameter | Description
inResource$ | The name of the resource
inType | The type of resource

Properties

No Properties

Methods

FUNCTION addDefFunction(inFunction$, inLine)

Add a DEF FN

Parameter | Description
inFunction$ | The name of the function
inLine | The line number for this reference
FUNCTION addFunction(inFunction$, inLine)

Add a FUNCTION

Parameter | Description
inFunction$ | The name of the function
inLine | The line number for this reference
FUNCTION addKeyword(inKeyword$, inValue$, inLine)

Add a KEYWORD/VALUE combination

Parameter | Description
inKeyword$ | A tag to indentify the type of reference
inValue$ | The name of this reference
inLine | The line number for this reference
FUNCTION addLabel(inLabel$, inLine)

Add a LABEL

Parameter | Description
inLabel$ | The statement label
inLine | The line number for this reference
FUNCTION addLocal(inVariable$, inLine)

Add a LOCAL property within a class definition

Parameter | Description
inVariable$ | The variable for the local property
inLine | The line number for this reference
FUNCTION addLocalFunction(inFunction$, inLine)

Add a FUNCTION LOCAL

Parameter | Description
inFunction$ | The name of the local function
inLine | The line number for this reference
FUNCTION addObjectProperty(inProperty$, inLine)

Add a PROPERTY that references an object

Parameter | Description
inProperty$ | The name for a property that references an object
inLine | The line number for this reference
FUNCTION addProperty(inProperty$, inLine)

Add a PROPERTY

Parameter | Description
inProperty$ | The name for a property
inLine | The line number for this reference
FUNCTION addVariable(inVariable$, inLine)

Add a VARIABLE

Parameter | Description
inVariable$ | The name of the variable
inLine | The line number for this reference
FUNCTION getNextLine$()

Return the next line from the stored information stored within this object

FUNCTION getResource$()

Return the name of the resource

FUNCTION getResourcePath$()

Return the path to the resource within the project

FUNCTION getType()

Return the type of the resource

Footer logo


domManager

Class domManager

This class will create the DOM information for resource using the information in the domEntity object.

Build Information

Forcelinenumbers false

Constructor

Create a file within the workspace control data for the specified resource. All information collected about the resource will be placed into this file.

Parameter | Description
inEntity | A reference to a domEntity object

Properties

No Properties

Methods

FUNCTION getDOMFile$()

Get the name of the DOM file for this resource

FUNCTION updateView()

Update the outline view for the resource.

Footer logo


EclipsePathResolver

Class EclipsePathResolver

The class will resolve (or expand) the name of the INCLUDE file relative to the source directory of the Eclipse project.

Build Information

Forcelinenumbers false

Constructor

Defines a new PathResolver for the specified Eclipse project source folder.

Parameter | Description
inSourceFolder$ | The source folder for the project.

Inherits

path_resolver

Properties

No Properties

Methods

FUNCTION resolve$(inSrcName$, inIncludeName$)

Resolve (or expand) the name of the INCLUDE file.

Parameter | Description
inSrcName$ | The name of file to source file
inIncludeName$ | The name of the include file
Returns The name of the INCLUDE file relative to the location of the Eclipse project source directory.

Properties inherited from: path_resolver

_version$

Methods inherited from: path_resolver

resolve$()

Footer logo


ErrorLogBuilder

Class ErrorLogBuilder

This class is used to update the log display for the activity that occurs during processing of an event. It is not limited to the logging of error information but also records information about the event itself.

Build Information

Forcelinenumbers false

Inherits

EventManagerObserver

Properties

LOCAL maxEntries=10
PROPERTY bFalse=0

Boolean - False

PROPERTY bTrue=1

Boolean - True

PROPERTY eInfo=0

Static property - data written to log is for information purposes

PROPERTY eConsoleInfo=1

Static property - data written to log is to copied to console

PROPERTY eWarning=2

Static property - data written to log is a warning message

PROPERTY ECLEAR=1003

Static property - ID of button that will trigger initialization of log window

PROPERTY ECONSOLE=1004

Static property - ID of button to allow access to console mode in a development environment

PROPERTY ETEXT=1005

Static property - ID of log window

PROPERTY eDebugLog$

Name of the log file

PROPERTY ViewManager

Eclipse View Manager

Methods

FUNCTION bufferAddText(initText$)

Add string to the current output buffer

Parameter | Description
initText$ | Text to be added to the output buffer
FUNCTION bufferInit()

Initialize the output buffer; any information in the buffer will be destroyed.

FUNCTION bufferWriteText()

Write the contents of the buffer to the log window and clear the buffer.

FUNCTION getBufferText$()

Get text in buffer

Returns The text in the buffer
FUNCTION setText(initText$)

Reset output buffer to the text provided.

Parameter | Description
initText$ | Text to be placed into the output buffer.
FUNCTION setVisible(initBoolean)

Show / Hide the log window.

Parameter | Description
initBoolean | A boolean flag to determine whether the log window is visible
FUNCTION update(aPvxState)

This class is primarily an observer that is invoked after an event to log information about the event and possibly information created by the event.

Parameter | Description
aPvxState | A pvxState object reference.
FUNCTION write_log(LogText$, Severity)

Write the information in the output buffer to the log window (and file). This is used internally by other classes and the event manager; the alternate method bufferWriteText() should be used instead.

Parameter | Description
LogText$ | The text to be written to the log window.
Severity | A severity level to be assigned to the information written to the log window.

Properties inherited from: EventManagerObserver

theDescription$, theNotificationFlag, theToolShortname$, mustRefreshResource

Methods inherited from: EventManagerObserver

getDescription$(), getEventNotificationFlag(), getToolShortname$(), init(), initState(), update(), setCurrentSource(), updateSourceFile()

Footer logo


EventManagerObserver

Class EventManagerObserver

The abstract class definition for all observers.

Build Information

Forcelinenumbers false

Constructor

This is an abstract class for all event manager observers.

Parameter | Description
init_pvxConstants | A reference to PvxConstants object
initViewManager | A reference to [Java Class:views/UIManager] object

Known SubClasses

ConfigAppserverActionListener, ConfigWebserverActionListener, ecDictListener, ecMsgLibListener, ecSearchListener, ecStyleCheck, ErrorLogBuilder, PvxdocObserver, PvxProgressView, set_copyright_year, set_mod_timestamp, ShutdownEventManager, stripTrailing_build, tagSubstitution_build, toolsListener, util_keyword_build, util_keyword_chg, XMItoPvxAction, XML_Convert

Properties

LOCAL theDescription$

Description to be used for tool in the list of Contributed Tools access from the ProvideX, Contributed Tools menu item

LOCAL theNotificationFlag=_pvxConstants'_ideNone
LOCAL theToolShortname$
PROPERTY mustRefreshResource

Methods

FUNCTION getDescription$()

This method is used to describe the purpose of this observer. The text will be placed on the observers preference page to describe the purpose of this observer. This description should be limited to no more than 80 characters.

Returns The description for this observer
FUNCTION getEventNotificationFlag()

Get the flag that will be used to trigger the 'update()' method during execution of the built-in events for the plug-in.

Returns A code used to register when the observer is triggered
Value | Description
Register | Observer Type
_pvxConstants'_ideNone | Do not register as an observer
_pvxConstants'_idePreProcess | Register as a Pre-Process observer
_pvxConstants'_idePrePostProcess | Register as both a Pre-Process and Post-Process observer.
_pvxConstants'_idePostProcess | Register as a Post-Process observer
FUNCTION getToolShortname$()

This method is used to get the short name of this observer.

Returns The short name for this observer
FUNCTION init()

Initialize this observer.

FUNCTION initState()

Initialize the internal control data for this observer

FUNCTION update(state)

The logic to be executed when the observer is triggered during the normal event process in the ProvideX event manager. This logic will check the major and minor codes to determine the current event and then decide what action is to be performed.

Parameter | Description
state | A reference to an object of class PvxState
FUNCTION LOCAL setCurrentSource(state, srcFile$)

Set the state property for source file to the new specified value

Parameter | Description
state | A reference to an object of class PvxState
srcFile | The source file with the modified/updated content
FUNCTION LOCAL updateSourceFile(state)

Update the content of the real source file with content of current source

Parameter | Description
state | A reference to an object of class PvxState
Footer logo


Iterator

Class Iterator

This class implements a simple iterator for a [ProvideX Library Class:*obj/group] object.

Build Information

Forcelinenumbers false

Properties

No Properties

Methods

FUNCTION hasNext()

Check for remaining items

Returns A boolean value if there are more items in the group (0=False, 1=True)
FUNCTION nextItem()

Get the next item

Returns A reference to the next [ProvideX Library Class:*obj/group] item in the group.
Footer logo


PvxClassLoader

Class PvxClassLoader

This class instantiates each of the objects that have been registered as observers in the "classes.txt" file and then stores the ID in a [ProvideX Library Class:*obj/group] object.

Build Information

Forcelinenumbers false

Constructor

Initializes the environment for all observers and create a reference to the [Java Class:eventmanager/EventManager] object.

Parameter | Description
init_pvxConstants | A reference to pvxConstants object
initViewManager | A reference to [Java Class:views/UIManager] object

Properties

PROPERTY observers
Type A reference to a [ProvideX Library Class:*obj/group] object
PROPERTY _pvxConstants
Type A reference to a PvxConstants object
PROPERTY ViewManager
Type A reference to a [Java Class:views/UIManager] object

Methods

FUNCTION loadClasses(classesFile$)

Load all classes that have been defined in the file.

Parameter | Description
classesFile$ | The name of the file that contains the list of classes to be loaded.
FUNCTION observers()

An iterator for the observers that were successfully loaded.

Footer logo


PvxConstants

Class PvxConstants

This class defines constants to be used to identify actions, events, and values used within the plug-in to maintain a consistent interface between objects.

Build Information

Forcelinenumbers false

Constructor

This class loads all of the constants used by the plugin into a single location. In addition to setting the ProvideX constants, all of the constants used by the Java components are also loaded from the [Java Class:preferences/PreferenceConstants] and [Java Class:eventmanager/EventManager] objects.

Parameter | Description
EventManager | A reference to [Java Class:eventmanager/EventManager] object

Properties

PROPERTY _iPluginID$
PROPERTY _iPluginHelperDir$
PROPERTY event_Desc$
PROPERTY event_Fired$
PROPERTY event_Listnr$
PROPERTY ext_Event$
PROPERTY act_Password$
PROPERTY adding_Resources_to_Src$
PROPERTY StripLines_Prep$
PROPERTY Eclipse_Shutdown$
PROPERTY Export$
PROPERTY Full_Build$
PROPERTY Full_Build_End$
PROPERTY Full_Build_Start$
PROPERTY generic_action$
PROPERTY Host_Is_Ready$
PROPERTY Import$
PROPERTY Import_Export_File$
PROPERTY Import_Export_Properties$
PROPERTY Importing_End$
PROPERTY Importing_Start$
PROPERTY Incremental_Build$
PROPERTY Incremental_Build_Alt_Exe$
PROPERTY Operation_Cancel$
PROPERTY Operation_Success$
PROPERTY PageID$
PROPERTY Preference_Change$
PROPERTY Preference_Page_Button$
PROPERTY Preference_Property$
PROPERTY Preference_New_Value$
PROPERTY Preference_Old_Value$
PROPERTY Project_List$
PROPERTY Project_Location$
PROPERTY Project_Member_Count$
PROPERTY Project_Name$
PROPERTY Removed_Resource_From_Src$
PROPERTY Request_Socket$
PROPERTY Resource_Properties_Changed$
PROPERTY Run_Console$
PROPERTY Run_Designer$
PROPERTY Run_DictMaint$
PROPERTY Run_IT$
PROPERTY Run_NOMADS$
PROPERTY Run_Test_Panel$
PROPERTY NOMADS_blocking$
PROPERTY NOMADS_non_blocking$
PROPERTY Strip_Line_No$
PROPERTY Validate$
PROPERTY Valid$
PROPERTY Invalid$
PROPERTY Load$
PROPERTY Remove$
PROPERTY Name$
PROPERTY Path$
PROPERTY Selected_View$
PROPERTY Build_File_Path$
PROPERTY Buildtype_Convert$
PROPERTY Buildtype_BuildOne$
PROPERTY Buildtype_DataFile$
PROPERTY Buildtype_NomadsLIB$
PROPERTY Buildtype_OtherFile$
PROPERTY Buildtype_SkipFile$
PROPERTY Buildtype_Source_Format$
PROPERTY Buildtype_Skip$
PROPERTY _ibDOAUTOFORMAT$
PROPERTY BuildLog$
PROPERTY BuildType$
PROPERTY Dest$
PROPERTY DomFile$
PROPERTY Flags$
PROPERTY OwnerCode$
PROPERTY pkf_Password$
PROPERTY SrcFile$
PROPERTY LockFile$
PROPERTY event_SrcFile$
PROPERTY Resource_OwnerCode$
PROPERTY Resource_Flags$
PROPERTY Import_SrcFile_Extension$
PROPERTY Import_Formatlist$
PROPERTY Import_Lowercase_Dir$
PROPERTY Import_Lowercase_Vars$
PROPERTY Import_Strip_Line_Label_Prefix$
PROPERTY Import_Strip_Line_no$
PROPERTY Import_Strip_Line_Use_Orig_no$
PROPERTY Import_SuppressLet$
PROPERTY isLine_Numbs_Required$
PROPERTY Output_File_Name$
PROPERTY Project_INI_File$
PROPERTY Project_Output_Directory$
PROPERTY Project_Source_Directory$
PROPERTY p_Password$
PROPERTY p_IsPVXData$
PROPERTY p_IsResource$
PROPERTY p_xml_export$
PROPERTY p_build_files_no_ext$
PROPERTY p_ischecking_file_extions$
PROPERTY p_save_window_position$
PROPERTY IS_ADD_EXT_TO_ALL$
PROPERTY Builder_Exe$
PROPERTY Build_Exec_CMD$
PROPERTY Build_Exec_Log$
PROPERTY Build_Exec_Out$
PROPERTY BuildInfoFound$
PROPERTY Project_Root$
PROPERTY PvxCTL$
PROPERTY _ibDebug$
PROPERTY _ibDebugProcessMessages$
PROPERTY _ibDebugVerbosityLevel$
PROPERTY _ibDebugLogToConsole$
PROPERTY _ibDebugLog$
PROPERTY _ibDebugSize$
PROPERTY _ibDebug_SC_DumpInfo$
PROPERTY _iBuildCheckStructure$
PROPERTY _iBuildMaintainCase$
PROPERTY _iBuildDebugTIM$
PROPERTY _iBuildProgress$
PROPERTY _iDisableCstyleComments$
PROPERTY _iShowSizeWarning$
PROPERTY _ibAltStartUp$
PROPERTY _ibBtiEnable$
PROPERTY _ibMasBuildOne$
PROPERTY _ibUseStartUp$
PROPERTY _iEclipseBuilderSocket$
PROPERTY _iOutlineExcludeVars$
PROPERTY _LineNumberInc$
PROPERTY _IRPC_EXE$
PROPERTY _iRPCisOK$
PROPERTY _IRPC_PORT$
PROPERTY _iShowEventParm$
PROPERTY _iShowInvokeCommand$
PROPERTY _iEventNotificationFlag$
PROPERTY _iAllowConsole$
PROPERTY _iSuppressDataPassword$
PROPERTY _ibStripLeadingWhiteSpace$
PROPERTY _ibLogErrorScan$
PROPERTY _ibForceDestinationName$
PROPERTY _ibStringLiteralContinue$
PROPERTY _ibSimpleScanDuplicateNames$
PROPERTY _KeywordConversion$
PROPERTY _AutoKeywordConversion$
PROPERTY _KC_ConvertLabels$
PROPERTY _NOMADS_Default_Suffix$
PROPERTY _NOMADS_Panel_Suppress_VAL$
PROPERTY _NOMADS_Panel_Column$
PROPERTY _NOMADS_Panel_Line$
PROPERTY _NOMADS_Panel_Width$
PROPERTY _NOMADS_Panel_Height$
PROPERTY _NOMADS_Panel_GUI_Style$
PROPERTY _NOMADS_Panel_Grid_Def$
PROPERTY _NOMADS_Object_Name$
PROPERTY _NOMADS_ExtImageDir$
PROPERTY _Cancel$
PROPERTY _bFormattedText$
PROPERTY _bIsOK$
PROPERTY _bPasswordValidate$
PROPERTY _bSaveAsText$
PROPERTY _ideFromStripper$
PROPERTY _iEventCommand$
PROPERTY _ideConvertSource$
PROPERTY _iDefaultTokenPgmExt$
PROPERTY _iStripSourceExtension$
PROPERTY _iAddSourceExtension$
PROPERTY _iPasswordType$
PROPERTY _extObserverEnable$
PROPERTY _extObserverUserDir$
PROPERTY _ProgramBlockComments$
PROPERTY _idePreProcess

Contributed Extension / Tool event notification type: Before event performed

PROPERTY _idePostProcess

Contributed Extension / Tool event notification type: After event performed

PROPERTY _idePrePostProcess

Contributed Extension / Tool event notification type: Before/After event performed

PROPERTY _ideNone

Contributed Extension / Tool event notification type: Not triggered during event process

PROPERTY _iPvxData
PROPERTY _iPvxProgram
PROPERTY _btiUpdateInfo$

Methods

FUNCTION getNoticationFlagDescription$(flag)

Get the description for notification flag

Returns A string with the description of the notification flag
FUNCTION getPvxHelperDir$()

Get the location of the PvxHelper root directory for this system

Returns A string value that contains the root directory of the PvxHelpers on the local file system.
Footer logo


PvxPreferences

Class PvxPreferences

This object is used to create a standard interface for accessing preferences of an event so that all logic associated with the processing that occurs during the event can access this data. A reference to this object is part of the state information for each event.

Build Information

Forcelinenumbers false

Constructor

Load the current values for all preferences into this class object.

Properties

LOCAL numPrefs=53

Methods

FUNCTION addPreference(eclipseData)

Add a preference

Parameter | Description
eclipseData | A reference to pvx_data
FUNCTION containsPreference(prefKey$)

Returns true (1) if there is a preference with the name specified.

Parameter | Description
prefKey$ | The name of the preference to be found.
FUNCTION deletePreference(prefKey$)

Delete a preference with the name specified, if it exists

FUNCTION getBooleanPreference(thisName$)

Return a value (0=False, 1=True) for the boolean preference with the name specified

FUNCTION getPreference(prefKey$)

Return a reference to pvx_data for the preference with the name specified

FUNCTION getStringPreference$(thisName$)

Return the value of the string preference with the name specified

FUNCTION load_Preferences()

Load the preferences from [Java Class:preferences/PreferenceManager]

FUNCTION preferenceIterator()

Initialize an iterator for the preferences [ProvideX Library Class:*obj/group] object

The preferences are access using the following constants:

Value | Description
_pvxConstants'_iEclipseBuilderSocket$ | TCP/IP socket to be used for commuication with the plug-in
_pvxConstants'_iBuildCheckStructure$ | BUILD: Enable check of program structure during build process
_pvxConstants'_iBuildProgress$ | BUILD: Enable build progress bar to show per centage of woek completed
_pvxConstants'_iDisableCstyleComments$ | BUILD: Disable C-Style block comments
_pvxConstants'_iOutlineExcludeVars$ | BUILD: Include variables in the outline view for programs
_pvxConstants'_iBuildMaintainCase$ | BUILD: Allow mixed case for variables and line labels
_pvxConstants'_ibDOAUTOFORMAT$ | BUILD: Automatically reformat during SAVE
_pvxConstants'_iShowSizeWarning$ | BUILD: Show 64K program size warning
_pvxConstants'_iStripSourceExtension$ | BUILD: Strip the default source file extension from output file name
_pvxConstants'_iDefaultTokenPgmExt$ | BUILD: Default extension to be appended to output file name if there is no extension
_pvxConstants'_ibUseStartUp$ | BUILD: Use a program to initialize build environment
_pvxConstants'_LineNumberInc$ | BUILD: Type of auto-increment when assigning line numbers
_pvxConstants'_ibAltStartUp$ | BUILD: Full path of program used to initialize build environment
_pvxConstants'_ibBTI_Enable$ | BUILD: Enable Load/Save to "project.BuildTagInfo.pvk" control file
_pvxConstants'_ibMasBuildOne$ | BUILD: Enable MAS 'project.BuildOne.pvx' during build
_pvxConstants'_ibDebug$ | LOG: Enable event logging
_pvxConstants'_ibDebugProcessMessages$ | LOG: Show process debug status messages
_pvxConstants'_ibDebugVerbosityLevel$ | LOG: Debug verbosity level (1=Minimum, 2=Medium, 9=Maximum)
_pvxConstants'_ibDebugLog$ | LOG: Log file for event information
_pvxConstants'_ibDebugSize$ | LOG: Maximum number of events in the event window; oldest will be deleted.
_pvxConstants'_iShowEventParm$ | LOG: Show event parameters (none, list, values)
_pvxConstants'_iSuppressDataPassword$ | IMPORT: Suppress request for passwords on protected data files
_pvxConstants'Import_Formatlist$ | IMPORT: Format source code during import
_pvxConstants'Import_Lowercase_Dir$ | IMPORT: All directives converted to lowercase
_pvxConstants'Import_Lowercase_Vars$ | IMPORT: All variables converted to lowercase
_pvxConstants'Import_Strip_Line_Label_Prefix$ | IMPORT: Prefix to be placed at begining of line labels when stripping line numbers
_pvxConstants'Import_Strip_Line_no$ | IMPORT: Strip line numbers
_pvxConstants'Import_Strip_Line_Use_Orig_no$ | IMPORT: Use orginal line number (instead of a counter) in the auto-generated labels
_pvxConstants'Import_SuppressLet$ | IMPORT: Suppress the LET directive
_pvxConstants'Import_SrcFile_Extension$ | IMPORT: Source File extension lst
_pvxConstants'_iAddSourceExtension$ | IMPORT: Always add source file extension
_pvxConstants'_extObserverEnable$ | OBSERVERS: Enable external observers
_pvxConstants'_extObserverUserDir$ | OBSERVERS: Directory for user-defined observers
_pvxConstants'_KeywordConversion$ | EDIT-OPTIONS: Keyword conversion rule
_pvxConstants'_KC_ConvertLabels$ | EDIT-OPTIONS: Convert Line Labels during Keyword conversion process
_pvxConstants'_NOMADS_Default_Suffix | NOMADS: Default library suffix
_pvxConstants'_NOMADS_Panel_Suppress_VAL | NOMADS: Suppress '.VAL' for variable values
_pvxConstants'_NOMADS_Panel_Column | NOMADS: Default column for new panel
_pvxConstants'_NOMADS_Panel_Line | NOMADS: Default line for new panel
_pvxConstants'_NOMADS_Panel_Width | NOMADS: Default width of new panel
_pvxConstants'_NOMADS_Panel_Height | NOMADS: Default height of new panel
_pvxConstants'_NOMADS_Panel_GUI_Style | NOMADS: Default GUI style
_pvxConstants'_NOMADS_Panel_Grid_Def | NOMADS: Default Grid definition
_pvxConstants'_NOMADS_ExtImageDir$ | NOMADS: External Image folder
Footer logo


PvxProgressView

Class PvxProgressView

This is an observer class that is used to show the progress of activity within events that can take a length of time to complete or that are performing a number of sub-events.

Build Information

Forcelinenumbers false

Inherits

EventManagerObserver

Properties

LOCAL theNotificationFlag=_pvxConstants'_idePostProcess
PROPERTY PVCANCEL=3
PROPERTY PV_NORMAL=0
PROPERTY PV_BUILD_START=1
PROPERTY PV_BUILD_END=2
PROPERTY PV_BUILD_CANCEL=3

Methods

FUNCTION update(initPvxState)

The logic to be executed when the observer is triggered. This logic must check the major and minor codes to determine the current event and then decide what action is to be performed.

Parameter | Description
initPvxState | A reference to an object of class PvxState

Properties inherited from: EventManagerObserver

theDescription$, theNotificationFlag, theToolShortname$, mustRefreshResource

Methods inherited from: EventManagerObserver

getDescription$(), getEventNotificationFlag(), getToolShortname$(), init(), initState(), update(), setCurrentSource(), updateSourceFile()

Footer logo


PvxResource

Class PvxResource

This class is used to collect information about a resource and its child resources.

Build Information

Forcelinenumbers false

Known SubClasses

PvxTextResource, PvxWorkspaceResource

Properties

No Properties

Methods

FUNCTION addMember()

Increment the count of children for this resource

FUNCTION addToChildList(name$)

Add the resource name the the list of children for this resource

FUNCTION export(builder)

Export all information gathered about this resource.

Parameter | Description
builder | A reference to a AbstractResourceBuilder subclass that will transfer the collected information to another container.
FUNCTION getMemberCount()

Returns The number of child resources for this resource.

FUNCTION getName$()

Returns The name of this resource.

FUNCTION setProperties(init_propertyList, init_resourceName$, init_fullPath$)

Set the properties of this resource

Parameter | Description
init_propertyList | A reference to a [ProvideX Library Class:*obj/group] that holds the properties for this resource.
init_resourceName$ | The name of this resource
init_fullPath$ | The path to this resource within the project
Footer logo


PvxResponse

Class PvxResponse

This object is used to communicate a response between objects.

Build Information

Forcelinenumbers false

Properties

No Properties

Methods

FUNCTION getArguments()

Returns a reference to an object for the arguments. Currently, not used.

FUNCTION getEventName$()

Returns the name of the event

FUNCTION getResponseMsg$()

Returns a string containing the response message

Footer logo


PvxState

Class PvxState

This object is used by the ProvideX Event Manager to store information about the current state for an event.

Build Information

Forcelinenumbers false

Constructor

Create a new object to store the state information for the specified event

Parameter | Description
initMajor$ | The major code used to identify the event
initMinor$ | The minor code used to identify the event

Properties

No Properties

Methods

FUNCTION addArgument(eclipseData)

Add an argument

Parameter | Description
eclipseData | A reference to pvx_data
FUNCTION argumentIterator()

Initialize an iterator for the arguments [ProvideX Library Class:*obj/group] object

Returns A reference to iterator
FUNCTION containsArgument(argKey$)
Parameter | Description
argKey$ | The name of the argument to be found.
Returns A simple boolean (0=False, 1=true) if there is an argument with the name specified.
FUNCTION deleteArgument(argKey$)

Delete an argument with the name specified, if it exists

Parameter | Description
argKey$ | The name of the argument to be deleted
FUNCTION getArgument(argKey$)
Parameter | Description
argKey$ | The name of the argument to be found.
Returns A reference to pvx_data for the argument with the name specified
FUNCTION getArgumentValue$(thisName$)
Parameter | Description
thisName$ | The name of the argument to be found.
Returns The value for the string argument with the name specified
FUNCTION getArgumentValue(thisName$)
Parameter | Description
thisName$ | The name of the argument to be found.
Returns The value for the numeric argument with the name specified
FUNCTION getBooleanPreference(thisName$)
Parameter | Description
thisName$ | The name of the argument to be found.
Returns A simple value (0=False, 1=True) for the boolean preference with the name specified
FUNCTION getMajor$()
Returns The major name of the current event
FUNCTION getMinor$()
Returns The minor name of the current event
FUNCTION getStringPreference$(thisName$)
Parameter | Description
thisName$ | The name of the argument to be found.
Returns The value of the string preference with the name specified
FUNCTION overrideBoolPref(thisName$, NewValue)
FUNCTION setArgument(argKey$, argValue$)

Set the value of the specified argument to the string value specified

Parameter | Description
argKey$ | The name of the argument to be found.
argValue$ | The string value to be assigned
FUNCTION setArgument(argKey$, argValue)

Set the value of the specified argument to the numeric value specified

Parameter | Description
argKey$ | The name of the argument to be found.
argValue | The numeric value to be assigned
Footer logo


PvxTextResource

Class PvxTextResource

This class uses the TextfileResourceReader class to read resource information from a text file.

Build Information

Forcelinenumbers false

Inherits

PvxResource

Properties

No Properties

Methods

FUNCTION addMember(initFile$, initPath$)

Add a new child to this resource.

Parameter | Description
initFile$ | The text file that contains the information about this resource
initPath$ | The path to the resource within the project

Methods inherited from: PvxResource

addMember(), addToChildList(), export(), getMemberCount(), getName$(), setProperties()

Footer logo


PvxWorkspaceResource

Class PvxWorkspaceResource

This class is used to collect information about a resource and its child resources.

Build Information

Forcelinenumbers false

Inherits

PvxResource

Properties

No Properties

Methods

FUNCTION addMember(resource)

Add a new child to this resource.

Parameter | Description
resource | A reference to a PvxResource object.

Methods inherited from: PvxResource

addMember(), addToChildList(), export(), getMemberCount(), getName$(), setProperties()

Footer logo


ResourceProperty

Class ResourceProperty

The class is used to store an instance of a resource that includes the name and associated value.

Build Information

Forcelinenumbers false

Properties

PROPERTY key$
PROPERTY value$

Methods

FUNCTION getKey$()

Return the name of this resource

FUNCTION getValue$()

Return the value for this resource

Footer logo


TextfileResourceBuilder

Class TextfileResourceBuilder

This class is used to create a simple text file to hold information about the properties for all resources in a project or group of projects.

Build Information

Forcelinenumbers false

Inherits

AbstractResourceBuilder

Properties

PROPERTY PROJ_LIST_HEADER_KEY$="~~List_of_Projects_in_File~~"

Methods

FUNCTION add(name$, path$, childList$, propList)

Add a new property into object to be created. This method is a stub that will be over-ridden by the child classes.

Parameter | Description
name$ | The name of the resource.
path$ | The path to the resource within the project.
childList$ | A comma-separated list of children for this resource.
propList | A reference to [ProvideX Library Class:*obj/group] which is a collection of ResourceProperty
FUNCTION build()

Create the output object from the information collected by the 'add()' method.

Methods inherited from: AbstractResourceBuilder

add(), build(), isCancelled(), setCancelled()

Footer logo


TextfileResourceReader

Class TextfileResourceReader

Read resource information from a text file.

Build Information

Forcelinenumbers false

Properties

No Properties

Methods

FUNCTION readResource(fullPath$)

Return a reference to PvxTextResource that holds the resource information loaded from the text file

Footer logo


WorkspaceResourceBuilder

Class WorkspaceResourceBuilder

This class is used by the 'Import ProvideX Properties' wizard to update the properties for all resources in a project or group of projects.

Build Information

Forcelinenumbers false

Constructor

Create a reference to [Java Class:eventmanager/ResourceManager] to be used to collect information about a resource.

Inherits

AbstractResourceBuilder

Properties

PROPERTY resManager

A reference to [Java Class:eventmanager/ResourceManager]

Methods

FUNCTION add(name$, path$, childList$, propList)

Add a new property into object to be created. This method is a stub that will be over-ridden by the child classes.

Parameter | Description
name$ | The name of the resource.
path$ | The path to the resource within the project.
childList$ | A comma-separated list of children for this resource.
propList | A reference to [ProvideX Library Class:*obj/group] which is a collection of ResourceProperty

Methods inherited from: AbstractResourceBuilder

add(), build(), isCancelled(), setCancelled()

Footer logo


WorkspaceResourceReader

Class WorkspaceResourceReader

This class is used to collect the properties for a resource. It is used by the 'Export ProvideX Properties' wizard.

Build Information

Forcelinenumbers false

Inherits

AbstractResourceReader

Properties

No Properties

Methods

FUNCTION readResource(fullPath$)
Returns A reference to a PvxWorkspaceResource

Methods inherited from: AbstractResourceReader

readResource()

Footer logo


Overview

The ProvideX Plug-in

The ProvideX Plug-in for Eclipse has been designed to provide an environment that integrates into the existing Eclipse framework and extends that infrastructure to ProvideX developers. This plug-in automatically converts tokenized ProvideX programs into text files and captures any additional control information (passwords, owner codes, and flags) as part of the conversion process. Once a program has been converted into text it can be used with many of the existing capabilities and other plug-ins available in Eclipse. This includes, but is not limited to, various change control systems such as CVS, Subversion, and MKS. The native version tracking that is part of the Eclipse framework can be used to keep track of localized modifications at the workstation.

The plug-in also allows third party collaboration to enhance or extend the capabilities of the plug-in.

If you are not familiar with the basic Workbench mechanisms, please review the Getting Started chapter of the Eclipse Workbench User Guide.

Next Section: Configure the Plug-in


Configure the Plug-in

Eclipse - Startup

The welcome page is the first page you see when you first launch eclipse. Its purpose is to introduce you to the product. Welcome content typically includes an overview the product and its features, tutorials to guide you through some basic tasks, samples to get you started, etc.

Configure the Workbench

The Plug-in uses an existing ProvideX installation for the executable file that is needed to run the ProvideX Event Manager. The Event Manager is one of the components of the Plug-in that listens for events triggered by actions made in the Eclipse Workbench. These events are communicated to the Event Manager through a TCP/IP connection similar to a NTHOST/NTSLAVE connection that is used in a ProvideX Thin Client environment.

The information required to identify this executable and the port to be used for the communications is configured on the ProvideX Preferences page.

Capture Debug Information

Environment variables used to enable capture of debug information:

PP4E_CT_DEBUG
Start-up for Contributed tools; log file name will be similar to pp4e_CT-Debug-*.txt
PP4E_SC_DEBUG
StyleCheck tool; log file name will be similar to pp4e_SC-*.txt
PP4E_PVXIDE_DEBUG
ProvideX Event Manager; log file name will be similar to pp4e_IDE-*.txt
PP4E_PVXHOST_DEBUG
ProvideX Host debug messages; log file name will be similar to pp4e_Host-*.txt
PP4E_PVXHOST_SHOW
Show the ProvideX Host session on a MS-Windows machine
PP4E_PVXHOST_TRACE
Trace of connection process in PvxHost; log file name will be similar to pp4e_Host-*.txt

The files will be placed into a folder identified by the environment variable TMP or TEMP.

Next Section: Views & Perspectives


Views and Perspectives

If you are not familiar with the concepts of Views and Perspectives, please review the Views chapter of the Eclipse Workbench User Guide.

The Sage 100 Perspective defines the views, menus, and toolbar items that are used to create and manage resources (files and programs) in projects that are part of an application.

ProvideX Builder Preferences

Views

Project Explorer

The Project Explorer view displays the projects in the current workspace and the resources in each of these projects. It is used to manage the projects and resources in the workspace.

Outline

The Outline view displays information about the selected resource in the Project Explorer View. This view will show different information based in the resource that is selected as described below:

ProvideX Data File
The view will display the structural information for the data file including name, record size, external key size, and key definitions.
ProvideX Program
The view will display a list of line labels and variables for the program. If the program is a class definition, the list will also include the public/private properties and functions for the class.

The content of the Outline View can be changed using the buttons on the toolbar or options from the drop-down menu.

Outline View menu options

Problems

The Problems view is used to record warnings and errors that are generated during the build process for ProvideX programs. This view can be configured to show information about all projects in the current workspace or restricted to only show information about the current project or even the current resource.

Console

The Console view is used for messages that are generated by the build process or contributed tools.

Properties

The Properties view shows operating system information about the currently selected resource including physical name, size, and modification date.

Tasks

The Tasks view can be used to keep track of tasks the need to be completed or work that needs to be done to complete a project. A task can be associated with any file loaded in the ProvideX Editor view by right-clicking in the left margin and choosing Add Task... from the pop-up menu.

NOMADS

When the selected resource is a NOMADS library file, the NOMADS view will display a list of the objects stored in the library. An object can be selected from this view to be maintained or tested. Additional information can be found in the NOMADS Integration section of this documentation.

Embedded Dictionary

When the selected resource is a ProvideX data file that has embedded data dictionary information, the Embedded Dictionary view will display a list of the fields defined for the file.

Bookmarks

The Bookmarks view can be used to keep track of bookmarks that have been assigned to a resource in the project. A bookmark can be associated with any file loaded in the ProvideX Editor view by right-clicking in the left margin and choosing Add Bookmark... from the pop-up menu.

Next Section: Link to Application Folder(s)


Link to Application Folder(s)

Eclipse includes the ability to create a "Linked Folder" which is a simple pointer to a folder outside of the current Eclipse workspace. This can be used to create a link to an application folder or to a special work folder.

Once the "Linked Folder" is created, the plug-in can search the contents of the folder or copy files into the folder or sub-folders of the folder.

While there are other methods of linking folders within Eclipse, the steps outlined below illustrate the preferred approach.

The steps below use a dummy project in the current workspace as a container where the linked folders are created.

Warning Eclipse is case sensitive - be consistent with the names used for any files created in Eclipse projects.

Create Project

If you do not already have a dummy project in the current workspace, the following steps describe how to create one.

  1. Select the menu item New > Project... to start the wizard.
  2. Expand the General category and select Project and press [Next] to create a generic project for the linked folders

    New project wizard

  3. Enter a unique name, such as zzLinkdedFolder, that will be easy to identify.
  4. Press [Finish] to complete the creation of the project.

Create a Linked Folder

STOP Once the linked folder has been created, it cannot be changed to reference a different application folder. A new linked folder must be created for each application folder to be referenced.
  1. Right click on the dummy project and choose New > Other... from the pop-up menu.
  2. Now choose the General > Folder wizard and press [Next >].

    New project wizard

  3. Enter a unique name for the folder that is derived from the application and version to make it easy to identify later, such as Sage100Standard2020.
  4. Press [Advanced>>] and select "Link to alternate location (Linked Folder)"

    New project wizard

  5. Press [Browse...] and select the application folder to be linked to the Eclipse project.
    Warning Be careful when selecting an application folder - the folder structure of the Eclipse project will be recreated in the selected application folder.
  6. Press [Finish] to complete the creation of the linked folder.

Next Section: ProvideX Project


ProvideX Project

All ProvideX projects have a common structure with several folders and files that must exist for the plug-in to recognize and work with the project.

Folder Structure

A ProvideX project will include two sub-folders:

Source Folder

All source files for the project will be placed in the source folder.

The default name used for this folder is src; this value can be overridden when creating a new ProvideX project or adding ProvideX to an existing project.

Output Folder

The compiled version of the source files are placed in the output folder.

This folder will be created, if necessary, when building (or compiling) the source files. The sub-folder structure of this folder will mirror the sub-folder structure of the source folder. When using a version control system, do not check in this folder.

The default name for the output folder is compiled; this value can be overridden when creating a new ProvideX project or adding ProvideX to an existing project.

Other Files

Every project will have several other files in the root folder of the project; not all of the files are required.

.project

This is an Eclipse control file used to describe information about the project and is created automatically when creating a new ProvideX project or adding ProvideX to an existing project.

This file is required and should be checked in to a version control system.

project.BuildTagInfo.properties

This is a special file used by the ProvideX plug-in to save properties for each file in the project. This file will be created and managed by the ProvideX plug-in when the 'Load/Save resource properties in "project.BuildTagInfo.properties" file' Build Options preference is enabled.

This file is optional and should be checked in to a version control system.

project.properties

This is a special file used by the ProvideX plug-in to set default and override values for common file properties and project preferences.

This file is optional and should be checked in to a version control system.

PVXProjectName.INI

This file is created by the wizard used to create a ProvideX project or tp add ProvideX to an existing project. The ProjectName part of this file name will be replaced with the actual name of the project.

This file is required and should be checked in to a version control system.

Next Section: ProvideX Editor


ProvideX Editor

The ProvideX Editor is an advanced text editor with dedicated features for ProvideX source code development. The editor is tightly integrated with the ProvideX Outline view. This view changes as the structure of the ProvideX source code changes.

There are many features of this editor that make developing ProvideX programs much easier and faster. Many of these features can be controlled through the settings on the editor preference pages.

Syntax Color and Style

The Editor provides configurable syntax highlighting. The following ProvideX elements are rendered in unique colors and text styles (bold, italic, etc):

  • Comments
  • Directives
  • Line Labels
  • Literals
  • Mnemonics
  • Operators
  • System Functions
  • System Variables

Content Assist

While editing a file in the ProvideX editor there are several triggers that will activate content assist.

For example, below is the a completion proposal and the context information for the DIALOGUE mnemonic that displayed automatically after a short pause when entering the code. The arrow keys can be used to move through the list of proposals. The list will be adjusted as the program code is entered, to show the items that match the information already entered.

An argument completion proposal is also available for System Functions, Directives, and Mnemonics. As you type, the current argument will be highlighted in bold.

The content assist window will also appear with a list of the Attributes, Functions, and Line Labels declared in the current ProvideX class or program

Context Information

The context information displayed along side the completion proposals above for ProvideX Directives, System Functions, System Variables and Mnemonics are available at any time in the editor by simply highlighting the keyword and hovering over it.

Block Comments

It is very easy to comment a block of code in the ProvideX Editor. There are two methods that can be used...

C-Style Block Comment
This approach can be used when the block of code (or other information) should not appear in the compiled program.

When the program is loaded into memory and listed, there will be a gap in the line number sequence that matches the lines that are in this block comment.

Pop-up Menu option 'Add Comment (REM)'

This approach can be used when the block of code (or other information) should be kept in the compiled program. Simply select the lines to be included in the block of comments, press the right mouse button to access the pop-up menu, and select the option 'Add Comment (REM)'.

When the program is loaded into memory and listed, the lines that are in this block of comments will be included.

Strip Line Numbers

Many older application programs were written using line numbers. When these programs are imported into a new project using the ProvideX Plug-in for Eclipse, the line numbers would probably be kept to make the transition easier.

If, at a later time, it is decided that the line numbers are no longer required in the source file, they can be easily removed using the Editor pop-up menu option 'Strip Line Numbers'. The settings in the 'Import / Convert' Preference page are used to control this process; these preferences are discussed in more detail in the "Preferences" section of this documentation.

Next Section: User Keyword Categories


User Keyword Categories

Overview

The plug-in has a feature to enable highlighting keywords in a source file when displayed in the ProvideX Editor. These keywords have been defined in control files shipped with plug-in and are not be easily modified by the user.

The plug-in will check in the same folder as contributed tools and extensions for user-defined keyword categories and will fall-back to the root folder of the current workspace.

info We recommend the keyword category files be placed into the folder identified for contributed tools and extensions. This will enable the same definitions to be used by multiple workspaces.

ProvideX Contributed Extensions / Tools Preferences

File: keywordcats.properties

This file defines one or more keyword categories. The comment lines beginning with a ' # ' character and any blank lines in the file will be ignored. Each of the remaining lines must define a new keyword category. Each category must have a unique name and a unique property file which is used to define the keywords for the category.

The key for each line in this properties file is the unique name for a keyword category. The value is list of characteristics separated by semicolons.

Property File
Name of the property file used to define the keywords in the category
Icon File Path
The relative path to an icon file contained within the plug-in distribution. The icon will appear in any completion list matching a keyword in the category.
Text Attributes
The remaining six items in the list are text attributes to be used when a keyword in the category is displayed in the editor.
  1. Keyword displayed as bold text (true, false)
  2. Keyword displayed as italic text (true, false)
  3. RGB text color (R-G-B); each value must be three characters in length and padded on left with zeroes
  4. RGB background color (R-G-B); each value must be three characters in length and padded on left with zeroes
  5. Keyword displayed as strike-through text (true, false)
  6. Keyword displayed as underlined text (true, false)

Sample keywordcats.properties

# Sample Keyword Categories File
# ----------------------------------------------------------------------------------------------------------
# UniqueKey=PropertyFile          ;IconFilePath              ;________________TextAttributes________________
#                                                            ;Bold;Ital ;TextColor  ;BkgdColor  ;Strk ;ULine
# ----------------------------------------------------------------------------------------------------------
MyConstants=myconstants.properties;$nl$/icons/masIconBlue.gif;true;false;064-128-016;200-200-200;false;false

Keyword Category File

This file defines the keywords for a category. The comment lines beginning with a ' # ' character and any blank lines in the file will be ignored. Each of the remaining lines must define a new keyword such as a variable used as a constant or a method name.

The key for each line in this properties file is a unique keyword in the category. The value is the text to appear in the help tip when a user hovers over the keyword.

Sample Category Properties File

# Sample Categories File
# ----------------------------------------------------------------------------------------------------------
# KeyWord=Help/Tip text
# ----------------------------------------------------------------------------------------------------------
statCLOSED$=Order status code 'Closed'
statNONE$=Order status code 'None'
statOPEN$=Order status code 'Open'

Next Section: Project-Specific Properties - Properties for Project


Properties for Project

Each project has a collection of property pages to allow override of many of the system defaults. One of these property pages shows the ProvideX-specific information about the project including the location of:

  • the source and compiled folders
  • the ProvideX executable to used when building code for the project
Properties for project

Folder Locations

Path
The relative path to the project in the current workspace.
Saved Project Location
When the information on the properties page is updated, this value will be updated to be the full path to the project location on the machine. This value is managed by the plug-in and cannot be changed by the user.
Absolute input directory
The full path to the 'src' folder for the project. This is usually a sub-folder of the project location.
Absolute output directory
The full path to the 'compiled' folder for the project. This is usually a sub-folder of the project location.

ProvideX Executable

ProvideX Executable
The full path to the ProvideX executable to be used to build the programs for this project. This will default to the same executable as the workbench.
Reset Executable
This option will only be enabled when the ProvideX executable is not using the same executable as the workbench. Simply check this option and click the 'Apply' button to force the executable to be reset. This may take a few minutes to complete since the plug-in must check and update each file in the project.

Other Options

Password
The password is used as the default for all programs in the project; override this value on the property page for a program.
Owner Code
The owner code is used as the default for all programs in the project; override this value on the property page for a program.
Flags
The flags are used as the default for all programs in the project; override this value on the property page for a program.
Force default folders for Inout/Output directories
The values for the Input/Output folders will be reset based on the current location of the project when the 'Apply' button is clicked.

Next Section: Project-Specific Properties - Property Files


Property Files

Project

A simple text file ( project.properties ) can be created in the root folder of each project to specify properties (or preferences) to be used by contributed tools or to override a Eclipse preference or project property setting.

Workspace

A simple text file ( workspace.properties ) can be created in the root folder of the Workspace to specify properties (or preferences) to be used when a property file has been defined for a project.

Info Any property value that represents an operating system path must use '/' character instead of '\'.

Project Properties

AltExe_EnvironmentPropertyFile
Set the name of a properties file containing name/value pairs to use to set environment variables when initializing the operating system process running the alternate executable to build files.
Info If the filename has no path, will look for the file in the project root folder. If it is not found, this property will be ignored.
AltExe_DebugShowEnvironmentData
Set to 'true' or '1' to show the environment data when option to show debug information is enabled. Otherwise, do not include in the project properties file or set to 'false' or '0' to not display this information. The default is to not display this information.
ForceDestinationName
Override the destination name for a resource with a value that is based on the name of the source file.
forceResource.<Filename>
Assign a BOOLEAN value to force the file to be handled as a resource - do not attempt to compile the file.
forceResourceDir.<ProjectPathToFile>
Assign a BOOLEAN value to force all files in the specified folder to be handled as resources - do not attempt to compile any of the files in the folder.
LogErrorScan
Create a log file for any messages generated by the 'ErrorScan' phase of the build process.
NOMADS_AltExe
A full path to a ProvideX executable to be used for all NOMADS sessions launched for a resource in the project; (Use "/" characters in the path). The path will be verified to be a valid ProvideX executable before it is used. If the validation fails, the first executable found from the following list will be used:
  • NOMADS executable for the workspace
  • ProvideX executable for the project
  • ProvideX executable used by the workbench
NOMADS_ExtDictDir
A folder outside of the project workspace to be used as the location of the ProvideX data dictionary files (Use "/" characters in the path). The file 'PROVIDEX.DDF' must exist in this folder, otherwise, the value of this property will not be used.
NOMADS_xml_export
Enable the prototype feature to create XML files from NOMADS library files.
overrideProperty.pathPreference
Full path to an alternate ProvideX executable to use for actions performed for files in the project/workspace (Use "/" characters in the path)
Info Any contributed tools triggered as pre/post process events for the build process will execute in the ProvideX environment associated with the workbench.
SetSysParamAI
set the Auto-Increment value; any value outside of the range 1 - 25 will be ignored
StripLeadingWhiteSpace
Strip all leading white space (TABs and spaces) when joining the lines from the source file to create a program line; this may introduce errors in compiled programs if there is not a space before the line continuation character at the end of the source line.
UseLineNumberIncFromAI
set to any value to override the Line Number Increment builder preference and force the use of the 'AI' system parameter value

Project-specific properties file

Preferences

The project/workspace specific properties files can append to string preferences, override the current value of a boolean or string preference, or set a new default to be used for a boolean or string preference.

Append to Preference Value

To append to the value of a string preference, prefix the internal name for the preference with 'appendPreferenceS' and assign a value or list of values to add to the current value of the system preference.

Override Preference

To override the value of a preference, prefix the internal name for the preference with 'overridePreferenceB' or 'overridePreferenceS', depending on the data type of the preference, and assign the new value or override the current value of the system preference.

A Boolean preference can be set to either true or false while a String preference is set to a text value based on the definition of the preference.

Set Default for a Preference

To define the default, prefix the internal name for the preference with 'defaultPreferenceB' or 'defaultPreferenceS' depending on the data type of the preference.

Info If the preference has already been set, or is changed later, this default value will not be used.

Preferences: Keywords

The values of many preferences can be set in either a project or workspace properties file using the keywords below except where highlighted.

Appearance Options
ID | Type | Description
P_SAVE_WINDOW_POSITION | Boolean | When this option is enabled, the window position of contributed tools window will be saved. ** Use this preference only in the Workspace Properties File. **
Builder Options
ID | Type | Description
_AddSourceFileExt | String | Always add the source file extension when importing/converting files. ** Use this preference only in the Workspace Properties File. **
_AltStartUp | String | The full path the the alternate startup program used to initialize the environment; _UseStartUp must be set to true to enable this option.
_AutoConvertPrograms | Boolean | Automatically convert ProvideX programs to text
_BtiEnable | Boolean | Load/Save resource properties in a project BuildTagInfo properties file
_BuildCheckStructure | Boolean | Check logical structure during build
_BuildMaintainCase | Boolean | Allow mixed case for variable names and line labels
_CheckBinaryDataInFileHeader | Boolean | Check file header (first 512 characters) for non-ASCII character(s)
_CommonResourceFileExtensions | String | A space separated list of file extensions used to identify common resource files for project
_DisableCstyleComments | Boolean | Disable C-Style comments
_ForceRebuildOfResourceFiles | Boolean | Force rebuild of files marked as resource
_IgnoreFullBuildAtStartup | Boolean | Ignore full build request triggered as Eclipse is starting
_ProgramPasswordList | String | A space-separated list of passwords to use when attempting to convert a protected program
_ShowSizeWarning | Boolean | Show program 64K size warning
_SimpleScanDuplicateNames | Boolean | Scan source during build process to identify duplicate function/variable declarations that may cause an Error 24 at run-time
_StringLiteralContinue | Boolean | Mark all string literals that span multiple lines with a Style Check warning
_StripSourceExtension | Boolean | Strip 'default source file extension' from output filename
_UseMASBuildOne | Boolean | Enable access to build process extensions for Sage 100
_UseStartUp | Boolean | Allow build process to use an alternate startup program to initialize the environment
P_BUILD_DATAFILES | Boolean | Build process will copy data files from source folder to compiled folder
P_BUILD_FILES_NO_EXT | Boolean | Build process will attempt to build files with no file extension
P_BUILD_RESOURCES | Boolean | Build process will copy files marked as resources from source folder to compiled folder
Contributed Extensions / Tools
ID | Type | Description
_extObserverEnable | Boolean | Enable external observers
_extObserverUserDir | String | Directory for user-defined observers
_extObserver_ClassName | Boolean | force enable/disable of a contributed tool, where ClassName matches the class name specified in the classes.txt file for either the user-defined or built-in contributed extensions / tools. The classes for the built-in extensions / tools include: set_copyright_year, set_mod_timestamp, simpleStyleCheck
Contributed Tools Startup Process
ID | Type | Description
AltInit.InitSageSessionObject | Boolean | Initialize Sage Session object as part or process startup for Workbench actions; this preference does not affect the startup process for contributed tools ** Use this preference only in the Workspace Properties File. **
Editor Options
ID | Type | Description
_bCodeFolding | Boolean | Enable code folding
_bCP_ExternalKeywords | Boolean | Completion Proposal: Enable load of external keyword categories
_bDC_LiteralWordOnly | Boolean | Double-Click in a literal - select current word instead of entire content
_KeywordConversion | String | Keyword case conversion rule lower ... Force lower case upper ... Force upper case
_KC_ConvertLabels | Boolean | Also convert program line labels during Keyword conversion process
Import / Convert
ID | Type | Description
_AddSourceFileExt | Boolean | Always add source file extension to source file when converting ProvideX programs to text
_ProgramPasswordList | String | A space-separated list of passwords to use when attempting to convert a protected program
P_IMPORT_SRCFILE_EXTENSION | String | A space separated list of source file extensions; the first file extension in the list will be used as the default.
_SuppressDatafilePassword | Boolean | Suppress password request when processing a new data file
NOMADS
ID | Type | Description
_NOMADS_Default_Suffix | Boolean | Default suffix (file extension) for NOMADS library files
Plug-in Debug
ID | Type | Description
_bDebug | Boolean | Show debug information
_bDebugChkVer | Boolean | Show output of 'ProvideX Version Check' in Console View
_bDebugLogToConsole | Boolean | Write debug messages to console instead of PvxProgress view
_bDebugVerbosityLevel | String | Debug verbosity level - the higher the number the more information will be sent to the console 1 ... Minimal 2 ... Medium 9 ... Maximum
_bDebugProcessMessages | Boolean | Write process status messages to Console View (and debug log when debug is enabled)
_ibDebug_SC_DumpInfo | Boolean | Write Style Check Errors/Warnings data to console

The following sample properties file shows how to use these keywords.

# Force values for preferences
# makes the Eclipse environment for the project consistent for all users
overridePreferenceB._bDebug=false
overridePreferenceB._BtiEnable=false
overridePreferenceB._BuildMaintainCase=true
overridePreferenceB._CheckBinaryDataInFileHeader=true

# Add to list of file extensions for resource files
appendPreferenceS._CommonResourceFileExtensions=bat bin cab cat chm cmd csv log manifest xls xml xsd zip

# Force specific contributed tools to be enabled or disabled
# (prefix contributed tool class name with an underscore)
overridePreferenceB._extObserver_masStyleCheck=false
overridePreferenceB._extObserver_simpleStyleCheck=true

# Additional file extensions to identify NOMADS libraries
appendPreferenceS._NOMADS_Default_Suffix=M4L LIB

# Force alternate startup program to initialize the build environment
overridePreferenceB._UseStartUp=true
overridePreferenceS._AltStartUp=C:/Dev/Work/ContribTools/CustABL/alt_startup.pvx

Next Section: Preferences - ProvideX Event Manager


Preferences - Event Manager

The ProvideX Plug-in for Eclipse has a number of components that work together. One of these components is the ProvideX Event Manager which provides the connection to the ProvideX application environment. It runs in the background to handle events that are triggered by user actions in the Eclipse Workbench.

The ProvideX Preference page is used to configure the version of ProvideX that will be used by the ProvideX Event Manager and the port that will be used for communicating with Eclipse.

This ProvideX executable will also be used as the default for every new ProvideX project that is created in the current workspace. The ProvideX executable for a project can be changed when the project is created or at any time afterwards through the project properties page.

Configure Event Manager

  1. Select the menu item Goto workbench preferences Window > Preferences... to open the workbench preferences.

  2. Select the Goto the ProvideX Configuration preference page ProvideX preference page. ProvideX Preferences
  3. Set the path to the ProvideX executable by clicking the Browse... button and selecting a valid ProvideX executable to use.
    info The selected ProvideX executable must have a valid activation (at least a 2 user v7 base developer license) before it will be allowed; the activation is verified when an executable is selected and will not be used if this validation fails.

  4. Set the port to be used for the Listener port.
    info The ProvideX plug-in for Eclipse uses a NTHOST-like connection to a process where a listener program is started. The listener program waits for Eclipse to send information about the next event to be processed. The listener will then start the execution of a helper application that will perform the requested task or perform the task itself.

Why is my ProvideX executable not accepted?

The plug-in will not allow a ProvideX executable when:

  • The license for the executable is not a developer license
  • The license for the executable is not at least a v7 base
  • A START_UP program (or user-defined windows device driver) exists and replaces the base window

Next Section: Preferences - Appearance


Preferences - Appearance

The Appearance preference page is used to control the appearance of all ProvideX applications (contributed tools, etc).

Select the Goto the ProvideX Builder preference page ProvideX > Appearance preference page.

Settings

Default text plane font
The font to be used when displaying text on the text plane in a ProvideX session.
Default graphic font
The font to be used as the default on all graphical controls in a ProvideX session.
Default minimum font size
The minimum font size to use for the text plane and graphical fonts for a JavX session.
Run programs inside Eclipse Views
Open a new view (below the editor) for each new ProvideX application. When not set, the application will open in a new window on top of the Eclipse session.
Show internal window borders
Show the borders of all windows in a ProvideX application session when running inside an Eclipse view.
Display Debug messages (during View start-up) to Console
Display debug messages associated with the initialization of each new host process to the console view.
Save position of windows for contributed tools
Save the new position of the window for a contributed tool if it is moved; this information is stored in the workspace properties file.
info When enabled, the current virtual desktop size will be saved into the workspace properties file during plug-in startup.
Report client version
The version of ProvideX captured when starting the executable associated with the workbench. This value is display only.

Next Section: Preferences - Builder


Preferences - Builder

The ProvideX Builder is responsible for compiling (converting) a ProvideX source file into a tokenized ProvideX program file. A number of options can be assigned to the new program as part of this process - each program can have different options that are managed through the properties page for the program source file.

The Builder Preferences are used to set the default values to be used for any new program created in a project in the current workspace and to also set the configuration options that control which files to compile.

Select the Goto the ProvideX Builder preference page ProvideX > Builder preference page.

ProvideX Builder Preferences

ProvideX Program Option Defaults

These options will be used as the defaults for any new program that is added to a project in the current workspace. These values can be changed through the properties page associated with the source file for the program.

Password
The password is used to encrypt the tokenized program. Any attempt to list the program will fail unless the user knows the password associated with the program.
Owner Code
Optional owner code to be used by registered application developers to restrict access to these application programs to only those environments that have been configured with an activation key that includes the same owner code.
info To enable use of the owner code, the ProvideX executable for the workbench/project must be configured with an activation key that includes the same owner code.
Flags
Optional package flags to be used by registered application developers to create application features that can be restricted to environments that have been configured with an activation key that includes the same package flags.

Builder Configuration Options

These options are used to control which resources the builder will process. A resource must be processed by the builder to get copied to the output folder for the project.

Only compile files associated with ProvideX Editor
The file extension is used to associate the ProvideX Editor to a resource. This option is used to restrict the builder from processing any other files.
Compile Files that have no File extension
Since the file extension is used to associate files to the ProvideX Editor, this option is used to identify how to handle the files without a file extension. If this option is not set, these files will be skipped.
Copy ProvideX Data Files
When this option is set, the builder will copy any ProvideX Data Files found in a project to the output folder.
Copy Resources
When this option is set, the builder will copy any other resource(s) (not covered by the previous options) found in a project to the output folder.

Next Section: Builder Options


Preferences - Builder Options

These options will adjust the build process to better fit with the work flow and processes used by each developer.

Select the Goto the ProvideX Builder preference page ProvideX > Builder > Options preference page.

ProvideX Builder Options Preferences

Builder Options

Automatically reformat on Save
The source file will be reformatted (LIST EDIT format) whenever it is updated.
Check logical structure during build
This option will enable the 'SS' system parameter (Check Structure on Save); ProvideX will check the logical integrity of the decision/loop structures in the program and report warnings for any issues that are discovered.
Allow mixed case for variable names and line labels ('MC' system parameter)
When this option is set, all variables and line labels in the compiled program file will remain the same as they are found in the source file.
Disable C-style block comments
The ProvideX Builder supports the use of C-style block comments

/*
 * this is a C-style block comment
 * that can span a number of lines in the source file
 */

The builder will automatically remove these comments from the work file that is used to create the compiled program file. This option can be used to disable the use of C-style block comments; any C-style block comments found in a source file will not get removed by the build pre-process. This may lead to errors in the compiled program.
Show program 64K size warning
Enable the 64K size warning when building a program; this may be useful when program sizes need to be kept below 64K.
Assign/Increment line numbers based on the system parameter 'AI'
This option will cause the builder to use the line number increment specified by the 'AI' system parameter. When this option is not enabled, the line number increment will be one and will correspond to the line number from the source file.
Strip 'default source file extension'
When a source file is compiled to a compiled program, the default "source file extension" will be stripped from the name of the output file.
Default extension for compiled programs
If all compiled ProvideX programs have the same file extension (in your application), this option can be used to force that extension for all programs that are built.
Program (equivalent to 'start_up') to initialize build environment
Many developers use special system parameter settings when building applications; this option provides a mechanism to allow these developers to specify the program to be used to initialize the build environment to fit their needs.
Full path to initialization program
When the previous option is checked, this option identifies the ProvideX program to be used to initialize the build environment; this program must be outside of the workspace for the plug-in session.
Load/Save resource properties in "project.BuildTagInfo.properties" file
Many version control systems are not aware of the meta-data used by Eclipse to track the properties of each resource in a project. This control file is used by the ProvideX plug-in to store this information. The file can be updated into the version control system. Some developers do not use the extra properties associated with the resources in a ProvideX project, and therefore may not require this data file.
info Previous versions of the plug-in stored this information in a ProvideX keyed file "project.BuildtagInfo.pvk". If this file exists, it will be converted to the properties file.
Enable access to build process extensions for Sage 100
The Sage 100 plug-in extends the ProvideX plug-in to add extra features to assist developers who are creating or modifying Sage 100 applications. This option is enabled by the Sage 100 plug-in.
Automatically convert ProvideX programs to text
This preference will default to "Enabled" to maintain compatibility with earlier releases.
info The MAS Plug-in will disable this preference when a new workspace is created or the MAS menu option is used to "Set Preference Defaults/Values".
Mark all string literals that span multiple lines with a warning
Each line that includes the start of a string literal that continues to the next line without a closing quote will be marked as a warning in the "Problem" view.
Common file extensions for resources
A space-separated list of file extensions used to identify files to be flagged as resources. The default list of file extensions is:
bmp conf config css doc docx dll exe gif hlp htm html ini iss jpg js mdb ocx pdb pdf png properties pthm pvs rpt sh svc tlb
info Set the property 'appendPreferenceS._CommonResourceFileExtensions' with a list of additional file extensions to include in this list. This property can be set in the project-specific properties file or the workspace-specific file.
Force rebuild of files marked as resources
All files marked as resources will be rebuilt during build process; when option is not set, files marked as resource are skipped during the build process.
Skip copy of programs with errors to linked folders
The compiled version of a program will not get copied to any linked folders if the program has errors.
Ignore FULL Build for existing projects triggered when starting Eclipse
Eclipse will sometimes trigger a full build in a project at startup for no obvious reason; enable this option to ignore these events.
Scan for duplicate function/variable names (Error 24)
Enable this preference to scan for duplicate function and variable declarations in a class \ definition to reduce chance of error 24 when instantiating the class at run-time.

Next Section: Contributed Extensions / Tools


Preferences - Contributed Extensions / Tools

Select the Goto the ProvideX Builder preference page ProvideX > Contributed Extensions / Tools preference page.

ProvideX Contributed Extensions / Tools Preferences

Standard Options

The ProvideX plug-in includes a feature that allows developers to write their own tools or extensions that can be used to extend the features of the Plug-in.

Directory for User Keyword Categories and Observers
This option is used to specify the directory outside of the Eclipse install where the user files are located. These files include:
  • User Keyword Categories definitions (For additional information, see User Keyword Categories)
  • User-defined Contributed tools and extensions
    info If the directory does not contain a file with the name 'classes.txt' containing the registration information, no observers will be loaded (For additional information, see Register User-Defined Observers)

  • Any NEW style check rules created by the user (For additional information, see Style Check - Configuration)
Enable external observers
This option tells the ProvideX plug-in to load all observers for the registered extensions and contributed tools.

All extensions and some contributed tools will listen for specific events from the Workbench and will execute only when these events occur. Many extensions add logic to the standard ProvideX build process and can be invoked before, after or before and after the standard build process. During the ProvideX Event Manager startup, an option will be added to this preference page for each registered extension or contributed tool.

Built-in Observers

The ProvideX plug-in includes several standard extensions and contributed tools.

Built-in ProvideX Contributed Extensions / Tools Preferences
Sage 100 - Style Check
This option is for a contributed tool that will also appear on the ProvideX | Contributed Tools menu and can be accessed from there. This tool has also registered itself as a builder extension. The option on this page is used to enable that part of the contributed tool - this option will NOT affect the operation of the tool from the contributed tools menu option.

This contributed tool is included with the 'Sage 100 Plug-in' and provides a rules-based source code style check.

Convert ProvideX keyed files to/from XML
This option is for a contributed tool that will also appear on the ProvideX | Contributed Tools menu and can be accessed from there. It has also registered itself as a builder extension and this option is used to enable that part of the contributed tool - this option will NOT affect the operation of the tool from the contributed tools menu option.

This contributed tool will convert ProvideX keyed files to/from XML.

Substitute modification year of source file for 'Copyright-year' tag
This is an extension that will replace the text '%(Copyright-year)%' within the first 1000 characters of the source file with the current year.

Set modification time stamp of output file to be the same as source file
This is an extension that has registered itself as a post-process builder extension that will change the modification time stamp of the output file to match the time stamp of the source file.

Simple rules-based Style Check
This option is for a contributed tool that will also appear on the ProvideX | Contributed Tools menu and can be accessed from there. This tool has also registered itself as a builder extension. The option on this page is used to enable that part of the contributed tool - this option will NOT affect the operation of the tool from the contributed tools menu option.

This contributed tool provides a simple rules-based source code style check.

Automatic keyword conversion in build process
This an extension that has registered itself as both a pre-process and post-process builder extension. It will perform keyword case conversion of the source file and once the build has completed, will save the modified source file.

Strip trailing whitespace (during build)
This an extension that has registered itself as both a pre-process and post-process builder extension. It will strip trailing whitespace from all lines of the source file and once the build has completed, will save the modified source file.

Register User-Defined Observers

A developer can write an extension (or contributed tool) following the steps described later in this documentation and place the programs into a directory on each workstation. This directory must also contain a file with the name 'classes.txt' to identify the programs to be registered with the plug-in.

# this file contains the names of my user-defined Observer classes
eventName=del_dupe_remarks
eventName=showtext
# must have a line after last observer definition

As this example shows, the format of each line is:
eventName=<NameOfClass>

where <NameOfClass> is replaced by the name of the class definition to be loaded.

Manage User-Defined Observers

Once the ProvideX Event Manager has been started, the observers that have registered themselves as pre/post process observers will appear on this preference page. The order of the observers on this preference page is not predictable.

User Defined ProvideX Contributed Extensions / Tools Preferences
Remove lines with duplicate line numbers
This extension has registered itself as a pre-process event listener for the build process.

It will scan the source file before it is passed to the builder looking for lines with duplicate line numbers and will create a new temporary to pass to the builder with the duplicate lines removed. The source code can be reviewed to see how easily this can be accomplished.

Show message in Console
This extension has registered itself as a pre-process and post-process event listener.

This is a very simple extension; the source code can be reviewed to see how easily this can be accomplished. When this extension is enabled, a message will be sent to the console during the pre-process and post-process for every event.

ShowText: A pre-process for FULL_BUILD/FULL_BUILD_START
ShowText: A post-process for FULL_BUILD/FULL_BUILD_START

Builder running

Compile Program: \DemoApp\src\prog\client.mnt.pvt
ShowText: A pre-process for INCREMENTAL_BUILD/BUILDONE
... Output File: ../compiled/prog/client.mnt
Build process: OK
ShowText: A post-process for INCREMENTAL_BUILD/BUILDONE

Build done
ShowText: A pre-process for FULL_BUILD/FULL_BUILD_END
ShowText: A post-process for FULL_BUILD/FULL_BUILD_END
Build time: 874
ShowText: A pre-process for PREFERENCE_CHANGE/_extObserver_masStyleCheck changed
ShowText: A post-process for PREFERENCE_CHANGE/_extObserver_masStyleCheck changed
ShowText: A pre-process for PREFERENCE_PAGE_BUTTON/performOk
ShowText: A post-process for PREFERENCE_PAGE_BUTTON/performOk

Next Section: Editor


Preferences - Editor

The Editor Preferences are used to control the features of the ProvideX Editor.

Select the Goto the ProvideX Builder preference page ProvideX > Editor preference page.

ProvideX Editor Preferences

The Editor provides configurable syntax highlighting. This preference page is used to control the colors and styles used for the syntax highlighting.

Next Section: Editor Options


Preferences - Editor Options

The Editor > Options preference page enables control of additional features of the ProvideX Editor.

Select the Goto the ProvideX Builder preference page ProvideX > Editor > Options preference page.

ProvideX Editor Options preference page

Smart auto Indent
When this option is enabled, the ProvideX Editor will automatically indent lines inside loop structures and IF statements.
Smart paste
When this option is enabled, the ProvideX Editor will automatically maintain indentation for the new lines that are pasted.
Smart auto complete braces
When this option is enabled, the ProvideX Editor will automatically add a second closing brace bracket when the user presses ENTER on a line that has an open brace bracket.
Keyword conversion rule
Select the case to be forced for keywords when the contributed tool is executed from the pop-up menu in the Editor view.
Also convert program line labels during Keyword conversion process
Enable this option to also convert the program line labels to the same case as the keywords. If this option is not enabled, program line labels will not change.
Enable code folding
When this option is enabled, the ProvideX Editor will mark the blocks in a ProvideX source file so each block can be collapsed (folded).
Completion Proposals - Enable load of external keyword categories
When the plug-in is loading, it will look in the same folder as user defined contributed tools for keyword category files and will load the definitions into memory.
Double-Click in a literal - select current word instead of entire content
When this option is enabled, the ProvideX Editor will select the current word instead of the entire content of a string literal.

Next Section: Editor Templates


Preferences - Editor Templates

Templates are sections of code that occur frequently enough that you would like to be able to insert them with a few keystrokes. The function that is to insert the sections of code is known as Content Assist; the sections of code that are inserted are known as templates.

Select the Goto the ProvideX Builder preference page ProvideX > Editor > Template Editor preference page.

ProvideX Editor Template preferences page

To input an existing Content Assist template into a file, such as one for an if statement, type the initial character ("i" in this case), then press Ctrl+Space. The templates that begin with that character appear. Double-click on a template to insert it into a file. You can edit existing templates or create new ones on this preference page.

Next Section: Import / Convert


Preferences - Import / Convert

The Import / Convert preference page controls the settings that are used when importing or converting a ProvideX program to a text (source) file. These settings are also used when performing conversion operations on source files (such as stripping line numbers).

Select the Goto the ProvideX Builder preference page ProvideX > Import / Convert preference page.

ProvideX Editor Options preference page

Default source file extension(s)
This is a space (or comma) separated list of file extensions that will be recognized by the Import/Convert process as ProvideX source files. The first file extension in the list will be used as the default source file extension.
Add source file extension to files with no extension
Should the import process add the default source file extension when the source file does not have a file extension? A file extension is required to associate an editor with the source file.
Strip line numbers
Should line numbers be stripped from the ProvideX program during the import process?
Label Prefix
When line numbers are stripped from a program, what should be used as the line number prefix? This value must begin with a letter since line labels must begin with a letter.
Use original line number references
How should line number references be converted when line numbers are stripped from the program? If this option is enabled, the line labels will use the line label prefix followed by the original line number. If this option is not enabled, the line labels will use the line label prefix followed by a simple counter that is incremented by one for each line number reference that is found.
Auto-format (ie. List Edit)
This option is used to force the source code to be saved in a 'LIST EDIT' format. If this option is not enabled, the source code will be in a simple 'LIST' format.
Suppress LET directive
Enable this option to remove the LET directive from the source code during the import process.
Lower case directives
Enable this option to force all directives to be converted to lower case.
Case to be used for variables
Select the case to be used for all variables found in the source file during the import process.
Known passwords for encrypted programs
A list of passwords (separated by spaces) to try when attempting to import encrypted programs. if all known passwords fail, the program will not get converted and will be flagged as a resource.
Always add source file extension when converting compiled ProvideX programs to text
Should the import process add the default source file extension to a file that has been identified as a compiled ProvideX program file (even when the original file already has an extension)? If this option is set, all ProvideX program source files will use the same file extension which will make it much easier to associate an editor with the source file(s).
Suppress data file password request
When a ProvideX data file is encountered during the import process, the user will be prompted to enter a password. This option will disable the prompt.

Next Section: NOMADS


Preferences - NOMADS

The NOMADS preference page is used to set the NOMADS system defaults for all projects in the current workspace.

Select the Goto the ProvideX Builder preference page ProvideX > NOMADS preference page.

System Defaults

Default suffix for NOMADS library files
A space-separated list of file extensions used for library files. The firs entry in the list will be used as the default for any new libraries created in any project in the workspace (e.g., .M4L where all libraries created will be library_name.M4L).

Panel Defaults

Suppress .VAL
Suppresses use of .VAL suffix. Each panel control value is automatically placed into a variable ctl_name.VAL$. For example, a list box defined as LBOX_1 is found in the variable LBOX_1.VAL$ (or LBOX_1$ if .VAL is suppressed)
Column
The column for the top left position of any new panels created
Line
The line for the top left position of any new panels created
Width
The width of any new panels created
Height
The height of any new panels created
Grid Definition
These define minimum increments for the height and location of a control when using the mouse or resize option in the Panel Designer. For example, if set to Full Line, then the height of the control automatically adjusts (snaps) to one line high when drawn and will resize in increments of 1 line (i.e., 2, 3, 4, etc.). Setting the grid to a smaller setting allows for finer control of resizing and movement. Sizing can be overridden from the Edit menu bar option in the Panel Designer.
GUI Style / Effect
Select visual mode that will apply to all controls except where overridden in the library defaults. Default assumes the currently set mnemonic in ProvideX. See also, NOMADS Variables, p.304 (%NOMAD_VISUAL_EFFECT and %NOMAD_VISUAL_OVERRIDE).

Additional Plug-in Defaults

Alternate ProvideX executable to use for NOMADS
The full path to an alternate ProvideX executable; different from one associated with project.
Alternate INI to use for NOMADS
The full path to an INI file to be used when starting a NOMADS session.
External Folder (outside workspace) for NOMADS image files
The full path to a folder that has image files referenced by controls defined for NOMADS panels; this folder will be added to the application prefix list.

Next Section: Plug-in Debug


Preferences - Plug-in Debug

The Plug-in Debug preference page is used to assist the developers with diagnosing issues that arise with the use of the plug-in in different environments. .

Select the Goto the ProvideX Builder preference page ProvideX > Plug-in Debug preference page.

ProvideX Plug-in Debug

If it is necessary for anyone to use this page, the developers will provide the information that is required for the specific situation.

Environment Variables

Environment variables used to enable capture of debug information:

PP4E_CT_DEBUG
Start-up for Contributed tools; log file name will be similar to pp4e_CT-Debug-*.txt
PP4E_SC_DEBUG
StyleCheck tool; log file name will be similar to pp4e_SC-*.txt
PP4E_PVXIDE_DEBUG
ProvideX Event Manager; log file name will be similar to pp4e_IDE-*.txt
PP4E_PVXHOST_DEBUG
ProvideX Host debug messages; log file name will be similar to pp4e_Host-*.txt
PP4E_PVXHOST_SHOW
Show the ProvideX Host session on a MS-Windows machine
PP4E_PVXHOST_TRACE
Trace of connection process in PvxHost; log file name will be similar to pp4e_Host-*.txt

The files will be placed into a folder identified by the environment variable TMP or TEMP.

Next Section: Builder - The Build Process


Builder - The Build Process

Initiate Build Process

There are several ways to initiate the build process... this includes:

  • SAVE in the editor,
  • right click one or more source file(s) in the Navigator view and choose "ProvideX Build" from the pop-up menu,
  • a clean build

The Build Process

In any case, the actual process that occurs is the same...

For each file in the list to build

  1. Execute each registered pre-process observer for the build process
  2. If file is a tokenized ProvideX program, convert to text file; skip remainder or process
  3. Do incremental build for file...
    • Execute build process 'Start-Up' program (if defined)
    • If 'Auto-Format on Save' is set, the source file is reformatted and updated
    • Scan program for errors
    • If no errors are found, build program using 'act_build_one.pvx' program
    • If errors were found (either in scan or during the build), log errors to 'Problem' View
  4. Execute each registered post-process observer for the build process

A Simple Example Observer

The showtext.pvc class is simple observer that will output messages to the console view during the build process. This observer will be triggered during the build pre-process and the build post-process.

The source code for the class can be viewed by clicking on the link.

Reading Source Files

All observer actions that need to read a source file should use the program_reader class as shown in the following sample code:

! Create a new instance of the ProgramReader for the source file
aReader=new("program_reader",theSourceFile$)

while not(aReader'getEOF())
    ! Get the next source file line
    aLine$=aReader'read$()
    ! logic to process the program line
wend
drop object aReader

What should not be attempted by an observer during the build process?

An observer cannot change the original source file - this will trigger a new build process. Any modifications to source files should be implemented in a contributed tool to avoid a run-away build process caused by continuously changing source files.

Next Section: Builder - C-Style Block Comments


Builder - C-Style Block Comments

The ProvideX Builder adds the ability to use C-Style block comments to ProvideX programming. These are special comments that span multiple lines of the source file and are not included as part of the tokenized program. This feature allows more detailed documentation to be placed in the source file(s) without increasing (or affecting) the size of the tokenized program.

Nested Block Comments

The builder allows unlimited nesting of C-Style block comments to be placed in the source file.

Original source file:
Original source code

Now, the lines 8-10 will be placed into a C-style block comment. The block comment on the end of line 3 will be included within this block comment and will not stop it from working.

The logic to set the color of the comments does not understand the nesting of block comments and therefore does not show the nested comment as the builder understands it.

The code that will be excluded from the tokenized program has been highlighted in this example.

Modified source file:
Modified source code

Tokenized program:
Program lines

Block Comments in Line-Numbered Source Files

Allow use of C-style block comments in source files that use line numbers. The begin C-style block comment (/*) and the end C-style block comment (*/) must be part of the standard ProvideX comment line so that it falls within the current source code rules.

Source file:
Line numbered program source file

Tokenized program:
Program lines

Next Section: Include Files


Builder - Include Files

The builder has the ability to process '#include' statements in source files. The statement must be at the beginning of a line and be the only statement on the line. The contents of the include file will replace the line in the source file.

The format of the line is:

#include <IncludeFile>

where <IncludeFile> is a relative path to the include file based on the source directory of the project.

The builder will allow up to 50 include files for each source file; this includes any nested include files.

The following program file and include file:
Program and include file source

will combine to create program:
Program listing

Next Section: Document Tags


Builder - Document Tags

Document tags have been used to store process-specific information in the source files. This allows control information for contributed tools (and other processes) to be included in the source files.

This information can then be more easily integrated with source control tools.

The document tags can be mixed case; the process that uses the tags must be able to handle the tags in any case and even mixed case.

Document Tags - Build Process

The document tags used by the build process are placed near the beginning of the program and are used to automatically update the build properties for the file during the build process. When modifications are made to the properties, these tags are updated with the new information.

The document tags used by the build process are:

@Author
The original author of the program. This can be a system login code or a full name. There is no corresponding property for this tag - it is for documentation only.
@Date
The creation date of the program. There is no corresponding property for this tag - it is for documentation only.
@Flags
Package flags to be assigned to the program during the build process. This option is restricted for use by registered developers.
@ForceLineNumbers
This option will force line numbers to be used when building the program. The allowed values are "true" or "false".
@LineNumberInc
The line number increment to be used when this source file is compiled. This will override the builder options preference page settings.
@OutputFile
The name to be used for the tokenized program.
@Owner
The owner code to be assigned to the program during the build process. This option is restricted for use by registered developers.
@Password
The password to be assigned to the program during the build process.

Document Tags - Contributed Tools

Other document tags can be placed anywhere in the source file - see the documentation for the specific contributed tool using the document tags for additional information.

The ProvideX Docs contributed tool is one contributed tool that used document tags for context information used by the documentation process.

Next Section: Output Folder Properties


Builder - Output Folder

Eclipse includes the ability to create a "Linked Folder" which is a simple pointer to a folder outside of the current Eclipse workspace. This can be used to create a link to an application folder or to a special work folder.

Once the "Linked Folder" is created, it can be associated to the output folder of one or more projects. The builder will then copy any file updated in the output folder to each linked folder maintaining the same sub-folder structure as the project.

While there are other methods of linking folders within Eclipse, the steps outlined below illustrate the preferred approach.

The steps below use a dummy project in the current workspace as a container where the linked folders are created.

Warning Eclipse is case sensitive - be consistent with the names that are used for any files created in Eclipse projects.

Create Project

If you do not already have a dummy project in the current workspace, the following steps describe how to create one.

  1. Select the menu item New > Project... to start the wizard.
  2. Expand the General category and select Project and press [Next] to create a generic project for the linked folders

    New project wizard

  3. Enter a unique name, such as zzLinkdedFolder, that will be easy to identify.
  4. Press [Finish] to complete the creation of the project.

Create a Linked Folder

STOP Once the linked folder has been created, it cannot be changed to reference a different application folder. A new linked folder must be created for each application folder to be referenced.
  1. Right click on the dummy project and choose New > Other... from the pop-up menu.
  2. Now choose the General > Folder wizard and press [Next >].

    New project wizard

  3. Enter a unique name for the folder that is derived from the application and version to make it easy to identify later, such as Sage100Standard2020.
  4. Press [Advanced>>] and select "Link to alternate location (Linked Folder)"

    New project wizard

  5. Press [Browse...] and select the application folder to be linked to the Eclipse project.
    Warning Be careful when selecting an application folder - the folder structure of the Eclipse project will be recreated in the selected application folder.
  6. Press [Finish] to complete the creation of the linked folder.

Link Project to Folder

Now that the "linked folder" has been created, it must be associated with the project that has the application programs/files that need to be copied during the build process.

  1. Expand the Eclipse project to be associated with the linked folder.
  2. Right-click on the output folder (usually named "compiled") and choose "Properties"
  3. Select the ProvideX properties page from the list

    Output folder properties

  4. Press [Search] enter the name of the linked folder in the filter field - do not press ENTER since the filter begins to work as you type.
  5. Choose the linked folder that was just defined (such as Sage100Standard2020) from the list of matching resources and press [OK]

    Choose test folder

  6. The selected resource will be added to the test platforms. Repeat the previous step for each application to be associated with this project.
  7. Press [OK] to complete the process.

Building Resources in Project

When a resource is (re)built in the project it will be copied to the test folder. The folder structure of the project will be recreated (as necessary) within each test folder that has been associated with the project's output folder.

Builder console output

Next Section: NOMADS Integration


NOMADS Integration - Overview

The NOMADS toolkit has been tightly integrated into the plug-in infrastructure. All actions that are available from the stand-alone NOMADS front-end can now be accessed from within the plug-in. The library files are maintained in the project source folder and are automatically updated to the output folder as modifications are made. This ensures that the maintenance of all panels will be updated into the correct location within the project.

The NOMADS Preference Page is used to set the NOMADS System Defaults for the workspace.

Next Section: NOMADS View


NOMADS View

The NOMADS View is the entry point for the integration of the NOMADS toolkit into the plug-in. The complete documentation for NOMADS is available on our web site, or with the ProvideX Reference Manuals plug-in on the ProvideX Plug-in Update Site.

The icons in the upper right corner of the NOMADS view provide access to the various features of the NOMADS toolkit. The drop-down menu can be used to view/access all of the features.

NOMADS view - Menu

The most commonly used actions are available through quick access icons that are to the left of the drop-down menu icon. These icons provide quick access to:

New Object
This action will display a simple dialogue asking for the name and type of the object to create. The NOMADS designer will be started to maintain the new object once this information has been accepted.

NOMADS create new object

Edit Object
Edit the object that is selected in the NOMADS view; if there is no object selected, a warning message will be displayed.

NOMADS edit object

Test Object
Test the object that is selected in the NOMADS view; if there is no object selected, a warning message will be displayed.

NOMADS test object

Library Defaults
Open the standard 'Library Defaults' panel for the current library.

NOMADS Library Defaults

System Defaults
Open the standard 'System Defaults' panel

NOMADS System Defaults

Data Classifications
Open the standard 'Data Classifications' panel

NOMADS Data Classifications

Copy
Copy the selected object in the current library

NOMADS copy object

Delete
Delete the selected object in the current library; there is no confirmation prompt!
Grouping
Assign controls in panel(s) in the current library to a group

NOMADS Group Assignment

Print
Print information fro selected object in the current library

NOMADS Print Panels

Compare
Compare the contents of two library files; will default to the current library

NOMADS Library Compare

Import
Import object definitions from a text file into the current library

NOMADS Library Import

Export
Export selected object definitions from the current library to a text file

NOMADS Library Export

Merge
Merge selected objects from one library to another; the current library is set as the input (source)

NOMADS Library Merge

Search
Access the 'Search / Replace' functionality for objects in the current library

NOMADS Library Search / Replace

Next Section: Dictionary Viewer


Dictionary Viewer

What is it?

This contributed tool shows information about files defined within the selected ProvideX data dictionary. The information that is displayed may not match the embedded dictionary information for the associated physical file(s).

This tool can be used to paste fields from a selected file into the current file that is open in the editor view at the last position of the cursor.

Select ProvideX Dictionary

First, a ProvideX Data Dictionary file (providex.ddf) must be selected; this contributed tool will not create a new data dictionary. Press the 'Open' button to open a file selection dialogue window which will default to the folders in the current project.

File Information

Once a ProvideX Data Dictionary has been selected, the files defined within this dictionary can be viewed.

The selected file can be changed by choosing a new file from the drop-down list or using the navigation arrows next to the "Table" field on the panel.

The current state (ProvideX Data Dictionary File, and selected definition) can be saved by pressing the 'Save' button in the top right corner of the panel. This information will be used the next time the Data Dictionary Viewer is started. The 'Clear' button can be used to clear the saved information and close the current ProvideX Data Dictionary file.

Paste Field Information

Once the correct file has been found, the columns within the file definition can] be selected and then pasted into the file loaded in the editor view.

Select columns to paste into editor

Once the columns have been selected, press the "Paste" button to begin the process of pasting the information into the editor view. There are several options that can affect the how the selected fields are pasted. All of the fields can be prefixed by a 'Record Prefix' and one of several different separator characters can be placed after each field.

Set options for paste action

Next Section: Inheritance Analysis


Message Library Viewer

What is it?

This contributed tool shows messages defined within the selected ProvideX Message Library. This tool can be used to paste a selected message into the current file that is open in the editor view at the last position of the cursor.

This tool can also be used to create a new message library and maintain the messages in an existing message library.

Select ProvideX Message Library

First, a ProvideX Message Library file must be selected or created. Press the 'Open' button to open a file selection dialogue window which will default to the folders in the current project.

View Messages

Once a ProvideX Message Library has been selected, the messages defined within this library can be viewed.

Message Library Viewer

The current state (message library, filter, and selected message) can be saved by pressing the 'Save' button in the top right corner of the panel. This information will be used the next time the Message Library Viewer is started. The 'Clear' button can be used to clear the saved information and close the current message library.

Add Messages

Once a ProvideX Message Library has been selected, new messages can be created in the library.

Add a message into the current Message Library

Edit/Delete Messages

Once a ProvideX Message Library has been selected, existing messages can be changed or deleted.

Modify or delete a message from the current Message Library

Paste Message

Select a message a either double-click or press the "Paste" button to begin the process of pasting the message information into the file open in the editor view.

Paste a message into current program in editor

The options 'Bus Object' and 'UI Object' are only valid when used with MAS 90/200 application programs.

Next Section: ProvideX Docs


ProvideX Class Documentation

What is it?

Java has Javadoc for generating the API documentation into HTML files from information in source code files. ProvideX now has PvxDoc which will allow the generation of class documentation from the source code of a ProvideX class definition.

This utility program was contributed by an anonymous third party. The original code was enhanced to allow it to be used as a contributed tool for the ProvideX plug-in for Eclipse. It will generate HTML documentation for all class files within a project (or directory tree). It will also identify any inheritance and sub-class relationships.

The plug-in API reference documentation was generated using this tool.

This document will provide a simple overview of the PvxDocs contributed tool. Additional information for creating and registering a new contributed tool is included in the 'Help Contents' for the ProvideX plug-in in Eclipse.

Additional Topics

Configuration
How to configure this contributed tool.
Write Class Documentation
How to add documentation in source for class.
Sample Source
Sample source code files.
Generate Documentation
Generate the documentation for resources selected in 'Navigator View'.


ProvideX Class Documentation - Configuration

Configuration

This contributed tool includes a configuration program that can be used to control how the tool operates and the content and format of the output that is created.

Header Tags

This panel identifies the header tags to be included in the documentation.

Configuration - Tags

Document Generation

This panel is used to set configuration options controlling the generation of the document content.

  • include documentation for the LOCAL (private) property and FUNCTION definitions
  • include the assignment of constants for PROPERTIES
  • set modification date/time stamp to match source file
  • the location where the documentation files will be created
    • create documentation in a folder OUTSIDE of the project;
    • if not selected, the documentation will be placed into a 'pvxdocs' folder in the root of the project
  • the organization of the files in the output folder
    • create a project-specific sub-folder; this is useful when creating documentation for several projects in the same output folder.
    • create sub-folders to mirror the structure of the source project
  • images files to be used for logo and copyright information to include as the header and/or footer of each page
Configuration - Generation

Order of Sections

This panel is used to select the sections to include in each document and the order of the sections. Double click on a section to include / exclude it from the documentation to be generated.

Configuration - Sections

Output Format

This panel is used to set the default format to be used when generating the documentation. The run-time setup panel is used to override most of these options. See Generate Documentation for additional information.

Configuration - Format

The default format for the documentation is HTML. In fact, the other formats are simply variations or repackaging of the HTML files.

Type of content to generate

HTML
Create one or more HTML files for the selected classes; the method used to link between files is set on another option.
Microsoft HTML Help (CHM)
Create a CHM (Microsoft Compressed HTML Help) file if the Microsoft HTML Help Workshop compiler is available. These workshop files were available from the Microsoft MSDN site - MSDN HTML Help Download (June 2011).
Mediawiki-compatible XML Export File
Create a Mediawiki compatible XML export file to be used to import the generated documentation to an existing Mediawiki site. The content that is created makes use of several Mediawiki extensions to improve the formatting/usability:
Custom Sidebar
This extension enables the dynamic sidebar functionality used for each of the major documentation areas in the wiki. See the web site for additional information.
Tree View and Menu
This extension allows bullet lists to be rendered as folder trees or dynamic drop-down menus. See the web site for additional information.
info When generating a Mediawiki-compatible export file, the size of the file(s) will be limited to approximately 400KB. A separate export file is created for the parent page and navigation sidebar content.

HTML: Number of files to create

Single file
this format can be useful when sending documentation via email and a CHM file cannot be created or is not acceptable.
Separate file for each class
This is the default output format; it will be forced when generating content for one of the other formats

HTML: Method used to link to other pages

Direct link to page
All references to pages, including on the main index page, are direct links to the page using the anchor tag.
JavaScript - menu and content in same page
The page is defined as a 2 column layout using DIV tags. The left column is a narrow column for the "navigation menu" while the right column occupies the remainder of the browser window and is used to display content. JavaScript is used to dynamically load the content into each of the layout regions.
JavaScript - menu and content load in separate frames
The page is defined as a 2 column layout using IFRAME tags. The left column is a narrow column for the "navigation menu" while the right column occupies the remainder of the browser window and is used to display content. JavaScript is used to dynamically load the content into each of the layout regions
Use folder structure for navigation menu
The navigation menu will mirror the folder structure of the project.

CHM: Location of 'HTML Help Workshop' compiler

The CHM compiler from the 'HTML Help Workshop' is required to create a MS-Windows compiled HTML Help file. These workshop files were available from the Microsoft MSDN site - MSDN HTML Help Download (June 2011).

WIKI: Parent page for generated files

Enter the location to be used as the "parent page" for the generated content when it is imported to the wiki site. An index (tree list) of the generated class documentation will be created as the content for this page.

Next Section: Write Documentation


ProvideX Class Documentation - Write Documentation

Write Documentation

When this tool is used with class source files that have not been modified to use the new PvxDoc document tags, it will generate documentation that includes only the property and method declarations for the class.

Collection Class minimal documentation

The remainder of this document will explain how to use the new PvxDoc tags and documentation formatting to add more information into this class definition.

Document the Class Definition

The placement and ordering of the documentation and tags within the source file is very important. All tags for the class, a property or a method must immediately precede the declaration. The documentation lines that do not include a tag are used to describe the class, property, or method.

The description of the class and the definition of the constructor for the class must be before the DEF CLASS statement. If there are arguments to be passed to the constructor, these must be described after the '@Constructor' tag and before the DEF CLASS statement.

Adding Documentation to Source Files

The documentation is placed into comment (remark) lines in the source file. All of these lines must begin with "! ** " or "! *- " and can be followed by an optional tag and then the documentation text.

Any lines that are placed within C-style block comments (starting with "/*" and ending with "*/" and spanning one or more lines of text in the source file), or that begin with "! *- ", will not be included in the tokenized program.

Tags to Classify / Organize Documentation

There are several types of tags used by ProvideX Docs. Each is described in detail in the following sections.

Build Information Tags

The build information tags are optional. If they exist in the source code (within the first 25 program lines), these tags will be used to update the build properties for the resource. When the properties are modified on the resource's properties page, the information for the corresponding tags will be automatically updated in the source file.

The build tags should be grouped together near the beginning of the source file. These tags can be used with any ProvideX source file and are not restricted to class definitions.

The build information is used when building the program from the source code. This information also includes the author and original date of creation for the program.

Tag | Description / Usage
@Author | The original author of the program. This value is not used by the build process.
@Date | The date when the original program was completed. This value is not used by the build process.
@Flags | The flags that are used during the build process to allow a developer to associate the program with special flags that are part of the system activation code.
@ForceLineNumbers | This boolean value (true or false) is used by the build process to determine if line numbers are to be forced for the tokenized program.
@LineNumberInc | This numeric value (1 - 25) is used by the build process to determine the line number increment to be used for the tokenized program.
@Outputfile | The name of the output file to be created by the build process.
@Owner | The owner code is used by the build process to allow a developer to assign a special code to the program.
@Password | A password that will be used to encrypt the program during the build process.

Class Definition Tags

The class definition tags are used to document the external interface to the class.

These tags are placed within the class definition section of the source file. Any documentation tags that are placed after the 'END DEF' are ignored when generating the HTML files.

Tag | Description / Usage
@Constructor Explain the actions performed by the constructor for the class. This tag is followed by the text that describes the constructor. The explanation can span multiple lines in the source file - only the first line is required to use this tag; the documentation will continue until another tag is used or the DEF CLASS statement is encountered.

When there are arguments that are required for the constructor, these will be described using @PARAM tags following the constructor documentation.
@Note | Document special information about a property that must be highlighted to draw the attention of the reader.
@OList Start an ordered list.
  • each item in the list must be on a separate line
  • start a line with a '+' character to add to the previous line
  • a blank comment line in a list will be ignored
  • the list ends at the next tag or the end tag for the list (@OList_End or @UList_End).
@Param | Defines a parameter for the class constructor or a method. This tag is followed by a variable to identify the parameter and then an explanation of the argument. Start the parameter description text with a '+' character to add to the previous line.
@Returns | This tag is followed by the description of the returned value for the constructor or method.
@Type | This tag is followed by the description of the data type of a property value.
@UList Start an un-ordered list.
  • each item in the list must be on a separate line
  • start a line with a '+' character to add to the previous line
  • a blank comment line in a list will be ignored
  • the list ends at the next tag or the end tag for the list (@OList_End or @UList_End).
@Value This tag is used to itemize fixed values that are used for parameters or returned values and explain the meaning of the each value.

The tag should follow the parameter or return value that uses the values. Each value is described on a separate line. All values will be grouped together into a table. To add a heading to the table, use a description starting with heading= as the first value in the list.
@Warn | This tag is followed by text to be placed into a warning box and can be associated with the documentation for the constructor, a property, or a method.

Special Substitution Tags

The following substitution tags are used to standardize the references to other classes.

%JavaClass(<class_name>)%
Highlight a reference to a Java class definition and generate a link to the documentation for the class.
%PvxClass(<class_name>)%
Highlight a reference to a ProvideX class definition and generate a link to the documentation for the class.
%PvxLibClass(<lib_class_name>)%
Highlight a reference to a standard ProvideX class definition (included in the ./lib folder of the distribution) but do not generate a link to the documentation for the class.

Formatting Tags

The following substitution tags are used to format the information in the final document.

%PvxCode(<ProvideX code example>)%
Special formatting for a ProvideX code segment; code segment on new line.
%PvxCode2(<ProvideX code example>)%
Special formatting for a ProvideX code segment; code segment will replace tag in same line.
%PvxCodeBegin% / %PvxCodeEnd%
Special formatting for a multiple line ProvideX code block; spacing and line breaks are preserved.
! ** ==>
Begin an unordered list of information. Each if the lines that follows will be a new item in the list.
The list will end at the next line that is either '! ** ' or '! ** <==' .

Documentation Lines

The following definition table shows the different types of documentation lines that can be used for a class definition.

! ** @Constructor
Document the constructor for the class. If this documentation is too long for a single line, each additional line does not use the '! ** @Constructor ' tag.
! **
Document the class, property or method. There may be multiple '! ** ' lines for a long or detailed explanation.
! ** @Note <text>
Include a notice within the documentation for a function. This notice will have a light grey background so that it will stand out from the other documentation for a function.
! ** @OList
Begin an ordered list; end the list with the '@OList_End' tag.
! ** @Param <var>
Document the arguments for the constructor or method. Each argument is described on a separate line.
! ** @Returns <text>
Document the value returned by the constructor or method
! ** @Type <text>
Document the data type of a property
! ** @UList
Begin an unordered list; end the list with the '@UList_End' tag.
! ** @Value <value>
When a parameter or the return value can be one of several fixed values, these values can be documented using this tag. The tag should follow the parameter or return value that uses the values. Each value is described on a separate line. All values will be grouped together into a table. To add a heading to the table, use a description starting with heading= as the first value in the list.
! ** @Warn <text>
Add a warning block into the documentation for the constructor, a property, or a method.

info All documentation for each tag should be grouped together; when the tag changes, the box surrounding the information will be closed and a new box will be started. This will force all documentation associated with each tag to be contained within the same box.

Next Section: Sample Source


ProvideX Class Documentation - Sample Source

Sample Source

The following sections show how to add comments into the program source code to be used to generate documentation for the class.

Simple Class
Documentation for a simple class.
Lists - Ordered and Unordered
How to include both ordered and unordered lists.
Function Declaration With Table of Codes
How to document an overloaded function and also include a table of codes for one of the function parameters.
ProvideX Code Sample - Single Line
How to include ProvideX code sample as a separate line.
ProvideX Code Sample - Embedded in Paragraph
How to include ProvideX code sample embedded in paragraph instead of in a separate line.
ProvideX Code Sample - Block of Code
How to include a block ProvideX sample code.

Next Section: Generate Documentation


ProvideX Class Documentation - Generate Documentation

Generate Documentation

This contributed tool requires that a resource in the source folder of a ProvideX project be selected in the 'Navigator View'. This resource can be the source folder or any resource in that folder (or a sub-folder).

The PvxDocs tool is selected from the list of available tools and the "Run" button is pressed to begin processing the selected folder (and sub-folders) or resource.

Contributed Tools - Selection menu

Setup

A setup panel will display to enable fine-tuning of the documentation to be generated.

PvxDocsRun - Setup

This panel allows adjustments to be made to the default information entered through the configuration panel:

Document Format
Output File Type
The type of file(s) to be generated (HTML, CHM, or Mediawiki-compatible XML export file)
Link to Pages
Method to use when creating links to other documentation files (Direct, Javascript: Same Page, Javascript: Separate frames)
Direct Links - Strip Text
Should text be stripped from path when using Direct Links to other documents
Value to Strip
Value to strip from the beginning of folder/file path in document links
Generation Information
Output Directory
The directory where the generated files will be created.
Wiki Parent Page
This option is available only when generating the Mediawiki XML export file and is used to set the import location for the generated content.
CHM Documentation Topic
This option will be used as the primary topic for the generated CHM file.
Javadoc Root Directory
Relative path (to output folder) for Javadocs referenced in generated documentation.
info Set the project-specific property pvxdoc.Javadoc_Root to set the default value of 'Javadoc Root Directory' used when generating PvxDocs for the project.
Document Generation
Create Folder Structure
The folder structure of the project will be created in the output directory.
Use Folder Structure for Menu
This option is available only for HTML output when generating separate files for each class.
Skip Classes not documented
Do not generate class documentation for any class where no documentation has been added to the source file.
Include 'LOCAL'
Include LOCAL property and function definitions documentation in the generated content.
Include Property assignment
Include the assignment information for any property assigned a value as part of the definition
Set Modification Date
Set the modification date/time of the generated documentation file(s) to match the modification date/time of the source file

Start Generate

A new view will be displayed to track the progress of the documentation generation process. While the source files are processed, click the 'Cancel' button to abort the document generation process.

PvxDocsRun - Process Log

Verify Generated Document(s)

Once the process has been completed, click the 'View Docs' button to view the generated documentation, or click the 'Close' button to close the view.

PvxDocsRun - Process Log

Viewing Content

After closing the log window, Viewing the generated documentation will depend on the output format that was chosen on the setup panel for the document generation process:

HTML

In a browser, simply open index.html to view the navigation menu and select the class documentation to display.

info CORS (Cross Origin Resource Sharing) will block loading of page content when using a modern browser and attempting to view documents generated using the 'Same Page' option for linking to documents unless the files are hosted on a web server.
Microsoft HTML Help files (CHM)

On a MS-Windows machine, simply open the pvxdoc.chm file; a CHM viewer is required to open the file on machines using other operating systems.

info After the CHM file is saved on a MS-Windows system, the security settings for the file must be adjusted to enable the content to display. In MS-Windows Explorer:
  • locate the file,
  • right click on the file and choose properties from the pop-up menu
  • at the bottom of the "General" page, click the <Unblock> button and then click <OK>
CHM - Security options

Mediawiki-compatible XML Export File

The documentation generation process will create at least two files named in the format 'PvxDoc_WikiExport_###.xml' and place them in the output folder.

The highest numbered file contains the parent page and sidebar navigation content and should only be imported when updating ALL content for a topic.

First, log in to the wiki as a user who is authorized to create (or modify) content and import pages.

Import NEW Content / Update existing content

The export files must be imported into the wiki site before it can be viewed.

  • Go to the 'Special:Import' page on the wiki site; this page can be accessed from "Special Pages" under the "Toolbox" menu.
  • For each of the export files:
    • Select the export file
    • Enter a comment to describe the content to be imported. This comment will be written to the change history for the wiki site.
    • Click the <Upload File> button to begin the import process.

    The time to complete the upload will depend on the size of each file.

info If the generated documentation is for a subset of the classes and is intended to update existing content, or add missing (or new) content, the highest numbered file should NOT be imported - it will replace the content of the parent page and sidebar with the partial content.

Manual Update of Parent Page / Sidebar

When the generated documentation is for a subset of the classes, the parent page and navigation sidebar must be updated manually to merge the new content with the existing content.

  • Open the highest numbered export file in a simple text editor
  • Locate the first page tag - this will be the beginning of the parent page.
  • The next line will contain the name of the parent page between two title tags. The content of the page will be between two text tags.
  • Go to the page on the wiki site with this name and select to edit the page.
    • In the Wiki editor, determine the location where the new content should be placed or the content to update.
    • Copy the content from the text editor and insert/replace in the Wiki editor.
    • Repeat until all of the new content for the page has been merged.
    • A closing page tag will indicate where the information for the page ends.
  • Locate the next page tag - this will be the start of the content for the navigation sidebar.
  • The next line will contain the name of the parent page between two title tags. The content of the page will be between two text tags.
  • Go to the page on the wiki site with this name and select to edit the page.
  • Repeat the steps above to merge the new content into the existing navigation sidebar content.

After all of the files are imported (updated), go to the parent page to view the new content.

Next Section: Style Check


Style Check

  • What is it?
  • Configuration
    • Viewing the Rules
    • Order of Rules
    • Add a Rule
    • Edit Rule
    • Delete Rule
  • Execution of Style Check
    • During SAVE in Editor
    • As Contributed Tool
  • Developer-Defined Style Check Class

What is it?

The Style Check contributed tool provides a mechanism for defining simple rules to describe a coding standard. The tool will then use these rules to verify that the source code for an application conforms to the defined standards. These rules are processed in order, and the first rule that fails will be recorded to the "Problem View" and the remaining rules will be skipped.

A simple rules-based style check (simpleStyleCheck) is included with the plug-in.

Configuration

Viewing the Rules

The operation of this tool is controlled through the use of simple rules that are stored in a text file located in the same folder as the primary class used to implement the style check.

info A secondary rule file can be created in the folder specified by the preference 'Contributed Extensions / Tools: Directory for user-defined observers' with the same name as the primary class for the style check. When this file exists, any new or modified rules will be saved to this file; the rules in this file will be added to the list of existing (standard) rules for the style check.

The name of the style check class will be displayed in parenthesis after the description of the plug-in on the 'Contributed Extensions / Tools' preference page once the plug-in has started.

The rules can be viewed in the configuration screen for this tool (see image below - click to view a larger image).

Style Check configuration (Click to view larger image)
Order of Rules
The rules are processed in order, from first to last. The first rule that fails will be tagged against the line in the "Problem View" and all remaining rules will be skipped. As a result of this processing method, any program line that has multiple rule violations will be flagged with the first rule that fails rather than all rules that might apply. The position of a rule in the list can be adjusted by pressing move up to move the rule up, or move down to move the rule down.
Automatically update source code for the rules that contain replacement or delete values
When the Style Check is executed from the "Contributed Tool" menu, this option will control whether the replacement and delete values are updated to each source file as it is processed.
Escalate a 'warning' to an 'error' when rule includes a replacement or delete value
When the Style Check is executed from the "Contributed Tool" menu and the automatic update is not enabled, this option will control whether a rule that is defined as a "Warning" and includes a replacement or delete value will get reported as an "Error".

Add a Rule

A new rule can be created by pressing the [Add] button on the screen that displays the list of rules.

Add a new rule (Click to view larger image)

The information associated with a rule is:

Rule Description
A short description for this rule that will be placed in the "Problem View" when there is a violation.
Search Value
The text value (20 characters) to locate within the program line.
Level of Severity
The severity to be assigned to a violation of this rule (E=Error, W=Warning)
Options
The options control how and when a rule will be applied.
Mandatory
This rule is mandatory and cannot be disabled by a user
Enabled
The current state of the rule when the user is allowed to enable/disable it
Ignore with *SC-OK*
A violation of this rule will be ignored if there is a comment on the same program line that contains the text " *SC-OK* "
Whole Word
The search value will be treated as a word for the search; this means that there must be a space before the search value and a space or ...
Check Remarks
Locate the text inside remarks; if not checked, the search will ignore comments
Delete Search Value
The search value will be deleted when the Style Check is executed as a contributed tool and the "Automatic update" option is set
ProvideX Class Only
The rule will be applied to the source files for ProvideX classes only (files with ".pvc" extensions)
Check Literals
Locate the text inside literal values; if not checked, the search will ignore string literals
Search First 10 Lines
Rule is restricted to the first 10 lines of the source file.
Log Text After Tag
Locate the search text and using the remainder of the program line as the description of the warning/error to be logged.
Check Keywords
Locate search text in list of keywords for the line; if search value contains multiple words, will check any order of the words
Replacement Value
The replacement value can be either a simple text value (20 characters) or a string expression that will be evaluated at run-time.
String Expression
This check box determines the type of replacement value to be used for this rule.
Fixed Text
A simple text value (20 characters) to replace all occurrences of the search text on a program line
String Expression
A string expression to be evaluated to create the replacement text value

Edit a Rule

Any existing rule can be modified by pressing the [Edit] button on the screen that displays the list of rules.

Edit existing rule (Click to view larger image)

The string expression is validated for correctness; update of the rule cannot occur until the expression is valid.

Edit existing rule (Click to view larger image)

Delete a Rule

Any existing rule can be deleted by pressing the [Delete] button on the screen that displays the list of rules.

Execution of Style Check

During SAVE in Editor

The external tools must be enabled on the "Contributed Tools / Extensions" preference page. The Style Check can then be enabled as an observer and will be triggered when a file is saved in the editor. When the style check is executed as part of the save process, all rule violations will be updated to the "Problems View" but no modifications will be made to the source files.

As Contributed Tool

When the style check is executed from the 'Contributed Tools' menu, any rule that includes a replacement text value, or option to delete the search value will be applied to the source file. Any remaining rule violations will be updated to the "Problems View".

Developer-Defined Style Check Class

Developer - Style Check

A developer who wants to implement a style check (or coding style validation mechanism) as part of the standard application development process must create a class based on the simple style check class. This class has been provided as an example that uses a text file to define the rules describing the coding style.

The source code for the class can be viewed by clicking on the link.

Style Check

The plug-in includes a standard class that is loosely based on the "Prototype" design pattern. This class defines the characteristics of a style check capability that can be implemented by a developer. The standard capabilities of the style check feature are implemented in this standard class. A developer can extend these methods or add specialized logic to implement rules that cannot be easily described using search patterns.

The documentation for the standard class can be accessed through the online help for the plug-on or by clicking on the link.

Next Section: Super Search


Super Search

  • What is it?
  • Search Parameters
    • Locations to Search
    • Search Criteria
    • Options
    • Only Search Within
    • Description for Bookmarks View
    • Start Search
    • Clear / Load / Save Search Parameters
  • Search Progress / Summary

What is it?

The search tool performs text searched of files in an Eclipse work space. The results are updated in the Bookmark View.

Project Properties

The search tool now supports additional configuration options using new properties in the project properties file.

SuperSearch.IgnoreCharacterList
The property can be set to a list of one or more hexadecimal values for the additional characters to be ignored when scanning for binary characters in source file(s).

For example, to ignore the copyright © symbol use the value of A9 as shown in the following sample line.
SuperSearch.IgnoreCharacterList=A9

Search Parameters

The output of the search is controlled by the choices that are made on the parameter screen (click on a number to learn more about the option).

Parameter screen with numbered topic items (Click to view larger image)

Locations to Search

Current Project
This option will restrict the search to only the resources in the source folder of the current project which will be determined by the first resource that is selected in the Navigation View. When selected, the current project will be displayed next to this option.
Navigator Selections
This option will restrict the search to only the resources that are selected in the Navigation View. When selected, the number of selected resources will be displayed next to this option.
Entire Workspace
This option will include all of the resources in the current work space. When selected, the name of the work space will be displayed next to this option.
Working Set
This option is currently unavailable.
Previous Results - Programs
This option will include all of the resources where a hit was found in the previous search.
Previous Results - Lines
This option will include only the lines from the resources where a hit was found in the previous search.
File Name Mask
Enter a DOS-style file mask to be used to restrict the resources to be searched based on the file name.
Skip ProvideX Programs
Skip all ProvideX programs that begin with "_"; this is the normal naming convention for the ProvideX utility programs.
Skip Programs That Begin With
This is a comma-delimited list of values. Any program name that begins with any one of these values will be excluded from the list of programs to be searched.
Skip Programs With These Extensions
Enter a comma-delimited list of file extensions to be used to exclude programs from the search.

Search Criteria

And/Or
Select "And" / "Or" from the drop box to build a more complex expression that combines multiple search values.
Parentheses
Use the check box to indicate where parentheses should be placed so that search items can be grouped together. Unmatched parentheses are automatically added to the expression and displayed as curly braces { } to indicate that they were auto-generated. The expression can be reviewed and additional parentheses added to form the expression as required for the search.
Not
Use the check box to negate all or part of the expression used for the search.
Search For
Enter the text to be located or use the drop box to choose from previous search values.
Match case
Use the check box to indicate that the search should locate only values that exactly match the case of the value entered.
Search Criteria: Whole Word
Use the check box to indicate that the search value must be a full word that is wrapped in spaces or punctuation marks.

Options

Output to Bookmarks View
Place a bookmark on each line where there is a match of the search criteria; this will also cause an entry to be added to the Bookmark View.
Ignore Remarks
Do not search the text in remarks
Ignore Text within Quotes
Do not search the text that is enclosed within quotation marks
Summarize Results
Summarize the results of the search on the Console View.
Invert Results

Only Search within

SELECT / NEXT RECORD
Restrict the search to lines that are within a SELECT / NEXT RECORD loop; the SELECT / NEXT RECORD must be the first words on the line to indicate the start and end of the loop.
REPEAT / UNTIL
Restrict the search to lines that are within a REPEAT / UNTIL loop; the REPEAT / UNTIL must be the first words on the line to indicate the start and end of the loop.
WHILE / WEND
Restrict the search to lines that are within a WHILE / WEND loop; the WHILE / WEND must be the first words on the line to indicate the start and end of the loop.
DEF CLASS
Restrict the search to lines that are within a class definition.
Line Label contains
Restrict the search to lines that are within a block of text that begins with the line label and ends with its RETURN or EXIT.

Description for Bookmarks View

Select the value to be used as the description in the Bookmarks view.

Program Line
The program line (up to 256 characters) that matches the search criteria.
Search Expression
The expression defined by the search parameters.
Both
The search expression followed by the program line - up to 256 characters.

Start search

Press the [OK] button to begin the search. The search parameter window will close and a new window will open to show the progress of the search.

Or, press the [Quit] button to cancel the search.

Clear / Load / Save Search Parameters

Clear, Load, or Save the search parameters.

Search Progress / Summary

A summary of the search results will be written to a 'Super Search - Results' view.

Progress Log - SuperSearch

From this progress log view:

  • Use the check-box "Force focus to remain on LAST line in log window" to start/stop the automatic scrolling if the search results in the log window.
  • Press [Cancel] any time to abort the search. Once the search has completed, this button will be disabled.
  • The [Close] will remain disabled until the process has completed. After reviewing the information, press this button to close the view.

Next Section: Tag Substitution


How to Extend the Plug-in

The plug-in allows third party collaboration to enhance or extend its capabilities. This section will describe the various methods that can be used to accomplish this.

The ability to extend the ProvideX plug-in is based on the observer design pattern. Each new extension is registered and the class associated with the extension is initialized during startup of the plug-in. Once each class has been initialized, it can be queried to identify when it is to be invoked during the normal event cycle.

Each class has an update() method that is called when it is triggered. This method will then perform the task required to provide the additional functionality.

The ProvideX plug-in can be enhanced using two different methods, or a combination of both.

Enhance Built-in Event Process

The first mechanism is to add functionality to the existing events that are supplied by the plug-in. These events allow two access points for the external logic to be executed. One is before the normal event logic and the second is after the event logic. A single enhancement can execute logic at either or both points in the event process.

Contributed Tools

The second mechanism is to add an external tool to the 'ProvideX' menu that will provide functionality outside of the plug-in event process. This external tool can manipulate the files within a ProvideX project in Eclipse.

Next Section: Design Patterns


Design Patterns

A well-designed application should meet its requirements. It should also be adaptable so that when the real-world requirements change, it can also be changed with minimal effort.

Introduction to Object-Oriented Analysis & Design

The following was taken from "Introduction to Object-Oriented Analysis & Design" available for download from the ProvideX web site.

In 1994, four computer scientists (Erich Gamma, Richard Helm, Ralph Johnson, and John Vlissides) authored a ground-breaking book entitled "Design Patterns: Elements of Reusable Object-Oriented Software". In this book, the authors (aka "the Gang of Four" or "GoF") assert that all of the design problems a software engineer faces have been identified and solved. The GoF identify twenty three different patterns, which can be divided into three groups:

  • Creational Patterns for object creation
  • Structural Patterns for the structure and composition of classes
  • Behavioral Patterns for the interactions between classes

Essentially, design patterns are recurring design solutions that may be applied to specific problems. A typical design pattern involves three or more classes. Some patterns are simple and obvious, some are complex and elegant.

Patterns can help software engineers resolve common software problems in a tried-and-true way. A development team that has adapted patterns can easily communicate the intention of their code - it becomes somewhat self-explanatory.

For example, when a developer who is familiar with design patterns encounters an Observer (behavioral pattern) in a program, he or she will not have to wade through the code to determine what it does. The pattern is often easily identified by the naming conventions used in the code, as well as by the intent of the pattern and by the way it works as a known commodity.

Don't confuse design patterns with algorithms or language idioms. A design pattern is a solution that can be applied to a design problem in any object-oriented language. In fact, you are probably using patterns already and may not know it.

The following are the design patterns identified in the original GoF design patterns book.

Creational | Structural | Behavioral
Factory Method (class scope) Abstract Factory Builder Prototype Singleton | Adapter (class scope) Adapter Bridge Composite Decorator Facade Flyweight Proxy | Interpreter (class scope) Chain of Responsibility Command Iterator Mediator Memento Observer State Strategy Visitor

Note: There are also some patterns in common use that do not appear in the list published by the GoF

All design patterns have four characteristics.

  • Name A name that communicates the use of the pattern
  • Problem The problem the pattern will solve
  • Solution The elements and relationships that comprise the pattern
  • Consequences The benefits and costs of the pattern

Observer Design Pattern

The essence of this pattern is that one or more objects (called listeners or observers) are registered to observe an event which is raised (or triggered) by the observed object (subject).

Observer pattern diagram Observer pattern diagram

Next Section: Plug-in Events


ProvideX Plug-in Events

The plug-in is organized around the processing of events that are triggered by user actions within the Eclipse Workbench. Most of the events will use logic that is written in both Java and ProvideX; some of these events are implemented entirely in Java.

A large number of events are triggered within the Eclipse Workbench. It is beyond the scope of this document to provide the details of these events and how to interact with them. Please see the Eclipse Plug-in Development Environment Guide for documentation.

All events within the ProvideX Plug-in are organized using both major and minor code names. The source code can be used to create a simple contributed tool that will print a message to the console view for the PRE and POST processes of all events that are triggered by the plug-in.

Identify Event

Every event that is handled by the ProvideX Event Manager can be identified by major and minor code names. The minor code name is not always required. Every major/minor code name can be referenced using a variable that is stored within the PvxConstants class.

The diagram (above) shows the name of the constant to be used to identify a specifc event. The name of the constant is derived by replacing "<event>" in the following reference "_pvxConstants'<event>$" with a name from the diagram.

For example, to refer to the event that is triggered when the user chooses to strip line numbers from the current program use the variable "_pvxConstants'strip_Line_No$". The mixed case for the variable name is intended to make the code more readable, it is not required to properly identify the variable.

Sample Logic

The following is a simple example of ProvideX code that could be used to display a message when the user chooses to strip line numbers from the program. This example is based on the logic that can be found in the source file ExampleObserver.pvc included with the plug-in. A more complete explanation can be found in a later section of this document.

aPvxState=new("PvxState")
psMajor$=aPvxState'getMajor$(), \
psMinor$=aPvxState'getMinor$()
if psMajor$=_pvxConstants'strip_Line_No$ {
    print "The line numbers have been stripped from the program."
}

This is not an actual implementation of an observer. It is simply a demonstration of how to identify the event and then execute logic that will add to the existing functionality of the plug-in.

Next Section: What is an Observer?


What is an Observer?

Observer Design Pattern

The essence of this pattern is that one or more objects (called listeners or observers) are registered to observe an event which is raised (or triggered) by the observed object (subject).

Observer pattern diagram Observer pattern diagram

Within the scope of the ProvideX plug-in, the ProvideX Event Manager is the subject object and it is responisble for instantiating the objects that have been registered as observers.

For simplicity, we have created a simple text file where each observer is registered. The Event Manager processes this file during initialization and loads each of the observers. As each observer is successfully loaded, it is added to the list of observers to be notified when events are triggered.

The initial implementation of the external observers will notify each observer for every event. A future implementation will allow each observer to identify the event(s) that it wishes to observe.

Each observer declares when it is to be notified of an event. There are currently three points within the processing of an event where this notification can occur. These are stated in relation to the standard logic that is implemented within the ProvideX plug-in. It is not possible to override or replace the built-in logic with the current implementation.

The event notification points are:

Before
The observer is notified before the built-in logic
After
The observer is notified after the built-in logic
Both
The observer is notified both before and after the built-in logic

Next Section: Built-in Observers


Built-in Observers

Post-Process Observers

There are two built-in observers, and each has been implemented as a post-process observer. This means that the observer is notified after the standard event logic has been executed.

Progress Monitor
The progress monitor is used to show the work that is performed during an event that may take an extended period of time, or that is made up of one or more smaller events.
Event Logging
The event logging observer is used to show the activity that occurred during processing of an event. This observer includes a number of methods that can be accessed from the ProvideX Event Manager or other events to add information to the log.

Next Section: Additional Examples


Additional Examples

There are several external observers included with the plug-in. These observers follow the guidelines outlined in this document and can be used as examples for how to write an external observer.

These observers fall into one (or both) of the following categories:

  • Enhancements/Add-on to existing Events
  • Contributed Tools

Set Copyright Year

Triggered
Pre/Post process of a build
Description
This observer will create a temporary copy of the source file and substitute the modification year of the original source file in place of the "%(copyright-year)%" tag found at the beginning (first 1000 characters) of the source file. It will also be triggered during the post-process of a build where it will delete the temporary source file.
Source Code
The source code is included with the plug-in.

Set Modification Date

Triggered
Post-process of a build
Description
This observer will be triggered during the post-process of a build and will set the modification date for the output file to match the modification date of the source file.
Source Code
The source code is included with the plug-in.

Show message in Console

Triggered
Pre/Post process of all events
Description
This is a very simple extension that will write a message to the console during the pre-process and post-process for every event.
Source Code
The source code can be reviewed to see how easily this can be accomplished.
Sample Output
ShowText: A pre-process for FULL_BUILD/FULL_BUILD_START
ShowText: A post-process for FULL_BUILD/FULL_BUILD_START

Builder running

Compile Program: \DemoApp\src\prog\client.mnt.pvt
ShowText: A pre-process for INCREMENTAL_BUILD/BUILDONE
... Output File: ../compiled/prog/client.mnt
Build process: OK
ShowText: A post-process for INCREMENTAL_BUILD/BUILDONE

Build done
ShowText: A pre-process for FULL_BUILD/FULL_BUILD_END
ShowText: A post-process for FULL_BUILD/FULL_BUILD_END
Build time: 874
ShowText: A pre-process for PREFERENCE_CHANGE/_extObserver_masStyleCheck changed
ShowText: A post-process for PREFERENCE_CHANGE/_extObserver_masStyleCheck changed
ShowText: A pre-process for PREFERENCE_PAGE_BUTTON/performOk
ShowText: A post-process for PREFERENCE_PAGE_BUTTON/performOk

Next Section: What can be added?


What can be added?

The Eclipse framework has been designed to be extensible and provides the tools and structure that allow people to build new things and enhance or extend existing things.

Something Old

One enhancement that can be made to the plug-in is to integrate it into a pre-existing or home-grown change management or version control system. The Eclipse framework already provides integration to a number of common version control systems; however, that should not stop you from connecting or integrating to your system.

Something New

The ProvideX plug-in also allows integration of existing tools that will extend its capabilities. The plug-in includes the 'XML Conversion' and 'PvxDocs' which are examples of tools that were contributed to add new functionality.

Something Revolutionary

The ProvideX plug-in can be used as the starting point for building something entirely new and fantastic. The plug-in can be integrated into a much larger tool that controls the entire life cycle of a software package.

Conclusion

The possible enhancements and uses of the plug-in are almost limitless.

Next Section: What is an Enhancement?


Why Add to Event?

Extending Plug-in Capabilities

The ProvideX plug-in has been designed to allow additional functionality to be added without requiring a large effort. The current version of the plug-in provides two methods to accomplish this.

Enhance Existing Events
Add new logic around the existing events (or logic) in the plug-in. This provides a mechanism for integrating with existing tools and methodologies for managing source code and documenting the history of an application.
External Tools
Add links to connect to external tools that are not directly associated with any of the events in the current ProvideX plug-in.

Enhance Existing Event

This section will discuss the steps required to enhance an existing event. This is accomplished by building an observer that will be notified when an event is triggered and can then add functionality to the event.

The new functionality can be triggered before and/or after the built-in logic. When there are multiple observers, the order of processing may always be the same. Any observer that is created must not rely on information from another observer. Otherwise, if the other observer has not yet been notified, the information may not be available.

Register User-Defined Observers

A developer can write an extension (or contributed tool) following the steps described later in this documentation and place the programs into a directory on each workstation. This directory must also contain a file with the name 'classes.txt' to identify the programs to be registered with the plug-in.

# this file contains the names of my user-defined Observer classes
eventName=del_dupe_remarks
eventName=showtext
# must have a line after last observer definition

As this example shows, the format of each line is:
eventName=<NameOfClass>

where <NameOfClass> is replaced by the name of the class definition to be loaded.

Next Section: Observer Class Template


Observer Class Template

The Class

The ExampleObserver class is intended to be used as the template for an observer.

API Documentation

Click HERE to view the API documentation for this class template. The complete documentation for all of the classes can be found in the API Reference.

Source Code

Click HERE to view the source for this class. This class does not include any code and it is intended to be used as a template for creating new observers.

Review the Class

Class Description

The theDescription$ private property must be set to a description for the new class.

Event Notification

The theNotificationFlag private property must be set to indicate the events that this observer will process. The values for this property can be one of the following:

_pvxConstants'_idePreProcess'
Register as a listener for pre-process events
_pvxConstants'_idePostProcess
Register as a listener for post-process events
_pvxConstants'_idePrePostProcess
Register as a listener for both pre-process and post-process events
_pvxConstants'_ideNone
Do not register as a listener; this is used for contributed tools

As long as the flag is not set to _pvxConstants'_ideNone, an preference will get added to the Contributed Extensions / Tools preference page to allow the user to enable use of the extension - the default value for this preference is disabled.

Do the Work

The update() method must be modified to add the logic that will be executed when the event has been triggered.

Event Arguments

The arguments that are passed into an event are generally the same for all events that share the same major ID. A summary of these arguments is listed later in this document.

Next Section: Build Program: Pre-process


Build Program: Pre-process

Build Program: Pre/Post Process

The Class

The set_copyright_year class is a simple example of an observer that listens for both the pre-process and post-process events of the Incremental Build / Program.

API Documentation

Click HERE to view the API documentation for this class. The complete documentation for all of the classes can be found in the API Reference.

Source Code

Click HERE to view the source code for the class.

Do the Work

The update() method has been modified to perform specific actions for the pre/post processes.

Pre-Process
  • change the text %(Copyright-year)% to the current year if found within the first 1000 characters of the program source code.
  • save the modified source into a new temporary work file, since the original file cannot be changed.
  • update the event property with the name of the new temporary file instead of the original source file
Post-Process
  • write status message to console
update:
enter aPvxState

    local psMajor$,psMinor$,enfState

    ! Get the Major/Minor codes that identify the current action
    psMajor$=aPvxState'getMajor$(), \
    psMinor$=aPvxState'getMinor$()

    ! Get the current state of processing for the ProvideX Event Manager
    enfState=aPvxState'getArgumentValue(_pvxConstants'_iEventNotificationFlag$)

    /*
     * This observer is for the program build event only; all other events
     * should be ignored.
     */
    switch psMajor$ + "|" + psMinor$

    ! Build a ProvideX program
    case _pvxConstants'Incremental_Build$ + "|" + _pvxConstants'BuildType_BuildOne$
    case _pvxConstants'Incremental_Build_Alt_Exe$ + "|" + _pvxConstants'BuildType_BuildOne$

        switch enfState

        case _pvxConstants'_idePreProcess
            isModified = _obj'update_copyright_year(aPvxState, outFile$)

            ! Set the current source file to the new output file
            if isModified {
                _obj'setCurrentSource(aPvxState, outFile$)
            }
            break

        case _pvxConstants'_idePostProcess

            ! write status message
            oReqClient = NEW( "pvxrequestclient")
            oReqClient'print(_obj'getDescription$()+": " + tbl(isModified, "no change", "updated"))
            drop object oReqClient

            break
        end switch
        break
    end switch
return 0

Next Section: Build Program: Post-process


Build Program: Post-process

The Class

The set_mod_timestamp class is a simple example of an observer that listens for the post-process event of the Incremental Build / Program.

API Documentation

Click HERE to view the API documentation for this class. The complete documentation for all of the classes can be found in the API Reference.

Source Code

Click HERE to view the source code for the class.

Do the Work

The update() method has been modified to perform specific actions for the post process.

Post-Process
Set the modification timestamp of the output file to match that of the source file.
update:
enter aPvxState

    local psMajor$,psMinor$,source,dest$,enfState,x,destObj,fileObj,projObj,sysType$, \
        utcMTime,secondsIntoDay,dayHours,dayMinutes,daySeconds,julDay,theCmd$

    ! Get the Major/Minor codes that identify the current action
    psMajor$=aPvxState'getMajor$(), \
    psMinor$=aPvxState'getMinor$()

    ! Check the current state of processing for the ProvideX Event Manager
    enfState=aPvxState'getArgumentValue(_pvxConstants'_iEventNotificationFlag$)

    /*
     * This observer is for the program build event only; all other events
     * should be ignored.
     */
    switch psMajor$ + "|" + psMinor$

    ! Build a ProvideX program
    case _pvxConstants'Incremental_Build$ + "|" + _pvxConstants'BuildType_BuildOne$
    case _pvxConstants'Incremental_Build_Alt_Exe$ + "|" + _pvxConstants'BuildType_BuildOne$

        switch enfState
        case _pvxConstants'_idePostProcess
            _obj'set_timestamp(aPvxtate)
            break
        end switch
    end switch
return 0

Next Section: Event Observer and Contributed Tool


Event Observer and Contributed Tool

The Class

The XML_Convert class is an observer that listens for the post-process event of the Incremental build of data/other files.

Class Documentation

Click HERE to view the API documentation for this class template. The complete documentation for all of the classes can be found in the API Reference.

Source Code

Click HERE to view the source code for this class.

Double Duty Class

This class actually performs two distinct functions. It will register itself as a post-process observer. It will also register itself as a contributed tool. This section will discuss only the event observer portion of the class.

Do the Work

The update() method has been modified to perform specific actions for the post process of the build process for specific minor IDs.

BuildType_DataFile
This observer will check the file to verify that it is a ProvideX keyed file and will then convert it to XML.
BuildType_OtherFile
This observer will verify that the file has an .xml extension and will then attempt to convert (or create) a ProvideX data file. The conversion logic requires that the XML file be defined for the schema 'providex'.
update:
enter aPvxState

    /*
     * This observer is triggered when an incremental build is initiated on a
     * data file.
     *
     * If the source file ends with the XML extension, it will be converted to
     * a PVX keyed file.  Otherwise, the file header is read to verify that this
     * is in fact a PVX keyed file and then it is converted to XML.
     */

    /* Get the major/minor codes for this event. */
    psMajor$     = aPvxState'getMajor$(), \
    psMinor$     = aPvxState'getMinor$()

    /* Get the parameters that were passed into this event. */
    source$      = aPvxState'getArgumentValue$(_pvxConstants'SrcFile$), \
    dest$        = aPvxState'getArgumentValue$(_pvxConstants'Dest$), \
    domFile$     = aPvxState'getArgumentValue$(_pvxConstants'DomFile$), \
    passwd$      = aPvxState'getArgumentValue$(_pvxConstants'pkf_Password$), \
    passwd_type$ = aPvxState'getArgumentValue$(_pvxConstants'_iPasswordType$)

    /* Create a local reference to the EventLog */
    _eventLog = new("ErrorLogBuilder",_pvxConstants,ViewManager)
    _eventLog'bufferInit()
    _eventLog'bufferAddText("["+psMajor$+"]"+$0A$+"==:"+psMinor$+":=="+$0A$)

     switch psMajor$
    case _pvxConstants'Incremental_Build$
        switch psMinor$

        /* Convert a ProvideX data file to XML */
        case _pvxConstants'BuildType_DataFile$
            _obj'data2xml(source$)
            break
        /* Convert a XML to ProvideX data file */
        case _pvxConstants'BuildType_OtherFile$
            _obj'xml2data(source$,dest$)
            break
        end switch
        break
     end switch

    _eventLog'bufferWriteText()
    drop object _eventLog

return 0

Next Section: Event Arguments


Event Arguments

The arguments that are passed into an event are generally the same for all events that share the same major ID. This section will list all of the arguments that are passed into each event.

Eclipse Shutdown

There are no arguments for this event.

Adding Resources to Source

This event is triggered for the import/convert process. As each new file is imported, an Incremental Build is triggered on that file to complete the process.

_pvxConstants'Project_Member_Count$
The number of files to be processed for this event.
_pvxConstants'Project_Name$
The name of the project that will be affected by this event.

Full Build

This event is triggered for the automated build process that is used when performing a clean build or when forcing a build of selected files. As each new file is imported, an Incremental Build is triggered on that file to complete the process.

_pvxConstants'Project_Location$
The full path (in the local file system) of the root folder for the project.
_pvxConstants'Project_Member_Count$
The number of files to be processed for this event.
_pvxConstants'Project_Name$
The name of the project that will be affected by this event.

Import / Export Properties

This event is triggered when the user chooses to import or export properties for selected projects in the workspace.

_pvxConstants'Project_List$
The list of projects to be exported or imported.
_pvxConstants'Import_Export_File$
The full path (in the local file system) of the file where the properties will be written.

Incremental Build

This event is triggered for any action that will require that the "compiled" version of a source file must be regenerated.

_pvxConstants'SrcFile$
The full path (in the local file system) to the current source file for this event; this file reference will change if/when a contributed tool modified the source file content.
_pvxConstants'event_SrcFile$
The full path (in the local file system) to the "original" source file for this event.
_pvxConstants'BuildLog$
The full path to a log file for any messages that are generated during the processing of this event. This file has a special format and is used to update the "Errors" and "Warnings" under the 'Problems' tab in the workbench.
_pvxConstants'BuildType$
This is the minor code for the event and is used to identify the type of build that is happening.
_pvxConstants'Dest$
The full path (in the local file system) to the destination file that will be created (or updated) as a result of this event.
_pvxConstants'DomFile$
The full path (in the local file system) to the file that will store the information displayed in the 'Outline' view.
_pvxConstants'isLine_Numbs_Required$
A flag that is used by the build process for ProvideX programs to indicate that the destination program requires line numbers.
_pvxConstants'pkf_Password$
The password to be used to encrypt the ProvideX program that is created.

Incremental Build - Alternate Executable

Each project and resource has a property to identify the ProvideX executable to use when building that resource. If this is different from the executable that was assigned to the plug-in on the ProvideX preference page, the build will use this event as a wrapper around the normal incremental build event. This event will start a RPC-style process that will use the alternate executable to process the normal incremental build event.

_pvxConstants'Builder_Exe$
The full path (in the local file system) of the alternate executable.
_pvxConstants'SrcFile$
The full path (in the local file system) to the current source file for this event; this file reference will change if/when a contributed tool modified the source file content.
_pvxConstants'event_SrcFile$
The full path (in the local file system) to the "original" source file for this event.
_pvxConstants'BuildLog$
The full path to a log file for any messages that are generated during the processing of this event. This file has a special format and is used to update the "Errors" and "Warnings" under the 'Problems' tab in the workbench.
_pvxConstants'BuildType$
This is the minor code for the event and is used to identify the type of build that is happening.
_pvxConstants'Dest$
The full path (in the local file system) to the destination file that will be created (or updated) as a result of this event.
_pvxConstants'DomFile$
The full path (in the local file system) to the file that will store the information displayed in the 'Outline' view.
_pvxConstants'isLine_Numbs_Required$
A flag that is used by the build process for ProvideX programs to indicate that the destination program requires line numbers.
_pvxConstants'pkf_Password$
The password to be used to encrypt the ProvideX program that is created.

Password

This event is triggered when passwords are to be validated or captured for a resource.

_pvxConstants'SrcFile$
The full path (in the local file system) to the source file to be used for this event.
_pvxConstants'pkf_Password$
The password to be validated against the specified source file.

Preference Change

This event is triggered for each preference that is modified.

_pvxConstants'Preference_Property$
The name of the preference property that has been modified.
_pvxConstants'Preference_New_Value$
The new value for this preference.
_pvxConstants'Preference_Old_Value$
The old value for this preference.

Preference Page Button

This event is triggered when the user accepts the modifications to the preference page(s).

_pvxConstants'PageID$
The name of the preference page where the properties were modified.

Run Console

This event is triggered when a user chooses either "Run ProvideX Console" or "Load Program" menu option.

The minor code for this event is the OS command to be executed to complete the event.
_pvxConstants'Project_INI_File$
The full path (in the local file system) to the INI file for the project.
_pvxConstants'Project_Output_Directory$
The full path (in the local file system) to the Output directory for the project.
_pvxConstants'SrcFile$
** OPTIONAL ** The full path (in the local file system) to the program to be loaded into the console mode workspace.

Run Designer

This event is triggered when the users presses the "Open selected panel in NOMADS designer" button in the NOMADS view.

The minor code for this event is the OS command to be executed to complete the event.
_pvxConstants'Project_INI_File$
The full path (in the local file system) to the INI file for the project.
_pvxConstants'Project_Output_Directory$
The full path (in the local file system) to the Output directory for the project.

Run Dictionary Maintenance

This event is triggered when the users presses the "Open Data Dictionary" button in the Embedded Dictionary view.

The minor code for this event is the OS command to be executed to complete the event.
_pvxConstants'Project_INI_File$
The full path (in the local file system) to the INI file for the project.
_pvxConstants'Project_Output_Directory$
The full path (in the local file system) to the Output directory for the project.

Run IT

The minor code for this event is the OS command to be executed to complete the event.
_pvxConstants'Project_INI_File$
The full path (in the local file system) to the INI file for the project.
_pvxConstants'Project_Output_Directory$
The full path (in the local file system) to the Output directory for the project.
_pvxConstants'SrcFile$
The full path (in the local file system) to the source file to be loaded into the editor.

Run NOMADS

This event is triggered when the users presses the "Run ProvideX NOMADS (external)" button in the NOMADS view. There are no arguments for this event.

The minor code for this event is the OS command to be executed to complete the event.

Run 'Test Panel'

The minor code for this event is the OS command to be executed to complete the event.
_pvxConstants'Project_INI_File$
The full path (in the local file system) to the INI file for the project.
_pvxConstants'Project_Output_Directory$
The full path (in the local file system) to the Output directory for the project.

Strip Line Numbers

The minor code for this event is the OS command to be executed to complete the event.
_pvxConstants'Project_INI_File$
The full path (in the local file system) to the INI file for the project.
_pvxConstants'Project_Output_Directory$
The full path (in the local file system) to the Output directory for the project.
_pvxConstants'SrcFile$
The full path (in the local file system) to the source file to be used for this event.

Next Section: What is a contributed tool?


Contributed Tools

Extending Plug-in Capabilities

The ProvideX plug-in has been designed to allow additional functionality to be added without requiring a large effort. The current version of the plug-in provides two methods to accomplish this.

Enhance Existing Events
Add new logic around the existing events (or logic) in the plug-in. This provides a mechanism for integrating with exiting tools and methodolgies for managing source code and documenting the history of an application.
External Tools
Add links to connect to external tools that are not directly associated with any of the events in the current ProvideX plug-in.

Using a Contributed Tool

This section will discuss the steps required to integrate an external tool into the Eclipse framework through the ProvideX Plug-in.

Built-in Contributed Tools

PvxDocs
Adds the capability to generate class documentation from the comments in the source code for a project.
Style Check
Adds a rules-based source code validation tool.
Convert XMI to ProvideX
Adds the ability to take an XMI definition and create ProvideX class definitions from it.
XML Conversion
Converts ProvideX keyed files to XML or XML files to ProvideX keyed files. It can also be enabled as an observer to the build process.

Next Section: Contributed tool Class template


Contributed Tool Class Template

The Class

The ActionListenerExample class is a template to be used when writing a new contributed tool.

API Documentation

Click HERE to view the API documentation for this class template. The complete documentation for all of the classes can be found in the API Reference.

Source Code

Click HERE to view the source for this class. This class does not include any code and it is intended to be used as a template for creating new observers.

Review the Class

Class Description

The theDescription$ private property must be set to a description for the new class.

Event Notification

The theNotificationFlag private property must be set to _pvxConstants'_ideNone to indicate that this class in not an event observer and can only be executed from the ProvideX | Contributed Tools menu.

Do the Work

The actionPerformed() method must be modified to add the logic that will be executed when the event has been triggered.

Next Section: Example 1: No configuration


Example 1: No Configuration

The Class

The ActionListenerExample class is a simple example of a contributed tool that does not have any configuration logic.

API Documentation

Click HERE to view the API documentation for this class.

Source Code

Click Formatted HTML or Simple Text to view the source code for the class.

Do the Work

The do_ActionPerformed() method has been modified to write a simple message to:

  • Plug-in debug event log
  • Console view
  • A standard ProvideX message box
do_ActionPerformed:
    enter IExtCommand

    /*
     * Write a short message to the Plug-in debug EventLog
     */
    _eventLog=new("ErrorLogBuilder",_pvxConstants,ViewManager)
    _eventLog'bufferInit()
    _eventLog'bufferAddText("Contributed tool: "+_obj'getDescription$()+$0A$)
    _eventLog'bufferWriteText()
    drop object _eventLog

    ! write a message to the 'Console' view
    aReq=new("pvxrequestclient")
    aReq'print("Contributed tool: "+_obj'getDescription$())
    drop object aReq

    ! Finally, use standard ProvideX message box to display message
    msgbox "Example contributed tool - my work is complete.","Message"

return

Next Section: Example 2: Use Progress Log


Example 2: Progress Log

The Class

This contributed tool (stripTrailing) is broken down into several separate pieces that work together to deliver the desired functionality to the user.

In this case, a NOMADS panel is used to display the output from the tool and to also allow the user to interact with the tool as it performs the work.

API Documentation

Listener
Click HERE to view the API documentation for the listener portion of this contributed tool.
User Interface
Click HERE to view the API documentation for the user interface portion of this contributed tool.
Plug-in Class: NOMADS Interface
Click HERE to view the API documentation for the standard NOMADS interface class that is part of the Plug-in.
Plug-in Class: ProgressLog
Click HERE to view the API documentation for the standard ProgressLog class that is part of the Plug-in.

Source Code

Listener
Click Formatted HTML or Simple Text to view the source code for the listener portion of this contributed tool.
User Interface
Click Formatted HTML or Simple Text to view the source code for the user interface portion of this contributed tool.

Do the Work

This contributed tool is broken down into several separate pieces that work together to deliver the desired functionality to the user. In this case, a NOMADS panel is used to display the output from the tool and to also allow the user to interact with the tool as it performs the work.

Listener

The do_ActionPerformed() method in the listener for this contributed tool simply starts the user interface class in a new process which will be responsible for completing the work.

do_ActionPerformed:
enter (IExtCommand)
    local oCommon
    oCommon=new("ecCommon")
    oCommon'processPanel(cUI$,cTitle$)
    drop object oCommon
return
User Interface

The user interface class inherits the standard Plug-in class com.pvx.util.progress which provides a simple progress log window that includes several buttons to allow user interaction as the work progresses. This class requires the child class to implement a do_work() method to perform the required work for the contributed tool and also manage the available features of the interface.

The child class interacts with the user interface using the following methods:

_obj'enable_cancel()
Use this method to enable the Cancel button.
_obj'checkCancel()
If Cancel has been enabled, the child class must use this method to determine if the user has attempted to cancel the task.
_obj'disable_cancel()
If Cancel has been enabled, the child class should use this method during any portion of work that cannot be aborted (such as an update).
_obj'writeLog(message$)
Use this method to write the value in the argument message$ to the progress log window.

The following image show an example if the user interface that will be presented to the user.

Example - Progress Log

Next Section: Example 3: Style Check


Example 3: Style Check

The Class

The simpleStyleCheck class shows the minimal amount of code required to enable a user-defined source code validation capability that is based on the built-in ecStyleCheck group of classes.

API Documentation

User class
Click HERE to view the API documentation for this class.
Plug-in Class: ecStyleCheck
Click HERE to view the API documentation for this class.
Plug-in Class: ecStyleCheckEditUI
Click HERE to view the API documentation for the user interface class for the configuration action of the style check.
Plug-in Class: ecStyleCheckUI
Click HERE to view the API documentation for the user interface class for to set the run-time options for the style check.
Plug-in Class: ecStyleCheckRun
Click HERE to view the API documentation for the user interface class for the run-time progress log for the style check.

Source Code

Click Formatted HTML or Simple Text to view the source code for the class.

Do the Work

The constructor for this contributed tool loads the style rules. The remainder of the logic for the source code validation is inherited from ecStyleCheck.

def class "simpleStyleCheck" create required
    like "ecStyleCheck"

    ! ** specify the name of the file that contains the style rules
    ! ** default value: %PvxCode(mid(pgn,1,pos(dlm=pgn,-1))+_obj'_Class$+"_rules.txt")%
    local styleRulesFile$=mid(pgn,1,pos(dlm=pgn,-1))+_obj'_Class$+"_rules.txt"
    ! ** Override Description
    local theDescription$="Simple rule-based Style Check"

end def

on_create:
    ! Use the method from the parent class to load the rules
    _obj'loadRules(from "ecStyleCheck",styleRulesFile$)
return

end

Next Section: Example 4: With Configuration


Example 4: With Configuration

The Class

The toolWithConfig class is a simple example of a contributed tool with configuration logic.

API Documentation

Click HERE to view the API documentation for this class.

Source Code

Click Formatted HTML or Simple Text to view the source code for the class.

Do the Work

Run Action

The do_ActionPerformed() method has been modified to write a simple message to:

  • Console view
  • A standard ProvideX message box
do_ActionPerformed:
    enter IExtCommand

    ! write a message to the 'Console' view
    aReq=new("pvxrequestclient")
    aReq'print("Contributed tool: " + _obj'getDescription$() + " - Action completed.")
    drop object aReq

    ! Finally, use standard ProvideX message box to display message
    msgbox "Example contributed tool - my work is complete.","Message"

return
Configure Action

The do_ConfigPerformed() method has been modified to write a simple message to:

  • Console view
  • A standard ProvideX message box
do_ConfigPerformed:
    ! write a message to the 'Console' view
    aReq=new("pvxrequestclient")
    aReq'print("Contributed tool: " + _obj'getDescription$() + " - Configuration completed.")
    drop object aReq

    msgbox "Example contributed tool - configuration is complete.","Message"

return

hasConfigAction:
    ! Return True (1) since the configuration action logic has been implemented
    return 1

Next Section: Example 5: Action on build files


Example 5: Action on build files

The Class

The execModifiedFiles class is a simple example to show how to perform an action for each file updated by the build process.

API Documentation

Click HERE to view the API documentation for this class.

Source Code

Click Formatted HTML or Simple Text to view the source code for the class.

How Does It Work

This class will be registered as a PostProcess observer and will monitor the following events:

  • Full Build Start
  • Incremental build for a single file
  • Full Build End

These events are triggered when:

  • A file is saved in the editor
  • The build action is selected from the popup menu in the editor
  • he build action is selected against one or more selected files in the Navigator View

Since this contributed tool will be triggered by one or more events, the logic must be placed in the update() method. The logic will create a list of files processed by the build, and perform an action for each file.

The list of files is initialized when the full build starts. As each file is processed, the build post-process trigger is used to add the relative path of each file to the list. At the end of the full build, the name of each file in the list is written to the console.

Next Section: Example 6: Configuration and Progress


Example 6: Configuration and Progress

Class Files

This contributed tool is more complex than most of the other examples and includes the following features:

  • Configuration panel to view, change, and save configuration values to Eclipse Preference store
  • Progress panel to show messages as the run action is working; the values saved on the configuration panel to control the actions performed
  • A Listener class to catch the configuration and run actions for this tool from the Contributed Tools menu and execute to appropriate UI class.

API Documentation

Click the links below to view the API (class) documentation for each of the classes used to implement this contributed tool.

Configuration and Progress - Configure action
Click HERE to view the API documentation for the Configure action UI class.
Configuration and Progress - Listener
Click HERE to view the API documentation for the Listener class.
Configuration and Progress - Run action
Click HERE to view the API documentation for the Run action UI class.
Plug-in Class: NOMADS Interface
Click HERE to view the API documentation for the standard NOMADS interface class that is part of the Plug-in.
Plug-in Class: ProgressLog
Click HERE to view the API documentation for the standard ProgressLog class that is part of the Plug-in.

Source Code

Click the links below to view the source code for each of the classes used to implement this contributed tool.

  • Click Formatted HTML or Simple Text to view the source code for the Configuration UI class.
  • Click Formatted HTML or Simple Text to view the source code for the Listener class.
  • Click Formatted HTML or Simple Text to view the source code for the Run action UI class.

Do the Work

This contributed tool is accessed from the Contributed Tools menu.

As described above, this contributed tool is broken down into several pieces that work together to deliver the desired functionality to the user.

  • A NOMADS panel and supporting class to configure how the contributed tool will work.
  • An Action Listener class that waits for an action to be initiated for this contributed tool from the Contributed Tools menu and then performs the selected action.
  • A NOMADS panel and supporting class to display information from the tool and allow the user to interact with the tool as it performs the work.
Configure Action - Listener

When the Configure action is selected for this tool from the Contributed Tools list, the configPerformed() method in the listener is called.

do_ConfigPerformed:

    local oCommon

    oCommon=new("ecCommon")
    oCommon'ConfigGuiDisplay()
    oCommon'processPanel(cConfigUI$, cConfigTitle$)
    drop object oCommon

return
Configure Action - User Interface

The user interface class inherits the standard Plug-in class ecCommonUI which provides base User Interface functionality. A NOMADS panel must be created in a library file and the supporting logic added to this class.

Example - WCaP Configure Action - Configuration panel
Run Action - Listener

When the Run action is selected for this tool from the Contributed Tools list, the do_ActionPerformed() method in the listener called.

do_ActionPerformed:

    enter IExtCommand

    local oCommon

    oCommon=new("ecCommon")
    oCommon'processPanel(cRunUI$, cRunTitle$)
    drop object oCommon

return
Run Action - User Interface

The user interface class inherits the standard Plug-in class com.pvx.util.progress which provides a simple progress log window that includes several buttons to allow user interaction as the work progresses. This class requires the child class to implement a do_work() method to perform the required work for the contributed tool and manage the available features of the interface.

The child class interacts with the user interface using the following methods:

_obj'createLogFile(aNamePfx$) or _obj'createLogFile(aNamePfx$, btnText$)
Use this method to create a temporary log file to update during the execution of the tool; the file will be deleted upon exit of the tool.
  • The aNamePfx$ value will be used as the first part of the log file name; use a value to make it easy to associate the log file with the contributed tool.
  • When the work is complete, a 'View Log' button will display to allow the user to view the log file; use the btnText$ parameter to override the default text for this button.
info When this method is used to create a log file, a 'View Log' button will display when the process is complete.
_obj'enable_cancel()
Use this method to enable the Cancel button.
_obj'checkCancel()
If Cancel has been enabled, the child class must use this method to determine if the user has attempted to cancel the task.
_obj'disable_cancel()
If Cancel has been enabled, the child class should use this method during any portion of work that cannot be aborted (such as an update).
_obj'enable_special(btnText$)
Use this method to show and enable the 'Special' button action after the process has completed. The btnText$ value will be displayed as the text on the button (must not be longer than 10 characters).
info Override the b_special() method to implement an action to perform when the button is clicked. The action can be used to view a detailed log file or special report.
_obj'disable_special()
Use this method to disable the special button.
_obj'writeLog(message$) or _obj'writeLog(message$,logFile$)
Use this method to write the value in the argument message$ to the progress log window. if a logFile$ is specified, the message will also be appended to the file.
_obj'writeLogFile(message$) or _obj'writeLogFile(message$,logFile$)
Use this method to write the value in the argument message$ to the specified log file. When the log file is not specified, the value is written to the file created by the _obj'createLogFile() method.

The following image shows the user interface after the user has cancelled the work in progress.

Example - WCaP Run Action - Work Cancelled

The following image shows the user interface after the user has allowed the work to complete. Notice the WooHoo! button - this button was enabled by calling the _obj'enable_special() method. When the user clicks the button the logic associated with the b_special() method is called.

Example - WCaP Run Action - Work Completed


Source Code Examples

This section includes the source code for several of the standard ProvideX utility programs that have been used as examples in the Developer Guide. It also includes the source code for an error handler that is based on the one used inside the plug-in.

Contents

  • Background Task Communications
  • Error Handler (Simple GUI Viewer)
  • Standardized Application Splash Screen


! *obj/background_task_comm.pvc

! (c) Copyright 2006, Sage Software Canada Ltd. (Ontario, Canada)

! $Id: background_task_comm.pvc.pvxsrc 406 2012-12-13 22:38:26Z fmcguirk $

/*

! ** This program can be used to assist with debugging in a background process on UNIX/Linux.

! **

! ** Start a listener in a new ProvideX process - this process will be "suspended" until

! ** the other task connects to the listener.  When using this class to assist with debug

! ** of a background process, it is easier to specify a name for the listener.

! **

! ** Add a line into the program executing in the background (or other) process to transfer

! ** terminal I/O to the listener process with the ID that is displayed on the listener

! ** screen.  You can then step through the code in the background process.  When

! ** complete, the connection to the listener must be broken so that normal processing can

! ** continue for both processes.

! **

! ** Steps:

! ** ==>

! ** Declare a new instance of this class

! ** Start the listener and optionally specify a name: %PvxCode(aTask=new("*obj/background_task_comm"); aTask'listenByName("DebugOne"))%

! ** Add line to background task program: %PvxCode(doDebug=new("*obj/background_task_comm"); doDebug'talk("DebugOne"); escape)%

! ** Step through the code in the background process.

! ** To disconnect from the listener (and leave it running), use the command: %PvxCode(doDebug'resume(""))%

! ** To disconnect from the listener (and stop it) use the command: %PvxCode(doDebug'stop_Listener("DebugOne"); run)%

! ** <==

! **

! ** Do not forget to include the 'RUN' directive, otherwise the background process will

! ** be left in console mode and it will have to be killed.  An alternative method is to

! ** simply delete the lock file that has been created in the '/tmp' directory.  The file

! ** is named "pvx_lock_"+ID$.

! **

 */

def class "*obj/background_task_comm" unique create required delete required

    local LISTEN=1,TALK=2

    local SLEEP_TIME=5

    local linkFile$,lockFile$,temp_dir$,this_PID$,this_Task

    ! ** Create a listener and automatically generate a name that is based in the process ID.

    function listen()                listen

    ! ** Create a listener and give it the name specfied.

    ! **

    ! ** @param aPID$  Fixed name or ID for the listener

    function listenByName(aPID$)    listenByName

    ! ** Resume execution of the program and keep the listener active.

    function resume()                resume

    ! ** Stop the specified listener

    ! **

    ! ** This task will erase the lock file for the specified LISTENER.  This command is

    ! ** executed within the workspace of the connecting process to break the connection

    ! ** and force the LISTENER process to stop.

    ! **

    ! ** @param aPID$  Fixed name or ID for the listener

    function stop_listener(aPid$)    stop_listener

    ! ** Transfer all terminal I/O to the specified LISTENER task.

    ! **

    ! ** This task will redirect all terminal I/O to the specified LISTENER.  This command

    ! ** is executed within the workspace of the connecting process to cause all terminal

    ! ** I/O to be redirected.  This is useful for allowing a debug process to be initiated.

    ! **

    ! ** @param aPID$  Fixed name or ID for the listener

    function talk(aPid$)            talk

end def

On_Create:

    local x$,x

    if pos("ix"=lcs(sys))=0 \

    {

        print "Only supported on UNIX platforms"

    } else {

        this_PID$=str(tcb(89))

        /* Set location of temp directory where LINK file is created */

        x$=tsk(-1), \

        x$=ucs(x$(2))+"TMP", \

        temp_dir$=env(x$)

        if temp_dir$="" \

        then temp_dir$=env("TEMP")

        if pos("ix"=lcs(sys)) and temp_dir$="" \

        then temp_dir$="/tmp"

        if temp_dir$<>"" \

        then temp_dir$+=dlm

    }

return

On_Delete:

    switch this_Task

    case _OBJ'LISTEN

        erase temp_dir$+aLockFile$,err=*next

        erase temp_dir$+aLinkFile$,err=*next

        break

    case _OBJ'TALK

        line_switch

        break

    end switch

return

/*

 * Create the LISTENER task.

 *

 * This task will wait for the background process to connect using the PID specified in the

 * creation command or generated from the LISTENER process ID.

 *

 * Arguments:

 *  aPID$    - ID to assign to the LISTENER process; this argument is optional and if it is

 *            not provided, the LISTENER process ID will be used.

 */

listenByName:

    enter aPID$,err=*next

listen:

    enter aPID$,err=*next

    if not(nul(aPID$)) \

    then this_PID$=aPID$

    local dim lf_Data$(256),linkFile$

    if pos("ix"=lcs(sys))>0 \

    {

        this_Task=_OBJ'LISTEN

        /*

         * First, a LINK file is required to allow a connection to be made

         * to this process from another ProvideX process.

         *

         * This file is be Process-Specific and will include the PID in the name.

         */

        linkFile$="HoldTTY_"+this_PID$

        erase temp_dir$+linkFile$,err=*next

        serial temp_dir$+linkFile$,err=*next

        lf_Data$(1,8)="[Pvxdev]", \

        lf_Data$(9,60)=fin(0,"Filename"), \

        lf_Data$(69,40)=fin(0,"Driver")

        open lock (hfn,isz=1)temp_dir$+linkFile$

        write record (lfo)lf_Data$

        close (lfo)

        /*

         * Create a lock file to be used to break the communications link

         */

        print 'CS',"Connect to process '"+this_PID$+"', waiting...",

        lockFile$="pvx_lock_"+this_PID$

        serial temp_dir$+lockFile$,err=*next

        /*

         * As long as this file exists, this process will sleep.  This allows another

         * process to use this one for I/O for communications.

         */

        open (hfn,err=*next)temp_dir$+lockFile$;

        close (lfo);

        wait SLEEP_TIME;

        goto *same

        /*

         * Now delete the LINK file, since the listener is no longer active!

         */

        erase temp_dir$+linkFile$,err=*next

    }

return

! Resume execution of the program and keep the listener active.

resume:

    preinput "RUN"

    line_switch

return

/*

 * Stop the specified LISTENER task.

 *

 * This task will erase the lock file for the specified LISTENER.  This command is executed

 * within the workspace of the connecting process to break the connection and force the

 * LISTENER process to stop.

 *

 * Arguments:

 *  aPID$    - ID to assign to the LISTENER process

 */

stop_listener:

    enter aPID$

    local lockFile$

    if pos("ix"=lcs(sys))>0    \

    {

        if aPID$="" \

        {

            print "There is no active listener in this session."

        } else {

            lockFile$="pvx_lock_"+aPID$

            /* Delete the LINK file to stop the listener */

            print @(0),"Attempting to clear lock for listener...",;

            wait 1;

            erase temp_dir$+lockFile$,err=*same

            this_PID$=""

            print 'CS',"The listener in process '"+aPid$+"' will stop within "+ \

                str(SLEEP_TIME)+" seconds."

            /* Return I/O to originating process */

            line_switch

        }

    }

return

/*

 * Transfer all terminal I/O to the specified LISTENER task.

 *

 * This task will redirect all terminal I/O to the specified LISTENER.  This command is

 * executed within the workspace of the connecting process to cause all terminal I/O to be

 * redirected. This is useful for allowing a debug process to be initiated.

 *

 * Arguments:

 *  aPID$    - ID to assign to the LISTENER process

 */

talk:

    enter aPID$

    local linkFile$,found

    if pos("ix"=lcs(sys))>0    \

    {

        this_Task=_OBJ'TALK

        linkFile$="HoldTTY_"+aPID$

        found=0;

        open (hfn,err=*next)temp_dir$+linkFile$;

        found=1;

        close (lfo)

        if not(found) \

        {

            print "There is no listener at the specified address ("+aPID$+")!"

        } else {

            set_param -'xt';

            preinput 2; preinput 2; preinput 2

            line_switch temp_dir$+linkFile$

            escape \        /* *SC-OK*  */

        } \

    }

return

end


!

! (c) Copyright 2006-2011, Sage Software Canada Ltd. (Ontario, Canada)

! $Id: _error_handler.pvx.pvxsrc 5519 2014-04-04 22:45:12Z fmcguirk $

! PP4E: *Id: error_handler.pvx.pvt 1071 2011-05-17 11:35:40Z fred.mcguirk *

/*

 * Error handler to provide more detailed information about current error condition.

 *

! ** @Author fmcguirk  @Date Dec 13, 2006 2:22:00 AM

!

 * This error handler will create a log file within system TEMP directory called

 * 'pvx_errorlog_<pgm>_<ErrNo>_<YYYYMMDD><UID>.txt'

 *

 * If the file exists, it will be overwritten.

 */

init:

    local fc,lc,log_dir$,log_file$,log_text$,fopen,x$,x

    ! Disable Error handler by forcing any error to end session

    seterr ""

    seterr get_out

    local errorNumber      = num(err("err"))

    local errorNumberTxt$  = msg(errorNumber)

    local errorSystem      = num(err("ret"))

    local osErrorMsg$      = err("oserr")

    local errorLine        = num(err("stno"))

    local errorProgram$    = err("program")

    local errorEntryPoint$ = err("entrypoint")

    local errorObject      = num(err("obj"))

    if errorObject {

        local errorMethod$    = err("method")

        local errorObjectTxt$ = errorObject'_class$

    }

    local msgLineWide

    local screenCols = int( dec($00$+mid(mse,27,2)) / dec($00$+mid(mse,10,1)) )

    local screenRows = int( dec($00$+mid(mse,29,2)) / dec($00$+mid(mse,11,1)) )

    local col, cols, row, rows, tmp, tmp$

    ! Variables to control content of the Log file (set default content)

    local pp4e_eh_pvxinfo     = 1

    local pp4e_eh_dump        = 1

    local pp4e_eh_dump_object = 1

    local pp4e_enable_debug   = 0

    local pp4e_eh_files       = 1

    local pp4e_eh_objects     = 1

    local pp4e_eh_prefix      = 1

    local pp4e_eh_public      = 0

    local pp4e_eh_stack       = 1

    local pp4e_eh_sysparam    = 1

    local pp4e_keep_logfile   = 0

    local pp4e_eh_display     = 1

    local pp4e_eh_add_config  = 1

    local pp4e_eh_log_file$   = ""

    /* Enable DEBUG button if any of DEVELOPER, EDIT, or LIST bits are set */

    if and($70000000$,bin(tcb(0,2),4))<>$00000000$ {

        pp4e_enable_debug     = 1

    }

    tmp = pos(dlm=errorProgram$,-1)

    if tmp { errorProgram$ = errorProgram$(tmp+1) }

    /*

     * Get name and location of the error handler; save/change/restore the

     * system parameter 'OP' to ensure that we get the full path of the program

     */

    local saveParamOP       = prm('op')

    set_param 'op'          = 0

    local errorConfigDir$   = mid(pgn,1,pos(dlm=pgn,-1))

    local errorHandlerName$ = mid(pgn,pos(dlm=pgn,-1)+1)

    x=pos("."=errorHandlerName$);

    if x>0 {

        errorHandlerName$=mid(errorHandlerName$,1,x-1)

    }

    set_param 'op'          = saveParamOP

     /*

      * Look for a file with the same name as the error handler and a '.config' file

      * extension in same directory as the error handler; this file will be used

      * to determine the content of the log file that is created by the error

      * handler.

      *

      * See below for additional details for the content of this file.

      */

     if not(nul(errorConfigDir$)) {

         open input (hfn,err=*next)errorConfigDir$+errorHandlerName$+".config";

         ec=lfo

        if ec {

            pp4e_eh_log=1

            while 1

                ! Initial control variables

                read data from "" to iol=config_iol

                ! get the next record from configuration file

                read (ec,err=*break)ec_line$

                ec_line$=cvs(ec_line$,19)+" "

                ! Skip comment lines

                if mid(ec_line$,1,1)="#" { continue }

            ! Is this line a keyword assignment?

                isAssign = pos("="=ec_line$)

                value$ = "", value = 0

                if isAssign>0 {

                    ec_line$(isAssign,1)=$0A$

                    read data from ec_line$,sep=$0A$ to iol=config_iol, err=*next

                    ! Strip leading / trailing spaces

                    keyword$ = cvs(keyword$, 3), \

                    value$ = cvs(value$, 3)

                    ! Validate the value for specific keywords

                    value = num(value$, err=*next)

                    switch lcs(keyword$)

                    case "dump"

                        if value<0 or value>2 { value = 0 }

                        break

                    case "log_file"

                        open input (hfn,err=*next)value$; fhTest = lfo

                        if fhTest > 0 {

                            ! If file exists and is not a text file, ignore setting

                            if mid(fib(fhTest), 19, 1) <> "S" {

                                value$ = ""

                                close (fhTest); fhTest = 0

                            }

                        }

                    default

                        if value<0 or value>1 { value = 0 }

                        break

                    end switch

                 } else {

                     keyword$=mid(ec_line$,1,pos(" "=ec_line$)-1)

                     value = 1

                }

                ! process configuration file settings

                switch lcs(keyword$)

                case "add_config";      pp4e_eh_add_config  = value;  break

                case "display";         pp4e_eh_display     = value;  break

                case "dump";            pp4e_eh_dump        = value;  break

                case "dump_all";        pp4e_eh_dump        = 2;      break

                case "dump_object";     pp4e_eh_dump_object = value;  break

                case "enable_debug";    pp4e_enable_debug   = value;  break

                case "files";           pp4e_eh_files       = value;  break

                case "keep_log";        pp4e_keep_logfile   = value;  break

                case "log_file";        pp4e_eh_log_file$   = value$; break

                case "objects";         pp4e_eh_objects     = value;  break

                case "prefix";          pp4e_eh_prefix      = value;  break

                case "public";          pp4e_eh_public      = value;  break

                case "pvx_info";        pp4e_eh_pvxinfo     = value;  break

                case "stack";           pp4e_eh_stack       = value;  break

                case "system_param";    pp4e_eh_sysparam    = value;  break

                end switch

            wend

            close (ec); ec=0

        }

    }

init_log:

    /*

     * Include program and error number in the log file name - only record the last

     * occurance of the error in the program - this is to reduce disk space usage when

     * the same error is generated repeatedly until process is killed!

     */

    if nul(pp4e_eh_log_file$) {

        log_file$ = fngetLogFile$("pvx_errorlog_"+errorProgram$+"_"+str(errorNumber))

    } else {

        log_file$ = pp4e_eh_log_file$

    }

    erase log_file$,err=*next

    serial log_file$,err=done

    open lock (hfn,err=done)log_file$;

    lc=lfo

    print (lc,err=*next)"# "+dte(0:"[ %Dl, %Ms %D/%Y %hz:%mz ]")

    print (lc,err=*next)'lf',fnTitle$("Error summary")

    tmp$  = stp(errorNumberTxt$,3,"#")

    tmp   = pos(":"=tmp$)

    if tmp { errorNumberTxt$ = cvs(tmp$(tmp+1),1) }

    errNumDisp$ = "Error " + str(errorNumber:"##0")

    print (lc,err=*next)pad( errNumDisp$,  20, "." ) + errorNumberTxt$

    print (lc,err=*next)pad( "Program",    20, "." ) + errorProgram$

    print (lc,err=*next)pad( "Statement",  20, "." ) + str(errorLine)

    tmp$ = msg(-1)

    if not(nul(tmp$)) {

        print (lc,err=*next)pad( "MSG(-1)",  20, "." ) + tmp$

    }

    if errorObject {

        print (lc,err=*next)pad( "Class",  20, "." ) + errorObjectTxt$

        print (lc,err=*next)pad( "Method", 20, "." ) + errorMethod$

    }

log_details:

    if pp4e_eh_pvxinfo  { gosub pvx_info        }

    if pp4e_eh_sysparam { gosub system_params   }

    if pp4e_eh_prefix   { gosub prefix_list     }

    if pp4e_eh_stack    { gosub stack_trace     }

    if pp4e_eh_files    { gosub open_files      }

    if pp4e_eh_public   { gosub public_programs }

    if pp4e_eh_objects  { gosub list_objects    }

    if pp4e_eh_dump>0   { gosub eh_dump         }

    if errorObject {

        if pp4e_eh_dump_object { gosub eh_object_dump }

    }

    /* Include information about the error handler configuration. */

    if pp4e_eh_add_config = 0 { goto done }

    print (lc,err=*next)'lf',fnTitle$("Error Handler Configuration")

    print (lc,err=*next)"The information captured by the error handler (for this workspace) can be controlled"

    print (lc,err=*next)"by settings stored in the configuration file:"

    print (lc,err=*next)errorConfigDir$+"error_handler.config"

    print (lc,err=*next)'lf',"The supported settings are:"

    print (lc,err=*next)"ADD_CONFIG   - Add configuration info to log file:  0 = Disabled, 1 = Enabled"

    print (lc,err=*next)"DISPLAY      - Display dump log in pop-up:          0 = Disabled, 1 = Enabled"

    print (lc,err=*next)"DUMP         - Dump data for workspace:             0 = Disabled, 1 = Current Level, 2 = All Levels"

    print (lc,err=*next)"DUMP_OBJECT  - Dump data for current object:        0 = Disabled, 1 = Enabled"

    print (lc,err=*next)"ENABLE_DEBUG - Allow access to CONSOLE prompt:      0 = Disabled, 1 = Enabled"

    print (lc,err=*next)"FILES        - List open files:                     0 = Disabled, 1 = Enabled"

    print (lc,err=*next)"KEEP_LOG     - Keep the log file on exit:           0 = Disabled, 1 = Enabled"

    print (lc,err=*next)"LOG_FILE     - full path to alternate log file; existing file will be erased"

    print (lc,err=*next)"OBJECTS      - List OOP objects:                    0 = Disabled, 1 = Enabled"

    print (lc,err=*next)"PREFIX       - Show the Prefix list(s):             0 = Disabled, 1 = Enabled"

    print (lc,err=*next)"PUBLIC       - Show public / cached programs:       0 = Disabled, 1 = Enabled"

    print (lc,err=*next)"PVX_INFO     - Information about ProvideX:          0 = Disabled, 1 = Enabled"

    print (lc,err=*next)"STACK        - Show program stack:                  0 = Disabled, 1 = Enabled"

    print (lc,err=*next)"SYSTEM_PARAM - System Parameters:                   0 = Disabled, 1 = Enabled"

    print (lc,err=*next)'lf',"The current settings are:"

    print (lc,err=*next)"add_config = " +   str(pp4e_eh_add_config)

    print (lc,err=*next)"display = " +      str(pp4e_eh_display)

    print (lc,err=*next)"dump = " +         str(pp4e_eh_dump)

    print (lc,err=*next)"dump_object = " +  str(pp4e_eh_dump_object)

    print (lc,err=*next)"enable_debug = " + str(pp4e_enable_debug)

    print (lc,err=*next)"files = " +        str(pp4e_eh_files)

    print (lc,err=*next)"keep_log = " +     str(pp4e_keep_logfile)

    if not(nul(pp4e_eh_log_file$)) \

        print (lc,err=*next)"log_file = " + pp4e_eh_log_file$

    print (lc,err=*next)"objects = " +      str(pp4e_eh_objects)

    print (lc,err=*next)"prefix = " +       str(pp4e_eh_prefix)

    print (lc,err=*next)"public = " +       str(pp4e_eh_public)

    print (lc,err=*next)"pvx_info = " +     str(pp4e_eh_pvxinfo)

    print (lc,err=*next)"stack = " +        str(pp4e_eh_stack)

    print (lc,err=*next)"system_param = " + str(pp4e_eh_sysparam)

done:

    if lc>0 \

    then close (lc)

    if not(pp4e_eh_display) \

    then goto finish_up

display_error_message:

    local BT_End, BT_Info, BT_Debug, xCTL, msgLines

    BT_End   = 1021, \

    BT_Info  = 1022, \

    BT_Debug = 1023

    local dim msgLine$[1:10]

    msgLines++        ! Force a blank line

    tmp$ = fnAddText$("", errNumDisp$ + " (" + errorNumberTxt$ + ") at line " + str(errorLine))

    if errorObject {

        tmp$ = fnAddText$("", "Class: " + errorObjectTxt$ + ", Method: " + errorMethod$ )

    } else {

        tmp$ = fnAddText$("", "Program: " + errorProgram$ )

    }

    msgLines++        ! Force a blank line

    ! Display the message

    cols = max(msgLineWide,40)

    rows = msgLines + 3

    col  = int ( (screenCols-cols) / 2 )

    row  = int ( (screenRows-rows) / 2 )

    print (0,err=get_out) 'DIALOGUE'(col,row,cols,rows,"Untrapped Error",opt="^Cix"),

    print 'mode'($000F$),'sr','df','cs','cursor'("off"), \

        'font'("MS Sans Serif",1),'gf','sf',

    for loop = 1 to msgLines

        print 'text'(@x(2),@y(loop-.25),msgLine$[loop]),

    next

    ! Add END button

    btnCol = cols - 12, \

    btnRow = rows - 2, \

    btnTxt$ = "End"

    button BT_End,@(btnCol,btnRow,10,1.5)=btnTxt$

    btnCol -= 10

    btnTxt$ = $$

    ! Add INFO button

    button BT_Info,@(btnCol,btnRow,10,1.5)="Info"

    btnCol -= 10

    ! Add DEBUG button

    if pp4e_enable_debug {

        button BT_Debug,@(btnCol,btnRow,10,1.5)="Debug"

        btnCol -= 10

    }

    ! force screen update

    wait 0

    ! Get user input

    while 1

        obtain (0,err=*next,tim=30)'bi',*,'ei'; xCTL=ctl

        if xCTL=BT_End or ctl=-1999 { break }

        if xCTL=BT_Info { gosub ShowInfo }

        if xCTL=BT_Debug { break }

    wend

get_out:

    print (0,err=*next)'pop',

    if xCTL=BT_Debug {

        print 'dialogue'(0,0,80,25,"Debug"),'cs',

        preinput "PRINT 'cs',"

        escape        /* *SC-OK* */

        print 'pop',

        goto display_error_message

    }

    if not(pp4e_keep_logfile) {

        erase log_file$, err=*next

    }

finish_up:

release

ShowInfo:

    local logFN, logSize, col, cols, row, rows, DB_Name, LB_Data, oCommon, \

        BT_Close, BT_Copy, BT_CopyAll

!print 'dialogue'(10,10,100,40,"Debug window",opt="^"),'cs',; escape

    open input (hfn,isz=1,err=*next)log_file$; logFN=lfo

    if logFN {

        logSize = num(fin(logFN,"filelength"))

        if logSize > dsz-50000 {

            logSize = 0

        } else {

            read record (logFN,ind=0,siz=logSize)logData$

            logData$ = sub(logData$, $0D0A$, $0A$, 0)

            numSections = pos($0A$+"***** "=logData$,1,0)

        }

        close (logFN); logFN=0

    }

    ! Create a "dummy" logFile with minimal information

    if numSections=0 {

        numSections = 2

        logData$ = \

            "# "+dte(0:"[ %Dl, %Ms %D/%Y %hz:%mz ]")+$0A0A$+ \

            fnTitle$("Error summary") + $0A$ + \

            errorNumberTxt$ + $0A$+ \

            pad( "Program",    20, "." ) + errorProgram$ + $0A$+ \

            pad( "Statement",  20, "." ) + str(errorLine) + $0A$

        tmp$ = msg(-1)

        if not(nul(tmp$)) {

            logData$ += \

                pad( "MSG(-1)",  20, "." ) + tmp$ + $0A$

        }

        if errorObject {

            logData$ += \

                pad( "Class",  20, "." ) + errorObjectTxt$ + $0A$ + \

                pad( "Method", 20, "." ) + errorMethod$ + $0A$

        }

        !

        logData$ += $0A$+ \

            fnTitle$("Warning Information")+$0A$+ \

            "There is not enough available data space to load the log file information into memory."+$0A$

    }

    ! Scan log data to identify each section

    local dim logSectionName$[ 1 : numSections ], logSectionData[ 1 : numSections, 1 ]

    logPos     = 1

    theSection = 0

    while logPos>0

        tmp = msk(mid(logData$,logPos),$0A$+"\*\*\*\*\* [^\*]* \*\*\*\*\*"+$0A$)

        if tmp {

            ++theSection

            logSectionName$[ theSection ]   = mid( logData$, logPos+tmp+6, msl-14 )

            logSectionData[ theSection, 0 ] = logPos + tmp + msl - 1

            if theSection>1 {

                logSectionData[ theSection - 1, 1 ] = tmp

            }

            logPos += tmp + msl

        } else {

            logSectionData[ theSection, 1 ] = len(logData$) - logPos + 1, \

            logPos = 0

            break

        }

    wend

    ! Create a new window and display the Error Information

    cols = min(screenCols - 10, 100)

    rows = min(screenRows - 4, 40)

    col  = int ( (screenCols-cols) / 2 )

    row  = int ( (screenRows-rows) / 2 )

    print (0,err=get_out) 'DIALOGUE'(col,row,cols,rows,"Error Information",opt="^Cix"),

    print 'mode'($000F$),'sr','df','cs','cursor'("off"), \

        'font'("MS Sans Serif",1),'gf','sf',

    ! Set control ID for objects display on page

    BT_Close = 1031, \

    BT_Copy  = 1032, \

    DB_Name  = 1033, \

    LB_Data  = 1034

    print 'text'(@x(2),@y(1),"Select the section of the log file to view:"),

    drop_box DB_Name,@(38,1,60,10)

    drop_box load DB_Name,logSectionName$[all]

    ! Use a report view to allow user to extend width to see all data

    list_box LB_Data, @(2,3,96,33)

    ! Set font for the list_box

    LB_Data'Font$ = "Consolas,1"

    ! Set initial data

    theSection = 1

    drop_box write DB_Name, theSection

    list_box load LB_Data, mid(logData$, logSectionData[theSection,0], logSectionData[theSection,1])+$0A$

    list_box write LB_Data, 1

    ! Add CLOSE button

    btnCol = cols - 12, \

    btnRow = rows - 2, \

    btnTxt$ = "Close"

    button BT_Close,@(btnCol,btnRow,10,1.5)=btnTxt$

    btnCol -= 10

    btnTxt$ = $$

    ! Add COPY button

    button BT_Copy,@(btnCol,btnRow,10,1.5)="Copy"

    btnCol -= 10

    ! Add COPY-ALL button

    button BT_CopyAll,@(btnCol,btnRow,10,1.5)="Copy All"

    btnCol -= 10

    ! force screen update

    wait 0

    ! Get user input

    while 1

        obtain (0,err=*next,tim=30)'bi',*,'ei'

        if ctl=BT_Close or ctl=-1999 { break }

        if ctl=BT_Copy {

            clip_board write mid(logData$, logSectionData[theSection,0], logSectionData[theSection,1])

        }

        if ctl=BT_CopyAll {

            clip_board write logData$

        }

        if ctl=DB_Name {

            drop_box read DB_Name,theSection

            drop_box write DB_Name, theSection

            list_box load LB_Data, mid(logData$, logSectionData[theSection,0], logSectionData[theSection,1])+$0A$

            list_box write LB_Data, 1

        }

    wend

    list_box remove LB_Data,err=*next

    drop_box remove DB_Name,err=*next

    button remove   BT_Copy,err=*next

    button remove   BT_Close,err=*next

    print 'pop',

return

prefix_list:

    print (lc,err=*next)'lf',fnTitle$("Prefix information")

    for p=-1 to 9

        _x$=pfx(p,err=*next);

        if not(nul(_x$)) {

            print (lc,err=*next)"PREFIX ",tbl(p<0,tbl(p>0,"    ","("+str(p)+") "),"FILE"),":",_x$

        } else {

            if p=0 {

                print (lc,err=*next)"PREFIX ",tbl(p<0,tbl(p>0,"    ","("+str(p)+") "),"FILE"),":","<NotSet>"

            }

        }

    next p

    _x$=pfx(pgn,err=*next);

    if not(nul(_x$)) {

        print (lc,err=*next)"PREFIX PROGRAM:",_x$

    }

return

stack_trace:

    local err_lvl

    err_lvl=tcb(12)+prm('b0')-1

    print (lc,err=*next)'lf',fnTitle$("Stack trace")

    while err_lvl>0

        X$=stk(err_lvl-prm('b0'))

        print (lc,err=*next)"Level:",err_lvl," Line:",num(X$(1,5)):"#0000"," ",X$(6)

        err_lvl--

    wend

return

pvx_info:

    print (lc,err=*next)'lf',fnTitle$("ProvideX information"),'lf', \

        "         HWD: ",hwd,'lf', \

        "         LWD: ",lwd,'lf', \

        "     TCB(29): ",tcb(29),'lf', \

        "      ARG(0): ",arg(0),'lf', \

        "     ARG(-1): ",arg(-1),'lf',

    if tcb(29)>=7600000 {

        print (lc,err=*next) \

            "     ARG(-2): ",arg(-2),'lf', \

            "     ARG(-3): ",arg(-3),'lf', \

            "     ARG(-4): ",arg(-4),'lf',

    }

return

system_params:

    print (lc)'lf',fnTitle$("System Parameters")

    x$=prm, \

    x1=1

    while x1+79<len(prm)

        x2=pos(","=mid(x$,x1,79),-1)

        if x2>0 {

            print (lc)mid(x$,x1,x2);

            x1+=x2

        } else {

            break

        }

    wend

    print (lc)mid(x$,x1)

return

open_files:

    local x,xRecs

    print (lc)'lf',fnTitle$("Open Files")

    for x=1 to len(chn) step 2

        fc=dec($00$+mid(chn,x,2))

        if fc>0 and fc<>lc {

            print (lc)str(fc:"##,##0"),":",pth(fc),

            xRecs=num(fin(fc,"records_used"),err=*next)

            if xRecs>0 {

                print (lc)" recUsed:",xRecs,

            }

            print (lc)'lf',

            fopen++

        }

    next x

    if fopen=0 {

        print (lc)"** None **"

    }

return

public_programs:

    local pInfo$,pCount

    print (lc)'lf',fnTitle$("Cached/ADDR Programs")

    while 1

        pInfo$=pub(pCount++,err=*break)

        print (lc,err=*next) pCount-1:"##0B", \            /* Position in list */

            tbl(mid(pInfo$,3,1)=$01$,"c","A")," ", \    /* Cached / ADDR */

            dec(mid(pInfo$,1,2)):"###,##0B", \            /* Program size */

            mid(pInfo$,17)                                /* Program name */

    wend

    if pCount=0 {

        print (lc)"** None **"

    }

return

list_objects:

    local oc,oh,oref

    print (lc,err=*next)'lf',fnTitle$("Active Objects")

    oh=100001

    while oh<=tcb(39)

        oref=0, \

        oref=ref(read oh,err=*next)

        if oref>0 {

            print (lc,err=*next)"Object: ",str(oh)," ("+oh'_class$+") has ",str(oref)," reference",tbl(oref>1,"","s")

            oc++

        }

        oh++

    wend

    if oc {

        print (lc,err=*next)">> ",str(oc)," active objects."

    } else {

        print (lc,err=*next)"** None **"

    }

return

/*

 * Include a dump of data information to the log file; this dump will be limited

 * to the previous level (where program is executing) unless the environment

 * variable EH_DUMP_ALL is set to any value.

 */

eh_dump:

    print (lc,err=*next)'lf',fnTitle$("Dump Information")

    if pp4e_eh_dump=2 {

        print (lc,err=*next)"** ALL Levels **"

        dump (lc,err=*next)*

    } else {

        print (lc,err=*next)"** Current Level ONLY **"

        dump (lc,err=*next)-1

    }

return

eh_object_dump:

    local the_prog$,oc,oh,oref

    print (lc,err=*next)'lf',fnTitle$("Dump Active Object Data")

    if lcs(mid(errorProgram$,-4))=".pvc" {

        errorProgram$=lcs(errorProgram$)

        ! locate object reference(s) for the class and dump all data

        oh=100001

        while oh<=tcb(39)

            oref=0, \

            oref=ref(read oh,err=*next)

            if oref>0 and lcs(oh'_class$)+".pvc"=errorProgram$ {

                print (lc,err=*next)oh'_class$+" (",str(oh)," "+" has ",str(oref)," reference",tbl(oref>1,"","s")+")"

                dump (lc,err=*next) object oh

                oc++

            }

            oh++

        wend

    }

return

/* FUNCTIONS */

def fngetLogFile$(NamePfx$)

    local done,temp_dir$,work_file$,x$,xt

    x$=tsk(-1), \

    x$=ucs(x$(2))+"TMP", \

    temp_dir$=env(x$);

    if temp_dir$="" \

    then temp_dir$=env("TEMP")

    if pos("ix"=lcs(sys)) and temp_dir$="" \

    then temp_dir$="/tmp"

    if temp_dir$<>"" \

    then temp_dir$+=dlm

    work_file$=temp_dir$+NamePfx$+"_"+dte(0:"%Y%Mz%Dz")+uid+".txt"

    return work_file$

end def

def fnAddText$(local arg1$, local arg2$)

    local haveArg1,tmp1,tmp2

    if not(nul(arg1$)) { haveArg1 = 1 }

    tmp2 = screenCols - 20

    while not(nul(arg2$))

        tmp1 = len(arg2$)

        if tmp1>tmp2 {

            tmp1 = pos(" "=mid(arg2$,tmp2),-1)

            if not(tmp1) { tmp1 = tmp2 }

        }

        if not(haveArg1) {

            msgLine$[++msgLines] = mid(arg2$, 1, tmp1)

        } else {

            ! Add "." to first argument to specified width of graphical units

            while 1

                if txw(arg1$,fnt="MS Sans Serif")>=200 { break }

                arg1$ += "."

            wend

            msgLine$[++msgLines] = arg1$ + mid(arg2$, 1, tmp1)

        }

        arg1$ = "", \

        arg2$ = mid(arg2$, tmp1 + 1)

        msgLineWide = max(msgLineWide, tmp1)

    wend

    return ""

end def

def fnTitle$(local aTitle$)

    local retVal$

    retVal$ = dim(5,"*") + " " + aTitle$ + " " + dim(5,"*")

    return retVal$

end def

config_iol: iolist keyword$, value$

end


!

! Copyright (c) 2009 Sage Software Canada Ltd. All Rights Reserved

! Author fmcguirk   Date 2009.04.29 18 at 10:47:01 AM EDT

!

/*

! ** This program is used to provide a standardized mechanism for the handling of splash

! ** screens for any application.  A splash screen will be displayed in the middle

! ** of the current desktop based on the size of the image file specified.

! **

! ** A single line text area will be created near the bottom of the image for the full width

! ** of the image when a message is updated to the status screen.  Two properties

! ** (messageTextColour, messageBackColour$) can be used to control the message

! ** area display.

! **

! ** If the image file is specified as part of the object instatiation (in 'new()'), be sure

! ** to include an 'err=' branch.  The object instatiation will fail with an error code if the

! ** image file is invalid or cannot be found.

! **

! ** Generic steps for splash screen usage:

! ** ==>

! ** Declare a new splash screen instance; and optionally include the name of the image file to be used  %PvxCode(theSplash=new("*obj/splash",theImageFile$,err=*next))%

! ** Provide the name of the image file to be used  %PvxCode(theSplash'setImage(theImageFile$,err=*next))%

! ** Display the splash screen  %PvxCode(theSplash'displaySplash())%

! ** Perform application initialization steps; message(s) can be updated to the splash screen to show progress  %PvxCode(theSplash'updateMessage(aProgressMessage$))%

! ** Remove the splash screen  %PvxCode(theSplash'dropSplash())%

! ** <==

! ** @Constructor  Create a new splash screen.

! ** @param aImage$ **Optional** A string containing the name of the image file to use for the splash screen

! ** @note  The object instantiation will exit with an error code if the image file is invalid or cannot be found.

 */

def class "*obj/splash" create required delete required

    local imageWidth,imageHeight

    local dtXpos,dtYpos

    local theMessageArea

    local theSplashImage$,wdxSplashImage$,javxSplashImage$

    local haveImageFile

    local loadTime,winHandle

    local isJavX = TCB(88) AND MID (MSE, 32,1)="J"

    local isWindX = TCB(88) AND MID (MSE, 32,1)="W"

    local isUNIX = pos("ix"=lcs(sys))>0

    ! ** Background colour for the message area

    property messageBackColour$

    ! ** Text colour for the message area

    property messageTextColour$

    ! ** Minimum splash screen display time (allowed value = 2 .. 20 seconds)

    property splashDuration                set setDuration

    ! ** Display the splash screen

    function displaySplash()            displaySplash

    ! ** Drop/remove the splash screen

    function dropSplash()                dropSplash

    ! ** Get a location for the temporary direcrory for the current user (WindX aware)

    ! ** @returns A string containing the full path to the temporary directory for the user

    function local getTempDir$()        getTempDir

    ! ** Set the name of the image file.  When used on a WindX client, the image will be transferred to the client.  When used in a JavX/UltraFX client, file image file extension will be changed from BMP to PNG or JPG depending on which one is found.

    ! ** @param aImageFile$  A string containing the name of the image file to use for the splash screen

    ! ** @note  The method will return an error code if the image file is invalid or cannot be found.

    function setImage(aImageFile$)        setImage

    ! ** Update a short text message on the splash screen; the message area will be created automatically the first time it is used.

    ! ** @param aText$ The message to be dispayed

    function updateMessage(aText$)        updateMessage

end def

on_create:

enter aImageFile$,err=*next

    if _obj'isUNIX and not(_obj'isWindX) and not(_obj'isJavX) {

        return 99

    }

    if not(nul(aImageFile$)) { _obj'setImage(aImageFile$,err=createFailed) }

    _obj'splashDuration=2

    messageBackColour$="White"

    messageTextColour$="RGB:0 132 105"

return

createFailed:

return err

on_delete:

    ! Drop any existing Splash screen

    if _obj'winHandle {_obj'dropSplash() }

return

displaySplash:

    local aTmpVal$,imageFile$,save_wf

    if haveImageFile {

        if isWindX {

            call "[wdx]*windx.utl;get_val",err=*next,"str(prm('wf'))",aTmpVal$

            save_wf=num(aTmpVal$);

            execute "[wdx]set_param 'wf'=1",err=*proceed

        } else {

            save_wf=prm('wf');

            set_param 'wf'=1

        }

        ! Drop any existing Splash screen

        if _obj'winHandle { _obj'dropSplash() }

        print 'cursor'("OFF"),'cursor'(1),

        winHandle=hwn(0)

        print 'dialogue'(dtXpos,dtYpos,imageWidth,imageHeight,winHandle,"",'B7'+'DF',opt="h^"),'SR','CS',

        print 'SP','DF',;

        wait 0

        imageFile$=theSplashImage$

        if isWindX {

            imageFile$=wdxSplashImage$

        }

        if isJavX {

            imageFile$=javxSplashImage$

        }

        print (0,err=*proceed)'picture'(@x(0),@y(0),@x(imageWidth),@y(imageHeight),imageFile$,0),

        wait 0

        loadTime=int(tim*3600)

        if isWindX {

            execute "[wdx]set_param 'wf'="+str(save_wf),err=*proceed

        } else {

            set_param 'wf'=save_wf

        }

    }

return

dropSplash:

    local aTmpVal$,save_wf

    if isWindX {

        call "[wdx]*windx.utl;get_val",err=*next,"str(prm('wf'))",aTmpVal$

        save_wf=num(aTmpVal$);

        execute "[wdx]set_param 'wf'=1",err=*proceed

    } else {

        save_wf=prm('wf');

        set_param 'wf'=1

    }

    if _obj'winHandle {

        if theMessageArea>0 {

            multi_line remove theMessageArea

        }

        ! Ensure that the splash screen displays for at least two seconds

        wait max(0,_obj'splashDuration-(int(tim*3600)-_obj'loadTime ))

        loadTime=0

        print (0,err=*next)'drop'(_obj'winHandle),

        winHandle=0

    }

    if isWindX {

        execute "[wdx]set_param 'wf'="+str(save_wf),err=*proceed

    } else {

        set_param 'wf'=save_wf

    }

    wait 0

    print 'cursor'(0),

return

getImage:

return tbl(haveImageFile,"",theSplashImage$)

getTempDir:

    local aWorkDir$,clientOS$,x$

    clientOS$=lcs(sys);

    if isWindX {

        call "[wdx]*windx.utl;get_val",err=*next,"sys",clientOS$

        clientOS$=lcs(clientOS$)

    }

    x$=tsk(-1), \

    x$=ucs(x$(2))+"TMP"

    aWorkDir$=env(x$)

    if isWindX {

        call "[wdx]*windx.utl;get_val",err=*next,"env("+quo+x$+quo+")",aWorkDir$

    }

    if isJavX {

        aWorkDir$=FIN(0,"gettempdir",err=*next)

    }

    if aWorkDir$="" {

        x$="TEMP"

        if isWindX {

            call "[wdx]*windx.utl;get_val",err=*next,"env("+quo+x$+quo+")",aWorkDir$

        } else {

            aWorkDir$=env(x$)

        }

    }

    if pos("ix"=clientOS$) and aWorkDir$="" {

        aWorkDir$="/tmp"

    }

    if aWorkDir$<>"" {

        aWorkDir$+=dlm

    }

return aWorkDir$

setImage:

enter (aImageFile$)

    local dtCols,dtRows,fileExt$,found,retErr,x$,theFile$,tmpH,tmpC,tmpData$

    haveImageFile=0

    if isJavX {

        fileExt$=lcs(mid(aImageFile$,pos("."=aImageFile$,-1)+1))

        if fileExt$="bmp" {

            aImageFile$=mid(aImageFile$,1,len(aImageFile$)-3)+"png"

            open (hfn,err=*next)aImageFile$;

            found=1;

            close (lfo)

            if not(found) {

                aImageFile$=mid(aImageFile$,1,len(aImageFile$)-3)+"jpg"

            }

        }

    }

    open (hfn,err=*next)aImageFile$;

    theSplashImage$=pth(lfo);

    close (lfo)

    if not(nul(theSplashImage$)) {

        haveImageFile=1

        call "*picture;get_size",err=BadImage,theSplashImage$,imageWidth,imageHeight

        imageWidth=int(imageWidth+sgn(fpt(imageWidth)))

        imageHeight=int(imageHeight+sgn(fpt(imageHeight)))

        x$=mse, \

        dtCols=max(0,dec(mid(x$,27,2))/dec($00$+mid(x$,10,1))), \

        dtRows=max(0,dec(mid(x$,29,2))/dec($00$+mid(x$,11,1)))

        dtXpos=max(int((dtCols-imageWidth)/2),0), \

        dtYpos=max(int((dtRows-imageHeight)/2),0)

        if isWindX {

            open (hfn,err=*next)"[wdx]"+aImageFile$;

            wdxSplashImage$=mid(pth(lfo),6);

            close (lfo)

            if nul(wdxSplashImage$) {

                tmpDir$=_obj'getTempDir$()

                wdxSplashImage$=tmpDir$+mid(theSplashImage$,pos(dlm=theSplashImage$,-1)+1)

                found=0;

                open (hfn,err=*next)"[wdx]"+wdxSplashImage$;

                found=1

                ! Only transfer file if it is not already there

                if not(found) {

                    execute "[wdx]SERIAL """+wdxSplashImage$+""",err=*proceed",err=*proceed

                    open input (hfn,isz=8192,err=*next)theSplashImage$;

                    tmpH=lfo

                    if tmpH {

                        x=prm('TU'); set_param 'TU'

                        open purge (hfn,isz=1,err=*next)"[wdx]"+wdxSplashImage$;

                        tmpC=lfo

                        while 1

                            read record (tmpH,end=*break)tmpData$

                            write record (tmpC)tmpData$

                        wend

                        close (tmpC)

                        close (tmpH)

                    }

                }

            }

        }

        if isJavX {

            theSplashImage$=sub(theSplashImage$,dlm,"/",0)

            theFile$=mid(theSplashImage$,pos("/"=theSplashImage$,-1)+1)

            theFile$=mid(theFile$,1,pos("."=theFile$,-1)-1)

            javxSplashImage$="!"+theFile$

        }

    } else {

        haveImageFile=0

    }

return

BadImage:

    haveImageFile=0

return

setDuration:

enter (theDuration)

    splashDuration=max(2,min(20,theDuration))

return

updateMessage:

enter (theText$),err=*next

    if theMessageArea= 0 {

        theMessageArea=99

        multi_line theMessageArea,@(2,max(1,imageHeight-1.25),max(5,imageWidth-4),1),opt="BL"

        theMessageArea'backColour$=_obj'messageBackColour$ , \

        theMessageArea'textColour$=_obj'messageTextColour$

    }

    theMessageArea'Value$=theText$

    wait .25

return

end


Sage ProvideX Plug-in for Eclipse v2.x - What's New

This document describes the some of latest features that have been added to the Sage ProvideX Plug-in for Eclipse:

info Prerequisites for this version of the plug-in:
  • Java 8 SE run-time or JDK; compatible with Java 17
  • Eclipse 4.5 (Mars) (or newer) with the Java Development Tools (JDT) plug-in
  • A local install of ProvideX with a 2 user developer license
Overview
Overview of changes in the current release.
Functional Areas
Changes grouped by functional area of the plug-in.
  • Builder
  • Editor
  • Contributed Tools
  • NOMADS Integration
Historic Releases
Summary of change from historic releases of the plug-in.
info The Sage 100 Plug-in information has moved to a separate document and is included with that plug-in.

What's New June 2022
Overview - Latest Release
v2.6.7 June 2022

General
  • Adjust logic to resolve issues with new features when using a ProvideX executable older than v9.20
  • New Writing a Contributed Tool example to show how to use a panel for configuration options and the progress view to show messages as the tool performs actions.
Builder
  • Add a new preference to skip copy of programs to linked folders when there are build or style check errors
  • Use default ProvideX executable when NOMADS Alternate executable is invalid or cannot be found
  • When full build is triggered at launch and output folder exists, only build modified files
  • Additional log messages when updating outline, dictionary, and library DOM data
  • Scan for duplicate function and variable names (Error 24)
    • Multiple definitions of a property (public and private)
    • Multiple definitions of a function with same parameter types
    • Support full function definition within the class declaration section
    • Ignore LOCAL within a function definition
  • Option to disable scan for duplicate function and variable names (Error 24)
  • Add support for encrypted password values (requires ProvideX v9.20 or newer)
  • Add new project-specific property 'AltExe_EnvironmentPropertyFile'
    • Set the name of a properties file containing name/value pairs to use to set environment variables when initializing the build process; when property is set force build process to use the alternate executable flow.
    • This format of this file:
      • one name/value pair per line in the format name=value
      • a line starting with '#' is considered to be a comment
      • blank lines are ignored
      # Example Name/Value pairs
my_app_title=Application Fantastic
my_app_debug=1
  • Change message displayed when build process is interrupted to a confirmation prompt to allow user to ignore attempt to cancel process.
  • Write message to Console when project.properties file exists for project
Import/Convert
  • The process to convert ProvideX programs to text has changed.
    Old Import/Convert Process
    The old process moved the file from the source folder to the output folder and then converted the file in the output folder to create a new text version of the program in the source folder. One of the primary issues with this approach is the impact it has when using version control - all history is lost on the original file and there is a potential that the file moved to the output folder may now be tracked by the version control process.
    New Import/Convert Process
    The new process leaves the source file in the source folder. If the option Always add source file extension when converting programs to text is enabled, the convert process will create the text file in the source folder and then delete the original source file. If this option is not enabled, the text version of the program will have the same name as the original program. The convert process creates a temporary file for the text version of the program and replaces the original program with this temporary file. If the convert to text fails, the original source file has not changed.
    This has a number of benefits:
    • reduces potential loss of original source file if conversion process fails
    • more accurate and complete history when tracking changes in version control
    • no longer have a file in the output folder that may be tracked by version control
Editor
  • Additional debug messages to track (rare) issue where NOMADS library information is not loaded
  • Fix for null pointer exception when processing file annotations
  • Identification of keywords to highlight will now stop when followed by one of the characters: < > - * /
  • Updated Constants and Functions
Contributed Tools
  • The Configure button is disabled when a configuration action has not been implemented
  • General
    • A new option on the Appearance Preferences page to enable saving the window position of a contributed tool if it is moved.
    • Common UI MessageBox() Method - add parameter to set title for message box
    • ProgressLog - add methods to support the creation and display of a log file
  • PvxDocs:
    • Add option to set date/time stamp of generated documentation file(s) to match source class
    • Add option to document generation setup page to set option for "Link to Page"
    • Add substitution tag %PvxCode2()% to add ProvideX code sample to replace the tag in line
    • Add substitution tags %PvxCodeBegin% / %PvxCodeEnd% to define blocks of code spanning multiple lines
    • When parameter information starts with plus (+) character, add the remaining text to previous line to allow parameter description to span multiple lines
  • Dictionary Viewer:
    • Add print format column to information displayed for fields
  • Build Tool - Encrypt Password Value
    • A new contributed tool to encrypt a password value.
  • Change Keyword Case
    • Resolve issue where keyword case gets changed in comments
  • Style Check
    • New option when creating a rule to check the search value against the list of keywords in the program line
    • Create a detailed log of the issues discovered during the scan process; this log can be viewed by clicking the Details button once the scan process is complete.
    • Perform tag substitution during the build process; include the substitution information in the detail log.
  • Tag Substitution
    • A new contributed tool to replace special tags in a source file with a substitution value before creating the output file. The tags and substitution values are defined in a properties file built-in to the plug-in.
    • Additional user-defined tags and substitution values can be defined in a tagSubstitution.properties files in the folder configured for user keywords and external observers on the Contributed Extensions/Tools preference page.
    • The original source file is not changed; changes will appear in the compiled program(s).
Preferences
  • Fix: Editor Preference page fails to load in Eclipse 2020-12
  • Resolve issue with export of ProvideX Properties for resources in project(s)
  • Add a new debug preference to set the debug message verbosity level
Sage 100 Plug-in
  • The What's New and additional documentation has been moved to the Sage 100 plug-in.
Builder
  1. Usability
    • Add a new preference to skip copy of programs to linked folders when there are build or style check errors
    • Use default ProvideX executable when NOMADS Alternate executable is invalid or cannot be found
    • When full build is triggered at launch and output folder exists, only build modified files
    • Additional log messages when updating outline, dictionary, and library DOM data
    • New builder option to disable scan for duplicate function and variable names (Error 24)
    • Add support for encrypted password values (requires ProvideX v9.20 or newer)
    • Improve error 24 scan logic for class declaration
      • Support full function definition within the class declaration section
      • Ignore LOCAL within a function definition
    • Add new project-specific property 'AltExe_EnvironmentPropertyFile'
      • Set the name of a properties file containing name/value pairs to use to set environment variables when initializing the build process; when property is set force build process to use the alternate executable flow.
      • This format of this file:
        • one name/value pair per line in the format name=value
        • a line starting with '#' is considered to be a comment
        • blank lines are ignored
        # Example Name/Value pairs
my_app_title=Application Fantastic
my_app_debug=1
    • The Convert programs to text process has changed to use the source file in the original location rather than move the file to the output folder. This will reduce issues with source control systems where the move to the output folder was tracked as an intentional change.
  2. Copy to Test System
    • Add a new preference, and associated logic, to skip copy of programs to linked folders when there are build or style check errors

  3. Preference page: Builder | Options

    Preferences: Builder | Options

    Several new preferences have been added to the "Builder Options" preference page:

    • Skip copy of programs with errors to linked folders

      When enabled, programs containing errors will not get copied to any linked folders.

    • Ignore FULL Build for existing projects triggered when starting Eclipse

      As part of the startup of Eclipse full builds are sometimes triggered for all projects in a workspace. When this preference is enabled the plug-in will ignore the full build request; full builds can still be triggered from the Project menu.

    • Simple scan for duplicate function/variable names (Error 24)

      When disabled, the simple scan for duplicate function/variable names is skipped

  4. Convert ProvideX programs to text
    • The process to convert ProvideX programs to text has changed.
      Old Import/Convert Process
      The old process moved the file from the source folder to the output folder and then converted the file in the output folder to create a new text version of the program in the source folder. One of the primary issues with this approach is the impact it has when using version control - all history is lost on the original file and there is a potential that the file moved to the output folder may now be tracked by the version control process.
      New Import/Convert Process
      The new process leaves the source file in the source folder. If the option Always add source file extension when converting programs to text is enabled, the convert process will create the text file in the source folder and then delete the original source file. If this option is not enabled, the text version of the program will have the same name as the original program. The convert process creates a temporary file for the text version of the program and replaces the original program with this temporary file. If the convert to text fails, the original source file has not changed.

      This has a number of benefits:
      • reduces potential loss of original source file if conversion process fails
      • more accurate and complete history when tracking changes in version control
      • no longer have a file in the output folder that may be tracked by version control
Editor
  1. Usability
    • Additional debug messages to track (rare) issue where NOMADS library information is not loaded
    • Fix for null pointer exception when processing file annotations
    • Identification of keywords to highlight will now stop when followed by one of the characters: < > - * /
    • Updated Constants and Functions
Contributed Tools
  1. General
    • Contributed Tools List
      • The Configure button on the Contributed Tools list is disabled when a configuration action has not been implemented
    • Writing a Contributed Tool
      • A new example to show how to use a panel for configuration options and the progress view to show messages as the tool performs actions.
    • Save Window Position
      • Save the new position of the window for a contributed tool if it is moved. For more information, see Preferences - Appearance in the Plug-in Documentation.

  2. Encrypt Password Value

    This is a contributed tool to encrypt a simple text password value. The encrypted password can be copied and used in:

    • The password field on a program properties page
    • The list of known passwords on the Import/Convert Preference page
    • The project properties file, property 'appendPreferenceS._ProgramPasswordList' to include the list of known passwords for a specific project.

      Tools - Encrypt Password

  3. ProvideX Docs
    • New substitution tags for code blocks
      • Add substitution tag %PvxCode2()% to add ProvideX code sample to replace the tag in line
      • Add substitution tags %PvxCodeBegin% / %PvxCodeEnd% to define blocks of code spanning multiple lines
    • Allow parameter documentation to span multiple lines
      • When parameter documentation text starts with plus (+) character, add the remaining text to previous line to allow parameter description to span multiple lines
    • Enhanced Documentation Generation Parameters

      Several new options have been added to the document generation setup page.

      PvxDocsRun - Setup

      • Option to override the method used to link to content pages from menu
      • Option to set modification date/time stamp to match source file

  4. Dictionary Viewer
    • Display additional field information

      Update to display additional information from the dictionary for each field:
      print format

    Dictionary Viewer

  5. Style Check

    A number of enhancements have been made to the Style Check contributed tool:

    • Check search value against list of keywords

      Define a rule to check the search value against list of keywords for each line.

    • Detailed Log of Issues

      The Style Check process will now create a detailed log of the issues discovered during the scan process; this log can be viewed by clicking new Details button once the scan process is complete.

  6. Tag Substitution
    • A new contributed tool to replace special tags in a source file with a substitution value before creating the output file. The tags and substitution values are defined in a properties file built-in to the plug-in.
    • Additional user-defined tags and substitution values can be defined in a tagSubstitution.properties files in the folder configured for user keywords and external observers on the Contributed Extensions/Tools preference page.
    • The original source file is not changed; changes will appear in the compiled program(s).
    • The logic will search for the tags in the following formats, there can be an optional colon after the keyword:
      • $keyword$
      • %keyword%
      • %(keyword)%
      • %{keyword}%
    • The format of the properties file is:
      keyword = substitution text or string expression
    • The string expression can use any ProvideX code to create the expression to use as the substitution value. The following variables are also available to include in the expression:
      • cOutputFilename$
      • cSourceLastModDate$
      • cSourceLastModTimestamp$
      • cSourceLastModYear$
    • The built-in tags and substitution values (some are formatted to be similar to the keyword substitution performed when using Subversion):
      Copyright = "(c) " + dte(0:"%Yl") +" The Sage Group plc or its licensors. All rights reserved."
Header = "$Id: " + cOutputFilename$ + " " + cSourceLastModTimestamp$ + " $"
Id = "$Id: " + cOutputFilename$ + " " + cSourceLastModTimestamp$ + " $"
Revision = "$Revision: " + cSourceLastModDate$ + " $"
    • The secondary properties file used for the user defined substitution tags can override the definitions of the built-in tags as well as create new tags.
NOMADS Integration
  1. NOMADS Preferences

    Override NOMADS preference page settings for a project.

    • NOMADS_AltExe

      A full path to a ProvideX executable to be used for all NOMADS sessions launched for a resource in the project; (Use "/" characters in the path). The path will be verified to be a valid ProvideX executable before it is used. If the validation fails, the first executable found from the following list will be used:

      • NOMADS executable for the workspace
      • ProvideX executable for the project
      • ProvideX executable used by the workbench

    • NOMADS_ExtDictDir

      Specify a folder that is outside of the project workspace as the location of the ProvideX data dictionary files. The file 'PROVIDEX.DDF' must exist in this folder, otherwise, the value of this property will not be used.
Historic Releases
v2.6.5 July 2020

General
  • New Project Explorer view as replacement for deprecated Navigation View
  • New Workspace Properties file preference AltInit.InitSageSessionObject to enable the startup for workbench actions to initialize the Sage Session object
  • Reduce number of messages written to console view when debug options are not enabled
  • Error handling to catch when Java event process is no longer active
  • Correction to line number increment from AI system parameter override
  • Startup program - use in console session and when using alternate executable for build process
  • Changes to improve the reliability of Project/Workspace Preference/Property override values
  • Outline View
    • Add filters: Public / Private Properties, Private Functions
    • Change order for "Group By Type" and sort alphabetically within type
    • Set "Group by Type" as default
Builder
  • Add logic to handle new and modified files when automatic build is triggered as a result of a refresh or plug-in start-up
  • Add logic to identify and build new files added to source folder from outside of Eclipse
  • Suppress password request for data files added to Import/Convert Preference page
  • Correction to automatic build to only process each file once
  • Incremental Build using an alternate executable to load properties from project properties file
  • Adjust logic used to check whether file is a resource when attempting to convert resources to text
Editor
  • Add new template 'esx' to insert the ProvideX code to Escape to Console in Command Window when Debug is enabled
  • Add new template 'sageheader' and change ProvideX Program Wizard and ProvideX Class Wizard to use this template instead of the 'header' template
Wizards
  • ProvideX Class Wizard
    • Allow selecting class files for LIKE from entire workspace in addition to current project
    • Adjust to use new 'sageheading' template
    • Change logic for creation of LIKE statement in new class to group up to five class files per line
    • Only use files from selected list with PVC extension, ignore any others
NOMADS Integration
  • Add 'Data Classifications' task to NOMADS View drop-down menu
Preferences
  • Change text for option to add file extension to source file when converting a compiled program on Import/Convert Preference page
  • Restore option to suppress password request as new data files are processed
Contributed Tools
  • Adjust contributed tool startup to skip theme logic when using a version of Sage 100 older than Sage 100 2016
  • Message Library Viewer
    • Change line-feed characters in modified text to SEP characters
  • Style Check
    • When preference for user defined keywords / contributed tools is set, automatically save new style rules to file in this folder
    • Update source file during build process when style check configuration option is set to automatically update source file and there is a replace value defined as part of a style check rule
  • Super Search
    • Add button to allow clearing previous search results

v2.6.2 July 2019

General
  • Outline View will now remember settings (sort / filter) for session
  • Resolve compatibility issues with Eclipse 2019-06 (4.12.0)
Builder
  • When building data files, check option to force rebuild of resource files
  • Enhance check for error 24 to match function declarations based on parameter data types
Preferences
  • Editor Preference Page
    • Fix for null pointer exception attempting to display Editor Preference page when the option to load external keyword completion proposals is not enabled
Contributed Tools
  • Super Search
    • Add button to allow clearing of book marks for current project or entire workspace depending on search selection

v2.6.0 March/April 2019

General
  • Now requires Java 8 run-time environment; compatibility fixes for OpenJDK 11
  • New option on 'Appearance' preference page to show value of TCB(29) reported by client (should be the same as the server value)
  • New preference to enable writing of debug messages to the console; use '_bDebugLogToConsole' to override this preference in project or workspace properties files
  • Catch actions / events that trigger the ProvideX EventManager to start and attempt to process after the EventManager has started
  • Use fonts set on Preferences / Appearance page for contributed tools and JavX console
Builder
  • Error scan will now check for duplicate property / method declarations which will trigger an error 24 when the class is instantiated
  • Add preference to force rebuild of files marked as resources
  • Update list of file extensions used to identify resource files
  • Display original source file name for event, when changed by intermediate observers
  • Changes to logic used to identify source file content type to improve builder stability
  • Skip build of any file identified as a resource in project/workspace properties file
  • Keep file attributes for copy from output folder to linked folders or test platform folders
  • Resolve potential builder hang when multiple line label references occur in single source line
Editor
  • Restore editor state from previous session
  • Single-click in outline view will now reposition to corresponding location in the editor view
  • New preference to allow double click in a string literal to select the current word instead of the entire contents
  • Code-highlighting to allow line labels to include '.' character
  • Update to code folding to resolve issue where editor window shifts to beginning of line when current cursor position is beyond the right edge of the editor window
  • User-defined Keyword Highlighting (v2.6.0)

    User can now define keyword categories and a list of keywords in each category. Each category must have a unique name and can be assigned special text and background colors to use for the display of the keywords. The category will be included in the list of categories on the Editor Preference page where the display colors can be changed.

    The keyword categories are defined in a new file placed in the folder defined for user contributed tools (fall-back to the root directory of the workspace) and the list of keywords in each category is defined in a new file using a name defined in the keyword categories file. The contents of these files are loaded when Eclipse starts with this workspace selected.

    For more information, see User Keyword Categories in the Plug-in Documentation.

  • Code folding, do not mark FOR-NEXT block starting with the FOR in a PRECISION x FOR OBJECT statement
Contributed Tools
  • General
    • All contributed tools will now use the default Sage 100 theme when the ProvideX executable referenced for the project (or workbench) is in a recent Sage 100 environment
  • Dictionary Viewer
    • Update to display additional information from the dictionary for each file
  • PvxDocs
    • Add new tags for ordered list (@OList) and unordered list (@UList).
      • Each item in the list must be on a separate line
      • Start a line with a '+' character to add to the previous line
      • A blank comment line in a list will be ignored
      • The list ends at the next tag or the end tag for the list (@OList_End or @UList_End).
    • New button to view documentation after generation process has completed
  • Strip Trailing White Space
    • The tool will now strip trailing blank lines from the source file.
    • Change to not remove whitespace before line continuation characters
  • Super Search
    • The tool will now use a new property SuperSearch.IgnoreCharacterList from the project properties file to set additional characters to be ignored when scanning the source file(s) for binary characters.
NOMADS Integration
  • When a new file extension is added to the list of file extensions for NOMADS library files, a new file association will be created to associate the file extension to the NOMADS editor
  • Add option to access Search / Replace action for the current library

v2.5.4 August 2017

Builder
  • Only change the 'LC', 'LD', 'LE', and 'NL' system parameters when corresponding preference on IMPORT preference page is set. Otherwise, keep the current setting from the environment. This will allow alternate START_UP programs to set these system parameters for the build process.
  • Add new project property 'forceResourceDir.xxx' to force all files in the folder 'xxx' to be resource files
  • Check / add passwords from preference page to list of known password at beginning of each build
Contributed Tools
  • PvxDocs
    • Correction for formatting of HTML output for build information block and unordered list
    • Adjust logic to group overloaded method declarations before the parameter information for the method(s)
  • Strip Trailing Whitespace
    • Contributed tool to enable strip of trailing whitespace as part of the build process
  • Dictionary Viewer
    • Display additional information: physical file, column options, column defaults, key segment options
    • Display full file description; do not strip module or other keywords
    • Display embedded dictionary information for ProvideX keyed files
    • Skip paste attempt when no file open in editor
Editor
  • A preference has been added to the Editor Options preference page 'Completion Proposals - Enable load of external keyword categories'. When this preference is not checked, the loading of external keyword categories will be disabled. When set as a workspace preference, the external keyword categories will be enabled for entire workspace. The preference (_bCP_ExternalKeywords) can be included in the project.properties file to override the setting for a project.
NOMADS Integration
  • NOMADS editor will force NOMADS view to be visible, load with information for the selected library file, and then force close the NOMADS editor window

v2.5.3 March 2016

Editor
  • Compare: open new tab for program compare even when program is already loaded in another editor tab
  • Correction to logic to use the file property 'Allow C-style block comments' to override the Builder Options Preference 'Disable C-style block comments'.
Contributed Tools
  • Style Check - A new 'TODO' rule where comment following the tag is recorded in warning description.
Miscellaneous
  • Add logic to CALL alternate startup program when initializing a new ProvideX console session or loading a program into a ProvideX session

v2.5.2, v2.5.0 November 2015

Editor
  • Automatic keyword conversion as part of the build process
  • Code folding
Contributed Tools
  • Style Check - Update override tags, User/Local secondary rule file
Miscellaneous
  • New logic to identify when a project / workspace has been relocated
  • Cleanup property pages

v2.4.2 March 2014

Contributed Tools
  • Style Check - new rule options
Miscellaneous
  • Compatibility issues with recent Java updates
  • Changes to reduce the number of full builds
  • Improved error handling / reporting for file copy to test area
  • Additional error handling and new messages for the copy to test system to help identify reason for a failed copy.
  • Historically, Eclipse will occasionally decide to perform a "Full" build of all projects in a work space when the 'Build Automatically' option is enabled on the "Project" menu. For some projects this can take a considerable amount of time. The builder will now check to see of the output folder exists (normally this will be "compiled") and will skip the "Full" build. To force a "Full" build for a project, choose "Project | Clean" from the menu.

    The 'clean build' will not delete the output folder so properties associated with the output folder will not be lost as part of the 'clean build'

v2.4.0 March 2013

Editor
  • Editor options - new option to enable conversion of statement labels during keyword conversion
Builder
  • Resource build information now stored in properties file
Contributed Tools
  • Style check - a simple rule-based style check is now included
Miscellaneous
  • Project-specific properties enhancements:
    • Check for a workspace properties file
    • Set defaults/overrides for System preferences
  • Improved error handling / reporting for file copy to test area


Install Eclipse and Sage Plug-in

info This documentation includes screen shots of web pages and application installation steps that may not reflect the current web site layout or application processes.

  • Pre-requisites
  • Install Eclipse
  • Install Sage Plug-in
Install Eclipse and Sage Plug-in Updated: July 2019
Pre-requisites
Java
warning The Oracle Java License has changed for releases starting April 16, 2019.

The new license permits certain uses, such as personal use and development use, at no cost -- but other uses authorized under prior Oracle Java licenses may no longer be available. Please review the terms carefully before downloading and using this product. An FAQ is available at https://www.oracle.com/technetwork/java/javase/overview/oracle-jdk-faqs.html.

The Sage Plug-in for Eclipse requires the latest Java run-time environment.

Oracle Java
Install the latest racle Java SE run-time from the Oracle web site http://www.java.com.

Oracle JDK
Install the latest Oracle Java JDK run-time from the Oracle web site https://www.oracle.com/java/technologies/downloads/.

OpenJDK

  1. Go to the OpenJDK web site (https://jdk.java.net/)
  2. Go to the page for the latest release version of the JDK, and download the version for your operating system. In March 2022, the latest version is JDK 18.
  3. Unpack the file into C:\Program Files\Java, create the folder, if necessary
  4. Search for 'Edit System Environment variables' in the Control Panel
  5. Click 'Environment Variables...' and edit the System Path environment variable.
  6. Add the path to the location of the OpenJDK 'bin' folder (for OpenJDK 18 the path is: C:\Program Files\Java\jdk-18\bin) and place at the top (beginning) of the list and save the changes.

Check Java Version
Open a command window and check the version of Java with the command 'java -version'; older versions will use 'java --version'.

ProvideX with Developer License
Install ProvideX on the local system with a developer license for at least two users.
Install Eclipse
Select/Download Eclipse Distribution

Download an Eclipse distribution from the Eclipse web site ( http://www.eclipse.org ). For Windows, download the installer executable or click the Download Packages link to select an alternate install package.

There are a large number of distributions available for download that have been created for specific development environments. It is best to review this list and choose the one that is closest to your requirements. If the selected distribution does not include all of the prerequisites for the plug-in, these can be installed using the Software Installation mechanism in Eclipse.

If you are planning to only develop using the Sage Plug-in for Eclipse, the distribution for Java developers is the smallest one that includes all of the required prerequisites.

Unpack/Install Eclipse

If you are using a distribution ZIP file from the Eclipse web site, simply unpack it on your system.

info For a consistent install on multiple workstations with different operating system versions, create a new folder in the root directory of the primary drive (for example: apps) and unpack the file into this folder.

There is no setup program - once the file has been unpacked, the Eclipse install is complete.

Now is a good time to create a shortcut to the Eclipse executable file to make it easier to locate and use later.
Install Sage Plug-in for Eclipse
Software Update

The simplest method for installing additional plug-ins is to use the "Software Update" capability in Eclipse. From the Eclipse menu, choose Help > Install New Software...

Eclipse - Install new software

The "Available Software" screen will display...

Eclipse - Available software

Define Update Site

Review the list of existing update sites to locate the site to use. If the site cannot be found in the list, the location of update site must be added to the list.

Click Add to create a new update site.

Enter a name and URL for the Sage Plug-in update site:

  • The public update site is http://eclipse.sagemas.com
  • The internal update site is http://svn.pvx.com/UpdateSite

Eclipse - Add update site

Click OK to complete the creation of the repository definition.

info If a ZIP file from the Plug-in Update site, it can be used as the installation source by clicking Archive... and selecting the ZIP file.

Install Plug-in

The following example demonstrates how to install the latest version of the Sage 100 ERP plug-in. These steps and messages will be similar for any other plug-in.

  • Expand the Sage 100 - Public Release category
  • Select the ProvideX Plug-in for Eclipse and Sage 100 Plug-in
  • Click Next to continue the installation process

Eclipse - Select plug-in to install

A new dialogue will display with a list of the items that were selected for installation. Click Next to begin the next step of the install process.

The next dialogue will display the licenses for the selected plug-in(s) for you to review. Once the licenses have been reviewed, select radio button below the license text to indicate whether you accept the terms of the license agreement.

  • If you do not accept the terms of the license agreement, you cannot continue and must click Cancel to abort the installation process.
  • If you accept the terms of the license agreement, click Finish to continue the installation process.

The files for each of the selected plug-ins will download and install. A progress window will show the progress of the installation process.

info If the installation package for any of the selected plug-ins is not signed, a security message will be displayed asking you to verify that the software should be installed. You must click OK to continue with the installation.

Once the installation is completed, the software update process will ask to restart Eclipse for the modifications to take effect. Click Restart Now to restart Eclipse.

Eclipse Welcome Page

Eclipse will restart and display the "Welcome" page which is used to access additional information about some of the registered features of the Eclipse installation.

The selected plug-ins are now installed; close the welcome page by pressing the button on the toolbar to go to the workbench or by pressing the close button on the "Welcome" page tab.


SLA for ProvideX Plug-in for Eclipse

License Agreement For ProvideX Plug-In For Eclipse Development Framework

Sage Software Canada, Ltd. ("Sage Software") created and owns the copyright and other intellectual property for various computer programs and related works including ProvideX software and including the ProvideX Plug-In that Sage Software makes accessible via its Update Server for downloading and use subject to the limitations set forth herein.

Sage Software has granted licenses to use ProvideX software, and provided that you have such a license, Sage Software grants to you, free of any royalty of other charge, a license to download and use the ProvideX Plug-In, but only for its intended purpose with a licensed copy of ProvideX software and within the Eclipse development framework.

Your use of the ProvideX Plug-In requires use of the same unlocking key needed for you to use your licensed copy of ProvideX software.

The license granted to you herein does not include any authorization for you to make any copy of any part or all of the ProvideX Plug-In other than as necessary to use it for its intended purpose, and you agree to refrain from doing so.

The license granted herein includes the conditional right to prepare and deliver to Sage Software a separate plug-in element, on condition that you hereby grant to Sage Software an irrevocable, perpetual, worldwide, royalty free license to reproduce, prepare derivative works thereon, and to distribute whether alone or in combination with other material including the ProvideX Plug-In. Except for the limited conditional right set forth above, the license granted to you herein does not include any authorization for you to prepare any derivative work based upon the ProvideX Plug-In, or to distribute any part or all of any derivative work based thereon.

Irrespective of how the ProvideX Plug-In is distributed (whether via downloading or otherwise), it is distributed AS IS, without warranty of any kind. Sage Software disclaims every warranty (whether any implied warranties of merchantability, fitness for particular purpose, against infringement, or otherwise).

This license granted under this agreement for the ProvideX Plug-in is governed by the laws of the Province of Ontario in the Country of Canada, and shall inure to the benefit of Sage Software Canada Ltd., its successors, administrators, heirs and assigns.


ProvideX Tutorial - Getting Started

This section of the ProvideX Developer Guide for Eclipse is presented in the format of a tutorial to help familiarize you with the ProvideX plug-in for Eclipse.

This tutorial will create two ProvideX Projects. The first is a project based on source for a sample application than contains ProvideX keyed files, NOMADS libraries, web pages and programs. The second project will import ProvideX programs and files from an existing application.

Contents

  • Prepare the Workbench
  • Create ProvideX Projects
    • Existing Source Code
    • Import Application Programs/Files
  • Browse a ProvideX Project
  • ProvideX Editor
    • Opening a ProvideX Editor
    • Content Assist
    • Identifying Problems in Code
    • Using Local History
  • Building ProvideX Projects
    • General Build Concepts
    • Building the DemoApp Project
    • Resources and ProvideX Source Code
  • Running ProvideX Programs
    • Running a Console
    • Launching a Program
    • Launching a Program in WindX
  • Testing a ProvideX Application
    • Simple Application
    • Complex Application


Launching a Program in JavX

In this section, you will run learn how to run ProvideX programs from the Workbench in the JavX thin client. Prior to running the DemoApp, please do a clean build and make sure there are no errors. For more information on building the project see Getting Started > Project Tutorial > Building ProvideX Projects > Build the DemoApp Project.

  1. From the Workbench toolbar, select Run > Run Configurations...

  2. The Run Configurations dialog opens. This allows you to configure how a program is launched, including its arguments and other options.

  3. Right click the JavX Client from the list of launch configurations and select New Configuration.

  4. The JavX Client launch configuration dialogue will appear. The JavX Client launch configuration dialogue as eight tabs:

    • Application
    • Arguments
    • Client
    • Parameters
    • JavX Java Arguments
    • JRE
    • Classpath
    • Common

    Note: Four of the eight JavX Client tabs are taken from the WindX Client launch configuration.

The Application Tab

The Following fields reside on the Application tab (below the Name field): ProvideX project, ProvideX program to run, ProvideX Executable, and Working Directory.

  1. Enter "JavX DemoApp" in the Name field

  2. In the ProvideX project section, click the Browse button and select the DemoApp project.

  3. In the ProvideX program to run section click on the Search button. Browse to and select the menu program in the project's output directory; e.g., browse to the file: compiled\prog\menu.

    Note: Do not select the menu file in the input directory.

  4. Accept the default ProvideX executable which will be the one that was selected for the workspace during the configuration of the ProvideX plug-in.

  5. In the Working Directory section, the default value will be the root directory for the workspace; simply add the name of the project output directory (DemoApp\compiled) to the end of the default value

  6. When the Application tab is done, click Apply.

The Arguments Tab

The following fields reside on the Arguments tab: Program Arguments, Path to Ini file, and Window state.

  1. Select the Arguments tab.

  2. By default, the program will use the project's default ini file. The project's default ini file is found in the project's root directory. For more information on the default ini file see Project Tutorial > Creating a ProvideX Project. To specify an ini file use the Search button, browse to, and select a ProvideX ini file located in any directory. This application will run with the default ProvideX ini file so leave this field blank.

  3. Enter "-hd" in the Window state field so that the main window of ProvideX is hidden when the the menu program is run

  4. When the Arguments tab is done, click Apply.

The Client Tab

The following mandatory fields reside on the Client tab: ProvideX host and Port number for host. There are also a number of optional fields. See the concepts section of this document for more on the Client tab's Optional fields.

  1. Select the Client tab.

  2. Simply check box beside the option Automatically launch ProvideX host locally on any free socket.

  3. The Client tab is done, click Apply.

The Classpath Tab

Several of the JavX client launch configuration tabs are optional and not used in this tutorial. The tabs covered above and the Classpath tab are the only tabs with mandatory fields.

  1. Select the Classpath tab.

  2. Select User Entries from the list of Classpaths.

  3. Click the Add External JARs... button.

  4. Browse to the JavXPlugin jar file you want to use. The JavXPlugin.jar is found in the Eclipse plugins directory.

  5. When the Classpath tab is done, click Apply.

  6. Click the Run button on the Eclipse JavX launch configuration dialogue.

    Note: The DemoApp demo program uses a COM control. JavX does not support these controls. The application may not run in JavX; if it does run, you will encounter some errors.

  7. Exit the ProvideX menu program

  8. To re-run this program, pres Ctrl+F11 or click the run icon [image] on the Workbench toolbar.

Next Section: Simple Application


-------------------------------------------------------------------------------
ProvideX Plug-in for Eclipse       - README File -                   June 2022
Release Notes
-------------------------------------------------------------------------------
$Id: PVXEclipse.txt 3096 2022-06-16 17:00:34Z fmcguirk $
-------------------------------------------------------------------------------
Sage Software
Tel. +1 800 463 4147
-------------------------------------------------------------------------------

This plug-in is designed for the development of ProvideX applications within
the Eclipse framework and is available for use with ProvideX Professional
Version 7 (or greater) activation.

For more information on Eclipse, please refer to the FAQ pages on the Eclipse
Foundation website:

    http://wiki.eclipse.org/index.php/The_Official_Eclipse_FAQs

-------------------------------------------------------------------------------

Pre-requisites

The ProvideX plug-in for Eclipse has a number of pre-requisites:

    * A ProvideX Professional v7 activation.
    * A 2 user license (or a demo on MS-Windows) is required.
    * Java SE 8 (1.8.x) run-time environment; compatible with Java 17
    * Eclipse Version 4.5 (Mars) or higher.

Known Issues / Limitations

    * As with most other applications, file access rights are very important and
      can lead to unexpected issues when not set to allow the current user to
      have access to the files.

    * MS-Windows UAC may cause issues when updating files in a folder that is
      shared by a number of users on the same system or on a central server.

    * Eclipse is case sensitive, but the standard file systems on MS-Windows are
      not case sensitive; this can lead to mysterious errors.  When the case of
      a file name in Eclipse does not match the file in the MS-Windows file
      system, Eclipse will report an error when attempting to create, delete, or
      update the file.

    * Inconsistent EOL handling; occasionally a file is created that does not
      have consistent end-of-line (EOL) character sequences.  When this happens,
      the editor will get confused and will lead to failed cut-and-paste
      operations.  The work-around is to copy the entire file contents into a
      new document in an external editor and then replace the text with a copy
      from the external editor.

    * The smart-indent capability can sometimes get confused and create
      unexpected indentation for a new line; work-around is to end line with
      remark, if possible.

-------------------------------------------------------------------------------
NOTE:

   See the online documentation for information about environment variables that
   are used to enable debug functionality.
-------------------------------------------------------------------------------

v2.6.7 (June 2022)

Enhancements:

    * General
      - Adjust logic to resolve issues with new features when using a ProvideX
        executable older than v9.20
      - New 'Writing a Contributed Tool' example to show how to use a panel for
        configuration options and the progress view to show messages as the tool
        perform actions.

    * Builder
      - Add a new preference, and associated logic, to Builder to skip copy of
        programs to linked folders when there are build or style check errors
      - Use default ProvideX executable when NOMADS Alternate executable is
        invalid or cannot be found
      - If full build is triggered at launch and output folder exists, only
        build modified files
      - Additional log messages when updating outline, dictionary, and library
        DOM data
      - New builder option to disable scan for duplicate function and variable
        names (error 24)
      - Convert Program to Text - copy source file to output folder when convert
        fails because the password is not known
      - Add support for encrypted password values (requires ProvideX v9.20)
      - improve error 24 scan logic to support function definitions within the
        class declaration section
      - Add new project-specific property 'AltExe_EnvironmentPropertyFile', and
        associated logic, to be used by build process to set environment
        variable values before starting build process; if property is set force
        build process to use Alternate Executable logic
      - Add a new debug preference to set the debug message verbosity level
      - Write message to Console when project.properties file exists for project

    * Import/Convert
      - The process to convert Providex programs to text has changed. The new
        process will use the source file in the original location and will not
        move the file to the output folder.

    * Editor
      - Additional debug messages to track (rare) issue where NOMADS library
        information is not loaded
      - fix for null pointer exception when processing file annotations
      - identification of keywords to highlight will now stop when followed by
        the characters: < > - * /
      - Updated Constants and Functions

    * Contributed Tools
      - Do not enable the Configure button when a configuration action has not
        been implemented
      - PvxDocs:
        o add option to set date/time stamp of generated documentation
          file(s) to match the source class
        o add option to document generation setup page to set option for
          "Link to Page"
        o add substitution tag %PvxCode2()% to add ProvideX code sample to
          replace the tag in line
        o add substitution tags %PvxCodeBegin% / %PvxCodeEnd% to define blocks
          of code spanning multiple lines
        o when parameter information starts with plus (+) character, add the
          remaining text to previous line to allow parameter description text
          to span multiple lines
      - Dictionary Viewer
        o add print format column to information displayed for fields
      - Common Tools / Methods
        o Common UI MessageBox() Method - add parameter to set title for message box
        o ProgressLog - add methods to support the creation and display of log file
      - Build Tool - Encrypt Password
        o a new contributed tool to encrypt a password value
      - Change Keyword Case
        o resolve issue where keyword case gets changed in comments
      - Style Check
        o new option to check search value against list of keywords
        o create a detailed log of issues found by scan and option to view this
          log once process is complete
        o perform tag substitution during the build process
      - Tag Substitution
        o a new contributed tool to perform substitutions as part of build
          process
        o allows for a user-defined properties file in contributed tools folder
          for additional tags or to override the substitution value of a
          built-in tag
        o searches for tag using regular expression for more flexibility with
          substitution content
        o does not change the original source file; changes will appear in
          compiled file

    * Preferences
      - Fix: Editor Preference page fails to load in Eclipse 2020-12
      - Resolve issue with export of ProvideX Properties for resources in
        project(s)

Sage 100 Plug-in

Enhancements:

    * General
      - New preference page to set configuration values for Sage 100 environment
        used for Sage 100 tools
      - Additional items on the Sage 100 menu
        o Code Coverage Analysis
        o Data File Display and Maintenance (DFDM)

v2.6.5 (July 2020)

Enhancements:

    * General
      - New Project Explorer view as replacement for deprecated Navigation View
      - New Workspace Properties file preference 'AltInit.InitSageSessionObject'
        to enable the startup for workbench actions to initialize the Sage
        Session object
      - Reduce number of messages written to console view when debug options
        are not enabled
      - error handling to catch when Java event process no longer active
      - correction to line number increment from AI system parameter override
      - startup program - use in PRC process and console session
      - add EventManager Resource Project property and set value when interacting
        with a resource to improve the reliability of Project/Workspace
        Preference/Property override values
      - Outline View
        o Add filters: Public / Private Properties, Private Functions
        o Change order for "Group By Type" and sort alphabetically within type
        o set "Group by Type" as default
    * Builder
      - add logic to handle new and modified files when automatic build is
        triggered as a result of a refresh or plug-in start-up
      - add logic to identify and build new files added to source folder from
        outside of Eclipse
      - correction to automatic build logic to only process each file once
      - Incremental Build using an alternate executable to load properties from
        project properties file
      - Adjust logic used to check whether file is a resource to work better
        when attempting to convert resources to text

    * Editor
      - add new template 'esx' to insert the ProvideX commands to Escape to
        Console in Command Window when Debug is enabled
      - add new template 'sageheader' and change ProvideX Program Wizard and
        ProvideX Class Wizard to use this template instead of the 'header'
        template

    * Wizards
      - ProvideX Class Wizard
        o allow selecting class files for LIKE from entire workspace in addition
          to current project
        o adjust to use new 'sageheading' template
        o change logic for creation of LIKE statement in new class to group up
          to five class files per line
        o only use files from selected list with PVC extension, ignore any others

    * NOMADS Integration
      - add 'Data Classifications' task to NOMADS View drop-down menu

    * Preferences
      - change text for option to add file extension to source file when
        converting a compiled program on Import/Convert Preference page
      - restore option to suppress password request for as new data files are
        processed

    * Contributed Tools
      - adjust contributed tool startup to skip theme logic when using a version
        of Sage 100 older than Sage 100 2016
      - Message Library Viewer
        o change line-feed characters in modified text to SEP characters
      - Style Check
        o when preference for user defined keywords / contributed tools is set,
          automatically save new style rules to file in this folder
        o update source file during build process when style check configuration
          option is set to automatically update source file and there is a replace
          value defined as part of a style check rule
      - Super Search
        o add button to allow clearing of previous search results

v2.6.2 (July 2019)

Enhancements:

    * General
      - Outline View will now remember settings (sort / filter) for session
      - NOMADS View additional debug messages
      - fix to resolve compatibility issues with Eclipse 2019.6 (4.12.0)

    * Builder
      - when building data files, check option to force rebuild of resource files;
        resolves bug with build of NOMADS Library files
      - enhance check for error 24 to match function declarations based on
        parameter data types

    * Preferences
      - Editor Preference Page
        - fix to resolve null pointer exception when Editor Options for Completion
          Proposals for external keywords is not enabled

    * Contributed Tools
      - Super Search
        o add button to allow clearing of book marks for current project or
          entire workspace depending on search selection

v2.6.0 (March/April 2019)

Enhancements:

    * General
      - now requires Java 8 run-time environment
      - new option on 'Appearance' preference page to set value of TCB(29)
        reported by client (should be the same as the server value)
      - new preference to enable writing of debug messages to the console;
        use '_bDebugLogToConsole' to override this preference can in project or
        workspace properties files.
      - catch actions / events that trigger the ProvideX EventManager to start
        and attempt to process after the start has completed
      - compatibility fixes for OpenJDK 11
      - use fonts set on Preferences / Appearance page for contributed tools

    * Builder
      - add check for error 24 (duplicate property/method declaration)
      - add new preference to force build of files marked as resources
      - update list of file extensions used to identify resource files
      - display original source file name for event, when changed by intermediate
        observers
      - Improve logic to build file(s) to resolve issue causing build process to hang
      - do not build file if identified as a resource based on file extension or
        forced by project/workspace properties file
      - keep file attributes for copy from output folder to linked folders or test
        platform folders
      - fix to resolve potential builder hand when multiple line label references
        occur in single source line

    * Editor
      - Single-click in outline view will now position to corresponding line in
        the editor view
      - On startup, Eclipse will restore the editor state from previous session
      - new preference to allow double click in string literal to select current
        word instead of the entire contents
      - add custom keyword categories using new control files
        o keywordcats.properties
          > define new (custom) keyword categories
        o newCategory.properties
          > use a separate file for each new keyword category to define the
            keywords for the category and the help text to display for each
        o check for keywordcats.properties file in the folder for user contributed
          tools and fall-back to the workspace root if not found
       - Code folding, do not mark FOR-NEXT block starting with the FOR in a
         PRECISION x FOR OBJECT statement

    * Contributed Tools
      - Dictionary Viewer
        o Add Description column to information displayed for columns in table
      - ProvideX Class documentation
        o Add new tags for ordered list (@OList) and unordered list (@UList)
          > each item in the list must be on separate line
          > start line with '+' character to add to the previous line
          > a blank comment line in a list will be ignored
          > the list ends at the next new tag or the end tag for the list
            (@OList_End or @UList_End)
        o Additional fields on main panel to display date changed, file options,
          block size, and button to view file notes
      - Strip Trailing during build updated to also strip trailing blank lines
        from the source file
        o change to not remove whitespace before line continuation characters
      - Super Search
        o will now use a new property 'SuperSearch.IgnoreCharacterList' from the
          project properties file to set additional characters to be ignored
          when scanning the source file(s) for binary characters.
        o correction for error when using 'Whole Word' option for search item

    * Preferences
      - NOMADS
        o When a new file extension is added to the list of file extensions for
          NOMADS library files, a new file association will be created to
          associate the file extension to NOMADS editor
        o Add option to access Search / Replace action for the current library

v2.5.4 (August 2017)

Enhancements:

    * Builder
      - only change the 'LC', 'LD', 'LE', and 'NL' system parameters when
        corresponding preference on IMPORT preference page are set; otherwise,
        keep the current setting from the environment; this will allow alternate
        START_UP programs to set these system parameters for the build process
      - add new project property 'forceResourceDir.xxx' to force all files in
        the folder 'xxx' to be resource files

    * Contributed Tools
      - ProvideX Class documentation
        o Adjust logic to group overloaded method declarations before the
          parameter information for the method(s)
      - Strip Trailing WhiteSpace
        o new contributed tool to enable strip trailing whitespace as part of
          the build process
      - Dictionary Viewer
        o display additional information: physical file, column options,
          column defaults, key segment options
        o display full file description; do not strip module or other keywords
        o display embedded dictionary information for ProvideX data files
        o error handling around paste action when no file in editor

    * Editor
      - new preference (_bCP_ExternalKeywords) to disable loading of external
        keyword categories; can be used to disable for entire workspace or as a
        project override

Bug Fixes:

    * Builder
      - check / add passwords from preference page to list of known password at
        beginning of each build
    * Pvx Docs
      - correction to formatting of HTML output for unordered lists and build
        information block
    * Miscellaneous
      - fix for null pointer exception when attempting to build file(s)
      - NOMADS editor will force NOMADS view to be visible, load with
        information for selected library file, and then force close the editor

v2.5.3 (March 2016)

Enhancements:

    * General
      - open new tab for program compare even when program is already loaded in
        another editor tab
      - add logic to CALL alternate startup program when initializing a new
        ProvideX console session or loading a program into a ProvideX session

    * Contributed Tools
      - Style Check
        o add option to style check rules to use text found in program line
          after the search value to be used as the log message instead of the
          rule description - useful for TODO: tags
       - Simple Style Check Rules
         o add a 'TODO:' style check rule to search comments and create warnings
           for any 'TODO:' that is found with the 'TODO:' text as the description
           of the warning

    * Sage 100 Plug-in
      - updated context information to include new constants and methods
      - add a 'TODO:' style check rule to search comments and create warnings
        for any 'TODO:' that is found with the 'TODO:' text as the description
        of the warning

Bug Fixes:

    * Builder
      - correction to logic to use the file property 'Allow C-style block
        comments' to override the Builder Options Preference 'Disable C Style
        block comments'

v2.5.2 (November 2015)

Enhancements:

    * General
      - improved logic to check for Sage 100 development environment
        o will now check for Sage 100 activation in the ProvideX environment
          associated with a project in addition to checking to see if Sage 100
          plug-in is installed

    * Contributed Tools
      - Keyword conversion
        o New contributed tool to enable keyword conversion as part of build
          process

Bug Fixes:

    * Contributed Tools
      - Keyword conversion
        o resolve issue where statement labels are not converted when Editor
          Option is enabled

v2.5.0 (October 2015)

Enhancements:

    * General
      - Update documentation in developer guide for PvxDocs
      - Additional debug logic added to PvxDocs / Scan Workspace
      - Updated structure of build properties file
      - improve logic to catch when a project has been moved or copied

    * Builder
      - adjust to always execute project-specific pre/post build logic
      - limit line increment to keep highest line number less than 64999

    * Editor
      - rewrite of code-folding logic to resolve performance issues
      - improve handling of block comments

    * Preference/Properties Pages
      - ProvideX Properties Page for a project
        o code cleanup to reduce occurrence of Java Null Pointer exceptions
        o now save project location to aide in process used to determine when
          a project is relocated
        o add option to reset the ProvideX executable for a project back to
          the default (workbench executable)

    * Contributed Tools
      - Style Check
        o Allow override for style check to be any of the following (ignore case):
          *SC-OK*, *SC_OK*, *SCF-OK*, *SCF_OK*

Bug Fixes:

    * General
      - code cleanup to reduce occurrence of Java Null pointer exceptions

    * Builder
      - resolve issue parsing PvxPlus structured strings

    * Contributed Tools
      - Style Check
        o correction to logic used to update rules when secondary file exists
      - Super Search
        o corrections to resolve error 11 when loading the saved search data
        o correction to message display when large result set created by search

v2.4.2 (March 2014)

Enhancements:

    * Automatic build of all ProvideX projects
      - logic updated to skip full build of project if the output folder
        (compiled) exists in the project
      - use 'Project | Clean' to force a full build on the project
      - logic adjusted to no longer delete the output folder so any existing
        properties will not be deleted

    * Builder
      - add builder option to disable logic to check for non-ASCII character(s)
        in first 512 characters of source file and identify file as BINARY
      - can override new builder option in project.properties file with the
        keyword: overridePreferenceB._CheckBinaryDataInFileHeader

Bug Fixes:

    * Plug-in
      - correction to logic used to determine type of source file when source
        file size is less than 512 bytes

v2.4.1 (December 2013)

Enhancements:

    * Contributed Tools

      - PvxDocs
        o update documentation for the contributed tool
        o adjust logic for %PvxCode()% tag to maintain leading whitespace to
          allow generated documentation to keep indentation from original code
        o modification to split generated export files into multiple 400KB files

      - Style Check
        o add option to restrict a rule to first 10 lines of source file

    * Sage 100 ERP Plug-in

      - branding modifications to change references to MAS/MAS90 to Sage 100 ERP
      - adjust Style check rules

Java Compatibility:

    * changes to logic to start ProvideX processes

Bug Fixes:

    * Plug-in
      - modification to resolve error 47 in 'get_LibInfo' when attempting to
        generate NOMADS library file contents page
    * Contributed tools
      - Correction to enable 'XML_Convert' to work when using an alternate EXE
      - remove name of class from StyleCheck description to resolve issue where
        Sage 100 ERP StyleCheck failed to execute when selected from 'Sage100ERP'
        menu

v2.4.0 (March 2013)

Enhancements:

    * Project / Workspace properties files
      - expand project specific property implementation to also check for a
        workspace properties file to be used when no project specific property
        has been defined.

    * Override System Preferences (in ProvideX Event Manager)
      - Adding the override information for system preferences into the project
        specific properties file.

        The internal names of the properties are prefixed with either
        'overridePreferenceB' or 'overridePreferenceS' depending on
        the data type of the preference.

        Some of the preferences that the "project.properties" can override:
        o overridePreferenceB._BtiEnable
          > enable use of BuildTagInfo file to load/store resource information
        o overridePreferenceB._BuildMaintainCase
          > enable system parameter to maintain case when build ProvideX programs
        o overridePreferenceS._NOMADS_Default_Suffix
          > set the default file suffix to use for NOMADS library files
        o overridePreferenceB._extObserver_<ClassName> to enable/disable a specific
          contributed tool

    * Contributed Tools

      - Message Viewer
        o add option to convert message library (increase key size of message
          library)
        o restrict length of code for new messages to match library definition
        o improve rules used to determine if a file is a message library

      - Dictionary Viewer
        o Add "All Files" option to 'Open' dialogue to allow selecting Roswell
          dictionary files in addition to ProvideX dictionary files
        o Loading the DropBox for 'Dictionary' is now based on the project
          instead of the location of the ProvideX executable

      - PvxDocs
        o Resolve issue with generation of documentation files into a sub-directory
          of project
        o Correction to substitution value for 'ClassStart' to remove extra tags
        o Remove TAB characters from documentation

      - Style Check
        o Split the "Check REM / Literals" into two separate options
          > Default new options based on setting of the old option
        o a simple rules-based style check contributed tool is now included
        o add ability for user-specific rules to be loaded/saved into the
          directory for user-defined external observers / contributed tools;
          simply create a text file with the same name as the style check class
          to enable this feature.

Bug Fixes:

    * resolve issue that caused error 88 when creating file information with
      the contributed tool 'Create ProvideX Data File Information'
    * resolve socket handling issue that caused some contributed tools to fail
      when using a Java SE 7 run-time
    * Resolve issue with bracket matching in Eclipse Juno
    * improved handling of warnings to resolve issue where warnings do not get
      marked correctly against a source file when the build process is using an
      alternate executable
    * correction to resolve issue where warnings do not get marked against a
      source file when using an alternate executable
    * correction to message filter logic to properly handle messages that
      include line breaks

v2.3.1 (Dec 2011)

Enhancements:

    * report when files/folders exist in test environment with different case;
    * change password validation to NOT prompt user for new password but instead
      mark the resource as password protected and password is not in list of
      known passwords

Documentation:
    * update documentation to include additional examples of:
      - Event observers (pre/post process observers)
      - Contributed tools

Bug Fixes:
    * correction to logic for paragraph breaks in comments for constructor
    * correction to logic in Style-Check to identify file as a class definition
      to properly handle files that do not have a source file extension that
      was stripped during the build process

v2.3.0 (Sept 2011)

Enhancements:

    * Preferences
      - Move "Providex UltraFX" preference page to the "Appearance" preference
        page in the "ProvideX" section

    * Builder
      - A new preference "Mark all string literals that span multiple lines
        with a warning" has been added to the 'Builder|Options' preference page
      - Adjust logic used to select files from the "Navigator" view for the
        build process to include files with no file extension based on the
        setting of the "Compile files that have no file extension" option on the
        builder preference page.

    * Contributed Tools

      - Style Check:
        o Allow a rule to be restricted to ProvideX Class definitions
          (files with an extension of '.pvc')
        o Add "Cancel" option to allow a Style Check to be aborted

      - Super Search:
        o Allow "?" to be used in the filename filter
        o Allow quotation marks to be used in the search value
        o ignore case when matching filenames against the filter

Bug Fixes:
    * resolve error 2 when attempting to process empty program source files
    * resolve "Out of Memory: Heap space" error when performing a "Super Search"
      on a project with a large number of files

v2.2.0 (Aug 2011)

Enhancements:

    * Builder
      - A new preference "Automatically convert ProvideX programs to text" has
        been added to the 'Builder|Options' preference page; this preference will
        default to enabled to maintain compatibility with previous releases
      - A new option has been added to the 'Navigator' view pop-up menu to force
        the conversion of the selected ProvideX programs to text

    * MAS Plug-in
      - MAS Plug-in has been modified to adjust the preference defaults / values
        to correspond with current MAS developer standards.  This will occur only
        when a new workspace is created.
      - A new action has been added the the "MAS" menu to allow a user to apply the
        MAS standard preferences settings

Bug Fixes:
    * ProvideX builder ProgressBar now shows actual work completed
    * WorkspaceReader will now check the 'Build files with no extension' builder
      preference when scanning the resources selected in the Navigator view for
      ProvideX source files
    * ProvideX Event Manager
      - NOMADS initialization to properly handle a project
       source folder that does not use the standard (src) name and is a different
       length.

v2.1.0 (June 2011)

Enhancements:

    * Plug-in error handler:
      - will automatically generate a log file
      - allow access to the information contained in the log file
      - allow copy of log file information to the clip_board
      - automatically delete the log file on exit

    * ProvideX Editor
      - display message associated with an annotation icon when mouse hovers
        over the icon on either the left or right margin in the editor view
      - double click on a variable that is between two string literals will now
        select the variable rather than all of the text between the two literals
      - context help for new keywords for ProvideX v9.30
      - colour highlighting of ProvideX File I/O options, new keywords, and
        several keywords that were not highlighted properly
      - add '_OBJ' to list of system variables for colour highlighting
      - now allows unlimited nested C-Style block comments
      - Adjust logic to properly identify arrays as arguments to function
        declarations when building the information for the Outline view
      - Outline View contents will now refresh properly after changing to an
        editor tab for a file with the same name in a different project.

    * NOMADS Integration
      - Project-Specific properties
        o 'NOMADS_AltExe' to specify the ProvideX executable to be used to
          launch NOMADS sessions for any resource in the project.
      - NOMADS Editor
        o display a form in Editor view to tell user to maintain NOMADS library
         contents using NOMADS view
        o force load of library contents into the NOMADS view:
          > on initial open of editor
          > when editor window becomes active

    * PvxDocs
      - choose to exclude sections from generated documentation
      - skip any classes that do not include documentation
      - generate documentation using same folder structure as project
      - add new output format: Wiki Text
      - add editor templates:
        o  pvxdoc.JavaClass: %JavaClass(class_name)%
        o pvxdoc.PvxClass: %PvxClass(class_name)%
        o pvxdoc.PvxLibClass: %PvxLibClass(class_name)%
        o pvxdoc.PvxCode: %PvxCode(code)%

    * Super Search
      - Enhancements for use with Annotation hover:
        o add new parameters to allow user to specify the value to be used for
          the book mark description; one of program line, search expression, or
          both
        o add ability to output search results to a log file instead of the
          book mark view
      - Has been split into two processes
        o the first is the UI for entering the parameters
        o the second is used to perform the search and log the work performed to
          enable monitoring of the progress of the search
      - When you press "OK" to begin a search, the UI screen will close and a
        "Progress Log" view will open to perform the work for the search
         o The "Progress Log" view is actually running in a new process
         o Log information is displayed in a window
         o The log information is thrown away when the view is closed

    * Progress Log:
      - Child class can now enable a “CANCEL” button and will need to implement
        logic to catch when the user presses this button and cancel the task
      - A new check-box allows the user to enable/disable the force focus on the
        LAST line of the log window
      - Forces standard Console font to be used for the log window

    * Miscellaneous:
      - new contributed tool to strip trailing white space on each line of
        the source files selected on the Navigator view
      - Common interface for processing a NOMADS panel now allows arguments to
        be passed to the new process and into the class instantiation of the
        UI class for the panel
      - WorkspaceResourceReader enhanced to process all resources in the
        workspace

    * Bug fixes
      - resolve issue with StyleCheck where reported Style Check issue did not
        get tagged against the correct line in the source file
      - change to 'file_reader.pvc' to remove $0D$ from data stream when reading
        a source file that was transferred from a Windows machine to a Linux
        machine using a binary copy instead of a text copy
      - correction to add space before line continuation characters after trailing
        white space has been removed

      - PvxDoc:
        o correction to class name when followed by a remark in the LIKE statement
        o do not create links to classes that are not included in the documentation
          generated from the current project

      - Super Search:
        o resolve issue where file name/mask was ignored and all files in a
          project were included in the search

      - Data Dictionary Viewer
        o resolve an error 11 when saving the current file information

v2.0.0 (Feb 2011)

    This release consolidates all fixes and enhancements that have been made
    to the plug-in.

    * Plug-in Enhancements:
      - JavX Plug-in based on JavX 3.0
      - the documentation has been updated to reflect the changes made to the
        contributed tools and structure of the plug-in.
      - the plug-in tutorial has been refreshed to include all of the information
        from the obsolete video tutorials
      - project-specific properties file.
      - use enhanced ERR() in ProvideX v9.20 to tag the warning messages
        created during the build process for errors 123, 124, and 125 to
        a specific line in the source file.
      - the console output from the ProvideX Builder now includes the name of
        the destination file that is created.
      - new Project-specific property 'ForceDestinationName' to override the
        destination name for a resource with a value that is based on the name
        of the source file.
      - Build process error/warning messages now include the program line number
        in the text that is written to the "Problem" view.

    * Contributed Tools

      - Style Check:
        o Enhancement to the logic used to search for a value when
          the whole word option is set.  The search will now check the search
          value with a semi-colon on either side with no intervening space and a
          back-slash following the search value.
        o Include the program line number in the message that is written to the
          "Problem" view
        o Enhanced to use the new 'Progress Log' view to log progress

      - PvxDocs:
        o Enhanced to use the new 'Progress Log' view class to log progress
        o add ability to include PROPERTY / LOCAL assignment definitions
        o add ability to override several configuration options on the setup
          panel that is displayed when executing the contributed tool

      - Message Library Viewer
        o can now be used to manage messages in a Message Library

      - Miscellaneous:
        o Adjustments to the configuration screens for several contributed tools
          to display the same as previous releases instead of in a view which is
          now the default.
        o Add a new Progress Log class to be used by contributed tools to show log
          information in a new view that will remain open until the user closes it

    * Development / Test Features
      - Store NOMADS library as a collection of XML files; this is a test
        feature that requires more testing and should be used in a production
        environment; this feature is enabled by adding "NOMADS_xml_export" into
        the properties file for the project

    * Bug fixes
      - adjust logic executed when changing ProvideX executable associated with
        a ProvideX Project to resolve issue where output file name was changed
        to an incorrect value
      - modification to resolve error in SuperSearch when there is an empty
        folder in a project
      - resolve issue where view action bar buttons were displayed on top of the
        "Navigator" view tab
      - do not display messages about invalid or incorrect ProvideX executable
        when the value is not set
      - resolve issue in Message Library Viewer where error is reported when
        invalid text is entered into the filter field
      - resolved an issue with the SuperSearch where the statistics always
        reported zero for the number of programs, lines, and hits.

-------------------------------------------------------------------------------


All Classes and Interfaces

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help

All Classes and Interfaces

Class
Description
AbstractProgressController
AbstractProgressController
AbstractProvideXFieldEditorPrefPage
AbstractPvxEditorAction
AddProvidexHandler
BlockCommentAction
BuilderOptions
BuildResourceAction
ClientTab
This tab appears for java applet launch configurations and allows the user to edit attributes such as the applet class to launch and its owning project, if any.
CodeStyleWarningResolution
ColorManager
ColourTokenFactory
ConsoleDisplayManager
Create an instance of this class in any of your plugin classes.
ConsoleDisplayManager
Create an instance of this class in any of your plugin classes.
ConsoleDisplayManager
Create an instance of this class in any of your plugin classes.
Constants
ConvertAction
CoreTexts
provides internationalized messages Strings from the coretexts resource bundle.
CurvesPanel
DebugLauncherThread
DebugServer
DebugWindXLauncherThread
DefaultItemContentProvider
DefaultLabelProvider
DelayedAction
DelayedEvent
DelayedMethodCall
DelayedMethodCall
DelayedMethodHandler
DelayedMethodHandler
EditorColorPreferencePage
EditorManager
EditorOptions
This class represents a preference page that is contributed to the Preferences dialog.
EditorOptionsPrefPage
EditorState
EditorSyntaxColorPref
EventManager
Controls communication between Eclipse and ProvideX.
EventManager
Controls communication between Eclipse and ProvideX.
EventManagerFactory
Factory that creates the EventManager which Controls communication between Eclipse and ProvideX
ExportPasswordsPage
Page 1 of the base preference export Wizard
ExtAction
ExtCommand
An event that indicates a Contributed action has occurred in Eclipse
ExtensionUtil
ExtKeywordCategoryEntity
ExtKeywordCompoundRule
ExtKeywordDetector
ExtKeywordRule
FlagsPropertyResolver
FxPagePartListener
GenericAction
GenericWorkbenchAction
GradientPanel
HandledInput
HostActionsView
IEmbeddedJavXView
IEventManager
IExtCommand
ImportOptionsPrefPage
ImportPasswordsWizard
Standard workbench wizard for importing resources from the local file system into the workspace.
IniFileBlock
Editor for VM arguments of a Java launch configuration.
IOListView
IPvxElement
IPvxEventCallBack
IPVXEventListener
IPvxIdePlugin
IPvxPlugin
IPvxSaveListener
IsLineNoReqPropertyResolver
JavXAppletArgumentsTab
JavXAppletLaunchConfigurationDelegate
JavXAppletTabGroup
JavXBrowserView
This sample class demonstrates how to plug-in a new workbench view.
JavXThread
LibView
This class displays / updates the information in the NOMADS view
LoadProgramAction
MonitorState
MonitorState
MyCompletionProcessor
NavigationFilter
NewFromExisting
NewLineResolver
NewNomadsDefaultsHandler
NewNomadsLibHandler
NewNomadsLibraryWizard
NewNomadsNmdWizard
NewNomadsObjectDialog
NewProgramHandler
NewProjectFromExistingPage
Standard main page for a wizard that is creates a project resource.
NewProjectHandler
NewPvcCreationWizard
NewPvxClassHandler
NewPvxProgramWizard
NomadsEditor
NomadsPreferencePage
NumericComparator
ObserversPreferencePage
OutputPropertyResolver
OwnerPropertyResolver
PasswordExporterWizard
PasswordPreferences
PasswordPropertyResolver
PasswordTransferElement
PixelConverter
Pixel conversion utility.
PluginTextPlaneView
PreferenceConstants
Constant definitions for plug-in preferences
PreferenceInitializer
Class used to initialize default preference values.
PreferenceManager
PrefPageVistor
ProcessRunner
ProgramViewsPrefs
ProgressIndicator
ProjectExplorer
ProjectUtils
Simple class to provide access to Project/Workspace utility methods.
ProvideX
ProvideXArgumentsTab
A launch configuration tab that displays and edits program arguments, VM arguments, and working directory launch configuration attributes.
ProvideXBuilder
ProvideXConfigurationTabGroup1
ProvideXLaunchConfigurationDelegate1
ProvideXLaunchConfigurationTab
Common function for Java launch configuration tabs.
ProvideXMainTab
A launch configuration tab that displays and edits project and main type name launch configuration attributes.
ProvideXNature
ProvideXNewAction
ProvideXNewWizard
ProvidexNewWizardPage
Standard main page for a wizard that is creates a project resource.
ProvideXNewWizardPageI
ProvideXOOADPlugin
ProvideXPreferencePage
This class represents a preference page that is contributed to the Preferences dialog.
ProvideXPropertyPage
PvcOutline
PvcOutline.OutlineFilter
PvcOutline.OutlineSortBy
PvcOutlineSettings
PvcPage
PvxAnnotationHover
The PvxAnnotationHover provides the hover support for ProvideX editors.
PvxArrayElementVariable
PVXArrayValue
PvxAutoIndentStrategy
Auto indent strategy sensitive to brackets.
PvxBaseClientConfigTab
Common function for Java launch configuration tabs.
PvxBreakpointAdapterFactory
PvxCompletionProposal
PvxContentAssistant
PvxContextInformation
PVXContextType
A very simple context type.
PVXDebugElement
PVXDebugTarget
PVX Debug Target
PvxDirectiveWordRule
PvxDirectiveWordRule.DirectiveWordDetector
PvxEditor
PvxElement
PvxElementAlphaComparator
PvxElementListSelectionDialog
PvxEolRule
PvxEvent
An event that indicates an action has occurred in Eclipse
PvxEvent
An event that indicates an action has occurred in Eclipse
PvxFileUtils
PvxHostLauncher
PvxInfoPresenter
PvxLibElement
PVXLineBreakpoint
PDA line breakpoint
PvxLineBreakpointAdapter
Adapter to create breakpoints in PVX files.
PvxLineLabelWordRule
PvxLineLabelWordRule.LineLabelWordDetector
PvxLineNoComparator
PvxListEditor
PvxMnemonicRule
PvxMnemonicRule.MnemonicWordDetector
PVXModelPresentation
Renders PDA debug elements
PvxNewProgramPropertiesWizardPage
PvxNumbLiteralRule
PvxNumbLiteralRule.numbWordDetector
PvxPairMatcher
PvxParameterListValidator
PvxPasswordInputDialogue
PvxPerspectiveFactory
PvxPluginImages
PvxPrefVisitee
PvxProblem
PvxProgressMonitorDialog
PvxProgressMonitorDialog
PvxPropertyResolver
PvxPropertySource
PvxRcpActivator
The activator class controls the plug-in life cycle
PvxRcpStateFlags
PvxReconcilingStrategy
PvxRequestManager
PvxRunnableWithProgress
PvxRunnableWithProgress
PVXRunToLineBreakpoint
A run to line breakpoint.
PVXSourceLookupDirector
PDA source lookup director.
PVXSourceLookupParticipant
The PDA source lookup participant knows how to translate a PDA stack frame into a source file name
PVXSourcePathComputerDelegate
Computes the default source lookup path for a PDA launch configuration.
PVXStackFrame
PDA stack frame.
PVXStackValue
A value on the data stack
PvxStructureComparator
PvxtagResolver
PVXThread
// * A y VM thread.
PvxUtil
PvxUtil
PvxUtil.ConfirmDialShower
PvxUtil.ConfirmDialShower
PVXValue
Value of a PDA variable.
PVXVariable
A variable in a PVX stack frame
PvxVersionInfo
PvxView
PvxViewSorter
PvxWizardNewFileCreatePage
PvxWordRule
PxvResourceListSelectionDialog
RcpEmbedJavXView
RcpMasProgramView
RcpPluginConnectionControl
RcpPluginJavXApplet
RcpPluginSwingGUIManager
RcpPreferenceConstants
RcpPreferenceInitializer
RcpProgramView
RcpPvxAction
RcpSpawnedMasProgramView
RcpSwtViewPanel
RefactorUtil
RenamePropertyAction
RenamePropertyInfo
an info object that holds the information that is passed from the user to the refactoring.
RenamePropertyInputPage
the input page for the Rename Property refactoring, where users can control the effects of the refactoring; to be shown in the wizard.
RenamePropertyInputPage
the input page for the Rename Property refactoring, where users can control the effects of the refactoring; to be shown in the wizard.
RenamePropertyProcessor
The processor is where the work is delegated to if participants are involved.
RenamePropertyProcessor
The processor is where the work is delegated to if participants are involved.
RenamePropertyRefactoring
Refactoring for renaming properties in Java Properties files.
RenamePropertyRefactoring
Refactoring for renaming properties in Java Properties files.
RenamePropertyWizard
The wizard that is shown to the user for entering the necessary information for property renaming.
RenamePropertyWizard
The wizard that is shown to the user for entering the necessary information for property renaming.
RenumberAction
ResourceManager
Provides access to resources in Eclipse for ProvideX programs
ResourcePropertyInfo
ResourceToChangeEntity
RulerActionDelegate
Toggles a breakpoint when ruler is double-clicked
RunDictDataClassAction
RunDictMaintAction
RunITAction1
RunPvxTester
RunUtil
RunUtilProxy
SageCopyrightPropertyResolver
SearchGotoAction
ServerSocketThread
SingleWinViewGuiMngr
SizeAnimationGlassPane
SortListener
SpacerFieldEditor
A field editor for adding space to a preference page.
SpawnUtil
StopWatch
StyleWarning
SwingProgressMonitorWrappper
TemplateEditorUI
The main plugin class to be used in the desktop.
TemplateMessages
TemplatesPreferencePage
TextHover
ToggleBreakpointAction
Action to toggle a breakpoint
ToggleNatureAction
ToolsEditorAction
UE_SearchAction
UIManager
Provides an Interface to the Eclipse GUI for ProvideX programs
UIManager
Provides an Interface to the Eclipse GUI for ProvideX programs
UiPrefManager
UITexts
provides internationalized String messages for the UI.
UITexts
provides internationalized String messages for the UI.
UserDefinedPrefPage
UserDefinedPropField
UserDefinedSortedField
UserPrefElement
UtilCommands
VersionControlIdPropertyResolver
WarningResolutionGenerator
WinDefine
WindowStateBlock
WindXLaunchConfigurationDelegate1
WindXLaunchConfigurationTabGroup
WizardNewProjectPasswordPage
WizardPasswordImportPage1
Page 1 of the base preference import Wizard
WizardPasswordPage
Base class for preference export/import pages.
XEditorMatchingStrategy
XMLConfiguration2
XMLDoubleClickStrategy


All Packages

  • Class
  • Use
  • Tree
  • Index
  • Help

All Packages

Package Summary
Package
Description
com.pvx.ooadide
com.pvx.ooadide.actions
com.pvx.ooadide.builder
com.pvx.ooadide.codehilite2
com.pvx.ooadide.dialogs
com.pvx.ooadide.editors
com.pvx.ooadide.editors.autoindent
com.pvx.ooadide.editors.codefolding
com.pvx.ooadide.editors.extkeyword
com.pvx.ooadide.editors.templates
com.pvx.ooadide.eventmanager
com.pvx.ooadide.handlers
com.pvx.ooadide.launchers
com.pvx.ooadide.launchers.debug
com.pvx.ooadide.launchers.debug.breakpoints
com.pvx.ooadide.launchers.debug.communication
com.pvx.ooadide.launchers.debug.launching
com.pvx.ooadide.launchers.debug.model
com.pvx.ooadide.launchers.thinclients
com.pvx.ooadide.launchers.thinclients.javx
com.pvx.ooadide.navigator
com.pvx.ooadide.navigator.filters
com.pvx.ooadide.popup.actions
com.pvx.ooadide.preferences
com.pvx.ooadide.preferences.nomads
com.pvx.ooadide.properties
com.pvx.ooadide.properties.dialogs
com.pvx.ooadide.properties.refactoring.core
com.pvx.ooadide.properties.refactoring.tagresolver
com.pvx.ooadide.properties.refactoring.ui
com.pvx.ooadide.properties.refactoring.ui.wizards
com.pvx.ooadide.properties.userdefined
com.pvx.ooadide.refactor
com.pvx.ooadide.uesearch
com.pvx.ooadide.ui
com.pvx.ooadide.util
com.pvx.ooadide.views
com.pvx.ooadide.views.comparators
com.pvx.ooadide.views.nomads
com.pvx.ooadide.wizards
com.pvx.ooadide.wizards.programs
com.sage.rcp
com.sage.rcp.eventmanager
com.sage.rcp.javx
com.sage.rcp.javx.windows
com.sage.rcp.preferences
com.sage.rcp.resizeanimation
com.sage.rcp.util
com.sage.rcp.views


Constant Field Values

  • Index
  • Help

Constant Field Values

Contents

  • com.pvx.*
  • com.sage.*

com.pvx.*

  • com.pvx.ooadide.ConsoleDisplayManager
    Modifier and Type
    Constant Field
    Value
    public static final String
    ID
    "com.pvx.ooadide.ConsoleDisplayManager"
    public static final int
    MSG_ERROR
    2
    public static final int
    MSG_ERROR_DESC
    4
    public static final int
    MSG_INFORMATION
    1
    public static final int
    MSG_WARNING
    3
  • com.pvx.ooadide.Constants
    Modifier and Type
    Constant Field
    Value
    public static final String
    ATTR_CLIENT_APPSERVER
    "ATTR_APPSERVER"
    public static final String
    ATTR_CLIENT_DEFAULTHOST
    "ATTR_DEFAULT_HOST"
    public static final String
    ATTR_CLIENT_EMBED_ONAPPLET
    "ATTR_EMBED_ONAPPLET"
    public static final String
    ATTR_CLIENT_FORCE_LOGIN
    "ATTR_CLIENT_FORCE_LOGIN"
    public static final String
    ATTR_CLIENT_HOST_ADDR
    "ATTR_HOST_ADDR"
    public static final String
    ATTR_CLIENT_HOST_PORT
    "ATTR_HOST_PORT"
    public static final String
    ATTR_CLIENT_SSL
    "ATTR_CLIENT_SSL"
    public static final String
    ATTR_DEBUG_CLIENT
    "ATTR_DEBUG_CLIENT"
    public static final String
    ATTR_DEBUG_HOST
    "ATTR_DEBUG_HOST"
    public static final String
    ATTR_LAUNCHER_PVX_EXE
    "ATTR_LAUNCHER_PVX_EXE"
    public static final String
    ATTR_LAUNCHER_WORKING_DIR
    "ATTR_LAUNCHER_WORKING_DIR"
    public static final String
    ATTR_PROGRAM_ARGS
    "ATTR_PROGRAM_ARGS"
    public static final String
    ATTR_PROGRAM_INI_FILE
    "ATTR_PROGRAM_INI_FILE"
    public static final String
    ATTR_PROGRAM_INI_FILE_DEFAULT_VALUE
    "[Project Default]"
    public static final String
    ATTR_PROGRAM_NAME
    "ATTR_PROGRAM_NAME"
    public static final String
    ATTR_PROJECT_NAME
    "ATTR_PROJECT_NAME"
    public static final String
    ATTR_WINDOW_STATE
    "ATTR_WINDOW_STATE"
    public static final String
    ID_PVX_DEBUG_MODEL
    "com.pvx.ooadide.debug.pvx"
    public static final String
    JavXAppletName
    "NetworkClientApplet"
  • com.pvx.ooadide.ProvideXOOADPlugin
    Modifier and Type
    Constant Field
    Value
    public static final String
    ID
    "com.pvx.ooadide"
  • com.pvx.ooadide.builder.ProvideXBuilder
    Modifier and Type
    Constant Field
    Value
    public static final String
    BUILDER_ID
    "com.pvx.ooadide.provideXBuilder"
    public static final String
    BUILDLOG_NAME
    "buildlog.txt"
    public static final String
    ERROR_SCAN_PROGRAM
    "ErrorScan.pvx"
    public static final String
    PVX_1FILE_COMPLR_PROGRAM
    "ide_events.pvx;call_build"
    public static final String
    PVX_CONTEXTMNU_BUILD
    "PVX_CONTEXTMNU_BUILD"
    public static final String
    PVXDATAFILE_SCAN_PROGRAM
    "Ecufi.pvs"
    public static final String
    STYLELOG_NAME
    "stylelog.txt"
  • com.pvx.ooadide.builder.ProvideXNature
    Modifier and Type
    Constant Field
    Value
    public static final String
    NATURE_ID
    "com.pvx.ooadide.provideXNature"
  • com.pvx.ooadide.builder.PvxProblem
    Modifier and Type
    Constant Field
    Value
    public static final String
    PVXCORRECTION
    "pvxcorrection"
    public static final String
    PVXCORRECTION_ACTION
    "pvxcorrectionaction"
  • com.pvx.ooadide.dialogs.PvxElementListSelectionDialog
    Modifier and Type
    Constant Field
    Value
    public static final int
    CONFIG_BTN_ID
    1000
  • com.pvx.ooadide.editors.MyCompletionProcessor
    Modifier and Type
    Constant Field
    Value
    public static final String
    DIRECTIVES_PROPERTIES_FILE
    "directives.properties"
    public static final String
    FORMAT_KEY
    "Format:"
    public static final String
    KEYWORDSCATS_PROPERTIES_FILE
    "keywordcats.properties"
    public static final String
    MNEMONICS_PROPERTIES_FILE
    "mnemonics.properties"
    public static final String
    SYSFUNCTION_PROPERTIES_FILE
    "sysfuncs.properties"
    public static final String
    SYSVARIABLES_PROPERTIES_FILE
    "sysvars.properties"
  • com.pvx.ooadide.editors.NomadsEditor
    Modifier and Type
    Constant Field
    Value
    public static final String
    ID
    "com.pvx.ooadide.editors.NomadsEditor"
  • com.pvx.ooadide.editors.PvxEditor
    Modifier and Type
    Constant Field
    Value
    public static final String
    ID
    "com.pvx.ooadide.editors.PvxEditor"
  • com.pvx.ooadide.editors.templates.PVXContextType
    Modifier and Type
    Constant Field
    Value
    public static final String
    PVX_CONTEXT_TYPE
    "com.pvx.ooadide.editors.templates.pvx"
  • com.pvx.ooadide.eventmanager.EventManager
    Modifier and Type
    Constant Field
    Value
    public static final String
    ADDING_RESOURCES_TO_SRC
    "ADDING_RESOURCES_TO_SRC"
    public static final String
    APPLY_IT_FORMAT
    "APPLY_IT_FORMAT"
    public static final String
    BUILDER_EXE
    "BUILDER_EXE"
    public static final String
    BUILDTYPE_STRIPLINES_PREP
    "BUILDTYPE_STRIPLINES_PREP"
    public static final String
    ECLIPSE_SHUTDOWN
    "ECLIPSE_SHUTDOWN"
    public static final String
    EVENT_FIRED
    "EVENT_FIRED"
    public static final String
    EVENT_LISTNR
    "EVENT_LISTNR"
    public static final String
    EXPORT
    "EXPORT"
    public static final String
    EXT_EVENT
    "EXT_EVENT"
    public static final String
    FULL_BUILD
    "FULL_BUILD"
    public static final String
    FULL_BUILD_ALT_EXE
    "FULL_BUILD_ALT_EXE"
    public static final String
    FULL_BUILD_END
    "FULL_BUILD_END"
    public static final String
    FULL_BUILD_START
    "FULL_BUILD_START"
    public static final String
    GENERIC_ACTION
    "GENERIC_ACTION"
    public static final String
    HOST_IS_READY
    "HOST_IS_READY"
    public static final String
    IMPORT
    "IMPORT"
    public static final String
    IMPORT_EXPORT_FILE
    "IMPORT_EXPORT_FILE"
    public static final String
    IMPORT_EXPORT_PROPERTIES
    "IMPORT_EXPORT_PROPERTIES"
    public static final String
    IMPORTING_END
    "IMPORTING_END"
    public static final String
    IMPORTING_START
    "IMPORTING_START"
    public static final String
    INCREMENTAL_BUILD
    "INCREMENTAL_BUILD"
    public static final String
    INCREMENTAL_BUILD_ALT_EXE
    "INCREMENTAL_BUILD_ALT_EXE"
    public static final String
    INVALID
    "INVALID"
    public static final String
    IOLIST_SCAN
    "IOLIST_SCAN"
    public static final String
    LIB_SCAN
    "LIB_SCAN"
    public static final String
    LOAD
    "LOAD"
    public static final String
    NAME
    "NAME"
    public static final String
    NOMADS_BLOCKING
    "NOMADS_BLOCKING"
    public static final String
    NOMADS_NON_BLOCKING
    "NOMADS_NON_BLOCKING"
    public static final String
    OPERATION_CANCEL
    "OPERATION_CANCEL"
    public static final String
    OPERATION_ERROR
    "OPERATION_ERROR"
    public static final String
    OPERATION_REDO
    "OPERATION_REDO"
    public static final String
    OPERATION_SUCCESS
    "OPERATION_SUCCESS"
    public static final String
    PASSWORD
    "PASSWORD"
    public static final String
    PATH
    "PATH"
    public static final String
    PREFERENCE_CHANGE
    "PREFERENCE_CHANGE"
    public static final String
    PREFERENCE_NEW_VALUE
    "PREFERENCE_NEW_VALUE"
    public static final String
    PREFERENCE_OLD_VALUE
    "PREFERENCE_OLD_VALUE"
    public static final String
    PREFERENCE_PAGE_BUTTON
    "PREFERENCE_PAGE_BUTTON"
    public static final String
    PREFERENCE_PAGE_ID
    "PREFERENCE_PAGE_ID"
    public static final String
    PREFERENCE_PROPERTY
    "PREFERENCE_PROPERTY"
    public static final String
    PROJECT_INI_FILE
    "PROJECT_INI_FILE"
    public static final String
    PROJECT_LIST
    "PROJECT_LIST"
    public static final String
    PROJECT_LOCATION
    "PROJECT_LOCATION"
    public static final String
    PROJECT_MEMBER_COUNT
    "PROJECT_MEMBER_COUNT"
    public static final String
    PROJECT_NAME
    "PROJECT_NAME"
    public static final String
    PROP_HIDDEN_ROOT_FOLDER
    "_ProjectRootFolder"
    public static final String
    PROP_PROJECT_FORCE_FOLDERS
    "_ProjectForceFolders"
    public static final String
    REMOVE
    "REMOVE"
    public static final String
    REMOVED_RESOURCE_FROM_SRC
    "REMOVED_RESOURCE_FROM_SRC"
    public static final String
    REQUEST_SOCKET
    "REQUEST_SOCKET"
    public static final String
    RESOURCE_LIST
    "RESOURCE_PROPERTIES_CHANGED"
    public static final String
    RESOURCE_PROPERTIES_CHANGED
    "RESOURCE_PROPERTIES_CHANGED"
    public static final String
    RUN_CONSOLE
    "RUN_CONSOLE"
    public static final String
    RUN_DESIGNER
    "RUN_DESIGNER"
    public static final String
    RUN_DICT_DATA_CLASS
    "RUN_DICT_DATA_CLASS"
    public static final String
    RUN_DICTMAINT
    "RUN_DICTMAINT"
    public static final String
    RUN_HOST
    "RUN_HOST"
    public static final String
    RUN_IT
    "RUN_IT"
    public static final String
    RUN_NOMADS
    "RUN_NOMADS"
    public static final String
    RUN_TEST_PANEL
    "RUN_TEST_PANEL"
    public static final String
    SELECTED_VIEW
    "SELECTED_VIEW"
    public static final String
    STRIP_LINE_NO
    "STRIP_LINE_NO"
    public static final String
    VALID
    "VALID"
    public static final String
    VALIDATE
    "VALIDATE"
  • com.pvx.ooadide.launchers.debug.model.PVXDebugTarget
    Modifier and Type
    Constant Field
    Value
    public static final String
    CHARSET
    "ISO-8859-1"
  • com.pvx.ooadide.launchers.debug.model.PVXVariable
    Modifier and Type
    Constant Field
    Value
    public static final String
    TYPE_NUMERIC
    "Numeric"
    public static final String
    TYPE_STRING
    "String"
  • com.pvx.ooadide.launchers.thinclients.javx.JavXAppletArgumentsTab
    Modifier and Type
    Constant Field
    Value
    public static final String
    JAVX_NAME
    "NetworkClientApplet"
  • com.pvx.ooadide.navigator.ProjectExplorer
    Modifier and Type
    Constant Field
    Value
    public static final String
    ID
    "com.pvx.ooadide.navigator.ProjectExplorer"
  • com.pvx.ooadide.preferences.BuilderOptions
    Modifier and Type
    Constant Field
    Value
    public static final String
    ID
    "com.pvx.ooadide.BuilderOptions"
  • com.pvx.ooadide.preferences.EditorOptionsPrefPage
    Modifier and Type
    Constant Field
    Value
    public static final String
    ID
    "com.pvx.ooadide.EditorOptions"
  • com.pvx.ooadide.preferences.ImportOptionsPrefPage
    Modifier and Type
    Constant Field
    Value
    public static final String
    ID
    "com.pvx.ooadide.preferencepages.importconvert"
  • com.pvx.ooadide.preferences.ObserversPreferencePage
    Modifier and Type
    Constant Field
    Value
    public static final String
    ID
    "com.pvx.ooadide.preferences.observers"
  • com.pvx.ooadide.preferences.PreferenceConstants
    Modifier and Type
    Constant Field
    Value
    public static final String
    _BACKCOLOR
    "_BACKCOLOR"
    public static final String
    _BOLD
    "_BOLD"
    public static final String
    _COLOR
    "_COLOR"
    public static final String
    _IS_SET
    "_IS_SET"
    public static final String
    _ITALIC
    "_ITALIC"
    public static final String
    _STRIKETHROUGH
    "_STRIKETHROUGH"
    public static final String
    _UNDERLINE
    "_UNDERLINE"
    public static final String
    BUILD_PROPERTY_FILE_NAME
    "BuildArguments.properties"
    public static final String
    BUILD_PROPERTY_FILE_PATH
    "BuildFilePath"
    public static final String
    BUILDTYPE_ALL
    "BUILDALL"
    public static final String
    BUILDTYPE_BUILDONE
    "BUILDONE"
    public static final String
    BUILDTYPE_CONVERT
    "CONVERT"
    public static final String
    BUILDTYPE_DATAFILE
    "DATAFILE"
    public static final String
    BUILDTYPE_NOMADSLIB
    "BUILDTYPE_NOMADSLIB"
    public static final String
    BUILDTYPE_OTHERFILE
    "BUILDTYPE_OTHERFILE"
    public static final String
    BUILDTYPE_SKIPFILE
    "BUILDTYPE_SKIPFILE"
    public static final String
    BUILDTYPE_SOURCE_FORMAT
    "SOURCEFORMAT"
    public static final String
    IS_ADD_EXT_TO_ALL
    "IS_ADD_EXT_TO_ALL"
    public static final String
    P_BOOLEAN
    "booleanPreference"
    public static final String
    P_BUILD_DATAFILES
    "P_BUILD_DATAFILES"
    public static final String
    P_BUILD_FILES_NO_EXT
    "P_BUILD_FILES_NO_EXT"
    public static final String
    P_BUILD_RESOURCES
    "P_BUILD_RESOURCES"
    public static final String
    P_CHOICE
    "choicePreference"
    public static final String
    P_CODECHECKER
    "stringPreference"
    public static final String
    P_DEBUG_PVX_MODE
    "P_DEBUG_PVX_MODE"
    public static final String
    P_DOSTYLECHECK
    "booleanPreference"
    public static final String
    P_EDITOR_CODE_FOLDING
    "CODE_FOLDING"
    public static final String
    P_EDITOR_COMMENT_LABEL
    "Comments"
    public static final String
    P_EDITOR_COMMENTS_BACKCOLOR
    "commentsBackColor"
    public static final String
    P_EDITOR_COMMENTS_BOLD
    "commentsBold"
    public static final String
    P_EDITOR_COMMENTS_COLOR
    "commentsColor"
    public static final String
    P_EDITOR_COMMENTS_ITALIC
    "commentsItalic"
    public static final String
    P_EDITOR_COMMENTS_STRIKETHROUGH
    "commentsStrike"
    public static final String
    P_EDITOR_COMMENTS_UNDERLINE
    "commentsUnderline"
    public static final String
    P_EDITOR_DIRECTIVE_LABEL
    "Directives"
    public static final String
    P_EDITOR_DIRECTIVES_BACKCOLOR
    "directiveBackColor"
    public static final String
    P_EDITOR_DIRECTIVES_BOLD
    "directiveBold"
    public static final String
    P_EDITOR_DIRECTIVES_COLOR
    "directiveColor"
    public static final String
    P_EDITOR_DIRECTIVES_ITALIC
    "directiveItalic"
    public static final String
    P_EDITOR_DIRECTIVES_STRIKETHROUGH
    "directiveStrike"
    public static final String
    P_EDITOR_DIRECTIVES_UNDERLINE
    "directivesUnderline"
    public static final String
    P_EDITOR_LINELABEL_LABEL
    "Line Labels"
    public static final String
    P_EDITOR_LINELABELS_BACKCOLOR
    "lineLabelsBackColor"
    public static final String
    P_EDITOR_LINELABELS_BOLD
    "lineLabelsBold"
    public static final String
    P_EDITOR_LINELABELS_COLOR
    "lineLabelsColor"
    public static final String
    P_EDITOR_LINELABELS_ITALIC
    "lineLabelsItalic"
    public static final String
    P_EDITOR_LINELABELS_STRIKETHROUGH
    "lineLablesStrike"
    public static final String
    P_EDITOR_LINELABELS_UNDERLINE
    "lineLabelsUnderline"
    public static final String
    P_EDITOR_LITERALS_BACKCOLOR
    "literalsBackColor"
    public static final String
    P_EDITOR_LITERALS_BOLD
    "literalsBold"
    public static final String
    P_EDITOR_LITERALS_COLOR
    "literalsColor"
    public static final String
    P_EDITOR_LITERALS_ITALIC
    "literalsItalic"
    public static final String
    P_EDITOR_LITERALS_LABEL
    "Literals"
    public static final String
    P_EDITOR_LITERALS_STRIKETHROUGH
    "literalsStrike"
    public static final String
    P_EDITOR_LITERALS_UNDERLINE
    "literalsUnderline"
    public static final String
    P_EDITOR_MNEMONICS_BACKCOLOR
    "mnemonicsBackColor"
    public static final String
    P_EDITOR_MNEMONICS_BOLD
    "mnemonicsBold"
    public static final String
    P_EDITOR_MNEMONICS_COLOR
    "mnemonicsColor"
    public static final String
    P_EDITOR_MNEMONICS_ITALIC
    "mnemonicsItalic"
    public static final String
    P_EDITOR_MNEMONICS_LABEL
    "Mnemonics"
    public static final String
    P_EDITOR_MNEMONICS_STRIKETHROUGH
    "mnemonicsStrike"
    public static final String
    P_EDITOR_MNEMONICS_UNDERLINE
    "menmonicsUnderline"
    public static final String
    P_EDITOR_OPERATORS_BACKCOLOR
    "operatorsBackColor"
    public static final String
    P_EDITOR_OPERATORS_BOLD
    "operatorsBold"
    public static final String
    P_EDITOR_OPERATORS_COLOR
    "operatorsColor"
    public static final String
    P_EDITOR_OPERATORS_ITALIC
    "operatorsItalic"
    public static final String
    P_EDITOR_OPERATORS_LABEL
    "Operators"
    public static final String
    P_EDITOR_OPERATORS_STRIKETHROUGH
    "operatorsStrike"
    public static final String
    P_EDITOR_OPERATORS_UNDERLINE
    "operatorsUnderline"
    public static final String
    P_EDITOR_SMART_BRACES
    "SMART_BRACES"
    public static final String
    P_EDITOR_SMART_INDENT
    "SMART_INDENT"
    public static final String
    P_EDITOR_SMART_PASTE
    "SMART_PASTE"
    public static final String
    P_EDITOR_SYSFUNCTIONS_BACKCOLOR
    "systemFunctionsBackColor"
    public static final String
    P_EDITOR_SYSFUNCTIONS_BOLD
    "systemFunctionsBold"
    public static final String
    P_EDITOR_SYSFUNCTIONS_COLOR
    "systemFunctionsColor"
    public static final String
    P_EDITOR_SYSFUNCTIONS_ITALIC
    "systemFunctionsItalic"
    public static final String
    P_EDITOR_SYSFUNCTIONS_STRIKETHROUGH
    "systemFunctionsStrike"
    public static final String
    P_EDITOR_SYSFUNCTIONS_UNDERLINE
    "systemFunctionsUnderline"
    public static final String
    P_EDITOR_SYSTEM_FUNCTIONS_LABEL
    "System Functions"
    public static final String
    P_EDITOR_SYSTEM_VARIABLES_LABEL
    "System Variables"
    public static final String
    P_EDITOR_SYSVARIABLES_BACKCOLOR
    "systemVariablesBackColor"
    public static final String
    P_EDITOR_SYSVARIABLES_BOLD
    "systemVariablesBold"
    public static final String
    P_EDITOR_SYSVARIABLES_COLOR
    "systemVariablesColor"
    public static final String
    P_EDITOR_SYSVARIABLES_ITALIC
    "systemVariablesItalic"
    public static final String
    P_EDITOR_SYSVARIABLES_STRIKETHROUGH
    "systemVariablesStrikeThrough"
    public static final String
    P_EDITOR_SYSVARIABLES_UNDERLINE
    "systemVariablesUnderline"
    public static final String
    P_EVENT_SOURCEFILE
    "P_EVENT_SOURCEFILE"
    public static final String
    P_IMPORT_SRCFILE_EXTENSION
    "P_IMPORT_SRCFILE_EXTENSION"
    public static final String
    P_IMPORT_STRIP_LINE_LABEL_PREFIX
    "P_IMPORT_STRIP_LINE_LABEL_PREFIX"
    public static final String
    P_IMPORT_STRIP_LINE_NO
    "P_IMPORT_STRIP_LINE_NO"
    public static final String
    P_IMPORT_STRIP_LINE_USE_ORIG_NO
    "P_IMPORT_STRIP_LINE_USE_ORIG_NO"
    public static final String
    P_ISCHECKING_FILE_EXTIONS
    "isFileExtesionCheck"
    public static final String
    P_ISLINE_NUMBS_REQUIRED
    "isLineNumbersRequiredPreference"
    public static final String
    P_ISPVXDATA
    "isPvxDataPreference"
    public static final String
    P_ISRESOURCE
    "isResourcePreference"
    public static final String
    P_OUTPUT_FILE_NAME
    "P_OUTPUT_FILE_NAME"
    public static final String
    P_OWNERCODE
    "ownerCodePreference"
    public static final String
    P_OWNERCODEFLAGS
    "ownerFlagsPreference"
    public static final String
    P_PASSWORD
    "passwordPreference"
    public static final String
    P_PATH
    "pathPreference"
    public static final String
    P_PROGRAM_CONVERT
    "forceConvertOfProgram"
    public static final String
    P_PROJECT_OUTPUT_DIRECTORY
    "P_PROJECT_OUTPUT_DIRECTORY"
    public static final String
    P_PROJECT_OUTPUT_LINK_DIRECTORY
    "P_PROJECT_OUTPUT_LINK_DIRECTORY"
    public static final String
    P_PROJECT_SRC_DIRECTORY
    "P_PROJECT_SRC_DIRECTORY"
    public static final String
    P_PROJECT_SRC_LINK_DIRECTORY
    "P_PROJECT_SRC_LINK_DIRECTORY"
    public static final String
    P_STRING
    "stringPreference"
    public static final String
    P_TESTFOLDER_LIST
    "P_TESTFOLDER_LIST"
    public static final String
    P_XML_EXPORT
    "P_XML_EXPORT"
    public static final String
    PLUGIN_VERSION
    "PLUGIN_VERSION"
    public static final String
    PROPERTY_FILE_KEY_BUILDLOG
    "Buildlog"
    public static final String
    PROPERTY_FILE_KEY_BUILDTYPE
    "BUILDTYPE"
    public static final String
    PROPERTY_FILE_KEY_DEST
    "Destination"
    public static final String
    PROPERTY_FILE_KEY_DOMFILE
    "DomDir"
    public static final String
    PROPERTY_FILE_KEY_ERRORSCANNER
    "ERRORSCANPRG"
    public static final String
    PROPERTY_FILE_KEY_FLAGS
    "FLAGS"
    public static final String
    PROPERTY_FILE_KEY_LOCKFILE
    "LockFile"
    public static final String
    PROPERTY_FILE_KEY_OWNERCODE
    "OWNER"
    public static final String
    PROPERTY_FILE_KEY_PASSWORD
    "PROPERTY_FILE_KEY_PASSWORD"
    public static final String
    PROPERTY_FILE_KEY_SRCFILE
    "SourceFile"
    public static final String
    PROPERTY_NOT_SET
    "PROPERTY_NOT_SET"
    public static final String
    STYLE_BOLD
    "BOLD"
    public static final String
    STYLE_ITALIC
    "ITALIC"
    public static final String
    STYLE_NONE
    "NONE"
    public static final String
    U_NOMADS_ALTEXE
    "_NOMADS_AltExe"
    public static final String
    U_NOMADS_ALTINI
    "_NOMADS_AltIni"
    public static final String
    U_NOMADS_EXTIMAGEDIR
    "_NOMADS_ExtImageDir"
  • com.pvx.ooadide.preferences.ProvideXPreferencePage
    Modifier and Type
    Constant Field
    Value
    public static final String
    ID
    "com.pvx.ooadide.preferences.ProvideXPreferencePage"
  • com.pvx.ooadide.preferences.UserDefinedPrefPage
    Modifier and Type
    Constant Field
    Value
    public static final String
    ID
    "com.pvx.ooadide.preferences.userdefined"
  • com.pvx.ooadide.preferences.nomads.NomadsPreferencePage
    Modifier and Type
    Constant Field
    Value
    public static final String
    ID
    "com.pvx.ooadide.preferences.nomads.mainpage"
  • com.pvx.ooadide.properties.ProvideXPropertyPage
    Modifier and Type
    Constant Field
    Value
    public static final String
    LINKED_DELIM
    "="
    public static final String
    P_USER_FILE
    "FILE"
    public static final String
    P_USER_FOLDER
    "FOLDER"
    public static final String
    P_USER_NOMADSLIBS
    "NOMADSLIBS"
    public static final String
    P_USER_PROGRAMS
    "PROGRAMS"
    public static final String
    P_USER_PROJECT
    "PROJECT"
    public static final String
    P_USER_RESOURCE
    "RESOURCE"
    public static final String
    QUALIFIED_ID
    "com.pvx.ooadide"
  • com.pvx.ooadide.properties.refactoring.tagresolver.PvxtagResolver
    Modifier and Type
    Constant Field
    Value
    public static final String
    PRIVATE_TAG_FLAGS
    "! *- @FLAGS"
    public static final String
    PRIVATE_TAG_FORCELINE_NO
    "! *- @FORCELINENUMBERS"
    public static final String
    PRIVATE_TAG_OUTPUT
    "! *- @OUTPUTFILE"
    public static final String
    PRIVATE_TAG_OWNER
    "! *- @OWNER"
    public static final String
    PRIVATE_TAG_PASSWORD
    "! *- @PASSWORD"
    public static final String
    TAG_FLAGS
    "! ** @FLAGS"
    public static final String
    TAG_FORCELINE_NO
    "! ** @FORCELINENUMBERS"
    public static final String
    TAG_OUTPUT
    "! ** @OUTPUTFILE"
    public static final String
    TAG_OWNER
    "! ** @OWNER"
    public static final String
    TAG_PASSWORD
    "! ** @PASSWORD"
  • com.pvx.ooadide.refactor.BlockCommentAction
    Modifier and Type
    Constant Field
    Value
    public static final String
    REM_BANG
    "! "
  • com.pvx.ooadide.refactor.RenamePropertyInfo
    Modifier and Type
    Constant Field
    Value
    public static final int
    TYPE_BLOCK_REM
    2
    public static final int
    TYPE_PROPERTY_RENAME
    1
    public static final int
    TYPE_REPLACE
    4
    public static final int
    TYPE_STRIP_NUMBERS
    3
  • com.pvx.ooadide.ui.PvxPluginImages
    Modifier and Type
    Constant Field
    Value
    public static final String
    IMG_OUTLINE_FILTER_NONE
    "Filter_None.png"
    public static final String
    IMG_OUTLINE_SETTINGS
    "Settings.png"
    public static final String
    IMG_OUTLINE_SORTBY_GROUP
    "SortBy_Group.png"
    public static final String
    IMG_OUTLINE_SORTBY_LINENUM
    "SortBy_LineNumber.png"
    public static final String
    IMG_OUTLINE_SORTBY_RESET
    "SortBy_Reset.png"
  • com.pvx.ooadide.util.ProjectUtils
    Modifier and Type
    Constant Field
    Value
    public static final String
    NOMADS_XML_EXPORT
    "NOMADS_xml_export"
    public static final String
    P_COMMON_RESOURCE_FILE_EXTENSIONS
    "_CommonResourceFileExtensions"
  • com.pvx.ooadide.util.PvxElement
    Modifier and Type
    Constant Field
    Value
    public static final int
    ATTRIB_TYPE
    1
    public static final char
    ATTRIB_TYPE_SYMBOL
    '\''
    public static final String
    DOM_INFO_BLOCK_HEADER
    "[DOM_INFO]"
    public static final String
    FILE_INFO_BLOCK_HEADER
    "[FILE_INFO]"
    public static final int
    FUNCTION_TYPE
    3
    public static final char
    FUNCTION_TYPE_SYMBOL
    '\''
    public static final char
    LOCAL_SYMBOL
    '@'
    public static final int
    LOCAL_TYPE
    2
    public static final int
    NOICON_TYPE
    6
    public static final char
    NON_OBJ_FUNCTION_SYMBOL
    '.'
    public static final int
    NON_OBJ_FUNCTION_TYPE
    7
    public static final int
    PRIVATE_FUNCTION
    4
    public static final char
    PRIVATE_FUNCTION_SYMBOL
    '@'
    public static final int
    PVXDATA_TYPE
    5
    public static final int
    PVXOBJ_PROP
    8
    public static final char
    PVXOBJ_PROP_SYMBOL
    '>'
    public static final int
    RTN_TYPE
    9
    public static final int
    VARIABLE_TYPE
    10
    public static final char
    VARIABLE_TYPE_SYMBOL
    '='
  • com.pvx.ooadide.util.PvxFileUtils
    Modifier and Type
    Constant Field
    Value
    public static final int
    IS_BINARY
    4
    public static final int
    IS_TEXT
    0
    public static final int
    PVX_DATA
    2
    public static final int
    PVX_OTHER
    3
    public static final int
    PVX_PROGRAM
    1
  • com.pvx.ooadide.util.PvxUtil
    Modifier and Type
    Constant Field
    Value
    public static final String
    BOOLEAN
    "BOOLEAN"
    public static final int
    BOOLEAN_DATA
    2
    public static final String
    DIRECTORY
    "DIRECTORY"
    public static final int
    DIRECTORY_DATA
    3
    public static final String
    FILE
    "FILE"
    public static final int
    FILE_DATA
    4
    public static final String
    LIST
    "LIST"
    public static final int
    LIST_DATA
    5
    public static final int
    OS_APPLE_OSX
    4
    public static final int
    OS_LINUX
    2
    public static final int
    OS_UNIX
    3
    public static final int
    OS_WINDOWS
    1
    public static final String
    PVX_LABEL_SEP
    "<%3B>"
    public static final String
    RADIOGROUP
    "RADIOGROUP"
    public static final int
    RADIOGROUP_DATA
    6
    public static final String
    STRING
    "STRING"
    public static final int
    STRING_DATA
    1
    public static final int
    TRACE_TO_ERRORLOG
    2
    public static final int
    TRACE_TO_STANDARDOUT
    1
  • com.pvx.ooadide.views.AbstractProgressController
    Modifier and Type
    Constant Field
    Value
    public static final int
    P_ALL
    -1
    public static final int
    P_SUB_TASKNAME
    1
    public static final int
    P_TASKNAME
    0
    public static final int
    P_VISIBLE
    2
    public static final int
    P_WORKED
    3
  • com.pvx.ooadide.views.IOListView
    Modifier and Type
    Constant Field
    Value
    public static final int
    DICT_ALT_NME
    6
    public static final int
    DICT_DESCR
    2
    public static final int
    DICT_ENTRY
    0
    public static final int
    DICT_FMT_MASK
    4
    public static final int
    DICT_LEN
    5
    public static final int
    DICT_NME
    1
    public static final int
    DICT_TYPE
    3
    public static final String
    ID
    "com.pvx.ooadide.views.iolistview"
    public static final String
    IOLOG_NAME
    "iolog.txt"
    public static final int
    numbObjElemnts
    8
    public static final int
    REQ_EXT
    7
  • com.pvx.ooadide.views.PvcOutline
    Modifier and Type
    Constant Field
    Value
    public static final String
    ID
    "com.pvx.ooadide.pvcoutline"
  • com.pvx.ooadide.views.WinDefine
    Modifier and Type
    Constant Field
    Value
    public static final String
    ID
    "com.pvx.ooadide.windefine"
  • com.pvx.ooadide.views.nomads.LibView
    Modifier and Type
    Constant Field
    Value
    public static final String
    CHARSET
    "ISO-8859-1"
    public static final String
    ID
    "com.pvx.ooadide.nomadslibview"
    public static final String
    LIBLOG_NAME
    "liblog.txt"
    public static final String
    NOMADS_systemDefaults
    "NOMADS_systemDefaults"
    public static final String
    sep
    "\u008a"
    public static final String
    WINDEFINE_PROGRAM
    "NOMADS_designer"
    public static final String
    WINTEST_PROGRAM
    "NOMADS_test"
  • com.pvx.ooadide.views.nomads.PvxLibElement
    Modifier and Type
    Constant Field
    Value
    public static final int
    INIT_TEXT$
    7
    public static final int
    numbObjElemnts
    11
    public static final int
    OBJ_C
    2
    public static final int
    OBJ_H
    5
    public static final int
    OBJ_KEY
    0
    public static final int
    OBJ_L
    3
    public static final int
    OBJ_NME
    1
    public static final int
    OBJ_TYPE$
    6
    public static final int
    OBJ_W
    4
    public static final int
    P_DATE$
    8
    public static final int
    P_TIME$
    9
    public static final int
    P_USERID$
    10
  • com.pvx.ooadide.wizards.NewFromExisting
    Modifier and Type
    Constant Field
    Value
    public static final String
    ID
    "com.pvx.ooadide.createfromexisitingwiz"
  • com.pvx.ooadide.wizards.NewNomadsLibraryWizard
    Modifier and Type
    Constant Field
    Value
    public static final String
    ID
    "com.pvx.ooadide.wizards.nomads.newlibrarywizard"
  • com.pvx.ooadide.wizards.NewNomadsNmdWizard
    Modifier and Type
    Constant Field
    Value
    public static final String
    ID
    "com.pvx.ooadide.wizards.nomads.sysdefaults"
  • com.pvx.ooadide.wizards.NewProjectFromExistingPage
    Modifier and Type
    Constant Field
    Value
    public static final String
    PROJECT_DEF_PVX_EXE
    "Compiler:"
    public static final String
    PROJECT_OWNER
    "Owner:"
    public static final String
    PROJECT_OWNER_FLAGS
    "Flags:"
    public static final String
    PROJECT_PASSWORD
    "Password:"
  • com.pvx.ooadide.wizards.ProvideXNewWizard
    Modifier and Type
    Constant Field
    Value
    public static final String
    ID
    "com.pvx.ooadide.wizards.ProvideXNewWizard"
  • com.pvx.ooadide.wizards.ProvidexNewWizardPage
    Modifier and Type
    Constant Field
    Value
    public static final String
    PROJECT_DEF_PVX_EXE
    "Compiler:"
    public static final String
    PROJECT_OWNER
    "Owner:"
    public static final String
    PROJECT_OWNER_FLAGS
    "Flags:"
    public static final String
    PROJECT_PASSWORD
    "Password:"
  • com.pvx.ooadide.wizards.programs.PvxNewProgramPropertiesWizardPage
    Modifier and Type
    Constant Field
    Value
    public static final String
    PROJECT_DEF_PVX_EXE
    "Compiler:"
    public static final String
    PROJECT_OWNER
    "Owner:"
    public static final String
    PROJECT_OWNER_FLAGS
    "Flags:"
    public static final String
    PROJECT_PASSWORD
    "Password:"

com.sage.*

  • com.sage.rcp.ConsoleDisplayManager
    Modifier and Type
    Constant Field
    Value
    public static final String
    ID
    "com.sage.rcp.ConsoleDisplayManager"
    public static final int
    MSG_ERROR
    2
    public static final int
    MSG_ERROR_DESC
    4
    public static final int
    MSG_INFORMATION
    1
    public static final int
    MSG_WARNING
    3
  • com.sage.rcp.PvxRcpActivator
    Modifier and Type
    Constant Field
    Value
    public static final String
    ID
    "com.sage.rcp"
  • com.sage.rcp.eventmanager.AbstractProgressController
    Modifier and Type
    Constant Field
    Value
    public static final int
    P_ALL
    -1
    public static final int
    P_SUB_TASKNAME
    1
    public static final int
    P_TASKNAME
    0
    public static final int
    P_VISIBLE
    2
    public static final int
    P_WORKED
    3
  • com.sage.rcp.eventmanager.ConsoleDisplayManager
    Modifier and Type
    Constant Field
    Value
    public static final String
    ID
    "com.pvx.ooadide.ConsoleDisplayManager"
    public static final int
    MSG_ERROR
    2
    public static final int
    MSG_ERROR_DESC
    4
    public static final int
    MSG_INFORMATION
    1
    public static final int
    MSG_WARNING
    3
  • com.sage.rcp.eventmanager.EventManager
    Modifier and Type
    Constant Field
    Value
    public static final String
    BROWSER_EVENT
    "BROWSER_EVENT"
    public static final String
    CALL_BACK_MJR
    "1"
    public static final String
    COOLBAR_ACTION
    "COOLBAR_ACTION"
    public static final String
    ECLIPSE_SHUTDOWN
    "ECLIPSE_SHUTDOWN"
    public static final String
    HOST_IS_READY
    "HOST_IS_READY"
    public static final String
    MENUBAR_ACTION
    "MENUBAR_ACTION"
    public static final String
    PVX_PROCESS_EVENT
    "PVX_PROCESS_EVENT"
    public static final String
    ULTRAFX_WINDOW_CLOSE
    "ULTRAFX_WINDOW_CLOSE"
  • com.sage.rcp.preferences.RcpPreferenceConstants
    Modifier and Type
    Constant Field
    Value
    public static final String
    P_5D
    "P_5D"
    public static final String
    P_6D
    "P_6D"
    public static final String
    P_DEBUG
    "P_DEBUG"
    public static final String
    P_GRAPHIC_FONT
    "P_GRAPHIC_FONT"
    public static final String
    P_INTERNAL_DIALOGUES
    "P_EXTERNAL_DIALOGUES"
    public static final String
    P_MAX_WINDOWS
    "P_MAX_WINDOWS"
    public static final String
    P_MINIMUM_FONTSIZE
    "P_MINIMUM_FONTSIZE"
    public static final String
    P_ONLY_SHOW_TOP_WINDOW
    "P_ONLY_SHOW_TOP_WINDOW"
    public static final String
    P_REPORT_VERSION_AS
    "P_REPORT_VERSION_AS"
    public static final String
    P_SAVE_WINDOW_POSITION
    "P_SAVE_WINDOW_POSITION"
    public static final String
    P_SHOW_BORDERS
    "P_SHOW_BORDERS"
    public static final String
    P_TEXTPLANE_FONT
    "P_TEXTPLANE_FONT"
  • com.sage.rcp.preferences.UiPrefManager
    Modifier and Type
    Constant Field
    Value
    public static final int
    FIVE_D
    5
    public static final int
    FOUR_D
    4
    public static final int
    SIX_D
    6
    public static final int
    THREE_D
    3
  • com.sage.rcp.util.PvxUtil
    Modifier and Type
    Constant Field
    Value
    public static final int
    OS_APPLE_OSX
    4
    public static final int
    OS_LINUX
    2
    public static final int
    OS_UNIX
    3
    public static final int
    OS_WINDOWS
    1
  • com.sage.rcp.util.RunUtilProxy
    Modifier and Type
    Constant Field
    Value
    public static final int
    OS_APPLE_OSX
    4
    public static final int
    OS_LINUX
    2
    public static final int
    OS_UNIX
    3
    public static final int
    OS_WINDOWS
    1
  • com.sage.rcp.views.HostActionsView
    Modifier and Type
    Constant Field
    Value
    public static final String
    ID
    "com.sage.rcp.views.hostactionsview"
  • com.sage.rcp.views.RcpEmbedJavXView
    Modifier and Type
    Constant Field
    Value
    public static final int
    DISPLAY_MIN_HEIGHT
    1024
    public static final int
    DISPLAY_MIN_WIDTH
    1280
    public static final String
    ID
    "com.sage.rcp.views.RcpEmbedJavXView"
  • com.sage.rcp.views.RcpMasProgramView
    Modifier and Type
    Constant Field
    Value
    public static final String
    ID
    "com.sage.rcp.views.RcpMasProgramView"
  • com.sage.rcp.views.RcpProgramView
    Modifier and Type
    Constant Field
    Value
    public static final String
    ID
    "com.sage.rcp.views.RcpProgramView"
    public static final String
    JAVX_ARGS_STRING
    "args"
  • com.sage.rcp.views.RcpSpawnedMasProgramView
    Modifier and Type
    Constant Field
    Value
    public static final String
    ID
    "com.sage.rcp.views.RcpSpawnedMasProgramView"


API Help

  • Help:
  • Navigation |
  • Pages

JavaDoc Help

  • Navigation:
    • Search
  • Kinds of Pages:
    • Overview
    • Package
    • Class or Interface
    • Other Files
    • Use
    • Tree (Class Hierarchy)
    • Constant Field Values
    • Serialized Form
    • All Packages
    • All Classes and Interfaces
    • Index

Navigation

Starting from the Overview page, you can browse the documentation using the links in each page, and in the navigation bar at the top of each page. The Index and Search box allow you to navigate to specific declarations and summary pages, including: All Packages, All Classes and Interfaces

Search

You can search for definitions of modules, packages, types, fields, methods, system properties and other terms defined in the API, using some or all of the name, optionally using "camelCase" abbreviations. For example:

  • j.l.obj will match "java.lang.Object"
  • InpStr will match "java.io.InputStream"
  • HM.cK will match "java.util.HashMap.containsKey(Object)"

Refer to the Javadoc Search Specification for a full description of search features.

Kinds of Pages

The following sections describe the different kinds of pages in this collection.

Overview

The Overview page is the front page of this API document and provides a list of all packages with a summary for each. This page can also contain an overall description of the set of packages.

Package

Each package has a page that contains a list of its classes and interfaces, with a summary for each. These pages may contain the following categories:

  • Interfaces
  • Classes
  • Enums
  • Exceptions
  • Errors
  • Annotation Types

Class or Interface

Each class, interface, nested class and nested interface has its own separate page. Each of these pages has three sections consisting of a declaration and description, member summary tables, and detailed member descriptions. Entries in each of these sections are omitted if they are empty or not applicable.

  • Class Inheritance Diagram
  • Direct Subclasses
  • All Known Subinterfaces
  • All Known Implementing Classes
  • Class or Interface Declaration
  • Class or Interface Description

  • Nested Class Summary
  • Enum Constant Summary
  • Field Summary
  • Property Summary
  • Constructor Summary
  • Method Summary
  • Required Element Summary
  • Optional Element Summary

  • Enum Constant Details
  • Field Details
  • Property Details
  • Constructor Details
  • Method Details
  • Element Details

Note: Annotation interfaces have required and optional elements, but not methods. Only enum classes have enum constants. The components of a record class are displayed as part of the declaration of the record class. Properties are a feature of JavaFX.

The summary entries are alphabetical, while the detailed descriptions are in the order they appear in the source code. This preserves the logical groupings established by the programmer.

Other Files

Packages and modules may contain pages with additional information related to the declarations nearby.

Use

Each documented package, class and interface has its own Use page. This page describes what packages, classes, methods, constructors and fields use any part of the given class or package. Given a class or interface A, its Use page includes subclasses of A, fields declared as A, methods that return A, and methods and constructors with parameters of type A. You can access this page by first going to the package, class or interface, then clicking on the USE link in the navigation bar.

Tree (Class Hierarchy)

There is a Class Hierarchy page for all packages, plus a hierarchy for each package. Each hierarchy page contains a list of classes and a list of interfaces. Classes are organized by inheritance structure starting with java.lang.Object. Interfaces do not inherit from java.lang.Object.

  • When viewing the Overview page, clicking on TREE displays the hierarchy for all packages.
  • When viewing a particular package, class or interface page, clicking on TREE displays the hierarchy for only that package.

Constant Field Values

The Constant Field Values page lists the static final fields and their values.

Serialized Form

Each serializable or externalizable class has a description of its serialization fields and methods. This information is of interest to those who implement rather than use the API. While there is no link in the navigation bar, you can get to this information by going to any serialized class and clicking "Serialized Form" in the "See Also" section of the class description.

All Packages

The All Packages page contains an alphabetic index of all packages contained in the documentation.

All Classes and Interfaces

The All Classes and Interfaces page contains an alphabetic index of all classes and interfaces contained in the documentation, including annotation interfaces, enum classes, and record classes.

Index

The Index contains an alphabetic index of all classes, interfaces, constructors, methods, and fields in the documentation, as well as summary pages such as All Packages, All Classes and Interfaces.

This help file applies to API documentation generated by the standard doclet.


Overview

ProvideX Plug-in for Eclipse

Packages
Package
Description
com.pvx.ooadide
com.pvx.ooadide.actions
com.pvx.ooadide.builder
com.pvx.ooadide.codehilite2
com.pvx.ooadide.dialogs
com.pvx.ooadide.editors
com.pvx.ooadide.editors.autoindent
com.pvx.ooadide.editors.codefolding
com.pvx.ooadide.editors.extkeyword
com.pvx.ooadide.editors.templates
com.pvx.ooadide.eventmanager
com.pvx.ooadide.handlers
com.pvx.ooadide.launchers
com.pvx.ooadide.launchers.debug
com.pvx.ooadide.launchers.debug.breakpoints
com.pvx.ooadide.launchers.debug.communication
com.pvx.ooadide.launchers.debug.launching
com.pvx.ooadide.launchers.debug.model
com.pvx.ooadide.launchers.thinclients
com.pvx.ooadide.launchers.thinclients.javx
com.pvx.ooadide.navigator
com.pvx.ooadide.navigator.filters
com.pvx.ooadide.popup.actions
com.pvx.ooadide.preferences
com.pvx.ooadide.preferences.nomads
com.pvx.ooadide.properties
com.pvx.ooadide.properties.dialogs
com.pvx.ooadide.properties.refactoring.core
com.pvx.ooadide.properties.refactoring.tagresolver
com.pvx.ooadide.properties.refactoring.ui
com.pvx.ooadide.properties.refactoring.ui.wizards
com.pvx.ooadide.properties.userdefined
com.pvx.ooadide.refactor
com.pvx.ooadide.uesearch
com.pvx.ooadide.ui
com.pvx.ooadide.util
com.pvx.ooadide.views
com.pvx.ooadide.views.comparators
com.pvx.ooadide.views.nomads
com.pvx.ooadide.wizards
com.pvx.ooadide.wizards.programs
com.sage.rcp
com.sage.rcp.eventmanager
com.sage.rcp.javx
com.sage.rcp.javx.windows
com.sage.rcp.preferences
com.sage.rcp.resizeanimation
com.sage.rcp.util
com.sage.rcp.views


Class Hierarchy

Hierarchy For All Packages

Package Hierarchies:
  • com.pvx.ooadide,
  • com.pvx.ooadide.actions,
  • com.pvx.ooadide.builder,
  • com.pvx.ooadide.codehilite2,
  • com.pvx.ooadide.dialogs,
  • com.pvx.ooadide.editors,
  • com.pvx.ooadide.editors.autoindent,
  • com.pvx.ooadide.editors.codefolding,
  • com.pvx.ooadide.editors.extkeyword,
  • com.pvx.ooadide.editors.templates,
  • com.pvx.ooadide.eventmanager,
  • com.pvx.ooadide.handlers,
  • com.pvx.ooadide.launchers,
  • com.pvx.ooadide.launchers.debug,
  • com.pvx.ooadide.launchers.debug.breakpoints,
  • com.pvx.ooadide.launchers.debug.communication,
  • com.pvx.ooadide.launchers.debug.launching,
  • com.pvx.ooadide.launchers.debug.model,
  • com.pvx.ooadide.launchers.thinclients,
  • com.pvx.ooadide.launchers.thinclients.javx,
  • com.pvx.ooadide.navigator,
  • com.pvx.ooadide.navigator.filters,
  • com.pvx.ooadide.popup.actions,
  • com.pvx.ooadide.preferences,
  • com.pvx.ooadide.preferences.nomads,
  • com.pvx.ooadide.properties,
  • com.pvx.ooadide.properties.dialogs,
  • com.pvx.ooadide.properties.refactoring.core,
  • com.pvx.ooadide.properties.refactoring.tagresolver,
  • com.pvx.ooadide.properties.refactoring.ui,
  • com.pvx.ooadide.properties.refactoring.ui.wizards,
  • com.pvx.ooadide.properties.userdefined,
  • com.pvx.ooadide.refactor,
  • com.pvx.ooadide.uesearch,
  • com.pvx.ooadide.ui,
  • com.pvx.ooadide.util,
  • com.pvx.ooadide.views,
  • com.pvx.ooadide.views.comparators,
  • com.pvx.ooadide.views.nomads,
  • com.pvx.ooadide.wizards,
  • com.pvx.ooadide.wizards.programs,
  • com.sage.rcp,
  • com.sage.rcp.eventmanager,
  • com.sage.rcp.javx,
  • com.sage.rcp.javx.windows,
  • com.sage.rcp.preferences,
  • com.sage.rcp.resizeanimation,
  • com.sage.rcp.util,
  • com.sage.rcp.views

Class Hierarchy

  • java.lang.Object
    • org.eclipse.debug.ui.AbstractLaunchConfigurationTab (implements org.eclipse.debug.ui.ILaunchConfigurationTab2, org.eclipse.debug.core.IPrototypeAttributesLabelProvider)
      • org.eclipse.jdt.debug.ui.launchConfigurations.JavaLaunchTab
        • org.eclipse.jdt.debug.ui.launchConfigurations.JavaArgumentsTab
          • org.eclipse.jdt.debug.ui.launchConfigurations.AppletArgumentsTab
            • com.pvx.ooadide.launchers.thinclients.javx.JavXAppletArgumentsTab
      • com.pvx.ooadide.launchers.ProvideXArgumentsTab
      • com.pvx.ooadide.launchers.ProvideXLaunchConfigurationTab
        • com.pvx.ooadide.launchers.IniFileBlock
      • com.pvx.ooadide.launchers.ProvideXMainTab
      • com.pvx.ooadide.launchers.thinclients.PvxBaseClientConfigTab (implements org.eclipse.jdt.internal.debug.ui.launcher.IEntriesChangedListener)
        • com.pvx.ooadide.launchers.thinclients.ClientTab
      • com.pvx.ooadide.launchers.WindowStateBlock
    • org.eclipse.debug.ui.AbstractLaunchConfigurationTabGroup (implements org.eclipse.debug.ui.ILaunchConfigurationTabGroup)
      • com.pvx.ooadide.launchers.thinclients.javx.JavXAppletTabGroup
      • com.pvx.ooadide.launchers.ProvideXConfigurationTabGroup1
      • com.pvx.ooadide.launchers.thinclients.WindXLaunchConfigurationTabGroup
    • org.eclipse.core.runtime.preferences.AbstractPreferenceInitializer
      • com.pvx.ooadide.preferences.PreferenceInitializer
      • com.sage.rcp.preferences.RcpPreferenceInitializer
    • com.pvx.ooadide.views.AbstractProgressController
      • com.pvx.ooadide.views.PvxRunnableWithProgress (implements org.eclipse.jface.operation.IRunnableWithProgress)
    • com.sage.rcp.eventmanager.AbstractProgressController
      • com.sage.rcp.eventmanager.PvxRunnableWithProgress (implements org.eclipse.jface.operation.IRunnableWithProgress)
    • com.pvx.ooadide.actions.AbstractPvxEditorAction (implements org.eclipse.ui.IEditorActionDelegate)
      • com.pvx.ooadide.actions.RunITAction1
    • org.eclipse.debug.core.sourcelookup.AbstractSourceLookupDirector (implements org.eclipse.debug.core.ILaunchConfigurationListener, org.eclipse.debug.core.ILaunchListener, org.eclipse.debug.core.sourcelookup.ISourceLookupDirector)
      • com.pvx.ooadide.launchers.debug.launching.PVXSourceLookupDirector
    • org.eclipse.debug.core.sourcelookup.AbstractSourceLookupParticipant (implements org.eclipse.debug.core.sourcelookup.ISourceLookupParticipant)
      • com.pvx.ooadide.launchers.debug.launching.PVXSourceLookupParticipant
    • org.eclipse.ui.actions.ActionDelegate (implements org.eclipse.ui.IActionDelegate2)
      • org.eclipse.ui.texteditor.AbstractRulerActionDelegate (implements org.eclipse.ui.IEditorActionDelegate, org.eclipse.jface.action.IMenuListener, org.eclipse.swt.events.MouseListener)
        • com.pvx.ooadide.launchers.debug.RulerActionDelegate
    • com.pvx.ooadide.builder.BuildResourceAction (implements org.eclipse.ui.IObjectActionDelegate)
    • com.pvx.ooadide.builder.CodeStyleWarningResolution (implements org.eclipse.ui.IMarkerResolution2)
    • com.pvx.ooadide.codehilite2.ColourTokenFactory
    • java.awt.Component (implements java.awt.image.ImageObserver, java.awt.MenuContainer, java.io.Serializable)
      • java.awt.Container
        • javax.swing.JComponent (implements java.io.Serializable)
          • javax.swing.JPanel (implements javax.accessibility.Accessible)
            • com.sage.rcp.resizeanimation.GradientPanel
              • com.sage.rcp.resizeanimation.CurvesPanel
          • com.sage.rcp.resizeanimation.SizeAnimationGlassPane
          • javxswing.SwingDefaultTextPlaneView (implements javxswing.MNEM_WSubject, java.awt.print.Printable, java.lang.Runnable, javxbaseui.TextPlaneView)
            • com.sage.rcp.javx.windows.PluginTextPlaneView (implements java.awt.event.ActionListener)
        • java.awt.Panel (implements javax.accessibility.Accessible)
          • java.applet.Applet
            • javax.swing.JApplet (implements javax.accessibility.Accessible, javax.swing.RootPaneContainer)
              • com.sage.rcp.javx.RcpPluginJavXApplet (implements javxswing.SwingWindow, java.awt.event.WindowListener)
          • com.sage.rcp.javx.RcpSwtViewPanel
    • com.pvx.ooadide.ConsoleDisplayManager
    • com.sage.rcp.ConsoleDisplayManager
    • com.sage.rcp.eventmanager.ConsoleDisplayManager
    • com.pvx.ooadide.Constants
    • org.eclipse.jface.text.contentassist.ContentAssistant (implements org.eclipse.jface.text.contentassist.IContentAssistant, org.eclipse.jface.text.contentassist.IContentAssistantExtension, org.eclipse.jface.text.contentassist.IContentAssistantExtension2, org.eclipse.jface.text.contentassist.IContentAssistantExtension3, org.eclipse.jface.text.contentassist.IContentAssistantExtension4, org.eclipse.jface.text.IWidgetTokenKeeper, org.eclipse.jface.text.IWidgetTokenKeeperExtension)
      • com.pvx.ooadide.codehilite2.PvxContentAssistant
    • com.pvx.ooadide.actions.ConvertAction (implements org.eclipse.ui.IObjectActionDelegate)
    • com.pvx.ooadide.launchers.debug.communication.DebugServer
    • org.eclipse.jface.text.DefaultIndentLineAutoEditStrategy (implements org.eclipse.jface.text.IAutoEditStrategy)
      • com.pvx.ooadide.editors.autoindent.PvxAutoIndentStrategy
    • com.pvx.ooadide.util.DefaultItemContentProvider (implements org.eclipse.jface.viewers.IStructuredContentProvider)
    • com.pvx.ooadide.eventmanager.DelayedAction
    • com.pvx.ooadide.eventmanager.DelayedEvent
    • com.pvx.ooadide.eventmanager.DelayedMethodCall
    • com.sage.rcp.eventmanager.DelayedMethodCall
    • com.pvx.ooadide.eventmanager.DelayedMethodHandler
    • com.sage.rcp.eventmanager.DelayedMethodHandler
    • org.eclipse.jface.dialogs.DialogPage (implements org.eclipse.jface.dialogs.IDialogPage, org.eclipse.jface.dialogs.IMessageProvider)
      • org.eclipse.jface.preference.PreferencePage (implements org.eclipse.jface.preference.IPreferencePage)
        • com.pvx.ooadide.preferences.EditorColorPreferencePage (implements org.eclipse.ui.IWorkbenchPreferencePage)
        • org.eclipse.jface.preference.FieldEditorPreferencePage (implements org.eclipse.jface.util.IPropertyChangeListener)
          • com.pvx.ooadide.preferences.AbstractProvideXFieldEditorPrefPage (implements org.eclipse.ui.IWorkbenchPreferencePage, com.pvx.ooadide.preferences.PvxPrefVisitee)
            • com.pvx.ooadide.preferences.BuilderOptions
            • com.pvx.ooadide.preferences.EditorOptions
            • com.pvx.ooadide.preferences.EditorOptionsPrefPage
            • com.pvx.ooadide.preferences.ImportOptionsPrefPage (implements org.eclipse.ui.IWorkbenchPreferencePage)
            • com.pvx.ooadide.preferences.nomads.NomadsPreferencePage
            • com.pvx.ooadide.preferences.ObserversPreferencePage
            • com.pvx.ooadide.preferences.ProvideXPreferencePage (implements org.eclipse.ui.IWorkbenchPreferencePage)
            • com.pvx.ooadide.preferences.UserDefinedPrefPage
          • com.sage.rcp.preferences.ProgramViewsPrefs (implements org.eclipse.ui.IWorkbenchPreferencePage)
        • org.eclipse.ui.dialogs.PropertyPage (implements org.eclipse.ui.IWorkbenchPropertyPage)
          • com.pvx.ooadide.properties.ProvideXPropertyPage
            • com.pvx.ooadide.preferences.PasswordPreferences (implements org.eclipse.ui.IWorkbenchPreferencePage)
        • org.eclipse.ui.texteditor.templates.TemplatePreferencePage (implements org.eclipse.ui.IWorkbenchPreferencePage)
          • com.pvx.ooadide.editors.templates.TemplatesPreferencePage (implements org.eclipse.ui.IWorkbenchPreferencePage)
      • org.eclipse.jface.wizard.WizardPage (implements org.eclipse.jface.wizard.IWizardPage)
        • com.pvx.ooadide.wizards.NewProjectFromExistingPage
        • com.pvx.ooadide.wizards.ProvidexNewWizardPage (implements com.pvx.ooadide.wizards.ProvideXNewWizardPageI)
          • com.pvx.ooadide.wizards.WizardNewProjectPasswordPage
        • com.pvx.ooadide.wizards.programs.PvxNewProgramPropertiesWizardPage
          • com.pvx.ooadide.wizards.programs.PvcPage
        • org.eclipse.ltk.ui.refactoring.RefactoringWizardPage
          • org.eclipse.ltk.ui.refactoring.UserInputWizardPage
            • com.pvx.ooadide.properties.refactoring.ui.wizards.RenamePropertyInputPage
            • com.pvx.ooadide.refactor.RenamePropertyInputPage
        • org.eclipse.ui.dialogs.WizardNewFileCreationPage (implements org.eclipse.swt.widgets.Listener)
          • com.pvx.ooadide.wizards.programs.PvxWizardNewFileCreatePage
        • com.pvx.ooadide.wizards.WizardPasswordPage (implements org.eclipse.ui.dialogs.IOverwriteQuery, org.eclipse.swt.widgets.Listener)
          • com.pvx.ooadide.wizards.ExportPasswordsPage
          • com.pvx.ooadide.wizards.WizardPasswordImportPage1
    • com.pvx.ooadide.eventmanager.EditorManager
    • com.pvx.ooadide.eventmanager.EditorState
    • com.pvx.ooadide.preferences.EditorSyntaxColorPref
    • com.pvx.ooadide.eventmanager.EventManager (implements com.sage.rcp.IEventManager)
    • com.sage.rcp.eventmanager.EventManager (implements com.sage.rcp.IEventManager)
    • org.eclipse.core.commands.common.EventManager
      • org.eclipse.jface.action.AbstractAction (implements org.eclipse.jface.action.IAction)
        • org.eclipse.jface.action.Action
          • com.sage.rcp.views.RcpPvxAction
          • com.pvx.ooadide.launchers.debug.ToggleBreakpointAction
      • org.eclipse.core.commands.AbstractHandler (implements org.eclipse.core.commands.IHandler2)
        • com.pvx.ooadide.handlers.AddProvidexHandler
        • com.pvx.ooadide.handlers.NewNomadsDefaultsHandler
        • com.pvx.ooadide.handlers.NewNomadsLibHandler
        • com.pvx.ooadide.handlers.NewProgramHandler
        • com.pvx.ooadide.handlers.NewProjectHandler
        • com.pvx.ooadide.handlers.NewPvxClassHandler
      • org.eclipse.jface.viewers.BaseLabelProvider (implements org.eclipse.jface.viewers.IBaseLabelProvider)
        • org.eclipse.jface.viewers.LabelProvider (implements org.eclipse.jface.viewers.ILabelProvider)
          • com.pvx.ooadide.util.DefaultLabelProvider (implements org.eclipse.jface.viewers.IColorProvider)
          • com.pvx.ooadide.views.IOListView.IOListLabelProvider (implements org.eclipse.jface.viewers.ITableLabelProvider)
          • com.pvx.ooadide.views.nomads.LibView.ViewLabelProvider (implements org.eclipse.jface.viewers.ITableLabelProvider)
          • com.pvx.ooadide.launchers.debug.launching.PVXModelPresentation (implements org.eclipse.debug.ui.IDebugModelPresentation)
      • org.eclipse.ui.part.WorkbenchPart (implements org.eclipse.core.runtime.IExecutableExtension, org.eclipse.ui.IWorkbenchPart3, org.eclipse.ui.part.IWorkbenchPartOrientation)
        • org.eclipse.ui.part.EditorPart (implements org.eclipse.ui.IEditorPart)
          • org.eclipse.ui.texteditor.AbstractTextEditor (implements org.eclipse.ui.INavigationLocationProvider, org.eclipse.ui.IPersistableEditor, org.eclipse.ui.IReusableEditor, org.eclipse.ui.ISaveablesSource, org.eclipse.ui.texteditor.ITextEditor, org.eclipse.ui.texteditor.ITextEditorExtension, org.eclipse.ui.texteditor.ITextEditorExtension2, org.eclipse.ui.texteditor.ITextEditorExtension3, org.eclipse.ui.texteditor.ITextEditorExtension4, org.eclipse.ui.texteditor.ITextEditorExtension5, org.eclipse.ui.texteditor.ITextEditorExtension6)
            • org.eclipse.ui.texteditor.StatusTextEditor
              • org.eclipse.ui.texteditor.AbstractDecoratedTextEditor
                • org.eclipse.ui.editors.text.TextEditor
                  • com.pvx.ooadide.editors.NomadsEditor
                  • com.pvx.ooadide.editors.PvxEditor (implements org.eclipse.ui.IShowEditorInput)
        • org.eclipse.ui.part.ViewPart (implements org.eclipse.ui.IViewPart)
          • org.eclipse.ui.navigator.CommonNavigator (implements org.eclipse.ui.ISaveablePart, org.eclipse.ui.ISaveablesSource, org.eclipse.ui.part.ISetSelectionTarget, org.eclipse.ui.part.IShowInTarget)
            • com.pvx.ooadide.navigator.ProjectExplorer
          • com.sage.rcp.views.HostActionsView (implements javxbaseui.AbstractGUIManagerFactory, com.sage.rcp.javx.IEmbeddedJavXView)
            • com.pvx.ooadide.views.WinDefine
          • com.pvx.ooadide.views.JavXBrowserView
          • com.pvx.ooadide.views.nomads.LibView (implements com.pvx.ooadide.views.PvxView)
            • com.pvx.ooadide.views.IOListView
          • com.pvx.ooadide.views.PvcOutline
          • com.sage.rcp.views.RcpEmbedJavXView (implements javxbaseui.AbstractGUIManagerFactory, com.sage.rcp.javx.IEmbeddedJavXView)
            • com.sage.rcp.views.RcpProgramView
              • com.sage.rcp.views.RcpMasProgramView
                • com.sage.rcp.views.RcpSpawnedMasProgramView
    • com.pvx.ooadide.eventmanager.EventManagerFactory
    • com.pvx.ooadide.actions.ExtAction (implements org.eclipse.ui.IWorkbenchWindowActionDelegate)
    • com.pvx.ooadide.eventmanager.ExtCommand (implements com.pvx.ooadide.actions.IExtCommand)
    • com.pvx.ooadide.util.ExtensionUtil (implements org.eclipse.ui.IPropertyListener)
    • com.pvx.ooadide.editors.extkeyword.ExtKeywordCategoryEntity
    • com.pvx.ooadide.codehilite2.ExtKeywordDetector (implements org.eclipse.jface.text.rules.IWordDetector)
    • org.eclipse.jface.preference.FieldEditor
      • org.eclipse.jface.preference.ListEditor
        • com.pvx.ooadide.preferences.PvxListEditor
      • com.pvx.ooadide.preferences.SpacerFieldEditor
    • com.sage.rcp.javx.FxPagePartListener (implements org.eclipse.ui.IPartListener2)
    • com.pvx.ooadide.actions.GenericAction (implements org.eclipse.ui.IEditorActionDelegate)
      • com.pvx.ooadide.actions.GenericWorkbenchAction (implements org.eclipse.ui.IWorkbenchWindowActionDelegate)
      • com.pvx.ooadide.actions.ToolsEditorAction
    • com.pvx.ooadide.editors.HandledInput (implements org.eclipse.ui.IFileEditorInput)
    • org.eclipse.core.internal.events.InternalBuilder
      • org.eclipse.core.resources.IncrementalProjectBuilder (implements org.eclipse.core.runtime.IExecutableExtension)
        • com.pvx.ooadide.builder.ProvideXBuilder
    • org.eclipse.jdt.internal.ui.text.JavaColorManager (implements org.eclipse.jdt.ui.text.IColorManager, org.eclipse.jdt.ui.text.IColorManagerExtension)
      • com.pvx.ooadide.codehilite2.ColorManager
    • org.eclipse.jdt.internal.ui.text.JavaWordDetector (implements org.eclipse.jface.text.rules.IWordDetector)
      • com.pvx.ooadide.codehilite2.PvxDirectiveWordRule.DirectiveWordDetector
    • org.eclipse.debug.core.model.LaunchConfigurationDelegate (implements org.eclipse.debug.core.model.ILaunchConfigurationDelegate2)
      • org.eclipse.jdt.launching.AbstractJavaLaunchConfigurationDelegate (implements org.eclipse.debug.core.IDebugEventSetListener)
        • com.pvx.ooadide.launchers.thinclients.javx.JavXAppletLaunchConfigurationDelegate
    • com.pvx.ooadide.views.nomads.LibView.ViewContentProvider (implements org.eclipse.jface.viewers.IStructuredContentProvider)
    • com.pvx.ooadide.editors.LoadProgramAction (implements org.eclipse.ui.IObjectActionDelegate)
    • com.pvx.ooadide.views.MonitorState
    • com.sage.rcp.eventmanager.MonitorState
    • org.eclipse.osgi.util.NLS
      • com.pvx.ooadide.properties.refactoring.core.CoreTexts
    • org.eclipse.core.runtime.NullProgressMonitor (implements org.eclipse.core.runtime.IProgressMonitor)
      • com.sage.rcp.util.SwingProgressMonitorWrappper
    • com.pvx.ooadide.views.comparators.NumericComparator (implements java.util.Comparator<T>)
    • com.pvx.ooadide.wizards.PasswordTransferElement (implements org.eclipse.core.runtime.preferences.IPreferenceFilter)
    • org.eclipse.jface.text.rules.PatternRule (implements org.eclipse.jface.text.rules.IPredicateRule)
      • org.eclipse.jface.text.rules.SingleLineRule
        • com.pvx.ooadide.codehilite2.PvxEolRule
    • com.pvx.ooadide.util.PixelConverter
    • org.eclipse.core.runtime.PlatformObject (implements org.eclipse.core.runtime.IAdaptable)
      • org.eclipse.debug.core.model.Breakpoint (implements org.eclipse.debug.core.model.IBreakpoint, org.eclipse.debug.core.model.ITriggerPoint)
        • org.eclipse.debug.core.model.LineBreakpoint (implements org.eclipse.debug.core.model.ILineBreakpoint)
          • com.pvx.ooadide.launchers.debug.breakpoints.PVXLineBreakpoint (implements com.pvx.ooadide.launchers.debug.model.IPVXEventListener)
            • com.pvx.ooadide.launchers.debug.breakpoints.PVXRunToLineBreakpoint
          • com.pvx.ooadide.launchers.debug.model.PvxLineBreakpointAdapter (implements com.pvx.ooadide.launchers.debug.model.IPVXEventListener)
      • org.eclipse.debug.core.model.DebugElement (implements org.eclipse.debug.core.model.IDebugElement)
        • com.pvx.ooadide.launchers.debug.model.PVXDebugElement
          • com.pvx.ooadide.launchers.debug.model.PVXDebugTarget (implements org.eclipse.debug.core.IBreakpointManagerListener, org.eclipse.debug.core.model.IDebugTarget, com.pvx.ooadide.launchers.debug.model.IPVXEventListener)
          • com.pvx.ooadide.launchers.debug.model.PVXStackFrame (implements org.eclipse.debug.core.model.IStackFrame)
          • com.pvx.ooadide.launchers.debug.model.PVXThread (implements com.pvx.ooadide.launchers.debug.model.IPVXEventListener, org.eclipse.debug.core.model.IThread)
          • com.pvx.ooadide.launchers.debug.model.PVXValue (implements org.eclipse.debug.core.model.IValue)
            • com.pvx.ooadide.launchers.debug.model.PVXStackValue
          • com.pvx.ooadide.launchers.debug.model.PVXVariable (implements org.eclipse.debug.core.model.IVariable)
            • com.pvx.ooadide.launchers.debug.model.PvxArrayElementVariable
            • com.pvx.ooadide.launchers.debug.model.PVXArrayValue (implements org.eclipse.debug.core.model.IIndexedValue)
      • org.eclipse.ltk.core.refactoring.Refactoring
        • org.eclipse.ltk.core.refactoring.participants.ProcessorBasedRefactoring
          • com.pvx.ooadide.properties.refactoring.core.RenamePropertyRefactoring
          • com.pvx.ooadide.refactor.RenamePropertyRefactoring
      • org.eclipse.ltk.core.refactoring.participants.RefactoringProcessor
        • com.pvx.ooadide.properties.refactoring.core.RenamePropertyProcessor
        • com.pvx.ooadide.refactor.RenamePropertyProcessor
    • org.eclipse.core.runtime.Plugin (implements org.osgi.framework.BundleActivator)
      • org.eclipse.ui.plugin.AbstractUIPlugin
        • com.pvx.ooadide.ProvideXOOADPlugin (implements com.pvx.ooadide.IPvxIdePlugin, org.eclipse.ui.IStartup)
        • com.sage.rcp.PvxRcpActivator
    • com.pvx.ooadide.preferences.PreferenceConstants
    • com.pvx.ooadide.preferences.PreferenceManager
    • com.pvx.ooadide.preferences.PrefPageVistor
    • com.pvx.ooadide.util.ProcessRunner
    • com.sage.rcp.util.ProgressIndicator
    • com.pvx.ooadide.util.ProjectUtils
    • com.pvx.ooadide.actions.ProvideX (implements org.eclipse.ui.IWorkbenchWindowActionDelegate)
      • com.pvx.ooadide.actions.RunDictDataClassAction
      • com.pvx.ooadide.actions.RunDictMaintAction
    • com.pvx.ooadide.launchers.ProvideXLaunchConfigurationDelegate1 (implements org.eclipse.debug.core.model.ILaunchConfigurationDelegate)
      • com.pvx.ooadide.launchers.thinclients.WindXLaunchConfigurationDelegate1
    • com.pvx.ooadide.builder.ProvideXNature (implements org.eclipse.core.resources.IProjectNature)
    • com.pvx.ooadide.popup.actions.ProvideXNewAction (implements org.eclipse.ui.IObjectActionDelegate)
    • com.pvx.ooadide.views.PvcOutlineSettings
    • com.pvx.ooadide.editors.PvxAnnotationHover (implements org.eclipse.jface.text.source.IAnnotationHover)
    • com.pvx.ooadide.launchers.debug.breakpoints.PvxBreakpointAdapterFactory (implements org.eclipse.core.runtime.IAdapterFactory)
    • com.pvx.ooadide.editors.PvxCompletionProposal
    • com.pvx.ooadide.editors.PvxContextInformation (implements org.eclipse.jface.text.contentassist.IContextInformation)
    • com.pvx.ooadide.util.PvxElement (implements com.pvx.ooadide.views.comparators.IPvxElement)
    • com.pvx.ooadide.views.comparators.PvxElementAlphaComparator (implements java.util.Comparator<T>)
    • com.pvx.ooadide.eventmanager.PvxEvent
    • com.sage.rcp.eventmanager.PvxEvent
    • com.pvx.ooadide.util.PvxFileUtils
    • javxbaseui.PvxGUIManager (implements java.awt.datatransfer.ClipboardOwner, javxbaseui.GUIManagerI, javxbaseui.PvxFocusObserver)
      • javxswing.SwingGUIManager (implements javxswing.MNEM_WObserver)
        • com.sage.rcp.javx.RcpPluginSwingGUIManager
          • com.sage.rcp.javx.SingleWinViewGuiMngr
    • javxclientcontrol.PvxHost (implements javxbaseui.PvxEventObserver, java.lang.Runnable)
      • javxclientcontrol.ConnectionControl
        • sagecrm.PluginConnectionControl
          • com.sage.rcp.javx.RcpPluginConnectionControl (implements java.awt.event.ActionListener)
    • com.sage.rcp.javx.PvxHostLauncher
    • com.pvx.ooadide.codehilite2.PvxInfoPresenter (implements org.eclipse.jface.text.DefaultInformationControl.IInformationPresenter)
    • com.pvx.ooadide.views.nomads.PvxLibElement (implements java.lang.Cloneable, com.pvx.ooadide.views.comparators.IPvxElement)
    • com.pvx.ooadide.codehilite2.PvxLineLabelWordRule.LineLabelWordDetector (implements org.eclipse.jface.text.rules.IWordDetector)
    • com.pvx.ooadide.views.comparators.PvxLineNoComparator (implements java.util.Comparator<T>)
    • com.pvx.ooadide.codehilite2.PvxMnemonicRule.MnemonicWordDetector (implements org.eclipse.jface.text.rules.IWordDetector)
    • com.pvx.ooadide.codehilite2.PvxNumbLiteralRule.numbWordDetector (implements org.eclipse.jface.text.rules.IWordDetector)
    • com.pvx.ooadide.editors.autoindent.PvxPairMatcher (implements org.eclipse.jface.text.source.ICharacterPairMatcher)
    • com.pvx.ooadide.editors.PvxParameterListValidator (implements org.eclipse.jface.text.contentassist.IContextInformationPresenter, org.eclipse.jface.text.contentassist.IContextInformationValidator)
    • com.pvx.ooadide.views.PvxPerspectiveFactory (implements org.eclipse.ui.IPerspectiveFactory)
    • com.pvx.ooadide.ui.PvxPluginImages
    • com.pvx.ooadide.builder.PvxProblem (implements org.eclipse.core.runtime.IAdaptable, org.eclipse.ui.views.tasklist.ITaskListResourceAdapter)
      • com.pvx.ooadide.builder.StyleWarning
    • com.sage.rcp.util.PvxRcpStateFlags
    • com.pvx.ooadide.editors.codefolding.PvxReconcilingStrategy (implements org.eclipse.jface.text.reconciler.IReconcilingStrategy, org.eclipse.jface.text.reconciler.IReconcilingStrategyExtension)
    • com.pvx.ooadide.launchers.debug.launching.PVXSourcePathComputerDelegate (implements org.eclipse.debug.core.sourcelookup.ISourcePathComputerDelegate)
    • com.pvx.ooadide.views.comparators.PvxStructureComparator (implements java.util.Comparator<T>)
    • com.pvx.ooadide.properties.refactoring.tagresolver.PvxtagResolver
    • com.pvx.ooadide.util.PvxUtil
    • com.sage.rcp.util.PvxUtil
    • com.pvx.ooadide.util.PvxUtil.ConfirmDialShower (implements java.lang.Runnable)
    • com.sage.rcp.util.PvxUtil.ConfirmDialShower (implements java.lang.Runnable)
    • com.pvx.ooadide.util.PvxVersionInfo
    • com.pvx.ooadide.codehilite2.PvxWordRule (implements org.eclipse.jface.text.rules.IRule)
      • com.pvx.ooadide.codehilite2.ExtKeywordRule
        • com.pvx.ooadide.codehilite2.ExtKeywordCompoundRule
      • com.pvx.ooadide.codehilite2.PvxDirectiveWordRule
      • com.pvx.ooadide.codehilite2.PvxLineLabelWordRule
      • com.pvx.ooadide.codehilite2.PvxMnemonicRule
      • com.pvx.ooadide.codehilite2.PvxNumbLiteralRule
    • com.sage.rcp.preferences.RcpPreferenceConstants
    • com.pvx.ooadide.refactor.RefactorUtil
    • com.pvx.ooadide.refactor.RenamePropertyAction (implements org.eclipse.ui.IEditorActionDelegate)
      • com.pvx.ooadide.refactor.BlockCommentAction
      • com.pvx.ooadide.refactor.RenumberAction
    • com.pvx.ooadide.refactor.RenamePropertyInfo
    • com.pvx.ooadide.eventmanager.ResourceManager
    • com.pvx.ooadide.properties.refactoring.core.ResourcePropertyInfo
    • org.eclipse.ui.views.properties.ResourcePropertySource (implements org.eclipse.ui.views.properties.IPropertySource)
      • com.pvx.ooadide.properties.PvxPropertySource
    • com.pvx.ooadide.properties.ResourceToChangeEntity (implements org.eclipse.compare.IModificationDate, org.eclipse.compare.IStreamContentAccessor, org.eclipse.compare.ITypedElement)
    • com.pvx.ooadide.util.RunPvxTester
    • com.pvx.ooadide.util.RunUtil
    • com.sage.rcp.util.RunUtilProxy
    • com.pvx.ooadide.uesearch.SearchGotoAction (implements org.eclipse.jface.action.IAction)
    • com.pvx.ooadide.views.comparators.SortListener (implements org.eclipse.swt.widgets.Listener)
    • org.eclipse.jface.text.source.SourceViewerConfiguration
      • com.pvx.ooadide.codehilite2.XMLConfiguration2
    • com.sage.rcp.javx.SpawnUtil
    • com.pvx.ooadide.util.StopWatch
    • org.eclipse.jface.text.templates.TemplateCompletionProcessor (implements org.eclipse.jface.text.contentassist.IContentAssistProcessor)
      • com.pvx.ooadide.editors.MyCompletionProcessor (implements org.eclipse.jface.text.contentassist.IContentAssistProcessor)
    • org.eclipse.jface.text.templates.TemplateContextType
      • com.pvx.ooadide.editors.templates.PVXContextType
    • com.pvx.ooadide.editors.templates.TemplateEditorUI
    • com.pvx.ooadide.editors.templates.TemplateMessages
    • org.eclipse.jface.text.templates.TemplateVariableResolver
      • com.pvx.ooadide.editors.templates.PvxPropertyResolver
        • com.pvx.ooadide.editors.templates.FlagsPropertyResolver
        • com.pvx.ooadide.editors.templates.IsLineNoReqPropertyResolver
        • com.pvx.ooadide.editors.templates.NewLineResolver
        • com.pvx.ooadide.editors.templates.OutputPropertyResolver
        • com.pvx.ooadide.editors.templates.OwnerPropertyResolver
        • com.pvx.ooadide.editors.templates.PasswordPropertyResolver
        • com.pvx.ooadide.editors.templates.SageCopyrightPropertyResolver
        • com.pvx.ooadide.editors.templates.VersionControlIdPropertyResolver
    • com.pvx.ooadide.editors.TextHover (implements org.eclipse.jface.text.ITextHover)
    • java.lang.Thread (implements java.lang.Runnable)
      • com.pvx.ooadide.launchers.debug.communication.DebugLauncherThread
        • com.pvx.ooadide.launchers.thinclients.DebugWindXLauncherThread
      • com.sage.rcp.views.JavXThread
      • com.pvx.ooadide.eventmanager.PvxRequestManager
      • com.pvx.ooadide.launchers.debug.communication.ServerSocketThread
    • com.pvx.ooadide.builder.ToggleNatureAction (implements org.eclipse.ui.IObjectActionDelegate)
    • com.pvx.ooadide.uesearch.UE_SearchAction
    • com.pvx.ooadide.views.UIManager
    • com.sage.rcp.eventmanager.UIManager
    • com.sage.rcp.preferences.UiPrefManager
    • com.pvx.ooadide.properties.refactoring.ui.UITexts
    • com.pvx.ooadide.refactor.UITexts
    • com.pvx.ooadide.properties.userdefined.UserDefinedPropField
    • com.pvx.ooadide.preferences.UserDefinedSortedField (implements java.lang.Comparable<T>)
    • com.pvx.ooadide.preferences.UserPrefElement
    • com.pvx.ooadide.util.UtilCommands
    • org.eclipse.jface.viewers.ViewerComparator
      • com.pvx.ooadide.views.PvxViewSorter
    • org.eclipse.jface.viewers.ViewerFilter
      • com.pvx.ooadide.navigator.filters.NavigationFilter
    • com.pvx.ooadide.builder.WarningResolutionGenerator (implements org.eclipse.ui.IMarkerResolutionGenerator2)
    • org.eclipse.jface.window.Window (implements org.eclipse.jface.window.IShellProvider)
      • org.eclipse.jface.dialogs.Dialog
        • org.eclipse.jface.dialogs.IconAndMessageDialog
          • org.eclipse.jface.dialogs.ProgressMonitorDialog (implements org.eclipse.jface.operation.IRunnableContext)
            • com.pvx.ooadide.views.PvxProgressMonitorDialog
            • com.sage.rcp.eventmanager.PvxProgressMonitorDialog
        • org.eclipse.jface.dialogs.InputDialog
          • com.pvx.ooadide.builder.PvxPasswordInputDialogue
        • com.pvx.ooadide.views.nomads.NewNomadsObjectDialog
        • org.eclipse.jface.dialogs.TrayDialog
          • org.eclipse.ui.dialogs.SelectionDialog
            • org.eclipse.ui.dialogs.ResourceListSelectionDialog
              • com.pvx.ooadide.properties.dialogs.PxvResourceListSelectionDialog
            • org.eclipse.ui.dialogs.SelectionStatusDialog
              • org.eclipse.ui.dialogs.AbstractElementListSelectionDialog
                • org.eclipse.ui.dialogs.ElementListSelectionDialog
                  • com.pvx.ooadide.dialogs.PvxElementListSelectionDialog
    • org.eclipse.jface.wizard.Wizard (implements org.eclipse.jface.window.IShellProvider, org.eclipse.jface.wizard.IWizard)
      • org.eclipse.ui.wizards.newresource.BasicNewResourceWizard (implements org.eclipse.ui.INewWizard)
        • org.eclipse.ui.wizards.newresource.BasicNewFileResourceWizard
          • com.pvx.ooadide.wizards.NewNomadsLibraryWizard (implements org.eclipse.ui.INewWizard)
          • com.pvx.ooadide.wizards.NewNomadsNmdWizard (implements org.eclipse.ui.INewWizard)
          • com.pvx.ooadide.wizards.programs.NewPvxProgramWizard (implements org.eclipse.ui.INewWizard)
            • com.pvx.ooadide.wizards.programs.NewPvcCreationWizard
      • com.pvx.ooadide.wizards.ImportPasswordsWizard (implements org.eclipse.ui.IImportWizard)
      • com.pvx.ooadide.wizards.NewFromExisting (implements org.eclipse.ui.INewWizard)
      • com.pvx.ooadide.wizards.PasswordExporterWizard (implements org.eclipse.ui.IExportWizard)
      • com.pvx.ooadide.wizards.ProvideXNewWizard (implements org.eclipse.ui.INewWizard)
      • org.eclipse.ltk.ui.refactoring.RefactoringWizard
        • com.pvx.ooadide.properties.refactoring.ui.wizards.RenamePropertyWizard
        • com.pvx.ooadide.refactor.RenamePropertyWizard
    • com.pvx.ooadide.editors.XEditorMatchingStrategy (implements org.eclipse.ui.IEditorMatchingStrategy)
    • com.pvx.ooadide.codehilite2.XMLDoubleClickStrategy (implements org.eclipse.jface.text.ITextDoubleClickStrategy)

Interface Hierarchy

  • com.sage.rcp.javx.IEmbeddedJavXView
  • com.sage.rcp.IEventManager
  • com.pvx.ooadide.actions.IExtCommand
  • com.pvx.ooadide.views.comparators.IPvxElement
  • com.sage.rcp.eventmanager.IPvxEventCallBack
  • com.pvx.ooadide.launchers.debug.model.IPVXEventListener
  • com.sage.rcp.IPvxPlugin
    • com.pvx.ooadide.IPvxIdePlugin
  • com.pvx.ooadide.builder.IPvxSaveListener
  • com.pvx.ooadide.wizards.ProvideXNewWizardPageI
  • com.pvx.ooadide.preferences.PvxPrefVisitee
  • com.pvx.ooadide.views.PvxView

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.lang.constant.Constable, java.io.Serializable)
      • com.pvx.ooadide.views.PvcOutline.OutlineFilter
      • com.pvx.ooadide.views.PvcOutline.OutlineSortBy


Serialized Form

Serialized Form

  • Package com.sage.rcp.javx

    • Class com.sage.rcp.javx.RcpPluginJavXApplet

      class RcpPluginJavXApplet extends JApplet implements Serializable

      • Serialized Fields

        • actionListener
          ActionListener actionListener
        • ActiveCtls
          Hashtable ActiveCtls
        • args
          String args
        • base
          URL base
        • canvas
          javxbaseui.PvxCanvas canvas
        • connectionAnimation
          sagecrm.AnimatedPanel connectionAnimation
        • desktop
          JDesktopPane desktop
        • menuBars
          Hashtable menuBars
        • nwClient
          RcpPluginConnectionControl nwClient
        • onApplet
          boolean onApplet
        • params
          Hashtable<String,String> params
        • parentFrame
          Frame parentFrame
        • request
          boolean request
        • resizable
          boolean resizable
        • scriptMessage
          String scriptMessage
        • start
          boolean start
        • statusBar
          javxswing.StatusBar statusBar
        • thisApplet
          JApplet thisApplet
        • view
          IEmbeddedJavXView view

    • Class com.sage.rcp.javx.RcpSwtViewPanel

      class RcpSwtViewPanel extends Panel implements Serializable

      • Serialized Fields

        • view
          RcpEmbedJavXView view

  • Package com.sage.rcp.javx.windows

    • Class com.sage.rcp.javx.windows.PluginTextPlaneView

      class PluginTextPlaneView extends javxswing.SwingDefaultTextPlaneView implements Serializable

      • Serialized Fields

        • animation
          Timer animation
        • fCompWinList
          javxswing.SwingWindowCompListener fCompWinList
        • host
          javxclientcontrol.PvxHost host
        • maxHeight
          int maxHeight
        • maxWidth
          int maxWidth
        • needToRepaintAll
          boolean needToRepaintAll
        • origGlassPane
          Component origGlassPane
        • paintHeight
          int paintHeight
        • paintWidth
          int paintWidth
        • resizePnl
          SizeAnimationGlassPane resizePnl

  • Package com.sage.rcp.resizeanimation

    • Class com.sage.rcp.resizeanimation.CurvesPanel

      class CurvesPanel extends GradientPanel implements Serializable

      • Serialized Fields

        • counter
          int counter
        • hints
          RenderingHints hints

    • Class com.sage.rcp.resizeanimation.GradientPanel

      class GradientPanel extends JPanel implements Serializable

      • Serialized Fields

        • gradientEnd1
          Color gradientEnd1
        • gradientEnd2
          Color gradientEnd2
        • gradientStart1
          Color gradientStart1
        • gradientStart2
          Color gradientStart2
        • mask
          BufferedImage mask

    • Class com.sage.rcp.resizeanimation.SizeAnimationGlassPane

      class SizeAnimationGlassPane extends JComponent implements Serializable

      • Serialized Fields

        • borderHeight
          int borderHeight
        • borderWidth
          int borderWidth
        • counter
          int counter
        • gradientEnd1
          Color gradientEnd1
        • gradientEnd2
          Color gradientEnd2
        • gradientStart1
          Color gradientStart1
        • gradientStart2
          Color gradientStart2
        • hints
          RenderingHints hints
        • mask
          BufferedImage mask
        • prevBoarderHeight
          int prevBoarderHeight
        • prevBorderWidth
          int prevBorderWidth


ConsoleDisplayManager

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide

Class ConsoleDisplayManager

java.lang.Object
com.pvx.ooadide.ConsoleDisplayManager
public class ConsoleDisplayManager extends Object
Create an instance of this class in any of your plugin classes. Use it as follows ... ConsoleDisplayMgr.getDefault().println("Some error msg", ConsoleDisplayMgr.MSG_ERROR); ... ... ConsoleDisplayMgr.getDefault().clear(); ...

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final String
    ID
    static final int
    MSG_ERROR
    static final int
    MSG_ERROR_DESC
    static final int
    MSG_INFORMATION
    static final int
    MSG_WARNING

  • Constructor Summary

    Constructors
    Constructor
    Description
    ConsoleDisplayManager(String messageTitle)

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    clear()
    static ConsoleDisplayManager
    getDefault()
    void
    println(String msg, int msgKind)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Field Details

    • ID

      public static final String ID
      See Also:
      • Constant Field Values

    • MSG_INFORMATION

      public static final int MSG_INFORMATION
      See Also:
      • Constant Field Values

    • MSG_ERROR

      public static final int MSG_ERROR
      See Also:
      • Constant Field Values

    • MSG_WARNING

      public static final int MSG_WARNING
      See Also:
      • Constant Field Values

    • MSG_ERROR_DESC

      public static final int MSG_ERROR_DESC
      See Also:
      • Constant Field Values

  • Constructor Details

    • ConsoleDisplayManager

      public ConsoleDisplayManager(String messageTitle)

  • Method Details

    • getDefault

      public static ConsoleDisplayManager getDefault()

    • println

      public void println(String msg, int msgKind)

    • clear

      public void clear()


Constants

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide

Class Constants

java.lang.Object
com.pvx.ooadide.Constants
public class Constants extends Object

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final String
    ATTR_CLIENT_APPSERVER
    static final String
    ATTR_CLIENT_DEFAULTHOST
    static final String
    ATTR_CLIENT_EMBED_ONAPPLET
    static final String
    ATTR_CLIENT_FORCE_LOGIN
    static final String
    ATTR_CLIENT_HOST_ADDR
    static final String
    ATTR_CLIENT_HOST_PORT
    static final String
    ATTR_CLIENT_SSL
    static final String
    ATTR_DEBUG_CLIENT
    static final String
    ATTR_DEBUG_HOST
    static final String
    ATTR_LAUNCHER_PVX_EXE
    static final String
    ATTR_LAUNCHER_WORKING_DIR
    static final String
    ATTR_PROGRAM_ARGS
    static final String
    ATTR_PROGRAM_INI_FILE
    static final String
    ATTR_PROGRAM_INI_FILE_DEFAULT_VALUE
    static final String
    ATTR_PROGRAM_NAME
    static final String
    ATTR_PROJECT_NAME
    static final String
    ATTR_WINDOW_STATE
    static final String
    ID_PVX_DEBUG_MODEL
    static final String
    JavXAppletName

  • Constructor Summary

    Constructors
    Constructor
    Description
    Constants()

  • Method Summary

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Field Details

    • ID_PVX_DEBUG_MODEL

      public static final String ID_PVX_DEBUG_MODEL
      See Also:
      • Constant Field Values

    • ATTR_CLIENT_HOST_ADDR

      public static final String ATTR_CLIENT_HOST_ADDR
      See Also:
      • Constant Field Values

    • ATTR_CLIENT_DEFAULTHOST

      public static final String ATTR_CLIENT_DEFAULTHOST
      See Also:
      • Constant Field Values

    • ATTR_CLIENT_HOST_PORT

      public static final String ATTR_CLIENT_HOST_PORT
      See Also:
      • Constant Field Values

    • ATTR_CLIENT_APPSERVER

      public static final String ATTR_CLIENT_APPSERVER
      See Also:
      • Constant Field Values

    • ATTR_CLIENT_EMBED_ONAPPLET

      public static final String ATTR_CLIENT_EMBED_ONAPPLET
      See Also:
      • Constant Field Values

    • ATTR_CLIENT_SSL

      public static final String ATTR_CLIENT_SSL
      See Also:
      • Constant Field Values

    • ATTR_CLIENT_FORCE_LOGIN

      public static final String ATTR_CLIENT_FORCE_LOGIN
      See Also:
      • Constant Field Values

    • ATTR_PROJECT_NAME

      public static final String ATTR_PROJECT_NAME
      See Also:
      • Constant Field Values

    • ATTR_PROGRAM_NAME

      public static final String ATTR_PROGRAM_NAME
      See Also:
      • Constant Field Values

    • ATTR_PROGRAM_ARGS

      public static final String ATTR_PROGRAM_ARGS
      See Also:
      • Constant Field Values

    • ATTR_PROGRAM_INI_FILE

      public static final String ATTR_PROGRAM_INI_FILE
      See Also:
      • Constant Field Values

    • ATTR_WINDOW_STATE

      public static final String ATTR_WINDOW_STATE
      See Also:
      • Constant Field Values

    • ATTR_DEBUG_HOST

      public static final String ATTR_DEBUG_HOST
      See Also:
      • Constant Field Values

    • ATTR_DEBUG_CLIENT

      public static final String ATTR_DEBUG_CLIENT
      See Also:
      • Constant Field Values

    • ATTR_PROGRAM_INI_FILE_DEFAULT_VALUE

      public static final String ATTR_PROGRAM_INI_FILE_DEFAULT_VALUE
      See Also:
      • Constant Field Values

    • JavXAppletName

      public static final String JavXAppletName
      See Also:
      • Constant Field Values

    • ATTR_LAUNCHER_PVX_EXE

      public static final String ATTR_LAUNCHER_PVX_EXE
      See Also:
      • Constant Field Values

    • ATTR_LAUNCHER_WORKING_DIR

      public static final String ATTR_LAUNCHER_WORKING_DIR
      See Also:
      • Constant Field Values

  • Constructor Details

    • Constants

      public Constants()


IPvxIdePlugin

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide

Interface IPvxIdePlugin

All Superinterfaces:
IPvxPlugin
All Known Implementing Classes:
ProvideXOOADPlugin
public interface IPvxIdePlugin extends IPvxPlugin

  • Method Summary

    Modifier and Type
    Method
    Description
    Hashtable
    getArgsFromProperties(String propfile)

    Methods inherited from interface com.sage.rcp.IPvxPlugin

    getApplicationArguments, getEventManager, getLog, getPluginId, getPreferenceStore, getPvxHelperPath, internalGetActivePage, isDebugWindowRequired, loadClassForName

  • Method Details

    • getArgsFromProperties

      Hashtable getArgsFromProperties(String propfile)


com.pvx.ooadide

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.pvx.ooadide

package com.pvx.ooadide
  • Related Packages
    Package
    Description
    com.pvx.ooadide.actions
    com.pvx.ooadide.builder
    com.pvx.ooadide.codehilite2
    com.pvx.ooadide.dialogs
    com.pvx.ooadide.editors
    com.pvx.ooadide.eventmanager
    com.pvx.ooadide.handlers
    com.pvx.ooadide.launchers
    com.pvx.ooadide.navigator
    com.pvx.ooadide.preferences
    com.pvx.ooadide.properties
    com.pvx.ooadide.refactor
    com.pvx.ooadide.uesearch
    com.pvx.ooadide.ui
    com.pvx.ooadide.util
    com.pvx.ooadide.views
    com.pvx.ooadide.wizards
  • Class
    Description
    ConsoleDisplayManager
    Create an instance of this class in any of your plugin classes.
    Constants
    IPvxIdePlugin
    ProvideXOOADPlugin


com.pvx.ooadide Class Hierarchy

Hierarchy For Package com.pvx.ooadide

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • com.pvx.ooadide.ConsoleDisplayManager
    • com.pvx.ooadide.Constants
    • org.eclipse.core.runtime.Plugin (implements org.osgi.framework.BundleActivator)
      • org.eclipse.ui.plugin.AbstractUIPlugin
        • com.pvx.ooadide.ProvideXOOADPlugin (implements com.pvx.ooadide.IPvxIdePlugin, org.eclipse.ui.IStartup)

Interface Hierarchy

  • com.sage.rcp.IPvxPlugin
    • com.pvx.ooadide.IPvxIdePlugin


Uses of Package com.pvx.ooadide

Uses of Package
com.pvx.ooadide

Packages that use com.pvx.ooadide
Package
Description
com.pvx.ooadide
com.pvx.ooadide.builder
com.pvx.ooadide.editors.extkeyword
com.pvx.ooadide.eventmanager
com.pvx.ooadide.launchers
com.pvx.ooadide.launchers.debug.communication
com.pvx.ooadide.launchers.thinclients
  • Classes in com.pvx.ooadide used by com.pvx.ooadide
    Class
    Description
    ConsoleDisplayManager
    Create an instance of this class in any of your plugin classes.
    IPvxIdePlugin
    ProvideXOOADPlugin
  • Classes in com.pvx.ooadide used by com.pvx.ooadide.builder
    Class
    Description
    ConsoleDisplayManager
    Create an instance of this class in any of your plugin classes.
  • Classes in com.pvx.ooadide used by com.pvx.ooadide.editors.extkeyword
    Class
    Description
    IPvxIdePlugin
  • Classes in com.pvx.ooadide used by com.pvx.ooadide.eventmanager
    Class
    Description
    IPvxIdePlugin
  • Classes in com.pvx.ooadide used by com.pvx.ooadide.launchers
    Class
    Description
    ConsoleDisplayManager
    Create an instance of this class in any of your plugin classes.
  • Classes in com.pvx.ooadide used by com.pvx.ooadide.launchers.debug.communication
    Class
    Description
    ConsoleDisplayManager
    Create an instance of this class in any of your plugin classes.
  • Classes in com.pvx.ooadide used by com.pvx.ooadide.launchers.thinclients
    Class
    Description
    ConsoleDisplayManager
    Create an instance of this class in any of your plugin classes.


ProvideXOOADPlugin

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide

Class ProvideXOOADPlugin

java.lang.Object
org.eclipse.core.runtime.Plugin
org.eclipse.ui.plugin.AbstractUIPlugin
com.pvx.ooadide.ProvideXOOADPlugin
All Implemented Interfaces:
IPvxIdePlugin, IPvxPlugin, org.eclipse.ui.IStartup, org.osgi.framework.BundleActivator
public class ProvideXOOADPlugin extends org.eclipse.ui.plugin.AbstractUIPlugin implements IPvxIdePlugin, org.eclipse.ui.IStartup

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final String
    ID

    Fields inherited from class org.eclipse.core.runtime.Plugin

    PLUGIN_PREFERENCE_SCOPE, PREFERENCES_DEFAULT_OVERRIDE_BASE_NAME, PREFERENCES_DEFAULT_OVERRIDE_FILE_NAME

  • Constructor Summary

    Constructors
    Constructor
    Description
    ProvideXOOADPlugin()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    addDependentPlugin(IPvxIdePlugin aPlugin)
    void
    doInit()
    void
    earlyStartup()
    static org.eclipse.ui.IWorkbenchPage
    getActivePage()
    String
    getApplicationArguments()
    final Hashtable
    getArgsFromProperties(String propfile)
    final Hashtable
    getArgsFromPropertiesInWorkspace(String propfile)
    static org.eclipse.core.runtime.Plugin
    getDefault()
    static ArrayList<IPvxIdePlugin>
    getDependentPluginList()
    String
    getDocument(String fileName)
    IEventManager
    getEventManager()
    static File
    getFileInPlugin(org.eclipse.core.runtime.IPath path)
    Return a java.io.File object that corresponds to the specified IPath in the plugin directory, or null if none.
    final org.eclipse.core.runtime.IPath
    getFolderForFile(String afile)
    static final Hashtable
    getJarConfigs()
    void
    getLocOfPvxPlugin()
    PvcOutlineSettings
    getOutlineSettings()
    Get save Outline View settings for the current session
    static final String
    getPluginDataPath(org.eclipse.core.resources.IProject project)
    String
    getPluginId()
    org.eclipse.jface.resource.ImageRegistry
    getPluginImageRegistry()
    static ArrayList<IPvxIdePlugin>
    getPluginsContributingKeywords()
    Hashtable
    getPrefsForFromProperties(Hashtable<String,Object> configs)
    static final String
    getPvxDOMPath(org.eclipse.core.resources.IProject project)
    String
    getPvxHelperPath()
    static ProvideXOOADPlugin
    getPvxPluginInstance()
    ResourceBundle
    getResourceBundle()
    Returns the plugin's resource bundle,
    static final Hashtable
    getUserConfigs()
    Hashtable
    getUserResourceProperties(Hashtable configs)
    static final Hashtable
    getUserResourceProps()
    org.eclipse.ui.IWorkbenchPage
    internalGetActivePage()
    boolean
    isDebugWindowRequired()
    static boolean
    isPluginAdded()
    Class
    loadClassForName(String className)
    static void
    log(org.eclipse.core.runtime.IStatus status)
    void
    saveOutlineSettings(PvcOutlineSettings pSettings)
    Save current state of Outline View Group-By and Filter settings (for current session)
    void
    setCongifValues()
    void
    stop(org.osgi.framework.BundleContext context)

    Methods inherited from class org.eclipse.ui.plugin.AbstractUIPlugin

    getDialogSettings, getImageRegistry, getPreferenceStore, getWorkbench, imageDescriptorFromPlugin, start

    Methods inherited from class org.eclipse.core.runtime.Plugin

    getBundle, getLog, getStateLocation, isDebugging, setDebugging, toString

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

    Methods inherited from interface com.sage.rcp.IPvxPlugin

    getLog, getPreferenceStore

  • Field Details

    • ID

      public static final String ID
      See Also:
      • Constant Field Values

  • Constructor Details

    • ProvideXOOADPlugin

      public ProvideXOOADPlugin()

  • Method Details

    • doInit

      public void doInit()

    • getOutlineSettings

      public PvcOutlineSettings getOutlineSettings()
      Get save Outline View settings for the current session
      Returns:
      Outline View settings (PvcOutlineSettings)

    • saveOutlineSettings

      public void saveOutlineSettings(PvcOutlineSettings pSettings)
      Save current state of Outline View Group-By and Filter settings (for current session)
      Parameters:
      pSettings - Outline View settings (PvcOutlineSettings)

    • getResourceBundle

      public ResourceBundle getResourceBundle()
      Returns the plugin's resource bundle,

    • getPluginImageRegistry

      public org.eclipse.jface.resource.ImageRegistry getPluginImageRegistry()

    • getLocOfPvxPlugin

      public void getLocOfPvxPlugin()

    • addDependentPlugin

      public void addDependentPlugin(IPvxIdePlugin aPlugin)

    • getPluginsContributingKeywords

      public static ArrayList<IPvxIdePlugin> getPluginsContributingKeywords()

    • getPvxPluginInstance

      public static ProvideXOOADPlugin getPvxPluginInstance()

    • getPvxDOMPath

      public static final String getPvxDOMPath(org.eclipse.core.resources.IProject project)

    • getPluginDataPath

      public static final String getPluginDataPath(org.eclipse.core.resources.IProject project)

    • getPvxHelperPath

      public String getPvxHelperPath()
      Specified by:
      getPvxHelperPath in interface IPvxPlugin

    • getPluginId

      public String getPluginId()
      Specified by:
      getPluginId in interface IPvxPlugin

    • log

      public static void log(org.eclipse.core.runtime.IStatus status)

    • getActivePage

      public static org.eclipse.ui.IWorkbenchPage getActivePage()

    • internalGetActivePage

      public org.eclipse.ui.IWorkbenchPage internalGetActivePage()
      Specified by:
      internalGetActivePage in interface IPvxPlugin

    • getFolderForFile

      public final org.eclipse.core.runtime.IPath getFolderForFile(String afile)

    • getArgsFromPropertiesInWorkspace

      public final Hashtable getArgsFromPropertiesInWorkspace(String propfile)

    • getArgsFromProperties

      public final Hashtable getArgsFromProperties(String propfile)
      Specified by:
      getArgsFromProperties in interface IPvxIdePlugin

    • getDocument

      public String getDocument(String fileName)

    • setCongifValues

      public void setCongifValues()

    • getUserResourceProperties

      public Hashtable getUserResourceProperties(Hashtable configs)

    • getPrefsForFromProperties

      public Hashtable getPrefsForFromProperties(Hashtable<String,Object> configs)

    • stop

      public void stop(org.osgi.framework.BundleContext context) throws Exception
      Specified by:
      stop in interface org.osgi.framework.BundleActivator
      Overrides:
      stop in class org.eclipse.ui.plugin.AbstractUIPlugin
      Throws:
      Exception

    • getJarConfigs

      public static final Hashtable getJarConfigs()

    • getUserConfigs

      public static final Hashtable getUserConfigs()

    • getUserResourceProps

      public static final Hashtable getUserResourceProps()

    • getFileInPlugin

      public static File getFileInPlugin(org.eclipse.core.runtime.IPath path)
      Return a java.io.File object that corresponds to the specified IPath in the plugin directory, or null if none.

    • getDefault

      public static org.eclipse.core.runtime.Plugin getDefault()

    • earlyStartup

      public void earlyStartup()
      Specified by:
      earlyStartup in interface org.eclipse.ui.IStartup

    • getDependentPluginList

      public static ArrayList<IPvxIdePlugin> getDependentPluginList()

    • isPluginAdded

      public static boolean isPluginAdded()

    • getEventManager

      public IEventManager getEventManager()
      Specified by:
      getEventManager in interface IPvxPlugin

    • loadClassForName

      public Class loadClassForName(String className)
      Specified by:
      loadClassForName in interface IPvxPlugin

    • getApplicationArguments

      public String getApplicationArguments()
      Specified by:
      getApplicationArguments in interface IPvxPlugin

    • isDebugWindowRequired

      public boolean isDebugWindowRequired()
      Specified by:
      isDebugWindowRequired in interface IPvxPlugin


AbstractPvxEditorAction

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.actions

Class AbstractPvxEditorAction

java.lang.Object
com.pvx.ooadide.actions.AbstractPvxEditorAction
All Implemented Interfaces:
org.eclipse.ui.IActionDelegate, org.eclipse.ui.IEditorActionDelegate
Direct Known Subclasses:
RunITAction1
public class AbstractPvxEditorAction extends Object implements org.eclipse.ui.IEditorActionDelegate

  • Constructor Summary

    Constructors
    Constructor
    Description
    AbstractPvxEditorAction()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    run(org.eclipse.jface.action.IAction action)
    void
    selectionChanged(org.eclipse.jface.action.IAction action, org.eclipse.jface.viewers.ISelection selection)
    void
    setActiveEditor(org.eclipse.jface.action.IAction action, org.eclipse.ui.IEditorPart targetEditor)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • AbstractPvxEditorAction

      public AbstractPvxEditorAction()

  • Method Details

    • run

      public void run(org.eclipse.jface.action.IAction action)
      Specified by:
      run in interface org.eclipse.ui.IActionDelegate

    • setActiveEditor

      public void setActiveEditor(org.eclipse.jface.action.IAction action, org.eclipse.ui.IEditorPart targetEditor)
      Specified by:
      setActiveEditor in interface org.eclipse.ui.IEditorActionDelegate

    • selectionChanged

      public void selectionChanged(org.eclipse.jface.action.IAction action, org.eclipse.jface.viewers.ISelection selection)
      Specified by:
      selectionChanged in interface org.eclipse.ui.IActionDelegate


ConvertAction

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.actions

Class ConvertAction

java.lang.Object
com.pvx.ooadide.actions.ConvertAction
All Implemented Interfaces:
org.eclipse.ui.IActionDelegate, org.eclipse.ui.IObjectActionDelegate
public class ConvertAction extends Object implements org.eclipse.ui.IObjectActionDelegate

  • Constructor Summary

    Constructors
    Constructor
    Description
    ConvertAction()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    run(org.eclipse.jface.action.IAction action)
    void
    selectionChanged(org.eclipse.jface.action.IAction action, org.eclipse.jface.viewers.ISelection selection)
    void
    setActivePart(org.eclipse.jface.action.IAction action, org.eclipse.ui.IWorkbenchPart targetPart)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • ConvertAction

      public ConvertAction()

  • Method Details

    • run

      public void run(org.eclipse.jface.action.IAction action)
      Specified by:
      run in interface org.eclipse.ui.IActionDelegate

    • selectionChanged

      public void selectionChanged(org.eclipse.jface.action.IAction action, org.eclipse.jface.viewers.ISelection selection)
      Specified by:
      selectionChanged in interface org.eclipse.ui.IActionDelegate

    • setActivePart

      public void setActivePart(org.eclipse.jface.action.IAction action, org.eclipse.ui.IWorkbenchPart targetPart)
      Specified by:
      setActivePart in interface org.eclipse.ui.IObjectActionDelegate


ExtAction

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.actions

Class ExtAction

java.lang.Object
com.pvx.ooadide.actions.ExtAction
All Implemented Interfaces:
org.eclipse.ui.IActionDelegate, org.eclipse.ui.IWorkbenchWindowActionDelegate
public class ExtAction extends Object implements org.eclipse.ui.IWorkbenchWindowActionDelegate

  • Constructor Summary

    Constructors
    Constructor
    Description
    ExtAction()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    dispose()
    void
    init(org.eclipse.ui.IWorkbenchWindow window)
    void
    run(org.eclipse.jface.action.IAction action)
    void
    selectionChanged(org.eclipse.jface.action.IAction action, org.eclipse.jface.viewers.ISelection selection)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • ExtAction

      public ExtAction()

  • Method Details

    • dispose

      public void dispose()
      Specified by:
      dispose in interface org.eclipse.ui.IWorkbenchWindowActionDelegate

    • init

      public void init(org.eclipse.ui.IWorkbenchWindow window)
      Specified by:
      init in interface org.eclipse.ui.IWorkbenchWindowActionDelegate

    • run

      public void run(org.eclipse.jface.action.IAction action)
      Specified by:
      run in interface org.eclipse.ui.IActionDelegate

    • selectionChanged

      public void selectionChanged(org.eclipse.jface.action.IAction action, org.eclipse.jface.viewers.ISelection selection)
      Specified by:
      selectionChanged in interface org.eclipse.ui.IActionDelegate


GenericAction

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.actions

Class GenericAction

java.lang.Object
com.pvx.ooadide.actions.GenericAction
All Implemented Interfaces:
org.eclipse.ui.IActionDelegate, org.eclipse.ui.IEditorActionDelegate
Direct Known Subclasses:
GenericWorkbenchAction, ToolsEditorAction
public class GenericAction extends Object implements org.eclipse.ui.IEditorActionDelegate

  • Constructor Summary

    Constructors
    Constructor
    Description
    GenericAction()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    run(org.eclipse.jface.action.IAction action)
    void
    selectionChanged(org.eclipse.jface.action.IAction action, org.eclipse.jface.viewers.ISelection selection)
    void
    sendActionMsg(String desc)
    void
    setActiveEditor(org.eclipse.jface.action.IAction action, org.eclipse.ui.IEditorPart targetPart)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • GenericAction

      public GenericAction()

  • Method Details

    • setActiveEditor

      public void setActiveEditor(org.eclipse.jface.action.IAction action, org.eclipse.ui.IEditorPart targetPart)
      Specified by:
      setActiveEditor in interface org.eclipse.ui.IEditorActionDelegate

    • run

      public void run(org.eclipse.jface.action.IAction action)
      Specified by:
      run in interface org.eclipse.ui.IActionDelegate

    • sendActionMsg

      public void sendActionMsg(String desc)

    • selectionChanged

      public void selectionChanged(org.eclipse.jface.action.IAction action, org.eclipse.jface.viewers.ISelection selection)
      Specified by:
      selectionChanged in interface org.eclipse.ui.IActionDelegate


GenericWorkbenchAction

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.actions

Class GenericWorkbenchAction

java.lang.Object
com.pvx.ooadide.actions.GenericAction
com.pvx.ooadide.actions.GenericWorkbenchAction
All Implemented Interfaces:
org.eclipse.ui.IActionDelegate, org.eclipse.ui.IEditorActionDelegate, org.eclipse.ui.IWorkbenchWindowActionDelegate
public class GenericWorkbenchAction extends GenericAction implements org.eclipse.ui.IWorkbenchWindowActionDelegate

  • Constructor Summary

    Constructors
    Constructor
    Description
    GenericWorkbenchAction()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    dispose()
    void
    init(org.eclipse.ui.IWorkbenchWindow window)

    Methods inherited from class com.pvx.ooadide.actions.GenericAction

    run, selectionChanged, sendActionMsg, setActiveEditor

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface org.eclipse.ui.IActionDelegate

    run, selectionChanged

  • Constructor Details

    • GenericWorkbenchAction

      public GenericWorkbenchAction()

  • Method Details

    • dispose

      public void dispose()
      Specified by:
      dispose in interface org.eclipse.ui.IWorkbenchWindowActionDelegate

    • init

      public void init(org.eclipse.ui.IWorkbenchWindow window)
      Specified by:
      init in interface org.eclipse.ui.IWorkbenchWindowActionDelegate


IExtCommand

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.actions

Interface IExtCommand

All Known Implementing Classes:
ExtCommand
public interface IExtCommand

  • Method Summary

    Modifier and Type
    Method
    Description
    String
    getCommand()
    Object
    getListener()
    boolean
    hasConfig()
    boolean
    notifyEventManager()

  • Method Details

    • getCommand

      String getCommand()

    • getListener

      Object getListener()

    • notifyEventManager

      boolean notifyEventManager()

    • hasConfig

      boolean hasConfig()


com.pvx.ooadide.actions

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.pvx.ooadide.actions

package com.pvx.ooadide.actions
  • Related Packages
    Package
    Description
    com.pvx.ooadide
  • Class
    Description
    AbstractPvxEditorAction
    ConvertAction
    ExtAction
    GenericAction
    GenericWorkbenchAction
    IExtCommand
    ProvideX
    RunDictDataClassAction
    RunDictMaintAction
    RunITAction1
    ToolsEditorAction


com.pvx.ooadide.actions Class Hierarchy

Hierarchy For Package com.pvx.ooadide.actions

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • com.pvx.ooadide.actions.AbstractPvxEditorAction (implements org.eclipse.ui.IEditorActionDelegate)
      • com.pvx.ooadide.actions.RunITAction1
    • com.pvx.ooadide.actions.ConvertAction (implements org.eclipse.ui.IObjectActionDelegate)
    • com.pvx.ooadide.actions.ExtAction (implements org.eclipse.ui.IWorkbenchWindowActionDelegate)
    • com.pvx.ooadide.actions.GenericAction (implements org.eclipse.ui.IEditorActionDelegate)
      • com.pvx.ooadide.actions.GenericWorkbenchAction (implements org.eclipse.ui.IWorkbenchWindowActionDelegate)
      • com.pvx.ooadide.actions.ToolsEditorAction
    • com.pvx.ooadide.actions.ProvideX (implements org.eclipse.ui.IWorkbenchWindowActionDelegate)
      • com.pvx.ooadide.actions.RunDictDataClassAction
      • com.pvx.ooadide.actions.RunDictMaintAction

Interface Hierarchy

  • com.pvx.ooadide.actions.IExtCommand


Uses of Package com.pvx.ooadide.actions

Uses of Package
com.pvx.ooadide.actions

Packages that use com.pvx.ooadide.actions
Package
Description
com.pvx.ooadide.actions
com.pvx.ooadide.eventmanager
  • Classes in com.pvx.ooadide.actions used by com.pvx.ooadide.actions
    Class
    Description
    AbstractPvxEditorAction
    GenericAction
    ProvideX
  • Classes in com.pvx.ooadide.actions used by com.pvx.ooadide.eventmanager
    Class
    Description
    IExtCommand


ProvideX

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.actions

Class ProvideX

java.lang.Object
com.pvx.ooadide.actions.ProvideX
All Implemented Interfaces:
org.eclipse.ui.IActionDelegate, org.eclipse.ui.IWorkbenchWindowActionDelegate
Direct Known Subclasses:
RunDictDataClassAction, RunDictMaintAction
public class ProvideX extends Object implements org.eclipse.ui.IWorkbenchWindowActionDelegate

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static boolean
    SAVEING_ALL

  • Constructor Summary

    Constructors
    Constructor
    Description
    ProvideX()
    The constructor.

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    dispose()
    We can use this method to dispose of any system resources we previously allocated.
    void
    init(org.eclipse.ui.IWorkbenchWindow window)
    We will cache window object in order to be able to provide parent shell for the message dialog.
    void
    run(org.eclipse.jface.action.IAction action)
    The action has been activated.
    void
    selectionChanged(org.eclipse.jface.action.IAction action, org.eclipse.jface.viewers.ISelection selection)
    Selection in the workbench has been changed.

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Field Details

    • SAVEING_ALL

      public static boolean SAVEING_ALL

  • Constructor Details

    • ProvideX

      public ProvideX()
      The constructor.

  • Method Details

    • run

      public void run(org.eclipse.jface.action.IAction action)
      The action has been activated. The argument of the method represents the 'real' action sitting in the workbench UI.
      Specified by:
      run in interface org.eclipse.ui.IActionDelegate
      See Also:
      • IActionDelegate.run(org.eclipse.jface.action.IAction)

    • selectionChanged

      public void selectionChanged(org.eclipse.jface.action.IAction action, org.eclipse.jface.viewers.ISelection selection)
      Selection in the workbench has been changed. We can change the state of the 'real' action here if we want, but this can only happen after the delegate has been created.
      Specified by:
      selectionChanged in interface org.eclipse.ui.IActionDelegate
      See Also:
      • IActionDelegate.selectionChanged(org.eclipse.jface.action.IAction, org.eclipse.jface.viewers.ISelection)

    • dispose

      public void dispose()
      We can use this method to dispose of any system resources we previously allocated.
      Specified by:
      dispose in interface org.eclipse.ui.IWorkbenchWindowActionDelegate
      See Also:
      • IWorkbenchWindowActionDelegate.dispose()

    • init

      public void init(org.eclipse.ui.IWorkbenchWindow window)
      We will cache window object in order to be able to provide parent shell for the message dialog.
      Specified by:
      init in interface org.eclipse.ui.IWorkbenchWindowActionDelegate
      See Also:
      • IWorkbenchWindowActionDelegate.init(org.eclipse.ui.IWorkbenchWindow)


RunDictDataClassAction

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.actions

Class RunDictDataClassAction

java.lang.Object
com.pvx.ooadide.actions.ProvideX
com.pvx.ooadide.actions.RunDictDataClassAction
All Implemented Interfaces:
org.eclipse.ui.IActionDelegate, org.eclipse.ui.IWorkbenchWindowActionDelegate
public class RunDictDataClassAction extends ProvideX

  • Field Summary

    Fields inherited from class com.pvx.ooadide.actions.ProvideX

    SAVEING_ALL

  • Constructor Summary

    Constructors
    Constructor
    Description
    RunDictDataClassAction()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    run(org.eclipse.jface.action.IAction action)
    The action has been activated.

    Methods inherited from class com.pvx.ooadide.actions.ProvideX

    dispose, init, selectionChanged

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • RunDictDataClassAction

      public RunDictDataClassAction()

  • Method Details

    • run

      public void run(org.eclipse.jface.action.IAction action)
      Description copied from class: ProvideX
      The action has been activated. The argument of the method represents the 'real' action sitting in the workbench UI.
      Specified by:
      run in interface org.eclipse.ui.IActionDelegate
      Overrides:
      run in class ProvideX
      See Also:
      • IActionDelegate.run(org.eclipse.jface.action.IAction)


RunDictMaintAction

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.actions

Class RunDictMaintAction

java.lang.Object
com.pvx.ooadide.actions.ProvideX
com.pvx.ooadide.actions.RunDictMaintAction
All Implemented Interfaces:
org.eclipse.ui.IActionDelegate, org.eclipse.ui.IWorkbenchWindowActionDelegate
public class RunDictMaintAction extends ProvideX

  • Field Summary

    Fields inherited from class com.pvx.ooadide.actions.ProvideX

    SAVEING_ALL

  • Constructor Summary

    Constructors
    Constructor
    Description
    RunDictMaintAction()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    run(org.eclipse.jface.action.IAction action)
    The action has been activated.

    Methods inherited from class com.pvx.ooadide.actions.ProvideX

    dispose, init, selectionChanged

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • RunDictMaintAction

      public RunDictMaintAction()

  • Method Details

    • run

      public void run(org.eclipse.jface.action.IAction action)
      Description copied from class: ProvideX
      The action has been activated. The argument of the method represents the 'real' action sitting in the workbench UI.
      Specified by:
      run in interface org.eclipse.ui.IActionDelegate
      Overrides:
      run in class ProvideX
      See Also:
      • IActionDelegate.run(org.eclipse.jface.action.IAction)


RunITAction1

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.actions

Class RunITAction1

java.lang.Object
com.pvx.ooadide.actions.AbstractPvxEditorAction
com.pvx.ooadide.actions.RunITAction1
All Implemented Interfaces:
org.eclipse.ui.IActionDelegate, org.eclipse.ui.IEditorActionDelegate
public class RunITAction1 extends AbstractPvxEditorAction

  • Constructor Summary

    Constructors
    Constructor
    Description
    RunITAction1()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    run(org.eclipse.jface.action.IAction action)

    Methods inherited from class com.pvx.ooadide.actions.AbstractPvxEditorAction

    selectionChanged, setActiveEditor

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • RunITAction1

      public RunITAction1()

  • Method Details

    • run

      public void run(org.eclipse.jface.action.IAction action)
      Specified by:
      run in interface org.eclipse.ui.IActionDelegate
      Overrides:
      run in class AbstractPvxEditorAction


ToolsEditorAction

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.actions

Class ToolsEditorAction

java.lang.Object
com.pvx.ooadide.actions.GenericAction
com.pvx.ooadide.actions.ToolsEditorAction
All Implemented Interfaces:
org.eclipse.ui.IActionDelegate, org.eclipse.ui.IEditorActionDelegate
public class ToolsEditorAction extends GenericAction

  • Constructor Summary

    Constructors
    Constructor
    Description
    ToolsEditorAction()

  • Method Summary

    Methods inherited from class com.pvx.ooadide.actions.GenericAction

    run, selectionChanged, sendActionMsg, setActiveEditor

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • ToolsEditorAction

      public ToolsEditorAction()


Uses of Class com.pvx.ooadide.actions.AbstractPvxEditorAction

Uses of Class
com.pvx.ooadide.actions.AbstractPvxEditorAction

Packages that use AbstractPvxEditorAction
Package
Description
com.pvx.ooadide.actions

  • Uses of AbstractPvxEditorAction in com.pvx.ooadide.actions

    Subclasses of AbstractPvxEditorAction in com.pvx.ooadide.actions
    Modifier and Type
    Class
    Description
    class
    RunITAction1


Uses of Class com.pvx.ooadide.actions.ConvertAction

Uses of Class
com.pvx.ooadide.actions.ConvertAction

No usage of com.pvx.ooadide.actions.ConvertAction


Uses of Class com.pvx.ooadide.actions.ExtAction

Uses of Class
com.pvx.ooadide.actions.ExtAction

No usage of com.pvx.ooadide.actions.ExtAction


Uses of Class com.pvx.ooadide.actions.GenericAction

Uses of Class
com.pvx.ooadide.actions.GenericAction

Packages that use GenericAction
Package
Description
com.pvx.ooadide.actions

  • Uses of GenericAction in com.pvx.ooadide.actions

    Subclasses of GenericAction in com.pvx.ooadide.actions
    Modifier and Type
    Class
    Description
    class
    GenericWorkbenchAction
    class
    ToolsEditorAction


Uses of Class com.pvx.ooadide.actions.GenericWorkbenchAction

Uses of Class
com.pvx.ooadide.actions.GenericWorkbenchAction

No usage of com.pvx.ooadide.actions.GenericWorkbenchAction


Uses of Interface com.pvx.ooadide.actions.IExtCommand

Uses of Interface
com.pvx.ooadide.actions.IExtCommand

Packages that use IExtCommand
Package
Description
com.pvx.ooadide.eventmanager

  • Uses of IExtCommand in com.pvx.ooadide.eventmanager

    Classes in com.pvx.ooadide.eventmanager that implement IExtCommand
    Modifier and Type
    Class
    Description
    class
    ExtCommand
    An event that indicates a Contributed action has occurred in Eclipse


Uses of Class com.pvx.ooadide.actions.ProvideX

Uses of Class
com.pvx.ooadide.actions.ProvideX

Packages that use ProvideX
Package
Description
com.pvx.ooadide.actions

  • Uses of ProvideX in com.pvx.ooadide.actions

    Subclasses of ProvideX in com.pvx.ooadide.actions
    Modifier and Type
    Class
    Description
    class
    RunDictDataClassAction
    class
    RunDictMaintAction


Uses of Class com.pvx.ooadide.actions.RunDictDataClassAction

Uses of Class
com.pvx.ooadide.actions.RunDictDataClassAction

No usage of com.pvx.ooadide.actions.RunDictDataClassAction


Uses of Class com.pvx.ooadide.actions.RunDictMaintAction

Uses of Class
com.pvx.ooadide.actions.RunDictMaintAction

No usage of com.pvx.ooadide.actions.RunDictMaintAction


Uses of Class com.pvx.ooadide.actions.RunITAction1

Uses of Class
com.pvx.ooadide.actions.RunITAction1

No usage of com.pvx.ooadide.actions.RunITAction1


Uses of Class com.pvx.ooadide.actions.ToolsEditorAction

Uses of Class
com.pvx.ooadide.actions.ToolsEditorAction

No usage of com.pvx.ooadide.actions.ToolsEditorAction


BuildResourceAction

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.builder

Class BuildResourceAction

java.lang.Object
com.pvx.ooadide.builder.BuildResourceAction
All Implemented Interfaces:
org.eclipse.ui.IActionDelegate, org.eclipse.ui.IObjectActionDelegate
public class BuildResourceAction extends Object implements org.eclipse.ui.IObjectActionDelegate

  • Constructor Summary

    Constructors
    Constructor
    Description
    BuildResourceAction()

  • Method Summary

    Modifier and Type
    Method
    Description
    static void
    doMultipleBuild(ArrayList<org.eclipse.core.resources.IResource> resToTouch)
    void
    run(org.eclipse.jface.action.IAction action)
    void
    selectionChanged(org.eclipse.jface.action.IAction action, org.eclipse.jface.viewers.ISelection selection)
    void
    setActivePart(org.eclipse.jface.action.IAction action, org.eclipse.ui.IWorkbenchPart targetPart)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • BuildResourceAction

      public BuildResourceAction()

  • Method Details

    • setActivePart

      public void setActivePart(org.eclipse.jface.action.IAction action, org.eclipse.ui.IWorkbenchPart targetPart)
      Specified by:
      setActivePart in interface org.eclipse.ui.IObjectActionDelegate

    • run

      public void run(org.eclipse.jface.action.IAction action)
      Specified by:
      run in interface org.eclipse.ui.IActionDelegate

    • doMultipleBuild

      public static void doMultipleBuild(ArrayList<org.eclipse.core.resources.IResource> resToTouch)

    • selectionChanged

      public void selectionChanged(org.eclipse.jface.action.IAction action, org.eclipse.jface.viewers.ISelection selection)
      Specified by:
      selectionChanged in interface org.eclipse.ui.IActionDelegate


CodeStyleWarningResolution

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.builder

Class CodeStyleWarningResolution

java.lang.Object
com.pvx.ooadide.builder.CodeStyleWarningResolution
All Implemented Interfaces:
org.eclipse.ui.IMarkerResolution, org.eclipse.ui.IMarkerResolution2
public class CodeStyleWarningResolution extends Object implements org.eclipse.ui.IMarkerResolution2

  • Constructor Summary

    Constructors
    Constructor
    Description
    CodeStyleWarningResolution(String correction, String corAction)

  • Method Summary

    Modifier and Type
    Method
    Description
    String
    getDescription()
    org.eclipse.swt.graphics.Image
    getImage()
    String
    getLabel()
    void
    run(org.eclipse.core.resources.IMarker marker)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • CodeStyleWarningResolution

      public CodeStyleWarningResolution(String correction, String corAction)

  • Method Details

    • getDescription

      public String getDescription()
      Specified by:
      getDescription in interface org.eclipse.ui.IMarkerResolution2

    • getImage

      public org.eclipse.swt.graphics.Image getImage()
      Specified by:
      getImage in interface org.eclipse.ui.IMarkerResolution2

    • getLabel

      public String getLabel()
      Specified by:
      getLabel in interface org.eclipse.ui.IMarkerResolution

    • run

      public void run(org.eclipse.core.resources.IMarker marker)
      Specified by:
      run in interface org.eclipse.ui.IMarkerResolution


IPvxSaveListener

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.builder

Interface IPvxSaveListener

public interface IPvxSaveListener

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    fileSaved(org.eclipse.core.resources.IFile file)

  • Method Details

    • fileSaved

      void fileSaved(org.eclipse.core.resources.IFile file)


com.pvx.ooadide.builder

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.pvx.ooadide.builder

package com.pvx.ooadide.builder
  • Related Packages
    Package
    Description
    com.pvx.ooadide
  • Class
    Description
    BuildResourceAction
    CodeStyleWarningResolution
    IPvxSaveListener
    ProvideXBuilder
    ProvideXNature
    PvxPasswordInputDialogue
    PvxProblem
    StyleWarning
    ToggleNatureAction
    WarningResolutionGenerator


com.pvx.ooadide.builder Class Hierarchy

Hierarchy For Package com.pvx.ooadide.builder

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • com.pvx.ooadide.builder.BuildResourceAction (implements org.eclipse.ui.IObjectActionDelegate)
    • com.pvx.ooadide.builder.CodeStyleWarningResolution (implements org.eclipse.ui.IMarkerResolution2)
    • org.eclipse.core.internal.events.InternalBuilder
      • org.eclipse.core.resources.IncrementalProjectBuilder (implements org.eclipse.core.runtime.IExecutableExtension)
        • com.pvx.ooadide.builder.ProvideXBuilder
    • com.pvx.ooadide.builder.ProvideXNature (implements org.eclipse.core.resources.IProjectNature)
    • com.pvx.ooadide.builder.PvxProblem (implements org.eclipse.core.runtime.IAdaptable, org.eclipse.ui.views.tasklist.ITaskListResourceAdapter)
      • com.pvx.ooadide.builder.StyleWarning
    • com.pvx.ooadide.builder.ToggleNatureAction (implements org.eclipse.ui.IObjectActionDelegate)
    • com.pvx.ooadide.builder.WarningResolutionGenerator (implements org.eclipse.ui.IMarkerResolutionGenerator2)
    • org.eclipse.jface.window.Window (implements org.eclipse.jface.window.IShellProvider)
      • org.eclipse.jface.dialogs.Dialog
        • org.eclipse.jface.dialogs.InputDialog
          • com.pvx.ooadide.builder.PvxPasswordInputDialogue

Interface Hierarchy

  • com.pvx.ooadide.builder.IPvxSaveListener


Uses of Package com.pvx.ooadide.builder

Uses of Package
com.pvx.ooadide.builder

Packages that use com.pvx.ooadide.builder
Package
Description
com.pvx.ooadide.builder
  • Classes in com.pvx.ooadide.builder used by com.pvx.ooadide.builder
    Class
    Description
    IPvxSaveListener
    PvxProblem


ProvideXBuilder

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.builder

Class ProvideXBuilder

java.lang.Object
org.eclipse.core.internal.events.InternalBuilder
org.eclipse.core.resources.IncrementalProjectBuilder
com.pvx.ooadide.builder.ProvideXBuilder
All Implemented Interfaces:
org.eclipse.core.runtime.IExecutableExtension
public class ProvideXBuilder extends org.eclipse.core.resources.IncrementalProjectBuilder

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final String
    BUILDER_ID
    static final String
    BUILDLOG_NAME
    static final org.eclipse.core.runtime.Path
    DEFAULT_DESTDIR
    static final org.eclipse.core.runtime.Path
    DEFAULT_SRCDIR
    static final String
    ERROR_SCAN_PROGRAM
    static final String
    PVX_1FILE_COMPLR_PROGRAM
    static final String
    PVX_CONTEXTMNU_BUILD
    static final String
    PVXDATAFILE_SCAN_PROGRAM
    static final String
    STYLELOG_NAME

    Fields inherited from class org.eclipse.core.resources.IncrementalProjectBuilder

    AUTO_BUILD, CLEAN_BUILD, FULL_BUILD, INCREMENTAL_BUILD

  • Constructor Summary

    Constructors
    Constructor
    Description
    ProvideXBuilder()

  • Method Summary

    Modifier and Type
    Method
    Description
    static void
    addSaveListener(IPvxSaveListener saveListener)
    static void
    addToKnownPassword(String pass)
    static void
    checkCodeStyle(org.eclipse.core.resources.IFile srcFile, Vector<PvxProblem> msgs)
    boolean
    checkPVX(org.eclipse.core.resources.IResource resource, ConsoleDisplayManager console)
    static String
    convertSrcToDestRelativePath(org.eclipse.core.resources.IResource inputResource, org.eclipse.core.resources.IProject project)
    String
    covertSrcPathToDestAbsolutePath(org.eclipse.core.resources.IResource relPath)
    static String
    covertSrcPathToDestAbsolutePath(org.eclipse.core.resources.IResource relPath, org.eclipse.core.resources.IProject project)
    void
    doConvertResource(org.eclipse.core.resources.IResource resource, org.eclipse.core.runtime.IProgressMonitor monitor)
    static File
    findDataDomFile(org.eclipse.core.resources.IResource resource, String fileExt)
    static File
    findDomFile(org.eclipse.core.resources.IResource resource)
    static final void
    generateFormattedSourceFile(org.eclipse.core.resources.IFile srcFile, String destFilePath)
    static org.eclipse.core.runtime.Path
    getAbsoluteSRCDIR(org.eclipse.core.resources.IProject project)
    static String
    getBuildErrorMsg()
    static String
    getDefaultRawOutputDir(org.eclipse.core.resources.IProject project)
    static String
    getDefaultRawSrcDir(org.eclipse.core.resources.IProject project)
    static org.eclipse.core.runtime.Path
    getDESTDIR(org.eclipse.core.resources.IProject project)
    static String
    getDOM_DIRECTORY(org.eclipse.core.resources.IProject project)
    static int
    getNumMembers(org.eclipse.core.resources.IResource[] resources)
    static int
    getNumResourcesInSrcDir(org.eclipse.core.resources.IFolder sourceFolder)
    static org.eclipse.core.runtime.Path
    getOutputLinkDIR(org.eclipse.core.resources.IProject project)
    String
    getPrgPassword(org.eclipse.core.resources.IResource resource, Vector<PvxProblem> msgs)
    static org.eclipse.core.runtime.Path
    getSRCDIR(org.eclipse.core.resources.IProject project)
    void
    handleConvertToASCII(org.eclipse.core.resources.IProject project, org.eclipse.core.runtime.IProgressMonitor monitor)
    static boolean
    hasProjectMoved(org.eclipse.core.resources.IProject project)
    Simple check to see if a project has moved using a new hidden property that saves the project location when the property page is updated.
    String
    initializePropertyFromArgsMap(Map args, org.eclipse.core.resources.IProject project, String key)
    static boolean
    isBuilderRunning()
    static boolean
    isCanceled()
    static boolean
    isConvertingResources()
    static boolean
    isInSrcDir(org.eclipse.core.resources.IResource resource)
    static boolean
    isOutputDirectory(org.eclipse.core.resources.IResource resource)
    static boolean
    isSourceDirectory(org.eclipse.core.resources.IResource resource)
    static void
    markFileAsResource(org.eclipse.core.resources.IResource resource)
    static void
    markFileAsResource(org.eclipse.core.resources.IResource resource, boolean bIsResource)
    static void
    notifyHostFullBuildEnd()
    static void
    notifyHostFullBuildStart(org.eclipse.core.resources.IProject project, int rCount)
    static String
    queryForPassword(InputStream in, org.eclipse.core.resources.IFile file, String pathToSrcFile, Vector<PvxProblem> msgs)
    static void
    removeSaveListener(IPvxSaveListener saveListener)
    static void
    setBuildError(boolean status)
    static void
    setBuildErrorMSg(String msg)
    static void
    setPvxFileProperties(org.eclipse.core.resources.IResource resource)
    static void
    syncInOutPutFolder(org.eclipse.core.resources.IContainer folder, org.eclipse.core.resources.IProject project)
    static void
    terminatePvxBuilds()
    static final String
    translatePath(String projectRelativePath)

    Methods inherited from class org.eclipse.core.resources.IncrementalProjectBuilder

    forgetLastBuiltState, getBuildConfig, getCommand, getContext, getDelta, getProject, getRule, hasBeenBuilt, isInterrupted, needRebuild, rememberLastBuiltState, setInitializationData

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Field Details

    • BUILDER_ID

      public static final String BUILDER_ID
      See Also:
      • Constant Field Values

    • DEFAULT_SRCDIR

      public static final org.eclipse.core.runtime.Path DEFAULT_SRCDIR

    • DEFAULT_DESTDIR

      public static final org.eclipse.core.runtime.Path DEFAULT_DESTDIR

    • BUILDLOG_NAME

      public static final String BUILDLOG_NAME
      See Also:
      • Constant Field Values

    • STYLELOG_NAME

      public static final String STYLELOG_NAME
      See Also:
      • Constant Field Values

    • PVX_1FILE_COMPLR_PROGRAM

      public static final String PVX_1FILE_COMPLR_PROGRAM
      See Also:
      • Constant Field Values

    • ERROR_SCAN_PROGRAM

      public static final String ERROR_SCAN_PROGRAM
      See Also:
      • Constant Field Values

    • PVXDATAFILE_SCAN_PROGRAM

      public static final String PVXDATAFILE_SCAN_PROGRAM
      See Also:
      • Constant Field Values

    • PVX_CONTEXTMNU_BUILD

      public static final String PVX_CONTEXTMNU_BUILD
      See Also:
      • Constant Field Values

  • Constructor Details

    • ProvideXBuilder

      public ProvideXBuilder()

  • Method Details

    • isInSrcDir

      public static boolean isInSrcDir(org.eclipse.core.resources.IResource resource)

    • findDomFile

      public static File findDomFile(org.eclipse.core.resources.IResource resource)

    • findDataDomFile

      public static File findDataDomFile(org.eclipse.core.resources.IResource resource, String fileExt)

    • isOutputDirectory

      public static boolean isOutputDirectory(org.eclipse.core.resources.IResource resource)

    • isSourceDirectory

      public static boolean isSourceDirectory(org.eclipse.core.resources.IResource resource)

    • hasProjectMoved

      public static boolean hasProjectMoved(org.eclipse.core.resources.IProject project)
      Simple check to see if a project has moved using a new hidden property that saves the project location when the property page is updated.
      Parameters:
      project - The project to check
      Returns:

    • isBuilderRunning

      public static boolean isBuilderRunning()

    • isConvertingResources

      public static boolean isConvertingResources()

    • initializePropertyFromArgsMap

      public String initializePropertyFromArgsMap(Map args, org.eclipse.core.resources.IProject project, String key)

    • notifyHostFullBuildEnd

      public static void notifyHostFullBuildEnd()

    • notifyHostFullBuildStart

      public static void notifyHostFullBuildStart(org.eclipse.core.resources.IProject project, int rCount)

    • getNumResourcesInSrcDir

      public static int getNumResourcesInSrcDir(org.eclipse.core.resources.IFolder sourceFolder)

    • getNumMembers

      public static int getNumMembers(org.eclipse.core.resources.IResource[] resources)

    • checkPVX

      public boolean checkPVX(org.eclipse.core.resources.IResource resource, ConsoleDisplayManager console)

    • addSaveListener

      public static void addSaveListener(IPvxSaveListener saveListener)

    • removeSaveListener

      public static void removeSaveListener(IPvxSaveListener saveListener)

    • syncInOutPutFolder

      public static void syncInOutPutFolder(org.eclipse.core.resources.IContainer folder, org.eclipse.core.resources.IProject project)

    • translatePath

      public static final String translatePath(String projectRelativePath)

    • covertSrcPathToDestAbsolutePath

      public static String covertSrcPathToDestAbsolutePath(org.eclipse.core.resources.IResource relPath, org.eclipse.core.resources.IProject project)

    • covertSrcPathToDestAbsolutePath

      public String covertSrcPathToDestAbsolutePath(org.eclipse.core.resources.IResource relPath)

    • convertSrcToDestRelativePath

      public static String convertSrcToDestRelativePath(org.eclipse.core.resources.IResource inputResource, org.eclipse.core.resources.IProject project)

    • generateFormattedSourceFile

      public static final void generateFormattedSourceFile(org.eclipse.core.resources.IFile srcFile, String destFilePath)

    • terminatePvxBuilds

      public static void terminatePvxBuilds()

    • handleConvertToASCII

      public void handleConvertToASCII(org.eclipse.core.resources.IProject project, org.eclipse.core.runtime.IProgressMonitor monitor) throws org.eclipse.core.runtime.CoreException
      Throws:
      org.eclipse.core.runtime.CoreException

    • doConvertResource

      public void doConvertResource(org.eclipse.core.resources.IResource resource, org.eclipse.core.runtime.IProgressMonitor monitor)

    • getPrgPassword

      public String getPrgPassword(org.eclipse.core.resources.IResource resource, Vector<PvxProblem> msgs)

    • queryForPassword

      public static String queryForPassword(InputStream in, org.eclipse.core.resources.IFile file, String pathToSrcFile, Vector<PvxProblem> msgs) throws IOException
      Throws:
      IOException

    • checkCodeStyle

      public static void checkCodeStyle(org.eclipse.core.resources.IFile srcFile, Vector<PvxProblem> msgs)

    • getDOM_DIRECTORY

      public static String getDOM_DIRECTORY(org.eclipse.core.resources.IProject project)

    • getAbsoluteSRCDIR

      public static org.eclipse.core.runtime.Path getAbsoluteSRCDIR(org.eclipse.core.resources.IProject project)

    • getDefaultRawSrcDir

      public static String getDefaultRawSrcDir(org.eclipse.core.resources.IProject project)

    • getSRCDIR

      public static org.eclipse.core.runtime.Path getSRCDIR(org.eclipse.core.resources.IProject project)

    • getOutputLinkDIR

      public static org.eclipse.core.runtime.Path getOutputLinkDIR(org.eclipse.core.resources.IProject project)

    • getDESTDIR

      public static org.eclipse.core.runtime.Path getDESTDIR(org.eclipse.core.resources.IProject project)

    • getDefaultRawOutputDir

      public static String getDefaultRawOutputDir(org.eclipse.core.resources.IProject project)

    • markFileAsResource

      public static void markFileAsResource(org.eclipse.core.resources.IResource resource)

    • markFileAsResource

      public static void markFileAsResource(org.eclipse.core.resources.IResource resource, boolean bIsResource)

    • setPvxFileProperties

      public static void setPvxFileProperties(org.eclipse.core.resources.IResource resource)

    • isCanceled

      public static boolean isCanceled()

    • setBuildError

      public static void setBuildError(boolean status)

    • getBuildErrorMsg

      public static String getBuildErrorMsg()

    • setBuildErrorMSg

      public static void setBuildErrorMSg(String msg)

    • addToKnownPassword

      public static void addToKnownPassword(String pass)


ProvideXNature

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.builder

Class ProvideXNature

java.lang.Object
com.pvx.ooadide.builder.ProvideXNature
All Implemented Interfaces:
org.eclipse.core.resources.IProjectNature
public class ProvideXNature extends Object implements org.eclipse.core.resources.IProjectNature

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final String
    NATURE_ID
    ID of this project nature

  • Constructor Summary

    Constructors
    Constructor
    Description
    ProvideXNature()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    configure()
    void
    deconfigure()
    org.eclipse.core.resources.IProject
    getProject()
    void
    setProject(org.eclipse.core.resources.IProject project)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Field Details

    • NATURE_ID

      public static final String NATURE_ID
      ID of this project nature
      See Also:
      • Constant Field Values

  • Constructor Details

    • ProvideXNature

      public ProvideXNature()

  • Method Details

    • configure

      public void configure() throws org.eclipse.core.runtime.CoreException
      Specified by:
      configure in interface org.eclipse.core.resources.IProjectNature
      Throws:
      org.eclipse.core.runtime.CoreException

    • deconfigure

      public void deconfigure() throws org.eclipse.core.runtime.CoreException
      Specified by:
      deconfigure in interface org.eclipse.core.resources.IProjectNature
      Throws:
      org.eclipse.core.runtime.CoreException

    • getProject

      public org.eclipse.core.resources.IProject getProject()
      Specified by:
      getProject in interface org.eclipse.core.resources.IProjectNature

    • setProject

      public void setProject(org.eclipse.core.resources.IProject project)
      Specified by:
      setProject in interface org.eclipse.core.resources.IProjectNature


PvxPasswordInputDialogue

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.builder

Class PvxPasswordInputDialogue

java.lang.Object
org.eclipse.jface.window.Window
org.eclipse.jface.dialogs.Dialog
org.eclipse.jface.dialogs.InputDialog
com.pvx.ooadide.builder.PvxPasswordInputDialogue
All Implemented Interfaces:
org.eclipse.jface.window.IShellProvider
public class PvxPasswordInputDialogue extends org.eclipse.jface.dialogs.InputDialog

  • Nested Class Summary

    Nested classes/interfaces inherited from class org.eclipse.jface.window.Window

    org.eclipse.jface.window.Window.IExceptionHandler

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    int
    OK_FOR_ALL_ID

    Fields inherited from class org.eclipse.jface.dialogs.Dialog

    blockedHandler, buttonBar, DIALOG_DEFAULT_BOUNDS, DIALOG_PERSISTLOCATION, DIALOG_PERSISTSIZE, DLG_IMG_HELP, DLG_IMG_MESSAGE_ERROR, DLG_IMG_MESSAGE_INFO, DLG_IMG_MESSAGE_WARNING, ELLIPSIS

    Fields inherited from class org.eclipse.jface.window.Window

    CANCEL, OK

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxPasswordInputDialogue(org.eclipse.swt.widgets.Shell parentShell, String dialogTitle, String dialogMessage, Vector<String> init_knownPasswords, org.eclipse.jface.dialogs.IInputValidator validator, String initSrcFile)

  • Method Summary

    Modifier and Type
    Method
    Description
    static boolean
    isPasswordValid(String posPass, String subjectFile)
    static void
    setPassword(boolean valid)

    Methods inherited from class org.eclipse.jface.dialogs.InputDialog

    getValue, setErrorMessage

    Methods inherited from class org.eclipse.jface.dialogs.Dialog

    applyDialogFont, close, convertHeightInCharsToPixels, convertHorizontalDLUsToPixels, convertVerticalDLUsToPixels, convertWidthInCharsToPixels, create, getBlockedHandler, getImage, setBlockedHandler, shortenText

    Methods inherited from class org.eclipse.jface.window.Window

    getDefaultImage, getDefaultImages, getDefaultOrientation, getReturnCode, getShell, getWindowManager, open, setBlockOnOpen, setDefaultImage, setDefaultImages, setDefaultModalParent, setDefaultOrientation, setExceptionHandler, setWindowManager

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Field Details

    • OK_FOR_ALL_ID

      public int OK_FOR_ALL_ID

  • Constructor Details

    • PvxPasswordInputDialogue

      public PvxPasswordInputDialogue(org.eclipse.swt.widgets.Shell parentShell, String dialogTitle, String dialogMessage, Vector<String> init_knownPasswords, org.eclipse.jface.dialogs.IInputValidator validator, String initSrcFile)

  • Method Details

    • isPasswordValid

      public static boolean isPasswordValid(String posPass, String subjectFile)

    • setPassword

      public static void setPassword(boolean valid)


PvxProblem

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.builder

Class PvxProblem

java.lang.Object
com.pvx.ooadide.builder.PvxProblem
All Implemented Interfaces:
org.eclipse.core.runtime.IAdaptable, org.eclipse.ui.views.tasklist.ITaskListResourceAdapter
Direct Known Subclasses:
StyleWarning
public class PvxProblem extends Object implements org.eclipse.core.runtime.IAdaptable, org.eclipse.ui.views.tasklist.ITaskListResourceAdapter

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static Vector<org.eclipse.core.resources.IMarker>
    curMarkers
    static final String
    PVXCORRECTION
    static final String
    PVXCORRECTION_ACTION

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxProblem(boolean init_isWarning, String r, String s, int init_startLine, int init_endLine, String desc, org.eclipse.core.resources.IFile init_srcFile)
    PvxProblem(boolean init_isWarning, String r, String e, String desc, org.eclipse.core.resources.IFile init_srcFile)
    PvxProblem(String r, String e, String desc, org.eclipse.core.resources.IFile init_srcFile, String init_corr)

  • Method Summary

    Modifier and Type
    Method
    Description
    Object
    getAdapter(Class adapter)
    org.eclipse.core.resources.IResource
    getAffectedResource(org.eclipse.core.runtime.IAdaptable adaptable)
    String
    getDescription()
    String
    getError()
    org.eclipse.core.resources.IResource
    getResource()
    String
    getResourcePath()
    int
    getStartLine()
    boolean
    isWarning()
    static void
    markAllProblemFiles(Enumeration currentErrors)
    void
    markProblemFile()
    static void
    scanPvxErrorLogFile(File errorLog, org.eclipse.core.resources.IFile srcFile, Vector<PvxProblem> msgs)
    static void
    scanPvxErrorLogString(String errorLog, org.eclipse.core.resources.IFile srcFile, Vector<PvxProblem> msgs)
    void
    setDescription(String description)
    void
    setResourcePath(String resource)
    void
    setSrcCode(String s)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Field Details

    • curMarkers

      public static Vector<org.eclipse.core.resources.IMarker> curMarkers

    • PVXCORRECTION

      public static final String PVXCORRECTION
      See Also:
      • Constant Field Values

    • PVXCORRECTION_ACTION

      public static final String PVXCORRECTION_ACTION
      See Also:
      • Constant Field Values

  • Constructor Details

    • PvxProblem

      public PvxProblem(boolean init_isWarning, String r, String e, String desc, org.eclipse.core.resources.IFile init_srcFile)

    • PvxProblem

      public PvxProblem(String r, String e, String desc, org.eclipse.core.resources.IFile init_srcFile, String init_corr)

    • PvxProblem

      public PvxProblem(boolean init_isWarning, String r, String s, int init_startLine, int init_endLine, String desc, org.eclipse.core.resources.IFile init_srcFile)

  • Method Details

    • setDescription

      public void setDescription(String description)

    • getDescription

      public String getDescription()

    • setResourcePath

      public void setResourcePath(String resource)

    • getResourcePath

      public String getResourcePath()

    • setSrcCode

      public void setSrcCode(String s)

    • getError

      public String getError()

    • scanPvxErrorLogString

      public static void scanPvxErrorLogString(String errorLog, org.eclipse.core.resources.IFile srcFile, Vector<PvxProblem> msgs)

    • scanPvxErrorLogFile

      public static void scanPvxErrorLogFile(File errorLog, org.eclipse.core.resources.IFile srcFile, Vector<PvxProblem> msgs)

    • markProblemFile

      public void markProblemFile()

    • markAllProblemFiles

      public static void markAllProblemFiles(Enumeration currentErrors)

    • getAdapter

      public Object getAdapter(Class adapter)
      Specified by:
      getAdapter in interface org.eclipse.core.runtime.IAdaptable

    • getAffectedResource

      public org.eclipse.core.resources.IResource getAffectedResource(org.eclipse.core.runtime.IAdaptable adaptable)
      Specified by:
      getAffectedResource in interface org.eclipse.ui.views.tasklist.ITaskListResourceAdapter

    • getResource

      public org.eclipse.core.resources.IResource getResource()

    • getStartLine

      public int getStartLine()

    • isWarning

      public boolean isWarning()


StyleWarning

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.builder

Class StyleWarning

java.lang.Object
com.pvx.ooadide.builder.PvxProblem
com.pvx.ooadide.builder.StyleWarning
All Implemented Interfaces:
org.eclipse.core.runtime.IAdaptable, org.eclipse.ui.views.tasklist.ITaskListResourceAdapter
public class StyleWarning extends PvxProblem

  • Field Summary

    Fields inherited from class com.pvx.ooadide.builder.PvxProblem

    curMarkers, PVXCORRECTION, PVXCORRECTION_ACTION

  • Constructor Summary

    Constructors
    Constructor
    Description
    StyleWarning(String r, String e, String desc, org.eclipse.core.resources.IFile init_srcFile, String init_corr, int init_line, String init_corAction)

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    markProblemFile()
    static void
    scanWarningLog(File warningLog, org.eclipse.core.resources.IFile srcFile, Vector<PvxProblem> msgs)

    Methods inherited from class com.pvx.ooadide.builder.PvxProblem

    getAdapter, getAffectedResource, getDescription, getError, getResource, getResourcePath, getStartLine, isWarning, markAllProblemFiles, scanPvxErrorLogFile, scanPvxErrorLogString, setDescription, setResourcePath, setSrcCode

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • StyleWarning

      public StyleWarning(String r, String e, String desc, org.eclipse.core.resources.IFile init_srcFile, String init_corr, int init_line, String init_corAction)

  • Method Details

    • scanWarningLog

      public static void scanWarningLog(File warningLog, org.eclipse.core.resources.IFile srcFile, Vector<PvxProblem> msgs)

    • markProblemFile

      public void markProblemFile()
      Overrides:
      markProblemFile in class PvxProblem


ToggleNatureAction

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.builder

Class ToggleNatureAction

java.lang.Object
com.pvx.ooadide.builder.ToggleNatureAction
All Implemented Interfaces:
org.eclipse.ui.IActionDelegate, org.eclipse.ui.IObjectActionDelegate
public class ToggleNatureAction extends Object implements org.eclipse.ui.IObjectActionDelegate

  • Constructor Summary

    Constructors
    Constructor
    Description
    ToggleNatureAction()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    run(org.eclipse.jface.action.IAction action)
    void
    selectionChanged(org.eclipse.jface.action.IAction action, org.eclipse.jface.viewers.ISelection selection)
    void
    setActivePart(org.eclipse.jface.action.IAction action, org.eclipse.ui.IWorkbenchPart targetPart)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • ToggleNatureAction

      public ToggleNatureAction()

  • Method Details

    • run

      public void run(org.eclipse.jface.action.IAction action)
      Specified by:
      run in interface org.eclipse.ui.IActionDelegate

    • selectionChanged

      public void selectionChanged(org.eclipse.jface.action.IAction action, org.eclipse.jface.viewers.ISelection selection)
      Specified by:
      selectionChanged in interface org.eclipse.ui.IActionDelegate

    • setActivePart

      public void setActivePart(org.eclipse.jface.action.IAction action, org.eclipse.ui.IWorkbenchPart targetPart)
      Specified by:
      setActivePart in interface org.eclipse.ui.IObjectActionDelegate


WarningResolutionGenerator

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.builder

Class WarningResolutionGenerator

java.lang.Object
com.pvx.ooadide.builder.WarningResolutionGenerator
All Implemented Interfaces:
org.eclipse.ui.IMarkerResolutionGenerator, org.eclipse.ui.IMarkerResolutionGenerator2
public class WarningResolutionGenerator extends Object implements org.eclipse.ui.IMarkerResolutionGenerator2

  • Constructor Summary

    Constructors
    Constructor
    Description
    WarningResolutionGenerator()

  • Method Summary

    Modifier and Type
    Method
    Description
    org.eclipse.ui.IMarkerResolution[]
    getResolutions(org.eclipse.core.resources.IMarker marker)
    boolean
    hasResolutions(org.eclipse.core.resources.IMarker marker)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • WarningResolutionGenerator

      public WarningResolutionGenerator()

  • Method Details

    • getResolutions

      public org.eclipse.ui.IMarkerResolution[] getResolutions(org.eclipse.core.resources.IMarker marker)
      Specified by:
      getResolutions in interface org.eclipse.ui.IMarkerResolutionGenerator

    • hasResolutions

      public boolean hasResolutions(org.eclipse.core.resources.IMarker marker)
      Specified by:
      hasResolutions in interface org.eclipse.ui.IMarkerResolutionGenerator2


Uses of Class com.pvx.ooadide.builder.BuildResourceAction

Uses of Class
com.pvx.ooadide.builder.BuildResourceAction

No usage of com.pvx.ooadide.builder.BuildResourceAction


Uses of Class com.pvx.ooadide.builder.CodeStyleWarningResolution

Uses of Class
com.pvx.ooadide.builder.CodeStyleWarningResolution

No usage of com.pvx.ooadide.builder.CodeStyleWarningResolution


Uses of Interface com.pvx.ooadide.builder.IPvxSaveListener

Uses of Interface
com.pvx.ooadide.builder.IPvxSaveListener

Packages that use IPvxSaveListener
Package
Description
com.pvx.ooadide.builder

  • Uses of IPvxSaveListener in com.pvx.ooadide.builder

    Methods in com.pvx.ooadide.builder with parameters of type IPvxSaveListener
    Modifier and Type
    Method
    Description
    static void
    ProvideXBuilder.addSaveListener(IPvxSaveListener saveListener)
    static void
    ProvideXBuilder.removeSaveListener(IPvxSaveListener saveListener)


Uses of Class com.pvx.ooadide.builder.ProvideXBuilder

Uses of Class
com.pvx.ooadide.builder.ProvideXBuilder

No usage of com.pvx.ooadide.builder.ProvideXBuilder


Uses of Class com.pvx.ooadide.builder.ProvideXNature

Uses of Class
com.pvx.ooadide.builder.ProvideXNature

No usage of com.pvx.ooadide.builder.ProvideXNature


Uses of Class com.pvx.ooadide.builder.PvxPasswordInputDialogue

Uses of Class
com.pvx.ooadide.builder.PvxPasswordInputDialogue

No usage of com.pvx.ooadide.builder.PvxPasswordInputDialogue


Uses of Class com.pvx.ooadide.builder.PvxProblem

Uses of Class
com.pvx.ooadide.builder.PvxProblem

Packages that use PvxProblem
Package
Description
com.pvx.ooadide.builder

  • Uses of PvxProblem in com.pvx.ooadide.builder

    Subclasses of PvxProblem in com.pvx.ooadide.builder
    Modifier and Type
    Class
    Description
    class
    StyleWarning
    Method parameters in com.pvx.ooadide.builder with type arguments of type PvxProblem
    Modifier and Type
    Method
    Description
    static void
    ProvideXBuilder.checkCodeStyle(org.eclipse.core.resources.IFile srcFile, Vector<PvxProblem> msgs)
    String
    ProvideXBuilder.getPrgPassword(org.eclipse.core.resources.IResource resource, Vector<PvxProblem> msgs)
    static String
    ProvideXBuilder.queryForPassword(InputStream in, org.eclipse.core.resources.IFile file, String pathToSrcFile, Vector<PvxProblem> msgs)
    static void
    PvxProblem.scanPvxErrorLogFile(File errorLog, org.eclipse.core.resources.IFile srcFile, Vector<PvxProblem> msgs)
    static void
    PvxProblem.scanPvxErrorLogString(String errorLog, org.eclipse.core.resources.IFile srcFile, Vector<PvxProblem> msgs)
    static void
    StyleWarning.scanWarningLog(File warningLog, org.eclipse.core.resources.IFile srcFile, Vector<PvxProblem> msgs)


Uses of Class com.pvx.ooadide.builder.StyleWarning

Uses of Class
com.pvx.ooadide.builder.StyleWarning

No usage of com.pvx.ooadide.builder.StyleWarning


Uses of Class com.pvx.ooadide.builder.ToggleNatureAction

Uses of Class
com.pvx.ooadide.builder.ToggleNatureAction

No usage of com.pvx.ooadide.builder.ToggleNatureAction


Uses of Class com.pvx.ooadide.builder.WarningResolutionGenerator

Uses of Class
com.pvx.ooadide.builder.WarningResolutionGenerator

No usage of com.pvx.ooadide.builder.WarningResolutionGenerator


Uses of Class com.pvx.ooadide.ConsoleDisplayManager

Uses of Class
com.pvx.ooadide.ConsoleDisplayManager

Packages that use ConsoleDisplayManager
Package
Description
com.pvx.ooadide
com.pvx.ooadide.builder
com.pvx.ooadide.launchers
com.pvx.ooadide.launchers.debug.communication
com.pvx.ooadide.launchers.thinclients

  • Uses of ConsoleDisplayManager in com.pvx.ooadide

    Methods in com.pvx.ooadide that return ConsoleDisplayManager
    Modifier and Type
    Method
    Description
    static ConsoleDisplayManager
    ConsoleDisplayManager.getDefault()

  • Uses of ConsoleDisplayManager in com.pvx.ooadide.builder

    Methods in com.pvx.ooadide.builder with parameters of type ConsoleDisplayManager
    Modifier and Type
    Method
    Description
    boolean
    ProvideXBuilder.checkPVX(org.eclipse.core.resources.IResource resource, ConsoleDisplayManager console)

  • Uses of ConsoleDisplayManager in com.pvx.ooadide.launchers

    Methods in com.pvx.ooadide.launchers with parameters of type ConsoleDisplayManager
    Modifier and Type
    Method
    Description
    String
    ProvideXLaunchConfigurationDelegate1.generateCommandLine(org.eclipse.debug.core.ILaunchConfiguration configuration, org.eclipse.debug.core.ILaunch launch, ConsoleDisplayManager console, org.eclipse.core.resources.IProject project, String prgName, String prg, int requestPort, int eventPort)
    String[]
    ProvideXLaunchConfigurationDelegate1.generateCommandLineArray(org.eclipse.debug.core.ILaunchConfiguration configuration, ConsoleDisplayManager console, org.eclipse.core.resources.IProject project, String prgName, String prg)

  • Uses of ConsoleDisplayManager in com.pvx.ooadide.launchers.debug.communication

    Constructors in com.pvx.ooadide.launchers.debug.communication with parameters of type ConsoleDisplayManager
    Modifier
    Constructor
    Description

    DebugLauncherThread(String dir, int port, ConsoleDisplayManager console, String name, int port2, String line, org.eclipse.debug.core.ILaunch launch, String args)

  • Uses of ConsoleDisplayManager in com.pvx.ooadide.launchers.thinclients

    Methods in com.pvx.ooadide.launchers.thinclients with parameters of type ConsoleDisplayManager
    Modifier and Type
    Method
    Description
    String
    WindXLaunchConfigurationDelegate1.generateCommandLine(org.eclipse.debug.core.ILaunchConfiguration configuration, org.eclipse.debug.core.ILaunch launch, ConsoleDisplayManager console, org.eclipse.core.resources.IProject project, String prgName, String prg, int requestPort, int eventPort)
    Constructors in com.pvx.ooadide.launchers.thinclients with parameters of type ConsoleDisplayManager
    Modifier
    Constructor
    Description

    DebugWindXLauncherThread(String dir, int port, ConsoleDisplayManager console, String name, int port2, String line, org.eclipse.debug.core.ILaunch launch, String args)


Uses of Class com.pvx.ooadide.Constants

Uses of Class
com.pvx.ooadide.Constants

No usage of com.pvx.ooadide.Constants


Uses of Interface com.pvx.ooadide.IPvxIdePlugin

Uses of Interface
com.pvx.ooadide.IPvxIdePlugin

Packages that use IPvxIdePlugin
Package
Description
com.pvx.ooadide
com.pvx.ooadide.editors.extkeyword
com.pvx.ooadide.eventmanager

  • Uses of IPvxIdePlugin in com.pvx.ooadide

    Classes in com.pvx.ooadide that implement IPvxIdePlugin
    Modifier and Type
    Class
    Description
    class
    ProvideXOOADPlugin
    Methods in com.pvx.ooadide that return types with arguments of type IPvxIdePlugin
    Modifier and Type
    Method
    Description
    static ArrayList<IPvxIdePlugin>
    ProvideXOOADPlugin.getDependentPluginList()
    static ArrayList<IPvxIdePlugin>
    ProvideXOOADPlugin.getPluginsContributingKeywords()
    Methods in com.pvx.ooadide with parameters of type IPvxIdePlugin
    Modifier and Type
    Method
    Description
    void
    ProvideXOOADPlugin.addDependentPlugin(IPvxIdePlugin aPlugin)

  • Uses of IPvxIdePlugin in com.pvx.ooadide.editors.extkeyword

    Methods in com.pvx.ooadide.editors.extkeyword that return IPvxIdePlugin
    Modifier and Type
    Method
    Description
    IPvxIdePlugin
    ExtKeywordCategoryEntity.getFPlugin()
    Methods in com.pvx.ooadide.editors.extkeyword with parameters of type IPvxIdePlugin
    Modifier and Type
    Method
    Description
    void
    ExtKeywordCategoryEntity.setFPlugin(IPvxIdePlugin fPlugin)
    Constructors in com.pvx.ooadide.editors.extkeyword with parameters of type IPvxIdePlugin
    Modifier
    Constructor
    Description

    ExtKeywordCategoryEntity(String nxtKey, String path, org.eclipse.swt.graphics.Image initImage, IPvxIdePlugin initfPlugin)

  • Uses of IPvxIdePlugin in com.pvx.ooadide.eventmanager

    Methods in com.pvx.ooadide.eventmanager that return types with arguments of type IPvxIdePlugin
    Modifier and Type
    Method
    Description
    static ArrayList<IPvxIdePlugin>
    ResourceManager.getDependentPlugins()


Uses of Class com.pvx.ooadide.ProvideXOOADPlugin

Uses of Class
com.pvx.ooadide.ProvideXOOADPlugin

Packages that use ProvideXOOADPlugin
Package
Description
com.pvx.ooadide

  • Uses of ProvideXOOADPlugin in com.pvx.ooadide

    Methods in com.pvx.ooadide that return ProvideXOOADPlugin
    Modifier and Type
    Method
    Description
    static ProvideXOOADPlugin
    ProvideXOOADPlugin.getPvxPluginInstance()


ColorManager

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.codehilite2

Class ColorManager

java.lang.Object
org.eclipse.jdt.internal.ui.text.JavaColorManager
com.pvx.ooadide.codehilite2.ColorManager
All Implemented Interfaces:
org.eclipse.jdt.ui.text.IColorManager, org.eclipse.jdt.ui.text.IColorManagerExtension, org.eclipse.jface.text.source.ISharedTextColors
public class ColorManager extends org.eclipse.jdt.internal.ui.text.JavaColorManager

  • Constructor Summary

    Constructors
    Constructor
    Description
    ColorManager()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    dispose()
    org.eclipse.swt.graphics.Color
    getColor(String key)
    org.eclipse.swt.graphics.Color
    getColor(org.eclipse.swt.graphics.RGB rgb)

    Methods inherited from class org.eclipse.jdt.internal.ui.text.JavaColorManager

    bindColor, dispose, unbindColor

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • ColorManager

      public ColorManager()

  • Method Details

    • dispose

      public void dispose()
      Specified by:
      dispose in interface org.eclipse.jface.text.source.ISharedTextColors
      Overrides:
      dispose in class org.eclipse.jdt.internal.ui.text.JavaColorManager

    • getColor

      public org.eclipse.swt.graphics.Color getColor(org.eclipse.swt.graphics.RGB rgb)
      Specified by:
      getColor in interface org.eclipse.jface.text.source.ISharedTextColors
      Overrides:
      getColor in class org.eclipse.jdt.internal.ui.text.JavaColorManager

    • getColor

      public org.eclipse.swt.graphics.Color getColor(String key)
      Specified by:
      getColor in interface org.eclipse.jdt.ui.text.IColorManager
      Overrides:
      getColor in class org.eclipse.jdt.internal.ui.text.JavaColorManager


ColourTokenFactory

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.codehilite2

Class ColourTokenFactory

java.lang.Object
com.pvx.ooadide.codehilite2.ColourTokenFactory
public class ColourTokenFactory extends Object

  • Constructor Summary

    Constructors
    Constructor
    Description
    ColourTokenFactory()

  • Method Summary

    Modifier and Type
    Method
    Description
    static final org.eclipse.jface.text.rules.Token
    makeColorToken(String boldKey, String italicKey, String fgColorKey, String bgColorKey, String strikeKey, String underLineKey)
    static final org.eclipse.jface.text.rules.Token
    makeColorToken(String boldKey, String italicKey, String fgColorKey, String bgColorKey, String strikeKey, String underLineKey, org.eclipse.jface.preference.IPreferenceStore store)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • ColourTokenFactory

      public ColourTokenFactory()

  • Method Details

    • makeColorToken

      public static final org.eclipse.jface.text.rules.Token makeColorToken(String boldKey, String italicKey, String fgColorKey, String bgColorKey, String strikeKey, String underLineKey)

    • makeColorToken

      public static final org.eclipse.jface.text.rules.Token makeColorToken(String boldKey, String italicKey, String fgColorKey, String bgColorKey, String strikeKey, String underLineKey, org.eclipse.jface.preference.IPreferenceStore store)


ExtKeywordCompoundRule

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.codehilite2

Class ExtKeywordCompoundRule

java.lang.Object
com.pvx.ooadide.codehilite2.PvxWordRule
com.pvx.ooadide.codehilite2.ExtKeywordRule
com.pvx.ooadide.codehilite2.ExtKeywordCompoundRule
All Implemented Interfaces:
org.eclipse.jface.text.rules.IRule
public class ExtKeywordCompoundRule extends ExtKeywordRule

  • Constructor Summary

    Constructors
    Constructor
    Description
    ExtKeywordCompoundRule(org.eclipse.jface.text.rules.IWordDetector wordDetector)

  • Method Summary

    Methods inherited from class com.pvx.ooadide.codehilite2.ExtKeywordRule

    evaluate

    Methods inherited from class com.pvx.ooadide.codehilite2.PvxWordRule

    addWord, setColumnConstraint

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • ExtKeywordCompoundRule

      public ExtKeywordCompoundRule(org.eclipse.jface.text.rules.IWordDetector wordDetector)


ExtKeywordDetector

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.codehilite2

Class ExtKeywordDetector

java.lang.Object
com.pvx.ooadide.codehilite2.ExtKeywordDetector
All Implemented Interfaces:
org.eclipse.jface.text.rules.IWordDetector
public class ExtKeywordDetector extends Object implements org.eclipse.jface.text.rules.IWordDetector

  • Constructor Summary

    Constructors
    Constructor
    Description
    ExtKeywordDetector(boolean b)

  • Method Summary

    Modifier and Type
    Method
    Description
    boolean
    isWordPart(char c)
    boolean
    isWordStart(char c)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • ExtKeywordDetector

      public ExtKeywordDetector(boolean b)

  • Method Details

    • isWordStart

      public boolean isWordStart(char c)
      Specified by:
      isWordStart in interface org.eclipse.jface.text.rules.IWordDetector

    • isWordPart

      public boolean isWordPart(char c)
      Specified by:
      isWordPart in interface org.eclipse.jface.text.rules.IWordDetector


ExtKeywordRule

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.codehilite2

Class ExtKeywordRule

java.lang.Object
com.pvx.ooadide.codehilite2.PvxWordRule
com.pvx.ooadide.codehilite2.ExtKeywordRule
All Implemented Interfaces:
org.eclipse.jface.text.rules.IRule
Direct Known Subclasses:
ExtKeywordCompoundRule
public class ExtKeywordRule extends PvxWordRule

  • Constructor Summary

    Constructors
    Constructor
    Description
    ExtKeywordRule(org.eclipse.jface.text.rules.IWordDetector wordDetector)

  • Method Summary

    Modifier and Type
    Method
    Description
    org.eclipse.jface.text.rules.IToken
    evaluate(org.eclipse.jface.text.rules.ICharacterScanner scanner)

    Methods inherited from class com.pvx.ooadide.codehilite2.PvxWordRule

    addWord, setColumnConstraint

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • ExtKeywordRule

      public ExtKeywordRule(org.eclipse.jface.text.rules.IWordDetector wordDetector)

  • Method Details

    • evaluate

      public org.eclipse.jface.text.rules.IToken evaluate(org.eclipse.jface.text.rules.ICharacterScanner scanner)
      Specified by:
      evaluate in interface org.eclipse.jface.text.rules.IRule
      Overrides:
      evaluate in class PvxWordRule


com.pvx.ooadide.codehilite2

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.pvx.ooadide.codehilite2

package com.pvx.ooadide.codehilite2
  • Related Packages
    Package
    Description
    com.pvx.ooadide
  • Classes
    Class
    Description
    ColorManager
    ColourTokenFactory
    ExtKeywordCompoundRule
    ExtKeywordDetector
    ExtKeywordRule
    PvxContentAssistant
    PvxDirectiveWordRule
    PvxDirectiveWordRule.DirectiveWordDetector
    PvxEolRule
    PvxInfoPresenter
    PvxLineLabelWordRule
    PvxLineLabelWordRule.LineLabelWordDetector
    PvxMnemonicRule
    PvxMnemonicRule.MnemonicWordDetector
    PvxNumbLiteralRule
    PvxNumbLiteralRule.numbWordDetector
    PvxWordRule
    XMLConfiguration2
    XMLDoubleClickStrategy


com.pvx.ooadide.codehilite2 Class Hierarchy

Hierarchy For Package com.pvx.ooadide.codehilite2

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • com.pvx.ooadide.codehilite2.ColourTokenFactory
    • org.eclipse.jface.text.contentassist.ContentAssistant (implements org.eclipse.jface.text.contentassist.IContentAssistant, org.eclipse.jface.text.contentassist.IContentAssistantExtension, org.eclipse.jface.text.contentassist.IContentAssistantExtension2, org.eclipse.jface.text.contentassist.IContentAssistantExtension3, org.eclipse.jface.text.contentassist.IContentAssistantExtension4, org.eclipse.jface.text.IWidgetTokenKeeper, org.eclipse.jface.text.IWidgetTokenKeeperExtension)
      • com.pvx.ooadide.codehilite2.PvxContentAssistant
    • com.pvx.ooadide.codehilite2.ExtKeywordDetector (implements org.eclipse.jface.text.rules.IWordDetector)
    • org.eclipse.jdt.internal.ui.text.JavaColorManager (implements org.eclipse.jdt.ui.text.IColorManager, org.eclipse.jdt.ui.text.IColorManagerExtension)
      • com.pvx.ooadide.codehilite2.ColorManager
    • org.eclipse.jdt.internal.ui.text.JavaWordDetector (implements org.eclipse.jface.text.rules.IWordDetector)
      • com.pvx.ooadide.codehilite2.PvxDirectiveWordRule.DirectiveWordDetector
    • org.eclipse.jface.text.rules.PatternRule (implements org.eclipse.jface.text.rules.IPredicateRule)
      • org.eclipse.jface.text.rules.SingleLineRule
        • com.pvx.ooadide.codehilite2.PvxEolRule
    • com.pvx.ooadide.codehilite2.PvxInfoPresenter (implements org.eclipse.jface.text.DefaultInformationControl.IInformationPresenter)
    • com.pvx.ooadide.codehilite2.PvxLineLabelWordRule.LineLabelWordDetector (implements org.eclipse.jface.text.rules.IWordDetector)
    • com.pvx.ooadide.codehilite2.PvxMnemonicRule.MnemonicWordDetector (implements org.eclipse.jface.text.rules.IWordDetector)
    • com.pvx.ooadide.codehilite2.PvxNumbLiteralRule.numbWordDetector (implements org.eclipse.jface.text.rules.IWordDetector)
    • com.pvx.ooadide.codehilite2.PvxWordRule (implements org.eclipse.jface.text.rules.IRule)
      • com.pvx.ooadide.codehilite2.ExtKeywordRule
        • com.pvx.ooadide.codehilite2.ExtKeywordCompoundRule
      • com.pvx.ooadide.codehilite2.PvxDirectiveWordRule
      • com.pvx.ooadide.codehilite2.PvxLineLabelWordRule
      • com.pvx.ooadide.codehilite2.PvxMnemonicRule
      • com.pvx.ooadide.codehilite2.PvxNumbLiteralRule
    • org.eclipse.jface.text.source.SourceViewerConfiguration
      • com.pvx.ooadide.codehilite2.XMLConfiguration2
    • com.pvx.ooadide.codehilite2.XMLDoubleClickStrategy (implements org.eclipse.jface.text.ITextDoubleClickStrategy)


Uses of Package com.pvx.ooadide.codehilite2

Uses of Package
com.pvx.ooadide.codehilite2

Packages that use com.pvx.ooadide.codehilite2
Package
Description
com.pvx.ooadide.codehilite2
  • Classes in com.pvx.ooadide.codehilite2 used by com.pvx.ooadide.codehilite2
    Class
    Description
    ColorManager
    ExtKeywordRule
    PvxWordRule


PvxContentAssistant

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.codehilite2

Class PvxContentAssistant

java.lang.Object
org.eclipse.jface.text.contentassist.ContentAssistant
com.pvx.ooadide.codehilite2.PvxContentAssistant
All Implemented Interfaces:
org.eclipse.jface.text.contentassist.IContentAssistant, org.eclipse.jface.text.contentassist.IContentAssistantExtension, org.eclipse.jface.text.contentassist.IContentAssistantExtension2, org.eclipse.jface.text.contentassist.IContentAssistantExtension3, org.eclipse.jface.text.contentassist.IContentAssistantExtension4, org.eclipse.jface.text.IWidgetTokenKeeper, org.eclipse.jface.text.IWidgetTokenKeeperExtension
public class PvxContentAssistant extends org.eclipse.jface.text.contentassist.ContentAssistant

  • Field Summary

    Fields inherited from class org.eclipse.jface.text.contentassist.ContentAssistant

    SELECT_NEXT_PROPOSAL_COMMAND_ID, SELECT_PREVIOUS_PROPOSAL_COMMAND_ID, STORE_CONTEXT_SELECTOR_POPUP_SIZE_X, STORE_CONTEXT_SELECTOR_POPUP_SIZE_Y, STORE_SIZE_X, STORE_SIZE_Y, WIDGET_PRIORITY

    Fields inherited from interface org.eclipse.jface.text.contentassist.IContentAssistant

    CONTEXT_INFO_ABOVE, CONTEXT_INFO_BELOW, PROPOSAL_OVERLAY, PROPOSAL_REMOVE, PROPOSAL_STACKED

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxContentAssistant()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    setContentAssistProcessor(org.eclipse.jface.text.contentassist.IContentAssistProcessor processor, String contentType)
    String
    showPossibleCompletions()

    Methods inherited from class org.eclipse.jface.text.contentassist.ContentAssistant

    addCompletionListener, addContentAssistProcessor, completePrefix, enableAutoActivation, enableAutoInsert, enableColoredLabels, enablePrefixCompletion, getAutoActivationDelay, getContentAssistProcessor, getDocumentPartitioning, getHandler, hasProposalPopupFocus, install, removeCompletionListener, requestWidgetToken, requestWidgetToken, setAutoActivationDelay, setContextInformationPopupBackground, setContextInformationPopupForeground, setContextInformationPopupOrientation, setContextSelectorBackground, setContextSelectorForeground, setDocumentPartitioning, setEmptyMessage, setFocus, setInformationControlCreator, setProposalPopupOrientation, setProposalSelectorBackground, setProposalSelectorForeground, setRepeatedInvocationMode, setRepeatedInvocationTrigger, setRestoreCompletionProposalSize, setShowEmptyList, setSorter, setStatusLineVisible, setStatusMessage, showContextInformation, uninstall

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • PvxContentAssistant

      public PvxContentAssistant()

  • Method Details

    • setContentAssistProcessor

      public void setContentAssistProcessor(org.eclipse.jface.text.contentassist.IContentAssistProcessor processor, String contentType)
      Overrides:
      setContentAssistProcessor in class org.eclipse.jface.text.contentassist.ContentAssistant

    • showPossibleCompletions

      public String showPossibleCompletions()
      Specified by:
      showPossibleCompletions in interface org.eclipse.jface.text.contentassist.IContentAssistant
      Overrides:
      showPossibleCompletions in class org.eclipse.jface.text.contentassist.ContentAssistant


PvxDirectiveWordRule

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.codehilite2

Class PvxDirectiveWordRule

java.lang.Object
com.pvx.ooadide.codehilite2.PvxWordRule
com.pvx.ooadide.codehilite2.PvxDirectiveWordRule
All Implemented Interfaces:
org.eclipse.jface.text.rules.IRule
public class PvxDirectiveWordRule extends PvxWordRule

  • Nested Class Summary

    Nested Classes
    Modifier and Type
    Class
    Description
    static class
    PvxDirectiveWordRule.DirectiveWordDetector

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxDirectiveWordRule()

  • Method Summary

    Modifier and Type
    Method
    Description
    org.eclipse.jface.text.rules.IToken
    evaluate(org.eclipse.jface.text.rules.ICharacterScanner scanner)

    Methods inherited from class com.pvx.ooadide.codehilite2.PvxWordRule

    addWord, setColumnConstraint

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • PvxDirectiveWordRule

      public PvxDirectiveWordRule()

  • Method Details

    • evaluate

      public org.eclipse.jface.text.rules.IToken evaluate(org.eclipse.jface.text.rules.ICharacterScanner scanner)
      Specified by:
      evaluate in interface org.eclipse.jface.text.rules.IRule
      Overrides:
      evaluate in class PvxWordRule


PvxDirectiveWordRule.DirectiveWordDetector

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.codehilite2

Class PvxDirectiveWordRule.DirectiveWordDetector

java.lang.Object
org.eclipse.jdt.internal.ui.text.JavaWordDetector
com.pvx.ooadide.codehilite2.PvxDirectiveWordRule.DirectiveWordDetector
All Implemented Interfaces:
org.eclipse.jface.text.rules.IWordDetector
Enclosing class:
PvxDirectiveWordRule
public static class PvxDirectiveWordRule.DirectiveWordDetector extends org.eclipse.jdt.internal.ui.text.JavaWordDetector

  • Constructor Summary

    Constructors
    Constructor
    Description
    DirectiveWordDetector()

  • Method Summary

    Modifier and Type
    Method
    Description
    boolean
    isWordPart(char c)
    boolean
    isWordStart(char c)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • DirectiveWordDetector

      public DirectiveWordDetector()

  • Method Details

    • isWordStart

      public boolean isWordStart(char c)
      Specified by:
      isWordStart in interface org.eclipse.jface.text.rules.IWordDetector
      Overrides:
      isWordStart in class org.eclipse.jdt.internal.ui.text.JavaWordDetector

    • isWordPart

      public boolean isWordPart(char c)
      Specified by:
      isWordPart in interface org.eclipse.jface.text.rules.IWordDetector
      Overrides:
      isWordPart in class org.eclipse.jdt.internal.ui.text.JavaWordDetector


PvxEolRule

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.codehilite2

Class PvxEolRule

java.lang.Object
org.eclipse.jface.text.rules.PatternRule
org.eclipse.jface.text.rules.SingleLineRule
com.pvx.ooadide.codehilite2.PvxEolRule
All Implemented Interfaces:
org.eclipse.jface.text.rules.IPredicateRule, org.eclipse.jface.text.rules.IRule
public class PvxEolRule extends org.eclipse.jface.text.rules.SingleLineRule

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxEolRule(String startSequence, String endSequence, org.eclipse.jface.text.rules.IToken token)
    PvxEolRule(String startSequence, String endSequence, org.eclipse.jface.text.rules.Token comment_token, char c, boolean b, boolean d)

  • Method Summary

    Modifier and Type
    Method
    Description
    org.eclipse.jface.text.rules.IToken
    evaluate(org.eclipse.jface.text.rules.ICharacterScanner scanner)

    Methods inherited from class org.eclipse.jface.text.rules.PatternRule

    evaluate, getSuccessToken, setColumnConstraint

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • PvxEolRule

      public PvxEolRule(String startSequence, String endSequence, org.eclipse.jface.text.rules.IToken token)

    • PvxEolRule

      public PvxEolRule(String startSequence, String endSequence, org.eclipse.jface.text.rules.Token comment_token, char c, boolean b, boolean d)

  • Method Details

    • evaluate

      public org.eclipse.jface.text.rules.IToken evaluate(org.eclipse.jface.text.rules.ICharacterScanner scanner)
      Specified by:
      evaluate in interface org.eclipse.jface.text.rules.IRule
      Overrides:
      evaluate in class org.eclipse.jface.text.rules.PatternRule


PvxInfoPresenter

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.codehilite2

Class PvxInfoPresenter

java.lang.Object
com.pvx.ooadide.codehilite2.PvxInfoPresenter
All Implemented Interfaces:
org.eclipse.jface.text.DefaultInformationControl.IInformationPresenter
public class PvxInfoPresenter extends Object implements org.eclipse.jface.text.DefaultInformationControl.IInformationPresenter

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxInfoPresenter()

  • Method Summary

    Modifier and Type
    Method
    Description
    String
    updatePresentation(org.eclipse.swt.widgets.Display display, String infoText, org.eclipse.jface.text.TextPresentation presentation, int maxWidth, int maxHeight)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • PvxInfoPresenter

      public PvxInfoPresenter()

  • Method Details

    • updatePresentation

      public String updatePresentation(org.eclipse.swt.widgets.Display display, String infoText, org.eclipse.jface.text.TextPresentation presentation, int maxWidth, int maxHeight)
      Specified by:
      updatePresentation in interface org.eclipse.jface.text.DefaultInformationControl.IInformationPresenter


PvxLineLabelWordRule

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.codehilite2

Class PvxLineLabelWordRule

java.lang.Object
com.pvx.ooadide.codehilite2.PvxWordRule
com.pvx.ooadide.codehilite2.PvxLineLabelWordRule
All Implemented Interfaces:
org.eclipse.jface.text.rules.IRule
public class PvxLineLabelWordRule extends PvxWordRule

  • Nested Class Summary

    Nested Classes
    Modifier and Type
    Class
    Description
    static class
    PvxLineLabelWordRule.LineLabelWordDetector

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxLineLabelWordRule()

  • Method Summary

    Modifier and Type
    Method
    Description
    org.eclipse.jface.text.rules.IToken
    evaluate(org.eclipse.jface.text.rules.ICharacterScanner scanner)

    Methods inherited from class com.pvx.ooadide.codehilite2.PvxWordRule

    addWord, setColumnConstraint

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • PvxLineLabelWordRule

      public PvxLineLabelWordRule()

  • Method Details

    • evaluate

      public org.eclipse.jface.text.rules.IToken evaluate(org.eclipse.jface.text.rules.ICharacterScanner scanner)
      Specified by:
      evaluate in interface org.eclipse.jface.text.rules.IRule
      Overrides:
      evaluate in class PvxWordRule


PvxLineLabelWordRule.LineLabelWordDetector

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.codehilite2

Class PvxLineLabelWordRule.LineLabelWordDetector

java.lang.Object
com.pvx.ooadide.codehilite2.PvxLineLabelWordRule.LineLabelWordDetector
All Implemented Interfaces:
org.eclipse.jface.text.rules.IWordDetector
Enclosing class:
PvxLineLabelWordRule
public static class PvxLineLabelWordRule.LineLabelWordDetector extends Object implements org.eclipse.jface.text.rules.IWordDetector

  • Constructor Summary

    Constructors
    Constructor
    Description
    LineLabelWordDetector()

  • Method Summary

    Modifier and Type
    Method
    Description
    boolean
    isWordPart(char c)
    boolean
    isWordStart(char c)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • LineLabelWordDetector

      public LineLabelWordDetector()

  • Method Details

    • isWordStart

      public boolean isWordStart(char c)
      Specified by:
      isWordStart in interface org.eclipse.jface.text.rules.IWordDetector

    • isWordPart

      public boolean isWordPart(char c)
      Specified by:
      isWordPart in interface org.eclipse.jface.text.rules.IWordDetector


PvxMnemonicRule

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.codehilite2

Class PvxMnemonicRule

java.lang.Object
com.pvx.ooadide.codehilite2.PvxWordRule
com.pvx.ooadide.codehilite2.PvxMnemonicRule
All Implemented Interfaces:
org.eclipse.jface.text.rules.IRule
public class PvxMnemonicRule extends PvxWordRule

  • Nested Class Summary

    Nested Classes
    Modifier and Type
    Class
    Description
    static class
    PvxMnemonicRule.MnemonicWordDetector

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxMnemonicRule()

  • Method Summary

    Methods inherited from class com.pvx.ooadide.codehilite2.PvxWordRule

    addWord, evaluate, setColumnConstraint

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • PvxMnemonicRule

      public PvxMnemonicRule()


PvxMnemonicRule.MnemonicWordDetector

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.codehilite2

Class PvxMnemonicRule.MnemonicWordDetector

java.lang.Object
com.pvx.ooadide.codehilite2.PvxMnemonicRule.MnemonicWordDetector
All Implemented Interfaces:
org.eclipse.jface.text.rules.IWordDetector
Enclosing class:
PvxMnemonicRule
public static class PvxMnemonicRule.MnemonicWordDetector extends Object implements org.eclipse.jface.text.rules.IWordDetector

  • Constructor Summary

    Constructors
    Constructor
    Description
    MnemonicWordDetector()

  • Method Summary

    Modifier and Type
    Method
    Description
    boolean
    isWordPart(char c)
    boolean
    isWordStart(char c)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • MnemonicWordDetector

      public MnemonicWordDetector()

  • Method Details

    • isWordStart

      public boolean isWordStart(char c)
      Specified by:
      isWordStart in interface org.eclipse.jface.text.rules.IWordDetector

    • isWordPart

      public boolean isWordPart(char c)
      Specified by:
      isWordPart in interface org.eclipse.jface.text.rules.IWordDetector


PvxNumbLiteralRule

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.codehilite2

Class PvxNumbLiteralRule

java.lang.Object
com.pvx.ooadide.codehilite2.PvxWordRule
com.pvx.ooadide.codehilite2.PvxNumbLiteralRule
All Implemented Interfaces:
org.eclipse.jface.text.rules.IRule
public class PvxNumbLiteralRule extends PvxWordRule

  • Nested Class Summary

    Nested Classes
    Modifier and Type
    Class
    Description
    static class
    PvxNumbLiteralRule.numbWordDetector

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxNumbLiteralRule()

  • Method Summary

    Modifier and Type
    Method
    Description
    org.eclipse.jface.text.rules.IToken
    evaluate(org.eclipse.jface.text.rules.ICharacterScanner scanner)

    Methods inherited from class com.pvx.ooadide.codehilite2.PvxWordRule

    addWord, setColumnConstraint

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • PvxNumbLiteralRule

      public PvxNumbLiteralRule()

  • Method Details

    • evaluate

      public org.eclipse.jface.text.rules.IToken evaluate(org.eclipse.jface.text.rules.ICharacterScanner scanner)
      Specified by:
      evaluate in interface org.eclipse.jface.text.rules.IRule
      Overrides:
      evaluate in class PvxWordRule


PvxNumbLiteralRule.numbWordDetector

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.codehilite2

Class PvxNumbLiteralRule.numbWordDetector

java.lang.Object
com.pvx.ooadide.codehilite2.PvxNumbLiteralRule.numbWordDetector
All Implemented Interfaces:
org.eclipse.jface.text.rules.IWordDetector
Enclosing class:
PvxNumbLiteralRule
public static class PvxNumbLiteralRule.numbWordDetector extends Object implements org.eclipse.jface.text.rules.IWordDetector

  • Constructor Summary

    Constructors
    Constructor
    Description
    numbWordDetector()

  • Method Summary

    Modifier and Type
    Method
    Description
    boolean
    isWordPart(char c)
    boolean
    isWordStart(char c)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • numbWordDetector

      public numbWordDetector()

  • Method Details

    • isWordStart

      public boolean isWordStart(char c)
      Specified by:
      isWordStart in interface org.eclipse.jface.text.rules.IWordDetector

    • isWordPart

      public boolean isWordPart(char c)
      Specified by:
      isWordPart in interface org.eclipse.jface.text.rules.IWordDetector


PvxWordRule

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.codehilite2

Class PvxWordRule

java.lang.Object
com.pvx.ooadide.codehilite2.PvxWordRule
All Implemented Interfaces:
org.eclipse.jface.text.rules.IRule
Direct Known Subclasses:
ExtKeywordRule, PvxDirectiveWordRule, PvxLineLabelWordRule, PvxMnemonicRule, PvxNumbLiteralRule
public class PvxWordRule extends Object implements org.eclipse.jface.text.rules.IRule

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxWordRule(org.eclipse.jface.text.rules.IWordDetector detector)
    Creates a rule which, with the help of an word detector, will return the token associated with the detected word.
    PvxWordRule(org.eclipse.jface.text.rules.IWordDetector detector, org.eclipse.jface.text.rules.IToken defaultToken)
    Creates a rule which, with the help of a word detector, will return the token associated with the detected word.

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    addWord(String word, org.eclipse.jface.text.rules.IToken token)
    Adds a word and the token to be returned if it is detected.
    org.eclipse.jface.text.rules.IToken
    evaluate(org.eclipse.jface.text.rules.ICharacterScanner scanner)
    void
    setColumnConstraint(int column)
    Sets a column constraint for this rule.

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • PvxWordRule

      public PvxWordRule(org.eclipse.jface.text.rules.IWordDetector detector)
      Creates a rule which, with the help of an word detector, will return the token associated with the detected word. If no token has been associated, the scanner will be rolled back and an undefined token will be returned in order to allow any subsequent rules to analyze the characters.
      Parameters:
      detector - the word detector to be used by this rule, may not be null
      See Also:
      • addWord(String, IToken)

    • PvxWordRule

      public PvxWordRule(org.eclipse.jface.text.rules.IWordDetector detector, org.eclipse.jface.text.rules.IToken defaultToken)
      Creates a rule which, with the help of a word detector, will return the token associated with the detected word. If no token has been associated, the specified default token will be returned.
      Parameters:
      detector - the word detector to be used by this rule, may not be null
      defaultToken - the default token to be returned on success if nothing else is specified, may not be null
      See Also:
      • addWord(String, IToken)

  • Method Details

    • addWord

      public void addWord(String word, org.eclipse.jface.text.rules.IToken token)
      Adds a word and the token to be returned if it is detected.
      Parameters:
      word - the word this rule will search for, may not be null
      token - the token to be returned if the word has been found, may not be null

    • setColumnConstraint

      public void setColumnConstraint(int column)
      Sets a column constraint for this rule. If set, the rule's token will only be returned if the pattern is detected starting at the specified column. If the column is smaller then 0, the column constraint is considered removed.
      Parameters:
      column - the column in which the pattern starts

    • evaluate

      public org.eclipse.jface.text.rules.IToken evaluate(org.eclipse.jface.text.rules.ICharacterScanner scanner)
      Specified by:
      evaluate in interface org.eclipse.jface.text.rules.IRule


XMLConfiguration2

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.codehilite2

Class XMLConfiguration2

java.lang.Object
org.eclipse.jface.text.source.SourceViewerConfiguration
com.pvx.ooadide.codehilite2.XMLConfiguration2
public class XMLConfiguration2 extends org.eclipse.jface.text.source.SourceViewerConfiguration

  • Constructor Summary

    Constructors
    Constructor
    Description
    XMLConfiguration2(ColorManager colorManager, PvxEditor init_pvxEditor)

  • Method Summary

    Modifier and Type
    Method
    Description
    org.eclipse.jface.text.source.IAnnotationHover
    getAnnotationHover(org.eclipse.jface.text.source.ISourceViewer sourceViewer)
    org.eclipse.jface.text.IAutoEditStrategy[]
    getAutoEditStrategies(org.eclipse.jface.text.source.ISourceViewer sourceViewer, String contentType)
    org.eclipse.jface.text.contentassist.IContentAssistant
    getContentAssistant(org.eclipse.jface.text.source.ISourceViewer sourceViewer)
    org.eclipse.jface.text.ITextDoubleClickStrategy
    getDoubleClickStrategy(org.eclipse.jface.text.source.ISourceViewer sourceViewer, String contentType)
    org.eclipse.jface.text.IInformationControlCreator
    getInformationControlCreator(org.eclipse.jface.text.source.ISourceViewer sourceViewer)
    org.eclipse.jface.text.presentation.IPresentationReconciler
    getPresentationReconciler(org.eclipse.jface.text.source.ISourceViewer sourceViewer)
    org.eclipse.jface.text.reconciler.IReconciler
    getReconciler(org.eclipse.jface.text.source.ISourceViewer sourceViewer)
    org.eclipse.jface.text.ITextHover
    getTextHover(org.eclipse.jface.text.source.ISourceViewer sourceViewer, String contentType)
    org.eclipse.jface.text.ITextHover
    getTextHover(org.eclipse.jface.text.source.ISourceViewer sourceViewer, String contentType, int stateMask)

    Methods inherited from class org.eclipse.jface.text.source.SourceViewerConfiguration

    getCodeMiningProviders, getConfiguredContentTypes, getConfiguredDocumentPartitioning, getConfiguredTextHoverStateMasks, getContentFormatter, getDefaultPrefixes, getHyperlinkDetectors, getHyperlinkPresenter, getHyperlinkStateMask, getIndentPrefixes, getInformationPresenter, getOverviewRulerAnnotationHover, getQuickAssistAssistant, getTabWidth, getUndoManager

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • XMLConfiguration2

      public XMLConfiguration2(ColorManager colorManager, PvxEditor init_pvxEditor)

  • Method Details

    • getDoubleClickStrategy

      public org.eclipse.jface.text.ITextDoubleClickStrategy getDoubleClickStrategy(org.eclipse.jface.text.source.ISourceViewer sourceViewer, String contentType)
      Overrides:
      getDoubleClickStrategy in class org.eclipse.jface.text.source.SourceViewerConfiguration

    • getPresentationReconciler

      public org.eclipse.jface.text.presentation.IPresentationReconciler getPresentationReconciler(org.eclipse.jface.text.source.ISourceViewer sourceViewer)
      Overrides:
      getPresentationReconciler in class org.eclipse.jface.text.source.SourceViewerConfiguration

    • getContentAssistant

      public org.eclipse.jface.text.contentassist.IContentAssistant getContentAssistant(org.eclipse.jface.text.source.ISourceViewer sourceViewer)
      Overrides:
      getContentAssistant in class org.eclipse.jface.text.source.SourceViewerConfiguration

    • getInformationControlCreator

      public org.eclipse.jface.text.IInformationControlCreator getInformationControlCreator(org.eclipse.jface.text.source.ISourceViewer sourceViewer)
      Overrides:
      getInformationControlCreator in class org.eclipse.jface.text.source.SourceViewerConfiguration

    • getTextHover

      public org.eclipse.jface.text.ITextHover getTextHover(org.eclipse.jface.text.source.ISourceViewer sourceViewer, String contentType)
      Overrides:
      getTextHover in class org.eclipse.jface.text.source.SourceViewerConfiguration

    • getTextHover

      public org.eclipse.jface.text.ITextHover getTextHover(org.eclipse.jface.text.source.ISourceViewer sourceViewer, String contentType, int stateMask)
      Overrides:
      getTextHover in class org.eclipse.jface.text.source.SourceViewerConfiguration

    • getReconciler

      public org.eclipse.jface.text.reconciler.IReconciler getReconciler(org.eclipse.jface.text.source.ISourceViewer sourceViewer)
      Overrides:
      getReconciler in class org.eclipse.jface.text.source.SourceViewerConfiguration

    • getAutoEditStrategies

      public org.eclipse.jface.text.IAutoEditStrategy[] getAutoEditStrategies(org.eclipse.jface.text.source.ISourceViewer sourceViewer, String contentType)
      Overrides:
      getAutoEditStrategies in class org.eclipse.jface.text.source.SourceViewerConfiguration

    • getAnnotationHover

      public org.eclipse.jface.text.source.IAnnotationHover getAnnotationHover(org.eclipse.jface.text.source.ISourceViewer sourceViewer)
      Overrides:
      getAnnotationHover in class org.eclipse.jface.text.source.SourceViewerConfiguration


XMLDoubleClickStrategy

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.codehilite2

Class XMLDoubleClickStrategy

java.lang.Object
com.pvx.ooadide.codehilite2.XMLDoubleClickStrategy
All Implemented Interfaces:
org.eclipse.jface.text.ITextDoubleClickStrategy
public class XMLDoubleClickStrategy extends Object implements org.eclipse.jface.text.ITextDoubleClickStrategy

  • Constructor Summary

    Constructors
    Constructor
    Description
    XMLDoubleClickStrategy()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    doubleClicked(org.eclipse.jface.text.ITextViewer textViewer)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • XMLDoubleClickStrategy

      public XMLDoubleClickStrategy()

  • Method Details

    • doubleClicked

      public void doubleClicked(org.eclipse.jface.text.ITextViewer textViewer)
      Specified by:
      doubleClicked in interface org.eclipse.jface.text.ITextDoubleClickStrategy


Uses of Class com.pvx.ooadide.codehilite2.ColorManager

Uses of Class
com.pvx.ooadide.codehilite2.ColorManager

Packages that use ColorManager
Package
Description
com.pvx.ooadide.codehilite2

  • Uses of ColorManager in com.pvx.ooadide.codehilite2

    Constructors in com.pvx.ooadide.codehilite2 with parameters of type ColorManager
    Modifier
    Constructor
    Description

    XMLConfiguration2(ColorManager colorManager, PvxEditor init_pvxEditor)


Uses of Class com.pvx.ooadide.codehilite2.ColourTokenFactory

Uses of Class
com.pvx.ooadide.codehilite2.ColourTokenFactory

No usage of com.pvx.ooadide.codehilite2.ColourTokenFactory


Uses of Class com.pvx.ooadide.codehilite2.ExtKeywordCompoundRule

Uses of Class
com.pvx.ooadide.codehilite2.ExtKeywordCompoundRule

No usage of com.pvx.ooadide.codehilite2.ExtKeywordCompoundRule


Uses of Class com.pvx.ooadide.codehilite2.ExtKeywordDetector

Uses of Class
com.pvx.ooadide.codehilite2.ExtKeywordDetector

No usage of com.pvx.ooadide.codehilite2.ExtKeywordDetector


Uses of Class com.pvx.ooadide.codehilite2.ExtKeywordRule

Uses of Class
com.pvx.ooadide.codehilite2.ExtKeywordRule

Packages that use ExtKeywordRule
Package
Description
com.pvx.ooadide.codehilite2

  • Uses of ExtKeywordRule in com.pvx.ooadide.codehilite2

    Subclasses of ExtKeywordRule in com.pvx.ooadide.codehilite2
    Modifier and Type
    Class
    Description
    class
    ExtKeywordCompoundRule


Uses of Class com.pvx.ooadide.codehilite2.PvxContentAssistant

Uses of Class
com.pvx.ooadide.codehilite2.PvxContentAssistant

No usage of com.pvx.ooadide.codehilite2.PvxContentAssistant


Uses of Class com.pvx.ooadide.codehilite2.PvxDirectiveWordRule

Uses of Class
com.pvx.ooadide.codehilite2.PvxDirectiveWordRule

No usage of com.pvx.ooadide.codehilite2.PvxDirectiveWordRule


Uses of Class com.pvx.ooadide.codehilite2.PvxDirectiveWordRule.DirectiveWordDetector

Uses of Class
com.pvx.ooadide.codehilite2.PvxDirectiveWordRule.DirectiveWordDetector

No usage of com.pvx.ooadide.codehilite2.PvxDirectiveWordRule.DirectiveWordDetector


Uses of Class com.pvx.ooadide.codehilite2.PvxEolRule

Uses of Class
com.pvx.ooadide.codehilite2.PvxEolRule

No usage of com.pvx.ooadide.codehilite2.PvxEolRule


Uses of Class com.pvx.ooadide.codehilite2.PvxInfoPresenter

Uses of Class
com.pvx.ooadide.codehilite2.PvxInfoPresenter

No usage of com.pvx.ooadide.codehilite2.PvxInfoPresenter


Uses of Class com.pvx.ooadide.codehilite2.PvxLineLabelWordRule

Uses of Class
com.pvx.ooadide.codehilite2.PvxLineLabelWordRule

No usage of com.pvx.ooadide.codehilite2.PvxLineLabelWordRule


Uses of Class com.pvx.ooadide.codehilite2.PvxLineLabelWordRule.LineLabelWordDetector

Uses of Class
com.pvx.ooadide.codehilite2.PvxLineLabelWordRule.LineLabelWordDetector

No usage of com.pvx.ooadide.codehilite2.PvxLineLabelWordRule.LineLabelWordDetector


Uses of Class com.pvx.ooadide.codehilite2.PvxMnemonicRule

Uses of Class
com.pvx.ooadide.codehilite2.PvxMnemonicRule

No usage of com.pvx.ooadide.codehilite2.PvxMnemonicRule


Uses of Class com.pvx.ooadide.codehilite2.PvxMnemonicRule.MnemonicWordDetector

Uses of Class
com.pvx.ooadide.codehilite2.PvxMnemonicRule.MnemonicWordDetector

No usage of com.pvx.ooadide.codehilite2.PvxMnemonicRule.MnemonicWordDetector


Uses of Class com.pvx.ooadide.codehilite2.PvxNumbLiteralRule

Uses of Class
com.pvx.ooadide.codehilite2.PvxNumbLiteralRule

No usage of com.pvx.ooadide.codehilite2.PvxNumbLiteralRule


Uses of Class com.pvx.ooadide.codehilite2.PvxNumbLiteralRule.numbWordDetector

Uses of Class
com.pvx.ooadide.codehilite2.PvxNumbLiteralRule.numbWordDetector

No usage of com.pvx.ooadide.codehilite2.PvxNumbLiteralRule.numbWordDetector


Uses of Class com.pvx.ooadide.codehilite2.PvxWordRule

Uses of Class
com.pvx.ooadide.codehilite2.PvxWordRule

Packages that use PvxWordRule
Package
Description
com.pvx.ooadide.codehilite2

  • Uses of PvxWordRule in com.pvx.ooadide.codehilite2

    Subclasses of PvxWordRule in com.pvx.ooadide.codehilite2
    Modifier and Type
    Class
    Description
    class
    ExtKeywordCompoundRule
    class
    ExtKeywordRule
    class
    PvxDirectiveWordRule
    class
    PvxLineLabelWordRule
    class
    PvxMnemonicRule
    class
    PvxNumbLiteralRule


Uses of Class com.pvx.ooadide.codehilite2.XMLConfiguration2

Uses of Class
com.pvx.ooadide.codehilite2.XMLConfiguration2

No usage of com.pvx.ooadide.codehilite2.XMLConfiguration2


Uses of Class com.pvx.ooadide.codehilite2.XMLDoubleClickStrategy

Uses of Class
com.pvx.ooadide.codehilite2.XMLDoubleClickStrategy

No usage of com.pvx.ooadide.codehilite2.XMLDoubleClickStrategy


com.pvx.ooadide.dialogs

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.pvx.ooadide.dialogs

package com.pvx.ooadide.dialogs
  • Related Packages
    Package
    Description
    com.pvx.ooadide
  • Classes
    Class
    Description
    PvxElementListSelectionDialog


com.pvx.ooadide.dialogs Class Hierarchy

Hierarchy For Package com.pvx.ooadide.dialogs

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.eclipse.jface.window.Window (implements org.eclipse.jface.window.IShellProvider)
      • org.eclipse.jface.dialogs.Dialog
        • org.eclipse.jface.dialogs.TrayDialog
          • org.eclipse.ui.dialogs.SelectionDialog
            • org.eclipse.ui.dialogs.SelectionStatusDialog
              • org.eclipse.ui.dialogs.AbstractElementListSelectionDialog
                • org.eclipse.ui.dialogs.ElementListSelectionDialog
                  • com.pvx.ooadide.dialogs.PvxElementListSelectionDialog


Uses of Package com.pvx.ooadide.dialogs

Uses of Package
com.pvx.ooadide.dialogs

No usage of com.pvx.ooadide.dialogs


PvxElementListSelectionDialog

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.dialogs

Class PvxElementListSelectionDialog

java.lang.Object
org.eclipse.jface.window.Window
org.eclipse.jface.dialogs.Dialog
org.eclipse.jface.dialogs.TrayDialog
org.eclipse.ui.dialogs.SelectionDialog
org.eclipse.ui.dialogs.SelectionStatusDialog
org.eclipse.ui.dialogs.AbstractElementListSelectionDialog
org.eclipse.ui.dialogs.ElementListSelectionDialog
com.pvx.ooadide.dialogs.PvxElementListSelectionDialog
All Implemented Interfaces:
org.eclipse.jface.window.IShellProvider
public class PvxElementListSelectionDialog extends org.eclipse.ui.dialogs.ElementListSelectionDialog

  • Nested Class Summary

    Nested classes/interfaces inherited from class org.eclipse.jface.window.Window

    org.eclipse.jface.window.Window.IExceptionHandler

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final int
    CONFIG_BTN_ID

    Fields inherited from class org.eclipse.jface.dialogs.Dialog

    blockedHandler, buttonBar, DIALOG_DEFAULT_BOUNDS, DIALOG_PERSISTLOCATION, DIALOG_PERSISTSIZE, DLG_IMG_HELP, DLG_IMG_MESSAGE_ERROR, DLG_IMG_MESSAGE_INFO, DLG_IMG_MESSAGE_WARNING, ELLIPSIS

    Fields inherited from class org.eclipse.jface.window.Window

    CANCEL, OK

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxElementListSelectionDialog(org.eclipse.swt.widgets.Shell parent, org.eclipse.jface.viewers.ILabelProvider renderer)

  • Method Summary

    Methods inherited from class org.eclipse.ui.dialogs.ElementListSelectionDialog

    setElements

    Methods inherited from class org.eclipse.ui.dialogs.AbstractElementListSelectionDialog

    create, getFilter, getFoldedElements, isCaseIgnored, open, setAllowDuplicates, setEmptyListMessage, setEmptySelectionMessage, setFilter, setIgnoreCase, setMatchEmptyString, setMultipleSelection, setSize, setValidator

    Methods inherited from class org.eclipse.ui.dialogs.SelectionStatusDialog

    getFirstResult, setImage, setStatusLineAboveButtons

    Methods inherited from class org.eclipse.ui.dialogs.SelectionDialog

    getOkButton, getResult, setDialogBoundsSettings, setInitialElementSelections, setInitialSelections, setMessage, setTitle

    Methods inherited from class org.eclipse.jface.dialogs.TrayDialog

    closeTray, getTray, isDialogHelpAvailable, isHelpAvailable, openTray, setDialogHelpAvailable, setHelpAvailable

    Methods inherited from class org.eclipse.jface.dialogs.Dialog

    applyDialogFont, close, convertHeightInCharsToPixels, convertHorizontalDLUsToPixels, convertVerticalDLUsToPixels, convertWidthInCharsToPixels, getBlockedHandler, getImage, setBlockedHandler, shortenText

    Methods inherited from class org.eclipse.jface.window.Window

    getDefaultImage, getDefaultImages, getDefaultOrientation, getReturnCode, getShell, getWindowManager, setBlockOnOpen, setDefaultImage, setDefaultImages, setDefaultModalParent, setDefaultOrientation, setExceptionHandler, setWindowManager

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Field Details

    • CONFIG_BTN_ID

      public static final int CONFIG_BTN_ID
      See Also:
      • Constant Field Values

  • Constructor Details

    • PvxElementListSelectionDialog

      public PvxElementListSelectionDialog(org.eclipse.swt.widgets.Shell parent, org.eclipse.jface.viewers.ILabelProvider renderer)


Uses of Class com.pvx.ooadide.dialogs.PvxElementListSelectionDialog

Uses of Class
com.pvx.ooadide.dialogs.PvxElementListSelectionDialog

No usage of com.pvx.ooadide.dialogs.PvxElementListSelectionDialog


HandledInput

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.editors

Class HandledInput

java.lang.Object
com.pvx.ooadide.editors.HandledInput
All Implemented Interfaces:
org.eclipse.core.runtime.IAdaptable, org.eclipse.ui.IEditorInput, org.eclipse.ui.IFileEditorInput, org.eclipse.ui.IStorageEditorInput
public class HandledInput extends Object implements org.eclipse.ui.IFileEditorInput

  • Constructor Summary

    Constructors
    Constructor
    Description
    HandledInput(org.eclipse.ui.IFileEditorInput editorInput)

  • Method Summary

    Modifier and Type
    Method
    Description
    boolean
    exists()
    <T> T
    getAdapter(Class<T> adapterType)
    org.eclipse.core.resources.IFile
    getFile()
    org.eclipse.jface.resource.ImageDescriptor
    getImageDescriptor()
    String
    getName()
    org.eclipse.ui.IPersistableElement
    getPersistable()
    org.eclipse.core.resources.IStorage
    getStorage()
    String
    getToolTipText()

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • HandledInput

      public HandledInput(org.eclipse.ui.IFileEditorInput editorInput)

  • Method Details

    • exists

      public boolean exists()
      Specified by:
      exists in interface org.eclipse.ui.IEditorInput

    • getImageDescriptor

      public org.eclipse.jface.resource.ImageDescriptor getImageDescriptor()
      Specified by:
      getImageDescriptor in interface org.eclipse.ui.IEditorInput

    • getName

      public String getName()
      Specified by:
      getName in interface org.eclipse.ui.IEditorInput

    • getPersistable

      public org.eclipse.ui.IPersistableElement getPersistable()
      Specified by:
      getPersistable in interface org.eclipse.ui.IEditorInput

    • getToolTipText

      public String getToolTipText()
      Specified by:
      getToolTipText in interface org.eclipse.ui.IEditorInput

    • getAdapter

      public <T> T getAdapter(Class<T> adapterType)
      Specified by:
      getAdapter in interface org.eclipse.core.runtime.IAdaptable

    • getFile

      public org.eclipse.core.resources.IFile getFile()
      Specified by:
      getFile in interface org.eclipse.ui.IFileEditorInput

    • getStorage

      public org.eclipse.core.resources.IStorage getStorage() throws org.eclipse.core.runtime.CoreException
      Specified by:
      getStorage in interface org.eclipse.ui.IStorageEditorInput
      Throws:
      org.eclipse.core.runtime.CoreException


LoadProgramAction

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.editors

Class LoadProgramAction

java.lang.Object
com.pvx.ooadide.editors.LoadProgramAction
All Implemented Interfaces:
org.eclipse.ui.IActionDelegate, org.eclipse.ui.IObjectActionDelegate
public class LoadProgramAction extends Object implements org.eclipse.ui.IObjectActionDelegate

  • Constructor Summary

    Constructors
    Constructor
    Description
    LoadProgramAction()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    run(org.eclipse.jface.action.IAction action)
    void
    selectionChanged(org.eclipse.jface.action.IAction action, org.eclipse.jface.viewers.ISelection selection)
    void
    setActivePart(org.eclipse.jface.action.IAction action, org.eclipse.ui.IWorkbenchPart targetPart)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • LoadProgramAction

      public LoadProgramAction()

  • Method Details

    • setActivePart

      public void setActivePart(org.eclipse.jface.action.IAction action, org.eclipse.ui.IWorkbenchPart targetPart)
      Specified by:
      setActivePart in interface org.eclipse.ui.IObjectActionDelegate

    • run

      public void run(org.eclipse.jface.action.IAction action)
      Specified by:
      run in interface org.eclipse.ui.IActionDelegate

    • selectionChanged

      public void selectionChanged(org.eclipse.jface.action.IAction action, org.eclipse.jface.viewers.ISelection selection)
      Specified by:
      selectionChanged in interface org.eclipse.ui.IActionDelegate


MyCompletionProcessor

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.editors

Class MyCompletionProcessor

java.lang.Object
org.eclipse.jface.text.templates.TemplateCompletionProcessor
com.pvx.ooadide.editors.MyCompletionProcessor
All Implemented Interfaces:
org.eclipse.jface.text.contentassist.IContentAssistProcessor
public class MyCompletionProcessor extends org.eclipse.jface.text.templates.TemplateCompletionProcessor implements org.eclipse.jface.text.contentassist.IContentAssistProcessor

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static String[]
    allDirectives
    static String[]
    allMnemonics
    static String[]
    allSysFunctions
    static String[]
    allSysVariables
    static PvxCompletionProposal[]
    directivePropl
    static final Hashtable
    directives
    static final String
    DIRECTIVES_PROPERTIES_FILE
    static ArrayList<ExtKeywordCategoryEntity>
    extKeywordsEntityList
    static final String
    FORMAT_KEY
    static Hashtable
    keywordsCategories
    static final String
    KEYWORDSCATS_PROPERTIES_FILE
    static final Hashtable
    mnemonics
    static final String
    MNEMONICS_PROPERTIES_FILE
    static PvxCompletionProposal[]
    mnemPropl
    static PvxCompletionProposal[]
    sysFuncPropl
    static final String
    SYSFUNCTION_PROPERTIES_FILE
    static final Hashtable
    sysfunctions
    static final Hashtable
    sysvariables
    static final String
    SYSVARIABLES_PROPERTIES_FILE
    static PvxCompletionProposal[]
    sysVarPropl

  • Constructor Summary

    Constructors
    Constructor
    Description
    MyCompletionProcessor(PvxEditor init_pvxEditor)

  • Method Summary

    Modifier and Type
    Method
    Description
    org.eclipse.jface.text.contentassist.ICompletionProposal[]
    computeCompletionProposals(org.eclipse.jface.text.ITextViewer viewer, int offset)
    org.eclipse.jface.text.contentassist.IContextInformation[]
    computeContextInformation(org.eclipse.jface.text.ITextViewer viewer, int documentOffset)
    static PvxCompletionProposal[]
    getAllCompletionProposals(org.eclipse.jface.text.contentassist.ICompletionProposal[] templates)
    static String[]
    getAllDirectives()
    static String[]
    getAllMnemonics()
    static String[]
    getAllSysFunctions()
    static String[]
    getAllSysVariables()
    char[]
    getCompletionProposalAutoActivationCharacters()
    static final org.eclipse.jface.text.contentassist.IContextInformation
    getContextForKey(String key)
    static String
    getContextInfo(Hashtable keywords, String targetProposal)
    char[]
    getContextInformationAutoActivationCharacters()
    org.eclipse.jface.text.contentassist.IContextInformationValidator
    getContextInformationValidator()
    static PvxCompletionProposal[]
    getDirectiveCompletionProposals()
    String
    getErrorMessage()
    static ArrayList<ExtKeywordCategoryEntity>
    getExtKeywordCategories()
    static PvxCompletionProposal[]
    getExtKeywordCompletionProposals()
    static ArrayList<String>
    getKeywordKeys(Enumeration dirs)
    static PvxCompletionProposal[]
    getMnemonicCompletionProposals()
    static PvxEditor
    getPvxEditor()
    static PvxCompletionProposal[]
    getSysFuncCompletionProposals()
    static PvxCompletionProposal[]
    getSysVarsCompletionProposals()
    boolean
    isAutoStartChar(char ch)
    boolean
    isProposalVisible()
    boolean
    isWhitespace(char c)
    static ArrayList<ExtKeywordCategoryEntity>
    loadExtKeywordCategories()
    void
    setProposalVisible(boolean isProposalVisible)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Field Details

    • directivePropl

      public static PvxCompletionProposal[] directivePropl

    • mnemPropl

      public static PvxCompletionProposal[] mnemPropl

    • sysVarPropl

      public static PvxCompletionProposal[] sysVarPropl

    • sysFuncPropl

      public static PvxCompletionProposal[] sysFuncPropl

    • FORMAT_KEY

      public static final String FORMAT_KEY
      See Also:
      • Constant Field Values

    • DIRECTIVES_PROPERTIES_FILE

      public static final String DIRECTIVES_PROPERTIES_FILE
      See Also:
      • Constant Field Values

    • SYSFUNCTION_PROPERTIES_FILE

      public static final String SYSFUNCTION_PROPERTIES_FILE
      See Also:
      • Constant Field Values

    • SYSVARIABLES_PROPERTIES_FILE

      public static final String SYSVARIABLES_PROPERTIES_FILE
      See Also:
      • Constant Field Values

    • MNEMONICS_PROPERTIES_FILE

      public static final String MNEMONICS_PROPERTIES_FILE
      See Also:
      • Constant Field Values

    • KEYWORDSCATS_PROPERTIES_FILE

      public static final String KEYWORDSCATS_PROPERTIES_FILE
      See Also:
      • Constant Field Values

    • directives

      public static final Hashtable directives

    • sysfunctions

      public static final Hashtable sysfunctions

    • sysvariables

      public static final Hashtable sysvariables

    • mnemonics

      public static final Hashtable mnemonics

    • keywordsCategories

      public static Hashtable keywordsCategories

    • extKeywordsEntityList

      public static ArrayList<ExtKeywordCategoryEntity> extKeywordsEntityList

    • allDirectives

      public static String[] allDirectives

    • allSysFunctions

      public static String[] allSysFunctions

    • allMnemonics

      public static String[] allMnemonics

    • allSysVariables

      public static String[] allSysVariables

  • Constructor Details

    • MyCompletionProcessor

      public MyCompletionProcessor(PvxEditor init_pvxEditor)

  • Method Details

    • getPvxEditor

      public static PvxEditor getPvxEditor()

    • isAutoStartChar

      public boolean isAutoStartChar(char ch)

    • computeCompletionProposals

      public org.eclipse.jface.text.contentassist.ICompletionProposal[] computeCompletionProposals(org.eclipse.jface.text.ITextViewer viewer, int offset)
      Specified by:
      computeCompletionProposals in interface org.eclipse.jface.text.contentassist.IContentAssistProcessor
      Overrides:
      computeCompletionProposals in class org.eclipse.jface.text.templates.TemplateCompletionProcessor

    • getCompletionProposalAutoActivationCharacters

      public char[] getCompletionProposalAutoActivationCharacters()
      Specified by:
      getCompletionProposalAutoActivationCharacters in interface org.eclipse.jface.text.contentassist.IContentAssistProcessor
      Overrides:
      getCompletionProposalAutoActivationCharacters in class org.eclipse.jface.text.templates.TemplateCompletionProcessor

    • getContextInformationAutoActivationCharacters

      public char[] getContextInformationAutoActivationCharacters()
      Specified by:
      getContextInformationAutoActivationCharacters in interface org.eclipse.jface.text.contentassist.IContentAssistProcessor
      Overrides:
      getContextInformationAutoActivationCharacters in class org.eclipse.jface.text.templates.TemplateCompletionProcessor

    • getAllCompletionProposals

      public static PvxCompletionProposal[] getAllCompletionProposals(org.eclipse.jface.text.contentassist.ICompletionProposal[] templates)

    • getExtKeywordCompletionProposals

      public static PvxCompletionProposal[] getExtKeywordCompletionProposals()

    • getExtKeywordCategories

      public static ArrayList<ExtKeywordCategoryEntity> getExtKeywordCategories()

    • loadExtKeywordCategories

      public static ArrayList<ExtKeywordCategoryEntity> loadExtKeywordCategories()

    • getDirectiveCompletionProposals

      public static PvxCompletionProposal[] getDirectiveCompletionProposals()

    • getContextInfo

      public static String getContextInfo(Hashtable keywords, String targetProposal)

    • getSysFuncCompletionProposals

      public static PvxCompletionProposal[] getSysFuncCompletionProposals()

    • getMnemonicCompletionProposals

      public static PvxCompletionProposal[] getMnemonicCompletionProposals()

    • getKeywordKeys

      public static ArrayList<String> getKeywordKeys(Enumeration dirs)

    • getSysVarsCompletionProposals

      public static PvxCompletionProposal[] getSysVarsCompletionProposals()

    • getAllMnemonics

      public static String[] getAllMnemonics()

    • getAllSysVariables

      public static String[] getAllSysVariables()

    • getAllSysFunctions

      public static String[] getAllSysFunctions()

    • getAllDirectives

      public static String[] getAllDirectives()

    • getContextInformationValidator

      public org.eclipse.jface.text.contentassist.IContextInformationValidator getContextInformationValidator()
      Specified by:
      getContextInformationValidator in interface org.eclipse.jface.text.contentassist.IContentAssistProcessor
      Overrides:
      getContextInformationValidator in class org.eclipse.jface.text.templates.TemplateCompletionProcessor

    • computeContextInformation

      public org.eclipse.jface.text.contentassist.IContextInformation[] computeContextInformation(org.eclipse.jface.text.ITextViewer viewer, int documentOffset)
      Specified by:
      computeContextInformation in interface org.eclipse.jface.text.contentassist.IContentAssistProcessor
      Overrides:
      computeContextInformation in class org.eclipse.jface.text.templates.TemplateCompletionProcessor

    • getContextForKey

      public static final org.eclipse.jface.text.contentassist.IContextInformation getContextForKey(String key)

    • isWhitespace

      public boolean isWhitespace(char c)

    • getErrorMessage

      public String getErrorMessage()
      Specified by:
      getErrorMessage in interface org.eclipse.jface.text.contentassist.IContentAssistProcessor
      Overrides:
      getErrorMessage in class org.eclipse.jface.text.templates.TemplateCompletionProcessor

    • setProposalVisible

      public void setProposalVisible(boolean isProposalVisible)

    • isProposalVisible

      public boolean isProposalVisible()


NomadsEditor

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.editors

Class NomadsEditor

java.lang.Object
org.eclipse.core.commands.common.EventManager
org.eclipse.ui.part.WorkbenchPart
org.eclipse.ui.part.EditorPart
org.eclipse.ui.texteditor.AbstractTextEditor
org.eclipse.ui.texteditor.StatusTextEditor
org.eclipse.ui.texteditor.AbstractDecoratedTextEditor
org.eclipse.ui.editors.text.TextEditor
com.pvx.ooadide.editors.NomadsEditor
All Implemented Interfaces:
org.eclipse.core.runtime.IAdaptable, org.eclipse.core.runtime.IExecutableExtension, org.eclipse.ui.IEditorPart, org.eclipse.ui.INavigationLocationProvider, org.eclipse.ui.IPersistable, org.eclipse.ui.IPersistableEditor, org.eclipse.ui.IReusableEditor, org.eclipse.ui.ISaveablePart, org.eclipse.ui.ISaveablesSource, org.eclipse.ui.IWorkbenchPart, org.eclipse.ui.IWorkbenchPart2, org.eclipse.ui.IWorkbenchPart3, org.eclipse.ui.part.IWorkbenchPartOrientation, org.eclipse.ui.texteditor.ITextEditor, org.eclipse.ui.texteditor.ITextEditorExtension, org.eclipse.ui.texteditor.ITextEditorExtension2, org.eclipse.ui.texteditor.ITextEditorExtension3, org.eclipse.ui.texteditor.ITextEditorExtension4, org.eclipse.ui.texteditor.ITextEditorExtension5, org.eclipse.ui.texteditor.ITextEditorExtension6
public class NomadsEditor extends org.eclipse.ui.editors.text.TextEditor

  • Nested Class Summary

    Nested classes/interfaces inherited from interface org.eclipse.ui.texteditor.ITextEditorExtension3

    org.eclipse.ui.texteditor.ITextEditorExtension3.InsertMode

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final String
    ID

    Fields inherited from class org.eclipse.ui.texteditor.AbstractDecoratedTextEditor

    DEFAULT_OVERVIEW_RULER_CONTEXT_MENU_ID

    Fields inherited from class org.eclipse.ui.texteditor.AbstractTextEditor

    COMMON_EDITOR_CONTEXT_MENU_ID, COMMON_RULER_CONTEXT_MENU_ID, DEFAULT_EDITOR_CONTEXT_MENU_ID, DEFAULT_RULER_CONTEXT_MENU_ID, PREFERENCE_COLOR_BACKGROUND, PREFERENCE_COLOR_BACKGROUND_SYSTEM_DEFAULT, PREFERENCE_COLOR_FIND_SCOPE, PREFERENCE_COLOR_FOREGROUND, PREFERENCE_COLOR_FOREGROUND_SYSTEM_DEFAULT, PREFERENCE_COLOR_SELECTION_BACKGROUND, PREFERENCE_COLOR_SELECTION_BACKGROUND_SYSTEM_DEFAULT, PREFERENCE_COLOR_SELECTION_FOREGROUND, PREFERENCE_COLOR_SELECTION_FOREGROUND_SYSTEM_DEFAULT, PREFERENCE_HOVER_ENRICH_MODE, PREFERENCE_HYPERLINK_KEY_MODIFIER, PREFERENCE_HYPERLINK_KEY_MODIFIER_MASK, PREFERENCE_HYPERLINKS_ENABLED, PREFERENCE_NAVIGATION_SMART_HOME_END, PREFERENCE_RULER_CONTRIBUTIONS, PREFERENCE_SHOW_CARRIAGE_RETURN, PREFERENCE_SHOW_ENCLOSED_IDEOGRAPHIC_SPACES, PREFERENCE_SHOW_ENCLOSED_SPACES, PREFERENCE_SHOW_ENCLOSED_TABS, PREFERENCE_SHOW_LEADING_IDEOGRAPHIC_SPACES, PREFERENCE_SHOW_LEADING_SPACES, PREFERENCE_SHOW_LEADING_TABS, PREFERENCE_SHOW_LINE_FEED, PREFERENCE_SHOW_TRAILING_IDEOGRAPHIC_SPACES, PREFERENCE_SHOW_TRAILING_SPACES, PREFERENCE_SHOW_TRAILING_TABS, PREFERENCE_SHOW_WHITESPACE_CHARACTERS, PREFERENCE_TEXT_DRAG_AND_DROP_ENABLED, PREFERENCE_USE_CUSTOM_CARETS, PREFERENCE_WHITESPACE_CHARACTER_ALPHA_VALUE, PREFERENCE_WIDE_CARET, PREFERENCE_WORD_WRAP_ENABLED

    Fields inherited from interface org.eclipse.ui.IEditorPart

    PROP_DIRTY, PROP_INPUT

    Fields inherited from interface org.eclipse.ui.texteditor.ITextEditorExtension3

    INSERT, SMART_INSERT

    Fields inherited from interface org.eclipse.ui.IWorkbenchPart

    PROP_TITLE

  • Constructor Summary

    Constructors
    Constructor
    Description
    NomadsEditor()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    createPartControl(org.eclipse.swt.widgets.Composite parent)
    void
    setBuildOnClose(boolean doBuild)

    Methods inherited from class org.eclipse.ui.editors.text.TextEditor

    dispose, getAdapter, isSaveAsAllowed

    Methods inherited from class org.eclipse.ui.texteditor.AbstractDecoratedTextEditor

    getDocumentProvider, gotoAnnotation, isChangeInformationShowing, isEditable, showChangeInformation, showRevisionInformation, validateEditorInputState

    Methods inherited from class org.eclipse.ui.texteditor.StatusTextEditor

    doRevertToSaved, setFocus, updatePartControl

    Methods inherited from class org.eclipse.ui.texteditor.AbstractTextEditor

    addRulerContextMenuListener, close, createEmptyNavigationLocation, createNavigationLocation, doSave, doSaveAs, getAction, getActiveSaveables, getHighlightRange, getInsertMode, getSaveables, getSelectionProvider, init, isBlockSelectionModeEnabled, isDirty, isEditorInputModifiable, isEditorInputReadOnly, isWordWrapEnabled, markAsContentDependentAction, markAsPropertyDependentAction, markAsSelectionDependentAction, markAsStateDependentAction, removeActionActivationCode, removeRulerContextMenuListener, resetHighlightRange, restoreState, saveState, selectAndReveal, setAction, setActionActivationCode, setBlockSelectionMode, setHighlightRange, setInput, setInsertMode, setStatusField, setWordWrap, showHighlightRangeOnly, showsHighlightRangeOnly

    Methods inherited from class org.eclipse.ui.part.EditorPart

    getEditorInput, getEditorSite, getTitleToolTip, isSaveOnCloseNeeded, setInitializationData

    Methods inherited from class org.eclipse.ui.part.WorkbenchPart

    addPartPropertyListener, addPropertyListener, getContentDescription, getOrientation, getPartName, getPartProperties, getPartProperty, getSite, getTitle, getTitleImage, removePartPropertyListener, removePropertyListener, setPartProperty, showBusy

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface org.eclipse.ui.IEditorPart

    getEditorInput, getEditorSite

    Methods inherited from interface org.eclipse.ui.ISaveablePart

    isSaveOnCloseNeeded

    Methods inherited from interface org.eclipse.ui.IWorkbenchPart

    addPropertyListener, getSite, getTitle, getTitleImage, getTitleToolTip, removePropertyListener

  • Field Details

    • ID

      public static final String ID
      See Also:
      • Constant Field Values

  • Constructor Details

    • NomadsEditor

      public NomadsEditor()

  • Method Details

    • createPartControl

      public void createPartControl(org.eclipse.swt.widgets.Composite parent)
      Specified by:
      createPartControl in interface org.eclipse.ui.IWorkbenchPart
      Overrides:
      createPartControl in class org.eclipse.ui.texteditor.AbstractDecoratedTextEditor

    • setBuildOnClose

      public void setBuildOnClose(boolean doBuild)


com.pvx.ooadide.editors

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.pvx.ooadide.editors

package com.pvx.ooadide.editors
  • Related Packages
    Package
    Description
    com.pvx.ooadide
    com.pvx.ooadide.editors.autoindent
    com.pvx.ooadide.editors.codefolding
    com.pvx.ooadide.editors.extkeyword
    com.pvx.ooadide.editors.templates
  • Classes
    Class
    Description
    HandledInput
    LoadProgramAction
    MyCompletionProcessor
    NomadsEditor
    PvxAnnotationHover
    The PvxAnnotationHover provides the hover support for ProvideX editors.
    PvxCompletionProposal
    PvxContextInformation
    PvxEditor
    PvxParameterListValidator
    TextHover
    XEditorMatchingStrategy


com.pvx.ooadide.editors Class Hierarchy

Hierarchy For Package com.pvx.ooadide.editors

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.eclipse.core.commands.common.EventManager
      • org.eclipse.ui.part.WorkbenchPart (implements org.eclipse.core.runtime.IExecutableExtension, org.eclipse.ui.IWorkbenchPart3, org.eclipse.ui.part.IWorkbenchPartOrientation)
        • org.eclipse.ui.part.EditorPart (implements org.eclipse.ui.IEditorPart)
          • org.eclipse.ui.texteditor.AbstractTextEditor (implements org.eclipse.ui.INavigationLocationProvider, org.eclipse.ui.IPersistableEditor, org.eclipse.ui.IReusableEditor, org.eclipse.ui.ISaveablesSource, org.eclipse.ui.texteditor.ITextEditor, org.eclipse.ui.texteditor.ITextEditorExtension, org.eclipse.ui.texteditor.ITextEditorExtension2, org.eclipse.ui.texteditor.ITextEditorExtension3, org.eclipse.ui.texteditor.ITextEditorExtension4, org.eclipse.ui.texteditor.ITextEditorExtension5, org.eclipse.ui.texteditor.ITextEditorExtension6)
            • org.eclipse.ui.texteditor.StatusTextEditor
              • org.eclipse.ui.texteditor.AbstractDecoratedTextEditor
                • org.eclipse.ui.editors.text.TextEditor
                  • com.pvx.ooadide.editors.NomadsEditor
                  • com.pvx.ooadide.editors.PvxEditor (implements org.eclipse.ui.IShowEditorInput)
    • com.pvx.ooadide.editors.HandledInput (implements org.eclipse.ui.IFileEditorInput)
    • com.pvx.ooadide.editors.LoadProgramAction (implements org.eclipse.ui.IObjectActionDelegate)
    • com.pvx.ooadide.editors.PvxAnnotationHover (implements org.eclipse.jface.text.source.IAnnotationHover)
    • com.pvx.ooadide.editors.PvxCompletionProposal
    • com.pvx.ooadide.editors.PvxContextInformation (implements org.eclipse.jface.text.contentassist.IContextInformation)
    • com.pvx.ooadide.editors.PvxParameterListValidator (implements org.eclipse.jface.text.contentassist.IContextInformationPresenter, org.eclipse.jface.text.contentassist.IContextInformationValidator)
    • org.eclipse.jface.text.templates.TemplateCompletionProcessor (implements org.eclipse.jface.text.contentassist.IContentAssistProcessor)
      • com.pvx.ooadide.editors.MyCompletionProcessor (implements org.eclipse.jface.text.contentassist.IContentAssistProcessor)
    • com.pvx.ooadide.editors.TextHover (implements org.eclipse.jface.text.ITextHover)
    • com.pvx.ooadide.editors.XEditorMatchingStrategy (implements org.eclipse.ui.IEditorMatchingStrategy)


Uses of Package com.pvx.ooadide.editors

Uses of Package
com.pvx.ooadide.editors

Packages that use com.pvx.ooadide.editors
Package
Description
com.pvx.ooadide.codehilite2
com.pvx.ooadide.editors
com.pvx.ooadide.editors.codefolding
com.pvx.ooadide.editors.extkeyword
com.pvx.ooadide.refactor
com.pvx.ooadide.util
  • Classes in com.pvx.ooadide.editors used by com.pvx.ooadide.codehilite2
    Class
    Description
    PvxEditor
  • Classes in com.pvx.ooadide.editors used by com.pvx.ooadide.editors
    Class
    Description
    PvxCompletionProposal
    PvxEditor
  • Classes in com.pvx.ooadide.editors used by com.pvx.ooadide.editors.codefolding
    Class
    Description
    PvxEditor
  • Classes in com.pvx.ooadide.editors used by com.pvx.ooadide.editors.extkeyword
    Class
    Description
    PvxCompletionProposal
  • Classes in com.pvx.ooadide.editors used by com.pvx.ooadide.refactor
    Class
    Description
    PvxEditor
  • Classes in com.pvx.ooadide.editors used by com.pvx.ooadide.util
    Class
    Description
    PvxEditor


PvxAnnotationHover

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.editors

Class PvxAnnotationHover

java.lang.Object
com.pvx.ooadide.editors.PvxAnnotationHover
All Implemented Interfaces:
org.eclipse.jface.text.source.IAnnotationHover
public class PvxAnnotationHover extends Object implements org.eclipse.jface.text.source.IAnnotationHover
The PvxAnnotationHover provides the hover support for ProvideX editors.

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxAnnotationHover()

  • Method Summary

    Modifier and Type
    Method
    Description
    String
    getHoverInfo(org.eclipse.jface.text.source.ISourceViewer sourceViewer, int lineNumber)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • PvxAnnotationHover

      public PvxAnnotationHover()

  • Method Details

    • getHoverInfo

      public String getHoverInfo(org.eclipse.jface.text.source.ISourceViewer sourceViewer, int lineNumber)
      Specified by:
      getHoverInfo in interface org.eclipse.jface.text.source.IAnnotationHover


PvxCompletionProposal

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.editors

Class PvxCompletionProposal

java.lang.Object
com.pvx.ooadide.editors.PvxCompletionProposal
public class PvxCompletionProposal extends Object

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxCompletionProposal(String targetProposal, String displayString, org.eclipse.jface.text.contentassist.IContextInformation contextInformation, org.eclipse.swt.graphics.Image ctxImage)

  • Method Summary

    Modifier and Type
    Method
    Description
    org.eclipse.jface.text.contentassist.IContextInformation
    getContextInformation()
    org.eclipse.swt.graphics.Image
    getCtxImage()
    String
    getDisplayString()
    void
    setContextInformation(org.eclipse.jface.text.contentassist.IContextInformation contextInformation)
    void
    setCtxImage(org.eclipse.swt.graphics.Image ctxImage)
    void
    setDisplayString(String displayString)
    String
    toString()

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

  • Constructor Details

    • PvxCompletionProposal

      public PvxCompletionProposal(String targetProposal, String displayString, org.eclipse.jface.text.contentassist.IContextInformation contextInformation, org.eclipse.swt.graphics.Image ctxImage)

  • Method Details

    • setDisplayString

      public void setDisplayString(String displayString)

    • getDisplayString

      public String getDisplayString()

    • setContextInformation

      public void setContextInformation(org.eclipse.jface.text.contentassist.IContextInformation contextInformation)

    • getContextInformation

      public org.eclipse.jface.text.contentassist.IContextInformation getContextInformation()

    • setCtxImage

      public void setCtxImage(org.eclipse.swt.graphics.Image ctxImage)

    • getCtxImage

      public org.eclipse.swt.graphics.Image getCtxImage()

    • toString

      public String toString()
      Overrides:
      toString in class Object


PvxContextInformation

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.editors

Class PvxContextInformation

java.lang.Object
com.pvx.ooadide.editors.PvxContextInformation
All Implemented Interfaces:
org.eclipse.jface.text.contentassist.IContextInformation
public class PvxContextInformation extends Object implements org.eclipse.jface.text.contentassist.IContextInformation

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxContextInformation(org.eclipse.swt.graphics.Image init_ctxImage, String init_ctxStr, String init_infoDisplay)

  • Method Summary

    Modifier and Type
    Method
    Description
    boolean
    equals(Object object)
    String
    getContextDisplayString()
    org.eclipse.swt.graphics.Image
    getImage()
    String
    getInformationDisplayString()
    int
    hashCode()

    Methods inherited from class java.lang.Object

    getClass, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • PvxContextInformation

      public PvxContextInformation(org.eclipse.swt.graphics.Image init_ctxImage, String init_ctxStr, String init_infoDisplay)

  • Method Details

    • getContextDisplayString

      public String getContextDisplayString()
      Specified by:
      getContextDisplayString in interface org.eclipse.jface.text.contentassist.IContextInformation

    • getImage

      public org.eclipse.swt.graphics.Image getImage()
      Specified by:
      getImage in interface org.eclipse.jface.text.contentassist.IContextInformation

    • getInformationDisplayString

      public String getInformationDisplayString()
      Specified by:
      getInformationDisplayString in interface org.eclipse.jface.text.contentassist.IContextInformation

    • equals

      public boolean equals(Object object)
      Specified by:
      equals in interface org.eclipse.jface.text.contentassist.IContextInformation
      Overrides:
      equals in class Object

    • hashCode

      public int hashCode()
      Overrides:
      hashCode in class Object


PvxEditor

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.editors

Class PvxEditor

java.lang.Object
org.eclipse.core.commands.common.EventManager
org.eclipse.ui.part.WorkbenchPart
org.eclipse.ui.part.EditorPart
org.eclipse.ui.texteditor.AbstractTextEditor
org.eclipse.ui.texteditor.StatusTextEditor
org.eclipse.ui.texteditor.AbstractDecoratedTextEditor
org.eclipse.ui.editors.text.TextEditor
com.pvx.ooadide.editors.PvxEditor
All Implemented Interfaces:
org.eclipse.core.runtime.IAdaptable, org.eclipse.core.runtime.IExecutableExtension, org.eclipse.ui.IEditorPart, org.eclipse.ui.INavigationLocationProvider, org.eclipse.ui.IPersistable, org.eclipse.ui.IPersistableEditor, org.eclipse.ui.IReusableEditor, org.eclipse.ui.ISaveablePart, org.eclipse.ui.ISaveablesSource, org.eclipse.ui.IShowEditorInput, org.eclipse.ui.IWorkbenchPart, org.eclipse.ui.IWorkbenchPart2, org.eclipse.ui.IWorkbenchPart3, org.eclipse.ui.part.IWorkbenchPartOrientation, org.eclipse.ui.texteditor.ITextEditor, org.eclipse.ui.texteditor.ITextEditorExtension, org.eclipse.ui.texteditor.ITextEditorExtension2, org.eclipse.ui.texteditor.ITextEditorExtension3, org.eclipse.ui.texteditor.ITextEditorExtension4, org.eclipse.ui.texteditor.ITextEditorExtension5, org.eclipse.ui.texteditor.ITextEditorExtension6
public class PvxEditor extends org.eclipse.ui.editors.text.TextEditor implements org.eclipse.ui.IShowEditorInput

  • Nested Class Summary

    Nested classes/interfaces inherited from interface org.eclipse.ui.texteditor.ITextEditorExtension3

    org.eclipse.ui.texteditor.ITextEditorExtension3.InsertMode

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final String
    ID

    Fields inherited from class org.eclipse.ui.texteditor.AbstractDecoratedTextEditor

    DEFAULT_OVERVIEW_RULER_CONTEXT_MENU_ID

    Fields inherited from class org.eclipse.ui.texteditor.AbstractTextEditor

    COMMON_EDITOR_CONTEXT_MENU_ID, COMMON_RULER_CONTEXT_MENU_ID, DEFAULT_EDITOR_CONTEXT_MENU_ID, DEFAULT_RULER_CONTEXT_MENU_ID, PREFERENCE_COLOR_BACKGROUND, PREFERENCE_COLOR_BACKGROUND_SYSTEM_DEFAULT, PREFERENCE_COLOR_FIND_SCOPE, PREFERENCE_COLOR_FOREGROUND, PREFERENCE_COLOR_FOREGROUND_SYSTEM_DEFAULT, PREFERENCE_COLOR_SELECTION_BACKGROUND, PREFERENCE_COLOR_SELECTION_BACKGROUND_SYSTEM_DEFAULT, PREFERENCE_COLOR_SELECTION_FOREGROUND, PREFERENCE_COLOR_SELECTION_FOREGROUND_SYSTEM_DEFAULT, PREFERENCE_HOVER_ENRICH_MODE, PREFERENCE_HYPERLINK_KEY_MODIFIER, PREFERENCE_HYPERLINK_KEY_MODIFIER_MASK, PREFERENCE_HYPERLINKS_ENABLED, PREFERENCE_NAVIGATION_SMART_HOME_END, PREFERENCE_RULER_CONTRIBUTIONS, PREFERENCE_SHOW_CARRIAGE_RETURN, PREFERENCE_SHOW_ENCLOSED_IDEOGRAPHIC_SPACES, PREFERENCE_SHOW_ENCLOSED_SPACES, PREFERENCE_SHOW_ENCLOSED_TABS, PREFERENCE_SHOW_LEADING_IDEOGRAPHIC_SPACES, PREFERENCE_SHOW_LEADING_SPACES, PREFERENCE_SHOW_LEADING_TABS, PREFERENCE_SHOW_LINE_FEED, PREFERENCE_SHOW_TRAILING_IDEOGRAPHIC_SPACES, PREFERENCE_SHOW_TRAILING_SPACES, PREFERENCE_SHOW_TRAILING_TABS, PREFERENCE_SHOW_WHITESPACE_CHARACTERS, PREFERENCE_TEXT_DRAG_AND_DROP_ENABLED, PREFERENCE_USE_CUSTOM_CARETS, PREFERENCE_WHITESPACE_CHARACTER_ALPHA_VALUE, PREFERENCE_WIDE_CARET, PREFERENCE_WORD_WRAP_ENABLED

    Fields inherited from interface org.eclipse.ui.IEditorPart

    PROP_DIRTY, PROP_INPUT

    Fields inherited from interface org.eclipse.ui.texteditor.ITextEditorExtension3

    INSERT, SMART_INSERT

    Fields inherited from interface org.eclipse.ui.IWorkbenchPart

    PROP_TITLE

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxEditor()

  • Method Summary

    Modifier and Type
    Method
    Description
    static void
    closeAndReOpenCurrent()
    void
    createPartControl(org.eclipse.swt.widgets.Composite parent)
    void
    dispose()
    org.eclipse.jface.text.IRegion
    getFunctionRegion(String name, org.eclipse.jface.text.source.ISourceViewer viewer, String searchStr)
    org.eclipse.jface.text.IRegion
    getLocationOfElement(String propName, int curOffset, boolean isFunction)
    void
    highLightAttrib(String name)
    void
    highLightFunction(String name, String srchStr)
    void
    highLightRoutine(String name)
    void
    highLiteElementAtLine(int offset, int length)
    boolean
    isFunction(String propName)
    boolean
    isProperty(String propName)
    void
    setFocus()
    void
    showEditorInput(org.eclipse.ui.IEditorInput editorInput)
    void
    updateFoldingStructure(ArrayList<org.eclipse.jface.text.Position> positions)
    Checks whether the given positions are in the ProjectionAnnotationModel or in the addition set.

    Methods inherited from class org.eclipse.ui.editors.text.TextEditor

    getAdapter, isSaveAsAllowed

    Methods inherited from class org.eclipse.ui.texteditor.AbstractDecoratedTextEditor

    getDocumentProvider, gotoAnnotation, isChangeInformationShowing, isEditable, showChangeInformation, showRevisionInformation, validateEditorInputState

    Methods inherited from class org.eclipse.ui.texteditor.StatusTextEditor

    doRevertToSaved, updatePartControl

    Methods inherited from class org.eclipse.ui.texteditor.AbstractTextEditor

    addRulerContextMenuListener, close, createEmptyNavigationLocation, createNavigationLocation, doSave, doSaveAs, getAction, getActiveSaveables, getHighlightRange, getInsertMode, getSaveables, getSelectionProvider, init, isBlockSelectionModeEnabled, isDirty, isEditorInputModifiable, isEditorInputReadOnly, isWordWrapEnabled, markAsContentDependentAction, markAsPropertyDependentAction, markAsSelectionDependentAction, markAsStateDependentAction, removeActionActivationCode, removeRulerContextMenuListener, resetHighlightRange, restoreState, saveState, selectAndReveal, setAction, setActionActivationCode, setBlockSelectionMode, setHighlightRange, setInput, setInsertMode, setStatusField, setWordWrap, showHighlightRangeOnly, showsHighlightRangeOnly

    Methods inherited from class org.eclipse.ui.part.EditorPart

    getEditorInput, getEditorSite, getTitleToolTip, isSaveOnCloseNeeded, setInitializationData

    Methods inherited from class org.eclipse.ui.part.WorkbenchPart

    addPartPropertyListener, addPropertyListener, getContentDescription, getOrientation, getPartName, getPartProperties, getPartProperty, getSite, getTitle, getTitleImage, removePartPropertyListener, removePropertyListener, setPartProperty, showBusy

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface org.eclipse.ui.IEditorPart

    getEditorInput, getEditorSite

    Methods inherited from interface org.eclipse.ui.ISaveablePart

    isSaveOnCloseNeeded

    Methods inherited from interface org.eclipse.ui.IWorkbenchPart

    addPropertyListener, getSite, getTitle, getTitleImage, getTitleToolTip, removePropertyListener

  • Field Details

    • ID

      public static final String ID
      See Also:
      • Constant Field Values

  • Constructor Details

    • PvxEditor

      public PvxEditor()

  • Method Details

    • closeAndReOpenCurrent

      public static void closeAndReOpenCurrent()

    • dispose

      public void dispose()
      Specified by:
      dispose in interface org.eclipse.ui.IWorkbenchPart
      Overrides:
      dispose in class org.eclipse.ui.editors.text.TextEditor

    • getFunctionRegion

      public org.eclipse.jface.text.IRegion getFunctionRegion(String name, org.eclipse.jface.text.source.ISourceViewer viewer, String searchStr)

    • highLightFunction

      public void highLightFunction(String name, String srchStr)

    • getLocationOfElement

      public org.eclipse.jface.text.IRegion getLocationOfElement(String propName, int curOffset, boolean isFunction)

    • isProperty

      public boolean isProperty(String propName)

    • isFunction

      public boolean isFunction(String propName)

    • highLiteElementAtLine

      public void highLiteElementAtLine(int offset, int length)

    • highLightAttrib

      public void highLightAttrib(String name)

    • highLightRoutine

      public void highLightRoutine(String name)

    • showEditorInput

      public void showEditorInput(org.eclipse.ui.IEditorInput editorInput)
      Specified by:
      showEditorInput in interface org.eclipse.ui.IShowEditorInput

    • setFocus

      public void setFocus()
      Specified by:
      setFocus in interface org.eclipse.ui.IWorkbenchPart
      Overrides:
      setFocus in class org.eclipse.ui.texteditor.StatusTextEditor

    • createPartControl

      public void createPartControl(org.eclipse.swt.widgets.Composite parent)
      Specified by:
      createPartControl in interface org.eclipse.ui.IWorkbenchPart
      Overrides:
      createPartControl in class org.eclipse.ui.texteditor.AbstractDecoratedTextEditor

    • updateFoldingStructure

      public void updateFoldingStructure(ArrayList<org.eclipse.jface.text.Position> positions)

      Checks whether the given positions are in the ProjectionAnnotationModel or in the addition set. If not it tries to add into additions. Deletes old ProjectionAnnotation with line count less than 2.

      Parameters:
      positions - a list of available foldable positions


PvxParameterListValidator

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.editors

Class PvxParameterListValidator

java.lang.Object
com.pvx.ooadide.editors.PvxParameterListValidator
All Implemented Interfaces:
org.eclipse.jface.text.contentassist.IContextInformationPresenter, org.eclipse.jface.text.contentassist.IContextInformationValidator
public class PvxParameterListValidator extends Object implements org.eclipse.jface.text.contentassist.IContextInformationValidator, org.eclipse.jface.text.contentassist.IContextInformationPresenter

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxParameterListValidator()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    install(org.eclipse.jface.text.contentassist.IContextInformation info, org.eclipse.jface.text.ITextViewer viewer, int documentPosition)
    boolean
    isContextInformationValid(int position)
    static final boolean
    isFunctionStyle(String paramsStr)
    boolean
    updatePresentation(int position, org.eclipse.jface.text.TextPresentation presentation)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • PvxParameterListValidator

      public PvxParameterListValidator()

  • Method Details

    • install

      public void install(org.eclipse.jface.text.contentassist.IContextInformation info, org.eclipse.jface.text.ITextViewer viewer, int documentPosition)
      Specified by:
      install in interface org.eclipse.jface.text.contentassist.IContextInformationPresenter
      Specified by:
      install in interface org.eclipse.jface.text.contentassist.IContextInformationValidator
      See Also:
      • IContextInformationValidator.install(IContextInformation, ITextViewer, int)
      • IContextInformationPresenter.install(IContextInformation, ITextViewer, int)

    • isFunctionStyle

      public static final boolean isFunctionStyle(String paramsStr)

    • isContextInformationValid

      public boolean isContextInformationValid(int position)
      Specified by:
      isContextInformationValid in interface org.eclipse.jface.text.contentassist.IContextInformationValidator
      See Also:
      • IContextInformationValidator.isContextInformationValid(int)

    • updatePresentation

      public boolean updatePresentation(int position, org.eclipse.jface.text.TextPresentation presentation)
      Specified by:
      updatePresentation in interface org.eclipse.jface.text.contentassist.IContextInformationPresenter
      See Also:
      • IContextInformationPresenter.updatePresentation(int, TextPresentation)


TextHover

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.editors

Class TextHover

java.lang.Object
com.pvx.ooadide.editors.TextHover
All Implemented Interfaces:
org.eclipse.jface.text.ITextHover
public class TextHover extends Object implements org.eclipse.jface.text.ITextHover

  • Constructor Summary

    Constructors
    Constructor
    Description
    TextHover(org.eclipse.jface.text.source.ISourceViewer sourceViewer, String contentType)
    TextHover(org.eclipse.jface.text.source.ISourceViewer sourceViewer, String contentType, int stateMask)

  • Method Summary

    Modifier and Type
    Method
    Description
    String
    getHoverInfo(org.eclipse.jface.text.ITextViewer tv, org.eclipse.jface.text.IRegion r)
    org.eclipse.jface.text.IRegion
    getHoverRegion(org.eclipse.jface.text.ITextViewer textViewer, int offset)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • TextHover

      public TextHover(org.eclipse.jface.text.source.ISourceViewer sourceViewer, String contentType, int stateMask)

    • TextHover

      public TextHover(org.eclipse.jface.text.source.ISourceViewer sourceViewer, String contentType)

  • Method Details

    • getHoverInfo

      public String getHoverInfo(org.eclipse.jface.text.ITextViewer tv, org.eclipse.jface.text.IRegion r)
      Specified by:
      getHoverInfo in interface org.eclipse.jface.text.ITextHover

    • getHoverRegion

      public org.eclipse.jface.text.IRegion getHoverRegion(org.eclipse.jface.text.ITextViewer textViewer, int offset)
      Specified by:
      getHoverRegion in interface org.eclipse.jface.text.ITextHover


XEditorMatchingStrategy

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.editors

Class XEditorMatchingStrategy

java.lang.Object
com.pvx.ooadide.editors.XEditorMatchingStrategy
All Implemented Interfaces:
org.eclipse.ui.IEditorMatchingStrategy
public class XEditorMatchingStrategy extends Object implements org.eclipse.ui.IEditorMatchingStrategy

  • Constructor Summary

    Constructors
    Constructor
    Description
    XEditorMatchingStrategy()

  • Method Summary

    Modifier and Type
    Method
    Description
    static org.eclipse.ui.IEditorReference
    isFileOpenAlready(org.eclipse.core.resources.IFile file)
    static boolean
    isFileOpenAlready(org.eclipse.ui.IEditorReference editorRef, org.eclipse.core.resources.IFile file)
    boolean
    matches(org.eclipse.ui.IEditorReference editorRef, org.eclipse.ui.IEditorInput input)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • XEditorMatchingStrategy

      public XEditorMatchingStrategy()

  • Method Details

    • matches

      public boolean matches(org.eclipse.ui.IEditorReference editorRef, org.eclipse.ui.IEditorInput input)
      Specified by:
      matches in interface org.eclipse.ui.IEditorMatchingStrategy

    • isFileOpenAlready

      public static org.eclipse.ui.IEditorReference isFileOpenAlready(org.eclipse.core.resources.IFile file)

    • isFileOpenAlready

      public static boolean isFileOpenAlready(org.eclipse.ui.IEditorReference editorRef, org.eclipse.core.resources.IFile file)


com.pvx.ooadide.editors.autoindent

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.pvx.ooadide.editors.autoindent

package com.pvx.ooadide.editors.autoindent
  • Related Packages
    Package
    Description
    com.pvx.ooadide.editors
    com.pvx.ooadide.editors.codefolding
    com.pvx.ooadide.editors.extkeyword
    com.pvx.ooadide.editors.templates
  • Classes
    Class
    Description
    PvxAutoIndentStrategy
    Auto indent strategy sensitive to brackets.
    PvxPairMatcher


com.pvx.ooadide.editors.autoindent Class Hierarchy

Hierarchy For Package com.pvx.ooadide.editors.autoindent

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.eclipse.jface.text.DefaultIndentLineAutoEditStrategy (implements org.eclipse.jface.text.IAutoEditStrategy)
      • com.pvx.ooadide.editors.autoindent.PvxAutoIndentStrategy
    • com.pvx.ooadide.editors.autoindent.PvxPairMatcher (implements org.eclipse.jface.text.source.ICharacterPairMatcher)


Uses of Package com.pvx.ooadide.editors.autoindent

Uses of Package
com.pvx.ooadide.editors.autoindent

No usage of com.pvx.ooadide.editors.autoindent


PvxAutoIndentStrategy

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.editors.autoindent

Class PvxAutoIndentStrategy

java.lang.Object
org.eclipse.jface.text.DefaultIndentLineAutoEditStrategy
com.pvx.ooadide.editors.autoindent.PvxAutoIndentStrategy
All Implemented Interfaces:
org.eclipse.jface.text.IAutoEditStrategy
public class PvxAutoIndentStrategy extends org.eclipse.jface.text.DefaultIndentLineAutoEditStrategy
Auto indent strategy sensitive to brackets.

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxAutoIndentStrategy(String partitioning, org.eclipse.jdt.core.IJavaProject project)
    Creates a new Java auto indent strategy for the given document partitioning.

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    customizeDocumentCommand(org.eclipse.jface.text.IDocument d, org.eclipse.jface.text.DocumentCommand c)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • PvxAutoIndentStrategy

      public PvxAutoIndentStrategy(String partitioning, org.eclipse.jdt.core.IJavaProject project)
      Creates a new Java auto indent strategy for the given document partitioning.
      Parameters:
      partitioning - the document partitioning
      project - the project to get formatting preferences from, or null to use default preferences

  • Method Details

    • customizeDocumentCommand

      public void customizeDocumentCommand(org.eclipse.jface.text.IDocument d, org.eclipse.jface.text.DocumentCommand c)
      Specified by:
      customizeDocumentCommand in interface org.eclipse.jface.text.IAutoEditStrategy
      Overrides:
      customizeDocumentCommand in class org.eclipse.jface.text.DefaultIndentLineAutoEditStrategy


PvxPairMatcher

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.editors.autoindent

Class PvxPairMatcher

java.lang.Object
com.pvx.ooadide.editors.autoindent.PvxPairMatcher
All Implemented Interfaces:
org.eclipse.jface.text.source.ICharacterPairMatcher
public class PvxPairMatcher extends Object implements org.eclipse.jface.text.source.ICharacterPairMatcher

  • Field Summary

    Fields inherited from interface org.eclipse.jface.text.source.ICharacterPairMatcher

    LEFT, RIGHT

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxPairMatcher(char[] pairs)

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    clear()
    void
    dispose()
    int
    getAnchor()
    org.eclipse.jface.text.IRegion
    match(org.eclipse.jface.text.IDocument document, int offset)
    void
    setSourceVersion(String version)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • PvxPairMatcher

      public PvxPairMatcher(char[] pairs)

  • Method Details

    • match

      public org.eclipse.jface.text.IRegion match(org.eclipse.jface.text.IDocument document, int offset)
      Specified by:
      match in interface org.eclipse.jface.text.source.ICharacterPairMatcher

    • getAnchor

      public int getAnchor()
      Specified by:
      getAnchor in interface org.eclipse.jface.text.source.ICharacterPairMatcher

    • dispose

      public void dispose()
      Specified by:
      dispose in interface org.eclipse.jface.text.source.ICharacterPairMatcher

    • clear

      public void clear()
      Specified by:
      clear in interface org.eclipse.jface.text.source.ICharacterPairMatcher

    • setSourceVersion

      public void setSourceVersion(String version)


Uses of Class com.pvx.ooadide.editors.autoindent.PvxAutoIndentStrategy

Uses of Class
com.pvx.ooadide.editors.autoindent.PvxAutoIndentStrategy

No usage of com.pvx.ooadide.editors.autoindent.PvxAutoIndentStrategy


Uses of Class com.pvx.ooadide.editors.autoindent.PvxPairMatcher

Uses of Class
com.pvx.ooadide.editors.autoindent.PvxPairMatcher

No usage of com.pvx.ooadide.editors.autoindent.PvxPairMatcher


Uses of Class com.pvx.ooadide.editors.HandledInput

Uses of Class
com.pvx.ooadide.editors.HandledInput

No usage of com.pvx.ooadide.editors.HandledInput


Uses of Class com.pvx.ooadide.editors.LoadProgramAction

Uses of Class
com.pvx.ooadide.editors.LoadProgramAction

No usage of com.pvx.ooadide.editors.LoadProgramAction


Uses of Class com.pvx.ooadide.editors.MyCompletionProcessor

Uses of Class
com.pvx.ooadide.editors.MyCompletionProcessor

No usage of com.pvx.ooadide.editors.MyCompletionProcessor


Uses of Class com.pvx.ooadide.editors.NomadsEditor

Uses of Class
com.pvx.ooadide.editors.NomadsEditor

No usage of com.pvx.ooadide.editors.NomadsEditor


Uses of Class com.pvx.ooadide.editors.PvxAnnotationHover

Uses of Class
com.pvx.ooadide.editors.PvxAnnotationHover

No usage of com.pvx.ooadide.editors.PvxAnnotationHover


Uses of Class com.pvx.ooadide.editors.PvxCompletionProposal

Uses of Class
com.pvx.ooadide.editors.PvxCompletionProposal

Packages that use PvxCompletionProposal
Package
Description
com.pvx.ooadide.editors
com.pvx.ooadide.editors.extkeyword

  • Uses of PvxCompletionProposal in com.pvx.ooadide.editors

    Fields in com.pvx.ooadide.editors declared as PvxCompletionProposal
    Modifier and Type
    Field
    Description
    static PvxCompletionProposal[]
    MyCompletionProcessor.directivePropl
    static PvxCompletionProposal[]
    MyCompletionProcessor.mnemPropl
    static PvxCompletionProposal[]
    MyCompletionProcessor.sysFuncPropl
    static PvxCompletionProposal[]
    MyCompletionProcessor.sysVarPropl
    Methods in com.pvx.ooadide.editors that return PvxCompletionProposal
    Modifier and Type
    Method
    Description
    static PvxCompletionProposal[]
    MyCompletionProcessor.getAllCompletionProposals(org.eclipse.jface.text.contentassist.ICompletionProposal[] templates)
    static PvxCompletionProposal[]
    MyCompletionProcessor.getDirectiveCompletionProposals()
    static PvxCompletionProposal[]
    MyCompletionProcessor.getExtKeywordCompletionProposals()
    static PvxCompletionProposal[]
    MyCompletionProcessor.getMnemonicCompletionProposals()
    static PvxCompletionProposal[]
    MyCompletionProcessor.getSysFuncCompletionProposals()
    static PvxCompletionProposal[]
    MyCompletionProcessor.getSysVarsCompletionProposals()

  • Uses of PvxCompletionProposal in com.pvx.ooadide.editors.extkeyword

    Methods in com.pvx.ooadide.editors.extkeyword that return PvxCompletionProposal
    Modifier and Type
    Method
    Description
    PvxCompletionProposal[]
    ExtKeywordCategoryEntity.getPvxCompletionProposals()


Uses of Class com.pvx.ooadide.editors.PvxContextInformation

Uses of Class
com.pvx.ooadide.editors.PvxContextInformation

No usage of com.pvx.ooadide.editors.PvxContextInformation


Uses of Class com.pvx.ooadide.editors.PvxEditor

Uses of Class
com.pvx.ooadide.editors.PvxEditor

Packages that use PvxEditor
Package
Description
com.pvx.ooadide.codehilite2
com.pvx.ooadide.editors
com.pvx.ooadide.editors.codefolding
com.pvx.ooadide.refactor
com.pvx.ooadide.util

  • Uses of PvxEditor in com.pvx.ooadide.codehilite2

    Constructors in com.pvx.ooadide.codehilite2 with parameters of type PvxEditor
    Modifier
    Constructor
    Description

    XMLConfiguration2(ColorManager colorManager, PvxEditor init_pvxEditor)

  • Uses of PvxEditor in com.pvx.ooadide.editors

    Methods in com.pvx.ooadide.editors that return PvxEditor
    Modifier and Type
    Method
    Description
    static PvxEditor
    MyCompletionProcessor.getPvxEditor()
    Constructors in com.pvx.ooadide.editors with parameters of type PvxEditor
    Modifier
    Constructor
    Description

    MyCompletionProcessor(PvxEditor init_pvxEditor)

  • Uses of PvxEditor in com.pvx.ooadide.editors.codefolding

    Methods in com.pvx.ooadide.editors.codefolding that return PvxEditor
    Modifier and Type
    Method
    Description
    PvxEditor
    PvxReconcilingStrategy.getEditor()
    Methods in com.pvx.ooadide.editors.codefolding with parameters of type PvxEditor
    Modifier and Type
    Method
    Description
    void
    PvxReconcilingStrategy.setEditor(PvxEditor editor)

  • Uses of PvxEditor in com.pvx.ooadide.refactor

    Methods in com.pvx.ooadide.refactor that return PvxEditor
    Modifier and Type
    Method
    Description
    PvxEditor
    RenamePropertyInfo.getEditor()
    Methods in com.pvx.ooadide.refactor with parameters of type PvxEditor
    Modifier and Type
    Method
    Description
    void
    RenamePropertyInfo.setEditor(PvxEditor editor)

  • Uses of PvxEditor in com.pvx.ooadide.util

    Methods in com.pvx.ooadide.util that return PvxEditor
    Modifier and Type
    Method
    Description
    static final PvxEditor
    PvxUtil.getActivePvxEditor()


Uses of Class com.pvx.ooadide.editors.PvxParameterListValidator

Uses of Class
com.pvx.ooadide.editors.PvxParameterListValidator

No usage of com.pvx.ooadide.editors.PvxParameterListValidator


Uses of Class com.pvx.ooadide.editors.TextHover

Uses of Class
com.pvx.ooadide.editors.TextHover

No usage of com.pvx.ooadide.editors.TextHover


Uses of Class com.pvx.ooadide.editors.XEditorMatchingStrategy

Uses of Class
com.pvx.ooadide.editors.XEditorMatchingStrategy

No usage of com.pvx.ooadide.editors.XEditorMatchingStrategy


com.pvx.ooadide.editors.codefolding

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.pvx.ooadide.editors.codefolding

package com.pvx.ooadide.editors.codefolding
  • Related Packages
    Package
    Description
    com.pvx.ooadide.editors
    com.pvx.ooadide.editors.autoindent
    com.pvx.ooadide.editors.extkeyword
    com.pvx.ooadide.editors.templates
  • Classes
    Class
    Description
    PvxReconcilingStrategy


com.pvx.ooadide.editors.codefolding Class Hierarchy

Hierarchy For Package com.pvx.ooadide.editors.codefolding

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • com.pvx.ooadide.editors.codefolding.PvxReconcilingStrategy (implements org.eclipse.jface.text.reconciler.IReconcilingStrategy, org.eclipse.jface.text.reconciler.IReconcilingStrategyExtension)


Uses of Package com.pvx.ooadide.editors.codefolding

Uses of Package
com.pvx.ooadide.editors.codefolding

No usage of com.pvx.ooadide.editors.codefolding


PvxReconcilingStrategy

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.editors.codefolding

Class PvxReconcilingStrategy

java.lang.Object
com.pvx.ooadide.editors.codefolding.PvxReconcilingStrategy
All Implemented Interfaces:
org.eclipse.jface.text.reconciler.IReconcilingStrategy, org.eclipse.jface.text.reconciler.IReconcilingStrategyExtension
public class PvxReconcilingStrategy extends Object implements org.eclipse.jface.text.reconciler.IReconcilingStrategy, org.eclipse.jface.text.reconciler.IReconcilingStrategyExtension

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxReconcilingStrategy()
    Constructor: Load list of keywords used to identify the blocks of code in the source file

  • Method Summary

    Modifier and Type
    Method
    Description
    PvxEditor
    getEditor()
    void
    initialReconcile()
    void
    reconcile(org.eclipse.jface.text.IRegion partition)
    void
    reconcile(org.eclipse.jface.text.reconciler.DirtyRegion dirtyRegion, org.eclipse.jface.text.IRegion subRegion)
    void
    setDocument(org.eclipse.jface.text.IDocument document)
    void
    setEditor(PvxEditor editor)
    void
    setProgressMonitor(org.eclipse.core.runtime.IProgressMonitor monitor)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • PvxReconcilingStrategy

      public PvxReconcilingStrategy()
      Constructor: Load list of keywords used to identify the blocks of code in the source file

  • Method Details

    • getEditor

      public PvxEditor getEditor()
      Returns:
      Returns the editor.

    • setEditor

      public void setEditor(PvxEditor editor)

    • setDocument

      public void setDocument(org.eclipse.jface.text.IDocument document)
      Specified by:
      setDocument in interface org.eclipse.jface.text.reconciler.IReconcilingStrategy

    • reconcile

      public void reconcile(org.eclipse.jface.text.reconciler.DirtyRegion dirtyRegion, org.eclipse.jface.text.IRegion subRegion)
      Specified by:
      reconcile in interface org.eclipse.jface.text.reconciler.IReconcilingStrategy

    • reconcile

      public void reconcile(org.eclipse.jface.text.IRegion partition)
      Specified by:
      reconcile in interface org.eclipse.jface.text.reconciler.IReconcilingStrategy

    • setProgressMonitor

      public void setProgressMonitor(org.eclipse.core.runtime.IProgressMonitor monitor)
      Specified by:
      setProgressMonitor in interface org.eclipse.jface.text.reconciler.IReconcilingStrategyExtension

    • initialReconcile

      public void initialReconcile()
      Specified by:
      initialReconcile in interface org.eclipse.jface.text.reconciler.IReconcilingStrategyExtension


Uses of Class com.pvx.ooadide.editors.codefolding.PvxReconcilingStrategy

Uses of Class
com.pvx.ooadide.editors.codefolding.PvxReconcilingStrategy

No usage of com.pvx.ooadide.editors.codefolding.PvxReconcilingStrategy


ExtKeywordCategoryEntity

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.editors.extkeyword

Class ExtKeywordCategoryEntity

java.lang.Object
com.pvx.ooadide.editors.extkeyword.ExtKeywordCategoryEntity
public class ExtKeywordCategoryEntity extends Object

  • Constructor Summary

    Constructors
    Constructor
    Description
    ExtKeywordCategoryEntity(String nxtKey, String path, org.eclipse.swt.graphics.Image initImage, IPvxIdePlugin initfPlugin)

  • Method Summary

    Modifier and Type
    Method
    Description
    String[]
    getAllKeywords()
    String
    getCategoryName()
    IPvxIdePlugin
    getFPlugin()
    Hashtable
    getKeywordsHashtable()
    PvxCompletionProposal[]
    getPvxCompletionProposals()
    void
    setAllKeywords(String[] allKeywords)
    void
    setCategoryName(String fCategoryName)
    void
    setFPlugin(IPvxIdePlugin fPlugin)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • ExtKeywordCategoryEntity

      public ExtKeywordCategoryEntity(String nxtKey, String path, org.eclipse.swt.graphics.Image initImage, IPvxIdePlugin initfPlugin)

  • Method Details

    • getPvxCompletionProposals

      public PvxCompletionProposal[] getPvxCompletionProposals()

    • setAllKeywords

      public void setAllKeywords(String[] allKeywords)

    • getAllKeywords

      public String[] getAllKeywords()

    • getKeywordsHashtable

      public Hashtable getKeywordsHashtable()

    • setCategoryName

      public void setCategoryName(String fCategoryName)

    • getCategoryName

      public String getCategoryName()

    • setFPlugin

      public void setFPlugin(IPvxIdePlugin fPlugin)

    • getFPlugin

      public IPvxIdePlugin getFPlugin()


com.pvx.ooadide.editors.extkeyword

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.pvx.ooadide.editors.extkeyword

package com.pvx.ooadide.editors.extkeyword
  • Related Packages
    Package
    Description
    com.pvx.ooadide.editors
    com.pvx.ooadide.editors.autoindent
    com.pvx.ooadide.editors.codefolding
    com.pvx.ooadide.editors.templates
  • Classes
    Class
    Description
    ExtKeywordCategoryEntity


com.pvx.ooadide.editors.extkeyword Class Hierarchy

Hierarchy For Package com.pvx.ooadide.editors.extkeyword

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • com.pvx.ooadide.editors.extkeyword.ExtKeywordCategoryEntity


Uses of Package com.pvx.ooadide.editors.extkeyword

Uses of Package
com.pvx.ooadide.editors.extkeyword

Packages that use com.pvx.ooadide.editors.extkeyword
Package
Description
com.pvx.ooadide.editors
  • Classes in com.pvx.ooadide.editors.extkeyword used by com.pvx.ooadide.editors
    Class
    Description
    ExtKeywordCategoryEntity


Uses of Class com.pvx.ooadide.editors.extkeyword.ExtKeywordCategoryEntity

Uses of Class
com.pvx.ooadide.editors.extkeyword.ExtKeywordCategoryEntity

Packages that use ExtKeywordCategoryEntity
Package
Description
com.pvx.ooadide.editors

  • Uses of ExtKeywordCategoryEntity in com.pvx.ooadide.editors

    Fields in com.pvx.ooadide.editors with type parameters of type ExtKeywordCategoryEntity
    Modifier and Type
    Field
    Description
    static ArrayList<ExtKeywordCategoryEntity>
    MyCompletionProcessor.extKeywordsEntityList
    Methods in com.pvx.ooadide.editors that return types with arguments of type ExtKeywordCategoryEntity
    Modifier and Type
    Method
    Description
    static ArrayList<ExtKeywordCategoryEntity>
    MyCompletionProcessor.getExtKeywordCategories()
    static ArrayList<ExtKeywordCategoryEntity>
    MyCompletionProcessor.loadExtKeywordCategories()


FlagsPropertyResolver

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.editors.templates

Class FlagsPropertyResolver

java.lang.Object
org.eclipse.jface.text.templates.TemplateVariableResolver
com.pvx.ooadide.editors.templates.PvxPropertyResolver
com.pvx.ooadide.editors.templates.FlagsPropertyResolver
public class FlagsPropertyResolver extends PvxPropertyResolver

  • Constructor Summary

    Constructors
    Constructor
    Description
    FlagsPropertyResolver()

  • Method Summary

    Methods inherited from class com.pvx.ooadide.editors.templates.PvxPropertyResolver

    resolvePropertyOnFile

    Methods inherited from class org.eclipse.jface.text.templates.TemplateVariableResolver

    getDescription, getType, resolve, setDescription, setType

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • FlagsPropertyResolver

      public FlagsPropertyResolver()


IsLineNoReqPropertyResolver

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.editors.templates

Class IsLineNoReqPropertyResolver

java.lang.Object
org.eclipse.jface.text.templates.TemplateVariableResolver
com.pvx.ooadide.editors.templates.PvxPropertyResolver
com.pvx.ooadide.editors.templates.IsLineNoReqPropertyResolver
public class IsLineNoReqPropertyResolver extends PvxPropertyResolver

  • Constructor Summary

    Constructors
    Constructor
    Description
    IsLineNoReqPropertyResolver()

  • Method Summary

    Methods inherited from class com.pvx.ooadide.editors.templates.PvxPropertyResolver

    resolvePropertyOnFile

    Methods inherited from class org.eclipse.jface.text.templates.TemplateVariableResolver

    getDescription, getType, resolve, setDescription, setType

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • IsLineNoReqPropertyResolver

      public IsLineNoReqPropertyResolver()


NewLineResolver

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.editors.templates

Class NewLineResolver

java.lang.Object
org.eclipse.jface.text.templates.TemplateVariableResolver
com.pvx.ooadide.editors.templates.PvxPropertyResolver
com.pvx.ooadide.editors.templates.NewLineResolver
public class NewLineResolver extends PvxPropertyResolver

  • Constructor Summary

    Constructors
    Constructor
    Description
    NewLineResolver()

  • Method Summary

    Modifier and Type
    Method
    Description
    static String
    getSystemDelimiter()

    Methods inherited from class com.pvx.ooadide.editors.templates.PvxPropertyResolver

    resolvePropertyOnFile

    Methods inherited from class org.eclipse.jface.text.templates.TemplateVariableResolver

    getDescription, getType, resolve, setDescription, setType

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • NewLineResolver

      public NewLineResolver()

  • Method Details

    • getSystemDelimiter

      public static String getSystemDelimiter()


OutputPropertyResolver

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.editors.templates

Class OutputPropertyResolver

java.lang.Object
org.eclipse.jface.text.templates.TemplateVariableResolver
com.pvx.ooadide.editors.templates.PvxPropertyResolver
com.pvx.ooadide.editors.templates.OutputPropertyResolver
public class OutputPropertyResolver extends PvxPropertyResolver

  • Constructor Summary

    Constructors
    Constructor
    Description
    OutputPropertyResolver()

  • Method Summary

    Methods inherited from class com.pvx.ooadide.editors.templates.PvxPropertyResolver

    resolvePropertyOnFile

    Methods inherited from class org.eclipse.jface.text.templates.TemplateVariableResolver

    getDescription, getType, resolve, setDescription, setType

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • OutputPropertyResolver

      public OutputPropertyResolver()


OwnerPropertyResolver

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.editors.templates

Class OwnerPropertyResolver

java.lang.Object
org.eclipse.jface.text.templates.TemplateVariableResolver
com.pvx.ooadide.editors.templates.PvxPropertyResolver
com.pvx.ooadide.editors.templates.OwnerPropertyResolver
public class OwnerPropertyResolver extends PvxPropertyResolver

  • Constructor Summary

    Constructors
    Constructor
    Description
    OwnerPropertyResolver()

  • Method Summary

    Methods inherited from class com.pvx.ooadide.editors.templates.PvxPropertyResolver

    resolvePropertyOnFile

    Methods inherited from class org.eclipse.jface.text.templates.TemplateVariableResolver

    getDescription, getType, resolve, setDescription, setType

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • OwnerPropertyResolver

      public OwnerPropertyResolver()


com.pvx.ooadide.editors.templates

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.pvx.ooadide.editors.templates

package com.pvx.ooadide.editors.templates
  • Related Packages
    Package
    Description
    com.pvx.ooadide.editors
    com.pvx.ooadide.editors.autoindent
    com.pvx.ooadide.editors.codefolding
    com.pvx.ooadide.editors.extkeyword
  • Classes
    Class
    Description
    FlagsPropertyResolver
    IsLineNoReqPropertyResolver
    NewLineResolver
    OutputPropertyResolver
    OwnerPropertyResolver
    PasswordPropertyResolver
    PVXContextType
    A very simple context type.
    PvxPropertyResolver
    SageCopyrightPropertyResolver
    TemplateEditorUI
    The main plugin class to be used in the desktop.
    TemplateMessages
    TemplatesPreferencePage
    VersionControlIdPropertyResolver


com.pvx.ooadide.editors.templates Class Hierarchy

Hierarchy For Package com.pvx.ooadide.editors.templates

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.eclipse.jface.dialogs.DialogPage (implements org.eclipse.jface.dialogs.IDialogPage, org.eclipse.jface.dialogs.IMessageProvider)
      • org.eclipse.jface.preference.PreferencePage (implements org.eclipse.jface.preference.IPreferencePage)
        • org.eclipse.ui.texteditor.templates.TemplatePreferencePage (implements org.eclipse.ui.IWorkbenchPreferencePage)
          • com.pvx.ooadide.editors.templates.TemplatesPreferencePage (implements org.eclipse.ui.IWorkbenchPreferencePage)
    • org.eclipse.jface.text.templates.TemplateContextType
      • com.pvx.ooadide.editors.templates.PVXContextType
    • com.pvx.ooadide.editors.templates.TemplateEditorUI
    • com.pvx.ooadide.editors.templates.TemplateMessages
    • org.eclipse.jface.text.templates.TemplateVariableResolver
      • com.pvx.ooadide.editors.templates.PvxPropertyResolver
        • com.pvx.ooadide.editors.templates.FlagsPropertyResolver
        • com.pvx.ooadide.editors.templates.IsLineNoReqPropertyResolver
        • com.pvx.ooadide.editors.templates.NewLineResolver
        • com.pvx.ooadide.editors.templates.OutputPropertyResolver
        • com.pvx.ooadide.editors.templates.OwnerPropertyResolver
        • com.pvx.ooadide.editors.templates.PasswordPropertyResolver
        • com.pvx.ooadide.editors.templates.SageCopyrightPropertyResolver
        • com.pvx.ooadide.editors.templates.VersionControlIdPropertyResolver


Uses of Package com.pvx.ooadide.editors.templates

Uses of Package
com.pvx.ooadide.editors.templates

Packages that use com.pvx.ooadide.editors.templates
Package
Description
com.pvx.ooadide.editors.templates
  • Classes in com.pvx.ooadide.editors.templates used by com.pvx.ooadide.editors.templates
    Class
    Description
    PvxPropertyResolver
    TemplateEditorUI
    The main plugin class to be used in the desktop.


PasswordPropertyResolver

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.editors.templates

Class PasswordPropertyResolver

java.lang.Object
org.eclipse.jface.text.templates.TemplateVariableResolver
com.pvx.ooadide.editors.templates.PvxPropertyResolver
com.pvx.ooadide.editors.templates.PasswordPropertyResolver
public class PasswordPropertyResolver extends PvxPropertyResolver

  • Constructor Summary

    Constructors
    Constructor
    Description
    PasswordPropertyResolver()

  • Method Summary

    Methods inherited from class com.pvx.ooadide.editors.templates.PvxPropertyResolver

    resolvePropertyOnFile

    Methods inherited from class org.eclipse.jface.text.templates.TemplateVariableResolver

    getDescription, getType, resolve, setDescription, setType

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • PasswordPropertyResolver

      public PasswordPropertyResolver()


PVXContextType

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.editors.templates

Class PVXContextType

java.lang.Object
org.eclipse.jface.text.templates.TemplateContextType
com.pvx.ooadide.editors.templates.PVXContextType
public class PVXContextType extends org.eclipse.jface.text.templates.TemplateContextType
A very simple context type.

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final String
    PVX_CONTEXT_TYPE
    This context's id

  • Constructor Summary

    Constructors
    Constructor
    Description
    PVXContextType()
    Creates a new PVX context type.

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    resolve(org.eclipse.jface.text.templates.TemplateBuffer buffer, org.eclipse.jface.text.templates.TemplateContext context)

    Methods inherited from class org.eclipse.jface.text.templates.TemplateContextType

    addResolver, getId, getName, removeAllResolvers, removeResolver, resolve, resolvers, setId, setName, validate

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Field Details

    • PVX_CONTEXT_TYPE

      public static final String PVX_CONTEXT_TYPE
      This context's id
      See Also:
      • Constant Field Values

  • Constructor Details

    • PVXContextType

      public PVXContextType()
      Creates a new PVX context type.

  • Method Details

    • resolve

      public void resolve(org.eclipse.jface.text.templates.TemplateBuffer buffer, org.eclipse.jface.text.templates.TemplateContext context) throws org.eclipse.text.edits.MalformedTreeException, org.eclipse.jface.text.BadLocationException
      Overrides:
      resolve in class org.eclipse.jface.text.templates.TemplateContextType
      Throws:
      org.eclipse.text.edits.MalformedTreeException
      org.eclipse.jface.text.BadLocationException


PvxPropertyResolver

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.editors.templates

Class PvxPropertyResolver

java.lang.Object
org.eclipse.jface.text.templates.TemplateVariableResolver
com.pvx.ooadide.editors.templates.PvxPropertyResolver
Direct Known Subclasses:
FlagsPropertyResolver, IsLineNoReqPropertyResolver, NewLineResolver, OutputPropertyResolver, OwnerPropertyResolver, PasswordPropertyResolver, SageCopyrightPropertyResolver, VersionControlIdPropertyResolver
public class PvxPropertyResolver extends org.eclipse.jface.text.templates.TemplateVariableResolver

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxPropertyResolver()

  • Method Summary

    Modifier and Type
    Method
    Description
    String
    resolvePropertyOnFile(String propertyKey, org.eclipse.jface.text.templates.TemplateContext context)

    Methods inherited from class org.eclipse.jface.text.templates.TemplateVariableResolver

    getDescription, getType, resolve, setDescription, setType

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • PvxPropertyResolver

      public PvxPropertyResolver()

  • Method Details

    • resolvePropertyOnFile

      public String resolvePropertyOnFile(String propertyKey, org.eclipse.jface.text.templates.TemplateContext context)


SageCopyrightPropertyResolver

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.editors.templates

Class SageCopyrightPropertyResolver

java.lang.Object
org.eclipse.jface.text.templates.TemplateVariableResolver
com.pvx.ooadide.editors.templates.PvxPropertyResolver
com.pvx.ooadide.editors.templates.SageCopyrightPropertyResolver
public class SageCopyrightPropertyResolver extends PvxPropertyResolver

  • Constructor Summary

    Constructors
    Constructor
    Description
    SageCopyrightPropertyResolver()

  • Method Summary

    Methods inherited from class com.pvx.ooadide.editors.templates.PvxPropertyResolver

    resolvePropertyOnFile

    Methods inherited from class org.eclipse.jface.text.templates.TemplateVariableResolver

    getDescription, getType, resolve, setDescription, setType

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • SageCopyrightPropertyResolver

      public SageCopyrightPropertyResolver()


TemplateEditorUI

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.editors.templates

Class TemplateEditorUI

java.lang.Object
com.pvx.ooadide.editors.templates.TemplateEditorUI
public class TemplateEditorUI extends Object
The main plugin class to be used in the desktop.

  • Method Summary

    Modifier and Type
    Method
    Description
    org.eclipse.jface.text.templates.ContextTypeRegistry
    getContextTypeRegistry()
    Returns this plug-in's context type registry.
    static TemplateEditorUI
    getDefault()
    Returns the shared instance.
    org.eclipse.jface.resource.ImageRegistry
    getImageRegistry()
    org.eclipse.jface.preference.IPreferenceStore
    getPreferenceStore()
    org.eclipse.jface.text.templates.persistence.TemplateStore
    getTemplateStore()
    Returns this plug-in's template store.
    static org.eclipse.jface.resource.ImageDescriptor
    imageDescriptorFromPlugin(String string, String default_image)
    void
    savePluginPreferences()

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Method Details

    • getDefault

      public static TemplateEditorUI getDefault()
      Returns the shared instance.
      Returns:
      the shared instance

    • getTemplateStore

      public org.eclipse.jface.text.templates.persistence.TemplateStore getTemplateStore()
      Returns this plug-in's template store.
      Returns:
      the template store of this plug-in instance

    • getContextTypeRegistry

      public org.eclipse.jface.text.templates.ContextTypeRegistry getContextTypeRegistry()
      Returns this plug-in's context type registry.
      Returns:
      the context type registry for this plug-in instance

    • getImageRegistry

      public org.eclipse.jface.resource.ImageRegistry getImageRegistry()

    • imageDescriptorFromPlugin

      public static org.eclipse.jface.resource.ImageDescriptor imageDescriptorFromPlugin(String string, String default_image)

    • getPreferenceStore

      public org.eclipse.jface.preference.IPreferenceStore getPreferenceStore()

    • savePluginPreferences

      public void savePluginPreferences()


TemplateMessages

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.editors.templates

Class TemplateMessages

java.lang.Object
com.pvx.ooadide.editors.templates.TemplateMessages
public class TemplateMessages extends Object

  • Method Summary

    Modifier and Type
    Method
    Description
    static String
    getFormattedString(String key, Object arg)
    static String
    getFormattedString(String key, Object[] args)
    static ResourceBundle
    getResourceBundle()
    static String
    getString(String key)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Method Details

    • getString

      public static String getString(String key)

    • getFormattedString

      public static String getFormattedString(String key, Object arg)

    • getFormattedString

      public static String getFormattedString(String key, Object[] args)

    • getResourceBundle

      public static ResourceBundle getResourceBundle()


TemplatesPreferencePage

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.editors.templates

Class TemplatesPreferencePage

java.lang.Object
org.eclipse.jface.dialogs.DialogPage
org.eclipse.jface.preference.PreferencePage
org.eclipse.ui.texteditor.templates.TemplatePreferencePage
com.pvx.ooadide.editors.templates.TemplatesPreferencePage
All Implemented Interfaces:
org.eclipse.jface.dialogs.IDialogPage, org.eclipse.jface.dialogs.IMessageProvider, org.eclipse.jface.preference.IPreferencePage, org.eclipse.ui.IWorkbenchPreferencePage
public class TemplatesPreferencePage extends org.eclipse.ui.texteditor.templates.TemplatePreferencePage implements org.eclipse.ui.IWorkbenchPreferencePage
See Also:
  • PreferencePage

  • Field Summary

    Fields inherited from interface org.eclipse.jface.dialogs.IMessageProvider

    ERROR, INFORMATION, NONE, WARNING

  • Constructor Summary

    Constructors
    Constructor
    Description
    TemplatesPreferencePage()

  • Method Summary

    Modifier and Type
    Method
    Description
    boolean
    performOk()

    Methods inherited from class org.eclipse.ui.texteditor.templates.TemplatePreferencePage

    getContextTypeRegistry, getTemplateStore, init, performCancel, setContextTypeRegistry, setTemplateStore, setVisible

    Methods inherited from class org.eclipse.jface.preference.PreferencePage

    applyData, computeSize, createControl, getContainer, getPreferenceStore, isValid, okToLeave, performHelp, setContainer, setErrorMessage, setMessage, setPreferenceStore, setSize, setTitle, setValid, toString

    Methods inherited from class org.eclipse.jface.dialogs.DialogPage

    dispose, getControl, getDescription, getErrorMessage, getImage, getMessage, getMessageType, getShell, getTitle, setDescription, setImageDescriptor, setMessage

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

    Methods inherited from interface org.eclipse.jface.dialogs.IDialogPage

    createControl, dispose, getControl, getDescription, getErrorMessage, getImage, getMessage, getTitle, performHelp, setDescription, setImageDescriptor, setTitle, setVisible

    Methods inherited from interface org.eclipse.jface.preference.IPreferencePage

    computeSize, isValid, okToLeave, performCancel, setContainer, setSize

    Methods inherited from interface org.eclipse.ui.IWorkbenchPreferencePage

    init

  • Constructor Details

    • TemplatesPreferencePage

      public TemplatesPreferencePage()

  • Method Details

    • performOk

      public boolean performOk()
      Specified by:
      performOk in interface org.eclipse.jface.preference.IPreferencePage
      Overrides:
      performOk in class org.eclipse.ui.texteditor.templates.TemplatePreferencePage


VersionControlIdPropertyResolver

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.editors.templates

Class VersionControlIdPropertyResolver

java.lang.Object
org.eclipse.jface.text.templates.TemplateVariableResolver
com.pvx.ooadide.editors.templates.PvxPropertyResolver
com.pvx.ooadide.editors.templates.VersionControlIdPropertyResolver
public class VersionControlIdPropertyResolver extends PvxPropertyResolver

  • Constructor Summary

    Constructors
    Constructor
    Description
    VersionControlIdPropertyResolver()

  • Method Summary

    Methods inherited from class com.pvx.ooadide.editors.templates.PvxPropertyResolver

    resolvePropertyOnFile

    Methods inherited from class org.eclipse.jface.text.templates.TemplateVariableResolver

    getDescription, getType, resolve, setDescription, setType

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • VersionControlIdPropertyResolver

      public VersionControlIdPropertyResolver()


Uses of Class com.pvx.ooadide.editors.templates.FlagsPropertyResolver

Uses of Class
com.pvx.ooadide.editors.templates.FlagsPropertyResolver

No usage of com.pvx.ooadide.editors.templates.FlagsPropertyResolver


Uses of Class com.pvx.ooadide.editors.templates.IsLineNoReqPropertyResolver

Uses of Class
com.pvx.ooadide.editors.templates.IsLineNoReqPropertyResolver

No usage of com.pvx.ooadide.editors.templates.IsLineNoReqPropertyResolver


Uses of Class com.pvx.ooadide.editors.templates.NewLineResolver

Uses of Class
com.pvx.ooadide.editors.templates.NewLineResolver

No usage of com.pvx.ooadide.editors.templates.NewLineResolver


Uses of Class com.pvx.ooadide.editors.templates.OutputPropertyResolver

Uses of Class
com.pvx.ooadide.editors.templates.OutputPropertyResolver

No usage of com.pvx.ooadide.editors.templates.OutputPropertyResolver


Uses of Class com.pvx.ooadide.editors.templates.OwnerPropertyResolver

Uses of Class
com.pvx.ooadide.editors.templates.OwnerPropertyResolver

No usage of com.pvx.ooadide.editors.templates.OwnerPropertyResolver


Uses of Class com.pvx.ooadide.editors.templates.PasswordPropertyResolver

Uses of Class
com.pvx.ooadide.editors.templates.PasswordPropertyResolver

No usage of com.pvx.ooadide.editors.templates.PasswordPropertyResolver


Uses of Class com.pvx.ooadide.editors.templates.PVXContextType

Uses of Class
com.pvx.ooadide.editors.templates.PVXContextType

No usage of com.pvx.ooadide.editors.templates.PVXContextType


Uses of Class com.pvx.ooadide.editors.templates.PvxPropertyResolver

Uses of Class
com.pvx.ooadide.editors.templates.PvxPropertyResolver

Packages that use PvxPropertyResolver
Package
Description
com.pvx.ooadide.editors.templates

  • Uses of PvxPropertyResolver in com.pvx.ooadide.editors.templates

    Subclasses of PvxPropertyResolver in com.pvx.ooadide.editors.templates
    Modifier and Type
    Class
    Description
    class
    FlagsPropertyResolver
    class
    IsLineNoReqPropertyResolver
    class
    NewLineResolver
    class
    OutputPropertyResolver
    class
    OwnerPropertyResolver
    class
    PasswordPropertyResolver
    class
    SageCopyrightPropertyResolver
    class
    VersionControlIdPropertyResolver


Uses of Class com.pvx.ooadide.editors.templates.SageCopyrightPropertyResolver

Uses of Class
com.pvx.ooadide.editors.templates.SageCopyrightPropertyResolver

No usage of com.pvx.ooadide.editors.templates.SageCopyrightPropertyResolver


Uses of Class com.pvx.ooadide.editors.templates.TemplateEditorUI

Uses of Class
com.pvx.ooadide.editors.templates.TemplateEditorUI

Packages that use TemplateEditorUI
Package
Description
com.pvx.ooadide.editors.templates

  • Uses of TemplateEditorUI in com.pvx.ooadide.editors.templates

    Methods in com.pvx.ooadide.editors.templates that return TemplateEditorUI
    Modifier and Type
    Method
    Description
    static TemplateEditorUI
    TemplateEditorUI.getDefault()
    Returns the shared instance.


Uses of Class com.pvx.ooadide.editors.templates.TemplateMessages

Uses of Class
com.pvx.ooadide.editors.templates.TemplateMessages

No usage of com.pvx.ooadide.editors.templates.TemplateMessages


Uses of Class com.pvx.ooadide.editors.templates.TemplatesPreferencePage

Uses of Class
com.pvx.ooadide.editors.templates.TemplatesPreferencePage

No usage of com.pvx.ooadide.editors.templates.TemplatesPreferencePage


Uses of Class com.pvx.ooadide.editors.templates.VersionControlIdPropertyResolver

Uses of Class
com.pvx.ooadide.editors.templates.VersionControlIdPropertyResolver

No usage of com.pvx.ooadide.editors.templates.VersionControlIdPropertyResolver


DelayedAction

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.eventmanager

Class DelayedAction

java.lang.Object
com.pvx.ooadide.eventmanager.DelayedAction
public class DelayedAction extends Object

  • Constructor Summary

    Constructors
    Constructor
    Description
    DelayedAction(org.eclipse.jface.action.IAction argAction)

  • Method Summary

    Modifier and Type
    Method
    Description
    org.eclipse.jface.action.IAction
    getDelayedAction()

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • DelayedAction

      public DelayedAction(org.eclipse.jface.action.IAction argAction)

  • Method Details

    • getDelayedAction

      public org.eclipse.jface.action.IAction getDelayedAction()
      Returns:
      the delayedAction


DelayedEvent

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.eventmanager

Class DelayedEvent

java.lang.Object
com.pvx.ooadide.eventmanager.DelayedEvent
public class DelayedEvent extends Object

  • Constructor Summary

    Constructors
    Constructor
    Description
    DelayedEvent(boolean init_Block, String init_EventName, String init_Detail, Properties init_BuildProps)

  • Method Summary

    Modifier and Type
    Method
    Description
    Properties
    getBuildProps()
    String
    getDetail()
    String
    getEventName()
    boolean
    isBlock()

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • DelayedEvent

      public DelayedEvent(boolean init_Block, String init_EventName, String init_Detail, Properties init_BuildProps)

  • Method Details

    • isBlock

      public boolean isBlock()
      Returns:
      the block

    • getEventName

      public String getEventName()
      Returns:
      the eventName

    • getDetail

      public String getDetail()
      Returns:
      the detail

    • getBuildProps

      public Properties getBuildProps()
      Returns:
      the buildProps


DelayedMethodCall

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.eventmanager

Class DelayedMethodCall

java.lang.Object
com.pvx.ooadide.eventmanager.DelayedMethodCall
public class DelayedMethodCall extends Object

  • Constructor Summary

    Constructors
    Constructor
    Description
    DelayedMethodCall(Object[] init_params, Method init_method, Object init_subjectObj, boolean inEvntQue)

  • Method Summary

    Modifier and Type
    Method
    Description
    Object
    getSubjectObj()
    boolean
    isExecuteInEvntQue()
    void
    setSubjectObj(Object subjectObj)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • DelayedMethodCall

      public DelayedMethodCall(Object[] init_params, Method init_method, Object init_subjectObj, boolean inEvntQue)

  • Method Details

    • setSubjectObj

      public void setSubjectObj(Object subjectObj)

    • getSubjectObj

      public Object getSubjectObj()

    • isExecuteInEvntQue

      public boolean isExecuteInEvntQue()


DelayedMethodHandler

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.eventmanager

Class DelayedMethodHandler

java.lang.Object
com.pvx.ooadide.eventmanager.DelayedMethodHandler
public class DelayedMethodHandler extends Object

  • Constructor Summary

    Constructors
    Constructor
    Description
    DelayedMethodHandler()

  • Method Summary

    Modifier and Type
    Method
    Description
    static void
    addMethod(DelayedMethodCall methodToCall)
    static void
    addMethodToInvokeLaterList(Object subject, Class[] paramsClass, Object[] params, String methodName)
    static Object
    callMethod(Method method, Object[] arguments, Object subject)
    static void
    callMethods()
    static void
    removeAll()

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • DelayedMethodHandler

      public DelayedMethodHandler()

  • Method Details

    • callMethod

      public static Object callMethod(Method method, Object[] arguments, Object subject)

    • addMethod

      public static void addMethod(DelayedMethodCall methodToCall)

    • removeAll

      public static void removeAll()

    • callMethods

      public static void callMethods()

    • addMethodToInvokeLaterList

      public static void addMethodToInvokeLaterList(Object subject, Class[] paramsClass, Object[] params, String methodName)


EditorManager

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.eventmanager

Class EditorManager

java.lang.Object
com.pvx.ooadide.eventmanager.EditorManager
public class EditorManager extends Object

  • Constructor Summary

    Constructors
    Constructor
    Description
    EditorManager()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    closeEditor()
    void
    closeEditor(boolean save)
    void
    insertText(String text, int position)
    Inserts text at the specified position with in the open pvx
    void
    openFile(String absolutePath)
    void
    openFile(String absolutePath, int lineNo, int length)
    Scroll editor to a line and select text in the pvx editor if the file is not open the open a file first
    void
    replaceText(org.eclipse.jface.text.ITextSelection selection, String newText)
    Inserts text at the current cursor position in the open pvx editor.
    EditorState
    takeSnapShot()

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • EditorManager

      public EditorManager()

  • Method Details

    • takeSnapShot

      public EditorState takeSnapShot()

    • replaceText

      public void replaceText(org.eclipse.jface.text.ITextSelection selection, String newText)
      Inserts text at the current cursor position in the open pvx editor. If there's text selected in the pvx editor then replace currently selected text with the specified text
      Parameters:
      text - -The text to insert/paste into document

    • insertText

      public void insertText(String text, int position)
      Inserts text at the specified position with in the open pvx
      Parameters:
      text - -The text to insert/paste into document
      position - -The position to insert/paste into document

    • openFile

      public void openFile(String absolutePath, int lineNo, int length)
      Scroll editor to a line and select text in the pvx editor if the file is not open the open a file first
      Parameters:
      absolutePath - file to open
      lineNumber - line number to display
      length - number of chars to select

    • openFile

      public void openFile(String absolutePath)
      Parameters:
      absolutePath - to file to open

    • closeEditor

      public void closeEditor()

    • closeEditor

      public void closeEditor(boolean save)


EditorState

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.eventmanager

Class EditorState

java.lang.Object
com.pvx.ooadide.eventmanager.EditorState
public class EditorState extends Object

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    int
    cAbsoluteCursorPosition
    String
    cFile
    org.eclipse.jface.text.ITextSelection
    cTextSelection
    boolean
    initialized

  • Constructor Summary

    Constructors
    Constructor
    Description
    EditorState()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    initializeEditorState(String f, org.eclipse.jface.text.ITextSelection t, int cp)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Field Details

    • cFile

      public String cFile

    • cTextSelection

      public org.eclipse.jface.text.ITextSelection cTextSelection

    • cAbsoluteCursorPosition

      public int cAbsoluteCursorPosition

    • initialized

      public boolean initialized

  • Constructor Details

    • EditorState

      public EditorState()

  • Method Details

    • initializeEditorState

      public void initializeEditorState(String f, org.eclipse.jface.text.ITextSelection t, int cp)


EventManager

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.eventmanager

Class EventManager

java.lang.Object
com.pvx.ooadide.eventmanager.EventManager
All Implemented Interfaces:
IEventManager
public class EventManager extends Object implements IEventManager
Controls communication between Eclipse and ProvideX.
Since:
1.0

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final String
    ADDING_RESOURCES_TO_SRC
    static final String
    APPLY_IT_FORMAT
    static final String
    BUILDER_EXE
    static final String
    BUILDTYPE_STRIPLINES_PREP
    static final String
    ECLIPSE_SHUTDOWN
    static final String
    EVENT_FIRED
    static final String
    EVENT_LISTNR
    static final String
    EXPORT
    static final String
    EXT_EVENT
    static final String
    FULL_BUILD
    static final String
    FULL_BUILD_ALT_EXE
    static final String
    FULL_BUILD_END
    static final String
    FULL_BUILD_START
    static final String
    GENERIC_ACTION
    static final String
    HOST_IS_READY
    static final String
    IMPORT
    static final String
    IMPORT_EXPORT_FILE
    static final String
    IMPORT_EXPORT_PROPERTIES
    static final String
    IMPORTING_END
    static final String
    IMPORTING_START
    static final String
    INCREMENTAL_BUILD
    static final String
    INCREMENTAL_BUILD_ALT_EXE
    static final String
    INVALID
    static final String
    IOLIST_SCAN
    static final String
    LIB_SCAN
    static final String
    LOAD
    static final String
    NAME
    static final String
    NOMADS_BLOCKING
    static final String
    NOMADS_NON_BLOCKING
    static final String
    OPERATION_CANCEL
    static final String
    OPERATION_ERROR
    static final String
    OPERATION_REDO
    static final String
    OPERATION_SUCCESS
    static final String
    PASSWORD
    static final String
    PATH
    static Vector<Integer>
    pervasiveHandles
    static final String
    PREFERENCE_CHANGE
    static final String
    PREFERENCE_NEW_VALUE
    static final String
    PREFERENCE_OLD_VALUE
    static final String
    PREFERENCE_PAGE_BUTTON
    static final String
    PREFERENCE_PAGE_ID
    static final String
    PREFERENCE_PROPERTY
    static final String
    PROJECT_INI_FILE
    static final String
    PROJECT_LIST
    static final String
    PROJECT_LOCATION
    static final String
    PROJECT_MEMBER_COUNT
    static final String
    PROJECT_NAME
    static final String
    PROP_HIDDEN_ROOT_FOLDER
    static final String
    PROP_PROJECT_FORCE_FOLDERS
    static final String
    REMOVE
    static final String
    REMOVED_RESOURCE_FROM_SRC
    static final String
    REQUEST_SOCKET
    static final String
    RESOURCE_LIST
    static final String
    RESOURCE_PROPERTIES_CHANGED
    static final String
    RUN_CONSOLE
    static final String
    RUN_DESIGNER
    static final String
    RUN_DICT_DATA_CLASS
    static final String
    RUN_DICTMAINT
    static final String
    RUN_HOST
    static final String
    RUN_IT
    static final String
    RUN_NOMADS
    static final String
    RUN_TEST_PANEL
    static final String
    SELECTED_VIEW
    static final String
    STRIP_LINE_NO
    static final String
    VALID
    static final String
    VALIDATE

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    addDelayedAction(org.eclipse.jface.action.IAction argAction)
    static void
    addExtJavaEventListener(Object listener, String commandStr, boolean notifyEvtMngr)
    Adds an AbstractActionListener.
    static void
    addExtPvxEventListener(int listener, String commandStr)
    Adds an AbstractActionListener
    static void
    addExtPvxEventListener(int listener, String commandStr, int hasConfig)
    Adds an AbstractActionListener
    void
    addListener(String eventName)
    Adds a listener to the EventManager.
    void
    addListener(String eventName, int ctlValue)
    Adds a listener to the EventManager.
    static void
    addPervasiveObject(int ocxId)
    Most Java objects instantiated by ProvideX are dropped after every event.
    void
    addToPrefPages(String key, String value)
    Adds the specified key to an Eclipse Preference page
    static final void
    bye()
    void
    clearAllBlocks()
    Frees all blocking PvxEvents
    static void
    collectGarbage()
    Cleans up all objects that are not persistent
    void
    confirmJavXIsRunning()
    Establishes a connection to the ProvideX host, I.E.
    static boolean
    connectionWasDropped()
    True if the connection with ProvideX has been dropped
    void
    dropInstance(RcpPluginConnectionControl rcpPluginConnectionControl)
    static void
    freeEvent(PvxEvent event)
    Notify Eclipse that ProvideX has finish processing the event and if the EventManager is the guiManager then frees the event
    String
    getAllocatedObjectList()
    Component
    getClientGUIComponent()
    RcpPluginConnectionControl
    getConCon()
    static org.eclipse.core.resources.IProject
    getCurrentProject()
    static Hashtable<String,Object>
    getExtClassPrefs()
    static ArrayList<ExtCommand>
    getExtCommands()
    static EventManager
    getInstance()
    static org.eclipse.core.runtime.IProgressMonitor
    getMonitor()
    static String
    getPvxHelperPath()
    Returns the path to the directory containing the ProvideX helper programs
    static org.eclipse.core.resources.IProject
    getResourceProject()
    static String
    getRunningPvxExecutable()
    static boolean
    handleEvent(boolean block, String eventName, String detail, Properties buildProps)
    Sends a PvxEvent to the ProvideX EventManager.
    static boolean
    hostIsConnected()
    void
    initConnection(RcpPluginConnectionControl initCon)
    static boolean
    isBlocking()
    True if Eclipse is waiting for ProvideX to complete processing and event
    static boolean
    isEclipseShutingDown()
    static boolean
    isEventManagerWaiting()
    static boolean
    isPvxReady()
    static boolean
    javXWasStarted()
    Returns true if a connection to the ProvideX EventManager was previously established
    static void
    notifyEclipse(String eventName, String status, String responseArguments)
    void
    removeListener(String eventName)
    Removes a listener from the EventManager.
    static void
    removePervasiveObject(int ocxId)
    Most Java objects instantiated by ProvideX will be dropped after every event.
    static void
    restartPvxHost()
    boolean
    runNtHost(String[] pvxHostArgs)
    static void
    runProgramInView(String javXArgs)
    void
    setConCon(RcpPluginConnectionControl conCon)
    static void
    setContinueWaiting(boolean sw)
    static void
    setCurrentProject(org.eclipse.core.resources.IProject currentProject)
    static void
    setEclipseBye(boolean eclipseBye)
    static void
    setIgnoreCancelBuild(boolean sw)
    static void
    setMonitor(org.eclipse.core.runtime.IProgressMonitor monitor)
    static void
    setPvxReady(boolean isPvxReady)
    Notify Eclipse that ProvideX is ready to receive events
    static void
    setResourceProject(org.eclipse.core.resources.IProject aProject)
    static void
    setRunningPvxExecutable(String runningPvxExecutable)
    static boolean
    shouldIgnoreCancelBuild()
    static void
    shutDownHost()

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Field Details

    • pervasiveHandles

      public static Vector<Integer> pervasiveHandles

    • ECLIPSE_SHUTDOWN

      public static final String ECLIPSE_SHUTDOWN
      See Also:
      • Constant Field Values

    • HOST_IS_READY

      public static final String HOST_IS_READY
      See Also:
      • Constant Field Values

    • EXT_EVENT

      public static final String EXT_EVENT
      See Also:
      • Constant Field Values

    • ADDING_RESOURCES_TO_SRC

      public static final String ADDING_RESOURCES_TO_SRC
      See Also:
      • Constant Field Values

    • REMOVED_RESOURCE_FROM_SRC

      public static final String REMOVED_RESOURCE_FROM_SRC
      See Also:
      • Constant Field Values

    • FULL_BUILD

      public static final String FULL_BUILD
      See Also:
      • Constant Field Values

    • INCREMENTAL_BUILD

      public static final String INCREMENTAL_BUILD
      See Also:
      • Constant Field Values

    • INCREMENTAL_BUILD_ALT_EXE

      public static final String INCREMENTAL_BUILD_ALT_EXE
      See Also:
      • Constant Field Values

    • FULL_BUILD_ALT_EXE

      public static final String FULL_BUILD_ALT_EXE
      See Also:
      • Constant Field Values

    • LIB_SCAN

      public static final String LIB_SCAN
      See Also:
      • Constant Field Values

    • IOLIST_SCAN

      public static final String IOLIST_SCAN
      See Also:
      • Constant Field Values

    • STRIP_LINE_NO

      public static final String STRIP_LINE_NO
      See Also:
      • Constant Field Values

    • BUILDTYPE_STRIPLINES_PREP

      public static final String BUILDTYPE_STRIPLINES_PREP
      See Also:
      • Constant Field Values

    • GENERIC_ACTION

      public static final String GENERIC_ACTION
      See Also:
      • Constant Field Values

    • APPLY_IT_FORMAT

      public static final String APPLY_IT_FORMAT
      See Also:
      • Constant Field Values

    • IMPORT_EXPORT_PROPERTIES

      public static final String IMPORT_EXPORT_PROPERTIES
      See Also:
      • Constant Field Values

    • IMPORT_EXPORT_FILE

      public static final String IMPORT_EXPORT_FILE
      See Also:
      • Constant Field Values

    • EXPORT

      public static final String EXPORT
      See Also:
      • Constant Field Values

    • IMPORT

      public static final String IMPORT
      See Also:
      • Constant Field Values

    • PROJECT_LIST

      public static final String PROJECT_LIST
      See Also:
      • Constant Field Values

    • RESOURCE_PROPERTIES_CHANGED

      public static final String RESOURCE_PROPERTIES_CHANGED
      See Also:
      • Constant Field Values

    • RESOURCE_LIST

      public static final String RESOURCE_LIST
      See Also:
      • Constant Field Values

    • PREFERENCE_PAGE_BUTTON

      public static final String PREFERENCE_PAGE_BUTTON
      See Also:
      • Constant Field Values

    • PREFERENCE_PAGE_ID

      public static final String PREFERENCE_PAGE_ID
      See Also:
      • Constant Field Values

    • PREFERENCE_CHANGE

      public static final String PREFERENCE_CHANGE
      See Also:
      • Constant Field Values

    • PREFERENCE_NEW_VALUE

      public static final String PREFERENCE_NEW_VALUE
      See Also:
      • Constant Field Values

    • PREFERENCE_OLD_VALUE

      public static final String PREFERENCE_OLD_VALUE
      See Also:
      • Constant Field Values

    • PREFERENCE_PROPERTY

      public static final String PREFERENCE_PROPERTY
      See Also:
      • Constant Field Values

    • PASSWORD

      public static final String PASSWORD
      See Also:
      • Constant Field Values

    • RUN_IT

      public static final String RUN_IT
      See Also:
      • Constant Field Values

    • RUN_DICTMAINT

      public static final String RUN_DICTMAINT
      See Also:
      • Constant Field Values

    • RUN_DICT_DATA_CLASS

      public static final String RUN_DICT_DATA_CLASS
      See Also:
      • Constant Field Values

    • RUN_DESIGNER

      public static final String RUN_DESIGNER
      See Also:
      • Constant Field Values

    • RUN_NOMADS

      public static final String RUN_NOMADS
      See Also:
      • Constant Field Values

    • RUN_TEST_PANEL

      public static final String RUN_TEST_PANEL
      See Also:
      • Constant Field Values

    • RUN_CONSOLE

      public static final String RUN_CONSOLE
      See Also:
      • Constant Field Values

    • RUN_HOST

      public static final String RUN_HOST
      See Also:
      • Constant Field Values

    • EVENT_FIRED

      public static final String EVENT_FIRED
      See Also:
      • Constant Field Values

    • FULL_BUILD_START

      public static final String FULL_BUILD_START
      See Also:
      • Constant Field Values

    • FULL_BUILD_END

      public static final String FULL_BUILD_END
      See Also:
      • Constant Field Values

    • IMPORTING_START

      public static final String IMPORTING_START
      See Also:
      • Constant Field Values

    • IMPORTING_END

      public static final String IMPORTING_END
      See Also:
      • Constant Field Values

    • OPERATION_CANCEL

      public static final String OPERATION_CANCEL
      See Also:
      • Constant Field Values

    • OPERATION_ERROR

      public static final String OPERATION_ERROR
      See Also:
      • Constant Field Values

    • OPERATION_SUCCESS

      public static final String OPERATION_SUCCESS
      See Also:
      • Constant Field Values

    • OPERATION_REDO

      public static final String OPERATION_REDO
      See Also:
      • Constant Field Values

    • LOAD

      public static final String LOAD
      See Also:
      • Constant Field Values

    • REMOVE

      public static final String REMOVE
      See Also:
      • Constant Field Values

    • NAME

      public static final String NAME
      See Also:
      • Constant Field Values

    • PATH

      public static final String PATH
      See Also:
      • Constant Field Values

    • PROJECT_INI_FILE

      public static final String PROJECT_INI_FILE
      See Also:
      • Constant Field Values

    • EVENT_LISTNR

      public static final String EVENT_LISTNR
      See Also:
      • Constant Field Values

    • PROJECT_NAME

      public static final String PROJECT_NAME
      See Also:
      • Constant Field Values

    • PROJECT_LOCATION

      public static final String PROJECT_LOCATION
      See Also:
      • Constant Field Values

    • PROJECT_MEMBER_COUNT

      public static final String PROJECT_MEMBER_COUNT
      See Also:
      • Constant Field Values

    • BUILDER_EXE

      public static final String BUILDER_EXE
      See Also:
      • Constant Field Values

    • VALIDATE

      public static final String VALIDATE
      See Also:
      • Constant Field Values

    • VALID

      public static final String VALID
      See Also:
      • Constant Field Values

    • INVALID

      public static final String INVALID
      See Also:
      • Constant Field Values

    • NOMADS_BLOCKING

      public static final String NOMADS_BLOCKING
      See Also:
      • Constant Field Values

    • NOMADS_NON_BLOCKING

      public static final String NOMADS_NON_BLOCKING
      See Also:
      • Constant Field Values

    • REQUEST_SOCKET

      public static final String REQUEST_SOCKET
      See Also:
      • Constant Field Values

    • SELECTED_VIEW

      public static final String SELECTED_VIEW
      See Also:
      • Constant Field Values

    • PROP_PROJECT_FORCE_FOLDERS

      public static final String PROP_PROJECT_FORCE_FOLDERS
      See Also:
      • Constant Field Values

    • PROP_HIDDEN_ROOT_FOLDER

      public static final String PROP_HIDDEN_ROOT_FOLDER
      See Also:
      • Constant Field Values

  • Method Details

    • getInstance

      public static EventManager getInstance()

    • addDelayedAction

      public void addDelayedAction(org.eclipse.jface.action.IAction argAction)

    • addListener

      public void addListener(String eventName)
      Adds a listener to the EventManager. The EventManager will send a PvxEvent to the host every time the specified event occurs
      Parameters:
      eventName - 1. The eventName to be added

    • addListener

      public void addListener(String eventName, int ctlValue)
      Adds a listener to the EventManager. The EventManager This method will cause ctlvalues to be sent to the host every time the specified event occurs. The addListener(String eventName) is the preferred mehtod to register a listener because listeners registering via this method cannot block or pass values then when the specified event occurs
      Parameters:
      eventName - 1. String the EventName to be added
      ctlValue - 2. int ctlValue to send when the specified event occurs

    • removeListener

      public void removeListener(String eventName)
      Removes a listener from the EventManager. The EventManager will stop sending a PvxEvent to the host every time the specified event occurs

    • connectionWasDropped

      public static boolean connectionWasDropped()
      True if the connection with ProvideX has been dropped
      Returns:
      true if the connection with ProvideX has been dropped

    • javXWasStarted

      public static boolean javXWasStarted()
      Returns true if a connection to the ProvideX EventManager was previously established
      Returns:
      boolean indicating true or false

    • restartPvxHost

      public static void restartPvxHost()

    • hostIsConnected

      public static boolean hostIsConnected()

    • shutDownHost

      public static void shutDownHost()

    • confirmJavXIsRunning

      public void confirmJavXIsRunning()
      Establishes a connection to the ProvideX host, I.E. Runs The PvxHost program, launches the ProvideX EventManager, and establishes a tcp/ip connection between Eclipse and ProvideX

    • handleEvent

      public static boolean handleEvent(boolean block, String eventName, String detail, Properties buildProps)
      Sends a PvxEvent to the ProvideX EventManager. This method creates, blocks Threads as required and notifies ProvideX an Event has occurred
      Parameters:
      block - 1 boolean. Indicates Eclipse must wait for a response from ProvideX prior to continuing
      eventName - 2 String. The name of the event that has occurred. there are no listeners registered for this event this method simply returns
      detail - 3 String. The minor code for this event
      buildProps - 4 Properties . The minor code for this event

    • freeEvent

      public static void freeEvent(PvxEvent event)
      Notify Eclipse that ProvideX has finish processing the event and if the EventManager is the guiManager then frees the event

    • addPervasiveObject

      public static void addPervasiveObject(int ocxId)
      Most Java objects instantiated by ProvideX are dropped after every event. Pervasive (persistent) objects should persist and will only be dropped via the ProvideX DROP OBJECT directive
      Parameters:
      ocxId - int. The object handle to make persistent
      See Also:
      • removePervasiveObject(int)

    • removePervasiveObject

      public static void removePervasiveObject(int ocxId)
      Most Java objects instantiated by ProvideX will be dropped after every event. Pervasive (persistent) objects should persist and will only be dropped via the ProvideX DROP OBJECT directive
      Parameters:
      ocxId - int. The object handle to remove from the list of persistent objects
      See Also:
      • addPervasiveObject(int)

    • collectGarbage

      public static void collectGarbage()
      Cleans up all objects that are not persistent
      See Also:
      • addPervasiveObject(int)
      • removePervasiveObject(int)

    • isBlocking

      public static boolean isBlocking()
      True if Eclipse is waiting for ProvideX to complete processing and event
      Returns:
      true if Eclipse is waiting for ProvideX to complete processing and event

    • clearAllBlocks

      public void clearAllBlocks()
      Frees all blocking PvxEvents
      Specified by:
      clearAllBlocks in interface IEventManager

    • initConnection

      public void initConnection(RcpPluginConnectionControl initCon)

    • getClientGUIComponent

      public Component getClientGUIComponent()
      Specified by:
      getClientGUIComponent in interface IEventManager

    • setConCon

      public void setConCon(RcpPluginConnectionControl conCon)
      Specified by:
      setConCon in interface IEventManager

    • getConCon

      public RcpPluginConnectionControl getConCon()
      Specified by:
      getConCon in interface IEventManager

    • getPvxHelperPath

      public static String getPvxHelperPath()
      Returns the path to the directory containing the ProvideX helper programs
      Returns:
      The path to the directory containing the ProvideX helper programs

    • bye

      public static final void bye()

    • notifyEclipse

      public static void notifyEclipse(String eventName, String status, String responseArguments)

    • setEclipseBye

      public static void setEclipseBye(boolean eclipseBye)

    • isEclipseShutingDown

      public static boolean isEclipseShutingDown()

    • setPvxReady

      public static void setPvxReady(boolean isPvxReady)
      Notify Eclipse that ProvideX is ready to receive events
      Parameters:
      isPvxReady - true if ProvideX is ready

    • isPvxReady

      public static boolean isPvxReady()

    • setContinueWaiting

      public static void setContinueWaiting(boolean sw)

    • setIgnoreCancelBuild

      public static void setIgnoreCancelBuild(boolean sw)

    • isEventManagerWaiting

      public static boolean isEventManagerWaiting()

    • shouldIgnoreCancelBuild

      public static boolean shouldIgnoreCancelBuild()

    • setMonitor

      public static void setMonitor(org.eclipse.core.runtime.IProgressMonitor monitor)

    • getMonitor

      public static org.eclipse.core.runtime.IProgressMonitor getMonitor()

    • getAllocatedObjectList

      public String getAllocatedObjectList()

    • setRunningPvxExecutable

      public static void setRunningPvxExecutable(String runningPvxExecutable)

    • getRunningPvxExecutable

      public static String getRunningPvxExecutable()

    • addToPrefPages

      public void addToPrefPages(String key, String value)
      Adds the specified key to an Eclipse Preference page
      Parameters:
      key -
      value -

    • getExtClassPrefs

      public static Hashtable<String,Object> getExtClassPrefs()

    • addExtPvxEventListener

      public static void addExtPvxEventListener(int listener, String commandStr)
      Adds an AbstractActionListener
      Parameters:
      listener - -The actionPerformed function of the listener will be called
      commandStr - -String will appear in the Contributed Tools list

    • addExtPvxEventListener

      public static void addExtPvxEventListener(int listener, String commandStr, int hasConfig)
      Adds an AbstractActionListener
      Parameters:
      listener - -The actionPerformed function of the listener will be called
      commandStr - -String will appear in the Contributed Tools list

    • addExtJavaEventListener

      public static void addExtJavaEventListener(Object listener, String commandStr, boolean notifyEvtMngr)
      Adds an AbstractActionListener.
      Parameters:
      listener - -The actionPerformed function of the listener will be called
      commandStr - -String will appear in the Contributed Tools list
      notifyEvtMngr - -True if ProvideX should be informed the action occurred.

    • getExtCommands

      public static ArrayList<ExtCommand> getExtCommands()

    • runProgramInView

      public static void runProgramInView(String javXArgs)

    • runNtHost

      public boolean runNtHost(String[] pvxHostArgs)
      Specified by:
      runNtHost in interface IEventManager

    • dropInstance

      public void dropInstance(RcpPluginConnectionControl rcpPluginConnectionControl)
      Specified by:
      dropInstance in interface IEventManager

    • setCurrentProject

      public static void setCurrentProject(org.eclipse.core.resources.IProject currentProject)

    • getCurrentProject

      public static org.eclipse.core.resources.IProject getCurrentProject()

    • setResourceProject

      public static void setResourceProject(org.eclipse.core.resources.IProject aProject)

    • getResourceProject

      public static org.eclipse.core.resources.IProject getResourceProject()


EventManagerFactory

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.eventmanager

Class EventManagerFactory

java.lang.Object
com.pvx.ooadide.eventmanager.EventManagerFactory
public class EventManagerFactory extends Object
Factory that creates the EventManager which Controls communication between Eclipse and ProvideX
Since:
1.0

  • Constructor Summary

    Constructors
    Constructor
    Description
    EventManagerFactory()

  • Method Summary

    Modifier and Type
    Method
    Description
    static EventManager
    getEventManager()
    static EventManager
    makeEventManager()
    Creates an EventManager class that Controls communication between Eclipse and ProvideX

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • EventManagerFactory

      public EventManagerFactory()

  • Method Details

    • getEventManager

      public static EventManager getEventManager()

    • makeEventManager

      public static EventManager makeEventManager()
      Creates an EventManager class that Controls communication between Eclipse and ProvideX
      Returns:
      EventManager


ExtCommand

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.eventmanager

Class ExtCommand

java.lang.Object
com.pvx.ooadide.eventmanager.ExtCommand
All Implemented Interfaces:
IExtCommand
public class ExtCommand extends Object implements IExtCommand
An event that indicates a Contributed action has occurred in Eclipse
Since:
1.0

  • Constructor Summary

    Constructors
    Constructor
    Description
    ExtCommand(String initCmd, Object initlistener)
    ExtCommand(String initCmd, Object initlistener, boolean initViaEventManager)
    ExtCommand(String initCmd, Object initlistener, boolean initViaEventManager, boolean initHasConfig)

  • Method Summary

    Modifier and Type
    Method
    Description
    String
    getCommand()
    Object
    getListener()
    boolean
    hasConfig()
    boolean
    notifyEventManager()

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • ExtCommand

      public ExtCommand(String initCmd, Object initlistener)

    • ExtCommand

      public ExtCommand(String initCmd, Object initlistener, boolean initViaEventManager)

    • ExtCommand

      public ExtCommand(String initCmd, Object initlistener, boolean initViaEventManager, boolean initHasConfig)

  • Method Details

    • getCommand

      public String getCommand()
      Specified by:
      getCommand in interface IExtCommand

    • getListener

      public Object getListener()
      Specified by:
      getListener in interface IExtCommand

    • notifyEventManager

      public boolean notifyEventManager()
      Specified by:
      notifyEventManager in interface IExtCommand

    • hasConfig

      public boolean hasConfig()
      Specified by:
      hasConfig in interface IExtCommand


com.pvx.ooadide.eventmanager

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.pvx.ooadide.eventmanager

package com.pvx.ooadide.eventmanager
  • Related Packages
    Package
    Description
    com.pvx.ooadide
  • Classes
    Class
    Description
    DelayedAction
    DelayedEvent
    DelayedMethodCall
    DelayedMethodHandler
    EditorManager
    EditorState
    EventManager
    Controls communication between Eclipse and ProvideX.
    EventManagerFactory
    Factory that creates the EventManager which Controls communication between Eclipse and ProvideX
    ExtCommand
    An event that indicates a Contributed action has occurred in Eclipse
    PvxEvent
    An event that indicates an action has occurred in Eclipse
    PvxRequestManager
    ResourceManager
    Provides access to resources in Eclipse for ProvideX programs


com.pvx.ooadide.eventmanager Class Hierarchy

Hierarchy For Package com.pvx.ooadide.eventmanager

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • com.pvx.ooadide.eventmanager.DelayedAction
    • com.pvx.ooadide.eventmanager.DelayedEvent
    • com.pvx.ooadide.eventmanager.DelayedMethodCall
    • com.pvx.ooadide.eventmanager.DelayedMethodHandler
    • com.pvx.ooadide.eventmanager.EditorManager
    • com.pvx.ooadide.eventmanager.EditorState
    • com.pvx.ooadide.eventmanager.EventManager (implements com.sage.rcp.IEventManager)
    • com.pvx.ooadide.eventmanager.EventManagerFactory
    • com.pvx.ooadide.eventmanager.ExtCommand (implements com.pvx.ooadide.actions.IExtCommand)
    • com.pvx.ooadide.eventmanager.PvxEvent
    • com.pvx.ooadide.eventmanager.ResourceManager
    • java.lang.Thread (implements java.lang.Runnable)
      • com.pvx.ooadide.eventmanager.PvxRequestManager


Uses of Package com.pvx.ooadide.eventmanager

Uses of Package
com.pvx.ooadide.eventmanager

Packages that use com.pvx.ooadide.eventmanager
Package
Description
com.pvx.ooadide.eventmanager
  • Classes in com.pvx.ooadide.eventmanager used by com.pvx.ooadide.eventmanager
    Class
    Description
    DelayedMethodCall
    EditorState
    EventManager
    Controls communication between Eclipse and ProvideX.
    ExtCommand
    An event that indicates a Contributed action has occurred in Eclipse
    PvxEvent
    An event that indicates an action has occurred in Eclipse
    PvxRequestManager


PvxEvent

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.eventmanager

Class PvxEvent

java.lang.Object
com.pvx.ooadide.eventmanager.PvxEvent
public class PvxEvent extends Object
An event that indicates an action has occurred in Eclipse
Since:
1.0

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxEvent(String init_eventName, String detail, Properties init_buildProps)
    Creates an event that indicates an action has occurred in Eclipse

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    addResponse(String init_eventName, String init_detail)
    ProvideX responds to Eclipse events via this method
    void
    addResponse(String init_eventName, String init_detail, Properties init_buildProps)
    ProvideX responds to Eclipse events via this method
    boolean
    containsArgument(String key)
    Wraps the Properties iterator that contains the arguments of associated with this event
    String
    getArgument(String key)
    Wraps the Properties iterator that contains the arguments of associated with this event
    Properties
    getBuildProps()
    String
    getEventCommand()
    Accessor that returns the minor code of an event
    String
    getEventName()
    Accessor that returns the major code of an event
    Object
    getObjectArgument(String key)
    Wraps the Properties iterator that contains the arguments of associated with this event
    ArrayList<PvxEvent>
    getResponses()
    boolean
    hasMoreArguments()
    Wraps the Properties iterator that contains the arguments of associated with this event
    String
    nextArgument()
    Wraps the Properties iterator that contains the arguments of associated with this event
    void
    resetIterator()
    Wraps the Properties iterator that contains the arguments of associated with this event
    String
    toString()

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

  • Constructor Details

    • PvxEvent

      public PvxEvent(String init_eventName, String detail, Properties init_buildProps)
      Creates an event that indicates an action has occurred in Eclipse
      Parameters:
      init_eventName - The major code of the event
      detail - The minor code of the event
      init_buildProps - The optional arguments

  • Method Details

    • getEventName

      public String getEventName()
      Accessor that returns the major code of an event
      Returns:
      String defined as a constant in EventManager

    • getEventCommand

      public String getEventCommand()
      Accessor that returns the minor code of an event
      Returns:
      String defined as a constant in EventManager

    • resetIterator

      public void resetIterator()
      Wraps the Properties iterator that contains the arguments of associated with this event

    • hasMoreArguments

      public boolean hasMoreArguments()
      Wraps the Properties iterator that contains the arguments of associated with this event

    • nextArgument

      public String nextArgument()
      Wraps the Properties iterator that contains the arguments of associated with this event

    • containsArgument

      public boolean containsArgument(String key)
      Wraps the Properties iterator that contains the arguments of associated with this event

    • getArgument

      public String getArgument(String key)
      Wraps the Properties iterator that contains the arguments of associated with this event

    • getObjectArgument

      public Object getObjectArgument(String key)
      Wraps the Properties iterator that contains the arguments of associated with this event

    • addResponse

      public void addResponse(String init_eventName, String init_detail)
      ProvideX responds to Eclipse events via this method
      Parameters:
      init_eventName - The major code of the response
      init_detail - The minor code of the response

    • addResponse

      public void addResponse(String init_eventName, String init_detail, Properties init_buildProps)
      ProvideX responds to Eclipse events via this method
      Parameters:
      init_eventName - The major code of the response
      init_detail - The minor code of the response
      init_buildProps - The Properties object that contains the arguments for this response

    • getResponses

      public ArrayList<PvxEvent> getResponses()

    • toString

      public String toString()
      Overrides:
      toString in class Object

    • getBuildProps

      public Properties getBuildProps()


PvxRequestManager

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.eventmanager

Class PvxRequestManager

java.lang.Object
java.lang.Thread
com.pvx.ooadide.eventmanager.PvxRequestManager
All Implemented Interfaces:
Runnable
public class PvxRequestManager extends Thread

  • Nested Class Summary

    Nested classes/interfaces inherited from class java.lang.Thread

    Thread.State, Thread.UncaughtExceptionHandler

  • Field Summary

    Fields inherited from class java.lang.Thread

    MAX_PRIORITY, MIN_PRIORITY, NORM_PRIORITY

  • Method Summary

    Modifier and Type
    Method
    Description
    int
    getEventPort()
    static PvxRequestManager
    getInstance()
    static boolean
    isListening()
    boolean
    isTerminated()
    void
    run()
    void
    terminated()

    Methods inherited from class java.lang.Thread

    activeCount, currentThread, dumpStack, enumerate, getAllStackTraces, getContextClassLoader, getDefaultUncaughtExceptionHandler, getId, getName, getPriority, getStackTrace, getState, getThreadGroup, getUncaughtExceptionHandler, holdsLock, interrupt, interrupted, isAlive, isDaemon, isInterrupted, join, join, join, onSpinWait, setContextClassLoader, setDaemon, setDefaultUncaughtExceptionHandler, setName, setPriority, setUncaughtExceptionHandler, sleep, sleep, start, toString, yield

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

  • Method Details

    • getInstance

      public static PvxRequestManager getInstance()

    • isListening

      public static boolean isListening()

    • run

      public void run()
      Specified by:
      run in interface Runnable
      Overrides:
      run in class Thread

    • terminated

      public void terminated()

    • isTerminated

      public boolean isTerminated()

    • getEventPort

      public int getEventPort()


ResourceManager

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.eventmanager

Class ResourceManager

java.lang.Object
com.pvx.ooadide.eventmanager.ResourceManager
public class ResourceManager extends Object
Provides access to resources in Eclipse for ProvideX programs
Since:
1.0

  • Constructor Summary

    Constructors
    Constructor
    Description
    ResourceManager()

  • Method Summary

    Modifier and Type
    Method
    Description
    static final void
    addToPropertyUpdateList(String filePath, String pref, String value)
    static final void
    doUpdateProps()
    static String
    getDefaultPvxExePath()
    Returns a path to the ProvideX executable associated with the specified file
    static String
    getDefaultPvxExePath(String filePath)
    Returns a path to the ProvideX executable associated with the specified file
    static ArrayList<IPvxIdePlugin>
    getDependentPlugins()
    static String
    getDOM_DIRECTORY(org.eclipse.core.resources.IProject project)
    This method (from ProvideXBuilder) is duplicated here to enable ProvideX applications to retrieve the information through the ResourceManager object.
    static final org.eclipse.core.resources.IFile
    getFile(String filePath)
    Returns the File for the specified path
    static String
    getFilesPvxExePath(String filePath)
    static final org.eclipse.core.resources.IContainer
    getFolder(String folderPath)
    Returns the IContainer folder for specified path
    static org.eclipse.core.resources.IWorkspace
    getIWorkspace()
    String
    getPathToSelectedResourceInNavigator()
    This method will return the string value of the first resources selected
    static final org.eclipse.core.resources.IProject
    getProject(String projectName)
    Returns a handle to the project resource with the given name which is a child of this root.
    static final String
    getProperty(org.eclipse.core.resources.IResource file, String pref)
    Returns the value of the persistent property of this resource identified by the given key, or null if this resource has no such property.
    static String
    getRequestSocket()
    static final org.eclipse.core.resources.IResource
    getResource(String filePath)
    Returns the Resource for the specified path
    org.eclipse.core.resources.IResource
    getSelectedResourceInNavigator()
    This method will return the first resources selected
    org.eclipse.jface.viewers.TreeSelection
    getSelectedTreeResourcesInNavigator()
    This method enables retrieve of all selected resources
    static String
    getWorkspace()
    static org.eclipse.core.resources.IResource
    getWorkspaceResource()
    static boolean
    isResourceInSourceDirectory(org.eclipse.core.resources.IResource resource)
    Returns true if the specified resource is located in a Project's input directory
    static final boolean
    isValidPvxExtension(String extension)
    Returns true if the specified extension is associated with the ProvideX Editor
    static final boolean
    setProperty(org.eclipse.core.resources.IResource file, String pref, String value)
    Sets the value of the persistent property of this resource identified by the given key.

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • ResourceManager

      public ResourceManager()

  • Method Details

    • getProject

      public static final org.eclipse.core.resources.IProject getProject(String projectName)
      Returns a handle to the project resource with the given name which is a child of this root. The given name must be a valid path segment as defined by IPath.isValidSegment(String).

      Note: This method deals exclusively with resource handles, independent of whether the resources exist in the workspace. With the exception of validating that the name is a valid path segment, validation checking of the project name is not done when the project handle is constructed; rather, it is done automatically as the project is created.

      Parameters:
      name - the name of the project
      Returns:
      a project resource handle

    • getPathToSelectedResourceInNavigator

      public String getPathToSelectedResourceInNavigator()
      This method will return the string value of the first resources selected
      Returns:
      String the first resource selected

    • getSelectedTreeResourcesInNavigator

      public org.eclipse.jface.viewers.TreeSelection getSelectedTreeResourcesInNavigator()
      This method enables retrieve of all selected resources
      Returns:
      TreeSelection all of the selected resources

    • getSelectedResourceInNavigator

      public org.eclipse.core.resources.IResource getSelectedResourceInNavigator()
      This method will return the first resources selected
      Returns:
      IResource the first resource selected

    • getFolder

      public static final org.eclipse.core.resources.IContainer getFolder(String folderPath)
      Returns the IContainer folder for specified path
      Returns:
      IContainer or null if the folder does not exist

    • getResource

      public static final org.eclipse.core.resources.IResource getResource(String filePath)
      Returns the Resource for the specified path
      Returns:
      IResource or null if the resource does not exist

    • getFile

      public static final org.eclipse.core.resources.IFile getFile(String filePath)
      Returns the File for the specified path
      Returns:
      File or null if the File does not exist

    • getProperty

      public static final String getProperty(org.eclipse.core.resources.IResource file, String pref)
      Returns the value of the persistent property of this resource identified by the given key, or null if this resource has no such property.
      Parameters:
      file - the target file
      pref - the qualified name of the property
      Returns:
      the string value of the property, or null if this resource has no such property
      Throws:
      org.eclipse.core.runtime.CoreException - if this method fails. Reasons include:
      • This resource does not exist.
      • This resource is not local.
      • This resource is a project that is not open.

    • setProperty

      public static final boolean setProperty(org.eclipse.core.resources.IResource file, String pref, String value)
      Sets the value of the persistent property of this resource identified by the given key. If the supplied value is null, the persistent property is removed from this resource. The change is made immediately on disk.

      Persistent properties are intended to be used by plug-ins to store resource-specific information that should be persisted across platform sessions. The value of a persistent property is a string that must be short - 2KB or less in length. Unlike session properties, persistent properties are stored on disk and maintained across workspace shutdown and restart.

      Parameters:
      file - the resource to set the property on
      pref - the name of the property
      value - the string value of the property, or null if the property is to be removed
      Throws:
      org.eclipse.core.runtime.CoreException - if this method fails. Reasons include:
      • This resource does not exist.
      • This resource is not local.
      • This resource is a project that is not open.
      • Resource changes are disallowed during certain types of resource change event notification. See IResourceChangeEvent for more details.

    • isValidPvxExtension

      public static final boolean isValidPvxExtension(String extension)
      Returns true if the specified extension is associated with the ProvideX Editor

    • addToPropertyUpdateList

      public static final void addToPropertyUpdateList(String filePath, String pref, String value)

    • doUpdateProps

      public static final void doUpdateProps()

    • getFilesPvxExePath

      public static String getFilesPvxExePath(String filePath)

    • getDefaultPvxExePath

      public static String getDefaultPvxExePath(String filePath)
      Returns a path to the ProvideX executable associated with the specified file

    • getDefaultPvxExePath

      public static String getDefaultPvxExePath()
      Returns a path to the ProvideX executable associated with the specified file

    • isResourceInSourceDirectory

      public static boolean isResourceInSourceDirectory(org.eclipse.core.resources.IResource resource)
      Returns true if the specified resource is located in a Project's input directory

    • getWorkspace

      public static String getWorkspace()

    • getWorkspaceResource

      public static org.eclipse.core.resources.IResource getWorkspaceResource()

    • getIWorkspace

      public static org.eclipse.core.resources.IWorkspace getIWorkspace()

    • getRequestSocket

      public static String getRequestSocket()

    • getDependentPlugins

      public static ArrayList<IPvxIdePlugin> getDependentPlugins()

    • getDOM_DIRECTORY

      public static String getDOM_DIRECTORY(org.eclipse.core.resources.IProject project)
      This method (from ProvideXBuilder) is duplicated here to enable ProvideX applications to retrieve the information through the ResourceManager object.
      Parameters:
      project - A reference to {$link IProject} object for a project in the workspace
      Returns:
      A simple string representation of the directory path


Uses of Class com.pvx.ooadide.eventmanager.DelayedAction

Uses of Class
com.pvx.ooadide.eventmanager.DelayedAction

No usage of com.pvx.ooadide.eventmanager.DelayedAction


Uses of Class com.pvx.ooadide.eventmanager.DelayedEvent

Uses of Class
com.pvx.ooadide.eventmanager.DelayedEvent

No usage of com.pvx.ooadide.eventmanager.DelayedEvent


Uses of Class com.pvx.ooadide.eventmanager.DelayedMethodCall

Uses of Class
com.pvx.ooadide.eventmanager.DelayedMethodCall

Packages that use DelayedMethodCall
Package
Description
com.pvx.ooadide.eventmanager

  • Uses of DelayedMethodCall in com.pvx.ooadide.eventmanager

    Methods in com.pvx.ooadide.eventmanager with parameters of type DelayedMethodCall
    Modifier and Type
    Method
    Description
    static void
    DelayedMethodHandler.addMethod(DelayedMethodCall methodToCall)


Uses of Class com.pvx.ooadide.eventmanager.DelayedMethodHandler

Uses of Class
com.pvx.ooadide.eventmanager.DelayedMethodHandler

No usage of com.pvx.ooadide.eventmanager.DelayedMethodHandler


Uses of Class com.pvx.ooadide.eventmanager.EditorManager

Uses of Class
com.pvx.ooadide.eventmanager.EditorManager

No usage of com.pvx.ooadide.eventmanager.EditorManager


Uses of Class com.pvx.ooadide.eventmanager.EditorState

Uses of Class
com.pvx.ooadide.eventmanager.EditorState

Packages that use EditorState
Package
Description
com.pvx.ooadide.eventmanager

  • Uses of EditorState in com.pvx.ooadide.eventmanager

    Methods in com.pvx.ooadide.eventmanager that return EditorState
    Modifier and Type
    Method
    Description
    EditorState
    EditorManager.takeSnapShot()


Uses of Class com.pvx.ooadide.eventmanager.EventManager

Uses of Class
com.pvx.ooadide.eventmanager.EventManager

Packages that use EventManager
Package
Description
com.pvx.ooadide.eventmanager

  • Uses of EventManager in com.pvx.ooadide.eventmanager

    Methods in com.pvx.ooadide.eventmanager that return EventManager
    Modifier and Type
    Method
    Description
    static EventManager
    EventManagerFactory.getEventManager()
    static EventManager
    EventManager.getInstance()
    static EventManager
    EventManagerFactory.makeEventManager()
    Creates an EventManager class that Controls communication between Eclipse and ProvideX


Uses of Class com.pvx.ooadide.eventmanager.EventManagerFactory

Uses of Class
com.pvx.ooadide.eventmanager.EventManagerFactory

No usage of com.pvx.ooadide.eventmanager.EventManagerFactory


Uses of Class com.pvx.ooadide.eventmanager.ExtCommand

Uses of Class
com.pvx.ooadide.eventmanager.ExtCommand

Packages that use ExtCommand
Package
Description
com.pvx.ooadide.eventmanager

  • Uses of ExtCommand in com.pvx.ooadide.eventmanager

    Methods in com.pvx.ooadide.eventmanager that return types with arguments of type ExtCommand
    Modifier and Type
    Method
    Description
    static ArrayList<ExtCommand>
    EventManager.getExtCommands()


Uses of Class com.pvx.ooadide.eventmanager.PvxEvent

Uses of Class
com.pvx.ooadide.eventmanager.PvxEvent

Packages that use PvxEvent
Package
Description
com.pvx.ooadide.eventmanager

  • Uses of PvxEvent in com.pvx.ooadide.eventmanager

    Methods in com.pvx.ooadide.eventmanager that return types with arguments of type PvxEvent
    Modifier and Type
    Method
    Description
    ArrayList<PvxEvent>
    PvxEvent.getResponses()
    Methods in com.pvx.ooadide.eventmanager with parameters of type PvxEvent
    Modifier and Type
    Method
    Description
    static void
    EventManager.freeEvent(PvxEvent event)
    Notify Eclipse that ProvideX has finish processing the event and if the EventManager is the guiManager then frees the event


Uses of Class com.pvx.ooadide.eventmanager.PvxRequestManager

Uses of Class
com.pvx.ooadide.eventmanager.PvxRequestManager

Packages that use PvxRequestManager
Package
Description
com.pvx.ooadide.eventmanager

  • Uses of PvxRequestManager in com.pvx.ooadide.eventmanager

    Methods in com.pvx.ooadide.eventmanager that return PvxRequestManager
    Modifier and Type
    Method
    Description
    static PvxRequestManager
    PvxRequestManager.getInstance()


Uses of Class com.pvx.ooadide.eventmanager.ResourceManager

Uses of Class
com.pvx.ooadide.eventmanager.ResourceManager

No usage of com.pvx.ooadide.eventmanager.ResourceManager


AddProvidexHandler

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.handlers

Class AddProvidexHandler

java.lang.Object
org.eclipse.core.commands.common.EventManager
org.eclipse.core.commands.AbstractHandler
com.pvx.ooadide.handlers.AddProvidexHandler
All Implemented Interfaces:
org.eclipse.core.commands.IHandler, org.eclipse.core.commands.IHandler2
public class AddProvidexHandler extends org.eclipse.core.commands.AbstractHandler

  • Constructor Summary

    Constructors
    Constructor
    Description
    AddProvidexHandler()

  • Method Summary

    Modifier and Type
    Method
    Description
    Object
    execute(org.eclipse.core.commands.ExecutionEvent event)

    Methods inherited from class org.eclipse.core.commands.AbstractHandler

    addHandlerListener, dispose, isEnabled, isHandled, removeHandlerListener, setEnabled

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • AddProvidexHandler

      public AddProvidexHandler()

  • Method Details

    • execute

      public Object execute(org.eclipse.core.commands.ExecutionEvent event) throws org.eclipse.core.commands.ExecutionException
      Throws:
      org.eclipse.core.commands.ExecutionException


NewNomadsDefaultsHandler

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.handlers

Class NewNomadsDefaultsHandler

java.lang.Object
org.eclipse.core.commands.common.EventManager
org.eclipse.core.commands.AbstractHandler
com.pvx.ooadide.handlers.NewNomadsDefaultsHandler
All Implemented Interfaces:
org.eclipse.core.commands.IHandler, org.eclipse.core.commands.IHandler2
public class NewNomadsDefaultsHandler extends org.eclipse.core.commands.AbstractHandler

  • Constructor Summary

    Constructors
    Constructor
    Description
    NewNomadsDefaultsHandler()

  • Method Summary

    Modifier and Type
    Method
    Description
    Object
    execute(org.eclipse.core.commands.ExecutionEvent event)

    Methods inherited from class org.eclipse.core.commands.AbstractHandler

    addHandlerListener, dispose, isEnabled, isHandled, removeHandlerListener, setEnabled

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • NewNomadsDefaultsHandler

      public NewNomadsDefaultsHandler()

  • Method Details

    • execute

      public Object execute(org.eclipse.core.commands.ExecutionEvent event) throws org.eclipse.core.commands.ExecutionException
      Throws:
      org.eclipse.core.commands.ExecutionException


NewNomadsLibHandler

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.handlers

Class NewNomadsLibHandler

java.lang.Object
org.eclipse.core.commands.common.EventManager
org.eclipse.core.commands.AbstractHandler
com.pvx.ooadide.handlers.NewNomadsLibHandler
All Implemented Interfaces:
org.eclipse.core.commands.IHandler, org.eclipse.core.commands.IHandler2
public class NewNomadsLibHandler extends org.eclipse.core.commands.AbstractHandler

  • Constructor Summary

    Constructors
    Constructor
    Description
    NewNomadsLibHandler()

  • Method Summary

    Modifier and Type
    Method
    Description
    Object
    execute(org.eclipse.core.commands.ExecutionEvent event)

    Methods inherited from class org.eclipse.core.commands.AbstractHandler

    addHandlerListener, dispose, isEnabled, isHandled, removeHandlerListener, setEnabled

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • NewNomadsLibHandler

      public NewNomadsLibHandler()

  • Method Details

    • execute

      public Object execute(org.eclipse.core.commands.ExecutionEvent event) throws org.eclipse.core.commands.ExecutionException
      Throws:
      org.eclipse.core.commands.ExecutionException


NewProgramHandler

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.handlers

Class NewProgramHandler

java.lang.Object
org.eclipse.core.commands.common.EventManager
org.eclipse.core.commands.AbstractHandler
com.pvx.ooadide.handlers.NewProgramHandler
All Implemented Interfaces:
org.eclipse.core.commands.IHandler, org.eclipse.core.commands.IHandler2
public class NewProgramHandler extends org.eclipse.core.commands.AbstractHandler

  • Constructor Summary

    Constructors
    Constructor
    Description
    NewProgramHandler()

  • Method Summary

    Modifier and Type
    Method
    Description
    Object
    execute(org.eclipse.core.commands.ExecutionEvent event)

    Methods inherited from class org.eclipse.core.commands.AbstractHandler

    addHandlerListener, dispose, isEnabled, isHandled, removeHandlerListener, setEnabled

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • NewProgramHandler

      public NewProgramHandler()

  • Method Details

    • execute

      public Object execute(org.eclipse.core.commands.ExecutionEvent event) throws org.eclipse.core.commands.ExecutionException
      Throws:
      org.eclipse.core.commands.ExecutionException


NewProjectHandler

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.handlers

Class NewProjectHandler

java.lang.Object
org.eclipse.core.commands.common.EventManager
org.eclipse.core.commands.AbstractHandler
com.pvx.ooadide.handlers.NewProjectHandler
All Implemented Interfaces:
org.eclipse.core.commands.IHandler, org.eclipse.core.commands.IHandler2
public class NewProjectHandler extends org.eclipse.core.commands.AbstractHandler

  • Constructor Summary

    Constructors
    Constructor
    Description
    NewProjectHandler()

  • Method Summary

    Modifier and Type
    Method
    Description
    Object
    execute(org.eclipse.core.commands.ExecutionEvent event)

    Methods inherited from class org.eclipse.core.commands.AbstractHandler

    addHandlerListener, dispose, isEnabled, isHandled, removeHandlerListener, setEnabled

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • NewProjectHandler

      public NewProjectHandler()

  • Method Details

    • execute

      public Object execute(org.eclipse.core.commands.ExecutionEvent event) throws org.eclipse.core.commands.ExecutionException
      Throws:
      org.eclipse.core.commands.ExecutionException


NewPvxClassHandler

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.handlers

Class NewPvxClassHandler

java.lang.Object
org.eclipse.core.commands.common.EventManager
org.eclipse.core.commands.AbstractHandler
com.pvx.ooadide.handlers.NewPvxClassHandler
All Implemented Interfaces:
org.eclipse.core.commands.IHandler, org.eclipse.core.commands.IHandler2
public class NewPvxClassHandler extends org.eclipse.core.commands.AbstractHandler

  • Constructor Summary

    Constructors
    Constructor
    Description
    NewPvxClassHandler()

  • Method Summary

    Modifier and Type
    Method
    Description
    Object
    execute(org.eclipse.core.commands.ExecutionEvent event)

    Methods inherited from class org.eclipse.core.commands.AbstractHandler

    addHandlerListener, dispose, isEnabled, isHandled, removeHandlerListener, setEnabled

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • NewPvxClassHandler

      public NewPvxClassHandler()

  • Method Details

    • execute

      public Object execute(org.eclipse.core.commands.ExecutionEvent event) throws org.eclipse.core.commands.ExecutionException
      Throws:
      org.eclipse.core.commands.ExecutionException


com.pvx.ooadide.handlers

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.pvx.ooadide.handlers

package com.pvx.ooadide.handlers
  • Related Packages
    Package
    Description
    com.pvx.ooadide
  • Classes
    Class
    Description
    AddProvidexHandler
    NewNomadsDefaultsHandler
    NewNomadsLibHandler
    NewProgramHandler
    NewProjectHandler
    NewPvxClassHandler


com.pvx.ooadide.handlers Class Hierarchy

Hierarchy For Package com.pvx.ooadide.handlers

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.eclipse.core.commands.common.EventManager
      • org.eclipse.core.commands.AbstractHandler (implements org.eclipse.core.commands.IHandler2)
        • com.pvx.ooadide.handlers.AddProvidexHandler
        • com.pvx.ooadide.handlers.NewNomadsDefaultsHandler
        • com.pvx.ooadide.handlers.NewNomadsLibHandler
        • com.pvx.ooadide.handlers.NewProgramHandler
        • com.pvx.ooadide.handlers.NewProjectHandler
        • com.pvx.ooadide.handlers.NewPvxClassHandler


Uses of Package com.pvx.ooadide.handlers

Uses of Package
com.pvx.ooadide.handlers

No usage of com.pvx.ooadide.handlers


Uses of Class com.pvx.ooadide.handlers.AddProvidexHandler

Uses of Class
com.pvx.ooadide.handlers.AddProvidexHandler

No usage of com.pvx.ooadide.handlers.AddProvidexHandler


Uses of Class com.pvx.ooadide.handlers.NewNomadsDefaultsHandler

Uses of Class
com.pvx.ooadide.handlers.NewNomadsDefaultsHandler

No usage of com.pvx.ooadide.handlers.NewNomadsDefaultsHandler


Uses of Class com.pvx.ooadide.handlers.NewNomadsLibHandler

Uses of Class
com.pvx.ooadide.handlers.NewNomadsLibHandler

No usage of com.pvx.ooadide.handlers.NewNomadsLibHandler


Uses of Class com.pvx.ooadide.handlers.NewProgramHandler

Uses of Class
com.pvx.ooadide.handlers.NewProgramHandler

No usage of com.pvx.ooadide.handlers.NewProgramHandler


Uses of Class com.pvx.ooadide.handlers.NewProjectHandler

Uses of Class
com.pvx.ooadide.handlers.NewProjectHandler

No usage of com.pvx.ooadide.handlers.NewProjectHandler


Uses of Class com.pvx.ooadide.handlers.NewPvxClassHandler

Uses of Class
com.pvx.ooadide.handlers.NewPvxClassHandler

No usage of com.pvx.ooadide.handlers.NewPvxClassHandler


IniFileBlock

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.launchers

Class IniFileBlock

java.lang.Object
org.eclipse.debug.ui.AbstractLaunchConfigurationTab
com.pvx.ooadide.launchers.ProvideXLaunchConfigurationTab
com.pvx.ooadide.launchers.IniFileBlock
All Implemented Interfaces:
org.eclipse.debug.core.IPrototypeAttributesLabelProvider, org.eclipse.debug.ui.ILaunchConfigurationTab, org.eclipse.debug.ui.ILaunchConfigurationTab2
public class IniFileBlock extends ProvideXLaunchConfigurationTab
Editor for VM arguments of a Java launch configuration.

  • Constructor Summary

    Constructors
    Constructor
    Description
    IniFileBlock()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    createControl(org.eclipse.swt.widgets.Composite parent)
    String
    getName()
    void
    initializeFrom(org.eclipse.debug.core.ILaunchConfiguration configuration)
    void
    performApply(org.eclipse.debug.core.ILaunchConfigurationWorkingCopy configuration)
    void
    setDefaults(org.eclipse.debug.core.ILaunchConfigurationWorkingCopy configuration)
    void
    setEnabled(boolean enabled)

    Methods inherited from class org.eclipse.debug.ui.AbstractLaunchConfigurationTab

    activated, canSave, deactivated, dispose, getAttributeLabel, getControl, getErrorMessage, getHelpContextId, getId, getImage, getMessage, getWarningMessage, isValid, setHelpContextId, setLaunchConfigurationDialog

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface org.eclipse.debug.ui.ILaunchConfigurationTab

    OkToLeaveTab, postApply

  • Constructor Details

    • IniFileBlock

      public IniFileBlock()

  • Method Details

    • createControl

      public void createControl(org.eclipse.swt.widgets.Composite parent)
      See Also:
      • ILaunchConfigurationTab.createControl(Composite)

    • setDefaults

      public void setDefaults(org.eclipse.debug.core.ILaunchConfigurationWorkingCopy configuration)
      See Also:
      • ILaunchConfigurationTab.setDefaults(ILaunchConfigurationWorkingCopy)

    • initializeFrom

      public void initializeFrom(org.eclipse.debug.core.ILaunchConfiguration configuration)
      See Also:
      • ILaunchConfigurationTab.initializeFrom(ILaunchConfiguration)

    • performApply

      public void performApply(org.eclipse.debug.core.ILaunchConfigurationWorkingCopy configuration)
      See Also:
      • ILaunchConfigurationTab.performApply(ILaunchConfigurationWorkingCopy)

    • getName

      public String getName()
      See Also:
      • ILaunchConfigurationTab.getName()

    • setEnabled

      public void setEnabled(boolean enabled)


com.pvx.ooadide.launchers

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.pvx.ooadide.launchers

package com.pvx.ooadide.launchers
  • Related Packages
    Package
    Description
    com.pvx.ooadide
    com.pvx.ooadide.launchers.debug
    com.pvx.ooadide.launchers.thinclients
  • Classes
    Class
    Description
    IniFileBlock
    Editor for VM arguments of a Java launch configuration.
    ProvideXArgumentsTab
    A launch configuration tab that displays and edits program arguments, VM arguments, and working directory launch configuration attributes.
    ProvideXConfigurationTabGroup1
    ProvideXLaunchConfigurationDelegate1
    ProvideXLaunchConfigurationTab
    Common function for Java launch configuration tabs.
    ProvideXMainTab
    A launch configuration tab that displays and edits project and main type name launch configuration attributes.
    WindowStateBlock


com.pvx.ooadide.launchers Class Hierarchy

Hierarchy For Package com.pvx.ooadide.launchers

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.eclipse.debug.ui.AbstractLaunchConfigurationTab (implements org.eclipse.debug.ui.ILaunchConfigurationTab2, org.eclipse.debug.core.IPrototypeAttributesLabelProvider)
      • com.pvx.ooadide.launchers.ProvideXArgumentsTab
      • com.pvx.ooadide.launchers.ProvideXLaunchConfigurationTab
        • com.pvx.ooadide.launchers.IniFileBlock
      • com.pvx.ooadide.launchers.ProvideXMainTab
      • com.pvx.ooadide.launchers.WindowStateBlock
    • org.eclipse.debug.ui.AbstractLaunchConfigurationTabGroup (implements org.eclipse.debug.ui.ILaunchConfigurationTabGroup)
      • com.pvx.ooadide.launchers.ProvideXConfigurationTabGroup1
    • com.pvx.ooadide.launchers.ProvideXLaunchConfigurationDelegate1 (implements org.eclipse.debug.core.model.ILaunchConfigurationDelegate)


Uses of Package com.pvx.ooadide.launchers

Uses of Package
com.pvx.ooadide.launchers

Packages that use com.pvx.ooadide.launchers
Package
Description
com.pvx.ooadide.launchers
com.pvx.ooadide.launchers.thinclients
  • Classes in com.pvx.ooadide.launchers used by com.pvx.ooadide.launchers
    Class
    Description
    ProvideXLaunchConfigurationTab
    Common function for Java launch configuration tabs.
  • Classes in com.pvx.ooadide.launchers used by com.pvx.ooadide.launchers.thinclients
    Class
    Description
    ProvideXLaunchConfigurationDelegate1


ProvideXArgumentsTab

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.launchers

Class ProvideXArgumentsTab

java.lang.Object
org.eclipse.debug.ui.AbstractLaunchConfigurationTab
com.pvx.ooadide.launchers.ProvideXArgumentsTab
All Implemented Interfaces:
org.eclipse.debug.core.IPrototypeAttributesLabelProvider, org.eclipse.debug.ui.ILaunchConfigurationTab, org.eclipse.debug.ui.ILaunchConfigurationTab2
public class ProvideXArgumentsTab extends org.eclipse.debug.ui.AbstractLaunchConfigurationTab
A launch configuration tab that displays and edits program arguments, VM arguments, and working directory launch configuration attributes.

This class may be instantiated. This class is not intended to be subclassed.

Since:
2.0

  • Constructor Summary

    Constructors
    Constructor
    Description
    ProvideXArgumentsTab()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    activated(org.eclipse.debug.core.ILaunchConfigurationWorkingCopy workingCopy)
    void
    createControl(org.eclipse.swt.widgets.Composite parent)
    void
    deactivated(org.eclipse.debug.core.ILaunchConfigurationWorkingCopy workingCopy)
    void
    dispose()
    String
    getErrorMessage()
    org.eclipse.swt.graphics.Image
    getImage()
    String
    getMessage()
    String
    getName()
    void
    initializeFrom(org.eclipse.debug.core.ILaunchConfiguration configuration)
    boolean
    isValid(org.eclipse.debug.core.ILaunchConfiguration config)
    void
    performApply(org.eclipse.debug.core.ILaunchConfigurationWorkingCopy configuration)
    void
    setDefaults(org.eclipse.debug.core.ILaunchConfigurationWorkingCopy config)
    Defaults are empty.
    void
    setLaunchConfigurationDialog(org.eclipse.debug.ui.ILaunchConfigurationDialog dialog)

    Methods inherited from class org.eclipse.debug.ui.AbstractLaunchConfigurationTab

    canSave, getAttributeLabel, getControl, getHelpContextId, getId, getWarningMessage, setHelpContextId

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface org.eclipse.debug.ui.ILaunchConfigurationTab

    OkToLeaveTab, postApply

  • Constructor Details

    • ProvideXArgumentsTab

      public ProvideXArgumentsTab()

  • Method Details

    • createControl

      public void createControl(org.eclipse.swt.widgets.Composite parent)
      See Also:
      • ILaunchConfigurationTab.createControl(Composite)

    • dispose

      public void dispose()
      Specified by:
      dispose in interface org.eclipse.debug.ui.ILaunchConfigurationTab
      Overrides:
      dispose in class org.eclipse.debug.ui.AbstractLaunchConfigurationTab
      See Also:
      • ILaunchConfigurationTab.dispose()

    • isValid

      public boolean isValid(org.eclipse.debug.core.ILaunchConfiguration config)
      Specified by:
      isValid in interface org.eclipse.debug.ui.ILaunchConfigurationTab
      Overrides:
      isValid in class org.eclipse.debug.ui.AbstractLaunchConfigurationTab
      See Also:
      • ILaunchConfigurationTab.isValid(ILaunchConfiguration)

    • setDefaults

      public void setDefaults(org.eclipse.debug.core.ILaunchConfigurationWorkingCopy config)
      Defaults are empty.
      See Also:
      • ILaunchConfigurationTab.setDefaults(ILaunchConfigurationWorkingCopy)

    • initializeFrom

      public void initializeFrom(org.eclipse.debug.core.ILaunchConfiguration configuration)
      See Also:
      • ILaunchConfigurationTab.initializeFrom(ILaunchConfiguration)

    • performApply

      public void performApply(org.eclipse.debug.core.ILaunchConfigurationWorkingCopy configuration)
      See Also:
      • ILaunchConfigurationTab.performApply(ILaunchConfigurationWorkingCopy)

    • getName

      public String getName()
      See Also:
      • ILaunchConfigurationTab.getName()

    • setLaunchConfigurationDialog

      public void setLaunchConfigurationDialog(org.eclipse.debug.ui.ILaunchConfigurationDialog dialog)
      Specified by:
      setLaunchConfigurationDialog in interface org.eclipse.debug.ui.ILaunchConfigurationTab
      Overrides:
      setLaunchConfigurationDialog in class org.eclipse.debug.ui.AbstractLaunchConfigurationTab
      See Also:
      • ILaunchConfigurationTab.setLaunchConfigurationDialog(ILaunchConfigurationDialog)

    • getErrorMessage

      public String getErrorMessage()
      Specified by:
      getErrorMessage in interface org.eclipse.debug.ui.ILaunchConfigurationTab
      Overrides:
      getErrorMessage in class org.eclipse.debug.ui.AbstractLaunchConfigurationTab
      See Also:
      • ILaunchConfigurationTab.getErrorMessage()

    • getMessage

      public String getMessage()
      Specified by:
      getMessage in interface org.eclipse.debug.ui.ILaunchConfigurationTab
      Overrides:
      getMessage in class org.eclipse.debug.ui.AbstractLaunchConfigurationTab
      See Also:
      • ILaunchConfigurationTab.getMessage()

    • getImage

      public org.eclipse.swt.graphics.Image getImage()
      Specified by:
      getImage in interface org.eclipse.debug.ui.ILaunchConfigurationTab
      Overrides:
      getImage in class org.eclipse.debug.ui.AbstractLaunchConfigurationTab
      See Also:
      • ILaunchConfigurationTab.getImage()

    • activated

      public void activated(org.eclipse.debug.core.ILaunchConfigurationWorkingCopy workingCopy)
      Specified by:
      activated in interface org.eclipse.debug.ui.ILaunchConfigurationTab
      Overrides:
      activated in class org.eclipse.debug.ui.AbstractLaunchConfigurationTab

    • deactivated

      public void deactivated(org.eclipse.debug.core.ILaunchConfigurationWorkingCopy workingCopy)
      Specified by:
      deactivated in interface org.eclipse.debug.ui.ILaunchConfigurationTab
      Overrides:
      deactivated in class org.eclipse.debug.ui.AbstractLaunchConfigurationTab


ProvideXConfigurationTabGroup1

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.launchers

Class ProvideXConfigurationTabGroup1

java.lang.Object
org.eclipse.debug.ui.AbstractLaunchConfigurationTabGroup
com.pvx.ooadide.launchers.ProvideXConfigurationTabGroup1
All Implemented Interfaces:
org.eclipse.debug.ui.ILaunchConfigurationTabGroup
public class ProvideXConfigurationTabGroup1 extends org.eclipse.debug.ui.AbstractLaunchConfigurationTabGroup

  • Constructor Summary

    Constructors
    Constructor
    Description
    ProvideXConfigurationTabGroup1()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    createTabs(org.eclipse.debug.ui.ILaunchConfigurationDialog dialog, String mode)

    Methods inherited from class org.eclipse.debug.ui.AbstractLaunchConfigurationTabGroup

    dispose, getTabs, initializeFrom, performApply, setDefaults

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • ProvideXConfigurationTabGroup1

      public ProvideXConfigurationTabGroup1()

  • Method Details

    • createTabs

      public void createTabs(org.eclipse.debug.ui.ILaunchConfigurationDialog dialog, String mode)


ProvideXLaunchConfigurationDelegate1

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.launchers

Class ProvideXLaunchConfigurationDelegate1

java.lang.Object
com.pvx.ooadide.launchers.ProvideXLaunchConfigurationDelegate1
All Implemented Interfaces:
org.eclipse.debug.core.model.ILaunchConfigurationDelegate
Direct Known Subclasses:
WindXLaunchConfigurationDelegate1
public class ProvideXLaunchConfigurationDelegate1 extends Object implements org.eclipse.debug.core.model.ILaunchConfigurationDelegate

  • Constructor Summary

    Constructors
    Constructor
    Description
    ProvideXLaunchConfigurationDelegate1()

  • Method Summary

    Modifier and Type
    Method
    Description
    String
    generateCommandLine(org.eclipse.debug.core.ILaunchConfiguration configuration, org.eclipse.debug.core.ILaunch launch, ConsoleDisplayManager console, org.eclipse.core.resources.IProject project, String prgName, String prg, int requestPort, int eventPort)
    String[]
    generateCommandLineArray(org.eclipse.debug.core.ILaunchConfiguration configuration, ConsoleDisplayManager console, org.eclipse.core.resources.IProject project, String prgName, String prg)
    String
    getIniFileName(org.eclipse.debug.core.ILaunchConfiguration configuration, org.eclipse.core.resources.IProject project)
    void
    launch(org.eclipse.debug.core.ILaunchConfiguration configuration, String mode, org.eclipse.debug.core.ILaunch launch, org.eclipse.core.runtime.IProgressMonitor monitor)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface org.eclipse.debug.core.model.ILaunchConfigurationDelegate

    showCommandLine

  • Constructor Details

    • ProvideXLaunchConfigurationDelegate1

      public ProvideXLaunchConfigurationDelegate1()

  • Method Details

    • launch

      public void launch(org.eclipse.debug.core.ILaunchConfiguration configuration, String mode, org.eclipse.debug.core.ILaunch launch, org.eclipse.core.runtime.IProgressMonitor monitor) throws org.eclipse.core.runtime.CoreException
      Specified by:
      launch in interface org.eclipse.debug.core.model.ILaunchConfigurationDelegate
      Throws:
      org.eclipse.core.runtime.CoreException

    • generateCommandLineArray

      public String[] generateCommandLineArray(org.eclipse.debug.core.ILaunchConfiguration configuration, ConsoleDisplayManager console, org.eclipse.core.resources.IProject project, String prgName, String prg) throws org.eclipse.core.runtime.CoreException
      Throws:
      org.eclipse.core.runtime.CoreException

    • generateCommandLine

      public String generateCommandLine(org.eclipse.debug.core.ILaunchConfiguration configuration, org.eclipse.debug.core.ILaunch launch, ConsoleDisplayManager console, org.eclipse.core.resources.IProject project, String prgName, String prg, int requestPort, int eventPort) throws org.eclipse.core.runtime.CoreException
      Throws:
      org.eclipse.core.runtime.CoreException

    • getIniFileName

      public String getIniFileName(org.eclipse.debug.core.ILaunchConfiguration configuration, org.eclipse.core.resources.IProject project)


ProvideXLaunchConfigurationTab

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.launchers

Class ProvideXLaunchConfigurationTab

java.lang.Object
org.eclipse.debug.ui.AbstractLaunchConfigurationTab
com.pvx.ooadide.launchers.ProvideXLaunchConfigurationTab
All Implemented Interfaces:
org.eclipse.debug.core.IPrototypeAttributesLabelProvider, org.eclipse.debug.ui.ILaunchConfigurationTab, org.eclipse.debug.ui.ILaunchConfigurationTab2
Direct Known Subclasses:
IniFileBlock
public abstract class ProvideXLaunchConfigurationTab extends org.eclipse.debug.ui.AbstractLaunchConfigurationTab
Common function for Java launch configuration tabs.

  • Constructor Summary

    Constructors
    Constructor
    Description
    ProvideXLaunchConfigurationTab()

  • Method Summary

    Methods inherited from class org.eclipse.debug.ui.AbstractLaunchConfigurationTab

    activated, canSave, deactivated, dispose, getAttributeLabel, getControl, getErrorMessage, getHelpContextId, getId, getImage, getMessage, getWarningMessage, isValid, setHelpContextId, setLaunchConfigurationDialog

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface org.eclipse.debug.ui.ILaunchConfigurationTab

    createControl, getName, initializeFrom, OkToLeaveTab, performApply, postApply, setDefaults

  • Constructor Details

    • ProvideXLaunchConfigurationTab

      public ProvideXLaunchConfigurationTab()


ProvideXMainTab

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.launchers

Class ProvideXMainTab

java.lang.Object
org.eclipse.debug.ui.AbstractLaunchConfigurationTab
com.pvx.ooadide.launchers.ProvideXMainTab
All Implemented Interfaces:
org.eclipse.debug.core.IPrototypeAttributesLabelProvider, org.eclipse.debug.ui.ILaunchConfigurationTab, org.eclipse.debug.ui.ILaunchConfigurationTab2
public class ProvideXMainTab extends org.eclipse.debug.ui.AbstractLaunchConfigurationTab
A launch configuration tab that displays and edits project and main type name launch configuration attributes.

This class may be instantiated. This class is not intended to be subclassed.

Since:
2.0

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final String
    ATTR_INCLUDE_EXTERNAL_JARS
    Boolean launch configuration attribute indicating that external jars (on the runtime classpath) should be searched when looking for a main type.

  • Constructor Summary

    Constructors
    Constructor
    Description
    ProvideXMainTab()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    activated(org.eclipse.debug.core.ILaunchConfigurationWorkingCopy workingCopy)
    void
    createControl(org.eclipse.swt.widgets.Composite parent)
    void
    deactivated(org.eclipse.debug.core.ILaunchConfigurationWorkingCopy workingCopy)
    org.eclipse.swt.graphics.Image
    getImage()
    String
    getName()
    void
    initializeFrom(org.eclipse.debug.core.ILaunchConfiguration config)
    boolean
    isValid(org.eclipse.debug.core.ILaunchConfiguration config)
    void
    performApply(org.eclipse.debug.core.ILaunchConfigurationWorkingCopy config)
    void
    setDefaults(org.eclipse.debug.core.ILaunchConfigurationWorkingCopy config)

    Methods inherited from class org.eclipse.debug.ui.AbstractLaunchConfigurationTab

    canSave, dispose, getAttributeLabel, getControl, getErrorMessage, getHelpContextId, getId, getMessage, getWarningMessage, setHelpContextId, setLaunchConfigurationDialog

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface org.eclipse.debug.ui.ILaunchConfigurationTab

    OkToLeaveTab, postApply

  • Field Details

    • ATTR_INCLUDE_EXTERNAL_JARS

      public static final String ATTR_INCLUDE_EXTERNAL_JARS
      Boolean launch configuration attribute indicating that external jars (on the runtime classpath) should be searched when looking for a main type. Default value is false.
      Since:
      2.1

  • Constructor Details

    • ProvideXMainTab

      public ProvideXMainTab()

  • Method Details

    • createControl

      public void createControl(org.eclipse.swt.widgets.Composite parent)
      See Also:
      • ILaunchConfigurationTab.createControl(Composite)

    • initializeFrom

      public void initializeFrom(org.eclipse.debug.core.ILaunchConfiguration config)
      See Also:
      • ILaunchConfigurationTab.initializeFrom(ILaunchConfiguration)

    • performApply

      public void performApply(org.eclipse.debug.core.ILaunchConfigurationWorkingCopy config)
      See Also:
      • ILaunchConfigurationTab.performApply(ILaunchConfigurationWorkingCopy)

    • isValid

      public boolean isValid(org.eclipse.debug.core.ILaunchConfiguration config)
      Specified by:
      isValid in interface org.eclipse.debug.ui.ILaunchConfigurationTab
      Overrides:
      isValid in class org.eclipse.debug.ui.AbstractLaunchConfigurationTab
      See Also:
      • ILaunchConfigurationTab.isValid(ILaunchConfiguration)

    • setDefaults

      public void setDefaults(org.eclipse.debug.core.ILaunchConfigurationWorkingCopy config)
      See Also:
      • The setDefaults() method is called when a new config is created. This method sets default values for all attributes it understands on the working copy argument. This is done differently depending on the nature of the attributes collected by the tab. The AppletMainTab checks the current workbench selection or active editor to determine default values for the Project & Applet class attributes.

    • getName

      public String getName()
      See Also:
      • ILaunchConfigurationTab.getName()

    • getImage

      public org.eclipse.swt.graphics.Image getImage()
      Specified by:
      getImage in interface org.eclipse.debug.ui.ILaunchConfigurationTab
      Overrides:
      getImage in class org.eclipse.debug.ui.AbstractLaunchConfigurationTab
      See Also:
      • ILaunchConfigurationTab.getImage()

    • activated

      public void activated(org.eclipse.debug.core.ILaunchConfigurationWorkingCopy workingCopy)
      Specified by:
      activated in interface org.eclipse.debug.ui.ILaunchConfigurationTab
      Overrides:
      activated in class org.eclipse.debug.ui.AbstractLaunchConfigurationTab

    • deactivated

      public void deactivated(org.eclipse.debug.core.ILaunchConfigurationWorkingCopy workingCopy)
      Specified by:
      deactivated in interface org.eclipse.debug.ui.ILaunchConfigurationTab
      Overrides:
      deactivated in class org.eclipse.debug.ui.AbstractLaunchConfigurationTab


WindowStateBlock

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.launchers

Class WindowStateBlock

java.lang.Object
org.eclipse.debug.ui.AbstractLaunchConfigurationTab
com.pvx.ooadide.launchers.WindowStateBlock
All Implemented Interfaces:
org.eclipse.debug.core.IPrototypeAttributesLabelProvider, org.eclipse.debug.ui.ILaunchConfigurationTab, org.eclipse.debug.ui.ILaunchConfigurationTab2
public class WindowStateBlock extends org.eclipse.debug.ui.AbstractLaunchConfigurationTab

  • Constructor Summary

    Constructors
    Constructor
    Description
    WindowStateBlock()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    createControl(org.eclipse.swt.widgets.Composite parent)
    String
    getName()
    void
    initializeFrom(org.eclipse.debug.core.ILaunchConfiguration configuration)
    boolean
    isValid(org.eclipse.debug.core.ILaunchConfiguration config)
    void
    performApply(org.eclipse.debug.core.ILaunchConfigurationWorkingCopy configuration)
    void
    setDefaults(org.eclipse.debug.core.ILaunchConfigurationWorkingCopy config)
    Defaults are empty.

    Methods inherited from class org.eclipse.debug.ui.AbstractLaunchConfigurationTab

    activated, canSave, deactivated, dispose, getAttributeLabel, getControl, getErrorMessage, getHelpContextId, getId, getImage, getMessage, getWarningMessage, setHelpContextId, setLaunchConfigurationDialog

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface org.eclipse.debug.ui.ILaunchConfigurationTab

    OkToLeaveTab, postApply

  • Constructor Details

    • WindowStateBlock

      public WindowStateBlock()

  • Method Details

    • createControl

      public void createControl(org.eclipse.swt.widgets.Composite parent)

    • isValid

      public boolean isValid(org.eclipse.debug.core.ILaunchConfiguration config)
      Specified by:
      isValid in interface org.eclipse.debug.ui.ILaunchConfigurationTab
      Overrides:
      isValid in class org.eclipse.debug.ui.AbstractLaunchConfigurationTab

    • setDefaults

      public void setDefaults(org.eclipse.debug.core.ILaunchConfigurationWorkingCopy config)
      Defaults are empty.
      See Also:
      • ILaunchConfigurationTab.setDefaults(org.eclipse.debug.core.ILaunchConfigurationWorkingCopy)

    • initializeFrom

      public void initializeFrom(org.eclipse.debug.core.ILaunchConfiguration configuration)

    • performApply

      public void performApply(org.eclipse.debug.core.ILaunchConfigurationWorkingCopy configuration)

    • getName

      public String getName()


Uses of Class com.pvx.ooadide.launchers.IniFileBlock

Uses of Class
com.pvx.ooadide.launchers.IniFileBlock

No usage of com.pvx.ooadide.launchers.IniFileBlock


Uses of Class com.pvx.ooadide.launchers.ProvideXArgumentsTab

Uses of Class
com.pvx.ooadide.launchers.ProvideXArgumentsTab

No usage of com.pvx.ooadide.launchers.ProvideXArgumentsTab


Uses of Class com.pvx.ooadide.launchers.ProvideXConfigurationTabGroup1

Uses of Class
com.pvx.ooadide.launchers.ProvideXConfigurationTabGroup1

No usage of com.pvx.ooadide.launchers.ProvideXConfigurationTabGroup1


Uses of Class com.pvx.ooadide.launchers.ProvideXLaunchConfigurationDelegate1

Uses of Class
com.pvx.ooadide.launchers.ProvideXLaunchConfigurationDelegate1

Packages that use ProvideXLaunchConfigurationDelegate1
Package
Description
com.pvx.ooadide.launchers.thinclients

  • Uses of ProvideXLaunchConfigurationDelegate1 in com.pvx.ooadide.launchers.thinclients

    Subclasses of ProvideXLaunchConfigurationDelegate1 in com.pvx.ooadide.launchers.thinclients
    Modifier and Type
    Class
    Description
    class
    WindXLaunchConfigurationDelegate1


Uses of Class com.pvx.ooadide.launchers.ProvideXLaunchConfigurationTab

Uses of Class
com.pvx.ooadide.launchers.ProvideXLaunchConfigurationTab

Packages that use ProvideXLaunchConfigurationTab
Package
Description
com.pvx.ooadide.launchers

  • Uses of ProvideXLaunchConfigurationTab in com.pvx.ooadide.launchers

    Subclasses of ProvideXLaunchConfigurationTab in com.pvx.ooadide.launchers
    Modifier and Type
    Class
    Description
    class
    IniFileBlock
    Editor for VM arguments of a Java launch configuration.


Uses of Class com.pvx.ooadide.launchers.ProvideXMainTab

Uses of Class
com.pvx.ooadide.launchers.ProvideXMainTab

No usage of com.pvx.ooadide.launchers.ProvideXMainTab


Uses of Class com.pvx.ooadide.launchers.WindowStateBlock

Uses of Class
com.pvx.ooadide.launchers.WindowStateBlock

No usage of com.pvx.ooadide.launchers.WindowStateBlock


com.pvx.ooadide.launchers.debug

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.pvx.ooadide.launchers.debug

package com.pvx.ooadide.launchers.debug
  • Related Packages
    Package
    Description
    com.pvx.ooadide.launchers
    com.pvx.ooadide.launchers.debug.breakpoints
    com.pvx.ooadide.launchers.debug.communication
    com.pvx.ooadide.launchers.debug.launching
    com.pvx.ooadide.launchers.debug.model
    com.pvx.ooadide.launchers.thinclients
  • Classes
    Class
    Description
    RulerActionDelegate
    Toggles a breakpoint when ruler is double-clicked
    ToggleBreakpointAction
    Action to toggle a breakpoint


com.pvx.ooadide.launchers.debug Class Hierarchy

Hierarchy For Package com.pvx.ooadide.launchers.debug

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.eclipse.ui.actions.ActionDelegate (implements org.eclipse.ui.IActionDelegate2)
      • org.eclipse.ui.texteditor.AbstractRulerActionDelegate (implements org.eclipse.ui.IEditorActionDelegate, org.eclipse.jface.action.IMenuListener, org.eclipse.swt.events.MouseListener)
        • com.pvx.ooadide.launchers.debug.RulerActionDelegate
    • org.eclipse.core.commands.common.EventManager
      • org.eclipse.jface.action.AbstractAction (implements org.eclipse.jface.action.IAction)
        • org.eclipse.jface.action.Action
          • com.pvx.ooadide.launchers.debug.ToggleBreakpointAction


Uses of Package com.pvx.ooadide.launchers.debug

Uses of Package
com.pvx.ooadide.launchers.debug

No usage of com.pvx.ooadide.launchers.debug


RulerActionDelegate

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.launchers.debug

Class RulerActionDelegate

java.lang.Object
org.eclipse.ui.actions.ActionDelegate
org.eclipse.ui.texteditor.AbstractRulerActionDelegate
com.pvx.ooadide.launchers.debug.RulerActionDelegate
All Implemented Interfaces:
EventListener, org.eclipse.jface.action.IMenuListener, org.eclipse.swt.events.MouseListener, org.eclipse.swt.internal.SWTEventListener, org.eclipse.ui.IActionDelegate, org.eclipse.ui.IActionDelegate2, org.eclipse.ui.IEditorActionDelegate
public class RulerActionDelegate extends org.eclipse.ui.texteditor.AbstractRulerActionDelegate
Toggles a breakpoint when ruler is double-clicked

  • Constructor Summary

    Constructors
    Constructor
    Description
    RulerActionDelegate()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    mouseDoubleClick(org.eclipse.swt.events.MouseEvent e)

    Methods inherited from class org.eclipse.ui.texteditor.AbstractRulerActionDelegate

    menuAboutToShow, mouseDown, mouseUp, run, runWithEvent, selectionChanged, setActiveEditor

    Methods inherited from class org.eclipse.ui.actions.ActionDelegate

    dispose, init

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • RulerActionDelegate

      public RulerActionDelegate()

  • Method Details

    • mouseDoubleClick

      public void mouseDoubleClick(org.eclipse.swt.events.MouseEvent e)
      Specified by:
      mouseDoubleClick in interface org.eclipse.swt.events.MouseListener
      Overrides:
      mouseDoubleClick in class org.eclipse.ui.texteditor.AbstractRulerActionDelegate


ToggleBreakpointAction

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.launchers.debug

Class ToggleBreakpointAction

java.lang.Object
org.eclipse.core.commands.common.EventManager
org.eclipse.jface.action.AbstractAction
org.eclipse.jface.action.Action
com.pvx.ooadide.launchers.debug.ToggleBreakpointAction
All Implemented Interfaces:
org.eclipse.jface.action.IAction
public class ToggleBreakpointAction extends org.eclipse.jface.action.Action
Action to toggle a breakpoint

  • Field Summary

    Fields inherited from interface org.eclipse.jface.action.IAction

    AS_CHECK_BOX, AS_DROP_DOWN_MENU, AS_PUSH_BUTTON, AS_RADIO_BUTTON, AS_UNSPECIFIED, CHECKED, DESCRIPTION, ENABLED, HANDLED, IMAGE, RESULT, TEXT, TOOL_TIP_TEXT

  • Constructor Summary

    Constructors
    Constructor
    Description
    ToggleBreakpointAction(org.eclipse.ui.texteditor.ITextEditor editor, org.eclipse.jface.text.source.IVerticalRulerInfo rulerInfo)
    Constructs a new action to toggle a PDA breakpoint

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    run()

    Methods inherited from class org.eclipse.jface.action.Action

    convertAccelerator, convertAccelerator, findKeyCode, findKeyString, findModifier, findModifierString, getAccelerator, getActionDefinitionId, getDescription, getDisabledImageDescriptor, getHelpListener, getHoverImageDescriptor, getId, getImageDescriptor, getMenuCreator, getStyle, getText, getToolTipText, isChecked, isEnabled, isHandled, notifyResult, removeAcceleratorText, removeMnemonics, runWithEvent, setAccelerator, setActionDefinitionId, setChecked, setDescription, setDisabledImageDescriptor, setEnabled, setHelpListener, setHoverImageDescriptor, setId, setImageDescriptor, setMenuCreator, setText, setToolTipText

    Methods inherited from class org.eclipse.jface.action.AbstractAction

    addPropertyChangeListener, removePropertyChangeListener

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • ToggleBreakpointAction

      public ToggleBreakpointAction(org.eclipse.ui.texteditor.ITextEditor editor, org.eclipse.jface.text.source.IVerticalRulerInfo rulerInfo)
      Constructs a new action to toggle a PDA breakpoint
      Parameters:
      editor - the editor in which to toggle the breakpoint
      rulerInfo - specifies breakpoint location

  • Method Details

    • run

      public void run()
      Specified by:
      run in interface org.eclipse.jface.action.IAction
      Overrides:
      run in class org.eclipse.jface.action.Action


com.pvx.ooadide.launchers.debug.breakpoints

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.pvx.ooadide.launchers.debug.breakpoints

package com.pvx.ooadide.launchers.debug.breakpoints
  • Related Packages
    Package
    Description
    com.pvx.ooadide.launchers.debug
    com.pvx.ooadide.launchers.debug.communication
    com.pvx.ooadide.launchers.debug.launching
    com.pvx.ooadide.launchers.debug.model
  • Classes
    Class
    Description
    PvxBreakpointAdapterFactory
    PVXLineBreakpoint
    PDA line breakpoint
    PVXRunToLineBreakpoint
    A run to line breakpoint.


com.pvx.ooadide.launchers.debug.breakpoints Class Hierarchy

Hierarchy For Package com.pvx.ooadide.launchers.debug.breakpoints

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.eclipse.core.runtime.PlatformObject (implements org.eclipse.core.runtime.IAdaptable)
      • org.eclipse.debug.core.model.Breakpoint (implements org.eclipse.debug.core.model.IBreakpoint, org.eclipse.debug.core.model.ITriggerPoint)
        • org.eclipse.debug.core.model.LineBreakpoint (implements org.eclipse.debug.core.model.ILineBreakpoint)
          • com.pvx.ooadide.launchers.debug.breakpoints.PVXLineBreakpoint (implements com.pvx.ooadide.launchers.debug.model.IPVXEventListener)
            • com.pvx.ooadide.launchers.debug.breakpoints.PVXRunToLineBreakpoint
    • com.pvx.ooadide.launchers.debug.breakpoints.PvxBreakpointAdapterFactory (implements org.eclipse.core.runtime.IAdapterFactory)


Uses of Package com.pvx.ooadide.launchers.debug.breakpoints

Uses of Package
com.pvx.ooadide.launchers.debug.breakpoints

Packages that use com.pvx.ooadide.launchers.debug.breakpoints
Package
Description
com.pvx.ooadide.launchers.debug.breakpoints
  • Classes in com.pvx.ooadide.launchers.debug.breakpoints used by com.pvx.ooadide.launchers.debug.breakpoints
    Class
    Description
    PVXLineBreakpoint
    PDA line breakpoint


PvxBreakpointAdapterFactory

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.launchers.debug.breakpoints

Class PvxBreakpointAdapterFactory

java.lang.Object
com.pvx.ooadide.launchers.debug.breakpoints.PvxBreakpointAdapterFactory
All Implemented Interfaces:
org.eclipse.core.runtime.IAdapterFactory
public class PvxBreakpointAdapterFactory extends Object implements org.eclipse.core.runtime.IAdapterFactory

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxBreakpointAdapterFactory()

  • Method Summary

    Modifier and Type
    Method
    Description
    Object
    getAdapter(Object adaptableObject, Class adapterType)
    Class[]
    getAdapterList()

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • PvxBreakpointAdapterFactory

      public PvxBreakpointAdapterFactory()

  • Method Details

    • getAdapter

      public Object getAdapter(Object adaptableObject, Class adapterType)
      Specified by:
      getAdapter in interface org.eclipse.core.runtime.IAdapterFactory

    • getAdapterList

      public Class[] getAdapterList()
      Specified by:
      getAdapterList in interface org.eclipse.core.runtime.IAdapterFactory


PVXLineBreakpoint

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.launchers.debug.breakpoints

Class PVXLineBreakpoint

java.lang.Object
org.eclipse.core.runtime.PlatformObject
org.eclipse.debug.core.model.Breakpoint
org.eclipse.debug.core.model.LineBreakpoint
com.pvx.ooadide.launchers.debug.breakpoints.PVXLineBreakpoint
All Implemented Interfaces:
IPVXEventListener, org.eclipse.core.runtime.IAdaptable, org.eclipse.debug.core.model.IBreakpoint, org.eclipse.debug.core.model.ILineBreakpoint, org.eclipse.debug.core.model.ITriggerPoint
Direct Known Subclasses:
PVXRunToLineBreakpoint
public class PVXLineBreakpoint extends org.eclipse.debug.core.model.LineBreakpoint implements IPVXEventListener
PDA line breakpoint

  • Field Summary

    Fields inherited from interface org.eclipse.debug.core.model.IBreakpoint

    BREAKPOINT_MARKER, ENABLED, ID, LINE_BREAKPOINT_MARKER, PERSISTED, REGISTERED

    Fields inherited from interface org.eclipse.debug.core.model.ITriggerPoint

    TRIGGERPOINT

  • Constructor Summary

    Constructors
    Constructor
    Description
    PVXLineBreakpoint()
    Default constructor is required for the breakpoint manager to re-create persisted breakpoints.
    PVXLineBreakpoint(org.eclipse.core.resources.IResource resource, int lineNumber)
    Constructs a line breakpoint on the given resource at the given line number.

  • Method Summary

    Modifier and Type
    Method
    Description
    String
    getModelIdentifier()
    void
    handleEvent(String event)
    Notification the given event occurred in the target program being interpretted.
    void
    install(PVXDebugTarget target)
    Installs this breakpoint in the given interprettor.
    boolean
    isRunToLineBreakpoint()
    Returns whether this breakpoint is a run-to-line breakpoint
    void
    remove(PVXDebugTarget target)
    Removes this breakpoint from the given interprettor.

    Methods inherited from class org.eclipse.debug.core.model.LineBreakpoint

    getCharEnd, getCharStart, getLineNumber

    Methods inherited from class org.eclipse.debug.core.model.Breakpoint

    delete, equals, getMarker, hashCode, isEnabled, isPersisted, isRegistered, isTriggerPoint, setEnabled, setMarker, setPersisted, setRegistered, setTriggerPoint, toString

    Methods inherited from class org.eclipse.core.runtime.PlatformObject

    getAdapter

    Methods inherited from class java.lang.Object

    getClass, notify, notifyAll, wait, wait, wait

    Methods inherited from interface org.eclipse.core.runtime.IAdaptable

    getAdapter

    Methods inherited from interface org.eclipse.debug.core.model.IBreakpoint

    delete, getMarker, isEnabled, isPersisted, isRegistered, setEnabled, setMarker, setPersisted, setRegistered

  • Constructor Details

    • PVXLineBreakpoint

      public PVXLineBreakpoint()
      Default constructor is required for the breakpoint manager to re-create persisted breakpoints. After instantiating a breakpoint, the setMarker(...) method is called to restore this breakpoint's attributes.

    • PVXLineBreakpoint

      public PVXLineBreakpoint(org.eclipse.core.resources.IResource resource, int lineNumber) throws org.eclipse.core.runtime.CoreException
      Constructs a line breakpoint on the given resource at the given line number. The line number is 1-based (i.e. the first line of a file is line number 1). The PDA VM uses 0-based line numbers, so this line number translation is done at breakpoint install time.
      Parameters:
      resource - file on which to set the breakpoint
      lineNumber - 1-based line number of the breakpoint
      Throws:
      org.eclipse.core.runtime.CoreException - if unable to create the breakpoint

  • Method Details

    • getModelIdentifier

      public String getModelIdentifier()
      Specified by:
      getModelIdentifier in interface org.eclipse.debug.core.model.IBreakpoint

    • isRunToLineBreakpoint

      public boolean isRunToLineBreakpoint()
      Returns whether this breakpoint is a run-to-line breakpoint
      Returns:
      whether this breakpoint is a run-to-line breakpoint

    • install

      public void install(PVXDebugTarget target) throws org.eclipse.core.runtime.CoreException
      Installs this breakpoint in the given interprettor. Registeres this breakpoint as an event listener in the given target and creates the breakpoint specific request.
      Parameters:
      target - PDA interprettor
      Throws:
      org.eclipse.core.runtime.CoreException - if installation fails

    • remove

      public void remove(PVXDebugTarget target) throws org.eclipse.core.runtime.CoreException
      Removes this breakpoint from the given interprettor. Removes this breakpoint as an event listener and clears the request for the interprettor.
      Parameters:
      target - PDA interprettor
      Throws:
      org.eclipse.core.runtime.CoreException - if removal fails

    • handleEvent

      public void handleEvent(String event)
      Description copied from interface: IPVXEventListener
      Notification the given event occurred in the target program being interpretted.
      Specified by:
      handleEvent in interface IPVXEventListener
      Parameters:
      event - the event


PVXRunToLineBreakpoint

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.launchers.debug.breakpoints

Class PVXRunToLineBreakpoint

java.lang.Object
org.eclipse.core.runtime.PlatformObject
org.eclipse.debug.core.model.Breakpoint
org.eclipse.debug.core.model.LineBreakpoint
com.pvx.ooadide.launchers.debug.breakpoints.PVXLineBreakpoint
com.pvx.ooadide.launchers.debug.breakpoints.PVXRunToLineBreakpoint
All Implemented Interfaces:
IPVXEventListener, org.eclipse.core.runtime.IAdaptable, org.eclipse.debug.core.model.IBreakpoint, org.eclipse.debug.core.model.ILineBreakpoint, org.eclipse.debug.core.model.ITriggerPoint
public class PVXRunToLineBreakpoint extends PVXLineBreakpoint
A run to line breakpoint.

  • Field Summary

    Fields inherited from interface org.eclipse.debug.core.model.IBreakpoint

    BREAKPOINT_MARKER, ENABLED, ID, LINE_BREAKPOINT_MARKER, PERSISTED, REGISTERED

    Fields inherited from interface org.eclipse.debug.core.model.ITriggerPoint

    TRIGGERPOINT

  • Constructor Summary

    Constructors
    Constructor
    Description
    PVXRunToLineBreakpoint(org.eclipse.core.resources.IFile resource, int lineNumber)
    Constructs a run-to-line breakpoint in the given PVX program.

  • Method Summary

    Modifier and Type
    Method
    Description
    org.eclipse.core.resources.IFile
    getSourceFile()
    Returns the source file this breakpoint is contained in.
    boolean
    isRunToLineBreakpoint()
    Returns whether this breakpoint is a run-to-line breakpoint

    Methods inherited from class com.pvx.ooadide.launchers.debug.breakpoints.PVXLineBreakpoint

    getModelIdentifier, handleEvent, install, remove

    Methods inherited from class org.eclipse.debug.core.model.LineBreakpoint

    getCharEnd, getCharStart, getLineNumber

    Methods inherited from class org.eclipse.debug.core.model.Breakpoint

    delete, equals, getMarker, hashCode, isEnabled, isPersisted, isRegistered, isTriggerPoint, setEnabled, setMarker, setPersisted, setRegistered, setTriggerPoint, toString

    Methods inherited from class org.eclipse.core.runtime.PlatformObject

    getAdapter

    Methods inherited from class java.lang.Object

    getClass, notify, notifyAll, wait, wait, wait

    Methods inherited from interface org.eclipse.core.runtime.IAdaptable

    getAdapter

    Methods inherited from interface org.eclipse.debug.core.model.IBreakpoint

    delete, getMarker, isEnabled, isPersisted, isRegistered, setEnabled, setMarker, setPersisted, setRegistered

  • Constructor Details

    • PVXRunToLineBreakpoint

      public PVXRunToLineBreakpoint(org.eclipse.core.resources.IFile resource, int lineNumber) throws org.eclipse.debug.core.DebugException
      Constructs a run-to-line breakpoint in the given PVX program.
      Parameters:
      resource - PVX source file
      lineNumber - line to run to
      Throws:
      org.eclipse.debug.core.DebugException - if unable to create the breakpoint

  • Method Details

    • isRunToLineBreakpoint

      public boolean isRunToLineBreakpoint()
      Returns whether this breakpoint is a run-to-line breakpoint
      Overrides:
      isRunToLineBreakpoint in class PVXLineBreakpoint
      Returns:
      whether this breakpoint is a run-to-line breakpoint

    • getSourceFile

      public org.eclipse.core.resources.IFile getSourceFile()
      Returns the source file this breakpoint is contained in.
      Returns:
      the source file this breakpoint is contained in


Uses of Class com.pvx.ooadide.launchers.debug.breakpoints.PvxBreakpointAdapterFactory

Uses of Class
com.pvx.ooadide.launchers.debug.breakpoints.PvxBreakpointAdapterFactory

No usage of com.pvx.ooadide.launchers.debug.breakpoints.PvxBreakpointAdapterFactory


Uses of Class com.pvx.ooadide.launchers.debug.breakpoints.PVXLineBreakpoint

Uses of Class
com.pvx.ooadide.launchers.debug.breakpoints.PVXLineBreakpoint

Packages that use PVXLineBreakpoint
Package
Description
com.pvx.ooadide.launchers.debug.breakpoints

  • Uses of PVXLineBreakpoint in com.pvx.ooadide.launchers.debug.breakpoints

    Subclasses of PVXLineBreakpoint in com.pvx.ooadide.launchers.debug.breakpoints
    Modifier and Type
    Class
    Description
    class
    PVXRunToLineBreakpoint
    A run to line breakpoint.


Uses of Class com.pvx.ooadide.launchers.debug.breakpoints.PVXRunToLineBreakpoint

Uses of Class
com.pvx.ooadide.launchers.debug.breakpoints.PVXRunToLineBreakpoint

No usage of com.pvx.ooadide.launchers.debug.breakpoints.PVXRunToLineBreakpoint


Uses of Class com.pvx.ooadide.launchers.debug.RulerActionDelegate

Uses of Class
com.pvx.ooadide.launchers.debug.RulerActionDelegate

No usage of com.pvx.ooadide.launchers.debug.RulerActionDelegate


Uses of Class com.pvx.ooadide.launchers.debug.ToggleBreakpointAction

Uses of Class
com.pvx.ooadide.launchers.debug.ToggleBreakpointAction

No usage of com.pvx.ooadide.launchers.debug.ToggleBreakpointAction


DebugLauncherThread

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.launchers.debug.communication

Class DebugLauncherThread

java.lang.Object
java.lang.Thread
com.pvx.ooadide.launchers.debug.communication.DebugLauncherThread
All Implemented Interfaces:
Runnable
Direct Known Subclasses:
DebugWindXLauncherThread
public class DebugLauncherThread extends Thread

  • Nested Class Summary

    Nested classes/interfaces inherited from class java.lang.Thread

    Thread.State, Thread.UncaughtExceptionHandler

  • Field Summary

    Fields inherited from class java.lang.Thread

    MAX_PRIORITY, MIN_PRIORITY, NORM_PRIORITY

  • Constructor Summary

    Constructors
    Constructor
    Description
    DebugLauncherThread(String dir, int port, ConsoleDisplayManager console, String name, int port2, String line, org.eclipse.debug.core.ILaunch launch, String args)

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    notifyProvideXConnect(Socket fRequestSocket, Socket fEventSocket)
    void
    run()

    Methods inherited from class java.lang.Thread

    activeCount, currentThread, dumpStack, enumerate, getAllStackTraces, getContextClassLoader, getDefaultUncaughtExceptionHandler, getId, getName, getPriority, getStackTrace, getState, getThreadGroup, getUncaughtExceptionHandler, holdsLock, interrupt, interrupted, isAlive, isDaemon, isInterrupted, join, join, join, onSpinWait, setContextClassLoader, setDaemon, setDefaultUncaughtExceptionHandler, setName, setPriority, setUncaughtExceptionHandler, sleep, sleep, start, toString, yield

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

  • Constructor Details

    • DebugLauncherThread

      public DebugLauncherThread(String dir, int port, ConsoleDisplayManager console, String name, int port2, String line, org.eclipse.debug.core.ILaunch launch, String args)

  • Method Details

    • notifyProvideXConnect

      public void notifyProvideXConnect(Socket fRequestSocket, Socket fEventSocket)

    • run

      public void run()
      Specified by:
      run in interface Runnable
      Overrides:
      run in class Thread


DebugServer

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.launchers.debug.communication

Class DebugServer

java.lang.Object
com.pvx.ooadide.launchers.debug.communication.DebugServer
public class DebugServer extends Object

  • Method Summary

    Modifier and Type
    Method
    Description
    Socket
    acceptEventConnection(MonitorState pd)
    Socket
    acceptRequestConnection(MonitorState pd)
    void
    close()
    static Socket
    doSocketAccept(MonitorState pd, ServerSocket targetSocket)
    static DebugServer
    getDefault()
    int
    getEventPort()
    static MonitorState
    getProgressMonitor()
    int
    getRequestPort()

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Method Details

    • getDefault

      public static DebugServer getDefault()

    • doSocketAccept

      public static Socket doSocketAccept(MonitorState pd, ServerSocket targetSocket) throws IOException
      Throws:
      IOException

    • acceptRequestConnection

      public Socket acceptRequestConnection(MonitorState pd) throws IOException
      Throws:
      IOException

    • acceptEventConnection

      public Socket acceptEventConnection(MonitorState pd) throws IOException
      Throws:
      IOException

    • getRequestPort

      public int getRequestPort()

    • getEventPort

      public int getEventPort()

    • close

      public void close()

    • getProgressMonitor

      public static MonitorState getProgressMonitor()


com.pvx.ooadide.launchers.debug.communication

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.pvx.ooadide.launchers.debug.communication

package com.pvx.ooadide.launchers.debug.communication
  • Related Packages
    Package
    Description
    com.pvx.ooadide.launchers.debug
    com.pvx.ooadide.launchers.debug.breakpoints
    com.pvx.ooadide.launchers.debug.launching
    com.pvx.ooadide.launchers.debug.model
  • Classes
    Class
    Description
    DebugLauncherThread
    DebugServer
    ServerSocketThread


com.pvx.ooadide.launchers.debug.communication Class Hierarchy

Hierarchy For Package com.pvx.ooadide.launchers.debug.communication

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • com.pvx.ooadide.launchers.debug.communication.DebugServer
    • java.lang.Thread (implements java.lang.Runnable)
      • com.pvx.ooadide.launchers.debug.communication.DebugLauncherThread
      • com.pvx.ooadide.launchers.debug.communication.ServerSocketThread


Uses of Package com.pvx.ooadide.launchers.debug.communication

Uses of Package
com.pvx.ooadide.launchers.debug.communication

Packages that use com.pvx.ooadide.launchers.debug.communication
Package
Description
com.pvx.ooadide.launchers.debug.communication
com.pvx.ooadide.launchers.thinclients
  • Classes in com.pvx.ooadide.launchers.debug.communication used by com.pvx.ooadide.launchers.debug.communication
    Class
    Description
    DebugLauncherThread
    DebugServer
  • Classes in com.pvx.ooadide.launchers.debug.communication used by com.pvx.ooadide.launchers.thinclients
    Class
    Description
    DebugLauncherThread


ServerSocketThread

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.launchers.debug.communication

Class ServerSocketThread

java.lang.Object
java.lang.Thread
com.pvx.ooadide.launchers.debug.communication.ServerSocketThread
All Implemented Interfaces:
Runnable
public class ServerSocketThread extends Thread

  • Nested Class Summary

    Nested classes/interfaces inherited from class java.lang.Thread

    Thread.State, Thread.UncaughtExceptionHandler

  • Field Summary

    Fields inherited from class java.lang.Thread

    MAX_PRIORITY, MIN_PRIORITY, NORM_PRIORITY

  • Constructor Summary

    Constructors
    Constructor
    Description
    ServerSocketThread(DebugLauncherThread thread, int requestPort, int eventPort)

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    run()

    Methods inherited from class java.lang.Thread

    activeCount, currentThread, dumpStack, enumerate, getAllStackTraces, getContextClassLoader, getDefaultUncaughtExceptionHandler, getId, getName, getPriority, getStackTrace, getState, getThreadGroup, getUncaughtExceptionHandler, holdsLock, interrupt, interrupted, isAlive, isDaemon, isInterrupted, join, join, join, onSpinWait, setContextClassLoader, setDaemon, setDefaultUncaughtExceptionHandler, setName, setPriority, setUncaughtExceptionHandler, sleep, sleep, start, toString, yield

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

  • Constructor Details

    • ServerSocketThread

      public ServerSocketThread(DebugLauncherThread thread, int requestPort, int eventPort)

  • Method Details

    • run

      public void run()
      Specified by:
      run in interface Runnable
      Overrides:
      run in class Thread


Uses of Class com.pvx.ooadide.launchers.debug.communication.DebugLauncherThread

Uses of Class
com.pvx.ooadide.launchers.debug.communication.DebugLauncherThread

Packages that use DebugLauncherThread
Package
Description
com.pvx.ooadide.launchers.debug.communication
com.pvx.ooadide.launchers.thinclients

  • Uses of DebugLauncherThread in com.pvx.ooadide.launchers.debug.communication

    Constructors in com.pvx.ooadide.launchers.debug.communication with parameters of type DebugLauncherThread
    Modifier
    Constructor
    Description

    ServerSocketThread(DebugLauncherThread thread, int requestPort, int eventPort)

  • Uses of DebugLauncherThread in com.pvx.ooadide.launchers.thinclients

    Subclasses of DebugLauncherThread in com.pvx.ooadide.launchers.thinclients
    Modifier and Type
    Class
    Description
    class
    DebugWindXLauncherThread


Uses of Class com.pvx.ooadide.launchers.debug.communication.DebugServer

Uses of Class
com.pvx.ooadide.launchers.debug.communication.DebugServer

Packages that use DebugServer
Package
Description
com.pvx.ooadide.launchers.debug.communication

  • Uses of DebugServer in com.pvx.ooadide.launchers.debug.communication

    Methods in com.pvx.ooadide.launchers.debug.communication that return DebugServer
    Modifier and Type
    Method
    Description
    static DebugServer
    DebugServer.getDefault()


Uses of Class com.pvx.ooadide.launchers.debug.communication.ServerSocketThread

Uses of Class
com.pvx.ooadide.launchers.debug.communication.ServerSocketThread

No usage of com.pvx.ooadide.launchers.debug.communication.ServerSocketThread


com.pvx.ooadide.launchers.debug.launching

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.pvx.ooadide.launchers.debug.launching

package com.pvx.ooadide.launchers.debug.launching
  • Related Packages
    Package
    Description
    com.pvx.ooadide.launchers.debug
    com.pvx.ooadide.launchers.debug.breakpoints
    com.pvx.ooadide.launchers.debug.communication
    com.pvx.ooadide.launchers.debug.model
  • Classes
    Class
    Description
    PVXModelPresentation
    Renders PDA debug elements
    PVXSourceLookupDirector
    PDA source lookup director.
    PVXSourceLookupParticipant
    The PDA source lookup participant knows how to translate a PDA stack frame into a source file name
    PVXSourcePathComputerDelegate
    Computes the default source lookup path for a PDA launch configuration.


com.pvx.ooadide.launchers.debug.launching Class Hierarchy

Hierarchy For Package com.pvx.ooadide.launchers.debug.launching

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.eclipse.debug.core.sourcelookup.AbstractSourceLookupDirector (implements org.eclipse.debug.core.ILaunchConfigurationListener, org.eclipse.debug.core.ILaunchListener, org.eclipse.debug.core.sourcelookup.ISourceLookupDirector)
      • com.pvx.ooadide.launchers.debug.launching.PVXSourceLookupDirector
    • org.eclipse.debug.core.sourcelookup.AbstractSourceLookupParticipant (implements org.eclipse.debug.core.sourcelookup.ISourceLookupParticipant)
      • com.pvx.ooadide.launchers.debug.launching.PVXSourceLookupParticipant
    • org.eclipse.core.commands.common.EventManager
      • org.eclipse.jface.viewers.BaseLabelProvider (implements org.eclipse.jface.viewers.IBaseLabelProvider)
        • org.eclipse.jface.viewers.LabelProvider (implements org.eclipse.jface.viewers.ILabelProvider)
          • com.pvx.ooadide.launchers.debug.launching.PVXModelPresentation (implements org.eclipse.debug.ui.IDebugModelPresentation)
    • com.pvx.ooadide.launchers.debug.launching.PVXSourcePathComputerDelegate (implements org.eclipse.debug.core.sourcelookup.ISourcePathComputerDelegate)


Uses of Package com.pvx.ooadide.launchers.debug.launching

Uses of Package
com.pvx.ooadide.launchers.debug.launching

No usage of com.pvx.ooadide.launchers.debug.launching


PVXModelPresentation

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.launchers.debug.launching

Class PVXModelPresentation

java.lang.Object
org.eclipse.core.commands.common.EventManager
org.eclipse.jface.viewers.BaseLabelProvider
org.eclipse.jface.viewers.LabelProvider
com.pvx.ooadide.launchers.debug.launching.PVXModelPresentation
All Implemented Interfaces:
org.eclipse.debug.ui.IDebugModelPresentation, org.eclipse.debug.ui.ISourcePresentation, org.eclipse.jface.viewers.IBaseLabelProvider, org.eclipse.jface.viewers.ILabelProvider
public class PVXModelPresentation extends org.eclipse.jface.viewers.LabelProvider implements org.eclipse.debug.ui.IDebugModelPresentation
Renders PDA debug elements

  • Field Summary

    Fields inherited from interface org.eclipse.debug.ui.IDebugModelPresentation

    DISPLAY_VARIABLE_TYPE_NAMES

  • Constructor Summary

    Constructors
    Constructor
    Description
    PVXModelPresentation()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    computeDetail(org.eclipse.debug.core.model.IValue value, org.eclipse.debug.ui.IValueDetailListener listener)
    String
    getEditorId(org.eclipse.ui.IEditorInput input, Object element)
    org.eclipse.ui.IEditorInput
    getEditorInput(Object element)
    org.eclipse.swt.graphics.Image
    getImage(Object element)
    String
    getText(Object element)
    void
    setAttribute(String attribute, Object value)

    Methods inherited from class org.eclipse.jface.viewers.BaseLabelProvider

    addListener, dispose, isLabelProperty, removeListener

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface org.eclipse.jface.viewers.IBaseLabelProvider

    addListener, dispose, isLabelProperty, removeListener

  • Constructor Details

    • PVXModelPresentation

      public PVXModelPresentation()

  • Method Details

    • setAttribute

      public void setAttribute(String attribute, Object value)
      Specified by:
      setAttribute in interface org.eclipse.debug.ui.IDebugModelPresentation

    • getImage

      public org.eclipse.swt.graphics.Image getImage(Object element)
      Specified by:
      getImage in interface org.eclipse.debug.ui.IDebugModelPresentation
      Specified by:
      getImage in interface org.eclipse.jface.viewers.ILabelProvider
      Overrides:
      getImage in class org.eclipse.jface.viewers.LabelProvider

    • getText

      public String getText(Object element)
      Specified by:
      getText in interface org.eclipse.debug.ui.IDebugModelPresentation
      Specified by:
      getText in interface org.eclipse.jface.viewers.ILabelProvider
      Overrides:
      getText in class org.eclipse.jface.viewers.LabelProvider

    • computeDetail

      public void computeDetail(org.eclipse.debug.core.model.IValue value, org.eclipse.debug.ui.IValueDetailListener listener)
      Specified by:
      computeDetail in interface org.eclipse.debug.ui.IDebugModelPresentation

    • getEditorInput

      public org.eclipse.ui.IEditorInput getEditorInput(Object element)
      Specified by:
      getEditorInput in interface org.eclipse.debug.ui.ISourcePresentation

    • getEditorId

      public String getEditorId(org.eclipse.ui.IEditorInput input, Object element)
      Specified by:
      getEditorId in interface org.eclipse.debug.ui.ISourcePresentation


PVXSourceLookupDirector

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.launchers.debug.launching

Class PVXSourceLookupDirector

java.lang.Object
org.eclipse.debug.core.sourcelookup.AbstractSourceLookupDirector
com.pvx.ooadide.launchers.debug.launching.PVXSourceLookupDirector
All Implemented Interfaces:
org.eclipse.debug.core.ILaunchConfigurationListener, org.eclipse.debug.core.ILaunchListener, org.eclipse.debug.core.model.IPersistableSourceLocator, org.eclipse.debug.core.model.ISourceLocator, org.eclipse.debug.core.sourcelookup.IPersistableSourceLocator2, org.eclipse.debug.core.sourcelookup.ISourceLookupDirector
public class PVXSourceLookupDirector extends org.eclipse.debug.core.sourcelookup.AbstractSourceLookupDirector
PDA source lookup director. For PDA source lookup there is one source lookup participant.

  • Constructor Summary

    Constructors
    Constructor
    Description
    PVXSourceLookupDirector()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    initializeParticipants()

    Methods inherited from class org.eclipse.debug.core.sourcelookup.AbstractSourceLookupDirector

    addParticipants, clearSourceElements, dispose, findSourceElements, getCurrentParticipant, getId, getLaunchConfiguration, getMemento, getParticipants, getSourceContainers, getSourceElement, getSourceElement, getSourcePathComputer, initializeDefaults, initializeFromMemento, initializeFromMemento, isFindDuplicates, launchAdded, launchChanged, launchConfigurationAdded, launchConfigurationChanged, launchConfigurationRemoved, launchRemoved, removeParticipants, resolveSourceElement, setFindDuplicates, setId, setSourceContainers, setSourcePathComputer, supportsSourceContainerType

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • PVXSourceLookupDirector

      public PVXSourceLookupDirector()

  • Method Details

    • initializeParticipants

      public void initializeParticipants()


PVXSourceLookupParticipant

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.launchers.debug.launching

Class PVXSourceLookupParticipant

java.lang.Object
org.eclipse.debug.core.sourcelookup.AbstractSourceLookupParticipant
com.pvx.ooadide.launchers.debug.launching.PVXSourceLookupParticipant
All Implemented Interfaces:
org.eclipse.debug.core.sourcelookup.ISourceLookupParticipant
public class PVXSourceLookupParticipant extends org.eclipse.debug.core.sourcelookup.AbstractSourceLookupParticipant
The PDA source lookup participant knows how to translate a PDA stack frame into a source file name

  • Constructor Summary

    Constructors
    Constructor
    Description
    PVXSourceLookupParticipant()

  • Method Summary

    Modifier and Type
    Method
    Description
    String
    getSourceName(Object object)

    Methods inherited from class org.eclipse.debug.core.sourcelookup.AbstractSourceLookupParticipant

    dispose, findSourceElements, init, isFindDuplicates, sourceContainersChanged

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • PVXSourceLookupParticipant

      public PVXSourceLookupParticipant()

  • Method Details

    • getSourceName

      public String getSourceName(Object object) throws org.eclipse.core.runtime.CoreException
      Throws:
      org.eclipse.core.runtime.CoreException


PVXSourcePathComputerDelegate

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.launchers.debug.launching

Class PVXSourcePathComputerDelegate

java.lang.Object
com.pvx.ooadide.launchers.debug.launching.PVXSourcePathComputerDelegate
All Implemented Interfaces:
org.eclipse.debug.core.sourcelookup.ISourcePathComputerDelegate
public class PVXSourcePathComputerDelegate extends Object implements org.eclipse.debug.core.sourcelookup.ISourcePathComputerDelegate
Computes the default source lookup path for a PDA launch configuration. The default source lookup path is the folder or project containing the PDA program being launched. If the program is not specified, the workspace is searched by default.

  • Constructor Summary

    Constructors
    Constructor
    Description
    PVXSourcePathComputerDelegate()

  • Method Summary

    Modifier and Type
    Method
    Description
    org.eclipse.debug.core.sourcelookup.ISourceContainer[]
    computeSourceContainers(org.eclipse.debug.core.ILaunchConfiguration configuration, org.eclipse.core.runtime.IProgressMonitor monitor)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • PVXSourcePathComputerDelegate

      public PVXSourcePathComputerDelegate()

  • Method Details

    • computeSourceContainers

      public org.eclipse.debug.core.sourcelookup.ISourceContainer[] computeSourceContainers(org.eclipse.debug.core.ILaunchConfiguration configuration, org.eclipse.core.runtime.IProgressMonitor monitor) throws org.eclipse.core.runtime.CoreException
      Specified by:
      computeSourceContainers in interface org.eclipse.debug.core.sourcelookup.ISourcePathComputerDelegate
      Throws:
      org.eclipse.core.runtime.CoreException


Uses of Class com.pvx.ooadide.launchers.debug.launching.PVXModelPresentation

Uses of Class
com.pvx.ooadide.launchers.debug.launching.PVXModelPresentation

No usage of com.pvx.ooadide.launchers.debug.launching.PVXModelPresentation


Uses of Class com.pvx.ooadide.launchers.debug.launching.PVXSourceLookupDirector

Uses of Class
com.pvx.ooadide.launchers.debug.launching.PVXSourceLookupDirector

No usage of com.pvx.ooadide.launchers.debug.launching.PVXSourceLookupDirector


Uses of Class com.pvx.ooadide.launchers.debug.launching.PVXSourceLookupParticipant

Uses of Class
com.pvx.ooadide.launchers.debug.launching.PVXSourceLookupParticipant

No usage of com.pvx.ooadide.launchers.debug.launching.PVXSourceLookupParticipant


Uses of Class com.pvx.ooadide.launchers.debug.launching.PVXSourcePathComputerDelegate

Uses of Class
com.pvx.ooadide.launchers.debug.launching.PVXSourcePathComputerDelegate

No usage of com.pvx.ooadide.launchers.debug.launching.PVXSourcePathComputerDelegate


IPVXEventListener

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.launchers.debug.model

Interface IPVXEventListener

All Known Implementing Classes:
PVXDebugTarget, PVXLineBreakpoint, PvxLineBreakpointAdapter, PVXRunToLineBreakpoint, PVXThread
public interface IPVXEventListener

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    handleEvent(String event)
    Notification the given event occurred in the target program being interpretted.

  • Method Details

    • handleEvent

      void handleEvent(String event)
      Notification the given event occurred in the target program being interpretted.
      Parameters:
      event - the event


com.pvx.ooadide.launchers.debug.model

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.pvx.ooadide.launchers.debug.model

package com.pvx.ooadide.launchers.debug.model
  • Related Packages
    Package
    Description
    com.pvx.ooadide.launchers.debug
    com.pvx.ooadide.launchers.debug.breakpoints
    com.pvx.ooadide.launchers.debug.communication
    com.pvx.ooadide.launchers.debug.launching
  • Class
    Description
    IPVXEventListener
    PvxArrayElementVariable
    PVXArrayValue
    PVXDebugElement
    PVXDebugTarget
    PVX Debug Target
    PvxLineBreakpointAdapter
    Adapter to create breakpoints in PVX files.
    PVXStackFrame
    PDA stack frame.
    PVXStackValue
    A value on the data stack
    PVXThread
    // * A y VM thread.
    PVXValue
    Value of a PDA variable.
    PVXVariable
    A variable in a PVX stack frame


com.pvx.ooadide.launchers.debug.model Class Hierarchy

Hierarchy For Package com.pvx.ooadide.launchers.debug.model

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.eclipse.core.runtime.PlatformObject (implements org.eclipse.core.runtime.IAdaptable)
      • org.eclipse.debug.core.model.Breakpoint (implements org.eclipse.debug.core.model.IBreakpoint, org.eclipse.debug.core.model.ITriggerPoint)
        • org.eclipse.debug.core.model.LineBreakpoint (implements org.eclipse.debug.core.model.ILineBreakpoint)
          • com.pvx.ooadide.launchers.debug.model.PvxLineBreakpointAdapter (implements com.pvx.ooadide.launchers.debug.model.IPVXEventListener)
      • org.eclipse.debug.core.model.DebugElement (implements org.eclipse.debug.core.model.IDebugElement)
        • com.pvx.ooadide.launchers.debug.model.PVXDebugElement
          • com.pvx.ooadide.launchers.debug.model.PVXDebugTarget (implements org.eclipse.debug.core.IBreakpointManagerListener, org.eclipse.debug.core.model.IDebugTarget, com.pvx.ooadide.launchers.debug.model.IPVXEventListener)
          • com.pvx.ooadide.launchers.debug.model.PVXStackFrame (implements org.eclipse.debug.core.model.IStackFrame)
          • com.pvx.ooadide.launchers.debug.model.PVXThread (implements com.pvx.ooadide.launchers.debug.model.IPVXEventListener, org.eclipse.debug.core.model.IThread)
          • com.pvx.ooadide.launchers.debug.model.PVXValue (implements org.eclipse.debug.core.model.IValue)
            • com.pvx.ooadide.launchers.debug.model.PVXStackValue
          • com.pvx.ooadide.launchers.debug.model.PVXVariable (implements org.eclipse.debug.core.model.IVariable)
            • com.pvx.ooadide.launchers.debug.model.PvxArrayElementVariable
            • com.pvx.ooadide.launchers.debug.model.PVXArrayValue (implements org.eclipse.debug.core.model.IIndexedValue)

Interface Hierarchy

  • com.pvx.ooadide.launchers.debug.model.IPVXEventListener


Uses of Package com.pvx.ooadide.launchers.debug.model

Uses of Package
com.pvx.ooadide.launchers.debug.model

Packages that use com.pvx.ooadide.launchers.debug.model
Package
Description
com.pvx.ooadide.launchers.debug.breakpoints
com.pvx.ooadide.launchers.debug.model
  • Classes in com.pvx.ooadide.launchers.debug.model used by com.pvx.ooadide.launchers.debug.breakpoints
    Class
    Description
    IPVXEventListener
    PVXDebugTarget
    PVX Debug Target
  • Classes in com.pvx.ooadide.launchers.debug.model used by com.pvx.ooadide.launchers.debug.model
    Class
    Description
    IPVXEventListener
    PVXDebugElement
    PVXDebugTarget
    PVX Debug Target
    PVXStackFrame
    PDA stack frame.
    PVXThread
    // * A y VM thread.
    PVXValue
    Value of a PDA variable.
    PVXVariable
    A variable in a PVX stack frame


PvxArrayElementVariable

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.launchers.debug.model

Class PvxArrayElementVariable

java.lang.Object
org.eclipse.core.runtime.PlatformObject
org.eclipse.debug.core.model.DebugElement
com.pvx.ooadide.launchers.debug.model.PVXDebugElement
com.pvx.ooadide.launchers.debug.model.PVXVariable
com.pvx.ooadide.launchers.debug.model.PvxArrayElementVariable
All Implemented Interfaces:
org.eclipse.core.runtime.IAdaptable, org.eclipse.debug.core.model.IDebugElement, org.eclipse.debug.core.model.IValueModification, org.eclipse.debug.core.model.IVariable
public class PvxArrayElementVariable extends PVXVariable

  • Field Summary

    Fields inherited from class com.pvx.ooadide.launchers.debug.model.PVXVariable

    TYPE_NUMERIC, TYPE_STRING

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxArrayElementVariable(PVXStackFrame frame, String var, int init_indx, int dimBase)

  • Method Summary

    Modifier and Type
    Method
    Description
    String
    getName()
    org.eclipse.debug.core.model.IValue
    getValue()

    Methods inherited from class com.pvx.ooadide.launchers.debug.model.PVXVariable

    getReferenceTypeName, hasValueChanged, hasVariables, setValue, setValue, supportsValueModification, verifyValue, verifyValue

    Methods inherited from class com.pvx.ooadide.launchers.debug.model.PVXDebugElement

    getModelIdentifier, sendRequest

    Methods inherited from class org.eclipse.debug.core.model.DebugElement

    fireChangeEvent, fireCreationEvent, fireEvent, fireResumeEvent, fireSuspendEvent, fireTerminateEvent, getAdapter, getDebugTarget, getLaunch

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface org.eclipse.core.runtime.IAdaptable

    getAdapter

    Methods inherited from interface org.eclipse.debug.core.model.IDebugElement

    getDebugTarget, getLaunch, getModelIdentifier

  • Constructor Details

    • PvxArrayElementVariable

      public PvxArrayElementVariable(PVXStackFrame frame, String var, int init_indx, int dimBase)

  • Method Details

    • getName

      public String getName() throws org.eclipse.debug.core.DebugException
      Specified by:
      getName in interface org.eclipse.debug.core.model.IVariable
      Overrides:
      getName in class PVXVariable
      Throws:
      org.eclipse.debug.core.DebugException

    • getValue

      public org.eclipse.debug.core.model.IValue getValue() throws org.eclipse.debug.core.DebugException
      Specified by:
      getValue in interface org.eclipse.debug.core.model.IVariable
      Overrides:
      getValue in class PVXVariable
      Throws:
      org.eclipse.debug.core.DebugException


PVXArrayValue

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.launchers.debug.model

Class PVXArrayValue

java.lang.Object
org.eclipse.core.runtime.PlatformObject
org.eclipse.debug.core.model.DebugElement
com.pvx.ooadide.launchers.debug.model.PVXDebugElement
com.pvx.ooadide.launchers.debug.model.PVXVariable
com.pvx.ooadide.launchers.debug.model.PVXArrayValue
All Implemented Interfaces:
org.eclipse.core.runtime.IAdaptable, org.eclipse.debug.core.model.IDebugElement, org.eclipse.debug.core.model.IIndexedValue, org.eclipse.debug.core.model.IValue, org.eclipse.debug.core.model.IValueModification, org.eclipse.debug.core.model.IVariable
public class PVXArrayValue extends PVXVariable implements org.eclipse.debug.core.model.IIndexedValue

  • Field Summary

    Fields inherited from class com.pvx.ooadide.launchers.debug.model.PVXVariable

    TYPE_NUMERIC, TYPE_STRING

  • Constructor Summary

    Constructors
    Constructor
    Description
    PVXArrayValue(PVXStackFrame frame, String name, int size, int dimBase)

  • Method Summary

    Modifier and Type
    Method
    Description
    int
    getInitialOffset()
    int
    getSize()
    String
    getValueString()
    org.eclipse.debug.core.model.IVariable
    getVariable(int offset)
    org.eclipse.debug.core.model.IVariable[]
    getVariables()
    org.eclipse.debug.core.model.IVariable[]
    getVariables(int offset, int length)
    boolean
    hasVariables()
    boolean
    isAllocated()

    Methods inherited from class com.pvx.ooadide.launchers.debug.model.PVXVariable

    getName, getReferenceTypeName, getValue, hasValueChanged, setValue, setValue, supportsValueModification, verifyValue, verifyValue

    Methods inherited from class com.pvx.ooadide.launchers.debug.model.PVXDebugElement

    getModelIdentifier, sendRequest

    Methods inherited from class org.eclipse.debug.core.model.DebugElement

    fireChangeEvent, fireCreationEvent, fireEvent, fireResumeEvent, fireSuspendEvent, fireTerminateEvent, getAdapter, getDebugTarget, getLaunch

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface org.eclipse.core.runtime.IAdaptable

    getAdapter

    Methods inherited from interface org.eclipse.debug.core.model.IDebugElement

    getDebugTarget, getLaunch, getModelIdentifier

    Methods inherited from interface org.eclipse.debug.core.model.IValue

    getReferenceTypeName

  • Constructor Details

    • PVXArrayValue

      public PVXArrayValue(PVXStackFrame frame, String name, int size, int dimBase)

  • Method Details

    • getInitialOffset

      public int getInitialOffset()
      Specified by:
      getInitialOffset in interface org.eclipse.debug.core.model.IIndexedValue

    • getSize

      public int getSize() throws org.eclipse.debug.core.DebugException
      Specified by:
      getSize in interface org.eclipse.debug.core.model.IIndexedValue
      Throws:
      org.eclipse.debug.core.DebugException

    • getVariable

      public org.eclipse.debug.core.model.IVariable getVariable(int offset) throws org.eclipse.debug.core.DebugException
      Specified by:
      getVariable in interface org.eclipse.debug.core.model.IIndexedValue
      Throws:
      org.eclipse.debug.core.DebugException

    • getVariables

      public org.eclipse.debug.core.model.IVariable[] getVariables(int offset, int length) throws org.eclipse.debug.core.DebugException
      Specified by:
      getVariables in interface org.eclipse.debug.core.model.IIndexedValue
      Throws:
      org.eclipse.debug.core.DebugException

    • getValueString

      public String getValueString() throws org.eclipse.debug.core.DebugException
      Specified by:
      getValueString in interface org.eclipse.debug.core.model.IValue
      Throws:
      org.eclipse.debug.core.DebugException

    • getVariables

      public org.eclipse.debug.core.model.IVariable[] getVariables() throws org.eclipse.debug.core.DebugException
      Specified by:
      getVariables in interface org.eclipse.debug.core.model.IValue
      Throws:
      org.eclipse.debug.core.DebugException

    • hasVariables

      public boolean hasVariables() throws org.eclipse.debug.core.DebugException
      Specified by:
      hasVariables in interface org.eclipse.debug.core.model.IValue
      Overrides:
      hasVariables in class PVXVariable
      Throws:
      org.eclipse.debug.core.DebugException

    • isAllocated

      public boolean isAllocated() throws org.eclipse.debug.core.DebugException
      Specified by:
      isAllocated in interface org.eclipse.debug.core.model.IValue
      Throws:
      org.eclipse.debug.core.DebugException


PVXDebugElement

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.launchers.debug.model

Class PVXDebugElement

java.lang.Object
org.eclipse.core.runtime.PlatformObject
org.eclipse.debug.core.model.DebugElement
com.pvx.ooadide.launchers.debug.model.PVXDebugElement
All Implemented Interfaces:
org.eclipse.core.runtime.IAdaptable, org.eclipse.debug.core.model.IDebugElement
Direct Known Subclasses:
PVXDebugTarget, PVXStackFrame, PVXThread, PVXValue, PVXVariable
public class PVXDebugElement extends org.eclipse.debug.core.model.DebugElement

  • Constructor Summary

    Constructors
    Constructor
    Description
    PVXDebugElement(org.eclipse.debug.core.model.IDebugTarget target)
    Constructs a new debug element in the given target.

  • Method Summary

    Modifier and Type
    Method
    Description
    String
    getModelIdentifier()
    String
    sendRequest(String request)
    Sends a request to the PDA interpretor, waits for and returns the reply.

    Methods inherited from class org.eclipse.debug.core.model.DebugElement

    fireChangeEvent, fireCreationEvent, fireEvent, fireResumeEvent, fireSuspendEvent, fireTerminateEvent, getAdapter, getDebugTarget, getLaunch

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • PVXDebugElement

      public PVXDebugElement(org.eclipse.debug.core.model.IDebugTarget target)
      Constructs a new debug element in the given target.
      Parameters:
      target - debug target

  • Method Details

    • getModelIdentifier

      public String getModelIdentifier()

    • sendRequest

      public String sendRequest(String request) throws org.eclipse.debug.core.DebugException
      Sends a request to the PDA interpretor, waits for and returns the reply.

      Interprettor commands and replies are as follows:

      • clear N - clear the breakpoint on line N; reply is ok
      • data - return the contents of the data stack; reply is the data from oldest to newest as a single string "value|value|value|...|value|"
      • drop - pops the top stack frame off the call stack setting the instruction pointer to the calling statement in the calling frame
      • eventstop E B - optionally stop the interpreter when an error event E is encountered; B specifies stop (1) or continue (0). The possible events are unimpinstr and nosuchlabel. Reply is ok. When an event is encountered, the interprettor sends the error event (for example unimlpemented instruction foo) and corresponding suspend event (for example suspended event unimpinstr).
      • exit - end the interpretter; reply is ok
      • popdata - pop the top value off the data stack; reply is the value
      • pushdata V - push the value V onto the data stack; reply is ok
      • resume - resume execution of the program; reply is ok
      • set N - set a line breakpoint on line N (lines are indexed from 0); reply is ok
      • setdata N V - set the contents of data stack element N to value V (the data stack is indexed from 0, 0 being the oldest); reply is ok
      • setvar N M V - set the contents of variable M from the control stack N to value V (the control stack is indexed from 0, 0 being the oldest); reply is ok
      • stack - return the contents of the control stack (program counters, function and variable names); reply is control stack from oldest to newest as a single string frame#frame#frame...#frame where each frame is a string "filename|pc|function name|variable name|variable name|...|variable name"
      • step - single step forward; reply is ok
      • stepreturn - single step forward until the next return op code; stop before executing the return ; reply is ok
      • suspend - suspend execution of the program and listen for debug comands; reply is ok
      • watch F::V M - set a watchpoint on variable V in function F to magic value M; the magic value is a bit flag corresponding to read access (1), write access (2), or both (3); the magic value 0 clears the watchpoint; reply is ok
      • var N M - return the contents of variable M in the control stack frame N (stack frames are indexed from 0, 0 being the oldest); reply is variable value

      Parameters:
      request - command
      Returns:
      reply
      Throws:
      org.eclipse.debug.core.DebugException - if the request fails


PVXDebugTarget

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.launchers.debug.model

Class PVXDebugTarget

java.lang.Object
org.eclipse.core.runtime.PlatformObject
org.eclipse.debug.core.model.DebugElement
com.pvx.ooadide.launchers.debug.model.PVXDebugElement
com.pvx.ooadide.launchers.debug.model.PVXDebugTarget
All Implemented Interfaces:
IPVXEventListener, org.eclipse.core.runtime.IAdaptable, org.eclipse.debug.core.IBreakpointListener, org.eclipse.debug.core.IBreakpointManagerListener, org.eclipse.debug.core.model.IDebugElement, org.eclipse.debug.core.model.IDebugTarget, org.eclipse.debug.core.model.IDisconnect, org.eclipse.debug.core.model.IMemoryBlockRetrieval, org.eclipse.debug.core.model.ISuspendResume, org.eclipse.debug.core.model.ITerminate
public class PVXDebugTarget extends PVXDebugElement implements org.eclipse.debug.core.model.IDebugTarget, org.eclipse.debug.core.IBreakpointManagerListener, IPVXEventListener
PVX Debug Target

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final String
    CHARSET

  • Constructor Summary

    Constructors
    Constructor
    Description
    PVXDebugTarget(org.eclipse.debug.core.ILaunch launch, org.eclipse.debug.core.model.IProcess process)
    Constructs a new debug target in the given launch for the associated PVX VM process.
    PVXDebugTarget(org.eclipse.debug.core.ILaunch launch, org.eclipse.debug.core.model.IProcess process, int requestPort, int eventPort)
    Constructs a new debug target in the given launch for the associated PVX VM process.
    PVXDebugTarget(org.eclipse.debug.core.ILaunch launch, org.eclipse.debug.core.model.IProcess p, String iName)

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    addEventListener(IPVXEventListener listener)
    Registers the given event listener.
    void
    breakpointAdded(org.eclipse.debug.core.model.IBreakpoint breakpoint)
    void
    breakpointChanged(org.eclipse.debug.core.model.IBreakpoint breakpoint, org.eclipse.core.resources.IMarkerDelta delta)
    void
    breakpointManagerEnablementChanged(boolean enabled)
    When the breakpoint manager disables, remove all registered breakpoints requests from the VM.
    void
    breakpointRemoved(org.eclipse.debug.core.model.IBreakpoint breakpoint, org.eclipse.core.resources.IMarkerDelta delta)
    boolean
    canDisconnect()
    boolean
    canPop()
    Returns whether popping the data stack is currently permitted
    boolean
    canPush()
    Returns whether pushing a value is currently supported.
    boolean
    canResume()
    boolean
    canSuspend()
    boolean
    canTerminate()
    boolean
    connectToInterpreter(int requestPort, int eventPort)
    void
    disconnect()
    org.eclipse.debug.core.model.IValue[]
    getDataStack()
    Returns the values on the data stack (top down)
    org.eclipse.debug.core.model.IDebugTarget
    getDebugTarget()
    org.eclipse.debug.core.ILaunch
    getLaunch()
    org.eclipse.debug.core.model.IMemoryBlock
    getMemoryBlock(long startAddress, long length)
    String
    getName()
    org.eclipse.debug.core.model.IProcess
    getProcess()
    org.eclipse.debug.core.model.IThread[]
    getThreads()
    void
    handleEvent(String event)
    Notification the given event occurred in the target program being interpretted.
    boolean
    hasThreads()
    boolean
    isDisconnected()
    boolean
    isSuspended()
    boolean
    isTerminated()
    void
    logAvailableData()
    void
    pauseExecution(int milliS)
    org.eclipse.debug.core.model.IValue
    pop()
    Pops and returns the top of the data stack
    void
    push(String value)
    Pushes a value onto the stack.
    void
    removeEventListener(IPVXEventListener listener)
    Deregisters the given event listener.
    void
    resume()
    String
    sendRequest(String request)
    Sends a request to the PDA interpretor, waits for and returns the reply.
    void
    startDebugSession(Socket requestSocket, Socket eventSocket)
    boolean
    supportsBreakpoint(org.eclipse.debug.core.model.IBreakpoint breakpoint)
    boolean
    supportsStorageRetrieval()
    void
    suspend()
    void
    terminate()

    Methods inherited from class com.pvx.ooadide.launchers.debug.model.PVXDebugElement

    getModelIdentifier

    Methods inherited from class org.eclipse.debug.core.model.DebugElement

    fireChangeEvent, fireCreationEvent, fireEvent, fireResumeEvent, fireSuspendEvent, fireTerminateEvent, getAdapter

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface org.eclipse.core.runtime.IAdaptable

    getAdapter

    Methods inherited from interface org.eclipse.debug.core.IBreakpointManagerListener

    breakpointManagerTriggerPointChanged

    Methods inherited from interface org.eclipse.debug.core.model.IDebugElement

    getModelIdentifier

  • Field Details

    • CHARSET

      public static final String CHARSET
      See Also:
      • Constant Field Values

  • Constructor Details

    • PVXDebugTarget

      public PVXDebugTarget(org.eclipse.debug.core.ILaunch launch, org.eclipse.debug.core.model.IProcess process, int requestPort, int eventPort) throws org.eclipse.core.runtime.CoreException
      Constructs a new debug target in the given launch for the associated PVX VM process. This constructor creates an instance that creates client sockets that open a connection to the pvx interpreter which is opening server sockets
      Parameters:
      launch - containing launch
      process - PVX VM
      requestPort - port to send requests to the VM
      eventPort - port to read events from
      Throws:
      org.eclipse.core.runtime.CoreException - if unable to connect to host

    • PVXDebugTarget

      public PVXDebugTarget(org.eclipse.debug.core.ILaunch launch, org.eclipse.debug.core.model.IProcess process) throws org.eclipse.core.runtime.CoreException
      Constructs a new debug target in the given launch for the associated PVX VM process. This constructor creates an instance that creates server sockets sockets that open a connection to the pvx interpreter which is opening server sockets
      Parameters:
      launch - containing launch
      process - PVX VM
      requestPort - port to send requests to the VM
      eventPort - port to read events from
      Throws:
      org.eclipse.core.runtime.CoreException - if unable to connect to host

    • PVXDebugTarget

      public PVXDebugTarget(org.eclipse.debug.core.ILaunch launch, org.eclipse.debug.core.model.IProcess p, String iName) throws org.eclipse.core.runtime.CoreException
      Throws:
      org.eclipse.core.runtime.CoreException

  • Method Details

    • addEventListener

      public void addEventListener(IPVXEventListener listener)
      Registers the given event listener. The listener will be notified of events in the program being interpretted. Has no effect if the listener is already registered.
      Parameters:
      listener - event listener

    • removeEventListener

      public void removeEventListener(IPVXEventListener listener)
      Deregisters the given event listener. Has no effect if the listener is not currently registered.
      Parameters:
      listener - event listener

    • startDebugSession

      public void startDebugSession(Socket requestSocket, Socket eventSocket)

    • pauseExecution

      public void pauseExecution(int milliS)

    • connectToInterpreter

      public boolean connectToInterpreter(int requestPort, int eventPort) throws org.eclipse.debug.core.DebugException
      Throws:
      org.eclipse.debug.core.DebugException

    • getProcess

      public org.eclipse.debug.core.model.IProcess getProcess()
      Specified by:
      getProcess in interface org.eclipse.debug.core.model.IDebugTarget

    • getThreads

      public org.eclipse.debug.core.model.IThread[] getThreads() throws org.eclipse.debug.core.DebugException
      Specified by:
      getThreads in interface org.eclipse.debug.core.model.IDebugTarget
      Throws:
      org.eclipse.debug.core.DebugException

    • hasThreads

      public boolean hasThreads() throws org.eclipse.debug.core.DebugException
      Specified by:
      hasThreads in interface org.eclipse.debug.core.model.IDebugTarget
      Throws:
      org.eclipse.debug.core.DebugException

    • getName

      public String getName() throws org.eclipse.debug.core.DebugException
      Specified by:
      getName in interface org.eclipse.debug.core.model.IDebugTarget
      Throws:
      org.eclipse.debug.core.DebugException

    • supportsBreakpoint

      public boolean supportsBreakpoint(org.eclipse.debug.core.model.IBreakpoint breakpoint)
      Specified by:
      supportsBreakpoint in interface org.eclipse.debug.core.model.IDebugTarget

    • getDebugTarget

      public org.eclipse.debug.core.model.IDebugTarget getDebugTarget()
      Specified by:
      getDebugTarget in interface org.eclipse.debug.core.model.IDebugElement
      Overrides:
      getDebugTarget in class org.eclipse.debug.core.model.DebugElement

    • getLaunch

      public org.eclipse.debug.core.ILaunch getLaunch()
      Specified by:
      getLaunch in interface org.eclipse.debug.core.model.IDebugElement
      Overrides:
      getLaunch in class org.eclipse.debug.core.model.DebugElement

    • canTerminate

      public boolean canTerminate()
      Specified by:
      canTerminate in interface org.eclipse.debug.core.model.ITerminate

    • isTerminated

      public boolean isTerminated()
      Specified by:
      isTerminated in interface org.eclipse.debug.core.model.ITerminate

    • terminate

      public void terminate() throws org.eclipse.debug.core.DebugException
      Specified by:
      terminate in interface org.eclipse.debug.core.model.ITerminate
      Throws:
      org.eclipse.debug.core.DebugException

    • canResume

      public boolean canResume()
      Specified by:
      canResume in interface org.eclipse.debug.core.model.ISuspendResume

    • canSuspend

      public boolean canSuspend()
      Specified by:
      canSuspend in interface org.eclipse.debug.core.model.ISuspendResume

    • isSuspended

      public boolean isSuspended()
      Specified by:
      isSuspended in interface org.eclipse.debug.core.model.ISuspendResume

    • resume

      public void resume() throws org.eclipse.debug.core.DebugException
      Specified by:
      resume in interface org.eclipse.debug.core.model.ISuspendResume
      Throws:
      org.eclipse.debug.core.DebugException

    • suspend

      public void suspend() throws org.eclipse.debug.core.DebugException
      Specified by:
      suspend in interface org.eclipse.debug.core.model.ISuspendResume
      Throws:
      org.eclipse.debug.core.DebugException

    • breakpointAdded

      public void breakpointAdded(org.eclipse.debug.core.model.IBreakpoint breakpoint)
      Specified by:
      breakpointAdded in interface org.eclipse.debug.core.IBreakpointListener

    • breakpointRemoved

      public void breakpointRemoved(org.eclipse.debug.core.model.IBreakpoint breakpoint, org.eclipse.core.resources.IMarkerDelta delta)
      Specified by:
      breakpointRemoved in interface org.eclipse.debug.core.IBreakpointListener

    • breakpointChanged

      public void breakpointChanged(org.eclipse.debug.core.model.IBreakpoint breakpoint, org.eclipse.core.resources.IMarkerDelta delta)
      Specified by:
      breakpointChanged in interface org.eclipse.debug.core.IBreakpointListener

    • canDisconnect

      public boolean canDisconnect()
      Specified by:
      canDisconnect in interface org.eclipse.debug.core.model.IDisconnect

    • disconnect

      public void disconnect() throws org.eclipse.debug.core.DebugException
      Specified by:
      disconnect in interface org.eclipse.debug.core.model.IDisconnect
      Throws:
      org.eclipse.debug.core.DebugException

    • isDisconnected

      public boolean isDisconnected()
      Specified by:
      isDisconnected in interface org.eclipse.debug.core.model.IDisconnect

    • supportsStorageRetrieval

      public boolean supportsStorageRetrieval()
      Specified by:
      supportsStorageRetrieval in interface org.eclipse.debug.core.model.IMemoryBlockRetrieval

    • getMemoryBlock

      public org.eclipse.debug.core.model.IMemoryBlock getMemoryBlock(long startAddress, long length) throws org.eclipse.debug.core.DebugException
      Specified by:
      getMemoryBlock in interface org.eclipse.debug.core.model.IMemoryBlockRetrieval
      Throws:
      org.eclipse.debug.core.DebugException

    • getDataStack

      public org.eclipse.debug.core.model.IValue[] getDataStack() throws org.eclipse.debug.core.DebugException
      Returns the values on the data stack (top down)
      Returns:
      the values on the data stack (top down)
      Throws:
      org.eclipse.debug.core.DebugException

    • logAvailableData

      public void logAvailableData() throws IOException
      Throws:
      IOException

    • sendRequest

      public String sendRequest(String request) throws org.eclipse.debug.core.DebugException
      Description copied from class: PVXDebugElement
      Sends a request to the PDA interpretor, waits for and returns the reply.

      Interprettor commands and replies are as follows:

      • clear N - clear the breakpoint on line N; reply is ok
      • data - return the contents of the data stack; reply is the data from oldest to newest as a single string "value|value|value|...|value|"
      • drop - pops the top stack frame off the call stack setting the instruction pointer to the calling statement in the calling frame
      • eventstop E B - optionally stop the interpreter when an error event E is encountered; B specifies stop (1) or continue (0). The possible events are unimpinstr and nosuchlabel. Reply is ok. When an event is encountered, the interprettor sends the error event (for example unimlpemented instruction foo) and corresponding suspend event (for example suspended event unimpinstr).
      • exit - end the interpretter; reply is ok
      • popdata - pop the top value off the data stack; reply is the value
      • pushdata V - push the value V onto the data stack; reply is ok
      • resume - resume execution of the program; reply is ok
      • set N - set a line breakpoint on line N (lines are indexed from 0); reply is ok
      • setdata N V - set the contents of data stack element N to value V (the data stack is indexed from 0, 0 being the oldest); reply is ok
      • setvar N M V - set the contents of variable M from the control stack N to value V (the control stack is indexed from 0, 0 being the oldest); reply is ok
      • stack - return the contents of the control stack (program counters, function and variable names); reply is control stack from oldest to newest as a single string frame#frame#frame...#frame where each frame is a string "filename|pc|function name|variable name|variable name|...|variable name"
      • step - single step forward; reply is ok
      • stepreturn - single step forward until the next return op code; stop before executing the return ; reply is ok
      • suspend - suspend execution of the program and listen for debug comands; reply is ok
      • watch F::V M - set a watchpoint on variable V in function F to magic value M; the magic value is a bit flag corresponding to read access (1), write access (2), or both (3); the magic value 0 clears the watchpoint; reply is ok
      • var N M - return the contents of variable M in the control stack frame N (stack frames are indexed from 0, 0 being the oldest); reply is variable value

      Overrides:
      sendRequest in class PVXDebugElement
      Parameters:
      request - command
      Returns:
      reply
      Throws:
      org.eclipse.debug.core.DebugException - if the request fails

    • breakpointManagerEnablementChanged

      public void breakpointManagerEnablementChanged(boolean enabled)
      When the breakpoint manager disables, remove all registered breakpoints requests from the VM. When it enables, reinstall them.
      Specified by:
      breakpointManagerEnablementChanged in interface org.eclipse.debug.core.IBreakpointManagerListener

    • canPop

      public boolean canPop()
      Returns whether popping the data stack is currently permitted
      Returns:
      whether popping the data stack is currently permitted

    • pop

      public org.eclipse.debug.core.model.IValue pop() throws org.eclipse.debug.core.DebugException
      Pops and returns the top of the data stack
      Returns:
      the top value on the stack
      Throws:
      org.eclipse.debug.core.DebugException - if the stack is empty or the request fails

    • canPush

      public boolean canPush()
      Returns whether pushing a value is currently supported.
      Returns:
      whether pushing a value is currently supported

    • push

      public void push(String value) throws org.eclipse.debug.core.DebugException
      Pushes a value onto the stack.
      Parameters:
      value - value to push
      Throws:
      org.eclipse.debug.core.DebugException - on failure

    • handleEvent

      public void handleEvent(String event)
      Description copied from interface: IPVXEventListener
      Notification the given event occurred in the target program being interpretted.
      Specified by:
      handleEvent in interface IPVXEventListener
      Parameters:
      event - the event


PvxLineBreakpointAdapter

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.launchers.debug.model

Class PvxLineBreakpointAdapter

java.lang.Object
org.eclipse.core.runtime.PlatformObject
org.eclipse.debug.core.model.Breakpoint
org.eclipse.debug.core.model.LineBreakpoint
com.pvx.ooadide.launchers.debug.model.PvxLineBreakpointAdapter
All Implemented Interfaces:
IPVXEventListener, org.eclipse.core.runtime.IAdaptable, org.eclipse.debug.core.model.IBreakpoint, org.eclipse.debug.core.model.ILineBreakpoint, org.eclipse.debug.core.model.ITriggerPoint
public class PvxLineBreakpointAdapter extends org.eclipse.debug.core.model.LineBreakpoint implements IPVXEventListener
Adapter to create breakpoints in PVX files.

  • Field Summary

    Fields inherited from interface org.eclipse.debug.core.model.IBreakpoint

    BREAKPOINT_MARKER, ENABLED, ID, LINE_BREAKPOINT_MARKER, PERSISTED, REGISTERED

    Fields inherited from interface org.eclipse.debug.core.model.ITriggerPoint

    TRIGGERPOINT

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxLineBreakpointAdapter()

  • Method Summary

    Modifier and Type
    Method
    Description
    boolean
    canToggleLineBreakpoints(org.eclipse.ui.texteditor.ITextEditor editor, org.eclipse.jface.text.ITextSelection selection)
    String
    getModelIdentifier()
    void
    handleEvent(String event)
    Notification the given event occurred in the target program being interpretted.
    void
    install(PVXDebugTarget target)
    Installs this breakpoint in the given interprettor.
    boolean
    isRunToLineBreakpoint()
    Returns whether this breakpoint is a run-to-line breakpoint
    void
    remove(PVXDebugTarget target)
    Removes this breakpoint from the given interprettor.
    void
    toggleLineBreakpoints(org.eclipse.ui.IWorkbenchPart part, org.eclipse.jface.viewers.ISelection selection)

    Methods inherited from class org.eclipse.debug.core.model.LineBreakpoint

    getCharEnd, getCharStart, getLineNumber

    Methods inherited from class org.eclipse.debug.core.model.Breakpoint

    delete, equals, getMarker, hashCode, isEnabled, isPersisted, isRegistered, isTriggerPoint, setEnabled, setMarker, setPersisted, setRegistered, setTriggerPoint, toString

    Methods inherited from class org.eclipse.core.runtime.PlatformObject

    getAdapter

    Methods inherited from class java.lang.Object

    getClass, notify, notifyAll, wait, wait, wait

    Methods inherited from interface org.eclipse.core.runtime.IAdaptable

    getAdapter

    Methods inherited from interface org.eclipse.debug.core.model.IBreakpoint

    delete, getMarker, isEnabled, isPersisted, isRegistered, setEnabled, setMarker, setPersisted, setRegistered

  • Constructor Details

    • PvxLineBreakpointAdapter

      public PvxLineBreakpointAdapter()

  • Method Details

    • toggleLineBreakpoints

      public void toggleLineBreakpoints(org.eclipse.ui.IWorkbenchPart part, org.eclipse.jface.viewers.ISelection selection) throws org.eclipse.core.runtime.CoreException
      Throws:
      org.eclipse.core.runtime.CoreException

    • isRunToLineBreakpoint

      public boolean isRunToLineBreakpoint()
      Returns whether this breakpoint is a run-to-line breakpoint
      Returns:
      whether this breakpoint is a run-to-line breakpoint

    • install

      public void install(PVXDebugTarget target) throws org.eclipse.core.runtime.CoreException
      Installs this breakpoint in the given interprettor. Registeres this breakpoint as an event listener in the given target and creates the breakpoint specific request.
      Parameters:
      target - PVX interprettor
      Throws:
      org.eclipse.core.runtime.CoreException - if installation fails

    • remove

      public void remove(PVXDebugTarget target) throws org.eclipse.core.runtime.CoreException
      Removes this breakpoint from the given interprettor. Removes this breakpoint as an event listener and clears the request for the interprettor.
      Parameters:
      target - PVX interprettor
      Throws:
      org.eclipse.core.runtime.CoreException - if removal fails

    • handleEvent

      public void handleEvent(String event)
      Description copied from interface: IPVXEventListener
      Notification the given event occurred in the target program being interpretted.
      Specified by:
      handleEvent in interface IPVXEventListener
      Parameters:
      event - the event

    • getModelIdentifier

      public String getModelIdentifier()
      Specified by:
      getModelIdentifier in interface org.eclipse.debug.core.model.IBreakpoint

    • canToggleLineBreakpoints

      public boolean canToggleLineBreakpoints(org.eclipse.ui.texteditor.ITextEditor editor, org.eclipse.jface.text.ITextSelection selection)


PVXStackFrame

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.launchers.debug.model

Class PVXStackFrame

java.lang.Object
org.eclipse.core.runtime.PlatformObject
org.eclipse.debug.core.model.DebugElement
com.pvx.ooadide.launchers.debug.model.PVXDebugElement
com.pvx.ooadide.launchers.debug.model.PVXStackFrame
All Implemented Interfaces:
org.eclipse.core.runtime.IAdaptable, org.eclipse.debug.core.model.IDebugElement, org.eclipse.debug.core.model.IStackFrame, org.eclipse.debug.core.model.IStep, org.eclipse.debug.core.model.ISuspendResume, org.eclipse.debug.core.model.ITerminate
public class PVXStackFrame extends PVXDebugElement implements org.eclipse.debug.core.model.IStackFrame
PDA stack frame.

  • Constructor Summary

    Constructors
    Constructor
    Description
    PVXStackFrame(PVXThread thread, String data, int id)
    Constructs a stack frame in the given thread with the given frame data.

  • Method Summary

    Modifier and Type
    Method
    Description
    boolean
    canResume()
    boolean
    canStepInto()
    boolean
    canStepOver()
    boolean
    canStepReturn()
    boolean
    canSuspend()
    boolean
    canTerminate()
    boolean
    equals(Object obj)
    int
    getCharEnd()
    int
    getCharStart()
    int
    getLineNumber()
    String
    getName()
    org.eclipse.debug.core.model.IRegisterGroup[]
    getRegisterGroups()
    String
    getSourceName()
    Returns the name of the source file this stack frame is associated with.
    org.eclipse.debug.core.model.IThread
    getThread()
    org.eclipse.debug.core.model.IVariable[]
    getVariables()
    int
    hashCode()
    boolean
    hasRegisterGroups()
    boolean
    hasVariables()
    boolean
    isStepping()
    boolean
    isSuspended()
    boolean
    isTerminated()
    void
    resume()
    void
    stepInto()
    void
    stepOver()
    void
    stepReturn()
    void
    suspend()
    void
    terminate()

    Methods inherited from class com.pvx.ooadide.launchers.debug.model.PVXDebugElement

    getModelIdentifier, sendRequest

    Methods inherited from class org.eclipse.debug.core.model.DebugElement

    fireChangeEvent, fireCreationEvent, fireEvent, fireResumeEvent, fireSuspendEvent, fireTerminateEvent, getAdapter, getDebugTarget, getLaunch

    Methods inherited from class java.lang.Object

    getClass, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface org.eclipse.core.runtime.IAdaptable

    getAdapter

    Methods inherited from interface org.eclipse.debug.core.model.IDebugElement

    getDebugTarget, getLaunch, getModelIdentifier

  • Constructor Details

    • PVXStackFrame

      public PVXStackFrame(PVXThread thread, String data, int id)
      Constructs a stack frame in the given thread with the given frame data.
      Parameters:
      thread -
      data - frame data
      id - stack frame id (0 is the bottom of the stack)

  • Method Details

    • getThread

      public org.eclipse.debug.core.model.IThread getThread()
      Specified by:
      getThread in interface org.eclipse.debug.core.model.IStackFrame

    • getVariables

      public org.eclipse.debug.core.model.IVariable[] getVariables() throws org.eclipse.debug.core.DebugException
      Specified by:
      getVariables in interface org.eclipse.debug.core.model.IStackFrame
      Throws:
      org.eclipse.debug.core.DebugException

    • hasVariables

      public boolean hasVariables() throws org.eclipse.debug.core.DebugException
      Specified by:
      hasVariables in interface org.eclipse.debug.core.model.IStackFrame
      Throws:
      org.eclipse.debug.core.DebugException

    • getLineNumber

      public int getLineNumber() throws org.eclipse.debug.core.DebugException
      Specified by:
      getLineNumber in interface org.eclipse.debug.core.model.IStackFrame
      Throws:
      org.eclipse.debug.core.DebugException

    • getCharStart

      public int getCharStart() throws org.eclipse.debug.core.DebugException
      Specified by:
      getCharStart in interface org.eclipse.debug.core.model.IStackFrame
      Throws:
      org.eclipse.debug.core.DebugException

    • getCharEnd

      public int getCharEnd() throws org.eclipse.debug.core.DebugException
      Specified by:
      getCharEnd in interface org.eclipse.debug.core.model.IStackFrame
      Throws:
      org.eclipse.debug.core.DebugException

    • getName

      public String getName() throws org.eclipse.debug.core.DebugException
      Specified by:
      getName in interface org.eclipse.debug.core.model.IStackFrame
      Throws:
      org.eclipse.debug.core.DebugException

    • getRegisterGroups

      public org.eclipse.debug.core.model.IRegisterGroup[] getRegisterGroups() throws org.eclipse.debug.core.DebugException
      Specified by:
      getRegisterGroups in interface org.eclipse.debug.core.model.IStackFrame
      Throws:
      org.eclipse.debug.core.DebugException

    • hasRegisterGroups

      public boolean hasRegisterGroups() throws org.eclipse.debug.core.DebugException
      Specified by:
      hasRegisterGroups in interface org.eclipse.debug.core.model.IStackFrame
      Throws:
      org.eclipse.debug.core.DebugException

    • canStepInto

      public boolean canStepInto()
      Specified by:
      canStepInto in interface org.eclipse.debug.core.model.IStep

    • canStepOver

      public boolean canStepOver()
      Specified by:
      canStepOver in interface org.eclipse.debug.core.model.IStep

    • canStepReturn

      public boolean canStepReturn()
      Specified by:
      canStepReturn in interface org.eclipse.debug.core.model.IStep

    • isStepping

      public boolean isStepping()
      Specified by:
      isStepping in interface org.eclipse.debug.core.model.IStep

    • stepInto

      public void stepInto() throws org.eclipse.debug.core.DebugException
      Specified by:
      stepInto in interface org.eclipse.debug.core.model.IStep
      Throws:
      org.eclipse.debug.core.DebugException

    • stepOver

      public void stepOver() throws org.eclipse.debug.core.DebugException
      Specified by:
      stepOver in interface org.eclipse.debug.core.model.IStep
      Throws:
      org.eclipse.debug.core.DebugException

    • stepReturn

      public void stepReturn() throws org.eclipse.debug.core.DebugException
      Specified by:
      stepReturn in interface org.eclipse.debug.core.model.IStep
      Throws:
      org.eclipse.debug.core.DebugException

    • canResume

      public boolean canResume()
      Specified by:
      canResume in interface org.eclipse.debug.core.model.ISuspendResume

    • canSuspend

      public boolean canSuspend()
      Specified by:
      canSuspend in interface org.eclipse.debug.core.model.ISuspendResume

    • isSuspended

      public boolean isSuspended()
      Specified by:
      isSuspended in interface org.eclipse.debug.core.model.ISuspendResume

    • resume

      public void resume() throws org.eclipse.debug.core.DebugException
      Specified by:
      resume in interface org.eclipse.debug.core.model.ISuspendResume
      Throws:
      org.eclipse.debug.core.DebugException

    • suspend

      public void suspend() throws org.eclipse.debug.core.DebugException
      Specified by:
      suspend in interface org.eclipse.debug.core.model.ISuspendResume
      Throws:
      org.eclipse.debug.core.DebugException

    • canTerminate

      public boolean canTerminate()
      Specified by:
      canTerminate in interface org.eclipse.debug.core.model.ITerminate

    • isTerminated

      public boolean isTerminated()
      Specified by:
      isTerminated in interface org.eclipse.debug.core.model.ITerminate

    • terminate

      public void terminate() throws org.eclipse.debug.core.DebugException
      Specified by:
      terminate in interface org.eclipse.debug.core.model.ITerminate
      Throws:
      org.eclipse.debug.core.DebugException

    • getSourceName

      public String getSourceName()
      Returns the name of the source file this stack frame is associated with.
      Returns:
      the name of the source file this stack frame is associated with

    • equals

      public boolean equals(Object obj)
      Overrides:
      equals in class Object

    • hashCode

      public int hashCode()
      Overrides:
      hashCode in class Object


PVXStackValue

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.launchers.debug.model

Class PVXStackValue

java.lang.Object
org.eclipse.core.runtime.PlatformObject
org.eclipse.debug.core.model.DebugElement
com.pvx.ooadide.launchers.debug.model.PVXDebugElement
com.pvx.ooadide.launchers.debug.model.PVXValue
com.pvx.ooadide.launchers.debug.model.PVXStackValue
All Implemented Interfaces:
org.eclipse.core.runtime.IAdaptable, org.eclipse.debug.core.model.IDebugElement, org.eclipse.debug.core.model.IValue
public class PVXStackValue extends PVXValue
A value on the data stack

  • Constructor Summary

    Constructors
    Constructor
    Description
    PVXStackValue(PVXDebugTarget target, String value, int index)
    Constructs a value that appears on the data stack

  • Method Summary

    Modifier and Type
    Method
    Description
    boolean
    equals(Object obj)
    int
    hashCode()

    Methods inherited from class com.pvx.ooadide.launchers.debug.model.PVXValue

    getReferenceTypeName, getValueString, getVariables, hasVariables, isAllocated

    Methods inherited from class com.pvx.ooadide.launchers.debug.model.PVXDebugElement

    getModelIdentifier, sendRequest

    Methods inherited from class org.eclipse.debug.core.model.DebugElement

    fireChangeEvent, fireCreationEvent, fireEvent, fireResumeEvent, fireSuspendEvent, fireTerminateEvent, getAdapter, getDebugTarget, getLaunch

    Methods inherited from class java.lang.Object

    getClass, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface org.eclipse.core.runtime.IAdaptable

    getAdapter

    Methods inherited from interface org.eclipse.debug.core.model.IDebugElement

    getDebugTarget, getLaunch, getModelIdentifier

  • Constructor Details

    • PVXStackValue

      public PVXStackValue(PVXDebugTarget target, String value, int index)
      Constructs a value that appears on the data stack
      Parameters:
      target - debug target
      value - value on the stack
      index - index on the stack

  • Method Details

    • equals

      public boolean equals(Object obj)
      Overrides:
      equals in class Object

    • hashCode

      public int hashCode()
      Overrides:
      hashCode in class Object


PVXThread

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.launchers.debug.model

Class PVXThread

java.lang.Object
org.eclipse.core.runtime.PlatformObject
org.eclipse.debug.core.model.DebugElement
com.pvx.ooadide.launchers.debug.model.PVXDebugElement
com.pvx.ooadide.launchers.debug.model.PVXThread
All Implemented Interfaces:
IPVXEventListener, org.eclipse.core.runtime.IAdaptable, org.eclipse.debug.core.model.IDebugElement, org.eclipse.debug.core.model.IStep, org.eclipse.debug.core.model.ISuspendResume, org.eclipse.debug.core.model.ITerminate, org.eclipse.debug.core.model.IThread
public class PVXThread extends PVXDebugElement implements org.eclipse.debug.core.model.IThread, IPVXEventListener
// * A y VM thread. A PVX VM is single threaded.

  • Constructor Summary

    Constructors
    Constructor
    Description
    PVXThread(PVXDebugTarget target)
    Constructs a new thread for the given target

  • Method Summary

    Modifier and Type
    Method
    Description
    boolean
    canPop()
    Returns whether this thread can pop the top stack frame.
    boolean
    canResume()
    boolean
    canStepInto()
    boolean
    canStepOver()
    boolean
    canStepReturn()
    boolean
    canSuspend()
    boolean
    canTerminate()
    org.eclipse.debug.core.model.IBreakpoint[]
    getBreakpoints()
    Object
    getError()
    Returns the most revent error event encountered since the last suspend, or null if none.
    String
    getName()
    int
    getPriority()
    org.eclipse.debug.core.model.IStackFrame[]
    getStackFrames()
    org.eclipse.debug.core.model.IStackFrame
    getTopStackFrame()
    void
    handleEvent(String event)
    Notification the given event occurred in the target program being interpretted.
    boolean
    hasStackFrames()
    boolean
    isStepping()
    boolean
    isSuspended()
    boolean
    isTerminated()
    void
    pop()
    Pops the top frame off the callstack.
    void
    resume()
    void
    stepInto()
    void
    stepOver()
    void
    stepReturn()
    void
    suspend()
    void
    suspendedBy(org.eclipse.debug.core.model.IBreakpoint breakpoint)
    Notifies this thread it has been suspended by the given breakpoint.
    void
    terminate()

    Methods inherited from class com.pvx.ooadide.launchers.debug.model.PVXDebugElement

    getModelIdentifier, sendRequest

    Methods inherited from class org.eclipse.debug.core.model.DebugElement

    fireChangeEvent, fireCreationEvent, fireEvent, fireResumeEvent, fireSuspendEvent, fireTerminateEvent, getAdapter, getDebugTarget, getLaunch

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface org.eclipse.core.runtime.IAdaptable

    getAdapter

    Methods inherited from interface org.eclipse.debug.core.model.IDebugElement

    getDebugTarget, getLaunch, getModelIdentifier

  • Constructor Details

    • PVXThread

      public PVXThread(PVXDebugTarget target)
      Constructs a new thread for the given target
      Parameters:
      target - VM

  • Method Details

    • getStackFrames

      public org.eclipse.debug.core.model.IStackFrame[] getStackFrames() throws org.eclipse.debug.core.DebugException
      Specified by:
      getStackFrames in interface org.eclipse.debug.core.model.IThread
      Throws:
      org.eclipse.debug.core.DebugException

    • hasStackFrames

      public boolean hasStackFrames() throws org.eclipse.debug.core.DebugException
      Specified by:
      hasStackFrames in interface org.eclipse.debug.core.model.IThread
      Throws:
      org.eclipse.debug.core.DebugException

    • getPriority

      public int getPriority() throws org.eclipse.debug.core.DebugException
      Specified by:
      getPriority in interface org.eclipse.debug.core.model.IThread
      Throws:
      org.eclipse.debug.core.DebugException

    • getTopStackFrame

      public org.eclipse.debug.core.model.IStackFrame getTopStackFrame() throws org.eclipse.debug.core.DebugException
      Specified by:
      getTopStackFrame in interface org.eclipse.debug.core.model.IThread
      Throws:
      org.eclipse.debug.core.DebugException

    • getName

      public String getName()
      Specified by:
      getName in interface org.eclipse.debug.core.model.IThread

    • getBreakpoints

      public org.eclipse.debug.core.model.IBreakpoint[] getBreakpoints()
      Specified by:
      getBreakpoints in interface org.eclipse.debug.core.model.IThread

    • suspendedBy

      public void suspendedBy(org.eclipse.debug.core.model.IBreakpoint breakpoint)
      Notifies this thread it has been suspended by the given breakpoint.
      Parameters:
      breakpoint - breakpoint

    • canResume

      public boolean canResume()
      Specified by:
      canResume in interface org.eclipse.debug.core.model.ISuspendResume

    • canSuspend

      public boolean canSuspend()
      Specified by:
      canSuspend in interface org.eclipse.debug.core.model.ISuspendResume

    • isSuspended

      public boolean isSuspended()
      Specified by:
      isSuspended in interface org.eclipse.debug.core.model.ISuspendResume

    • resume

      public void resume() throws org.eclipse.debug.core.DebugException
      Specified by:
      resume in interface org.eclipse.debug.core.model.ISuspendResume
      Throws:
      org.eclipse.debug.core.DebugException

    • suspend

      public void suspend() throws org.eclipse.debug.core.DebugException
      Specified by:
      suspend in interface org.eclipse.debug.core.model.ISuspendResume
      Throws:
      org.eclipse.debug.core.DebugException

    • canStepInto

      public boolean canStepInto()
      Specified by:
      canStepInto in interface org.eclipse.debug.core.model.IStep

    • canStepOver

      public boolean canStepOver()
      Specified by:
      canStepOver in interface org.eclipse.debug.core.model.IStep

    • canStepReturn

      public boolean canStepReturn()
      Specified by:
      canStepReturn in interface org.eclipse.debug.core.model.IStep

    • isStepping

      public boolean isStepping()
      Specified by:
      isStepping in interface org.eclipse.debug.core.model.IStep

    • stepInto

      public void stepInto() throws org.eclipse.debug.core.DebugException
      Specified by:
      stepInto in interface org.eclipse.debug.core.model.IStep
      Throws:
      org.eclipse.debug.core.DebugException

    • stepOver

      public void stepOver() throws org.eclipse.debug.core.DebugException
      Specified by:
      stepOver in interface org.eclipse.debug.core.model.IStep
      Throws:
      org.eclipse.debug.core.DebugException

    • stepReturn

      public void stepReturn() throws org.eclipse.debug.core.DebugException
      Specified by:
      stepReturn in interface org.eclipse.debug.core.model.IStep
      Throws:
      org.eclipse.debug.core.DebugException

    • canTerminate

      public boolean canTerminate()
      Specified by:
      canTerminate in interface org.eclipse.debug.core.model.ITerminate

    • isTerminated

      public boolean isTerminated()
      Specified by:
      isTerminated in interface org.eclipse.debug.core.model.ITerminate

    • terminate

      public void terminate() throws org.eclipse.debug.core.DebugException
      Specified by:
      terminate in interface org.eclipse.debug.core.model.ITerminate
      Throws:
      org.eclipse.debug.core.DebugException

    • getError

      public Object getError()
      Returns the most revent error event encountered since the last suspend, or null if none.
      Returns:
      the most revent error event encountered since the last suspend, or null if none

    • handleEvent

      public void handleEvent(String event)
      Description copied from interface: IPVXEventListener
      Notification the given event occurred in the target program being interpretted.
      Specified by:
      handleEvent in interface IPVXEventListener
      Parameters:
      event - the event

    • pop

      public void pop() throws org.eclipse.debug.core.DebugException
      Pops the top frame off the callstack.
      Throws:
      org.eclipse.debug.core.DebugException

    • canPop

      public boolean canPop()
      Returns whether this thread can pop the top stack frame.
      Returns:
      whether this thread can pop the top stack frame


PVXValue

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.launchers.debug.model

Class PVXValue

java.lang.Object
org.eclipse.core.runtime.PlatformObject
org.eclipse.debug.core.model.DebugElement
com.pvx.ooadide.launchers.debug.model.PVXDebugElement
com.pvx.ooadide.launchers.debug.model.PVXValue
All Implemented Interfaces:
org.eclipse.core.runtime.IAdaptable, org.eclipse.debug.core.model.IDebugElement, org.eclipse.debug.core.model.IValue
Direct Known Subclasses:
PVXStackValue
public class PVXValue extends PVXDebugElement implements org.eclipse.debug.core.model.IValue
Value of a PDA variable.

  • Constructor Summary

    Constructors
    Constructor
    Description
    PVXValue(PVXDebugTarget target, String value)
    PVXValue(PVXDebugTarget target, String value, String name)

  • Method Summary

    Modifier and Type
    Method
    Description
    String
    getReferenceTypeName()
    String
    getValueString()
    org.eclipse.debug.core.model.IVariable[]
    getVariables()
    boolean
    hasVariables()
    boolean
    isAllocated()

    Methods inherited from class com.pvx.ooadide.launchers.debug.model.PVXDebugElement

    getModelIdentifier, sendRequest

    Methods inherited from class org.eclipse.debug.core.model.DebugElement

    fireChangeEvent, fireCreationEvent, fireEvent, fireResumeEvent, fireSuspendEvent, fireTerminateEvent, getAdapter, getDebugTarget, getLaunch

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface org.eclipse.core.runtime.IAdaptable

    getAdapter

    Methods inherited from interface org.eclipse.debug.core.model.IDebugElement

    getDebugTarget, getLaunch, getModelIdentifier

  • Constructor Details

    • PVXValue

      public PVXValue(PVXDebugTarget target, String value)

    • PVXValue

      public PVXValue(PVXDebugTarget target, String value, String name)

  • Method Details

    • getReferenceTypeName

      public String getReferenceTypeName() throws org.eclipse.debug.core.DebugException
      Specified by:
      getReferenceTypeName in interface org.eclipse.debug.core.model.IValue
      Throws:
      org.eclipse.debug.core.DebugException

    • getValueString

      public String getValueString() throws org.eclipse.debug.core.DebugException
      Specified by:
      getValueString in interface org.eclipse.debug.core.model.IValue
      Throws:
      org.eclipse.debug.core.DebugException

    • isAllocated

      public boolean isAllocated() throws org.eclipse.debug.core.DebugException
      Specified by:
      isAllocated in interface org.eclipse.debug.core.model.IValue
      Throws:
      org.eclipse.debug.core.DebugException

    • getVariables

      public org.eclipse.debug.core.model.IVariable[] getVariables() throws org.eclipse.debug.core.DebugException
      Specified by:
      getVariables in interface org.eclipse.debug.core.model.IValue
      Throws:
      org.eclipse.debug.core.DebugException

    • hasVariables

      public boolean hasVariables() throws org.eclipse.debug.core.DebugException
      Specified by:
      hasVariables in interface org.eclipse.debug.core.model.IValue
      Throws:
      org.eclipse.debug.core.DebugException


PVXVariable

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.launchers.debug.model

Class PVXVariable

java.lang.Object
org.eclipse.core.runtime.PlatformObject
org.eclipse.debug.core.model.DebugElement
com.pvx.ooadide.launchers.debug.model.PVXDebugElement
com.pvx.ooadide.launchers.debug.model.PVXVariable
All Implemented Interfaces:
org.eclipse.core.runtime.IAdaptable, org.eclipse.debug.core.model.IDebugElement, org.eclipse.debug.core.model.IValueModification, org.eclipse.debug.core.model.IVariable
Direct Known Subclasses:
PvxArrayElementVariable, PVXArrayValue
public class PVXVariable extends PVXDebugElement implements org.eclipse.debug.core.model.IVariable
A variable in a PVX stack frame

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final String
    TYPE_NUMERIC
    static final String
    TYPE_STRING

  • Constructor Summary

    Constructors
    Constructor
    Description
    PVXVariable(PVXStackFrame frame, String var)
    Constructs a variable contained in the given stack frame with the given name.

  • Method Summary

    Modifier and Type
    Method
    Description
    String
    getName()
    String
    getReferenceTypeName()
    org.eclipse.debug.core.model.IValue
    getValue()
    boolean
    hasValueChanged()
    boolean
    hasVariables()
    void
    setValue(String expression)
    void
    setValue(org.eclipse.debug.core.model.IValue value)
    boolean
    supportsValueModification()
    boolean
    verifyValue(String expression)
    boolean
    verifyValue(org.eclipse.debug.core.model.IValue value)

    Methods inherited from class com.pvx.ooadide.launchers.debug.model.PVXDebugElement

    getModelIdentifier, sendRequest

    Methods inherited from class org.eclipse.debug.core.model.DebugElement

    fireChangeEvent, fireCreationEvent, fireEvent, fireResumeEvent, fireSuspendEvent, fireTerminateEvent, getAdapter, getDebugTarget, getLaunch

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface org.eclipse.core.runtime.IAdaptable

    getAdapter

    Methods inherited from interface org.eclipse.debug.core.model.IDebugElement

    getDebugTarget, getLaunch, getModelIdentifier

  • Field Details

    • TYPE_STRING

      public static final String TYPE_STRING
      See Also:
      • Constant Field Values

    • TYPE_NUMERIC

      public static final String TYPE_NUMERIC
      See Also:
      • Constant Field Values

  • Constructor Details

    • PVXVariable

      public PVXVariable(PVXStackFrame frame, String var)
      Constructs a variable contained in the given stack frame with the given name.
      Parameters:
      frame - owning stack frame
      name - variable name

  • Method Details

    • getValue

      public org.eclipse.debug.core.model.IValue getValue() throws org.eclipse.debug.core.DebugException
      Specified by:
      getValue in interface org.eclipse.debug.core.model.IVariable
      Throws:
      org.eclipse.debug.core.DebugException

    • getName

      public String getName() throws org.eclipse.debug.core.DebugException
      Specified by:
      getName in interface org.eclipse.debug.core.model.IVariable
      Throws:
      org.eclipse.debug.core.DebugException

    • getReferenceTypeName

      public String getReferenceTypeName() throws org.eclipse.debug.core.DebugException
      Specified by:
      getReferenceTypeName in interface org.eclipse.debug.core.model.IVariable
      Throws:
      org.eclipse.debug.core.DebugException

    • hasValueChanged

      public boolean hasValueChanged() throws org.eclipse.debug.core.DebugException
      Specified by:
      hasValueChanged in interface org.eclipse.debug.core.model.IVariable
      Throws:
      org.eclipse.debug.core.DebugException

    • setValue

      public void setValue(String expression) throws org.eclipse.debug.core.DebugException
      Specified by:
      setValue in interface org.eclipse.debug.core.model.IValueModification
      Throws:
      org.eclipse.debug.core.DebugException

    • setValue

      public void setValue(org.eclipse.debug.core.model.IValue value) throws org.eclipse.debug.core.DebugException
      Specified by:
      setValue in interface org.eclipse.debug.core.model.IValueModification
      Throws:
      org.eclipse.debug.core.DebugException

    • supportsValueModification

      public boolean supportsValueModification()
      Specified by:
      supportsValueModification in interface org.eclipse.debug.core.model.IValueModification

    • verifyValue

      public boolean verifyValue(String expression) throws org.eclipse.debug.core.DebugException
      Specified by:
      verifyValue in interface org.eclipse.debug.core.model.IValueModification
      Throws:
      org.eclipse.debug.core.DebugException

    • verifyValue

      public boolean verifyValue(org.eclipse.debug.core.model.IValue value) throws org.eclipse.debug.core.DebugException
      Specified by:
      verifyValue in interface org.eclipse.debug.core.model.IValueModification
      Throws:
      org.eclipse.debug.core.DebugException

    • hasVariables

      public boolean hasVariables() throws org.eclipse.debug.core.DebugException
      Throws:
      org.eclipse.debug.core.DebugException


Uses of Interface com.pvx.ooadide.launchers.debug.model.IPVXEventListener

Uses of Interface
com.pvx.ooadide.launchers.debug.model.IPVXEventListener

Packages that use IPVXEventListener
Package
Description
com.pvx.ooadide.launchers.debug.breakpoints
com.pvx.ooadide.launchers.debug.model

  • Uses of IPVXEventListener in com.pvx.ooadide.launchers.debug.breakpoints

    Classes in com.pvx.ooadide.launchers.debug.breakpoints that implement IPVXEventListener
    Modifier and Type
    Class
    Description
    class
    PVXLineBreakpoint
    PDA line breakpoint
    class
    PVXRunToLineBreakpoint
    A run to line breakpoint.

  • Uses of IPVXEventListener in com.pvx.ooadide.launchers.debug.model

    Classes in com.pvx.ooadide.launchers.debug.model that implement IPVXEventListener
    Modifier and Type
    Class
    Description
    class
    PVXDebugTarget
    PVX Debug Target
    class
    PvxLineBreakpointAdapter
    Adapter to create breakpoints in PVX files.
    class
    PVXThread
    // * A y VM thread.
    Methods in com.pvx.ooadide.launchers.debug.model with parameters of type IPVXEventListener
    Modifier and Type
    Method
    Description
    void
    PVXDebugTarget.addEventListener(IPVXEventListener listener)
    Registers the given event listener.
    void
    PVXDebugTarget.removeEventListener(IPVXEventListener listener)
    Deregisters the given event listener.


Uses of Class com.pvx.ooadide.launchers.debug.model.PvxArrayElementVariable

Uses of Class
com.pvx.ooadide.launchers.debug.model.PvxArrayElementVariable

No usage of com.pvx.ooadide.launchers.debug.model.PvxArrayElementVariable


Uses of Class com.pvx.ooadide.launchers.debug.model.PVXArrayValue

Uses of Class
com.pvx.ooadide.launchers.debug.model.PVXArrayValue

No usage of com.pvx.ooadide.launchers.debug.model.PVXArrayValue


Uses of Class com.pvx.ooadide.launchers.debug.model.PVXDebugElement

Uses of Class
com.pvx.ooadide.launchers.debug.model.PVXDebugElement

Packages that use PVXDebugElement
Package
Description
com.pvx.ooadide.launchers.debug.model

  • Uses of PVXDebugElement in com.pvx.ooadide.launchers.debug.model

    Subclasses of PVXDebugElement in com.pvx.ooadide.launchers.debug.model
    Modifier and Type
    Class
    Description
    class
    PvxArrayElementVariable
    class
    PVXArrayValue
    class
    PVXDebugTarget
    PVX Debug Target
    class
    PVXStackFrame
    PDA stack frame.
    class
    PVXStackValue
    A value on the data stack
    class
    PVXThread
    // * A y VM thread.
    class
    PVXValue
    Value of a PDA variable.
    class
    PVXVariable
    A variable in a PVX stack frame


Uses of Class com.pvx.ooadide.launchers.debug.model.PVXDebugTarget

Uses of Class
com.pvx.ooadide.launchers.debug.model.PVXDebugTarget

Packages that use PVXDebugTarget
Package
Description
com.pvx.ooadide.launchers.debug.breakpoints
com.pvx.ooadide.launchers.debug.model

  • Uses of PVXDebugTarget in com.pvx.ooadide.launchers.debug.breakpoints

    Methods in com.pvx.ooadide.launchers.debug.breakpoints with parameters of type PVXDebugTarget
    Modifier and Type
    Method
    Description
    void
    PVXLineBreakpoint.install(PVXDebugTarget target)
    Installs this breakpoint in the given interprettor.
    void
    PVXLineBreakpoint.remove(PVXDebugTarget target)
    Removes this breakpoint from the given interprettor.

  • Uses of PVXDebugTarget in com.pvx.ooadide.launchers.debug.model

    Methods in com.pvx.ooadide.launchers.debug.model with parameters of type PVXDebugTarget
    Modifier and Type
    Method
    Description
    void
    PvxLineBreakpointAdapter.install(PVXDebugTarget target)
    Installs this breakpoint in the given interprettor.
    void
    PvxLineBreakpointAdapter.remove(PVXDebugTarget target)
    Removes this breakpoint from the given interprettor.
    Constructors in com.pvx.ooadide.launchers.debug.model with parameters of type PVXDebugTarget
    Modifier
    Constructor
    Description

    PVXStackValue(PVXDebugTarget target, String value, int index)
    Constructs a value that appears on the data stack

    PVXThread(PVXDebugTarget target)
    Constructs a new thread for the given target

    PVXValue(PVXDebugTarget target, String value)

    PVXValue(PVXDebugTarget target, String value, String name)


Uses of Class com.pvx.ooadide.launchers.debug.model.PvxLineBreakpointAdapter

Uses of Class
com.pvx.ooadide.launchers.debug.model.PvxLineBreakpointAdapter

No usage of com.pvx.ooadide.launchers.debug.model.PvxLineBreakpointAdapter


Uses of Class com.pvx.ooadide.launchers.debug.model.PVXStackFrame

Uses of Class
com.pvx.ooadide.launchers.debug.model.PVXStackFrame

Packages that use PVXStackFrame
Package
Description
com.pvx.ooadide.launchers.debug.model

  • Uses of PVXStackFrame in com.pvx.ooadide.launchers.debug.model

    Constructors in com.pvx.ooadide.launchers.debug.model with parameters of type PVXStackFrame
    Modifier
    Constructor
    Description

    PvxArrayElementVariable(PVXStackFrame frame, String var, int init_indx, int dimBase)

    PVXArrayValue(PVXStackFrame frame, String name, int size, int dimBase)

    PVXVariable(PVXStackFrame frame, String var)
    Constructs a variable contained in the given stack frame with the given name.


Uses of Class com.pvx.ooadide.launchers.debug.model.PVXStackValue

Uses of Class
com.pvx.ooadide.launchers.debug.model.PVXStackValue

No usage of com.pvx.ooadide.launchers.debug.model.PVXStackValue


Uses of Class com.pvx.ooadide.launchers.debug.model.PVXThread

Uses of Class
com.pvx.ooadide.launchers.debug.model.PVXThread

Packages that use PVXThread
Package
Description
com.pvx.ooadide.launchers.debug.model

  • Uses of PVXThread in com.pvx.ooadide.launchers.debug.model

    Constructors in com.pvx.ooadide.launchers.debug.model with parameters of type PVXThread
    Modifier
    Constructor
    Description

    PVXStackFrame(PVXThread thread, String data, int id)
    Constructs a stack frame in the given thread with the given frame data.


Uses of Class com.pvx.ooadide.launchers.debug.model.PVXValue

Uses of Class
com.pvx.ooadide.launchers.debug.model.PVXValue

Packages that use PVXValue
Package
Description
com.pvx.ooadide.launchers.debug.model

  • Uses of PVXValue in com.pvx.ooadide.launchers.debug.model

    Subclasses of PVXValue in com.pvx.ooadide.launchers.debug.model
    Modifier and Type
    Class
    Description
    class
    PVXStackValue
    A value on the data stack


Uses of Class com.pvx.ooadide.launchers.debug.model.PVXVariable

Uses of Class
com.pvx.ooadide.launchers.debug.model.PVXVariable

Packages that use PVXVariable
Package
Description
com.pvx.ooadide.launchers.debug.model

  • Uses of PVXVariable in com.pvx.ooadide.launchers.debug.model

    Subclasses of PVXVariable in com.pvx.ooadide.launchers.debug.model
    Modifier and Type
    Class
    Description
    class
    PvxArrayElementVariable
    class
    PVXArrayValue


ClientTab

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.launchers.thinclients

Class ClientTab

java.lang.Object
org.eclipse.debug.ui.AbstractLaunchConfigurationTab
com.pvx.ooadide.launchers.thinclients.PvxBaseClientConfigTab
com.pvx.ooadide.launchers.thinclients.ClientTab
All Implemented Interfaces:
org.eclipse.debug.core.IPrototypeAttributesLabelProvider, org.eclipse.debug.ui.ILaunchConfigurationTab, org.eclipse.debug.ui.ILaunchConfigurationTab2, org.eclipse.jdt.internal.debug.ui.launcher.IEntriesChangedListener
public class ClientTab extends PvxBaseClientConfigTab
This tab appears for java applet launch configurations and allows the user to edit attributes such as the applet class to launch and its owning project, if any.

This class may be instantiated. This class is not intended to be subclassed.

Since:
2.1

  • Constructor Summary

    Constructors
    Constructor
    Description
    ClientTab()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    activated(org.eclipse.debug.core.ILaunchConfigurationWorkingCopy workingCopy)
    void
    createControl(org.eclipse.swt.widgets.Composite parent)
    void
    deactivated(org.eclipse.debug.core.ILaunchConfigurationWorkingCopy workingCopy)
    void
    dispose()
    org.eclipse.swt.graphics.Image
    getImage()
    String
    getName()
    void
    initializeFrom(org.eclipse.debug.core.ILaunchConfiguration config)
    boolean
    isValid(org.eclipse.debug.core.ILaunchConfiguration launchConfig)
    void
    performApply(org.eclipse.debug.core.ILaunchConfigurationWorkingCopy config)
    void
    setDefaults(org.eclipse.debug.core.ILaunchConfigurationWorkingCopy config)
    void
    setLaunchConfigurationDialog(org.eclipse.debug.ui.ILaunchConfigurationDialog dialog)
    Sets the java project currently specified by the given launch config, if any.

    Methods inherited from class com.pvx.ooadide.launchers.thinclients.PvxBaseClientConfigTab

    entriesChanged

    Methods inherited from class org.eclipse.debug.ui.AbstractLaunchConfigurationTab

    canSave, getAttributeLabel, getControl, getErrorMessage, getHelpContextId, getId, getMessage, getWarningMessage, setHelpContextId

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface org.eclipse.debug.ui.ILaunchConfigurationTab

    OkToLeaveTab, postApply

  • Constructor Details

    • ClientTab

      public ClientTab()

  • Method Details

    • createControl

      public void createControl(org.eclipse.swt.widgets.Composite parent)
      See Also:
      • ILaunchConfigurationTab.createControl(Composite)

    • initializeFrom

      public void initializeFrom(org.eclipse.debug.core.ILaunchConfiguration config)
      See Also:
      • ILaunchConfigurationTab.initializeFrom(ILaunchConfiguration)

    • performApply

      public void performApply(org.eclipse.debug.core.ILaunchConfigurationWorkingCopy config)
      See Also:
      • ILaunchConfigurationTab.performApply(ILaunchConfigurationWorkingCopy)

    • dispose

      public void dispose()
      Specified by:
      dispose in interface org.eclipse.debug.ui.ILaunchConfigurationTab
      Overrides:
      dispose in class org.eclipse.debug.ui.AbstractLaunchConfigurationTab
      See Also:
      • ILaunchConfigurationTab.dispose()

    • isValid

      public boolean isValid(org.eclipse.debug.core.ILaunchConfiguration launchConfig)
      Specified by:
      isValid in interface org.eclipse.debug.ui.ILaunchConfigurationTab
      Overrides:
      isValid in class org.eclipse.debug.ui.AbstractLaunchConfigurationTab
      See Also:
      • ILaunchConfigurationTab.isValid(ILaunchConfiguration)

    • setDefaults

      public void setDefaults(org.eclipse.debug.core.ILaunchConfigurationWorkingCopy config)
      See Also:
      • ILaunchConfigurationTab.setDefaults(ILaunchConfigurationWorkingCopy)

    • getName

      public String getName()
      See Also:
      • ILaunchConfigurationTab.getName()

    • getImage

      public org.eclipse.swt.graphics.Image getImage()
      Specified by:
      getImage in interface org.eclipse.debug.ui.ILaunchConfigurationTab
      Overrides:
      getImage in class org.eclipse.debug.ui.AbstractLaunchConfigurationTab
      See Also:
      • ILaunchConfigurationTab.getImage()

    • activated

      public void activated(org.eclipse.debug.core.ILaunchConfigurationWorkingCopy workingCopy)
      Specified by:
      activated in interface org.eclipse.debug.ui.ILaunchConfigurationTab
      Overrides:
      activated in class org.eclipse.debug.ui.AbstractLaunchConfigurationTab

    • deactivated

      public void deactivated(org.eclipse.debug.core.ILaunchConfigurationWorkingCopy workingCopy)
      Specified by:
      deactivated in interface org.eclipse.debug.ui.ILaunchConfigurationTab
      Overrides:
      deactivated in class org.eclipse.debug.ui.AbstractLaunchConfigurationTab

    • setLaunchConfigurationDialog

      public void setLaunchConfigurationDialog(org.eclipse.debug.ui.ILaunchConfigurationDialog dialog)
      Sets the java project currently specified by the given launch config, if any.
      Specified by:
      setLaunchConfigurationDialog in interface org.eclipse.debug.ui.ILaunchConfigurationTab
      Overrides:
      setLaunchConfigurationDialog in class org.eclipse.debug.ui.AbstractLaunchConfigurationTab


DebugWindXLauncherThread

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.launchers.thinclients

Class DebugWindXLauncherThread

java.lang.Object
java.lang.Thread
com.pvx.ooadide.launchers.debug.communication.DebugLauncherThread
com.pvx.ooadide.launchers.thinclients.DebugWindXLauncherThread
All Implemented Interfaces:
Runnable
public class DebugWindXLauncherThread extends DebugLauncherThread

  • Nested Class Summary

    Nested classes/interfaces inherited from class java.lang.Thread

    Thread.State, Thread.UncaughtExceptionHandler

  • Field Summary

    Fields inherited from class java.lang.Thread

    MAX_PRIORITY, MIN_PRIORITY, NORM_PRIORITY

  • Constructor Summary

    Constructors
    Constructor
    Description
    DebugWindXLauncherThread(String dir, int port, ConsoleDisplayManager console, String name, int port2, String line, org.eclipse.debug.core.ILaunch launch, String args)

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    notifyProvideXConnect(Socket fRequestSocket, Socket fEventSocket)
    void
    run()

    Methods inherited from class java.lang.Thread

    activeCount, currentThread, dumpStack, enumerate, getAllStackTraces, getContextClassLoader, getDefaultUncaughtExceptionHandler, getId, getName, getPriority, getStackTrace, getState, getThreadGroup, getUncaughtExceptionHandler, holdsLock, interrupt, interrupted, isAlive, isDaemon, isInterrupted, join, join, join, onSpinWait, setContextClassLoader, setDaemon, setDefaultUncaughtExceptionHandler, setName, setPriority, setUncaughtExceptionHandler, sleep, sleep, start, toString, yield

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

  • Constructor Details

    • DebugWindXLauncherThread

      public DebugWindXLauncherThread(String dir, int port, ConsoleDisplayManager console, String name, int port2, String line, org.eclipse.debug.core.ILaunch launch, String args)

  • Method Details

    • run

      public void run()
      Specified by:
      run in interface Runnable
      Overrides:
      run in class DebugLauncherThread

    • notifyProvideXConnect

      public void notifyProvideXConnect(Socket fRequestSocket, Socket fEventSocket)
      Overrides:
      notifyProvideXConnect in class DebugLauncherThread


com.pvx.ooadide.launchers.thinclients

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.pvx.ooadide.launchers.thinclients

package com.pvx.ooadide.launchers.thinclients
  • Related Packages
    Package
    Description
    com.pvx.ooadide.launchers
    com.pvx.ooadide.launchers.thinclients.javx
    com.pvx.ooadide.launchers.debug
  • Classes
    Class
    Description
    ClientTab
    This tab appears for java applet launch configurations and allows the user to edit attributes such as the applet class to launch and its owning project, if any.
    DebugWindXLauncherThread
    PvxBaseClientConfigTab
    Common function for Java launch configuration tabs.
    WindXLaunchConfigurationDelegate1
    WindXLaunchConfigurationTabGroup


com.pvx.ooadide.launchers.thinclients Class Hierarchy

Hierarchy For Package com.pvx.ooadide.launchers.thinclients

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.eclipse.debug.ui.AbstractLaunchConfigurationTab (implements org.eclipse.debug.ui.ILaunchConfigurationTab2, org.eclipse.debug.core.IPrototypeAttributesLabelProvider)
      • com.pvx.ooadide.launchers.thinclients.PvxBaseClientConfigTab (implements org.eclipse.jdt.internal.debug.ui.launcher.IEntriesChangedListener)
        • com.pvx.ooadide.launchers.thinclients.ClientTab
    • org.eclipse.debug.ui.AbstractLaunchConfigurationTabGroup (implements org.eclipse.debug.ui.ILaunchConfigurationTabGroup)
      • com.pvx.ooadide.launchers.thinclients.WindXLaunchConfigurationTabGroup
    • com.pvx.ooadide.launchers.ProvideXLaunchConfigurationDelegate1 (implements org.eclipse.debug.core.model.ILaunchConfigurationDelegate)
      • com.pvx.ooadide.launchers.thinclients.WindXLaunchConfigurationDelegate1
    • java.lang.Thread (implements java.lang.Runnable)
      • com.pvx.ooadide.launchers.debug.communication.DebugLauncherThread
        • com.pvx.ooadide.launchers.thinclients.DebugWindXLauncherThread


Uses of Package com.pvx.ooadide.launchers.thinclients

Uses of Package
com.pvx.ooadide.launchers.thinclients

Packages that use com.pvx.ooadide.launchers.thinclients
Package
Description
com.pvx.ooadide.launchers.thinclients
  • Classes in com.pvx.ooadide.launchers.thinclients used by com.pvx.ooadide.launchers.thinclients
    Class
    Description
    PvxBaseClientConfigTab
    Common function for Java launch configuration tabs.


PvxBaseClientConfigTab

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.launchers.thinclients

Class PvxBaseClientConfigTab

java.lang.Object
org.eclipse.debug.ui.AbstractLaunchConfigurationTab
com.pvx.ooadide.launchers.thinclients.PvxBaseClientConfigTab
All Implemented Interfaces:
org.eclipse.debug.core.IPrototypeAttributesLabelProvider, org.eclipse.debug.ui.ILaunchConfigurationTab, org.eclipse.debug.ui.ILaunchConfigurationTab2, org.eclipse.jdt.internal.debug.ui.launcher.IEntriesChangedListener
Direct Known Subclasses:
ClientTab
public abstract class PvxBaseClientConfigTab extends org.eclipse.debug.ui.AbstractLaunchConfigurationTab implements org.eclipse.jdt.internal.debug.ui.launcher.IEntriesChangedListener
Common function for Java launch configuration tabs.

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxBaseClientConfigTab()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    entriesChanged(org.eclipse.jdt.internal.debug.ui.launcher.IClasspathViewer viewer)

    Methods inherited from class org.eclipse.debug.ui.AbstractLaunchConfigurationTab

    activated, canSave, deactivated, dispose, getAttributeLabel, getControl, getErrorMessage, getHelpContextId, getId, getImage, getMessage, getWarningMessage, isValid, setHelpContextId, setLaunchConfigurationDialog

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface org.eclipse.debug.ui.ILaunchConfigurationTab

    createControl, getName, initializeFrom, OkToLeaveTab, performApply, postApply, setDefaults

  • Constructor Details

    • PvxBaseClientConfigTab

      public PvxBaseClientConfigTab()

  • Method Details

    • entriesChanged

      public void entriesChanged(org.eclipse.jdt.internal.debug.ui.launcher.IClasspathViewer viewer)
      Specified by:
      entriesChanged in interface org.eclipse.jdt.internal.debug.ui.launcher.IEntriesChangedListener
      See Also:
      • IEntriesChangedListener.entriesChanged(RuntimeClasspathViewer)


WindXLaunchConfigurationDelegate1

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.launchers.thinclients

Class WindXLaunchConfigurationDelegate1

java.lang.Object
com.pvx.ooadide.launchers.ProvideXLaunchConfigurationDelegate1
com.pvx.ooadide.launchers.thinclients.WindXLaunchConfigurationDelegate1
All Implemented Interfaces:
org.eclipse.debug.core.model.ILaunchConfigurationDelegate
public class WindXLaunchConfigurationDelegate1 extends ProvideXLaunchConfigurationDelegate1

  • Constructor Summary

    Constructors
    Constructor
    Description
    WindXLaunchConfigurationDelegate1()

  • Method Summary

    Modifier and Type
    Method
    Description
    String
    generateCommandLine(org.eclipse.debug.core.ILaunchConfiguration configuration, org.eclipse.debug.core.ILaunch launch, ConsoleDisplayManager console, org.eclipse.core.resources.IProject project, String prgName, String prg, int requestPort, int eventPort)
    static boolean
    launchDebugPvxHost(int requestPort, int eventPort, String outDir, int socket, org.eclipse.debug.core.ILaunch launch)

    Methods inherited from class com.pvx.ooadide.launchers.ProvideXLaunchConfigurationDelegate1

    generateCommandLineArray, getIniFileName, launch

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface org.eclipse.debug.core.model.ILaunchConfigurationDelegate

    showCommandLine

  • Constructor Details

    • WindXLaunchConfigurationDelegate1

      public WindXLaunchConfigurationDelegate1()

  • Method Details

    • generateCommandLine

      public String generateCommandLine(org.eclipse.debug.core.ILaunchConfiguration configuration, org.eclipse.debug.core.ILaunch launch, ConsoleDisplayManager console, org.eclipse.core.resources.IProject project, String prgName, String prg, int requestPort, int eventPort) throws org.eclipse.core.runtime.CoreException
      Overrides:
      generateCommandLine in class ProvideXLaunchConfigurationDelegate1
      Throws:
      org.eclipse.core.runtime.CoreException

    • launchDebugPvxHost

      public static boolean launchDebugPvxHost(int requestPort, int eventPort, String outDir, int socket, org.eclipse.debug.core.ILaunch launch)


WindXLaunchConfigurationTabGroup

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.launchers.thinclients

Class WindXLaunchConfigurationTabGroup

java.lang.Object
org.eclipse.debug.ui.AbstractLaunchConfigurationTabGroup
com.pvx.ooadide.launchers.thinclients.WindXLaunchConfigurationTabGroup
All Implemented Interfaces:
org.eclipse.debug.ui.ILaunchConfigurationTabGroup
public class WindXLaunchConfigurationTabGroup extends org.eclipse.debug.ui.AbstractLaunchConfigurationTabGroup

  • Constructor Summary

    Constructors
    Constructor
    Description
    WindXLaunchConfigurationTabGroup()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    createTabs(org.eclipse.debug.ui.ILaunchConfigurationDialog dialog, String mode)

    Methods inherited from class org.eclipse.debug.ui.AbstractLaunchConfigurationTabGroup

    dispose, getTabs, initializeFrom, performApply, setDefaults

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • WindXLaunchConfigurationTabGroup

      public WindXLaunchConfigurationTabGroup()

  • Method Details

    • createTabs

      public void createTabs(org.eclipse.debug.ui.ILaunchConfigurationDialog dialog, String mode)


Uses of Class com.pvx.ooadide.launchers.thinclients.ClientTab

Uses of Class
com.pvx.ooadide.launchers.thinclients.ClientTab

No usage of com.pvx.ooadide.launchers.thinclients.ClientTab


Uses of Class com.pvx.ooadide.launchers.thinclients.DebugWindXLauncherThread

Uses of Class
com.pvx.ooadide.launchers.thinclients.DebugWindXLauncherThread

No usage of com.pvx.ooadide.launchers.thinclients.DebugWindXLauncherThread


Uses of Class com.pvx.ooadide.launchers.thinclients.PvxBaseClientConfigTab

Uses of Class
com.pvx.ooadide.launchers.thinclients.PvxBaseClientConfigTab

Packages that use PvxBaseClientConfigTab
Package
Description
com.pvx.ooadide.launchers.thinclients

  • Uses of PvxBaseClientConfigTab in com.pvx.ooadide.launchers.thinclients

    Subclasses of PvxBaseClientConfigTab in com.pvx.ooadide.launchers.thinclients
    Modifier and Type
    Class
    Description
    class
    ClientTab
    This tab appears for java applet launch configurations and allows the user to edit attributes such as the applet class to launch and its owning project, if any.


Uses of Class com.pvx.ooadide.launchers.thinclients.WindXLaunchConfigurationDelegate1

Uses of Class
com.pvx.ooadide.launchers.thinclients.WindXLaunchConfigurationDelegate1

No usage of com.pvx.ooadide.launchers.thinclients.WindXLaunchConfigurationDelegate1


Uses of Class com.pvx.ooadide.launchers.thinclients.WindXLaunchConfigurationTabGroup

Uses of Class
com.pvx.ooadide.launchers.thinclients.WindXLaunchConfigurationTabGroup

No usage of com.pvx.ooadide.launchers.thinclients.WindXLaunchConfigurationTabGroup


JavXAppletArgumentsTab

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.launchers.thinclients.javx

Class JavXAppletArgumentsTab

java.lang.Object
org.eclipse.debug.ui.AbstractLaunchConfigurationTab
org.eclipse.jdt.debug.ui.launchConfigurations.JavaLaunchTab
org.eclipse.jdt.debug.ui.launchConfigurations.JavaArgumentsTab
org.eclipse.jdt.debug.ui.launchConfigurations.AppletArgumentsTab
com.pvx.ooadide.launchers.thinclients.javx.JavXAppletArgumentsTab
All Implemented Interfaces:
org.eclipse.debug.core.IPrototypeAttributesLabelProvider, org.eclipse.debug.ui.ILaunchConfigurationTab, org.eclipse.debug.ui.ILaunchConfigurationTab2
public class JavXAppletArgumentsTab extends org.eclipse.jdt.debug.ui.launchConfigurations.AppletArgumentsTab

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final String
    JAVX_NAME

  • Constructor Summary

    Constructors
    Constructor
    Description
    JavXAppletArgumentsTab()

  • Method Summary

    Modifier and Type
    Method
    Description
    String
    getName()
    void
    setDefaults(org.eclipse.debug.core.ILaunchConfigurationWorkingCopy configuration)

    Methods inherited from class org.eclipse.jdt.debug.ui.launchConfigurations.JavaArgumentsTab

    activated, createControl, deactivated, dispose, getErrorMessage, getId, getImage, getMessage, initializeFrom, isValid, performApply, setLaunchConfigurationDialog

    Methods inherited from class org.eclipse.debug.ui.AbstractLaunchConfigurationTab

    canSave, getAttributeLabel, getControl, getHelpContextId, getWarningMessage, setHelpContextId

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface org.eclipse.debug.ui.ILaunchConfigurationTab

    OkToLeaveTab, postApply

  • Field Details

    • JAVX_NAME

      public static final String JAVX_NAME
      See Also:
      • Constant Field Values

  • Constructor Details

    • JavXAppletArgumentsTab

      public JavXAppletArgumentsTab()

  • Method Details

    • getName

      public String getName()
      Specified by:
      getName in interface org.eclipse.debug.ui.ILaunchConfigurationTab
      Overrides:
      getName in class org.eclipse.jdt.debug.ui.launchConfigurations.JavaArgumentsTab

    • setDefaults

      public void setDefaults(org.eclipse.debug.core.ILaunchConfigurationWorkingCopy configuration)
      Specified by:
      setDefaults in interface org.eclipse.debug.ui.ILaunchConfigurationTab
      Overrides:
      setDefaults in class org.eclipse.jdt.debug.ui.launchConfigurations.JavaArgumentsTab


JavXAppletLaunchConfigurationDelegate

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.launchers.thinclients.javx

Class JavXAppletLaunchConfigurationDelegate

java.lang.Object
org.eclipse.debug.core.model.LaunchConfigurationDelegate
org.eclipse.jdt.launching.AbstractJavaLaunchConfigurationDelegate
com.pvx.ooadide.launchers.thinclients.javx.JavXAppletLaunchConfigurationDelegate
All Implemented Interfaces:
org.eclipse.debug.core.IDebugEventSetListener, org.eclipse.debug.core.model.ILaunchConfigurationDelegate, org.eclipse.debug.core.model.ILaunchConfigurationDelegate2
public class JavXAppletLaunchConfigurationDelegate extends org.eclipse.jdt.launching.AbstractJavaLaunchConfigurationDelegate

  • Constructor Summary

    Constructors
    Constructor
    Description
    JavXAppletLaunchConfigurationDelegate()

  • Method Summary

    Modifier and Type
    Method
    Description
    String
    getJavaPolicyFile(File workingDir)
    Returns the system property string for the policy file
    String
    getMainTypeName(org.eclipse.debug.core.ILaunchConfiguration configuration)
    String
    getProgramArguments(org.eclipse.debug.core.ILaunchConfiguration configuration)
    String
    getVMArguments(org.eclipse.debug.core.ILaunchConfiguration configuration)
    void
    handleDebugEvents(org.eclipse.debug.core.DebugEvent[] events)
    void
    launch(org.eclipse.debug.core.ILaunchConfiguration configuration, String mode, org.eclipse.debug.core.ILaunch launch, org.eclipse.core.runtime.IProgressMonitor monitor)
    Used to map temp file to launch obejct.

    Methods inherited from class org.eclipse.jdt.launching.AbstractJavaLaunchConfigurationDelegate

    getBootpath, getBootpathExt, getClasspath, getClasspathAndModulepath, getEnvironment, getJavaLibraryPath, getJavaProject, getJavaProjectName, getLaunch, getModuleCLIOptions, getVMArguments, getVMConnectorId, getVMInstall, getVMInstallName, getVMInstallType, getVMInstallTypeId, getVMRunner, getVMSpecificAttributesMap, getWorkingDirectory, getWorkingDirectoryPath, isAllowTerminate, isStopInMain, preLaunchCheck, verifyJavaProject, verifyMainTypeName, verifyVMInstall, verifyWorkingDirectory

    Methods inherited from class org.eclipse.debug.core.model.LaunchConfigurationDelegate

    buildForLaunch, finalLaunchCheck

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface org.eclipse.debug.core.model.ILaunchConfigurationDelegate

    showCommandLine

  • Constructor Details

    • JavXAppletLaunchConfigurationDelegate

      public JavXAppletLaunchConfigurationDelegate()

  • Method Details

    • getProgramArguments

      public String getProgramArguments(org.eclipse.debug.core.ILaunchConfiguration configuration) throws org.eclipse.core.runtime.CoreException
      Overrides:
      getProgramArguments in class org.eclipse.jdt.launching.AbstractJavaLaunchConfigurationDelegate
      Throws:
      org.eclipse.core.runtime.CoreException

    • launch

      public void launch(org.eclipse.debug.core.ILaunchConfiguration configuration, String mode, org.eclipse.debug.core.ILaunch launch, org.eclipse.core.runtime.IProgressMonitor monitor) throws org.eclipse.core.runtime.CoreException
      Used to map temp file to launch obejct.
      Throws:
      org.eclipse.core.runtime.CoreException

    • getJavaPolicyFile

      public String getJavaPolicyFile(File workingDir)
      Returns the system property string for the policy file
      Parameters:
      workingDir - the working directory
      Returns:
      system property for the policy file

    • handleDebugEvents

      public void handleDebugEvents(org.eclipse.debug.core.DebugEvent[] events)
      Specified by:
      handleDebugEvents in interface org.eclipse.debug.core.IDebugEventSetListener
      Overrides:
      handleDebugEvents in class org.eclipse.jdt.launching.AbstractJavaLaunchConfigurationDelegate

    • getVMArguments

      public String getVMArguments(org.eclipse.debug.core.ILaunchConfiguration configuration) throws org.eclipse.core.runtime.CoreException
      Overrides:
      getVMArguments in class org.eclipse.jdt.launching.AbstractJavaLaunchConfigurationDelegate
      Throws:
      org.eclipse.core.runtime.CoreException

    • getMainTypeName

      public String getMainTypeName(org.eclipse.debug.core.ILaunchConfiguration configuration) throws org.eclipse.core.runtime.CoreException
      Overrides:
      getMainTypeName in class org.eclipse.jdt.launching.AbstractJavaLaunchConfigurationDelegate
      Throws:
      org.eclipse.core.runtime.CoreException


JavXAppletTabGroup

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.launchers.thinclients.javx

Class JavXAppletTabGroup

java.lang.Object
org.eclipse.debug.ui.AbstractLaunchConfigurationTabGroup
com.pvx.ooadide.launchers.thinclients.javx.JavXAppletTabGroup
All Implemented Interfaces:
org.eclipse.debug.ui.ILaunchConfigurationTabGroup
public class JavXAppletTabGroup extends org.eclipse.debug.ui.AbstractLaunchConfigurationTabGroup

  • Constructor Summary

    Constructors
    Constructor
    Description
    JavXAppletTabGroup()
    Constructs a new Java applet tab group.

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    createTabs(org.eclipse.debug.ui.ILaunchConfigurationDialog dialog, String mode)

    Methods inherited from class org.eclipse.debug.ui.AbstractLaunchConfigurationTabGroup

    dispose, getTabs, initializeFrom, performApply, setDefaults

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • JavXAppletTabGroup

      public JavXAppletTabGroup()
      Constructs a new Java applet tab group.

  • Method Details

    • createTabs

      public void createTabs(org.eclipse.debug.ui.ILaunchConfigurationDialog dialog, String mode)


com.pvx.ooadide.launchers.thinclients.javx

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.pvx.ooadide.launchers.thinclients.javx

package com.pvx.ooadide.launchers.thinclients.javx
  • Related Packages
    Package
    Description
    com.pvx.ooadide.launchers.thinclients
  • Classes
    Class
    Description
    JavXAppletArgumentsTab
    JavXAppletLaunchConfigurationDelegate
    JavXAppletTabGroup


com.pvx.ooadide.launchers.thinclients.javx Class Hierarchy

Hierarchy For Package com.pvx.ooadide.launchers.thinclients.javx

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.eclipse.debug.ui.AbstractLaunchConfigurationTab (implements org.eclipse.debug.ui.ILaunchConfigurationTab2, org.eclipse.debug.core.IPrototypeAttributesLabelProvider)
      • org.eclipse.jdt.debug.ui.launchConfigurations.JavaLaunchTab
        • org.eclipse.jdt.debug.ui.launchConfigurations.JavaArgumentsTab
          • org.eclipse.jdt.debug.ui.launchConfigurations.AppletArgumentsTab
            • com.pvx.ooadide.launchers.thinclients.javx.JavXAppletArgumentsTab
    • org.eclipse.debug.ui.AbstractLaunchConfigurationTabGroup (implements org.eclipse.debug.ui.ILaunchConfigurationTabGroup)
      • com.pvx.ooadide.launchers.thinclients.javx.JavXAppletTabGroup
    • org.eclipse.debug.core.model.LaunchConfigurationDelegate (implements org.eclipse.debug.core.model.ILaunchConfigurationDelegate2)
      • org.eclipse.jdt.launching.AbstractJavaLaunchConfigurationDelegate (implements org.eclipse.debug.core.IDebugEventSetListener)
        • com.pvx.ooadide.launchers.thinclients.javx.JavXAppletLaunchConfigurationDelegate


Uses of Package com.pvx.ooadide.launchers.thinclients.javx

Uses of Package
com.pvx.ooadide.launchers.thinclients.javx

No usage of com.pvx.ooadide.launchers.thinclients.javx


Uses of Class com.pvx.ooadide.launchers.thinclients.javx.JavXAppletArgumentsTab

Uses of Class
com.pvx.ooadide.launchers.thinclients.javx.JavXAppletArgumentsTab

No usage of com.pvx.ooadide.launchers.thinclients.javx.JavXAppletArgumentsTab


Uses of Class com.pvx.ooadide.launchers.thinclients.javx.JavXAppletLaunchConfigurationDelegate

Uses of Class
com.pvx.ooadide.launchers.thinclients.javx.JavXAppletLaunchConfigurationDelegate

No usage of com.pvx.ooadide.launchers.thinclients.javx.JavXAppletLaunchConfigurationDelegate


Uses of Class com.pvx.ooadide.launchers.thinclients.javx.JavXAppletTabGroup

Uses of Class
com.pvx.ooadide.launchers.thinclients.javx.JavXAppletTabGroup

No usage of com.pvx.ooadide.launchers.thinclients.javx.JavXAppletTabGroup


com.pvx.ooadide.navigator

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.pvx.ooadide.navigator

package com.pvx.ooadide.navigator
  • Related Packages
    Package
    Description
    com.pvx.ooadide
    com.pvx.ooadide.navigator.filters
  • Classes
    Class
    Description
    ProjectExplorer


com.pvx.ooadide.navigator Class Hierarchy

Hierarchy For Package com.pvx.ooadide.navigator

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.eclipse.core.commands.common.EventManager
      • org.eclipse.ui.part.WorkbenchPart (implements org.eclipse.core.runtime.IExecutableExtension, org.eclipse.ui.IWorkbenchPart3, org.eclipse.ui.part.IWorkbenchPartOrientation)
        • org.eclipse.ui.part.ViewPart (implements org.eclipse.ui.IViewPart)
          • org.eclipse.ui.navigator.CommonNavigator (implements org.eclipse.ui.ISaveablePart, org.eclipse.ui.ISaveablesSource, org.eclipse.ui.part.ISetSelectionTarget, org.eclipse.ui.part.IShowInTarget)
            • com.pvx.ooadide.navigator.ProjectExplorer


Uses of Package com.pvx.ooadide.navigator

Uses of Package
com.pvx.ooadide.navigator

No usage of com.pvx.ooadide.navigator


ProjectExplorer

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.navigator

Class ProjectExplorer

java.lang.Object
org.eclipse.core.commands.common.EventManager
org.eclipse.ui.part.WorkbenchPart
org.eclipse.ui.part.ViewPart
org.eclipse.ui.navigator.CommonNavigator
com.pvx.ooadide.navigator.ProjectExplorer
All Implemented Interfaces:
org.eclipse.core.runtime.IAdaptable, org.eclipse.core.runtime.IExecutableExtension, org.eclipse.ui.IPersistable, org.eclipse.ui.ISaveablePart, org.eclipse.ui.ISaveablesSource, org.eclipse.ui.IViewPart, org.eclipse.ui.IWorkbenchPart, org.eclipse.ui.IWorkbenchPart2, org.eclipse.ui.IWorkbenchPart3, org.eclipse.ui.part.ISetSelectionTarget, org.eclipse.ui.part.IShowInTarget, org.eclipse.ui.part.IWorkbenchPartOrientation
public class ProjectExplorer extends org.eclipse.ui.navigator.CommonNavigator

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final String
    ID

    Fields inherited from class org.eclipse.ui.navigator.CommonNavigator

    IS_LINKING_ENABLED_PROPERTY

    Fields inherited from interface org.eclipse.ui.ISaveablePart

    PROP_DIRTY

    Fields inherited from interface org.eclipse.ui.IWorkbenchPart

    PROP_TITLE

  • Constructor Summary

    Constructors
    Constructor
    Description
    ProjectExplorer()

  • Method Summary

    Methods inherited from class org.eclipse.ui.navigator.CommonNavigator

    createPartControl, dispose, doSave, doSaveAs, getActiveSaveables, getAdapter, getCommonViewer, getFrameToolTipText, getNavigatorActionService, getNavigatorContentService, getRootMode, getSaveables, getWorkingSetLabel, init, isDirty, isLinkingEnabled, isSaveAsAllowed, isSaveOnCloseNeeded, saveState, selectReveal, setFocus, setLinkingEnabled, setRootMode, setWorkingSetLabel, show, updateTitle

    Methods inherited from class org.eclipse.ui.part.ViewPart

    getViewSite, init, setInitializationData

    Methods inherited from class org.eclipse.ui.part.WorkbenchPart

    addPartPropertyListener, addPropertyListener, getContentDescription, getOrientation, getPartName, getPartProperties, getPartProperty, getSite, getTitle, getTitleImage, getTitleToolTip, removePartPropertyListener, removePropertyListener, setPartProperty, showBusy

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface org.eclipse.ui.IWorkbenchPart

    addPropertyListener, getSite, getTitle, getTitleImage, getTitleToolTip, removePropertyListener

  • Field Details

    • ID

      public static final String ID
      See Also:
      • Constant Field Values

  • Constructor Details

    • ProjectExplorer

      public ProjectExplorer()


Uses of Class com.pvx.ooadide.navigator.ProjectExplorer

Uses of Class
com.pvx.ooadide.navigator.ProjectExplorer

No usage of com.pvx.ooadide.navigator.ProjectExplorer


NavigationFilter

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.navigator.filters

Class NavigationFilter

java.lang.Object
org.eclipse.jface.viewers.ViewerFilter
com.pvx.ooadide.navigator.filters.NavigationFilter
public class NavigationFilter extends org.eclipse.jface.viewers.ViewerFilter

  • Constructor Summary

    Constructors
    Constructor
    Description
    NavigationFilter()

  • Method Summary

    Modifier and Type
    Method
    Description
    boolean
    select(org.eclipse.jface.viewers.Viewer viewer, Object parentElement, Object element)

    Methods inherited from class org.eclipse.jface.viewers.ViewerFilter

    filter, filter, isFilterProperty

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • NavigationFilter

      public NavigationFilter()

  • Method Details

    • select

      public boolean select(org.eclipse.jface.viewers.Viewer viewer, Object parentElement, Object element)
      Specified by:
      select in class org.eclipse.jface.viewers.ViewerFilter


com.pvx.ooadide.navigator.filters

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.pvx.ooadide.navigator.filters

package com.pvx.ooadide.navigator.filters
  • Related Packages
    Package
    Description
    com.pvx.ooadide.navigator
  • Classes
    Class
    Description
    NavigationFilter


com.pvx.ooadide.navigator.filters Class Hierarchy

Hierarchy For Package com.pvx.ooadide.navigator.filters

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.eclipse.jface.viewers.ViewerFilter
      • com.pvx.ooadide.navigator.filters.NavigationFilter


Uses of Package com.pvx.ooadide.navigator.filters

Uses of Package
com.pvx.ooadide.navigator.filters

No usage of com.pvx.ooadide.navigator.filters


Uses of Class com.pvx.ooadide.navigator.filters.NavigationFilter

Uses of Class
com.pvx.ooadide.navigator.filters.NavigationFilter

No usage of com.pvx.ooadide.navigator.filters.NavigationFilter


com.pvx.ooadide.popup.actions

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.pvx.ooadide.popup.actions

package com.pvx.ooadide.popup.actions
  • Classes
    Class
    Description
    ProvideXNewAction


com.pvx.ooadide.popup.actions Class Hierarchy

Hierarchy For Package com.pvx.ooadide.popup.actions

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • com.pvx.ooadide.popup.actions.ProvideXNewAction (implements org.eclipse.ui.IObjectActionDelegate)


Uses of Package com.pvx.ooadide.popup.actions

Uses of Package
com.pvx.ooadide.popup.actions

No usage of com.pvx.ooadide.popup.actions


ProvideXNewAction

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.popup.actions

Class ProvideXNewAction

java.lang.Object
com.pvx.ooadide.popup.actions.ProvideXNewAction
All Implemented Interfaces:
org.eclipse.ui.IActionDelegate, org.eclipse.ui.IObjectActionDelegate
public class ProvideXNewAction extends Object implements org.eclipse.ui.IObjectActionDelegate

  • Constructor Summary

    Constructors
    Constructor
    Description
    ProvideXNewAction()
    Constructor for Action1.

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    run(org.eclipse.jface.action.IAction action)
    void
    selectionChanged(org.eclipse.jface.action.IAction action, org.eclipse.jface.viewers.ISelection selection)
    void
    setActivePart(org.eclipse.jface.action.IAction action, org.eclipse.ui.IWorkbenchPart targetPart)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • ProvideXNewAction

      public ProvideXNewAction()
      Constructor for Action1.

  • Method Details

    • setActivePart

      public void setActivePart(org.eclipse.jface.action.IAction action, org.eclipse.ui.IWorkbenchPart targetPart)
      Specified by:
      setActivePart in interface org.eclipse.ui.IObjectActionDelegate
      See Also:
      • IObjectActionDelegate.setActivePart(IAction, IWorkbenchPart)

    • run

      public void run(org.eclipse.jface.action.IAction action)
      Specified by:
      run in interface org.eclipse.ui.IActionDelegate
      See Also:
      • IActionDelegate#run(IAction)

    • selectionChanged

      public void selectionChanged(org.eclipse.jface.action.IAction action, org.eclipse.jface.viewers.ISelection selection)
      Specified by:
      selectionChanged in interface org.eclipse.ui.IActionDelegate
      See Also:
      • IActionDelegate#selectionChanged(IAction, ISelection)


Uses of Class com.pvx.ooadide.popup.actions.ProvideXNewAction

Uses of Class
com.pvx.ooadide.popup.actions.ProvideXNewAction

No usage of com.pvx.ooadide.popup.actions.ProvideXNewAction


AbstractProvideXFieldEditorPrefPage

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.preferences

Class AbstractProvideXFieldEditorPrefPage

java.lang.Object
org.eclipse.jface.dialogs.DialogPage
org.eclipse.jface.preference.PreferencePage
org.eclipse.jface.preference.FieldEditorPreferencePage
com.pvx.ooadide.preferences.AbstractProvideXFieldEditorPrefPage
All Implemented Interfaces:
PvxPrefVisitee, EventListener, org.eclipse.jface.dialogs.IDialogPage, org.eclipse.jface.dialogs.IMessageProvider, org.eclipse.jface.preference.IPreferencePage, org.eclipse.jface.util.IPropertyChangeListener, org.eclipse.ui.IWorkbenchPreferencePage
Direct Known Subclasses:
BuilderOptions, EditorOptions, EditorOptionsPrefPage, ImportOptionsPrefPage, NomadsPreferencePage, ObserversPreferencePage, ProvideXPreferencePage, UserDefinedPrefPage
public abstract class AbstractProvideXFieldEditorPrefPage extends org.eclipse.jface.preference.FieldEditorPreferencePage implements PvxPrefVisitee, org.eclipse.ui.IWorkbenchPreferencePage

  • Field Summary

    Fields inherited from class org.eclipse.jface.preference.FieldEditorPreferencePage

    FLAT, GRID

    Fields inherited from interface org.eclipse.jface.dialogs.IMessageProvider

    ERROR, INFORMATION, NONE, WARNING

  • Method Summary

    Modifier and Type
    Method
    Description
    static void
    addToDependencies(String controller, String slave)
    abstract String
    getID()
    void
    init(org.eclipse.ui.IWorkbench workbench)
    boolean
    isValid()
    boolean
    performCancel()
    boolean
    performOk()
    void
    propertyChange(org.eclipse.jface.util.PropertyChangeEvent event)
    void
    visit(int dataType, String displayName, String configKey, boolean enable)

    Methods inherited from class org.eclipse.jface.preference.FieldEditorPreferencePage

    dispose, setVisible

    Methods inherited from class org.eclipse.jface.preference.PreferencePage

    applyData, computeSize, createControl, getContainer, getPreferenceStore, okToLeave, performHelp, setContainer, setErrorMessage, setMessage, setPreferenceStore, setSize, setTitle, setValid, toString

    Methods inherited from class org.eclipse.jface.dialogs.DialogPage

    getControl, getDescription, getErrorMessage, getImage, getMessage, getMessageType, getShell, getTitle, setDescription, setImageDescriptor, setMessage

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

    Methods inherited from interface org.eclipse.jface.dialogs.IDialogPage

    createControl, dispose, getControl, getDescription, getErrorMessage, getImage, getMessage, getTitle, performHelp, setDescription, setImageDescriptor, setTitle, setVisible

    Methods inherited from interface org.eclipse.jface.preference.IPreferencePage

    computeSize, okToLeave, setContainer, setSize

  • Method Details

    • init

      public void init(org.eclipse.ui.IWorkbench workbench)
      Specified by:
      init in interface org.eclipse.ui.IWorkbenchPreferencePage

    • getID

      public abstract String getID()

    • visit

      public void visit(int dataType, String displayName, String configKey, boolean enable)
      Specified by:
      visit in interface PvxPrefVisitee

    • addToDependencies

      public static void addToDependencies(String controller, String slave)

    • propertyChange

      public void propertyChange(org.eclipse.jface.util.PropertyChangeEvent event)
      Specified by:
      propertyChange in interface org.eclipse.jface.util.IPropertyChangeListener
      Overrides:
      propertyChange in class org.eclipse.jface.preference.FieldEditorPreferencePage

    • performOk

      public boolean performOk()
      Specified by:
      performOk in interface org.eclipse.jface.preference.IPreferencePage
      Overrides:
      performOk in class org.eclipse.jface.preference.FieldEditorPreferencePage

    • performCancel

      public boolean performCancel()
      Specified by:
      performCancel in interface org.eclipse.jface.preference.IPreferencePage
      Overrides:
      performCancel in class org.eclipse.jface.preference.PreferencePage

    • isValid

      public boolean isValid()
      Specified by:
      isValid in interface org.eclipse.jface.preference.IPreferencePage
      Overrides:
      isValid in class org.eclipse.jface.preference.PreferencePage


BuilderOptions

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.preferences

Class BuilderOptions

java.lang.Object
org.eclipse.jface.dialogs.DialogPage
org.eclipse.jface.preference.PreferencePage
org.eclipse.jface.preference.FieldEditorPreferencePage
com.pvx.ooadide.preferences.AbstractProvideXFieldEditorPrefPage
com.pvx.ooadide.preferences.BuilderOptions
All Implemented Interfaces:
PvxPrefVisitee, EventListener, org.eclipse.jface.dialogs.IDialogPage, org.eclipse.jface.dialogs.IMessageProvider, org.eclipse.jface.preference.IPreferencePage, org.eclipse.jface.util.IPropertyChangeListener, org.eclipse.ui.IWorkbenchPreferencePage
public class BuilderOptions extends AbstractProvideXFieldEditorPrefPage

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final String
    ID

    Fields inherited from class org.eclipse.jface.preference.FieldEditorPreferencePage

    FLAT, GRID

    Fields inherited from interface org.eclipse.jface.dialogs.IMessageProvider

    ERROR, INFORMATION, NONE, WARNING

  • Constructor Summary

    Constructors
    Constructor
    Description
    BuilderOptions()

  • Method Summary

    Modifier and Type
    Method
    Description
    String
    getID()

    Methods inherited from class com.pvx.ooadide.preferences.AbstractProvideXFieldEditorPrefPage

    addToDependencies, init, isValid, performCancel, performOk, propertyChange, visit

    Methods inherited from class org.eclipse.jface.preference.FieldEditorPreferencePage

    dispose, setVisible

    Methods inherited from class org.eclipse.jface.preference.PreferencePage

    applyData, computeSize, createControl, getContainer, getPreferenceStore, okToLeave, performHelp, setContainer, setErrorMessage, setMessage, setPreferenceStore, setSize, setTitle, setValid, toString

    Methods inherited from class org.eclipse.jface.dialogs.DialogPage

    getControl, getDescription, getErrorMessage, getImage, getMessage, getMessageType, getShell, getTitle, setDescription, setImageDescriptor, setMessage

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

    Methods inherited from interface org.eclipse.jface.dialogs.IDialogPage

    createControl, dispose, getControl, getDescription, getErrorMessage, getImage, getMessage, getTitle, performHelp, setDescription, setImageDescriptor, setTitle, setVisible

    Methods inherited from interface org.eclipse.jface.preference.IPreferencePage

    computeSize, okToLeave, setContainer, setSize

  • Field Details

    • ID

      public static final String ID
      See Also:
      • Constant Field Values

  • Constructor Details

    • BuilderOptions

      public BuilderOptions()

  • Method Details

    • getID

      public String getID()
      Specified by:
      getID in class AbstractProvideXFieldEditorPrefPage


EditorColorPreferencePage

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.preferences

Class EditorColorPreferencePage

java.lang.Object
org.eclipse.jface.dialogs.DialogPage
org.eclipse.jface.preference.PreferencePage
com.pvx.ooadide.preferences.EditorColorPreferencePage
All Implemented Interfaces:
org.eclipse.jface.dialogs.IDialogPage, org.eclipse.jface.dialogs.IMessageProvider, org.eclipse.jface.preference.IPreferencePage, org.eclipse.ui.IWorkbenchPreferencePage
public class EditorColorPreferencePage extends org.eclipse.jface.preference.PreferencePage implements org.eclipse.ui.IWorkbenchPreferencePage

  • Field Summary

    Fields inherited from interface org.eclipse.jface.dialogs.IMessageProvider

    ERROR, INFORMATION, NONE, WARNING

  • Constructor Summary

    Constructors
    Constructor
    Description
    EditorColorPreferencePage()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    createControl(org.eclipse.swt.widgets.Composite parent)
    void
    dispose()
    void
    init(org.eclipse.ui.IWorkbench workbench)
    void
    performDefaults()
    boolean
    performOk()

    Methods inherited from class org.eclipse.jface.preference.PreferencePage

    applyData, computeSize, getContainer, getPreferenceStore, isValid, okToLeave, performCancel, performHelp, setContainer, setErrorMessage, setMessage, setPreferenceStore, setSize, setTitle, setValid, toString

    Methods inherited from class org.eclipse.jface.dialogs.DialogPage

    getControl, getDescription, getErrorMessage, getImage, getMessage, getMessageType, getShell, getTitle, setDescription, setImageDescriptor, setMessage, setVisible

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

    Methods inherited from interface org.eclipse.jface.dialogs.IDialogPage

    getControl, getDescription, getErrorMessage, getImage, getMessage, getTitle, performHelp, setDescription, setImageDescriptor, setTitle, setVisible

    Methods inherited from interface org.eclipse.jface.preference.IPreferencePage

    computeSize, isValid, okToLeave, performCancel, setContainer, setSize

  • Constructor Details

    • EditorColorPreferencePage

      public EditorColorPreferencePage()

  • Method Details

    • init

      public void init(org.eclipse.ui.IWorkbench workbench)
      Specified by:
      init in interface org.eclipse.ui.IWorkbenchPreferencePage

    • createControl

      public void createControl(org.eclipse.swt.widgets.Composite parent)
      Specified by:
      createControl in interface org.eclipse.jface.dialogs.IDialogPage
      Overrides:
      createControl in class org.eclipse.jface.preference.PreferencePage

    • performOk

      public boolean performOk()
      Specified by:
      performOk in interface org.eclipse.jface.preference.IPreferencePage
      Overrides:
      performOk in class org.eclipse.jface.preference.PreferencePage

    • performDefaults

      public void performDefaults()

    • dispose

      public void dispose()
      Specified by:
      dispose in interface org.eclipse.jface.dialogs.IDialogPage
      Overrides:
      dispose in class org.eclipse.jface.dialogs.DialogPage


EditorOptions

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.preferences

Class EditorOptions

java.lang.Object
org.eclipse.jface.dialogs.DialogPage
org.eclipse.jface.preference.PreferencePage
org.eclipse.jface.preference.FieldEditorPreferencePage
com.pvx.ooadide.preferences.AbstractProvideXFieldEditorPrefPage
com.pvx.ooadide.preferences.EditorOptions
All Implemented Interfaces:
PvxPrefVisitee, EventListener, org.eclipse.jface.dialogs.IDialogPage, org.eclipse.jface.dialogs.IMessageProvider, org.eclipse.jface.preference.IPreferencePage, org.eclipse.jface.util.IPropertyChangeListener, org.eclipse.ui.IWorkbenchPreferencePage
public class EditorOptions extends AbstractProvideXFieldEditorPrefPage
This class represents a preference page that is contributed to the Preferences dialog. By subclassing FieldEditorPreferencePage, we can use the field support built into JFace that allows us to create a page that is small and knows how to save, restore and apply itself.

This page is used to modify preferences only. They are stored in the preference store that belongs to the main plug-in class. That way, preferences can be accessed directly via the preference store.

  • Field Summary

    Fields inherited from class org.eclipse.jface.preference.FieldEditorPreferencePage

    FLAT, GRID

    Fields inherited from interface org.eclipse.jface.dialogs.IMessageProvider

    ERROR, INFORMATION, NONE, WARNING

  • Constructor Summary

    Constructors
    Constructor
    Description
    EditorOptions()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    createFieldEditors()
    Creates the field editors.
    String
    getID()
    void
    propertyChange(org.eclipse.jface.util.PropertyChangeEvent event)

    Methods inherited from class com.pvx.ooadide.preferences.AbstractProvideXFieldEditorPrefPage

    addToDependencies, init, isValid, performCancel, performOk, visit

    Methods inherited from class org.eclipse.jface.preference.FieldEditorPreferencePage

    dispose, setVisible

    Methods inherited from class org.eclipse.jface.preference.PreferencePage

    applyData, computeSize, createControl, getContainer, getPreferenceStore, okToLeave, performHelp, setContainer, setErrorMessage, setMessage, setPreferenceStore, setSize, setTitle, setValid, toString

    Methods inherited from class org.eclipse.jface.dialogs.DialogPage

    getControl, getDescription, getErrorMessage, getImage, getMessage, getMessageType, getShell, getTitle, setDescription, setImageDescriptor, setMessage

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

    Methods inherited from interface org.eclipse.jface.dialogs.IDialogPage

    createControl, dispose, getControl, getDescription, getErrorMessage, getImage, getMessage, getTitle, performHelp, setDescription, setImageDescriptor, setTitle, setVisible

    Methods inherited from interface org.eclipse.jface.preference.IPreferencePage

    computeSize, okToLeave, setContainer, setSize

  • Constructor Details

    • EditorOptions

      public EditorOptions()

  • Method Details

    • createFieldEditors

      public void createFieldEditors()
      Creates the field editors. Field editors are abstractions of the common GUI blocks needed to manipulate various types of preferences. Each field editor knows how to save and restore itself.

    • propertyChange

      public void propertyChange(org.eclipse.jface.util.PropertyChangeEvent event)
      Specified by:
      propertyChange in interface org.eclipse.jface.util.IPropertyChangeListener
      Overrides:
      propertyChange in class AbstractProvideXFieldEditorPrefPage

    • getID

      public String getID()
      Specified by:
      getID in class AbstractProvideXFieldEditorPrefPage


EditorOptionsPrefPage

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.preferences

Class EditorOptionsPrefPage

java.lang.Object
org.eclipse.jface.dialogs.DialogPage
org.eclipse.jface.preference.PreferencePage
org.eclipse.jface.preference.FieldEditorPreferencePage
com.pvx.ooadide.preferences.AbstractProvideXFieldEditorPrefPage
com.pvx.ooadide.preferences.EditorOptionsPrefPage
All Implemented Interfaces:
PvxPrefVisitee, EventListener, org.eclipse.jface.dialogs.IDialogPage, org.eclipse.jface.dialogs.IMessageProvider, org.eclipse.jface.preference.IPreferencePage, org.eclipse.jface.util.IPropertyChangeListener, org.eclipse.ui.IWorkbenchPreferencePage
public class EditorOptionsPrefPage extends AbstractProvideXFieldEditorPrefPage

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final String
    ID

    Fields inherited from class org.eclipse.jface.preference.FieldEditorPreferencePage

    FLAT, GRID

    Fields inherited from interface org.eclipse.jface.dialogs.IMessageProvider

    ERROR, INFORMATION, NONE, WARNING

  • Constructor Summary

    Constructors
    Constructor
    Description
    EditorOptionsPrefPage()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    createFieldEditors()
    String
    getID()

    Methods inherited from class com.pvx.ooadide.preferences.AbstractProvideXFieldEditorPrefPage

    addToDependencies, init, isValid, performCancel, performOk, propertyChange, visit

    Methods inherited from class org.eclipse.jface.preference.FieldEditorPreferencePage

    dispose, setVisible

    Methods inherited from class org.eclipse.jface.preference.PreferencePage

    applyData, computeSize, createControl, getContainer, getPreferenceStore, okToLeave, performHelp, setContainer, setErrorMessage, setMessage, setPreferenceStore, setSize, setTitle, setValid, toString

    Methods inherited from class org.eclipse.jface.dialogs.DialogPage

    getControl, getDescription, getErrorMessage, getImage, getMessage, getMessageType, getShell, getTitle, setDescription, setImageDescriptor, setMessage

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

    Methods inherited from interface org.eclipse.jface.dialogs.IDialogPage

    createControl, dispose, getControl, getDescription, getErrorMessage, getImage, getMessage, getTitle, performHelp, setDescription, setImageDescriptor, setTitle, setVisible

    Methods inherited from interface org.eclipse.jface.preference.IPreferencePage

    computeSize, okToLeave, setContainer, setSize

  • Field Details

    • ID

      public static final String ID
      See Also:
      • Constant Field Values

  • Constructor Details

    • EditorOptionsPrefPage

      public EditorOptionsPrefPage()

  • Method Details

    • createFieldEditors

      public void createFieldEditors()

    • getID

      public String getID()
      Specified by:
      getID in class AbstractProvideXFieldEditorPrefPage


EditorSyntaxColorPref

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.preferences

Class EditorSyntaxColorPref

java.lang.Object
com.pvx.ooadide.preferences.EditorSyntaxColorPref
public class EditorSyntaxColorPref extends Object

  • Constructor Summary

    Constructors
    Constructor
    Description
    EditorSyntaxColorPref(String keywordLabel, String bgColorKey, String fgColorKey, String italicKey, String boldKey, String strikeThrough, String underLine)

  • Method Summary

    Modifier and Type
    Method
    Description
    String
    getStrikeThrough()
    String
    getUnderLine()
    void
    setStrikeThrough(String strikeThrough)
    void
    setUnderLine(String underLine)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • EditorSyntaxColorPref

      public EditorSyntaxColorPref(String keywordLabel, String bgColorKey, String fgColorKey, String italicKey, String boldKey, String strikeThrough, String underLine)

  • Method Details

    • setStrikeThrough

      public void setStrikeThrough(String strikeThrough)

    • getStrikeThrough

      public String getStrikeThrough()

    • setUnderLine

      public void setUnderLine(String underLine)

    • getUnderLine

      public String getUnderLine()


ImportOptionsPrefPage

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.preferences

Class ImportOptionsPrefPage

java.lang.Object
org.eclipse.jface.dialogs.DialogPage
org.eclipse.jface.preference.PreferencePage
org.eclipse.jface.preference.FieldEditorPreferencePage
com.pvx.ooadide.preferences.AbstractProvideXFieldEditorPrefPage
com.pvx.ooadide.preferences.ImportOptionsPrefPage
All Implemented Interfaces:
PvxPrefVisitee, EventListener, org.eclipse.jface.dialogs.IDialogPage, org.eclipse.jface.dialogs.IMessageProvider, org.eclipse.jface.preference.IPreferencePage, org.eclipse.jface.util.IPropertyChangeListener, org.eclipse.ui.IWorkbenchPreferencePage
public class ImportOptionsPrefPage extends AbstractProvideXFieldEditorPrefPage implements org.eclipse.ui.IWorkbenchPreferencePage

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final String
    ID

    Fields inherited from class org.eclipse.jface.preference.FieldEditorPreferencePage

    FLAT, GRID

    Fields inherited from interface org.eclipse.jface.dialogs.IMessageProvider

    ERROR, INFORMATION, NONE, WARNING

  • Constructor Summary

    Constructors
    Constructor
    Description
    ImportOptionsPrefPage()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    createFieldEditors()
    Creates the field editors.
    String
    getID()
    void
    init(org.eclipse.ui.IWorkbench workbench)
    void
    propertyChange(org.eclipse.jface.util.PropertyChangeEvent event)

    Methods inherited from class com.pvx.ooadide.preferences.AbstractProvideXFieldEditorPrefPage

    addToDependencies, isValid, performCancel, performOk, visit

    Methods inherited from class org.eclipse.jface.preference.FieldEditorPreferencePage

    dispose, setVisible

    Methods inherited from class org.eclipse.jface.preference.PreferencePage

    applyData, computeSize, createControl, getContainer, getPreferenceStore, okToLeave, performHelp, setContainer, setErrorMessage, setMessage, setPreferenceStore, setSize, setTitle, setValid, toString

    Methods inherited from class org.eclipse.jface.dialogs.DialogPage

    getControl, getDescription, getErrorMessage, getImage, getMessage, getMessageType, getShell, getTitle, setDescription, setImageDescriptor, setMessage

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

    Methods inherited from interface org.eclipse.jface.dialogs.IDialogPage

    createControl, dispose, getControl, getDescription, getErrorMessage, getImage, getMessage, getTitle, performHelp, setDescription, setImageDescriptor, setTitle, setVisible

    Methods inherited from interface org.eclipse.jface.preference.IPreferencePage

    computeSize, isValid, okToLeave, performCancel, performOk, setContainer, setSize

  • Field Details

    • ID

      public static final String ID
      See Also:
      • Constant Field Values

  • Constructor Details

    • ImportOptionsPrefPage

      public ImportOptionsPrefPage()

  • Method Details

    • createFieldEditors

      public void createFieldEditors()
      Creates the field editors. Field editors are abstractions of the common GUI blocks needed to manipulate various types of preferences. Each field editor knows how to save and restore itself.

    • init

      public void init(org.eclipse.ui.IWorkbench workbench)
      Specified by:
      init in interface org.eclipse.ui.IWorkbenchPreferencePage
      Overrides:
      init in class AbstractProvideXFieldEditorPrefPage

    • propertyChange

      public void propertyChange(org.eclipse.jface.util.PropertyChangeEvent event)
      Specified by:
      propertyChange in interface org.eclipse.jface.util.IPropertyChangeListener
      Overrides:
      propertyChange in class AbstractProvideXFieldEditorPrefPage

    • getID

      public String getID()
      Specified by:
      getID in class AbstractProvideXFieldEditorPrefPage


ObserversPreferencePage

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.preferences

Class ObserversPreferencePage

java.lang.Object
org.eclipse.jface.dialogs.DialogPage
org.eclipse.jface.preference.PreferencePage
org.eclipse.jface.preference.FieldEditorPreferencePage
com.pvx.ooadide.preferences.AbstractProvideXFieldEditorPrefPage
com.pvx.ooadide.preferences.ObserversPreferencePage
All Implemented Interfaces:
PvxPrefVisitee, EventListener, org.eclipse.jface.dialogs.IDialogPage, org.eclipse.jface.dialogs.IMessageProvider, org.eclipse.jface.preference.IPreferencePage, org.eclipse.jface.util.IPropertyChangeListener, org.eclipse.ui.IWorkbenchPreferencePage
public class ObserversPreferencePage extends AbstractProvideXFieldEditorPrefPage

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final String
    ID

    Fields inherited from class org.eclipse.jface.preference.FieldEditorPreferencePage

    FLAT, GRID

    Fields inherited from interface org.eclipse.jface.dialogs.IMessageProvider

    ERROR, INFORMATION, NONE, WARNING

  • Constructor Summary

    Constructors
    Constructor
    Description
    ObserversPreferencePage()

  • Method Summary

    Modifier and Type
    Method
    Description
    String
    getID()

    Methods inherited from class com.pvx.ooadide.preferences.AbstractProvideXFieldEditorPrefPage

    addToDependencies, init, isValid, performCancel, performOk, propertyChange, visit

    Methods inherited from class org.eclipse.jface.preference.FieldEditorPreferencePage

    dispose, setVisible

    Methods inherited from class org.eclipse.jface.preference.PreferencePage

    applyData, computeSize, createControl, getContainer, getPreferenceStore, okToLeave, performHelp, setContainer, setErrorMessage, setMessage, setPreferenceStore, setSize, setTitle, setValid, toString

    Methods inherited from class org.eclipse.jface.dialogs.DialogPage

    getControl, getDescription, getErrorMessage, getImage, getMessage, getMessageType, getShell, getTitle, setDescription, setImageDescriptor, setMessage

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

    Methods inherited from interface org.eclipse.jface.dialogs.IDialogPage

    createControl, dispose, getControl, getDescription, getErrorMessage, getImage, getMessage, getTitle, performHelp, setDescription, setImageDescriptor, setTitle, setVisible

    Methods inherited from interface org.eclipse.jface.preference.IPreferencePage

    computeSize, okToLeave, setContainer, setSize

  • Field Details

    • ID

      public static final String ID
      See Also:
      • Constant Field Values

  • Constructor Details

    • ObserversPreferencePage

      public ObserversPreferencePage()

  • Method Details

    • getID

      public String getID()
      Specified by:
      getID in class AbstractProvideXFieldEditorPrefPage


com.pvx.ooadide.preferences

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.pvx.ooadide.preferences

package com.pvx.ooadide.preferences
  • Related Packages
    Package
    Description
    com.pvx.ooadide
    com.pvx.ooadide.preferences.nomads
  • Class
    Description
    AbstractProvideXFieldEditorPrefPage
    BuilderOptions
    EditorColorPreferencePage
    EditorOptions
    This class represents a preference page that is contributed to the Preferences dialog.
    EditorOptionsPrefPage
    EditorSyntaxColorPref
    ImportOptionsPrefPage
    ObserversPreferencePage
    PasswordPreferences
    PreferenceConstants
    Constant definitions for plug-in preferences
    PreferenceInitializer
    Class used to initialize default preference values.
    PreferenceManager
    PrefPageVistor
    ProvideXPreferencePage
    This class represents a preference page that is contributed to the Preferences dialog.
    PvxListEditor
    PvxPrefVisitee
    SpacerFieldEditor
    A field editor for adding space to a preference page.
    UserDefinedPrefPage
    UserDefinedSortedField
    UserPrefElement


com.pvx.ooadide.preferences Class Hierarchy

Hierarchy For Package com.pvx.ooadide.preferences

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.eclipse.core.runtime.preferences.AbstractPreferenceInitializer
      • com.pvx.ooadide.preferences.PreferenceInitializer
    • org.eclipse.jface.dialogs.DialogPage (implements org.eclipse.jface.dialogs.IDialogPage, org.eclipse.jface.dialogs.IMessageProvider)
      • org.eclipse.jface.preference.PreferencePage (implements org.eclipse.jface.preference.IPreferencePage)
        • com.pvx.ooadide.preferences.EditorColorPreferencePage (implements org.eclipse.ui.IWorkbenchPreferencePage)
        • org.eclipse.jface.preference.FieldEditorPreferencePage (implements org.eclipse.jface.util.IPropertyChangeListener)
          • com.pvx.ooadide.preferences.AbstractProvideXFieldEditorPrefPage (implements org.eclipse.ui.IWorkbenchPreferencePage, com.pvx.ooadide.preferences.PvxPrefVisitee)
            • com.pvx.ooadide.preferences.BuilderOptions
            • com.pvx.ooadide.preferences.EditorOptions
            • com.pvx.ooadide.preferences.EditorOptionsPrefPage
            • com.pvx.ooadide.preferences.ImportOptionsPrefPage (implements org.eclipse.ui.IWorkbenchPreferencePage)
            • com.pvx.ooadide.preferences.ObserversPreferencePage
            • com.pvx.ooadide.preferences.ProvideXPreferencePage (implements org.eclipse.ui.IWorkbenchPreferencePage)
            • com.pvx.ooadide.preferences.UserDefinedPrefPage
        • org.eclipse.ui.dialogs.PropertyPage (implements org.eclipse.ui.IWorkbenchPropertyPage)
          • com.pvx.ooadide.properties.ProvideXPropertyPage
            • com.pvx.ooadide.preferences.PasswordPreferences (implements org.eclipse.ui.IWorkbenchPreferencePage)
    • com.pvx.ooadide.preferences.EditorSyntaxColorPref
    • org.eclipse.jface.preference.FieldEditor
      • org.eclipse.jface.preference.ListEditor
        • com.pvx.ooadide.preferences.PvxListEditor
      • com.pvx.ooadide.preferences.SpacerFieldEditor
    • com.pvx.ooadide.preferences.PreferenceConstants
    • com.pvx.ooadide.preferences.PreferenceManager
    • com.pvx.ooadide.preferences.PrefPageVistor
    • com.pvx.ooadide.preferences.UserDefinedSortedField (implements java.lang.Comparable<T>)
    • com.pvx.ooadide.preferences.UserPrefElement

Interface Hierarchy

  • com.pvx.ooadide.preferences.PvxPrefVisitee


Uses of Package com.pvx.ooadide.preferences

Uses of Package
com.pvx.ooadide.preferences

Packages that use com.pvx.ooadide.preferences
Package
Description
com.pvx.ooadide.preferences
com.pvx.ooadide.preferences.nomads
com.pvx.ooadide.properties.userdefined
  • Classes in com.pvx.ooadide.preferences used by com.pvx.ooadide.preferences
    Class
    Description
    AbstractProvideXFieldEditorPrefPage
    EditorSyntaxColorPref
    PreferenceInitializer
    Class used to initialize default preference values.
    PvxPrefVisitee
    UserPrefElement
  • Classes in com.pvx.ooadide.preferences used by com.pvx.ooadide.preferences.nomads
    Class
    Description
    AbstractProvideXFieldEditorPrefPage
    PvxPrefVisitee
  • Classes in com.pvx.ooadide.preferences used by com.pvx.ooadide.properties.userdefined
    Class
    Description
    UserPrefElement


PasswordPreferences

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.preferences

Class PasswordPreferences

java.lang.Object
org.eclipse.jface.dialogs.DialogPage
org.eclipse.jface.preference.PreferencePage
org.eclipse.ui.dialogs.PropertyPage
com.pvx.ooadide.properties.ProvideXPropertyPage
com.pvx.ooadide.preferences.PasswordPreferences
All Implemented Interfaces:
org.eclipse.jface.dialogs.IDialogPage, org.eclipse.jface.dialogs.IMessageProvider, org.eclipse.jface.preference.IPreferencePage, org.eclipse.ui.IWorkbenchPreferencePage, org.eclipse.ui.IWorkbenchPropertyPage
public class PasswordPreferences extends ProvideXPropertyPage implements org.eclipse.ui.IWorkbenchPreferencePage

  • Field Summary

    Fields inherited from class com.pvx.ooadide.properties.ProvideXPropertyPage

    LINKED_DELIM, P_USER_FILE, P_USER_FOLDER, P_USER_NOMADSLIBS, P_USER_PROGRAMS, P_USER_PROJECT, P_USER_RESOURCE, QUALIFIED_ID

    Fields inherited from interface org.eclipse.jface.dialogs.IMessageProvider

    ERROR, INFORMATION, NONE, WARNING

  • Constructor Summary

    Constructors
    Constructor
    Description
    PasswordPreferences()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    init(org.eclipse.ui.IWorkbench workbench)
    boolean
    performOk()

    Methods inherited from class com.pvx.ooadide.properties.ProvideXPropertyPage

    doApplyProp, doApplyProp, doApplyProps, getDefaultOutputName, getDefaultValue, getTestFolderList, isInInvalidList, removeFromHistory, scanFolder

    Methods inherited from class org.eclipse.ui.dialogs.PropertyPage

    getElement, setElement

    Methods inherited from class org.eclipse.jface.preference.PreferencePage

    applyData, computeSize, createControl, getContainer, getPreferenceStore, isValid, okToLeave, performCancel, performHelp, setContainer, setErrorMessage, setMessage, setPreferenceStore, setSize, setTitle, setValid, toString

    Methods inherited from class org.eclipse.jface.dialogs.DialogPage

    dispose, getControl, getDescription, getErrorMessage, getImage, getMessage, getMessageType, getShell, getTitle, setDescription, setImageDescriptor, setMessage, setVisible

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

    Methods inherited from interface org.eclipse.jface.dialogs.IDialogPage

    createControl, dispose, getControl, getDescription, getErrorMessage, getImage, getMessage, getTitle, performHelp, setDescription, setImageDescriptor, setTitle, setVisible

    Methods inherited from interface org.eclipse.jface.preference.IPreferencePage

    computeSize, isValid, okToLeave, performCancel, setContainer, setSize

  • Constructor Details

    • PasswordPreferences

      public PasswordPreferences()

  • Method Details

    • init

      public void init(org.eclipse.ui.IWorkbench workbench)
      Specified by:
      init in interface org.eclipse.ui.IWorkbenchPreferencePage

    • performOk

      public boolean performOk()
      Specified by:
      performOk in interface org.eclipse.jface.preference.IPreferencePage
      Overrides:
      performOk in class ProvideXPropertyPage


PreferenceConstants

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.preferences

Class PreferenceConstants

java.lang.Object
com.pvx.ooadide.preferences.PreferenceConstants
public class PreferenceConstants extends Object
Constant definitions for plug-in preferences
Since:
1.0

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final String
    _BACKCOLOR
    static final String
    _BOLD
    static final String
    _COLOR
    static final String
    _IS_SET
    static final String
    _ITALIC
    static final String
    _STRIKETHROUGH
    static final String
    _UNDERLINE
    static final String
    BUILD_PROPERTY_FILE_NAME
    static final String
    BUILD_PROPERTY_FILE_PATH
    static final String
    BUILDTYPE_ALL
    static final String
    BUILDTYPE_BUILDONE
    static final String
    BUILDTYPE_CONVERT
    static final String
    BUILDTYPE_DATAFILE
    static final String
    BUILDTYPE_NOMADSLIB
    static final String
    BUILDTYPE_OTHERFILE
    static final String
    BUILDTYPE_SKIPFILE
    static final String
    BUILDTYPE_SOURCE_FORMAT
    static final String
    IS_ADD_EXT_TO_ALL
    static final EditorSyntaxColorPref[]
    keywordPrefList
    static String
    LIST_OF_PROPERITES
    static final String
    P_BOOLEAN
    static final String
    P_BUILD_DATAFILES
    static final String
    P_BUILD_FILES_NO_EXT
    static final String
    P_BUILD_RESOURCES
    static final String
    P_CHOICE
    static final String
    P_CODECHECKER
    static final String
    P_DEBUG_PVX_MODE
    static final String
    P_DOSTYLECHECK
    static final String
    P_EDITOR_CODE_FOLDING
    static final String
    P_EDITOR_COMMENT_LABEL
    static final String
    P_EDITOR_COMMENTS_BACKCOLOR
    static final String
    P_EDITOR_COMMENTS_BOLD
    static final String
    P_EDITOR_COMMENTS_COLOR
    static final String
    P_EDITOR_COMMENTS_ITALIC
    static final String
    P_EDITOR_COMMENTS_STRIKETHROUGH
    static final String
    P_EDITOR_COMMENTS_UNDERLINE
    static final String
    P_EDITOR_DIRECTIVE_LABEL
    static final String
    P_EDITOR_DIRECTIVES_BACKCOLOR
    static final String
    P_EDITOR_DIRECTIVES_BOLD
    static final String
    P_EDITOR_DIRECTIVES_COLOR
    static final String
    P_EDITOR_DIRECTIVES_ITALIC
    static final String
    P_EDITOR_DIRECTIVES_STRIKETHROUGH
    static final String
    P_EDITOR_DIRECTIVES_UNDERLINE
    static final String
    P_EDITOR_LINELABEL_LABEL
    static final String
    P_EDITOR_LINELABELS_BACKCOLOR
    static final String
    P_EDITOR_LINELABELS_BOLD
    static final String
    P_EDITOR_LINELABELS_COLOR
    static final String
    P_EDITOR_LINELABELS_ITALIC
    static final String
    P_EDITOR_LINELABELS_STRIKETHROUGH
    static final String
    P_EDITOR_LINELABELS_UNDERLINE
    static final String
    P_EDITOR_LITERALS_BACKCOLOR
    static final String
    P_EDITOR_LITERALS_BOLD
    static final String
    P_EDITOR_LITERALS_COLOR
    static final String
    P_EDITOR_LITERALS_ITALIC
    static final String
    P_EDITOR_LITERALS_LABEL
    static final String
    P_EDITOR_LITERALS_STRIKETHROUGH
    static final String
    P_EDITOR_LITERALS_UNDERLINE
    static final String
    P_EDITOR_MNEMONICS_BACKCOLOR
    static final String
    P_EDITOR_MNEMONICS_BOLD
    static final String
    P_EDITOR_MNEMONICS_COLOR
    static final String
    P_EDITOR_MNEMONICS_ITALIC
    static final String
    P_EDITOR_MNEMONICS_LABEL
    static final String
    P_EDITOR_MNEMONICS_STRIKETHROUGH
    static final String
    P_EDITOR_MNEMONICS_UNDERLINE
    static final String
    P_EDITOR_OPERATORS_BACKCOLOR
    static final String
    P_EDITOR_OPERATORS_BOLD
    static final String
    P_EDITOR_OPERATORS_COLOR
    static final String
    P_EDITOR_OPERATORS_ITALIC
    static final String
    P_EDITOR_OPERATORS_LABEL
    static final String
    P_EDITOR_OPERATORS_STRIKETHROUGH
    static final String
    P_EDITOR_OPERATORS_UNDERLINE
    static final String
    P_EDITOR_SMART_BRACES
    static final String
    P_EDITOR_SMART_INDENT
    static final String
    P_EDITOR_SMART_PASTE
    static final String
    P_EDITOR_SYSFUNCTIONS_BACKCOLOR
    static final String
    P_EDITOR_SYSFUNCTIONS_BOLD
    static final String
    P_EDITOR_SYSFUNCTIONS_COLOR
    static final String
    P_EDITOR_SYSFUNCTIONS_ITALIC
    static final String
    P_EDITOR_SYSFUNCTIONS_STRIKETHROUGH
    static final String
    P_EDITOR_SYSFUNCTIONS_UNDERLINE
    static final String
    P_EDITOR_SYSTEM_FUNCTIONS_LABEL
    static final String
    P_EDITOR_SYSTEM_VARIABLES_LABEL
    static final String
    P_EDITOR_SYSVARIABLES_BACKCOLOR
    static final String
    P_EDITOR_SYSVARIABLES_BOLD
    static final String
    P_EDITOR_SYSVARIABLES_COLOR
    static final String
    P_EDITOR_SYSVARIABLES_ITALIC
    static final String
    P_EDITOR_SYSVARIABLES_STRIKETHROUGH
    static final String
    P_EDITOR_SYSVARIABLES_UNDERLINE
    static final String
    P_EVENT_SOURCEFILE
    static final String
    P_IMPORT_SRCFILE_EXTENSION
    static final String
    P_IMPORT_STRIP_LINE_LABEL_PREFIX
    static final String
    P_IMPORT_STRIP_LINE_NO
    static final String
    P_IMPORT_STRIP_LINE_USE_ORIG_NO
    static final String
    P_ISCHECKING_FILE_EXTIONS
    static final String
    P_ISLINE_NUMBS_REQUIRED
    static final String
    P_ISPVXDATA
    static final String
    P_ISRESOURCE
    static final String
    P_OUTPUT_FILE_NAME
    static final String
    P_OWNERCODE
    static final String
    P_OWNERCODEFLAGS
    static final String
    P_PASSWORD
    static final String
    P_PATH
    static final String
    P_PROGRAM_CONVERT
    static final String
    P_PROJECT_OUTPUT_DIRECTORY
    static final String
    P_PROJECT_OUTPUT_LINK_DIRECTORY
    static final String
    P_PROJECT_SRC_DIRECTORY
    static final String
    P_PROJECT_SRC_LINK_DIRECTORY
    static final String
    P_STRING
    static final String
    P_TESTFOLDER_LIST
    static final String
    P_XML_EXPORT
    static final String
    PLUGIN_VERSION
    static final String
    PROPERTY_FILE_KEY_BUILDLOG
    static final String
    PROPERTY_FILE_KEY_BUILDTYPE
    static final String
    PROPERTY_FILE_KEY_DEST
    static final String
    PROPERTY_FILE_KEY_DOMFILE
    static final String
    PROPERTY_FILE_KEY_ERRORSCANNER
    static final String
    PROPERTY_FILE_KEY_FLAGS
    static final String
    PROPERTY_FILE_KEY_LOCKFILE
    static final String
    PROPERTY_FILE_KEY_OWNERCODE
    static final String
    PROPERTY_FILE_KEY_PASSWORD
    static final String
    PROPERTY_FILE_KEY_SRCFILE
    static final String
    PROPERTY_NOT_SET
    static final ArrayList<String>
    RESOURCE_PROPERTIES_LIST
    static final String
    STYLE_BOLD
    static final String
    STYLE_ITALIC
    static final String
    STYLE_NONE
    static final String
    U_NOMADS_ALTEXE
    static final String
    U_NOMADS_ALTINI
    static final String
    U_NOMADS_EXTIMAGEDIR

  • Constructor Summary

    Constructors
    Constructor
    Description
    PreferenceConstants()

  • Method Summary

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Field Details

    • LIST_OF_PROPERITES

      public static String LIST_OF_PROPERITES

    • PLUGIN_VERSION

      public static final String PLUGIN_VERSION
      See Also:
      • Constant Field Values

    • BUILD_PROPERTY_FILE_NAME

      public static final String BUILD_PROPERTY_FILE_NAME
      See Also:
      • Constant Field Values

    • BUILD_PROPERTY_FILE_PATH

      public static final String BUILD_PROPERTY_FILE_PATH
      See Also:
      • Constant Field Values

    • PROPERTY_NOT_SET

      public static final String PROPERTY_NOT_SET
      See Also:
      • Constant Field Values

    • BUILDTYPE_ALL

      public static final String BUILDTYPE_ALL
      See Also:
      • Constant Field Values

    • BUILDTYPE_CONVERT

      public static final String BUILDTYPE_CONVERT
      See Also:
      • Constant Field Values

    • BUILDTYPE_BUILDONE

      public static final String BUILDTYPE_BUILDONE
      See Also:
      • Constant Field Values

    • BUILDTYPE_SOURCE_FORMAT

      public static final String BUILDTYPE_SOURCE_FORMAT
      See Also:
      • Constant Field Values

    • BUILDTYPE_NOMADSLIB

      public static final String BUILDTYPE_NOMADSLIB
      See Also:
      • Constant Field Values

    • BUILDTYPE_DATAFILE

      public static final String BUILDTYPE_DATAFILE
      See Also:
      • Constant Field Values

    • BUILDTYPE_OTHERFILE

      public static final String BUILDTYPE_OTHERFILE
      See Also:
      • Constant Field Values

    • BUILDTYPE_SKIPFILE

      public static final String BUILDTYPE_SKIPFILE
      See Also:
      • Constant Field Values

    • PROPERTY_FILE_KEY_BUILDTYPE

      public static final String PROPERTY_FILE_KEY_BUILDTYPE
      See Also:
      • Constant Field Values

    • PROPERTY_FILE_KEY_DOMFILE

      public static final String PROPERTY_FILE_KEY_DOMFILE
      See Also:
      • Constant Field Values

    • PROPERTY_FILE_KEY_SRCFILE

      public static final String PROPERTY_FILE_KEY_SRCFILE
      See Also:
      • Constant Field Values

    • PROPERTY_FILE_KEY_LOCKFILE

      public static final String PROPERTY_FILE_KEY_LOCKFILE
      See Also:
      • Constant Field Values

    • PROPERTY_FILE_KEY_DEST

      public static final String PROPERTY_FILE_KEY_DEST
      See Also:
      • Constant Field Values

    • PROPERTY_FILE_KEY_BUILDLOG

      public static final String PROPERTY_FILE_KEY_BUILDLOG
      See Also:
      • Constant Field Values

    • PROPERTY_FILE_KEY_PASSWORD

      public static final String PROPERTY_FILE_KEY_PASSWORD
      See Also:
      • Constant Field Values

    • PROPERTY_FILE_KEY_OWNERCODE

      public static final String PROPERTY_FILE_KEY_OWNERCODE
      See Also:
      • Constant Field Values

    • PROPERTY_FILE_KEY_FLAGS

      public static final String PROPERTY_FILE_KEY_FLAGS
      See Also:
      • Constant Field Values

    • PROPERTY_FILE_KEY_ERRORSCANNER

      public static final String PROPERTY_FILE_KEY_ERRORSCANNER
      See Also:
      • Constant Field Values

    • P_OUTPUT_FILE_NAME

      public static final String P_OUTPUT_FILE_NAME
      See Also:
      • Constant Field Values

    • P_PROJECT_OUTPUT_LINK_DIRECTORY

      public static final String P_PROJECT_OUTPUT_LINK_DIRECTORY
      See Also:
      • Constant Field Values

    • P_PROJECT_SRC_LINK_DIRECTORY

      public static final String P_PROJECT_SRC_LINK_DIRECTORY
      See Also:
      • Constant Field Values

    • P_PROJECT_SRC_DIRECTORY

      public static final String P_PROJECT_SRC_DIRECTORY
      See Also:
      • Constant Field Values

    • P_PROJECT_OUTPUT_DIRECTORY

      public static final String P_PROJECT_OUTPUT_DIRECTORY
      See Also:
      • Constant Field Values

    • P_PATH

      public static final String P_PATH
      See Also:
      • Constant Field Values

    • P_PASSWORD

      public static final String P_PASSWORD
      See Also:
      • Constant Field Values

    • P_ISRESOURCE

      public static final String P_ISRESOURCE
      See Also:
      • Constant Field Values

    • P_PROGRAM_CONVERT

      public static final String P_PROGRAM_CONVERT
      See Also:
      • Constant Field Values

    • P_ISLINE_NUMBS_REQUIRED

      public static final String P_ISLINE_NUMBS_REQUIRED
      See Also:
      • Constant Field Values

    • P_ISPVXDATA

      public static final String P_ISPVXDATA
      See Also:
      • Constant Field Values

    • P_XML_EXPORT

      public static final String P_XML_EXPORT
      See Also:
      • Constant Field Values

    • P_OWNERCODE

      public static final String P_OWNERCODE
      See Also:
      • Constant Field Values

    • P_OWNERCODEFLAGS

      public static final String P_OWNERCODEFLAGS
      See Also:
      • Constant Field Values

    • P_TESTFOLDER_LIST

      public static final String P_TESTFOLDER_LIST
      See Also:
      • Constant Field Values

    • P_BUILD_RESOURCES

      public static final String P_BUILD_RESOURCES
      See Also:
      • Constant Field Values

    • P_BUILD_DATAFILES

      public static final String P_BUILD_DATAFILES
      See Also:
      • Constant Field Values

    • P_BUILD_FILES_NO_EXT

      public static final String P_BUILD_FILES_NO_EXT
      See Also:
      • Constant Field Values

    • P_EVENT_SOURCEFILE

      public static final String P_EVENT_SOURCEFILE
      See Also:
      • Constant Field Values

    • _UNDERLINE

      public static final String _UNDERLINE
      See Also:
      • Constant Field Values

    • _STRIKETHROUGH

      public static final String _STRIKETHROUGH
      See Also:
      • Constant Field Values

    • _BACKCOLOR

      public static final String _BACKCOLOR
      See Also:
      • Constant Field Values

    • _COLOR

      public static final String _COLOR
      See Also:
      • Constant Field Values

    • _ITALIC

      public static final String _ITALIC
      See Also:
      • Constant Field Values

    • _BOLD

      public static final String _BOLD
      See Also:
      • Constant Field Values

    • _IS_SET

      public static final String _IS_SET
      See Also:
      • Constant Field Values

    • RESOURCE_PROPERTIES_LIST

      public static final ArrayList<String> RESOURCE_PROPERTIES_LIST

    • IS_ADD_EXT_TO_ALL

      public static final String IS_ADD_EXT_TO_ALL
      See Also:
      • Constant Field Values

    • P_IMPORT_STRIP_LINE_NO

      public static final String P_IMPORT_STRIP_LINE_NO
      See Also:
      • Constant Field Values

    • P_IMPORT_STRIP_LINE_LABEL_PREFIX

      public static final String P_IMPORT_STRIP_LINE_LABEL_PREFIX
      See Also:
      • Constant Field Values

    • P_IMPORT_STRIP_LINE_USE_ORIG_NO

      public static final String P_IMPORT_STRIP_LINE_USE_ORIG_NO
      See Also:
      • Constant Field Values

    • P_IMPORT_SRCFILE_EXTENSION

      public static final String P_IMPORT_SRCFILE_EXTENSION
      See Also:
      • Constant Field Values

    • P_DEBUG_PVX_MODE

      public static final String P_DEBUG_PVX_MODE
      See Also:
      • Constant Field Values

    • U_NOMADS_ALTEXE

      public static final String U_NOMADS_ALTEXE
      See Also:
      • Constant Field Values

    • U_NOMADS_ALTINI

      public static final String U_NOMADS_ALTINI
      See Also:
      • Constant Field Values

    • U_NOMADS_EXTIMAGEDIR

      public static final String U_NOMADS_EXTIMAGEDIR
      See Also:
      • Constant Field Values

    • P_DOSTYLECHECK

      public static final String P_DOSTYLECHECK
      See Also:
      • Constant Field Values

    • P_CHOICE

      public static final String P_CHOICE
      See Also:
      • Constant Field Values

    • P_CODECHECKER

      public static final String P_CODECHECKER
      See Also:
      • Constant Field Values

    • P_ISCHECKING_FILE_EXTIONS

      public static final String P_ISCHECKING_FILE_EXTIONS
      See Also:
      • Constant Field Values

    • STYLE_NONE

      public static final String STYLE_NONE
      See Also:
      • Constant Field Values

    • STYLE_BOLD

      public static final String STYLE_BOLD
      See Also:
      • Constant Field Values

    • STYLE_ITALIC

      public static final String STYLE_ITALIC
      See Also:
      • Constant Field Values

    • P_EDITOR_CODE_FOLDING

      public static final String P_EDITOR_CODE_FOLDING
      See Also:
      • Constant Field Values

    • P_EDITOR_SMART_INDENT

      public static final String P_EDITOR_SMART_INDENT
      See Also:
      • Constant Field Values

    • P_EDITOR_SMART_PASTE

      public static final String P_EDITOR_SMART_PASTE
      See Also:
      • Constant Field Values

    • P_EDITOR_SMART_BRACES

      public static final String P_EDITOR_SMART_BRACES
      See Also:
      • Constant Field Values

    • P_EDITOR_DIRECTIVE_LABEL

      public static final String P_EDITOR_DIRECTIVE_LABEL
      See Also:
      • Constant Field Values

    • P_EDITOR_COMMENT_LABEL

      public static final String P_EDITOR_COMMENT_LABEL
      See Also:
      • Constant Field Values

    • P_EDITOR_LINELABEL_LABEL

      public static final String P_EDITOR_LINELABEL_LABEL
      See Also:
      • Constant Field Values

    • P_EDITOR_LITERALS_LABEL

      public static final String P_EDITOR_LITERALS_LABEL
      See Also:
      • Constant Field Values

    • P_EDITOR_MNEMONICS_LABEL

      public static final String P_EDITOR_MNEMONICS_LABEL
      See Also:
      • Constant Field Values

    • P_EDITOR_OPERATORS_LABEL

      public static final String P_EDITOR_OPERATORS_LABEL
      See Also:
      • Constant Field Values

    • P_EDITOR_SYSTEM_FUNCTIONS_LABEL

      public static final String P_EDITOR_SYSTEM_FUNCTIONS_LABEL
      See Also:
      • Constant Field Values

    • P_EDITOR_SYSTEM_VARIABLES_LABEL

      public static final String P_EDITOR_SYSTEM_VARIABLES_LABEL
      See Also:
      • Constant Field Values

    • P_EDITOR_COMMENTS_COLOR

      public static final String P_EDITOR_COMMENTS_COLOR
      See Also:
      • Constant Field Values

    • P_EDITOR_COMMENTS_BACKCOLOR

      public static final String P_EDITOR_COMMENTS_BACKCOLOR
      See Also:
      • Constant Field Values

    • P_EDITOR_COMMENTS_BOLD

      public static final String P_EDITOR_COMMENTS_BOLD
      See Also:
      • Constant Field Values

    • P_EDITOR_COMMENTS_ITALIC

      public static final String P_EDITOR_COMMENTS_ITALIC
      See Also:
      • Constant Field Values

    • P_EDITOR_COMMENTS_STRIKETHROUGH

      public static final String P_EDITOR_COMMENTS_STRIKETHROUGH
      See Also:
      • Constant Field Values

    • P_EDITOR_COMMENTS_UNDERLINE

      public static final String P_EDITOR_COMMENTS_UNDERLINE
      See Also:
      • Constant Field Values

    • P_EDITOR_DIRECTIVES_COLOR

      public static final String P_EDITOR_DIRECTIVES_COLOR
      See Also:
      • Constant Field Values

    • P_EDITOR_DIRECTIVES_BACKCOLOR

      public static final String P_EDITOR_DIRECTIVES_BACKCOLOR
      See Also:
      • Constant Field Values

    • P_EDITOR_DIRECTIVES_BOLD

      public static final String P_EDITOR_DIRECTIVES_BOLD
      See Also:
      • Constant Field Values

    • P_EDITOR_DIRECTIVES_ITALIC

      public static final String P_EDITOR_DIRECTIVES_ITALIC
      See Also:
      • Constant Field Values

    • P_EDITOR_DIRECTIVES_STRIKETHROUGH

      public static final String P_EDITOR_DIRECTIVES_STRIKETHROUGH
      See Also:
      • Constant Field Values

    • P_EDITOR_DIRECTIVES_UNDERLINE

      public static final String P_EDITOR_DIRECTIVES_UNDERLINE
      See Also:
      • Constant Field Values

    • P_EDITOR_LINELABELS_COLOR

      public static final String P_EDITOR_LINELABELS_COLOR
      See Also:
      • Constant Field Values

    • P_EDITOR_LINELABELS_BACKCOLOR

      public static final String P_EDITOR_LINELABELS_BACKCOLOR
      See Also:
      • Constant Field Values

    • P_EDITOR_LINELABELS_BOLD

      public static final String P_EDITOR_LINELABELS_BOLD
      See Also:
      • Constant Field Values

    • P_EDITOR_LINELABELS_ITALIC

      public static final String P_EDITOR_LINELABELS_ITALIC
      See Also:
      • Constant Field Values

    • P_EDITOR_LINELABELS_STRIKETHROUGH

      public static final String P_EDITOR_LINELABELS_STRIKETHROUGH
      See Also:
      • Constant Field Values

    • P_EDITOR_LINELABELS_UNDERLINE

      public static final String P_EDITOR_LINELABELS_UNDERLINE
      See Also:
      • Constant Field Values

    • P_EDITOR_LITERALS_BACKCOLOR

      public static final String P_EDITOR_LITERALS_BACKCOLOR
      See Also:
      • Constant Field Values

    • P_EDITOR_LITERALS_COLOR

      public static final String P_EDITOR_LITERALS_COLOR
      See Also:
      • Constant Field Values

    • P_EDITOR_LITERALS_BOLD

      public static final String P_EDITOR_LITERALS_BOLD
      See Also:
      • Constant Field Values

    • P_EDITOR_LITERALS_ITALIC

      public static final String P_EDITOR_LITERALS_ITALIC
      See Also:
      • Constant Field Values

    • P_EDITOR_LITERALS_STRIKETHROUGH

      public static final String P_EDITOR_LITERALS_STRIKETHROUGH
      See Also:
      • Constant Field Values

    • P_EDITOR_LITERALS_UNDERLINE

      public static final String P_EDITOR_LITERALS_UNDERLINE
      See Also:
      • Constant Field Values

    • P_EDITOR_MNEMONICS_COLOR

      public static final String P_EDITOR_MNEMONICS_COLOR
      See Also:
      • Constant Field Values

    • P_EDITOR_MNEMONICS_BACKCOLOR

      public static final String P_EDITOR_MNEMONICS_BACKCOLOR
      See Also:
      • Constant Field Values

    • P_EDITOR_MNEMONICS_BOLD

      public static final String P_EDITOR_MNEMONICS_BOLD
      See Also:
      • Constant Field Values

    • P_EDITOR_MNEMONICS_ITALIC

      public static final String P_EDITOR_MNEMONICS_ITALIC
      See Also:
      • Constant Field Values

    • P_EDITOR_MNEMONICS_STRIKETHROUGH

      public static final String P_EDITOR_MNEMONICS_STRIKETHROUGH
      See Also:
      • Constant Field Values

    • P_EDITOR_MNEMONICS_UNDERLINE

      public static final String P_EDITOR_MNEMONICS_UNDERLINE
      See Also:
      • Constant Field Values

    • P_EDITOR_OPERATORS_COLOR

      public static final String P_EDITOR_OPERATORS_COLOR
      See Also:
      • Constant Field Values

    • P_EDITOR_OPERATORS_BACKCOLOR

      public static final String P_EDITOR_OPERATORS_BACKCOLOR
      See Also:
      • Constant Field Values

    • P_EDITOR_OPERATORS_BOLD

      public static final String P_EDITOR_OPERATORS_BOLD
      See Also:
      • Constant Field Values

    • P_EDITOR_OPERATORS_ITALIC

      public static final String P_EDITOR_OPERATORS_ITALIC
      See Also:
      • Constant Field Values

    • P_EDITOR_OPERATORS_STRIKETHROUGH

      public static final String P_EDITOR_OPERATORS_STRIKETHROUGH
      See Also:
      • Constant Field Values

    • P_EDITOR_OPERATORS_UNDERLINE

      public static final String P_EDITOR_OPERATORS_UNDERLINE
      See Also:
      • Constant Field Values

    • P_EDITOR_SYSFUNCTIONS_COLOR

      public static final String P_EDITOR_SYSFUNCTIONS_COLOR
      See Also:
      • Constant Field Values

    • P_EDITOR_SYSFUNCTIONS_BACKCOLOR

      public static final String P_EDITOR_SYSFUNCTIONS_BACKCOLOR
      See Also:
      • Constant Field Values

    • P_EDITOR_SYSFUNCTIONS_BOLD

      public static final String P_EDITOR_SYSFUNCTIONS_BOLD
      See Also:
      • Constant Field Values

    • P_EDITOR_SYSFUNCTIONS_ITALIC

      public static final String P_EDITOR_SYSFUNCTIONS_ITALIC
      See Also:
      • Constant Field Values

    • P_EDITOR_SYSFUNCTIONS_STRIKETHROUGH

      public static final String P_EDITOR_SYSFUNCTIONS_STRIKETHROUGH
      See Also:
      • Constant Field Values

    • P_EDITOR_SYSFUNCTIONS_UNDERLINE

      public static final String P_EDITOR_SYSFUNCTIONS_UNDERLINE
      See Also:
      • Constant Field Values

    • P_EDITOR_SYSVARIABLES_COLOR

      public static final String P_EDITOR_SYSVARIABLES_COLOR
      See Also:
      • Constant Field Values

    • P_EDITOR_SYSVARIABLES_BACKCOLOR

      public static final String P_EDITOR_SYSVARIABLES_BACKCOLOR
      See Also:
      • Constant Field Values

    • P_EDITOR_SYSVARIABLES_BOLD

      public static final String P_EDITOR_SYSVARIABLES_BOLD
      See Also:
      • Constant Field Values

    • P_EDITOR_SYSVARIABLES_ITALIC

      public static final String P_EDITOR_SYSVARIABLES_ITALIC
      See Also:
      • Constant Field Values

    • P_EDITOR_SYSVARIABLES_STRIKETHROUGH

      public static final String P_EDITOR_SYSVARIABLES_STRIKETHROUGH
      See Also:
      • Constant Field Values

    • P_EDITOR_SYSVARIABLES_UNDERLINE

      public static final String P_EDITOR_SYSVARIABLES_UNDERLINE
      See Also:
      • Constant Field Values

    • keywordPrefList

      public static final EditorSyntaxColorPref[] keywordPrefList

    • P_BOOLEAN

      public static final String P_BOOLEAN
      See Also:
      • Constant Field Values

    • P_STRING

      public static final String P_STRING
      See Also:
      • Constant Field Values

  • Constructor Details

    • PreferenceConstants

      public PreferenceConstants()


PreferenceInitializer

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.preferences

Class PreferenceInitializer

java.lang.Object
org.eclipse.core.runtime.preferences.AbstractPreferenceInitializer
com.pvx.ooadide.preferences.PreferenceInitializer
public class PreferenceInitializer extends org.eclipse.core.runtime.preferences.AbstractPreferenceInitializer
Class used to initialize default preference values.

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static PreferenceInitializer
    thisInitializer
    static final org.eclipse.swt.graphics.RGB
    WHITE

  • Constructor Summary

    Constructors
    Constructor
    Description
    PreferenceInitializer()

  • Method Summary

    Modifier and Type
    Method
    Description
    static PreferenceInitializer
    getPreferenceInitializer()
    void
    initializeDefaultPreferences()

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Field Details

    • thisInitializer

      public static PreferenceInitializer thisInitializer

    • WHITE

      public static final org.eclipse.swt.graphics.RGB WHITE

  • Constructor Details

    • PreferenceInitializer

      public PreferenceInitializer()

  • Method Details

    • getPreferenceInitializer

      public static PreferenceInitializer getPreferenceInitializer()

    • initializeDefaultPreferences

      public void initializeDefaultPreferences()
      Specified by:
      initializeDefaultPreferences in class org.eclipse.core.runtime.preferences.AbstractPreferenceInitializer


PreferenceManager

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.preferences

Class PreferenceManager

java.lang.Object
com.pvx.ooadide.preferences.PreferenceManager
public class PreferenceManager extends Object

  • Constructor Summary

    Constructors
    Constructor
    Description
    PreferenceManager()

  • Method Summary

    Modifier and Type
    Method
    Description
    static String
    getBoolean(String name)
    static String
    getDefaultBoolean(String name)
    static String
    getDefaultString(String name)
    static String
    getString(String name)
    static String
    hasPreference(String name)
    static void
    setBoolean(String name, String value)
    static void
    setDefaultBoolean(String name, String value)
    static void
    setDefaultString(String name, String value)
    static void
    setString(String name, String value)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • PreferenceManager

      public PreferenceManager()

  • Method Details

    • hasPreference

      public static String hasPreference(String name)

    • getBoolean

      public static String getBoolean(String name)

    • getDefaultBoolean

      public static String getDefaultBoolean(String name)

    • getString

      public static String getString(String name)

    • getDefaultString

      public static String getDefaultString(String name)

    • setString

      public static void setString(String name, String value)

    • setDefaultString

      public static void setDefaultString(String name, String value)

    • setBoolean

      public static void setBoolean(String name, String value)

    • setDefaultBoolean

      public static void setDefaultBoolean(String name, String value)


PrefPageVistor

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.preferences

Class PrefPageVistor

java.lang.Object
com.pvx.ooadide.preferences.PrefPageVistor
public class PrefPageVistor extends Object

  • Constructor Summary

    Constructors
    Constructor
    Description
    PrefPageVistor()

  • Method Summary

    Modifier and Type
    Method
    Description
    static void
    addFieldToPage(String id, PvxPrefVisitee page)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • PrefPageVistor

      public PrefPageVistor()

  • Method Details

    • addFieldToPage

      public static void addFieldToPage(String id, PvxPrefVisitee page)


ProvideXPreferencePage

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.preferences

Class ProvideXPreferencePage

java.lang.Object
org.eclipse.jface.dialogs.DialogPage
org.eclipse.jface.preference.PreferencePage
org.eclipse.jface.preference.FieldEditorPreferencePage
com.pvx.ooadide.preferences.AbstractProvideXFieldEditorPrefPage
com.pvx.ooadide.preferences.ProvideXPreferencePage
All Implemented Interfaces:
PvxPrefVisitee, EventListener, org.eclipse.jface.dialogs.IDialogPage, org.eclipse.jface.dialogs.IMessageProvider, org.eclipse.jface.preference.IPreferencePage, org.eclipse.jface.util.IPropertyChangeListener, org.eclipse.ui.IWorkbenchPreferencePage
public class ProvideXPreferencePage extends AbstractProvideXFieldEditorPrefPage implements org.eclipse.ui.IWorkbenchPreferencePage
This class represents a preference page that is contributed to the Preferences dialog. By subclassing FieldEditorPreferencePage, we can use the field support built into JFace that allows us to create a page that is small and knows how to save, restore and apply itself.

This page is used to modify preferences only. They are stored in the preference store that belongs to the main plug-in class. That way, preferences can be accessed directly via the preference store.

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final String
    ID

    Fields inherited from class org.eclipse.jface.preference.FieldEditorPreferencePage

    FLAT, GRID

    Fields inherited from interface org.eclipse.jface.dialogs.IMessageProvider

    ERROR, INFORMATION, NONE, WARNING

  • Constructor Summary

    Constructors
    Constructor
    Description
    ProvideXPreferencePage()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    createFieldEditors()
    Creates the field editors.
    String
    getID()
    void
    init(org.eclipse.ui.IWorkbench workbench)
    boolean
    performOk()
    void
    propertyChange(org.eclipse.jface.util.PropertyChangeEvent event)

    Methods inherited from class com.pvx.ooadide.preferences.AbstractProvideXFieldEditorPrefPage

    addToDependencies, isValid, performCancel, visit

    Methods inherited from class org.eclipse.jface.preference.FieldEditorPreferencePage

    dispose, setVisible

    Methods inherited from class org.eclipse.jface.preference.PreferencePage

    applyData, computeSize, createControl, getContainer, getPreferenceStore, okToLeave, performHelp, setContainer, setErrorMessage, setMessage, setPreferenceStore, setSize, setTitle, setValid, toString

    Methods inherited from class org.eclipse.jface.dialogs.DialogPage

    getControl, getDescription, getErrorMessage, getImage, getMessage, getMessageType, getShell, getTitle, setDescription, setImageDescriptor, setMessage

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

    Methods inherited from interface org.eclipse.jface.dialogs.IDialogPage

    createControl, dispose, getControl, getDescription, getErrorMessage, getImage, getMessage, getTitle, performHelp, setDescription, setImageDescriptor, setTitle, setVisible

    Methods inherited from interface org.eclipse.jface.preference.IPreferencePage

    computeSize, isValid, okToLeave, performCancel, setContainer, setSize

  • Field Details

    • ID

      public static final String ID
      See Also:
      • Constant Field Values

  • Constructor Details

    • ProvideXPreferencePage

      public ProvideXPreferencePage()

  • Method Details

    • createFieldEditors

      public void createFieldEditors()
      Creates the field editors. Field editors are abstractions of the common GUI blocks needed to manipulate various types of preferences. Each field editor knows how to save and restore itself.

    • propertyChange

      public void propertyChange(org.eclipse.jface.util.PropertyChangeEvent event)
      Specified by:
      propertyChange in interface org.eclipse.jface.util.IPropertyChangeListener
      Overrides:
      propertyChange in class AbstractProvideXFieldEditorPrefPage

    • getID

      public String getID()
      Specified by:
      getID in class AbstractProvideXFieldEditorPrefPage

    • init

      public void init(org.eclipse.ui.IWorkbench workbench)
      Specified by:
      init in interface org.eclipse.ui.IWorkbenchPreferencePage
      Overrides:
      init in class AbstractProvideXFieldEditorPrefPage

    • performOk

      public boolean performOk()
      Specified by:
      performOk in interface org.eclipse.jface.preference.IPreferencePage
      Overrides:
      performOk in class AbstractProvideXFieldEditorPrefPage


PvxListEditor

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.preferences

Class PvxListEditor

java.lang.Object
org.eclipse.jface.preference.FieldEditor
org.eclipse.jface.preference.ListEditor
com.pvx.ooadide.preferences.PvxListEditor
public class PvxListEditor extends org.eclipse.jface.preference.ListEditor

  • Field Summary

    Fields inherited from class org.eclipse.jface.preference.FieldEditor

    IS_VALID, VALUE

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxListEditor(String configKey, String displayName, org.eclipse.swt.widgets.Composite fieldEditorParent)

  • Method Summary

    Methods inherited from class org.eclipse.jface.preference.ListEditor

    createSelectionListener, getButtonBoxControl, getListControl, getNumberOfControls, setEnabled, setFocus

    Methods inherited from class org.eclipse.jface.preference.FieldEditor

    dispose, fillIntoGrid, getFieldEditorFontName, getLabelControl, getLabelText, getPreferenceName, getPreferenceStore, isValid, load, loadDefault, presentsDefaultValue, setLabelText, setPage, setPreferenceName, setPreferenceStore, setPropertyChangeListener, store

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • PvxListEditor

      public PvxListEditor(String configKey, String displayName, org.eclipse.swt.widgets.Composite fieldEditorParent)


PvxPrefVisitee

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.preferences

Interface PvxPrefVisitee

All Known Implementing Classes:
AbstractProvideXFieldEditorPrefPage, BuilderOptions, EditorOptions, EditorOptionsPrefPage, ImportOptionsPrefPage, NomadsPreferencePage, ObserversPreferencePage, ProvideXPreferencePage, UserDefinedPrefPage
public interface PvxPrefVisitee

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    visit(int dataType, String displayName, String configKey, boolean enable)

  • Method Details

    • visit

      void visit(int dataType, String displayName, String configKey, boolean enable)


SpacerFieldEditor

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.preferences

Class SpacerFieldEditor

java.lang.Object
org.eclipse.jface.preference.FieldEditor
com.pvx.ooadide.preferences.SpacerFieldEditor
public class SpacerFieldEditor extends org.eclipse.jface.preference.FieldEditor
A field editor for adding space to a preference page.

  • Field Summary

    Fields inherited from class org.eclipse.jface.preference.FieldEditor

    IS_VALID, VALUE

  • Constructor Summary

    Constructors
    Constructor
    Description
    SpacerFieldEditor(org.eclipse.swt.widgets.Composite parent)

  • Method Summary

    Modifier and Type
    Method
    Description
    int
    getNumberOfControls()

    Methods inherited from class org.eclipse.jface.preference.FieldEditor

    dispose, fillIntoGrid, getFieldEditorFontName, getLabelControl, getLabelText, getPreferenceName, getPreferenceStore, isValid, load, loadDefault, presentsDefaultValue, setEnabled, setFocus, setLabelText, setPage, setPreferenceName, setPreferenceStore, setPropertyChangeListener, store

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • SpacerFieldEditor

      public SpacerFieldEditor(org.eclipse.swt.widgets.Composite parent)

  • Method Details

    • getNumberOfControls

      public int getNumberOfControls()
      Specified by:
      getNumberOfControls in class org.eclipse.jface.preference.FieldEditor


UserDefinedPrefPage

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.preferences

Class UserDefinedPrefPage

java.lang.Object
org.eclipse.jface.dialogs.DialogPage
org.eclipse.jface.preference.PreferencePage
org.eclipse.jface.preference.FieldEditorPreferencePage
com.pvx.ooadide.preferences.AbstractProvideXFieldEditorPrefPage
com.pvx.ooadide.preferences.UserDefinedPrefPage
All Implemented Interfaces:
PvxPrefVisitee, EventListener, org.eclipse.jface.dialogs.IDialogPage, org.eclipse.jface.dialogs.IMessageProvider, org.eclipse.jface.preference.IPreferencePage, org.eclipse.jface.util.IPropertyChangeListener, org.eclipse.ui.IWorkbenchPreferencePage
public class UserDefinedPrefPage extends AbstractProvideXFieldEditorPrefPage

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final String
    ID

    Fields inherited from class org.eclipse.jface.preference.FieldEditorPreferencePage

    FLAT, GRID

    Fields inherited from interface org.eclipse.jface.dialogs.IMessageProvider

    ERROR, INFORMATION, NONE, WARNING

  • Constructor Summary

    Constructors
    Constructor
    Description
    UserDefinedPrefPage()

  • Method Summary

    Modifier and Type
    Method
    Description
    String
    getID()
    void
    propertyChange(org.eclipse.jface.util.PropertyChangeEvent event)

    Methods inherited from class com.pvx.ooadide.preferences.AbstractProvideXFieldEditorPrefPage

    addToDependencies, init, isValid, performCancel, performOk, visit

    Methods inherited from class org.eclipse.jface.preference.FieldEditorPreferencePage

    dispose, setVisible

    Methods inherited from class org.eclipse.jface.preference.PreferencePage

    applyData, computeSize, createControl, getContainer, getPreferenceStore, okToLeave, performHelp, setContainer, setErrorMessage, setMessage, setPreferenceStore, setSize, setTitle, setValid, toString

    Methods inherited from class org.eclipse.jface.dialogs.DialogPage

    getControl, getDescription, getErrorMessage, getImage, getMessage, getMessageType, getShell, getTitle, setDescription, setImageDescriptor, setMessage

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

    Methods inherited from interface org.eclipse.jface.dialogs.IDialogPage

    createControl, dispose, getControl, getDescription, getErrorMessage, getImage, getMessage, getTitle, performHelp, setDescription, setImageDescriptor, setTitle, setVisible

    Methods inherited from interface org.eclipse.jface.preference.IPreferencePage

    computeSize, okToLeave, setContainer, setSize

  • Field Details

    • ID

      public static final String ID
      See Also:
      • Constant Field Values

  • Constructor Details

    • UserDefinedPrefPage

      public UserDefinedPrefPage()

  • Method Details

    • getID

      public String getID()
      Specified by:
      getID in class AbstractProvideXFieldEditorPrefPage

    • propertyChange

      public void propertyChange(org.eclipse.jface.util.PropertyChangeEvent event)
      Specified by:
      propertyChange in interface org.eclipse.jface.util.IPropertyChangeListener
      Overrides:
      propertyChange in class AbstractProvideXFieldEditorPrefPage


UserDefinedSortedField

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.preferences

Class UserDefinedSortedField

java.lang.Object
com.pvx.ooadide.preferences.UserDefinedSortedField
All Implemented Interfaces:
Comparable
public class UserDefinedSortedField extends Object implements Comparable

  • Constructor Summary

    Constructors
    Constructor
    Description
    UserDefinedSortedField(String initKey, UserPrefElement initUserElemnt)

  • Method Summary

    Modifier and Type
    Method
    Description
    int
    compareTo(Object o)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • UserDefinedSortedField

      public UserDefinedSortedField(String initKey, UserPrefElement initUserElemnt)

  • Method Details

    • compareTo

      public int compareTo(Object o)
      Specified by:
      compareTo in interface Comparable


UserPrefElement

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.preferences

Class UserPrefElement

java.lang.Object
com.pvx.ooadide.preferences.UserPrefElement
public class UserPrefElement extends Object

  • Constructor Summary

    Constructors
    Constructor
    Description
    UserPrefElement(String cKey, int dType, String curVal, String defVal, String bAddList, String pageId, String dispName)
    UserPrefElement(String cKey, int dType, String curVal, String defVal, String bAddList, String pageId, String dispName, int initPos)

  • Method Summary

    Modifier and Type
    Method
    Description
    String
    getCurrentValue()
    int
    getDataType()
    String
    getDefaultValue()
    String
    getDisplayName()
    String
    getKey()
    String
    getPageToAdd()
    int
    getPosOnPage()
    boolean
    isEnabled()
    void
    setCurrentValue(String currentValue)
    void
    setDataType(int dataType)
    void
    setDefaultValue(String defaultValue)
    void
    setPageToAdd(String pageToAdd)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • UserPrefElement

      public UserPrefElement(String cKey, int dType, String curVal, String defVal, String bAddList, String pageId, String dispName, int initPos)

    • UserPrefElement

      public UserPrefElement(String cKey, int dType, String curVal, String defVal, String bAddList, String pageId, String dispName)

  • Method Details

    • setCurrentValue

      public void setCurrentValue(String currentValue)

    • getCurrentValue

      public String getCurrentValue()

    • setDefaultValue

      public void setDefaultValue(String defaultValue)

    • getDefaultValue

      public String getDefaultValue()

    • isEnabled

      public boolean isEnabled()

    • setPageToAdd

      public void setPageToAdd(String pageToAdd)

    • getPageToAdd

      public String getPageToAdd()

    • setDataType

      public void setDataType(int dataType)

    • getDataType

      public int getDataType()

    • getDisplayName

      public String getDisplayName()

    • getKey

      public String getKey()

    • getPosOnPage

      public int getPosOnPage()


Uses of Class com.pvx.ooadide.preferences.AbstractProvideXFieldEditorPrefPage

Uses of Class
com.pvx.ooadide.preferences.AbstractProvideXFieldEditorPrefPage

Packages that use AbstractProvideXFieldEditorPrefPage
Package
Description
com.pvx.ooadide.preferences
com.pvx.ooadide.preferences.nomads

  • Uses of AbstractProvideXFieldEditorPrefPage in com.pvx.ooadide.preferences

    Subclasses of AbstractProvideXFieldEditorPrefPage in com.pvx.ooadide.preferences
    Modifier and Type
    Class
    Description
    class
    BuilderOptions
    class
    EditorOptions
    This class represents a preference page that is contributed to the Preferences dialog.
    class
    EditorOptionsPrefPage
    class
    ImportOptionsPrefPage
    class
    ObserversPreferencePage
    class
    ProvideXPreferencePage
    This class represents a preference page that is contributed to the Preferences dialog.
    class
    UserDefinedPrefPage

  • Uses of AbstractProvideXFieldEditorPrefPage in com.pvx.ooadide.preferences.nomads

    Subclasses of AbstractProvideXFieldEditorPrefPage in com.pvx.ooadide.preferences.nomads
    Modifier and Type
    Class
    Description
    class
    NomadsPreferencePage


Uses of Class com.pvx.ooadide.preferences.BuilderOptions

Uses of Class
com.pvx.ooadide.preferences.BuilderOptions

No usage of com.pvx.ooadide.preferences.BuilderOptions


Uses of Class com.pvx.ooadide.preferences.EditorColorPreferencePage

Uses of Class
com.pvx.ooadide.preferences.EditorColorPreferencePage

No usage of com.pvx.ooadide.preferences.EditorColorPreferencePage


Uses of Class com.pvx.ooadide.preferences.EditorOptions

Uses of Class
com.pvx.ooadide.preferences.EditorOptions

No usage of com.pvx.ooadide.preferences.EditorOptions


Uses of Class com.pvx.ooadide.preferences.EditorOptionsPrefPage

Uses of Class
com.pvx.ooadide.preferences.EditorOptionsPrefPage

No usage of com.pvx.ooadide.preferences.EditorOptionsPrefPage


Uses of Class com.pvx.ooadide.preferences.EditorSyntaxColorPref

Uses of Class
com.pvx.ooadide.preferences.EditorSyntaxColorPref

Packages that use EditorSyntaxColorPref
Package
Description
com.pvx.ooadide.preferences

  • Uses of EditorSyntaxColorPref in com.pvx.ooadide.preferences

    Fields in com.pvx.ooadide.preferences declared as EditorSyntaxColorPref
    Modifier and Type
    Field
    Description
    static final EditorSyntaxColorPref[]
    PreferenceConstants.keywordPrefList


Uses of Class com.pvx.ooadide.preferences.ImportOptionsPrefPage

Uses of Class
com.pvx.ooadide.preferences.ImportOptionsPrefPage

No usage of com.pvx.ooadide.preferences.ImportOptionsPrefPage


Uses of Class com.pvx.ooadide.preferences.ObserversPreferencePage

Uses of Class
com.pvx.ooadide.preferences.ObserversPreferencePage

No usage of com.pvx.ooadide.preferences.ObserversPreferencePage


Uses of Class com.pvx.ooadide.preferences.PasswordPreferences

Uses of Class
com.pvx.ooadide.preferences.PasswordPreferences

No usage of com.pvx.ooadide.preferences.PasswordPreferences


Uses of Class com.pvx.ooadide.preferences.PreferenceConstants

Uses of Class
com.pvx.ooadide.preferences.PreferenceConstants

No usage of com.pvx.ooadide.preferences.PreferenceConstants


Uses of Class com.pvx.ooadide.preferences.PreferenceInitializer

Uses of Class
com.pvx.ooadide.preferences.PreferenceInitializer

Packages that use PreferenceInitializer
Package
Description
com.pvx.ooadide.preferences

  • Uses of PreferenceInitializer in com.pvx.ooadide.preferences

    Fields in com.pvx.ooadide.preferences declared as PreferenceInitializer
    Modifier and Type
    Field
    Description
    static PreferenceInitializer
    PreferenceInitializer.thisInitializer
    Methods in com.pvx.ooadide.preferences that return PreferenceInitializer
    Modifier and Type
    Method
    Description
    static PreferenceInitializer
    PreferenceInitializer.getPreferenceInitializer()


Uses of Class com.pvx.ooadide.preferences.PreferenceManager

Uses of Class
com.pvx.ooadide.preferences.PreferenceManager

No usage of com.pvx.ooadide.preferences.PreferenceManager


Uses of Class com.pvx.ooadide.preferences.PrefPageVistor

Uses of Class
com.pvx.ooadide.preferences.PrefPageVistor

No usage of com.pvx.ooadide.preferences.PrefPageVistor


Uses of Class com.pvx.ooadide.preferences.ProvideXPreferencePage

Uses of Class
com.pvx.ooadide.preferences.ProvideXPreferencePage

No usage of com.pvx.ooadide.preferences.ProvideXPreferencePage


Uses of Class com.pvx.ooadide.preferences.PvxListEditor

Uses of Class
com.pvx.ooadide.preferences.PvxListEditor

No usage of com.pvx.ooadide.preferences.PvxListEditor


Uses of Interface com.pvx.ooadide.preferences.PvxPrefVisitee

Uses of Interface
com.pvx.ooadide.preferences.PvxPrefVisitee

Packages that use PvxPrefVisitee
Package
Description
com.pvx.ooadide.preferences
com.pvx.ooadide.preferences.nomads

  • Uses of PvxPrefVisitee in com.pvx.ooadide.preferences

    Classes in com.pvx.ooadide.preferences that implement PvxPrefVisitee
    Modifier and Type
    Class
    Description
    class
    AbstractProvideXFieldEditorPrefPage
    class
    BuilderOptions
    class
    EditorOptions
    This class represents a preference page that is contributed to the Preferences dialog.
    class
    EditorOptionsPrefPage
    class
    ImportOptionsPrefPage
    class
    ObserversPreferencePage
    class
    ProvideXPreferencePage
    This class represents a preference page that is contributed to the Preferences dialog.
    class
    UserDefinedPrefPage
    Methods in com.pvx.ooadide.preferences with parameters of type PvxPrefVisitee
    Modifier and Type
    Method
    Description
    static void
    PrefPageVistor.addFieldToPage(String id, PvxPrefVisitee page)

  • Uses of PvxPrefVisitee in com.pvx.ooadide.preferences.nomads

    Classes in com.pvx.ooadide.preferences.nomads that implement PvxPrefVisitee
    Modifier and Type
    Class
    Description
    class
    NomadsPreferencePage


Uses of Class com.pvx.ooadide.preferences.SpacerFieldEditor

Uses of Class
com.pvx.ooadide.preferences.SpacerFieldEditor

No usage of com.pvx.ooadide.preferences.SpacerFieldEditor


Uses of Class com.pvx.ooadide.preferences.UserDefinedPrefPage

Uses of Class
com.pvx.ooadide.preferences.UserDefinedPrefPage

No usage of com.pvx.ooadide.preferences.UserDefinedPrefPage


Uses of Class com.pvx.ooadide.preferences.UserDefinedSortedField

Uses of Class
com.pvx.ooadide.preferences.UserDefinedSortedField

No usage of com.pvx.ooadide.preferences.UserDefinedSortedField


Uses of Class com.pvx.ooadide.preferences.UserPrefElement

Uses of Class
com.pvx.ooadide.preferences.UserPrefElement

Packages that use UserPrefElement
Package
Description
com.pvx.ooadide.preferences
com.pvx.ooadide.properties.userdefined

  • Uses of UserPrefElement in com.pvx.ooadide.preferences

    Constructors in com.pvx.ooadide.preferences with parameters of type UserPrefElement
    Modifier
    Constructor
    Description

    UserDefinedSortedField(String initKey, UserPrefElement initUserElemnt)

  • Uses of UserPrefElement in com.pvx.ooadide.properties.userdefined

    Methods in com.pvx.ooadide.properties.userdefined that return UserPrefElement
    Modifier and Type
    Method
    Description
    UserPrefElement
    UserDefinedPropField.getUserElemnt()
    Methods in com.pvx.ooadide.properties.userdefined with parameters of type UserPrefElement
    Modifier and Type
    Method
    Description
    void
    UserDefinedPropField.setUserElemnt(UserPrefElement userElemnt)
    Constructors in com.pvx.ooadide.properties.userdefined with parameters of type UserPrefElement
    Modifier
    Constructor
    Description

    UserDefinedPropField(UserPrefElement inituserElemnt, org.eclipse.swt.widgets.Widget initwidget)


NomadsPreferencePage

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.preferences.nomads

Class NomadsPreferencePage

java.lang.Object
org.eclipse.jface.dialogs.DialogPage
org.eclipse.jface.preference.PreferencePage
org.eclipse.jface.preference.FieldEditorPreferencePage
com.pvx.ooadide.preferences.AbstractProvideXFieldEditorPrefPage
com.pvx.ooadide.preferences.nomads.NomadsPreferencePage
All Implemented Interfaces:
PvxPrefVisitee, EventListener, org.eclipse.jface.dialogs.IDialogPage, org.eclipse.jface.dialogs.IMessageProvider, org.eclipse.jface.preference.IPreferencePage, org.eclipse.jface.util.IPropertyChangeListener, org.eclipse.ui.IWorkbenchPreferencePage
public class NomadsPreferencePage extends AbstractProvideXFieldEditorPrefPage

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final String
    ID

    Fields inherited from class org.eclipse.jface.preference.FieldEditorPreferencePage

    FLAT, GRID

    Fields inherited from interface org.eclipse.jface.dialogs.IMessageProvider

    ERROR, INFORMATION, NONE, WARNING

  • Constructor Summary

    Constructors
    Constructor
    Description
    NomadsPreferencePage()

  • Method Summary

    Modifier and Type
    Method
    Description
    String
    getID()
    boolean
    performOk()
    void
    propertyChange(org.eclipse.jface.util.PropertyChangeEvent event)

    Methods inherited from class com.pvx.ooadide.preferences.AbstractProvideXFieldEditorPrefPage

    addToDependencies, init, isValid, performCancel, visit

    Methods inherited from class org.eclipse.jface.preference.FieldEditorPreferencePage

    dispose, setVisible

    Methods inherited from class org.eclipse.jface.preference.PreferencePage

    applyData, computeSize, createControl, getContainer, getPreferenceStore, okToLeave, performHelp, setContainer, setErrorMessage, setMessage, setPreferenceStore, setSize, setTitle, setValid, toString

    Methods inherited from class org.eclipse.jface.dialogs.DialogPage

    getControl, getDescription, getErrorMessage, getImage, getMessage, getMessageType, getShell, getTitle, setDescription, setImageDescriptor, setMessage

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

    Methods inherited from interface org.eclipse.jface.dialogs.IDialogPage

    createControl, dispose, getControl, getDescription, getErrorMessage, getImage, getMessage, getTitle, performHelp, setDescription, setImageDescriptor, setTitle, setVisible

    Methods inherited from interface org.eclipse.jface.preference.IPreferencePage

    computeSize, okToLeave, setContainer, setSize

  • Field Details

    • ID

      public static final String ID
      See Also:
      • Constant Field Values

  • Constructor Details

    • NomadsPreferencePage

      public NomadsPreferencePage()

  • Method Details

    • getID

      public String getID()
      Specified by:
      getID in class AbstractProvideXFieldEditorPrefPage

    • propertyChange

      public void propertyChange(org.eclipse.jface.util.PropertyChangeEvent event)
      Specified by:
      propertyChange in interface org.eclipse.jface.util.IPropertyChangeListener
      Overrides:
      propertyChange in class AbstractProvideXFieldEditorPrefPage

    • performOk

      public boolean performOk()
      Specified by:
      performOk in interface org.eclipse.jface.preference.IPreferencePage
      Overrides:
      performOk in class AbstractProvideXFieldEditorPrefPage


com.pvx.ooadide.preferences.nomads

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.pvx.ooadide.preferences.nomads

package com.pvx.ooadide.preferences.nomads
  • Related Packages
    Package
    Description
    com.pvx.ooadide.preferences
  • Classes
    Class
    Description
    NomadsPreferencePage


com.pvx.ooadide.preferences.nomads Class Hierarchy

Hierarchy For Package com.pvx.ooadide.preferences.nomads

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.eclipse.jface.dialogs.DialogPage (implements org.eclipse.jface.dialogs.IDialogPage, org.eclipse.jface.dialogs.IMessageProvider)
      • org.eclipse.jface.preference.PreferencePage (implements org.eclipse.jface.preference.IPreferencePage)
        • org.eclipse.jface.preference.FieldEditorPreferencePage (implements org.eclipse.jface.util.IPropertyChangeListener)
          • com.pvx.ooadide.preferences.AbstractProvideXFieldEditorPrefPage (implements org.eclipse.ui.IWorkbenchPreferencePage, com.pvx.ooadide.preferences.PvxPrefVisitee)
            • com.pvx.ooadide.preferences.nomads.NomadsPreferencePage


Uses of Package com.pvx.ooadide.preferences.nomads

Uses of Package
com.pvx.ooadide.preferences.nomads

No usage of com.pvx.ooadide.preferences.nomads


Uses of Class com.pvx.ooadide.preferences.nomads.NomadsPreferencePage

Uses of Class
com.pvx.ooadide.preferences.nomads.NomadsPreferencePage

No usage of com.pvx.ooadide.preferences.nomads.NomadsPreferencePage


com.pvx.ooadide.properties

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.pvx.ooadide.properties

package com.pvx.ooadide.properties
  • Related Packages
    Package
    Description
    com.pvx.ooadide
    com.pvx.ooadide.properties.dialogs
    com.pvx.ooadide.properties.userdefined
  • Classes
    Class
    Description
    ProvideXPropertyPage
    PvxPropertySource
    ResourceToChangeEntity


com.pvx.ooadide.properties Class Hierarchy

Hierarchy For Package com.pvx.ooadide.properties

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.eclipse.jface.dialogs.DialogPage (implements org.eclipse.jface.dialogs.IDialogPage, org.eclipse.jface.dialogs.IMessageProvider)
      • org.eclipse.jface.preference.PreferencePage (implements org.eclipse.jface.preference.IPreferencePage)
        • org.eclipse.ui.dialogs.PropertyPage (implements org.eclipse.ui.IWorkbenchPropertyPage)
          • com.pvx.ooadide.properties.ProvideXPropertyPage
    • org.eclipse.ui.views.properties.ResourcePropertySource (implements org.eclipse.ui.views.properties.IPropertySource)
      • com.pvx.ooadide.properties.PvxPropertySource
    • com.pvx.ooadide.properties.ResourceToChangeEntity (implements org.eclipse.compare.IModificationDate, org.eclipse.compare.IStreamContentAccessor, org.eclipse.compare.ITypedElement)


Uses of Package com.pvx.ooadide.properties

Uses of Package
com.pvx.ooadide.properties

Packages that use com.pvx.ooadide.properties
Package
Description
com.pvx.ooadide.preferences
  • Classes in com.pvx.ooadide.properties used by com.pvx.ooadide.preferences
    Class
    Description
    ProvideXPropertyPage


ProvideXPropertyPage

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.properties

Class ProvideXPropertyPage

java.lang.Object
org.eclipse.jface.dialogs.DialogPage
org.eclipse.jface.preference.PreferencePage
org.eclipse.ui.dialogs.PropertyPage
com.pvx.ooadide.properties.ProvideXPropertyPage
All Implemented Interfaces:
org.eclipse.jface.dialogs.IDialogPage, org.eclipse.jface.dialogs.IMessageProvider, org.eclipse.jface.preference.IPreferencePage, org.eclipse.ui.IWorkbenchPropertyPage
Direct Known Subclasses:
PasswordPreferences
public class ProvideXPropertyPage extends org.eclipse.ui.dialogs.PropertyPage

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final String
    LINKED_DELIM
    static final String
    P_USER_FILE
    static final String
    P_USER_FOLDER
    static final String
    P_USER_NOMADSLIBS
    static final String
    P_USER_PROGRAMS
    static final String
    P_USER_PROJECT
    static final String
    P_USER_RESOURCE
    static final String
    QUALIFIED_ID

    Fields inherited from interface org.eclipse.jface.dialogs.IMessageProvider

    ERROR, INFORMATION, NONE, WARNING

  • Constructor Summary

    Constructors
    Constructor
    Description
    ProvideXPropertyPage()
    Constructor for SamplePropertyPage.

  • Method Summary

    Modifier and Type
    Method
    Description
    static void
    doApplyProp(org.eclipse.core.resources.IResource srcFile, String key, String value)
    static void
    doApplyProp(org.eclipse.core.resources.IResource srcFile, String key, String value, String passwordVal)
    static void
    doApplyProps(org.eclipse.core.resources.IResource srcFile, String ownerval, String flagval, String passwordval, String isResource, String builderval, String isLineNumbsRequired, String outputName)
    String
    getDefaultOutputName()
    static String
    getDefaultValue(String prop, org.eclipse.core.resources.IResource resr)
    static String
    getTestFolderList(ArrayList testFolderItems)
    static boolean
    isInInvalidList(org.eclipse.core.resources.IFile srcFile)
    boolean
    performOk()
    String
    removeFromHistory(String[] hist, String nwEntry)
    static void
    scanFolder(org.eclipse.core.resources.IFolder srcFolder, String ownerval, String flagval, String passwordval, String isResource, String builderval, String isLineNumbsReq, String outputName)

    Methods inherited from class org.eclipse.ui.dialogs.PropertyPage

    getElement, setElement

    Methods inherited from class org.eclipse.jface.preference.PreferencePage

    applyData, computeSize, createControl, getContainer, getPreferenceStore, isValid, okToLeave, performCancel, performHelp, setContainer, setErrorMessage, setMessage, setPreferenceStore, setSize, setTitle, setValid, toString

    Methods inherited from class org.eclipse.jface.dialogs.DialogPage

    dispose, getControl, getDescription, getErrorMessage, getImage, getMessage, getMessageType, getShell, getTitle, setDescription, setImageDescriptor, setMessage, setVisible

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

    Methods inherited from interface org.eclipse.jface.dialogs.IDialogPage

    createControl, dispose, getControl, getDescription, getErrorMessage, getImage, getMessage, getTitle, performHelp, setDescription, setImageDescriptor, setTitle, setVisible

    Methods inherited from interface org.eclipse.jface.preference.IPreferencePage

    computeSize, isValid, okToLeave, performCancel, setContainer, setSize

  • Field Details

    • QUALIFIED_ID

      public static final String QUALIFIED_ID
      See Also:
      • Constant Field Values

    • P_USER_RESOURCE

      public static final String P_USER_RESOURCE
      See Also:
      • Constant Field Values

    • P_USER_PROJECT

      public static final String P_USER_PROJECT
      See Also:
      • Constant Field Values

    • P_USER_FOLDER

      public static final String P_USER_FOLDER
      See Also:
      • Constant Field Values

    • P_USER_PROGRAMS

      public static final String P_USER_PROGRAMS
      See Also:
      • Constant Field Values

    • P_USER_NOMADSLIBS

      public static final String P_USER_NOMADSLIBS
      See Also:
      • Constant Field Values

    • P_USER_FILE

      public static final String P_USER_FILE
      See Also:
      • Constant Field Values

    • LINKED_DELIM

      public static final String LINKED_DELIM
      See Also:
      • Constant Field Values

  • Constructor Details

    • ProvideXPropertyPage

      public ProvideXPropertyPage()
      Constructor for SamplePropertyPage.

  • Method Details

    • removeFromHistory

      public String removeFromHistory(String[] hist, String nwEntry)

    • getDefaultOutputName

      public String getDefaultOutputName()

    • performOk

      public boolean performOk()
      Specified by:
      performOk in interface org.eclipse.jface.preference.IPreferencePage
      Overrides:
      performOk in class org.eclipse.jface.preference.PreferencePage

    • getTestFolderList

      public static String getTestFolderList(ArrayList testFolderItems)

    • doApplyProp

      public static void doApplyProp(org.eclipse.core.resources.IResource srcFile, String key, String value, String passwordVal) throws org.eclipse.core.runtime.CoreException
      Throws:
      org.eclipse.core.runtime.CoreException

    • doApplyProp

      public static void doApplyProp(org.eclipse.core.resources.IResource srcFile, String key, String value) throws org.eclipse.core.runtime.CoreException
      Throws:
      org.eclipse.core.runtime.CoreException

    • isInInvalidList

      public static boolean isInInvalidList(org.eclipse.core.resources.IFile srcFile)

    • doApplyProps

      public static void doApplyProps(org.eclipse.core.resources.IResource srcFile, String ownerval, String flagval, String passwordval, String isResource, String builderval, String isLineNumbsRequired, String outputName) throws org.eclipse.core.runtime.CoreException
      Throws:
      org.eclipse.core.runtime.CoreException

    • scanFolder

      public static void scanFolder(org.eclipse.core.resources.IFolder srcFolder, String ownerval, String flagval, String passwordval, String isResource, String builderval, String isLineNumbsReq, String outputName)

    • getDefaultValue

      public static String getDefaultValue(String prop, org.eclipse.core.resources.IResource resr)


PvxPropertySource

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.properties

Class PvxPropertySource

java.lang.Object
org.eclipse.ui.views.properties.ResourcePropertySource
com.pvx.ooadide.properties.PvxPropertySource
All Implemented Interfaces:
org.eclipse.ui.views.properties.IPropertySource
public class PvxPropertySource extends org.eclipse.ui.views.properties.ResourcePropertySource

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxPropertySource(org.eclipse.core.resources.IResource res)

  • Method Summary

    Methods inherited from class org.eclipse.ui.views.properties.ResourcePropertySource

    getEditableValue, getPropertyDescriptors, getPropertyValue, isPropertySet, resetPropertyValue, setPropertyValue

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • PvxPropertySource

      public PvxPropertySource(org.eclipse.core.resources.IResource res)


ResourceToChangeEntity

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.properties

Class ResourceToChangeEntity

java.lang.Object
com.pvx.ooadide.properties.ResourceToChangeEntity
All Implemented Interfaces:
org.eclipse.compare.IModificationDate, org.eclipse.compare.IStreamContentAccessor, org.eclipse.compare.ITypedElement
public class ResourceToChangeEntity extends Object implements org.eclipse.compare.IStreamContentAccessor, org.eclipse.compare.ITypedElement, org.eclipse.compare.IModificationDate

  • Field Summary

    Fields inherited from interface org.eclipse.compare.ITypedElement

    FOLDER_TYPE, TEXT_TYPE, UNKNOWN_TYPE

  • Constructor Summary

    Constructors
    Constructor
    Description
    ResourceToChangeEntity(org.eclipse.core.resources.IFile initResource)

  • Method Summary

    Modifier and Type
    Method
    Description
    InputStream
    getContents()
    org.eclipse.core.resources.IFile
    getFile()
    org.eclipse.swt.graphics.Image
    getImage()
    long
    getModificationDate()
    String
    getName()
    String
    getTempFile()
    String
    getType()
    void
    setFile(org.eclipse.core.resources.IFile resource)
    void
    setTempFile(String tempFile)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • ResourceToChangeEntity

      public ResourceToChangeEntity(org.eclipse.core.resources.IFile initResource)

  • Method Details

    • setFile

      public void setFile(org.eclipse.core.resources.IFile resource)

    • getFile

      public org.eclipse.core.resources.IFile getFile()

    • setTempFile

      public void setTempFile(String tempFile)

    • getTempFile

      public String getTempFile()

    • getContents

      public InputStream getContents() throws org.eclipse.core.runtime.CoreException
      Specified by:
      getContents in interface org.eclipse.compare.IStreamContentAccessor
      Throws:
      org.eclipse.core.runtime.CoreException

    • getImage

      public org.eclipse.swt.graphics.Image getImage()
      Specified by:
      getImage in interface org.eclipse.compare.ITypedElement

    • getName

      public String getName()
      Specified by:
      getName in interface org.eclipse.compare.ITypedElement

    • getType

      public String getType()
      Specified by:
      getType in interface org.eclipse.compare.ITypedElement

    • getModificationDate

      public long getModificationDate()
      Specified by:
      getModificationDate in interface org.eclipse.compare.IModificationDate


Uses of Class com.pvx.ooadide.properties.ProvideXPropertyPage

Uses of Class
com.pvx.ooadide.properties.ProvideXPropertyPage

Packages that use ProvideXPropertyPage
Package
Description
com.pvx.ooadide.preferences

  • Uses of ProvideXPropertyPage in com.pvx.ooadide.preferences

    Subclasses of ProvideXPropertyPage in com.pvx.ooadide.preferences
    Modifier and Type
    Class
    Description
    class
    PasswordPreferences


Uses of Class com.pvx.ooadide.properties.PvxPropertySource

Uses of Class
com.pvx.ooadide.properties.PvxPropertySource

No usage of com.pvx.ooadide.properties.PvxPropertySource


Uses of Class com.pvx.ooadide.properties.ResourceToChangeEntity

Uses of Class
com.pvx.ooadide.properties.ResourceToChangeEntity

No usage of com.pvx.ooadide.properties.ResourceToChangeEntity


com.pvx.ooadide.properties.dialogs

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.pvx.ooadide.properties.dialogs

package com.pvx.ooadide.properties.dialogs
  • Related Packages
    Package
    Description
    com.pvx.ooadide.properties
    com.pvx.ooadide.properties.userdefined
  • Classes
    Class
    Description
    PxvResourceListSelectionDialog


com.pvx.ooadide.properties.dialogs Class Hierarchy

Hierarchy For Package com.pvx.ooadide.properties.dialogs

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.eclipse.jface.window.Window (implements org.eclipse.jface.window.IShellProvider)
      • org.eclipse.jface.dialogs.Dialog
        • org.eclipse.jface.dialogs.TrayDialog
          • org.eclipse.ui.dialogs.SelectionDialog
            • org.eclipse.ui.dialogs.ResourceListSelectionDialog
              • com.pvx.ooadide.properties.dialogs.PxvResourceListSelectionDialog


Uses of Package com.pvx.ooadide.properties.dialogs

Uses of Package
com.pvx.ooadide.properties.dialogs

No usage of com.pvx.ooadide.properties.dialogs


PxvResourceListSelectionDialog

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.properties.dialogs

Class PxvResourceListSelectionDialog

java.lang.Object
org.eclipse.jface.window.Window
org.eclipse.jface.dialogs.Dialog
org.eclipse.jface.dialogs.TrayDialog
org.eclipse.ui.dialogs.SelectionDialog
org.eclipse.ui.dialogs.ResourceListSelectionDialog
com.pvx.ooadide.properties.dialogs.PxvResourceListSelectionDialog
All Implemented Interfaces:
org.eclipse.jface.window.IShellProvider
public class PxvResourceListSelectionDialog extends org.eclipse.ui.dialogs.ResourceListSelectionDialog

  • Nested Class Summary

    Nested classes/interfaces inherited from class org.eclipse.jface.window.Window

    org.eclipse.jface.window.Window.IExceptionHandler

  • Field Summary

    Fields inherited from class org.eclipse.jface.dialogs.Dialog

    blockedHandler, buttonBar, DIALOG_DEFAULT_BOUNDS, DIALOG_PERSISTLOCATION, DIALOG_PERSISTSIZE, DLG_IMG_HELP, DLG_IMG_MESSAGE_ERROR, DLG_IMG_MESSAGE_INFO, DLG_IMG_MESSAGE_WARNING, ELLIPSIS

    Fields inherited from class org.eclipse.jface.window.Window

    CANCEL, OK

  • Constructor Summary

    Constructors
    Constructor
    Description
    PxvResourceListSelectionDialog(org.eclipse.swt.widgets.Shell parentShell, org.eclipse.core.resources.IContainer container, int typeMask)

  • Method Summary

    Modifier and Type
    Method
    Description
    boolean
    importDirStructure()

    Methods inherited from class org.eclipse.ui.dialogs.ResourceListSelectionDialog

    close, create, getAllowUserToToggleDerived, setAllowUserToToggleDerived

    Methods inherited from class org.eclipse.ui.dialogs.SelectionDialog

    getOkButton, getResult, setDialogBoundsSettings, setInitialElementSelections, setInitialSelections, setMessage, setTitle

    Methods inherited from class org.eclipse.jface.dialogs.TrayDialog

    closeTray, getTray, isDialogHelpAvailable, isHelpAvailable, openTray, setDialogHelpAvailable, setHelpAvailable

    Methods inherited from class org.eclipse.jface.dialogs.Dialog

    applyDialogFont, convertHeightInCharsToPixels, convertHorizontalDLUsToPixels, convertVerticalDLUsToPixels, convertWidthInCharsToPixels, getBlockedHandler, getImage, setBlockedHandler, shortenText

    Methods inherited from class org.eclipse.jface.window.Window

    getDefaultImage, getDefaultImages, getDefaultOrientation, getReturnCode, getShell, getWindowManager, open, setBlockOnOpen, setDefaultImage, setDefaultImages, setDefaultModalParent, setDefaultOrientation, setExceptionHandler, setWindowManager

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • PxvResourceListSelectionDialog

      public PxvResourceListSelectionDialog(org.eclipse.swt.widgets.Shell parentShell, org.eclipse.core.resources.IContainer container, int typeMask)

  • Method Details

    • importDirStructure

      public boolean importDirStructure()


Uses of Class com.pvx.ooadide.properties.dialogs.PxvResourceListSelectionDialog

Uses of Class
com.pvx.ooadide.properties.dialogs.PxvResourceListSelectionDialog

No usage of com.pvx.ooadide.properties.dialogs.PxvResourceListSelectionDialog


CoreTexts

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.properties.refactoring.core

Class CoreTexts

java.lang.Object
org.eclipse.osgi.util.NLS
com.pvx.ooadide.properties.refactoring.core.CoreTexts
public class CoreTexts extends org.eclipse.osgi.util.NLS

provides internationalized messages Strings from the coretexts resource bundle.

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static String
    renamePropertyDelegate_checking
    static String
    renamePropertyDelegate_collectingChanges
    static String
    renamePropertyDelegate_noSourceFile
    static String
    renamePropertyDelegate_propNotFound
    static String
    renamePropertyDelegate_roFile
    static String
    renamePropertyProcessor_name

  • Constructor Summary

    Constructors
    Constructor
    Description
    CoreTexts()

  • Method Summary

    Methods inherited from class org.eclipse.osgi.util.NLS

    bind, bind, bind, initializeMessages

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Field Details

    • renamePropertyProcessor_name

      public static String renamePropertyProcessor_name

    • renamePropertyDelegate_noSourceFile

      public static String renamePropertyDelegate_noSourceFile

    • renamePropertyDelegate_roFile

      public static String renamePropertyDelegate_roFile

    • renamePropertyDelegate_collectingChanges

      public static String renamePropertyDelegate_collectingChanges

    • renamePropertyDelegate_checking

      public static String renamePropertyDelegate_checking

    • renamePropertyDelegate_propNotFound

      public static String renamePropertyDelegate_propNotFound

  • Constructor Details

    • CoreTexts

      public CoreTexts()


com.pvx.ooadide.properties.refactoring.core

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.pvx.ooadide.properties.refactoring.core

package com.pvx.ooadide.properties.refactoring.core
  • Classes
    Class
    Description
    CoreTexts
    provides internationalized messages Strings from the coretexts resource bundle.
    RenamePropertyProcessor
    The processor is where the work is delegated to if participants are involved.
    RenamePropertyRefactoring
    Refactoring for renaming properties in Java Properties files.
    ResourcePropertyInfo


com.pvx.ooadide.properties.refactoring.core Class Hierarchy

Hierarchy For Package com.pvx.ooadide.properties.refactoring.core

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.eclipse.osgi.util.NLS
      • com.pvx.ooadide.properties.refactoring.core.CoreTexts
    • org.eclipse.core.runtime.PlatformObject (implements org.eclipse.core.runtime.IAdaptable)
      • org.eclipse.ltk.core.refactoring.Refactoring
        • org.eclipse.ltk.core.refactoring.participants.ProcessorBasedRefactoring
          • com.pvx.ooadide.properties.refactoring.core.RenamePropertyRefactoring
      • org.eclipse.ltk.core.refactoring.participants.RefactoringProcessor
        • com.pvx.ooadide.properties.refactoring.core.RenamePropertyProcessor
    • com.pvx.ooadide.properties.refactoring.core.ResourcePropertyInfo


Uses of Package com.pvx.ooadide.properties.refactoring.core

Uses of Package
com.pvx.ooadide.properties.refactoring.core

Packages that use com.pvx.ooadide.properties.refactoring.core
Package
Description
com.pvx.ooadide.properties.refactoring.core
com.pvx.ooadide.properties.refactoring.ui.wizards
  • Classes in com.pvx.ooadide.properties.refactoring.core used by com.pvx.ooadide.properties.refactoring.core
    Class
    Description
    ResourcePropertyInfo
  • Classes in com.pvx.ooadide.properties.refactoring.core used by com.pvx.ooadide.properties.refactoring.ui.wizards
    Class
    Description
    RenamePropertyRefactoring
    Refactoring for renaming properties in Java Properties files.
    ResourcePropertyInfo


RenamePropertyProcessor

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.properties.refactoring.core

Class RenamePropertyProcessor

java.lang.Object
org.eclipse.core.runtime.PlatformObject
org.eclipse.ltk.core.refactoring.participants.RefactoringProcessor
com.pvx.ooadide.properties.refactoring.core.RenamePropertyProcessor
All Implemented Interfaces:
org.eclipse.core.runtime.IAdaptable
public class RenamePropertyProcessor extends org.eclipse.ltk.core.refactoring.participants.RefactoringProcessor

The processor is where the work is delegated to if participants are involved. The processor loads the participants and manages the lifecycle of the refactoring. In order to do that, the refactoring entry point methods must be implemented.

  • Constructor Summary

    Constructors
    Constructor
    Description
    RenamePropertyProcessor(ResourcePropertyInfo[] info)

  • Method Summary

    Modifier and Type
    Method
    Description
    org.eclipse.ltk.core.refactoring.RefactoringStatus
    checkFinalConditions(org.eclipse.core.runtime.IProgressMonitor pm, org.eclipse.ltk.core.refactoring.participants.CheckConditionsContext context)
    org.eclipse.ltk.core.refactoring.RefactoringStatus
    checkInitialConditions(org.eclipse.core.runtime.IProgressMonitor pm)
    org.eclipse.ltk.core.refactoring.Change
    createChange(org.eclipse.core.runtime.IProgressMonitor pm)
    Object[]
    getElements()
    String
    getIdentifier()
    String
    getProcessorName()
    boolean
    isApplicable()
    org.eclipse.ltk.core.refactoring.participants.RefactoringParticipant[]
    loadParticipants(org.eclipse.ltk.core.refactoring.RefactoringStatus status, org.eclipse.ltk.core.refactoring.participants.SharableParticipants sharedParticipants)

    Methods inherited from class org.eclipse.ltk.core.refactoring.participants.RefactoringProcessor

    getRefactoring, postCreateChange

    Methods inherited from class org.eclipse.core.runtime.PlatformObject

    getAdapter

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • RenamePropertyProcessor

      public RenamePropertyProcessor(ResourcePropertyInfo[] info)

  • Method Details

    • getElements

      public Object[] getElements()
      Specified by:
      getElements in class org.eclipse.ltk.core.refactoring.participants.RefactoringProcessor

    • getIdentifier

      public String getIdentifier()
      Specified by:
      getIdentifier in class org.eclipse.ltk.core.refactoring.participants.RefactoringProcessor

    • getProcessorName

      public String getProcessorName()
      Specified by:
      getProcessorName in class org.eclipse.ltk.core.refactoring.participants.RefactoringProcessor

    • isApplicable

      public boolean isApplicable() throws org.eclipse.core.runtime.CoreException
      Specified by:
      isApplicable in class org.eclipse.ltk.core.refactoring.participants.RefactoringProcessor
      Throws:
      org.eclipse.core.runtime.CoreException

    • checkInitialConditions

      public org.eclipse.ltk.core.refactoring.RefactoringStatus checkInitialConditions(org.eclipse.core.runtime.IProgressMonitor pm)
      Specified by:
      checkInitialConditions in class org.eclipse.ltk.core.refactoring.participants.RefactoringProcessor

    • checkFinalConditions

      public org.eclipse.ltk.core.refactoring.RefactoringStatus checkFinalConditions(org.eclipse.core.runtime.IProgressMonitor pm, org.eclipse.ltk.core.refactoring.participants.CheckConditionsContext context)
      Specified by:
      checkFinalConditions in class org.eclipse.ltk.core.refactoring.participants.RefactoringProcessor

    • createChange

      public org.eclipse.ltk.core.refactoring.Change createChange(org.eclipse.core.runtime.IProgressMonitor pm)
      Specified by:
      createChange in class org.eclipse.ltk.core.refactoring.participants.RefactoringProcessor

    • loadParticipants

      public org.eclipse.ltk.core.refactoring.participants.RefactoringParticipant[] loadParticipants(org.eclipse.ltk.core.refactoring.RefactoringStatus status, org.eclipse.ltk.core.refactoring.participants.SharableParticipants sharedParticipants)
      Specified by:
      loadParticipants in class org.eclipse.ltk.core.refactoring.participants.RefactoringProcessor


RenamePropertyRefactoring

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.properties.refactoring.core

Class RenamePropertyRefactoring

java.lang.Object
org.eclipse.core.runtime.PlatformObject
org.eclipse.ltk.core.refactoring.Refactoring
org.eclipse.ltk.core.refactoring.participants.ProcessorBasedRefactoring
com.pvx.ooadide.properties.refactoring.core.RenamePropertyRefactoring
All Implemented Interfaces:
org.eclipse.core.runtime.IAdaptable
public class RenamePropertyRefactoring extends org.eclipse.ltk.core.refactoring.participants.ProcessorBasedRefactoring

Refactoring for renaming properties in Java Properties files.

All the actual work is done in the processor, so we just have to keep a reference to one here.

  • Constructor Summary

    Constructors
    Constructor
    Description
    RenamePropertyRefactoring(org.eclipse.ltk.core.refactoring.participants.RefactoringProcessor processor)

  • Method Summary

    Modifier and Type
    Method
    Description
    org.eclipse.ltk.core.refactoring.participants.RefactoringProcessor
    getProcessor()

    Methods inherited from class org.eclipse.ltk.core.refactoring.participants.ProcessorBasedRefactoring

    checkFinalConditions, checkInitialConditions, createChange, getAdapter, getName, getTextChange, isApplicable, setProcessor, toString

    Methods inherited from class org.eclipse.ltk.core.refactoring.Refactoring

    checkAllConditions, getRefactoringTickProvider, getValidationContext, setValidationContext

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

  • Constructor Details

    • RenamePropertyRefactoring

      public RenamePropertyRefactoring(org.eclipse.ltk.core.refactoring.participants.RefactoringProcessor processor)

  • Method Details

    • getProcessor

      public org.eclipse.ltk.core.refactoring.participants.RefactoringProcessor getProcessor()
      Overrides:
      getProcessor in class org.eclipse.ltk.core.refactoring.participants.ProcessorBasedRefactoring


ResourcePropertyInfo

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.properties.refactoring.core

Class ResourcePropertyInfo

java.lang.Object
com.pvx.ooadide.properties.refactoring.core.ResourcePropertyInfo
public class ResourcePropertyInfo extends Object

  • Constructor Summary

    Constructors
    Constructor
    Description
    ResourcePropertyInfo(String initPropertyKey, String initNewName, org.eclipse.core.resources.IFile initSourceFile, int initoffset)

  • Method Summary

    Modifier and Type
    Method
    Description
    String
    getNewName()
    int
    getOffset()
    String
    getOldName()
    String
    getPropertyKey()
    org.eclipse.core.resources.IFile
    getSourceFile()
    void
    setNewName(String newName)
    void
    setOffset(int offset)
    void
    setOldName(String oldName)
    void
    setPropertyKey(String propertyKey)
    void
    setSourceFile(org.eclipse.core.resources.IFile sourceFile)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • ResourcePropertyInfo

      public ResourcePropertyInfo(String initPropertyKey, String initNewName, org.eclipse.core.resources.IFile initSourceFile, int initoffset)

  • Method Details

    • getOffset

      public int getOffset()

    • setOffset

      public void setOffset(int offset)

    • getNewName

      public String getNewName()

    • setNewName

      public void setNewName(String newName)

    • getOldName

      public String getOldName()

    • setOldName

      public void setOldName(String oldName)

    • getSourceFile

      public org.eclipse.core.resources.IFile getSourceFile()

    • setSourceFile

      public void setSourceFile(org.eclipse.core.resources.IFile sourceFile)

    • setPropertyKey

      public void setPropertyKey(String propertyKey)

    • getPropertyKey

      public String getPropertyKey()


Uses of Class com.pvx.ooadide.properties.refactoring.core.CoreTexts

Uses of Class
com.pvx.ooadide.properties.refactoring.core.CoreTexts

No usage of com.pvx.ooadide.properties.refactoring.core.CoreTexts


Uses of Class com.pvx.ooadide.properties.refactoring.core.RenamePropertyProcessor

Uses of Class
com.pvx.ooadide.properties.refactoring.core.RenamePropertyProcessor

No usage of com.pvx.ooadide.properties.refactoring.core.RenamePropertyProcessor


Uses of Class com.pvx.ooadide.properties.refactoring.core.RenamePropertyRefactoring

Uses of Class
com.pvx.ooadide.properties.refactoring.core.RenamePropertyRefactoring

Packages that use RenamePropertyRefactoring
Package
Description
com.pvx.ooadide.properties.refactoring.ui.wizards

  • Uses of RenamePropertyRefactoring in com.pvx.ooadide.properties.refactoring.ui.wizards

    Constructors in com.pvx.ooadide.properties.refactoring.ui.wizards with parameters of type RenamePropertyRefactoring
    Modifier
    Constructor
    Description

    RenamePropertyWizard(RenamePropertyRefactoring refactoring, ResourcePropertyInfo[] info)


Uses of Class com.pvx.ooadide.properties.refactoring.core.ResourcePropertyInfo

Uses of Class
com.pvx.ooadide.properties.refactoring.core.ResourcePropertyInfo

Packages that use ResourcePropertyInfo
Package
Description
com.pvx.ooadide.properties.refactoring.core
com.pvx.ooadide.properties.refactoring.ui.wizards

  • Uses of ResourcePropertyInfo in com.pvx.ooadide.properties.refactoring.core

    Constructors in com.pvx.ooadide.properties.refactoring.core with parameters of type ResourcePropertyInfo
    Modifier
    Constructor
    Description

    RenamePropertyProcessor(ResourcePropertyInfo[] info)

  • Uses of ResourcePropertyInfo in com.pvx.ooadide.properties.refactoring.ui.wizards

    Constructors in com.pvx.ooadide.properties.refactoring.ui.wizards with parameters of type ResourcePropertyInfo
    Modifier
    Constructor
    Description

    RenamePropertyInputPage(ResourcePropertyInfo[] info)

    RenamePropertyWizard(RenamePropertyRefactoring refactoring, ResourcePropertyInfo[] info)


com.pvx.ooadide.properties.refactoring.tagresolver

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.pvx.ooadide.properties.refactoring.tagresolver

package com.pvx.ooadide.properties.refactoring.tagresolver
  • Classes
    Class
    Description
    PvxtagResolver


com.pvx.ooadide.properties.refactoring.tagresolver Class Hierarchy

Hierarchy For Package com.pvx.ooadide.properties.refactoring.tagresolver

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • com.pvx.ooadide.properties.refactoring.tagresolver.PvxtagResolver


Uses of Package com.pvx.ooadide.properties.refactoring.tagresolver

Uses of Package
com.pvx.ooadide.properties.refactoring.tagresolver

No usage of com.pvx.ooadide.properties.refactoring.tagresolver


PvxtagResolver

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.properties.refactoring.tagresolver

Class PvxtagResolver

java.lang.Object
com.pvx.ooadide.properties.refactoring.tagresolver.PvxtagResolver
public class PvxtagResolver extends Object

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final String
    PRIVATE_TAG_FLAGS
    static final String
    PRIVATE_TAG_FORCELINE_NO
    static final String
    PRIVATE_TAG_OUTPUT
    static final String
    PRIVATE_TAG_OWNER
    static final String
    PRIVATE_TAG_PASSWORD
    static final String
    TAG_FLAGS
    static final String
    TAG_FORCELINE_NO
    static final String
    TAG_OUTPUT
    static final String
    TAG_OWNER
    static final String
    TAG_PASSWORD

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxtagResolver()

  • Method Summary

    Modifier and Type
    Method
    Description
    static int
    getOffsetOfTag(BufferedReader reader, String propertyKey)
    static int
    getOffsetOfTag(org.eclipse.core.resources.IFile sourceFile, String propertyKey)
    static String
    getOldValueOfTag(InputStream in, int offset)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Field Details

    • TAG_PASSWORD

      public static final String TAG_PASSWORD
      See Also:
      • Constant Field Values

    • TAG_OWNER

      public static final String TAG_OWNER
      See Also:
      • Constant Field Values

    • TAG_FLAGS

      public static final String TAG_FLAGS
      See Also:
      • Constant Field Values

    • TAG_OUTPUT

      public static final String TAG_OUTPUT
      See Also:
      • Constant Field Values

    • TAG_FORCELINE_NO

      public static final String TAG_FORCELINE_NO
      See Also:
      • Constant Field Values

    • PRIVATE_TAG_PASSWORD

      public static final String PRIVATE_TAG_PASSWORD
      See Also:
      • Constant Field Values

    • PRIVATE_TAG_OWNER

      public static final String PRIVATE_TAG_OWNER
      See Also:
      • Constant Field Values

    • PRIVATE_TAG_FLAGS

      public static final String PRIVATE_TAG_FLAGS
      See Also:
      • Constant Field Values

    • PRIVATE_TAG_OUTPUT

      public static final String PRIVATE_TAG_OUTPUT
      See Also:
      • Constant Field Values

    • PRIVATE_TAG_FORCELINE_NO

      public static final String PRIVATE_TAG_FORCELINE_NO
      See Also:
      • Constant Field Values

  • Constructor Details

    • PvxtagResolver

      public PvxtagResolver()

  • Method Details

    • getOldValueOfTag

      public static String getOldValueOfTag(InputStream in, int offset)

    • getOffsetOfTag

      public static int getOffsetOfTag(org.eclipse.core.resources.IFile sourceFile, String propertyKey)

    • getOffsetOfTag

      public static int getOffsetOfTag(BufferedReader reader, String propertyKey)


Uses of Class com.pvx.ooadide.properties.refactoring.tagresolver.PvxtagResolver

Uses of Class
com.pvx.ooadide.properties.refactoring.tagresolver.PvxtagResolver

No usage of com.pvx.ooadide.properties.refactoring.tagresolver.PvxtagResolver


com.pvx.ooadide.properties.refactoring.ui

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.pvx.ooadide.properties.refactoring.ui

package com.pvx.ooadide.properties.refactoring.ui
  • Related Packages
    Package
    Description
    com.pvx.ooadide.properties.refactoring.ui.wizards
  • Classes
    Class
    Description
    UITexts
    provides internationalized String messages for the UI.


com.pvx.ooadide.properties.refactoring.ui Class Hierarchy

Hierarchy For Package com.pvx.ooadide.properties.refactoring.ui

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • com.pvx.ooadide.properties.refactoring.ui.UITexts


Uses of Package com.pvx.ooadide.properties.refactoring.ui

Uses of Package
com.pvx.ooadide.properties.refactoring.ui

No usage of com.pvx.ooadide.properties.refactoring.ui


UITexts

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.properties.refactoring.ui

Class UITexts

java.lang.Object
com.pvx.ooadide.properties.refactoring.ui.UITexts
public class UITexts extends Object

provides internationalized String messages for the UI.

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static String
    renameProperty_refuseDlg_message
    static String
    renameProperty_refuseDlg_title
    static String
    renamePropertyInputPage_cbAllProjects
    static String
    renamePropertyInputPage_cbUpdateBundle
    static String
    renamePropertyInputPage_lblNewName

  • Constructor Summary

    Constructors
    Constructor
    Description
    UITexts()

  • Method Summary

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Field Details

    • renameProperty_refuseDlg_title

      public static String renameProperty_refuseDlg_title

    • renameProperty_refuseDlg_message

      public static String renameProperty_refuseDlg_message

    • renamePropertyInputPage_lblNewName

      public static String renamePropertyInputPage_lblNewName

    • renamePropertyInputPage_cbUpdateBundle

      public static String renamePropertyInputPage_cbUpdateBundle

    • renamePropertyInputPage_cbAllProjects

      public static String renamePropertyInputPage_cbAllProjects

  • Constructor Details

    • UITexts

      public UITexts()


Uses of Class com.pvx.ooadide.properties.refactoring.ui.UITexts

Uses of Class
com.pvx.ooadide.properties.refactoring.ui.UITexts

No usage of com.pvx.ooadide.properties.refactoring.ui.UITexts


com.pvx.ooadide.properties.refactoring.ui.wizards

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.pvx.ooadide.properties.refactoring.ui.wizards

package com.pvx.ooadide.properties.refactoring.ui.wizards
  • Related Packages
    Package
    Description
    com.pvx.ooadide.properties.refactoring.ui
  • Classes
    Class
    Description
    RenamePropertyInputPage
    the input page for the Rename Property refactoring, where users can control the effects of the refactoring; to be shown in the wizard.
    RenamePropertyWizard
    The wizard that is shown to the user for entering the necessary information for property renaming.


com.pvx.ooadide.properties.refactoring.ui.wizards Class Hierarchy

Hierarchy For Package com.pvx.ooadide.properties.refactoring.ui.wizards

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.eclipse.jface.dialogs.DialogPage (implements org.eclipse.jface.dialogs.IDialogPage, org.eclipse.jface.dialogs.IMessageProvider)
      • org.eclipse.jface.wizard.WizardPage (implements org.eclipse.jface.wizard.IWizardPage)
        • org.eclipse.ltk.ui.refactoring.RefactoringWizardPage
          • org.eclipse.ltk.ui.refactoring.UserInputWizardPage
            • com.pvx.ooadide.properties.refactoring.ui.wizards.RenamePropertyInputPage
    • org.eclipse.jface.wizard.Wizard (implements org.eclipse.jface.window.IShellProvider, org.eclipse.jface.wizard.IWizard)
      • org.eclipse.ltk.ui.refactoring.RefactoringWizard
        • com.pvx.ooadide.properties.refactoring.ui.wizards.RenamePropertyWizard


Uses of Package com.pvx.ooadide.properties.refactoring.ui.wizards

Uses of Package
com.pvx.ooadide.properties.refactoring.ui.wizards

No usage of com.pvx.ooadide.properties.refactoring.ui.wizards


RenamePropertyInputPage

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.properties.refactoring.ui.wizards

Class RenamePropertyInputPage

java.lang.Object
org.eclipse.jface.dialogs.DialogPage
org.eclipse.jface.wizard.WizardPage
org.eclipse.ltk.ui.refactoring.RefactoringWizardPage
org.eclipse.ltk.ui.refactoring.UserInputWizardPage
com.pvx.ooadide.properties.refactoring.ui.wizards.RenamePropertyInputPage
All Implemented Interfaces:
org.eclipse.jface.dialogs.IDialogPage, org.eclipse.jface.dialogs.IMessageProvider, org.eclipse.jface.wizard.IWizardPage
public class RenamePropertyInputPage extends org.eclipse.ltk.ui.refactoring.UserInputWizardPage

the input page for the Rename Property refactoring, where users can control the effects of the refactoring; to be shown in the wizard.

We let the user enter the new name for the property, and we let her decide whether other property files in the bundle should be affected, and whether the operation is supposed to span the entire workspace or only the current project.

  • Field Summary

    Fields inherited from class org.eclipse.ltk.ui.refactoring.RefactoringWizardPage

    REFACTORING_SETTINGS

    Fields inherited from interface org.eclipse.jface.dialogs.IMessageProvider

    ERROR, INFORMATION, NONE, WARNING

  • Constructor Summary

    Constructors
    Constructor
    Description
    RenamePropertyInputPage(ResourcePropertyInfo[] info)

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    createControl(org.eclipse.swt.widgets.Composite parent)

    Methods inherited from class org.eclipse.ltk.ui.refactoring.UserInputWizardPage

    canFlipToNextPage, getNextPage, isLastUserInputPage, setPageComplete, setVisible

    Methods inherited from class org.eclipse.ltk.ui.refactoring.RefactoringWizardPage

    setWizard

    Methods inherited from class org.eclipse.jface.wizard.WizardPage

    getImage, getName, getPreviousPage, getShell, getWizard, isPageComplete, setDescription, setErrorMessage, setImageDescriptor, setMessage, setPageComplete, setPreviousPage, setTitle, toString

    Methods inherited from class org.eclipse.jface.dialogs.DialogPage

    dispose, getControl, getDescription, getErrorMessage, getMessage, getMessageType, getTitle, performHelp, setMessage

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

    Methods inherited from interface org.eclipse.jface.dialogs.IDialogPage

    dispose, getControl, getDescription, getErrorMessage, getMessage, getTitle, performHelp

  • Constructor Details

    • RenamePropertyInputPage

      public RenamePropertyInputPage(ResourcePropertyInfo[] info)

  • Method Details

    • createControl

      public void createControl(org.eclipse.swt.widgets.Composite parent)


RenamePropertyWizard

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.properties.refactoring.ui.wizards

Class RenamePropertyWizard

java.lang.Object
org.eclipse.jface.wizard.Wizard
org.eclipse.ltk.ui.refactoring.RefactoringWizard
com.pvx.ooadide.properties.refactoring.ui.wizards.RenamePropertyWizard
All Implemented Interfaces:
org.eclipse.jface.window.IShellProvider, org.eclipse.jface.wizard.IWizard
public class RenamePropertyWizard extends org.eclipse.ltk.ui.refactoring.RefactoringWizard

The wizard that is shown to the user for entering the necessary information for property renaming.

The wizard class is primarily needed for deciding which pages are shown to the user. The actual user interface creation goes on the pages.

  • Field Summary

    Fields inherited from class org.eclipse.ltk.ui.refactoring.RefactoringWizard

    CHECK_INITIAL_CONDITIONS_ON_OPEN, DIALOG_BASED_USER_INTERFACE, NO_BACK_BUTTON_ON_STATUS_DIALOG, NO_PREVIEW_PAGE, NONE, PREVIEW_EXPAND_FIRST_NODE, SHOW_HELP_CONTROL, WIZARD_BASED_USER_INTERFACE, YES_NO_BUTTON_STYLE

    Fields inherited from class org.eclipse.jface.wizard.Wizard

    DEFAULT_IMAGE

  • Constructor Summary

    Constructors
    Constructor
    Description
    RenamePropertyWizard(RenamePropertyRefactoring refactoring, ResourcePropertyInfo[] info)

  • Method Summary

    Methods inherited from class org.eclipse.ltk.ui.refactoring.RefactoringWizard

    addPage, addPages, canFinish, getChange, getDefaultPageTitle, getMessageLineWidthInChars, getPreviousPage, getRefactoring, getRefactoringContext, getStartingPage, getWizardFlags, internalCreateChange, internalGetExpandFirstNode, internalHasPreviewPage, internalIsYesNoStyle, internalPerformFinish, internalSetChange, internalSetPreviewShown, internalShowBackButtonOnStatusDialog, performCancel, performFinish, setChangeCreationCancelable, setDefaultPageTitle, setForcePreviewReview, setInitialComputationContext, setInitialConditionCheckingStatus

    Methods inherited from class org.eclipse.jface.wizard.Wizard

    createPageControls, dispose, getContainer, getDefaultPageImage, getDialogSettings, getNextPage, getPage, getPageCount, getPages, getShell, getTitleBarColor, getWindowTitle, isHelpAvailable, needsPreviousAndNextButtons, needsProgressMonitor, setContainer, setDefaultPageImageDescriptor, setDialogSettings, setForcePreviousAndNextButtons, setHelpAvailable, setNeedsProgressMonitor, setTitleBarColor, setWindowTitle

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • RenamePropertyWizard

      public RenamePropertyWizard(RenamePropertyRefactoring refactoring, ResourcePropertyInfo[] info)


Uses of Class com.pvx.ooadide.properties.refactoring.ui.wizards.RenamePropertyInputPage

Uses of Class
com.pvx.ooadide.properties.refactoring.ui.wizards.RenamePropertyInputPage

No usage of com.pvx.ooadide.properties.refactoring.ui.wizards.RenamePropertyInputPage


Uses of Class com.pvx.ooadide.properties.refactoring.ui.wizards.RenamePropertyWizard

Uses of Class
com.pvx.ooadide.properties.refactoring.ui.wizards.RenamePropertyWizard

No usage of com.pvx.ooadide.properties.refactoring.ui.wizards.RenamePropertyWizard


com.pvx.ooadide.properties.userdefined

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.pvx.ooadide.properties.userdefined

package com.pvx.ooadide.properties.userdefined
  • Related Packages
    Package
    Description
    com.pvx.ooadide.properties
    com.pvx.ooadide.properties.dialogs
  • Classes
    Class
    Description
    UserDefinedPropField


com.pvx.ooadide.properties.userdefined Class Hierarchy

Hierarchy For Package com.pvx.ooadide.properties.userdefined

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • com.pvx.ooadide.properties.userdefined.UserDefinedPropField


Uses of Package com.pvx.ooadide.properties.userdefined

Uses of Package
com.pvx.ooadide.properties.userdefined

No usage of com.pvx.ooadide.properties.userdefined


UserDefinedPropField

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.properties.userdefined

Class UserDefinedPropField

java.lang.Object
com.pvx.ooadide.properties.userdefined.UserDefinedPropField
public class UserDefinedPropField extends Object

  • Constructor Summary

    Constructors
    Constructor
    Description
    UserDefinedPropField(UserPrefElement inituserElemnt, org.eclipse.swt.widgets.Widget initwidget)

  • Method Summary

    Modifier and Type
    Method
    Description
    UserPrefElement
    getUserElemnt()
    org.eclipse.swt.widgets.Widget
    getWidget()
    void
    setUserElemnt(UserPrefElement userElemnt)
    void
    setWidget(org.eclipse.swt.widgets.Widget widget)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • UserDefinedPropField

      public UserDefinedPropField(UserPrefElement inituserElemnt, org.eclipse.swt.widgets.Widget initwidget)

  • Method Details

    • setWidget

      public void setWidget(org.eclipse.swt.widgets.Widget widget)

    • getWidget

      public org.eclipse.swt.widgets.Widget getWidget()

    • setUserElemnt

      public void setUserElemnt(UserPrefElement userElemnt)

    • getUserElemnt

      public UserPrefElement getUserElemnt()


Uses of Class com.pvx.ooadide.properties.userdefined.UserDefinedPropField

Uses of Class
com.pvx.ooadide.properties.userdefined.UserDefinedPropField

No usage of com.pvx.ooadide.properties.userdefined.UserDefinedPropField


BlockCommentAction

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.refactor

Class BlockCommentAction

java.lang.Object
com.pvx.ooadide.refactor.RenamePropertyAction
com.pvx.ooadide.refactor.BlockCommentAction
All Implemented Interfaces:
org.eclipse.ui.IActionDelegate, org.eclipse.ui.IEditorActionDelegate
public class BlockCommentAction extends RenamePropertyAction

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final String
    REM_BANG

  • Constructor Summary

    Constructors
    Constructor
    Description
    BlockCommentAction()

  • Method Summary

    Methods inherited from class com.pvx.ooadide.refactor.RenamePropertyAction

    getPropertyAction, getSelection, run, selectionChanged, setActiveEditor

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Field Details

    • REM_BANG

      public static final String REM_BANG
      See Also:
      • Constant Field Values

  • Constructor Details

    • BlockCommentAction

      public BlockCommentAction()


com.pvx.ooadide.refactor

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.pvx.ooadide.refactor

package com.pvx.ooadide.refactor
  • Related Packages
    Package
    Description
    com.pvx.ooadide
  • Classes
    Class
    Description
    BlockCommentAction
    RefactorUtil
    RenamePropertyAction
    RenamePropertyInfo
    an info object that holds the information that is passed from the user to the refactoring.
    RenamePropertyInputPage
    the input page for the Rename Property refactoring, where users can control the effects of the refactoring; to be shown in the wizard.
    RenamePropertyProcessor
    The processor is where the work is delegated to if participants are involved.
    RenamePropertyRefactoring
    Refactoring for renaming properties in Java Properties files.
    RenamePropertyWizard
    The wizard that is shown to the user for entering the necessary information for property renaming.
    RenumberAction
    UITexts
    provides internationalized String messages for the UI.


com.pvx.ooadide.refactor Class Hierarchy

Hierarchy For Package com.pvx.ooadide.refactor

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.eclipse.jface.dialogs.DialogPage (implements org.eclipse.jface.dialogs.IDialogPage, org.eclipse.jface.dialogs.IMessageProvider)
      • org.eclipse.jface.wizard.WizardPage (implements org.eclipse.jface.wizard.IWizardPage)
        • org.eclipse.ltk.ui.refactoring.RefactoringWizardPage
          • org.eclipse.ltk.ui.refactoring.UserInputWizardPage
            • com.pvx.ooadide.refactor.RenamePropertyInputPage
    • org.eclipse.core.runtime.PlatformObject (implements org.eclipse.core.runtime.IAdaptable)
      • org.eclipse.ltk.core.refactoring.Refactoring
        • org.eclipse.ltk.core.refactoring.participants.ProcessorBasedRefactoring
          • com.pvx.ooadide.refactor.RenamePropertyRefactoring
      • org.eclipse.ltk.core.refactoring.participants.RefactoringProcessor
        • com.pvx.ooadide.refactor.RenamePropertyProcessor
    • com.pvx.ooadide.refactor.RefactorUtil
    • com.pvx.ooadide.refactor.RenamePropertyAction (implements org.eclipse.ui.IEditorActionDelegate)
      • com.pvx.ooadide.refactor.BlockCommentAction
      • com.pvx.ooadide.refactor.RenumberAction
    • com.pvx.ooadide.refactor.RenamePropertyInfo
    • com.pvx.ooadide.refactor.UITexts
    • org.eclipse.jface.wizard.Wizard (implements org.eclipse.jface.window.IShellProvider, org.eclipse.jface.wizard.IWizard)
      • org.eclipse.ltk.ui.refactoring.RefactoringWizard
        • com.pvx.ooadide.refactor.RenamePropertyWizard


Uses of Package com.pvx.ooadide.refactor

Uses of Package
com.pvx.ooadide.refactor

Packages that use com.pvx.ooadide.refactor
Package
Description
com.pvx.ooadide.refactor
  • Classes in com.pvx.ooadide.refactor used by com.pvx.ooadide.refactor
    Class
    Description
    RenamePropertyAction
    RenamePropertyInfo
    an info object that holds the information that is passed from the user to the refactoring.
    RenamePropertyRefactoring
    Refactoring for renaming properties in Java Properties files.


RefactorUtil

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.refactor

Class RefactorUtil

java.lang.Object
com.pvx.ooadide.refactor.RefactorUtil
public class RefactorUtil extends Object

  • Constructor Summary

    Constructors
    Constructor
    Description
    RefactorUtil()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    openWizard(org.eclipse.jface.text.ITextSelection textSelection, String newText)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • RefactorUtil

      public RefactorUtil()

  • Method Details

    • openWizard

      public void openWizard(org.eclipse.jface.text.ITextSelection textSelection, String newText)


RenamePropertyAction

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.refactor

Class RenamePropertyAction

java.lang.Object
com.pvx.ooadide.refactor.RenamePropertyAction
All Implemented Interfaces:
org.eclipse.ui.IActionDelegate, org.eclipse.ui.IEditorActionDelegate
Direct Known Subclasses:
BlockCommentAction, RenumberAction
public class RenamePropertyAction extends Object implements org.eclipse.ui.IEditorActionDelegate

  • Constructor Summary

    Constructors
    Constructor
    Description
    RenamePropertyAction()

  • Method Summary

    Modifier and Type
    Method
    Description
    static RenamePropertyAction
    getPropertyAction()
    org.eclipse.jface.viewers.ISelection
    getSelection()
    void
    run(org.eclipse.jface.action.IAction action)
    void
    selectionChanged(org.eclipse.jface.action.IAction action, org.eclipse.jface.viewers.ISelection selection)
    void
    setActiveEditor(org.eclipse.jface.action.IAction action, org.eclipse.ui.IEditorPart targetEditor)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • RenamePropertyAction

      public RenamePropertyAction()

  • Method Details

    • setActiveEditor

      public void setActiveEditor(org.eclipse.jface.action.IAction action, org.eclipse.ui.IEditorPart targetEditor)
      Specified by:
      setActiveEditor in interface org.eclipse.ui.IEditorActionDelegate

    • run

      public void run(org.eclipse.jface.action.IAction action)
      Specified by:
      run in interface org.eclipse.ui.IActionDelegate

    • selectionChanged

      public void selectionChanged(org.eclipse.jface.action.IAction action, org.eclipse.jface.viewers.ISelection selection)
      Specified by:
      selectionChanged in interface org.eclipse.ui.IActionDelegate

    • getSelection

      public org.eclipse.jface.viewers.ISelection getSelection()

    • getPropertyAction

      public static RenamePropertyAction getPropertyAction()


RenamePropertyInfo

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.refactor

Class RenamePropertyInfo

java.lang.Object
com.pvx.ooadide.refactor.RenamePropertyInfo
public class RenamePropertyInfo extends Object

an info object that holds the information that is passed from the user to the refactoring.

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final int
    TYPE_BLOCK_REM
    static final int
    TYPE_PROPERTY_RENAME
    static final int
    TYPE_REPLACE
    static final int
    TYPE_STRIP_NUMBERS

  • Constructor Summary

    Constructors
    Constructor
    Description
    RenamePropertyInfo()

  • Method Summary

    Modifier and Type
    Method
    Description
    int
    getChangeType()
    PvxEditor
    getEditor()
    String
    getNewName()
    int
    getOffset()
    String
    getOldName()
    org.eclipse.core.resources.IFile
    getSourceFile()
    boolean
    isAllProjects()
    boolean
    isFunction()
    boolean
    isUpdateBundle()
    void
    setAllProjects(boolean allProjects)
    void
    setChangeType(int i)
    void
    setEditor(PvxEditor editor)
    void
    setFunction(boolean isFunction)
    void
    setNewName(String newName)
    void
    setOffset(int offset)
    void
    setOldName(String oldName)
    void
    setSourceFile(org.eclipse.core.resources.IFile sourceFile)
    void
    setUpdateBundle(boolean updateBundle)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Field Details

    • TYPE_PROPERTY_RENAME

      public static final int TYPE_PROPERTY_RENAME
      See Also:
      • Constant Field Values

    • TYPE_BLOCK_REM

      public static final int TYPE_BLOCK_REM
      See Also:
      • Constant Field Values

    • TYPE_STRIP_NUMBERS

      public static final int TYPE_STRIP_NUMBERS
      See Also:
      • Constant Field Values

    • TYPE_REPLACE

      public static final int TYPE_REPLACE
      See Also:
      • Constant Field Values

  • Constructor Details

    • RenamePropertyInfo

      public RenamePropertyInfo()

  • Method Details

    • getOffset

      public int getOffset()

    • setOffset

      public void setOffset(int offset)

    • getNewName

      public String getNewName()

    • setNewName

      public void setNewName(String newName)

    • getOldName

      public String getOldName()

    • setOldName

      public void setOldName(String oldName)

    • getSourceFile

      public org.eclipse.core.resources.IFile getSourceFile()

    • setSourceFile

      public void setSourceFile(org.eclipse.core.resources.IFile sourceFile)

    • isAllProjects

      public boolean isAllProjects()

    • setAllProjects

      public void setAllProjects(boolean allProjects)

    • isUpdateBundle

      public boolean isUpdateBundle()

    • setUpdateBundle

      public void setUpdateBundle(boolean updateBundle)

    • setEditor

      public void setEditor(PvxEditor editor)

    • getEditor

      public PvxEditor getEditor()

    • setFunction

      public void setFunction(boolean isFunction)

    • isFunction

      public boolean isFunction()

    • setChangeType

      public void setChangeType(int i)

    • getChangeType

      public int getChangeType()


RenamePropertyInputPage

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.refactor

Class RenamePropertyInputPage

java.lang.Object
org.eclipse.jface.dialogs.DialogPage
org.eclipse.jface.wizard.WizardPage
org.eclipse.ltk.ui.refactoring.RefactoringWizardPage
org.eclipse.ltk.ui.refactoring.UserInputWizardPage
com.pvx.ooadide.refactor.RenamePropertyInputPage
All Implemented Interfaces:
org.eclipse.jface.dialogs.IDialogPage, org.eclipse.jface.dialogs.IMessageProvider, org.eclipse.jface.wizard.IWizardPage
public class RenamePropertyInputPage extends org.eclipse.ltk.ui.refactoring.UserInputWizardPage

the input page for the Rename Property refactoring, where users can control the effects of the refactoring; to be shown in the wizard.

We let the user enter the new name for the property, and we let her decide whether other property files in the bundle should be affected, and whether the operation is supposed to span the entire workspace or only the current project.

  • Field Summary

    Fields inherited from class org.eclipse.ltk.ui.refactoring.RefactoringWizardPage

    REFACTORING_SETTINGS

    Fields inherited from interface org.eclipse.jface.dialogs.IMessageProvider

    ERROR, INFORMATION, NONE, WARNING

  • Constructor Summary

    Constructors
    Constructor
    Description
    RenamePropertyInputPage(RenamePropertyInfo info)

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    createControl(org.eclipse.swt.widgets.Composite parent)

    Methods inherited from class org.eclipse.ltk.ui.refactoring.UserInputWizardPage

    canFlipToNextPage, getNextPage, isLastUserInputPage, setPageComplete, setVisible

    Methods inherited from class org.eclipse.ltk.ui.refactoring.RefactoringWizardPage

    setWizard

    Methods inherited from class org.eclipse.jface.wizard.WizardPage

    getImage, getName, getPreviousPage, getShell, getWizard, isPageComplete, setDescription, setErrorMessage, setImageDescriptor, setMessage, setPageComplete, setPreviousPage, setTitle, toString

    Methods inherited from class org.eclipse.jface.dialogs.DialogPage

    dispose, getControl, getDescription, getErrorMessage, getMessage, getMessageType, getTitle, performHelp, setMessage

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

    Methods inherited from interface org.eclipse.jface.dialogs.IDialogPage

    dispose, getControl, getDescription, getErrorMessage, getMessage, getTitle, performHelp

  • Constructor Details

    • RenamePropertyInputPage

      public RenamePropertyInputPage(RenamePropertyInfo info)

  • Method Details

    • createControl

      public void createControl(org.eclipse.swt.widgets.Composite parent)


RenamePropertyProcessor

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.refactor

Class RenamePropertyProcessor

java.lang.Object
org.eclipse.core.runtime.PlatformObject
org.eclipse.ltk.core.refactoring.participants.RefactoringProcessor
com.pvx.ooadide.refactor.RenamePropertyProcessor
All Implemented Interfaces:
org.eclipse.core.runtime.IAdaptable
public class RenamePropertyProcessor extends org.eclipse.ltk.core.refactoring.participants.RefactoringProcessor

The processor is where the work is delegated to if participants are involved. The processor loads the participants and manages the lifecycle of the refactoring. In order to do that, the refactoring entry point methods must be implemented.

  • Constructor Summary

    Constructors
    Constructor
    Description
    RenamePropertyProcessor(RenamePropertyInfo info)

  • Method Summary

    Modifier and Type
    Method
    Description
    org.eclipse.ltk.core.refactoring.RefactoringStatus
    checkFinalConditions(org.eclipse.core.runtime.IProgressMonitor pm, org.eclipse.ltk.core.refactoring.participants.CheckConditionsContext context)
    org.eclipse.ltk.core.refactoring.RefactoringStatus
    checkInitialConditions(org.eclipse.core.runtime.IProgressMonitor pm)
    org.eclipse.ltk.core.refactoring.Change
    createChange(org.eclipse.core.runtime.IProgressMonitor pm)
    Object[]
    getElements()
    String
    getIdentifier()
    String
    getProcessorName()
    boolean
    isApplicable()
    org.eclipse.ltk.core.refactoring.participants.RefactoringParticipant[]
    loadParticipants(org.eclipse.ltk.core.refactoring.RefactoringStatus status, org.eclipse.ltk.core.refactoring.participants.SharableParticipants sharedParticipants)

    Methods inherited from class org.eclipse.ltk.core.refactoring.participants.RefactoringProcessor

    getRefactoring, postCreateChange

    Methods inherited from class org.eclipse.core.runtime.PlatformObject

    getAdapter

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • RenamePropertyProcessor

      public RenamePropertyProcessor(RenamePropertyInfo info)

  • Method Details

    • getElements

      public Object[] getElements()
      Specified by:
      getElements in class org.eclipse.ltk.core.refactoring.participants.RefactoringProcessor

    • getIdentifier

      public String getIdentifier()
      Specified by:
      getIdentifier in class org.eclipse.ltk.core.refactoring.participants.RefactoringProcessor

    • getProcessorName

      public String getProcessorName()
      Specified by:
      getProcessorName in class org.eclipse.ltk.core.refactoring.participants.RefactoringProcessor

    • isApplicable

      public boolean isApplicable() throws org.eclipse.core.runtime.CoreException
      Specified by:
      isApplicable in class org.eclipse.ltk.core.refactoring.participants.RefactoringProcessor
      Throws:
      org.eclipse.core.runtime.CoreException

    • checkInitialConditions

      public org.eclipse.ltk.core.refactoring.RefactoringStatus checkInitialConditions(org.eclipse.core.runtime.IProgressMonitor pm)
      Specified by:
      checkInitialConditions in class org.eclipse.ltk.core.refactoring.participants.RefactoringProcessor

    • checkFinalConditions

      public org.eclipse.ltk.core.refactoring.RefactoringStatus checkFinalConditions(org.eclipse.core.runtime.IProgressMonitor pm, org.eclipse.ltk.core.refactoring.participants.CheckConditionsContext context)
      Specified by:
      checkFinalConditions in class org.eclipse.ltk.core.refactoring.participants.RefactoringProcessor

    • createChange

      public org.eclipse.ltk.core.refactoring.Change createChange(org.eclipse.core.runtime.IProgressMonitor pm)
      Specified by:
      createChange in class org.eclipse.ltk.core.refactoring.participants.RefactoringProcessor

    • loadParticipants

      public org.eclipse.ltk.core.refactoring.participants.RefactoringParticipant[] loadParticipants(org.eclipse.ltk.core.refactoring.RefactoringStatus status, org.eclipse.ltk.core.refactoring.participants.SharableParticipants sharedParticipants)
      Specified by:
      loadParticipants in class org.eclipse.ltk.core.refactoring.participants.RefactoringProcessor


RenamePropertyRefactoring

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.refactor

Class RenamePropertyRefactoring

java.lang.Object
org.eclipse.core.runtime.PlatformObject
org.eclipse.ltk.core.refactoring.Refactoring
org.eclipse.ltk.core.refactoring.participants.ProcessorBasedRefactoring
com.pvx.ooadide.refactor.RenamePropertyRefactoring
All Implemented Interfaces:
org.eclipse.core.runtime.IAdaptable
public class RenamePropertyRefactoring extends org.eclipse.ltk.core.refactoring.participants.ProcessorBasedRefactoring

Refactoring for renaming properties in Java Properties files.

All the actual work is done in the processor, so we just have to keep a reference to one here.

  • Constructor Summary

    Constructors
    Constructor
    Description
    RenamePropertyRefactoring(org.eclipse.ltk.core.refactoring.participants.RefactoringProcessor processor)

  • Method Summary

    Modifier and Type
    Method
    Description
    org.eclipse.ltk.core.refactoring.participants.RefactoringProcessor
    getProcessor()

    Methods inherited from class org.eclipse.ltk.core.refactoring.participants.ProcessorBasedRefactoring

    checkFinalConditions, checkInitialConditions, createChange, getAdapter, getName, getTextChange, isApplicable, setProcessor, toString

    Methods inherited from class org.eclipse.ltk.core.refactoring.Refactoring

    checkAllConditions, getRefactoringTickProvider, getValidationContext, setValidationContext

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

  • Constructor Details

    • RenamePropertyRefactoring

      public RenamePropertyRefactoring(org.eclipse.ltk.core.refactoring.participants.RefactoringProcessor processor)

  • Method Details

    • getProcessor

      public org.eclipse.ltk.core.refactoring.participants.RefactoringProcessor getProcessor()
      Overrides:
      getProcessor in class org.eclipse.ltk.core.refactoring.participants.ProcessorBasedRefactoring


RenamePropertyWizard

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.refactor

Class RenamePropertyWizard

java.lang.Object
org.eclipse.jface.wizard.Wizard
org.eclipse.ltk.ui.refactoring.RefactoringWizard
com.pvx.ooadide.refactor.RenamePropertyWizard
All Implemented Interfaces:
org.eclipse.jface.window.IShellProvider, org.eclipse.jface.wizard.IWizard
public class RenamePropertyWizard extends org.eclipse.ltk.ui.refactoring.RefactoringWizard

The wizard that is shown to the user for entering the necessary information for property renaming.

The wizard class is primarily needed for deciding which pages are shown to the user. The actual user interface creation goes on the pages.

  • Field Summary

    Fields inherited from class org.eclipse.ltk.ui.refactoring.RefactoringWizard

    CHECK_INITIAL_CONDITIONS_ON_OPEN, DIALOG_BASED_USER_INTERFACE, NO_BACK_BUTTON_ON_STATUS_DIALOG, NO_PREVIEW_PAGE, NONE, PREVIEW_EXPAND_FIRST_NODE, SHOW_HELP_CONTROL, WIZARD_BASED_USER_INTERFACE, YES_NO_BUTTON_STYLE

    Fields inherited from class org.eclipse.jface.wizard.Wizard

    DEFAULT_IMAGE

  • Constructor Summary

    Constructors
    Constructor
    Description
    RenamePropertyWizard(RenamePropertyRefactoring refactoring, RenamePropertyInfo info)

  • Method Summary

    Methods inherited from class org.eclipse.ltk.ui.refactoring.RefactoringWizard

    addPage, addPages, canFinish, getChange, getDefaultPageTitle, getMessageLineWidthInChars, getPreviousPage, getRefactoring, getRefactoringContext, getStartingPage, getWizardFlags, internalCreateChange, internalGetExpandFirstNode, internalHasPreviewPage, internalIsYesNoStyle, internalPerformFinish, internalSetChange, internalSetPreviewShown, internalShowBackButtonOnStatusDialog, performCancel, performFinish, setChangeCreationCancelable, setDefaultPageTitle, setForcePreviewReview, setInitialComputationContext, setInitialConditionCheckingStatus

    Methods inherited from class org.eclipse.jface.wizard.Wizard

    createPageControls, dispose, getContainer, getDefaultPageImage, getDialogSettings, getNextPage, getPage, getPageCount, getPages, getShell, getTitleBarColor, getWindowTitle, isHelpAvailable, needsPreviousAndNextButtons, needsProgressMonitor, setContainer, setDefaultPageImageDescriptor, setDialogSettings, setForcePreviousAndNextButtons, setHelpAvailable, setNeedsProgressMonitor, setTitleBarColor, setWindowTitle

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • RenamePropertyWizard

      public RenamePropertyWizard(RenamePropertyRefactoring refactoring, RenamePropertyInfo info)


RenumberAction

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.refactor

Class RenumberAction

java.lang.Object
com.pvx.ooadide.refactor.RenamePropertyAction
com.pvx.ooadide.refactor.RenumberAction
All Implemented Interfaces:
org.eclipse.ui.IActionDelegate, org.eclipse.ui.IEditorActionDelegate
public class RenumberAction extends RenamePropertyAction

  • Constructor Summary

    Constructors
    Constructor
    Description
    RenumberAction()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    run(org.eclipse.jface.action.IAction action)

    Methods inherited from class com.pvx.ooadide.refactor.RenamePropertyAction

    getPropertyAction, getSelection, selectionChanged, setActiveEditor

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • RenumberAction

      public RenumberAction()

  • Method Details

    • run

      public void run(org.eclipse.jface.action.IAction action)
      Specified by:
      run in interface org.eclipse.ui.IActionDelegate
      Overrides:
      run in class RenamePropertyAction


UITexts

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.refactor

Class UITexts

java.lang.Object
com.pvx.ooadide.refactor.UITexts
public class UITexts extends Object

provides internationalized String messages for the UI.

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static String
    renameProperty_refuseDlg_message
    static String
    renameProperty_refuseDlg_title
    static String
    renamePropertyDelegate_checking
    static String
    renamePropertyDelegate_collectingChanges
    static String
    renamePropertyDelegate_noPropertyKey
    static String
    renamePropertyDelegate_propNotFound
    static String
    renamePropertyInputPage_cbAllProjects
    static String
    renamePropertyInputPage_cbUpdateBundle
    static String
    renamePropertyInputPage_lblNewName
    static String
    renamePropertyProcessor_name

  • Constructor Summary

    Constructors
    Constructor
    Description
    UITexts()

  • Method Summary

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Field Details

    • renameProperty_refuseDlg_title

      public static String renameProperty_refuseDlg_title

    • renameProperty_refuseDlg_message

      public static String renameProperty_refuseDlg_message

    • renamePropertyInputPage_lblNewName

      public static String renamePropertyInputPage_lblNewName

    • renamePropertyInputPage_cbUpdateBundle

      public static String renamePropertyInputPage_cbUpdateBundle

    • renamePropertyInputPage_cbAllProjects

      public static String renamePropertyInputPage_cbAllProjects

    • renamePropertyProcessor_name

      public static String renamePropertyProcessor_name

    • renamePropertyDelegate_noPropertyKey

      public static String renamePropertyDelegate_noPropertyKey

    • renamePropertyDelegate_collectingChanges

      public static String renamePropertyDelegate_collectingChanges

    • renamePropertyDelegate_checking

      public static String renamePropertyDelegate_checking

    • renamePropertyDelegate_propNotFound

      public static String renamePropertyDelegate_propNotFound

  • Constructor Details

    • UITexts

      public UITexts()


Uses of Class com.pvx.ooadide.refactor.BlockCommentAction

Uses of Class
com.pvx.ooadide.refactor.BlockCommentAction

No usage of com.pvx.ooadide.refactor.BlockCommentAction


Uses of Class com.pvx.ooadide.refactor.RefactorUtil

Uses of Class
com.pvx.ooadide.refactor.RefactorUtil

No usage of com.pvx.ooadide.refactor.RefactorUtil


Uses of Class com.pvx.ooadide.refactor.RenamePropertyAction

Uses of Class
com.pvx.ooadide.refactor.RenamePropertyAction

Packages that use RenamePropertyAction
Package
Description
com.pvx.ooadide.refactor

  • Uses of RenamePropertyAction in com.pvx.ooadide.refactor

    Subclasses of RenamePropertyAction in com.pvx.ooadide.refactor
    Modifier and Type
    Class
    Description
    class
    BlockCommentAction
    class
    RenumberAction
    Methods in com.pvx.ooadide.refactor that return RenamePropertyAction
    Modifier and Type
    Method
    Description
    static RenamePropertyAction
    RenamePropertyAction.getPropertyAction()


Uses of Class com.pvx.ooadide.refactor.RenamePropertyInfo

Uses of Class
com.pvx.ooadide.refactor.RenamePropertyInfo

Packages that use RenamePropertyInfo
Package
Description
com.pvx.ooadide.refactor

  • Uses of RenamePropertyInfo in com.pvx.ooadide.refactor

    Constructors in com.pvx.ooadide.refactor with parameters of type RenamePropertyInfo
    Modifier
    Constructor
    Description

    RenamePropertyInputPage(RenamePropertyInfo info)

    RenamePropertyProcessor(RenamePropertyInfo info)

    RenamePropertyWizard(RenamePropertyRefactoring refactoring, RenamePropertyInfo info)


Uses of Class com.pvx.ooadide.refactor.RenamePropertyInputPage

Uses of Class
com.pvx.ooadide.refactor.RenamePropertyInputPage

No usage of com.pvx.ooadide.refactor.RenamePropertyInputPage


Uses of Class com.pvx.ooadide.refactor.RenamePropertyProcessor

Uses of Class
com.pvx.ooadide.refactor.RenamePropertyProcessor

No usage of com.pvx.ooadide.refactor.RenamePropertyProcessor


Uses of Class com.pvx.ooadide.refactor.RenamePropertyRefactoring

Uses of Class
com.pvx.ooadide.refactor.RenamePropertyRefactoring

Packages that use RenamePropertyRefactoring
Package
Description
com.pvx.ooadide.refactor

  • Uses of RenamePropertyRefactoring in com.pvx.ooadide.refactor

    Constructors in com.pvx.ooadide.refactor with parameters of type RenamePropertyRefactoring
    Modifier
    Constructor
    Description

    RenamePropertyWizard(RenamePropertyRefactoring refactoring, RenamePropertyInfo info)


Uses of Class com.pvx.ooadide.refactor.RenamePropertyWizard

Uses of Class
com.pvx.ooadide.refactor.RenamePropertyWizard

No usage of com.pvx.ooadide.refactor.RenamePropertyWizard


Uses of Class com.pvx.ooadide.refactor.RenumberAction

Uses of Class
com.pvx.ooadide.refactor.RenumberAction

No usage of com.pvx.ooadide.refactor.RenumberAction


Uses of Class com.pvx.ooadide.refactor.UITexts

Uses of Class
com.pvx.ooadide.refactor.UITexts

No usage of com.pvx.ooadide.refactor.UITexts


com.pvx.ooadide.uesearch

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.pvx.ooadide.uesearch

package com.pvx.ooadide.uesearch
  • Related Packages
    Package
    Description
    com.pvx.ooadide
  • Classes
    Class
    Description
    SearchGotoAction
    UE_SearchAction


com.pvx.ooadide.uesearch Class Hierarchy

Hierarchy For Package com.pvx.ooadide.uesearch

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • com.pvx.ooadide.uesearch.SearchGotoAction (implements org.eclipse.jface.action.IAction)
    • com.pvx.ooadide.uesearch.UE_SearchAction


Uses of Package com.pvx.ooadide.uesearch

Uses of Package
com.pvx.ooadide.uesearch

No usage of com.pvx.ooadide.uesearch


SearchGotoAction

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.uesearch

Class SearchGotoAction

java.lang.Object
com.pvx.ooadide.uesearch.SearchGotoAction
All Implemented Interfaces:
org.eclipse.jface.action.IAction
public class SearchGotoAction extends Object implements org.eclipse.jface.action.IAction

  • Field Summary

    Fields inherited from interface org.eclipse.jface.action.IAction

    AS_CHECK_BOX, AS_DROP_DOWN_MENU, AS_PUSH_BUTTON, AS_RADIO_BUTTON, AS_UNSPECIFIED, CHECKED, DESCRIPTION, ENABLED, HANDLED, IMAGE, RESULT, TEXT, TOOL_TIP_TEXT

  • Constructor Summary

    Constructors
    Constructor
    Description
    SearchGotoAction(org.eclipse.search.ui.ISearchResultView view)

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    addPropertyChangeListener(org.eclipse.jface.util.IPropertyChangeListener listener)
    int
    getAccelerator()
    String
    getActionDefinitionId()
    String
    getDescription()
    org.eclipse.jface.resource.ImageDescriptor
    getDisabledImageDescriptor()
    org.eclipse.swt.events.HelpListener
    getHelpListener()
    org.eclipse.jface.resource.ImageDescriptor
    getHoverImageDescriptor()
    String
    getId()
    org.eclipse.jface.resource.ImageDescriptor
    getImageDescriptor()
    org.eclipse.jface.action.IMenuCreator
    getMenuCreator()
    int
    getStyle()
    String
    getText()
    String
    getToolTipText()
    boolean
    isChecked()
    boolean
    isEnabled()
    boolean
    isHandled()
    void
    removePropertyChangeListener(org.eclipse.jface.util.IPropertyChangeListener listener)
    void
    run()
    void
    runWithEvent(org.eclipse.swt.widgets.Event event)
    void
    setAccelerator(int keycode)
    void
    setActionDefinitionId(String id)
    void
    setChecked(boolean checked)
    void
    setDescription(String text)
    void
    setDisabledImageDescriptor(org.eclipse.jface.resource.ImageDescriptor newImage)
    void
    setEnabled(boolean enabled)
    void
    setHelpListener(org.eclipse.swt.events.HelpListener listener)
    void
    setHoverImageDescriptor(org.eclipse.jface.resource.ImageDescriptor newImage)
    void
    setId(String id)
    void
    setImageDescriptor(org.eclipse.jface.resource.ImageDescriptor newImage)
    void
    setMenuCreator(org.eclipse.jface.action.IMenuCreator creator)
    void
    setText(String text)
    void
    setToolTipText(String text)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • SearchGotoAction

      public SearchGotoAction(org.eclipse.search.ui.ISearchResultView view)

  • Method Details

    • addPropertyChangeListener

      public void addPropertyChangeListener(org.eclipse.jface.util.IPropertyChangeListener listener)
      Specified by:
      addPropertyChangeListener in interface org.eclipse.jface.action.IAction

    • getAccelerator

      public int getAccelerator()
      Specified by:
      getAccelerator in interface org.eclipse.jface.action.IAction

    • getActionDefinitionId

      public String getActionDefinitionId()
      Specified by:
      getActionDefinitionId in interface org.eclipse.jface.action.IAction

    • getDescription

      public String getDescription()
      Specified by:
      getDescription in interface org.eclipse.jface.action.IAction

    • getDisabledImageDescriptor

      public org.eclipse.jface.resource.ImageDescriptor getDisabledImageDescriptor()
      Specified by:
      getDisabledImageDescriptor in interface org.eclipse.jface.action.IAction

    • getHelpListener

      public org.eclipse.swt.events.HelpListener getHelpListener()
      Specified by:
      getHelpListener in interface org.eclipse.jface.action.IAction

    • getHoverImageDescriptor

      public org.eclipse.jface.resource.ImageDescriptor getHoverImageDescriptor()
      Specified by:
      getHoverImageDescriptor in interface org.eclipse.jface.action.IAction

    • getId

      public String getId()
      Specified by:
      getId in interface org.eclipse.jface.action.IAction

    • getImageDescriptor

      public org.eclipse.jface.resource.ImageDescriptor getImageDescriptor()
      Specified by:
      getImageDescriptor in interface org.eclipse.jface.action.IAction

    • getMenuCreator

      public org.eclipse.jface.action.IMenuCreator getMenuCreator()
      Specified by:
      getMenuCreator in interface org.eclipse.jface.action.IAction

    • getStyle

      public int getStyle()
      Specified by:
      getStyle in interface org.eclipse.jface.action.IAction

    • getText

      public String getText()
      Specified by:
      getText in interface org.eclipse.jface.action.IAction

    • getToolTipText

      public String getToolTipText()
      Specified by:
      getToolTipText in interface org.eclipse.jface.action.IAction

    • isChecked

      public boolean isChecked()
      Specified by:
      isChecked in interface org.eclipse.jface.action.IAction

    • isEnabled

      public boolean isEnabled()
      Specified by:
      isEnabled in interface org.eclipse.jface.action.IAction

    • isHandled

      public boolean isHandled()
      Specified by:
      isHandled in interface org.eclipse.jface.action.IAction

    • removePropertyChangeListener

      public void removePropertyChangeListener(org.eclipse.jface.util.IPropertyChangeListener listener)
      Specified by:
      removePropertyChangeListener in interface org.eclipse.jface.action.IAction

    • run

      public void run()
      Specified by:
      run in interface org.eclipse.jface.action.IAction

    • runWithEvent

      public void runWithEvent(org.eclipse.swt.widgets.Event event)
      Specified by:
      runWithEvent in interface org.eclipse.jface.action.IAction

    • setAccelerator

      public void setAccelerator(int keycode)
      Specified by:
      setAccelerator in interface org.eclipse.jface.action.IAction

    • setActionDefinitionId

      public void setActionDefinitionId(String id)
      Specified by:
      setActionDefinitionId in interface org.eclipse.jface.action.IAction

    • setChecked

      public void setChecked(boolean checked)
      Specified by:
      setChecked in interface org.eclipse.jface.action.IAction

    • setDescription

      public void setDescription(String text)
      Specified by:
      setDescription in interface org.eclipse.jface.action.IAction

    • setDisabledImageDescriptor

      public void setDisabledImageDescriptor(org.eclipse.jface.resource.ImageDescriptor newImage)
      Specified by:
      setDisabledImageDescriptor in interface org.eclipse.jface.action.IAction

    • setEnabled

      public void setEnabled(boolean enabled)
      Specified by:
      setEnabled in interface org.eclipse.jface.action.IAction

    • setHelpListener

      public void setHelpListener(org.eclipse.swt.events.HelpListener listener)
      Specified by:
      setHelpListener in interface org.eclipse.jface.action.IAction

    • setHoverImageDescriptor

      public void setHoverImageDescriptor(org.eclipse.jface.resource.ImageDescriptor newImage)
      Specified by:
      setHoverImageDescriptor in interface org.eclipse.jface.action.IAction

    • setId

      public void setId(String id)
      Specified by:
      setId in interface org.eclipse.jface.action.IAction

    • setImageDescriptor

      public void setImageDescriptor(org.eclipse.jface.resource.ImageDescriptor newImage)
      Specified by:
      setImageDescriptor in interface org.eclipse.jface.action.IAction

    • setMenuCreator

      public void setMenuCreator(org.eclipse.jface.action.IMenuCreator creator)
      Specified by:
      setMenuCreator in interface org.eclipse.jface.action.IAction

    • setText

      public void setText(String text)
      Specified by:
      setText in interface org.eclipse.jface.action.IAction

    • setToolTipText

      public void setToolTipText(String text)
      Specified by:
      setToolTipText in interface org.eclipse.jface.action.IAction


UE_SearchAction

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.uesearch

Class UE_SearchAction

java.lang.Object
com.pvx.ooadide.uesearch.UE_SearchAction
public class UE_SearchAction extends Object

  • Constructor Summary

    Constructors
    Constructor
    Description
    UE_SearchAction()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    actionPerformed(Object params)
    void
    markProblemFile(org.eclipse.core.resources.IFile file, String desc, int lineNo, org.eclipse.search.ui.ISearchResultView view)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • UE_SearchAction

      public UE_SearchAction()

  • Method Details

    • actionPerformed

      public void actionPerformed(Object params)

    • markProblemFile

      public void markProblemFile(org.eclipse.core.resources.IFile file, String desc, int lineNo, org.eclipse.search.ui.ISearchResultView view)


Uses of Class com.pvx.ooadide.uesearch.SearchGotoAction

Uses of Class
com.pvx.ooadide.uesearch.SearchGotoAction

No usage of com.pvx.ooadide.uesearch.SearchGotoAction


Uses of Class com.pvx.ooadide.uesearch.UE_SearchAction

Uses of Class
com.pvx.ooadide.uesearch.UE_SearchAction

No usage of com.pvx.ooadide.uesearch.UE_SearchAction


com.pvx.ooadide.ui

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.pvx.ooadide.ui

package com.pvx.ooadide.ui
  • Related Packages
    Package
    Description
    com.pvx.ooadide
  • Classes
    Class
    Description
    PvxPluginImages


com.pvx.ooadide.ui Class Hierarchy

Hierarchy For Package com.pvx.ooadide.ui

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • com.pvx.ooadide.ui.PvxPluginImages


Uses of Package com.pvx.ooadide.ui

Uses of Package
com.pvx.ooadide.ui

No usage of com.pvx.ooadide.ui


PvxPluginImages

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.ui

Class PvxPluginImages

java.lang.Object
com.pvx.ooadide.ui.PvxPluginImages
public class PvxPluginImages extends Object

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final org.eclipse.jface.resource.ImageDescriptor
    DESC_OUTLINE_FILTER_NONE
    static final org.eclipse.jface.resource.ImageDescriptor
    DESC_OUTLINE_SETTINGS
    static final org.eclipse.jface.resource.ImageDescriptor
    DESC_OUTLINE_SORTBY_GROUP
    static final org.eclipse.jface.resource.ImageDescriptor
    DESC_OUTLINE_SORTBY_LINENUM
    static final org.eclipse.jface.resource.ImageDescriptor
    DESC_OUTLINE_SORTBY_RESET
    static final org.eclipse.core.runtime.IPath
    ICONS_PATH
    static final String
    IMG_OUTLINE_FILTER_NONE
    static final String
    IMG_OUTLINE_SETTINGS
    static final String
    IMG_OUTLINE_SORTBY_GROUP
    static final String
    IMG_OUTLINE_SORTBY_LINENUM
    static final String
    IMG_OUTLINE_SORTBY_RESET

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxPluginImages()

  • Method Summary

    Modifier and Type
    Method
    Description
    static org.eclipse.jface.resource.ImageDescriptor
    create(String name)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Field Details

    • ICONS_PATH

      public static final org.eclipse.core.runtime.IPath ICONS_PATH

    • IMG_OUTLINE_FILTER_NONE

      public static final String IMG_OUTLINE_FILTER_NONE
      See Also:
      • Constant Field Values

    • IMG_OUTLINE_SORTBY_GROUP

      public static final String IMG_OUTLINE_SORTBY_GROUP
      See Also:
      • Constant Field Values

    • IMG_OUTLINE_SORTBY_LINENUM

      public static final String IMG_OUTLINE_SORTBY_LINENUM
      See Also:
      • Constant Field Values

    • IMG_OUTLINE_SORTBY_RESET

      public static final String IMG_OUTLINE_SORTBY_RESET
      See Also:
      • Constant Field Values

    • IMG_OUTLINE_SETTINGS

      public static final String IMG_OUTLINE_SETTINGS
      See Also:
      • Constant Field Values

    • DESC_OUTLINE_FILTER_NONE

      public static final org.eclipse.jface.resource.ImageDescriptor DESC_OUTLINE_FILTER_NONE

    • DESC_OUTLINE_SORTBY_GROUP

      public static final org.eclipse.jface.resource.ImageDescriptor DESC_OUTLINE_SORTBY_GROUP

    • DESC_OUTLINE_SORTBY_LINENUM

      public static final org.eclipse.jface.resource.ImageDescriptor DESC_OUTLINE_SORTBY_LINENUM

    • DESC_OUTLINE_SORTBY_RESET

      public static final org.eclipse.jface.resource.ImageDescriptor DESC_OUTLINE_SORTBY_RESET

    • DESC_OUTLINE_SETTINGS

      public static final org.eclipse.jface.resource.ImageDescriptor DESC_OUTLINE_SETTINGS

  • Constructor Details

    • PvxPluginImages

      public PvxPluginImages()

  • Method Details

    • create

      public static org.eclipse.jface.resource.ImageDescriptor create(String name)


Uses of Class com.pvx.ooadide.ui.PvxPluginImages

Uses of Class
com.pvx.ooadide.ui.PvxPluginImages

No usage of com.pvx.ooadide.ui.PvxPluginImages


DefaultItemContentProvider

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.util

Class DefaultItemContentProvider

java.lang.Object
com.pvx.ooadide.util.DefaultItemContentProvider
All Implemented Interfaces:
org.eclipse.jface.viewers.IContentProvider, org.eclipse.jface.viewers.IStructuredContentProvider
public class DefaultItemContentProvider extends Object implements org.eclipse.jface.viewers.IStructuredContentProvider

  • Constructor Summary

    Constructors
    Constructor
    Description
    DefaultItemContentProvider()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    dispose()
    Object[]
    getElements(Object inputElement)
    void
    inputChanged(org.eclipse.jface.viewers.Viewer viewer, Object oldInput, Object newInput)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • DefaultItemContentProvider

      public DefaultItemContentProvider()

  • Method Details

    • getElements

      public Object[] getElements(Object inputElement)
      Specified by:
      getElements in interface org.eclipse.jface.viewers.IStructuredContentProvider

    • dispose

      public void dispose()
      Specified by:
      dispose in interface org.eclipse.jface.viewers.IContentProvider

    • inputChanged

      public void inputChanged(org.eclipse.jface.viewers.Viewer viewer, Object oldInput, Object newInput)
      Specified by:
      inputChanged in interface org.eclipse.jface.viewers.IContentProvider


DefaultLabelProvider

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.util

Class DefaultLabelProvider

java.lang.Object
org.eclipse.core.commands.common.EventManager
org.eclipse.jface.viewers.BaseLabelProvider
org.eclipse.jface.viewers.LabelProvider
com.pvx.ooadide.util.DefaultLabelProvider
All Implemented Interfaces:
org.eclipse.jface.viewers.IBaseLabelProvider, org.eclipse.jface.viewers.IColorProvider, org.eclipse.jface.viewers.ILabelProvider
public class DefaultLabelProvider extends org.eclipse.jface.viewers.LabelProvider implements org.eclipse.jface.viewers.IColorProvider

  • Constructor Summary

    Constructors
    Constructor
    Description
    DefaultLabelProvider()

  • Method Summary

    Modifier and Type
    Method
    Description
    org.eclipse.swt.graphics.Color
    getBackground(Object element)
    org.eclipse.swt.graphics.Color
    getForeground(Object element)
    String
    getText(Object element)

    Methods inherited from class org.eclipse.jface.viewers.LabelProvider

    getImage

    Methods inherited from class org.eclipse.jface.viewers.BaseLabelProvider

    addListener, dispose, isLabelProperty, removeListener

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface org.eclipse.jface.viewers.IBaseLabelProvider

    addListener, dispose, isLabelProperty, removeListener

  • Constructor Details

    • DefaultLabelProvider

      public DefaultLabelProvider()

  • Method Details

    • getText

      public String getText(Object element)
      Specified by:
      getText in interface org.eclipse.jface.viewers.ILabelProvider
      Overrides:
      getText in class org.eclipse.jface.viewers.LabelProvider

    • getBackground

      public org.eclipse.swt.graphics.Color getBackground(Object element)
      Specified by:
      getBackground in interface org.eclipse.jface.viewers.IColorProvider

    • getForeground

      public org.eclipse.swt.graphics.Color getForeground(Object element)
      Specified by:
      getForeground in interface org.eclipse.jface.viewers.IColorProvider


ExtensionUtil

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.util

Class ExtensionUtil

java.lang.Object
com.pvx.ooadide.util.ExtensionUtil
All Implemented Interfaces:
org.eclipse.ui.IPropertyListener
public class ExtensionUtil extends Object implements org.eclipse.ui.IPropertyListener

  • Constructor Summary

    Constructors
    Constructor
    Description
    ExtensionUtil()

  • Method Summary

    Modifier and Type
    Method
    Description
    static boolean
    isEditorExtension(String extension, String editorId, ArrayList knownExtList)
    static boolean
    isNomadsEditorExtension(String extension)
    static boolean
    isPvxEditorExtension(String extension)
    void
    propertyChanged(Object source, int propId)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • ExtensionUtil

      public ExtensionUtil()

  • Method Details

    • isEditorExtension

      public static boolean isEditorExtension(String extension, String editorId, ArrayList knownExtList)

    • isNomadsEditorExtension

      public static boolean isNomadsEditorExtension(String extension)

    • isPvxEditorExtension

      public static boolean isPvxEditorExtension(String extension)

    • propertyChanged

      public void propertyChanged(Object source, int propId)
      Specified by:
      propertyChanged in interface org.eclipse.ui.IPropertyListener


com.pvx.ooadide.util

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.pvx.ooadide.util

package com.pvx.ooadide.util
  • Related Packages
    Package
    Description
    com.pvx.ooadide
  • Classes
    Class
    Description
    DefaultItemContentProvider
    DefaultLabelProvider
    ExtensionUtil
    PixelConverter
    Pixel conversion utility.
    ProcessRunner
    ProjectUtils
    Simple class to provide access to Project/Workspace utility methods.
    PvxElement
    PvxFileUtils
    PvxUtil
    PvxUtil.ConfirmDialShower
    PvxVersionInfo
    RunPvxTester
    RunUtil
    StopWatch
    UtilCommands


com.pvx.ooadide.util Class Hierarchy

Hierarchy For Package com.pvx.ooadide.util

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • com.pvx.ooadide.util.DefaultItemContentProvider (implements org.eclipse.jface.viewers.IStructuredContentProvider)
    • org.eclipse.core.commands.common.EventManager
      • org.eclipse.jface.viewers.BaseLabelProvider (implements org.eclipse.jface.viewers.IBaseLabelProvider)
        • org.eclipse.jface.viewers.LabelProvider (implements org.eclipse.jface.viewers.ILabelProvider)
          • com.pvx.ooadide.util.DefaultLabelProvider (implements org.eclipse.jface.viewers.IColorProvider)
    • com.pvx.ooadide.util.ExtensionUtil (implements org.eclipse.ui.IPropertyListener)
    • com.pvx.ooadide.util.PixelConverter
    • com.pvx.ooadide.util.ProcessRunner
    • com.pvx.ooadide.util.ProjectUtils
    • com.pvx.ooadide.util.PvxElement (implements com.pvx.ooadide.views.comparators.IPvxElement)
    • com.pvx.ooadide.util.PvxFileUtils
    • com.pvx.ooadide.util.PvxUtil
    • com.pvx.ooadide.util.PvxUtil.ConfirmDialShower (implements java.lang.Runnable)
    • com.pvx.ooadide.util.PvxVersionInfo
    • com.pvx.ooadide.util.RunPvxTester
    • com.pvx.ooadide.util.RunUtil
    • com.pvx.ooadide.util.StopWatch
    • com.pvx.ooadide.util.UtilCommands


Uses of Package com.pvx.ooadide.util

Uses of Package
com.pvx.ooadide.util

Packages that use com.pvx.ooadide.util
Package
Description
com.pvx.ooadide.util
  • Classes in com.pvx.ooadide.util used by com.pvx.ooadide.util
    Class
    Description
    PvxVersionInfo


PixelConverter

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.util

Class PixelConverter

java.lang.Object
com.pvx.ooadide.util.PixelConverter
public class PixelConverter extends Object
Pixel conversion utility.
Since:
3.0

  • Constructor Summary

    Constructors
    Constructor
    Description
    PixelConverter(org.eclipse.swt.widgets.Control control)

  • Method Summary

    Modifier and Type
    Method
    Description
    int
    convertHeightInCharsToPixels(int chars)
    int
    convertHorizontalDLUsToPixels(int dlus)
    int
    convertVerticalDLUsToPixels(int dlus)
    int
    convertWidthInCharsToPixels(int chars)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • PixelConverter

      public PixelConverter(org.eclipse.swt.widgets.Control control)

  • Method Details

    • convertHeightInCharsToPixels

      public int convertHeightInCharsToPixels(int chars)

    • convertHorizontalDLUsToPixels

      public int convertHorizontalDLUsToPixels(int dlus)

    • convertVerticalDLUsToPixels

      public int convertVerticalDLUsToPixels(int dlus)

    • convertWidthInCharsToPixels

      public int convertWidthInCharsToPixels(int chars)


ProcessRunner

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.util

Class ProcessRunner

java.lang.Object
com.pvx.ooadide.util.ProcessRunner
public class ProcessRunner extends Object

  • Constructor Summary

    Constructors
    Constructor
    Description
    ProcessRunner()

  • Method Summary

    Modifier and Type
    Method
    Description
    static Process
    createProcess(String helperDir, String program)
    static Process
    createProcess(String workingDir, String program, String[] args)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • ProcessRunner

      public ProcessRunner()

  • Method Details

    • createProcess

      public static Process createProcess(String helperDir, String program)

    • createProcess

      public static Process createProcess(String workingDir, String program, String[] args)


ProjectUtils

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.util

Class ProjectUtils

java.lang.Object
com.pvx.ooadide.util.ProjectUtils
public class ProjectUtils extends Object
Simple class to provide access to Project/Workspace utility methods. Also, Eclipse PvxHelper class pvxState will perform similar functions for ProvideX code.

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final String
    NOMADS_XML_EXPORT
    static final String
    P_COMMON_RESOURCE_FILE_EXTENSIONS

  • Constructor Summary

    Constructors
    Constructor
    Description
    ProjectUtils()

  • Method Summary

    Modifier and Type
    Method
    Description
    static boolean
    getBooleanPreference(String sPref)
    static String
    getBooleanPreferenceAsString(String sPref)
    static boolean
    getBooleanProperty(String propName)
    Get the value of specified boolean property from the project/workspace specific properties file
    static String
    getProjectPath()
    Get the OS path of the current project based on selected resources in the Navigator view.
    static String
    getStringPreference(String sPref)
    static String
    getStringProperty(String propName)
    Get the value of specified String property from the project/workspace specific properties file
    static String
    getWorkspacePath()
    Get the OS Path to the current workspace root
    static void
    setProjectPath(String projectPath)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Field Details

    • NOMADS_XML_EXPORT

      public static final String NOMADS_XML_EXPORT
      See Also:
      • Constant Field Values

    • P_COMMON_RESOURCE_FILE_EXTENSIONS

      public static final String P_COMMON_RESOURCE_FILE_EXTENSIONS
      See Also:
      • Constant Field Values

  • Constructor Details

    • ProjectUtils

      public ProjectUtils()

  • Method Details

    • getStringProperty

      public static String getStringProperty(String propName)
      Get the value of specified String property from the project/workspace specific properties file
      Parameters:
      propName - The name of the property to retrieve
      Returns:
      The current value assigned to the property in the project/workspace properties file or null if not set

    • getBooleanProperty

      public static boolean getBooleanProperty(String propName)
      Get the value of specified boolean property from the project/workspace specific properties file
      Parameters:
      propName - The name of the property to retrieve
      Returns:
      The current value assigned to the property in the project/workspace properties file or null if not set

    • getWorkspacePath

      public static String getWorkspacePath()
      Get the OS Path to the current workspace root
      Returns:
      The OS path for the workspace root.

    • getProjectPath

      public static String getProjectPath()
      Get the OS path of the current project based on selected resources in the Navigator view.
      Returns:
      The OS path of the current project.

    • getBooleanPreference

      public static boolean getBooleanPreference(String sPref)

    • getBooleanPreferenceAsString

      public static String getBooleanPreferenceAsString(String sPref)

    • getStringPreference

      public static String getStringPreference(String sPref)

    • setProjectPath

      public static void setProjectPath(String projectPath)


PvxElement

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.util

Class PvxElement

java.lang.Object
com.pvx.ooadide.util.PvxElement
All Implemented Interfaces:
IPvxElement
public class PvxElement extends Object implements IPvxElement

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final int
    ATTRIB_TYPE
    static final char
    ATTRIB_TYPE_SYMBOL
    static final String
    DOM_INFO_BLOCK_HEADER
    static final String
    FILE_INFO_BLOCK_HEADER
    static final int
    FUNCTION_TYPE
    static final char
    FUNCTION_TYPE_SYMBOL
    static final char
    LOCAL_SYMBOL
    static final int
    LOCAL_TYPE
    static final int
    NOICON_TYPE
    static final char
    NON_OBJ_FUNCTION_SYMBOL
    static final int
    NON_OBJ_FUNCTION_TYPE
    static final int
    PRIVATE_FUNCTION
    static final char
    PRIVATE_FUNCTION_SYMBOL
    static final int
    PVXDATA_TYPE
    static final int
    PVXOBJ_PROP
    static final char
    PVXOBJ_PROP_SYMBOL
    static final int
    RTN_TYPE
    static final int
    VARIABLE_TYPE
    static final char
    VARIABLE_TYPE_SYMBOL

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxElement(String value, org.eclipse.core.resources.IFile initSrcFile, boolean isDataFile)

  • Method Summary

    Modifier and Type
    Method
    Description
    org.eclipse.swt.graphics.Image
    getImage()
    int
    getLineNumber()
    String
    getName()
    String
    getResourcePath()
    org.eclipse.core.resources.IFile
    getSrcFile()
    int
    getType()
    static void
    scanPvxDomLog(File domLog, org.eclipse.core.resources.IFile srcFile, Vector msgs)
    void
    setSrcFile(org.eclipse.core.resources.IFile srcFile)
    void
    setType(int type)
    String
    toString()

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

  • Field Details

    • DOM_INFO_BLOCK_HEADER

      public static final String DOM_INFO_BLOCK_HEADER
      See Also:
      • Constant Field Values

    • FILE_INFO_BLOCK_HEADER

      public static final String FILE_INFO_BLOCK_HEADER
      See Also:
      • Constant Field Values

    • ATTRIB_TYPE

      public static final int ATTRIB_TYPE
      See Also:
      • Constant Field Values

    • LOCAL_TYPE

      public static final int LOCAL_TYPE
      See Also:
      • Constant Field Values

    • FUNCTION_TYPE

      public static final int FUNCTION_TYPE
      See Also:
      • Constant Field Values

    • PRIVATE_FUNCTION

      public static final int PRIVATE_FUNCTION
      See Also:
      • Constant Field Values

    • PVXDATA_TYPE

      public static final int PVXDATA_TYPE
      See Also:
      • Constant Field Values

    • NOICON_TYPE

      public static final int NOICON_TYPE
      See Also:
      • Constant Field Values

    • NON_OBJ_FUNCTION_TYPE

      public static final int NON_OBJ_FUNCTION_TYPE
      See Also:
      • Constant Field Values

    • PVXOBJ_PROP

      public static final int PVXOBJ_PROP
      See Also:
      • Constant Field Values

    • RTN_TYPE

      public static final int RTN_TYPE
      See Also:
      • Constant Field Values

    • VARIABLE_TYPE

      public static final int VARIABLE_TYPE
      See Also:
      • Constant Field Values

    • FUNCTION_TYPE_SYMBOL

      public static final char FUNCTION_TYPE_SYMBOL
      See Also:
      • Constant Field Values

    • ATTRIB_TYPE_SYMBOL

      public static final char ATTRIB_TYPE_SYMBOL
      See Also:
      • Constant Field Values

    • NON_OBJ_FUNCTION_SYMBOL

      public static final char NON_OBJ_FUNCTION_SYMBOL
      See Also:
      • Constant Field Values

    • LOCAL_SYMBOL

      public static final char LOCAL_SYMBOL
      See Also:
      • Constant Field Values

    • PRIVATE_FUNCTION_SYMBOL

      public static final char PRIVATE_FUNCTION_SYMBOL
      See Also:
      • Constant Field Values

    • PVXOBJ_PROP_SYMBOL

      public static final char PVXOBJ_PROP_SYMBOL
      See Also:
      • Constant Field Values

    • VARIABLE_TYPE_SYMBOL

      public static final char VARIABLE_TYPE_SYMBOL
      See Also:
      • Constant Field Values

  • Constructor Details

    • PvxElement

      public PvxElement(String value, org.eclipse.core.resources.IFile initSrcFile, boolean isDataFile)

  • Method Details

    • toString

      public String toString()
      Overrides:
      toString in class Object

    • getImage

      public org.eclipse.swt.graphics.Image getImage()

    • getName

      public String getName()

    • getResourcePath

      public String getResourcePath()

    • scanPvxDomLog

      public static void scanPvxDomLog(File domLog, org.eclipse.core.resources.IFile srcFile, Vector msgs)

    • setSrcFile

      public void setSrcFile(org.eclipse.core.resources.IFile srcFile)

    • getSrcFile

      public org.eclipse.core.resources.IFile getSrcFile()

    • setType

      public void setType(int type)

    • getType

      public int getType()
      Specified by:
      getType in interface IPvxElement

    • getLineNumber

      public int getLineNumber()


PvxFileUtils

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.util

Class PvxFileUtils

java.lang.Object
com.pvx.ooadide.util.PvxFileUtils
public class PvxFileUtils extends Object

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final int
    IS_BINARY
    static final int
    IS_TEXT
    static final int
    PVX_DATA
    static final int
    PVX_OTHER
    static final int
    PVX_PROGRAM

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxFileUtils()

  • Method Summary

    Modifier and Type
    Method
    Description
    static void
    copyFileUsingChannel(File source, File dest)
    static int
    getFileType(org.eclipse.core.resources.IResource resource)
    static String
    getFileTypeDescription(int chkFileType)
    static boolean
    isPvxDataFile(org.eclipse.core.resources.IResource resource)
    static boolean
    isPvxOtherFile(org.eclipse.core.resources.IResource resource)
    static boolean
    isPvxProgram(org.eclipse.core.resources.IResource resource)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Field Details

    • IS_TEXT

      public static final int IS_TEXT
      See Also:
      • Constant Field Values

    • PVX_PROGRAM

      public static final int PVX_PROGRAM
      See Also:
      • Constant Field Values

    • PVX_DATA

      public static final int PVX_DATA
      See Also:
      • Constant Field Values

    • PVX_OTHER

      public static final int PVX_OTHER
      See Also:
      • Constant Field Values

    • IS_BINARY

      public static final int IS_BINARY
      See Also:
      • Constant Field Values

  • Constructor Details

    • PvxFileUtils

      public PvxFileUtils()

  • Method Details

    • getFileType

      public static int getFileType(org.eclipse.core.resources.IResource resource)

    • getFileTypeDescription

      public static String getFileTypeDescription(int chkFileType)

    • isPvxProgram

      public static boolean isPvxProgram(org.eclipse.core.resources.IResource resource)

    • isPvxDataFile

      public static boolean isPvxDataFile(org.eclipse.core.resources.IResource resource)

    • isPvxOtherFile

      public static boolean isPvxOtherFile(org.eclipse.core.resources.IResource resource)

    • copyFileUsingChannel

      public static void copyFileUsingChannel(File source, File dest) throws IOException
      Throws:
      IOException


PvxUtil

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.util

Class PvxUtil

java.lang.Object
com.pvx.ooadide.util.PvxUtil
public class PvxUtil extends Object

  • Nested Class Summary

    Nested Classes
    Modifier and Type
    Class
    Description
    static class
    PvxUtil.ConfirmDialShower

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final String
    BOOLEAN
    static final int
    BOOLEAN_DATA
    static final String
    DIRECTORY
    static final int
    DIRECTORY_DATA
    static final String
    FILE
    static final int
    FILE_DATA
    static final String
    LIST
    static final int
    LIST_DATA
    static final int
    OS_APPLE_OSX
    static final int
    OS_LINUX
    static final int
    OS_UNIX
    static final int
    OS_WINDOWS
    static final String
    PVX_LABEL_SEP
    static final String
    RADIOGROUP
    static final int
    RADIOGROUP_DATA
    static final String
    STRING
    static final int
    STRING_DATA
    static final int
    TRACE_TO_ERRORLOG
    static final int
    TRACE_TO_STANDARDOUT
    static HashMap
    validExecutables

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxUtil()

  • Method Summary

    Modifier and Type
    Method
    Description
    static void
    addBuilder(org.eclipse.core.resources.IProjectDescription desc, String id, String outputDir, String outputLinkDir, String inputDir, String inputLinkDir)
    static void
    addNature(org.eclipse.core.resources.IProjectDescription description)
    static final void
    addVersionPluginVersion(org.eclipse.core.resources.IResource resource)
    static org.eclipse.core.resources.IProject
    createChooseProjectDial(org.eclipse.core.resources.IProject[] projects, org.eclipse.core.resources.IProject pvxProject, org.eclipse.swt.widgets.Shell shell)
    static org.eclipse.core.resources.IResource
    createChooseResourceDial(org.eclipse.core.resources.IContainer rootContainer, org.eclipse.core.resources.IProject pvxProject, org.eclipse.swt.widgets.Shell shell, String title, String msg, int type)
    static final org.eclipse.core.resources.IProject[]
    findPvxProjects()
    static final PvxEditor
    getActivePvxEditor()
    static final int
    getDataTypeForPref(String key)
    static String
    getDefaultPvxPath()
    static String
    getFileProperty(org.eclipse.core.resources.IResource srcFile, String propKey)
    static org.eclipse.swt.graphics.Image
    getImage(String pluginId, String imagePath)
    static final org.eclipse.ui.IViewPart
    getNavView()
    static int
    getOperatingSystem()
    static final org.eclipse.core.resources.IProject
    getProjectFromNavView()
    static Hashtable
    getProjectsInPropertiesFile(String filePth)
    static org.eclipse.core.resources.IProject
    getProjectViaEditor()
    static String
    getPvxPath(org.eclipse.core.resources.IResource srcFile)
    static String
    getPvxPath(org.eclipse.core.resources.IResource srcFile, boolean informUser)
    static org.eclipse.swt.widgets.Shell
    getShell()
    static org.eclipse.core.resources.IWorkspaceRoot
    getWorkspaceRoot()
    static int
    initOperatingSystem()
    static final boolean
    isNumericArg(String str)
    static final boolean
    isPvxProject(org.eclipse.core.resources.IProject project)
    static final void
    log(String message, Throwable t)
    static final void
    log(Throwable t)
    static void
    openPvxEditor(org.eclipse.core.resources.IFile file)
    static String
    replaceAll(String base, String search, String replace)
    static boolean
    showConfirmDialogue(String title, String msg)
    static void
    showErrorDialogue(String title, String msg)
    static void
    showMessageDialogue(String title, String msg)
    static void
    showMessageOnStatusBar(String msg, org.eclipse.ui.IEditorPart editor)
    static void
    showMessageOnStatusBar(String msg, org.eclipse.ui.IViewPart view)
    static void
    showPvxPrefPage()
    static void
    showWarningDialogue(String title, String msg)
    static final void
    syncFolders(org.eclipse.core.resources.IResource resToSync, org.eclipse.core.resources.IResource targetRes)
    static final void
    toStandardOut(String str)
    static final void
    traceEvent(String eventName, String detail, Properties buildProps)
    static void
    writeToConsole(String msg)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Field Details

    • PVX_LABEL_SEP

      public static final String PVX_LABEL_SEP
      See Also:
      • Constant Field Values

    • BOOLEAN

      public static final String BOOLEAN
      See Also:
      • Constant Field Values

    • STRING

      public static final String STRING
      See Also:
      • Constant Field Values

    • DIRECTORY

      public static final String DIRECTORY
      See Also:
      • Constant Field Values

    • FILE

      public static final String FILE
      See Also:
      • Constant Field Values

    • LIST

      public static final String LIST
      See Also:
      • Constant Field Values

    • RADIOGROUP

      public static final String RADIOGROUP
      See Also:
      • Constant Field Values

    • STRING_DATA

      public static final int STRING_DATA
      See Also:
      • Constant Field Values

    • BOOLEAN_DATA

      public static final int BOOLEAN_DATA
      See Also:
      • Constant Field Values

    • DIRECTORY_DATA

      public static final int DIRECTORY_DATA
      See Also:
      • Constant Field Values

    • FILE_DATA

      public static final int FILE_DATA
      See Also:
      • Constant Field Values

    • LIST_DATA

      public static final int LIST_DATA
      See Also:
      • Constant Field Values

    • RADIOGROUP_DATA

      public static final int RADIOGROUP_DATA
      See Also:
      • Constant Field Values

    • TRACE_TO_STANDARDOUT

      public static final int TRACE_TO_STANDARDOUT
      See Also:
      • Constant Field Values

    • TRACE_TO_ERRORLOG

      public static final int TRACE_TO_ERRORLOG
      See Also:
      • Constant Field Values

    • OS_WINDOWS

      public static final int OS_WINDOWS
      See Also:
      • Constant Field Values

    • OS_LINUX

      public static final int OS_LINUX
      See Also:
      • Constant Field Values

    • OS_UNIX

      public static final int OS_UNIX
      See Also:
      • Constant Field Values

    • OS_APPLE_OSX

      public static final int OS_APPLE_OSX
      See Also:
      • Constant Field Values

    • validExecutables

      public static HashMap validExecutables

  • Constructor Details

    • PvxUtil

      public PvxUtil()

  • Method Details

    • getOperatingSystem

      public static int getOperatingSystem()

    • initOperatingSystem

      public static int initOperatingSystem()

    • getFileProperty

      public static String getFileProperty(org.eclipse.core.resources.IResource srcFile, String propKey)

    • getShell

      public static org.eclipse.swt.widgets.Shell getShell()

    • replaceAll

      public static String replaceAll(String base, String search, String replace)

    • getDefaultPvxPath

      public static String getDefaultPvxPath()

    • showPvxPrefPage

      public static void showPvxPrefPage()

    • getPvxPath

      public static String getPvxPath(org.eclipse.core.resources.IResource srcFile)

    • getPvxPath

      public static String getPvxPath(org.eclipse.core.resources.IResource srcFile, boolean informUser)

    • traceEvent

      public static final void traceEvent(String eventName, String detail, Properties buildProps)

    • log

      public static final void log(Throwable t)

    • log

      public static final void log(String message, Throwable t)

    • writeToConsole

      public static void writeToConsole(String msg)

    • showMessageDialogue

      public static void showMessageDialogue(String title, String msg)

    • showMessageOnStatusBar

      public static void showMessageOnStatusBar(String msg, org.eclipse.ui.IViewPart view)

    • showMessageOnStatusBar

      public static void showMessageOnStatusBar(String msg, org.eclipse.ui.IEditorPart editor)

    • showConfirmDialogue

      public static boolean showConfirmDialogue(String title, String msg)

    • showWarningDialogue

      public static void showWarningDialogue(String title, String msg)

    • showErrorDialogue

      public static void showErrorDialogue(String title, String msg)

    • createChooseProjectDial

      public static org.eclipse.core.resources.IProject createChooseProjectDial(org.eclipse.core.resources.IProject[] projects, org.eclipse.core.resources.IProject pvxProject, org.eclipse.swt.widgets.Shell shell)

    • createChooseResourceDial

      public static org.eclipse.core.resources.IResource createChooseResourceDial(org.eclipse.core.resources.IContainer rootContainer, org.eclipse.core.resources.IProject pvxProject, org.eclipse.swt.widgets.Shell shell, String title, String msg, int type)

    • isPvxProject

      public static final boolean isPvxProject(org.eclipse.core.resources.IProject project)

    • findPvxProjects

      public static final org.eclipse.core.resources.IProject[] findPvxProjects()

    • getWorkspaceRoot

      public static org.eclipse.core.resources.IWorkspaceRoot getWorkspaceRoot()

    • getProjectsInPropertiesFile

      public static Hashtable getProjectsInPropertiesFile(String filePth)

    • addBuilder

      public static void addBuilder(org.eclipse.core.resources.IProjectDescription desc, String id, String outputDir, String outputLinkDir, String inputDir, String inputLinkDir)

    • addNature

      public static void addNature(org.eclipse.core.resources.IProjectDescription description)

    • isNumericArg

      public static final boolean isNumericArg(String str)

    • getDataTypeForPref

      public static final int getDataTypeForPref(String key)

    • syncFolders

      public static final void syncFolders(org.eclipse.core.resources.IResource resToSync, org.eclipse.core.resources.IResource targetRes)
      Parameters:
      folderToSync - the folder to create all children in
      targetFolder - the folder to duplicate

    • getNavView

      public static final org.eclipse.ui.IViewPart getNavView()

    • getProjectFromNavView

      public static final org.eclipse.core.resources.IProject getProjectFromNavView()

    • getProjectViaEditor

      public static org.eclipse.core.resources.IProject getProjectViaEditor()

    • openPvxEditor

      public static void openPvxEditor(org.eclipse.core.resources.IFile file)

    • getActivePvxEditor

      public static final PvxEditor getActivePvxEditor()

    • addVersionPluginVersion

      public static final void addVersionPluginVersion(org.eclipse.core.resources.IResource resource) throws org.eclipse.core.runtime.CoreException
      Throws:
      org.eclipse.core.runtime.CoreException

    • getImage

      public static org.eclipse.swt.graphics.Image getImage(String pluginId, String imagePath)
      Parameters:
      pluginId - Id of Plugin (E.G: "com.pvx.ooadide") for imageDescriptorFromPlugin
      imagePath - path to image
      Returns:

    • toStandardOut

      public static final void toStandardOut(String str)


PvxUtil.ConfirmDialShower

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.util

Class PvxUtil.ConfirmDialShower

java.lang.Object
com.pvx.ooadide.util.PvxUtil.ConfirmDialShower
All Implemented Interfaces:
Runnable
Enclosing class:
PvxUtil
public static class PvxUtil.ConfirmDialShower extends Object implements Runnable

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    String
    message
    String
    title

  • Constructor Summary

    Constructors
    Constructor
    Description
    ConfirmDialShower(String initTitle, String initMessage)

  • Method Summary

    Modifier and Type
    Method
    Description
    boolean
    isDoable()
    void
    run()

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Field Details

    • title

      public String title

    • message

      public String message

  • Constructor Details

    • ConfirmDialShower

      public ConfirmDialShower(String initTitle, String initMessage)

  • Method Details

    • run

      public void run()
      Specified by:
      run in interface Runnable

    • isDoable

      public boolean isDoable()


PvxVersionInfo

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.util

Class PvxVersionInfo

java.lang.Object
com.pvx.ooadide.util.PvxVersionInfo
public class PvxVersionInfo extends Object

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxVersionInfo(int level, String msg, String pTcb29)

  • Method Summary

    Modifier and Type
    Method
    Description
    int
    getActivationLevel()
    String
    getDebugInfo()
    String
    getTcb29()

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • PvxVersionInfo

      public PvxVersionInfo(int level, String msg, String pTcb29)

  • Method Details

    • getActivationLevel

      public int getActivationLevel()

    • getDebugInfo

      public String getDebugInfo()

    • getTcb29

      public String getTcb29()


RunPvxTester

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.util

Class RunPvxTester

java.lang.Object
com.pvx.ooadide.util.RunPvxTester
public class RunPvxTester extends Object

  • Constructor Summary

    Constructors
    Constructor
    Description
    RunPvxTester()

  • Method Summary

    Modifier and Type
    Method
    Description
    static void
    main(String[] args)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • RunPvxTester

      public RunPvxTester()

  • Method Details

    • main

      public static void main(String[] args)
      Parameters:
      args -


RunUtil

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.util

Class RunUtil

java.lang.Object
com.pvx.ooadide.util.RunUtil
public class RunUtil extends Object

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final String
    DICT_DATA_CLASS
    static final String
    DICT_MAINT_PROGRAM
    static final String
    EXE_VERIFY_PROGRAM
    static final String
    IOLIST_SCANNER_PROGRAM
    static final String
    IT_PROGRAM
    static final String
    LIB_SCANNER_PROGRAM
    static final String
    NOMADS_PROGRAM
    static final String
    NTHOST_PROGRAM
    static final String
    PVX_CONSOLE
    static final String
    PVXENTRY_PRG
    static final String
    PVXHELPER_DIR
    static final String
    STRIPPER_PROGRAM

  • Constructor Summary

    Constructors
    Constructor
    Description
    RunUtil()

  • Method Summary

    Modifier and Type
    Method
    Description
    static boolean
    findMatchingContributedTool(String desc, Properties props)
    static String
    getOutputDirectory(org.eclipse.core.resources.IProject project)
    static final String
    getPathToIni(org.eclipse.core.resources.IProject project)
    static PvxVersionInfo
    getPvxExeVersion(String exePath)
    static String
    getRunningExecutable()
    static Properties
    getStandardArgs(org.eclipse.core.resources.IProject project)
    static void
    invokeContributedTool(String desc)
    static void
    invokeContributedTool(String desc, boolean wait)
    static void
    loadProgram(org.eclipse.core.resources.IProject project, String programName)
    static final void
    processPanel(String evtName, String entryPoint, org.eclipse.core.resources.IProject project, String panel, String lib, String type, String outputLib, boolean waitForComplete)
    static void
    runConsole(org.eclipse.core.resources.IProject project)
    static void
    runDictDataClass(org.eclipse.core.resources.IProject project, String outputDir, String selectedFile)
    static void
    runDictMaint(org.eclipse.core.resources.IProject project, String outputDir, String selectedFile)
    static void
    runIOListScanner(org.eclipse.core.resources.IProject curProject, String pth, String libLog)
    static final void
    runIT(org.eclipse.core.resources.IFile file)
    static final void
    runLibScanner(org.eclipse.core.resources.IProject curProject, String pth, String libLog)
    static final void
    runNomads()
    static final boolean
    runNtHost(int socket)
    static final boolean
    runNtHost(String[] args)
    static boolean
    runProgram(String eventName, String programName, String windowState, String pvxINI, String[] arguments, boolean waitForCompletion)
    static boolean
    runProgram(String eventName, String programName, String windowState, String pvxINI, String[] arguments, boolean waitForCompletion, Properties props)
    static boolean
    runProgram(String executablePathStr, String eventName, String programName, String windowState, String pvxINI, String[] arguments, boolean waitForCompletion, boolean firstTryEventManager, Properties props)
    static void
    runStripper(org.eclipse.core.resources.IProject project, String fileLocation, String fileLock)
    static void
    setRunningExecutable(String runningExecutable)
    static boolean
    validateExecutable(String exePath)
    static final void
    verifyPvxExe(String output, String exeProgramPath)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Field Details

    • PVXHELPER_DIR

      public static final String PVXHELPER_DIR

    • PVXENTRY_PRG

      public static final String PVXENTRY_PRG

    • NOMADS_PROGRAM

      public static final String NOMADS_PROGRAM

    • DICT_MAINT_PROGRAM

      public static final String DICT_MAINT_PROGRAM

    • DICT_DATA_CLASS

      public static final String DICT_DATA_CLASS

    • IOLIST_SCANNER_PROGRAM

      public static final String IOLIST_SCANNER_PROGRAM

    • IT_PROGRAM

      public static final String IT_PROGRAM

    • STRIPPER_PROGRAM

      public static final String STRIPPER_PROGRAM

    • EXE_VERIFY_PROGRAM

      public static final String EXE_VERIFY_PROGRAM

    • PVX_CONSOLE

      public static final String PVX_CONSOLE

    • NTHOST_PROGRAM

      public static final String NTHOST_PROGRAM

    • LIB_SCANNER_PROGRAM

      public static final String LIB_SCANNER_PROGRAM

  • Constructor Details

    • RunUtil

      public RunUtil()

  • Method Details

    • invokeContributedTool

      public static void invokeContributedTool(String desc)

    • invokeContributedTool

      public static void invokeContributedTool(String desc, boolean wait)

    • findMatchingContributedTool

      public static boolean findMatchingContributedTool(String desc, Properties props)

    • getPvxExeVersion

      public static PvxVersionInfo getPvxExeVersion(String exePath)

    • validateExecutable

      public static boolean validateExecutable(String exePath)

    • verifyPvxExe

      public static final void verifyPvxExe(String output, String exeProgramPath)

    • runNtHost

      public static final boolean runNtHost(int socket)

    • runNtHost

      public static final boolean runNtHost(String[] args)

    • runIT

      public static final void runIT(org.eclipse.core.resources.IFile file)

    • runLibScanner

      public static final void runLibScanner(org.eclipse.core.resources.IProject curProject, String pth, String libLog)

    • runIOListScanner

      public static void runIOListScanner(org.eclipse.core.resources.IProject curProject, String pth, String libLog)

    • runNomads

      public static final void runNomads()

    • processPanel

      public static final void processPanel(String evtName, String entryPoint, org.eclipse.core.resources.IProject project, String panel, String lib, String type, String outputLib, boolean waitForComplete)

    • getPathToIni

      public static final String getPathToIni(org.eclipse.core.resources.IProject project)

    • runStripper

      public static void runStripper(org.eclipse.core.resources.IProject project, String fileLocation, String fileLock)

    • runDictMaint

      public static void runDictMaint(org.eclipse.core.resources.IProject project, String outputDir, String selectedFile)

    • runDictDataClass

      public static void runDictDataClass(org.eclipse.core.resources.IProject project, String outputDir, String selectedFile)

    • getStandardArgs

      public static Properties getStandardArgs(org.eclipse.core.resources.IProject project)

    • loadProgram

      public static void loadProgram(org.eclipse.core.resources.IProject project, String programName)

    • getOutputDirectory

      public static String getOutputDirectory(org.eclipse.core.resources.IProject project)

    • runConsole

      public static void runConsole(org.eclipse.core.resources.IProject project)

    • runProgram

      public static boolean runProgram(String eventName, String programName, String windowState, String pvxINI, String[] arguments, boolean waitForCompletion)

    • runProgram

      public static boolean runProgram(String eventName, String programName, String windowState, String pvxINI, String[] arguments, boolean waitForCompletion, Properties props)

    • runProgram

      public static boolean runProgram(String executablePathStr, String eventName, String programName, String windowState, String pvxINI, String[] arguments, boolean waitForCompletion, boolean firstTryEventManager, Properties props)

    • setRunningExecutable

      public static void setRunningExecutable(String runningExecutable)

    • getRunningExecutable

      public static String getRunningExecutable()


StopWatch

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.util

Class StopWatch

java.lang.Object
com.pvx.ooadide.util.StopWatch
public class StopWatch extends Object

  • Constructor Summary

    Constructors
    Constructor
    Description
    StopWatch()

  • Method Summary

    Modifier and Type
    Method
    Description
    static long
    getElapsedTime()
    static void
    reset()
    static void
    start()
    static void
    stop()

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • StopWatch

      public StopWatch()

  • Method Details

    • start

      public static void start()

    • stop

      public static void stop()

    • getElapsedTime

      public static long getElapsedTime()

    • reset

      public static void reset()


UtilCommands

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.util

Class UtilCommands

java.lang.Object
com.pvx.ooadide.util.UtilCommands
public class UtilCommands extends Object

  • Constructor Summary

    Constructors
    Constructor
    Description
    UtilCommands()

  • Method Summary

    Modifier and Type
    Method
    Description
    static org.eclipse.core.resources.IResource[]
    getCommonNavigatorResources(org.eclipse.ui.navigator.CommonNavigator resNav)
    static org.eclipse.core.resources.IResource[]
    getNavigatorResources(org.eclipse.ui.IWorkbenchPart navPart)
    static String
    getOsUserName()

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • UtilCommands

      public UtilCommands()

  • Method Details

    • getNavigatorResources

      public static org.eclipse.core.resources.IResource[] getNavigatorResources(org.eclipse.ui.IWorkbenchPart navPart)

    • getCommonNavigatorResources

      public static org.eclipse.core.resources.IResource[] getCommonNavigatorResources(org.eclipse.ui.navigator.CommonNavigator resNav)

    • getOsUserName

      public static String getOsUserName()


Uses of Class com.pvx.ooadide.util.DefaultItemContentProvider

Uses of Class
com.pvx.ooadide.util.DefaultItemContentProvider

No usage of com.pvx.ooadide.util.DefaultItemContentProvider


Uses of Class com.pvx.ooadide.util.DefaultLabelProvider

Uses of Class
com.pvx.ooadide.util.DefaultLabelProvider

No usage of com.pvx.ooadide.util.DefaultLabelProvider


Uses of Class com.pvx.ooadide.util.ExtensionUtil

Uses of Class
com.pvx.ooadide.util.ExtensionUtil

No usage of com.pvx.ooadide.util.ExtensionUtil


Uses of Class com.pvx.ooadide.util.PixelConverter

Uses of Class
com.pvx.ooadide.util.PixelConverter

No usage of com.pvx.ooadide.util.PixelConverter


Uses of Class com.pvx.ooadide.util.ProcessRunner

Uses of Class
com.pvx.ooadide.util.ProcessRunner

No usage of com.pvx.ooadide.util.ProcessRunner


Uses of Class com.pvx.ooadide.util.ProjectUtils

Uses of Class
com.pvx.ooadide.util.ProjectUtils

No usage of com.pvx.ooadide.util.ProjectUtils


Uses of Class com.pvx.ooadide.util.PvxElement

Uses of Class
com.pvx.ooadide.util.PvxElement

No usage of com.pvx.ooadide.util.PvxElement


Uses of Class com.pvx.ooadide.util.PvxFileUtils

Uses of Class
com.pvx.ooadide.util.PvxFileUtils

No usage of com.pvx.ooadide.util.PvxFileUtils


Uses of Class com.pvx.ooadide.util.PvxUtil

Uses of Class
com.pvx.ooadide.util.PvxUtil

No usage of com.pvx.ooadide.util.PvxUtil


Uses of Class com.pvx.ooadide.util.PvxUtil.ConfirmDialShower

Uses of Class
com.pvx.ooadide.util.PvxUtil.ConfirmDialShower

No usage of com.pvx.ooadide.util.PvxUtil.ConfirmDialShower


Uses of Class com.pvx.ooadide.util.PvxVersionInfo

Uses of Class
com.pvx.ooadide.util.PvxVersionInfo

Packages that use PvxVersionInfo
Package
Description
com.pvx.ooadide.util

  • Uses of PvxVersionInfo in com.pvx.ooadide.util

    Methods in com.pvx.ooadide.util that return PvxVersionInfo
    Modifier and Type
    Method
    Description
    static PvxVersionInfo
    RunUtil.getPvxExeVersion(String exePath)


Uses of Class com.pvx.ooadide.util.RunPvxTester

Uses of Class
com.pvx.ooadide.util.RunPvxTester

No usage of com.pvx.ooadide.util.RunPvxTester


Uses of Class com.pvx.ooadide.util.RunUtil

Uses of Class
com.pvx.ooadide.util.RunUtil

No usage of com.pvx.ooadide.util.RunUtil


Uses of Class com.pvx.ooadide.util.StopWatch

Uses of Class
com.pvx.ooadide.util.StopWatch

No usage of com.pvx.ooadide.util.StopWatch


Uses of Class com.pvx.ooadide.util.UtilCommands

Uses of Class
com.pvx.ooadide.util.UtilCommands

No usage of com.pvx.ooadide.util.UtilCommands


AbstractProgressController

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.views

Class AbstractProgressController

java.lang.Object
com.pvx.ooadide.views.AbstractProgressController
Direct Known Subclasses:
PvxRunnableWithProgress
public abstract class AbstractProgressController extends Object

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final int
    P_ALL
    static final int
    P_SUB_TASKNAME
    static final int
    P_TASKNAME
    static final int
    P_VISIBLE
    static final int
    P_WORKED

  • Constructor Summary

    Constructors
    Constructor
    Description
    AbstractProgressController()

  • Method Summary

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Field Details

    • P_ALL

      public static final int P_ALL
      See Also:
      • Constant Field Values

    • P_TASKNAME

      public static final int P_TASKNAME
      See Also:
      • Constant Field Values

    • P_SUB_TASKNAME

      public static final int P_SUB_TASKNAME
      See Also:
      • Constant Field Values

    • P_VISIBLE

      public static final int P_VISIBLE
      See Also:
      • Constant Field Values

    • P_WORKED

      public static final int P_WORKED
      See Also:
      • Constant Field Values

  • Constructor Details

    • AbstractProgressController

      public AbstractProgressController()


IOListView

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.views

Class IOListView

java.lang.Object
org.eclipse.core.commands.common.EventManager
org.eclipse.ui.part.WorkbenchPart
org.eclipse.ui.part.ViewPart
com.pvx.ooadide.views.nomads.LibView
com.pvx.ooadide.views.IOListView
All Implemented Interfaces:
PvxView, org.eclipse.core.runtime.IAdaptable, org.eclipse.core.runtime.IExecutableExtension, org.eclipse.ui.IPersistable, org.eclipse.ui.IViewPart, org.eclipse.ui.IWorkbenchPart, org.eclipse.ui.IWorkbenchPart2, org.eclipse.ui.IWorkbenchPart3, org.eclipse.ui.part.IWorkbenchPartOrientation
public class IOListView extends LibView

  • Nested Class Summary

    Nested Classes
    Modifier and Type
    Class
    Description
    class
    IOListView.IOListLabelProvider

    Nested classes/interfaces inherited from class com.pvx.ooadide.views.nomads.LibView

    LibView.ViewContentProvider, LibView.ViewLabelProvider

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final int
    DICT_ALT_NME
    static final int
    DICT_DESCR
    static final int
    DICT_ENTRY
    static final int
    DICT_FMT_MASK
    static final int
    DICT_LEN
    static final int
    DICT_NME
    static final int
    DICT_TYPE
    static final String
    ID
    static final String
    IOLOG_NAME
    static final int
    numbObjElemnts
    static final int
    REQ_EXT

    Fields inherited from class com.pvx.ooadide.views.nomads.LibView

    CHARSET, LIBLOG_NAME, NOMADS_systemDefaults, sep, WINDEFINE_PROGRAM, WINTEST_PROGRAM

    Fields inherited from interface org.eclipse.ui.IWorkbenchPart

    PROP_TITLE

  • Constructor Summary

    Constructors
    Constructor
    Description
    IOListView()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    createPartControl(org.eclipse.swt.widgets.Composite parent)
    This is a callback that will allow us to create the viewer and initialize it.
    void
    refresh()
    void
    setFocus()
    Passing the focus request to the viewer's control.

    Methods inherited from class com.pvx.ooadide.views.nomads.LibView

    changeViewFile, dispose, openWinDefineView, scanLog

    Methods inherited from class org.eclipse.ui.part.ViewPart

    getViewSite, init, init, saveState, setInitializationData

    Methods inherited from class org.eclipse.ui.part.WorkbenchPart

    addPartPropertyListener, addPropertyListener, getAdapter, getContentDescription, getOrientation, getPartName, getPartProperties, getPartProperty, getSite, getTitle, getTitleImage, getTitleToolTip, removePartPropertyListener, removePropertyListener, setPartProperty, showBusy

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface org.eclipse.core.runtime.IAdaptable

    getAdapter

    Methods inherited from interface org.eclipse.ui.IWorkbenchPart

    addPropertyListener, getSite, getTitle, getTitleImage, getTitleToolTip, removePropertyListener

  • Field Details

    • ID

      public static final String ID
      See Also:
      • Constant Field Values

    • IOLOG_NAME

      public static final String IOLOG_NAME
      See Also:
      • Constant Field Values

    • DICT_ENTRY

      public static final int DICT_ENTRY
      See Also:
      • Constant Field Values

    • DICT_NME

      public static final int DICT_NME
      See Also:
      • Constant Field Values

    • DICT_DESCR

      public static final int DICT_DESCR
      See Also:
      • Constant Field Values

    • DICT_TYPE

      public static final int DICT_TYPE
      See Also:
      • Constant Field Values

    • DICT_FMT_MASK

      public static final int DICT_FMT_MASK
      See Also:
      • Constant Field Values

    • DICT_LEN

      public static final int DICT_LEN
      See Also:
      • Constant Field Values

    • DICT_ALT_NME

      public static final int DICT_ALT_NME
      See Also:
      • Constant Field Values

    • REQ_EXT

      public static final int REQ_EXT
      See Also:
      • Constant Field Values

    • numbObjElemnts

      public static final int numbObjElemnts
      See Also:
      • Constant Field Values

  • Constructor Details

    • IOListView

      public IOListView()

  • Method Details

    • createPartControl

      public void createPartControl(org.eclipse.swt.widgets.Composite parent)
      Description copied from class: LibView
      This is a callback that will allow us to create the viewer and initialize it.
      Specified by:
      createPartControl in interface org.eclipse.ui.IWorkbenchPart
      Overrides:
      createPartControl in class LibView

    • setFocus

      public void setFocus()
      Description copied from class: LibView
      Passing the focus request to the viewer's control.
      Specified by:
      setFocus in interface org.eclipse.ui.IWorkbenchPart
      Overrides:
      setFocus in class LibView

    • refresh

      public void refresh()
      Specified by:
      refresh in interface PvxView
      Overrides:
      refresh in class LibView


IOListView.IOListLabelProvider

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.views

Class IOListView.IOListLabelProvider

java.lang.Object
org.eclipse.core.commands.common.EventManager
org.eclipse.jface.viewers.BaseLabelProvider
org.eclipse.jface.viewers.LabelProvider
com.pvx.ooadide.views.IOListView.IOListLabelProvider
All Implemented Interfaces:
org.eclipse.jface.viewers.IBaseLabelProvider, org.eclipse.jface.viewers.ILabelProvider, org.eclipse.jface.viewers.ITableLabelProvider
Enclosing class:
IOListView
public class IOListView.IOListLabelProvider extends org.eclipse.jface.viewers.LabelProvider implements org.eclipse.jface.viewers.ITableLabelProvider

  • Constructor Summary

    Constructors
    Constructor
    Description
    IOListLabelProvider()

  • Method Summary

    Modifier and Type
    Method
    Description
    org.eclipse.swt.graphics.Image
    getColumnImage(Object obj, int index)
    String
    getColumnText(Object obj, int index)

    Methods inherited from class org.eclipse.jface.viewers.LabelProvider

    getImage, getText

    Methods inherited from class org.eclipse.jface.viewers.BaseLabelProvider

    addListener, dispose, isLabelProperty, removeListener

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface org.eclipse.jface.viewers.IBaseLabelProvider

    addListener, dispose, isLabelProperty, removeListener

  • Constructor Details

    • IOListLabelProvider

      public IOListLabelProvider()

  • Method Details

    • getColumnText

      public String getColumnText(Object obj, int index)
      Specified by:
      getColumnText in interface org.eclipse.jface.viewers.ITableLabelProvider

    • getColumnImage

      public org.eclipse.swt.graphics.Image getColumnImage(Object obj, int index)
      Specified by:
      getColumnImage in interface org.eclipse.jface.viewers.ITableLabelProvider


JavXBrowserView

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.views

Class JavXBrowserView

java.lang.Object
org.eclipse.core.commands.common.EventManager
org.eclipse.ui.part.WorkbenchPart
org.eclipse.ui.part.ViewPart
com.pvx.ooadide.views.JavXBrowserView
All Implemented Interfaces:
org.eclipse.core.runtime.IAdaptable, org.eclipse.core.runtime.IExecutableExtension, org.eclipse.ui.IPersistable, org.eclipse.ui.IViewPart, org.eclipse.ui.IWorkbenchPart, org.eclipse.ui.IWorkbenchPart2, org.eclipse.ui.IWorkbenchPart3, org.eclipse.ui.part.IWorkbenchPartOrientation
public class JavXBrowserView extends org.eclipse.ui.part.ViewPart
This sample class demonstrates how to plug-in a new workbench view. The view shows data obtained from the model. The sample creates a dummy model on the fly, but a real implementation would connect to the model available either in this or another plug-in (e.g. the workspace). The view is connected to the model using a content provider.

The view uses a label provider to define how model objects should be presented in the view. Each view can present the same model objects using different labels and icons, if needed. Alternatively, a single label provider can be shared between views in order to ensure that objects of the same type are presented in the same way everywhere.

  • Field Summary

    Fields inherited from interface org.eclipse.ui.IWorkbenchPart

    PROP_TITLE

  • Constructor Summary

    Constructors
    Constructor
    Description
    JavXBrowserView()
    The constructor.

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    createPartControl(org.eclipse.swt.widgets.Composite parent)
    This is a callback that will allow us to create the viewer and initialize it.
    void
    dispose()
    void
    openPvxEditor(org.eclipse.core.resources.IFile file)
    void
    setFocus()
    Passing the focus request to the viewer's control.

    Methods inherited from class org.eclipse.ui.part.ViewPart

    getViewSite, init, init, saveState, setInitializationData

    Methods inherited from class org.eclipse.ui.part.WorkbenchPart

    addPartPropertyListener, addPropertyListener, getAdapter, getContentDescription, getOrientation, getPartName, getPartProperties, getPartProperty, getSite, getTitle, getTitleImage, getTitleToolTip, removePartPropertyListener, removePropertyListener, setPartProperty, showBusy

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface org.eclipse.core.runtime.IAdaptable

    getAdapter

    Methods inherited from interface org.eclipse.ui.IWorkbenchPart

    addPropertyListener, getSite, getTitle, getTitleImage, getTitleToolTip, removePropertyListener

  • Constructor Details

    • JavXBrowserView

      public JavXBrowserView()
      The constructor.

  • Method Details

    • createPartControl

      public void createPartControl(org.eclipse.swt.widgets.Composite parent)
      This is a callback that will allow us to create the viewer and initialize it.
      Specified by:
      createPartControl in interface org.eclipse.ui.IWorkbenchPart
      Specified by:
      createPartControl in class org.eclipse.ui.part.WorkbenchPart

    • setFocus

      public void setFocus()
      Passing the focus request to the viewer's control.
      Specified by:
      setFocus in interface org.eclipse.ui.IWorkbenchPart
      Specified by:
      setFocus in class org.eclipse.ui.part.WorkbenchPart

    • dispose

      public void dispose()
      Specified by:
      dispose in interface org.eclipse.ui.IWorkbenchPart
      Overrides:
      dispose in class org.eclipse.ui.part.WorkbenchPart

    • openPvxEditor

      public void openPvxEditor(org.eclipse.core.resources.IFile file)


MonitorState

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.views

Class MonitorState

java.lang.Object
com.pvx.ooadide.views.MonitorState
public class MonitorState extends Object
Since:
1.0

  • Constructor Summary

    Constructors
    Constructor
    Description
    MonitorState()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    cancel()
    void
    done()
    String
    getTaskDetail()
    String
    getTaskName()
    int
    getWorked()
    boolean
    isCancelled()
    boolean
    isDialogueVisible()
    boolean
    isDone()
    void
    setDialogueVisible(boolean vis)
    void
    setRunnable(PvxRunnableWithProgress initRunner)
    void
    setTaskDetail(String taskDetail)
    void
    setTaskName(String taskName)
    void
    setWorked(int initworked)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • MonitorState

      public MonitorState()

  • Method Details

    • setRunnable

      public void setRunnable(PvxRunnableWithProgress initRunner)

    • done

      public void done()

    • isDone

      public boolean isDone()

    • isCancelled

      public boolean isCancelled()

    • cancel

      public void cancel()

    • setWorked

      public void setWorked(int initworked)

    • getWorked

      public int getWorked()

    • setDialogueVisible

      public void setDialogueVisible(boolean vis)

    • isDialogueVisible

      public boolean isDialogueVisible()

    • setTaskName

      public void setTaskName(String taskName)

    • getTaskName

      public String getTaskName()

    • setTaskDetail

      public void setTaskDetail(String taskDetail)

    • getTaskDetail

      public String getTaskDetail()


com.pvx.ooadide.views

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.pvx.ooadide.views

package com.pvx.ooadide.views
  • Related Packages
    Package
    Description
    com.pvx.ooadide
    com.pvx.ooadide.views.comparators
    com.pvx.ooadide.views.nomads
  • Class
    Description
    AbstractProgressController
    IOListView
    JavXBrowserView
    This sample class demonstrates how to plug-in a new workbench view.
    MonitorState
    PvcOutline
    PvcOutline.OutlineFilter
    PvcOutline.OutlineSortBy
    PvcOutlineSettings
    PvxPerspectiveFactory
    PvxProgressMonitorDialog
    PvxRunnableWithProgress
    PvxView
    PvxViewSorter
    UIManager
    Provides an Interface to the Eclipse GUI for ProvideX programs
    WinDefine


com.pvx.ooadide.views Class Hierarchy

Hierarchy For Package com.pvx.ooadide.views

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • com.pvx.ooadide.views.AbstractProgressController
      • com.pvx.ooadide.views.PvxRunnableWithProgress (implements org.eclipse.jface.operation.IRunnableWithProgress)
    • org.eclipse.core.commands.common.EventManager
      • org.eclipse.jface.viewers.BaseLabelProvider (implements org.eclipse.jface.viewers.IBaseLabelProvider)
        • org.eclipse.jface.viewers.LabelProvider (implements org.eclipse.jface.viewers.ILabelProvider)
          • com.pvx.ooadide.views.IOListView.IOListLabelProvider (implements org.eclipse.jface.viewers.ITableLabelProvider)
      • org.eclipse.ui.part.WorkbenchPart (implements org.eclipse.core.runtime.IExecutableExtension, org.eclipse.ui.IWorkbenchPart3, org.eclipse.ui.part.IWorkbenchPartOrientation)
        • org.eclipse.ui.part.ViewPart (implements org.eclipse.ui.IViewPart)
          • com.sage.rcp.views.HostActionsView (implements javxbaseui.AbstractGUIManagerFactory, com.sage.rcp.javx.IEmbeddedJavXView)
            • com.pvx.ooadide.views.WinDefine
          • com.pvx.ooadide.views.JavXBrowserView
          • com.pvx.ooadide.views.nomads.LibView (implements com.pvx.ooadide.views.PvxView)
            • com.pvx.ooadide.views.IOListView
          • com.pvx.ooadide.views.PvcOutline
    • com.pvx.ooadide.views.MonitorState
    • com.pvx.ooadide.views.PvcOutlineSettings
    • com.pvx.ooadide.views.PvxPerspectiveFactory (implements org.eclipse.ui.IPerspectiveFactory)
    • com.pvx.ooadide.views.UIManager
    • org.eclipse.jface.viewers.ViewerComparator
      • com.pvx.ooadide.views.PvxViewSorter
    • org.eclipse.jface.window.Window (implements org.eclipse.jface.window.IShellProvider)
      • org.eclipse.jface.dialogs.Dialog
        • org.eclipse.jface.dialogs.IconAndMessageDialog
          • org.eclipse.jface.dialogs.ProgressMonitorDialog (implements org.eclipse.jface.operation.IRunnableContext)
            • com.pvx.ooadide.views.PvxProgressMonitorDialog

Interface Hierarchy

  • com.pvx.ooadide.views.PvxView

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.lang.constant.Constable, java.io.Serializable)
      • com.pvx.ooadide.views.PvcOutline.OutlineFilter
      • com.pvx.ooadide.views.PvcOutline.OutlineSortBy


Uses of Package com.pvx.ooadide.views

Uses of Package
com.pvx.ooadide.views

Packages that use com.pvx.ooadide.views
Package
Description
com.pvx.ooadide
com.pvx.ooadide.launchers.debug.communication
com.pvx.ooadide.views
com.pvx.ooadide.views.nomads
  • Classes in com.pvx.ooadide.views used by com.pvx.ooadide
    Class
    Description
    PvcOutlineSettings
  • Classes in com.pvx.ooadide.views used by com.pvx.ooadide.launchers.debug.communication
    Class
    Description
    MonitorState
  • Classes in com.pvx.ooadide.views used by com.pvx.ooadide.views
    Class
    Description
    AbstractProgressController
    MonitorState
    PvcOutline.OutlineFilter
    PvcOutline.OutlineSortBy
    PvxProgressMonitorDialog
    PvxRunnableWithProgress
    PvxView
  • Classes in com.pvx.ooadide.views used by com.pvx.ooadide.views.nomads
    Class
    Description
    PvxView


PvcOutline

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.views

Class PvcOutline

java.lang.Object
org.eclipse.core.commands.common.EventManager
org.eclipse.ui.part.WorkbenchPart
org.eclipse.ui.part.ViewPart
com.pvx.ooadide.views.PvcOutline
All Implemented Interfaces:
org.eclipse.core.runtime.IAdaptable, org.eclipse.core.runtime.IExecutableExtension, org.eclipse.ui.IPersistable, org.eclipse.ui.IViewPart, org.eclipse.ui.IWorkbenchPart, org.eclipse.ui.IWorkbenchPart2, org.eclipse.ui.IWorkbenchPart3, org.eclipse.ui.part.IWorkbenchPartOrientation
public class PvcOutline extends org.eclipse.ui.part.ViewPart

  • Nested Class Summary

    Nested Classes
    Modifier and Type
    Class
    Description
    static enum
    PvcOutline.OutlineFilter
    static enum
    PvcOutline.OutlineSortBy

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final String
    ID

    Fields inherited from interface org.eclipse.ui.IWorkbenchPart

    PROP_TITLE

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvcOutline()
    The constructor.

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    createPartControl(org.eclipse.swt.widgets.Composite parent)
    This is a callback that will allow us to create the viewer and initialize it.
    void
    dispose()
    static final org.eclipse.ui.IEditorPart
    getActiveEditor()
    static org.eclipse.core.resources.IFile
    getEditingFile()
    static final String
    getEditingFileName()
    void
    setFocus()
    Passing the focus request to the viewer's control.
    void
    updateDomList(boolean rebuilt, org.eclipse.core.resources.IFile curEdit)

    Methods inherited from class org.eclipse.ui.part.ViewPart

    getViewSite, init, init, saveState, setInitializationData

    Methods inherited from class org.eclipse.ui.part.WorkbenchPart

    addPartPropertyListener, addPropertyListener, getAdapter, getContentDescription, getOrientation, getPartName, getPartProperties, getPartProperty, getSite, getTitle, getTitleImage, getTitleToolTip, removePartPropertyListener, removePropertyListener, setPartProperty, showBusy

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface org.eclipse.core.runtime.IAdaptable

    getAdapter

    Methods inherited from interface org.eclipse.ui.IWorkbenchPart

    addPropertyListener, getSite, getTitle, getTitleImage, getTitleToolTip, removePropertyListener

  • Field Details

    • ID

      public static final String ID
      See Also:
      • Constant Field Values

  • Constructor Details

    • PvcOutline

      public PvcOutline()
      The constructor.

  • Method Details

    • createPartControl

      public void createPartControl(org.eclipse.swt.widgets.Composite parent)
      This is a callback that will allow us to create the viewer and initialize it.
      Specified by:
      createPartControl in interface org.eclipse.ui.IWorkbenchPart
      Specified by:
      createPartControl in class org.eclipse.ui.part.WorkbenchPart

    • setFocus

      public void setFocus()
      Passing the focus request to the viewer's control.
      Specified by:
      setFocus in interface org.eclipse.ui.IWorkbenchPart
      Specified by:
      setFocus in class org.eclipse.ui.part.WorkbenchPart

    • dispose

      public void dispose()
      Specified by:
      dispose in interface org.eclipse.ui.IWorkbenchPart
      Overrides:
      dispose in class org.eclipse.ui.part.WorkbenchPart

    • getActiveEditor

      public static final org.eclipse.ui.IEditorPart getActiveEditor()

    • getEditingFile

      public static org.eclipse.core.resources.IFile getEditingFile()

    • getEditingFileName

      public static final String getEditingFileName()

    • updateDomList

      public void updateDomList(boolean rebuilt, org.eclipse.core.resources.IFile curEdit)


PvcOutline.OutlineFilter

  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
Package com.pvx.ooadide.views

Enum PvcOutline.OutlineFilter

java.lang.Object
java.lang.Enum<PvcOutline.OutlineFilter>
com.pvx.ooadide.views.PvcOutline.OutlineFilter
All Implemented Interfaces:
Serializable, Comparable<PvcOutline.OutlineFilter>, java.lang.constant.Constable
Enclosing class:
PvcOutline
public static enum PvcOutline.OutlineFilter extends Enum<PvcOutline.OutlineFilter>

  • Nested Class Summary

    Nested classes/interfaces inherited from class java.lang.Enum

    Enum.EnumDesc<E extends Enum<E>>

  • Enum Constant Summary

    Enum Constants
    Enum Constant
    Description
    LOCAL_FUNC_FILTER
    LOCAL_PROP_FILTER
    NO_FILTER
    PUB_FUNC_FILTER
    PUB_PROP_FILTER
    RTN_FILTER
    VARIABLE_FILTER

  • Method Summary

    Modifier and Type
    Method
    Description
    static PvcOutline.OutlineFilter
    valueOf(String name)
    Returns the enum constant of this type with the specified name.
    static PvcOutline.OutlineFilter[]
    values()
    Returns an array containing the constants of this enum type, in the order they are declared.

    Methods inherited from class java.lang.Enum

    compareTo, describeConstable, equals, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

    Methods inherited from class java.lang.Object

    getClass, notify, notifyAll, wait, wait, wait

  • Enum Constant Details

    • NO_FILTER

      public static final PvcOutline.OutlineFilter NO_FILTER

    • VARIABLE_FILTER

      public static final PvcOutline.OutlineFilter VARIABLE_FILTER

    • RTN_FILTER

      public static final PvcOutline.OutlineFilter RTN_FILTER

    • PUB_FUNC_FILTER

      public static final PvcOutline.OutlineFilter PUB_FUNC_FILTER

    • LOCAL_FUNC_FILTER

      public static final PvcOutline.OutlineFilter LOCAL_FUNC_FILTER

    • PUB_PROP_FILTER

      public static final PvcOutline.OutlineFilter PUB_PROP_FILTER

    • LOCAL_PROP_FILTER

      public static final PvcOutline.OutlineFilter LOCAL_PROP_FILTER

  • Method Details

    • values

      public static PvcOutline.OutlineFilter[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.
      Returns:
      an array containing the constants of this enum type, in the order they are declared

    • valueOf

      public static PvcOutline.OutlineFilter valueOf(String name)
      Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
      Parameters:
      name - the name of the enum constant to be returned.
      Returns:
      the enum constant with the specified name
      Throws:
      IllegalArgumentException - if this enum type has no constant with the specified name
      NullPointerException - if the argument is null


PvcOutline.OutlineSortBy

  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
Package com.pvx.ooadide.views

Enum PvcOutline.OutlineSortBy

java.lang.Object
java.lang.Enum<PvcOutline.OutlineSortBy>
com.pvx.ooadide.views.PvcOutline.OutlineSortBy
All Implemented Interfaces:
Serializable, Comparable<PvcOutline.OutlineSortBy>, java.lang.constant.Constable
Enclosing class:
PvcOutline
public static enum PvcOutline.OutlineSortBy extends Enum<PvcOutline.OutlineSortBy>

  • Nested Class Summary

    Nested classes/interfaces inherited from class java.lang.Enum

    Enum.EnumDesc<E extends Enum<E>>

  • Enum Constant Summary

    Enum Constants
    Enum Constant
    Description
    AS_GENERATED
    FILTERED
    GROUP
    LINE_NUMBER

  • Method Summary

    Modifier and Type
    Method
    Description
    static PvcOutline.OutlineSortBy
    valueOf(String name)
    Returns the enum constant of this type with the specified name.
    static PvcOutline.OutlineSortBy[]
    values()
    Returns an array containing the constants of this enum type, in the order they are declared.

    Methods inherited from class java.lang.Enum

    compareTo, describeConstable, equals, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

    Methods inherited from class java.lang.Object

    getClass, notify, notifyAll, wait, wait, wait

  • Enum Constant Details

    • GROUP

      public static final PvcOutline.OutlineSortBy GROUP

    • AS_GENERATED

      public static final PvcOutline.OutlineSortBy AS_GENERATED

    • LINE_NUMBER

      public static final PvcOutline.OutlineSortBy LINE_NUMBER

    • FILTERED

      public static final PvcOutline.OutlineSortBy FILTERED

  • Method Details

    • values

      public static PvcOutline.OutlineSortBy[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.
      Returns:
      an array containing the constants of this enum type, in the order they are declared

    • valueOf

      public static PvcOutline.OutlineSortBy valueOf(String name)
      Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
      Parameters:
      name - the name of the enum constant to be returned.
      Returns:
      the enum constant with the specified name
      Throws:
      IllegalArgumentException - if this enum type has no constant with the specified name
      NullPointerException - if the argument is null


PvcOutlineSettings

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.views

Class PvcOutlineSettings

java.lang.Object
com.pvx.ooadide.views.PvcOutlineSettings
public class PvcOutlineSettings extends Object

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvcOutlineSettings(PvcOutline.OutlineSortBy pSortBy, PvcOutline.OutlineFilter pFilter)

  • Method Summary

    Modifier and Type
    Method
    Description
    PvcOutline.OutlineFilter
    getFilter()
    PvcOutline.OutlineSortBy
    getSortBy()

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • PvcOutlineSettings

      public PvcOutlineSettings(PvcOutline.OutlineSortBy pSortBy, PvcOutline.OutlineFilter pFilter)

  • Method Details

    • getFilter

      public PvcOutline.OutlineFilter getFilter()

    • getSortBy

      public PvcOutline.OutlineSortBy getSortBy()


PvxPerspectiveFactory

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.views

Class PvxPerspectiveFactory

java.lang.Object
com.pvx.ooadide.views.PvxPerspectiveFactory
All Implemented Interfaces:
org.eclipse.ui.IPerspectiveFactory
public class PvxPerspectiveFactory extends Object implements org.eclipse.ui.IPerspectiveFactory

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxPerspectiveFactory()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    createInitialLayout(org.eclipse.ui.IPageLayout layout)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • PvxPerspectiveFactory

      public PvxPerspectiveFactory()

  • Method Details

    • createInitialLayout

      public void createInitialLayout(org.eclipse.ui.IPageLayout layout)
      Specified by:
      createInitialLayout in interface org.eclipse.ui.IPerspectiveFactory


PvxProgressMonitorDialog

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.views

Class PvxProgressMonitorDialog

java.lang.Object
org.eclipse.jface.window.Window
org.eclipse.jface.dialogs.Dialog
org.eclipse.jface.dialogs.IconAndMessageDialog
org.eclipse.jface.dialogs.ProgressMonitorDialog
com.pvx.ooadide.views.PvxProgressMonitorDialog
All Implemented Interfaces:
org.eclipse.jface.operation.IRunnableContext, org.eclipse.jface.window.IShellProvider
public class PvxProgressMonitorDialog extends org.eclipse.jface.dialogs.ProgressMonitorDialog

  • Nested Class Summary

    Nested classes/interfaces inherited from class org.eclipse.jface.window.Window

    org.eclipse.jface.window.Window.IExceptionHandler

  • Field Summary

    Fields inherited from class org.eclipse.jface.dialogs.Dialog

    blockedHandler, buttonBar, DIALOG_DEFAULT_BOUNDS, DIALOG_PERSISTLOCATION, DIALOG_PERSISTSIZE, DLG_IMG_HELP, DLG_IMG_MESSAGE_ERROR, DLG_IMG_MESSAGE_INFO, DLG_IMG_MESSAGE_WARNING, ELLIPSIS

    Fields inherited from class org.eclipse.jface.window.Window

    CANCEL, OK

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxProgressMonitorDialog(org.eclipse.swt.widgets.Shell shel)

  • Method Summary

    Modifier and Type
    Method
    Description
    int
    open(int toComplete, MonitorState mState, String taskName)

    Methods inherited from class org.eclipse.jface.dialogs.ProgressMonitorDialog

    close, getOpenOnRun, getProgressMonitor, open, run, setCancelable, setOpenOnRun

    Methods inherited from class org.eclipse.jface.dialogs.IconAndMessageDialog

    getErrorImage, getInfoImage, getQuestionImage, getWarningImage

    Methods inherited from class org.eclipse.jface.dialogs.Dialog

    applyDialogFont, convertHeightInCharsToPixels, convertHorizontalDLUsToPixels, convertVerticalDLUsToPixels, convertWidthInCharsToPixels, create, getBlockedHandler, getImage, setBlockedHandler, shortenText

    Methods inherited from class org.eclipse.jface.window.Window

    getDefaultImage, getDefaultImages, getDefaultOrientation, getReturnCode, getShell, getWindowManager, setBlockOnOpen, setDefaultImage, setDefaultImages, setDefaultModalParent, setDefaultOrientation, setExceptionHandler, setWindowManager

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • PvxProgressMonitorDialog

      public PvxProgressMonitorDialog(org.eclipse.swt.widgets.Shell shel)

  • Method Details

    • open

      public int open(int toComplete, MonitorState mState, String taskName)


PvxRunnableWithProgress

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.views

Class PvxRunnableWithProgress

java.lang.Object
com.pvx.ooadide.views.AbstractProgressController
com.pvx.ooadide.views.PvxRunnableWithProgress
All Implemented Interfaces:
org.eclipse.jface.operation.IRunnableWithProgress
public class PvxRunnableWithProgress extends AbstractProgressController implements org.eclipse.jface.operation.IRunnableWithProgress

  • Field Summary

    Fields inherited from class com.pvx.ooadide.views.AbstractProgressController

    P_ALL, P_SUB_TASKNAME, P_TASKNAME, P_VISIBLE, P_WORKED

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxRunnableWithProgress(PvxProgressMonitorDialog dialog, MonitorState init_State, String taskName, int toComplete)

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    cancel()
    void
    do_setVisible()
    void
    run(org.eclipse.core.runtime.IProgressMonitor monitor)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • PvxRunnableWithProgress

      public PvxRunnableWithProgress(PvxProgressMonitorDialog dialog, MonitorState init_State, String taskName, int toComplete)

  • Method Details

    • run

      public void run(org.eclipse.core.runtime.IProgressMonitor monitor) throws InvocationTargetException, InterruptedException
      Specified by:
      run in interface org.eclipse.jface.operation.IRunnableWithProgress
      Throws:
      InvocationTargetException
      InterruptedException

    • cancel

      public void cancel()

    • do_setVisible

      public void do_setVisible()


PvxView

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.views

Interface PvxView

All Known Implementing Classes:
IOListView, LibView
public interface PvxView

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    refresh()

  • Method Details

    • refresh

      void refresh()


PvxViewSorter

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.views

Class PvxViewSorter

java.lang.Object
org.eclipse.jface.viewers.ViewerComparator
com.pvx.ooadide.views.PvxViewSorter
public class PvxViewSorter extends org.eclipse.jface.viewers.ViewerComparator

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxViewSorter()

  • Method Summary

    Modifier and Type
    Method
    Description
    int
    compare(org.eclipse.jface.viewers.Viewer viewer, Object e1, Object e2)
    void
    sortUsingComparator(Comparator init_comparator)

    Methods inherited from class org.eclipse.jface.viewers.ViewerComparator

    category, isSorterProperty, sort

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • PvxViewSorter

      public PvxViewSorter()

  • Method Details

    • compare

      public int compare(org.eclipse.jface.viewers.Viewer viewer, Object e1, Object e2)
      Overrides:
      compare in class org.eclipse.jface.viewers.ViewerComparator

    • sortUsingComparator

      public void sortUsingComparator(Comparator init_comparator)


UIManager

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.views

Class UIManager

java.lang.Object
com.pvx.ooadide.views.UIManager
public class UIManager extends Object
Provides an Interface to the Eclipse GUI for ProvideX programs
Since:
1.0

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static String
    CONSOLE_VIEW_ID
    static String
    IOLIST_VIEW_ID
    static String
    NOMADS_VIEW_ID
    static String
    PVCOUTLINE_VIEW_ID

  • Constructor Summary

    Constructors
    Constructor
    Description
    UIManager()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    addRowToView(String id, String text)
    void
    clearView(String id)
    void
    closeAllEditors(boolean save)
    Closes all open editors
    static void
    createDialProgressMonitor(String taskName, int toComplete, MonitorState mState)
    This method should not be called directly by ProvideX programs.
    void
    editFile(String filePath, String projectName)
    Opens the file specified in the ProvideX Editor
    int
    getNumberOfColumns(String id)
    int
    getNumberOfRows(String id)
    static MonitorState
    getProgressMonitor(String taskName, int toComplete)
    Creates a progress monitor dialog.
    String
    getRegisteredEditors(String fileName)
    Get a list of all of the editors associated with the specified file
    String
    getRegisteredViews()
    Return a list of views defined in the Eclipse registry.
    static void
    hideView(String id)
    Hides the view identified
    static boolean
    isPvxProgressMonitorDialogVisible()
    static boolean
    isViewVisible(String id)
    Returns whether the specified Eclipse part is visible.
    void
    printLnToConsole(String text)
    Prints a line of text to the Console view
    static void
    setPvxProgressMonitorDialogVisible(boolean vis)
    static void
    showView(String id)
    Shows the view identified by the given view id in this Eclipse page and gives it focus.

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Field Details

    • CONSOLE_VIEW_ID

      public static String CONSOLE_VIEW_ID

    • PVCOUTLINE_VIEW_ID

      public static String PVCOUTLINE_VIEW_ID

    • IOLIST_VIEW_ID

      public static String IOLIST_VIEW_ID

    • NOMADS_VIEW_ID

      public static String NOMADS_VIEW_ID

  • Constructor Details

    • UIManager

      public UIManager()

  • Method Details

    • editFile

      public void editFile(String filePath, String projectName)
      Opens the file specified in the ProvideX Editor
      Parameters:
      filePath - The file to edit
      projectName - The project containing the file

    • closeAllEditors

      public void closeAllEditors(boolean save)
      Closes all open editors
      Parameters:
      save - If true save dirty files prior to closes

    • printLnToConsole

      public void printLnToConsole(String text)
      Prints a line of text to the Console view
      Parameters:
      text - String to print

    • getRegisteredEditors

      public String getRegisteredEditors(String fileName)
      Get a list of all of the editors associated with the specified file
      Parameters:
      fileName - The file to
      Returns:
      an 0x8a (ProvideX sep) delimited list of all of the editors associated with the specified file

    • getRegisteredViews

      public String getRegisteredViews()
      Return a list of views defined in the Eclipse registry.
      Returns:
      the views or ""

    • clearView

      public void clearView(String id)

    • isViewVisible

      public static boolean isViewVisible(String id)
      Returns whether the specified Eclipse part is visible.
      Parameters:
      id - The id of the Eclipse part
      Returns:
      boolean true if part is visible

    • showView

      public static void showView(String id)
      Shows the view identified by the given view id in this Eclipse page and gives it focus. If there is a view identified by the given view id is already open in this page, it is given focus.
      Parameters:
      id - The id of the view to show

    • addRowToView

      public void addRowToView(String id, String text)

    • getNumberOfRows

      public int getNumberOfRows(String id)

    • getNumberOfColumns

      public int getNumberOfColumns(String id)

    • hideView

      public static void hideView(String id)
      Hides the view identified
      Parameters:
      id - The id of the view to hide

    • getProgressMonitor

      public static MonitorState getProgressMonitor(String taskName, int toComplete)
      Creates a progress monitor dialog. Retrieves an active progress monitor.
      Parameters:
      taskName -
      toComplete -
      Returns:
      MonitorState object to interface with the dialog

    • createDialProgressMonitor

      public static void createDialProgressMonitor(String taskName, int toComplete, MonitorState mState)
      This method should not be called directly by ProvideX programs. Use the getProgressMonitor instead
      Parameters:
      taskName - The title for the dialog
      toComplete - The amount of work to be done
      mState - The Monitor state object
      See Also:
      • getProgressMonitor(String, int)

    • isPvxProgressMonitorDialogVisible

      public static boolean isPvxProgressMonitorDialogVisible()

    • setPvxProgressMonitorDialogVisible

      public static void setPvxProgressMonitorDialogVisible(boolean vis)


WinDefine

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.views

Class WinDefine

java.lang.Object
org.eclipse.core.commands.common.EventManager
org.eclipse.ui.part.WorkbenchPart
org.eclipse.ui.part.ViewPart
com.sage.rcp.views.HostActionsView
com.pvx.ooadide.views.WinDefine
All Implemented Interfaces:
IEmbeddedJavXView, javxbaseui.AbstractGUIManagerFactory, org.eclipse.core.runtime.IAdaptable, org.eclipse.core.runtime.IExecutableExtension, org.eclipse.ui.IPersistable, org.eclipse.ui.IViewPart, org.eclipse.ui.IWorkbenchPart, org.eclipse.ui.IWorkbenchPart2, org.eclipse.ui.IWorkbenchPart3, org.eclipse.ui.part.IWorkbenchPartOrientation
public class WinDefine extends HostActionsView

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    String
    actionText
    String
    actionTip
    static final String
    ID
    static String
    lib
    static String
    panel
    String
    program

    Fields inherited from interface org.eclipse.ui.IWorkbenchPart

    PROP_TITLE

  • Constructor Summary

    Constructors
    Constructor
    Description
    WinDefine()

  • Method Summary

    Modifier and Type
    Method
    Description
    String
    getActionText()
    String
    getActionTip()
    String
    getArgsStr()
    String
    getPartName()
    static void
    setLib(String lb)
    static void
    setPanel(String pnl)

    Methods inherited from class com.sage.rcp.views.HostActionsView

    addJavX, createPartControl, getActionBars, getCompositeColor, getIViewSite, makeGUIManager, notifyConnected, setActionBars, setCompositeColor, setFocus, setJavXVisible, setViewSite, startJavX

    Methods inherited from class org.eclipse.ui.part.ViewPart

    getViewSite, init, init, saveState, setInitializationData

    Methods inherited from class org.eclipse.ui.part.WorkbenchPart

    addPartPropertyListener, addPropertyListener, dispose, getAdapter, getContentDescription, getOrientation, getPartProperties, getPartProperty, getSite, getTitle, getTitleImage, getTitleToolTip, removePartPropertyListener, removePropertyListener, setPartProperty, showBusy

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface org.eclipse.core.runtime.IAdaptable

    getAdapter

    Methods inherited from interface org.eclipse.ui.IWorkbenchPart

    addPropertyListener, dispose, getSite, getTitle, getTitleImage, getTitleToolTip, removePropertyListener

  • Field Details

    • actionText

      public String actionText

    • actionTip

      public String actionTip

    • panel

      public static String panel

    • lib

      public static String lib

    • program

      public String program

    • ID

      public static final String ID
      See Also:
      • Constant Field Values

  • Constructor Details

    • WinDefine

      public WinDefine()

  • Method Details

    • getPartName

      public String getPartName()
      Specified by:
      getPartName in interface org.eclipse.ui.IWorkbenchPart2
      Overrides:
      getPartName in class org.eclipse.ui.part.WorkbenchPart

    • getActionText

      public String getActionText()

    • getActionTip

      public String getActionTip()

    • getArgsStr

      public String getArgsStr()
      Specified by:
      getArgsStr in interface IEmbeddedJavXView
      Overrides:
      getArgsStr in class HostActionsView

    • setPanel

      public static void setPanel(String pnl)

    • setLib

      public static void setLib(String lb)


Uses of Class com.pvx.ooadide.views.AbstractProgressController

Uses of Class
com.pvx.ooadide.views.AbstractProgressController

Packages that use AbstractProgressController
Package
Description
com.pvx.ooadide.views

  • Uses of AbstractProgressController in com.pvx.ooadide.views

    Subclasses of AbstractProgressController in com.pvx.ooadide.views
    Modifier and Type
    Class
    Description
    class
    PvxRunnableWithProgress


Uses of Class com.pvx.ooadide.views.IOListView

Uses of Class
com.pvx.ooadide.views.IOListView

No usage of com.pvx.ooadide.views.IOListView


Uses of Class com.pvx.ooadide.views.IOListView.IOListLabelProvider

Uses of Class
com.pvx.ooadide.views.IOListView.IOListLabelProvider

No usage of com.pvx.ooadide.views.IOListView.IOListLabelProvider


Uses of Class com.pvx.ooadide.views.JavXBrowserView

Uses of Class
com.pvx.ooadide.views.JavXBrowserView

No usage of com.pvx.ooadide.views.JavXBrowserView


Uses of Class com.pvx.ooadide.views.MonitorState

Uses of Class
com.pvx.ooadide.views.MonitorState

Packages that use MonitorState
Package
Description
com.pvx.ooadide.launchers.debug.communication
com.pvx.ooadide.views

  • Uses of MonitorState in com.pvx.ooadide.launchers.debug.communication

    Methods in com.pvx.ooadide.launchers.debug.communication that return MonitorState
    Modifier and Type
    Method
    Description
    static MonitorState
    DebugServer.getProgressMonitor()
    Methods in com.pvx.ooadide.launchers.debug.communication with parameters of type MonitorState
    Modifier and Type
    Method
    Description
    Socket
    DebugServer.acceptEventConnection(MonitorState pd)
    Socket
    DebugServer.acceptRequestConnection(MonitorState pd)
    static Socket
    DebugServer.doSocketAccept(MonitorState pd, ServerSocket targetSocket)

  • Uses of MonitorState in com.pvx.ooadide.views

    Methods in com.pvx.ooadide.views that return MonitorState
    Modifier and Type
    Method
    Description
    static MonitorState
    UIManager.getProgressMonitor(String taskName, int toComplete)
    Creates a progress monitor dialog.
    Methods in com.pvx.ooadide.views with parameters of type MonitorState
    Modifier and Type
    Method
    Description
    static void
    UIManager.createDialProgressMonitor(String taskName, int toComplete, MonitorState mState)
    This method should not be called directly by ProvideX programs.
    int
    PvxProgressMonitorDialog.open(int toComplete, MonitorState mState, String taskName)
    Constructors in com.pvx.ooadide.views with parameters of type MonitorState
    Modifier
    Constructor
    Description

    PvxRunnableWithProgress(PvxProgressMonitorDialog dialog, MonitorState init_State, String taskName, int toComplete)


Uses of Class com.pvx.ooadide.views.PvcOutline

Uses of Class
com.pvx.ooadide.views.PvcOutline

No usage of com.pvx.ooadide.views.PvcOutline


Uses of Enum com.pvx.ooadide.views.PvcOutline.OutlineFilter

Uses of Enum
com.pvx.ooadide.views.PvcOutline.OutlineFilter

Packages that use PvcOutline.OutlineFilter
Package
Description
com.pvx.ooadide.views

  • Uses of PvcOutline.OutlineFilter in com.pvx.ooadide.views

    Methods in com.pvx.ooadide.views that return PvcOutline.OutlineFilter
    Modifier and Type
    Method
    Description
    PvcOutline.OutlineFilter
    PvcOutlineSettings.getFilter()
    static PvcOutline.OutlineFilter
    PvcOutline.OutlineFilter.valueOf(String name)
    Returns the enum constant of this type with the specified name.
    static PvcOutline.OutlineFilter[]
    PvcOutline.OutlineFilter.values()
    Returns an array containing the constants of this enum type, in the order they are declared.
    Constructors in com.pvx.ooadide.views with parameters of type PvcOutline.OutlineFilter
    Modifier
    Constructor
    Description

    PvcOutlineSettings(PvcOutline.OutlineSortBy pSortBy, PvcOutline.OutlineFilter pFilter)


Uses of Enum com.pvx.ooadide.views.PvcOutline.OutlineSortBy

Uses of Enum
com.pvx.ooadide.views.PvcOutline.OutlineSortBy

Packages that use PvcOutline.OutlineSortBy
Package
Description
com.pvx.ooadide.views

  • Uses of PvcOutline.OutlineSortBy in com.pvx.ooadide.views

    Methods in com.pvx.ooadide.views that return PvcOutline.OutlineSortBy
    Modifier and Type
    Method
    Description
    PvcOutline.OutlineSortBy
    PvcOutlineSettings.getSortBy()
    static PvcOutline.OutlineSortBy
    PvcOutline.OutlineSortBy.valueOf(String name)
    Returns the enum constant of this type with the specified name.
    static PvcOutline.OutlineSortBy[]
    PvcOutline.OutlineSortBy.values()
    Returns an array containing the constants of this enum type, in the order they are declared.
    Constructors in com.pvx.ooadide.views with parameters of type PvcOutline.OutlineSortBy
    Modifier
    Constructor
    Description

    PvcOutlineSettings(PvcOutline.OutlineSortBy pSortBy, PvcOutline.OutlineFilter pFilter)


Uses of Class com.pvx.ooadide.views.PvcOutlineSettings

Uses of Class
com.pvx.ooadide.views.PvcOutlineSettings

Packages that use PvcOutlineSettings
Package
Description
com.pvx.ooadide

  • Uses of PvcOutlineSettings in com.pvx.ooadide

    Methods in com.pvx.ooadide that return PvcOutlineSettings
    Modifier and Type
    Method
    Description
    PvcOutlineSettings
    ProvideXOOADPlugin.getOutlineSettings()
    Get save Outline View settings for the current session
    Methods in com.pvx.ooadide with parameters of type PvcOutlineSettings
    Modifier and Type
    Method
    Description
    void
    ProvideXOOADPlugin.saveOutlineSettings(PvcOutlineSettings pSettings)
    Save current state of Outline View Group-By and Filter settings (for current session)


Uses of Class com.pvx.ooadide.views.PvxPerspectiveFactory

Uses of Class
com.pvx.ooadide.views.PvxPerspectiveFactory

No usage of com.pvx.ooadide.views.PvxPerspectiveFactory


Uses of Class com.pvx.ooadide.views.PvxProgressMonitorDialog

Uses of Class
com.pvx.ooadide.views.PvxProgressMonitorDialog

Packages that use PvxProgressMonitorDialog
Package
Description
com.pvx.ooadide.views

  • Uses of PvxProgressMonitorDialog in com.pvx.ooadide.views

    Constructors in com.pvx.ooadide.views with parameters of type PvxProgressMonitorDialog
    Modifier
    Constructor
    Description

    PvxRunnableWithProgress(PvxProgressMonitorDialog dialog, MonitorState init_State, String taskName, int toComplete)


Uses of Class com.pvx.ooadide.views.PvxRunnableWithProgress

Uses of Class
com.pvx.ooadide.views.PvxRunnableWithProgress

Packages that use PvxRunnableWithProgress
Package
Description
com.pvx.ooadide.views

  • Uses of PvxRunnableWithProgress in com.pvx.ooadide.views

    Methods in com.pvx.ooadide.views with parameters of type PvxRunnableWithProgress
    Modifier and Type
    Method
    Description
    void
    MonitorState.setRunnable(PvxRunnableWithProgress initRunner)


Uses of Interface com.pvx.ooadide.views.PvxView

Uses of Interface
com.pvx.ooadide.views.PvxView

Packages that use PvxView
Package
Description
com.pvx.ooadide.views
com.pvx.ooadide.views.nomads

  • Uses of PvxView in com.pvx.ooadide.views

    Classes in com.pvx.ooadide.views that implement PvxView
    Modifier and Type
    Class
    Description
    class
    IOListView

  • Uses of PvxView in com.pvx.ooadide.views.nomads

    Classes in com.pvx.ooadide.views.nomads that implement PvxView
    Modifier and Type
    Class
    Description
    class
    LibView
    This class displays / updates the information in the NOMADS view


Uses of Class com.pvx.ooadide.views.PvxViewSorter

Uses of Class
com.pvx.ooadide.views.PvxViewSorter

No usage of com.pvx.ooadide.views.PvxViewSorter


Uses of Class com.pvx.ooadide.views.UIManager

Uses of Class
com.pvx.ooadide.views.UIManager

No usage of com.pvx.ooadide.views.UIManager


Uses of Class com.pvx.ooadide.views.WinDefine

Uses of Class
com.pvx.ooadide.views.WinDefine

No usage of com.pvx.ooadide.views.WinDefine


IPvxElement

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.views.comparators

Interface IPvxElement

All Known Implementing Classes:
PvxElement, PvxLibElement
public interface IPvxElement

  • Method Summary

    Modifier and Type
    Method
    Description
    int
    getType()

  • Method Details

    • getType

      int getType()


NumericComparator

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.views.comparators

Class NumericComparator

java.lang.Object
com.pvx.ooadide.views.comparators.NumericComparator
All Implemented Interfaces:
Comparator<Object>
public class NumericComparator extends Object implements Comparator<Object>

  • Constructor Summary

    Constructors
    Constructor
    Description
    NumericComparator(int dir, int numb, org.eclipse.jface.viewers.ITableLabelProvider initLblProvider)

  • Method Summary

    Modifier and Type
    Method
    Description
    int
    compare(Object arg0, Object arg1)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface java.util.Comparator

    equals, reversed, thenComparing, thenComparing, thenComparing, thenComparingDouble, thenComparingInt, thenComparingLong

  • Constructor Details

    • NumericComparator

      public NumericComparator(int dir, int numb, org.eclipse.jface.viewers.ITableLabelProvider initLblProvider)

  • Method Details

    • compare

      public int compare(Object arg0, Object arg1)
      Specified by:
      compare in interface Comparator<Object>


com.pvx.ooadide.views.comparators

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.pvx.ooadide.views.comparators

package com.pvx.ooadide.views.comparators
  • Related Packages
    Package
    Description
    com.pvx.ooadide.views
    com.pvx.ooadide.views.nomads
  • Class
    Description
    IPvxElement
    NumericComparator
    PvxElementAlphaComparator
    PvxLineNoComparator
    PvxStructureComparator
    SortListener


com.pvx.ooadide.views.comparators Class Hierarchy

Hierarchy For Package com.pvx.ooadide.views.comparators

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • com.pvx.ooadide.views.comparators.NumericComparator (implements java.util.Comparator<T>)
    • com.pvx.ooadide.views.comparators.PvxElementAlphaComparator (implements java.util.Comparator<T>)
    • com.pvx.ooadide.views.comparators.PvxLineNoComparator (implements java.util.Comparator<T>)
    • com.pvx.ooadide.views.comparators.PvxStructureComparator (implements java.util.Comparator<T>)
    • com.pvx.ooadide.views.comparators.SortListener (implements org.eclipse.swt.widgets.Listener)

Interface Hierarchy

  • com.pvx.ooadide.views.comparators.IPvxElement


Uses of Package com.pvx.ooadide.views.comparators

Uses of Package
com.pvx.ooadide.views.comparators

Packages that use com.pvx.ooadide.views.comparators
Package
Description
com.pvx.ooadide.util
com.pvx.ooadide.views.nomads
  • Classes in com.pvx.ooadide.views.comparators used by com.pvx.ooadide.util
    Class
    Description
    IPvxElement
  • Classes in com.pvx.ooadide.views.comparators used by com.pvx.ooadide.views.nomads
    Class
    Description
    IPvxElement


PvxElementAlphaComparator

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.views.comparators

Class PvxElementAlphaComparator

java.lang.Object
com.pvx.ooadide.views.comparators.PvxElementAlphaComparator
All Implemented Interfaces:
Comparator<Object>
public class PvxElementAlphaComparator extends Object implements Comparator<Object>

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxElementAlphaComparator(int dir, int numb, org.eclipse.jface.viewers.ITableLabelProvider initLblProvider)

  • Method Summary

    Modifier and Type
    Method
    Description
    int
    compare(Object arg0, Object arg1)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface java.util.Comparator

    equals, reversed, thenComparing, thenComparing, thenComparing, thenComparingDouble, thenComparingInt, thenComparingLong

  • Constructor Details

    • PvxElementAlphaComparator

      public PvxElementAlphaComparator(int dir, int numb, org.eclipse.jface.viewers.ITableLabelProvider initLblProvider)

  • Method Details

    • compare

      public int compare(Object arg0, Object arg1)
      Specified by:
      compare in interface Comparator<Object>


PvxLineNoComparator

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.views.comparators

Class PvxLineNoComparator

java.lang.Object
com.pvx.ooadide.views.comparators.PvxLineNoComparator
All Implemented Interfaces:
Comparator<Object>
public class PvxLineNoComparator extends Object implements Comparator<Object>

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxLineNoComparator()

  • Method Summary

    Modifier and Type
    Method
    Description
    int
    compare(Object arg0, Object arg1)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface java.util.Comparator

    equals, reversed, thenComparing, thenComparing, thenComparing, thenComparingDouble, thenComparingInt, thenComparingLong

  • Constructor Details

    • PvxLineNoComparator

      public PvxLineNoComparator()

  • Method Details

    • compare

      public int compare(Object arg0, Object arg1)
      Specified by:
      compare in interface Comparator<Object>


PvxStructureComparator

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.views.comparators

Class PvxStructureComparator

java.lang.Object
com.pvx.ooadide.views.comparators.PvxStructureComparator
All Implemented Interfaces:
Comparator<Object>
public class PvxStructureComparator extends Object implements Comparator<Object>

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxStructureComparator(int dir, int numb, org.eclipse.jface.viewers.ITableLabelProvider initLblProvider)

  • Method Summary

    Modifier and Type
    Method
    Description
    int
    compare(Object arg0, Object arg1)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface java.util.Comparator

    equals, reversed, thenComparing, thenComparing, thenComparing, thenComparingDouble, thenComparingInt, thenComparingLong

  • Constructor Details

    • PvxStructureComparator

      public PvxStructureComparator(int dir, int numb, org.eclipse.jface.viewers.ITableLabelProvider initLblProvider)

  • Method Details

    • compare

      public int compare(Object arg0, Object arg1)
      Specified by:
      compare in interface Comparator<Object>


SortListener

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.views.comparators

Class SortListener

java.lang.Object
com.pvx.ooadide.views.comparators.SortListener
All Implemented Interfaces:
org.eclipse.swt.widgets.Listener
public class SortListener extends Object implements org.eclipse.swt.widgets.Listener

  • Constructor Summary

    Constructors
    Constructor
    Description
    SortListener(org.eclipse.jface.viewers.TableViewer initViewer)
    SortListener(org.eclipse.jface.viewers.TableViewer initViewer, boolean numeric)

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    handleEvent(org.eclipse.swt.widgets.Event e)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • SortListener

      public SortListener(org.eclipse.jface.viewers.TableViewer initViewer)

    • SortListener

      public SortListener(org.eclipse.jface.viewers.TableViewer initViewer, boolean numeric)

  • Method Details

    • handleEvent

      public void handleEvent(org.eclipse.swt.widgets.Event e)
      Specified by:
      handleEvent in interface org.eclipse.swt.widgets.Listener


Uses of Interface com.pvx.ooadide.views.comparators.IPvxElement

Uses of Interface
com.pvx.ooadide.views.comparators.IPvxElement

Packages that use IPvxElement
Package
Description
com.pvx.ooadide.util
com.pvx.ooadide.views.nomads

  • Uses of IPvxElement in com.pvx.ooadide.util

    Classes in com.pvx.ooadide.util that implement IPvxElement
    Modifier and Type
    Class
    Description
    class
    PvxElement

  • Uses of IPvxElement in com.pvx.ooadide.views.nomads

    Classes in com.pvx.ooadide.views.nomads that implement IPvxElement
    Modifier and Type
    Class
    Description
    class
    PvxLibElement


Uses of Class com.pvx.ooadide.views.comparators.NumericComparator

Uses of Class
com.pvx.ooadide.views.comparators.NumericComparator

No usage of com.pvx.ooadide.views.comparators.NumericComparator


Uses of Class com.pvx.ooadide.views.comparators.PvxElementAlphaComparator

Uses of Class
com.pvx.ooadide.views.comparators.PvxElementAlphaComparator

No usage of com.pvx.ooadide.views.comparators.PvxElementAlphaComparator


Uses of Class com.pvx.ooadide.views.comparators.PvxLineNoComparator

Uses of Class
com.pvx.ooadide.views.comparators.PvxLineNoComparator

No usage of com.pvx.ooadide.views.comparators.PvxLineNoComparator


Uses of Class com.pvx.ooadide.views.comparators.PvxStructureComparator

Uses of Class
com.pvx.ooadide.views.comparators.PvxStructureComparator

No usage of com.pvx.ooadide.views.comparators.PvxStructureComparator


Uses of Class com.pvx.ooadide.views.comparators.SortListener

Uses of Class
com.pvx.ooadide.views.comparators.SortListener

No usage of com.pvx.ooadide.views.comparators.SortListener


LibView

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.views.nomads

Class LibView

java.lang.Object
org.eclipse.core.commands.common.EventManager
org.eclipse.ui.part.WorkbenchPart
org.eclipse.ui.part.ViewPart
com.pvx.ooadide.views.nomads.LibView
All Implemented Interfaces:
PvxView, org.eclipse.core.runtime.IAdaptable, org.eclipse.core.runtime.IExecutableExtension, org.eclipse.ui.IPersistable, org.eclipse.ui.IViewPart, org.eclipse.ui.IWorkbenchPart, org.eclipse.ui.IWorkbenchPart2, org.eclipse.ui.IWorkbenchPart3, org.eclipse.ui.part.IWorkbenchPartOrientation
Direct Known Subclasses:
IOListView
public class LibView extends org.eclipse.ui.part.ViewPart implements PvxView
This class displays / updates the information in the NOMADS view

  • Nested Class Summary

    Nested Classes
    Modifier and Type
    Class
    Description
    class
    LibView.ViewContentProvider
    class
    LibView.ViewLabelProvider

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final String
    CHARSET
    static final String
    ID
    static final String
    LIBLOG_NAME
    static final String
    NOMADS_systemDefaults
    static final String
    sep
    static final String
    WINDEFINE_PROGRAM
    static final String
    WINTEST_PROGRAM

    Fields inherited from interface org.eclipse.ui.IWorkbenchPart

    PROP_TITLE

  • Constructor Summary

    Constructors
    Constructor
    Description
    LibView()
    The constructor.

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    changeViewFile(org.eclipse.core.resources.IFile aFile)
    void
    createPartControl(org.eclipse.swt.widgets.Composite parent)
    This is a callback that will allow us to create the viewer and initialize it.
    void
    dispose()
    void
    openWinDefineView()
    void
    refresh()
    void
    scanLog(File libLog, Vector msgs, String libPath)
    void
    setFocus()
    Passing the focus request to the viewer's control.

    Methods inherited from class org.eclipse.ui.part.ViewPart

    getViewSite, init, init, saveState, setInitializationData

    Methods inherited from class org.eclipse.ui.part.WorkbenchPart

    addPartPropertyListener, addPropertyListener, getAdapter, getContentDescription, getOrientation, getPartName, getPartProperties, getPartProperty, getSite, getTitle, getTitleImage, getTitleToolTip, removePartPropertyListener, removePropertyListener, setPartProperty, showBusy

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface org.eclipse.core.runtime.IAdaptable

    getAdapter

    Methods inherited from interface org.eclipse.ui.IWorkbenchPart

    addPropertyListener, getSite, getTitle, getTitleImage, getTitleToolTip, removePropertyListener

  • Field Details

    • WINDEFINE_PROGRAM

      public static final String WINDEFINE_PROGRAM
      See Also:
      • Constant Field Values

    • WINTEST_PROGRAM

      public static final String WINTEST_PROGRAM
      See Also:
      • Constant Field Values

    • LIBLOG_NAME

      public static final String LIBLOG_NAME
      See Also:
      • Constant Field Values

    • CHARSET

      public static final String CHARSET
      See Also:
      • Constant Field Values

    • sep

      public static final String sep
      See Also:
      • Constant Field Values

    • ID

      public static final String ID
      See Also:
      • Constant Field Values

    • NOMADS_systemDefaults

      public static final String NOMADS_systemDefaults
      See Also:
      • Constant Field Values

  • Constructor Details

    • LibView

      public LibView()
      The constructor.

  • Method Details

    • createPartControl

      public void createPartControl(org.eclipse.swt.widgets.Composite parent)
      This is a callback that will allow us to create the viewer and initialize it.
      Specified by:
      createPartControl in interface org.eclipse.ui.IWorkbenchPart
      Specified by:
      createPartControl in class org.eclipse.ui.part.WorkbenchPart

    • setFocus

      public void setFocus()
      Passing the focus request to the viewer's control.
      Specified by:
      setFocus in interface org.eclipse.ui.IWorkbenchPart
      Specified by:
      setFocus in class org.eclipse.ui.part.WorkbenchPart

    • dispose

      public void dispose()
      Specified by:
      dispose in interface org.eclipse.ui.IWorkbenchPart
      Overrides:
      dispose in class org.eclipse.ui.part.WorkbenchPart

    • changeViewFile

      public void changeViewFile(org.eclipse.core.resources.IFile aFile)

    • openWinDefineView

      public void openWinDefineView()

    • scanLog

      public void scanLog(File libLog, Vector msgs, String libPath)

    • refresh

      public void refresh()
      Specified by:
      refresh in interface PvxView


LibView.ViewContentProvider

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.views.nomads

Class LibView.ViewContentProvider

java.lang.Object
com.pvx.ooadide.views.nomads.LibView.ViewContentProvider
All Implemented Interfaces:
org.eclipse.jface.viewers.IContentProvider, org.eclipse.jface.viewers.IStructuredContentProvider
Enclosing class:
LibView
public class LibView.ViewContentProvider extends Object implements org.eclipse.jface.viewers.IStructuredContentProvider

  • Constructor Summary

    Constructors
    Constructor
    Description
    ViewContentProvider()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    dispose()
    Object[]
    getElements(Object parent)
    void
    inputChanged(org.eclipse.jface.viewers.Viewer v, Object oldInput, Object newInput)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • ViewContentProvider

      public ViewContentProvider()

  • Method Details

    • inputChanged

      public void inputChanged(org.eclipse.jface.viewers.Viewer v, Object oldInput, Object newInput)
      Specified by:
      inputChanged in interface org.eclipse.jface.viewers.IContentProvider

    • dispose

      public void dispose()
      Specified by:
      dispose in interface org.eclipse.jface.viewers.IContentProvider

    • getElements

      public Object[] getElements(Object parent)
      Specified by:
      getElements in interface org.eclipse.jface.viewers.IStructuredContentProvider


LibView.ViewLabelProvider

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.views.nomads

Class LibView.ViewLabelProvider

java.lang.Object
org.eclipse.core.commands.common.EventManager
org.eclipse.jface.viewers.BaseLabelProvider
org.eclipse.jface.viewers.LabelProvider
com.pvx.ooadide.views.nomads.LibView.ViewLabelProvider
All Implemented Interfaces:
org.eclipse.jface.viewers.IBaseLabelProvider, org.eclipse.jface.viewers.ILabelProvider, org.eclipse.jface.viewers.ITableLabelProvider
Enclosing class:
LibView
public class LibView.ViewLabelProvider extends org.eclipse.jface.viewers.LabelProvider implements org.eclipse.jface.viewers.ITableLabelProvider

  • Constructor Summary

    Constructors
    Constructor
    Description
    ViewLabelProvider()

  • Method Summary

    Modifier and Type
    Method
    Description
    org.eclipse.swt.graphics.Image
    getColumnImage(Object obj, int index)
    String
    getColumnText(Object obj, int index)

    Methods inherited from class org.eclipse.jface.viewers.LabelProvider

    getImage, getText

    Methods inherited from class org.eclipse.jface.viewers.BaseLabelProvider

    addListener, dispose, isLabelProperty, removeListener

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface org.eclipse.jface.viewers.IBaseLabelProvider

    addListener, dispose, isLabelProperty, removeListener

  • Constructor Details

    • ViewLabelProvider

      public ViewLabelProvider()

  • Method Details

    • getColumnText

      public String getColumnText(Object obj, int index)
      Specified by:
      getColumnText in interface org.eclipse.jface.viewers.ITableLabelProvider

    • getColumnImage

      public org.eclipse.swt.graphics.Image getColumnImage(Object obj, int index)
      Specified by:
      getColumnImage in interface org.eclipse.jface.viewers.ITableLabelProvider


NewNomadsObjectDialog

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.views.nomads

Class NewNomadsObjectDialog

java.lang.Object
org.eclipse.jface.window.Window
org.eclipse.jface.dialogs.Dialog
com.pvx.ooadide.views.nomads.NewNomadsObjectDialog
All Implemented Interfaces:
org.eclipse.jface.window.IShellProvider
public class NewNomadsObjectDialog extends org.eclipse.jface.dialogs.Dialog

  • Nested Class Summary

    Nested classes/interfaces inherited from class org.eclipse.jface.window.Window

    org.eclipse.jface.window.Window.IExceptionHandler

  • Field Summary

    Fields inherited from class org.eclipse.jface.dialogs.Dialog

    blockedHandler, buttonBar, DIALOG_DEFAULT_BOUNDS, DIALOG_PERSISTLOCATION, DIALOG_PERSISTSIZE, DLG_IMG_HELP, DLG_IMG_MESSAGE_ERROR, DLG_IMG_MESSAGE_INFO, DLG_IMG_MESSAGE_WARNING, ELLIPSIS

    Fields inherited from class org.eclipse.jface.window.Window

    CANCEL, OK

  • Constructor Summary

    Constructors
    Constructor
    Description
    NewNomadsObjectDialog(org.eclipse.swt.widgets.Shell parentShell, String dialogTitle, String dialogMessage, String initialValue, org.eclipse.jface.dialogs.IInputValidator validator)
    Creates an input dialog with OK and Cancel buttons.

  • Method Summary

    Modifier and Type
    Method
    Description
    String
    getObjectType()
    String
    getValue()
    Returns the string typed into this input dialog.
    void
    setErrorMessage(String errorMessage)
    Sets or clears the error message.

    Methods inherited from class org.eclipse.jface.dialogs.Dialog

    applyDialogFont, close, convertHeightInCharsToPixels, convertHorizontalDLUsToPixels, convertVerticalDLUsToPixels, convertWidthInCharsToPixels, create, getBlockedHandler, getImage, setBlockedHandler, shortenText

    Methods inherited from class org.eclipse.jface.window.Window

    getDefaultImage, getDefaultImages, getDefaultOrientation, getReturnCode, getShell, getWindowManager, open, setBlockOnOpen, setDefaultImage, setDefaultImages, setDefaultModalParent, setDefaultOrientation, setExceptionHandler, setWindowManager

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • NewNomadsObjectDialog

      public NewNomadsObjectDialog(org.eclipse.swt.widgets.Shell parentShell, String dialogTitle, String dialogMessage, String initialValue, org.eclipse.jface.dialogs.IInputValidator validator)
      Creates an input dialog with OK and Cancel buttons. Note that the dialog will have no visual representation (no widgets) until it is told to open.

      Note that the open method blocks for input dialogs.

      Parameters:
      parentShell - the parent shell, or null to create a top-level shell
      dialogTitle - the dialog title, or null if none
      dialogMessage - the dialog message, or null if none
      initialValue - the initial input value, or null if none (equivalent to the empty string)
      validator - an input validator, or null if none

  • Method Details

    • getValue

      public String getValue()
      Returns the string typed into this input dialog.
      Returns:
      the input string

    • setErrorMessage

      public void setErrorMessage(String errorMessage)
      Sets or clears the error message. If not null, the OK button is disabled.
      Parameters:
      errorMessage - the error message, or null to clear
      Since:
      3.0

    • getObjectType

      public String getObjectType()


com.pvx.ooadide.views.nomads

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.pvx.ooadide.views.nomads

package com.pvx.ooadide.views.nomads
  • Related Packages
    Package
    Description
    com.pvx.ooadide.views
    com.pvx.ooadide.views.comparators
  • Classes
    Class
    Description
    LibView
    This class displays / updates the information in the NOMADS view
    NewNomadsObjectDialog
    PvxLibElement


com.pvx.ooadide.views.nomads Class Hierarchy

Hierarchy For Package com.pvx.ooadide.views.nomads

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.eclipse.core.commands.common.EventManager
      • org.eclipse.jface.viewers.BaseLabelProvider (implements org.eclipse.jface.viewers.IBaseLabelProvider)
        • org.eclipse.jface.viewers.LabelProvider (implements org.eclipse.jface.viewers.ILabelProvider)
          • com.pvx.ooadide.views.nomads.LibView.ViewLabelProvider (implements org.eclipse.jface.viewers.ITableLabelProvider)
      • org.eclipse.ui.part.WorkbenchPart (implements org.eclipse.core.runtime.IExecutableExtension, org.eclipse.ui.IWorkbenchPart3, org.eclipse.ui.part.IWorkbenchPartOrientation)
        • org.eclipse.ui.part.ViewPart (implements org.eclipse.ui.IViewPart)
          • com.pvx.ooadide.views.nomads.LibView (implements com.pvx.ooadide.views.PvxView)
    • com.pvx.ooadide.views.nomads.LibView.ViewContentProvider (implements org.eclipse.jface.viewers.IStructuredContentProvider)
    • com.pvx.ooadide.views.nomads.PvxLibElement (implements java.lang.Cloneable, com.pvx.ooadide.views.comparators.IPvxElement)
    • org.eclipse.jface.window.Window (implements org.eclipse.jface.window.IShellProvider)
      • org.eclipse.jface.dialogs.Dialog
        • com.pvx.ooadide.views.nomads.NewNomadsObjectDialog


Uses of Package com.pvx.ooadide.views.nomads

Uses of Package
com.pvx.ooadide.views.nomads

Packages that use com.pvx.ooadide.views.nomads
Package
Description
com.pvx.ooadide.views
  • Classes in com.pvx.ooadide.views.nomads used by com.pvx.ooadide.views
    Class
    Description
    LibView
    This class displays / updates the information in the NOMADS view


PvxLibElement

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.views.nomads

Class PvxLibElement

java.lang.Object
com.pvx.ooadide.views.nomads.PvxLibElement
All Implemented Interfaces:
IPvxElement, Cloneable
public class PvxLibElement extends Object implements IPvxElement, Cloneable

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final int
    INIT_TEXT$
    static final int
    numbObjElemnts
    static final int
    OBJ_C
    static final int
    OBJ_H
    static final int
    OBJ_KEY
    static final int
    OBJ_L
    static final int
    OBJ_NME
    static final int
    OBJ_TYPE$
    static final int
    OBJ_W
    static final int
    P_DATE$
    static final int
    P_TIME$
    static final int
    P_USERID$

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxLibElement(String[] libElementData, org.eclipse.core.resources.IResource lib, String initPath)

  • Method Summary

    Modifier and Type
    Method
    Description
    String
    getElement(int indx)
    org.eclipse.swt.graphics.Image
    getImageForElement()
    String
    getLibOutputDir()
    String
    getName()
    String
    getPathToFile()
    String
    getStpElement(int indx)
    int
    getType()
    void
    setElement(int indx, String value)
    String
    toString()

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

  • Field Details

    • numbObjElemnts

      public static final int numbObjElemnts
      See Also:
      • Constant Field Values

    • P_USERID$

      public static final int P_USERID$
      See Also:
      • Constant Field Values

    • P_TIME$

      public static final int P_TIME$
      See Also:
      • Constant Field Values

    • P_DATE$

      public static final int P_DATE$
      See Also:
      • Constant Field Values

    • INIT_TEXT$

      public static final int INIT_TEXT$
      See Also:
      • Constant Field Values

    • OBJ_TYPE$

      public static final int OBJ_TYPE$
      See Also:
      • Constant Field Values

    • OBJ_H

      public static final int OBJ_H
      See Also:
      • Constant Field Values

    • OBJ_W

      public static final int OBJ_W
      See Also:
      • Constant Field Values

    • OBJ_L

      public static final int OBJ_L
      See Also:
      • Constant Field Values

    • OBJ_C

      public static final int OBJ_C
      See Also:
      • Constant Field Values

    • OBJ_NME

      public static final int OBJ_NME
      See Also:
      • Constant Field Values

    • OBJ_KEY

      public static final int OBJ_KEY
      See Also:
      • Constant Field Values

  • Constructor Details

    • PvxLibElement

      public PvxLibElement(String[] libElementData, org.eclipse.core.resources.IResource lib, String initPath)

  • Method Details

    • getImageForElement

      public org.eclipse.swt.graphics.Image getImageForElement()

    • getStpElement

      public String getStpElement(int indx)

    • setElement

      public void setElement(int indx, String value)

    • getElement

      public String getElement(int indx)

    • getPathToFile

      public String getPathToFile()

    • getLibOutputDir

      public String getLibOutputDir()

    • getName

      public String getName()

    • getType

      public int getType()
      Specified by:
      getType in interface IPvxElement

    • toString

      public String toString()
      Overrides:
      toString in class Object


Uses of Class com.pvx.ooadide.views.nomads.LibView

Uses of Class
com.pvx.ooadide.views.nomads.LibView

Packages that use LibView
Package
Description
com.pvx.ooadide.views

  • Uses of LibView in com.pvx.ooadide.views

    Subclasses of LibView in com.pvx.ooadide.views
    Modifier and Type
    Class
    Description
    class
    IOListView


Uses of Class com.pvx.ooadide.views.nomads.LibView.ViewContentProvider

Uses of Class
com.pvx.ooadide.views.nomads.LibView.ViewContentProvider

No usage of com.pvx.ooadide.views.nomads.LibView.ViewContentProvider


Uses of Class com.pvx.ooadide.views.nomads.LibView.ViewLabelProvider

Uses of Class
com.pvx.ooadide.views.nomads.LibView.ViewLabelProvider

No usage of com.pvx.ooadide.views.nomads.LibView.ViewLabelProvider


Uses of Class com.pvx.ooadide.views.nomads.NewNomadsObjectDialog

Uses of Class
com.pvx.ooadide.views.nomads.NewNomadsObjectDialog

No usage of com.pvx.ooadide.views.nomads.NewNomadsObjectDialog


Uses of Class com.pvx.ooadide.views.nomads.PvxLibElement

Uses of Class
com.pvx.ooadide.views.nomads.PvxLibElement

No usage of com.pvx.ooadide.views.nomads.PvxLibElement


ExportPasswordsPage

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.wizards

Class ExportPasswordsPage

java.lang.Object
org.eclipse.jface.dialogs.DialogPage
org.eclipse.jface.wizard.WizardPage
com.pvx.ooadide.wizards.WizardPasswordPage
com.pvx.ooadide.wizards.ExportPasswordsPage
All Implemented Interfaces:
org.eclipse.jface.dialogs.IDialogPage, org.eclipse.jface.dialogs.IMessageProvider, org.eclipse.jface.wizard.IWizardPage, org.eclipse.swt.widgets.Listener, org.eclipse.ui.dialogs.IOverwriteQuery
public class ExportPasswordsPage extends WizardPasswordPage
Page 1 of the base preference export Wizard
Since:
3.1

  • Field Summary

    Fields inherited from interface org.eclipse.jface.dialogs.IMessageProvider

    ERROR, INFORMATION, NONE, WARNING

    Fields inherited from interface org.eclipse.ui.dialogs.IOverwriteQuery

    ALL, CANCEL, NO, NO_ALL, YES

  • Constructor Summary

    Constructors
    Constructor
    Description
    ExportPasswordsPage()
    Create an instance of this class

  • Method Summary

    Methods inherited from class com.pvx.ooadide.wizards.WizardPasswordPage

    createControl, dispose, finish, handleEvent, queryOverwrite, setPageComplete

    Methods inherited from class org.eclipse.jface.wizard.WizardPage

    canFlipToNextPage, getImage, getName, getNextPage, getPreviousPage, getShell, getWizard, isPageComplete, setDescription, setErrorMessage, setImageDescriptor, setMessage, setPageComplete, setPreviousPage, setTitle, setWizard, toString

    Methods inherited from class org.eclipse.jface.dialogs.DialogPage

    getControl, getDescription, getErrorMessage, getMessage, getMessageType, getTitle, performHelp, setMessage, setVisible

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

    Methods inherited from interface org.eclipse.jface.dialogs.IDialogPage

    getControl, getDescription, getErrorMessage, getMessage, getTitle, performHelp, setVisible

  • Constructor Details

    • ExportPasswordsPage

      public ExportPasswordsPage()
      Create an instance of this class


ImportPasswordsWizard

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.wizards

Class ImportPasswordsWizard

java.lang.Object
org.eclipse.jface.wizard.Wizard
com.pvx.ooadide.wizards.ImportPasswordsWizard
All Implemented Interfaces:
org.eclipse.jface.window.IShellProvider, org.eclipse.jface.wizard.IWizard, org.eclipse.ui.IImportWizard, org.eclipse.ui.IWorkbenchWizard
public class ImportPasswordsWizard extends org.eclipse.jface.wizard.Wizard implements org.eclipse.ui.IImportWizard
Standard workbench wizard for importing resources from the local file system into the workspace.

This class may be instantiated and used without further configuration; this class is not intended to be subclassed.

Example:

 IWizard wizard = new PreferencesImportWizard();
 wizard.init(workbench, selection);
 WizardDialog dialog = new WizardDialog(shell, wizard);
 dialog.open();
During the call to open, the wizard dialog is presented to the user. When the user hits Finish, the user-selected files are imported into the workspace, the dialog closes, and the call to open returns.

Since:
3.1

  • Field Summary

    Fields inherited from class org.eclipse.jface.wizard.Wizard

    DEFAULT_IMAGE

  • Constructor Summary

    Constructors
    Constructor
    Description
    ImportPasswordsWizard()
    Creates a wizard for importing resources into the workspace from the file system.

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    addPages()
    void
    init(org.eclipse.ui.IWorkbench workbench, org.eclipse.jface.viewers.IStructuredSelection currentSelection)
    boolean
    performFinish()

    Methods inherited from class org.eclipse.jface.wizard.Wizard

    addPage, canFinish, createPageControls, dispose, getContainer, getDefaultPageImage, getDialogSettings, getNextPage, getPage, getPageCount, getPages, getPreviousPage, getShell, getStartingPage, getTitleBarColor, getWindowTitle, isHelpAvailable, needsPreviousAndNextButtons, needsProgressMonitor, performCancel, setContainer, setDefaultPageImageDescriptor, setDialogSettings, setForcePreviousAndNextButtons, setHelpAvailable, setNeedsProgressMonitor, setTitleBarColor, setWindowTitle

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface org.eclipse.jface.wizard.IWizard

    canFinish, createPageControls, dispose, getContainer, getDefaultPageImage, getDialogSettings, getNextPage, getPage, getPageCount, getPages, getPreviousPage, getStartingPage, getTitleBarColor, getWindowTitle, isHelpAvailable, needsPreviousAndNextButtons, needsProgressMonitor, performCancel, setContainer

  • Constructor Details

    • ImportPasswordsWizard

      public ImportPasswordsWizard()
      Creates a wizard for importing resources into the workspace from the file system.

  • Method Details

    • addPages

      public void addPages()
      Specified by:
      addPages in interface org.eclipse.jface.wizard.IWizard
      Overrides:
      addPages in class org.eclipse.jface.wizard.Wizard

    • init

      public void init(org.eclipse.ui.IWorkbench workbench, org.eclipse.jface.viewers.IStructuredSelection currentSelection)
      Specified by:
      init in interface org.eclipse.ui.IWorkbenchWizard

    • performFinish

      public boolean performFinish()
      Specified by:
      performFinish in interface org.eclipse.jface.wizard.IWizard
      Specified by:
      performFinish in class org.eclipse.jface.wizard.Wizard


NewFromExisting

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.wizards

Class NewFromExisting

java.lang.Object
org.eclipse.jface.wizard.Wizard
com.pvx.ooadide.wizards.NewFromExisting
All Implemented Interfaces:
org.eclipse.jface.window.IShellProvider, org.eclipse.jface.wizard.IWizard, org.eclipse.ui.INewWizard, org.eclipse.ui.IWorkbenchWizard
public class NewFromExisting extends org.eclipse.jface.wizard.Wizard implements org.eclipse.ui.INewWizard

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final String
    ID

    Fields inherited from class org.eclipse.jface.wizard.Wizard

    DEFAULT_IMAGE

  • Constructor Summary

    Constructors
    Constructor
    Description
    NewFromExisting()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    addPages()
    static org.eclipse.core.runtime.Path
    createIniFileName(String projLocation, String projName)
    NewProjectFromExistingPage
    getNewProjectPage()
    void
    init(org.eclipse.ui.IWorkbench workbench, org.eclipse.jface.viewers.IStructuredSelection selection)
    static boolean
    isWizardRunning()
    boolean
    performFinish()
    void
    setNewProjectPage(NewProjectFromExistingPage page)

    Methods inherited from class org.eclipse.jface.wizard.Wizard

    addPage, canFinish, createPageControls, dispose, getContainer, getDefaultPageImage, getDialogSettings, getNextPage, getPage, getPageCount, getPages, getPreviousPage, getShell, getStartingPage, getTitleBarColor, getWindowTitle, isHelpAvailable, needsPreviousAndNextButtons, needsProgressMonitor, performCancel, setContainer, setDefaultPageImageDescriptor, setDialogSettings, setForcePreviousAndNextButtons, setHelpAvailable, setNeedsProgressMonitor, setTitleBarColor, setWindowTitle

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface org.eclipse.jface.wizard.IWizard

    canFinish, createPageControls, dispose, getContainer, getDefaultPageImage, getDialogSettings, getNextPage, getPage, getPageCount, getPages, getPreviousPage, getStartingPage, getTitleBarColor, getWindowTitle, isHelpAvailable, needsPreviousAndNextButtons, needsProgressMonitor, performCancel, setContainer

  • Field Details

    • ID

      public static final String ID
      See Also:
      • Constant Field Values

  • Constructor Details

    • NewFromExisting

      public NewFromExisting()

  • Method Details

    • addPages

      public void addPages()
      Specified by:
      addPages in interface org.eclipse.jface.wizard.IWizard
      Overrides:
      addPages in class org.eclipse.jface.wizard.Wizard

    • performFinish

      public boolean performFinish()
      Specified by:
      performFinish in interface org.eclipse.jface.wizard.IWizard
      Specified by:
      performFinish in class org.eclipse.jface.wizard.Wizard

    • init

      public void init(org.eclipse.ui.IWorkbench workbench, org.eclipse.jface.viewers.IStructuredSelection selection)
      Specified by:
      init in interface org.eclipse.ui.IWorkbenchWizard

    • createIniFileName

      public static org.eclipse.core.runtime.Path createIniFileName(String projLocation, String projName)

    • isWizardRunning

      public static boolean isWizardRunning()

    • setNewProjectPage

      public void setNewProjectPage(NewProjectFromExistingPage page)

    • getNewProjectPage

      public NewProjectFromExistingPage getNewProjectPage()


NewNomadsLibraryWizard

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.wizards

Class NewNomadsLibraryWizard

java.lang.Object
org.eclipse.jface.wizard.Wizard
org.eclipse.ui.wizards.newresource.BasicNewResourceWizard
org.eclipse.ui.wizards.newresource.BasicNewFileResourceWizard
com.pvx.ooadide.wizards.NewNomadsLibraryWizard
All Implemented Interfaces:
org.eclipse.jface.window.IShellProvider, org.eclipse.jface.wizard.IWizard, org.eclipse.ui.INewWizard, org.eclipse.ui.IWorkbenchWizard
public class NewNomadsLibraryWizard extends org.eclipse.ui.wizards.newresource.BasicNewFileResourceWizard implements org.eclipse.ui.INewWizard

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final String
    ID

    Fields inherited from class org.eclipse.ui.wizards.newresource.BasicNewFileResourceWizard

    WIZARD_ID

    Fields inherited from class org.eclipse.jface.wizard.Wizard

    DEFAULT_IMAGE

  • Constructor Summary

    Constructors
    Constructor
    Description
    NewNomadsLibraryWizard()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    addPages()
    Adding the page to the wizard.
    void
    addTestPage(PvxNewProgramPropertiesWizardPage testpage)
    PvxNewProgramPropertiesWizardPage
    getPvxWizPage()
    void
    init(org.eclipse.ui.IWorkbench workbench, org.eclipse.jface.viewers.IStructuredSelection selection)
    We will accept the selection in the workbench to see if we can initialize from it.
    boolean
    performFinish()
    This method is called when 'Finish' button is pressed in the wizard.
    static void
    selectAndReveal(org.eclipse.core.resources.IResource resource, org.eclipse.ui.IWorkbenchWindow window)
    Attempts to select and reveal the specified resource in all parts within the supplied workbench window's active page.

    Methods inherited from class org.eclipse.ui.wizards.newresource.BasicNewResourceWizard

    getSelection, getWorkbench

    Methods inherited from class org.eclipse.jface.wizard.Wizard

    addPage, canFinish, createPageControls, dispose, getContainer, getDefaultPageImage, getDialogSettings, getNextPage, getPage, getPageCount, getPages, getPreviousPage, getShell, getStartingPage, getTitleBarColor, getWindowTitle, isHelpAvailable, needsPreviousAndNextButtons, needsProgressMonitor, performCancel, setContainer, setDefaultPageImageDescriptor, setDialogSettings, setForcePreviousAndNextButtons, setHelpAvailable, setNeedsProgressMonitor, setTitleBarColor, setWindowTitle

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface org.eclipse.jface.wizard.IWizard

    canFinish, createPageControls, dispose, getContainer, getDefaultPageImage, getDialogSettings, getNextPage, getPage, getPageCount, getPages, getPreviousPage, getStartingPage, getTitleBarColor, getWindowTitle, isHelpAvailable, needsPreviousAndNextButtons, needsProgressMonitor, performCancel, setContainer

  • Field Details

    • ID

      public static final String ID
      See Also:
      • Constant Field Values

  • Constructor Details

    • NewNomadsLibraryWizard

      public NewNomadsLibraryWizard()

  • Method Details

    • getPvxWizPage

      public PvxNewProgramPropertiesWizardPage getPvxWizPage()

    • addPages

      public void addPages()
      Adding the page to the wizard.
      Specified by:
      addPages in interface org.eclipse.jface.wizard.IWizard
      Overrides:
      addPages in class org.eclipse.ui.wizards.newresource.BasicNewFileResourceWizard

    • addTestPage

      public void addTestPage(PvxNewProgramPropertiesWizardPage testpage)

    • performFinish

      public boolean performFinish()
      This method is called when 'Finish' button is pressed in the wizard. We will create an operation and run it using wizard as execution context.
      Specified by:
      performFinish in interface org.eclipse.jface.wizard.IWizard
      Overrides:
      performFinish in class org.eclipse.ui.wizards.newresource.BasicNewFileResourceWizard

    • init

      public void init(org.eclipse.ui.IWorkbench workbench, org.eclipse.jface.viewers.IStructuredSelection selection)
      We will accept the selection in the workbench to see if we can initialize from it.
      Specified by:
      init in interface org.eclipse.ui.IWorkbenchWizard
      Overrides:
      init in class org.eclipse.ui.wizards.newresource.BasicNewFileResourceWizard
      See Also:
      • IWorkbenchWizard.init(IWorkbench, IStructuredSelection)

    • selectAndReveal

      public static void selectAndReveal(org.eclipse.core.resources.IResource resource, org.eclipse.ui.IWorkbenchWindow window)
      Attempts to select and reveal the specified resource in all parts within the supplied workbench window's active page.

      Checks all parts in the active page to see if they implement ISetSelectionTarget, either directly or as an adapter. If so, tells the part to select and reveal the specified resource.

      Parameters:
      resource - the resource to be selected and revealed
      window - the workbench window to select and reveal the resource
      See Also:
      • ISetSelectionTarget


NewNomadsNmdWizard

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.wizards

Class NewNomadsNmdWizard

java.lang.Object
org.eclipse.jface.wizard.Wizard
org.eclipse.ui.wizards.newresource.BasicNewResourceWizard
org.eclipse.ui.wizards.newresource.BasicNewFileResourceWizard
com.pvx.ooadide.wizards.NewNomadsNmdWizard
All Implemented Interfaces:
org.eclipse.jface.window.IShellProvider, org.eclipse.jface.wizard.IWizard, org.eclipse.ui.INewWizard, org.eclipse.ui.IWorkbenchWizard
public class NewNomadsNmdWizard extends org.eclipse.ui.wizards.newresource.BasicNewFileResourceWizard implements org.eclipse.ui.INewWizard

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final String
    ID

    Fields inherited from class org.eclipse.ui.wizards.newresource.BasicNewFileResourceWizard

    WIZARD_ID

    Fields inherited from class org.eclipse.jface.wizard.Wizard

    DEFAULT_IMAGE

  • Constructor Summary

    Constructors
    Constructor
    Description
    NewNomadsNmdWizard()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    addPages()
    Adding the page to the wizard.
    void
    addTestPage(PvxNewProgramPropertiesWizardPage testpage)
    PvxNewProgramPropertiesWizardPage
    getPvxWizPage()
    void
    init(org.eclipse.ui.IWorkbench workbench, org.eclipse.jface.viewers.IStructuredSelection selection)
    We will accept the selection in the workbench to see if we can initialize from it.
    boolean
    performFinish()
    This method is called when 'Finish' button is pressed in the wizard.
    static void
    selectAndReveal(org.eclipse.core.resources.IResource resource, org.eclipse.ui.IWorkbenchWindow window)
    Attempts to select and reveal the specified resource in all parts within the supplied workbench window's active page.

    Methods inherited from class org.eclipse.ui.wizards.newresource.BasicNewResourceWizard

    getSelection, getWorkbench

    Methods inherited from class org.eclipse.jface.wizard.Wizard

    addPage, canFinish, createPageControls, dispose, getContainer, getDefaultPageImage, getDialogSettings, getNextPage, getPage, getPageCount, getPages, getPreviousPage, getShell, getStartingPage, getTitleBarColor, getWindowTitle, isHelpAvailable, needsPreviousAndNextButtons, needsProgressMonitor, performCancel, setContainer, setDefaultPageImageDescriptor, setDialogSettings, setForcePreviousAndNextButtons, setHelpAvailable, setNeedsProgressMonitor, setTitleBarColor, setWindowTitle

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface org.eclipse.jface.wizard.IWizard

    canFinish, createPageControls, dispose, getContainer, getDefaultPageImage, getDialogSettings, getNextPage, getPage, getPageCount, getPages, getPreviousPage, getStartingPage, getTitleBarColor, getWindowTitle, isHelpAvailable, needsPreviousAndNextButtons, needsProgressMonitor, performCancel, setContainer

  • Field Details

    • ID

      public static final String ID
      See Also:
      • Constant Field Values

  • Constructor Details

    • NewNomadsNmdWizard

      public NewNomadsNmdWizard()

  • Method Details

    • getPvxWizPage

      public PvxNewProgramPropertiesWizardPage getPvxWizPage()

    • addPages

      public void addPages()
      Adding the page to the wizard.
      Specified by:
      addPages in interface org.eclipse.jface.wizard.IWizard
      Overrides:
      addPages in class org.eclipse.ui.wizards.newresource.BasicNewFileResourceWizard

    • addTestPage

      public void addTestPage(PvxNewProgramPropertiesWizardPage testpage)

    • performFinish

      public boolean performFinish()
      This method is called when 'Finish' button is pressed in the wizard. We will create an operation and run it using wizard as execution context.
      Specified by:
      performFinish in interface org.eclipse.jface.wizard.IWizard
      Overrides:
      performFinish in class org.eclipse.ui.wizards.newresource.BasicNewFileResourceWizard

    • init

      public void init(org.eclipse.ui.IWorkbench workbench, org.eclipse.jface.viewers.IStructuredSelection selection)
      We will accept the selection in the workbench to see if we can initialize from it.
      Specified by:
      init in interface org.eclipse.ui.IWorkbenchWizard
      Overrides:
      init in class org.eclipse.ui.wizards.newresource.BasicNewFileResourceWizard
      See Also:
      • IWorkbenchWizard.init(IWorkbench, IStructuredSelection)

    • selectAndReveal

      public static void selectAndReveal(org.eclipse.core.resources.IResource resource, org.eclipse.ui.IWorkbenchWindow window)
      Attempts to select and reveal the specified resource in all parts within the supplied workbench window's active page.

      Checks all parts in the active page to see if they implement ISetSelectionTarget, either directly or as an adapter. If so, tells the part to select and reveal the specified resource.

      Parameters:
      resource - the resource to be selected and revealed
      window - the workbench window to select and reveal the resource
      See Also:
      • ISetSelectionTarget


NewProjectFromExistingPage

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.wizards

Class NewProjectFromExistingPage

java.lang.Object
org.eclipse.jface.dialogs.DialogPage
org.eclipse.jface.wizard.WizardPage
com.pvx.ooadide.wizards.NewProjectFromExistingPage
All Implemented Interfaces:
org.eclipse.jface.dialogs.IDialogPage, org.eclipse.jface.dialogs.IMessageProvider, org.eclipse.jface.wizard.IWizardPage
public class NewProjectFromExistingPage extends org.eclipse.jface.wizard.WizardPage
Standard main page for a wizard that is creates a project resource.

This page may be used by clients as-is; it may be also be subclassed to suit.

Example useage:

 mainPage = new WizardNewProjectCreationPage("basicNewProjectPage");
 mainPage.setTitle("Project");
 mainPage.setDescription("Create a new project resource.");

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final String
    PROJECT_DEF_PVX_EXE
    static final String
    PROJECT_OWNER
    static final String
    PROJECT_OWNER_FLAGS
    static final String
    PROJECT_PASSWORD
    boolean
    useOutputDefaults

    Fields inherited from interface org.eclipse.jface.dialogs.IMessageProvider

    ERROR, INFORMATION, NONE, WARNING

  • Constructor Summary

    Constructors
    Constructor
    Description
    NewProjectFromExistingPage(org.eclipse.jface.viewers.ISelection selection)
    Creates a new project creation wizard page.

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    createControl(org.eclipse.swt.widgets.Composite parent)
    (non-Javadoc) Method declared on IDialogPage.
    String
    getInitialInputLocationFieldValue()
    String
    getInputFolder()
    org.eclipse.swt.widgets.Text
    getInputLocationPathField()
    org.eclipse.core.runtime.IPath
    getLocationPath()
    Returns the current project location path as entered by the user, or its anticipated initial value.
    String
    getOutputFolder()
    String
    getProjectBuilder()
    org.eclipse.core.resources.IProject
    getProjectHandle()
    Creates a project resource handle for the current project name field value.
    String
    getProjectName()
    Returns the current project name as entered by the user, or its anticipated initial value.
    String
    getProjectOwnerCode()
    org.eclipse.swt.widgets.Text
    getProjectOwnerField()
    String
    getProjectOwnerFlags()
    String
    getProjectPassword()
    String
    getPropsField()
    void
    setInitialInputLocationFieldValue(String initialInputLocationFieldValue)
    void
    setInputLocationPathField(org.eclipse.swt.widgets.Text inputLocationPathField)
    void
    setProjectOwnerField(org.eclipse.swt.widgets.Text projectOwnerField)

    Methods inherited from class org.eclipse.jface.wizard.WizardPage

    canFlipToNextPage, getImage, getName, getNextPage, getPreviousPage, getShell, getWizard, isPageComplete, setDescription, setErrorMessage, setImageDescriptor, setMessage, setPageComplete, setPreviousPage, setTitle, setWizard, toString

    Methods inherited from class org.eclipse.jface.dialogs.DialogPage

    dispose, getControl, getDescription, getErrorMessage, getMessage, getMessageType, getTitle, performHelp, setMessage, setVisible

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

    Methods inherited from interface org.eclipse.jface.dialogs.IDialogPage

    dispose, getControl, getDescription, getErrorMessage, getMessage, getTitle, performHelp, setVisible

  • Field Details

    • PROJECT_DEF_PVX_EXE

      public static final String PROJECT_DEF_PVX_EXE
      See Also:
      • Constant Field Values

    • PROJECT_PASSWORD

      public static final String PROJECT_PASSWORD
      See Also:
      • Constant Field Values

    • PROJECT_OWNER

      public static final String PROJECT_OWNER
      See Also:
      • Constant Field Values

    • PROJECT_OWNER_FLAGS

      public static final String PROJECT_OWNER_FLAGS
      See Also:
      • Constant Field Values

    • useOutputDefaults

      public boolean useOutputDefaults

  • Constructor Details

    • NewProjectFromExistingPage

      public NewProjectFromExistingPage(org.eclipse.jface.viewers.ISelection selection)
      Creates a new project creation wizard page.
      Parameters:
      pageName - the name of this page

  • Method Details

    • createControl

      public void createControl(org.eclipse.swt.widgets.Composite parent)
      (non-Javadoc) Method declared on IDialogPage.

    • getLocationPath

      public org.eclipse.core.runtime.IPath getLocationPath()
      Returns the current project location path as entered by the user, or its anticipated initial value. Note that if the default has been returned the path in a project description used to create a project should not be set.
      Returns:
      the project location path or its anticipated initial value.

    • getOutputFolder

      public String getOutputFolder()

    • getInputFolder

      public String getInputFolder()

    • getProjectHandle

      public org.eclipse.core.resources.IProject getProjectHandle()
      Creates a project resource handle for the current project name field value.

      This method does not create the project resource; this is the responsibility of IProject::create invoked by the new project resource wizard.

      Returns:
      the new project resource handle

    • getProjectName

      public String getProjectName()
      Returns the current project name as entered by the user, or its anticipated initial value.
      Returns:
      the project name, its anticipated initial value, or null if no project name is known

    • getProjectBuilder

      public String getProjectBuilder()

    • getProjectPassword

      public String getProjectPassword()

    • getProjectOwnerFlags

      public String getProjectOwnerFlags()

    • getProjectOwnerCode

      public String getProjectOwnerCode()

    • getPropsField

      public String getPropsField()

    • setInitialInputLocationFieldValue

      public void setInitialInputLocationFieldValue(String initialInputLocationFieldValue)

    • getInitialInputLocationFieldValue

      public String getInitialInputLocationFieldValue()

    • setInputLocationPathField

      public void setInputLocationPathField(org.eclipse.swt.widgets.Text inputLocationPathField)

    • getInputLocationPathField

      public org.eclipse.swt.widgets.Text getInputLocationPathField()

    • setProjectOwnerField

      public void setProjectOwnerField(org.eclipse.swt.widgets.Text projectOwnerField)

    • getProjectOwnerField

      public org.eclipse.swt.widgets.Text getProjectOwnerField()


com.pvx.ooadide.wizards

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.pvx.ooadide.wizards

package com.pvx.ooadide.wizards
  • Related Packages
    Package
    Description
    com.pvx.ooadide
    com.pvx.ooadide.wizards.programs
  • Class
    Description
    ExportPasswordsPage
    Page 1 of the base preference export Wizard
    ImportPasswordsWizard
    Standard workbench wizard for importing resources from the local file system into the workspace.
    NewFromExisting
    NewNomadsLibraryWizard
    NewNomadsNmdWizard
    NewProjectFromExistingPage
    Standard main page for a wizard that is creates a project resource.
    PasswordExporterWizard
    PasswordTransferElement
    ProvideXNewWizard
    ProvidexNewWizardPage
    Standard main page for a wizard that is creates a project resource.
    ProvideXNewWizardPageI
    WizardNewProjectPasswordPage
    WizardPasswordImportPage1
    Page 1 of the base preference import Wizard
    WizardPasswordPage
    Base class for preference export/import pages.


com.pvx.ooadide.wizards Class Hierarchy

Hierarchy For Package com.pvx.ooadide.wizards

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.eclipse.jface.dialogs.DialogPage (implements org.eclipse.jface.dialogs.IDialogPage, org.eclipse.jface.dialogs.IMessageProvider)
      • org.eclipse.jface.wizard.WizardPage (implements org.eclipse.jface.wizard.IWizardPage)
        • com.pvx.ooadide.wizards.NewProjectFromExistingPage
        • com.pvx.ooadide.wizards.ProvidexNewWizardPage (implements com.pvx.ooadide.wizards.ProvideXNewWizardPageI)
          • com.pvx.ooadide.wizards.WizardNewProjectPasswordPage
        • com.pvx.ooadide.wizards.WizardPasswordPage (implements org.eclipse.ui.dialogs.IOverwriteQuery, org.eclipse.swt.widgets.Listener)
          • com.pvx.ooadide.wizards.ExportPasswordsPage
          • com.pvx.ooadide.wizards.WizardPasswordImportPage1
    • com.pvx.ooadide.wizards.PasswordTransferElement (implements org.eclipse.core.runtime.preferences.IPreferenceFilter)
    • org.eclipse.jface.wizard.Wizard (implements org.eclipse.jface.window.IShellProvider, org.eclipse.jface.wizard.IWizard)
      • org.eclipse.ui.wizards.newresource.BasicNewResourceWizard (implements org.eclipse.ui.INewWizard)
        • org.eclipse.ui.wizards.newresource.BasicNewFileResourceWizard
          • com.pvx.ooadide.wizards.NewNomadsLibraryWizard (implements org.eclipse.ui.INewWizard)
          • com.pvx.ooadide.wizards.NewNomadsNmdWizard (implements org.eclipse.ui.INewWizard)
      • com.pvx.ooadide.wizards.ImportPasswordsWizard (implements org.eclipse.ui.IImportWizard)
      • com.pvx.ooadide.wizards.NewFromExisting (implements org.eclipse.ui.INewWizard)
      • com.pvx.ooadide.wizards.PasswordExporterWizard (implements org.eclipse.ui.IExportWizard)
      • com.pvx.ooadide.wizards.ProvideXNewWizard (implements org.eclipse.ui.INewWizard)

Interface Hierarchy

  • com.pvx.ooadide.wizards.ProvideXNewWizardPageI


Uses of Package com.pvx.ooadide.wizards

Uses of Package
com.pvx.ooadide.wizards

Packages that use com.pvx.ooadide.wizards
Package
Description
com.pvx.ooadide.wizards
  • Classes in com.pvx.ooadide.wizards used by com.pvx.ooadide.wizards
    Class
    Description
    NewProjectFromExistingPage
    Standard main page for a wizard that is creates a project resource.
    ProvidexNewWizardPage
    Standard main page for a wizard that is creates a project resource.
    ProvideXNewWizardPageI
    WizardPasswordPage
    Base class for preference export/import pages.


PasswordExporterWizard

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.wizards

Class PasswordExporterWizard

java.lang.Object
org.eclipse.jface.wizard.Wizard
com.pvx.ooadide.wizards.PasswordExporterWizard
All Implemented Interfaces:
org.eclipse.jface.window.IShellProvider, org.eclipse.jface.wizard.IWizard, org.eclipse.ui.IExportWizard, org.eclipse.ui.IWorkbenchWizard
public class PasswordExporterWizard extends org.eclipse.jface.wizard.Wizard implements org.eclipse.ui.IExportWizard

  • Field Summary

    Fields inherited from class org.eclipse.jface.wizard.Wizard

    DEFAULT_IMAGE

  • Constructor Summary

    Constructors
    Constructor
    Description
    PasswordExporterWizard()
    Creates a wizard for exporting workspace preferences to the local file system.

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    addPages()
    void
    init(org.eclipse.ui.IWorkbench workbench, org.eclipse.jface.viewers.IStructuredSelection currentSelection)
    boolean
    performFinish()

    Methods inherited from class org.eclipse.jface.wizard.Wizard

    addPage, canFinish, createPageControls, dispose, getContainer, getDefaultPageImage, getDialogSettings, getNextPage, getPage, getPageCount, getPages, getPreviousPage, getShell, getStartingPage, getTitleBarColor, getWindowTitle, isHelpAvailable, needsPreviousAndNextButtons, needsProgressMonitor, performCancel, setContainer, setDefaultPageImageDescriptor, setDialogSettings, setForcePreviousAndNextButtons, setHelpAvailable, setNeedsProgressMonitor, setTitleBarColor, setWindowTitle

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface org.eclipse.jface.wizard.IWizard

    canFinish, createPageControls, dispose, getContainer, getDefaultPageImage, getDialogSettings, getNextPage, getPage, getPageCount, getPages, getPreviousPage, getStartingPage, getTitleBarColor, getWindowTitle, isHelpAvailable, needsPreviousAndNextButtons, needsProgressMonitor, performCancel, setContainer

  • Constructor Details

    • PasswordExporterWizard

      public PasswordExporterWizard()
      Creates a wizard for exporting workspace preferences to the local file system.

  • Method Details

    • addPages

      public void addPages()
      Specified by:
      addPages in interface org.eclipse.jface.wizard.IWizard
      Overrides:
      addPages in class org.eclipse.jface.wizard.Wizard

    • init

      public void init(org.eclipse.ui.IWorkbench workbench, org.eclipse.jface.viewers.IStructuredSelection currentSelection)
      Specified by:
      init in interface org.eclipse.ui.IWorkbenchWizard

    • performFinish

      public boolean performFinish()
      Specified by:
      performFinish in interface org.eclipse.jface.wizard.IWizard
      Specified by:
      performFinish in class org.eclipse.jface.wizard.Wizard


PasswordTransferElement

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.wizards

Class PasswordTransferElement

java.lang.Object
com.pvx.ooadide.wizards.PasswordTransferElement
All Implemented Interfaces:
org.eclipse.core.runtime.preferences.IPreferenceFilter
public class PasswordTransferElement extends Object implements org.eclipse.core.runtime.preferences.IPreferenceFilter

  • Constructor Summary

    Constructors
    Constructor
    Description
    PasswordTransferElement(org.eclipse.core.resources.IProject init_project)

  • Method Summary

    Modifier and Type
    Method
    Description
    String
    getDescription()
    org.eclipse.jface.resource.ImageDescriptor
    getImageDescriptor()
    Map
    getMapping(String scope)
    String[]
    getName()
    String[]
    getScopes()
    Object
    getTransElement()

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • PasswordTransferElement

      public PasswordTransferElement(org.eclipse.core.resources.IProject init_project)

  • Method Details

    • getImageDescriptor

      public org.eclipse.jface.resource.ImageDescriptor getImageDescriptor()

    • getName

      public String[] getName()

    • getDescription

      public String getDescription()

    • getScopes

      public String[] getScopes()
      Specified by:
      getScopes in interface org.eclipse.core.runtime.preferences.IPreferenceFilter

    • getMapping

      public Map getMapping(String scope)
      Specified by:
      getMapping in interface org.eclipse.core.runtime.preferences.IPreferenceFilter

    • getTransElement

      public Object getTransElement()


ProvideXNewWizard

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.wizards

Class ProvideXNewWizard

java.lang.Object
org.eclipse.jface.wizard.Wizard
com.pvx.ooadide.wizards.ProvideXNewWizard
All Implemented Interfaces:
org.eclipse.jface.window.IShellProvider, org.eclipse.jface.wizard.IWizard, org.eclipse.ui.INewWizard, org.eclipse.ui.IWorkbenchWizard
public class ProvideXNewWizard extends org.eclipse.jface.wizard.Wizard implements org.eclipse.ui.INewWizard

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final String
    ID

    Fields inherited from class org.eclipse.jface.wizard.Wizard

    DEFAULT_IMAGE

  • Constructor Summary

    Constructors
    Constructor
    Description
    ProvideXNewWizard()
    Constructor for ProvideXNewWizard.

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    addPages()
    Adding the page to the wizard.
    void
    addTestPage(ProvideXNewWizardPageI testpage)
    static org.eclipse.core.runtime.Path
    createIniFileName(String projLocation, String projName)
    ProvideXNewWizardPageI
    getPvxWizPage()
    void
    init(org.eclipse.ui.IWorkbench workbench, org.eclipse.jface.viewers.IStructuredSelection selection)
    We will accept the selection in the workbench to see if we can initialize from it.
    static boolean
    isWizardRunning()
    static void
    linkToExternalFolder(String externalOutputDir, org.eclipse.core.resources.IFolder folderHandle, org.eclipse.core.resources.IProject project, org.eclipse.core.runtime.IProgressMonitor monitor)
    boolean
    performFinish()
    This method is called when 'Finish' button is pressed in the wizard.

    Methods inherited from class org.eclipse.jface.wizard.Wizard

    addPage, canFinish, createPageControls, dispose, getContainer, getDefaultPageImage, getDialogSettings, getNextPage, getPage, getPageCount, getPages, getPreviousPage, getShell, getStartingPage, getTitleBarColor, getWindowTitle, isHelpAvailable, needsPreviousAndNextButtons, needsProgressMonitor, performCancel, setContainer, setDefaultPageImageDescriptor, setDialogSettings, setForcePreviousAndNextButtons, setHelpAvailable, setNeedsProgressMonitor, setTitleBarColor, setWindowTitle

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface org.eclipse.jface.wizard.IWizard

    canFinish, createPageControls, dispose, getContainer, getDefaultPageImage, getDialogSettings, getNextPage, getPage, getPageCount, getPages, getPreviousPage, getStartingPage, getTitleBarColor, getWindowTitle, isHelpAvailable, needsPreviousAndNextButtons, needsProgressMonitor, performCancel, setContainer

  • Field Details

    • ID

      public static final String ID
      See Also:
      • Constant Field Values

  • Constructor Details

    • ProvideXNewWizard

      public ProvideXNewWizard()
      Constructor for ProvideXNewWizard.

  • Method Details

    • getPvxWizPage

      public ProvideXNewWizardPageI getPvxWizPage()

    • addPages

      public void addPages()
      Adding the page to the wizard.
      Specified by:
      addPages in interface org.eclipse.jface.wizard.IWizard
      Overrides:
      addPages in class org.eclipse.jface.wizard.Wizard

    • addTestPage

      public void addTestPage(ProvideXNewWizardPageI testpage)

    • performFinish

      public boolean performFinish()
      This method is called when 'Finish' button is pressed in the wizard. We will create an operation and run it using wizard as execution context.
      Specified by:
      performFinish in interface org.eclipse.jface.wizard.IWizard
      Specified by:
      performFinish in class org.eclipse.jface.wizard.Wizard

    • init

      public void init(org.eclipse.ui.IWorkbench workbench, org.eclipse.jface.viewers.IStructuredSelection selection)
      We will accept the selection in the workbench to see if we can initialize from it.
      Specified by:
      init in interface org.eclipse.ui.IWorkbenchWizard
      See Also:
      • IWorkbenchWizard.init(IWorkbench, IStructuredSelection)

    • createIniFileName

      public static org.eclipse.core.runtime.Path createIniFileName(String projLocation, String projName)

    • isWizardRunning

      public static boolean isWizardRunning()

    • linkToExternalFolder

      public static void linkToExternalFolder(String externalOutputDir, org.eclipse.core.resources.IFolder folderHandle, org.eclipse.core.resources.IProject project, org.eclipse.core.runtime.IProgressMonitor monitor)


ProvidexNewWizardPage

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.wizards

Class ProvidexNewWizardPage

java.lang.Object
org.eclipse.jface.dialogs.DialogPage
org.eclipse.jface.wizard.WizardPage
com.pvx.ooadide.wizards.ProvidexNewWizardPage
All Implemented Interfaces:
ProvideXNewWizardPageI, org.eclipse.jface.dialogs.IDialogPage, org.eclipse.jface.dialogs.IMessageProvider, org.eclipse.jface.wizard.IWizardPage
Direct Known Subclasses:
WizardNewProjectPasswordPage
public class ProvidexNewWizardPage extends org.eclipse.jface.wizard.WizardPage implements ProvideXNewWizardPageI
Standard main page for a wizard that is creates a project resource.

This page may be used by clients as-is; it may be also be subclassed to suit.

Example useage:

 mainPage = new WizardNewProjectCreationPage("basicNewProjectPage");
 mainPage.setTitle("Project");
 mainPage.setDescription("Create a new project resource.");

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final String
    PROJECT_DEF_PVX_EXE
    static final String
    PROJECT_OWNER
    static final String
    PROJECT_OWNER_FLAGS
    static final String
    PROJECT_PASSWORD

    Fields inherited from interface org.eclipse.jface.dialogs.IMessageProvider

    ERROR, INFORMATION, NONE, WARNING

  • Constructor Summary

    Constructors
    Constructor
    Description
    ProvidexNewWizardPage(org.eclipse.jface.viewers.ISelection selection)
    Creates a new project creation wizard page.

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    createControl(org.eclipse.swt.widgets.Composite parent)
    (non-Javadoc) Method declared on IDialogPage.
    String
    getInputFolder()
    org.eclipse.core.runtime.IPath
    getLocationPath()
    Returns the current project location path as entered by the user, or its anticipated initial value.
    String
    getOutputFolder()
    String
    getProjectBuilder()
    org.eclipse.core.resources.IProject
    getProjectHandle()
    Creates a project resource handle for the current project name field value.
    String
    getProjectName()
    String
    getProjectOwnerCode()
    String
    getProjectOwnerFlags()
    String
    getProjectPassword()
    org.eclipse.jface.wizard.IWizardPage
    getWizardPage()
    Returns the current project name as entered by the user, or its anticipated initial value.
    boolean
    isUseDefaults()
    boolean
    isUseInputDefaults()
    boolean
    isUseOutputDefaults()
    void
    setInitialProjectName(String name)
    Sets the initial project name that this page will use when created.
    void
    setUseInputDefaults(boolean useInputDefaults)
    void
    setUseOutputDefaults(boolean useOutputDefaults)
    void
    setVisible(boolean visible)
    boolean
    useDefaults()
    Returns the useDefaults.

    Methods inherited from class org.eclipse.jface.wizard.WizardPage

    canFlipToNextPage, getImage, getName, getNextPage, getPreviousPage, getShell, getWizard, isPageComplete, setDescription, setErrorMessage, setImageDescriptor, setMessage, setPageComplete, setPreviousPage, setTitle, setWizard, toString

    Methods inherited from class org.eclipse.jface.dialogs.DialogPage

    dispose, getControl, getDescription, getErrorMessage, getMessage, getMessageType, getTitle, performHelp, setMessage

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

    Methods inherited from interface org.eclipse.jface.dialogs.IDialogPage

    dispose, getControl, getDescription, getErrorMessage, getMessage, getTitle, performHelp

  • Field Details

    • PROJECT_DEF_PVX_EXE

      public static final String PROJECT_DEF_PVX_EXE
      See Also:
      • Constant Field Values

    • PROJECT_PASSWORD

      public static final String PROJECT_PASSWORD
      See Also:
      • Constant Field Values

    • PROJECT_OWNER

      public static final String PROJECT_OWNER
      See Also:
      • Constant Field Values

    • PROJECT_OWNER_FLAGS

      public static final String PROJECT_OWNER_FLAGS
      See Also:
      • Constant Field Values

  • Constructor Details

    • ProvidexNewWizardPage

      public ProvidexNewWizardPage(org.eclipse.jface.viewers.ISelection selection)
      Creates a new project creation wizard page.
      Parameters:
      pageName - the name of this page

  • Method Details

    • createControl

      public void createControl(org.eclipse.swt.widgets.Composite parent)
      (non-Javadoc) Method declared on IDialogPage.
      Specified by:
      createControl in interface org.eclipse.jface.dialogs.IDialogPage

    • getLocationPath

      public org.eclipse.core.runtime.IPath getLocationPath()
      Description copied from interface: ProvideXNewWizardPageI
      Returns the current project location path as entered by the user, or its anticipated initial value. Note that if the default has been returned the path in a project description used to create a project should not be set.
      Specified by:
      getLocationPath in interface ProvideXNewWizardPageI
      Returns:
      the project location path or its anticipated initial value.

    • getOutputFolder

      public String getOutputFolder()
      Specified by:
      getOutputFolder in interface ProvideXNewWizardPageI

    • getInputFolder

      public String getInputFolder()
      Specified by:
      getInputFolder in interface ProvideXNewWizardPageI

    • getProjectHandle

      public org.eclipse.core.resources.IProject getProjectHandle()
      Description copied from interface: ProvideXNewWizardPageI
      Creates a project resource handle for the current project name field value.

      This method does not create the project resource; this is the responsibility of IProject::create invoked by the new project resource wizard.

      Specified by:
      getProjectHandle in interface ProvideXNewWizardPageI
      Returns:
      the new project resource handle

    • getProjectName

      public String getProjectName()
      Specified by:
      getProjectName in interface ProvideXNewWizardPageI

    • setInitialProjectName

      public void setInitialProjectName(String name)
      Sets the initial project name that this page will use when created. The name is ignored if the createControl(Composite) method has already been called. Leading and trailing spaces in the name are ignored.
      Parameters:
      name - initial project name for this page

    • setVisible

      public void setVisible(boolean visible)
      Specified by:
      setVisible in interface org.eclipse.jface.dialogs.IDialogPage
      Overrides:
      setVisible in class org.eclipse.jface.dialogs.DialogPage

    • useDefaults

      public boolean useDefaults()
      Returns the useDefaults.
      Returns:
      boolean

    • getProjectBuilder

      public String getProjectBuilder()
      Specified by:
      getProjectBuilder in interface ProvideXNewWizardPageI

    • getProjectPassword

      public String getProjectPassword()
      Specified by:
      getProjectPassword in interface ProvideXNewWizardPageI

    • getProjectOwnerFlags

      public String getProjectOwnerFlags()
      Specified by:
      getProjectOwnerFlags in interface ProvideXNewWizardPageI

    • getProjectOwnerCode

      public String getProjectOwnerCode()
      Specified by:
      getProjectOwnerCode in interface ProvideXNewWizardPageI

    • isUseDefaults

      public boolean isUseDefaults()
      Specified by:
      isUseDefaults in interface ProvideXNewWizardPageI

    • setUseOutputDefaults

      public void setUseOutputDefaults(boolean useOutputDefaults)
      Specified by:
      setUseOutputDefaults in interface ProvideXNewWizardPageI

    • isUseOutputDefaults

      public boolean isUseOutputDefaults()
      Specified by:
      isUseOutputDefaults in interface ProvideXNewWizardPageI

    • setUseInputDefaults

      public void setUseInputDefaults(boolean useInputDefaults)

    • isUseInputDefaults

      public boolean isUseInputDefaults()
      Specified by:
      isUseInputDefaults in interface ProvideXNewWizardPageI

    • getWizardPage

      public org.eclipse.jface.wizard.IWizardPage getWizardPage()
      Description copied from interface: ProvideXNewWizardPageI
      Returns the current project name as entered by the user, or its anticipated initial value.
      Specified by:
      getWizardPage in interface ProvideXNewWizardPageI
      Returns:
      the project name, its anticipated initial value, or null if no project name is known


ProvideXNewWizardPageI

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.wizards

Interface ProvideXNewWizardPageI

All Known Implementing Classes:
ProvidexNewWizardPage, WizardNewProjectPasswordPage
public interface ProvideXNewWizardPageI

  • Method Summary

    Modifier and Type
    Method
    Description
    String
    getInputFolder()
    org.eclipse.core.runtime.IPath
    getLocationPath()
    Returns the current project location path as entered by the user, or its anticipated initial value.
    String
    getOutputFolder()
    String
    getProjectBuilder()
    org.eclipse.core.resources.IProject
    getProjectHandle()
    Creates a project resource handle for the current project name field value.
    String
    getProjectName()
    String
    getProjectOwnerCode()
    String
    getProjectOwnerFlags()
    String
    getProjectPassword()
    org.eclipse.jface.wizard.IWizardPage
    getWizardPage()
    Returns the current project name as entered by the user, or its anticipated initial value.
    boolean
    isUseDefaults()
    boolean
    isUseInputDefaults()
    boolean
    isUseOutputDefaults()
    void
    setUseOutputDefaults(boolean useOutputDefaults)

  • Method Details

    • getLocationPath

      org.eclipse.core.runtime.IPath getLocationPath()
      Returns the current project location path as entered by the user, or its anticipated initial value. Note that if the default has been returned the path in a project description used to create a project should not be set.
      Returns:
      the project location path or its anticipated initial value.

    • getOutputFolder

      String getOutputFolder()

    • getInputFolder

      String getInputFolder()

    • getProjectHandle

      org.eclipse.core.resources.IProject getProjectHandle()
      Creates a project resource handle for the current project name field value.

      This method does not create the project resource; this is the responsibility of IProject::create invoked by the new project resource wizard.

      Returns:
      the new project resource handle

    • getWizardPage

      org.eclipse.jface.wizard.IWizardPage getWizardPage()
      Returns the current project name as entered by the user, or its anticipated initial value.
      Returns:
      the project name, its anticipated initial value, or null if no project name is known

    • getProjectName

      String getProjectName()

    • getProjectBuilder

      String getProjectBuilder()

    • getProjectPassword

      String getProjectPassword()

    • getProjectOwnerFlags

      String getProjectOwnerFlags()

    • getProjectOwnerCode

      String getProjectOwnerCode()

    • isUseDefaults

      boolean isUseDefaults()

    • isUseInputDefaults

      boolean isUseInputDefaults()

    • setUseOutputDefaults

      void setUseOutputDefaults(boolean useOutputDefaults)

    • isUseOutputDefaults

      boolean isUseOutputDefaults()


WizardNewProjectPasswordPage

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.wizards

Class WizardNewProjectPasswordPage

java.lang.Object
org.eclipse.jface.dialogs.DialogPage
org.eclipse.jface.wizard.WizardPage
com.pvx.ooadide.wizards.ProvidexNewWizardPage
com.pvx.ooadide.wizards.WizardNewProjectPasswordPage
All Implemented Interfaces:
ProvideXNewWizardPageI, org.eclipse.jface.dialogs.IDialogPage, org.eclipse.jface.dialogs.IMessageProvider, org.eclipse.jface.wizard.IWizardPage
public class WizardNewProjectPasswordPage extends ProvidexNewWizardPage

  • Field Summary

    Fields inherited from class com.pvx.ooadide.wizards.ProvidexNewWizardPage

    PROJECT_DEF_PVX_EXE, PROJECT_OWNER, PROJECT_OWNER_FLAGS, PROJECT_PASSWORD

    Fields inherited from interface org.eclipse.jface.dialogs.IMessageProvider

    ERROR, INFORMATION, NONE, WARNING

  • Constructor Summary

    Constructors
    Constructor
    Description
    WizardNewProjectPasswordPage(org.eclipse.jface.viewers.ISelection selection)

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    createControl(org.eclipse.swt.widgets.Composite parent)
    (non-Javadoc) Method declared on IDialogPage.

    Methods inherited from class com.pvx.ooadide.wizards.ProvidexNewWizardPage

    getInputFolder, getLocationPath, getOutputFolder, getProjectBuilder, getProjectHandle, getProjectName, getProjectOwnerCode, getProjectOwnerFlags, getProjectPassword, getWizardPage, isUseDefaults, isUseInputDefaults, isUseOutputDefaults, setInitialProjectName, setUseInputDefaults, setUseOutputDefaults, setVisible, useDefaults

    Methods inherited from class org.eclipse.jface.wizard.WizardPage

    canFlipToNextPage, getImage, getName, getNextPage, getPreviousPage, getShell, getWizard, isPageComplete, setDescription, setErrorMessage, setImageDescriptor, setMessage, setPageComplete, setPreviousPage, setTitle, setWizard, toString

    Methods inherited from class org.eclipse.jface.dialogs.DialogPage

    dispose, getControl, getDescription, getErrorMessage, getMessage, getMessageType, getTitle, performHelp, setMessage

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

    Methods inherited from interface org.eclipse.jface.dialogs.IDialogPage

    dispose, getControl, getDescription, getErrorMessage, getMessage, getTitle, performHelp

  • Constructor Details

    • WizardNewProjectPasswordPage

      public WizardNewProjectPasswordPage(org.eclipse.jface.viewers.ISelection selection)

  • Method Details

    • createControl

      public void createControl(org.eclipse.swt.widgets.Composite parent)
      Description copied from class: ProvidexNewWizardPage
      (non-Javadoc) Method declared on IDialogPage.
      Specified by:
      createControl in interface org.eclipse.jface.dialogs.IDialogPage
      Overrides:
      createControl in class ProvidexNewWizardPage


WizardPasswordImportPage1

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.wizards

Class WizardPasswordImportPage1

java.lang.Object
org.eclipse.jface.dialogs.DialogPage
org.eclipse.jface.wizard.WizardPage
com.pvx.ooadide.wizards.WizardPasswordPage
com.pvx.ooadide.wizards.WizardPasswordImportPage1
All Implemented Interfaces:
org.eclipse.jface.dialogs.IDialogPage, org.eclipse.jface.dialogs.IMessageProvider, org.eclipse.jface.wizard.IWizardPage, org.eclipse.swt.widgets.Listener, org.eclipse.ui.dialogs.IOverwriteQuery
public class WizardPasswordImportPage1 extends WizardPasswordPage
Page 1 of the base preference import Wizard
Since:
3.1

  • Field Summary

    Fields inherited from interface org.eclipse.jface.dialogs.IMessageProvider

    ERROR, INFORMATION, NONE, WARNING

    Fields inherited from interface org.eclipse.ui.dialogs.IOverwriteQuery

    ALL, CANCEL, NO, NO_ALL, YES

  • Constructor Summary

    Constructors
    Constructor
    Description
    WizardPasswordImportPage1()
    Create an instance of this class

  • Method Summary

    Modifier and Type
    Method
    Description
    String
    extractProjectName(String key)
    String
    extractResourceName(String key)
    void
    handleEvent(org.eclipse.swt.widgets.Event e)
    Handle events and enablements for widgets in this page

    Methods inherited from class com.pvx.ooadide.wizards.WizardPasswordPage

    createControl, dispose, finish, queryOverwrite, setPageComplete

    Methods inherited from class org.eclipse.jface.wizard.WizardPage

    canFlipToNextPage, getImage, getName, getNextPage, getPreviousPage, getShell, getWizard, isPageComplete, setDescription, setErrorMessage, setImageDescriptor, setMessage, setPageComplete, setPreviousPage, setTitle, setWizard, toString

    Methods inherited from class org.eclipse.jface.dialogs.DialogPage

    getControl, getDescription, getErrorMessage, getMessage, getMessageType, getTitle, performHelp, setMessage, setVisible

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

    Methods inherited from interface org.eclipse.jface.dialogs.IDialogPage

    getControl, getDescription, getErrorMessage, getMessage, getTitle, performHelp, setVisible

  • Constructor Details

    • WizardPasswordImportPage1

      public WizardPasswordImportPage1()
      Create an instance of this class

  • Method Details

    • extractProjectName

      public String extractProjectName(String key)

    • extractResourceName

      public String extractResourceName(String key)

    • handleEvent

      public void handleEvent(org.eclipse.swt.widgets.Event e)
      Handle events and enablements for widgets in this page
      Specified by:
      handleEvent in interface org.eclipse.swt.widgets.Listener
      Overrides:
      handleEvent in class WizardPasswordPage
      Parameters:
      e - Event


WizardPasswordPage

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.wizards

Class WizardPasswordPage

java.lang.Object
org.eclipse.jface.dialogs.DialogPage
org.eclipse.jface.wizard.WizardPage
com.pvx.ooadide.wizards.WizardPasswordPage
All Implemented Interfaces:
org.eclipse.jface.dialogs.IDialogPage, org.eclipse.jface.dialogs.IMessageProvider, org.eclipse.jface.wizard.IWizardPage, org.eclipse.swt.widgets.Listener, org.eclipse.ui.dialogs.IOverwriteQuery
Direct Known Subclasses:
ExportPasswordsPage, WizardPasswordImportPage1
public abstract class WizardPasswordPage extends org.eclipse.jface.wizard.WizardPage implements org.eclipse.swt.widgets.Listener, org.eclipse.ui.dialogs.IOverwriteQuery
Base class for preference export/import pages.
Since:
3.1

  • Field Summary

    Fields inherited from interface org.eclipse.jface.dialogs.IMessageProvider

    ERROR, INFORMATION, NONE, WARNING

    Fields inherited from interface org.eclipse.ui.dialogs.IOverwriteQuery

    ALL, CANCEL, NO, NO_ALL, YES

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    createControl(org.eclipse.swt.widgets.Composite parent)
    (non-Javadoc) Method declared on IDialogPage.
    void
    dispose()
    boolean
    finish(String eventName)
    The Finish button was pressed.
    void
    handleEvent(org.eclipse.swt.widgets.Event e)
    Handle all events and enablements for widgets in this page
    String
    queryOverwrite(String pathString)
    The WizardDataTransfer implementation of this IOverwriteQuery method asks the user whether the existing resource at the given path should be overwritten.
    void
    setPageComplete()
    Check whether the internal state of the page is complete and update the dialog

    Methods inherited from class org.eclipse.jface.wizard.WizardPage

    canFlipToNextPage, getImage, getName, getNextPage, getPreviousPage, getShell, getWizard, isPageComplete, setDescription, setErrorMessage, setImageDescriptor, setMessage, setPageComplete, setPreviousPage, setTitle, setWizard, toString

    Methods inherited from class org.eclipse.jface.dialogs.DialogPage

    getControl, getDescription, getErrorMessage, getMessage, getMessageType, getTitle, performHelp, setMessage, setVisible

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

    Methods inherited from interface org.eclipse.jface.dialogs.IDialogPage

    getControl, getDescription, getErrorMessage, getMessage, getTitle, performHelp, setVisible

  • Method Details

    • createControl

      public void createControl(org.eclipse.swt.widgets.Composite parent)
      (non-Javadoc) Method declared on IDialogPage.
      Specified by:
      createControl in interface org.eclipse.jface.dialogs.IDialogPage

    • finish

      public boolean finish(String eventName)
      The Finish button was pressed. Try to do the required work now and answer a boolean indicating success. If false is returned then the wizard will not close.
      Returns:
      boolean

    • setPageComplete

      public void setPageComplete()
      Check whether the internal state of the page is complete and update the dialog

    • handleEvent

      public void handleEvent(org.eclipse.swt.widgets.Event e)
      Handle all events and enablements for widgets in this page
      Specified by:
      handleEvent in interface org.eclipse.swt.widgets.Listener
      Parameters:
      e - Event

    • dispose

      public void dispose()
      Specified by:
      dispose in interface org.eclipse.jface.dialogs.IDialogPage
      Overrides:
      dispose in class org.eclipse.jface.dialogs.DialogPage

    • queryOverwrite

      public String queryOverwrite(String pathString)
      The WizardDataTransfer implementation of this IOverwriteQuery method asks the user whether the existing resource at the given path should be overwritten.
      Specified by:
      queryOverwrite in interface org.eclipse.ui.dialogs.IOverwriteQuery
      Parameters:
      pathString -
      Returns:
      the user's reply: one of "YES", "NO", "ALL", or "CANCEL"


Uses of Class com.pvx.ooadide.wizards.ExportPasswordsPage

Uses of Class
com.pvx.ooadide.wizards.ExportPasswordsPage

No usage of com.pvx.ooadide.wizards.ExportPasswordsPage


Uses of Class com.pvx.ooadide.wizards.ImportPasswordsWizard

Uses of Class
com.pvx.ooadide.wizards.ImportPasswordsWizard

No usage of com.pvx.ooadide.wizards.ImportPasswordsWizard


Uses of Class com.pvx.ooadide.wizards.NewFromExisting

Uses of Class
com.pvx.ooadide.wizards.NewFromExisting

No usage of com.pvx.ooadide.wizards.NewFromExisting


Uses of Class com.pvx.ooadide.wizards.NewNomadsLibraryWizard

Uses of Class
com.pvx.ooadide.wizards.NewNomadsLibraryWizard

No usage of com.pvx.ooadide.wizards.NewNomadsLibraryWizard


Uses of Class com.pvx.ooadide.wizards.NewNomadsNmdWizard

Uses of Class
com.pvx.ooadide.wizards.NewNomadsNmdWizard

No usage of com.pvx.ooadide.wizards.NewNomadsNmdWizard


Uses of Class com.pvx.ooadide.wizards.NewProjectFromExistingPage

Uses of Class
com.pvx.ooadide.wizards.NewProjectFromExistingPage

Packages that use NewProjectFromExistingPage
Package
Description
com.pvx.ooadide.wizards

  • Uses of NewProjectFromExistingPage in com.pvx.ooadide.wizards

    Methods in com.pvx.ooadide.wizards that return NewProjectFromExistingPage
    Modifier and Type
    Method
    Description
    NewProjectFromExistingPage
    NewFromExisting.getNewProjectPage()
    Methods in com.pvx.ooadide.wizards with parameters of type NewProjectFromExistingPage
    Modifier and Type
    Method
    Description
    void
    NewFromExisting.setNewProjectPage(NewProjectFromExistingPage page)


Uses of Class com.pvx.ooadide.wizards.PasswordExporterWizard

Uses of Class
com.pvx.ooadide.wizards.PasswordExporterWizard

No usage of com.pvx.ooadide.wizards.PasswordExporterWizard


Uses of Class com.pvx.ooadide.wizards.PasswordTransferElement

Uses of Class
com.pvx.ooadide.wizards.PasswordTransferElement

No usage of com.pvx.ooadide.wizards.PasswordTransferElement


Uses of Class com.pvx.ooadide.wizards.ProvideXNewWizard

Uses of Class
com.pvx.ooadide.wizards.ProvideXNewWizard

No usage of com.pvx.ooadide.wizards.ProvideXNewWizard


Uses of Class com.pvx.ooadide.wizards.ProvidexNewWizardPage

Uses of Class
com.pvx.ooadide.wizards.ProvidexNewWizardPage

Packages that use ProvidexNewWizardPage
Package
Description
com.pvx.ooadide.wizards

  • Uses of ProvidexNewWizardPage in com.pvx.ooadide.wizards

    Subclasses of ProvidexNewWizardPage in com.pvx.ooadide.wizards
    Modifier and Type
    Class
    Description
    class
    WizardNewProjectPasswordPage


Uses of Interface com.pvx.ooadide.wizards.ProvideXNewWizardPageI

Uses of Interface
com.pvx.ooadide.wizards.ProvideXNewWizardPageI

Packages that use ProvideXNewWizardPageI
Package
Description
com.pvx.ooadide.wizards

  • Uses of ProvideXNewWizardPageI in com.pvx.ooadide.wizards

    Classes in com.pvx.ooadide.wizards that implement ProvideXNewWizardPageI
    Modifier and Type
    Class
    Description
    class
    ProvidexNewWizardPage
    Standard main page for a wizard that is creates a project resource.
    class
    WizardNewProjectPasswordPage
    Methods in com.pvx.ooadide.wizards that return ProvideXNewWizardPageI
    Modifier and Type
    Method
    Description
    ProvideXNewWizardPageI
    ProvideXNewWizard.getPvxWizPage()
    Methods in com.pvx.ooadide.wizards with parameters of type ProvideXNewWizardPageI
    Modifier and Type
    Method
    Description
    void
    ProvideXNewWizard.addTestPage(ProvideXNewWizardPageI testpage)


Uses of Class com.pvx.ooadide.wizards.WizardNewProjectPasswordPage

Uses of Class
com.pvx.ooadide.wizards.WizardNewProjectPasswordPage

No usage of com.pvx.ooadide.wizards.WizardNewProjectPasswordPage


Uses of Class com.pvx.ooadide.wizards.WizardPasswordImportPage1

Uses of Class
com.pvx.ooadide.wizards.WizardPasswordImportPage1

No usage of com.pvx.ooadide.wizards.WizardPasswordImportPage1


Uses of Class com.pvx.ooadide.wizards.WizardPasswordPage

Uses of Class
com.pvx.ooadide.wizards.WizardPasswordPage

Packages that use WizardPasswordPage
Package
Description
com.pvx.ooadide.wizards

  • Uses of WizardPasswordPage in com.pvx.ooadide.wizards

    Subclasses of WizardPasswordPage in com.pvx.ooadide.wizards
    Modifier and Type
    Class
    Description
    class
    ExportPasswordsPage
    Page 1 of the base preference export Wizard
    class
    WizardPasswordImportPage1
    Page 1 of the base preference import Wizard


NewPvcCreationWizard

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.wizards.programs

Class NewPvcCreationWizard

java.lang.Object
org.eclipse.jface.wizard.Wizard
org.eclipse.ui.wizards.newresource.BasicNewResourceWizard
org.eclipse.ui.wizards.newresource.BasicNewFileResourceWizard
com.pvx.ooadide.wizards.programs.NewPvxProgramWizard
com.pvx.ooadide.wizards.programs.NewPvcCreationWizard
All Implemented Interfaces:
org.eclipse.jface.window.IShellProvider, org.eclipse.jface.wizard.IWizard, org.eclipse.ui.INewWizard, org.eclipse.ui.IWorkbenchWizard
public class NewPvcCreationWizard extends NewPvxProgramWizard

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static String
    ID

    Fields inherited from class org.eclipse.ui.wizards.newresource.BasicNewFileResourceWizard

    WIZARD_ID

    Fields inherited from class org.eclipse.jface.wizard.Wizard

    DEFAULT_IMAGE

  • Constructor Summary

    Constructors
    Constructor
    Description
    NewPvcCreationWizard()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    addPages()
    Adding the page to the wizard.

    Methods inherited from class com.pvx.ooadide.wizards.programs.NewPvxProgramWizard

    addTestPage, getPvxWizPage, init, performFinish, selectAndReveal

    Methods inherited from class org.eclipse.ui.wizards.newresource.BasicNewResourceWizard

    getSelection, getWorkbench

    Methods inherited from class org.eclipse.jface.wizard.Wizard

    addPage, canFinish, createPageControls, dispose, getContainer, getDefaultPageImage, getDialogSettings, getNextPage, getPage, getPageCount, getPages, getPreviousPage, getShell, getStartingPage, getTitleBarColor, getWindowTitle, isHelpAvailable, needsPreviousAndNextButtons, needsProgressMonitor, performCancel, setContainer, setDefaultPageImageDescriptor, setDialogSettings, setForcePreviousAndNextButtons, setHelpAvailable, setNeedsProgressMonitor, setTitleBarColor, setWindowTitle

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface org.eclipse.jface.wizard.IWizard

    canFinish, createPageControls, dispose, getContainer, getDefaultPageImage, getDialogSettings, getNextPage, getPage, getPageCount, getPages, getPreviousPage, getStartingPage, getTitleBarColor, getWindowTitle, isHelpAvailable, needsPreviousAndNextButtons, needsProgressMonitor, performCancel, setContainer

  • Field Details

    • ID

      public static String ID

  • Constructor Details

    • NewPvcCreationWizard

      public NewPvcCreationWizard()

  • Method Details

    • addPages

      public void addPages()
      Description copied from class: NewPvxProgramWizard
      Adding the page to the wizard.
      Specified by:
      addPages in interface org.eclipse.jface.wizard.IWizard
      Overrides:
      addPages in class NewPvxProgramWizard


NewPvxProgramWizard

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.wizards.programs

Class NewPvxProgramWizard

java.lang.Object
org.eclipse.jface.wizard.Wizard
org.eclipse.ui.wizards.newresource.BasicNewResourceWizard
org.eclipse.ui.wizards.newresource.BasicNewFileResourceWizard
com.pvx.ooadide.wizards.programs.NewPvxProgramWizard
All Implemented Interfaces:
org.eclipse.jface.window.IShellProvider, org.eclipse.jface.wizard.IWizard, org.eclipse.ui.INewWizard, org.eclipse.ui.IWorkbenchWizard
Direct Known Subclasses:
NewPvcCreationWizard
public class NewPvxProgramWizard extends org.eclipse.ui.wizards.newresource.BasicNewFileResourceWizard implements org.eclipse.ui.INewWizard

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static String
    ID

    Fields inherited from class org.eclipse.ui.wizards.newresource.BasicNewFileResourceWizard

    WIZARD_ID

    Fields inherited from class org.eclipse.jface.wizard.Wizard

    DEFAULT_IMAGE

  • Constructor Summary

    Constructors
    Constructor
    Description
    NewPvxProgramWizard()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    addPages()
    Adding the page to the wizard.
    void
    addTestPage(PvxNewProgramPropertiesWizardPage testpage)
    PvxNewProgramPropertiesWizardPage
    getPvxWizPage()
    void
    init(org.eclipse.ui.IWorkbench workbench, org.eclipse.jface.viewers.IStructuredSelection selection)
    We will accept the selection in the workbench to see if we can initialize from it.
    boolean
    performFinish()
    This method is called when 'Finish' button is pressed in the wizard.
    static void
    selectAndReveal(org.eclipse.core.resources.IResource resource, org.eclipse.ui.IWorkbenchWindow window)
    Attempts to select and reveal the specified resource in all parts within the supplied workbench window's active page.

    Methods inherited from class org.eclipse.ui.wizards.newresource.BasicNewResourceWizard

    getSelection, getWorkbench

    Methods inherited from class org.eclipse.jface.wizard.Wizard

    addPage, canFinish, createPageControls, dispose, getContainer, getDefaultPageImage, getDialogSettings, getNextPage, getPage, getPageCount, getPages, getPreviousPage, getShell, getStartingPage, getTitleBarColor, getWindowTitle, isHelpAvailable, needsPreviousAndNextButtons, needsProgressMonitor, performCancel, setContainer, setDefaultPageImageDescriptor, setDialogSettings, setForcePreviousAndNextButtons, setHelpAvailable, setNeedsProgressMonitor, setTitleBarColor, setWindowTitle

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface org.eclipse.jface.wizard.IWizard

    canFinish, createPageControls, dispose, getContainer, getDefaultPageImage, getDialogSettings, getNextPage, getPage, getPageCount, getPages, getPreviousPage, getStartingPage, getTitleBarColor, getWindowTitle, isHelpAvailable, needsPreviousAndNextButtons, needsProgressMonitor, performCancel, setContainer

  • Field Details

    • ID

      public static String ID

  • Constructor Details

    • NewPvxProgramWizard

      public NewPvxProgramWizard()

  • Method Details

    • getPvxWizPage

      public PvxNewProgramPropertiesWizardPage getPvxWizPage()

    • addPages

      public void addPages()
      Adding the page to the wizard.
      Specified by:
      addPages in interface org.eclipse.jface.wizard.IWizard
      Overrides:
      addPages in class org.eclipse.ui.wizards.newresource.BasicNewFileResourceWizard

    • addTestPage

      public void addTestPage(PvxNewProgramPropertiesWizardPage testpage)

    • performFinish

      public boolean performFinish()
      This method is called when 'Finish' button is pressed in the wizard. We will create an operation and run it using wizard as execution context.
      Specified by:
      performFinish in interface org.eclipse.jface.wizard.IWizard
      Overrides:
      performFinish in class org.eclipse.ui.wizards.newresource.BasicNewFileResourceWizard

    • init

      public void init(org.eclipse.ui.IWorkbench workbench, org.eclipse.jface.viewers.IStructuredSelection selection)
      We will accept the selection in the workbench to see if we can initialize from it.
      Specified by:
      init in interface org.eclipse.ui.IWorkbenchWizard
      Overrides:
      init in class org.eclipse.ui.wizards.newresource.BasicNewFileResourceWizard
      See Also:
      • IWorkbenchWizard.init(IWorkbench, IStructuredSelection)

    • selectAndReveal

      public static void selectAndReveal(org.eclipse.core.resources.IResource resource, org.eclipse.ui.IWorkbenchWindow window)
      Attempts to select and reveal the specified resource in all parts within the supplied workbench window's active page.

      Checks all parts in the active page to see if they implement ISetSelectionTarget, either directly or as an adapter. If so, tells the part to select and reveal the specified resource.

      Parameters:
      resource - the resource to be selected and revealed
      window - the workbench window to select and reveal the resource
      See Also:
      • ISetSelectionTarget


com.pvx.ooadide.wizards.programs

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.pvx.ooadide.wizards.programs

package com.pvx.ooadide.wizards.programs
  • Related Packages
    Package
    Description
    com.pvx.ooadide.wizards
  • Classes
    Class
    Description
    NewPvcCreationWizard
    NewPvxProgramWizard
    PvcPage
    PvxNewProgramPropertiesWizardPage
    PvxWizardNewFileCreatePage


com.pvx.ooadide.wizards.programs Class Hierarchy

Hierarchy For Package com.pvx.ooadide.wizards.programs

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.eclipse.jface.dialogs.DialogPage (implements org.eclipse.jface.dialogs.IDialogPage, org.eclipse.jface.dialogs.IMessageProvider)
      • org.eclipse.jface.wizard.WizardPage (implements org.eclipse.jface.wizard.IWizardPage)
        • com.pvx.ooadide.wizards.programs.PvxNewProgramPropertiesWizardPage
          • com.pvx.ooadide.wizards.programs.PvcPage
        • org.eclipse.ui.dialogs.WizardNewFileCreationPage (implements org.eclipse.swt.widgets.Listener)
          • com.pvx.ooadide.wizards.programs.PvxWizardNewFileCreatePage
    • org.eclipse.jface.wizard.Wizard (implements org.eclipse.jface.window.IShellProvider, org.eclipse.jface.wizard.IWizard)
      • org.eclipse.ui.wizards.newresource.BasicNewResourceWizard (implements org.eclipse.ui.INewWizard)
        • org.eclipse.ui.wizards.newresource.BasicNewFileResourceWizard
          • com.pvx.ooadide.wizards.programs.NewPvxProgramWizard (implements org.eclipse.ui.INewWizard)
            • com.pvx.ooadide.wizards.programs.NewPvcCreationWizard


Uses of Package com.pvx.ooadide.wizards.programs

Uses of Package
com.pvx.ooadide.wizards.programs

Packages that use com.pvx.ooadide.wizards.programs
Package
Description
com.pvx.ooadide.wizards
com.pvx.ooadide.wizards.programs
  • Classes in com.pvx.ooadide.wizards.programs used by com.pvx.ooadide.wizards
    Class
    Description
    PvxNewProgramPropertiesWizardPage
  • Classes in com.pvx.ooadide.wizards.programs used by com.pvx.ooadide.wizards.programs
    Class
    Description
    NewPvxProgramWizard
    PvxNewProgramPropertiesWizardPage
    PvxWizardNewFileCreatePage


PvcPage

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.wizards.programs

Class PvcPage

java.lang.Object
org.eclipse.jface.dialogs.DialogPage
org.eclipse.jface.wizard.WizardPage
com.pvx.ooadide.wizards.programs.PvxNewProgramPropertiesWizardPage
com.pvx.ooadide.wizards.programs.PvcPage
All Implemented Interfaces:
org.eclipse.jface.dialogs.IDialogPage, org.eclipse.jface.dialogs.IMessageProvider, org.eclipse.jface.wizard.IWizardPage
public class PvcPage extends PvxNewProgramPropertiesWizardPage

  • Field Summary

    Fields inherited from class com.pvx.ooadide.wizards.programs.PvxNewProgramPropertiesWizardPage

    PROJECT_DEF_PVX_EXE, PROJECT_OWNER, PROJECT_OWNER_FLAGS, PROJECT_PASSWORD

    Fields inherited from interface org.eclipse.jface.dialogs.IMessageProvider

    ERROR, INFORMATION, NONE, WARNING

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvcPage(org.eclipse.jface.viewers.ISelection selection)

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    createControl(org.eclipse.swt.widgets.Composite parent)
    (non-Javadoc) Method declared on IDialogPage.

    Methods inherited from class com.pvx.ooadide.wizards.programs.PvxNewProgramPropertiesWizardPage

    getFileCreatePage, getOutputFileName, getProjectBuilder, getProjectOwnerCode, getProjectOwnerFlags, getProjectPassword, getWizardPage, isLineNoReq, resolvePvxVariables, setFields, setFileCreatePage, setOutputFileName

    Methods inherited from class org.eclipse.jface.wizard.WizardPage

    canFlipToNextPage, getImage, getName, getNextPage, getPreviousPage, getShell, getWizard, isPageComplete, setDescription, setErrorMessage, setImageDescriptor, setMessage, setPageComplete, setPreviousPage, setTitle, setWizard, toString

    Methods inherited from class org.eclipse.jface.dialogs.DialogPage

    dispose, getControl, getDescription, getErrorMessage, getMessage, getMessageType, getTitle, performHelp, setMessage, setVisible

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

    Methods inherited from interface org.eclipse.jface.dialogs.IDialogPage

    dispose, getControl, getDescription, getErrorMessage, getMessage, getTitle, performHelp, setVisible

  • Constructor Details

    • PvcPage

      public PvcPage(org.eclipse.jface.viewers.ISelection selection)

  • Method Details

    • createControl

      public void createControl(org.eclipse.swt.widgets.Composite parent)
      Description copied from class: PvxNewProgramPropertiesWizardPage
      (non-Javadoc) Method declared on IDialogPage.
      Specified by:
      createControl in interface org.eclipse.jface.dialogs.IDialogPage
      Overrides:
      createControl in class PvxNewProgramPropertiesWizardPage


PvxNewProgramPropertiesWizardPage

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.wizards.programs

Class PvxNewProgramPropertiesWizardPage

java.lang.Object
org.eclipse.jface.dialogs.DialogPage
org.eclipse.jface.wizard.WizardPage
com.pvx.ooadide.wizards.programs.PvxNewProgramPropertiesWizardPage
All Implemented Interfaces:
org.eclipse.jface.dialogs.IDialogPage, org.eclipse.jface.dialogs.IMessageProvider, org.eclipse.jface.wizard.IWizardPage
Direct Known Subclasses:
PvcPage
public class PvxNewProgramPropertiesWizardPage extends org.eclipse.jface.wizard.WizardPage

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final String
    PROJECT_DEF_PVX_EXE
    static final String
    PROJECT_OWNER
    static final String
    PROJECT_OWNER_FLAGS
    static final String
    PROJECT_PASSWORD

    Fields inherited from interface org.eclipse.jface.dialogs.IMessageProvider

    ERROR, INFORMATION, NONE, WARNING

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxNewProgramPropertiesWizardPage(org.eclipse.jface.viewers.ISelection selection)
    Creates a new project creation wizard page.

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    createControl(org.eclipse.swt.widgets.Composite parent)
    (non-Javadoc) Method declared on IDialogPage.
    PvxWizardNewFileCreatePage
    getFileCreatePage()
    String
    getOutputFileName()
    String
    getProjectBuilder()
    String
    getProjectOwnerCode()
    String
    getProjectOwnerFlags()
    String
    getProjectPassword()
    org.eclipse.jface.wizard.IWizardPage
    getWizardPage()
    boolean
    isLineNoReq()
    String
    resolvePvxVariables(String pattern)
    void
    setFields(org.eclipse.core.runtime.IPath containerPath, String fleName)
    void
    setFileCreatePage(PvxWizardNewFileCreatePage fileCreatePage)
    void
    setOutputFileName(String fleName)

    Methods inherited from class org.eclipse.jface.wizard.WizardPage

    canFlipToNextPage, getImage, getName, getNextPage, getPreviousPage, getShell, getWizard, isPageComplete, setDescription, setErrorMessage, setImageDescriptor, setMessage, setPageComplete, setPreviousPage, setTitle, setWizard, toString

    Methods inherited from class org.eclipse.jface.dialogs.DialogPage

    dispose, getControl, getDescription, getErrorMessage, getMessage, getMessageType, getTitle, performHelp, setMessage, setVisible

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

    Methods inherited from interface org.eclipse.jface.dialogs.IDialogPage

    dispose, getControl, getDescription, getErrorMessage, getMessage, getTitle, performHelp, setVisible

  • Field Details

    • PROJECT_DEF_PVX_EXE

      public static final String PROJECT_DEF_PVX_EXE
      See Also:
      • Constant Field Values

    • PROJECT_PASSWORD

      public static final String PROJECT_PASSWORD
      See Also:
      • Constant Field Values

    • PROJECT_OWNER

      public static final String PROJECT_OWNER
      See Also:
      • Constant Field Values

    • PROJECT_OWNER_FLAGS

      public static final String PROJECT_OWNER_FLAGS
      See Also:
      • Constant Field Values

  • Constructor Details

    • PvxNewProgramPropertiesWizardPage

      public PvxNewProgramPropertiesWizardPage(org.eclipse.jface.viewers.ISelection selection)
      Creates a new project creation wizard page.
      Parameters:
      newFilePage -
      pageName - the name of this page

  • Method Details

    • createControl

      public void createControl(org.eclipse.swt.widgets.Composite parent)
      (non-Javadoc) Method declared on IDialogPage.

    • isLineNoReq

      public boolean isLineNoReq()

    • getProjectBuilder

      public String getProjectBuilder()

    • getProjectPassword

      public String getProjectPassword()

    • getProjectOwnerFlags

      public String getProjectOwnerFlags()

    • getProjectOwnerCode

      public String getProjectOwnerCode()

    • getWizardPage

      public org.eclipse.jface.wizard.IWizardPage getWizardPage()

    • setOutputFileName

      public void setOutputFileName(String fleName)

    • getOutputFileName

      public String getOutputFileName()

    • setFileCreatePage

      public void setFileCreatePage(PvxWizardNewFileCreatePage fileCreatePage)

    • getFileCreatePage

      public PvxWizardNewFileCreatePage getFileCreatePage()

    • setFields

      public void setFields(org.eclipse.core.runtime.IPath containerPath, String fleName)

    • resolvePvxVariables

      public String resolvePvxVariables(String pattern)


PvxWizardNewFileCreatePage

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.pvx.ooadide.wizards.programs

Class PvxWizardNewFileCreatePage

java.lang.Object
org.eclipse.jface.dialogs.DialogPage
org.eclipse.jface.wizard.WizardPage
org.eclipse.ui.dialogs.WizardNewFileCreationPage
com.pvx.ooadide.wizards.programs.PvxWizardNewFileCreatePage
All Implemented Interfaces:
org.eclipse.jface.dialogs.IDialogPage, org.eclipse.jface.dialogs.IMessageProvider, org.eclipse.jface.wizard.IWizardPage, org.eclipse.swt.widgets.Listener
public class PvxWizardNewFileCreatePage extends org.eclipse.ui.dialogs.WizardNewFileCreationPage

  • Field Summary

    Fields inherited from interface org.eclipse.jface.dialogs.IMessageProvider

    ERROR, INFORMATION, NONE, WARNING

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxWizardNewFileCreatePage(String pageName, String desc, org.eclipse.jface.viewers.IStructuredSelection selection)

  • Method Summary

    Modifier and Type
    Method
    Description
    PvxNewProgramPropertiesWizardPage
    getPropertiesPage()
    void
    setPropertiesPage(PvxNewProgramPropertiesWizardPage newPropertiesPage)

    Methods inherited from class org.eclipse.ui.dialogs.WizardNewFileCreationPage

    createControl, createNewFile, getContainerFullPath, getFileExtension, getFileName, handleEvent, setAllowExistingResources, setContainerFullPath, setFileExtension, setFileName, setVisible

    Methods inherited from class org.eclipse.jface.wizard.WizardPage

    canFlipToNextPage, getImage, getName, getNextPage, getPreviousPage, getShell, getWizard, isPageComplete, setDescription, setErrorMessage, setImageDescriptor, setMessage, setPageComplete, setPreviousPage, setTitle, setWizard, toString

    Methods inherited from class org.eclipse.jface.dialogs.DialogPage

    dispose, getControl, getDescription, getErrorMessage, getMessage, getMessageType, getTitle, performHelp, setMessage

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

    Methods inherited from interface org.eclipse.jface.dialogs.IDialogPage

    dispose, getControl, getDescription, getErrorMessage, getMessage, getTitle, performHelp

  • Constructor Details

    • PvxWizardNewFileCreatePage

      public PvxWizardNewFileCreatePage(String pageName, String desc, org.eclipse.jface.viewers.IStructuredSelection selection)

  • Method Details

    • setPropertiesPage

      public void setPropertiesPage(PvxNewProgramPropertiesWizardPage newPropertiesPage)

    • getPropertiesPage

      public PvxNewProgramPropertiesWizardPage getPropertiesPage()


Uses of Class com.pvx.ooadide.wizards.programs.NewPvcCreationWizard

Uses of Class
com.pvx.ooadide.wizards.programs.NewPvcCreationWizard

No usage of com.pvx.ooadide.wizards.programs.NewPvcCreationWizard


Uses of Class com.pvx.ooadide.wizards.programs.NewPvxProgramWizard

Uses of Class
com.pvx.ooadide.wizards.programs.NewPvxProgramWizard

Packages that use NewPvxProgramWizard
Package
Description
com.pvx.ooadide.wizards.programs

  • Uses of NewPvxProgramWizard in com.pvx.ooadide.wizards.programs

    Subclasses of NewPvxProgramWizard in com.pvx.ooadide.wizards.programs
    Modifier and Type
    Class
    Description
    class
    NewPvcCreationWizard


Uses of Class com.pvx.ooadide.wizards.programs.PvcPage

Uses of Class
com.pvx.ooadide.wizards.programs.PvcPage

No usage of com.pvx.ooadide.wizards.programs.PvcPage


Uses of Class com.pvx.ooadide.wizards.programs.PvxNewProgramPropertiesWizardPage

Uses of Class
com.pvx.ooadide.wizards.programs.PvxNewProgramPropertiesWizardPage

Packages that use PvxNewProgramPropertiesWizardPage
Package
Description
com.pvx.ooadide.wizards
com.pvx.ooadide.wizards.programs

  • Uses of PvxNewProgramPropertiesWizardPage in com.pvx.ooadide.wizards

    Methods in com.pvx.ooadide.wizards that return PvxNewProgramPropertiesWizardPage
    Modifier and Type
    Method
    Description
    PvxNewProgramPropertiesWizardPage
    NewNomadsLibraryWizard.getPvxWizPage()
    PvxNewProgramPropertiesWizardPage
    NewNomadsNmdWizard.getPvxWizPage()
    Methods in com.pvx.ooadide.wizards with parameters of type PvxNewProgramPropertiesWizardPage
    Modifier and Type
    Method
    Description
    void
    NewNomadsLibraryWizard.addTestPage(PvxNewProgramPropertiesWizardPage testpage)
    void
    NewNomadsNmdWizard.addTestPage(PvxNewProgramPropertiesWizardPage testpage)

  • Uses of PvxNewProgramPropertiesWizardPage in com.pvx.ooadide.wizards.programs

    Subclasses of PvxNewProgramPropertiesWizardPage in com.pvx.ooadide.wizards.programs
    Modifier and Type
    Class
    Description
    class
    PvcPage
    Methods in com.pvx.ooadide.wizards.programs that return PvxNewProgramPropertiesWizardPage
    Modifier and Type
    Method
    Description
    PvxNewProgramPropertiesWizardPage
    PvxWizardNewFileCreatePage.getPropertiesPage()
    PvxNewProgramPropertiesWizardPage
    NewPvxProgramWizard.getPvxWizPage()
    Methods in com.pvx.ooadide.wizards.programs with parameters of type PvxNewProgramPropertiesWizardPage
    Modifier and Type
    Method
    Description
    void
    NewPvxProgramWizard.addTestPage(PvxNewProgramPropertiesWizardPage testpage)
    void
    PvxWizardNewFileCreatePage.setPropertiesPage(PvxNewProgramPropertiesWizardPage newPropertiesPage)


Uses of Class com.pvx.ooadide.wizards.programs.PvxWizardNewFileCreatePage

Uses of Class
com.pvx.ooadide.wizards.programs.PvxWizardNewFileCreatePage

Packages that use PvxWizardNewFileCreatePage
Package
Description
com.pvx.ooadide.wizards.programs

  • Uses of PvxWizardNewFileCreatePage in com.pvx.ooadide.wizards.programs

    Methods in com.pvx.ooadide.wizards.programs that return PvxWizardNewFileCreatePage
    Modifier and Type
    Method
    Description
    PvxWizardNewFileCreatePage
    PvxNewProgramPropertiesWizardPage.getFileCreatePage()
    Methods in com.pvx.ooadide.wizards.programs with parameters of type PvxWizardNewFileCreatePage
    Modifier and Type
    Method
    Description
    void
    PvxNewProgramPropertiesWizardPage.setFileCreatePage(PvxWizardNewFileCreatePage fileCreatePage)


ConsoleDisplayManager

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.sage.rcp

Class ConsoleDisplayManager

java.lang.Object
com.sage.rcp.ConsoleDisplayManager
public class ConsoleDisplayManager extends Object
Create an instance of this class in any of your plugin classes. Use it as follows ... ConsoleDisplayMgr.getDefault().println("Some error msg", ConsoleDisplayMgr.MSG_ERROR); ... ... ConsoleDisplayMgr.getDefault().clear(); ...

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final String
    ID
    static final int
    MSG_ERROR
    static final int
    MSG_ERROR_DESC
    static final int
    MSG_INFORMATION
    static final int
    MSG_WARNING

  • Constructor Summary

    Constructors
    Constructor
    Description
    ConsoleDisplayManager(String messageTitle)

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    clear()
    static ConsoleDisplayManager
    getDefault()
    void
    println(String msg, int msgKind)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Field Details

    • ID

      public static final String ID
      See Also:
      • Constant Field Values

    • MSG_INFORMATION

      public static final int MSG_INFORMATION
      See Also:
      • Constant Field Values

    • MSG_ERROR

      public static final int MSG_ERROR
      See Also:
      • Constant Field Values

    • MSG_WARNING

      public static final int MSG_WARNING
      See Also:
      • Constant Field Values

    • MSG_ERROR_DESC

      public static final int MSG_ERROR_DESC
      See Also:
      • Constant Field Values

  • Constructor Details

    • ConsoleDisplayManager

      public ConsoleDisplayManager(String messageTitle)

  • Method Details

    • getDefault

      public static ConsoleDisplayManager getDefault()

    • println

      public void println(String msg, int msgKind)

    • clear

      public void clear()


IEventManager

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.sage.rcp

Interface IEventManager

All Known Implementing Classes:
EventManager, EventManager
public interface IEventManager

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    clearAllBlocks()
    void
    dropInstance(RcpPluginConnectionControl rcpPluginConnectionControl)
    Component
    getClientGUIComponent()
    RcpPluginConnectionControl
    getConCon()
    boolean
    runNtHost(String[] pvxHostArgs)
    void
    setConCon(RcpPluginConnectionControl connectionControl)

  • Method Details

    • getConCon

      RcpPluginConnectionControl getConCon()

    • setConCon

      void setConCon(RcpPluginConnectionControl connectionControl)

    • dropInstance

      void dropInstance(RcpPluginConnectionControl rcpPluginConnectionControl)

    • clearAllBlocks

      void clearAllBlocks()

    • getClientGUIComponent

      Component getClientGUIComponent()

    • runNtHost

      boolean runNtHost(String[] pvxHostArgs)


IPvxPlugin

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.sage.rcp

Interface IPvxPlugin

All Known Subinterfaces:
IPvxIdePlugin
All Known Implementing Classes:
ProvideXOOADPlugin
public interface IPvxPlugin

  • Method Summary

    Modifier and Type
    Method
    Description
    String
    getApplicationArguments()
    IEventManager
    getEventManager()
    org.eclipse.core.runtime.ILog
    getLog()
    String
    getPluginId()
    org.eclipse.jface.preference.IPreferenceStore
    getPreferenceStore()
    String
    getPvxHelperPath()
    org.eclipse.ui.IWorkbenchPage
    internalGetActivePage()
    boolean
    isDebugWindowRequired()
    Class
    loadClassForName(String className)

  • Method Details

    • isDebugWindowRequired

      boolean isDebugWindowRequired()

    • getPluginId

      String getPluginId()

    • getPreferenceStore

      org.eclipse.jface.preference.IPreferenceStore getPreferenceStore()

    • getPvxHelperPath

      String getPvxHelperPath()

    • internalGetActivePage

      org.eclipse.ui.IWorkbenchPage internalGetActivePage()

    • getLog

      org.eclipse.core.runtime.ILog getLog()

    • getEventManager

      IEventManager getEventManager()

    • loadClassForName

      Class loadClassForName(String className)

    • getApplicationArguments

      String getApplicationArguments()


com.sage.rcp

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.sage.rcp

package com.sage.rcp
  • Related Packages
    Package
    Description
    com.sage.rcp.eventmanager
    com.sage.rcp.javx
    com.sage.rcp.preferences
    com.sage.rcp.resizeanimation
    com.sage.rcp.util
    com.sage.rcp.views
  • Class
    Description
    ConsoleDisplayManager
    Create an instance of this class in any of your plugin classes.
    IEventManager
    IPvxPlugin
    PvxRcpActivator
    The activator class controls the plug-in life cycle


com.sage.rcp Class Hierarchy

Hierarchy For Package com.sage.rcp

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • com.sage.rcp.ConsoleDisplayManager
    • org.eclipse.core.runtime.Plugin (implements org.osgi.framework.BundleActivator)
      • org.eclipse.ui.plugin.AbstractUIPlugin
        • com.sage.rcp.PvxRcpActivator

Interface Hierarchy

  • com.sage.rcp.IEventManager
  • com.sage.rcp.IPvxPlugin


Uses of Package com.sage.rcp

Uses of Package
com.sage.rcp

Packages that use com.sage.rcp
Package
Description
com.pvx.ooadide
com.pvx.ooadide.eventmanager
com.sage.rcp
com.sage.rcp.eventmanager
  • Classes in com.sage.rcp used by com.pvx.ooadide
    Class
    Description
    IEventManager
    IPvxPlugin
  • Classes in com.sage.rcp used by com.pvx.ooadide.eventmanager
    Class
    Description
    IEventManager
  • Classes in com.sage.rcp used by com.sage.rcp
    Class
    Description
    ConsoleDisplayManager
    Create an instance of this class in any of your plugin classes.
    IEventManager
    IPvxPlugin
    PvxRcpActivator
    The activator class controls the plug-in life cycle
  • Classes in com.sage.rcp used by com.sage.rcp.eventmanager
    Class
    Description
    IEventManager


PvxRcpActivator

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.sage.rcp

Class PvxRcpActivator

java.lang.Object
org.eclipse.core.runtime.Plugin
org.eclipse.ui.plugin.AbstractUIPlugin
com.sage.rcp.PvxRcpActivator
All Implemented Interfaces:
org.osgi.framework.BundleActivator
public class PvxRcpActivator extends org.eclipse.ui.plugin.AbstractUIPlugin
The activator class controls the plug-in life cycle

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static boolean
    doLogging
    static final String
    ID

    Fields inherited from class org.eclipse.core.runtime.Plugin

    PLUGIN_PREFERENCE_SCOPE, PREFERENCES_DEFAULT_OVERRIDE_BASE_NAME, PREFERENCES_DEFAULT_OVERRIDE_FILE_NAME

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxRcpActivator()
    The constructor

  • Method Summary

    Modifier and Type
    Method
    Description
    IPvxPlugin
    getControlPlugin()
    static PvxRcpActivator
    getDefault()
    Returns the shared instance
    static org.eclipse.jface.resource.ImageDescriptor
    getImageDescriptor(String path)
    Returns an image descriptor for the image file at the given plug-in relative path
    static IPvxPlugin
    getPvxPluginInstance()
    org.eclipse.ui.IWorkbenchPage
    internalGetActivePage()
    void
    setControlPlugin(IPvxPlugin controlPlugin)
    void
    start(org.osgi.framework.BundleContext context)
    void
    stop(org.osgi.framework.BundleContext context)

    Methods inherited from class org.eclipse.ui.plugin.AbstractUIPlugin

    getDialogSettings, getImageRegistry, getPreferenceStore, getWorkbench, imageDescriptorFromPlugin

    Methods inherited from class org.eclipse.core.runtime.Plugin

    getBundle, getLog, getStateLocation, isDebugging, setDebugging, toString

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

  • Field Details

    • ID

      public static final String ID
      See Also:
      • Constant Field Values

    • doLogging

      public static boolean doLogging

  • Constructor Details

    • PvxRcpActivator

      public PvxRcpActivator()
      The constructor

  • Method Details

    • start

      public void start(org.osgi.framework.BundleContext context) throws Exception
      Specified by:
      start in interface org.osgi.framework.BundleActivator
      Overrides:
      start in class org.eclipse.ui.plugin.AbstractUIPlugin
      Throws:
      Exception

    • stop

      public void stop(org.osgi.framework.BundleContext context) throws Exception
      Specified by:
      stop in interface org.osgi.framework.BundleActivator
      Overrides:
      stop in class org.eclipse.ui.plugin.AbstractUIPlugin
      Throws:
      Exception

    • getDefault

      public static PvxRcpActivator getDefault()
      Returns the shared instance
      Returns:
      the shared instance

    • getImageDescriptor

      public static org.eclipse.jface.resource.ImageDescriptor getImageDescriptor(String path)
      Returns an image descriptor for the image file at the given plug-in relative path
      Parameters:
      path - the path
      Returns:
      the image descriptor

    • getPvxPluginInstance

      public static IPvxPlugin getPvxPluginInstance()

    • internalGetActivePage

      public org.eclipse.ui.IWorkbenchPage internalGetActivePage()

    • setControlPlugin

      public void setControlPlugin(IPvxPlugin controlPlugin)

    • getControlPlugin

      public IPvxPlugin getControlPlugin()


Uses of Class com.sage.rcp.ConsoleDisplayManager

Uses of Class
com.sage.rcp.ConsoleDisplayManager

Packages that use ConsoleDisplayManager
Package
Description
com.sage.rcp

  • Uses of ConsoleDisplayManager in com.sage.rcp

    Methods in com.sage.rcp that return ConsoleDisplayManager
    Modifier and Type
    Method
    Description
    static ConsoleDisplayManager
    ConsoleDisplayManager.getDefault()


Uses of Interface com.sage.rcp.IEventManager

Uses of Interface
com.sage.rcp.IEventManager

Packages that use IEventManager
Package
Description
com.pvx.ooadide
com.pvx.ooadide.eventmanager
com.sage.rcp
com.sage.rcp.eventmanager

  • Uses of IEventManager in com.pvx.ooadide

    Methods in com.pvx.ooadide that return IEventManager
    Modifier and Type
    Method
    Description
    IEventManager
    ProvideXOOADPlugin.getEventManager()

  • Uses of IEventManager in com.pvx.ooadide.eventmanager

    Classes in com.pvx.ooadide.eventmanager that implement IEventManager
    Modifier and Type
    Class
    Description
    class
    EventManager
    Controls communication between Eclipse and ProvideX.

  • Uses of IEventManager in com.sage.rcp

    Methods in com.sage.rcp that return IEventManager
    Modifier and Type
    Method
    Description
    IEventManager
    IPvxPlugin.getEventManager()

  • Uses of IEventManager in com.sage.rcp.eventmanager

    Classes in com.sage.rcp.eventmanager that implement IEventManager
    Modifier and Type
    Class
    Description
    class
    EventManager
    Controls communication between Eclipse and ProvideX.
    Methods in com.sage.rcp.eventmanager that return IEventManager
    Modifier and Type
    Method
    Description
    static IEventManager
    EventManager.getInstance()


Uses of Interface com.sage.rcp.IPvxPlugin

Uses of Interface
com.sage.rcp.IPvxPlugin

Packages that use IPvxPlugin
Package
Description
com.pvx.ooadide
com.sage.rcp

  • Uses of IPvxPlugin in com.pvx.ooadide

    Subinterfaces of IPvxPlugin in com.pvx.ooadide
    Modifier and Type
    Interface
    Description
    interface
    IPvxIdePlugin
    Classes in com.pvx.ooadide that implement IPvxPlugin
    Modifier and Type
    Class
    Description
    class
    ProvideXOOADPlugin

  • Uses of IPvxPlugin in com.sage.rcp

    Methods in com.sage.rcp that return IPvxPlugin
    Modifier and Type
    Method
    Description
    IPvxPlugin
    PvxRcpActivator.getControlPlugin()
    static IPvxPlugin
    PvxRcpActivator.getPvxPluginInstance()
    Methods in com.sage.rcp with parameters of type IPvxPlugin
    Modifier and Type
    Method
    Description
    void
    PvxRcpActivator.setControlPlugin(IPvxPlugin controlPlugin)


Uses of Class com.sage.rcp.PvxRcpActivator

Uses of Class
com.sage.rcp.PvxRcpActivator

Packages that use PvxRcpActivator
Package
Description
com.sage.rcp

  • Uses of PvxRcpActivator in com.sage.rcp

    Methods in com.sage.rcp that return PvxRcpActivator
    Modifier and Type
    Method
    Description
    static PvxRcpActivator
    PvxRcpActivator.getDefault()
    Returns the shared instance


AbstractProgressController

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.sage.rcp.eventmanager

Class AbstractProgressController

java.lang.Object
com.sage.rcp.eventmanager.AbstractProgressController
Direct Known Subclasses:
PvxRunnableWithProgress
public abstract class AbstractProgressController extends Object

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final int
    P_ALL
    static final int
    P_SUB_TASKNAME
    static final int
    P_TASKNAME
    static final int
    P_VISIBLE
    static final int
    P_WORKED

  • Constructor Summary

    Constructors
    Constructor
    Description
    AbstractProgressController()

  • Method Summary

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Field Details

    • P_ALL

      public static final int P_ALL
      See Also:
      • Constant Field Values

    • P_TASKNAME

      public static final int P_TASKNAME
      See Also:
      • Constant Field Values

    • P_SUB_TASKNAME

      public static final int P_SUB_TASKNAME
      See Also:
      • Constant Field Values

    • P_VISIBLE

      public static final int P_VISIBLE
      See Also:
      • Constant Field Values

    • P_WORKED

      public static final int P_WORKED
      See Also:
      • Constant Field Values

  • Constructor Details

    • AbstractProgressController

      public AbstractProgressController()


ConsoleDisplayManager

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.sage.rcp.eventmanager

Class ConsoleDisplayManager

java.lang.Object
com.sage.rcp.eventmanager.ConsoleDisplayManager
public class ConsoleDisplayManager extends Object
Create an instance of this class in any of your plugin classes. Use it as follows ... ConsoleDisplayMgr.getDefault().println("Some error msg", ConsoleDisplayMgr.MSG_ERROR); ... ... ConsoleDisplayMgr.getDefault().clear(); ...

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final String
    ID
    static final int
    MSG_ERROR
    static final int
    MSG_ERROR_DESC
    static final int
    MSG_INFORMATION
    static final int
    MSG_WARNING

  • Constructor Summary

    Constructors
    Constructor
    Description
    ConsoleDisplayManager(String messageTitle)

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    clear()
    static ConsoleDisplayManager
    getDefault()
    void
    println(String msg, int msgKind)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Field Details

    • ID

      public static final String ID
      See Also:
      • Constant Field Values

    • MSG_INFORMATION

      public static final int MSG_INFORMATION
      See Also:
      • Constant Field Values

    • MSG_ERROR

      public static final int MSG_ERROR
      See Also:
      • Constant Field Values

    • MSG_WARNING

      public static final int MSG_WARNING
      See Also:
      • Constant Field Values

    • MSG_ERROR_DESC

      public static final int MSG_ERROR_DESC
      See Also:
      • Constant Field Values

  • Constructor Details

    • ConsoleDisplayManager

      public ConsoleDisplayManager(String messageTitle)

  • Method Details

    • getDefault

      public static ConsoleDisplayManager getDefault()

    • println

      public void println(String msg, int msgKind)

    • clear

      public void clear()


DelayedMethodCall

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.sage.rcp.eventmanager

Class DelayedMethodCall

java.lang.Object
com.sage.rcp.eventmanager.DelayedMethodCall
public class DelayedMethodCall extends Object

  • Constructor Summary

    Constructors
    Constructor
    Description
    DelayedMethodCall(Object[] init_params, Method init_method, Object init_subjectObj, boolean inEvntQue)

  • Method Summary

    Modifier and Type
    Method
    Description
    Object
    getSubjectObj()
    boolean
    isExecuteInEvntQue()
    void
    setSubjectObj(Object subjectObj)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • DelayedMethodCall

      public DelayedMethodCall(Object[] init_params, Method init_method, Object init_subjectObj, boolean inEvntQue)

  • Method Details

    • setSubjectObj

      public void setSubjectObj(Object subjectObj)

    • getSubjectObj

      public Object getSubjectObj()

    • isExecuteInEvntQue

      public boolean isExecuteInEvntQue()


DelayedMethodHandler

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.sage.rcp.eventmanager

Class DelayedMethodHandler

java.lang.Object
com.sage.rcp.eventmanager.DelayedMethodHandler
public class DelayedMethodHandler extends Object

  • Constructor Summary

    Constructors
    Constructor
    Description
    DelayedMethodHandler()

  • Method Summary

    Modifier and Type
    Method
    Description
    static void
    addMethod(DelayedMethodCall methodToCall)
    static void
    addMethodToInvokeLaterList(Object subject, Class[] paramsClass, Object[] params, String methodName)
    static Object
    callMethod(Method method, Object[] arguments, Object subject)
    static void
    callMethods()
    static void
    removeAll()

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • DelayedMethodHandler

      public DelayedMethodHandler()

  • Method Details

    • callMethod

      public static Object callMethod(Method method, Object[] arguments, Object subject)

    • addMethod

      public static void addMethod(DelayedMethodCall methodToCall)

    • removeAll

      public static void removeAll()

    • callMethods

      public static void callMethods()

    • addMethodToInvokeLaterList

      public static void addMethodToInvokeLaterList(Object subject, Class[] paramsClass, Object[] params, String methodName)


EventManager

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.sage.rcp.eventmanager

Class EventManager

java.lang.Object
com.sage.rcp.eventmanager.EventManager
All Implemented Interfaces:
IEventManager
public class EventManager extends Object implements IEventManager
Controls communication between Eclipse and ProvideX. The EventManager is notified every time an event occurs within the Eclipse Workbench window. E.G: When a menubar item or toolbar item is clicked) the EventManger is notified.

The EventManager class maintains a list of ProvideX processes interested in these events and forwards event messages to the ProvideX process. A ProvideX process adds itself to this list by creating an instance of the EventManager class and calling the EventManager's addListener( SomeEvent$ ) method. E.G The following ProvideX code creates an instance of the EventManager class and informs the EventManager class that the ProvideX program wants to be notified when menubar items are clicked and when the Workbench Windows close window button is clicked:

DEF OBJECT EventManager, "[wdx]*com.sage.ultrafx.eventmanager" EventManager'addListener( EventManager'MENUBAR_ACTION$ ) EventManager'addListener( EventManager'ULTRAFX_WINDOW_CLOSE$ )

The following events can be observed by ProvideX programs via the EventManager:

PVX_PROCESS_EVENT ECLIPSE_SHUTDOWN ULTRAFX_WINDOW_CLOSE COOLBAR_ACTION MENUBAR_ACTION BROWSER_EVENT

When an event occurs the EventManager will send a PvxEvent object to the program. The PvxEvent class's getEventName() method will return one of the eventNames specified above.

Since:
1.0

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final String
    BROWSER_EVENT
    static final String
    CALL_BACK_MJR
    static final String
    COOLBAR_ACTION
    static final String
    ECLIPSE_SHUTDOWN
    These are the event messages that can be observed.
    static final String
    HOST_IS_READY
    static final String
    MENUBAR_ACTION
    static Vector<Integer>
    pervasiveHandles
    static final String
    PVX_PROCESS_EVENT
    static final String
    ULTRAFX_WINDOW_CLOSE

  • Constructor Summary

    Constructors
    Constructor
    Description
    EventManager(RcpPluginConnectionControl conObserver)
    EventManager(RcpPluginConnectionControl conObserver, boolean initIde)

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    addListener(String eventName)
    Adds a listener to the EventManager.
    void
    addListener(String eventName, int ctlValue)
    Adds a listener to the EventManager.
    static void
    addPervasiveObject(int ocxId)
    Most Java objects instantiated by ProvideX are dropped after every event.
    static boolean
    asyncEvent(String eventName, String detail)
    Sends a Message to the ProvideX EventManager and immediately returns.
    static final void
    bye()
    void
    clearAllBlocks()
    Frees all blocking PvxEvents
    static void
    clearFxGlobals()
    This method clears (removes from memory) all UltraFX String and numeric global variables
    void
    clientReady()
    Informs the EventManger that the ProvideX process is ready to receive events:
    void
    collectGarbage()
    Cleans up all objects that are not persistent
    boolean
    connectionWasDropped()
    True if the connection with ProvideX has been dropped
    void
    dropInstance(RcpPluginConnectionControl rcpPluginConnectionControl)
    void
    freeEvent(PvxEvent event)
    Notify Eclipse that ProvideX has finish processing the event and the EventManager can free/delete/dropped the event object
    String
    getAllocatedObjectList()
    Component
    getClientGUIComponent()
    RcpPluginConnectionControl
    getConCon()
    static String
    getFxGlobalNumericVariables()
    This method returns a comma delimited list of all UltraFX String global variables
    static String
    getFxGlobalStringVariables()
    This method returns a comma delimited list of all UltraFX String global variables
    static double
    getFxNumbericGlobal(String variable)
    This method returns the value of the specified numeric global variable
    static String
    getFxStringGlobal(String variable)
    This method returns the value of the specified string global variable
    static IEventManager
    getInstance()
    static boolean
    handleEvent(boolean block, String eventName, String detail, Properties buildProps)
    Sends a PvxEvent to the ProvideX EventManager.
    static boolean
    isBlocking()
    True if Eclipse is waiting for ProvideX to complete processing and event
    static boolean
    isEclipseShutingDown()
    static boolean
    isEventManagerWaiting()
    static boolean
    isPvxReady()
    boolean
    notifyAllEventManagers(boolean block, String eventName, String detail, Properties buildProps)
    void
    notifyEclipse(String eventName, String status, String responseArguments)
    Sends a message to Eclipse EventManger.
    void
    removeListener(String eventName)
    Removes a listener from the EventManager.
    static void
    removePervasiveObject(int ocxId)
    Most Java objects instantiated by ProvideX will be dropped after every event.
    boolean
    runNtHost(String[] pvxHostArgs)
    void
    setConCon(RcpPluginConnectionControl conCon)
    static void
    setContinueWaiting(boolean sw)
    static void
    setEclipseBye(boolean eclipseBye)
    static void
    setFxGlobal(String variable, double value)
    This method sets the value of the specified global variable
    static void
    setFxGlobal(String variable, String value)
    This method sets the value of the specified global variable
    static void
    setPvxReady(boolean isPvxReady)
    Notify Eclipse that ProvideX is ready to receive events

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Field Details

    • CALL_BACK_MJR

      public static final String CALL_BACK_MJR
      See Also:
      • Constant Field Values

    • BROWSER_EVENT

      public static final String BROWSER_EVENT
      See Also:
      • Constant Field Values

    • pervasiveHandles

      public static Vector<Integer> pervasiveHandles

    • ECLIPSE_SHUTDOWN

      public static final String ECLIPSE_SHUTDOWN
      These are the event messages that can be observed. E.G: ProvideX programs can listen for these events. When they occur the EventManager will send a PvxEvent object to the program. The PvxEvent class's getEventName() method will return one of the following eventNames
      See Also:
      • Constant Field Values

    • ULTRAFX_WINDOW_CLOSE

      public static final String ULTRAFX_WINDOW_CLOSE
      See Also:
      • Constant Field Values

    • COOLBAR_ACTION

      public static final String COOLBAR_ACTION
      See Also:
      • Constant Field Values

    • MENUBAR_ACTION

      public static final String MENUBAR_ACTION
      See Also:
      • Constant Field Values

    • PVX_PROCESS_EVENT

      public static final String PVX_PROCESS_EVENT
      See Also:
      • Constant Field Values

    • HOST_IS_READY

      public static final String HOST_IS_READY
      See Also:
      • Constant Field Values

  • Constructor Details

    • EventManager

      public EventManager(RcpPluginConnectionControl conObserver, boolean initIde)

    • EventManager

      public EventManager(RcpPluginConnectionControl conObserver)

  • Method Details

    • addListener

      public void addListener(String eventName)
      Adds a listener to the EventManager. The EventManager will send a PvxEvent to the host every time the specified event occurs
      Parameters:
      eventName - 1. The eventName to be added

    • addListener

      public void addListener(String eventName, int ctlValue)
      Adds a listener to the EventManager. The EventManager This method will cause ctlvalues to be sent to the host every time the specified event occurs. The addListener(String eventName) is the preferred mehtod to register a listener because listeners registering via this method cannot block or pass values then when the specified event occurs
      Parameters:
      eventName - String the EventName to be added
      ctlValue - int ctlValue to send when the specified event occurs

    • removeListener

      public void removeListener(String eventName)
      Removes a listener from the EventManager. The EventManager will stop sending a PvxEvent to the host every time the specified event occurs

    • asyncEvent

      public static boolean asyncEvent(String eventName, String detail)
      Sends a Message to the ProvideX EventManager and immediately returns. This method calls handleEvent with default values for block and properties; i.e. this method is same as calling handleEvent(false, "some event", "some event detail", null)
      Parameters:
      eventName - 2 String. The name of the event that has occurred. there are no listeners registered for this event this method simply returns
      detail - 3 String. The minor code for this event

    • handleEvent

      public static boolean handleEvent(boolean block, String eventName, String detail, Properties buildProps)
      Sends a PvxEvent to the ProvideX EventManager. This method creates, blocks Threads as required and notifies ProvideX an Event has occurred
      Parameters:
      block - 1 boolean. Indicates Eclipse must wait for a response from ProvideX prior to continuing
      eventName - 2 String. The name of the event that has occurred. there are no listeners registered for this event this method simply returns
      detail - 3 String. The minor code for this event
      buildProps - 4 Properties . The minor code for this event

    • notifyAllEventManagers

      public boolean notifyAllEventManagers(boolean block, String eventName, String detail, Properties buildProps)

    • connectionWasDropped

      public boolean connectionWasDropped()
      True if the connection with ProvideX has been dropped
      Returns:
      true if the connection with ProvideX has been dropped

    • freeEvent

      public void freeEvent(PvxEvent event)
      Notify Eclipse that ProvideX has finish processing the event and the EventManager can free/delete/dropped the event object
      Parameters:
      event - -The event to be dropped

    • addPervasiveObject

      public static void addPervasiveObject(int ocxId)
      Most Java objects instantiated by ProvideX are dropped after every event. Pervasive (persistent) objects should persist and will only be dropped via the ProvideX DROP OBJECT directive
      Parameters:
      ocxId - int. The object handle to make persistent
      See Also:
      • removePervasiveObject(int)

    • removePervasiveObject

      public static void removePervasiveObject(int ocxId)
      Most Java objects instantiated by ProvideX will be dropped after every event. Pervasive (persistent) objects should persist and will only be dropped via the ProvideX DROP OBJECT directive
      Parameters:
      ocxId - int. The object handle to remove from the list of persistent objects
      See Also:
      • addPervasiveObject(int)

    • collectGarbage

      public void collectGarbage()
      Cleans up all objects that are not persistent
      See Also:
      • addPervasiveObject(int)
      • removePervasiveObject(int)

    • isBlocking

      public static boolean isBlocking()
      True if Eclipse is waiting for ProvideX to complete processing and event
      Returns:
      true if Eclipse is waiting for ProvideX to complete processing and event

    • clearAllBlocks

      public void clearAllBlocks()
      Frees all blocking PvxEvents
      Specified by:
      clearAllBlocks in interface IEventManager

    • getClientGUIComponent

      public Component getClientGUIComponent()
      Specified by:
      getClientGUIComponent in interface IEventManager

    • setConCon

      public void setConCon(RcpPluginConnectionControl conCon)
      Specified by:
      setConCon in interface IEventManager

    • getConCon

      public RcpPluginConnectionControl getConCon()
      Specified by:
      getConCon in interface IEventManager

    • bye

      public static final void bye()

    • notifyEclipse

      public void notifyEclipse(String eventName, String status, String responseArguments)
      Sends a message to Eclipse EventManger. E.G: to notify the EventManager that the ProvideX process is ready to receive events:

      EventManager'notifyEclipse( Eventmanager'Host_Is_Ready$, "true", *-1 )

      Parameters:
      eventName - 1. The eventName
      status - -The value
      responseArguments - *-1 for null

    • clientReady

      public void clientReady()
      Informs the EventManger that the ProvideX process is ready to receive events:

      EventManager'clientReady()

      After this method call the client ProvideX Process will recieve workbench events. Client ProvideX processes must also register to receive specific events via the addListener method

      See Also:
      • addListener(String eventName)

    • setEclipseBye

      public static void setEclipseBye(boolean eclipseBye)

    • isEclipseShutingDown

      public static boolean isEclipseShutingDown()

    • setPvxReady

      public static void setPvxReady(boolean isPvxReady)
      Notify Eclipse that ProvideX is ready to receive events
      Parameters:
      isPvxReady - true if ProvideX is ready

    • isPvxReady

      public static boolean isPvxReady()

    • setContinueWaiting

      public static void setContinueWaiting(boolean sw)

    • isEventManagerWaiting

      public static boolean isEventManagerWaiting()

    • getAllocatedObjectList

      public String getAllocatedObjectList()

    • runNtHost

      public boolean runNtHost(String[] pvxHostArgs)
      Specified by:
      runNtHost in interface IEventManager

    • getInstance

      public static IEventManager getInstance()

    • dropInstance

      public void dropInstance(RcpPluginConnectionControl rcpPluginConnectionControl)
      Specified by:
      dropInstance in interface IEventManager

    • clearFxGlobals

      public static void clearFxGlobals()
      This method clears (removes from memory) all UltraFX String and numeric global variables

      See Also:
      • setFxGlobal(String variable, String value)
      • getFxStringGlobal(String variable)

    • setFxGlobal

      public static void setFxGlobal(String variable, String value)
      This method sets the value of the specified global variable

      The Event Manager can maintain a list of Global variables that are available to every ProvideX process that's running within UltraFX.

      This allow for multiple ProvideX Process is to access/share data

      Care should be taken when using UltraFX Global variables because each ProvideX Process is running with a separate thread in UltraFX and race conditions can cause unexpected results. For example if multiple ProvideX processes change and retrieve the same variable at the same time.

      Parameters:
      variable - String. The name of the variable to set
      value - String. The numeric value to set the variable
      See Also:
      • getFxStringGlobal(String variable)

    • setFxGlobal

      public static void setFxGlobal(String variable, double value)
      This method sets the value of the specified global variable

      The Event Manager can maintain a list of Global variables that are available to every ProvideX process that's running within UltraFX.

      This allow for multiple ProvideX Process is to access/share data

      Care should be taken when using UltraFX Global variables because each ProvideX Process is running with a separate thread in UltraFX and race conditions can cause unexpected results. For example if multiple ProvideX processes change and retrieve the same variable at the same time.

      Parameters:
      variable - String. The name of the variable to set
      value - Numeric. The numeric value to set the variable
      See Also:
      • setFxGlobal(String variable, String value)
      • getFxStringGlobal(String variable)

    • getFxStringGlobal

      public static String getFxStringGlobal(String variable)
      This method returns the value of the specified string global variable

      The Event Manager can maintain a list of Global variables that are available to every ProvideX process that's running within UltraFX.

      Parameters:
      variable - String. The name of the variable to get the value
      See Also:
      • setFxGlobal(String variable, double value)

    • getFxNumbericGlobal

      public static double getFxNumbericGlobal(String variable)
      This method returns the value of the specified numeric global variable

      The Event Manager can maintain a list of Global variables that are available to every ProvideX process that's running within UltraFX.

      Parameters:
      variable - String. The name of the variable to get the value
      See Also:
      • setFxGlobal(String variable, numeric value)

    • getFxGlobalStringVariables

      public static String getFxGlobalStringVariables()
      This method returns a comma delimited list of all UltraFX String global variables

      See Also:
      • setFxGlobal(String variable, String value)
      • getFxStringGlobal(String variable)

    • getFxGlobalNumericVariables

      public static String getFxGlobalNumericVariables()
      This method returns a comma delimited list of all UltraFX String global variables

      See Also:
      • setFxGlobal(String variable, String value)
      • getFxStringGlobal(String variable)


IPvxEventCallBack

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.sage.rcp.eventmanager

Interface IPvxEventCallBack

public interface IPvxEventCallBack

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    handleEventCallBack(String major, String minor)

  • Method Details

    • handleEventCallBack

      void handleEventCallBack(String major, String minor)


MonitorState

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.sage.rcp.eventmanager

Class MonitorState

java.lang.Object
com.sage.rcp.eventmanager.MonitorState
public class MonitorState extends Object
Since:
1.0

  • Constructor Summary

    Constructors
    Constructor
    Description
    MonitorState()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    cancel()
    void
    done()
    String
    getTaskDetail()
    String
    getTaskName()
    int
    getWorked()
    boolean
    isCancelled()
    boolean
    isDialogueVisible()
    boolean
    isDone()
    void
    setDialogueVisible(boolean vis)
    void
    setRunnable(PvxRunnableWithProgress initRunner)
    void
    setTaskDetail(String taskDetail)
    void
    setTaskName(String taskName)
    void
    setWorked(int initworked)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • MonitorState

      public MonitorState()

  • Method Details

    • setRunnable

      public void setRunnable(PvxRunnableWithProgress initRunner)

    • done

      public void done()

    • isDone

      public boolean isDone()

    • isCancelled

      public boolean isCancelled()

    • cancel

      public void cancel()

    • setWorked

      public void setWorked(int initworked)

    • getWorked

      public int getWorked()

    • setDialogueVisible

      public void setDialogueVisible(boolean vis)

    • isDialogueVisible

      public boolean isDialogueVisible()

    • setTaskName

      public void setTaskName(String taskName)

    • getTaskName

      public String getTaskName()

    • setTaskDetail

      public void setTaskDetail(String taskDetail)

    • getTaskDetail

      public String getTaskDetail()


com.sage.rcp.eventmanager

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.sage.rcp.eventmanager

package com.sage.rcp.eventmanager
  • Related Packages
    Package
    Description
    com.sage.rcp
    com.sage.rcp.javx
    com.sage.rcp.preferences
    com.sage.rcp.resizeanimation
    com.sage.rcp.util
    com.sage.rcp.views
  • Class
    Description
    AbstractProgressController
    ConsoleDisplayManager
    Create an instance of this class in any of your plugin classes.
    DelayedMethodCall
    DelayedMethodHandler
    EventManager
    Controls communication between Eclipse and ProvideX.
    IPvxEventCallBack
    MonitorState
    PvxEvent
    An event that indicates an action has occurred in Eclipse
    PvxProgressMonitorDialog
    PvxRunnableWithProgress
    UIManager
    Provides an Interface to the Eclipse GUI for ProvideX programs


com.sage.rcp.eventmanager Class Hierarchy

Hierarchy For Package com.sage.rcp.eventmanager

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • com.sage.rcp.eventmanager.AbstractProgressController
      • com.sage.rcp.eventmanager.PvxRunnableWithProgress (implements org.eclipse.jface.operation.IRunnableWithProgress)
    • com.sage.rcp.eventmanager.ConsoleDisplayManager
    • com.sage.rcp.eventmanager.DelayedMethodCall
    • com.sage.rcp.eventmanager.DelayedMethodHandler
    • com.sage.rcp.eventmanager.EventManager (implements com.sage.rcp.IEventManager)
    • com.sage.rcp.eventmanager.MonitorState
    • com.sage.rcp.eventmanager.PvxEvent
    • com.sage.rcp.eventmanager.UIManager
    • org.eclipse.jface.window.Window (implements org.eclipse.jface.window.IShellProvider)
      • org.eclipse.jface.dialogs.Dialog
        • org.eclipse.jface.dialogs.IconAndMessageDialog
          • org.eclipse.jface.dialogs.ProgressMonitorDialog (implements org.eclipse.jface.operation.IRunnableContext)
            • com.sage.rcp.eventmanager.PvxProgressMonitorDialog

Interface Hierarchy

  • com.sage.rcp.eventmanager.IPvxEventCallBack


Uses of Package com.sage.rcp.eventmanager

Uses of Package
com.sage.rcp.eventmanager

Packages that use com.sage.rcp.eventmanager
Package
Description
com.sage.rcp.eventmanager
  • Classes in com.sage.rcp.eventmanager used by com.sage.rcp.eventmanager
    Class
    Description
    AbstractProgressController
    ConsoleDisplayManager
    Create an instance of this class in any of your plugin classes.
    DelayedMethodCall
    MonitorState
    PvxEvent
    An event that indicates an action has occurred in Eclipse
    PvxProgressMonitorDialog
    PvxRunnableWithProgress


PvxEvent

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.sage.rcp.eventmanager

Class PvxEvent

java.lang.Object
com.sage.rcp.eventmanager.PvxEvent
public class PvxEvent extends Object
An event that indicates an action has occurred in Eclipse
Since:
1.0

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxEvent(String init_eventName, String detail, Properties init_buildProps)
    Creates an event that indicates an action has occurred in Eclipse

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    addResponse(String init_eventName, String init_detail)
    ProvideX responds to Eclipse events via this method
    void
    addResponse(String init_eventName, String init_detail, Properties init_buildProps)
    ProvideX responds to Eclipse events via this method
    boolean
    containsArgument(String key)
    Wraps the Properties iterator that contains the arguments of associated with this event
    String
    getArgument(String key)
    Wraps the Properties iterator that contains the arguments of associated with this event
    Properties
    getBuildProps()
    String
    getEventCommand()
    Accessor that returns the minor code of an event
    String
    getEventName()
    Accessor that returns the major code of an event; the name of the event that occured within the Eclipse Workbench.
    Object
    getObjectArgument(String key)
    Wraps the Properties iterator that contains the arguments of associated with this event
    ArrayList<PvxEvent>
    getResponses()
    boolean
    hasMoreArguments()
    Wraps the Properties iterator that contains the arguments of associated with this event
    String
    nextArgument()
    Wraps the Properties iterator that contains the arguments of associated with this event
    void
    resetIterator()
    Wraps the Properties iterator that contains the arguments of associated with this event
    String
    toString()

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

  • Constructor Details

    • PvxEvent

      public PvxEvent(String init_eventName, String detail, Properties init_buildProps)
      Creates an event that indicates an action has occurred in Eclipse
      Parameters:
      init_eventName - The major code of the event
      detail - The minor code of the event
      init_buildProps - The optional arguments

  • Method Details

    • getEventName

      public String getEventName()
      Accessor that returns the major code of an event; the name of the event that occured within the Eclipse Workbench.
      Returns:
      String defined as a constant in EventManager

    • getEventCommand

      public String getEventCommand()
      Accessor that returns the minor code of an event
      Returns:
      String defined as a constant in EventManager

    • resetIterator

      public void resetIterator()
      Wraps the Properties iterator that contains the arguments of associated with this event

    • hasMoreArguments

      public boolean hasMoreArguments()
      Wraps the Properties iterator that contains the arguments of associated with this event

    • nextArgument

      public String nextArgument()
      Wraps the Properties iterator that contains the arguments of associated with this event

    • containsArgument

      public boolean containsArgument(String key)
      Wraps the Properties iterator that contains the arguments of associated with this event

    • getArgument

      public String getArgument(String key)
      Wraps the Properties iterator that contains the arguments of associated with this event

    • getObjectArgument

      public Object getObjectArgument(String key)
      Wraps the Properties iterator that contains the arguments of associated with this event

    • addResponse

      public void addResponse(String init_eventName, String init_detail)
      ProvideX responds to Eclipse events via this method
      Parameters:
      init_eventName - The major code of the response
      init_detail - The minor code of the response

    • addResponse

      public void addResponse(String init_eventName, String init_detail, Properties init_buildProps)
      ProvideX responds to Eclipse events via this method
      Parameters:
      init_eventName - The major code of the response
      init_detail - The minor code of the response
      init_buildProps - The Properties object that contains the arguments for this response

    • getResponses

      public ArrayList<PvxEvent> getResponses()

    • toString

      public String toString()
      Overrides:
      toString in class Object

    • getBuildProps

      public Properties getBuildProps()


PvxProgressMonitorDialog

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.sage.rcp.eventmanager

Class PvxProgressMonitorDialog

java.lang.Object
org.eclipse.jface.window.Window
org.eclipse.jface.dialogs.Dialog
org.eclipse.jface.dialogs.IconAndMessageDialog
org.eclipse.jface.dialogs.ProgressMonitorDialog
com.sage.rcp.eventmanager.PvxProgressMonitorDialog
All Implemented Interfaces:
org.eclipse.jface.operation.IRunnableContext, org.eclipse.jface.window.IShellProvider
public class PvxProgressMonitorDialog extends org.eclipse.jface.dialogs.ProgressMonitorDialog

  • Nested Class Summary

    Nested classes/interfaces inherited from class org.eclipse.jface.window.Window

    org.eclipse.jface.window.Window.IExceptionHandler

  • Field Summary

    Fields inherited from class org.eclipse.jface.dialogs.Dialog

    blockedHandler, buttonBar, DIALOG_DEFAULT_BOUNDS, DIALOG_PERSISTLOCATION, DIALOG_PERSISTSIZE, DLG_IMG_HELP, DLG_IMG_MESSAGE_ERROR, DLG_IMG_MESSAGE_INFO, DLG_IMG_MESSAGE_WARNING, ELLIPSIS

    Fields inherited from class org.eclipse.jface.window.Window

    CANCEL, OK

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxProgressMonitorDialog(org.eclipse.swt.widgets.Shell shel)

  • Method Summary

    Modifier and Type
    Method
    Description
    int
    open(int toComplete, MonitorState mState, String taskName)

    Methods inherited from class org.eclipse.jface.dialogs.ProgressMonitorDialog

    close, getOpenOnRun, getProgressMonitor, open, run, setCancelable, setOpenOnRun

    Methods inherited from class org.eclipse.jface.dialogs.IconAndMessageDialog

    getErrorImage, getInfoImage, getQuestionImage, getWarningImage

    Methods inherited from class org.eclipse.jface.dialogs.Dialog

    applyDialogFont, convertHeightInCharsToPixels, convertHorizontalDLUsToPixels, convertVerticalDLUsToPixels, convertWidthInCharsToPixels, create, getBlockedHandler, getImage, setBlockedHandler, shortenText

    Methods inherited from class org.eclipse.jface.window.Window

    getDefaultImage, getDefaultImages, getDefaultOrientation, getReturnCode, getShell, getWindowManager, setBlockOnOpen, setDefaultImage, setDefaultImages, setDefaultModalParent, setDefaultOrientation, setExceptionHandler, setWindowManager

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • PvxProgressMonitorDialog

      public PvxProgressMonitorDialog(org.eclipse.swt.widgets.Shell shel)

  • Method Details

    • open

      public int open(int toComplete, MonitorState mState, String taskName)


PvxRunnableWithProgress

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.sage.rcp.eventmanager

Class PvxRunnableWithProgress

java.lang.Object
com.sage.rcp.eventmanager.AbstractProgressController
com.sage.rcp.eventmanager.PvxRunnableWithProgress
All Implemented Interfaces:
org.eclipse.jface.operation.IRunnableWithProgress
public class PvxRunnableWithProgress extends AbstractProgressController implements org.eclipse.jface.operation.IRunnableWithProgress

  • Field Summary

    Fields inherited from class com.sage.rcp.eventmanager.AbstractProgressController

    P_ALL, P_SUB_TASKNAME, P_TASKNAME, P_VISIBLE, P_WORKED

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxRunnableWithProgress(PvxProgressMonitorDialog dialog, MonitorState init_State, String taskName, int toComplete)

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    cancel()
    void
    do_setVisible()
    void
    run(org.eclipse.core.runtime.IProgressMonitor monitor)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • PvxRunnableWithProgress

      public PvxRunnableWithProgress(PvxProgressMonitorDialog dialog, MonitorState init_State, String taskName, int toComplete)

  • Method Details

    • run

      public void run(org.eclipse.core.runtime.IProgressMonitor monitor) throws InvocationTargetException, InterruptedException
      Specified by:
      run in interface org.eclipse.jface.operation.IRunnableWithProgress
      Throws:
      InvocationTargetException
      InterruptedException

    • cancel

      public void cancel()

    • do_setVisible

      public void do_setVisible()


UIManager

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.sage.rcp.eventmanager

Class UIManager

java.lang.Object
com.sage.rcp.eventmanager.UIManager
public class UIManager extends Object
Provides an Interface to the Eclipse GUI for ProvideX programs
Since:
1.0

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static String
    CONSOLE_VIEW_ID

  • Constructor Summary

    Constructors
    Constructor
    Description
    UIManager()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    addRowToView(String id, String text)
    void
    clearView(String id)
    void
    closeAllEditors(boolean save)
    Closes all open editors
    static void
    createDialProgressMonitor(String taskName, int toComplete, MonitorState mState)
    This method should not be called directly by ProvideX programs.
    int
    getNumberOfColumns(String id)
    int
    getNumberOfRows(String id)
    static MonitorState
    getProgressMonitor(String taskName, int toComplete)
    Creates a progress monitor dialog.
    String
    getRegisteredEditors(String fileName)
    Get a list of all of the editors associated with the specified file
    String
    getRegisteredViews()
    Return a list of views defined in the Eclipse registry.
    static void
    hideView(String id)
    Hides the view identified
    static boolean
    isPvxProgressMonitorDialogVisible()
    static boolean
    isViewVisible(String id)
    Returns whether the specified Eclipse part is visible.
    void
    printLnToConsole(String text)
    Prints a line of text to the Console view
    static void
    setPvxProgressMonitorDialogVisible(boolean vis)
    static void
    showView(String id)
    Shows the view identified by the given view id in this Eclipse page and gives it focus.

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Field Details

    • CONSOLE_VIEW_ID

      public static String CONSOLE_VIEW_ID

  • Constructor Details

    • UIManager

      public UIManager()

  • Method Details

    • closeAllEditors

      public void closeAllEditors(boolean save)
      Closes all open editors
      Parameters:
      save - If true save dirty files prior to closes

    • printLnToConsole

      public void printLnToConsole(String text)
      Prints a line of text to the Console view
      Parameters:
      text - String to print

    • getRegisteredEditors

      public String getRegisteredEditors(String fileName)
      Get a list of all of the editors associated with the specified file
      Parameters:
      fileName - The file to
      Returns:
      an 0x8a (ProvideX sep) delimited list of all of the editors associated with the specified file

    • getRegisteredViews

      public String getRegisteredViews()
      Return a list of views defined in the Eclipse registry.
      Returns:
      the views or ""

    • clearView

      public void clearView(String id)

    • isViewVisible

      public static boolean isViewVisible(String id)
      Returns whether the specified Eclipse part is visible.
      Parameters:
      id - The id of the Eclipse part
      Returns:
      boolean true if part is visible

    • showView

      public static void showView(String id)
      Shows the view identified by the given view id in this Eclipse page and gives it focus. If there is a view identified by the given view id is already open in this page, it is given focus.
      Parameters:
      id - The id of the view to show

    • addRowToView

      public void addRowToView(String id, String text)

    • getNumberOfRows

      public int getNumberOfRows(String id)

    • getNumberOfColumns

      public int getNumberOfColumns(String id)

    • hideView

      public static void hideView(String id)
      Hides the view identified
      Parameters:
      id - The id of the view to hide

    • getProgressMonitor

      public static MonitorState getProgressMonitor(String taskName, int toComplete)
      Creates a progress monitor dialog. Retrieves an active progress monitor.
      Parameters:
      taskName -
      toComplete -
      Returns:
      MonitorState object to interface with the dialog

    • createDialProgressMonitor

      public static void createDialProgressMonitor(String taskName, int toComplete, MonitorState mState)
      This method should not be called directly by ProvideX programs. Use the getProgressMonitor instead
      Parameters:
      taskName - The title for the dialog
      toComplete - The amount of work to be done
      mState - The Monitor state object
      See Also:
      • getProgressMonitor(String, int)

    • isPvxProgressMonitorDialogVisible

      public static boolean isPvxProgressMonitorDialogVisible()

    • setPvxProgressMonitorDialogVisible

      public static void setPvxProgressMonitorDialogVisible(boolean vis)


Uses of Class com.sage.rcp.eventmanager.AbstractProgressController

Uses of Class
com.sage.rcp.eventmanager.AbstractProgressController

Packages that use AbstractProgressController
Package
Description
com.sage.rcp.eventmanager

  • Uses of AbstractProgressController in com.sage.rcp.eventmanager

    Subclasses of AbstractProgressController in com.sage.rcp.eventmanager
    Modifier and Type
    Class
    Description
    class
    PvxRunnableWithProgress


Uses of Class com.sage.rcp.eventmanager.ConsoleDisplayManager

Uses of Class
com.sage.rcp.eventmanager.ConsoleDisplayManager

Packages that use ConsoleDisplayManager
Package
Description
com.sage.rcp.eventmanager

  • Uses of ConsoleDisplayManager in com.sage.rcp.eventmanager

    Methods in com.sage.rcp.eventmanager that return ConsoleDisplayManager
    Modifier and Type
    Method
    Description
    static ConsoleDisplayManager
    ConsoleDisplayManager.getDefault()


Uses of Class com.sage.rcp.eventmanager.DelayedMethodCall

Uses of Class
com.sage.rcp.eventmanager.DelayedMethodCall

Packages that use DelayedMethodCall
Package
Description
com.sage.rcp.eventmanager

  • Uses of DelayedMethodCall in com.sage.rcp.eventmanager

    Methods in com.sage.rcp.eventmanager with parameters of type DelayedMethodCall
    Modifier and Type
    Method
    Description
    static void
    DelayedMethodHandler.addMethod(DelayedMethodCall methodToCall)


Uses of Class com.sage.rcp.eventmanager.DelayedMethodHandler

Uses of Class
com.sage.rcp.eventmanager.DelayedMethodHandler

No usage of com.sage.rcp.eventmanager.DelayedMethodHandler


Uses of Class com.sage.rcp.eventmanager.EventManager

Uses of Class
com.sage.rcp.eventmanager.EventManager

No usage of com.sage.rcp.eventmanager.EventManager


Uses of Interface com.sage.rcp.eventmanager.IPvxEventCallBack

Uses of Interface
com.sage.rcp.eventmanager.IPvxEventCallBack

No usage of com.sage.rcp.eventmanager.IPvxEventCallBack


Uses of Class com.sage.rcp.eventmanager.MonitorState

Uses of Class
com.sage.rcp.eventmanager.MonitorState

Packages that use MonitorState
Package
Description
com.sage.rcp.eventmanager

  • Uses of MonitorState in com.sage.rcp.eventmanager

    Methods in com.sage.rcp.eventmanager that return MonitorState
    Modifier and Type
    Method
    Description
    static MonitorState
    UIManager.getProgressMonitor(String taskName, int toComplete)
    Creates a progress monitor dialog.
    Methods in com.sage.rcp.eventmanager with parameters of type MonitorState
    Modifier and Type
    Method
    Description
    static void
    UIManager.createDialProgressMonitor(String taskName, int toComplete, MonitorState mState)
    This method should not be called directly by ProvideX programs.
    int
    PvxProgressMonitorDialog.open(int toComplete, MonitorState mState, String taskName)
    Constructors in com.sage.rcp.eventmanager with parameters of type MonitorState
    Modifier
    Constructor
    Description

    PvxRunnableWithProgress(PvxProgressMonitorDialog dialog, MonitorState init_State, String taskName, int toComplete)


Uses of Class com.sage.rcp.eventmanager.PvxEvent

Uses of Class
com.sage.rcp.eventmanager.PvxEvent

Packages that use PvxEvent
Package
Description
com.sage.rcp.eventmanager

  • Uses of PvxEvent in com.sage.rcp.eventmanager

    Methods in com.sage.rcp.eventmanager that return types with arguments of type PvxEvent
    Modifier and Type
    Method
    Description
    ArrayList<PvxEvent>
    PvxEvent.getResponses()
    Methods in com.sage.rcp.eventmanager with parameters of type PvxEvent
    Modifier and Type
    Method
    Description
    void
    EventManager.freeEvent(PvxEvent event)
    Notify Eclipse that ProvideX has finish processing the event and the EventManager can free/delete/dropped the event object


Uses of Class com.sage.rcp.eventmanager.PvxProgressMonitorDialog

Uses of Class
com.sage.rcp.eventmanager.PvxProgressMonitorDialog

Packages that use PvxProgressMonitorDialog
Package
Description
com.sage.rcp.eventmanager

  • Uses of PvxProgressMonitorDialog in com.sage.rcp.eventmanager

    Constructors in com.sage.rcp.eventmanager with parameters of type PvxProgressMonitorDialog
    Modifier
    Constructor
    Description

    PvxRunnableWithProgress(PvxProgressMonitorDialog dialog, MonitorState init_State, String taskName, int toComplete)


Uses of Class com.sage.rcp.eventmanager.PvxRunnableWithProgress

Uses of Class
com.sage.rcp.eventmanager.PvxRunnableWithProgress

Packages that use PvxRunnableWithProgress
Package
Description
com.sage.rcp.eventmanager

  • Uses of PvxRunnableWithProgress in com.sage.rcp.eventmanager

    Methods in com.sage.rcp.eventmanager with parameters of type PvxRunnableWithProgress
    Modifier and Type
    Method
    Description
    void
    MonitorState.setRunnable(PvxRunnableWithProgress initRunner)


Uses of Class com.sage.rcp.eventmanager.UIManager

Uses of Class
com.sage.rcp.eventmanager.UIManager

No usage of com.sage.rcp.eventmanager.UIManager


FxPagePartListener

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.sage.rcp.javx

Class FxPagePartListener

java.lang.Object
com.sage.rcp.javx.FxPagePartListener
All Implemented Interfaces:
org.eclipse.ui.IPartListener2
public final class FxPagePartListener extends Object implements org.eclipse.ui.IPartListener2

  • Constructor Summary

    Constructors
    Constructor
    Description
    FxPagePartListener()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    partActivated(org.eclipse.ui.IWorkbenchPartReference partRef)
    void
    partBroughtToTop(org.eclipse.ui.IWorkbenchPartReference partRef)
    void
    partClosed(org.eclipse.ui.IWorkbenchPartReference partRef)
    void
    partDeactivated(org.eclipse.ui.IWorkbenchPartReference partRef)
    void
    partHidden(org.eclipse.ui.IWorkbenchPartReference partRef)
    void
    partInputChanged(org.eclipse.ui.IWorkbenchPartReference partRef)
    void
    partOpened(org.eclipse.ui.IWorkbenchPartReference partRef)
    void
    partVisible(org.eclipse.ui.IWorkbenchPartReference partRef)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • FxPagePartListener

      public FxPagePartListener()

  • Method Details

    • partActivated

      public void partActivated(org.eclipse.ui.IWorkbenchPartReference partRef)
      Specified by:
      partActivated in interface org.eclipse.ui.IPartListener2
      Parameters:
      rcpPluginSwingGUIManager -

    • partBroughtToTop

      public void partBroughtToTop(org.eclipse.ui.IWorkbenchPartReference partRef)
      Specified by:
      partBroughtToTop in interface org.eclipse.ui.IPartListener2

    • partClosed

      public void partClosed(org.eclipse.ui.IWorkbenchPartReference partRef)
      Specified by:
      partClosed in interface org.eclipse.ui.IPartListener2

    • partDeactivated

      public void partDeactivated(org.eclipse.ui.IWorkbenchPartReference partRef)
      Specified by:
      partDeactivated in interface org.eclipse.ui.IPartListener2

    • partHidden

      public void partHidden(org.eclipse.ui.IWorkbenchPartReference partRef)
      Specified by:
      partHidden in interface org.eclipse.ui.IPartListener2

    • partInputChanged

      public void partInputChanged(org.eclipse.ui.IWorkbenchPartReference partRef)
      Specified by:
      partInputChanged in interface org.eclipse.ui.IPartListener2

    • partOpened

      public void partOpened(org.eclipse.ui.IWorkbenchPartReference partRef)
      Specified by:
      partOpened in interface org.eclipse.ui.IPartListener2

    • partVisible

      public void partVisible(org.eclipse.ui.IWorkbenchPartReference partRef)
      Specified by:
      partVisible in interface org.eclipse.ui.IPartListener2


IEmbeddedJavXView

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.sage.rcp.javx

Interface IEmbeddedJavXView

All Known Implementing Classes:
HostActionsView, RcpEmbedJavXView, RcpMasProgramView, RcpProgramView, RcpSpawnedMasProgramView, WinDefine
public interface IEmbeddedJavXView

  • Method Summary

    Modifier and Type
    Method
    Description
    org.eclipse.ui.IActionBars
    getActionBars()
    String
    getArgsStr()
    org.eclipse.swt.graphics.Color
    getCompositeColor()
    org.eclipse.ui.IViewSite
    getIViewSite()
    void
    setActionBars(org.eclipse.ui.IActionBars bars)
    void
    setViewSite(org.eclipse.ui.IViewSite site)

  • Method Details

    • getArgsStr

      String getArgsStr()

    • getActionBars

      org.eclipse.ui.IActionBars getActionBars()

    • setActionBars

      void setActionBars(org.eclipse.ui.IActionBars bars)

    • getIViewSite

      org.eclipse.ui.IViewSite getIViewSite()

    • setViewSite

      void setViewSite(org.eclipse.ui.IViewSite site)

    • getCompositeColor

      org.eclipse.swt.graphics.Color getCompositeColor()


com.sage.rcp.javx

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.sage.rcp.javx

package com.sage.rcp.javx
  • Related Packages
    Package
    Description
    com.sage.rcp
    com.sage.rcp.javx.windows
    com.sage.rcp.eventmanager
    com.sage.rcp.preferences
    com.sage.rcp.resizeanimation
    com.sage.rcp.util
    com.sage.rcp.views
  • Class
    Description
    FxPagePartListener
    IEmbeddedJavXView
    PvxHostLauncher
    RcpPluginConnectionControl
    RcpPluginJavXApplet
    RcpPluginSwingGUIManager
    RcpSwtViewPanel
    SingleWinViewGuiMngr
    SpawnUtil


com.sage.rcp.javx Class Hierarchy

Hierarchy For Package com.sage.rcp.javx

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.awt.Component (implements java.awt.image.ImageObserver, java.awt.MenuContainer, java.io.Serializable)
      • java.awt.Container
        • java.awt.Panel (implements javax.accessibility.Accessible)
          • java.applet.Applet
            • javax.swing.JApplet (implements javax.accessibility.Accessible, javax.swing.RootPaneContainer)
              • com.sage.rcp.javx.RcpPluginJavXApplet (implements javxswing.SwingWindow, java.awt.event.WindowListener)
          • com.sage.rcp.javx.RcpSwtViewPanel
    • com.sage.rcp.javx.FxPagePartListener (implements org.eclipse.ui.IPartListener2)
    • javxbaseui.PvxGUIManager (implements java.awt.datatransfer.ClipboardOwner, javxbaseui.GUIManagerI, javxbaseui.PvxFocusObserver)
      • javxswing.SwingGUIManager (implements javxswing.MNEM_WObserver)
        • com.sage.rcp.javx.RcpPluginSwingGUIManager
          • com.sage.rcp.javx.SingleWinViewGuiMngr
    • javxclientcontrol.PvxHost (implements javxbaseui.PvxEventObserver, java.lang.Runnable)
      • javxclientcontrol.ConnectionControl
        • sagecrm.PluginConnectionControl
          • com.sage.rcp.javx.RcpPluginConnectionControl (implements java.awt.event.ActionListener)
    • com.sage.rcp.javx.PvxHostLauncher
    • com.sage.rcp.javx.SpawnUtil

Interface Hierarchy

  • com.sage.rcp.javx.IEmbeddedJavXView


Uses of Package com.sage.rcp.javx

Uses of Package
com.sage.rcp.javx

Packages that use com.sage.rcp.javx
Package
Description
com.pvx.ooadide.eventmanager
com.pvx.ooadide.views
com.sage.rcp
com.sage.rcp.eventmanager
com.sage.rcp.javx
com.sage.rcp.views
  • Classes in com.sage.rcp.javx used by com.pvx.ooadide.eventmanager
    Class
    Description
    RcpPluginConnectionControl
  • Classes in com.sage.rcp.javx used by com.pvx.ooadide.views
    Class
    Description
    IEmbeddedJavXView
  • Classes in com.sage.rcp.javx used by com.sage.rcp
    Class
    Description
    RcpPluginConnectionControl
  • Classes in com.sage.rcp.javx used by com.sage.rcp.eventmanager
    Class
    Description
    RcpPluginConnectionControl
  • Classes in com.sage.rcp.javx used by com.sage.rcp.javx
    Class
    Description
    IEmbeddedJavXView
    RcpPluginConnectionControl
    RcpPluginSwingGUIManager
  • Classes in com.sage.rcp.javx used by com.sage.rcp.views
    Class
    Description
    IEmbeddedJavXView
    RcpPluginSwingGUIManager
    RcpSwtViewPanel


PvxHostLauncher

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.sage.rcp.javx

Class PvxHostLauncher

java.lang.Object
com.sage.rcp.javx.PvxHostLauncher
public class PvxHostLauncher extends Object

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxHostLauncher()

  • Method Summary

    Modifier and Type
    Method
    Description
    static int
    findOpenSocket()
    static int
    findOpenSocket(int socket)
    static int
    getDefaultDebugSocket()
    static int
    getDefaultEventManagerSocket()
    static int
    getDefaultSocket()
    static int
    getRequestManagerSocket()
    static final boolean
    launchPvxHost(int socket)
    static final boolean
    launchPvxHost(int socket, boolean isPlugin)
    static final boolean
    launchPvxHost(int socket, String outDir)
    static final boolean
    launchPvxHost(String[] args)
    static boolean
    showNagMessage()

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • PvxHostLauncher

      public PvxHostLauncher()

  • Method Details

    • showNagMessage

      public static boolean showNagMessage()

    • findOpenSocket

      public static int findOpenSocket() throws IOException
      Throws:
      IOException

    • findOpenSocket

      public static int findOpenSocket(int socket) throws IOException
      Throws:
      IOException

    • getRequestManagerSocket

      public static int getRequestManagerSocket() throws IOException
      Throws:
      IOException

    • getDefaultDebugSocket

      public static int getDefaultDebugSocket() throws IOException
      Throws:
      IOException

    • getDefaultEventManagerSocket

      public static int getDefaultEventManagerSocket()

    • getDefaultSocket

      public static int getDefaultSocket()

    • launchPvxHost

      public static final boolean launchPvxHost(int socket)

    • launchPvxHost

      public static final boolean launchPvxHost(int socket, boolean isPlugin)

    • launchPvxHost

      public static final boolean launchPvxHost(int socket, String outDir)

    • launchPvxHost

      public static final boolean launchPvxHost(String[] args)


RcpPluginConnectionControl

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.sage.rcp.javx

Class RcpPluginConnectionControl

java.lang.Object
javxclientcontrol.PvxHost
javxclientcontrol.ConnectionControl
sagecrm.PluginConnectionControl
com.sage.rcp.javx.RcpPluginConnectionControl
All Implemented Interfaces:
ActionListener, Runnable, EventListener, javxbaseui.PvxEventObserver
public class RcpPluginConnectionControl extends sagecrm.PluginConnectionControl implements ActionListener

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static boolean
    incorrectLic
    static int
    INSTANCE_NUM

    Fields inherited from class javxclientcontrol.ConnectionControl

    applet, DEBUG, endSession, err, fIsUltraFX, host, HTHOSTSPAWN, intry, javXUtil, Jkio, out, params, port, PRIAS_SERVERSPAWN, printIt, pvx_frms, readLoop, RECORDING, recvBytes, sentBytes, SERVERSPAWN, spawnCtr, spawnHideClientMainWindow, spwEmbed, spwner, tabAsEnter, webstart

  • Constructor Summary

    Constructors
    Constructor
    Description
    RcpPluginConnectionControl(String arg0, int arg1, javxbaseui.PvxBaseWindow arg2, Hashtable arg3, javxbaseui.PvxBaseWindow arg4, Socket arg5)

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    actionPerformed(ActionEvent e)
    boolean
    doAppClientLaunch()
    byte[]
    doLocalExecutionCall(byte[] data, Vector callArgs, String mxCallStr, String callStr, int echoLen)
    void
    endRcpSession()
    int
    freeUpFrame()
    static RcpPluginConnectionControl
    getCurrentInstance()
    void
    initSession()
    static boolean
    isIncorrectLic()
    void
    readSyncPkt()
    void
    run()
    void
    setHandshakeComplete(boolean handshakeComplete)
    void
    spawnClient(int sock, Vector callArgs)

    Methods inherited from class sagecrm.PluginConnectionControl

    connect, connect, doObjCreation

    Methods inherited from class javxclientcontrol.ConnectionControl

    callObjectMethod, checkForTab, closeAllFiles, containerTerminatedExit, ctlEventUpdate, doNotSynAck, formatDataForPrint, getAppClient, getAttrb, getFileNumber, getHost, getHostVersion, getIsApplet, getNumBytesRecvd, getNumBytesSent, getOpenLocalFileNumber, getParams, getPort, getPvxGuiManager, handleConnection, isHandshakeComplete, isSynPacket, isValidUltraFXPkg, mark, menuBarDisable, menuBarEnable, menuBarOnOff, nonBlockingRawRead, notiyAppletIsDestroyed, printReleaseInfo, rawRead, read, read, ready, registerNewConnection, reset, runLocalProgram, sendCtl, sendPopupResponse, setPipe, synAck, synAck, synAckFile, synCan, synCan, synNak, waitForData, waitForSynChar, write, write, writeflush

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Field Details

    • incorrectLic

      public static boolean incorrectLic

    • INSTANCE_NUM

      public static int INSTANCE_NUM

  • Constructor Details

    • RcpPluginConnectionControl

      public RcpPluginConnectionControl(String arg0, int arg1, javxbaseui.PvxBaseWindow arg2, Hashtable arg3, javxbaseui.PvxBaseWindow arg4, Socket arg5)

  • Method Details

    • getCurrentInstance

      public static RcpPluginConnectionControl getCurrentInstance()

    • doAppClientLaunch

      public boolean doAppClientLaunch()
      Overrides:
      doAppClientLaunch in class javxclientcontrol.ConnectionControl

    • spawnClient

      public void spawnClient(int sock, Vector callArgs)
      Overrides:
      spawnClient in class sagecrm.PluginConnectionControl

    • readSyncPkt

      public void readSyncPkt()
      Overrides:
      readSyncPkt in class javxclientcontrol.ConnectionControl

    • doLocalExecutionCall

      public byte[] doLocalExecutionCall(byte[] data, Vector callArgs, String mxCallStr, String callStr, int echoLen) throws Exception
      Overrides:
      doLocalExecutionCall in class javxclientcontrol.ConnectionControl
      Throws:
      Exception

    • run

      public void run()
      Specified by:
      run in interface Runnable
      Overrides:
      run in class sagecrm.PluginConnectionControl

    • actionPerformed

      public void actionPerformed(ActionEvent e)
      Specified by:
      actionPerformed in interface ActionListener

    • freeUpFrame

      public int freeUpFrame()
      Overrides:
      freeUpFrame in class javxclientcontrol.ConnectionControl

    • endRcpSession

      public void endRcpSession()

    • initSession

      public void initSession()
      Overrides:
      initSession in class javxclientcontrol.ConnectionControl

    • isIncorrectLic

      public static boolean isIncorrectLic()

    • setHandshakeComplete

      public void setHandshakeComplete(boolean handshakeComplete)
      Overrides:
      setHandshakeComplete in class javxclientcontrol.ConnectionControl


RcpPluginJavXApplet

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.sage.rcp.javx

Class RcpPluginJavXApplet

java.lang.Object
java.awt.Component
java.awt.Container
java.awt.Panel
java.applet.Applet
javax.swing.JApplet
com.sage.rcp.javx.RcpPluginJavXApplet
All Implemented Interfaces:
WindowListener, ImageObserver, MenuContainer, Serializable, EventListener, Accessible, RootPaneContainer, javxbaseui.PvxBaseWindow, javxbaseui.PvxWindow, javxswing.SwingWindow
public class RcpPluginJavXApplet extends JApplet implements javxswing.SwingWindow, WindowListener
See Also:
  • Serialized Form

  • Nested Class Summary

    Nested classes/interfaces inherited from class java.awt.Component

    Component.BaselineResizeBehavior

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    String
    args
    URL
    base
    javxbaseui.PvxCanvas
    canvas
    static String
    host
    RcpPluginConnectionControl
    nwClient
    String
    scriptMessage
    boolean
    start
    javxswing.StatusBar
    statusBar

    Fields inherited from class java.awt.Component

    BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

    Fields inherited from interface java.awt.image.ImageObserver

    ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

  • Constructor Summary

    Constructors
    Constructor
    Description
    RcpPluginJavXApplet(IEmbeddedJavXView view)

  • Method Summary

    Modifier and Type
    Method
    Description
    javxswing.JavXInternalFrame
    addChildWindow(javxswing.WindowFactory windowFactory, int argX, int argY, int argWidth, int argHeight, String title, int[] curAttrb, int winNumb, boolean resizable, boolean closable, boolean maximizable, boolean iconifiable, boolean withTitle, int barHeight, boolean statBar, boolean textWin, boolean border, javxclientcontrol.PvxHost applet)
    If OnApplet equal True this Method will add windows (created with the 'window' mnemonic) directly onto the Applet
    void
    addToHeight(int hite)
    void
    addToWidth(int wid)
    void
    dispose()
    RcpPluginConnectionControl
    establishConnection(javxbaseui.PvxBaseWindow prnt, Hashtable<String,String> params, javxclientcontrol.PvxSSLSocketFactory sslSocketFactory)
    Hashtable
    getActiveCtrls()
    If On Applet is true returns the Applets ProvideX GUI objects
    String
    getAppletInfo()
    javxbaseui.PvxCanvas
    getCanvas()
    sagecrm.AnimatedPanel
    getConnectionAnimation()
    javxclientcontrol.ConnectionControl
    getConnectionControl()
    Container
    getDeskTopContainer()
    URL
    getDocumentBase()
    Component
    getImplComponent()
    IEmbeddedJavXView
    getJavXView()
    Hashtable
    getMenuBarCollection()
    String
    getParameter(String name)
    Container
    getPvxCompContainer()
    javxswing.SwingWindowCompListener
    getResizeHandler()
    boolean
    getScrllHeight()
    boolean
    getScrllWidth()
    String
    getTitle()
    int
    getWIN_Y()
    void
    init(Color desktopColor)
    void
    initializeArgsParameters(String[] args)
    boolean
    isDialogue()
    boolean
    isDialWMnu()
    boolean
    isResizable()
    void
    jsForceFocus()
    void
    removeAllCtrl(boolean disposed)
    void
    scrlRemoveCtls(int scrlX_1, int scrlY_1, int scrlX_2, int scrlY_2)
    void
    setConnectionAnimation(sagecrm.AnimatedPanel connectionAnimation)
    void
    setLocation(int x, int y)
    void
    setScrllHeight(boolean wid)
    void
    setScrllWidth(boolean hite)
    void
    setSelectedFrame(javxbaseui.PvxBaseWindow internalFrame)
    void
    start()
    void
    startItUp()
    void
    startItUp(javxbaseui.AbstractGUIManagerFactory guiManagerFactory)
    void
    terminatedConnectionAnimation()
    void
    toFront()
    void
    windowActivated(WindowEvent e)
    void
    windowClosed(WindowEvent e)
    void
    windowClosing(WindowEvent e)
    void
    windowDeactivated(WindowEvent e)
    void
    windowDeiconified(WindowEvent e)
    void
    windowIconified(WindowEvent e)
    void
    windowOpened(WindowEvent e)

    Methods inherited from class javax.swing.JApplet

    getAccessibleContext, getContentPane, getGlassPane, getGraphics, getJMenuBar, getLayeredPane, getRootPane, getTransferHandler, remove, repaint, setContentPane, setGlassPane, setJMenuBar, setLayeredPane, setLayout, setTransferHandler, update

    Methods inherited from class java.applet.Applet

    destroy, getAppletContext, getAudioClip, getAudioClip, getCodeBase, getImage, getImage, getLocale, getParameterInfo, init, isActive, isValidateRoot, newAudioClip, play, play, resize, resize, setStub, showStatus, stop

    Methods inherited from class java.awt.Panel

    addNotify

    Methods inherited from class java.awt.Container

    add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, doLayout, findComponentAt, findComponentAt, getAlignmentX, getAlignmentY, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getInsets, getLayout, getListeners, getMaximumSize, getMinimumSize, getMousePosition, getPreferredSize, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, list, list, paint, paintComponents, print, printComponents, remove, removeAll, removeContainerListener, removeNotify, setComponentZOrder, setFocusCycleRoot, setFocusTraversalKeys, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setFont, transferFocusDownCycle, validate

    Methods inherited from class java.awt.Component

    add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, checkImage, checkImage, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, dispatchEvent, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocation, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getToolkit, getTreeLock, getWidth, getX, getY, hasFocus, imageUpdate, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusOwner, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isShowing, isValid, isVisible, list, list, list, paintAll, prepareImage, prepareImage, printAll, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, revalidate, setBackground, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeysEnabled, setForeground, setIgnoreRepaint, setLocale, setLocation, setMaximumSize, setMinimumSize, setMixingCutoutShape, setName, setPreferredSize, setSize, setSize, setVisible, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

    Methods inherited from interface javxbaseui.PvxBaseWindow

    destroy, invalidate, repaint, setSize, setVisible, validate

    Methods inherited from interface javxbaseui.PvxWindow

    getGlassPane, getLocation

    Methods inherited from interface javxswing.SwingWindow

    getJMenuBar, remove, setJMenuBar

  • Field Details

    • host

      public static String host

    • scriptMessage

      public String scriptMessage

    • args

      public String args

    • base

      public URL base

    • nwClient

      public RcpPluginConnectionControl nwClient

    • statusBar

      public javxswing.StatusBar statusBar

    • canvas

      public javxbaseui.PvxCanvas canvas

    • start

      public boolean start

  • Constructor Details

    • RcpPluginJavXApplet

      public RcpPluginJavXApplet(IEmbeddedJavXView view)
      Parameters:
      view -

  • Method Details

    • getParameter

      public String getParameter(String name)
      Overrides:
      getParameter in class Applet

    • getDocumentBase

      public URL getDocumentBase()
      Overrides:
      getDocumentBase in class Applet

    • init

      public void init(Color desktopColor)

    • initializeArgsParameters

      public void initializeArgsParameters(String[] args)

    • start

      public void start()
      Overrides:
      start in class Applet

    • startItUp

      public void startItUp()

    • startItUp

      public void startItUp(javxbaseui.AbstractGUIManagerFactory guiManagerFactory)

    • terminatedConnectionAnimation

      public void terminatedConnectionAnimation()

    • establishConnection

      public RcpPluginConnectionControl establishConnection(javxbaseui.PvxBaseWindow prnt, Hashtable<String,String> params, javxclientcontrol.PvxSSLSocketFactory sslSocketFactory)

    • addChildWindow

      public javxswing.JavXInternalFrame addChildWindow(javxswing.WindowFactory windowFactory, int argX, int argY, int argWidth, int argHeight, String title, int[] curAttrb, int winNumb, boolean resizable, boolean closable, boolean maximizable, boolean iconifiable, boolean withTitle, int barHeight, boolean statBar, boolean textWin, boolean border, javxclientcontrol.PvxHost applet)
      If OnApplet equal True this Method will add windows (created with the 'window' mnemonic) directly onto the Applet
      Specified by:
      addChildWindow in interface javxswing.SwingWindow
      Parameters:
      argX - The x-coordinate
      argY - The y-coordinate
      argWidth - The Window Width
      argHeight - The Window Height
      title - The Title to appear in the Title bar
      curAttrb - The Attributes for the window
      winNumb - The window number
      resizable - If true, the window is resizable
      closable - If true, the window is closable
      maximizable - If true, window is maximizable
      iconifiable - If true, window is iconifiable
      withTitle - If true, window will have a title bar
      barHeight - height of the title bar
      statBar - If true, window will have a status bar
      textWin - If true, window is a textWin (CUI style)
      border - If true, window has a border
      applet - a referrence to the ConnectionControl instance for this window
      Returns:
      a referrence to the JavXInternalFrame ('window') which has been added to the Applet

    • scrlRemoveCtls

      public void scrlRemoveCtls(int scrlX_1, int scrlY_1, int scrlX_2, int scrlY_2)
      Specified by:
      scrlRemoveCtls in interface javxbaseui.PvxBaseWindow

    • removeAllCtrl

      public void removeAllCtrl(boolean disposed)
      Specified by:
      removeAllCtrl in interface javxbaseui.PvxBaseWindow

    • addToWidth

      public void addToWidth(int wid)
      Specified by:
      addToWidth in interface javxbaseui.PvxBaseWindow

    • addToHeight

      public void addToHeight(int hite)
      Specified by:
      addToHeight in interface javxbaseui.PvxBaseWindow

    • toFront

      public void toFront()
      Specified by:
      toFront in interface javxbaseui.PvxBaseWindow

    • getActiveCtrls

      public Hashtable getActiveCtrls()
      If On Applet is true returns the Applets ProvideX GUI objects
      Specified by:
      getActiveCtrls in interface javxbaseui.PvxBaseWindow
      Returns:
      A Hashtable or Hashmap containing all of the current ProvideX GUI objects

    • getCanvas

      public javxbaseui.PvxCanvas getCanvas()
      Specified by:
      getCanvas in interface javxbaseui.PvxWindow

    • dispose

      public void dispose()
      Specified by:
      dispose in interface javxbaseui.PvxBaseWindow

    • setLocation

      public void setLocation(int x, int y)
      Specified by:
      setLocation in interface javxbaseui.PvxBaseWindow
      Overrides:
      setLocation in class Component

    • getTitle

      public String getTitle()
      Specified by:
      getTitle in interface javxbaseui.PvxBaseWindow

    • isDialogue

      public boolean isDialogue()
      Specified by:
      isDialogue in interface javxbaseui.PvxBaseWindow

    • isDialWMnu

      public boolean isDialWMnu()
      Specified by:
      isDialWMnu in interface javxbaseui.PvxBaseWindow

    • getScrllWidth

      public boolean getScrllWidth()
      Specified by:
      getScrllWidth in interface javxbaseui.PvxBaseWindow

    • getScrllHeight

      public boolean getScrllHeight()
      Specified by:
      getScrllHeight in interface javxbaseui.PvxBaseWindow

    • setScrllWidth

      public void setScrllWidth(boolean hite)
      Specified by:
      setScrllWidth in interface javxbaseui.PvxBaseWindow

    • setScrllHeight

      public void setScrllHeight(boolean wid)
      Specified by:
      setScrllHeight in interface javxbaseui.PvxBaseWindow

    • getConnectionControl

      public javxclientcontrol.ConnectionControl getConnectionControl()

    • jsForceFocus

      public void jsForceFocus()

    • windowOpened

      public void windowOpened(WindowEvent e)
      Specified by:
      windowOpened in interface WindowListener

    • windowClosing

      public void windowClosing(WindowEvent e)
      Specified by:
      windowClosing in interface WindowListener

    • windowClosed

      public void windowClosed(WindowEvent e)
      Specified by:
      windowClosed in interface WindowListener

    • windowIconified

      public void windowIconified(WindowEvent e)
      Specified by:
      windowIconified in interface WindowListener

    • windowDeiconified

      public void windowDeiconified(WindowEvent e)
      Specified by:
      windowDeiconified in interface WindowListener

    • windowActivated

      public void windowActivated(WindowEvent e)
      Specified by:
      windowActivated in interface WindowListener

    • windowDeactivated

      public void windowDeactivated(WindowEvent e)
      Specified by:
      windowDeactivated in interface WindowListener

    • getAppletInfo

      public String getAppletInfo()
      Overrides:
      getAppletInfo in class Applet

    • getPvxCompContainer

      public Container getPvxCompContainer()
      Specified by:
      getPvxCompContainer in interface javxbaseui.PvxWindow

    • getDeskTopContainer

      public Container getDeskTopContainer()
      Specified by:
      getDeskTopContainer in interface javxbaseui.PvxWindow

    • setSelectedFrame

      public void setSelectedFrame(javxbaseui.PvxBaseWindow internalFrame)
      Specified by:
      setSelectedFrame in interface javxbaseui.PvxBaseWindow

    • getImplComponent

      public Component getImplComponent()
      Specified by:
      getImplComponent in interface javxbaseui.PvxWindow

    • getWIN_Y

      public int getWIN_Y()
      Specified by:
      getWIN_Y in interface javxbaseui.PvxWindow

    • getJavXView

      public IEmbeddedJavXView getJavXView()

    • setConnectionAnimation

      public void setConnectionAnimation(sagecrm.AnimatedPanel connectionAnimation)

    • getConnectionAnimation

      public sagecrm.AnimatedPanel getConnectionAnimation()

    • getMenuBarCollection

      public Hashtable getMenuBarCollection()
      Specified by:
      getMenuBarCollection in interface javxswing.SwingWindow

    • getResizeHandler

      public javxswing.SwingWindowCompListener getResizeHandler()
      Specified by:
      getResizeHandler in interface javxswing.SwingWindow

    • isResizable

      public boolean isResizable()
      Specified by:
      isResizable in interface javxswing.SwingWindow


RcpPluginSwingGUIManager

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.sage.rcp.javx

Class RcpPluginSwingGUIManager

java.lang.Object
javxbaseui.PvxGUIManager
javxswing.SwingGUIManager
com.sage.rcp.javx.RcpPluginSwingGUIManager
All Implemented Interfaces:
ClipboardOwner, javxbaseui.GUIManagerI, javxbaseui.PvxFocusObserver, javxswing.MNEM_WObserver
Direct Known Subclasses:
SingleWinViewGuiMngr
public class RcpPluginSwingGUIManager extends javxswing.SwingGUIManager

  • Field Summary

    Fields inherited from class javxswing.SwingGUIManager

    FIVE_D_BG_COLOR, MainWin, msgBoxFont, popup, previousLook, rmnByte

    Fields inherited from class javxbaseui.PvxGUIManager

    ActiveWindows, chosenMnuItm, commonProps, comnProps, curAttBGCol, curAttFGCol, curAttOpt, extendedScreenColours, globalCtrls, isDialsOnApplet, isMAS, macPlaf, mapedFonts, ocxHelper, oldCvs, optionPanVis, paintPrev, popupVis, pvxHost, screenColours, screenSize, speedVisible, sxFlag, textCtrlColor, wdwIcon, WINDOW_ON_TOP, windowPlaf, winList

  • Constructor Summary

    Constructors
    Constructor
    Description
    RcpPluginSwingGUIManager(IEmbeddedJavXView embedJavXView, javxclientcontrol.PvxHost arg0)

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    addJavaComponent(boolean addToContainer, Object comp, String ctlValue, int init_x, int init_y, int init_w, int init_h)
    void
    addWindow(int argX, int argY, int argWidth, int argHeight, String title, int nxtWinNum, int[] curAttrb, int[] winOpts, boolean dialogBox, boolean textWin)
    void
    destroyNxtWind(int windNumb)
    void
    endSession(javxbaseui.PvxBaseWindow applet)
    void
    gc_OCX_Handles(Vector<Integer> excemptHandles)
    String
    getAllocatedObjectList()
    byte[]
    getFINValue(String key)
    static InputStream
    getInternalImageStream(String imgName)
    String
    getLocationOfPlugin()
    String
    getLocationOfPvxHelpers()
    String
    getLocationOfStateDirectory()
    sagecrm.windows.PluginWindowDelegate
    getTopWindowDelegate()
    void
    initDialFactory()
    void
    initMainWindow(javxbaseui.PvxBaseWindow applet)
    void
    initSession(javxbaseui.PvxBaseWindow applet)
    boolean
    isEmbedMainWindowOnApplet()
    javxbaseui.TextPlaneView
    makeTextPlaneView(javxbaseui.PvxCanvas init_canvas, Component statBar, javxclientcontrol.PvxHost init_applet)
    void
    moveWindow(int posX, int posY)
    void
    progressIndcator(String title, String detail, int workToDo)
    byte[]
    readTxtCtrl(String ctl)
    void
    selectWindow(javxbaseui.PvxWindow topWindow, boolean dropped)
    void
    sendViewActionEvent(int ctlValue)
    void
    setLookAndFeel(String m_LookAndFeel)
    JLayeredPane
    showProgressIndicator(javxbaseui.TextPlaneModel canvasModel, javxbaseui.TextPlaneView canvasView, boolean isGlobal)
    boolean
    updateProgressIndcator(String message, int workDone)
    void
    windowResized(javxbaseui.PvxWindow window)

    Methods inherited from class javxswing.SwingGUIManager

    addCtrl, addMenuBar, addOptionMsgBox, addPopupMenu, addScrollBar, addTextCtrl, assignCtlsToPopup, buttonON, canAccessClipBoard, changeFont, clearMenuBar, destroyPopupMenu, displayLoginBox, enableCtrl, finalizeUpPopup, findInCtrl, focusUpdate, getAvailableFontNames, getBMP, getComponentPropertyValue, getCurrentComponentContainer, getCurrentWindowContainer, getFeedGuiFactory, getFileBox, getFrameManager, getHighCanvas, getHighWindow, getHotKey, getInternalBmpFromJar, getLookAndFeelName, getMainWindow, getMenuItem, getMenuWithCtl, getObj, getSysImage, getTopFrame, getTopInternalFrame, getTopMenuBar, getTranslatedBounds, getTriState, getUIDefaults, getViewableColumnsRow, getWebExClient, getWindowFactory, gotoCtrl, gotoMenuBar, gotoWindow, gridAdd, gridAuto, gridClear, gridDel, gridFind, gridGoto, gridLock, gridRead, gridSelect, gridWrite, hideCtrl, invokeInEventQue, isSigned, loadImageData, loadTxtCtrl, lockCtrl, makeFrame, makeSysObject, menuDataStr, menuEnable, putComponentOnContainer, pvxBitMapPostion, pvxTextIconLayout, radioButtonOff, readScrollBar, readTxtCtrlBytes, removeCtrl, removeMenuBar, rstMnu, setBoundsOfButton, setComponentPropertyValue, setFocus, setFocusFlag, setFocusTraversalKeysEnabled, setHighWindow, setMainWindow, setMenuBarOn, setWDWICON, setWindowBorderVisible, showCtrl, systemHelp, updateLookAndFeel, updateMNEM_W, writeScrollBar, writeTxtCtrl

    Methods inherited from class javxbaseui.PvxGUIManager

    addDefObject, addPvxOCXListener, clipBoardRead, clipBoardWrite, cloneHighWin, displayTitle, doRepaint, findPvxCtrl, focusOnTextPlane, get_PROPLIST, get_PROPSEP, get_PROPVALUES, getActiveWindows, getCharsSentToScreen, getColourAtIndex, getFIBValue, getFINValue, getFntOpt, getGlobalCtrls, getHighActiveCtrls, getHighCtrl, getIndexOfColor, getMenuBars, getMSEValue, getObjectNameFromList, getOBJValue, getPvxColor, getPvxFocusObserver, getStrColor, getTopContainer, getTxWorH, getURLResource, handleMnemonic, isOptionPanVis, isPopupVis, isRepaintRequired, isWindowsTopFrameNull, lostOwnership, makeTextPlaneModel, messageBox, notSupported, putMediaPlayer, readMenuBar, removePvxCtrl, setActiveWindows, setColourAtIndex, setDragDrop, setGlobalCtrls, setHighActiveCtrls, setHighCtrl, setMenuBars, setOptionPanVis, setPopupVis, setSignalChangeMnemonic, setTopContainer, sizeWindow, systemHelp, tabOffControl, uniGetImage, uniGetImage, waitForImage, windowMediaPlayer

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • RcpPluginSwingGUIManager

      public RcpPluginSwingGUIManager(IEmbeddedJavXView embedJavXView, javxclientcontrol.PvxHost arg0)

  • Method Details

    • initSession

      public void initSession(javxbaseui.PvxBaseWindow applet)
      Specified by:
      initSession in interface javxbaseui.GUIManagerI
      Overrides:
      initSession in class javxswing.SwingGUIManager

    • initMainWindow

      public void initMainWindow(javxbaseui.PvxBaseWindow applet)
      Overrides:
      initMainWindow in class javxswing.SwingGUIManager

    • makeTextPlaneView

      public javxbaseui.TextPlaneView makeTextPlaneView(javxbaseui.PvxCanvas init_canvas, Component statBar, javxclientcontrol.PvxHost init_applet)
      Overrides:
      makeTextPlaneView in class javxswing.SwingGUIManager

    • initDialFactory

      public void initDialFactory()
      Overrides:
      initDialFactory in class javxswing.SwingGUIManager

    • moveWindow

      public void moveWindow(int posX, int posY)
      Overrides:
      moveWindow in class javxbaseui.PvxGUIManager

    • addJavaComponent

      public void addJavaComponent(boolean addToContainer, Object comp, String ctlValue, int init_x, int init_y, int init_w, int init_h)
      Specified by:
      addJavaComponent in interface javxbaseui.GUIManagerI
      Overrides:
      addJavaComponent in class javxbaseui.PvxGUIManager

    • endSession

      public void endSession(javxbaseui.PvxBaseWindow applet)
      Specified by:
      endSession in interface javxbaseui.GUIManagerI
      Overrides:
      endSession in class javxswing.SwingGUIManager

    • gc_OCX_Handles

      public void gc_OCX_Handles(Vector<Integer> excemptHandles)

    • setLookAndFeel

      public void setLookAndFeel(String m_LookAndFeel)
      Specified by:
      setLookAndFeel in interface javxbaseui.GUIManagerI
      Overrides:
      setLookAndFeel in class javxswing.SwingGUIManager

    • isEmbedMainWindowOnApplet

      public boolean isEmbedMainWindowOnApplet()
      Overrides:
      isEmbedMainWindowOnApplet in class javxswing.SwingGUIManager

    • addWindow

      public void addWindow(int argX, int argY, int argWidth, int argHeight, String title, int nxtWinNum, int[] curAttrb, int[] winOpts, boolean dialogBox, boolean textWin)
      Overrides:
      addWindow in class javxswing.SwingGUIManager

    • destroyNxtWind

      public void destroyNxtWind(int windNumb)
      Overrides:
      destroyNxtWind in class javxswing.SwingGUIManager

    • selectWindow

      public void selectWindow(javxbaseui.PvxWindow topWindow, boolean dropped)
      Overrides:
      selectWindow in class javxswing.SwingGUIManager

    • getTopWindowDelegate

      public sagecrm.windows.PluginWindowDelegate getTopWindowDelegate()

    • getAllocatedObjectList

      public String getAllocatedObjectList()

    • sendViewActionEvent

      public void sendViewActionEvent(int ctlValue)

    • windowResized

      public void windowResized(javxbaseui.PvxWindow window)
      Specified by:
      windowResized in interface javxbaseui.GUIManagerI
      Overrides:
      windowResized in class javxbaseui.PvxGUIManager

    • getLocationOfPlugin

      public String getLocationOfPlugin()

    • getLocationOfPvxHelpers

      public String getLocationOfPvxHelpers()

    • getLocationOfStateDirectory

      public String getLocationOfStateDirectory()

    • getFINValue

      public byte[] getFINValue(String key)
      Specified by:
      getFINValue in interface javxbaseui.GUIManagerI
      Overrides:
      getFINValue in class javxswing.SwingGUIManager

    • getInternalImageStream

      public static InputStream getInternalImageStream(String imgName)

    • progressIndcator

      public void progressIndcator(String title, String detail, int workToDo)
      Specified by:
      progressIndcator in interface javxbaseui.GUIManagerI
      Overrides:
      progressIndcator in class javxbaseui.PvxGUIManager

    • updateProgressIndcator

      public boolean updateProgressIndcator(String message, int workDone)
      Specified by:
      updateProgressIndcator in interface javxbaseui.GUIManagerI
      Overrides:
      updateProgressIndcator in class javxbaseui.PvxGUIManager

    • showProgressIndicator

      public JLayeredPane showProgressIndicator(javxbaseui.TextPlaneModel canvasModel, javxbaseui.TextPlaneView canvasView, boolean isGlobal)
      Overrides:
      showProgressIndicator in class javxswing.SwingGUIManager

    • readTxtCtrl

      public byte[] readTxtCtrl(String ctl) throws NullPointerException
      Specified by:
      readTxtCtrl in interface javxbaseui.GUIManagerI
      Overrides:
      readTxtCtrl in class javxswing.SwingGUIManager
      Throws:
      NullPointerException


RcpSwtViewPanel

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.sage.rcp.javx

Class RcpSwtViewPanel

java.lang.Object
java.awt.Component
java.awt.Container
java.awt.Panel
com.sage.rcp.javx.RcpSwtViewPanel
All Implemented Interfaces:
ImageObserver, MenuContainer, Serializable, Accessible
public class RcpSwtViewPanel extends Panel
See Also:
  • Serialized Form

  • Nested Class Summary

    Nested classes/interfaces inherited from class java.awt.Component

    Component.BaselineResizeBehavior

  • Field Summary

    Fields inherited from class java.awt.Component

    BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

    Fields inherited from interface java.awt.image.ImageObserver

    ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

  • Constructor Summary

    Constructors
    Constructor
    Description
    RcpSwtViewPanel(RcpEmbedJavXView embedJavXView)

  • Method Summary

    Modifier and Type
    Method
    Description
    RcpEmbedJavXView
    getView()
    void
    setView(RcpEmbedJavXView view)

    Methods inherited from class java.awt.Panel

    addNotify, getAccessibleContext

    Methods inherited from class java.awt.Container

    add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, doLayout, findComponentAt, findComponentAt, getAlignmentX, getAlignmentY, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getInsets, getLayout, getListeners, getMaximumSize, getMinimumSize, getMousePosition, getPreferredSize, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, isValidateRoot, list, list, paint, paintComponents, print, printComponents, remove, remove, removeAll, removeContainerListener, removeNotify, setComponentZOrder, setFocusCycleRoot, setFocusTraversalKeys, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setFont, setLayout, transferFocusDownCycle, update, validate

    Methods inherited from class java.awt.Component

    add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, checkImage, checkImage, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, dispatchEvent, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getToolkit, getTreeLock, getWidth, getX, getY, hasFocus, imageUpdate, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusOwner, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isShowing, isValid, isVisible, list, list, list, paintAll, prepareImage, prepareImage, printAll, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, revalidate, setBackground, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeysEnabled, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setMinimumSize, setMixingCutoutShape, setName, setPreferredSize, setSize, setSize, setVisible, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

  • Constructor Details

    • RcpSwtViewPanel

      public RcpSwtViewPanel(RcpEmbedJavXView embedJavXView)

  • Method Details

    • setView

      public void setView(RcpEmbedJavXView view)

    • getView

      public RcpEmbedJavXView getView()


SingleWinViewGuiMngr

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.sage.rcp.javx

Class SingleWinViewGuiMngr

java.lang.Object
javxbaseui.PvxGUIManager
javxswing.SwingGUIManager
com.sage.rcp.javx.RcpPluginSwingGUIManager
com.sage.rcp.javx.SingleWinViewGuiMngr
All Implemented Interfaces:
ClipboardOwner, javxbaseui.GUIManagerI, javxbaseui.PvxFocusObserver, javxswing.MNEM_WObserver
public class SingleWinViewGuiMngr extends RcpPluginSwingGUIManager

  • Field Summary

    Fields inherited from class javxswing.SwingGUIManager

    FIVE_D_BG_COLOR, MainWin, msgBoxFont, popup, previousLook, rmnByte

    Fields inherited from class javxbaseui.PvxGUIManager

    ActiveWindows, chosenMnuItm, commonProps, comnProps, curAttBGCol, curAttFGCol, curAttOpt, extendedScreenColours, globalCtrls, isDialsOnApplet, isMAS, macPlaf, mapedFonts, ocxHelper, oldCvs, optionPanVis, paintPrev, popupVis, pvxHost, screenColours, screenSize, speedVisible, sxFlag, textCtrlColor, wdwIcon, WINDOW_ON_TOP, windowPlaf, winList

  • Constructor Summary

    Constructors
    Constructor
    Description
    SingleWinViewGuiMngr(IEmbeddedJavXView embedJavXView, javxclientcontrol.PvxHost arg0)

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    addWindow(int argX, int argY, int argWidth, int argHeight, String title, int nxtWinNum, int[] curAttrb, int[] winOpts, boolean dialogBox, boolean textWin)

    Methods inherited from class com.sage.rcp.javx.RcpPluginSwingGUIManager

    addJavaComponent, destroyNxtWind, endSession, gc_OCX_Handles, getAllocatedObjectList, getFINValue, getInternalImageStream, getLocationOfPlugin, getLocationOfPvxHelpers, getLocationOfStateDirectory, getTopWindowDelegate, initDialFactory, initMainWindow, initSession, isEmbedMainWindowOnApplet, makeTextPlaneView, moveWindow, progressIndcator, readTxtCtrl, selectWindow, sendViewActionEvent, setLookAndFeel, showProgressIndicator, updateProgressIndcator, windowResized

    Methods inherited from class javxswing.SwingGUIManager

    addCtrl, addMenuBar, addOptionMsgBox, addPopupMenu, addScrollBar, addTextCtrl, assignCtlsToPopup, buttonON, canAccessClipBoard, changeFont, clearMenuBar, destroyPopupMenu, displayLoginBox, enableCtrl, finalizeUpPopup, findInCtrl, focusUpdate, getAvailableFontNames, getBMP, getComponentPropertyValue, getCurrentComponentContainer, getCurrentWindowContainer, getFeedGuiFactory, getFileBox, getFrameManager, getHighCanvas, getHighWindow, getHotKey, getInternalBmpFromJar, getLookAndFeelName, getMainWindow, getMenuItem, getMenuWithCtl, getObj, getSysImage, getTopFrame, getTopInternalFrame, getTopMenuBar, getTranslatedBounds, getTriState, getUIDefaults, getViewableColumnsRow, getWebExClient, getWindowFactory, gotoCtrl, gotoMenuBar, gotoWindow, gridAdd, gridAuto, gridClear, gridDel, gridFind, gridGoto, gridLock, gridRead, gridSelect, gridWrite, hideCtrl, invokeInEventQue, isSigned, loadImageData, loadTxtCtrl, lockCtrl, makeFrame, makeSysObject, menuDataStr, menuEnable, putComponentOnContainer, pvxBitMapPostion, pvxTextIconLayout, radioButtonOff, readScrollBar, readTxtCtrlBytes, removeCtrl, removeMenuBar, rstMnu, setBoundsOfButton, setComponentPropertyValue, setFocus, setFocusFlag, setFocusTraversalKeysEnabled, setHighWindow, setMainWindow, setMenuBarOn, setWDWICON, setWindowBorderVisible, showCtrl, systemHelp, updateLookAndFeel, updateMNEM_W, writeScrollBar, writeTxtCtrl

    Methods inherited from class javxbaseui.PvxGUIManager

    addDefObject, addPvxOCXListener, clipBoardRead, clipBoardWrite, cloneHighWin, displayTitle, doRepaint, findPvxCtrl, focusOnTextPlane, get_PROPLIST, get_PROPSEP, get_PROPVALUES, getActiveWindows, getCharsSentToScreen, getColourAtIndex, getFIBValue, getFINValue, getFntOpt, getGlobalCtrls, getHighActiveCtrls, getHighCtrl, getIndexOfColor, getMenuBars, getMSEValue, getObjectNameFromList, getOBJValue, getPvxColor, getPvxFocusObserver, getStrColor, getTopContainer, getTxWorH, getURLResource, handleMnemonic, isOptionPanVis, isPopupVis, isRepaintRequired, isWindowsTopFrameNull, lostOwnership, makeTextPlaneModel, messageBox, notSupported, putMediaPlayer, readMenuBar, removePvxCtrl, setActiveWindows, setColourAtIndex, setDragDrop, setGlobalCtrls, setHighActiveCtrls, setHighCtrl, setMenuBars, setOptionPanVis, setPopupVis, setSignalChangeMnemonic, setTopContainer, sizeWindow, systemHelp, tabOffControl, uniGetImage, uniGetImage, waitForImage, windowMediaPlayer

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • SingleWinViewGuiMngr

      public SingleWinViewGuiMngr(IEmbeddedJavXView embedJavXView, javxclientcontrol.PvxHost arg0)

  • Method Details

    • addWindow

      public void addWindow(int argX, int argY, int argWidth, int argHeight, String title, int nxtWinNum, int[] curAttrb, int[] winOpts, boolean dialogBox, boolean textWin)
      Overrides:
      addWindow in class RcpPluginSwingGUIManager


SpawnUtil

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.sage.rcp.javx

Class SpawnUtil

java.lang.Object
com.sage.rcp.javx.SpawnUtil
public class SpawnUtil extends Object

  • Constructor Summary

    Constructors
    Constructor
    Description
    SpawnUtil()

  • Method Summary

    Modifier and Type
    Method
    Description
    static void
    spawn(String viewId)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • SpawnUtil

      public SpawnUtil()

  • Method Details

    • spawn

      public static void spawn(String viewId)


Uses of Class com.sage.rcp.javx.FxPagePartListener

Uses of Class
com.sage.rcp.javx.FxPagePartListener

No usage of com.sage.rcp.javx.FxPagePartListener


Uses of Interface com.sage.rcp.javx.IEmbeddedJavXView

Uses of Interface
com.sage.rcp.javx.IEmbeddedJavXView

Packages that use IEmbeddedJavXView
Package
Description
com.pvx.ooadide.views
com.sage.rcp.javx
com.sage.rcp.views

  • Uses of IEmbeddedJavXView in com.pvx.ooadide.views

    Classes in com.pvx.ooadide.views that implement IEmbeddedJavXView
    Modifier and Type
    Class
    Description
    class
    WinDefine

  • Uses of IEmbeddedJavXView in com.sage.rcp.javx

    Methods in com.sage.rcp.javx that return IEmbeddedJavXView
    Modifier and Type
    Method
    Description
    IEmbeddedJavXView
    RcpPluginJavXApplet.getJavXView()
    Constructors in com.sage.rcp.javx with parameters of type IEmbeddedJavXView
    Modifier
    Constructor
    Description

    RcpPluginJavXApplet(IEmbeddedJavXView view)

    RcpPluginSwingGUIManager(IEmbeddedJavXView embedJavXView, javxclientcontrol.PvxHost arg0)

    SingleWinViewGuiMngr(IEmbeddedJavXView embedJavXView, javxclientcontrol.PvxHost arg0)

  • Uses of IEmbeddedJavXView in com.sage.rcp.views

    Classes in com.sage.rcp.views that implement IEmbeddedJavXView
    Modifier and Type
    Class
    Description
    class
    HostActionsView
    class
    RcpEmbedJavXView
    class
    RcpMasProgramView
    class
    RcpProgramView
    class
    RcpSpawnedMasProgramView


Uses of Class com.sage.rcp.javx.PvxHostLauncher

Uses of Class
com.sage.rcp.javx.PvxHostLauncher

No usage of com.sage.rcp.javx.PvxHostLauncher


Uses of Class com.sage.rcp.javx.RcpPluginConnectionControl

Uses of Class
com.sage.rcp.javx.RcpPluginConnectionControl

Packages that use RcpPluginConnectionControl
Package
Description
com.pvx.ooadide.eventmanager
com.sage.rcp
com.sage.rcp.eventmanager
com.sage.rcp.javx

  • Uses of RcpPluginConnectionControl in com.pvx.ooadide.eventmanager

    Methods in com.pvx.ooadide.eventmanager that return RcpPluginConnectionControl
    Modifier and Type
    Method
    Description
    RcpPluginConnectionControl
    EventManager.getConCon()
    Methods in com.pvx.ooadide.eventmanager with parameters of type RcpPluginConnectionControl
    Modifier and Type
    Method
    Description
    void
    EventManager.dropInstance(RcpPluginConnectionControl rcpPluginConnectionControl)
    void
    EventManager.initConnection(RcpPluginConnectionControl initCon)
    void
    EventManager.setConCon(RcpPluginConnectionControl conCon)

  • Uses of RcpPluginConnectionControl in com.sage.rcp

    Methods in com.sage.rcp that return RcpPluginConnectionControl
    Modifier and Type
    Method
    Description
    RcpPluginConnectionControl
    IEventManager.getConCon()
    Methods in com.sage.rcp with parameters of type RcpPluginConnectionControl
    Modifier and Type
    Method
    Description
    void
    IEventManager.dropInstance(RcpPluginConnectionControl rcpPluginConnectionControl)
    void
    IEventManager.setConCon(RcpPluginConnectionControl connectionControl)

  • Uses of RcpPluginConnectionControl in com.sage.rcp.eventmanager

    Methods in com.sage.rcp.eventmanager that return RcpPluginConnectionControl
    Modifier and Type
    Method
    Description
    RcpPluginConnectionControl
    EventManager.getConCon()
    Methods in com.sage.rcp.eventmanager with parameters of type RcpPluginConnectionControl
    Modifier and Type
    Method
    Description
    void
    EventManager.dropInstance(RcpPluginConnectionControl rcpPluginConnectionControl)
    void
    EventManager.setConCon(RcpPluginConnectionControl conCon)
    Constructors in com.sage.rcp.eventmanager with parameters of type RcpPluginConnectionControl
    Modifier
    Constructor
    Description

    EventManager(RcpPluginConnectionControl conObserver)

    EventManager(RcpPluginConnectionControl conObserver, boolean initIde)

  • Uses of RcpPluginConnectionControl in com.sage.rcp.javx

    Fields in com.sage.rcp.javx declared as RcpPluginConnectionControl
    Modifier and Type
    Field
    Description
    RcpPluginConnectionControl
    RcpPluginJavXApplet.nwClient
    Methods in com.sage.rcp.javx that return RcpPluginConnectionControl
    Modifier and Type
    Method
    Description
    RcpPluginConnectionControl
    RcpPluginJavXApplet.establishConnection(javxbaseui.PvxBaseWindow prnt, Hashtable<String,String> params, javxclientcontrol.PvxSSLSocketFactory sslSocketFactory)
    static RcpPluginConnectionControl
    RcpPluginConnectionControl.getCurrentInstance()


Uses of Class com.sage.rcp.javx.RcpPluginJavXApplet

Uses of Class
com.sage.rcp.javx.RcpPluginJavXApplet

No usage of com.sage.rcp.javx.RcpPluginJavXApplet


Uses of Class com.sage.rcp.javx.RcpPluginSwingGUIManager

Uses of Class
com.sage.rcp.javx.RcpPluginSwingGUIManager

Packages that use RcpPluginSwingGUIManager
Package
Description
com.sage.rcp.javx
com.sage.rcp.views

  • Uses of RcpPluginSwingGUIManager in com.sage.rcp.javx

    Subclasses of RcpPluginSwingGUIManager in com.sage.rcp.javx
    Modifier and Type
    Class
    Description
    class
    SingleWinViewGuiMngr

  • Uses of RcpPluginSwingGUIManager in com.sage.rcp.views

    Constructors in com.sage.rcp.views with parameters of type RcpPluginSwingGUIManager
    Modifier
    Constructor
    Description

    RcpPvxAction(RcpPluginSwingGUIManager rcpPluginSwingGUIManager, int ctl)


Uses of Class com.sage.rcp.javx.RcpSwtViewPanel

Uses of Class
com.sage.rcp.javx.RcpSwtViewPanel

Packages that use RcpSwtViewPanel
Package
Description
com.sage.rcp.views

  • Uses of RcpSwtViewPanel in com.sage.rcp.views

    Fields in com.sage.rcp.views declared as RcpSwtViewPanel
    Modifier and Type
    Field
    Description
    RcpSwtViewPanel
    RcpEmbedJavXView.panel
    Methods in com.sage.rcp.views that return types with arguments of type RcpSwtViewPanel
    Modifier and Type
    Method
    Description
    static Hashtable<String,RcpSwtViewPanel>
    JavXThread.getActiveFrames()


Uses of Class com.sage.rcp.javx.SingleWinViewGuiMngr

Uses of Class
com.sage.rcp.javx.SingleWinViewGuiMngr

No usage of com.sage.rcp.javx.SingleWinViewGuiMngr


Uses of Class com.sage.rcp.javx.SpawnUtil

Uses of Class
com.sage.rcp.javx.SpawnUtil

No usage of com.sage.rcp.javx.SpawnUtil


com.sage.rcp.javx.windows

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.sage.rcp.javx.windows

package com.sage.rcp.javx.windows
  • Related Packages
    Package
    Description
    com.sage.rcp.javx
  • Classes
    Class
    Description
    PluginTextPlaneView


com.sage.rcp.javx.windows Class Hierarchy

Hierarchy For Package com.sage.rcp.javx.windows

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.awt.Component (implements java.awt.image.ImageObserver, java.awt.MenuContainer, java.io.Serializable)
      • java.awt.Container
        • javax.swing.JComponent (implements java.io.Serializable)
          • javxswing.SwingDefaultTextPlaneView (implements javxswing.MNEM_WSubject, java.awt.print.Printable, java.lang.Runnable, javxbaseui.TextPlaneView)
            • com.sage.rcp.javx.windows.PluginTextPlaneView (implements java.awt.event.ActionListener)


Uses of Package com.sage.rcp.javx.windows

Uses of Package
com.sage.rcp.javx.windows

No usage of com.sage.rcp.javx.windows


PluginTextPlaneView

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.sage.rcp.javx.windows

Class PluginTextPlaneView

java.lang.Object
java.awt.Component
java.awt.Container
javax.swing.JComponent
javxswing.SwingDefaultTextPlaneView
com.sage.rcp.javx.windows.PluginTextPlaneView
All Implemented Interfaces:
ActionListener, ImageObserver, MenuContainer, Printable, Serializable, Runnable, EventListener, javxbaseui.TextPlaneView, javxswing.MNEM_WSubject
public class PluginTextPlaneView extends javxswing.SwingDefaultTextPlaneView implements ActionListener
See Also:
  • Serialized Form

  • Nested Class Summary

    Nested classes/interfaces inherited from class javxswing.SwingDefaultTextPlaneView

    javxswing.SwingDefaultTextPlaneView.MouseDropHandler, javxswing.SwingDefaultTextPlaneView.MouseEventHandler

    Nested classes/interfaces inherited from class javax.swing.JComponent

    JComponent.AccessibleJComponent

    Nested classes/interfaces inherited from class java.awt.Component

    Component.BaselineResizeBehavior

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static boolean
    internalDialogues
    static boolean
    windowBorders

    Fields inherited from class javxswing.SwingDefaultTextPlaneView

    cursorTimer, frameState, hasFocus, m_maxNumPage, makeVisible, popX, popY

    Fields inherited from class javax.swing.JComponent

    TOOL_TIP_TEXT_KEY, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

    Fields inherited from class java.awt.Component

    BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

    Fields inherited from interface java.awt.image.ImageObserver

    ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    Fields inherited from interface java.awt.print.Printable

    NO_SUCH_PAGE, PAGE_EXISTS

  • Constructor Summary

    Constructors
    Constructor
    Description
    PluginTextPlaneView(javxbaseui.PvxCanvas init_canvas, Component statBar, javxclientcontrol.PvxHost appl)

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    actionPerformed(ActionEvent e)
    JDesktopPane
    getDeskTopPane()
    javxswing.SwingWindowCompListener
    getSwingWindowCompListener()
    RcpEmbedJavXView
    getTopRcpView()
    void
    optionMn(String cmnd, String val)
    void
    paintComponent(Graphics screen)
    void
    rcpShowFrm(short state)
    void
    setSizeAdjust(int size)
    void
    setSizeAdjustStart()
    void
    setSizePercent(int selected)
    void
    setWinCaption(String caption)
    boolean
    zoomFrm(short state)

    Methods inherited from class javxswing.SwingDefaultTextPlaneView

    addActionListener, addDebugPopUp, addDebugWin, addMNEM_WObserver, addStatusBar, createComponentImage, defineStatusBar, do6dFrame, draw4DFrame, drawCustomFrame, drawG2DFocusLines, drawG2DImage, drawG2DUnderLine, drawGraphics, getBottomInset, getCollapseImage, getDragCursor, getDropCursor, getExpandImage, getFrameState, getImplComponent, getLeftInset, getLineAscent, getModel, getMouseEventHandler, getMse, getParentInternalWindow, getPinImage, getPopupInvoker, getPopX, getPopY, getRightInset, getStatusBar, getTopApplet, getTopDeskTop, getTopFrame, getTopInset, getTopInternalFrame, getTopWindow, handleSixDFrameDraw, handleSixDFrameDraw, hasFocusFlag, inDragDropList, isDiscloseable, isFocusTraversable, isMakeVisible, isManagingFocus, isMoveableDiscloseable, notifyAllMNEM_WObservers, notifyWindowPending, playBeep, print, removeAllListeners, removeDebugWin, removeMNEM_WObserver, requestFocus, rotateG2D, run, sendCtl, setDiscloseable, setDragDrop, setG2DPaint, setG2DStroke, setHiddenMainWindow, setMakeVisible, setMoveableDiscloseable, setMse, setPattern, setPopupInvoker, setRectanglePattern, setStatusBarMessage, setTextPlaneModel, setToNull, showFrm, sizeMN, speedVisible, startCursorTimer, stopCursorTimer

    Methods inherited from class javax.swing.JComponent

    addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, firePropertyChange, firePropertyChange, firePropertyChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getUI, getUIClassID, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintImmediately, paintImmediately, print, printAll, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestFocus, requestFocusInWindow, resetKeyboardActions, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update, updateUI

    Methods inherited from class java.awt.Container

    add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, list, list, paintComponents, printComponents, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate

    Methods inherited from class java.awt.Component

    add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, checkImage, checkImage, contains, createImage, createImage, createVolatileImage, createVolatileImage, dispatchEvent, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getAccessibleContext, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, hasFocus, imageUpdate, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, list, list, list, paintAll, prepareImage, prepareImage, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, requestFocus, requestFocusInWindow, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setMixingCutoutShape, setName, setSize, setSize, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

    Methods inherited from interface javxbaseui.TextPlaneView

    repaint

  • Field Details

    • internalDialogues

      public static boolean internalDialogues

    • windowBorders

      public static boolean windowBorders

  • Constructor Details

    • PluginTextPlaneView

      public PluginTextPlaneView(javxbaseui.PvxCanvas init_canvas, Component statBar, javxclientcontrol.PvxHost appl)

  • Method Details

    • rcpShowFrm

      public void rcpShowFrm(short state)

    • zoomFrm

      public boolean zoomFrm(short state)

    • setWinCaption

      public void setWinCaption(String caption)
      Specified by:
      setWinCaption in interface javxbaseui.TextPlaneView
      Overrides:
      setWinCaption in class javxswing.SwingDefaultTextPlaneView

    • getTopRcpView

      public RcpEmbedJavXView getTopRcpView()

    • getSwingWindowCompListener

      public javxswing.SwingWindowCompListener getSwingWindowCompListener()

    • getDeskTopPane

      public JDesktopPane getDeskTopPane()

    • paintComponent

      public void paintComponent(Graphics screen)
      Overrides:
      paintComponent in class javxswing.SwingDefaultTextPlaneView

    • actionPerformed

      public void actionPerformed(ActionEvent e)
      Specified by:
      actionPerformed in interface ActionListener

    • setSizeAdjustStart

      public void setSizeAdjustStart()

    • setSizeAdjust

      public void setSizeAdjust(int size)

    • setSizePercent

      public void setSizePercent(int selected)

    • optionMn

      public void optionMn(String cmnd, String val)
      Specified by:
      optionMn in interface javxbaseui.TextPlaneView
      Overrides:
      optionMn in class javxswing.SwingDefaultTextPlaneView


Uses of Class com.sage.rcp.javx.windows.PluginTextPlaneView

Uses of Class
com.sage.rcp.javx.windows.PluginTextPlaneView

No usage of com.sage.rcp.javx.windows.PluginTextPlaneView


com.sage.rcp.preferences

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.sage.rcp.preferences

package com.sage.rcp.preferences
  • Related Packages
    Package
    Description
    com.sage.rcp
    com.sage.rcp.eventmanager
    com.sage.rcp.javx
    com.sage.rcp.resizeanimation
    com.sage.rcp.util
    com.sage.rcp.views
  • Classes
    Class
    Description
    ProgramViewsPrefs
    RcpPreferenceConstants
    RcpPreferenceInitializer
    UiPrefManager


com.sage.rcp.preferences Class Hierarchy

Hierarchy For Package com.sage.rcp.preferences

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.eclipse.core.runtime.preferences.AbstractPreferenceInitializer
      • com.sage.rcp.preferences.RcpPreferenceInitializer
    • org.eclipse.jface.dialogs.DialogPage (implements org.eclipse.jface.dialogs.IDialogPage, org.eclipse.jface.dialogs.IMessageProvider)
      • org.eclipse.jface.preference.PreferencePage (implements org.eclipse.jface.preference.IPreferencePage)
        • org.eclipse.jface.preference.FieldEditorPreferencePage (implements org.eclipse.jface.util.IPropertyChangeListener)
          • com.sage.rcp.preferences.ProgramViewsPrefs (implements org.eclipse.ui.IWorkbenchPreferencePage)
    • com.sage.rcp.preferences.RcpPreferenceConstants
    • com.sage.rcp.preferences.UiPrefManager


Uses of Package com.sage.rcp.preferences

Uses of Package
com.sage.rcp.preferences

No usage of com.sage.rcp.preferences


ProgramViewsPrefs

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.sage.rcp.preferences

Class ProgramViewsPrefs

java.lang.Object
org.eclipse.jface.dialogs.DialogPage
org.eclipse.jface.preference.PreferencePage
org.eclipse.jface.preference.FieldEditorPreferencePage
com.sage.rcp.preferences.ProgramViewsPrefs
All Implemented Interfaces:
EventListener, org.eclipse.jface.dialogs.IDialogPage, org.eclipse.jface.dialogs.IMessageProvider, org.eclipse.jface.preference.IPreferencePage, org.eclipse.jface.util.IPropertyChangeListener, org.eclipse.ui.IWorkbenchPreferencePage
public class ProgramViewsPrefs extends org.eclipse.jface.preference.FieldEditorPreferencePage implements org.eclipse.ui.IWorkbenchPreferencePage

  • Field Summary

    Fields inherited from class org.eclipse.jface.preference.FieldEditorPreferencePage

    FLAT, GRID

    Fields inherited from interface org.eclipse.jface.dialogs.IMessageProvider

    ERROR, INFORMATION, NONE, WARNING

  • Constructor Summary

    Constructors
    Constructor
    Description
    ProgramViewsPrefs()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    createFieldEditors()
    Creates the field editors.
    void
    init(org.eclipse.ui.IWorkbench workbench)
    boolean
    performOk()
    void
    propertyChange(org.eclipse.jface.util.PropertyChangeEvent event)
    void
    setEnableOptions()

    Methods inherited from class org.eclipse.jface.preference.FieldEditorPreferencePage

    dispose, setVisible

    Methods inherited from class org.eclipse.jface.preference.PreferencePage

    applyData, computeSize, createControl, getContainer, getPreferenceStore, isValid, okToLeave, performCancel, performHelp, setContainer, setErrorMessage, setMessage, setPreferenceStore, setSize, setTitle, setValid, toString

    Methods inherited from class org.eclipse.jface.dialogs.DialogPage

    getControl, getDescription, getErrorMessage, getImage, getMessage, getMessageType, getShell, getTitle, setDescription, setImageDescriptor, setMessage

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

    Methods inherited from interface org.eclipse.jface.dialogs.IDialogPage

    createControl, dispose, getControl, getDescription, getErrorMessage, getImage, getMessage, getTitle, performHelp, setDescription, setImageDescriptor, setTitle, setVisible

    Methods inherited from interface org.eclipse.jface.preference.IPreferencePage

    computeSize, isValid, okToLeave, performCancel, setContainer, setSize

  • Constructor Details

    • ProgramViewsPrefs

      public ProgramViewsPrefs()

  • Method Details

    • createFieldEditors

      public void createFieldEditors()
      Creates the field editors. Field editors are abstractions of the common GUI blocks needed to manipulate various types of preferences. Each field editor knows how to save and restore itself.

    • setEnableOptions

      public void setEnableOptions()

    • init

      public void init(org.eclipse.ui.IWorkbench workbench)
      Specified by:
      init in interface org.eclipse.ui.IWorkbenchPreferencePage

    • propertyChange

      public void propertyChange(org.eclipse.jface.util.PropertyChangeEvent event)
      Specified by:
      propertyChange in interface org.eclipse.jface.util.IPropertyChangeListener
      Overrides:
      propertyChange in class org.eclipse.jface.preference.FieldEditorPreferencePage

    • performOk

      public boolean performOk()
      Specified by:
      performOk in interface org.eclipse.jface.preference.IPreferencePage
      Overrides:
      performOk in class org.eclipse.jface.preference.FieldEditorPreferencePage


RcpPreferenceConstants

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.sage.rcp.preferences

Class RcpPreferenceConstants

java.lang.Object
com.sage.rcp.preferences.RcpPreferenceConstants
public class RcpPreferenceConstants extends Object

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final String
    P_5D
    static final String
    P_6D
    static final String
    P_DEBUG
    static final String
    P_GRAPHIC_FONT
    static final String
    P_INTERNAL_DIALOGUES
    static final String
    P_MAX_WINDOWS
    static final String
    P_MINIMUM_FONTSIZE
    static final String
    P_ONLY_SHOW_TOP_WINDOW
    static final String
    P_REPORT_VERSION_AS
    static final String
    P_SAVE_WINDOW_POSITION
    static final String
    P_SHOW_BORDERS
    static final String
    P_TEXTPLANE_FONT

  • Constructor Summary

    Constructors
    Constructor
    Description
    RcpPreferenceConstants()

  • Method Summary

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Field Details

    • P_5D

      public static final String P_5D
      See Also:
      • Constant Field Values

    • P_6D

      public static final String P_6D
      See Also:
      • Constant Field Values

    • P_ONLY_SHOW_TOP_WINDOW

      public static final String P_ONLY_SHOW_TOP_WINDOW
      See Also:
      • Constant Field Values

    • P_INTERNAL_DIALOGUES

      public static final String P_INTERNAL_DIALOGUES
      See Also:
      • Constant Field Values

    • P_SHOW_BORDERS

      public static final String P_SHOW_BORDERS
      See Also:
      • Constant Field Values

    • P_MAX_WINDOWS

      public static final String P_MAX_WINDOWS
      See Also:
      • Constant Field Values

    • P_DEBUG

      public static final String P_DEBUG
      See Also:
      • Constant Field Values

    • P_REPORT_VERSION_AS

      public static final String P_REPORT_VERSION_AS
      See Also:
      • Constant Field Values

    • P_SAVE_WINDOW_POSITION

      public static final String P_SAVE_WINDOW_POSITION
      See Also:
      • Constant Field Values

    • P_TEXTPLANE_FONT

      public static final String P_TEXTPLANE_FONT
      See Also:
      • Constant Field Values

    • P_GRAPHIC_FONT

      public static final String P_GRAPHIC_FONT
      See Also:
      • Constant Field Values

    • P_MINIMUM_FONTSIZE

      public static final String P_MINIMUM_FONTSIZE
      See Also:
      • Constant Field Values

  • Constructor Details

    • RcpPreferenceConstants

      public RcpPreferenceConstants()


RcpPreferenceInitializer

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.sage.rcp.preferences

Class RcpPreferenceInitializer

java.lang.Object
org.eclipse.core.runtime.preferences.AbstractPreferenceInitializer
com.sage.rcp.preferences.RcpPreferenceInitializer
public class RcpPreferenceInitializer extends org.eclipse.core.runtime.preferences.AbstractPreferenceInitializer

  • Constructor Summary

    Constructors
    Constructor
    Description
    RcpPreferenceInitializer()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    initializeDefaultPreferences()

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • RcpPreferenceInitializer

      public RcpPreferenceInitializer()

  • Method Details

    • initializeDefaultPreferences

      public void initializeDefaultPreferences()
      Specified by:
      initializeDefaultPreferences in class org.eclipse.core.runtime.preferences.AbstractPreferenceInitializer


UiPrefManager

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.sage.rcp.preferences

Class UiPrefManager

java.lang.Object
com.sage.rcp.preferences.UiPrefManager
public class UiPrefManager extends Object

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final int
    FIVE_D
    static final int
    FOUR_D
    static final int
    SIX_D
    static final int
    THREE_D

  • Constructor Summary

    Constructors
    Constructor
    Description
    UiPrefManager()

  • Method Summary

    Modifier and Type
    Method
    Description
    static boolean
    debug()
    static int
    getLookAndFeelMnemonic()
    static boolean
    internalWindowsOnly()
    static boolean
    maximizedWindowsOnly()
    static String
    reportVersionAs()
    static void
    setReportVersionAs(String newValue)
    static boolean
    showBorders()

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Field Details

    • FIVE_D

      public static final int FIVE_D
      See Also:
      • Constant Field Values

    • FOUR_D

      public static final int FOUR_D
      See Also:
      • Constant Field Values

    • THREE_D

      public static final int THREE_D
      See Also:
      • Constant Field Values

    • SIX_D

      public static final int SIX_D
      See Also:
      • Constant Field Values

  • Constructor Details

    • UiPrefManager

      public UiPrefManager()

  • Method Details

    • getLookAndFeelMnemonic

      public static int getLookAndFeelMnemonic()

    • showBorders

      public static boolean showBorders()

    • internalWindowsOnly

      public static boolean internalWindowsOnly()

    • maximizedWindowsOnly

      public static boolean maximizedWindowsOnly()

    • debug

      public static boolean debug()

    • reportVersionAs

      public static String reportVersionAs()

    • setReportVersionAs

      public static void setReportVersionAs(String newValue)


Uses of Class com.sage.rcp.preferences.ProgramViewsPrefs

Uses of Class
com.sage.rcp.preferences.ProgramViewsPrefs

No usage of com.sage.rcp.preferences.ProgramViewsPrefs


Uses of Class com.sage.rcp.preferences.RcpPreferenceConstants

Uses of Class
com.sage.rcp.preferences.RcpPreferenceConstants

No usage of com.sage.rcp.preferences.RcpPreferenceConstants


Uses of Class com.sage.rcp.preferences.RcpPreferenceInitializer

Uses of Class
com.sage.rcp.preferences.RcpPreferenceInitializer

No usage of com.sage.rcp.preferences.RcpPreferenceInitializer


Uses of Class com.sage.rcp.preferences.UiPrefManager

Uses of Class
com.sage.rcp.preferences.UiPrefManager

No usage of com.sage.rcp.preferences.UiPrefManager


CurvesPanel

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.sage.rcp.resizeanimation

Class CurvesPanel

java.lang.Object
java.awt.Component
java.awt.Container
javax.swing.JComponent
javax.swing.JPanel
com.sage.rcp.resizeanimation.GradientPanel
com.sage.rcp.resizeanimation.CurvesPanel
All Implemented Interfaces:
ImageObserver, MenuContainer, Serializable, Accessible
public class CurvesPanel extends GradientPanel
See Also:
  • Serialized Form

  • Nested Class Summary

    Nested classes/interfaces inherited from class javax.swing.JComponent

    JComponent.AccessibleJComponent

    Nested classes/interfaces inherited from class java.awt.Component

    Component.BaselineResizeBehavior

  • Field Summary

    Fields inherited from class javax.swing.JComponent

    TOOL_TIP_TEXT_KEY, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

    Fields inherited from class java.awt.Component

    BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

    Fields inherited from interface java.awt.image.ImageObserver

    ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

  • Constructor Summary

    Constructors
    Constructor
    Description
    CurvesPanel()

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    paintComponent(Graphics g)

    Methods inherited from class com.sage.rcp.resizeanimation.GradientPanel

    getGradientEnd1, getGradientEnd2, getGradientStart1, getGradientStart2, setGradientEnd1, setGradientEnd2, setGradientStart1, setGradientStart2

    Methods inherited from class javax.swing.JPanel

    getAccessibleContext, getUI, getUIClassID, setUI, updateUI

    Methods inherited from class javax.swing.JComponent

    addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, firePropertyChange, firePropertyChange, firePropertyChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintImmediately, paintImmediately, print, printAll, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestFocus, requestFocus, requestFocusInWindow, resetKeyboardActions, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

    Methods inherited from class java.awt.Container

    add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, list, list, paintComponents, printComponents, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate

    Methods inherited from class java.awt.Component

    add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, checkImage, checkImage, contains, createImage, createImage, createVolatileImage, createVolatileImage, dispatchEvent, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, hasFocus, imageUpdate, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, list, list, list, paintAll, prepareImage, prepareImage, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, requestFocus, requestFocusInWindow, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setMixingCutoutShape, setName, setSize, setSize, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

  • Constructor Details

    • CurvesPanel

      public CurvesPanel()

  • Method Details

    • paintComponent

      public void paintComponent(Graphics g)
      Overrides:
      paintComponent in class GradientPanel


GradientPanel

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.sage.rcp.resizeanimation

Class GradientPanel

java.lang.Object
java.awt.Component
java.awt.Container
javax.swing.JComponent
javax.swing.JPanel
com.sage.rcp.resizeanimation.GradientPanel
All Implemented Interfaces:
ImageObserver, MenuContainer, Serializable, Accessible
Direct Known Subclasses:
CurvesPanel
public class GradientPanel extends JPanel
See Also:
  • Serialized Form

  • Nested Class Summary

    Nested classes/interfaces inherited from class javax.swing.JComponent

    JComponent.AccessibleJComponent

    Nested classes/interfaces inherited from class java.awt.Component

    Component.BaselineResizeBehavior

  • Field Summary

    Fields inherited from class javax.swing.JComponent

    TOOL_TIP_TEXT_KEY, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

    Fields inherited from class java.awt.Component

    BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

    Fields inherited from interface java.awt.image.ImageObserver

    ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

  • Constructor Summary

    Constructors
    Constructor
    Description
    GradientPanel()

  • Method Summary

    Modifier and Type
    Method
    Description
    Color
    getGradientEnd1()
    Color
    getGradientEnd2()
    Color
    getGradientStart1()
    Color
    getGradientStart2()
    void
    paintComponent(Graphics g)
    void
    setGradientEnd1(Color gradientEnd1)
    void
    setGradientEnd2(Color gradientEnd2)
    void
    setGradientStart1(Color gradientStart1)
    void
    setGradientStart2(Color gradientStart2)

    Methods inherited from class javax.swing.JPanel

    getAccessibleContext, getUI, getUIClassID, setUI, updateUI

    Methods inherited from class javax.swing.JComponent

    addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, firePropertyChange, firePropertyChange, firePropertyChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintImmediately, paintImmediately, print, printAll, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestFocus, requestFocus, requestFocusInWindow, resetKeyboardActions, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

    Methods inherited from class java.awt.Container

    add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, list, list, paintComponents, printComponents, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate

    Methods inherited from class java.awt.Component

    add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, checkImage, checkImage, contains, createImage, createImage, createVolatileImage, createVolatileImage, dispatchEvent, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, hasFocus, imageUpdate, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, list, list, list, paintAll, prepareImage, prepareImage, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, requestFocus, requestFocusInWindow, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setMixingCutoutShape, setName, setSize, setSize, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

  • Constructor Details

    • GradientPanel

      public GradientPanel()

  • Method Details

    • paintComponent

      public void paintComponent(Graphics g)

    • setGradientStart1

      public void setGradientStart1(Color gradientStart1)

    • getGradientStart1

      public Color getGradientStart1()

    • setGradientEnd1

      public void setGradientEnd1(Color gradientEnd1)

    • getGradientEnd1

      public Color getGradientEnd1()

    • setGradientStart2

      public void setGradientStart2(Color gradientStart2)

    • getGradientStart2

      public Color getGradientStart2()

    • setGradientEnd2

      public void setGradientEnd2(Color gradientEnd2)

    • getGradientEnd2

      public Color getGradientEnd2()


com.sage.rcp.resizeanimation

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.sage.rcp.resizeanimation

package com.sage.rcp.resizeanimation
  • Related Packages
    Package
    Description
    com.sage.rcp
    com.sage.rcp.eventmanager
    com.sage.rcp.javx
    com.sage.rcp.preferences
    com.sage.rcp.util
    com.sage.rcp.views
  • Classes
    Class
    Description
    CurvesPanel
    GradientPanel
    SizeAnimationGlassPane


com.sage.rcp.resizeanimation Class Hierarchy

Hierarchy For Package com.sage.rcp.resizeanimation

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.awt.Component (implements java.awt.image.ImageObserver, java.awt.MenuContainer, java.io.Serializable)
      • java.awt.Container
        • javax.swing.JComponent (implements java.io.Serializable)
          • javax.swing.JPanel (implements javax.accessibility.Accessible)
            • com.sage.rcp.resizeanimation.GradientPanel
              • com.sage.rcp.resizeanimation.CurvesPanel
          • com.sage.rcp.resizeanimation.SizeAnimationGlassPane


Uses of Package com.sage.rcp.resizeanimation

Uses of Package
com.sage.rcp.resizeanimation

Packages that use com.sage.rcp.resizeanimation
Package
Description
com.sage.rcp.resizeanimation
  • Classes in com.sage.rcp.resizeanimation used by com.sage.rcp.resizeanimation
    Class
    Description
    GradientPanel


SizeAnimationGlassPane

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.sage.rcp.resizeanimation

Class SizeAnimationGlassPane

java.lang.Object
java.awt.Component
java.awt.Container
javax.swing.JComponent
com.sage.rcp.resizeanimation.SizeAnimationGlassPane
All Implemented Interfaces:
ImageObserver, MenuContainer, Serializable
public class SizeAnimationGlassPane extends JComponent
See Also:
  • Serialized Form

  • Nested Class Summary

    Nested classes/interfaces inherited from class javax.swing.JComponent

    JComponent.AccessibleJComponent

    Nested classes/interfaces inherited from class java.awt.Component

    Component.BaselineResizeBehavior

  • Field Summary

    Fields inherited from class javax.swing.JComponent

    TOOL_TIP_TEXT_KEY, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

    Fields inherited from class java.awt.Component

    BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

    Fields inherited from interface java.awt.image.ImageObserver

    ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

  • Constructor Summary

    Constructors
    Constructor
    Description
    SizeAnimationGlassPane()
    SizeAnimationGlassPane(Color bgClr)

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    doCurvyPainting(Graphics g)
    void
    paintComponent(Graphics g)
    void
    updateBoarderSize(int width, int height)

    Methods inherited from class javax.swing.JComponent

    addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, firePropertyChange, firePropertyChange, firePropertyChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getUI, getUIClassID, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintImmediately, paintImmediately, print, printAll, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestFocus, requestFocus, requestFocusInWindow, resetKeyboardActions, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update, updateUI

    Methods inherited from class java.awt.Container

    add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, list, list, paintComponents, printComponents, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate

    Methods inherited from class java.awt.Component

    add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, checkImage, checkImage, contains, createImage, createImage, createVolatileImage, createVolatileImage, dispatchEvent, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getAccessibleContext, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, hasFocus, imageUpdate, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, list, list, list, paintAll, prepareImage, prepareImage, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, requestFocus, requestFocusInWindow, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setMixingCutoutShape, setName, setSize, setSize, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

  • Constructor Details

    • SizeAnimationGlassPane

      public SizeAnimationGlassPane()

    • SizeAnimationGlassPane

      public SizeAnimationGlassPane(Color bgClr)

  • Method Details

    • paintComponent

      public void paintComponent(Graphics g)

    • updateBoarderSize

      public void updateBoarderSize(int width, int height)

    • doCurvyPainting

      public void doCurvyPainting(Graphics g)


Uses of Class com.sage.rcp.resizeanimation.CurvesPanel

Uses of Class
com.sage.rcp.resizeanimation.CurvesPanel

No usage of com.sage.rcp.resizeanimation.CurvesPanel


Uses of Class com.sage.rcp.resizeanimation.GradientPanel

Uses of Class
com.sage.rcp.resizeanimation.GradientPanel

Packages that use GradientPanel
Package
Description
com.sage.rcp.resizeanimation

  • Uses of GradientPanel in com.sage.rcp.resizeanimation

    Subclasses of GradientPanel in com.sage.rcp.resizeanimation
    Modifier and Type
    Class
    Description
    class
    CurvesPanel


Uses of Class com.sage.rcp.resizeanimation.SizeAnimationGlassPane

Uses of Class
com.sage.rcp.resizeanimation.SizeAnimationGlassPane

No usage of com.sage.rcp.resizeanimation.SizeAnimationGlassPane


com.sage.rcp.util

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.sage.rcp.util

package com.sage.rcp.util
  • Related Packages
    Package
    Description
    com.sage.rcp
    com.sage.rcp.eventmanager
    com.sage.rcp.javx
    com.sage.rcp.preferences
    com.sage.rcp.resizeanimation
    com.sage.rcp.views
  • Classes
    Class
    Description
    ProgressIndicator
    PvxRcpStateFlags
    PvxUtil
    PvxUtil.ConfirmDialShower
    RunUtilProxy
    SwingProgressMonitorWrappper


com.sage.rcp.util Class Hierarchy

Hierarchy For Package com.sage.rcp.util

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.eclipse.core.runtime.NullProgressMonitor (implements org.eclipse.core.runtime.IProgressMonitor)
      • com.sage.rcp.util.SwingProgressMonitorWrappper
    • com.sage.rcp.util.ProgressIndicator
    • com.sage.rcp.util.PvxRcpStateFlags
    • com.sage.rcp.util.PvxUtil
    • com.sage.rcp.util.PvxUtil.ConfirmDialShower (implements java.lang.Runnable)
    • com.sage.rcp.util.RunUtilProxy


Uses of Package com.sage.rcp.util

Uses of Package
com.sage.rcp.util

Packages that use com.sage.rcp.util
Package
Description
com.sage.rcp.util
  • Classes in com.sage.rcp.util used by com.sage.rcp.util
    Class
    Description
    PvxRcpStateFlags


ProgressIndicator

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.sage.rcp.util

Class ProgressIndicator

java.lang.Object
com.sage.rcp.util.ProgressIndicator
public class ProgressIndicator extends Object

  • Constructor Summary

    Constructors
    Constructor
    Description
    ProgressIndicator(javxbaseui.PvxBaseWindow pvxBaseWindow)

  • Method Summary

    Modifier and Type
    Method
    Description
    String
    getCurrentMessage()
    boolean
    isCanceled()
    void
    setBusy(boolean init_isBusy)
    void
    setCanceled(boolean isCanceled)
    void
    setCurrentMessage(String currentMessage)
    void
    showProgress(String msgName, String detail, int totalWork)
    void
    updateProgress(int work)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • ProgressIndicator

      public ProgressIndicator(javxbaseui.PvxBaseWindow pvxBaseWindow)

  • Method Details

    • updateProgress

      public void updateProgress(int work)

    • showProgress

      public void showProgress(String msgName, String detail, int totalWork)

    • setBusy

      public void setBusy(boolean init_isBusy)

    • setCurrentMessage

      public void setCurrentMessage(String currentMessage)

    • getCurrentMessage

      public String getCurrentMessage()

    • setCanceled

      public void setCanceled(boolean isCanceled)

    • isCanceled

      public boolean isCanceled()


PvxRcpStateFlags

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.sage.rcp.util

Class PvxRcpStateFlags

java.lang.Object
com.sage.rcp.util.PvxRcpStateFlags
public class PvxRcpStateFlags extends Object

  • Method Summary

    Modifier and Type
    Method
    Description
    Object
    clone()
    static final boolean
    getProvideXPlugin()
    static PvxRcpStateFlags
    getSingletonObject()
    static final boolean
    setProvideXPlugin(boolean isPlugin)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Method Details

    • getSingletonObject

      public static PvxRcpStateFlags getSingletonObject()

    • clone

      public Object clone() throws CloneNotSupportedException
      Throws:
      CloneNotSupportedException

    • getProvideXPlugin

      public static final boolean getProvideXPlugin()

    • setProvideXPlugin

      public static final boolean setProvideXPlugin(boolean isPlugin)


PvxUtil

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.sage.rcp.util

Class PvxUtil

java.lang.Object
com.sage.rcp.util.PvxUtil
public class PvxUtil extends Object

  • Nested Class Summary

    Nested Classes
    Modifier and Type
    Class
    Description
    static class
    PvxUtil.ConfirmDialShower

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final int
    OS_APPLE_OSX
    static final int
    OS_LINUX
    static final int
    OS_UNIX
    static final int
    OS_WINDOWS

  • Constructor Summary

    Constructors
    Constructor
    Description
    PvxUtil()

  • Method Summary

    Modifier and Type
    Method
    Description
    static final void
    doNagUser(String nxtMessage)
    static String
    getDefaultPvxPath()
    static int
    getOperatingSystem()
    static void
    hideView(String viewId)
    static int
    initOperatingSystem()
    static final void
    log(String message, Throwable t)
    static final void
    log(Throwable t)
    static void
    setDefaultPvxPath(String exe)
    static boolean
    showConfirmDialogue(String title, String msg)
    static void
    showErrorDialogue(String title, String msg)
    static void
    showMessageDialogue(String title, String msg)
    static void
    showMessageOnStatusBar(String msg, org.eclipse.ui.IEditorPart editor)
    static void
    showMessageOnStatusBar(String msg, org.eclipse.ui.IViewPart view)
    static void
    showView(String viewId)
    static void
    writeToConsole(String msg)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Field Details

    • OS_WINDOWS

      public static final int OS_WINDOWS
      See Also:
      • Constant Field Values

    • OS_LINUX

      public static final int OS_LINUX
      See Also:
      • Constant Field Values

    • OS_UNIX

      public static final int OS_UNIX
      See Also:
      • Constant Field Values

    • OS_APPLE_OSX

      public static final int OS_APPLE_OSX
      See Also:
      • Constant Field Values

  • Constructor Details

    • PvxUtil

      public PvxUtil()

  • Method Details

    • log

      public static final void log(Throwable t)

    • doNagUser

      public static final void doNagUser(String nxtMessage)

    • log

      public static final void log(String message, Throwable t)

    • showMessageDialogue

      public static void showMessageDialogue(String title, String msg)

    • showMessageOnStatusBar

      public static void showMessageOnStatusBar(String msg, org.eclipse.ui.IViewPart view)

    • showMessageOnStatusBar

      public static void showMessageOnStatusBar(String msg, org.eclipse.ui.IEditorPart editor)

    • showConfirmDialogue

      public static boolean showConfirmDialogue(String title, String msg)

    • showErrorDialogue

      public static void showErrorDialogue(String title, String msg)

    • showView

      public static void showView(String viewId)

    • hideView

      public static void hideView(String viewId)

    • getOperatingSystem

      public static int getOperatingSystem()

    • initOperatingSystem

      public static int initOperatingSystem()

    • getDefaultPvxPath

      public static String getDefaultPvxPath()

    • setDefaultPvxPath

      public static void setDefaultPvxPath(String exe)

    • writeToConsole

      public static void writeToConsole(String msg)


PvxUtil.ConfirmDialShower

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.sage.rcp.util

Class PvxUtil.ConfirmDialShower

java.lang.Object
com.sage.rcp.util.PvxUtil.ConfirmDialShower
All Implemented Interfaces:
Runnable
Enclosing class:
PvxUtil
public static class PvxUtil.ConfirmDialShower extends Object implements Runnable

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    String
    message
    String
    title

  • Constructor Summary

    Constructors
    Constructor
    Description
    ConfirmDialShower(String initTitle, String initMessage)

  • Method Summary

    Modifier and Type
    Method
    Description
    boolean
    isDoable()
    void
    run()

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Field Details

    • title

      public String title

    • message

      public String message

  • Constructor Details

    • ConfirmDialShower

      public ConfirmDialShower(String initTitle, String initMessage)

  • Method Details

    • run

      public void run()
      Specified by:
      run in interface Runnable

    • isDoable

      public boolean isDoable()


RunUtilProxy

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.sage.rcp.util

Class RunUtilProxy

java.lang.Object
com.sage.rcp.util.RunUtilProxy
public class RunUtilProxy extends Object

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final int
    OS_APPLE_OSX
    static final int
    OS_LINUX
    static final int
    OS_UNIX
    static final int
    OS_WINDOWS

  • Constructor Summary

    Constructors
    Constructor
    Description
    RunUtilProxy()

  • Method Summary

    Modifier and Type
    Method
    Description
    static boolean
    runNtHost(String[] pvxHostArgs)
    static boolean
    runProgram(String executablePathStr, String programName, String windowState, String pvxINI, String[] arguments, boolean waitForCompletion, boolean firstTryEventManager, Properties props)

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Field Details

    • OS_WINDOWS

      public static final int OS_WINDOWS
      See Also:
      • Constant Field Values

    • OS_LINUX

      public static final int OS_LINUX
      See Also:
      • Constant Field Values

    • OS_UNIX

      public static final int OS_UNIX
      See Also:
      • Constant Field Values

    • OS_APPLE_OSX

      public static final int OS_APPLE_OSX
      See Also:
      • Constant Field Values

  • Constructor Details

    • RunUtilProxy

      public RunUtilProxy()

  • Method Details

    • runNtHost

      public static boolean runNtHost(String[] pvxHostArgs)

    • runProgram

      public static boolean runProgram(String executablePathStr, String programName, String windowState, String pvxINI, String[] arguments, boolean waitForCompletion, boolean firstTryEventManager, Properties props)


SwingProgressMonitorWrappper

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.sage.rcp.util

Class SwingProgressMonitorWrappper

java.lang.Object
org.eclipse.core.runtime.NullProgressMonitor
com.sage.rcp.util.SwingProgressMonitorWrappper
All Implemented Interfaces:
org.eclipse.core.runtime.IProgressMonitor
public class SwingProgressMonitorWrappper extends org.eclipse.core.runtime.NullProgressMonitor

  • Field Summary

    Fields inherited from interface org.eclipse.core.runtime.IProgressMonitor

    UNKNOWN

  • Constructor Summary

    Constructors
    Constructor
    Description
    SwingProgressMonitorWrappper(javxbaseui.PvxBaseWindow parentComp)

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    beginTask(String name, int totalWork)
    void
    done()
    void
    setTaskName(String name)
    void
    worked(int work)

    Methods inherited from class org.eclipse.core.runtime.NullProgressMonitor

    internalWorked, isCanceled, setCanceled, subTask

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • SwingProgressMonitorWrappper

      public SwingProgressMonitorWrappper(javxbaseui.PvxBaseWindow parentComp)

  • Method Details

    • beginTask

      public void beginTask(String name, int totalWork)
      Specified by:
      beginTask in interface org.eclipse.core.runtime.IProgressMonitor
      Overrides:
      beginTask in class org.eclipse.core.runtime.NullProgressMonitor

    • done

      public void done()
      Specified by:
      done in interface org.eclipse.core.runtime.IProgressMonitor
      Overrides:
      done in class org.eclipse.core.runtime.NullProgressMonitor

    • worked

      public void worked(int work)
      Specified by:
      worked in interface org.eclipse.core.runtime.IProgressMonitor
      Overrides:
      worked in class org.eclipse.core.runtime.NullProgressMonitor

    • setTaskName

      public void setTaskName(String name)
      Specified by:
      setTaskName in interface org.eclipse.core.runtime.IProgressMonitor
      Overrides:
      setTaskName in class org.eclipse.core.runtime.NullProgressMonitor


Uses of Class com.sage.rcp.util.ProgressIndicator

Uses of Class
com.sage.rcp.util.ProgressIndicator

No usage of com.sage.rcp.util.ProgressIndicator


Uses of Class com.sage.rcp.util.PvxRcpStateFlags

Uses of Class
com.sage.rcp.util.PvxRcpStateFlags

Packages that use PvxRcpStateFlags
Package
Description
com.sage.rcp.util

  • Uses of PvxRcpStateFlags in com.sage.rcp.util

    Methods in com.sage.rcp.util that return PvxRcpStateFlags
    Modifier and Type
    Method
    Description
    static PvxRcpStateFlags
    PvxRcpStateFlags.getSingletonObject()


Uses of Class com.sage.rcp.util.PvxUtil

Uses of Class
com.sage.rcp.util.PvxUtil

No usage of com.sage.rcp.util.PvxUtil


Uses of Class com.sage.rcp.util.PvxUtil.ConfirmDialShower

Uses of Class
com.sage.rcp.util.PvxUtil.ConfirmDialShower

No usage of com.sage.rcp.util.PvxUtil.ConfirmDialShower


Uses of Class com.sage.rcp.util.RunUtilProxy

Uses of Class
com.sage.rcp.util.RunUtilProxy

No usage of com.sage.rcp.util.RunUtilProxy


Uses of Class com.sage.rcp.util.SwingProgressMonitorWrappper

Uses of Class
com.sage.rcp.util.SwingProgressMonitorWrappper

No usage of com.sage.rcp.util.SwingProgressMonitorWrappper


HostActionsView

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.sage.rcp.views

Class HostActionsView

java.lang.Object
org.eclipse.core.commands.common.EventManager
org.eclipse.ui.part.WorkbenchPart
org.eclipse.ui.part.ViewPart
com.sage.rcp.views.HostActionsView
All Implemented Interfaces:
IEmbeddedJavXView, javxbaseui.AbstractGUIManagerFactory, org.eclipse.core.runtime.IAdaptable, org.eclipse.core.runtime.IExecutableExtension, org.eclipse.ui.IPersistable, org.eclipse.ui.IViewPart, org.eclipse.ui.IWorkbenchPart, org.eclipse.ui.IWorkbenchPart2, org.eclipse.ui.IWorkbenchPart3, org.eclipse.ui.part.IWorkbenchPartOrientation
Direct Known Subclasses:
WinDefine
public class HostActionsView extends org.eclipse.ui.part.ViewPart implements IEmbeddedJavXView, javxbaseui.AbstractGUIManagerFactory

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final String
    ID

    Fields inherited from interface org.eclipse.ui.IWorkbenchPart

    PROP_TITLE

  • Constructor Summary

    Constructors
    Constructor
    Description
    HostActionsView()

  • Method Summary

    Modifier and Type
    Method
    Description
    static void
    addJavX(Component comp)
    void
    createPartControl(org.eclipse.swt.widgets.Composite parent)
    org.eclipse.ui.IActionBars
    getActionBars()
    String
    getArgsStr()
    org.eclipse.swt.graphics.Color
    getCompositeColor()
    org.eclipse.ui.IViewSite
    getIViewSite()
    javxbaseui.GUIManagerI
    makeGUIManager(javxclientcontrol.PvxHost arg0)
    void
    notifyConnected()
    void
    setActionBars(org.eclipse.ui.IActionBars init_bars)
    void
    setCompositeColor(org.eclipse.swt.graphics.Color compositeColor)
    void
    setFocus()
    static void
    setJavXVisible(boolean vis)
    void
    setViewSite(org.eclipse.ui.IViewSite site)
    static void
    startJavX(int socket)

    Methods inherited from class org.eclipse.ui.part.ViewPart

    getViewSite, init, init, saveState, setInitializationData

    Methods inherited from class org.eclipse.ui.part.WorkbenchPart

    addPartPropertyListener, addPropertyListener, dispose, getAdapter, getContentDescription, getOrientation, getPartName, getPartProperties, getPartProperty, getSite, getTitle, getTitleImage, getTitleToolTip, removePartPropertyListener, removePropertyListener, setPartProperty, showBusy

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface org.eclipse.core.runtime.IAdaptable

    getAdapter

    Methods inherited from interface org.eclipse.ui.IWorkbenchPart

    addPropertyListener, dispose, getSite, getTitle, getTitleImage, getTitleToolTip, removePropertyListener

  • Field Details

    • ID

      public static final String ID
      See Also:
      • Constant Field Values

  • Constructor Details

    • HostActionsView

      public HostActionsView()

  • Method Details

    • setJavXVisible

      public static void setJavXVisible(boolean vis)

    • createPartControl

      public void createPartControl(org.eclipse.swt.widgets.Composite parent)
      Specified by:
      createPartControl in interface org.eclipse.ui.IWorkbenchPart
      Specified by:
      createPartControl in class org.eclipse.ui.part.WorkbenchPart

    • startJavX

      public static void startJavX(int socket)

    • addJavX

      public static void addJavX(Component comp)

    • setFocus

      public void setFocus()
      Specified by:
      setFocus in interface org.eclipse.ui.IWorkbenchPart
      Specified by:
      setFocus in class org.eclipse.ui.part.WorkbenchPart

    • getArgsStr

      public String getArgsStr()
      Specified by:
      getArgsStr in interface IEmbeddedJavXView

    • getActionBars

      public org.eclipse.ui.IActionBars getActionBars()
      Specified by:
      getActionBars in interface IEmbeddedJavXView

    • setActionBars

      public void setActionBars(org.eclipse.ui.IActionBars init_bars)
      Specified by:
      setActionBars in interface IEmbeddedJavXView

    • getIViewSite

      public org.eclipse.ui.IViewSite getIViewSite()
      Specified by:
      getIViewSite in interface IEmbeddedJavXView

    • setViewSite

      public void setViewSite(org.eclipse.ui.IViewSite site)
      Specified by:
      setViewSite in interface IEmbeddedJavXView

    • makeGUIManager

      public javxbaseui.GUIManagerI makeGUIManager(javxclientcontrol.PvxHost arg0) throws Exception
      Specified by:
      makeGUIManager in interface javxbaseui.AbstractGUIManagerFactory
      Throws:
      Exception

    • notifyConnected

      public void notifyConnected()

    • setCompositeColor

      public void setCompositeColor(org.eclipse.swt.graphics.Color compositeColor)

    • getCompositeColor

      public org.eclipse.swt.graphics.Color getCompositeColor()
      Specified by:
      getCompositeColor in interface IEmbeddedJavXView


JavXThread

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.sage.rcp.views

Class JavXThread

java.lang.Object
java.lang.Thread
com.sage.rcp.views.JavXThread
All Implemented Interfaces:
Runnable
public class JavXThread extends Thread

  • Nested Class Summary

    Nested classes/interfaces inherited from class java.lang.Thread

    Thread.State, Thread.UncaughtExceptionHandler

  • Field Summary

    Fields inherited from class java.lang.Thread

    MAX_PRIORITY, MIN_PRIORITY, NORM_PRIORITY

  • Constructor Summary

    Constructors
    Constructor
    Description
    JavXThread(RcpEmbedJavXView rcpEmbedJavXView, RcpEmbedJavXView embedRCpLauncherJavXView)

  • Method Summary

    Modifier and Type
    Method
    Description
    static Hashtable<String,RcpSwtViewPanel>
    getActiveFrames()
    void
    run()

    Methods inherited from class java.lang.Thread

    activeCount, currentThread, dumpStack, enumerate, getAllStackTraces, getContextClassLoader, getDefaultUncaughtExceptionHandler, getId, getName, getPriority, getStackTrace, getState, getThreadGroup, getUncaughtExceptionHandler, holdsLock, interrupt, interrupted, isAlive, isDaemon, isInterrupted, join, join, join, onSpinWait, setContextClassLoader, setDaemon, setDefaultUncaughtExceptionHandler, setName, setPriority, setUncaughtExceptionHandler, sleep, sleep, start, toString, yield

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

  • Constructor Details

    • JavXThread

      public JavXThread(RcpEmbedJavXView rcpEmbedJavXView, RcpEmbedJavXView embedRCpLauncherJavXView)

  • Method Details

    • run

      public void run()
      Specified by:
      run in interface Runnable
      Overrides:
      run in class Thread

    • getActiveFrames

      public static Hashtable<String,RcpSwtViewPanel> getActiveFrames()


com.sage.rcp.views

  • Package:
  • Description |
  • Related Packages |
  • Classes and Interfaces

Package com.sage.rcp.views

package com.sage.rcp.views
  • Related Packages
    Package
    Description
    com.sage.rcp
    com.sage.rcp.eventmanager
    com.sage.rcp.javx
    com.sage.rcp.preferences
    com.sage.rcp.resizeanimation
    com.sage.rcp.util
  • Classes
    Class
    Description
    HostActionsView
    JavXThread
    RcpEmbedJavXView
    RcpMasProgramView
    RcpProgramView
    RcpPvxAction
    RcpSpawnedMasProgramView


com.sage.rcp.views Class Hierarchy

Hierarchy For Package com.sage.rcp.views

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.eclipse.core.commands.common.EventManager
      • org.eclipse.jface.action.AbstractAction (implements org.eclipse.jface.action.IAction)
        • org.eclipse.jface.action.Action
          • com.sage.rcp.views.RcpPvxAction
      • org.eclipse.ui.part.WorkbenchPart (implements org.eclipse.core.runtime.IExecutableExtension, org.eclipse.ui.IWorkbenchPart3, org.eclipse.ui.part.IWorkbenchPartOrientation)
        • org.eclipse.ui.part.ViewPart (implements org.eclipse.ui.IViewPart)
          • com.sage.rcp.views.HostActionsView (implements javxbaseui.AbstractGUIManagerFactory, com.sage.rcp.javx.IEmbeddedJavXView)
          • com.sage.rcp.views.RcpEmbedJavXView (implements javxbaseui.AbstractGUIManagerFactory, com.sage.rcp.javx.IEmbeddedJavXView)
            • com.sage.rcp.views.RcpProgramView
              • com.sage.rcp.views.RcpMasProgramView
                • com.sage.rcp.views.RcpSpawnedMasProgramView
    • java.lang.Thread (implements java.lang.Runnable)
      • com.sage.rcp.views.JavXThread


Uses of Package com.sage.rcp.views

Uses of Package
com.sage.rcp.views

Packages that use com.sage.rcp.views
Package
Description
com.pvx.ooadide.views
com.sage.rcp.javx
com.sage.rcp.javx.windows
com.sage.rcp.views
  • Classes in com.sage.rcp.views used by com.pvx.ooadide.views
    Class
    Description
    HostActionsView
  • Classes in com.sage.rcp.views used by com.sage.rcp.javx
    Class
    Description
    RcpEmbedJavXView
  • Classes in com.sage.rcp.views used by com.sage.rcp.javx.windows
    Class
    Description
    RcpEmbedJavXView
  • Classes in com.sage.rcp.views used by com.sage.rcp.views
    Class
    Description
    RcpEmbedJavXView
    RcpMasProgramView
    RcpProgramView


RcpEmbedJavXView

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.sage.rcp.views

Class RcpEmbedJavXView

java.lang.Object
org.eclipse.core.commands.common.EventManager
org.eclipse.ui.part.WorkbenchPart
org.eclipse.ui.part.ViewPart
com.sage.rcp.views.RcpEmbedJavXView
All Implemented Interfaces:
IEmbeddedJavXView, javxbaseui.AbstractGUIManagerFactory, org.eclipse.core.runtime.IAdaptable, org.eclipse.core.runtime.IExecutableExtension, org.eclipse.ui.IPersistable, org.eclipse.ui.IViewPart, org.eclipse.ui.IWorkbenchPart, org.eclipse.ui.IWorkbenchPart2, org.eclipse.ui.IWorkbenchPart3, org.eclipse.ui.part.IWorkbenchPartOrientation
Direct Known Subclasses:
RcpProgramView
public class RcpEmbedJavXView extends org.eclipse.ui.part.ViewPart implements IEmbeddedJavXView, javxbaseui.AbstractGUIManagerFactory

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static String
    argsStr
    org.eclipse.ui.IActionBars
    bars
    static final int
    DISPLAY_MIN_HEIGHT
    static final int
    DISPLAY_MIN_WIDTH
    static int
    height
    static final String
    ID
    static int
    instanceCtr
    RcpSwtViewPanel
    panel
    static String
    SECND_ID_KEY
    org.eclipse.ui.IViewSite
    viewSite
    static int
    width

    Fields inherited from interface org.eclipse.ui.IWorkbenchPart

    PROP_TITLE

  • Constructor Summary

    Constructors
    Constructor
    Description
    RcpEmbedJavXView()
    The constructor.

  • Method Summary

    Modifier and Type
    Method
    Description
    static void
    argsAppendAppearanceFonts(StringBuffer buf)
    void
    createPartControl(org.eclipse.swt.widgets.Composite parent)
    This is a callback that will allow us to create the viewer and initialize it.
    void
    dispose()
    void
    doInternalBorderChange(boolean showBorder)
    void
    endJavXSession()
    org.eclipse.ui.IActionBars
    getActionBars()
    String
    getArgsStr()
    org.eclipse.swt.widgets.Composite
    getComposite()
    org.eclipse.swt.graphics.Color
    getCompositeColor()
    String
    getID()
    org.eclipse.ui.IViewSite
    getIViewSite()
    static String
    getNextInstId()
    org.eclipse.swt.widgets.Composite
    getParent()
    String
    getPvxTrackingKey()
    void
    hideView(RcpEmbedJavXView targetView)
    void
    initializeHost()
    String
    initStatusMessage()
    boolean
    isBorderIsVisible()
    boolean
    isResizeControlsEnabled()
    boolean
    isRunning()
    javxbaseui.GUIManagerI
    makeGUIManager(javxclientcontrol.PvxHost arg0)
    void
    requestJavXFocus()
    void
    runJavX()
    void
    setActionBars(org.eclipse.ui.IActionBars init_bars)
    void
    setArgsStr(String argsStr)
    void
    setBorderIsVisible(boolean borderIsVisible)
    void
    setCompositeColor(org.eclipse.swt.graphics.Color compositeColor)
    void
    setFocus()
    void
    setJavXTabTitle(String aTitle)
    void
    setResizeControlsEnabled(boolean b)
    void
    setScaleValue(int value)
    void
    setViewSite(org.eclipse.ui.IViewSite site)
    boolean
    shouldAddToView()

    Methods inherited from class org.eclipse.ui.part.ViewPart

    getViewSite, init, init, saveState, setInitializationData

    Methods inherited from class org.eclipse.ui.part.WorkbenchPart

    addPartPropertyListener, addPropertyListener, getAdapter, getContentDescription, getOrientation, getPartName, getPartProperties, getPartProperty, getSite, getTitle, getTitleImage, getTitleToolTip, removePartPropertyListener, removePropertyListener, setPartProperty, showBusy

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface org.eclipse.core.runtime.IAdaptable

    getAdapter

    Methods inherited from interface org.eclipse.ui.IWorkbenchPart

    addPropertyListener, getSite, getTitle, getTitleImage, getTitleToolTip, removePropertyListener

  • Field Details

    • ID

      public static final String ID
      See Also:
      • Constant Field Values

    • argsStr

      public static String argsStr

    • bars

      public org.eclipse.ui.IActionBars bars

    • viewSite

      public org.eclipse.ui.IViewSite viewSite

    • DISPLAY_MIN_WIDTH

      public static final int DISPLAY_MIN_WIDTH
      See Also:
      • Constant Field Values

    • DISPLAY_MIN_HEIGHT

      public static final int DISPLAY_MIN_HEIGHT
      See Also:
      • Constant Field Values

    • width

      public static int width

    • height

      public static int height

    • panel

      public RcpSwtViewPanel panel

    • instanceCtr

      public static int instanceCtr

    • SECND_ID_KEY

      public static String SECND_ID_KEY

  • Constructor Details

    • RcpEmbedJavXView

      public RcpEmbedJavXView()
      The constructor.

  • Method Details

    • getNextInstId

      public static String getNextInstId()

    • getID

      public String getID()

    • getPvxTrackingKey

      public String getPvxTrackingKey()

    • dispose

      public void dispose()
      Specified by:
      dispose in interface org.eclipse.ui.IWorkbenchPart
      Overrides:
      dispose in class org.eclipse.ui.part.WorkbenchPart

    • endJavXSession

      public void endJavXSession()

    • makeGUIManager

      public javxbaseui.GUIManagerI makeGUIManager(javxclientcontrol.PvxHost arg0) throws Exception
      Specified by:
      makeGUIManager in interface javxbaseui.AbstractGUIManagerFactory
      Throws:
      Exception

    • createPartControl

      public void createPartControl(org.eclipse.swt.widgets.Composite parent)
      This is a callback that will allow us to create the viewer and initialize it.
      Specified by:
      createPartControl in interface org.eclipse.ui.IWorkbenchPart
      Specified by:
      createPartControl in class org.eclipse.ui.part.WorkbenchPart

    • doInternalBorderChange

      public void doInternalBorderChange(boolean showBorder)

    • runJavX

      public void runJavX()

    • shouldAddToView

      public boolean shouldAddToView()

    • hideView

      public void hideView(RcpEmbedJavXView targetView)

    • initializeHost

      public void initializeHost()

    • argsAppendAppearanceFonts

      public static void argsAppendAppearanceFonts(StringBuffer buf)

    • setArgsStr

      public void setArgsStr(String argsStr)

    • getArgsStr

      public String getArgsStr()
      Specified by:
      getArgsStr in interface IEmbeddedJavXView

    • getActionBars

      public org.eclipse.ui.IActionBars getActionBars()
      Specified by:
      getActionBars in interface IEmbeddedJavXView

    • setActionBars

      public void setActionBars(org.eclipse.ui.IActionBars init_bars)
      Specified by:
      setActionBars in interface IEmbeddedJavXView

    • getIViewSite

      public org.eclipse.ui.IViewSite getIViewSite()
      Specified by:
      getIViewSite in interface IEmbeddedJavXView

    • setViewSite

      public void setViewSite(org.eclipse.ui.IViewSite site)
      Specified by:
      setViewSite in interface IEmbeddedJavXView

    • setJavXTabTitle

      public void setJavXTabTitle(String aTitle)

    • initStatusMessage

      public String initStatusMessage()

    • getComposite

      public org.eclipse.swt.widgets.Composite getComposite()

    • getParent

      public org.eclipse.swt.widgets.Composite getParent()

    • isRunning

      public boolean isRunning()

    • setCompositeColor

      public void setCompositeColor(org.eclipse.swt.graphics.Color compositeColor)

    • getCompositeColor

      public org.eclipse.swt.graphics.Color getCompositeColor()
      Specified by:
      getCompositeColor in interface IEmbeddedJavXView

    • setScaleValue

      public void setScaleValue(int value)

    • isResizeControlsEnabled

      public boolean isResizeControlsEnabled()

    • setResizeControlsEnabled

      public void setResizeControlsEnabled(boolean b)

    • setBorderIsVisible

      public void setBorderIsVisible(boolean borderIsVisible)

    • isBorderIsVisible

      public boolean isBorderIsVisible()

    • requestJavXFocus

      public void requestJavXFocus()

    • setFocus

      public void setFocus()
      Specified by:
      setFocus in interface org.eclipse.ui.IWorkbenchPart
      Specified by:
      setFocus in class org.eclipse.ui.part.WorkbenchPart


RcpMasProgramView

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.sage.rcp.views

Class RcpMasProgramView

java.lang.Object
org.eclipse.core.commands.common.EventManager
org.eclipse.ui.part.WorkbenchPart
org.eclipse.ui.part.ViewPart
com.sage.rcp.views.RcpEmbedJavXView
com.sage.rcp.views.RcpProgramView
com.sage.rcp.views.RcpMasProgramView
All Implemented Interfaces:
IEmbeddedJavXView, javxbaseui.AbstractGUIManagerFactory, org.eclipse.core.runtime.IAdaptable, org.eclipse.core.runtime.IExecutableExtension, org.eclipse.ui.IPersistable, org.eclipse.ui.IViewPart, org.eclipse.ui.IWorkbenchPart, org.eclipse.ui.IWorkbenchPart2, org.eclipse.ui.IWorkbenchPart3, org.eclipse.ui.part.IWorkbenchPartOrientation
Direct Known Subclasses:
RcpSpawnedMasProgramView
public class RcpMasProgramView extends RcpProgramView

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final String
    ID

    Fields inherited from class com.sage.rcp.views.RcpProgramView

    actionText, JAVX_ARGS_STRING, program

    Fields inherited from class com.sage.rcp.views.RcpEmbedJavXView

    argsStr, bars, DISPLAY_MIN_HEIGHT, DISPLAY_MIN_WIDTH, height, instanceCtr, panel, SECND_ID_KEY, viewSite, width

    Fields inherited from interface org.eclipse.ui.IWorkbenchPart

    PROP_TITLE

  • Constructor Summary

    Constructors
    Constructor
    Description
    RcpMasProgramView()

  • Method Summary

    Modifier and Type
    Method
    Description
    String
    getID()
    void
    initializeHost()

    Methods inherited from class com.sage.rcp.views.RcpProgramView

    addCallToArgs, createPartControl, getActionText, getActionTip, getArgsStr, getCallArgs, init, peekCallArgs, saveState

    Methods inherited from class com.sage.rcp.views.RcpEmbedJavXView

    argsAppendAppearanceFonts, dispose, doInternalBorderChange, endJavXSession, getActionBars, getComposite, getCompositeColor, getIViewSite, getNextInstId, getParent, getPvxTrackingKey, hideView, initStatusMessage, isBorderIsVisible, isResizeControlsEnabled, isRunning, makeGUIManager, requestJavXFocus, runJavX, setActionBars, setArgsStr, setBorderIsVisible, setCompositeColor, setFocus, setJavXTabTitle, setResizeControlsEnabled, setScaleValue, setViewSite, shouldAddToView

    Methods inherited from class org.eclipse.ui.part.ViewPart

    getViewSite, init, setInitializationData

    Methods inherited from class org.eclipse.ui.part.WorkbenchPart

    addPartPropertyListener, addPropertyListener, getAdapter, getContentDescription, getOrientation, getPartName, getPartProperties, getPartProperty, getSite, getTitle, getTitleImage, getTitleToolTip, removePartPropertyListener, removePropertyListener, setPartProperty, showBusy

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface org.eclipse.core.runtime.IAdaptable

    getAdapter

    Methods inherited from interface org.eclipse.ui.IWorkbenchPart

    addPropertyListener, getSite, getTitle, getTitleImage, getTitleToolTip, removePropertyListener

  • Field Details

    • ID

      public static final String ID
      See Also:
      • Constant Field Values

  • Constructor Details

    • RcpMasProgramView

      public RcpMasProgramView()

  • Method Details

    • initializeHost

      public void initializeHost()
      Overrides:
      initializeHost in class RcpProgramView

    • getID

      public String getID()
      Overrides:
      getID in class RcpProgramView


RcpProgramView

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.sage.rcp.views

Class RcpProgramView

java.lang.Object
org.eclipse.core.commands.common.EventManager
org.eclipse.ui.part.WorkbenchPart
org.eclipse.ui.part.ViewPart
com.sage.rcp.views.RcpEmbedJavXView
com.sage.rcp.views.RcpProgramView
All Implemented Interfaces:
IEmbeddedJavXView, javxbaseui.AbstractGUIManagerFactory, org.eclipse.core.runtime.IAdaptable, org.eclipse.core.runtime.IExecutableExtension, org.eclipse.ui.IPersistable, org.eclipse.ui.IViewPart, org.eclipse.ui.IWorkbenchPart, org.eclipse.ui.IWorkbenchPart2, org.eclipse.ui.IWorkbenchPart3, org.eclipse.ui.part.IWorkbenchPartOrientation
Direct Known Subclasses:
RcpMasProgramView
public class RcpProgramView extends RcpEmbedJavXView

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    String
    actionText
    static final String
    ID
    static final String
    JAVX_ARGS_STRING
    String
    program

    Fields inherited from class com.sage.rcp.views.RcpEmbedJavXView

    argsStr, bars, DISPLAY_MIN_HEIGHT, DISPLAY_MIN_WIDTH, height, instanceCtr, panel, SECND_ID_KEY, viewSite, width

    Fields inherited from interface org.eclipse.ui.IWorkbenchPart

    PROP_TITLE

  • Constructor Summary

    Constructors
    Constructor
    Description
    RcpProgramView()

  • Method Summary

    Modifier and Type
    Method
    Description
    static void
    addCallToArgs(Hashtable params)
    void
    createPartControl(org.eclipse.swt.widgets.Composite parent)
    This is a callback that will allow us to create the viewer and initialize it.
    String
    getActionText()
    String
    getActionTip()
    String
    getArgsStr()
    static Hashtable
    getCallArgs()
    String
    getID()
    void
    init(org.eclipse.ui.IViewSite site, org.eclipse.ui.IMemento memento)
    void
    initializeHost()
    static Hashtable
    peekCallArgs()
    void
    saveState(org.eclipse.ui.IMemento memento)

    Methods inherited from class com.sage.rcp.views.RcpEmbedJavXView

    argsAppendAppearanceFonts, dispose, doInternalBorderChange, endJavXSession, getActionBars, getComposite, getCompositeColor, getIViewSite, getNextInstId, getParent, getPvxTrackingKey, hideView, initStatusMessage, isBorderIsVisible, isResizeControlsEnabled, isRunning, makeGUIManager, requestJavXFocus, runJavX, setActionBars, setArgsStr, setBorderIsVisible, setCompositeColor, setFocus, setJavXTabTitle, setResizeControlsEnabled, setScaleValue, setViewSite, shouldAddToView

    Methods inherited from class org.eclipse.ui.part.ViewPart

    getViewSite, init, setInitializationData

    Methods inherited from class org.eclipse.ui.part.WorkbenchPart

    addPartPropertyListener, addPropertyListener, getAdapter, getContentDescription, getOrientation, getPartName, getPartProperties, getPartProperty, getSite, getTitle, getTitleImage, getTitleToolTip, removePartPropertyListener, removePropertyListener, setPartProperty, showBusy

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface org.eclipse.core.runtime.IAdaptable

    getAdapter

    Methods inherited from interface org.eclipse.ui.IWorkbenchPart

    addPropertyListener, getSite, getTitle, getTitleImage, getTitleToolTip, removePropertyListener

  • Field Details

    • ID

      public static final String ID
      See Also:
      • Constant Field Values

    • actionText

      public String actionText

    • program

      public String program

    • JAVX_ARGS_STRING

      public static final String JAVX_ARGS_STRING
      See Also:
      • Constant Field Values

  • Constructor Details

    • RcpProgramView

      public RcpProgramView()

  • Method Details

    • addCallToArgs

      public static void addCallToArgs(Hashtable params)

    • peekCallArgs

      public static Hashtable peekCallArgs()

    • getCallArgs

      public static Hashtable getCallArgs()

    • getActionText

      public String getActionText()

    • getActionTip

      public String getActionTip()

    • getArgsStr

      public String getArgsStr()
      Specified by:
      getArgsStr in interface IEmbeddedJavXView
      Overrides:
      getArgsStr in class RcpEmbedJavXView

    • initializeHost

      public void initializeHost()
      Overrides:
      initializeHost in class RcpEmbedJavXView

    • saveState

      public void saveState(org.eclipse.ui.IMemento memento)
      Specified by:
      saveState in interface org.eclipse.ui.IPersistable
      Specified by:
      saveState in interface org.eclipse.ui.IViewPart
      Overrides:
      saveState in class org.eclipse.ui.part.ViewPart

    • init

      public void init(org.eclipse.ui.IViewSite site, org.eclipse.ui.IMemento memento) throws org.eclipse.ui.PartInitException
      Specified by:
      init in interface org.eclipse.ui.IViewPart
      Overrides:
      init in class org.eclipse.ui.part.ViewPart
      Throws:
      org.eclipse.ui.PartInitException

    • createPartControl

      public void createPartControl(org.eclipse.swt.widgets.Composite parent)
      Description copied from class: RcpEmbedJavXView
      This is a callback that will allow us to create the viewer and initialize it.
      Specified by:
      createPartControl in interface org.eclipse.ui.IWorkbenchPart
      Overrides:
      createPartControl in class RcpEmbedJavXView

    • getID

      public String getID()
      Overrides:
      getID in class RcpEmbedJavXView


RcpPvxAction

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.sage.rcp.views

Class RcpPvxAction

java.lang.Object
org.eclipse.core.commands.common.EventManager
org.eclipse.jface.action.AbstractAction
org.eclipse.jface.action.Action
com.sage.rcp.views.RcpPvxAction
All Implemented Interfaces:
org.eclipse.jface.action.IAction
public class RcpPvxAction extends org.eclipse.jface.action.Action

  • Field Summary

    Fields inherited from interface org.eclipse.jface.action.IAction

    AS_CHECK_BOX, AS_DROP_DOWN_MENU, AS_PUSH_BUTTON, AS_RADIO_BUTTON, AS_UNSPECIFIED, CHECKED, DESCRIPTION, ENABLED, HANDLED, IMAGE, RESULT, TEXT, TOOL_TIP_TEXT

  • Constructor Summary

    Constructors
    Constructor
    Description
    RcpPvxAction(RcpPluginSwingGUIManager rcpPluginSwingGUIManager, int ctl)

  • Method Summary

    Modifier and Type
    Method
    Description
    void
    run()

    Methods inherited from class org.eclipse.jface.action.Action

    convertAccelerator, convertAccelerator, findKeyCode, findKeyString, findModifier, findModifierString, getAccelerator, getActionDefinitionId, getDescription, getDisabledImageDescriptor, getHelpListener, getHoverImageDescriptor, getId, getImageDescriptor, getMenuCreator, getStyle, getText, getToolTipText, isChecked, isEnabled, isHandled, notifyResult, removeAcceleratorText, removeMnemonics, runWithEvent, setAccelerator, setActionDefinitionId, setChecked, setDescription, setDisabledImageDescriptor, setEnabled, setHelpListener, setHoverImageDescriptor, setId, setImageDescriptor, setMenuCreator, setText, setToolTipText

    Methods inherited from class org.eclipse.jface.action.AbstractAction

    addPropertyChangeListener, removePropertyChangeListener

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

  • Constructor Details

    • RcpPvxAction

      public RcpPvxAction(RcpPluginSwingGUIManager rcpPluginSwingGUIManager, int ctl)

  • Method Details

    • run

      public void run()
      Specified by:
      run in interface org.eclipse.jface.action.IAction
      Overrides:
      run in class org.eclipse.jface.action.Action


RcpSpawnedMasProgramView

  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
Package com.sage.rcp.views

Class RcpSpawnedMasProgramView

java.lang.Object
org.eclipse.core.commands.common.EventManager
org.eclipse.ui.part.WorkbenchPart
org.eclipse.ui.part.ViewPart
com.sage.rcp.views.RcpEmbedJavXView
com.sage.rcp.views.RcpProgramView
com.sage.rcp.views.RcpMasProgramView
com.sage.rcp.views.RcpSpawnedMasProgramView
All Implemented Interfaces:
IEmbeddedJavXView, javxbaseui.AbstractGUIManagerFactory, org.eclipse.core.runtime.IAdaptable, org.eclipse.core.runtime.IExecutableExtension, org.eclipse.ui.IPersistable, org.eclipse.ui.IViewPart, org.eclipse.ui.IWorkbenchPart, org.eclipse.ui.IWorkbenchPart2, org.eclipse.ui.IWorkbenchPart3, org.eclipse.ui.part.IWorkbenchPartOrientation
public class RcpSpawnedMasProgramView extends RcpMasProgramView

  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final String
    ID

    Fields inherited from class com.sage.rcp.views.RcpProgramView

    actionText, JAVX_ARGS_STRING, program

    Fields inherited from class com.sage.rcp.views.RcpEmbedJavXView

    argsStr, bars, DISPLAY_MIN_HEIGHT, DISPLAY_MIN_WIDTH, height, instanceCtr, panel, SECND_ID_KEY, viewSite, width

    Fields inherited from interface org.eclipse.ui.IWorkbenchPart

    PROP_TITLE

  • Constructor Summary

    Constructors
    Constructor
    Description
    RcpSpawnedMasProgramView()

  • Method Summary

    Modifier and Type
    Method
    Description
    String
    getArgsStr()
    String
    getID()
    String
    initStatusMessage()

    Methods inherited from class com.sage.rcp.views.RcpMasProgramView

    initializeHost

    Methods inherited from class com.sage.rcp.views.RcpProgramView

    addCallToArgs, createPartControl, getActionText, getActionTip, getCallArgs, init, peekCallArgs, saveState

    Methods inherited from class com.sage.rcp.views.RcpEmbedJavXView

    argsAppendAppearanceFonts, dispose, doInternalBorderChange, endJavXSession, getActionBars, getComposite, getCompositeColor, getIViewSite, getNextInstId, getParent, getPvxTrackingKey, hideView, isBorderIsVisible, isResizeControlsEnabled, isRunning, makeGUIManager, requestJavXFocus, runJavX, setActionBars, setArgsStr, setBorderIsVisible, setCompositeColor, setFocus, setJavXTabTitle, setResizeControlsEnabled, setScaleValue, setViewSite, shouldAddToView

    Methods inherited from class org.eclipse.ui.part.ViewPart

    getViewSite, init, setInitializationData

    Methods inherited from class org.eclipse.ui.part.WorkbenchPart

    addPartPropertyListener, addPropertyListener, getAdapter, getContentDescription, getOrientation, getPartName, getPartProperties, getPartProperty, getSite, getTitle, getTitleImage, getTitleToolTip, removePartPropertyListener, removePropertyListener, setPartProperty, showBusy

    Methods inherited from class java.lang.Object

    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Methods inherited from interface org.eclipse.core.runtime.IAdaptable

    getAdapter

    Methods inherited from interface org.eclipse.ui.IWorkbenchPart

    addPropertyListener, getSite, getTitle, getTitleImage, getTitleToolTip, removePropertyListener

  • Field Details

    • ID

      public static final String ID
      See Also:
      • Constant Field Values

  • Constructor Details

    • RcpSpawnedMasProgramView

      public RcpSpawnedMasProgramView()

  • Method Details

    • getArgsStr

      public String getArgsStr()
      Specified by:
      getArgsStr in interface IEmbeddedJavXView
      Overrides:
      getArgsStr in class RcpProgramView

    • initStatusMessage

      public String initStatusMessage()
      Overrides:
      initStatusMessage in class RcpEmbedJavXView

    • getID

      public String getID()
      Overrides:
      getID in class RcpMasProgramView


Uses of Class com.sage.rcp.views.HostActionsView

Uses of Class
com.sage.rcp.views.HostActionsView

Packages that use HostActionsView
Package
Description
com.pvx.ooadide.views

  • Uses of HostActionsView in com.pvx.ooadide.views

    Subclasses of HostActionsView in com.pvx.ooadide.views
    Modifier and Type
    Class
    Description
    class
    WinDefine


Uses of Class com.sage.rcp.views.JavXThread

Uses of Class
com.sage.rcp.views.JavXThread

No usage of com.sage.rcp.views.JavXThread


Uses of Class com.sage.rcp.views.RcpEmbedJavXView

Uses of Class
com.sage.rcp.views.RcpEmbedJavXView

Packages that use RcpEmbedJavXView
Package
Description
com.sage.rcp.javx
com.sage.rcp.javx.windows
com.sage.rcp.views

  • Uses of RcpEmbedJavXView in com.sage.rcp.javx

    Methods in com.sage.rcp.javx that return RcpEmbedJavXView
    Modifier and Type
    Method
    Description
    RcpEmbedJavXView
    RcpSwtViewPanel.getView()
    Methods in com.sage.rcp.javx with parameters of type RcpEmbedJavXView
    Modifier and Type
    Method
    Description
    void
    RcpSwtViewPanel.setView(RcpEmbedJavXView view)
    Constructors in com.sage.rcp.javx with parameters of type RcpEmbedJavXView
    Modifier
    Constructor
    Description

    RcpSwtViewPanel(RcpEmbedJavXView embedJavXView)

  • Uses of RcpEmbedJavXView in com.sage.rcp.javx.windows

    Methods in com.sage.rcp.javx.windows that return RcpEmbedJavXView
    Modifier and Type
    Method
    Description
    RcpEmbedJavXView
    PluginTextPlaneView.getTopRcpView()

  • Uses of RcpEmbedJavXView in com.sage.rcp.views

    Subclasses of RcpEmbedJavXView in com.sage.rcp.views
    Modifier and Type
    Class
    Description
    class
    RcpMasProgramView
    class
    RcpProgramView
    class
    RcpSpawnedMasProgramView
    Methods in com.sage.rcp.views with parameters of type RcpEmbedJavXView
    Modifier and Type
    Method
    Description
    void
    RcpEmbedJavXView.hideView(RcpEmbedJavXView targetView)
    Constructors in com.sage.rcp.views with parameters of type RcpEmbedJavXView
    Modifier
    Constructor
    Description

    JavXThread(RcpEmbedJavXView rcpEmbedJavXView, RcpEmbedJavXView embedRCpLauncherJavXView)


Uses of Class com.sage.rcp.views.RcpMasProgramView

Uses of Class
com.sage.rcp.views.RcpMasProgramView

Packages that use RcpMasProgramView
Package
Description
com.sage.rcp.views

  • Uses of RcpMasProgramView in com.sage.rcp.views

    Subclasses of RcpMasProgramView in com.sage.rcp.views
    Modifier and Type
    Class
    Description
    class
    RcpSpawnedMasProgramView


Uses of Class com.sage.rcp.views.RcpProgramView

Uses of Class
com.sage.rcp.views.RcpProgramView

Packages that use RcpProgramView
Package
Description
com.sage.rcp.views

  • Uses of RcpProgramView in com.sage.rcp.views

    Subclasses of RcpProgramView in com.sage.rcp.views
    Modifier and Type
    Class
    Description
    class
    RcpMasProgramView
    class
    RcpSpawnedMasProgramView


Uses of Class com.sage.rcp.views.RcpPvxAction

Uses of Class
com.sage.rcp.views.RcpPvxAction

No usage of com.sage.rcp.views.RcpPvxAction


Uses of Class com.sage.rcp.views.RcpSpawnedMasProgramView

Uses of Class
com.sage.rcp.views.RcpSpawnedMasProgramView

No usage of com.sage.rcp.views.RcpSpawnedMasProgramView


A-Index

Index

A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form

A

AbstractProgressController - Class in com.pvx.ooadide.views
AbstractProgressController - Class in com.sage.rcp.eventmanager
AbstractProgressController() - Constructor for class com.pvx.ooadide.views.AbstractProgressController
AbstractProgressController() - Constructor for class com.sage.rcp.eventmanager.AbstractProgressController
AbstractProvideXFieldEditorPrefPage - Class in com.pvx.ooadide.preferences
AbstractPvxEditorAction - Class in com.pvx.ooadide.actions
AbstractPvxEditorAction() - Constructor for class com.pvx.ooadide.actions.AbstractPvxEditorAction
acceptEventConnection(MonitorState) - Method in class com.pvx.ooadide.launchers.debug.communication.DebugServer
acceptRequestConnection(MonitorState) - Method in class com.pvx.ooadide.launchers.debug.communication.DebugServer
actionPerformed(ActionEvent) - Method in class com.sage.rcp.javx.RcpPluginConnectionControl
actionPerformed(ActionEvent) - Method in class com.sage.rcp.javx.windows.PluginTextPlaneView
actionPerformed(Object) - Method in class com.pvx.ooadide.uesearch.UE_SearchAction
actionText - Variable in class com.pvx.ooadide.views.WinDefine
actionText - Variable in class com.sage.rcp.views.RcpProgramView
actionTip - Variable in class com.pvx.ooadide.views.WinDefine
activated(ILaunchConfigurationWorkingCopy) - Method in class com.pvx.ooadide.launchers.ProvideXArgumentsTab
activated(ILaunchConfigurationWorkingCopy) - Method in class com.pvx.ooadide.launchers.ProvideXMainTab
activated(ILaunchConfigurationWorkingCopy) - Method in class com.pvx.ooadide.launchers.thinclients.ClientTab
addBuilder(IProjectDescription, String, String, String, String, String) - Static method in class com.pvx.ooadide.util.PvxUtil
addCallToArgs(Hashtable) - Static method in class com.sage.rcp.views.RcpProgramView
addChildWindow(WindowFactory, int, int, int, int, String, int[], int, boolean, boolean, boolean, boolean, boolean, int, boolean, boolean, boolean, PvxHost) - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
If OnApplet equal True this Method will add windows (created with the 'window' mnemonic) directly onto the Applet
addDelayedAction(IAction) - Method in class com.pvx.ooadide.eventmanager.EventManager
addDependentPlugin(IPvxIdePlugin) - Method in class com.pvx.ooadide.ProvideXOOADPlugin
addEventListener(IPVXEventListener) - Method in class com.pvx.ooadide.launchers.debug.model.PVXDebugTarget
Registers the given event listener.
addExtJavaEventListener(Object, String, boolean) - Static method in class com.pvx.ooadide.eventmanager.EventManager
Adds an AbstractActionListener.
addExtPvxEventListener(int, String) - Static method in class com.pvx.ooadide.eventmanager.EventManager
Adds an AbstractActionListener
addExtPvxEventListener(int, String, int) - Static method in class com.pvx.ooadide.eventmanager.EventManager
Adds an AbstractActionListener
addFieldToPage(String, PvxPrefVisitee) - Static method in class com.pvx.ooadide.preferences.PrefPageVistor
ADDING_RESOURCES_TO_SRC - Static variable in class com.pvx.ooadide.eventmanager.EventManager
addJavaComponent(boolean, Object, String, int, int, int, int) - Method in class com.sage.rcp.javx.RcpPluginSwingGUIManager
addJavX(Component) - Static method in class com.sage.rcp.views.HostActionsView
addListener(String) - Method in class com.pvx.ooadide.eventmanager.EventManager
Adds a listener to the EventManager.
addListener(String) - Method in class com.sage.rcp.eventmanager.EventManager
Adds a listener to the EventManager.
addListener(String, int) - Method in class com.pvx.ooadide.eventmanager.EventManager
Adds a listener to the EventManager.
addListener(String, int) - Method in class com.sage.rcp.eventmanager.EventManager
Adds a listener to the EventManager.
addMethod(DelayedMethodCall) - Static method in class com.pvx.ooadide.eventmanager.DelayedMethodHandler
addMethod(DelayedMethodCall) - Static method in class com.sage.rcp.eventmanager.DelayedMethodHandler
addMethodToInvokeLaterList(Object, Class[], Object[], String) - Static method in class com.pvx.ooadide.eventmanager.DelayedMethodHandler
addMethodToInvokeLaterList(Object, Class[], Object[], String) - Static method in class com.sage.rcp.eventmanager.DelayedMethodHandler
addNature(IProjectDescription) - Static method in class com.pvx.ooadide.util.PvxUtil
addPages() - Method in class com.pvx.ooadide.wizards.ImportPasswordsWizard
addPages() - Method in class com.pvx.ooadide.wizards.NewFromExisting
addPages() - Method in class com.pvx.ooadide.wizards.NewNomadsLibraryWizard
Adding the page to the wizard.
addPages() - Method in class com.pvx.ooadide.wizards.NewNomadsNmdWizard
Adding the page to the wizard.
addPages() - Method in class com.pvx.ooadide.wizards.PasswordExporterWizard
addPages() - Method in class com.pvx.ooadide.wizards.programs.NewPvcCreationWizard
addPages() - Method in class com.pvx.ooadide.wizards.programs.NewPvxProgramWizard
Adding the page to the wizard.
addPages() - Method in class com.pvx.ooadide.wizards.ProvideXNewWizard
Adding the page to the wizard.
addPervasiveObject(int) - Static method in class com.pvx.ooadide.eventmanager.EventManager
Most Java objects instantiated by ProvideX are dropped after every event.
addPervasiveObject(int) - Static method in class com.sage.rcp.eventmanager.EventManager
Most Java objects instantiated by ProvideX are dropped after every event.
addPropertyChangeListener(IPropertyChangeListener) - Method in class com.pvx.ooadide.uesearch.SearchGotoAction
AddProvidexHandler - Class in com.pvx.ooadide.handlers
AddProvidexHandler() - Constructor for class com.pvx.ooadide.handlers.AddProvidexHandler
addResponse(String, String) - Method in class com.pvx.ooadide.eventmanager.PvxEvent
ProvideX responds to Eclipse events via this method
addResponse(String, String) - Method in class com.sage.rcp.eventmanager.PvxEvent
ProvideX responds to Eclipse events via this method
addResponse(String, String, Properties) - Method in class com.pvx.ooadide.eventmanager.PvxEvent
ProvideX responds to Eclipse events via this method
addResponse(String, String, Properties) - Method in class com.sage.rcp.eventmanager.PvxEvent
ProvideX responds to Eclipse events via this method
addRowToView(String, String) - Method in class com.pvx.ooadide.views.UIManager
addRowToView(String, String) - Method in class com.sage.rcp.eventmanager.UIManager
addSaveListener(IPvxSaveListener) - Static method in class com.pvx.ooadide.builder.ProvideXBuilder
addTestPage(PvxNewProgramPropertiesWizardPage) - Method in class com.pvx.ooadide.wizards.NewNomadsLibraryWizard
addTestPage(PvxNewProgramPropertiesWizardPage) - Method in class com.pvx.ooadide.wizards.NewNomadsNmdWizard
addTestPage(PvxNewProgramPropertiesWizardPage) - Method in class com.pvx.ooadide.wizards.programs.NewPvxProgramWizard
addTestPage(ProvideXNewWizardPageI) - Method in class com.pvx.ooadide.wizards.ProvideXNewWizard
addToDependencies(String, String) - Static method in class com.pvx.ooadide.preferences.AbstractProvideXFieldEditorPrefPage
addToHeight(int) - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
addToKnownPassword(String) - Static method in class com.pvx.ooadide.builder.ProvideXBuilder
addToPrefPages(String, String) - Method in class com.pvx.ooadide.eventmanager.EventManager
Adds the specified key to an Eclipse Preference page
addToPropertyUpdateList(String, String, String) - Static method in class com.pvx.ooadide.eventmanager.ResourceManager
addToWidth(int) - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
addVersionPluginVersion(IResource) - Static method in class com.pvx.ooadide.util.PvxUtil
addWindow(int, int, int, int, String, int, int[], int[], boolean, boolean) - Method in class com.sage.rcp.javx.RcpPluginSwingGUIManager
addWindow(int, int, int, int, String, int, int[], int[], boolean, boolean) - Method in class com.sage.rcp.javx.SingleWinViewGuiMngr
addWord(String, IToken) - Method in class com.pvx.ooadide.codehilite2.PvxWordRule
Adds a word and the token to be returned if it is detected.
allDirectives - Static variable in class com.pvx.ooadide.editors.MyCompletionProcessor
allMnemonics - Static variable in class com.pvx.ooadide.editors.MyCompletionProcessor
allSysFunctions - Static variable in class com.pvx.ooadide.editors.MyCompletionProcessor
allSysVariables - Static variable in class com.pvx.ooadide.editors.MyCompletionProcessor
APPLY_IT_FORMAT - Static variable in class com.pvx.ooadide.eventmanager.EventManager
args - Variable in class com.sage.rcp.javx.RcpPluginJavXApplet
argsAppendAppearanceFonts(StringBuffer) - Static method in class com.sage.rcp.views.RcpEmbedJavXView
argsStr - Static variable in class com.sage.rcp.views.RcpEmbedJavXView
AS_GENERATED - Enum constant in enum com.pvx.ooadide.views.PvcOutline.OutlineSortBy
asyncEvent(String, String) - Static method in class com.sage.rcp.eventmanager.EventManager
Sends a Message to the ProvideX EventManager and immediately returns.
ATTR_CLIENT_APPSERVER - Static variable in class com.pvx.ooadide.Constants
ATTR_CLIENT_DEFAULTHOST - Static variable in class com.pvx.ooadide.Constants
ATTR_CLIENT_EMBED_ONAPPLET - Static variable in class com.pvx.ooadide.Constants
ATTR_CLIENT_FORCE_LOGIN - Static variable in class com.pvx.ooadide.Constants
ATTR_CLIENT_HOST_ADDR - Static variable in class com.pvx.ooadide.Constants
ATTR_CLIENT_HOST_PORT - Static variable in class com.pvx.ooadide.Constants
ATTR_CLIENT_SSL - Static variable in class com.pvx.ooadide.Constants
ATTR_DEBUG_CLIENT - Static variable in class com.pvx.ooadide.Constants
ATTR_DEBUG_HOST - Static variable in class com.pvx.ooadide.Constants
ATTR_INCLUDE_EXTERNAL_JARS - Static variable in class com.pvx.ooadide.launchers.ProvideXMainTab
Boolean launch configuration attribute indicating that external jars (on the runtime classpath) should be searched when looking for a main type.
ATTR_LAUNCHER_PVX_EXE - Static variable in class com.pvx.ooadide.Constants
ATTR_LAUNCHER_WORKING_DIR - Static variable in class com.pvx.ooadide.Constants
ATTR_PROGRAM_ARGS - Static variable in class com.pvx.ooadide.Constants
ATTR_PROGRAM_INI_FILE - Static variable in class com.pvx.ooadide.Constants
ATTR_PROGRAM_INI_FILE_DEFAULT_VALUE - Static variable in class com.pvx.ooadide.Constants
ATTR_PROGRAM_NAME - Static variable in class com.pvx.ooadide.Constants
ATTR_PROJECT_NAME - Static variable in class com.pvx.ooadide.Constants
ATTR_WINDOW_STATE - Static variable in class com.pvx.ooadide.Constants
ATTRIB_TYPE - Static variable in class com.pvx.ooadide.util.PvxElement
ATTRIB_TYPE_SYMBOL - Static variable in class com.pvx.ooadide.util.PvxElement
A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form


B-Index

Index

A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form

B

bars - Variable in class com.sage.rcp.views.RcpEmbedJavXView
base - Variable in class com.sage.rcp.javx.RcpPluginJavXApplet
beginTask(String, int) - Method in class com.sage.rcp.util.SwingProgressMonitorWrappper
BlockCommentAction - Class in com.pvx.ooadide.refactor
BlockCommentAction() - Constructor for class com.pvx.ooadide.refactor.BlockCommentAction
BOOLEAN - Static variable in class com.pvx.ooadide.util.PvxUtil
BOOLEAN_DATA - Static variable in class com.pvx.ooadide.util.PvxUtil
breakpointAdded(IBreakpoint) - Method in class com.pvx.ooadide.launchers.debug.model.PVXDebugTarget
breakpointChanged(IBreakpoint, IMarkerDelta) - Method in class com.pvx.ooadide.launchers.debug.model.PVXDebugTarget
breakpointManagerEnablementChanged(boolean) - Method in class com.pvx.ooadide.launchers.debug.model.PVXDebugTarget
When the breakpoint manager disables, remove all registered breakpoints requests from the VM.
breakpointRemoved(IBreakpoint, IMarkerDelta) - Method in class com.pvx.ooadide.launchers.debug.model.PVXDebugTarget
BROWSER_EVENT - Static variable in class com.sage.rcp.eventmanager.EventManager
BUILD_PROPERTY_FILE_NAME - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
BUILD_PROPERTY_FILE_PATH - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
BUILDER_EXE - Static variable in class com.pvx.ooadide.eventmanager.EventManager
BUILDER_ID - Static variable in class com.pvx.ooadide.builder.ProvideXBuilder
BuilderOptions - Class in com.pvx.ooadide.preferences
BuilderOptions() - Constructor for class com.pvx.ooadide.preferences.BuilderOptions
BUILDLOG_NAME - Static variable in class com.pvx.ooadide.builder.ProvideXBuilder
BuildResourceAction - Class in com.pvx.ooadide.builder
BuildResourceAction() - Constructor for class com.pvx.ooadide.builder.BuildResourceAction
BUILDTYPE_ALL - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
BUILDTYPE_BUILDONE - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
BUILDTYPE_CONVERT - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
BUILDTYPE_DATAFILE - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
BUILDTYPE_NOMADSLIB - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
BUILDTYPE_OTHERFILE - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
BUILDTYPE_SKIPFILE - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
BUILDTYPE_SOURCE_FORMAT - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
BUILDTYPE_STRIPLINES_PREP - Static variable in class com.pvx.ooadide.eventmanager.EventManager
bye() - Static method in class com.pvx.ooadide.eventmanager.EventManager
bye() - Static method in class com.sage.rcp.eventmanager.EventManager
A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form


C-Index

Index

A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form

C

cAbsoluteCursorPosition - Variable in class com.pvx.ooadide.eventmanager.EditorState
CALL_BACK_MJR - Static variable in class com.sage.rcp.eventmanager.EventManager
callMethod(Method, Object[], Object) - Static method in class com.pvx.ooadide.eventmanager.DelayedMethodHandler
callMethod(Method, Object[], Object) - Static method in class com.sage.rcp.eventmanager.DelayedMethodHandler
callMethods() - Static method in class com.pvx.ooadide.eventmanager.DelayedMethodHandler
callMethods() - Static method in class com.sage.rcp.eventmanager.DelayedMethodHandler
cancel() - Method in class com.pvx.ooadide.views.MonitorState
cancel() - Method in class com.pvx.ooadide.views.PvxRunnableWithProgress
cancel() - Method in class com.sage.rcp.eventmanager.MonitorState
cancel() - Method in class com.sage.rcp.eventmanager.PvxRunnableWithProgress
canDisconnect() - Method in class com.pvx.ooadide.launchers.debug.model.PVXDebugTarget
canPop() - Method in class com.pvx.ooadide.launchers.debug.model.PVXDebugTarget
Returns whether popping the data stack is currently permitted
canPop() - Method in class com.pvx.ooadide.launchers.debug.model.PVXThread
Returns whether this thread can pop the top stack frame.
canPush() - Method in class com.pvx.ooadide.launchers.debug.model.PVXDebugTarget
Returns whether pushing a value is currently supported.
canResume() - Method in class com.pvx.ooadide.launchers.debug.model.PVXDebugTarget
canResume() - Method in class com.pvx.ooadide.launchers.debug.model.PVXStackFrame
canResume() - Method in class com.pvx.ooadide.launchers.debug.model.PVXThread
canStepInto() - Method in class com.pvx.ooadide.launchers.debug.model.PVXStackFrame
canStepInto() - Method in class com.pvx.ooadide.launchers.debug.model.PVXThread
canStepOver() - Method in class com.pvx.ooadide.launchers.debug.model.PVXStackFrame
canStepOver() - Method in class com.pvx.ooadide.launchers.debug.model.PVXThread
canStepReturn() - Method in class com.pvx.ooadide.launchers.debug.model.PVXStackFrame
canStepReturn() - Method in class com.pvx.ooadide.launchers.debug.model.PVXThread
canSuspend() - Method in class com.pvx.ooadide.launchers.debug.model.PVXDebugTarget
canSuspend() - Method in class com.pvx.ooadide.launchers.debug.model.PVXStackFrame
canSuspend() - Method in class com.pvx.ooadide.launchers.debug.model.PVXThread
canTerminate() - Method in class com.pvx.ooadide.launchers.debug.model.PVXDebugTarget
canTerminate() - Method in class com.pvx.ooadide.launchers.debug.model.PVXStackFrame
canTerminate() - Method in class com.pvx.ooadide.launchers.debug.model.PVXThread
canToggleLineBreakpoints(ITextEditor, ITextSelection) - Method in class com.pvx.ooadide.launchers.debug.model.PvxLineBreakpointAdapter
canvas - Variable in class com.sage.rcp.javx.RcpPluginJavXApplet
cFile - Variable in class com.pvx.ooadide.eventmanager.EditorState
changeViewFile(IFile) - Method in class com.pvx.ooadide.views.nomads.LibView
CHARSET - Static variable in class com.pvx.ooadide.launchers.debug.model.PVXDebugTarget
CHARSET - Static variable in class com.pvx.ooadide.views.nomads.LibView
checkCodeStyle(IFile, Vector<PvxProblem>) - Static method in class com.pvx.ooadide.builder.ProvideXBuilder
checkFinalConditions(IProgressMonitor, CheckConditionsContext) - Method in class com.pvx.ooadide.properties.refactoring.core.RenamePropertyProcessor
checkFinalConditions(IProgressMonitor, CheckConditionsContext) - Method in class com.pvx.ooadide.refactor.RenamePropertyProcessor
checkInitialConditions(IProgressMonitor) - Method in class com.pvx.ooadide.properties.refactoring.core.RenamePropertyProcessor
checkInitialConditions(IProgressMonitor) - Method in class com.pvx.ooadide.refactor.RenamePropertyProcessor
checkPVX(IResource, ConsoleDisplayManager) - Method in class com.pvx.ooadide.builder.ProvideXBuilder
clear() - Method in class com.pvx.ooadide.ConsoleDisplayManager
clear() - Method in class com.pvx.ooadide.editors.autoindent.PvxPairMatcher
clear() - Method in class com.sage.rcp.ConsoleDisplayManager
clear() - Method in class com.sage.rcp.eventmanager.ConsoleDisplayManager
clearAllBlocks() - Method in class com.pvx.ooadide.eventmanager.EventManager
Frees all blocking PvxEvents
clearAllBlocks() - Method in class com.sage.rcp.eventmanager.EventManager
Frees all blocking PvxEvents
clearAllBlocks() - Method in interface com.sage.rcp.IEventManager
clearFxGlobals() - Static method in class com.sage.rcp.eventmanager.EventManager
This method clears (removes from memory) all UltraFX String and numeric global variables
clearView(String) - Method in class com.pvx.ooadide.views.UIManager
clearView(String) - Method in class com.sage.rcp.eventmanager.UIManager
clientReady() - Method in class com.sage.rcp.eventmanager.EventManager
Informs the EventManger that the ProvideX process is ready to receive events:
ClientTab - Class in com.pvx.ooadide.launchers.thinclients
This tab appears for java applet launch configurations and allows the user to edit attributes such as the applet class to launch and its owning project, if any.
ClientTab() - Constructor for class com.pvx.ooadide.launchers.thinclients.ClientTab
clone() - Method in class com.sage.rcp.util.PvxRcpStateFlags
close() - Method in class com.pvx.ooadide.launchers.debug.communication.DebugServer
closeAllEditors(boolean) - Method in class com.pvx.ooadide.views.UIManager
Closes all open editors
closeAllEditors(boolean) - Method in class com.sage.rcp.eventmanager.UIManager
Closes all open editors
closeAndReOpenCurrent() - Static method in class com.pvx.ooadide.editors.PvxEditor
closeEditor() - Method in class com.pvx.ooadide.eventmanager.EditorManager
closeEditor(boolean) - Method in class com.pvx.ooadide.eventmanager.EditorManager
CodeStyleWarningResolution - Class in com.pvx.ooadide.builder
CodeStyleWarningResolution(String, String) - Constructor for class com.pvx.ooadide.builder.CodeStyleWarningResolution
collectGarbage() - Static method in class com.pvx.ooadide.eventmanager.EventManager
Cleans up all objects that are not persistent
collectGarbage() - Method in class com.sage.rcp.eventmanager.EventManager
Cleans up all objects that are not persistent
ColorManager - Class in com.pvx.ooadide.codehilite2
ColorManager() - Constructor for class com.pvx.ooadide.codehilite2.ColorManager
ColourTokenFactory - Class in com.pvx.ooadide.codehilite2
ColourTokenFactory() - Constructor for class com.pvx.ooadide.codehilite2.ColourTokenFactory
com.pvx.ooadide - package com.pvx.ooadide
com.pvx.ooadide.actions - package com.pvx.ooadide.actions
com.pvx.ooadide.builder - package com.pvx.ooadide.builder
com.pvx.ooadide.codehilite2 - package com.pvx.ooadide.codehilite2
com.pvx.ooadide.dialogs - package com.pvx.ooadide.dialogs
com.pvx.ooadide.editors - package com.pvx.ooadide.editors
com.pvx.ooadide.editors.autoindent - package com.pvx.ooadide.editors.autoindent
com.pvx.ooadide.editors.codefolding - package com.pvx.ooadide.editors.codefolding
com.pvx.ooadide.editors.extkeyword - package com.pvx.ooadide.editors.extkeyword
com.pvx.ooadide.editors.templates - package com.pvx.ooadide.editors.templates
com.pvx.ooadide.eventmanager - package com.pvx.ooadide.eventmanager
com.pvx.ooadide.handlers - package com.pvx.ooadide.handlers
com.pvx.ooadide.launchers - package com.pvx.ooadide.launchers
com.pvx.ooadide.launchers.debug - package com.pvx.ooadide.launchers.debug
com.pvx.ooadide.launchers.debug.breakpoints - package com.pvx.ooadide.launchers.debug.breakpoints
com.pvx.ooadide.launchers.debug.communication - package com.pvx.ooadide.launchers.debug.communication
com.pvx.ooadide.launchers.debug.launching - package com.pvx.ooadide.launchers.debug.launching
com.pvx.ooadide.launchers.debug.model - package com.pvx.ooadide.launchers.debug.model
com.pvx.ooadide.launchers.thinclients - package com.pvx.ooadide.launchers.thinclients
com.pvx.ooadide.launchers.thinclients.javx - package com.pvx.ooadide.launchers.thinclients.javx
com.pvx.ooadide.navigator - package com.pvx.ooadide.navigator
com.pvx.ooadide.navigator.filters - package com.pvx.ooadide.navigator.filters
com.pvx.ooadide.popup.actions - package com.pvx.ooadide.popup.actions
com.pvx.ooadide.preferences - package com.pvx.ooadide.preferences
com.pvx.ooadide.preferences.nomads - package com.pvx.ooadide.preferences.nomads
com.pvx.ooadide.properties - package com.pvx.ooadide.properties
com.pvx.ooadide.properties.dialogs - package com.pvx.ooadide.properties.dialogs
com.pvx.ooadide.properties.refactoring.core - package com.pvx.ooadide.properties.refactoring.core
com.pvx.ooadide.properties.refactoring.tagresolver - package com.pvx.ooadide.properties.refactoring.tagresolver
com.pvx.ooadide.properties.refactoring.ui - package com.pvx.ooadide.properties.refactoring.ui
com.pvx.ooadide.properties.refactoring.ui.wizards - package com.pvx.ooadide.properties.refactoring.ui.wizards
com.pvx.ooadide.properties.userdefined - package com.pvx.ooadide.properties.userdefined
com.pvx.ooadide.refactor - package com.pvx.ooadide.refactor
com.pvx.ooadide.uesearch - package com.pvx.ooadide.uesearch
com.pvx.ooadide.ui - package com.pvx.ooadide.ui
com.pvx.ooadide.util - package com.pvx.ooadide.util
com.pvx.ooadide.views - package com.pvx.ooadide.views
com.pvx.ooadide.views.comparators - package com.pvx.ooadide.views.comparators
com.pvx.ooadide.views.nomads - package com.pvx.ooadide.views.nomads
com.pvx.ooadide.wizards - package com.pvx.ooadide.wizards
com.pvx.ooadide.wizards.programs - package com.pvx.ooadide.wizards.programs
com.sage.rcp - package com.sage.rcp
com.sage.rcp.eventmanager - package com.sage.rcp.eventmanager
com.sage.rcp.javx - package com.sage.rcp.javx
com.sage.rcp.javx.windows - package com.sage.rcp.javx.windows
com.sage.rcp.preferences - package com.sage.rcp.preferences
com.sage.rcp.resizeanimation - package com.sage.rcp.resizeanimation
com.sage.rcp.util - package com.sage.rcp.util
com.sage.rcp.views - package com.sage.rcp.views
compare(Object, Object) - Method in class com.pvx.ooadide.views.comparators.NumericComparator
compare(Object, Object) - Method in class com.pvx.ooadide.views.comparators.PvxElementAlphaComparator
compare(Object, Object) - Method in class com.pvx.ooadide.views.comparators.PvxLineNoComparator
compare(Object, Object) - Method in class com.pvx.ooadide.views.comparators.PvxStructureComparator
compare(Viewer, Object, Object) - Method in class com.pvx.ooadide.views.PvxViewSorter
compareTo(Object) - Method in class com.pvx.ooadide.preferences.UserDefinedSortedField
computeCompletionProposals(ITextViewer, int) - Method in class com.pvx.ooadide.editors.MyCompletionProcessor
computeContextInformation(ITextViewer, int) - Method in class com.pvx.ooadide.editors.MyCompletionProcessor
computeDetail(IValue, IValueDetailListener) - Method in class com.pvx.ooadide.launchers.debug.launching.PVXModelPresentation
computeSourceContainers(ILaunchConfiguration, IProgressMonitor) - Method in class com.pvx.ooadide.launchers.debug.launching.PVXSourcePathComputerDelegate
CONFIG_BTN_ID - Static variable in class com.pvx.ooadide.dialogs.PvxElementListSelectionDialog
configure() - Method in class com.pvx.ooadide.builder.ProvideXNature
ConfirmDialShower(String, String) - Constructor for class com.pvx.ooadide.util.PvxUtil.ConfirmDialShower
ConfirmDialShower(String, String) - Constructor for class com.sage.rcp.util.PvxUtil.ConfirmDialShower
confirmJavXIsRunning() - Method in class com.pvx.ooadide.eventmanager.EventManager
Establishes a connection to the ProvideX host, I.E.
connectionWasDropped() - Static method in class com.pvx.ooadide.eventmanager.EventManager
True if the connection with ProvideX has been dropped
connectionWasDropped() - Method in class com.sage.rcp.eventmanager.EventManager
True if the connection with ProvideX has been dropped
connectToInterpreter(int, int) - Method in class com.pvx.ooadide.launchers.debug.model.PVXDebugTarget
CONSOLE_VIEW_ID - Static variable in class com.pvx.ooadide.views.UIManager
CONSOLE_VIEW_ID - Static variable in class com.sage.rcp.eventmanager.UIManager
ConsoleDisplayManager - Class in com.pvx.ooadide
Create an instance of this class in any of your plugin classes.
ConsoleDisplayManager - Class in com.sage.rcp
Create an instance of this class in any of your plugin classes.
ConsoleDisplayManager - Class in com.sage.rcp.eventmanager
Create an instance of this class in any of your plugin classes.
ConsoleDisplayManager(String) - Constructor for class com.pvx.ooadide.ConsoleDisplayManager
ConsoleDisplayManager(String) - Constructor for class com.sage.rcp.ConsoleDisplayManager
ConsoleDisplayManager(String) - Constructor for class com.sage.rcp.eventmanager.ConsoleDisplayManager
Constants - Class in com.pvx.ooadide
Constants() - Constructor for class com.pvx.ooadide.Constants
containsArgument(String) - Method in class com.pvx.ooadide.eventmanager.PvxEvent
Wraps the Properties iterator that contains the arguments of associated with this event
containsArgument(String) - Method in class com.sage.rcp.eventmanager.PvxEvent
Wraps the Properties iterator that contains the arguments of associated with this event
ConvertAction - Class in com.pvx.ooadide.actions
ConvertAction() - Constructor for class com.pvx.ooadide.actions.ConvertAction
convertHeightInCharsToPixels(int) - Method in class com.pvx.ooadide.util.PixelConverter
convertHorizontalDLUsToPixels(int) - Method in class com.pvx.ooadide.util.PixelConverter
convertSrcToDestRelativePath(IResource, IProject) - Static method in class com.pvx.ooadide.builder.ProvideXBuilder
convertVerticalDLUsToPixels(int) - Method in class com.pvx.ooadide.util.PixelConverter
convertWidthInCharsToPixels(int) - Method in class com.pvx.ooadide.util.PixelConverter
COOLBAR_ACTION - Static variable in class com.sage.rcp.eventmanager.EventManager
copyFileUsingChannel(File, File) - Static method in class com.pvx.ooadide.util.PvxFileUtils
CoreTexts - Class in com.pvx.ooadide.properties.refactoring.core
provides internationalized messages Strings from the coretexts resource bundle.
CoreTexts() - Constructor for class com.pvx.ooadide.properties.refactoring.core.CoreTexts
covertSrcPathToDestAbsolutePath(IResource) - Method in class com.pvx.ooadide.builder.ProvideXBuilder
covertSrcPathToDestAbsolutePath(IResource, IProject) - Static method in class com.pvx.ooadide.builder.ProvideXBuilder
create(String) - Static method in class com.pvx.ooadide.ui.PvxPluginImages
createChange(IProgressMonitor) - Method in class com.pvx.ooadide.properties.refactoring.core.RenamePropertyProcessor
createChange(IProgressMonitor) - Method in class com.pvx.ooadide.refactor.RenamePropertyProcessor
createChooseProjectDial(IProject[], IProject, Shell) - Static method in class com.pvx.ooadide.util.PvxUtil
createChooseResourceDial(IContainer, IProject, Shell, String, String, int) - Static method in class com.pvx.ooadide.util.PvxUtil
createControl(Composite) - Method in class com.pvx.ooadide.launchers.IniFileBlock
createControl(Composite) - Method in class com.pvx.ooadide.launchers.ProvideXArgumentsTab
createControl(Composite) - Method in class com.pvx.ooadide.launchers.ProvideXMainTab
createControl(Composite) - Method in class com.pvx.ooadide.launchers.thinclients.ClientTab
createControl(Composite) - Method in class com.pvx.ooadide.launchers.WindowStateBlock
createControl(Composite) - Method in class com.pvx.ooadide.preferences.EditorColorPreferencePage
createControl(Composite) - Method in class com.pvx.ooadide.properties.refactoring.ui.wizards.RenamePropertyInputPage
createControl(Composite) - Method in class com.pvx.ooadide.refactor.RenamePropertyInputPage
createControl(Composite) - Method in class com.pvx.ooadide.wizards.NewProjectFromExistingPage
(non-Javadoc) Method declared on IDialogPage.
createControl(Composite) - Method in class com.pvx.ooadide.wizards.programs.PvcPage
createControl(Composite) - Method in class com.pvx.ooadide.wizards.programs.PvxNewProgramPropertiesWizardPage
(non-Javadoc) Method declared on IDialogPage.
createControl(Composite) - Method in class com.pvx.ooadide.wizards.ProvidexNewWizardPage
(non-Javadoc) Method declared on IDialogPage.
createControl(Composite) - Method in class com.pvx.ooadide.wizards.WizardNewProjectPasswordPage
createControl(Composite) - Method in class com.pvx.ooadide.wizards.WizardPasswordPage
(non-Javadoc) Method declared on IDialogPage.
createDialProgressMonitor(String, int, MonitorState) - Static method in class com.pvx.ooadide.views.UIManager
This method should not be called directly by ProvideX programs.
createDialProgressMonitor(String, int, MonitorState) - Static method in class com.sage.rcp.eventmanager.UIManager
This method should not be called directly by ProvideX programs.
createFieldEditors() - Method in class com.pvx.ooadide.preferences.EditorOptions
Creates the field editors.
createFieldEditors() - Method in class com.pvx.ooadide.preferences.EditorOptionsPrefPage
createFieldEditors() - Method in class com.pvx.ooadide.preferences.ImportOptionsPrefPage
Creates the field editors.
createFieldEditors() - Method in class com.pvx.ooadide.preferences.ProvideXPreferencePage
Creates the field editors.
createFieldEditors() - Method in class com.sage.rcp.preferences.ProgramViewsPrefs
Creates the field editors.
createIniFileName(String, String) - Static method in class com.pvx.ooadide.wizards.NewFromExisting
createIniFileName(String, String) - Static method in class com.pvx.ooadide.wizards.ProvideXNewWizard
createInitialLayout(IPageLayout) - Method in class com.pvx.ooadide.views.PvxPerspectiveFactory
createPartControl(Composite) - Method in class com.pvx.ooadide.editors.NomadsEditor
createPartControl(Composite) - Method in class com.pvx.ooadide.editors.PvxEditor
createPartControl(Composite) - Method in class com.pvx.ooadide.views.IOListView
createPartControl(Composite) - Method in class com.pvx.ooadide.views.JavXBrowserView
This is a callback that will allow us to create the viewer and initialize it.
createPartControl(Composite) - Method in class com.pvx.ooadide.views.nomads.LibView
This is a callback that will allow us to create the viewer and initialize it.
createPartControl(Composite) - Method in class com.pvx.ooadide.views.PvcOutline
This is a callback that will allow us to create the viewer and initialize it.
createPartControl(Composite) - Method in class com.sage.rcp.views.HostActionsView
createPartControl(Composite) - Method in class com.sage.rcp.views.RcpEmbedJavXView
This is a callback that will allow us to create the viewer and initialize it.
createPartControl(Composite) - Method in class com.sage.rcp.views.RcpProgramView
createProcess(String, String) - Static method in class com.pvx.ooadide.util.ProcessRunner
createProcess(String, String, String[]) - Static method in class com.pvx.ooadide.util.ProcessRunner
createTabs(ILaunchConfigurationDialog, String) - Method in class com.pvx.ooadide.launchers.ProvideXConfigurationTabGroup1
createTabs(ILaunchConfigurationDialog, String) - Method in class com.pvx.ooadide.launchers.thinclients.javx.JavXAppletTabGroup
createTabs(ILaunchConfigurationDialog, String) - Method in class com.pvx.ooadide.launchers.thinclients.WindXLaunchConfigurationTabGroup
cTextSelection - Variable in class com.pvx.ooadide.eventmanager.EditorState
curMarkers - Static variable in class com.pvx.ooadide.builder.PvxProblem
CurvesPanel - Class in com.sage.rcp.resizeanimation
CurvesPanel() - Constructor for class com.sage.rcp.resizeanimation.CurvesPanel
customizeDocumentCommand(IDocument, DocumentCommand) - Method in class com.pvx.ooadide.editors.autoindent.PvxAutoIndentStrategy
A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form


D-Index

Index

A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form

D

deactivated(ILaunchConfigurationWorkingCopy) - Method in class com.pvx.ooadide.launchers.ProvideXArgumentsTab
deactivated(ILaunchConfigurationWorkingCopy) - Method in class com.pvx.ooadide.launchers.ProvideXMainTab
deactivated(ILaunchConfigurationWorkingCopy) - Method in class com.pvx.ooadide.launchers.thinclients.ClientTab
debug() - Static method in class com.sage.rcp.preferences.UiPrefManager
DebugLauncherThread - Class in com.pvx.ooadide.launchers.debug.communication
DebugLauncherThread(String, int, ConsoleDisplayManager, String, int, String, ILaunch, String) - Constructor for class com.pvx.ooadide.launchers.debug.communication.DebugLauncherThread
DebugServer - Class in com.pvx.ooadide.launchers.debug.communication
DebugWindXLauncherThread - Class in com.pvx.ooadide.launchers.thinclients
DebugWindXLauncherThread(String, int, ConsoleDisplayManager, String, int, String, ILaunch, String) - Constructor for class com.pvx.ooadide.launchers.thinclients.DebugWindXLauncherThread
deconfigure() - Method in class com.pvx.ooadide.builder.ProvideXNature
DEFAULT_DESTDIR - Static variable in class com.pvx.ooadide.builder.ProvideXBuilder
DEFAULT_SRCDIR - Static variable in class com.pvx.ooadide.builder.ProvideXBuilder
DefaultItemContentProvider - Class in com.pvx.ooadide.util
DefaultItemContentProvider() - Constructor for class com.pvx.ooadide.util.DefaultItemContentProvider
DefaultLabelProvider - Class in com.pvx.ooadide.util
DefaultLabelProvider() - Constructor for class com.pvx.ooadide.util.DefaultLabelProvider
DelayedAction - Class in com.pvx.ooadide.eventmanager
DelayedAction(IAction) - Constructor for class com.pvx.ooadide.eventmanager.DelayedAction
DelayedEvent - Class in com.pvx.ooadide.eventmanager
DelayedEvent(boolean, String, String, Properties) - Constructor for class com.pvx.ooadide.eventmanager.DelayedEvent
DelayedMethodCall - Class in com.pvx.ooadide.eventmanager
DelayedMethodCall - Class in com.sage.rcp.eventmanager
DelayedMethodCall(Object[], Method, Object, boolean) - Constructor for class com.pvx.ooadide.eventmanager.DelayedMethodCall
DelayedMethodCall(Object[], Method, Object, boolean) - Constructor for class com.sage.rcp.eventmanager.DelayedMethodCall
DelayedMethodHandler - Class in com.pvx.ooadide.eventmanager
DelayedMethodHandler - Class in com.sage.rcp.eventmanager
DelayedMethodHandler() - Constructor for class com.pvx.ooadide.eventmanager.DelayedMethodHandler
DelayedMethodHandler() - Constructor for class com.sage.rcp.eventmanager.DelayedMethodHandler
DESC_OUTLINE_FILTER_NONE - Static variable in class com.pvx.ooadide.ui.PvxPluginImages
DESC_OUTLINE_SETTINGS - Static variable in class com.pvx.ooadide.ui.PvxPluginImages
DESC_OUTLINE_SORTBY_GROUP - Static variable in class com.pvx.ooadide.ui.PvxPluginImages
DESC_OUTLINE_SORTBY_LINENUM - Static variable in class com.pvx.ooadide.ui.PvxPluginImages
DESC_OUTLINE_SORTBY_RESET - Static variable in class com.pvx.ooadide.ui.PvxPluginImages
destroyNxtWind(int) - Method in class com.sage.rcp.javx.RcpPluginSwingGUIManager
DICT_ALT_NME - Static variable in class com.pvx.ooadide.views.IOListView
DICT_DATA_CLASS - Static variable in class com.pvx.ooadide.util.RunUtil
DICT_DESCR - Static variable in class com.pvx.ooadide.views.IOListView
DICT_ENTRY - Static variable in class com.pvx.ooadide.views.IOListView
DICT_FMT_MASK - Static variable in class com.pvx.ooadide.views.IOListView
DICT_LEN - Static variable in class com.pvx.ooadide.views.IOListView
DICT_MAINT_PROGRAM - Static variable in class com.pvx.ooadide.util.RunUtil
DICT_NME - Static variable in class com.pvx.ooadide.views.IOListView
DICT_TYPE - Static variable in class com.pvx.ooadide.views.IOListView
directivePropl - Static variable in class com.pvx.ooadide.editors.MyCompletionProcessor
directives - Static variable in class com.pvx.ooadide.editors.MyCompletionProcessor
DIRECTIVES_PROPERTIES_FILE - Static variable in class com.pvx.ooadide.editors.MyCompletionProcessor
DirectiveWordDetector() - Constructor for class com.pvx.ooadide.codehilite2.PvxDirectiveWordRule.DirectiveWordDetector
DIRECTORY - Static variable in class com.pvx.ooadide.util.PvxUtil
DIRECTORY_DATA - Static variable in class com.pvx.ooadide.util.PvxUtil
disconnect() - Method in class com.pvx.ooadide.launchers.debug.model.PVXDebugTarget
DISPLAY_MIN_HEIGHT - Static variable in class com.sage.rcp.views.RcpEmbedJavXView
DISPLAY_MIN_WIDTH - Static variable in class com.sage.rcp.views.RcpEmbedJavXView
dispose() - Method in class com.pvx.ooadide.actions.ExtAction
dispose() - Method in class com.pvx.ooadide.actions.GenericWorkbenchAction
dispose() - Method in class com.pvx.ooadide.actions.ProvideX
We can use this method to dispose of any system resources we previously allocated.
dispose() - Method in class com.pvx.ooadide.codehilite2.ColorManager
dispose() - Method in class com.pvx.ooadide.editors.autoindent.PvxPairMatcher
dispose() - Method in class com.pvx.ooadide.editors.PvxEditor
dispose() - Method in class com.pvx.ooadide.launchers.ProvideXArgumentsTab
dispose() - Method in class com.pvx.ooadide.launchers.thinclients.ClientTab
dispose() - Method in class com.pvx.ooadide.preferences.EditorColorPreferencePage
dispose() - Method in class com.pvx.ooadide.util.DefaultItemContentProvider
dispose() - Method in class com.pvx.ooadide.views.JavXBrowserView
dispose() - Method in class com.pvx.ooadide.views.nomads.LibView
dispose() - Method in class com.pvx.ooadide.views.nomads.LibView.ViewContentProvider
dispose() - Method in class com.pvx.ooadide.views.PvcOutline
dispose() - Method in class com.pvx.ooadide.wizards.WizardPasswordPage
dispose() - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
dispose() - Method in class com.sage.rcp.views.RcpEmbedJavXView
do_setVisible() - Method in class com.pvx.ooadide.views.PvxRunnableWithProgress
do_setVisible() - Method in class com.sage.rcp.eventmanager.PvxRunnableWithProgress
doAppClientLaunch() - Method in class com.sage.rcp.javx.RcpPluginConnectionControl
doApplyProp(IResource, String, String) - Static method in class com.pvx.ooadide.properties.ProvideXPropertyPage
doApplyProp(IResource, String, String, String) - Static method in class com.pvx.ooadide.properties.ProvideXPropertyPage
doApplyProps(IResource, String, String, String, String, String, String, String) - Static method in class com.pvx.ooadide.properties.ProvideXPropertyPage
doConvertResource(IResource, IProgressMonitor) - Method in class com.pvx.ooadide.builder.ProvideXBuilder
doCurvyPainting(Graphics) - Method in class com.sage.rcp.resizeanimation.SizeAnimationGlassPane
doInit() - Method in class com.pvx.ooadide.ProvideXOOADPlugin
doInternalBorderChange(boolean) - Method in class com.sage.rcp.views.RcpEmbedJavXView
doLocalExecutionCall(byte[], Vector, String, String, int) - Method in class com.sage.rcp.javx.RcpPluginConnectionControl
doLogging - Static variable in class com.sage.rcp.PvxRcpActivator
DOM_INFO_BLOCK_HEADER - Static variable in class com.pvx.ooadide.util.PvxElement
doMultipleBuild(ArrayList<IResource>) - Static method in class com.pvx.ooadide.builder.BuildResourceAction
doNagUser(String) - Static method in class com.sage.rcp.util.PvxUtil
done() - Method in class com.pvx.ooadide.views.MonitorState
done() - Method in class com.sage.rcp.eventmanager.MonitorState
done() - Method in class com.sage.rcp.util.SwingProgressMonitorWrappper
doSocketAccept(MonitorState, ServerSocket) - Static method in class com.pvx.ooadide.launchers.debug.communication.DebugServer
doubleClicked(ITextViewer) - Method in class com.pvx.ooadide.codehilite2.XMLDoubleClickStrategy
doUpdateProps() - Static method in class com.pvx.ooadide.eventmanager.ResourceManager
dropInstance(RcpPluginConnectionControl) - Method in class com.pvx.ooadide.eventmanager.EventManager
dropInstance(RcpPluginConnectionControl) - Method in class com.sage.rcp.eventmanager.EventManager
dropInstance(RcpPluginConnectionControl) - Method in interface com.sage.rcp.IEventManager
A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form


E-Index

Index

A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form

E

earlyStartup() - Method in class com.pvx.ooadide.ProvideXOOADPlugin
ECLIPSE_SHUTDOWN - Static variable in class com.pvx.ooadide.eventmanager.EventManager
ECLIPSE_SHUTDOWN - Static variable in class com.sage.rcp.eventmanager.EventManager
These are the event messages that can be observed.
editFile(String, String) - Method in class com.pvx.ooadide.views.UIManager
Opens the file specified in the ProvideX Editor
EditorColorPreferencePage - Class in com.pvx.ooadide.preferences
EditorColorPreferencePage() - Constructor for class com.pvx.ooadide.preferences.EditorColorPreferencePage
EditorManager - Class in com.pvx.ooadide.eventmanager
EditorManager() - Constructor for class com.pvx.ooadide.eventmanager.EditorManager
EditorOptions - Class in com.pvx.ooadide.preferences
This class represents a preference page that is contributed to the Preferences dialog.
EditorOptions() - Constructor for class com.pvx.ooadide.preferences.EditorOptions
EditorOptionsPrefPage - Class in com.pvx.ooadide.preferences
EditorOptionsPrefPage() - Constructor for class com.pvx.ooadide.preferences.EditorOptionsPrefPage
EditorState - Class in com.pvx.ooadide.eventmanager
EditorState() - Constructor for class com.pvx.ooadide.eventmanager.EditorState
EditorSyntaxColorPref - Class in com.pvx.ooadide.preferences
EditorSyntaxColorPref(String, String, String, String, String, String, String) - Constructor for class com.pvx.ooadide.preferences.EditorSyntaxColorPref
endJavXSession() - Method in class com.sage.rcp.views.RcpEmbedJavXView
endRcpSession() - Method in class com.sage.rcp.javx.RcpPluginConnectionControl
endSession(PvxBaseWindow) - Method in class com.sage.rcp.javx.RcpPluginSwingGUIManager
entriesChanged(IClasspathViewer) - Method in class com.pvx.ooadide.launchers.thinclients.PvxBaseClientConfigTab
equals(Object) - Method in class com.pvx.ooadide.editors.PvxContextInformation
equals(Object) - Method in class com.pvx.ooadide.launchers.debug.model.PVXStackFrame
equals(Object) - Method in class com.pvx.ooadide.launchers.debug.model.PVXStackValue
ERROR_SCAN_PROGRAM - Static variable in class com.pvx.ooadide.builder.ProvideXBuilder
establishConnection(PvxBaseWindow, Hashtable<String, String>, PvxSSLSocketFactory) - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
evaluate(ICharacterScanner) - Method in class com.pvx.ooadide.codehilite2.ExtKeywordRule
evaluate(ICharacterScanner) - Method in class com.pvx.ooadide.codehilite2.PvxDirectiveWordRule
evaluate(ICharacterScanner) - Method in class com.pvx.ooadide.codehilite2.PvxEolRule
evaluate(ICharacterScanner) - Method in class com.pvx.ooadide.codehilite2.PvxLineLabelWordRule
evaluate(ICharacterScanner) - Method in class com.pvx.ooadide.codehilite2.PvxNumbLiteralRule
evaluate(ICharacterScanner) - Method in class com.pvx.ooadide.codehilite2.PvxWordRule
EVENT_FIRED - Static variable in class com.pvx.ooadide.eventmanager.EventManager
EVENT_LISTNR - Static variable in class com.pvx.ooadide.eventmanager.EventManager
EventManager - Class in com.pvx.ooadide.eventmanager
Controls communication between Eclipse and ProvideX.
EventManager - Class in com.sage.rcp.eventmanager
Controls communication between Eclipse and ProvideX.
EventManager(RcpPluginConnectionControl) - Constructor for class com.sage.rcp.eventmanager.EventManager
EventManager(RcpPluginConnectionControl, boolean) - Constructor for class com.sage.rcp.eventmanager.EventManager
EventManagerFactory - Class in com.pvx.ooadide.eventmanager
Factory that creates the EventManager which Controls communication between Eclipse and ProvideX
EventManagerFactory() - Constructor for class com.pvx.ooadide.eventmanager.EventManagerFactory
EXE_VERIFY_PROGRAM - Static variable in class com.pvx.ooadide.util.RunUtil
execute(ExecutionEvent) - Method in class com.pvx.ooadide.handlers.AddProvidexHandler
execute(ExecutionEvent) - Method in class com.pvx.ooadide.handlers.NewNomadsDefaultsHandler
execute(ExecutionEvent) - Method in class com.pvx.ooadide.handlers.NewNomadsLibHandler
execute(ExecutionEvent) - Method in class com.pvx.ooadide.handlers.NewProgramHandler
execute(ExecutionEvent) - Method in class com.pvx.ooadide.handlers.NewProjectHandler
execute(ExecutionEvent) - Method in class com.pvx.ooadide.handlers.NewPvxClassHandler
exists() - Method in class com.pvx.ooadide.editors.HandledInput
EXPORT - Static variable in class com.pvx.ooadide.eventmanager.EventManager
ExportPasswordsPage - Class in com.pvx.ooadide.wizards
Page 1 of the base preference export Wizard
ExportPasswordsPage() - Constructor for class com.pvx.ooadide.wizards.ExportPasswordsPage
Create an instance of this class
EXT_EVENT - Static variable in class com.pvx.ooadide.eventmanager.EventManager
ExtAction - Class in com.pvx.ooadide.actions
ExtAction() - Constructor for class com.pvx.ooadide.actions.ExtAction
ExtCommand - Class in com.pvx.ooadide.eventmanager
An event that indicates a Contributed action has occurred in Eclipse
ExtCommand(String, Object) - Constructor for class com.pvx.ooadide.eventmanager.ExtCommand
ExtCommand(String, Object, boolean) - Constructor for class com.pvx.ooadide.eventmanager.ExtCommand
ExtCommand(String, Object, boolean, boolean) - Constructor for class com.pvx.ooadide.eventmanager.ExtCommand
ExtensionUtil - Class in com.pvx.ooadide.util
ExtensionUtil() - Constructor for class com.pvx.ooadide.util.ExtensionUtil
ExtKeywordCategoryEntity - Class in com.pvx.ooadide.editors.extkeyword
ExtKeywordCategoryEntity(String, String, Image, IPvxIdePlugin) - Constructor for class com.pvx.ooadide.editors.extkeyword.ExtKeywordCategoryEntity
ExtKeywordCompoundRule - Class in com.pvx.ooadide.codehilite2
ExtKeywordCompoundRule(IWordDetector) - Constructor for class com.pvx.ooadide.codehilite2.ExtKeywordCompoundRule
ExtKeywordDetector - Class in com.pvx.ooadide.codehilite2
ExtKeywordDetector(boolean) - Constructor for class com.pvx.ooadide.codehilite2.ExtKeywordDetector
ExtKeywordRule - Class in com.pvx.ooadide.codehilite2
ExtKeywordRule(IWordDetector) - Constructor for class com.pvx.ooadide.codehilite2.ExtKeywordRule
extKeywordsEntityList - Static variable in class com.pvx.ooadide.editors.MyCompletionProcessor
extractProjectName(String) - Method in class com.pvx.ooadide.wizards.WizardPasswordImportPage1
extractResourceName(String) - Method in class com.pvx.ooadide.wizards.WizardPasswordImportPage1
A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form


F-Index

Index

A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form

F

FILE - Static variable in class com.pvx.ooadide.util.PvxUtil
FILE_DATA - Static variable in class com.pvx.ooadide.util.PvxUtil
FILE_INFO_BLOCK_HEADER - Static variable in class com.pvx.ooadide.util.PvxElement
fileSaved(IFile) - Method in interface com.pvx.ooadide.builder.IPvxSaveListener
FILTERED - Enum constant in enum com.pvx.ooadide.views.PvcOutline.OutlineSortBy
findDataDomFile(IResource, String) - Static method in class com.pvx.ooadide.builder.ProvideXBuilder
findDomFile(IResource) - Static method in class com.pvx.ooadide.builder.ProvideXBuilder
findMatchingContributedTool(String, Properties) - Static method in class com.pvx.ooadide.util.RunUtil
findOpenSocket() - Static method in class com.sage.rcp.javx.PvxHostLauncher
findOpenSocket(int) - Static method in class com.sage.rcp.javx.PvxHostLauncher
findPvxProjects() - Static method in class com.pvx.ooadide.util.PvxUtil
finish(String) - Method in class com.pvx.ooadide.wizards.WizardPasswordPage
The Finish button was pressed.
FIVE_D - Static variable in class com.sage.rcp.preferences.UiPrefManager
FlagsPropertyResolver - Class in com.pvx.ooadide.editors.templates
FlagsPropertyResolver() - Constructor for class com.pvx.ooadide.editors.templates.FlagsPropertyResolver
FORMAT_KEY - Static variable in class com.pvx.ooadide.editors.MyCompletionProcessor
FOUR_D - Static variable in class com.sage.rcp.preferences.UiPrefManager
freeEvent(PvxEvent) - Static method in class com.pvx.ooadide.eventmanager.EventManager
Notify Eclipse that ProvideX has finish processing the event and if the EventManager is the guiManager then frees the event
freeEvent(PvxEvent) - Method in class com.sage.rcp.eventmanager.EventManager
Notify Eclipse that ProvideX has finish processing the event and the EventManager can free/delete/dropped the event object
freeUpFrame() - Method in class com.sage.rcp.javx.RcpPluginConnectionControl
FULL_BUILD - Static variable in class com.pvx.ooadide.eventmanager.EventManager
FULL_BUILD_ALT_EXE - Static variable in class com.pvx.ooadide.eventmanager.EventManager
FULL_BUILD_END - Static variable in class com.pvx.ooadide.eventmanager.EventManager
FULL_BUILD_START - Static variable in class com.pvx.ooadide.eventmanager.EventManager
FUNCTION_TYPE - Static variable in class com.pvx.ooadide.util.PvxElement
FUNCTION_TYPE_SYMBOL - Static variable in class com.pvx.ooadide.util.PvxElement
FxPagePartListener - Class in com.sage.rcp.javx
FxPagePartListener() - Constructor for class com.sage.rcp.javx.FxPagePartListener
A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form


G-Index

Index

A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form

G

gc_OCX_Handles(Vector<Integer>) - Method in class com.sage.rcp.javx.RcpPluginSwingGUIManager
generateCommandLine(ILaunchConfiguration, ILaunch, ConsoleDisplayManager, IProject, String, String, int, int) - Method in class com.pvx.ooadide.launchers.ProvideXLaunchConfigurationDelegate1
generateCommandLine(ILaunchConfiguration, ILaunch, ConsoleDisplayManager, IProject, String, String, int, int) - Method in class com.pvx.ooadide.launchers.thinclients.WindXLaunchConfigurationDelegate1
generateCommandLineArray(ILaunchConfiguration, ConsoleDisplayManager, IProject, String, String) - Method in class com.pvx.ooadide.launchers.ProvideXLaunchConfigurationDelegate1
generateFormattedSourceFile(IFile, String) - Static method in class com.pvx.ooadide.builder.ProvideXBuilder
GENERIC_ACTION - Static variable in class com.pvx.ooadide.eventmanager.EventManager
GenericAction - Class in com.pvx.ooadide.actions
GenericAction() - Constructor for class com.pvx.ooadide.actions.GenericAction
GenericWorkbenchAction - Class in com.pvx.ooadide.actions
GenericWorkbenchAction() - Constructor for class com.pvx.ooadide.actions.GenericWorkbenchAction
getAbsoluteSRCDIR(IProject) - Static method in class com.pvx.ooadide.builder.ProvideXBuilder
getAccelerator() - Method in class com.pvx.ooadide.uesearch.SearchGotoAction
getActionBars() - Method in interface com.sage.rcp.javx.IEmbeddedJavXView
getActionBars() - Method in class com.sage.rcp.views.HostActionsView
getActionBars() - Method in class com.sage.rcp.views.RcpEmbedJavXView
getActionDefinitionId() - Method in class com.pvx.ooadide.uesearch.SearchGotoAction
getActionText() - Method in class com.pvx.ooadide.views.WinDefine
getActionText() - Method in class com.sage.rcp.views.RcpProgramView
getActionTip() - Method in class com.pvx.ooadide.views.WinDefine
getActionTip() - Method in class com.sage.rcp.views.RcpProgramView
getActivationLevel() - Method in class com.pvx.ooadide.util.PvxVersionInfo
getActiveCtrls() - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
If On Applet is true returns the Applets ProvideX GUI objects
getActiveEditor() - Static method in class com.pvx.ooadide.views.PvcOutline
getActiveFrames() - Static method in class com.sage.rcp.views.JavXThread
getActivePage() - Static method in class com.pvx.ooadide.ProvideXOOADPlugin
getActivePvxEditor() - Static method in class com.pvx.ooadide.util.PvxUtil
getAdapter(Class) - Method in class com.pvx.ooadide.builder.PvxProblem
getAdapter(Class<T>) - Method in class com.pvx.ooadide.editors.HandledInput
getAdapter(Object, Class) - Method in class com.pvx.ooadide.launchers.debug.breakpoints.PvxBreakpointAdapterFactory
getAdapterList() - Method in class com.pvx.ooadide.launchers.debug.breakpoints.PvxBreakpointAdapterFactory
getAffectedResource(IAdaptable) - Method in class com.pvx.ooadide.builder.PvxProblem
getAllCompletionProposals(ICompletionProposal[]) - Static method in class com.pvx.ooadide.editors.MyCompletionProcessor
getAllDirectives() - Static method in class com.pvx.ooadide.editors.MyCompletionProcessor
getAllKeywords() - Method in class com.pvx.ooadide.editors.extkeyword.ExtKeywordCategoryEntity
getAllMnemonics() - Static method in class com.pvx.ooadide.editors.MyCompletionProcessor
getAllocatedObjectList() - Method in class com.pvx.ooadide.eventmanager.EventManager
getAllocatedObjectList() - Method in class com.sage.rcp.eventmanager.EventManager
getAllocatedObjectList() - Method in class com.sage.rcp.javx.RcpPluginSwingGUIManager
getAllSysFunctions() - Static method in class com.pvx.ooadide.editors.MyCompletionProcessor
getAllSysVariables() - Static method in class com.pvx.ooadide.editors.MyCompletionProcessor
getAnchor() - Method in class com.pvx.ooadide.editors.autoindent.PvxPairMatcher
getAnnotationHover(ISourceViewer) - Method in class com.pvx.ooadide.codehilite2.XMLConfiguration2
getAppletInfo() - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
getApplicationArguments() - Method in class com.pvx.ooadide.ProvideXOOADPlugin
getApplicationArguments() - Method in interface com.sage.rcp.IPvxPlugin
getArgsFromProperties(String) - Method in interface com.pvx.ooadide.IPvxIdePlugin
getArgsFromProperties(String) - Method in class com.pvx.ooadide.ProvideXOOADPlugin
getArgsFromPropertiesInWorkspace(String) - Method in class com.pvx.ooadide.ProvideXOOADPlugin
getArgsStr() - Method in class com.pvx.ooadide.views.WinDefine
getArgsStr() - Method in interface com.sage.rcp.javx.IEmbeddedJavXView
getArgsStr() - Method in class com.sage.rcp.views.HostActionsView
getArgsStr() - Method in class com.sage.rcp.views.RcpEmbedJavXView
getArgsStr() - Method in class com.sage.rcp.views.RcpProgramView
getArgsStr() - Method in class com.sage.rcp.views.RcpSpawnedMasProgramView
getArgument(String) - Method in class com.pvx.ooadide.eventmanager.PvxEvent
Wraps the Properties iterator that contains the arguments of associated with this event
getArgument(String) - Method in class com.sage.rcp.eventmanager.PvxEvent
Wraps the Properties iterator that contains the arguments of associated with this event
getAutoEditStrategies(ISourceViewer, String) - Method in class com.pvx.ooadide.codehilite2.XMLConfiguration2
getBackground(Object) - Method in class com.pvx.ooadide.util.DefaultLabelProvider
getBoolean(String) - Static method in class com.pvx.ooadide.preferences.PreferenceManager
getBooleanPreference(String) - Static method in class com.pvx.ooadide.util.ProjectUtils
getBooleanPreferenceAsString(String) - Static method in class com.pvx.ooadide.util.ProjectUtils
getBooleanProperty(String) - Static method in class com.pvx.ooadide.util.ProjectUtils
Get the value of specified boolean property from the project/workspace specific properties file
getBreakpoints() - Method in class com.pvx.ooadide.launchers.debug.model.PVXThread
getBuildErrorMsg() - Static method in class com.pvx.ooadide.builder.ProvideXBuilder
getBuildProps() - Method in class com.pvx.ooadide.eventmanager.DelayedEvent
getBuildProps() - Method in class com.pvx.ooadide.eventmanager.PvxEvent
getBuildProps() - Method in class com.sage.rcp.eventmanager.PvxEvent
getCallArgs() - Static method in class com.sage.rcp.views.RcpProgramView
getCanvas() - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
getCategoryName() - Method in class com.pvx.ooadide.editors.extkeyword.ExtKeywordCategoryEntity
getChangeType() - Method in class com.pvx.ooadide.refactor.RenamePropertyInfo
getCharEnd() - Method in class com.pvx.ooadide.launchers.debug.model.PVXStackFrame
getCharStart() - Method in class com.pvx.ooadide.launchers.debug.model.PVXStackFrame
getClientGUIComponent() - Method in class com.pvx.ooadide.eventmanager.EventManager
getClientGUIComponent() - Method in class com.sage.rcp.eventmanager.EventManager
getClientGUIComponent() - Method in interface com.sage.rcp.IEventManager
getColor(String) - Method in class com.pvx.ooadide.codehilite2.ColorManager
getColor(RGB) - Method in class com.pvx.ooadide.codehilite2.ColorManager
getColumnImage(Object, int) - Method in class com.pvx.ooadide.views.IOListView.IOListLabelProvider
getColumnImage(Object, int) - Method in class com.pvx.ooadide.views.nomads.LibView.ViewLabelProvider
getColumnText(Object, int) - Method in class com.pvx.ooadide.views.IOListView.IOListLabelProvider
getColumnText(Object, int) - Method in class com.pvx.ooadide.views.nomads.LibView.ViewLabelProvider
getCommand() - Method in interface com.pvx.ooadide.actions.IExtCommand
getCommand() - Method in class com.pvx.ooadide.eventmanager.ExtCommand
getCommonNavigatorResources(CommonNavigator) - Static method in class com.pvx.ooadide.util.UtilCommands
getCompletionProposalAutoActivationCharacters() - Method in class com.pvx.ooadide.editors.MyCompletionProcessor
getComposite() - Method in class com.sage.rcp.views.RcpEmbedJavXView
getCompositeColor() - Method in interface com.sage.rcp.javx.IEmbeddedJavXView
getCompositeColor() - Method in class com.sage.rcp.views.HostActionsView
getCompositeColor() - Method in class com.sage.rcp.views.RcpEmbedJavXView
getConCon() - Method in class com.pvx.ooadide.eventmanager.EventManager
getConCon() - Method in class com.sage.rcp.eventmanager.EventManager
getConCon() - Method in interface com.sage.rcp.IEventManager
getConnectionAnimation() - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
getConnectionControl() - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
getContentAssistant(ISourceViewer) - Method in class com.pvx.ooadide.codehilite2.XMLConfiguration2
getContents() - Method in class com.pvx.ooadide.properties.ResourceToChangeEntity
getContextDisplayString() - Method in class com.pvx.ooadide.editors.PvxContextInformation
getContextForKey(String) - Static method in class com.pvx.ooadide.editors.MyCompletionProcessor
getContextInfo(Hashtable, String) - Static method in class com.pvx.ooadide.editors.MyCompletionProcessor
getContextInformation() - Method in class com.pvx.ooadide.editors.PvxCompletionProposal
getContextInformationAutoActivationCharacters() - Method in class com.pvx.ooadide.editors.MyCompletionProcessor
getContextInformationValidator() - Method in class com.pvx.ooadide.editors.MyCompletionProcessor
getContextTypeRegistry() - Method in class com.pvx.ooadide.editors.templates.TemplateEditorUI
Returns this plug-in's context type registry.
getControlPlugin() - Method in class com.sage.rcp.PvxRcpActivator
getCtxImage() - Method in class com.pvx.ooadide.editors.PvxCompletionProposal
getCurrentInstance() - Static method in class com.sage.rcp.javx.RcpPluginConnectionControl
getCurrentMessage() - Method in class com.sage.rcp.util.ProgressIndicator
getCurrentProject() - Static method in class com.pvx.ooadide.eventmanager.EventManager
getCurrentValue() - Method in class com.pvx.ooadide.preferences.UserPrefElement
getDataStack() - Method in class com.pvx.ooadide.launchers.debug.model.PVXDebugTarget
Returns the values on the data stack (top down)
getDataType() - Method in class com.pvx.ooadide.preferences.UserPrefElement
getDataTypeForPref(String) - Static method in class com.pvx.ooadide.util.PvxUtil
getDebugInfo() - Method in class com.pvx.ooadide.util.PvxVersionInfo
getDebugTarget() - Method in class com.pvx.ooadide.launchers.debug.model.PVXDebugTarget
getDefault() - Static method in class com.pvx.ooadide.ConsoleDisplayManager
getDefault() - Static method in class com.pvx.ooadide.editors.templates.TemplateEditorUI
Returns the shared instance.
getDefault() - Static method in class com.pvx.ooadide.launchers.debug.communication.DebugServer
getDefault() - Static method in class com.pvx.ooadide.ProvideXOOADPlugin
getDefault() - Static method in class com.sage.rcp.ConsoleDisplayManager
getDefault() - Static method in class com.sage.rcp.eventmanager.ConsoleDisplayManager
getDefault() - Static method in class com.sage.rcp.PvxRcpActivator
Returns the shared instance
getDefaultBoolean(String) - Static method in class com.pvx.ooadide.preferences.PreferenceManager
getDefaultDebugSocket() - Static method in class com.sage.rcp.javx.PvxHostLauncher
getDefaultEventManagerSocket() - Static method in class com.sage.rcp.javx.PvxHostLauncher
getDefaultOutputName() - Method in class com.pvx.ooadide.properties.ProvideXPropertyPage
getDefaultPvxExePath() - Static method in class com.pvx.ooadide.eventmanager.ResourceManager
Returns a path to the ProvideX executable associated with the specified file
getDefaultPvxExePath(String) - Static method in class com.pvx.ooadide.eventmanager.ResourceManager
Returns a path to the ProvideX executable associated with the specified file
getDefaultPvxPath() - Static method in class com.pvx.ooadide.util.PvxUtil
getDefaultPvxPath() - Static method in class com.sage.rcp.util.PvxUtil
getDefaultRawOutputDir(IProject) - Static method in class com.pvx.ooadide.builder.ProvideXBuilder
getDefaultRawSrcDir(IProject) - Static method in class com.pvx.ooadide.builder.ProvideXBuilder
getDefaultSocket() - Static method in class com.sage.rcp.javx.PvxHostLauncher
getDefaultString(String) - Static method in class com.pvx.ooadide.preferences.PreferenceManager
getDefaultValue() - Method in class com.pvx.ooadide.preferences.UserPrefElement
getDefaultValue(String, IResource) - Static method in class com.pvx.ooadide.properties.ProvideXPropertyPage
getDelayedAction() - Method in class com.pvx.ooadide.eventmanager.DelayedAction
getDependentPluginList() - Static method in class com.pvx.ooadide.ProvideXOOADPlugin
getDependentPlugins() - Static method in class com.pvx.ooadide.eventmanager.ResourceManager
getDescription() - Method in class com.pvx.ooadide.builder.CodeStyleWarningResolution
getDescription() - Method in class com.pvx.ooadide.builder.PvxProblem
getDescription() - Method in class com.pvx.ooadide.uesearch.SearchGotoAction
getDescription() - Method in class com.pvx.ooadide.wizards.PasswordTransferElement
getDeskTopContainer() - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
getDeskTopPane() - Method in class com.sage.rcp.javx.windows.PluginTextPlaneView
getDESTDIR(IProject) - Static method in class com.pvx.ooadide.builder.ProvideXBuilder
getDetail() - Method in class com.pvx.ooadide.eventmanager.DelayedEvent
getDirectiveCompletionProposals() - Static method in class com.pvx.ooadide.editors.MyCompletionProcessor
getDisabledImageDescriptor() - Method in class com.pvx.ooadide.uesearch.SearchGotoAction
getDisplayName() - Method in class com.pvx.ooadide.preferences.UserPrefElement
getDisplayString() - Method in class com.pvx.ooadide.editors.PvxCompletionProposal
getDocument(String) - Method in class com.pvx.ooadide.ProvideXOOADPlugin
getDocumentBase() - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
getDOM_DIRECTORY(IProject) - Static method in class com.pvx.ooadide.builder.ProvideXBuilder
getDOM_DIRECTORY(IProject) - Static method in class com.pvx.ooadide.eventmanager.ResourceManager
This method (from ProvideXBuilder) is duplicated here to enable ProvideX applications to retrieve the information through the ResourceManager object.
getDoubleClickStrategy(ISourceViewer, String) - Method in class com.pvx.ooadide.codehilite2.XMLConfiguration2
getEditingFile() - Static method in class com.pvx.ooadide.views.PvcOutline
getEditingFileName() - Static method in class com.pvx.ooadide.views.PvcOutline
getEditor() - Method in class com.pvx.ooadide.editors.codefolding.PvxReconcilingStrategy
getEditor() - Method in class com.pvx.ooadide.refactor.RenamePropertyInfo
getEditorId(IEditorInput, Object) - Method in class com.pvx.ooadide.launchers.debug.launching.PVXModelPresentation
getEditorInput(Object) - Method in class com.pvx.ooadide.launchers.debug.launching.PVXModelPresentation
getElapsedTime() - Static method in class com.pvx.ooadide.util.StopWatch
getElement(int) - Method in class com.pvx.ooadide.views.nomads.PvxLibElement
getElements() - Method in class com.pvx.ooadide.properties.refactoring.core.RenamePropertyProcessor
getElements() - Method in class com.pvx.ooadide.refactor.RenamePropertyProcessor
getElements(Object) - Method in class com.pvx.ooadide.util.DefaultItemContentProvider
getElements(Object) - Method in class com.pvx.ooadide.views.nomads.LibView.ViewContentProvider
getError() - Method in class com.pvx.ooadide.builder.PvxProblem
getError() - Method in class com.pvx.ooadide.launchers.debug.model.PVXThread
Returns the most revent error event encountered since the last suspend, or null if none.
getErrorMessage() - Method in class com.pvx.ooadide.editors.MyCompletionProcessor
getErrorMessage() - Method in class com.pvx.ooadide.launchers.ProvideXArgumentsTab
getEventCommand() - Method in class com.pvx.ooadide.eventmanager.PvxEvent
Accessor that returns the minor code of an event
getEventCommand() - Method in class com.sage.rcp.eventmanager.PvxEvent
Accessor that returns the minor code of an event
getEventManager() - Static method in class com.pvx.ooadide.eventmanager.EventManagerFactory
getEventManager() - Method in class com.pvx.ooadide.ProvideXOOADPlugin
getEventManager() - Method in interface com.sage.rcp.IPvxPlugin
getEventName() - Method in class com.pvx.ooadide.eventmanager.DelayedEvent
getEventName() - Method in class com.pvx.ooadide.eventmanager.PvxEvent
Accessor that returns the major code of an event
getEventName() - Method in class com.sage.rcp.eventmanager.PvxEvent
Accessor that returns the major code of an event; the name of the event that occured within the Eclipse Workbench.
getEventPort() - Method in class com.pvx.ooadide.eventmanager.PvxRequestManager
getEventPort() - Method in class com.pvx.ooadide.launchers.debug.communication.DebugServer
getExtClassPrefs() - Static method in class com.pvx.ooadide.eventmanager.EventManager
getExtCommands() - Static method in class com.pvx.ooadide.eventmanager.EventManager
getExtKeywordCategories() - Static method in class com.pvx.ooadide.editors.MyCompletionProcessor
getExtKeywordCompletionProposals() - Static method in class com.pvx.ooadide.editors.MyCompletionProcessor
getFile() - Method in class com.pvx.ooadide.editors.HandledInput
getFile() - Method in class com.pvx.ooadide.properties.ResourceToChangeEntity
getFile(String) - Static method in class com.pvx.ooadide.eventmanager.ResourceManager
Returns the File for the specified path
getFileCreatePage() - Method in class com.pvx.ooadide.wizards.programs.PvxNewProgramPropertiesWizardPage
getFileInPlugin(IPath) - Static method in class com.pvx.ooadide.ProvideXOOADPlugin
Return a java.io.File object that corresponds to the specified IPath in the plugin directory, or null if none.
getFileProperty(IResource, String) - Static method in class com.pvx.ooadide.util.PvxUtil
getFilesPvxExePath(String) - Static method in class com.pvx.ooadide.eventmanager.ResourceManager
getFileType(IResource) - Static method in class com.pvx.ooadide.util.PvxFileUtils
getFileTypeDescription(int) - Static method in class com.pvx.ooadide.util.PvxFileUtils
getFilter() - Method in class com.pvx.ooadide.views.PvcOutlineSettings
getFINValue(String) - Method in class com.sage.rcp.javx.RcpPluginSwingGUIManager
getFolder(String) - Static method in class com.pvx.ooadide.eventmanager.ResourceManager
Returns the IContainer folder for specified path
getFolderForFile(String) - Method in class com.pvx.ooadide.ProvideXOOADPlugin
getForeground(Object) - Method in class com.pvx.ooadide.util.DefaultLabelProvider
getFormattedString(String, Object) - Static method in class com.pvx.ooadide.editors.templates.TemplateMessages
getFormattedString(String, Object[]) - Static method in class com.pvx.ooadide.editors.templates.TemplateMessages
getFPlugin() - Method in class com.pvx.ooadide.editors.extkeyword.ExtKeywordCategoryEntity
getFunctionRegion(String, ISourceViewer, String) - Method in class com.pvx.ooadide.editors.PvxEditor
getFxGlobalNumericVariables() - Static method in class com.sage.rcp.eventmanager.EventManager
This method returns a comma delimited list of all UltraFX String global variables
getFxGlobalStringVariables() - Static method in class com.sage.rcp.eventmanager.EventManager
This method returns a comma delimited list of all UltraFX String global variables
getFxNumbericGlobal(String) - Static method in class com.sage.rcp.eventmanager.EventManager
This method returns the value of the specified numeric global variable
getFxStringGlobal(String) - Static method in class com.sage.rcp.eventmanager.EventManager
This method returns the value of the specified string global variable
getGradientEnd1() - Method in class com.sage.rcp.resizeanimation.GradientPanel
getGradientEnd2() - Method in class com.sage.rcp.resizeanimation.GradientPanel
getGradientStart1() - Method in class com.sage.rcp.resizeanimation.GradientPanel
getGradientStart2() - Method in class com.sage.rcp.resizeanimation.GradientPanel
getHelpListener() - Method in class com.pvx.ooadide.uesearch.SearchGotoAction
getHoverImageDescriptor() - Method in class com.pvx.ooadide.uesearch.SearchGotoAction
getHoverInfo(ITextViewer, IRegion) - Method in class com.pvx.ooadide.editors.TextHover
getHoverInfo(ISourceViewer, int) - Method in class com.pvx.ooadide.editors.PvxAnnotationHover
getHoverRegion(ITextViewer, int) - Method in class com.pvx.ooadide.editors.TextHover
getId() - Method in class com.pvx.ooadide.uesearch.SearchGotoAction
getID() - Method in class com.pvx.ooadide.preferences.AbstractProvideXFieldEditorPrefPage
getID() - Method in class com.pvx.ooadide.preferences.BuilderOptions
getID() - Method in class com.pvx.ooadide.preferences.EditorOptions
getID() - Method in class com.pvx.ooadide.preferences.EditorOptionsPrefPage
getID() - Method in class com.pvx.ooadide.preferences.ImportOptionsPrefPage
getID() - Method in class com.pvx.ooadide.preferences.nomads.NomadsPreferencePage
getID() - Method in class com.pvx.ooadide.preferences.ObserversPreferencePage
getID() - Method in class com.pvx.ooadide.preferences.ProvideXPreferencePage
getID() - Method in class com.pvx.ooadide.preferences.UserDefinedPrefPage
getID() - Method in class com.sage.rcp.views.RcpEmbedJavXView
getID() - Method in class com.sage.rcp.views.RcpMasProgramView
getID() - Method in class com.sage.rcp.views.RcpProgramView
getID() - Method in class com.sage.rcp.views.RcpSpawnedMasProgramView
getIdentifier() - Method in class com.pvx.ooadide.properties.refactoring.core.RenamePropertyProcessor
getIdentifier() - Method in class com.pvx.ooadide.refactor.RenamePropertyProcessor
getImage() - Method in class com.pvx.ooadide.builder.CodeStyleWarningResolution
getImage() - Method in class com.pvx.ooadide.editors.PvxContextInformation
getImage() - Method in class com.pvx.ooadide.launchers.ProvideXArgumentsTab
getImage() - Method in class com.pvx.ooadide.launchers.ProvideXMainTab
getImage() - Method in class com.pvx.ooadide.launchers.thinclients.ClientTab
getImage() - Method in class com.pvx.ooadide.properties.ResourceToChangeEntity
getImage() - Method in class com.pvx.ooadide.util.PvxElement
getImage(Object) - Method in class com.pvx.ooadide.launchers.debug.launching.PVXModelPresentation
getImage(String, String) - Static method in class com.pvx.ooadide.util.PvxUtil
getImageDescriptor() - Method in class com.pvx.ooadide.editors.HandledInput
getImageDescriptor() - Method in class com.pvx.ooadide.uesearch.SearchGotoAction
getImageDescriptor() - Method in class com.pvx.ooadide.wizards.PasswordTransferElement
getImageDescriptor(String) - Static method in class com.sage.rcp.PvxRcpActivator
Returns an image descriptor for the image file at the given plug-in relative path
getImageForElement() - Method in class com.pvx.ooadide.views.nomads.PvxLibElement
getImageRegistry() - Method in class com.pvx.ooadide.editors.templates.TemplateEditorUI
getImplComponent() - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
getInformationControlCreator(ISourceViewer) - Method in class com.pvx.ooadide.codehilite2.XMLConfiguration2
getInformationDisplayString() - Method in class com.pvx.ooadide.editors.PvxContextInformation
getIniFileName(ILaunchConfiguration, IProject) - Method in class com.pvx.ooadide.launchers.ProvideXLaunchConfigurationDelegate1
getInitialInputLocationFieldValue() - Method in class com.pvx.ooadide.wizards.NewProjectFromExistingPage
getInitialOffset() - Method in class com.pvx.ooadide.launchers.debug.model.PVXArrayValue
getInputFolder() - Method in class com.pvx.ooadide.wizards.NewProjectFromExistingPage
getInputFolder() - Method in class com.pvx.ooadide.wizards.ProvidexNewWizardPage
getInputFolder() - Method in interface com.pvx.ooadide.wizards.ProvideXNewWizardPageI
getInputLocationPathField() - Method in class com.pvx.ooadide.wizards.NewProjectFromExistingPage
getInstance() - Static method in class com.pvx.ooadide.eventmanager.EventManager
getInstance() - Static method in class com.pvx.ooadide.eventmanager.PvxRequestManager
getInstance() - Static method in class com.sage.rcp.eventmanager.EventManager
getInternalImageStream(String) - Static method in class com.sage.rcp.javx.RcpPluginSwingGUIManager
getIViewSite() - Method in interface com.sage.rcp.javx.IEmbeddedJavXView
getIViewSite() - Method in class com.sage.rcp.views.HostActionsView
getIViewSite() - Method in class com.sage.rcp.views.RcpEmbedJavXView
getIWorkspace() - Static method in class com.pvx.ooadide.eventmanager.ResourceManager
getJarConfigs() - Static method in class com.pvx.ooadide.ProvideXOOADPlugin
getJavaPolicyFile(File) - Method in class com.pvx.ooadide.launchers.thinclients.javx.JavXAppletLaunchConfigurationDelegate
Returns the system property string for the policy file
getJavXView() - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
getKey() - Method in class com.pvx.ooadide.preferences.UserPrefElement
getKeywordKeys(Enumeration) - Static method in class com.pvx.ooadide.editors.MyCompletionProcessor
getKeywordsHashtable() - Method in class com.pvx.ooadide.editors.extkeyword.ExtKeywordCategoryEntity
getLabel() - Method in class com.pvx.ooadide.builder.CodeStyleWarningResolution
getLaunch() - Method in class com.pvx.ooadide.launchers.debug.model.PVXDebugTarget
getLibOutputDir() - Method in class com.pvx.ooadide.views.nomads.PvxLibElement
getLineNumber() - Method in class com.pvx.ooadide.launchers.debug.model.PVXStackFrame
getLineNumber() - Method in class com.pvx.ooadide.util.PvxElement
getListener() - Method in interface com.pvx.ooadide.actions.IExtCommand
getListener() - Method in class com.pvx.ooadide.eventmanager.ExtCommand
getLocationOfElement(String, int, boolean) - Method in class com.pvx.ooadide.editors.PvxEditor
getLocationOfPlugin() - Method in class com.sage.rcp.javx.RcpPluginSwingGUIManager
getLocationOfPvxHelpers() - Method in class com.sage.rcp.javx.RcpPluginSwingGUIManager
getLocationOfStateDirectory() - Method in class com.sage.rcp.javx.RcpPluginSwingGUIManager
getLocationPath() - Method in class com.pvx.ooadide.wizards.NewProjectFromExistingPage
Returns the current project location path as entered by the user, or its anticipated initial value.
getLocationPath() - Method in class com.pvx.ooadide.wizards.ProvidexNewWizardPage
getLocationPath() - Method in interface com.pvx.ooadide.wizards.ProvideXNewWizardPageI
Returns the current project location path as entered by the user, or its anticipated initial value.
getLocOfPvxPlugin() - Method in class com.pvx.ooadide.ProvideXOOADPlugin
getLog() - Method in interface com.sage.rcp.IPvxPlugin
getLookAndFeelMnemonic() - Static method in class com.sage.rcp.preferences.UiPrefManager
getMainTypeName(ILaunchConfiguration) - Method in class com.pvx.ooadide.launchers.thinclients.javx.JavXAppletLaunchConfigurationDelegate
getMapping(String) - Method in class com.pvx.ooadide.wizards.PasswordTransferElement
getMemoryBlock(long, long) - Method in class com.pvx.ooadide.launchers.debug.model.PVXDebugTarget
getMenuBarCollection() - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
getMenuCreator() - Method in class com.pvx.ooadide.uesearch.SearchGotoAction
getMessage() - Method in class com.pvx.ooadide.launchers.ProvideXArgumentsTab
getMnemonicCompletionProposals() - Static method in class com.pvx.ooadide.editors.MyCompletionProcessor
getModelIdentifier() - Method in class com.pvx.ooadide.launchers.debug.breakpoints.PVXLineBreakpoint
getModelIdentifier() - Method in class com.pvx.ooadide.launchers.debug.model.PVXDebugElement
getModelIdentifier() - Method in class com.pvx.ooadide.launchers.debug.model.PvxLineBreakpointAdapter
getModificationDate() - Method in class com.pvx.ooadide.properties.ResourceToChangeEntity
getMonitor() - Static method in class com.pvx.ooadide.eventmanager.EventManager
getName() - Method in class com.pvx.ooadide.editors.HandledInput
getName() - Method in class com.pvx.ooadide.launchers.debug.model.PvxArrayElementVariable
getName() - Method in class com.pvx.ooadide.launchers.debug.model.PVXDebugTarget
getName() - Method in class com.pvx.ooadide.launchers.debug.model.PVXStackFrame
getName() - Method in class com.pvx.ooadide.launchers.debug.model.PVXThread
getName() - Method in class com.pvx.ooadide.launchers.debug.model.PVXVariable
getName() - Method in class com.pvx.ooadide.launchers.IniFileBlock
getName() - Method in class com.pvx.ooadide.launchers.ProvideXArgumentsTab
getName() - Method in class com.pvx.ooadide.launchers.ProvideXMainTab
getName() - Method in class com.pvx.ooadide.launchers.thinclients.ClientTab
getName() - Method in class com.pvx.ooadide.launchers.thinclients.javx.JavXAppletArgumentsTab
getName() - Method in class com.pvx.ooadide.launchers.WindowStateBlock
getName() - Method in class com.pvx.ooadide.properties.ResourceToChangeEntity
getName() - Method in class com.pvx.ooadide.util.PvxElement
getName() - Method in class com.pvx.ooadide.views.nomads.PvxLibElement
getName() - Method in class com.pvx.ooadide.wizards.PasswordTransferElement
getNavigatorResources(IWorkbenchPart) - Static method in class com.pvx.ooadide.util.UtilCommands
getNavView() - Static method in class com.pvx.ooadide.util.PvxUtil
getNewName() - Method in class com.pvx.ooadide.properties.refactoring.core.ResourcePropertyInfo
getNewName() - Method in class com.pvx.ooadide.refactor.RenamePropertyInfo
getNewProjectPage() - Method in class com.pvx.ooadide.wizards.NewFromExisting
getNextInstId() - Static method in class com.sage.rcp.views.RcpEmbedJavXView
getNumberOfColumns(String) - Method in class com.pvx.ooadide.views.UIManager
getNumberOfColumns(String) - Method in class com.sage.rcp.eventmanager.UIManager
getNumberOfControls() - Method in class com.pvx.ooadide.preferences.SpacerFieldEditor
getNumberOfRows(String) - Method in class com.pvx.ooadide.views.UIManager
getNumberOfRows(String) - Method in class com.sage.rcp.eventmanager.UIManager
getNumMembers(IResource[]) - Static method in class com.pvx.ooadide.builder.ProvideXBuilder
getNumResourcesInSrcDir(IFolder) - Static method in class com.pvx.ooadide.builder.ProvideXBuilder
getObjectArgument(String) - Method in class com.pvx.ooadide.eventmanager.PvxEvent
Wraps the Properties iterator that contains the arguments of associated with this event
getObjectArgument(String) - Method in class com.sage.rcp.eventmanager.PvxEvent
Wraps the Properties iterator that contains the arguments of associated with this event
getObjectType() - Method in class com.pvx.ooadide.views.nomads.NewNomadsObjectDialog
getOffset() - Method in class com.pvx.ooadide.properties.refactoring.core.ResourcePropertyInfo
getOffset() - Method in class com.pvx.ooadide.refactor.RenamePropertyInfo
getOffsetOfTag(BufferedReader, String) - Static method in class com.pvx.ooadide.properties.refactoring.tagresolver.PvxtagResolver
getOffsetOfTag(IFile, String) - Static method in class com.pvx.ooadide.properties.refactoring.tagresolver.PvxtagResolver
getOldName() - Method in class com.pvx.ooadide.properties.refactoring.core.ResourcePropertyInfo
getOldName() - Method in class com.pvx.ooadide.refactor.RenamePropertyInfo
getOldValueOfTag(InputStream, int) - Static method in class com.pvx.ooadide.properties.refactoring.tagresolver.PvxtagResolver
getOperatingSystem() - Static method in class com.pvx.ooadide.util.PvxUtil
getOperatingSystem() - Static method in class com.sage.rcp.util.PvxUtil
getOsUserName() - Static method in class com.pvx.ooadide.util.UtilCommands
getOutlineSettings() - Method in class com.pvx.ooadide.ProvideXOOADPlugin
Get save Outline View settings for the current session
getOutputDirectory(IProject) - Static method in class com.pvx.ooadide.util.RunUtil
getOutputFileName() - Method in class com.pvx.ooadide.wizards.programs.PvxNewProgramPropertiesWizardPage
getOutputFolder() - Method in class com.pvx.ooadide.wizards.NewProjectFromExistingPage
getOutputFolder() - Method in class com.pvx.ooadide.wizards.ProvidexNewWizardPage
getOutputFolder() - Method in interface com.pvx.ooadide.wizards.ProvideXNewWizardPageI
getOutputLinkDIR(IProject) - Static method in class com.pvx.ooadide.builder.ProvideXBuilder
getPageToAdd() - Method in class com.pvx.ooadide.preferences.UserPrefElement
getParameter(String) - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
getParent() - Method in class com.sage.rcp.views.RcpEmbedJavXView
getPartName() - Method in class com.pvx.ooadide.views.WinDefine
getPathToFile() - Method in class com.pvx.ooadide.views.nomads.PvxLibElement
getPathToIni(IProject) - Static method in class com.pvx.ooadide.util.RunUtil
getPathToSelectedResourceInNavigator() - Method in class com.pvx.ooadide.eventmanager.ResourceManager
This method will return the string value of the first resources selected
getPersistable() - Method in class com.pvx.ooadide.editors.HandledInput
getPluginDataPath(IProject) - Static method in class com.pvx.ooadide.ProvideXOOADPlugin
getPluginId() - Method in class com.pvx.ooadide.ProvideXOOADPlugin
getPluginId() - Method in interface com.sage.rcp.IPvxPlugin
getPluginImageRegistry() - Method in class com.pvx.ooadide.ProvideXOOADPlugin
getPluginsContributingKeywords() - Static method in class com.pvx.ooadide.ProvideXOOADPlugin
getPosOnPage() - Method in class com.pvx.ooadide.preferences.UserPrefElement
getPreferenceInitializer() - Static method in class com.pvx.ooadide.preferences.PreferenceInitializer
getPreferenceStore() - Method in class com.pvx.ooadide.editors.templates.TemplateEditorUI
getPreferenceStore() - Method in interface com.sage.rcp.IPvxPlugin
getPrefsForFromProperties(Hashtable<String, Object>) - Method in class com.pvx.ooadide.ProvideXOOADPlugin
getPresentationReconciler(ISourceViewer) - Method in class com.pvx.ooadide.codehilite2.XMLConfiguration2
getPrgPassword(IResource, Vector<PvxProblem>) - Method in class com.pvx.ooadide.builder.ProvideXBuilder
getPriority() - Method in class com.pvx.ooadide.launchers.debug.model.PVXThread
getProcess() - Method in class com.pvx.ooadide.launchers.debug.model.PVXDebugTarget
getProcessor() - Method in class com.pvx.ooadide.properties.refactoring.core.RenamePropertyRefactoring
getProcessor() - Method in class com.pvx.ooadide.refactor.RenamePropertyRefactoring
getProcessorName() - Method in class com.pvx.ooadide.properties.refactoring.core.RenamePropertyProcessor
getProcessorName() - Method in class com.pvx.ooadide.refactor.RenamePropertyProcessor
getProgramArguments(ILaunchConfiguration) - Method in class com.pvx.ooadide.launchers.thinclients.javx.JavXAppletLaunchConfigurationDelegate
getProgressMonitor() - Static method in class com.pvx.ooadide.launchers.debug.communication.DebugServer
getProgressMonitor(String, int) - Static method in class com.pvx.ooadide.views.UIManager
Creates a progress monitor dialog.
getProgressMonitor(String, int) - Static method in class com.sage.rcp.eventmanager.UIManager
Creates a progress monitor dialog.
getProject() - Method in class com.pvx.ooadide.builder.ProvideXNature
getProject(String) - Static method in class com.pvx.ooadide.eventmanager.ResourceManager
Returns a handle to the project resource with the given name which is a child of this root.
getProjectBuilder() - Method in class com.pvx.ooadide.wizards.NewProjectFromExistingPage
getProjectBuilder() - Method in class com.pvx.ooadide.wizards.programs.PvxNewProgramPropertiesWizardPage
getProjectBuilder() - Method in class com.pvx.ooadide.wizards.ProvidexNewWizardPage
getProjectBuilder() - Method in interface com.pvx.ooadide.wizards.ProvideXNewWizardPageI
getProjectFromNavView() - Static method in class com.pvx.ooadide.util.PvxUtil
getProjectHandle() - Method in class com.pvx.ooadide.wizards.NewProjectFromExistingPage
Creates a project resource handle for the current project name field value.
getProjectHandle() - Method in class com.pvx.ooadide.wizards.ProvidexNewWizardPage
getProjectHandle() - Method in interface com.pvx.ooadide.wizards.ProvideXNewWizardPageI
Creates a project resource handle for the current project name field value.
getProjectName() - Method in class com.pvx.ooadide.wizards.NewProjectFromExistingPage
Returns the current project name as entered by the user, or its anticipated initial value.
getProjectName() - Method in class com.pvx.ooadide.wizards.ProvidexNewWizardPage
getProjectName() - Method in interface com.pvx.ooadide.wizards.ProvideXNewWizardPageI
getProjectOwnerCode() - Method in class com.pvx.ooadide.wizards.NewProjectFromExistingPage
getProjectOwnerCode() - Method in class com.pvx.ooadide.wizards.programs.PvxNewProgramPropertiesWizardPage
getProjectOwnerCode() - Method in class com.pvx.ooadide.wizards.ProvidexNewWizardPage
getProjectOwnerCode() - Method in interface com.pvx.ooadide.wizards.ProvideXNewWizardPageI
getProjectOwnerField() - Method in class com.pvx.ooadide.wizards.NewProjectFromExistingPage
getProjectOwnerFlags() - Method in class com.pvx.ooadide.wizards.NewProjectFromExistingPage
getProjectOwnerFlags() - Method in class com.pvx.ooadide.wizards.programs.PvxNewProgramPropertiesWizardPage
getProjectOwnerFlags() - Method in class com.pvx.ooadide.wizards.ProvidexNewWizardPage
getProjectOwnerFlags() - Method in interface com.pvx.ooadide.wizards.ProvideXNewWizardPageI
getProjectPassword() - Method in class com.pvx.ooadide.wizards.NewProjectFromExistingPage
getProjectPassword() - Method in class com.pvx.ooadide.wizards.programs.PvxNewProgramPropertiesWizardPage
getProjectPassword() - Method in class com.pvx.ooadide.wizards.ProvidexNewWizardPage
getProjectPassword() - Method in interface com.pvx.ooadide.wizards.ProvideXNewWizardPageI
getProjectPath() - Static method in class com.pvx.ooadide.util.ProjectUtils
Get the OS path of the current project based on selected resources in the Navigator view.
getProjectsInPropertiesFile(String) - Static method in class com.pvx.ooadide.util.PvxUtil
getProjectViaEditor() - Static method in class com.pvx.ooadide.util.PvxUtil
getPropertiesPage() - Method in class com.pvx.ooadide.wizards.programs.PvxWizardNewFileCreatePage
getProperty(IResource, String) - Static method in class com.pvx.ooadide.eventmanager.ResourceManager
Returns the value of the persistent property of this resource identified by the given key, or null if this resource has no such property.
getPropertyAction() - Static method in class com.pvx.ooadide.refactor.RenamePropertyAction
getPropertyKey() - Method in class com.pvx.ooadide.properties.refactoring.core.ResourcePropertyInfo
getPropsField() - Method in class com.pvx.ooadide.wizards.NewProjectFromExistingPage
getProvideXPlugin() - Static method in class com.sage.rcp.util.PvxRcpStateFlags
getPvxCompContainer() - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
getPvxCompletionProposals() - Method in class com.pvx.ooadide.editors.extkeyword.ExtKeywordCategoryEntity
getPvxDOMPath(IProject) - Static method in class com.pvx.ooadide.ProvideXOOADPlugin
getPvxEditor() - Static method in class com.pvx.ooadide.editors.MyCompletionProcessor
getPvxExeVersion(String) - Static method in class com.pvx.ooadide.util.RunUtil
getPvxHelperPath() - Static method in class com.pvx.ooadide.eventmanager.EventManager
Returns the path to the directory containing the ProvideX helper programs
getPvxHelperPath() - Method in class com.pvx.ooadide.ProvideXOOADPlugin
getPvxHelperPath() - Method in interface com.sage.rcp.IPvxPlugin
getPvxPath(IResource) - Static method in class com.pvx.ooadide.util.PvxUtil
getPvxPath(IResource, boolean) - Static method in class com.pvx.ooadide.util.PvxUtil
getPvxPluginInstance() - Static method in class com.pvx.ooadide.ProvideXOOADPlugin
getPvxPluginInstance() - Static method in class com.sage.rcp.PvxRcpActivator
getPvxTrackingKey() - Method in class com.sage.rcp.views.RcpEmbedJavXView
getPvxWizPage() - Method in class com.pvx.ooadide.wizards.NewNomadsLibraryWizard
getPvxWizPage() - Method in class com.pvx.ooadide.wizards.NewNomadsNmdWizard
getPvxWizPage() - Method in class com.pvx.ooadide.wizards.programs.NewPvxProgramWizard
getPvxWizPage() - Method in class com.pvx.ooadide.wizards.ProvideXNewWizard
getReconciler(ISourceViewer) - Method in class com.pvx.ooadide.codehilite2.XMLConfiguration2
getReferenceTypeName() - Method in class com.pvx.ooadide.launchers.debug.model.PVXValue
getReferenceTypeName() - Method in class com.pvx.ooadide.launchers.debug.model.PVXVariable
getRegisteredEditors(String) - Method in class com.pvx.ooadide.views.UIManager
Get a list of all of the editors associated with the specified file
getRegisteredEditors(String) - Method in class com.sage.rcp.eventmanager.UIManager
Get a list of all of the editors associated with the specified file
getRegisteredViews() - Method in class com.pvx.ooadide.views.UIManager
Return a list of views defined in the Eclipse registry.
getRegisteredViews() - Method in class com.sage.rcp.eventmanager.UIManager
Return a list of views defined in the Eclipse registry.
getRegisterGroups() - Method in class com.pvx.ooadide.launchers.debug.model.PVXStackFrame
getRequestManagerSocket() - Static method in class com.sage.rcp.javx.PvxHostLauncher
getRequestPort() - Method in class com.pvx.ooadide.launchers.debug.communication.DebugServer
getRequestSocket() - Static method in class com.pvx.ooadide.eventmanager.ResourceManager
getResizeHandler() - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
getResolutions(IMarker) - Method in class com.pvx.ooadide.builder.WarningResolutionGenerator
getResource() - Method in class com.pvx.ooadide.builder.PvxProblem
getResource(String) - Static method in class com.pvx.ooadide.eventmanager.ResourceManager
Returns the Resource for the specified path
getResourceBundle() - Static method in class com.pvx.ooadide.editors.templates.TemplateMessages
getResourceBundle() - Method in class com.pvx.ooadide.ProvideXOOADPlugin
Returns the plugin's resource bundle,
getResourcePath() - Method in class com.pvx.ooadide.builder.PvxProblem
getResourcePath() - Method in class com.pvx.ooadide.util.PvxElement
getResourceProject() - Static method in class com.pvx.ooadide.eventmanager.EventManager
getResponses() - Method in class com.pvx.ooadide.eventmanager.PvxEvent
getResponses() - Method in class com.sage.rcp.eventmanager.PvxEvent
getRunningExecutable() - Static method in class com.pvx.ooadide.util.RunUtil
getRunningPvxExecutable() - Static method in class com.pvx.ooadide.eventmanager.EventManager
getScopes() - Method in class com.pvx.ooadide.wizards.PasswordTransferElement
getScrllHeight() - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
getScrllWidth() - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
getSelectedResourceInNavigator() - Method in class com.pvx.ooadide.eventmanager.ResourceManager
This method will return the first resources selected
getSelectedTreeResourcesInNavigator() - Method in class com.pvx.ooadide.eventmanager.ResourceManager
This method enables retrieve of all selected resources
getSelection() - Method in class com.pvx.ooadide.refactor.RenamePropertyAction
getShell() - Static method in class com.pvx.ooadide.util.PvxUtil
getSingletonObject() - Static method in class com.sage.rcp.util.PvxRcpStateFlags
getSize() - Method in class com.pvx.ooadide.launchers.debug.model.PVXArrayValue
getSortBy() - Method in class com.pvx.ooadide.views.PvcOutlineSettings
getSourceFile() - Method in class com.pvx.ooadide.launchers.debug.breakpoints.PVXRunToLineBreakpoint
Returns the source file this breakpoint is contained in.
getSourceFile() - Method in class com.pvx.ooadide.properties.refactoring.core.ResourcePropertyInfo
getSourceFile() - Method in class com.pvx.ooadide.refactor.RenamePropertyInfo
getSourceName() - Method in class com.pvx.ooadide.launchers.debug.model.PVXStackFrame
Returns the name of the source file this stack frame is associated with.
getSourceName(Object) - Method in class com.pvx.ooadide.launchers.debug.launching.PVXSourceLookupParticipant
getSRCDIR(IProject) - Static method in class com.pvx.ooadide.builder.ProvideXBuilder
getSrcFile() - Method in class com.pvx.ooadide.util.PvxElement
getStackFrames() - Method in class com.pvx.ooadide.launchers.debug.model.PVXThread
getStandardArgs(IProject) - Static method in class com.pvx.ooadide.util.RunUtil
getStartLine() - Method in class com.pvx.ooadide.builder.PvxProblem
getStorage() - Method in class com.pvx.ooadide.editors.HandledInput
getStpElement(int) - Method in class com.pvx.ooadide.views.nomads.PvxLibElement
getStrikeThrough() - Method in class com.pvx.ooadide.preferences.EditorSyntaxColorPref
getString(String) - Static method in class com.pvx.ooadide.editors.templates.TemplateMessages
getString(String) - Static method in class com.pvx.ooadide.preferences.PreferenceManager
getStringPreference(String) - Static method in class com.pvx.ooadide.util.ProjectUtils
getStringProperty(String) - Static method in class com.pvx.ooadide.util.ProjectUtils
Get the value of specified String property from the project/workspace specific properties file
getStyle() - Method in class com.pvx.ooadide.uesearch.SearchGotoAction
getSubjectObj() - Method in class com.pvx.ooadide.eventmanager.DelayedMethodCall
getSubjectObj() - Method in class com.sage.rcp.eventmanager.DelayedMethodCall
getSwingWindowCompListener() - Method in class com.sage.rcp.javx.windows.PluginTextPlaneView
getSysFuncCompletionProposals() - Static method in class com.pvx.ooadide.editors.MyCompletionProcessor
getSystemDelimiter() - Static method in class com.pvx.ooadide.editors.templates.NewLineResolver
getSysVarsCompletionProposals() - Static method in class com.pvx.ooadide.editors.MyCompletionProcessor
getTaskDetail() - Method in class com.pvx.ooadide.views.MonitorState
getTaskDetail() - Method in class com.sage.rcp.eventmanager.MonitorState
getTaskName() - Method in class com.pvx.ooadide.views.MonitorState
getTaskName() - Method in class com.sage.rcp.eventmanager.MonitorState
getTcb29() - Method in class com.pvx.ooadide.util.PvxVersionInfo
getTempFile() - Method in class com.pvx.ooadide.properties.ResourceToChangeEntity
getTemplateStore() - Method in class com.pvx.ooadide.editors.templates.TemplateEditorUI
Returns this plug-in's template store.
getTestFolderList(ArrayList) - Static method in class com.pvx.ooadide.properties.ProvideXPropertyPage
getText() - Method in class com.pvx.ooadide.uesearch.SearchGotoAction
getText(Object) - Method in class com.pvx.ooadide.launchers.debug.launching.PVXModelPresentation
getText(Object) - Method in class com.pvx.ooadide.util.DefaultLabelProvider
getTextHover(ISourceViewer, String) - Method in class com.pvx.ooadide.codehilite2.XMLConfiguration2
getTextHover(ISourceViewer, String, int) - Method in class com.pvx.ooadide.codehilite2.XMLConfiguration2
getThread() - Method in class com.pvx.ooadide.launchers.debug.model.PVXStackFrame
getThreads() - Method in class com.pvx.ooadide.launchers.debug.model.PVXDebugTarget
getTitle() - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
getToolTipText() - Method in class com.pvx.ooadide.editors.HandledInput
getToolTipText() - Method in class com.pvx.ooadide.uesearch.SearchGotoAction
getTopRcpView() - Method in class com.sage.rcp.javx.windows.PluginTextPlaneView
getTopStackFrame() - Method in class com.pvx.ooadide.launchers.debug.model.PVXThread
getTopWindowDelegate() - Method in class com.sage.rcp.javx.RcpPluginSwingGUIManager
getTransElement() - Method in class com.pvx.ooadide.wizards.PasswordTransferElement
getType() - Method in class com.pvx.ooadide.properties.ResourceToChangeEntity
getType() - Method in class com.pvx.ooadide.util.PvxElement
getType() - Method in interface com.pvx.ooadide.views.comparators.IPvxElement
getType() - Method in class com.pvx.ooadide.views.nomads.PvxLibElement
getUnderLine() - Method in class com.pvx.ooadide.preferences.EditorSyntaxColorPref
getUserConfigs() - Static method in class com.pvx.ooadide.ProvideXOOADPlugin
getUserElemnt() - Method in class com.pvx.ooadide.properties.userdefined.UserDefinedPropField
getUserResourceProperties(Hashtable) - Method in class com.pvx.ooadide.ProvideXOOADPlugin
getUserResourceProps() - Static method in class com.pvx.ooadide.ProvideXOOADPlugin
getValue() - Method in class com.pvx.ooadide.launchers.debug.model.PvxArrayElementVariable
getValue() - Method in class com.pvx.ooadide.launchers.debug.model.PVXVariable
getValue() - Method in class com.pvx.ooadide.views.nomads.NewNomadsObjectDialog
Returns the string typed into this input dialog.
getValueString() - Method in class com.pvx.ooadide.launchers.debug.model.PVXArrayValue
getValueString() - Method in class com.pvx.ooadide.launchers.debug.model.PVXValue
getVariable(int) - Method in class com.pvx.ooadide.launchers.debug.model.PVXArrayValue
getVariables() - Method in class com.pvx.ooadide.launchers.debug.model.PVXArrayValue
getVariables() - Method in class com.pvx.ooadide.launchers.debug.model.PVXStackFrame
getVariables() - Method in class com.pvx.ooadide.launchers.debug.model.PVXValue
getVariables(int, int) - Method in class com.pvx.ooadide.launchers.debug.model.PVXArrayValue
getView() - Method in class com.sage.rcp.javx.RcpSwtViewPanel
getVMArguments(ILaunchConfiguration) - Method in class com.pvx.ooadide.launchers.thinclients.javx.JavXAppletLaunchConfigurationDelegate
getWidget() - Method in class com.pvx.ooadide.properties.userdefined.UserDefinedPropField
getWIN_Y() - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
getWizardPage() - Method in class com.pvx.ooadide.wizards.programs.PvxNewProgramPropertiesWizardPage
getWizardPage() - Method in class com.pvx.ooadide.wizards.ProvidexNewWizardPage
getWizardPage() - Method in interface com.pvx.ooadide.wizards.ProvideXNewWizardPageI
Returns the current project name as entered by the user, or its anticipated initial value.
getWorked() - Method in class com.pvx.ooadide.views.MonitorState
getWorked() - Method in class com.sage.rcp.eventmanager.MonitorState
getWorkspace() - Static method in class com.pvx.ooadide.eventmanager.ResourceManager
getWorkspacePath() - Static method in class com.pvx.ooadide.util.ProjectUtils
Get the OS Path to the current workspace root
getWorkspaceResource() - Static method in class com.pvx.ooadide.eventmanager.ResourceManager
getWorkspaceRoot() - Static method in class com.pvx.ooadide.util.PvxUtil
GradientPanel - Class in com.sage.rcp.resizeanimation
GradientPanel() - Constructor for class com.sage.rcp.resizeanimation.GradientPanel
GROUP - Enum constant in enum com.pvx.ooadide.views.PvcOutline.OutlineSortBy
A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form


H-Index

Index

A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form

H

handleConvertToASCII(IProject, IProgressMonitor) - Method in class com.pvx.ooadide.builder.ProvideXBuilder
handleDebugEvents(DebugEvent[]) - Method in class com.pvx.ooadide.launchers.thinclients.javx.JavXAppletLaunchConfigurationDelegate
HandledInput - Class in com.pvx.ooadide.editors
HandledInput(IFileEditorInput) - Constructor for class com.pvx.ooadide.editors.HandledInput
handleEvent(boolean, String, String, Properties) - Static method in class com.pvx.ooadide.eventmanager.EventManager
Sends a PvxEvent to the ProvideX EventManager.
handleEvent(boolean, String, String, Properties) - Static method in class com.sage.rcp.eventmanager.EventManager
Sends a PvxEvent to the ProvideX EventManager.
handleEvent(String) - Method in class com.pvx.ooadide.launchers.debug.breakpoints.PVXLineBreakpoint
handleEvent(String) - Method in interface com.pvx.ooadide.launchers.debug.model.IPVXEventListener
Notification the given event occurred in the target program being interpretted.
handleEvent(String) - Method in class com.pvx.ooadide.launchers.debug.model.PVXDebugTarget
handleEvent(String) - Method in class com.pvx.ooadide.launchers.debug.model.PvxLineBreakpointAdapter
handleEvent(String) - Method in class com.pvx.ooadide.launchers.debug.model.PVXThread
handleEvent(Event) - Method in class com.pvx.ooadide.views.comparators.SortListener
handleEvent(Event) - Method in class com.pvx.ooadide.wizards.WizardPasswordImportPage1
Handle events and enablements for widgets in this page
handleEvent(Event) - Method in class com.pvx.ooadide.wizards.WizardPasswordPage
Handle all events and enablements for widgets in this page
handleEventCallBack(String, String) - Method in interface com.sage.rcp.eventmanager.IPvxEventCallBack
hasConfig() - Method in interface com.pvx.ooadide.actions.IExtCommand
hasConfig() - Method in class com.pvx.ooadide.eventmanager.ExtCommand
hashCode() - Method in class com.pvx.ooadide.editors.PvxContextInformation
hashCode() - Method in class com.pvx.ooadide.launchers.debug.model.PVXStackFrame
hashCode() - Method in class com.pvx.ooadide.launchers.debug.model.PVXStackValue
hasMoreArguments() - Method in class com.pvx.ooadide.eventmanager.PvxEvent
Wraps the Properties iterator that contains the arguments of associated with this event
hasMoreArguments() - Method in class com.sage.rcp.eventmanager.PvxEvent
Wraps the Properties iterator that contains the arguments of associated with this event
hasPreference(String) - Static method in class com.pvx.ooadide.preferences.PreferenceManager
hasProjectMoved(IProject) - Static method in class com.pvx.ooadide.builder.ProvideXBuilder
Simple check to see if a project has moved using a new hidden property that saves the project location when the property page is updated.
hasRegisterGroups() - Method in class com.pvx.ooadide.launchers.debug.model.PVXStackFrame
hasResolutions(IMarker) - Method in class com.pvx.ooadide.builder.WarningResolutionGenerator
hasStackFrames() - Method in class com.pvx.ooadide.launchers.debug.model.PVXThread
hasThreads() - Method in class com.pvx.ooadide.launchers.debug.model.PVXDebugTarget
hasValueChanged() - Method in class com.pvx.ooadide.launchers.debug.model.PVXVariable
hasVariables() - Method in class com.pvx.ooadide.launchers.debug.model.PVXArrayValue
hasVariables() - Method in class com.pvx.ooadide.launchers.debug.model.PVXStackFrame
hasVariables() - Method in class com.pvx.ooadide.launchers.debug.model.PVXValue
hasVariables() - Method in class com.pvx.ooadide.launchers.debug.model.PVXVariable
height - Static variable in class com.sage.rcp.views.RcpEmbedJavXView
hideView(RcpEmbedJavXView) - Method in class com.sage.rcp.views.RcpEmbedJavXView
hideView(String) - Static method in class com.pvx.ooadide.views.UIManager
Hides the view identified
hideView(String) - Static method in class com.sage.rcp.eventmanager.UIManager
Hides the view identified
hideView(String) - Static method in class com.sage.rcp.util.PvxUtil
highLightAttrib(String) - Method in class com.pvx.ooadide.editors.PvxEditor
highLightFunction(String, String) - Method in class com.pvx.ooadide.editors.PvxEditor
highLightRoutine(String) - Method in class com.pvx.ooadide.editors.PvxEditor
highLiteElementAtLine(int, int) - Method in class com.pvx.ooadide.editors.PvxEditor
host - Static variable in class com.sage.rcp.javx.RcpPluginJavXApplet
HOST_IS_READY - Static variable in class com.pvx.ooadide.eventmanager.EventManager
HOST_IS_READY - Static variable in class com.sage.rcp.eventmanager.EventManager
HostActionsView - Class in com.sage.rcp.views
HostActionsView() - Constructor for class com.sage.rcp.views.HostActionsView
hostIsConnected() - Static method in class com.pvx.ooadide.eventmanager.EventManager
A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form


I-Index

Index

A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form

I

ICONS_PATH - Static variable in class com.pvx.ooadide.ui.PvxPluginImages
ID - Static variable in class com.pvx.ooadide.ConsoleDisplayManager
ID - Static variable in class com.pvx.ooadide.editors.NomadsEditor
ID - Static variable in class com.pvx.ooadide.editors.PvxEditor
ID - Static variable in class com.pvx.ooadide.navigator.ProjectExplorer
ID - Static variable in class com.pvx.ooadide.preferences.BuilderOptions
ID - Static variable in class com.pvx.ooadide.preferences.EditorOptionsPrefPage
ID - Static variable in class com.pvx.ooadide.preferences.ImportOptionsPrefPage
ID - Static variable in class com.pvx.ooadide.preferences.nomads.NomadsPreferencePage
ID - Static variable in class com.pvx.ooadide.preferences.ObserversPreferencePage
ID - Static variable in class com.pvx.ooadide.preferences.ProvideXPreferencePage
ID - Static variable in class com.pvx.ooadide.preferences.UserDefinedPrefPage
ID - Static variable in class com.pvx.ooadide.ProvideXOOADPlugin
ID - Static variable in class com.pvx.ooadide.views.IOListView
ID - Static variable in class com.pvx.ooadide.views.nomads.LibView
ID - Static variable in class com.pvx.ooadide.views.PvcOutline
ID - Static variable in class com.pvx.ooadide.views.WinDefine
ID - Static variable in class com.pvx.ooadide.wizards.NewFromExisting
ID - Static variable in class com.pvx.ooadide.wizards.NewNomadsLibraryWizard
ID - Static variable in class com.pvx.ooadide.wizards.NewNomadsNmdWizard
ID - Static variable in class com.pvx.ooadide.wizards.programs.NewPvcCreationWizard
ID - Static variable in class com.pvx.ooadide.wizards.programs.NewPvxProgramWizard
ID - Static variable in class com.pvx.ooadide.wizards.ProvideXNewWizard
ID - Static variable in class com.sage.rcp.ConsoleDisplayManager
ID - Static variable in class com.sage.rcp.eventmanager.ConsoleDisplayManager
ID - Static variable in class com.sage.rcp.PvxRcpActivator
ID - Static variable in class com.sage.rcp.views.HostActionsView
ID - Static variable in class com.sage.rcp.views.RcpEmbedJavXView
ID - Static variable in class com.sage.rcp.views.RcpMasProgramView
ID - Static variable in class com.sage.rcp.views.RcpProgramView
ID - Static variable in class com.sage.rcp.views.RcpSpawnedMasProgramView
ID_PVX_DEBUG_MODEL - Static variable in class com.pvx.ooadide.Constants
IEmbeddedJavXView - Interface in com.sage.rcp.javx
IEventManager - Interface in com.sage.rcp
IExtCommand - Interface in com.pvx.ooadide.actions
imageDescriptorFromPlugin(String, String) - Static method in class com.pvx.ooadide.editors.templates.TemplateEditorUI
IMG_OUTLINE_FILTER_NONE - Static variable in class com.pvx.ooadide.ui.PvxPluginImages
IMG_OUTLINE_SETTINGS - Static variable in class com.pvx.ooadide.ui.PvxPluginImages
IMG_OUTLINE_SORTBY_GROUP - Static variable in class com.pvx.ooadide.ui.PvxPluginImages
IMG_OUTLINE_SORTBY_LINENUM - Static variable in class com.pvx.ooadide.ui.PvxPluginImages
IMG_OUTLINE_SORTBY_RESET - Static variable in class com.pvx.ooadide.ui.PvxPluginImages
IMPORT - Static variable in class com.pvx.ooadide.eventmanager.EventManager
IMPORT_EXPORT_FILE - Static variable in class com.pvx.ooadide.eventmanager.EventManager
IMPORT_EXPORT_PROPERTIES - Static variable in class com.pvx.ooadide.eventmanager.EventManager
importDirStructure() - Method in class com.pvx.ooadide.properties.dialogs.PxvResourceListSelectionDialog
IMPORTING_END - Static variable in class com.pvx.ooadide.eventmanager.EventManager
IMPORTING_START - Static variable in class com.pvx.ooadide.eventmanager.EventManager
ImportOptionsPrefPage - Class in com.pvx.ooadide.preferences
ImportOptionsPrefPage() - Constructor for class com.pvx.ooadide.preferences.ImportOptionsPrefPage
ImportPasswordsWizard - Class in com.pvx.ooadide.wizards
Standard workbench wizard for importing resources from the local file system into the workspace.
ImportPasswordsWizard() - Constructor for class com.pvx.ooadide.wizards.ImportPasswordsWizard
Creates a wizard for importing resources into the workspace from the file system.
incorrectLic - Static variable in class com.sage.rcp.javx.RcpPluginConnectionControl
INCREMENTAL_BUILD - Static variable in class com.pvx.ooadide.eventmanager.EventManager
INCREMENTAL_BUILD_ALT_EXE - Static variable in class com.pvx.ooadide.eventmanager.EventManager
IniFileBlock - Class in com.pvx.ooadide.launchers
Editor for VM arguments of a Java launch configuration.
IniFileBlock() - Constructor for class com.pvx.ooadide.launchers.IniFileBlock
init(Color) - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
init(IViewSite, IMemento) - Method in class com.sage.rcp.views.RcpProgramView
init(IWorkbench) - Method in class com.pvx.ooadide.preferences.AbstractProvideXFieldEditorPrefPage
init(IWorkbench) - Method in class com.pvx.ooadide.preferences.EditorColorPreferencePage
init(IWorkbench) - Method in class com.pvx.ooadide.preferences.ImportOptionsPrefPage
init(IWorkbench) - Method in class com.pvx.ooadide.preferences.PasswordPreferences
init(IWorkbench) - Method in class com.pvx.ooadide.preferences.ProvideXPreferencePage
init(IWorkbench) - Method in class com.sage.rcp.preferences.ProgramViewsPrefs
init(IWorkbench, IStructuredSelection) - Method in class com.pvx.ooadide.wizards.ImportPasswordsWizard
init(IWorkbench, IStructuredSelection) - Method in class com.pvx.ooadide.wizards.NewFromExisting
init(IWorkbench, IStructuredSelection) - Method in class com.pvx.ooadide.wizards.NewNomadsLibraryWizard
We will accept the selection in the workbench to see if we can initialize from it.
init(IWorkbench, IStructuredSelection) - Method in class com.pvx.ooadide.wizards.NewNomadsNmdWizard
We will accept the selection in the workbench to see if we can initialize from it.
init(IWorkbench, IStructuredSelection) - Method in class com.pvx.ooadide.wizards.PasswordExporterWizard
init(IWorkbench, IStructuredSelection) - Method in class com.pvx.ooadide.wizards.programs.NewPvxProgramWizard
We will accept the selection in the workbench to see if we can initialize from it.
init(IWorkbench, IStructuredSelection) - Method in class com.pvx.ooadide.wizards.ProvideXNewWizard
We will accept the selection in the workbench to see if we can initialize from it.
init(IWorkbenchWindow) - Method in class com.pvx.ooadide.actions.ExtAction
init(IWorkbenchWindow) - Method in class com.pvx.ooadide.actions.GenericWorkbenchAction
init(IWorkbenchWindow) - Method in class com.pvx.ooadide.actions.ProvideX
We will cache window object in order to be able to provide parent shell for the message dialog.
INIT_TEXT$ - Static variable in class com.pvx.ooadide.views.nomads.PvxLibElement
initConnection(RcpPluginConnectionControl) - Method in class com.pvx.ooadide.eventmanager.EventManager
initDialFactory() - Method in class com.sage.rcp.javx.RcpPluginSwingGUIManager
initializeArgsParameters(String[]) - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
initialized - Variable in class com.pvx.ooadide.eventmanager.EditorState
initializeDefaultPreferences() - Method in class com.pvx.ooadide.preferences.PreferenceInitializer
initializeDefaultPreferences() - Method in class com.sage.rcp.preferences.RcpPreferenceInitializer
initializeEditorState(String, ITextSelection, int) - Method in class com.pvx.ooadide.eventmanager.EditorState
initializeFrom(ILaunchConfiguration) - Method in class com.pvx.ooadide.launchers.IniFileBlock
initializeFrom(ILaunchConfiguration) - Method in class com.pvx.ooadide.launchers.ProvideXArgumentsTab
initializeFrom(ILaunchConfiguration) - Method in class com.pvx.ooadide.launchers.ProvideXMainTab
initializeFrom(ILaunchConfiguration) - Method in class com.pvx.ooadide.launchers.thinclients.ClientTab
initializeFrom(ILaunchConfiguration) - Method in class com.pvx.ooadide.launchers.WindowStateBlock
initializeHost() - Method in class com.sage.rcp.views.RcpEmbedJavXView
initializeHost() - Method in class com.sage.rcp.views.RcpMasProgramView
initializeHost() - Method in class com.sage.rcp.views.RcpProgramView
initializeParticipants() - Method in class com.pvx.ooadide.launchers.debug.launching.PVXSourceLookupDirector
initializePropertyFromArgsMap(Map, IProject, String) - Method in class com.pvx.ooadide.builder.ProvideXBuilder
initialReconcile() - Method in class com.pvx.ooadide.editors.codefolding.PvxReconcilingStrategy
initMainWindow(PvxBaseWindow) - Method in class com.sage.rcp.javx.RcpPluginSwingGUIManager
initOperatingSystem() - Static method in class com.pvx.ooadide.util.PvxUtil
initOperatingSystem() - Static method in class com.sage.rcp.util.PvxUtil
initSession() - Method in class com.sage.rcp.javx.RcpPluginConnectionControl
initSession(PvxBaseWindow) - Method in class com.sage.rcp.javx.RcpPluginSwingGUIManager
initStatusMessage() - Method in class com.sage.rcp.views.RcpEmbedJavXView
initStatusMessage() - Method in class com.sage.rcp.views.RcpSpawnedMasProgramView
inputChanged(Viewer, Object, Object) - Method in class com.pvx.ooadide.util.DefaultItemContentProvider
inputChanged(Viewer, Object, Object) - Method in class com.pvx.ooadide.views.nomads.LibView.ViewContentProvider
insertText(String, int) - Method in class com.pvx.ooadide.eventmanager.EditorManager
Inserts text at the specified position with in the open pvx
install(PVXDebugTarget) - Method in class com.pvx.ooadide.launchers.debug.breakpoints.PVXLineBreakpoint
Installs this breakpoint in the given interprettor.
install(PVXDebugTarget) - Method in class com.pvx.ooadide.launchers.debug.model.PvxLineBreakpointAdapter
Installs this breakpoint in the given interprettor.
install(IContextInformation, ITextViewer, int) - Method in class com.pvx.ooadide.editors.PvxParameterListValidator
INSTANCE_NUM - Static variable in class com.sage.rcp.javx.RcpPluginConnectionControl
instanceCtr - Static variable in class com.sage.rcp.views.RcpEmbedJavXView
internalDialogues - Static variable in class com.sage.rcp.javx.windows.PluginTextPlaneView
internalGetActivePage() - Method in class com.pvx.ooadide.ProvideXOOADPlugin
internalGetActivePage() - Method in interface com.sage.rcp.IPvxPlugin
internalGetActivePage() - Method in class com.sage.rcp.PvxRcpActivator
internalWindowsOnly() - Static method in class com.sage.rcp.preferences.UiPrefManager
INVALID - Static variable in class com.pvx.ooadide.eventmanager.EventManager
invokeContributedTool(String) - Static method in class com.pvx.ooadide.util.RunUtil
invokeContributedTool(String, boolean) - Static method in class com.pvx.ooadide.util.RunUtil
IOLIST_SCAN - Static variable in class com.pvx.ooadide.eventmanager.EventManager
IOLIST_SCANNER_PROGRAM - Static variable in class com.pvx.ooadide.util.RunUtil
IOLIST_VIEW_ID - Static variable in class com.pvx.ooadide.views.UIManager
IOListLabelProvider() - Constructor for class com.pvx.ooadide.views.IOListView.IOListLabelProvider
IOListView - Class in com.pvx.ooadide.views
IOListView() - Constructor for class com.pvx.ooadide.views.IOListView
IOListView.IOListLabelProvider - Class in com.pvx.ooadide.views
IOLOG_NAME - Static variable in class com.pvx.ooadide.views.IOListView
IPvxElement - Interface in com.pvx.ooadide.views.comparators
IPvxEventCallBack - Interface in com.sage.rcp.eventmanager
IPVXEventListener - Interface in com.pvx.ooadide.launchers.debug.model
IPvxIdePlugin - Interface in com.pvx.ooadide
IPvxPlugin - Interface in com.sage.rcp
IPvxSaveListener - Interface in com.pvx.ooadide.builder
IS_ADD_EXT_TO_ALL - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
IS_BINARY - Static variable in class com.pvx.ooadide.util.PvxFileUtils
IS_TEXT - Static variable in class com.pvx.ooadide.util.PvxFileUtils
isAllocated() - Method in class com.pvx.ooadide.launchers.debug.model.PVXArrayValue
isAllocated() - Method in class com.pvx.ooadide.launchers.debug.model.PVXValue
isAllProjects() - Method in class com.pvx.ooadide.refactor.RenamePropertyInfo
isApplicable() - Method in class com.pvx.ooadide.properties.refactoring.core.RenamePropertyProcessor
isApplicable() - Method in class com.pvx.ooadide.refactor.RenamePropertyProcessor
isAutoStartChar(char) - Method in class com.pvx.ooadide.editors.MyCompletionProcessor
isBlock() - Method in class com.pvx.ooadide.eventmanager.DelayedEvent
isBlocking() - Static method in class com.pvx.ooadide.eventmanager.EventManager
True if Eclipse is waiting for ProvideX to complete processing and event
isBlocking() - Static method in class com.sage.rcp.eventmanager.EventManager
True if Eclipse is waiting for ProvideX to complete processing and event
isBorderIsVisible() - Method in class com.sage.rcp.views.RcpEmbedJavXView
isBuilderRunning() - Static method in class com.pvx.ooadide.builder.ProvideXBuilder
isCanceled() - Static method in class com.pvx.ooadide.builder.ProvideXBuilder
isCanceled() - Method in class com.sage.rcp.util.ProgressIndicator
isCancelled() - Method in class com.pvx.ooadide.views.MonitorState
isCancelled() - Method in class com.sage.rcp.eventmanager.MonitorState
isChecked() - Method in class com.pvx.ooadide.uesearch.SearchGotoAction
isContextInformationValid(int) - Method in class com.pvx.ooadide.editors.PvxParameterListValidator
isConvertingResources() - Static method in class com.pvx.ooadide.builder.ProvideXBuilder
isDebugWindowRequired() - Method in class com.pvx.ooadide.ProvideXOOADPlugin
isDebugWindowRequired() - Method in interface com.sage.rcp.IPvxPlugin
isDialogue() - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
isDialogueVisible() - Method in class com.pvx.ooadide.views.MonitorState
isDialogueVisible() - Method in class com.sage.rcp.eventmanager.MonitorState
isDialWMnu() - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
isDisconnected() - Method in class com.pvx.ooadide.launchers.debug.model.PVXDebugTarget
isDoable() - Method in class com.pvx.ooadide.util.PvxUtil.ConfirmDialShower
isDoable() - Method in class com.sage.rcp.util.PvxUtil.ConfirmDialShower
isDone() - Method in class com.pvx.ooadide.views.MonitorState
isDone() - Method in class com.sage.rcp.eventmanager.MonitorState
isEclipseShutingDown() - Static method in class com.pvx.ooadide.eventmanager.EventManager
isEclipseShutingDown() - Static method in class com.sage.rcp.eventmanager.EventManager
isEditorExtension(String, String, ArrayList) - Static method in class com.pvx.ooadide.util.ExtensionUtil
isEmbedMainWindowOnApplet() - Method in class com.sage.rcp.javx.RcpPluginSwingGUIManager
isEnabled() - Method in class com.pvx.ooadide.preferences.UserPrefElement
isEnabled() - Method in class com.pvx.ooadide.uesearch.SearchGotoAction
isEventManagerWaiting() - Static method in class com.pvx.ooadide.eventmanager.EventManager
isEventManagerWaiting() - Static method in class com.sage.rcp.eventmanager.EventManager
isExecuteInEvntQue() - Method in class com.pvx.ooadide.eventmanager.DelayedMethodCall
isExecuteInEvntQue() - Method in class com.sage.rcp.eventmanager.DelayedMethodCall
isFileOpenAlready(IFile) - Static method in class com.pvx.ooadide.editors.XEditorMatchingStrategy
isFileOpenAlready(IEditorReference, IFile) - Static method in class com.pvx.ooadide.editors.XEditorMatchingStrategy
isFunction() - Method in class com.pvx.ooadide.refactor.RenamePropertyInfo
isFunction(String) - Method in class com.pvx.ooadide.editors.PvxEditor
isFunctionStyle(String) - Static method in class com.pvx.ooadide.editors.PvxParameterListValidator
isHandled() - Method in class com.pvx.ooadide.uesearch.SearchGotoAction
isIncorrectLic() - Static method in class com.sage.rcp.javx.RcpPluginConnectionControl
isInInvalidList(IFile) - Static method in class com.pvx.ooadide.properties.ProvideXPropertyPage
isInSrcDir(IResource) - Static method in class com.pvx.ooadide.builder.ProvideXBuilder
isLineNoReq() - Method in class com.pvx.ooadide.wizards.programs.PvxNewProgramPropertiesWizardPage
IsLineNoReqPropertyResolver - Class in com.pvx.ooadide.editors.templates
IsLineNoReqPropertyResolver() - Constructor for class com.pvx.ooadide.editors.templates.IsLineNoReqPropertyResolver
isListening() - Static method in class com.pvx.ooadide.eventmanager.PvxRequestManager
isNomadsEditorExtension(String) - Static method in class com.pvx.ooadide.util.ExtensionUtil
isNumericArg(String) - Static method in class com.pvx.ooadide.util.PvxUtil
isOutputDirectory(IResource) - Static method in class com.pvx.ooadide.builder.ProvideXBuilder
isPasswordValid(String, String) - Static method in class com.pvx.ooadide.builder.PvxPasswordInputDialogue
isPluginAdded() - Static method in class com.pvx.ooadide.ProvideXOOADPlugin
isProperty(String) - Method in class com.pvx.ooadide.editors.PvxEditor
isProposalVisible() - Method in class com.pvx.ooadide.editors.MyCompletionProcessor
isPvxDataFile(IResource) - Static method in class com.pvx.ooadide.util.PvxFileUtils
isPvxEditorExtension(String) - Static method in class com.pvx.ooadide.util.ExtensionUtil
isPvxOtherFile(IResource) - Static method in class com.pvx.ooadide.util.PvxFileUtils
isPvxProgram(IResource) - Static method in class com.pvx.ooadide.util.PvxFileUtils
isPvxProgressMonitorDialogVisible() - Static method in class com.pvx.ooadide.views.UIManager
isPvxProgressMonitorDialogVisible() - Static method in class com.sage.rcp.eventmanager.UIManager
isPvxProject(IProject) - Static method in class com.pvx.ooadide.util.PvxUtil
isPvxReady() - Static method in class com.pvx.ooadide.eventmanager.EventManager
isPvxReady() - Static method in class com.sage.rcp.eventmanager.EventManager
isResizable() - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
isResizeControlsEnabled() - Method in class com.sage.rcp.views.RcpEmbedJavXView
isResourceInSourceDirectory(IResource) - Static method in class com.pvx.ooadide.eventmanager.ResourceManager
Returns true if the specified resource is located in a Project's input directory
isRunning() - Method in class com.sage.rcp.views.RcpEmbedJavXView
isRunToLineBreakpoint() - Method in class com.pvx.ooadide.launchers.debug.breakpoints.PVXLineBreakpoint
Returns whether this breakpoint is a run-to-line breakpoint
isRunToLineBreakpoint() - Method in class com.pvx.ooadide.launchers.debug.breakpoints.PVXRunToLineBreakpoint
Returns whether this breakpoint is a run-to-line breakpoint
isRunToLineBreakpoint() - Method in class com.pvx.ooadide.launchers.debug.model.PvxLineBreakpointAdapter
Returns whether this breakpoint is a run-to-line breakpoint
isSourceDirectory(IResource) - Static method in class com.pvx.ooadide.builder.ProvideXBuilder
isStepping() - Method in class com.pvx.ooadide.launchers.debug.model.PVXStackFrame
isStepping() - Method in class com.pvx.ooadide.launchers.debug.model.PVXThread
isSuspended() - Method in class com.pvx.ooadide.launchers.debug.model.PVXDebugTarget
isSuspended() - Method in class com.pvx.ooadide.launchers.debug.model.PVXStackFrame
isSuspended() - Method in class com.pvx.ooadide.launchers.debug.model.PVXThread
isTerminated() - Method in class com.pvx.ooadide.eventmanager.PvxRequestManager
isTerminated() - Method in class com.pvx.ooadide.launchers.debug.model.PVXDebugTarget
isTerminated() - Method in class com.pvx.ooadide.launchers.debug.model.PVXStackFrame
isTerminated() - Method in class com.pvx.ooadide.launchers.debug.model.PVXThread
isUpdateBundle() - Method in class com.pvx.ooadide.refactor.RenamePropertyInfo
isUseDefaults() - Method in class com.pvx.ooadide.wizards.ProvidexNewWizardPage
isUseDefaults() - Method in interface com.pvx.ooadide.wizards.ProvideXNewWizardPageI
isUseInputDefaults() - Method in class com.pvx.ooadide.wizards.ProvidexNewWizardPage
isUseInputDefaults() - Method in interface com.pvx.ooadide.wizards.ProvideXNewWizardPageI
isUseOutputDefaults() - Method in class com.pvx.ooadide.wizards.ProvidexNewWizardPage
isUseOutputDefaults() - Method in interface com.pvx.ooadide.wizards.ProvideXNewWizardPageI
isValid() - Method in class com.pvx.ooadide.preferences.AbstractProvideXFieldEditorPrefPage
isValid(ILaunchConfiguration) - Method in class com.pvx.ooadide.launchers.ProvideXArgumentsTab
isValid(ILaunchConfiguration) - Method in class com.pvx.ooadide.launchers.ProvideXMainTab
isValid(ILaunchConfiguration) - Method in class com.pvx.ooadide.launchers.thinclients.ClientTab
isValid(ILaunchConfiguration) - Method in class com.pvx.ooadide.launchers.WindowStateBlock
isValidPvxExtension(String) - Static method in class com.pvx.ooadide.eventmanager.ResourceManager
Returns true if the specified extension is associated with the ProvideX Editor
isViewVisible(String) - Static method in class com.pvx.ooadide.views.UIManager
Returns whether the specified Eclipse part is visible.
isViewVisible(String) - Static method in class com.sage.rcp.eventmanager.UIManager
Returns whether the specified Eclipse part is visible.
isWarning() - Method in class com.pvx.ooadide.builder.PvxProblem
isWhitespace(char) - Method in class com.pvx.ooadide.editors.MyCompletionProcessor
isWizardRunning() - Static method in class com.pvx.ooadide.wizards.NewFromExisting
isWizardRunning() - Static method in class com.pvx.ooadide.wizards.ProvideXNewWizard
isWordPart(char) - Method in class com.pvx.ooadide.codehilite2.ExtKeywordDetector
isWordPart(char) - Method in class com.pvx.ooadide.codehilite2.PvxDirectiveWordRule.DirectiveWordDetector
isWordPart(char) - Method in class com.pvx.ooadide.codehilite2.PvxLineLabelWordRule.LineLabelWordDetector
isWordPart(char) - Method in class com.pvx.ooadide.codehilite2.PvxMnemonicRule.MnemonicWordDetector
isWordPart(char) - Method in class com.pvx.ooadide.codehilite2.PvxNumbLiteralRule.numbWordDetector
isWordStart(char) - Method in class com.pvx.ooadide.codehilite2.ExtKeywordDetector
isWordStart(char) - Method in class com.pvx.ooadide.codehilite2.PvxDirectiveWordRule.DirectiveWordDetector
isWordStart(char) - Method in class com.pvx.ooadide.codehilite2.PvxLineLabelWordRule.LineLabelWordDetector
isWordStart(char) - Method in class com.pvx.ooadide.codehilite2.PvxMnemonicRule.MnemonicWordDetector
isWordStart(char) - Method in class com.pvx.ooadide.codehilite2.PvxNumbLiteralRule.numbWordDetector
IT_PROGRAM - Static variable in class com.pvx.ooadide.util.RunUtil
A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form


J-Index

Index

A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form

J

JAVX_ARGS_STRING - Static variable in class com.sage.rcp.views.RcpProgramView
JAVX_NAME - Static variable in class com.pvx.ooadide.launchers.thinclients.javx.JavXAppletArgumentsTab
JavXAppletArgumentsTab - Class in com.pvx.ooadide.launchers.thinclients.javx
JavXAppletArgumentsTab() - Constructor for class com.pvx.ooadide.launchers.thinclients.javx.JavXAppletArgumentsTab
JavXAppletLaunchConfigurationDelegate - Class in com.pvx.ooadide.launchers.thinclients.javx
JavXAppletLaunchConfigurationDelegate() - Constructor for class com.pvx.ooadide.launchers.thinclients.javx.JavXAppletLaunchConfigurationDelegate
JavXAppletName - Static variable in class com.pvx.ooadide.Constants
JavXAppletTabGroup - Class in com.pvx.ooadide.launchers.thinclients.javx
JavXAppletTabGroup() - Constructor for class com.pvx.ooadide.launchers.thinclients.javx.JavXAppletTabGroup
Constructs a new Java applet tab group.
JavXBrowserView - Class in com.pvx.ooadide.views
This sample class demonstrates how to plug-in a new workbench view.
JavXBrowserView() - Constructor for class com.pvx.ooadide.views.JavXBrowserView
The constructor.
JavXThread - Class in com.sage.rcp.views
JavXThread(RcpEmbedJavXView, RcpEmbedJavXView) - Constructor for class com.sage.rcp.views.JavXThread
javXWasStarted() - Static method in class com.pvx.ooadide.eventmanager.EventManager
Returns true if a connection to the ProvideX EventManager was previously established
jsForceFocus() - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form


K-Index

Index

A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form

K

keywordPrefList - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
keywordsCategories - Static variable in class com.pvx.ooadide.editors.MyCompletionProcessor
KEYWORDSCATS_PROPERTIES_FILE - Static variable in class com.pvx.ooadide.editors.MyCompletionProcessor
A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form


L-Index

Index

A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form

L

launch(ILaunchConfiguration, String, ILaunch, IProgressMonitor) - Method in class com.pvx.ooadide.launchers.ProvideXLaunchConfigurationDelegate1
launch(ILaunchConfiguration, String, ILaunch, IProgressMonitor) - Method in class com.pvx.ooadide.launchers.thinclients.javx.JavXAppletLaunchConfigurationDelegate
Used to map temp file to launch obejct.
launchDebugPvxHost(int, int, String, int, ILaunch) - Static method in class com.pvx.ooadide.launchers.thinclients.WindXLaunchConfigurationDelegate1
launchPvxHost(int) - Static method in class com.sage.rcp.javx.PvxHostLauncher
launchPvxHost(int, boolean) - Static method in class com.sage.rcp.javx.PvxHostLauncher
launchPvxHost(int, String) - Static method in class com.sage.rcp.javx.PvxHostLauncher
launchPvxHost(String[]) - Static method in class com.sage.rcp.javx.PvxHostLauncher
lib - Static variable in class com.pvx.ooadide.views.WinDefine
LIB_SCAN - Static variable in class com.pvx.ooadide.eventmanager.EventManager
LIB_SCANNER_PROGRAM - Static variable in class com.pvx.ooadide.util.RunUtil
LIBLOG_NAME - Static variable in class com.pvx.ooadide.views.nomads.LibView
LibView - Class in com.pvx.ooadide.views.nomads
This class displays / updates the information in the NOMADS view
LibView() - Constructor for class com.pvx.ooadide.views.nomads.LibView
The constructor.
LibView.ViewContentProvider - Class in com.pvx.ooadide.views.nomads
LibView.ViewLabelProvider - Class in com.pvx.ooadide.views.nomads
LINE_NUMBER - Enum constant in enum com.pvx.ooadide.views.PvcOutline.OutlineSortBy
LineLabelWordDetector() - Constructor for class com.pvx.ooadide.codehilite2.PvxLineLabelWordRule.LineLabelWordDetector
LINKED_DELIM - Static variable in class com.pvx.ooadide.properties.ProvideXPropertyPage
linkToExternalFolder(String, IFolder, IProject, IProgressMonitor) - Static method in class com.pvx.ooadide.wizards.ProvideXNewWizard
LIST - Static variable in class com.pvx.ooadide.util.PvxUtil
LIST_DATA - Static variable in class com.pvx.ooadide.util.PvxUtil
LIST_OF_PROPERITES - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
LOAD - Static variable in class com.pvx.ooadide.eventmanager.EventManager
loadClassForName(String) - Method in class com.pvx.ooadide.ProvideXOOADPlugin
loadClassForName(String) - Method in interface com.sage.rcp.IPvxPlugin
loadExtKeywordCategories() - Static method in class com.pvx.ooadide.editors.MyCompletionProcessor
loadParticipants(RefactoringStatus, SharableParticipants) - Method in class com.pvx.ooadide.properties.refactoring.core.RenamePropertyProcessor
loadParticipants(RefactoringStatus, SharableParticipants) - Method in class com.pvx.ooadide.refactor.RenamePropertyProcessor
loadProgram(IProject, String) - Static method in class com.pvx.ooadide.util.RunUtil
LoadProgramAction - Class in com.pvx.ooadide.editors
LoadProgramAction() - Constructor for class com.pvx.ooadide.editors.LoadProgramAction
LOCAL_FUNC_FILTER - Enum constant in enum com.pvx.ooadide.views.PvcOutline.OutlineFilter
LOCAL_PROP_FILTER - Enum constant in enum com.pvx.ooadide.views.PvcOutline.OutlineFilter
LOCAL_SYMBOL - Static variable in class com.pvx.ooadide.util.PvxElement
LOCAL_TYPE - Static variable in class com.pvx.ooadide.util.PvxElement
log(String, Throwable) - Static method in class com.pvx.ooadide.util.PvxUtil
log(String, Throwable) - Static method in class com.sage.rcp.util.PvxUtil
log(Throwable) - Static method in class com.pvx.ooadide.util.PvxUtil
log(Throwable) - Static method in class com.sage.rcp.util.PvxUtil
log(IStatus) - Static method in class com.pvx.ooadide.ProvideXOOADPlugin
logAvailableData() - Method in class com.pvx.ooadide.launchers.debug.model.PVXDebugTarget
A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form


M-Index

Index

A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form

M

main(String[]) - Static method in class com.pvx.ooadide.util.RunPvxTester
makeColorToken(String, String, String, String, String, String) - Static method in class com.pvx.ooadide.codehilite2.ColourTokenFactory
makeColorToken(String, String, String, String, String, String, IPreferenceStore) - Static method in class com.pvx.ooadide.codehilite2.ColourTokenFactory
makeEventManager() - Static method in class com.pvx.ooadide.eventmanager.EventManagerFactory
Creates an EventManager class that Controls communication between Eclipse and ProvideX
makeGUIManager(PvxHost) - Method in class com.sage.rcp.views.HostActionsView
makeGUIManager(PvxHost) - Method in class com.sage.rcp.views.RcpEmbedJavXView
makeTextPlaneView(PvxCanvas, Component, PvxHost) - Method in class com.sage.rcp.javx.RcpPluginSwingGUIManager
markAllProblemFiles(Enumeration) - Static method in class com.pvx.ooadide.builder.PvxProblem
markFileAsResource(IResource) - Static method in class com.pvx.ooadide.builder.ProvideXBuilder
markFileAsResource(IResource, boolean) - Static method in class com.pvx.ooadide.builder.ProvideXBuilder
markProblemFile() - Method in class com.pvx.ooadide.builder.PvxProblem
markProblemFile() - Method in class com.pvx.ooadide.builder.StyleWarning
markProblemFile(IFile, String, int, ISearchResultView) - Method in class com.pvx.ooadide.uesearch.UE_SearchAction
match(IDocument, int) - Method in class com.pvx.ooadide.editors.autoindent.PvxPairMatcher
matches(IEditorReference, IEditorInput) - Method in class com.pvx.ooadide.editors.XEditorMatchingStrategy
maximizedWindowsOnly() - Static method in class com.sage.rcp.preferences.UiPrefManager
MENUBAR_ACTION - Static variable in class com.sage.rcp.eventmanager.EventManager
message - Variable in class com.pvx.ooadide.util.PvxUtil.ConfirmDialShower
message - Variable in class com.sage.rcp.util.PvxUtil.ConfirmDialShower
mnemonics - Static variable in class com.pvx.ooadide.editors.MyCompletionProcessor
MNEMONICS_PROPERTIES_FILE - Static variable in class com.pvx.ooadide.editors.MyCompletionProcessor
MnemonicWordDetector() - Constructor for class com.pvx.ooadide.codehilite2.PvxMnemonicRule.MnemonicWordDetector
mnemPropl - Static variable in class com.pvx.ooadide.editors.MyCompletionProcessor
MonitorState - Class in com.pvx.ooadide.views
MonitorState - Class in com.sage.rcp.eventmanager
MonitorState() - Constructor for class com.pvx.ooadide.views.MonitorState
MonitorState() - Constructor for class com.sage.rcp.eventmanager.MonitorState
mouseDoubleClick(MouseEvent) - Method in class com.pvx.ooadide.launchers.debug.RulerActionDelegate
moveWindow(int, int) - Method in class com.sage.rcp.javx.RcpPluginSwingGUIManager
MSG_ERROR - Static variable in class com.pvx.ooadide.ConsoleDisplayManager
MSG_ERROR - Static variable in class com.sage.rcp.ConsoleDisplayManager
MSG_ERROR - Static variable in class com.sage.rcp.eventmanager.ConsoleDisplayManager
MSG_ERROR_DESC - Static variable in class com.pvx.ooadide.ConsoleDisplayManager
MSG_ERROR_DESC - Static variable in class com.sage.rcp.ConsoleDisplayManager
MSG_ERROR_DESC - Static variable in class com.sage.rcp.eventmanager.ConsoleDisplayManager
MSG_INFORMATION - Static variable in class com.pvx.ooadide.ConsoleDisplayManager
MSG_INFORMATION - Static variable in class com.sage.rcp.ConsoleDisplayManager
MSG_INFORMATION - Static variable in class com.sage.rcp.eventmanager.ConsoleDisplayManager
MSG_WARNING - Static variable in class com.pvx.ooadide.ConsoleDisplayManager
MSG_WARNING - Static variable in class com.sage.rcp.ConsoleDisplayManager
MSG_WARNING - Static variable in class com.sage.rcp.eventmanager.ConsoleDisplayManager
MyCompletionProcessor - Class in com.pvx.ooadide.editors
MyCompletionProcessor(PvxEditor) - Constructor for class com.pvx.ooadide.editors.MyCompletionProcessor
A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form


N-Index

Index

A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form

N

NAME - Static variable in class com.pvx.ooadide.eventmanager.EventManager
NATURE_ID - Static variable in class com.pvx.ooadide.builder.ProvideXNature
ID of this project nature
NavigationFilter - Class in com.pvx.ooadide.navigator.filters
NavigationFilter() - Constructor for class com.pvx.ooadide.navigator.filters.NavigationFilter
NewFromExisting - Class in com.pvx.ooadide.wizards
NewFromExisting() - Constructor for class com.pvx.ooadide.wizards.NewFromExisting
NewLineResolver - Class in com.pvx.ooadide.editors.templates
NewLineResolver() - Constructor for class com.pvx.ooadide.editors.templates.NewLineResolver
NewNomadsDefaultsHandler - Class in com.pvx.ooadide.handlers
NewNomadsDefaultsHandler() - Constructor for class com.pvx.ooadide.handlers.NewNomadsDefaultsHandler
NewNomadsLibHandler - Class in com.pvx.ooadide.handlers
NewNomadsLibHandler() - Constructor for class com.pvx.ooadide.handlers.NewNomadsLibHandler
NewNomadsLibraryWizard - Class in com.pvx.ooadide.wizards
NewNomadsLibraryWizard() - Constructor for class com.pvx.ooadide.wizards.NewNomadsLibraryWizard
NewNomadsNmdWizard - Class in com.pvx.ooadide.wizards
NewNomadsNmdWizard() - Constructor for class com.pvx.ooadide.wizards.NewNomadsNmdWizard
NewNomadsObjectDialog - Class in com.pvx.ooadide.views.nomads
NewNomadsObjectDialog(Shell, String, String, String, IInputValidator) - Constructor for class com.pvx.ooadide.views.nomads.NewNomadsObjectDialog
Creates an input dialog with OK and Cancel buttons.
NewProgramHandler - Class in com.pvx.ooadide.handlers
NewProgramHandler() - Constructor for class com.pvx.ooadide.handlers.NewProgramHandler
NewProjectFromExistingPage - Class in com.pvx.ooadide.wizards
Standard main page for a wizard that is creates a project resource.
NewProjectFromExistingPage(ISelection) - Constructor for class com.pvx.ooadide.wizards.NewProjectFromExistingPage
Creates a new project creation wizard page.
NewProjectHandler - Class in com.pvx.ooadide.handlers
NewProjectHandler() - Constructor for class com.pvx.ooadide.handlers.NewProjectHandler
NewPvcCreationWizard - Class in com.pvx.ooadide.wizards.programs
NewPvcCreationWizard() - Constructor for class com.pvx.ooadide.wizards.programs.NewPvcCreationWizard
NewPvxClassHandler - Class in com.pvx.ooadide.handlers
NewPvxClassHandler() - Constructor for class com.pvx.ooadide.handlers.NewPvxClassHandler
NewPvxProgramWizard - Class in com.pvx.ooadide.wizards.programs
NewPvxProgramWizard() - Constructor for class com.pvx.ooadide.wizards.programs.NewPvxProgramWizard
nextArgument() - Method in class com.pvx.ooadide.eventmanager.PvxEvent
Wraps the Properties iterator that contains the arguments of associated with this event
nextArgument() - Method in class com.sage.rcp.eventmanager.PvxEvent
Wraps the Properties iterator that contains the arguments of associated with this event
NO_FILTER - Enum constant in enum com.pvx.ooadide.views.PvcOutline.OutlineFilter
NOICON_TYPE - Static variable in class com.pvx.ooadide.util.PvxElement
NOMADS_BLOCKING - Static variable in class com.pvx.ooadide.eventmanager.EventManager
NOMADS_NON_BLOCKING - Static variable in class com.pvx.ooadide.eventmanager.EventManager
NOMADS_PROGRAM - Static variable in class com.pvx.ooadide.util.RunUtil
NOMADS_systemDefaults - Static variable in class com.pvx.ooadide.views.nomads.LibView
NOMADS_VIEW_ID - Static variable in class com.pvx.ooadide.views.UIManager
NOMADS_XML_EXPORT - Static variable in class com.pvx.ooadide.util.ProjectUtils
NomadsEditor - Class in com.pvx.ooadide.editors
NomadsEditor() - Constructor for class com.pvx.ooadide.editors.NomadsEditor
NomadsPreferencePage - Class in com.pvx.ooadide.preferences.nomads
NomadsPreferencePage() - Constructor for class com.pvx.ooadide.preferences.nomads.NomadsPreferencePage
NON_OBJ_FUNCTION_SYMBOL - Static variable in class com.pvx.ooadide.util.PvxElement
NON_OBJ_FUNCTION_TYPE - Static variable in class com.pvx.ooadide.util.PvxElement
notifyAllEventManagers(boolean, String, String, Properties) - Method in class com.sage.rcp.eventmanager.EventManager
notifyConnected() - Method in class com.sage.rcp.views.HostActionsView
notifyEclipse(String, String, String) - Static method in class com.pvx.ooadide.eventmanager.EventManager
notifyEclipse(String, String, String) - Method in class com.sage.rcp.eventmanager.EventManager
Sends a message to Eclipse EventManger.
notifyEventManager() - Method in interface com.pvx.ooadide.actions.IExtCommand
notifyEventManager() - Method in class com.pvx.ooadide.eventmanager.ExtCommand
notifyHostFullBuildEnd() - Static method in class com.pvx.ooadide.builder.ProvideXBuilder
notifyHostFullBuildStart(IProject, int) - Static method in class com.pvx.ooadide.builder.ProvideXBuilder
notifyProvideXConnect(Socket, Socket) - Method in class com.pvx.ooadide.launchers.debug.communication.DebugLauncherThread
notifyProvideXConnect(Socket, Socket) - Method in class com.pvx.ooadide.launchers.thinclients.DebugWindXLauncherThread
NTHOST_PROGRAM - Static variable in class com.pvx.ooadide.util.RunUtil
numbObjElemnts - Static variable in class com.pvx.ooadide.views.IOListView
numbObjElemnts - Static variable in class com.pvx.ooadide.views.nomads.PvxLibElement
numbWordDetector() - Constructor for class com.pvx.ooadide.codehilite2.PvxNumbLiteralRule.numbWordDetector
NumericComparator - Class in com.pvx.ooadide.views.comparators
NumericComparator(int, int, ITableLabelProvider) - Constructor for class com.pvx.ooadide.views.comparators.NumericComparator
nwClient - Variable in class com.sage.rcp.javx.RcpPluginJavXApplet
A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form


O-Index

Index

A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form

O

OBJ_C - Static variable in class com.pvx.ooadide.views.nomads.PvxLibElement
OBJ_H - Static variable in class com.pvx.ooadide.views.nomads.PvxLibElement
OBJ_KEY - Static variable in class com.pvx.ooadide.views.nomads.PvxLibElement
OBJ_L - Static variable in class com.pvx.ooadide.views.nomads.PvxLibElement
OBJ_NME - Static variable in class com.pvx.ooadide.views.nomads.PvxLibElement
OBJ_TYPE$ - Static variable in class com.pvx.ooadide.views.nomads.PvxLibElement
OBJ_W - Static variable in class com.pvx.ooadide.views.nomads.PvxLibElement
ObserversPreferencePage - Class in com.pvx.ooadide.preferences
ObserversPreferencePage() - Constructor for class com.pvx.ooadide.preferences.ObserversPreferencePage
OK_FOR_ALL_ID - Variable in class com.pvx.ooadide.builder.PvxPasswordInputDialogue
open(int, MonitorState, String) - Method in class com.pvx.ooadide.views.PvxProgressMonitorDialog
open(int, MonitorState, String) - Method in class com.sage.rcp.eventmanager.PvxProgressMonitorDialog
openFile(String) - Method in class com.pvx.ooadide.eventmanager.EditorManager
openFile(String, int, int) - Method in class com.pvx.ooadide.eventmanager.EditorManager
Scroll editor to a line and select text in the pvx editor if the file is not open the open a file first
openPvxEditor(IFile) - Static method in class com.pvx.ooadide.util.PvxUtil
openPvxEditor(IFile) - Method in class com.pvx.ooadide.views.JavXBrowserView
openWinDefineView() - Method in class com.pvx.ooadide.views.nomads.LibView
openWizard(ITextSelection, String) - Method in class com.pvx.ooadide.refactor.RefactorUtil
OPERATION_CANCEL - Static variable in class com.pvx.ooadide.eventmanager.EventManager
OPERATION_ERROR - Static variable in class com.pvx.ooadide.eventmanager.EventManager
OPERATION_REDO - Static variable in class com.pvx.ooadide.eventmanager.EventManager
OPERATION_SUCCESS - Static variable in class com.pvx.ooadide.eventmanager.EventManager
optionMn(String, String) - Method in class com.sage.rcp.javx.windows.PluginTextPlaneView
OS_APPLE_OSX - Static variable in class com.pvx.ooadide.util.PvxUtil
OS_APPLE_OSX - Static variable in class com.sage.rcp.util.PvxUtil
OS_APPLE_OSX - Static variable in class com.sage.rcp.util.RunUtilProxy
OS_LINUX - Static variable in class com.pvx.ooadide.util.PvxUtil
OS_LINUX - Static variable in class com.sage.rcp.util.PvxUtil
OS_LINUX - Static variable in class com.sage.rcp.util.RunUtilProxy
OS_UNIX - Static variable in class com.pvx.ooadide.util.PvxUtil
OS_UNIX - Static variable in class com.sage.rcp.util.PvxUtil
OS_UNIX - Static variable in class com.sage.rcp.util.RunUtilProxy
OS_WINDOWS - Static variable in class com.pvx.ooadide.util.PvxUtil
OS_WINDOWS - Static variable in class com.sage.rcp.util.PvxUtil
OS_WINDOWS - Static variable in class com.sage.rcp.util.RunUtilProxy
OutputPropertyResolver - Class in com.pvx.ooadide.editors.templates
OutputPropertyResolver() - Constructor for class com.pvx.ooadide.editors.templates.OutputPropertyResolver
OwnerPropertyResolver - Class in com.pvx.ooadide.editors.templates
OwnerPropertyResolver() - Constructor for class com.pvx.ooadide.editors.templates.OwnerPropertyResolver
A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form


P-Index

Index

A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form

P

P_5D - Static variable in class com.sage.rcp.preferences.RcpPreferenceConstants
P_6D - Static variable in class com.sage.rcp.preferences.RcpPreferenceConstants
P_ALL - Static variable in class com.pvx.ooadide.views.AbstractProgressController
P_ALL - Static variable in class com.sage.rcp.eventmanager.AbstractProgressController
P_BOOLEAN - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_BUILD_DATAFILES - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_BUILD_FILES_NO_EXT - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_BUILD_RESOURCES - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_CHOICE - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_CODECHECKER - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_COMMON_RESOURCE_FILE_EXTENSIONS - Static variable in class com.pvx.ooadide.util.ProjectUtils
P_DATE$ - Static variable in class com.pvx.ooadide.views.nomads.PvxLibElement
P_DEBUG - Static variable in class com.sage.rcp.preferences.RcpPreferenceConstants
P_DEBUG_PVX_MODE - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_DOSTYLECHECK - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_CODE_FOLDING - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_COMMENT_LABEL - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_COMMENTS_BACKCOLOR - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_COMMENTS_BOLD - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_COMMENTS_COLOR - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_COMMENTS_ITALIC - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_COMMENTS_STRIKETHROUGH - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_COMMENTS_UNDERLINE - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_DIRECTIVE_LABEL - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_DIRECTIVES_BACKCOLOR - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_DIRECTIVES_BOLD - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_DIRECTIVES_COLOR - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_DIRECTIVES_ITALIC - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_DIRECTIVES_STRIKETHROUGH - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_DIRECTIVES_UNDERLINE - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_LINELABEL_LABEL - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_LINELABELS_BACKCOLOR - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_LINELABELS_BOLD - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_LINELABELS_COLOR - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_LINELABELS_ITALIC - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_LINELABELS_STRIKETHROUGH - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_LINELABELS_UNDERLINE - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_LITERALS_BACKCOLOR - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_LITERALS_BOLD - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_LITERALS_COLOR - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_LITERALS_ITALIC - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_LITERALS_LABEL - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_LITERALS_STRIKETHROUGH - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_LITERALS_UNDERLINE - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_MNEMONICS_BACKCOLOR - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_MNEMONICS_BOLD - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_MNEMONICS_COLOR - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_MNEMONICS_ITALIC - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_MNEMONICS_LABEL - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_MNEMONICS_STRIKETHROUGH - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_MNEMONICS_UNDERLINE - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_OPERATORS_BACKCOLOR - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_OPERATORS_BOLD - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_OPERATORS_COLOR - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_OPERATORS_ITALIC - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_OPERATORS_LABEL - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_OPERATORS_STRIKETHROUGH - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_OPERATORS_UNDERLINE - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_SMART_BRACES - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_SMART_INDENT - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_SMART_PASTE - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_SYSFUNCTIONS_BACKCOLOR - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_SYSFUNCTIONS_BOLD - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_SYSFUNCTIONS_COLOR - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_SYSFUNCTIONS_ITALIC - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_SYSFUNCTIONS_STRIKETHROUGH - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_SYSFUNCTIONS_UNDERLINE - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_SYSTEM_FUNCTIONS_LABEL - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_SYSTEM_VARIABLES_LABEL - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_SYSVARIABLES_BACKCOLOR - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_SYSVARIABLES_BOLD - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_SYSVARIABLES_COLOR - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_SYSVARIABLES_ITALIC - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_SYSVARIABLES_STRIKETHROUGH - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EDITOR_SYSVARIABLES_UNDERLINE - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_EVENT_SOURCEFILE - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_GRAPHIC_FONT - Static variable in class com.sage.rcp.preferences.RcpPreferenceConstants
P_IMPORT_SRCFILE_EXTENSION - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_IMPORT_STRIP_LINE_LABEL_PREFIX - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_IMPORT_STRIP_LINE_NO - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_IMPORT_STRIP_LINE_USE_ORIG_NO - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_INTERNAL_DIALOGUES - Static variable in class com.sage.rcp.preferences.RcpPreferenceConstants
P_ISCHECKING_FILE_EXTIONS - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_ISLINE_NUMBS_REQUIRED - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_ISPVXDATA - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_ISRESOURCE - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_MAX_WINDOWS - Static variable in class com.sage.rcp.preferences.RcpPreferenceConstants
P_MINIMUM_FONTSIZE - Static variable in class com.sage.rcp.preferences.RcpPreferenceConstants
P_ONLY_SHOW_TOP_WINDOW - Static variable in class com.sage.rcp.preferences.RcpPreferenceConstants
P_OUTPUT_FILE_NAME - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_OWNERCODE - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_OWNERCODEFLAGS - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_PASSWORD - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_PATH - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_PROGRAM_CONVERT - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_PROJECT_OUTPUT_DIRECTORY - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_PROJECT_OUTPUT_LINK_DIRECTORY - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_PROJECT_SRC_DIRECTORY - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_PROJECT_SRC_LINK_DIRECTORY - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_REPORT_VERSION_AS - Static variable in class com.sage.rcp.preferences.RcpPreferenceConstants
P_SAVE_WINDOW_POSITION - Static variable in class com.sage.rcp.preferences.RcpPreferenceConstants
P_SHOW_BORDERS - Static variable in class com.sage.rcp.preferences.RcpPreferenceConstants
P_STRING - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_SUB_TASKNAME - Static variable in class com.pvx.ooadide.views.AbstractProgressController
P_SUB_TASKNAME - Static variable in class com.sage.rcp.eventmanager.AbstractProgressController
P_TASKNAME - Static variable in class com.pvx.ooadide.views.AbstractProgressController
P_TASKNAME - Static variable in class com.sage.rcp.eventmanager.AbstractProgressController
P_TESTFOLDER_LIST - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
P_TEXTPLANE_FONT - Static variable in class com.sage.rcp.preferences.RcpPreferenceConstants
P_TIME$ - Static variable in class com.pvx.ooadide.views.nomads.PvxLibElement
P_USER_FILE - Static variable in class com.pvx.ooadide.properties.ProvideXPropertyPage
P_USER_FOLDER - Static variable in class com.pvx.ooadide.properties.ProvideXPropertyPage
P_USER_NOMADSLIBS - Static variable in class com.pvx.ooadide.properties.ProvideXPropertyPage
P_USER_PROGRAMS - Static variable in class com.pvx.ooadide.properties.ProvideXPropertyPage
P_USER_PROJECT - Static variable in class com.pvx.ooadide.properties.ProvideXPropertyPage
P_USER_RESOURCE - Static variable in class com.pvx.ooadide.properties.ProvideXPropertyPage
P_USERID$ - Static variable in class com.pvx.ooadide.views.nomads.PvxLibElement
P_VISIBLE - Static variable in class com.pvx.ooadide.views.AbstractProgressController
P_VISIBLE - Static variable in class com.sage.rcp.eventmanager.AbstractProgressController
P_WORKED - Static variable in class com.pvx.ooadide.views.AbstractProgressController
P_WORKED - Static variable in class com.sage.rcp.eventmanager.AbstractProgressController
P_XML_EXPORT - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
paintComponent(Graphics) - Method in class com.sage.rcp.javx.windows.PluginTextPlaneView
paintComponent(Graphics) - Method in class com.sage.rcp.resizeanimation.CurvesPanel
paintComponent(Graphics) - Method in class com.sage.rcp.resizeanimation.GradientPanel
paintComponent(Graphics) - Method in class com.sage.rcp.resizeanimation.SizeAnimationGlassPane
panel - Static variable in class com.pvx.ooadide.views.WinDefine
panel - Variable in class com.sage.rcp.views.RcpEmbedJavXView
partActivated(IWorkbenchPartReference) - Method in class com.sage.rcp.javx.FxPagePartListener
partBroughtToTop(IWorkbenchPartReference) - Method in class com.sage.rcp.javx.FxPagePartListener
partClosed(IWorkbenchPartReference) - Method in class com.sage.rcp.javx.FxPagePartListener
partDeactivated(IWorkbenchPartReference) - Method in class com.sage.rcp.javx.FxPagePartListener
partHidden(IWorkbenchPartReference) - Method in class com.sage.rcp.javx.FxPagePartListener
partInputChanged(IWorkbenchPartReference) - Method in class com.sage.rcp.javx.FxPagePartListener
partOpened(IWorkbenchPartReference) - Method in class com.sage.rcp.javx.FxPagePartListener
partVisible(IWorkbenchPartReference) - Method in class com.sage.rcp.javx.FxPagePartListener
PASSWORD - Static variable in class com.pvx.ooadide.eventmanager.EventManager
PasswordExporterWizard - Class in com.pvx.ooadide.wizards
PasswordExporterWizard() - Constructor for class com.pvx.ooadide.wizards.PasswordExporterWizard
Creates a wizard for exporting workspace preferences to the local file system.
PasswordPreferences - Class in com.pvx.ooadide.preferences
PasswordPreferences() - Constructor for class com.pvx.ooadide.preferences.PasswordPreferences
PasswordPropertyResolver - Class in com.pvx.ooadide.editors.templates
PasswordPropertyResolver() - Constructor for class com.pvx.ooadide.editors.templates.PasswordPropertyResolver
PasswordTransferElement - Class in com.pvx.ooadide.wizards
PasswordTransferElement(IProject) - Constructor for class com.pvx.ooadide.wizards.PasswordTransferElement
PATH - Static variable in class com.pvx.ooadide.eventmanager.EventManager
pauseExecution(int) - Method in class com.pvx.ooadide.launchers.debug.model.PVXDebugTarget
peekCallArgs() - Static method in class com.sage.rcp.views.RcpProgramView
performApply(ILaunchConfigurationWorkingCopy) - Method in class com.pvx.ooadide.launchers.IniFileBlock
performApply(ILaunchConfigurationWorkingCopy) - Method in class com.pvx.ooadide.launchers.ProvideXArgumentsTab
performApply(ILaunchConfigurationWorkingCopy) - Method in class com.pvx.ooadide.launchers.ProvideXMainTab
performApply(ILaunchConfigurationWorkingCopy) - Method in class com.pvx.ooadide.launchers.thinclients.ClientTab
performApply(ILaunchConfigurationWorkingCopy) - Method in class com.pvx.ooadide.launchers.WindowStateBlock
performCancel() - Method in class com.pvx.ooadide.preferences.AbstractProvideXFieldEditorPrefPage
performDefaults() - Method in class com.pvx.ooadide.preferences.EditorColorPreferencePage
performFinish() - Method in class com.pvx.ooadide.wizards.ImportPasswordsWizard
performFinish() - Method in class com.pvx.ooadide.wizards.NewFromExisting
performFinish() - Method in class com.pvx.ooadide.wizards.NewNomadsLibraryWizard
This method is called when 'Finish' button is pressed in the wizard.
performFinish() - Method in class com.pvx.ooadide.wizards.NewNomadsNmdWizard
This method is called when 'Finish' button is pressed in the wizard.
performFinish() - Method in class com.pvx.ooadide.wizards.PasswordExporterWizard
performFinish() - Method in class com.pvx.ooadide.wizards.programs.NewPvxProgramWizard
This method is called when 'Finish' button is pressed in the wizard.
performFinish() - Method in class com.pvx.ooadide.wizards.ProvideXNewWizard
This method is called when 'Finish' button is pressed in the wizard.
performOk() - Method in class com.pvx.ooadide.editors.templates.TemplatesPreferencePage
performOk() - Method in class com.pvx.ooadide.preferences.AbstractProvideXFieldEditorPrefPage
performOk() - Method in class com.pvx.ooadide.preferences.EditorColorPreferencePage
performOk() - Method in class com.pvx.ooadide.preferences.nomads.NomadsPreferencePage
performOk() - Method in class com.pvx.ooadide.preferences.PasswordPreferences
performOk() - Method in class com.pvx.ooadide.preferences.ProvideXPreferencePage
performOk() - Method in class com.pvx.ooadide.properties.ProvideXPropertyPage
performOk() - Method in class com.sage.rcp.preferences.ProgramViewsPrefs
pervasiveHandles - Static variable in class com.pvx.ooadide.eventmanager.EventManager
pervasiveHandles - Static variable in class com.sage.rcp.eventmanager.EventManager
PixelConverter - Class in com.pvx.ooadide.util
Pixel conversion utility.
PixelConverter(Control) - Constructor for class com.pvx.ooadide.util.PixelConverter
PLUGIN_VERSION - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
PluginTextPlaneView - Class in com.sage.rcp.javx.windows
PluginTextPlaneView(PvxCanvas, Component, PvxHost) - Constructor for class com.sage.rcp.javx.windows.PluginTextPlaneView
pop() - Method in class com.pvx.ooadide.launchers.debug.model.PVXDebugTarget
Pops and returns the top of the data stack
pop() - Method in class com.pvx.ooadide.launchers.debug.model.PVXThread
Pops the top frame off the callstack.
PREFERENCE_CHANGE - Static variable in class com.pvx.ooadide.eventmanager.EventManager
PREFERENCE_NEW_VALUE - Static variable in class com.pvx.ooadide.eventmanager.EventManager
PREFERENCE_OLD_VALUE - Static variable in class com.pvx.ooadide.eventmanager.EventManager
PREFERENCE_PAGE_BUTTON - Static variable in class com.pvx.ooadide.eventmanager.EventManager
PREFERENCE_PAGE_ID - Static variable in class com.pvx.ooadide.eventmanager.EventManager
PREFERENCE_PROPERTY - Static variable in class com.pvx.ooadide.eventmanager.EventManager
PreferenceConstants - Class in com.pvx.ooadide.preferences
Constant definitions for plug-in preferences
PreferenceConstants() - Constructor for class com.pvx.ooadide.preferences.PreferenceConstants
PreferenceInitializer - Class in com.pvx.ooadide.preferences
Class used to initialize default preference values.
PreferenceInitializer() - Constructor for class com.pvx.ooadide.preferences.PreferenceInitializer
PreferenceManager - Class in com.pvx.ooadide.preferences
PreferenceManager() - Constructor for class com.pvx.ooadide.preferences.PreferenceManager
PrefPageVistor - Class in com.pvx.ooadide.preferences
PrefPageVistor() - Constructor for class com.pvx.ooadide.preferences.PrefPageVistor
println(String, int) - Method in class com.pvx.ooadide.ConsoleDisplayManager
println(String, int) - Method in class com.sage.rcp.ConsoleDisplayManager
println(String, int) - Method in class com.sage.rcp.eventmanager.ConsoleDisplayManager
printLnToConsole(String) - Method in class com.pvx.ooadide.views.UIManager
Prints a line of text to the Console view
printLnToConsole(String) - Method in class com.sage.rcp.eventmanager.UIManager
Prints a line of text to the Console view
PRIVATE_FUNCTION - Static variable in class com.pvx.ooadide.util.PvxElement
PRIVATE_FUNCTION_SYMBOL - Static variable in class com.pvx.ooadide.util.PvxElement
PRIVATE_TAG_FLAGS - Static variable in class com.pvx.ooadide.properties.refactoring.tagresolver.PvxtagResolver
PRIVATE_TAG_FORCELINE_NO - Static variable in class com.pvx.ooadide.properties.refactoring.tagresolver.PvxtagResolver
PRIVATE_TAG_OUTPUT - Static variable in class com.pvx.ooadide.properties.refactoring.tagresolver.PvxtagResolver
PRIVATE_TAG_OWNER - Static variable in class com.pvx.ooadide.properties.refactoring.tagresolver.PvxtagResolver
PRIVATE_TAG_PASSWORD - Static variable in class com.pvx.ooadide.properties.refactoring.tagresolver.PvxtagResolver
processPanel(String, String, IProject, String, String, String, String, boolean) - Static method in class com.pvx.ooadide.util.RunUtil
ProcessRunner - Class in com.pvx.ooadide.util
ProcessRunner() - Constructor for class com.pvx.ooadide.util.ProcessRunner
program - Variable in class com.pvx.ooadide.views.WinDefine
program - Variable in class com.sage.rcp.views.RcpProgramView
ProgramViewsPrefs - Class in com.sage.rcp.preferences
ProgramViewsPrefs() - Constructor for class com.sage.rcp.preferences.ProgramViewsPrefs
progressIndcator(String, String, int) - Method in class com.sage.rcp.javx.RcpPluginSwingGUIManager
ProgressIndicator - Class in com.sage.rcp.util
ProgressIndicator(PvxBaseWindow) - Constructor for class com.sage.rcp.util.ProgressIndicator
PROJECT_DEF_PVX_EXE - Static variable in class com.pvx.ooadide.wizards.NewProjectFromExistingPage
PROJECT_DEF_PVX_EXE - Static variable in class com.pvx.ooadide.wizards.programs.PvxNewProgramPropertiesWizardPage
PROJECT_DEF_PVX_EXE - Static variable in class com.pvx.ooadide.wizards.ProvidexNewWizardPage
PROJECT_INI_FILE - Static variable in class com.pvx.ooadide.eventmanager.EventManager
PROJECT_LIST - Static variable in class com.pvx.ooadide.eventmanager.EventManager
PROJECT_LOCATION - Static variable in class com.pvx.ooadide.eventmanager.EventManager
PROJECT_MEMBER_COUNT - Static variable in class com.pvx.ooadide.eventmanager.EventManager
PROJECT_NAME - Static variable in class com.pvx.ooadide.eventmanager.EventManager
PROJECT_OWNER - Static variable in class com.pvx.ooadide.wizards.NewProjectFromExistingPage
PROJECT_OWNER - Static variable in class com.pvx.ooadide.wizards.programs.PvxNewProgramPropertiesWizardPage
PROJECT_OWNER - Static variable in class com.pvx.ooadide.wizards.ProvidexNewWizardPage
PROJECT_OWNER_FLAGS - Static variable in class com.pvx.ooadide.wizards.NewProjectFromExistingPage
PROJECT_OWNER_FLAGS - Static variable in class com.pvx.ooadide.wizards.programs.PvxNewProgramPropertiesWizardPage
PROJECT_OWNER_FLAGS - Static variable in class com.pvx.ooadide.wizards.ProvidexNewWizardPage
PROJECT_PASSWORD - Static variable in class com.pvx.ooadide.wizards.NewProjectFromExistingPage
PROJECT_PASSWORD - Static variable in class com.pvx.ooadide.wizards.programs.PvxNewProgramPropertiesWizardPage
PROJECT_PASSWORD - Static variable in class com.pvx.ooadide.wizards.ProvidexNewWizardPage
ProjectExplorer - Class in com.pvx.ooadide.navigator
ProjectExplorer() - Constructor for class com.pvx.ooadide.navigator.ProjectExplorer
ProjectUtils - Class in com.pvx.ooadide.util
Simple class to provide access to Project/Workspace utility methods.
ProjectUtils() - Constructor for class com.pvx.ooadide.util.ProjectUtils
PROP_HIDDEN_ROOT_FOLDER - Static variable in class com.pvx.ooadide.eventmanager.EventManager
PROP_PROJECT_FORCE_FOLDERS - Static variable in class com.pvx.ooadide.eventmanager.EventManager
PROPERTY_FILE_KEY_BUILDLOG - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
PROPERTY_FILE_KEY_BUILDTYPE - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
PROPERTY_FILE_KEY_DEST - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
PROPERTY_FILE_KEY_DOMFILE - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
PROPERTY_FILE_KEY_ERRORSCANNER - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
PROPERTY_FILE_KEY_FLAGS - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
PROPERTY_FILE_KEY_LOCKFILE - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
PROPERTY_FILE_KEY_OWNERCODE - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
PROPERTY_FILE_KEY_PASSWORD - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
PROPERTY_FILE_KEY_SRCFILE - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
PROPERTY_NOT_SET - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
propertyChange(PropertyChangeEvent) - Method in class com.pvx.ooadide.preferences.AbstractProvideXFieldEditorPrefPage
propertyChange(PropertyChangeEvent) - Method in class com.pvx.ooadide.preferences.EditorOptions
propertyChange(PropertyChangeEvent) - Method in class com.pvx.ooadide.preferences.ImportOptionsPrefPage
propertyChange(PropertyChangeEvent) - Method in class com.pvx.ooadide.preferences.nomads.NomadsPreferencePage
propertyChange(PropertyChangeEvent) - Method in class com.pvx.ooadide.preferences.ProvideXPreferencePage
propertyChange(PropertyChangeEvent) - Method in class com.pvx.ooadide.preferences.UserDefinedPrefPage
propertyChange(PropertyChangeEvent) - Method in class com.sage.rcp.preferences.ProgramViewsPrefs
propertyChanged(Object, int) - Method in class com.pvx.ooadide.util.ExtensionUtil
ProvideX - Class in com.pvx.ooadide.actions
ProvideX() - Constructor for class com.pvx.ooadide.actions.ProvideX
The constructor.
ProvideXArgumentsTab - Class in com.pvx.ooadide.launchers
A launch configuration tab that displays and edits program arguments, VM arguments, and working directory launch configuration attributes.
ProvideXArgumentsTab() - Constructor for class com.pvx.ooadide.launchers.ProvideXArgumentsTab
ProvideXBuilder - Class in com.pvx.ooadide.builder
ProvideXBuilder() - Constructor for class com.pvx.ooadide.builder.ProvideXBuilder
ProvideXConfigurationTabGroup1 - Class in com.pvx.ooadide.launchers
ProvideXConfigurationTabGroup1() - Constructor for class com.pvx.ooadide.launchers.ProvideXConfigurationTabGroup1
ProvideXLaunchConfigurationDelegate1 - Class in com.pvx.ooadide.launchers
ProvideXLaunchConfigurationDelegate1() - Constructor for class com.pvx.ooadide.launchers.ProvideXLaunchConfigurationDelegate1
ProvideXLaunchConfigurationTab - Class in com.pvx.ooadide.launchers
Common function for Java launch configuration tabs.
ProvideXLaunchConfigurationTab() - Constructor for class com.pvx.ooadide.launchers.ProvideXLaunchConfigurationTab
ProvideXMainTab - Class in com.pvx.ooadide.launchers
A launch configuration tab that displays and edits project and main type name launch configuration attributes.
ProvideXMainTab() - Constructor for class com.pvx.ooadide.launchers.ProvideXMainTab
ProvideXNature - Class in com.pvx.ooadide.builder
ProvideXNature() - Constructor for class com.pvx.ooadide.builder.ProvideXNature
ProvideXNewAction - Class in com.pvx.ooadide.popup.actions
ProvideXNewAction() - Constructor for class com.pvx.ooadide.popup.actions.ProvideXNewAction
Constructor for Action1.
ProvideXNewWizard - Class in com.pvx.ooadide.wizards
ProvideXNewWizard() - Constructor for class com.pvx.ooadide.wizards.ProvideXNewWizard
Constructor for ProvideXNewWizard.
ProvidexNewWizardPage - Class in com.pvx.ooadide.wizards
Standard main page for a wizard that is creates a project resource.
ProvidexNewWizardPage(ISelection) - Constructor for class com.pvx.ooadide.wizards.ProvidexNewWizardPage
Creates a new project creation wizard page.
ProvideXNewWizardPageI - Interface in com.pvx.ooadide.wizards
ProvideXOOADPlugin - Class in com.pvx.ooadide
ProvideXOOADPlugin() - Constructor for class com.pvx.ooadide.ProvideXOOADPlugin
ProvideXPreferencePage - Class in com.pvx.ooadide.preferences
This class represents a preference page that is contributed to the Preferences dialog.
ProvideXPreferencePage() - Constructor for class com.pvx.ooadide.preferences.ProvideXPreferencePage
ProvideXPropertyPage - Class in com.pvx.ooadide.properties
ProvideXPropertyPage() - Constructor for class com.pvx.ooadide.properties.ProvideXPropertyPage
Constructor for SamplePropertyPage.
PUB_FUNC_FILTER - Enum constant in enum com.pvx.ooadide.views.PvcOutline.OutlineFilter
PUB_PROP_FILTER - Enum constant in enum com.pvx.ooadide.views.PvcOutline.OutlineFilter
push(String) - Method in class com.pvx.ooadide.launchers.debug.model.PVXDebugTarget
Pushes a value onto the stack.
PvcOutline - Class in com.pvx.ooadide.views
PvcOutline() - Constructor for class com.pvx.ooadide.views.PvcOutline
The constructor.
PVCOUTLINE_VIEW_ID - Static variable in class com.pvx.ooadide.views.UIManager
PvcOutline.OutlineFilter - Enum in com.pvx.ooadide.views
PvcOutline.OutlineSortBy - Enum in com.pvx.ooadide.views
PvcOutlineSettings - Class in com.pvx.ooadide.views
PvcOutlineSettings(PvcOutline.OutlineSortBy, PvcOutline.OutlineFilter) - Constructor for class com.pvx.ooadide.views.PvcOutlineSettings
PvcPage - Class in com.pvx.ooadide.wizards.programs
PvcPage(ISelection) - Constructor for class com.pvx.ooadide.wizards.programs.PvcPage
PVX_1FILE_COMPLR_PROGRAM - Static variable in class com.pvx.ooadide.builder.ProvideXBuilder
PVX_CONSOLE - Static variable in class com.pvx.ooadide.util.RunUtil
PVX_CONTEXT_TYPE - Static variable in class com.pvx.ooadide.editors.templates.PVXContextType
This context's id
PVX_CONTEXTMNU_BUILD - Static variable in class com.pvx.ooadide.builder.ProvideXBuilder
PVX_DATA - Static variable in class com.pvx.ooadide.util.PvxFileUtils
PVX_LABEL_SEP - Static variable in class com.pvx.ooadide.util.PvxUtil
PVX_OTHER - Static variable in class com.pvx.ooadide.util.PvxFileUtils
PVX_PROCESS_EVENT - Static variable in class com.sage.rcp.eventmanager.EventManager
PVX_PROGRAM - Static variable in class com.pvx.ooadide.util.PvxFileUtils
PvxAnnotationHover - Class in com.pvx.ooadide.editors
The PvxAnnotationHover provides the hover support for ProvideX editors.
PvxAnnotationHover() - Constructor for class com.pvx.ooadide.editors.PvxAnnotationHover
PvxArrayElementVariable - Class in com.pvx.ooadide.launchers.debug.model
PvxArrayElementVariable(PVXStackFrame, String, int, int) - Constructor for class com.pvx.ooadide.launchers.debug.model.PvxArrayElementVariable
PVXArrayValue - Class in com.pvx.ooadide.launchers.debug.model
PVXArrayValue(PVXStackFrame, String, int, int) - Constructor for class com.pvx.ooadide.launchers.debug.model.PVXArrayValue
PvxAutoIndentStrategy - Class in com.pvx.ooadide.editors.autoindent
Auto indent strategy sensitive to brackets.
PvxAutoIndentStrategy(String, IJavaProject) - Constructor for class com.pvx.ooadide.editors.autoindent.PvxAutoIndentStrategy
Creates a new Java auto indent strategy for the given document partitioning.
PvxBaseClientConfigTab - Class in com.pvx.ooadide.launchers.thinclients
Common function for Java launch configuration tabs.
PvxBaseClientConfigTab() - Constructor for class com.pvx.ooadide.launchers.thinclients.PvxBaseClientConfigTab
PvxBreakpointAdapterFactory - Class in com.pvx.ooadide.launchers.debug.breakpoints
PvxBreakpointAdapterFactory() - Constructor for class com.pvx.ooadide.launchers.debug.breakpoints.PvxBreakpointAdapterFactory
PvxCompletionProposal - Class in com.pvx.ooadide.editors
PvxCompletionProposal(String, String, IContextInformation, Image) - Constructor for class com.pvx.ooadide.editors.PvxCompletionProposal
PvxContentAssistant - Class in com.pvx.ooadide.codehilite2
PvxContentAssistant() - Constructor for class com.pvx.ooadide.codehilite2.PvxContentAssistant
PvxContextInformation - Class in com.pvx.ooadide.editors
PvxContextInformation(Image, String, String) - Constructor for class com.pvx.ooadide.editors.PvxContextInformation
PVXContextType - Class in com.pvx.ooadide.editors.templates
A very simple context type.
PVXContextType() - Constructor for class com.pvx.ooadide.editors.templates.PVXContextType
Creates a new PVX context type.
PVXCORRECTION - Static variable in class com.pvx.ooadide.builder.PvxProblem
PVXCORRECTION_ACTION - Static variable in class com.pvx.ooadide.builder.PvxProblem
PVXDATA_TYPE - Static variable in class com.pvx.ooadide.util.PvxElement
PVXDATAFILE_SCAN_PROGRAM - Static variable in class com.pvx.ooadide.builder.ProvideXBuilder
PVXDebugElement - Class in com.pvx.ooadide.launchers.debug.model
PVXDebugElement(IDebugTarget) - Constructor for class com.pvx.ooadide.launchers.debug.model.PVXDebugElement
Constructs a new debug element in the given target.
PVXDebugTarget - Class in com.pvx.ooadide.launchers.debug.model
PVX Debug Target
PVXDebugTarget(ILaunch, IProcess) - Constructor for class com.pvx.ooadide.launchers.debug.model.PVXDebugTarget
Constructs a new debug target in the given launch for the associated PVX VM process.
PVXDebugTarget(ILaunch, IProcess, int, int) - Constructor for class com.pvx.ooadide.launchers.debug.model.PVXDebugTarget
Constructs a new debug target in the given launch for the associated PVX VM process.
PVXDebugTarget(ILaunch, IProcess, String) - Constructor for class com.pvx.ooadide.launchers.debug.model.PVXDebugTarget
PvxDirectiveWordRule - Class in com.pvx.ooadide.codehilite2
PvxDirectiveWordRule() - Constructor for class com.pvx.ooadide.codehilite2.PvxDirectiveWordRule
PvxDirectiveWordRule.DirectiveWordDetector - Class in com.pvx.ooadide.codehilite2
PvxEditor - Class in com.pvx.ooadide.editors
PvxEditor() - Constructor for class com.pvx.ooadide.editors.PvxEditor
PvxElement - Class in com.pvx.ooadide.util
PvxElement(String, IFile, boolean) - Constructor for class com.pvx.ooadide.util.PvxElement
PvxElementAlphaComparator - Class in com.pvx.ooadide.views.comparators
PvxElementAlphaComparator(int, int, ITableLabelProvider) - Constructor for class com.pvx.ooadide.views.comparators.PvxElementAlphaComparator
PvxElementListSelectionDialog - Class in com.pvx.ooadide.dialogs
PvxElementListSelectionDialog(Shell, ILabelProvider) - Constructor for class com.pvx.ooadide.dialogs.PvxElementListSelectionDialog
PVXENTRY_PRG - Static variable in class com.pvx.ooadide.util.RunUtil
PvxEolRule - Class in com.pvx.ooadide.codehilite2
PvxEolRule(String, String, IToken) - Constructor for class com.pvx.ooadide.codehilite2.PvxEolRule
PvxEolRule(String, String, Token, char, boolean, boolean) - Constructor for class com.pvx.ooadide.codehilite2.PvxEolRule
PvxEvent - Class in com.pvx.ooadide.eventmanager
An event that indicates an action has occurred in Eclipse
PvxEvent - Class in com.sage.rcp.eventmanager
An event that indicates an action has occurred in Eclipse
PvxEvent(String, String, Properties) - Constructor for class com.pvx.ooadide.eventmanager.PvxEvent
Creates an event that indicates an action has occurred in Eclipse
PvxEvent(String, String, Properties) - Constructor for class com.sage.rcp.eventmanager.PvxEvent
Creates an event that indicates an action has occurred in Eclipse
PvxFileUtils - Class in com.pvx.ooadide.util
PvxFileUtils() - Constructor for class com.pvx.ooadide.util.PvxFileUtils
PVXHELPER_DIR - Static variable in class com.pvx.ooadide.util.RunUtil
PvxHostLauncher - Class in com.sage.rcp.javx
PvxHostLauncher() - Constructor for class com.sage.rcp.javx.PvxHostLauncher
PvxInfoPresenter - Class in com.pvx.ooadide.codehilite2
PvxInfoPresenter() - Constructor for class com.pvx.ooadide.codehilite2.PvxInfoPresenter
PvxLibElement - Class in com.pvx.ooadide.views.nomads
PvxLibElement(String[], IResource, String) - Constructor for class com.pvx.ooadide.views.nomads.PvxLibElement
PVXLineBreakpoint - Class in com.pvx.ooadide.launchers.debug.breakpoints
PDA line breakpoint
PVXLineBreakpoint() - Constructor for class com.pvx.ooadide.launchers.debug.breakpoints.PVXLineBreakpoint
Default constructor is required for the breakpoint manager to re-create persisted breakpoints.
PVXLineBreakpoint(IResource, int) - Constructor for class com.pvx.ooadide.launchers.debug.breakpoints.PVXLineBreakpoint
Constructs a line breakpoint on the given resource at the given line number.
PvxLineBreakpointAdapter - Class in com.pvx.ooadide.launchers.debug.model
Adapter to create breakpoints in PVX files.
PvxLineBreakpointAdapter() - Constructor for class com.pvx.ooadide.launchers.debug.model.PvxLineBreakpointAdapter
PvxLineLabelWordRule - Class in com.pvx.ooadide.codehilite2
PvxLineLabelWordRule() - Constructor for class com.pvx.ooadide.codehilite2.PvxLineLabelWordRule
PvxLineLabelWordRule.LineLabelWordDetector - Class in com.pvx.ooadide.codehilite2
PvxLineNoComparator - Class in com.pvx.ooadide.views.comparators
PvxLineNoComparator() - Constructor for class com.pvx.ooadide.views.comparators.PvxLineNoComparator
PvxListEditor - Class in com.pvx.ooadide.preferences
PvxListEditor(String, String, Composite) - Constructor for class com.pvx.ooadide.preferences.PvxListEditor
PvxMnemonicRule - Class in com.pvx.ooadide.codehilite2
PvxMnemonicRule() - Constructor for class com.pvx.ooadide.codehilite2.PvxMnemonicRule
PvxMnemonicRule.MnemonicWordDetector - Class in com.pvx.ooadide.codehilite2
PVXModelPresentation - Class in com.pvx.ooadide.launchers.debug.launching
Renders PDA debug elements
PVXModelPresentation() - Constructor for class com.pvx.ooadide.launchers.debug.launching.PVXModelPresentation
PvxNewProgramPropertiesWizardPage - Class in com.pvx.ooadide.wizards.programs
PvxNewProgramPropertiesWizardPage(ISelection) - Constructor for class com.pvx.ooadide.wizards.programs.PvxNewProgramPropertiesWizardPage
Creates a new project creation wizard page.
PvxNumbLiteralRule - Class in com.pvx.ooadide.codehilite2
PvxNumbLiteralRule() - Constructor for class com.pvx.ooadide.codehilite2.PvxNumbLiteralRule
PvxNumbLiteralRule.numbWordDetector - Class in com.pvx.ooadide.codehilite2
PVXOBJ_PROP - Static variable in class com.pvx.ooadide.util.PvxElement
PVXOBJ_PROP_SYMBOL - Static variable in class com.pvx.ooadide.util.PvxElement
PvxPairMatcher - Class in com.pvx.ooadide.editors.autoindent
PvxPairMatcher(char[]) - Constructor for class com.pvx.ooadide.editors.autoindent.PvxPairMatcher
PvxParameterListValidator - Class in com.pvx.ooadide.editors
PvxParameterListValidator() - Constructor for class com.pvx.ooadide.editors.PvxParameterListValidator
PvxPasswordInputDialogue - Class in com.pvx.ooadide.builder
PvxPasswordInputDialogue(Shell, String, String, Vector<String>, IInputValidator, String) - Constructor for class com.pvx.ooadide.builder.PvxPasswordInputDialogue
PvxPerspectiveFactory - Class in com.pvx.ooadide.views
PvxPerspectiveFactory() - Constructor for class com.pvx.ooadide.views.PvxPerspectiveFactory
PvxPluginImages - Class in com.pvx.ooadide.ui
PvxPluginImages() - Constructor for class com.pvx.ooadide.ui.PvxPluginImages
PvxPrefVisitee - Interface in com.pvx.ooadide.preferences
PvxProblem - Class in com.pvx.ooadide.builder
PvxProblem(boolean, String, String, int, int, String, IFile) - Constructor for class com.pvx.ooadide.builder.PvxProblem
PvxProblem(boolean, String, String, String, IFile) - Constructor for class com.pvx.ooadide.builder.PvxProblem
PvxProblem(String, String, String, IFile, String) - Constructor for class com.pvx.ooadide.builder.PvxProblem
PvxProgressMonitorDialog - Class in com.pvx.ooadide.views
PvxProgressMonitorDialog - Class in com.sage.rcp.eventmanager
PvxProgressMonitorDialog(Shell) - Constructor for class com.pvx.ooadide.views.PvxProgressMonitorDialog
PvxProgressMonitorDialog(Shell) - Constructor for class com.sage.rcp.eventmanager.PvxProgressMonitorDialog
PvxPropertyResolver - Class in com.pvx.ooadide.editors.templates
PvxPropertyResolver() - Constructor for class com.pvx.ooadide.editors.templates.PvxPropertyResolver
PvxPropertySource - Class in com.pvx.ooadide.properties
PvxPropertySource(IResource) - Constructor for class com.pvx.ooadide.properties.PvxPropertySource
PvxRcpActivator - Class in com.sage.rcp
The activator class controls the plug-in life cycle
PvxRcpActivator() - Constructor for class com.sage.rcp.PvxRcpActivator
The constructor
PvxRcpStateFlags - Class in com.sage.rcp.util
PvxReconcilingStrategy - Class in com.pvx.ooadide.editors.codefolding
PvxReconcilingStrategy() - Constructor for class com.pvx.ooadide.editors.codefolding.PvxReconcilingStrategy
Constructor: Load list of keywords used to identify the blocks of code in the source file
PvxRequestManager - Class in com.pvx.ooadide.eventmanager
PvxRunnableWithProgress - Class in com.pvx.ooadide.views
PvxRunnableWithProgress - Class in com.sage.rcp.eventmanager
PvxRunnableWithProgress(PvxProgressMonitorDialog, MonitorState, String, int) - Constructor for class com.pvx.ooadide.views.PvxRunnableWithProgress
PvxRunnableWithProgress(PvxProgressMonitorDialog, MonitorState, String, int) - Constructor for class com.sage.rcp.eventmanager.PvxRunnableWithProgress
PVXRunToLineBreakpoint - Class in com.pvx.ooadide.launchers.debug.breakpoints
A run to line breakpoint.
PVXRunToLineBreakpoint(IFile, int) - Constructor for class com.pvx.ooadide.launchers.debug.breakpoints.PVXRunToLineBreakpoint
Constructs a run-to-line breakpoint in the given PVX program.
PVXSourceLookupDirector - Class in com.pvx.ooadide.launchers.debug.launching
PDA source lookup director.
PVXSourceLookupDirector() - Constructor for class com.pvx.ooadide.launchers.debug.launching.PVXSourceLookupDirector
PVXSourceLookupParticipant - Class in com.pvx.ooadide.launchers.debug.launching
The PDA source lookup participant knows how to translate a PDA stack frame into a source file name
PVXSourceLookupParticipant() - Constructor for class com.pvx.ooadide.launchers.debug.launching.PVXSourceLookupParticipant
PVXSourcePathComputerDelegate - Class in com.pvx.ooadide.launchers.debug.launching
Computes the default source lookup path for a PDA launch configuration.
PVXSourcePathComputerDelegate() - Constructor for class com.pvx.ooadide.launchers.debug.launching.PVXSourcePathComputerDelegate
PVXStackFrame - Class in com.pvx.ooadide.launchers.debug.model
PDA stack frame.
PVXStackFrame(PVXThread, String, int) - Constructor for class com.pvx.ooadide.launchers.debug.model.PVXStackFrame
Constructs a stack frame in the given thread with the given frame data.
PVXStackValue - Class in com.pvx.ooadide.launchers.debug.model
A value on the data stack
PVXStackValue(PVXDebugTarget, String, int) - Constructor for class com.pvx.ooadide.launchers.debug.model.PVXStackValue
Constructs a value that appears on the data stack
PvxStructureComparator - Class in com.pvx.ooadide.views.comparators
PvxStructureComparator(int, int, ITableLabelProvider) - Constructor for class com.pvx.ooadide.views.comparators.PvxStructureComparator
PvxtagResolver - Class in com.pvx.ooadide.properties.refactoring.tagresolver
PvxtagResolver() - Constructor for class com.pvx.ooadide.properties.refactoring.tagresolver.PvxtagResolver
PVXThread - Class in com.pvx.ooadide.launchers.debug.model
// * A y VM thread.
PVXThread(PVXDebugTarget) - Constructor for class com.pvx.ooadide.launchers.debug.model.PVXThread
Constructs a new thread for the given target
PvxUtil - Class in com.pvx.ooadide.util
PvxUtil - Class in com.sage.rcp.util
PvxUtil() - Constructor for class com.pvx.ooadide.util.PvxUtil
PvxUtil() - Constructor for class com.sage.rcp.util.PvxUtil
PvxUtil.ConfirmDialShower - Class in com.pvx.ooadide.util
PvxUtil.ConfirmDialShower - Class in com.sage.rcp.util
PVXValue - Class in com.pvx.ooadide.launchers.debug.model
Value of a PDA variable.
PVXValue(PVXDebugTarget, String) - Constructor for class com.pvx.ooadide.launchers.debug.model.PVXValue
PVXValue(PVXDebugTarget, String, String) - Constructor for class com.pvx.ooadide.launchers.debug.model.PVXValue
PVXVariable - Class in com.pvx.ooadide.launchers.debug.model
A variable in a PVX stack frame
PVXVariable(PVXStackFrame, String) - Constructor for class com.pvx.ooadide.launchers.debug.model.PVXVariable
Constructs a variable contained in the given stack frame with the given name.
PvxVersionInfo - Class in com.pvx.ooadide.util
PvxVersionInfo(int, String, String) - Constructor for class com.pvx.ooadide.util.PvxVersionInfo
PvxView - Interface in com.pvx.ooadide.views
PvxViewSorter - Class in com.pvx.ooadide.views
PvxViewSorter() - Constructor for class com.pvx.ooadide.views.PvxViewSorter
PvxWizardNewFileCreatePage - Class in com.pvx.ooadide.wizards.programs
PvxWizardNewFileCreatePage(String, String, IStructuredSelection) - Constructor for class com.pvx.ooadide.wizards.programs.PvxWizardNewFileCreatePage
PvxWordRule - Class in com.pvx.ooadide.codehilite2
PvxWordRule(IWordDetector) - Constructor for class com.pvx.ooadide.codehilite2.PvxWordRule
Creates a rule which, with the help of an word detector, will return the token associated with the detected word.
PvxWordRule(IWordDetector, IToken) - Constructor for class com.pvx.ooadide.codehilite2.PvxWordRule
Creates a rule which, with the help of a word detector, will return the token associated with the detected word.
PxvResourceListSelectionDialog - Class in com.pvx.ooadide.properties.dialogs
PxvResourceListSelectionDialog(Shell, IContainer, int) - Constructor for class com.pvx.ooadide.properties.dialogs.PxvResourceListSelectionDialog
A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form


Q-Index

Index

A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form

Q

QUALIFIED_ID - Static variable in class com.pvx.ooadide.properties.ProvideXPropertyPage
queryForPassword(InputStream, IFile, String, Vector<PvxProblem>) - Static method in class com.pvx.ooadide.builder.ProvideXBuilder
queryOverwrite(String) - Method in class com.pvx.ooadide.wizards.WizardPasswordPage
The WizardDataTransfer implementation of this IOverwriteQuery method asks the user whether the existing resource at the given path should be overwritten.
A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form


R-Index

Index

A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form

R

RADIOGROUP - Static variable in class com.pvx.ooadide.util.PvxUtil
RADIOGROUP_DATA - Static variable in class com.pvx.ooadide.util.PvxUtil
RcpEmbedJavXView - Class in com.sage.rcp.views
RcpEmbedJavXView() - Constructor for class com.sage.rcp.views.RcpEmbedJavXView
The constructor.
RcpMasProgramView - Class in com.sage.rcp.views
RcpMasProgramView() - Constructor for class com.sage.rcp.views.RcpMasProgramView
RcpPluginConnectionControl - Class in com.sage.rcp.javx
RcpPluginConnectionControl(String, int, PvxBaseWindow, Hashtable, PvxBaseWindow, Socket) - Constructor for class com.sage.rcp.javx.RcpPluginConnectionControl
RcpPluginJavXApplet - Class in com.sage.rcp.javx
RcpPluginJavXApplet(IEmbeddedJavXView) - Constructor for class com.sage.rcp.javx.RcpPluginJavXApplet
RcpPluginSwingGUIManager - Class in com.sage.rcp.javx
RcpPluginSwingGUIManager(IEmbeddedJavXView, PvxHost) - Constructor for class com.sage.rcp.javx.RcpPluginSwingGUIManager
RcpPreferenceConstants - Class in com.sage.rcp.preferences
RcpPreferenceConstants() - Constructor for class com.sage.rcp.preferences.RcpPreferenceConstants
RcpPreferenceInitializer - Class in com.sage.rcp.preferences
RcpPreferenceInitializer() - Constructor for class com.sage.rcp.preferences.RcpPreferenceInitializer
RcpProgramView - Class in com.sage.rcp.views
RcpProgramView() - Constructor for class com.sage.rcp.views.RcpProgramView
RcpPvxAction - Class in com.sage.rcp.views
RcpPvxAction(RcpPluginSwingGUIManager, int) - Constructor for class com.sage.rcp.views.RcpPvxAction
rcpShowFrm(short) - Method in class com.sage.rcp.javx.windows.PluginTextPlaneView
RcpSpawnedMasProgramView - Class in com.sage.rcp.views
RcpSpawnedMasProgramView() - Constructor for class com.sage.rcp.views.RcpSpawnedMasProgramView
RcpSwtViewPanel - Class in com.sage.rcp.javx
RcpSwtViewPanel(RcpEmbedJavXView) - Constructor for class com.sage.rcp.javx.RcpSwtViewPanel
readSyncPkt() - Method in class com.sage.rcp.javx.RcpPluginConnectionControl
readTxtCtrl(String) - Method in class com.sage.rcp.javx.RcpPluginSwingGUIManager
reconcile(IRegion) - Method in class com.pvx.ooadide.editors.codefolding.PvxReconcilingStrategy
reconcile(DirtyRegion, IRegion) - Method in class com.pvx.ooadide.editors.codefolding.PvxReconcilingStrategy
RefactorUtil - Class in com.pvx.ooadide.refactor
RefactorUtil() - Constructor for class com.pvx.ooadide.refactor.RefactorUtil
refresh() - Method in class com.pvx.ooadide.views.IOListView
refresh() - Method in class com.pvx.ooadide.views.nomads.LibView
refresh() - Method in interface com.pvx.ooadide.views.PvxView
REM_BANG - Static variable in class com.pvx.ooadide.refactor.BlockCommentAction
remove(PVXDebugTarget) - Method in class com.pvx.ooadide.launchers.debug.breakpoints.PVXLineBreakpoint
Removes this breakpoint from the given interprettor.
remove(PVXDebugTarget) - Method in class com.pvx.ooadide.launchers.debug.model.PvxLineBreakpointAdapter
Removes this breakpoint from the given interprettor.
REMOVE - Static variable in class com.pvx.ooadide.eventmanager.EventManager
removeAll() - Static method in class com.pvx.ooadide.eventmanager.DelayedMethodHandler
removeAll() - Static method in class com.sage.rcp.eventmanager.DelayedMethodHandler
removeAllCtrl(boolean) - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
REMOVED_RESOURCE_FROM_SRC - Static variable in class com.pvx.ooadide.eventmanager.EventManager
removeEventListener(IPVXEventListener) - Method in class com.pvx.ooadide.launchers.debug.model.PVXDebugTarget
Deregisters the given event listener.
removeFromHistory(String[], String) - Method in class com.pvx.ooadide.properties.ProvideXPropertyPage
removeListener(String) - Method in class com.pvx.ooadide.eventmanager.EventManager
Removes a listener from the EventManager.
removeListener(String) - Method in class com.sage.rcp.eventmanager.EventManager
Removes a listener from the EventManager.
removePervasiveObject(int) - Static method in class com.pvx.ooadide.eventmanager.EventManager
Most Java objects instantiated by ProvideX will be dropped after every event.
removePervasiveObject(int) - Static method in class com.sage.rcp.eventmanager.EventManager
Most Java objects instantiated by ProvideX will be dropped after every event.
removePropertyChangeListener(IPropertyChangeListener) - Method in class com.pvx.ooadide.uesearch.SearchGotoAction
removeSaveListener(IPvxSaveListener) - Static method in class com.pvx.ooadide.builder.ProvideXBuilder
renameProperty_refuseDlg_message - Static variable in class com.pvx.ooadide.properties.refactoring.ui.UITexts
renameProperty_refuseDlg_message - Static variable in class com.pvx.ooadide.refactor.UITexts
renameProperty_refuseDlg_title - Static variable in class com.pvx.ooadide.properties.refactoring.ui.UITexts
renameProperty_refuseDlg_title - Static variable in class com.pvx.ooadide.refactor.UITexts
RenamePropertyAction - Class in com.pvx.ooadide.refactor
RenamePropertyAction() - Constructor for class com.pvx.ooadide.refactor.RenamePropertyAction
renamePropertyDelegate_checking - Static variable in class com.pvx.ooadide.properties.refactoring.core.CoreTexts
renamePropertyDelegate_checking - Static variable in class com.pvx.ooadide.refactor.UITexts
renamePropertyDelegate_collectingChanges - Static variable in class com.pvx.ooadide.properties.refactoring.core.CoreTexts
renamePropertyDelegate_collectingChanges - Static variable in class com.pvx.ooadide.refactor.UITexts
renamePropertyDelegate_noPropertyKey - Static variable in class com.pvx.ooadide.refactor.UITexts
renamePropertyDelegate_noSourceFile - Static variable in class com.pvx.ooadide.properties.refactoring.core.CoreTexts
renamePropertyDelegate_propNotFound - Static variable in class com.pvx.ooadide.properties.refactoring.core.CoreTexts
renamePropertyDelegate_propNotFound - Static variable in class com.pvx.ooadide.refactor.UITexts
renamePropertyDelegate_roFile - Static variable in class com.pvx.ooadide.properties.refactoring.core.CoreTexts
RenamePropertyInfo - Class in com.pvx.ooadide.refactor
an info object that holds the information that is passed from the user to the refactoring.
RenamePropertyInfo() - Constructor for class com.pvx.ooadide.refactor.RenamePropertyInfo
RenamePropertyInputPage - Class in com.pvx.ooadide.properties.refactoring.ui.wizards
the input page for the Rename Property refactoring, where users can control the effects of the refactoring; to be shown in the wizard.
RenamePropertyInputPage - Class in com.pvx.ooadide.refactor
the input page for the Rename Property refactoring, where users can control the effects of the refactoring; to be shown in the wizard.
RenamePropertyInputPage(ResourcePropertyInfo[]) - Constructor for class com.pvx.ooadide.properties.refactoring.ui.wizards.RenamePropertyInputPage
RenamePropertyInputPage(RenamePropertyInfo) - Constructor for class com.pvx.ooadide.refactor.RenamePropertyInputPage
renamePropertyInputPage_cbAllProjects - Static variable in class com.pvx.ooadide.properties.refactoring.ui.UITexts
renamePropertyInputPage_cbAllProjects - Static variable in class com.pvx.ooadide.refactor.UITexts
renamePropertyInputPage_cbUpdateBundle - Static variable in class com.pvx.ooadide.properties.refactoring.ui.UITexts
renamePropertyInputPage_cbUpdateBundle - Static variable in class com.pvx.ooadide.refactor.UITexts
renamePropertyInputPage_lblNewName - Static variable in class com.pvx.ooadide.properties.refactoring.ui.UITexts
renamePropertyInputPage_lblNewName - Static variable in class com.pvx.ooadide.refactor.UITexts
RenamePropertyProcessor - Class in com.pvx.ooadide.properties.refactoring.core
The processor is where the work is delegated to if participants are involved.
RenamePropertyProcessor - Class in com.pvx.ooadide.refactor
The processor is where the work is delegated to if participants are involved.
RenamePropertyProcessor(ResourcePropertyInfo[]) - Constructor for class com.pvx.ooadide.properties.refactoring.core.RenamePropertyProcessor
RenamePropertyProcessor(RenamePropertyInfo) - Constructor for class com.pvx.ooadide.refactor.RenamePropertyProcessor
renamePropertyProcessor_name - Static variable in class com.pvx.ooadide.properties.refactoring.core.CoreTexts
renamePropertyProcessor_name - Static variable in class com.pvx.ooadide.refactor.UITexts
RenamePropertyRefactoring - Class in com.pvx.ooadide.properties.refactoring.core
Refactoring for renaming properties in Java Properties files.
RenamePropertyRefactoring - Class in com.pvx.ooadide.refactor
Refactoring for renaming properties in Java Properties files.
RenamePropertyRefactoring(RefactoringProcessor) - Constructor for class com.pvx.ooadide.properties.refactoring.core.RenamePropertyRefactoring
RenamePropertyRefactoring(RefactoringProcessor) - Constructor for class com.pvx.ooadide.refactor.RenamePropertyRefactoring
RenamePropertyWizard - Class in com.pvx.ooadide.properties.refactoring.ui.wizards
The wizard that is shown to the user for entering the necessary information for property renaming.
RenamePropertyWizard - Class in com.pvx.ooadide.refactor
The wizard that is shown to the user for entering the necessary information for property renaming.
RenamePropertyWizard(RenamePropertyRefactoring, ResourcePropertyInfo[]) - Constructor for class com.pvx.ooadide.properties.refactoring.ui.wizards.RenamePropertyWizard
RenamePropertyWizard(RenamePropertyRefactoring, RenamePropertyInfo) - Constructor for class com.pvx.ooadide.refactor.RenamePropertyWizard
RenumberAction - Class in com.pvx.ooadide.refactor
RenumberAction() - Constructor for class com.pvx.ooadide.refactor.RenumberAction
replaceAll(String, String, String) - Static method in class com.pvx.ooadide.util.PvxUtil
replaceText(ITextSelection, String) - Method in class com.pvx.ooadide.eventmanager.EditorManager
Inserts text at the current cursor position in the open pvx editor.
reportVersionAs() - Static method in class com.sage.rcp.preferences.UiPrefManager
REQ_EXT - Static variable in class com.pvx.ooadide.views.IOListView
REQUEST_SOCKET - Static variable in class com.pvx.ooadide.eventmanager.EventManager
requestJavXFocus() - Method in class com.sage.rcp.views.RcpEmbedJavXView
reset() - Static method in class com.pvx.ooadide.util.StopWatch
resetIterator() - Method in class com.pvx.ooadide.eventmanager.PvxEvent
Wraps the Properties iterator that contains the arguments of associated with this event
resetIterator() - Method in class com.sage.rcp.eventmanager.PvxEvent
Wraps the Properties iterator that contains the arguments of associated with this event
resolve(TemplateBuffer, TemplateContext) - Method in class com.pvx.ooadide.editors.templates.PVXContextType
resolvePropertyOnFile(String, TemplateContext) - Method in class com.pvx.ooadide.editors.templates.PvxPropertyResolver
resolvePvxVariables(String) - Method in class com.pvx.ooadide.wizards.programs.PvxNewProgramPropertiesWizardPage
RESOURCE_LIST - Static variable in class com.pvx.ooadide.eventmanager.EventManager
RESOURCE_PROPERTIES_CHANGED - Static variable in class com.pvx.ooadide.eventmanager.EventManager
RESOURCE_PROPERTIES_LIST - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
ResourceManager - Class in com.pvx.ooadide.eventmanager
Provides access to resources in Eclipse for ProvideX programs
ResourceManager() - Constructor for class com.pvx.ooadide.eventmanager.ResourceManager
ResourcePropertyInfo - Class in com.pvx.ooadide.properties.refactoring.core
ResourcePropertyInfo(String, String, IFile, int) - Constructor for class com.pvx.ooadide.properties.refactoring.core.ResourcePropertyInfo
ResourceToChangeEntity - Class in com.pvx.ooadide.properties
ResourceToChangeEntity(IFile) - Constructor for class com.pvx.ooadide.properties.ResourceToChangeEntity
restartPvxHost() - Static method in class com.pvx.ooadide.eventmanager.EventManager
resume() - Method in class com.pvx.ooadide.launchers.debug.model.PVXDebugTarget
resume() - Method in class com.pvx.ooadide.launchers.debug.model.PVXStackFrame
resume() - Method in class com.pvx.ooadide.launchers.debug.model.PVXThread
RTN_FILTER - Enum constant in enum com.pvx.ooadide.views.PvcOutline.OutlineFilter
RTN_TYPE - Static variable in class com.pvx.ooadide.util.PvxElement
RulerActionDelegate - Class in com.pvx.ooadide.launchers.debug
Toggles a breakpoint when ruler is double-clicked
RulerActionDelegate() - Constructor for class com.pvx.ooadide.launchers.debug.RulerActionDelegate
run() - Method in class com.pvx.ooadide.eventmanager.PvxRequestManager
run() - Method in class com.pvx.ooadide.launchers.debug.communication.DebugLauncherThread
run() - Method in class com.pvx.ooadide.launchers.debug.communication.ServerSocketThread
run() - Method in class com.pvx.ooadide.launchers.debug.ToggleBreakpointAction
run() - Method in class com.pvx.ooadide.launchers.thinclients.DebugWindXLauncherThread
run() - Method in class com.pvx.ooadide.uesearch.SearchGotoAction
run() - Method in class com.pvx.ooadide.util.PvxUtil.ConfirmDialShower
run() - Method in class com.sage.rcp.javx.RcpPluginConnectionControl
run() - Method in class com.sage.rcp.util.PvxUtil.ConfirmDialShower
run() - Method in class com.sage.rcp.views.JavXThread
run() - Method in class com.sage.rcp.views.RcpPvxAction
run(IMarker) - Method in class com.pvx.ooadide.builder.CodeStyleWarningResolution
run(IProgressMonitor) - Method in class com.pvx.ooadide.views.PvxRunnableWithProgress
run(IProgressMonitor) - Method in class com.sage.rcp.eventmanager.PvxRunnableWithProgress
run(IAction) - Method in class com.pvx.ooadide.actions.AbstractPvxEditorAction
run(IAction) - Method in class com.pvx.ooadide.actions.ConvertAction
run(IAction) - Method in class com.pvx.ooadide.actions.ExtAction
run(IAction) - Method in class com.pvx.ooadide.actions.GenericAction
run(IAction) - Method in class com.pvx.ooadide.actions.ProvideX
The action has been activated.
run(IAction) - Method in class com.pvx.ooadide.actions.RunDictDataClassAction
run(IAction) - Method in class com.pvx.ooadide.actions.RunDictMaintAction
run(IAction) - Method in class com.pvx.ooadide.actions.RunITAction1
run(IAction) - Method in class com.pvx.ooadide.builder.BuildResourceAction
run(IAction) - Method in class com.pvx.ooadide.builder.ToggleNatureAction
run(IAction) - Method in class com.pvx.ooadide.editors.LoadProgramAction
run(IAction) - Method in class com.pvx.ooadide.popup.actions.ProvideXNewAction
run(IAction) - Method in class com.pvx.ooadide.refactor.RenamePropertyAction
run(IAction) - Method in class com.pvx.ooadide.refactor.RenumberAction
RUN_CONSOLE - Static variable in class com.pvx.ooadide.eventmanager.EventManager
RUN_DESIGNER - Static variable in class com.pvx.ooadide.eventmanager.EventManager
RUN_DICT_DATA_CLASS - Static variable in class com.pvx.ooadide.eventmanager.EventManager
RUN_DICTMAINT - Static variable in class com.pvx.ooadide.eventmanager.EventManager
RUN_HOST - Static variable in class com.pvx.ooadide.eventmanager.EventManager
RUN_IT - Static variable in class com.pvx.ooadide.eventmanager.EventManager
RUN_NOMADS - Static variable in class com.pvx.ooadide.eventmanager.EventManager
RUN_TEST_PANEL - Static variable in class com.pvx.ooadide.eventmanager.EventManager
runConsole(IProject) - Static method in class com.pvx.ooadide.util.RunUtil
runDictDataClass(IProject, String, String) - Static method in class com.pvx.ooadide.util.RunUtil
RunDictDataClassAction - Class in com.pvx.ooadide.actions
RunDictDataClassAction() - Constructor for class com.pvx.ooadide.actions.RunDictDataClassAction
runDictMaint(IProject, String, String) - Static method in class com.pvx.ooadide.util.RunUtil
RunDictMaintAction - Class in com.pvx.ooadide.actions
RunDictMaintAction() - Constructor for class com.pvx.ooadide.actions.RunDictMaintAction
runIOListScanner(IProject, String, String) - Static method in class com.pvx.ooadide.util.RunUtil
runIT(IFile) - Static method in class com.pvx.ooadide.util.RunUtil
RunITAction1 - Class in com.pvx.ooadide.actions
RunITAction1() - Constructor for class com.pvx.ooadide.actions.RunITAction1
runJavX() - Method in class com.sage.rcp.views.RcpEmbedJavXView
runLibScanner(IProject, String, String) - Static method in class com.pvx.ooadide.util.RunUtil
runNomads() - Static method in class com.pvx.ooadide.util.RunUtil
runNtHost(int) - Static method in class com.pvx.ooadide.util.RunUtil
runNtHost(String[]) - Method in class com.pvx.ooadide.eventmanager.EventManager
runNtHost(String[]) - Static method in class com.pvx.ooadide.util.RunUtil
runNtHost(String[]) - Method in class com.sage.rcp.eventmanager.EventManager
runNtHost(String[]) - Method in interface com.sage.rcp.IEventManager
runNtHost(String[]) - Static method in class com.sage.rcp.util.RunUtilProxy
runProgram(String, String, String, String, String[], boolean) - Static method in class com.pvx.ooadide.util.RunUtil
runProgram(String, String, String, String, String[], boolean, boolean, Properties) - Static method in class com.sage.rcp.util.RunUtilProxy
runProgram(String, String, String, String, String[], boolean, Properties) - Static method in class com.pvx.ooadide.util.RunUtil
runProgram(String, String, String, String, String, String[], boolean, boolean, Properties) - Static method in class com.pvx.ooadide.util.RunUtil
runProgramInView(String) - Static method in class com.pvx.ooadide.eventmanager.EventManager
RunPvxTester - Class in com.pvx.ooadide.util
RunPvxTester() - Constructor for class com.pvx.ooadide.util.RunPvxTester
runStripper(IProject, String, String) - Static method in class com.pvx.ooadide.util.RunUtil
RunUtil - Class in com.pvx.ooadide.util
RunUtil() - Constructor for class com.pvx.ooadide.util.RunUtil
RunUtilProxy - Class in com.sage.rcp.util
RunUtilProxy() - Constructor for class com.sage.rcp.util.RunUtilProxy
runWithEvent(Event) - Method in class com.pvx.ooadide.uesearch.SearchGotoAction
A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form


S-Index

Index

A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form

S

SageCopyrightPropertyResolver - Class in com.pvx.ooadide.editors.templates
SageCopyrightPropertyResolver() - Constructor for class com.pvx.ooadide.editors.templates.SageCopyrightPropertyResolver
SAVEING_ALL - Static variable in class com.pvx.ooadide.actions.ProvideX
saveOutlineSettings(PvcOutlineSettings) - Method in class com.pvx.ooadide.ProvideXOOADPlugin
Save current state of Outline View Group-By and Filter settings (for current session)
savePluginPreferences() - Method in class com.pvx.ooadide.editors.templates.TemplateEditorUI
saveState(IMemento) - Method in class com.sage.rcp.views.RcpProgramView
scanFolder(IFolder, String, String, String, String, String, String, String) - Static method in class com.pvx.ooadide.properties.ProvideXPropertyPage
scanLog(File, Vector, String) - Method in class com.pvx.ooadide.views.nomads.LibView
scanPvxDomLog(File, IFile, Vector) - Static method in class com.pvx.ooadide.util.PvxElement
scanPvxErrorLogFile(File, IFile, Vector<PvxProblem>) - Static method in class com.pvx.ooadide.builder.PvxProblem
scanPvxErrorLogString(String, IFile, Vector<PvxProblem>) - Static method in class com.pvx.ooadide.builder.PvxProblem
scanWarningLog(File, IFile, Vector<PvxProblem>) - Static method in class com.pvx.ooadide.builder.StyleWarning
scriptMessage - Variable in class com.sage.rcp.javx.RcpPluginJavXApplet
scrlRemoveCtls(int, int, int, int) - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
SearchGotoAction - Class in com.pvx.ooadide.uesearch
SearchGotoAction(ISearchResultView) - Constructor for class com.pvx.ooadide.uesearch.SearchGotoAction
SECND_ID_KEY - Static variable in class com.sage.rcp.views.RcpEmbedJavXView
select(Viewer, Object, Object) - Method in class com.pvx.ooadide.navigator.filters.NavigationFilter
selectAndReveal(IResource, IWorkbenchWindow) - Static method in class com.pvx.ooadide.wizards.NewNomadsLibraryWizard
Attempts to select and reveal the specified resource in all parts within the supplied workbench window's active page.
selectAndReveal(IResource, IWorkbenchWindow) - Static method in class com.pvx.ooadide.wizards.NewNomadsNmdWizard
Attempts to select and reveal the specified resource in all parts within the supplied workbench window's active page.
selectAndReveal(IResource, IWorkbenchWindow) - Static method in class com.pvx.ooadide.wizards.programs.NewPvxProgramWizard
Attempts to select and reveal the specified resource in all parts within the supplied workbench window's active page.
SELECTED_VIEW - Static variable in class com.pvx.ooadide.eventmanager.EventManager
selectionChanged(IAction, ISelection) - Method in class com.pvx.ooadide.actions.AbstractPvxEditorAction
selectionChanged(IAction, ISelection) - Method in class com.pvx.ooadide.actions.ConvertAction
selectionChanged(IAction, ISelection) - Method in class com.pvx.ooadide.actions.ExtAction
selectionChanged(IAction, ISelection) - Method in class com.pvx.ooadide.actions.GenericAction
selectionChanged(IAction, ISelection) - Method in class com.pvx.ooadide.actions.ProvideX
Selection in the workbench has been changed.
selectionChanged(IAction, ISelection) - Method in class com.pvx.ooadide.builder.BuildResourceAction
selectionChanged(IAction, ISelection) - Method in class com.pvx.ooadide.builder.ToggleNatureAction
selectionChanged(IAction, ISelection) - Method in class com.pvx.ooadide.editors.LoadProgramAction
selectionChanged(IAction, ISelection) - Method in class com.pvx.ooadide.popup.actions.ProvideXNewAction
selectionChanged(IAction, ISelection) - Method in class com.pvx.ooadide.refactor.RenamePropertyAction
selectWindow(PvxWindow, boolean) - Method in class com.sage.rcp.javx.RcpPluginSwingGUIManager
sendActionMsg(String) - Method in class com.pvx.ooadide.actions.GenericAction
sendRequest(String) - Method in class com.pvx.ooadide.launchers.debug.model.PVXDebugElement
Sends a request to the PDA interpretor, waits for and returns the reply.
sendRequest(String) - Method in class com.pvx.ooadide.launchers.debug.model.PVXDebugTarget
sendViewActionEvent(int) - Method in class com.sage.rcp.javx.RcpPluginSwingGUIManager
sep - Static variable in class com.pvx.ooadide.views.nomads.LibView
ServerSocketThread - Class in com.pvx.ooadide.launchers.debug.communication
ServerSocketThread(DebugLauncherThread, int, int) - Constructor for class com.pvx.ooadide.launchers.debug.communication.ServerSocketThread
setAccelerator(int) - Method in class com.pvx.ooadide.uesearch.SearchGotoAction
setActionBars(IActionBars) - Method in interface com.sage.rcp.javx.IEmbeddedJavXView
setActionBars(IActionBars) - Method in class com.sage.rcp.views.HostActionsView
setActionBars(IActionBars) - Method in class com.sage.rcp.views.RcpEmbedJavXView
setActionDefinitionId(String) - Method in class com.pvx.ooadide.uesearch.SearchGotoAction
setActiveEditor(IAction, IEditorPart) - Method in class com.pvx.ooadide.actions.AbstractPvxEditorAction
setActiveEditor(IAction, IEditorPart) - Method in class com.pvx.ooadide.actions.GenericAction
setActiveEditor(IAction, IEditorPart) - Method in class com.pvx.ooadide.refactor.RenamePropertyAction
setActivePart(IAction, IWorkbenchPart) - Method in class com.pvx.ooadide.actions.ConvertAction
setActivePart(IAction, IWorkbenchPart) - Method in class com.pvx.ooadide.builder.BuildResourceAction
setActivePart(IAction, IWorkbenchPart) - Method in class com.pvx.ooadide.builder.ToggleNatureAction
setActivePart(IAction, IWorkbenchPart) - Method in class com.pvx.ooadide.editors.LoadProgramAction
setActivePart(IAction, IWorkbenchPart) - Method in class com.pvx.ooadide.popup.actions.ProvideXNewAction
setAllKeywords(String[]) - Method in class com.pvx.ooadide.editors.extkeyword.ExtKeywordCategoryEntity
setAllProjects(boolean) - Method in class com.pvx.ooadide.refactor.RenamePropertyInfo
setArgsStr(String) - Method in class com.sage.rcp.views.RcpEmbedJavXView
setAttribute(String, Object) - Method in class com.pvx.ooadide.launchers.debug.launching.PVXModelPresentation
setBoolean(String, String) - Static method in class com.pvx.ooadide.preferences.PreferenceManager
setBorderIsVisible(boolean) - Method in class com.sage.rcp.views.RcpEmbedJavXView
setBuildError(boolean) - Static method in class com.pvx.ooadide.builder.ProvideXBuilder
setBuildErrorMSg(String) - Static method in class com.pvx.ooadide.builder.ProvideXBuilder
setBuildOnClose(boolean) - Method in class com.pvx.ooadide.editors.NomadsEditor
setBusy(boolean) - Method in class com.sage.rcp.util.ProgressIndicator
setCanceled(boolean) - Method in class com.sage.rcp.util.ProgressIndicator
setCategoryName(String) - Method in class com.pvx.ooadide.editors.extkeyword.ExtKeywordCategoryEntity
setChangeType(int) - Method in class com.pvx.ooadide.refactor.RenamePropertyInfo
setChecked(boolean) - Method in class com.pvx.ooadide.uesearch.SearchGotoAction
setColumnConstraint(int) - Method in class com.pvx.ooadide.codehilite2.PvxWordRule
Sets a column constraint for this rule.
setCompositeColor(Color) - Method in class com.sage.rcp.views.HostActionsView
setCompositeColor(Color) - Method in class com.sage.rcp.views.RcpEmbedJavXView
setConCon(RcpPluginConnectionControl) - Method in class com.pvx.ooadide.eventmanager.EventManager
setConCon(RcpPluginConnectionControl) - Method in class com.sage.rcp.eventmanager.EventManager
setConCon(RcpPluginConnectionControl) - Method in interface com.sage.rcp.IEventManager
setCongifValues() - Method in class com.pvx.ooadide.ProvideXOOADPlugin
setConnectionAnimation(AnimatedPanel) - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
setContentAssistProcessor(IContentAssistProcessor, String) - Method in class com.pvx.ooadide.codehilite2.PvxContentAssistant
setContextInformation(IContextInformation) - Method in class com.pvx.ooadide.editors.PvxCompletionProposal
setContinueWaiting(boolean) - Static method in class com.pvx.ooadide.eventmanager.EventManager
setContinueWaiting(boolean) - Static method in class com.sage.rcp.eventmanager.EventManager
setControlPlugin(IPvxPlugin) - Method in class com.sage.rcp.PvxRcpActivator
setCtxImage(Image) - Method in class com.pvx.ooadide.editors.PvxCompletionProposal
setCurrentMessage(String) - Method in class com.sage.rcp.util.ProgressIndicator
setCurrentProject(IProject) - Static method in class com.pvx.ooadide.eventmanager.EventManager
setCurrentValue(String) - Method in class com.pvx.ooadide.preferences.UserPrefElement
setDataType(int) - Method in class com.pvx.ooadide.preferences.UserPrefElement
setDefaultBoolean(String, String) - Static method in class com.pvx.ooadide.preferences.PreferenceManager
setDefaultPvxPath(String) - Static method in class com.sage.rcp.util.PvxUtil
setDefaults(ILaunchConfigurationWorkingCopy) - Method in class com.pvx.ooadide.launchers.IniFileBlock
setDefaults(ILaunchConfigurationWorkingCopy) - Method in class com.pvx.ooadide.launchers.ProvideXArgumentsTab
Defaults are empty.
setDefaults(ILaunchConfigurationWorkingCopy) - Method in class com.pvx.ooadide.launchers.ProvideXMainTab
setDefaults(ILaunchConfigurationWorkingCopy) - Method in class com.pvx.ooadide.launchers.thinclients.ClientTab
setDefaults(ILaunchConfigurationWorkingCopy) - Method in class com.pvx.ooadide.launchers.thinclients.javx.JavXAppletArgumentsTab
setDefaults(ILaunchConfigurationWorkingCopy) - Method in class com.pvx.ooadide.launchers.WindowStateBlock
Defaults are empty.
setDefaultString(String, String) - Static method in class com.pvx.ooadide.preferences.PreferenceManager
setDefaultValue(String) - Method in class com.pvx.ooadide.preferences.UserPrefElement
setDescription(String) - Method in class com.pvx.ooadide.builder.PvxProblem
setDescription(String) - Method in class com.pvx.ooadide.uesearch.SearchGotoAction
setDialogueVisible(boolean) - Method in class com.pvx.ooadide.views.MonitorState
setDialogueVisible(boolean) - Method in class com.sage.rcp.eventmanager.MonitorState
setDisabledImageDescriptor(ImageDescriptor) - Method in class com.pvx.ooadide.uesearch.SearchGotoAction
setDisplayString(String) - Method in class com.pvx.ooadide.editors.PvxCompletionProposal
setDocument(IDocument) - Method in class com.pvx.ooadide.editors.codefolding.PvxReconcilingStrategy
setEclipseBye(boolean) - Static method in class com.pvx.ooadide.eventmanager.EventManager
setEclipseBye(boolean) - Static method in class com.sage.rcp.eventmanager.EventManager
setEditor(PvxEditor) - Method in class com.pvx.ooadide.editors.codefolding.PvxReconcilingStrategy
setEditor(PvxEditor) - Method in class com.pvx.ooadide.refactor.RenamePropertyInfo
setElement(int, String) - Method in class com.pvx.ooadide.views.nomads.PvxLibElement
setEnabled(boolean) - Method in class com.pvx.ooadide.launchers.IniFileBlock
setEnabled(boolean) - Method in class com.pvx.ooadide.uesearch.SearchGotoAction
setEnableOptions() - Method in class com.sage.rcp.preferences.ProgramViewsPrefs
setErrorMessage(String) - Method in class com.pvx.ooadide.views.nomads.NewNomadsObjectDialog
Sets or clears the error message.
setFields(IPath, String) - Method in class com.pvx.ooadide.wizards.programs.PvxNewProgramPropertiesWizardPage
setFile(IFile) - Method in class com.pvx.ooadide.properties.ResourceToChangeEntity
setFileCreatePage(PvxWizardNewFileCreatePage) - Method in class com.pvx.ooadide.wizards.programs.PvxNewProgramPropertiesWizardPage
setFocus() - Method in class com.pvx.ooadide.editors.PvxEditor
setFocus() - Method in class com.pvx.ooadide.views.IOListView
setFocus() - Method in class com.pvx.ooadide.views.JavXBrowserView
Passing the focus request to the viewer's control.
setFocus() - Method in class com.pvx.ooadide.views.nomads.LibView
Passing the focus request to the viewer's control.
setFocus() - Method in class com.pvx.ooadide.views.PvcOutline
Passing the focus request to the viewer's control.
setFocus() - Method in class com.sage.rcp.views.HostActionsView
setFocus() - Method in class com.sage.rcp.views.RcpEmbedJavXView
setFPlugin(IPvxIdePlugin) - Method in class com.pvx.ooadide.editors.extkeyword.ExtKeywordCategoryEntity
setFunction(boolean) - Method in class com.pvx.ooadide.refactor.RenamePropertyInfo
setFxGlobal(String, double) - Static method in class com.sage.rcp.eventmanager.EventManager
This method sets the value of the specified global variable
setFxGlobal(String, String) - Static method in class com.sage.rcp.eventmanager.EventManager
This method sets the value of the specified global variable
setGradientEnd1(Color) - Method in class com.sage.rcp.resizeanimation.GradientPanel
setGradientEnd2(Color) - Method in class com.sage.rcp.resizeanimation.GradientPanel
setGradientStart1(Color) - Method in class com.sage.rcp.resizeanimation.GradientPanel
setGradientStart2(Color) - Method in class com.sage.rcp.resizeanimation.GradientPanel
setHandshakeComplete(boolean) - Method in class com.sage.rcp.javx.RcpPluginConnectionControl
setHelpListener(HelpListener) - Method in class com.pvx.ooadide.uesearch.SearchGotoAction
setHoverImageDescriptor(ImageDescriptor) - Method in class com.pvx.ooadide.uesearch.SearchGotoAction
setId(String) - Method in class com.pvx.ooadide.uesearch.SearchGotoAction
setIgnoreCancelBuild(boolean) - Static method in class com.pvx.ooadide.eventmanager.EventManager
setImageDescriptor(ImageDescriptor) - Method in class com.pvx.ooadide.uesearch.SearchGotoAction
setInitialInputLocationFieldValue(String) - Method in class com.pvx.ooadide.wizards.NewProjectFromExistingPage
setInitialProjectName(String) - Method in class com.pvx.ooadide.wizards.ProvidexNewWizardPage
Sets the initial project name that this page will use when created.
setInputLocationPathField(Text) - Method in class com.pvx.ooadide.wizards.NewProjectFromExistingPage
setJavXTabTitle(String) - Method in class com.sage.rcp.views.RcpEmbedJavXView
setJavXVisible(boolean) - Static method in class com.sage.rcp.views.HostActionsView
setLaunchConfigurationDialog(ILaunchConfigurationDialog) - Method in class com.pvx.ooadide.launchers.ProvideXArgumentsTab
setLaunchConfigurationDialog(ILaunchConfigurationDialog) - Method in class com.pvx.ooadide.launchers.thinclients.ClientTab
Sets the java project currently specified by the given launch config, if any.
setLib(String) - Static method in class com.pvx.ooadide.views.WinDefine
setLocation(int, int) - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
setLookAndFeel(String) - Method in class com.sage.rcp.javx.RcpPluginSwingGUIManager
setMenuCreator(IMenuCreator) - Method in class com.pvx.ooadide.uesearch.SearchGotoAction
setMonitor(IProgressMonitor) - Static method in class com.pvx.ooadide.eventmanager.EventManager
setNewName(String) - Method in class com.pvx.ooadide.properties.refactoring.core.ResourcePropertyInfo
setNewName(String) - Method in class com.pvx.ooadide.refactor.RenamePropertyInfo
setNewProjectPage(NewProjectFromExistingPage) - Method in class com.pvx.ooadide.wizards.NewFromExisting
setOffset(int) - Method in class com.pvx.ooadide.properties.refactoring.core.ResourcePropertyInfo
setOffset(int) - Method in class com.pvx.ooadide.refactor.RenamePropertyInfo
setOldName(String) - Method in class com.pvx.ooadide.properties.refactoring.core.ResourcePropertyInfo
setOldName(String) - Method in class com.pvx.ooadide.refactor.RenamePropertyInfo
setOutputFileName(String) - Method in class com.pvx.ooadide.wizards.programs.PvxNewProgramPropertiesWizardPage
setPageComplete() - Method in class com.pvx.ooadide.wizards.WizardPasswordPage
Check whether the internal state of the page is complete and update the dialog
setPageToAdd(String) - Method in class com.pvx.ooadide.preferences.UserPrefElement
setPanel(String) - Static method in class com.pvx.ooadide.views.WinDefine
setPassword(boolean) - Static method in class com.pvx.ooadide.builder.PvxPasswordInputDialogue
setProgressMonitor(IProgressMonitor) - Method in class com.pvx.ooadide.editors.codefolding.PvxReconcilingStrategy
setProject(IProject) - Method in class com.pvx.ooadide.builder.ProvideXNature
setProjectOwnerField(Text) - Method in class com.pvx.ooadide.wizards.NewProjectFromExistingPage
setProjectPath(String) - Static method in class com.pvx.ooadide.util.ProjectUtils
setPropertiesPage(PvxNewProgramPropertiesWizardPage) - Method in class com.pvx.ooadide.wizards.programs.PvxWizardNewFileCreatePage
setProperty(IResource, String, String) - Static method in class com.pvx.ooadide.eventmanager.ResourceManager
Sets the value of the persistent property of this resource identified by the given key.
setPropertyKey(String) - Method in class com.pvx.ooadide.properties.refactoring.core.ResourcePropertyInfo
setProposalVisible(boolean) - Method in class com.pvx.ooadide.editors.MyCompletionProcessor
setProvideXPlugin(boolean) - Static method in class com.sage.rcp.util.PvxRcpStateFlags
setPvxFileProperties(IResource) - Static method in class com.pvx.ooadide.builder.ProvideXBuilder
setPvxProgressMonitorDialogVisible(boolean) - Static method in class com.pvx.ooadide.views.UIManager
setPvxProgressMonitorDialogVisible(boolean) - Static method in class com.sage.rcp.eventmanager.UIManager
setPvxReady(boolean) - Static method in class com.pvx.ooadide.eventmanager.EventManager
Notify Eclipse that ProvideX is ready to receive events
setPvxReady(boolean) - Static method in class com.sage.rcp.eventmanager.EventManager
Notify Eclipse that ProvideX is ready to receive events
setReportVersionAs(String) - Static method in class com.sage.rcp.preferences.UiPrefManager
setResizeControlsEnabled(boolean) - Method in class com.sage.rcp.views.RcpEmbedJavXView
setResourcePath(String) - Method in class com.pvx.ooadide.builder.PvxProblem
setResourceProject(IProject) - Static method in class com.pvx.ooadide.eventmanager.EventManager
setRunnable(PvxRunnableWithProgress) - Method in class com.pvx.ooadide.views.MonitorState
setRunnable(PvxRunnableWithProgress) - Method in class com.sage.rcp.eventmanager.MonitorState
setRunningExecutable(String) - Static method in class com.pvx.ooadide.util.RunUtil
setRunningPvxExecutable(String) - Static method in class com.pvx.ooadide.eventmanager.EventManager
setScaleValue(int) - Method in class com.sage.rcp.views.RcpEmbedJavXView
setScrllHeight(boolean) - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
setScrllWidth(boolean) - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
setSelectedFrame(PvxBaseWindow) - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
setSizeAdjust(int) - Method in class com.sage.rcp.javx.windows.PluginTextPlaneView
setSizeAdjustStart() - Method in class com.sage.rcp.javx.windows.PluginTextPlaneView
setSizePercent(int) - Method in class com.sage.rcp.javx.windows.PluginTextPlaneView
setSourceFile(IFile) - Method in class com.pvx.ooadide.properties.refactoring.core.ResourcePropertyInfo
setSourceFile(IFile) - Method in class com.pvx.ooadide.refactor.RenamePropertyInfo
setSourceVersion(String) - Method in class com.pvx.ooadide.editors.autoindent.PvxPairMatcher
setSrcCode(String) - Method in class com.pvx.ooadide.builder.PvxProblem
setSrcFile(IFile) - Method in class com.pvx.ooadide.util.PvxElement
setStrikeThrough(String) - Method in class com.pvx.ooadide.preferences.EditorSyntaxColorPref
setString(String, String) - Static method in class com.pvx.ooadide.preferences.PreferenceManager
setSubjectObj(Object) - Method in class com.pvx.ooadide.eventmanager.DelayedMethodCall
setSubjectObj(Object) - Method in class com.sage.rcp.eventmanager.DelayedMethodCall
setTaskDetail(String) - Method in class com.pvx.ooadide.views.MonitorState
setTaskDetail(String) - Method in class com.sage.rcp.eventmanager.MonitorState
setTaskName(String) - Method in class com.pvx.ooadide.views.MonitorState
setTaskName(String) - Method in class com.sage.rcp.eventmanager.MonitorState
setTaskName(String) - Method in class com.sage.rcp.util.SwingProgressMonitorWrappper
setTempFile(String) - Method in class com.pvx.ooadide.properties.ResourceToChangeEntity
setText(String) - Method in class com.pvx.ooadide.uesearch.SearchGotoAction
setToolTipText(String) - Method in class com.pvx.ooadide.uesearch.SearchGotoAction
setType(int) - Method in class com.pvx.ooadide.util.PvxElement
setUnderLine(String) - Method in class com.pvx.ooadide.preferences.EditorSyntaxColorPref
setUpdateBundle(boolean) - Method in class com.pvx.ooadide.refactor.RenamePropertyInfo
setUseInputDefaults(boolean) - Method in class com.pvx.ooadide.wizards.ProvidexNewWizardPage
setUseOutputDefaults(boolean) - Method in class com.pvx.ooadide.wizards.ProvidexNewWizardPage
setUseOutputDefaults(boolean) - Method in interface com.pvx.ooadide.wizards.ProvideXNewWizardPageI
setUserElemnt(UserPrefElement) - Method in class com.pvx.ooadide.properties.userdefined.UserDefinedPropField
setValue(String) - Method in class com.pvx.ooadide.launchers.debug.model.PVXVariable
setValue(IValue) - Method in class com.pvx.ooadide.launchers.debug.model.PVXVariable
setView(RcpEmbedJavXView) - Method in class com.sage.rcp.javx.RcpSwtViewPanel
setViewSite(IViewSite) - Method in interface com.sage.rcp.javx.IEmbeddedJavXView
setViewSite(IViewSite) - Method in class com.sage.rcp.views.HostActionsView
setViewSite(IViewSite) - Method in class com.sage.rcp.views.RcpEmbedJavXView
setVisible(boolean) - Method in class com.pvx.ooadide.wizards.ProvidexNewWizardPage
setWidget(Widget) - Method in class com.pvx.ooadide.properties.userdefined.UserDefinedPropField
setWinCaption(String) - Method in class com.sage.rcp.javx.windows.PluginTextPlaneView
setWorked(int) - Method in class com.pvx.ooadide.views.MonitorState
setWorked(int) - Method in class com.sage.rcp.eventmanager.MonitorState
shouldAddToView() - Method in class com.sage.rcp.views.RcpEmbedJavXView
shouldIgnoreCancelBuild() - Static method in class com.pvx.ooadide.eventmanager.EventManager
showBorders() - Static method in class com.sage.rcp.preferences.UiPrefManager
showConfirmDialogue(String, String) - Static method in class com.pvx.ooadide.util.PvxUtil
showConfirmDialogue(String, String) - Static method in class com.sage.rcp.util.PvxUtil
showEditorInput(IEditorInput) - Method in class com.pvx.ooadide.editors.PvxEditor
showErrorDialogue(String, String) - Static method in class com.pvx.ooadide.util.PvxUtil
showErrorDialogue(String, String) - Static method in class com.sage.rcp.util.PvxUtil
showMessageDialogue(String, String) - Static method in class com.pvx.ooadide.util.PvxUtil
showMessageDialogue(String, String) - Static method in class com.sage.rcp.util.PvxUtil
showMessageOnStatusBar(String, IEditorPart) - Static method in class com.pvx.ooadide.util.PvxUtil
showMessageOnStatusBar(String, IEditorPart) - Static method in class com.sage.rcp.util.PvxUtil
showMessageOnStatusBar(String, IViewPart) - Static method in class com.pvx.ooadide.util.PvxUtil
showMessageOnStatusBar(String, IViewPart) - Static method in class com.sage.rcp.util.PvxUtil
showNagMessage() - Static method in class com.sage.rcp.javx.PvxHostLauncher
showPossibleCompletions() - Method in class com.pvx.ooadide.codehilite2.PvxContentAssistant
showProgress(String, String, int) - Method in class com.sage.rcp.util.ProgressIndicator
showProgressIndicator(TextPlaneModel, TextPlaneView, boolean) - Method in class com.sage.rcp.javx.RcpPluginSwingGUIManager
showPvxPrefPage() - Static method in class com.pvx.ooadide.util.PvxUtil
showView(String) - Static method in class com.pvx.ooadide.views.UIManager
Shows the view identified by the given view id in this Eclipse page and gives it focus.
showView(String) - Static method in class com.sage.rcp.eventmanager.UIManager
Shows the view identified by the given view id in this Eclipse page and gives it focus.
showView(String) - Static method in class com.sage.rcp.util.PvxUtil
showWarningDialogue(String, String) - Static method in class com.pvx.ooadide.util.PvxUtil
shutDownHost() - Static method in class com.pvx.ooadide.eventmanager.EventManager
SingleWinViewGuiMngr - Class in com.sage.rcp.javx
SingleWinViewGuiMngr(IEmbeddedJavXView, PvxHost) - Constructor for class com.sage.rcp.javx.SingleWinViewGuiMngr
SIX_D - Static variable in class com.sage.rcp.preferences.UiPrefManager
SizeAnimationGlassPane - Class in com.sage.rcp.resizeanimation
SizeAnimationGlassPane() - Constructor for class com.sage.rcp.resizeanimation.SizeAnimationGlassPane
SizeAnimationGlassPane(Color) - Constructor for class com.sage.rcp.resizeanimation.SizeAnimationGlassPane
SortListener - Class in com.pvx.ooadide.views.comparators
SortListener(TableViewer) - Constructor for class com.pvx.ooadide.views.comparators.SortListener
SortListener(TableViewer, boolean) - Constructor for class com.pvx.ooadide.views.comparators.SortListener
sortUsingComparator(Comparator) - Method in class com.pvx.ooadide.views.PvxViewSorter
SpacerFieldEditor - Class in com.pvx.ooadide.preferences
A field editor for adding space to a preference page.
SpacerFieldEditor(Composite) - Constructor for class com.pvx.ooadide.preferences.SpacerFieldEditor
spawn(String) - Static method in class com.sage.rcp.javx.SpawnUtil
spawnClient(int, Vector) - Method in class com.sage.rcp.javx.RcpPluginConnectionControl
SpawnUtil - Class in com.sage.rcp.javx
SpawnUtil() - Constructor for class com.sage.rcp.javx.SpawnUtil
start - Variable in class com.sage.rcp.javx.RcpPluginJavXApplet
start() - Static method in class com.pvx.ooadide.util.StopWatch
start() - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
start(BundleContext) - Method in class com.sage.rcp.PvxRcpActivator
startDebugSession(Socket, Socket) - Method in class com.pvx.ooadide.launchers.debug.model.PVXDebugTarget
startItUp() - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
startItUp(AbstractGUIManagerFactory) - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
startJavX(int) - Static method in class com.sage.rcp.views.HostActionsView
statusBar - Variable in class com.sage.rcp.javx.RcpPluginJavXApplet
stepInto() - Method in class com.pvx.ooadide.launchers.debug.model.PVXStackFrame
stepInto() - Method in class com.pvx.ooadide.launchers.debug.model.PVXThread
stepOver() - Method in class com.pvx.ooadide.launchers.debug.model.PVXStackFrame
stepOver() - Method in class com.pvx.ooadide.launchers.debug.model.PVXThread
stepReturn() - Method in class com.pvx.ooadide.launchers.debug.model.PVXStackFrame
stepReturn() - Method in class com.pvx.ooadide.launchers.debug.model.PVXThread
stop() - Static method in class com.pvx.ooadide.util.StopWatch
stop(BundleContext) - Method in class com.pvx.ooadide.ProvideXOOADPlugin
stop(BundleContext) - Method in class com.sage.rcp.PvxRcpActivator
StopWatch - Class in com.pvx.ooadide.util
StopWatch() - Constructor for class com.pvx.ooadide.util.StopWatch
STRING - Static variable in class com.pvx.ooadide.util.PvxUtil
STRING_DATA - Static variable in class com.pvx.ooadide.util.PvxUtil
STRIP_LINE_NO - Static variable in class com.pvx.ooadide.eventmanager.EventManager
STRIPPER_PROGRAM - Static variable in class com.pvx.ooadide.util.RunUtil
STYLE_BOLD - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
STYLE_ITALIC - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
STYLE_NONE - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
STYLELOG_NAME - Static variable in class com.pvx.ooadide.builder.ProvideXBuilder
StyleWarning - Class in com.pvx.ooadide.builder
StyleWarning(String, String, String, IFile, String, int, String) - Constructor for class com.pvx.ooadide.builder.StyleWarning
supportsBreakpoint(IBreakpoint) - Method in class com.pvx.ooadide.launchers.debug.model.PVXDebugTarget
supportsStorageRetrieval() - Method in class com.pvx.ooadide.launchers.debug.model.PVXDebugTarget
supportsValueModification() - Method in class com.pvx.ooadide.launchers.debug.model.PVXVariable
suspend() - Method in class com.pvx.ooadide.launchers.debug.model.PVXDebugTarget
suspend() - Method in class com.pvx.ooadide.launchers.debug.model.PVXStackFrame
suspend() - Method in class com.pvx.ooadide.launchers.debug.model.PVXThread
suspendedBy(IBreakpoint) - Method in class com.pvx.ooadide.launchers.debug.model.PVXThread
Notifies this thread it has been suspended by the given breakpoint.
SwingProgressMonitorWrappper - Class in com.sage.rcp.util
SwingProgressMonitorWrappper(PvxBaseWindow) - Constructor for class com.sage.rcp.util.SwingProgressMonitorWrappper
syncFolders(IResource, IResource) - Static method in class com.pvx.ooadide.util.PvxUtil
syncInOutPutFolder(IContainer, IProject) - Static method in class com.pvx.ooadide.builder.ProvideXBuilder
sysFuncPropl - Static variable in class com.pvx.ooadide.editors.MyCompletionProcessor
SYSFUNCTION_PROPERTIES_FILE - Static variable in class com.pvx.ooadide.editors.MyCompletionProcessor
sysfunctions - Static variable in class com.pvx.ooadide.editors.MyCompletionProcessor
sysvariables - Static variable in class com.pvx.ooadide.editors.MyCompletionProcessor
SYSVARIABLES_PROPERTIES_FILE - Static variable in class com.pvx.ooadide.editors.MyCompletionProcessor
sysVarPropl - Static variable in class com.pvx.ooadide.editors.MyCompletionProcessor
A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form


T-Index

Index

A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form

T

TAG_FLAGS - Static variable in class com.pvx.ooadide.properties.refactoring.tagresolver.PvxtagResolver
TAG_FORCELINE_NO - Static variable in class com.pvx.ooadide.properties.refactoring.tagresolver.PvxtagResolver
TAG_OUTPUT - Static variable in class com.pvx.ooadide.properties.refactoring.tagresolver.PvxtagResolver
TAG_OWNER - Static variable in class com.pvx.ooadide.properties.refactoring.tagresolver.PvxtagResolver
TAG_PASSWORD - Static variable in class com.pvx.ooadide.properties.refactoring.tagresolver.PvxtagResolver
takeSnapShot() - Method in class com.pvx.ooadide.eventmanager.EditorManager
TemplateEditorUI - Class in com.pvx.ooadide.editors.templates
The main plugin class to be used in the desktop.
TemplateMessages - Class in com.pvx.ooadide.editors.templates
TemplatesPreferencePage - Class in com.pvx.ooadide.editors.templates
TemplatesPreferencePage() - Constructor for class com.pvx.ooadide.editors.templates.TemplatesPreferencePage
terminate() - Method in class com.pvx.ooadide.launchers.debug.model.PVXDebugTarget
terminate() - Method in class com.pvx.ooadide.launchers.debug.model.PVXStackFrame
terminate() - Method in class com.pvx.ooadide.launchers.debug.model.PVXThread
terminated() - Method in class com.pvx.ooadide.eventmanager.PvxRequestManager
terminatedConnectionAnimation() - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
terminatePvxBuilds() - Static method in class com.pvx.ooadide.builder.ProvideXBuilder
TextHover - Class in com.pvx.ooadide.editors
TextHover(ISourceViewer, String) - Constructor for class com.pvx.ooadide.editors.TextHover
TextHover(ISourceViewer, String, int) - Constructor for class com.pvx.ooadide.editors.TextHover
thisInitializer - Static variable in class com.pvx.ooadide.preferences.PreferenceInitializer
THREE_D - Static variable in class com.sage.rcp.preferences.UiPrefManager
title - Variable in class com.pvx.ooadide.util.PvxUtil.ConfirmDialShower
title - Variable in class com.sage.rcp.util.PvxUtil.ConfirmDialShower
toFront() - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
ToggleBreakpointAction - Class in com.pvx.ooadide.launchers.debug
Action to toggle a breakpoint
ToggleBreakpointAction(ITextEditor, IVerticalRulerInfo) - Constructor for class com.pvx.ooadide.launchers.debug.ToggleBreakpointAction
Constructs a new action to toggle a PDA breakpoint
toggleLineBreakpoints(IWorkbenchPart, ISelection) - Method in class com.pvx.ooadide.launchers.debug.model.PvxLineBreakpointAdapter
ToggleNatureAction - Class in com.pvx.ooadide.builder
ToggleNatureAction() - Constructor for class com.pvx.ooadide.builder.ToggleNatureAction
ToolsEditorAction - Class in com.pvx.ooadide.actions
ToolsEditorAction() - Constructor for class com.pvx.ooadide.actions.ToolsEditorAction
toStandardOut(String) - Static method in class com.pvx.ooadide.util.PvxUtil
toString() - Method in class com.pvx.ooadide.editors.PvxCompletionProposal
toString() - Method in class com.pvx.ooadide.eventmanager.PvxEvent
toString() - Method in class com.pvx.ooadide.util.PvxElement
toString() - Method in class com.pvx.ooadide.views.nomads.PvxLibElement
toString() - Method in class com.sage.rcp.eventmanager.PvxEvent
TRACE_TO_ERRORLOG - Static variable in class com.pvx.ooadide.util.PvxUtil
TRACE_TO_STANDARDOUT - Static variable in class com.pvx.ooadide.util.PvxUtil
traceEvent(String, String, Properties) - Static method in class com.pvx.ooadide.util.PvxUtil
translatePath(String) - Static method in class com.pvx.ooadide.builder.ProvideXBuilder
TYPE_BLOCK_REM - Static variable in class com.pvx.ooadide.refactor.RenamePropertyInfo
TYPE_NUMERIC - Static variable in class com.pvx.ooadide.launchers.debug.model.PVXVariable
TYPE_PROPERTY_RENAME - Static variable in class com.pvx.ooadide.refactor.RenamePropertyInfo
TYPE_REPLACE - Static variable in class com.pvx.ooadide.refactor.RenamePropertyInfo
TYPE_STRING - Static variable in class com.pvx.ooadide.launchers.debug.model.PVXVariable
TYPE_STRIP_NUMBERS - Static variable in class com.pvx.ooadide.refactor.RenamePropertyInfo
A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form


U-Index

Index

A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form

U

U_NOMADS_ALTEXE - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
U_NOMADS_ALTINI - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
U_NOMADS_EXTIMAGEDIR - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
UE_SearchAction - Class in com.pvx.ooadide.uesearch
UE_SearchAction() - Constructor for class com.pvx.ooadide.uesearch.UE_SearchAction
UIManager - Class in com.pvx.ooadide.views
Provides an Interface to the Eclipse GUI for ProvideX programs
UIManager - Class in com.sage.rcp.eventmanager
Provides an Interface to the Eclipse GUI for ProvideX programs
UIManager() - Constructor for class com.pvx.ooadide.views.UIManager
UIManager() - Constructor for class com.sage.rcp.eventmanager.UIManager
UiPrefManager - Class in com.sage.rcp.preferences
UiPrefManager() - Constructor for class com.sage.rcp.preferences.UiPrefManager
UITexts - Class in com.pvx.ooadide.properties.refactoring.ui
provides internationalized String messages for the UI.
UITexts - Class in com.pvx.ooadide.refactor
provides internationalized String messages for the UI.
UITexts() - Constructor for class com.pvx.ooadide.properties.refactoring.ui.UITexts
UITexts() - Constructor for class com.pvx.ooadide.refactor.UITexts
ULTRAFX_WINDOW_CLOSE - Static variable in class com.sage.rcp.eventmanager.EventManager
updateBoarderSize(int, int) - Method in class com.sage.rcp.resizeanimation.SizeAnimationGlassPane
updateDomList(boolean, IFile) - Method in class com.pvx.ooadide.views.PvcOutline
updateFoldingStructure(ArrayList<Position>) - Method in class com.pvx.ooadide.editors.PvxEditor
Checks whether the given positions are in the ProjectionAnnotationModel or in the addition set.
updatePresentation(int, TextPresentation) - Method in class com.pvx.ooadide.editors.PvxParameterListValidator
updatePresentation(Display, String, TextPresentation, int, int) - Method in class com.pvx.ooadide.codehilite2.PvxInfoPresenter
updateProgress(int) - Method in class com.sage.rcp.util.ProgressIndicator
updateProgressIndcator(String, int) - Method in class com.sage.rcp.javx.RcpPluginSwingGUIManager
useDefaults() - Method in class com.pvx.ooadide.wizards.ProvidexNewWizardPage
Returns the useDefaults.
useOutputDefaults - Variable in class com.pvx.ooadide.wizards.NewProjectFromExistingPage
UserDefinedPrefPage - Class in com.pvx.ooadide.preferences
UserDefinedPrefPage() - Constructor for class com.pvx.ooadide.preferences.UserDefinedPrefPage
UserDefinedPropField - Class in com.pvx.ooadide.properties.userdefined
UserDefinedPropField(UserPrefElement, Widget) - Constructor for class com.pvx.ooadide.properties.userdefined.UserDefinedPropField
UserDefinedSortedField - Class in com.pvx.ooadide.preferences
UserDefinedSortedField(String, UserPrefElement) - Constructor for class com.pvx.ooadide.preferences.UserDefinedSortedField
UserPrefElement - Class in com.pvx.ooadide.preferences
UserPrefElement(String, int, String, String, String, String, String) - Constructor for class com.pvx.ooadide.preferences.UserPrefElement
UserPrefElement(String, int, String, String, String, String, String, int) - Constructor for class com.pvx.ooadide.preferences.UserPrefElement
UtilCommands - Class in com.pvx.ooadide.util
UtilCommands() - Constructor for class com.pvx.ooadide.util.UtilCommands
A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form


V-Index

Index

A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form

V

VALID - Static variable in class com.pvx.ooadide.eventmanager.EventManager
VALIDATE - Static variable in class com.pvx.ooadide.eventmanager.EventManager
validateExecutable(String) - Static method in class com.pvx.ooadide.util.RunUtil
validExecutables - Static variable in class com.pvx.ooadide.util.PvxUtil
valueOf(String) - Static method in enum com.pvx.ooadide.views.PvcOutline.OutlineFilter
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum com.pvx.ooadide.views.PvcOutline.OutlineSortBy
Returns the enum constant of this type with the specified name.
values() - Static method in enum com.pvx.ooadide.views.PvcOutline.OutlineFilter
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum com.pvx.ooadide.views.PvcOutline.OutlineSortBy
Returns an array containing the constants of this enum type, in the order they are declared.
VARIABLE_FILTER - Enum constant in enum com.pvx.ooadide.views.PvcOutline.OutlineFilter
VARIABLE_TYPE - Static variable in class com.pvx.ooadide.util.PvxElement
VARIABLE_TYPE_SYMBOL - Static variable in class com.pvx.ooadide.util.PvxElement
verifyPvxExe(String, String) - Static method in class com.pvx.ooadide.util.RunUtil
verifyValue(String) - Method in class com.pvx.ooadide.launchers.debug.model.PVXVariable
verifyValue(IValue) - Method in class com.pvx.ooadide.launchers.debug.model.PVXVariable
VersionControlIdPropertyResolver - Class in com.pvx.ooadide.editors.templates
VersionControlIdPropertyResolver() - Constructor for class com.pvx.ooadide.editors.templates.VersionControlIdPropertyResolver
ViewContentProvider() - Constructor for class com.pvx.ooadide.views.nomads.LibView.ViewContentProvider
ViewLabelProvider() - Constructor for class com.pvx.ooadide.views.nomads.LibView.ViewLabelProvider
viewSite - Variable in class com.sage.rcp.views.RcpEmbedJavXView
visit(int, String, String, boolean) - Method in class com.pvx.ooadide.preferences.AbstractProvideXFieldEditorPrefPage
visit(int, String, String, boolean) - Method in interface com.pvx.ooadide.preferences.PvxPrefVisitee
A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form


W-Index

Index

A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form

W

WarningResolutionGenerator - Class in com.pvx.ooadide.builder
WarningResolutionGenerator() - Constructor for class com.pvx.ooadide.builder.WarningResolutionGenerator
WHITE - Static variable in class com.pvx.ooadide.preferences.PreferenceInitializer
width - Static variable in class com.sage.rcp.views.RcpEmbedJavXView
WinDefine - Class in com.pvx.ooadide.views
WinDefine() - Constructor for class com.pvx.ooadide.views.WinDefine
WINDEFINE_PROGRAM - Static variable in class com.pvx.ooadide.views.nomads.LibView
windowActivated(WindowEvent) - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
windowBorders - Static variable in class com.sage.rcp.javx.windows.PluginTextPlaneView
windowClosed(WindowEvent) - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
windowClosing(WindowEvent) - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
windowDeactivated(WindowEvent) - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
windowDeiconified(WindowEvent) - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
windowIconified(WindowEvent) - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
windowOpened(WindowEvent) - Method in class com.sage.rcp.javx.RcpPluginJavXApplet
windowResized(PvxWindow) - Method in class com.sage.rcp.javx.RcpPluginSwingGUIManager
WindowStateBlock - Class in com.pvx.ooadide.launchers
WindowStateBlock() - Constructor for class com.pvx.ooadide.launchers.WindowStateBlock
WindXLaunchConfigurationDelegate1 - Class in com.pvx.ooadide.launchers.thinclients
WindXLaunchConfigurationDelegate1() - Constructor for class com.pvx.ooadide.launchers.thinclients.WindXLaunchConfigurationDelegate1
WindXLaunchConfigurationTabGroup - Class in com.pvx.ooadide.launchers.thinclients
WindXLaunchConfigurationTabGroup() - Constructor for class com.pvx.ooadide.launchers.thinclients.WindXLaunchConfigurationTabGroup
WINTEST_PROGRAM - Static variable in class com.pvx.ooadide.views.nomads.LibView
WizardNewProjectPasswordPage - Class in com.pvx.ooadide.wizards
WizardNewProjectPasswordPage(ISelection) - Constructor for class com.pvx.ooadide.wizards.WizardNewProjectPasswordPage
WizardPasswordImportPage1 - Class in com.pvx.ooadide.wizards
Page 1 of the base preference import Wizard
WizardPasswordImportPage1() - Constructor for class com.pvx.ooadide.wizards.WizardPasswordImportPage1
Create an instance of this class
WizardPasswordPage - Class in com.pvx.ooadide.wizards
Base class for preference export/import pages.
worked(int) - Method in class com.sage.rcp.util.SwingProgressMonitorWrappper
writeToConsole(String) - Static method in class com.pvx.ooadide.util.PvxUtil
writeToConsole(String) - Static method in class com.sage.rcp.util.PvxUtil
A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form


X-Index

Index

A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form

X

XEditorMatchingStrategy - Class in com.pvx.ooadide.editors
XEditorMatchingStrategy() - Constructor for class com.pvx.ooadide.editors.XEditorMatchingStrategy
XMLConfiguration2 - Class in com.pvx.ooadide.codehilite2
XMLConfiguration2(ColorManager, PvxEditor) - Constructor for class com.pvx.ooadide.codehilite2.XMLConfiguration2
XMLDoubleClickStrategy - Class in com.pvx.ooadide.codehilite2
XMLDoubleClickStrategy() - Constructor for class com.pvx.ooadide.codehilite2.XMLDoubleClickStrategy
A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form


Z-Index

Index

A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form

Z

zoomFrm(short) - Method in class com.sage.rcp.javx.windows.PluginTextPlaneView
A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form


_-Index

Index

A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form

_

_BACKCOLOR - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
_BOLD - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
_COLOR - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
_IS_SET - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
_ITALIC - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
_STRIKETHROUGH - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
_UNDERLINE - Static variable in class com.pvx.ooadide.preferences.PreferenceConstants
A B C D E F G H I J K L M N O P Q R S T U V W X Z _
All Classes and Interfaces | All Packages | Constant Field Values | Serialized Form


ProvideX Plug-in for Eclipse - Features

This document contains information on some of the key features of the ProvideX Plug-in for Eclipse.It is broken down into the following topics:

  • Overview
  • Preferences
  • Editor
  • Builder
  • Launchers
  • Wizards
  • NOMADS Integration
  • Contributed Tools


ProvideX Plug-in for Eclipse - Editor

This document describes the capabilities of the ProvideX Editor for the ProvideX Plug-in for Eclipse. For information on Eclipse features please see:

  • Workbench User Guide > What's new
  • Workbench User Guide > Concepts > Features

The discussion is organized into the following topics:

  • Builder
  • Contributed Extensions / Tools
  • Editor
  • Import /Convert
  • NOMADS
  • Plug-in Debug
  • Program Views

Features
Builder
  1. Build Preferences

    First feature...

    a description
  2. Options

    Second feature...

    a description


Reference Material

Contents

  • API Documentation
  • Sage Plug-in Documentation
  • Readme File


Plug-in Documentation

Contents
Tutorial
 Tutorial
 Preparing the Workbench
Creating a ProvideX Project
Browsing a ProvideX Project
Editing ProvideX Elements
 Editing ProvideX Elements
 Opening a ProvideX Editor
Content Assist
Identifying Problems in Your Code
Using the Local History
 Building ProvideX Projects
 Building ProvideX Projects
 General Build Concepts
Building the DemoApp Project
Resources and ProvideX Source Code
 Running ProvideX Programs
 Running ProvideX Programs
 Running a Console
Launching a Program
Launching a Program in WindX
Launching a Program in JavX
 Testing a ProvideX Application
 Testing a ProvideX Application
 Simple Application
Complex Application
 User Guide
 User Guide
 Overview
 Overview
 Overview of ProvideX Plug-in
Configure the Plug-in
Views and Perspectives
Link to Application Folder(s)
ProvideX Project
ProvideX Editor
User Keyword Categories
Project-Specific Properties
 Project-Specific Properties
 Properties for Project
Property Files
 Preference Pages
 Preference Pages
 ProvideX Event Manager
Appearance
Builder
Builder - Options
Contributed Extensions / Tools
Editor
Editor - Options
Editor - Templates
Import / Convert
NOMADS
Plug-in Debug
 Builder
 Builder
 The Build Process
C-Style Block Comments
Include Files
Document Tags
Output Folder Properties
 NOMADS Integration
 NOMADS Integration
 Overview
NOMADS View
 Built-in Contributed Tools
 Built-in Contributed Tools
 Dictionary Viewer
Inheritance Analysis
Message Library Viewer
ProvideX Class Documentation
 ProvideX Class Documentation
 Overview
Configuration
Write Documentation
Sample Source
Generate Documentation
 Style Check
Super Search
Tag Substitution
Other Contributed Tools
 How to Extend the Plug-in
 How to Extend the Plug-in
 Overview
 Overview
 Introduction
Design Patterns
Plug-in Events
 Observers
 Observers
 What is an Observer?
Built-in Observers
Additional Examples
What can be added?
 Add to Existing Event
 Add to Existing Event
 What is an enhancement?
Observer Class Template
Build Program: Pre/Post Process
Build Program: Post-process
Event Observer and Contributed Tool
Event Arguments
 Writing Contributed Tools
 Writing Contributed Tools
 What is a contributed tool?
Contributed Tool Class Template
Example 1: No Configuration
Example 2: Progress Log
Example 3: Style Check
Example 4: With Configuration
Example 5: Action on Build Files
Example 6: Configuration and Progress
 What's New


Inheritance Analysis

info This is an early access release and the features in the final version will change. The current feature set is useful for developers to identify potential issues with inheritance in new and existing classes.

What is it?

This tool will scan the inheritance chain of the selected class in in the project explorer view. The scan will only include classes in the same project; any other class files will be skipped.

Analyze Class

It will start analyzing the inheritance tree for the class to create a list of Functions (public/private) and Properties (public/private).

Search Results

The search can be used to make sure a property or function is not replicated accidentally in the scope of the object, or to even just find which class it is defined.

Next Section: Message Library Viewer


Tag Substitution

  • What is it?
  • Configuration
    • Tag Substitution Configuration
    • Built-in Keyword/Substitution Values
    • Built-in Keyword/Substitution Values - Git

What is it?

The Tag Substitution contributed tool provides a mechanism for defining a keyword and substitution value to be applied to the source code of a program during the build process.

The original source file will not change when a substitution occurs; only the compiled program.

Configuration

The keyword/substitution values are defined in a properties file named tagSubstitution.properties that is built-in to the plug-in. A secondary properties file in the Directory for Keyword Categories and Observers can be defined for additional keyword/substitution values or to override the existing values.

Tag Substitution Configuration

The built-in tag substitution includes configuration options to check for a '.git' folder in the project root or workspace root to trigger loading the addition rules for Git. These options can overridden in the user-define properties file.

# Configuration settings (start with a colon)
# ----------------------------------------------------------------------------
:GitCheck_ProjectRoot = 1
:GitCheck_WorkspaceRoot = 1

Built-in Keyword/Substitution Values

# Substitution Settings
# ----------------------------------------------------------------------------
Copyright = "(c) " + dte(0:"%Yl") +" The Sage Group plc or its licensors. All rights reserved."
#

Built-in Keyword/Substitution Values - Git

A second properties file is used to define keyword/substitution values that are specific to projects from a Git repository. The built-in version of this file has keyword/substitution values to handle the Subversion keywords.

# Substitution Settings
# ----------------------------------------------------------------------------
Header = "$Id: " + cOutputFilename$ + " " + cSourceLastModTimestamp$ + " $"
Id = "$Id: " + cOutputFilename$ + " " + cSourceLastModTimestamp$ + " $"
Revision = "$Revision: " + cSourceLastModDate$ + " $"
#

Next Section: Other Contributed Tools


Other Contributed Tools

  • Build Process
  • Contributed Tools List

Build Process

Many contributed tools are triggered during the pre/post process of the build of source files in the project and can affect the format or content of the compiled program or file.

Convert ProvideX Keyed Files to/from XML

This tool is triggered during the Build Post-Process.

It will convert a ProvideX keyed file to/from XML. This can be useful when it is necessary to track changes to data files in projects are part of a version control process.

Substitute modification year of source file for 'Copyright-year' tag

This tool is triggered during both the Build PreProcess and the Build PostProcess.

In the Build PreProcess the tool will replace the %(copyright-year)% tag within the first 1000 characters of the source file with the current date. If changes are made to the source file, the new source is written to a temporary file and this file is set as the source file for the remainder of the build process.

In the Build PostProcess the tool will write a message to the console log to tell the user whether the file was changed.

Set modification timestamp of output file to be the same as source file

This tool is triggered as part of the Build Post-Process.

In the Build PostProcess the tool will set the modification date of the output file to be the same as the source file.

Automatic keyword conversion in build process

This tool is triggered during both the Build PreProcess and the Build PostProcess.

In the Build PreProcess the tool will convert the ProvideX keywords in source file based on the settings on the Editor Options preference page. The new source is written to a temporary file and this file is set as the source file for the remainder of the build process.

In the Build PostProcess the tool will write a message to the console log to tell the user the conversion has completed.

Strip Trailing Whitespace

This tool is triggered during both the Build PreProcess and the Build PostProcess.

In the Build PreProcess the tool will strip trailing white space (tabs and spaces) from all lines of the source file. If changes are made to the source file, the new source is written to a temporary file and this file is set as the source file for the remainder of the build process.

In the Build PostProcess the tool will write a message to the console log to tell the user whether the file was changed.

Contributed Tools List

Tools - Encrypt Password

This tool is used to encrypt a simple text pass phrase that can be copied an set as the password for a source file.

Tool - Encrypt Password

This values is entered into the password field on the properties pagae for the source file. This will password protect the programs without making the password publicly visible.

Convert ProvideX Keyed Files to/from XML

It will convert a ProvideX keyed file to/from XML. This can be useful when it is necessary to track changes to data files in projects are part of a version control process.

Create ProvideX Data File Information

This tool will create the information for the Outline view for all files selected in the Project Explorer.

Shutdown ProvideX EventManager

This tool will trigger the shutdown of the ProvideX Event Manager process. The ProvideX Event Manager will automatically restart when a new action is requested from Eclipse.

Next Section: Extending the Plug-in: Introduction


Sample Source - Simple Class

Lists - Ordered and Unordered

The following block of source code shows how to include create ordered and unordered lists.

Source Code from Class

/*
 * Build information:
! ** @Author Fred McGuirk

! ** Sample class to show how to perform an action for each file updated by the
! ** build process.
! **
! ** This class will be registered as a PostProcess observer and will monitor the
! ** following events:
! ** @OList
! ** Full Build Start
! ** Incremental build for a single file
! ** Full Build End
! ** @OLIst_End
! ** These events are triggered when:
! ** @UList
! ** A file is saved in the editor
! ** The build action is selected from the pop-up menu in the editor
! ** The build action is selected against one or more selected files in the Navigator View
! ** @UList_End
 */
DEF CLASS "execModifiedFiles"

Generated HTML Documentation

Documentation with Ordered and Unordered lists.


Sample Source - Simple Class

ProvideX Code Sample - Block of Code

The following block of source code shows how to include a block of ProvideX code.

Source Code from Class

! ** It is also possible to process all of the properties in a file using the built-in iterator
! ** as the following example demonstrates:%PvxCodeBegin%
! ** coPropFile = new("properties_file", aPropFile$)
! ** coPropFile'iterator_init()
! ** WHILE coPropFile'iterator_has_next()
! **     oNVPair = coPropFile'iterator_get_next()
! **     IF oNVPair <> -1 {
! **         ! Get the Name and Value from the 'name_value_pair' object
! **         tagKeyword$ = oNVPair'getName$()
! **         tagValue$   = oNVPair'getValue$()
! **           ...
! **     }
! ** WEND
! ** %PvxCodeEnd%
! **
! ** @Constructor Manage a properties file in memory.
! ** @param aFile$ (optional) The name of the INI or Properties file to be loaded into memory
DEF CLASS "properties_file" create required

Generated HTML Documentation

Documentation with example of ProvideX code in paragraph rather than separate line.


Sample Source - Simple Class

ProvideX Code Sample - Embedded in Paragraph

The following block of source code shows how to include a ProvideX code sample embedded in paragraph instead of in a separate line.

Source Code from Class

    ! ** the value %PvxCode2(mid(pgn, 1, pos(dlm=pgn, -1)) + _obj'_Class$ + "_rules.txt")% is used ...
    local styleRulesFile$=mid(pgn,1,pos(dlm=pgn,-1))+_obj'_Class$+"_rules.txt"
    ! ** Override Description
    local theDescription$="Simple rule-based Style Check"

Generated HTML Documentation

Documentation with example of ProvideX code in paragraph rather than separate line.


Sample Source - Simple Class

ProvideX Code Sample - Single Line

The following block of source code shows how to include a single line ProvideX code sample in the class documentation.

Source Code from Class

! ** @note The sub-class initialization method must set the following variables
! ** @note which will be used to identify the panel.
! ** @note %PvxCode(theCaption$, theDescription$)%

! ** @note The sub-class initialization method can also enable the 'CANCEL'
! ** @note button on the "Progress Log" panel by calling the method:
! ** @note %PvxCode(_obj'enable_cancel())%

Generated HTML Documentation

Documentation with example of single line ProvideX code sample.


Sample Source - Simple Class

Simple Class

Include additional comments in the class definition to document each of the properties and methods for a class. The PvxDocs tool will read these comments and use them to create a HTML file documenting the class.

Source Code from Class

/*
! ** The is a simple class to read the contents of a file and will also handle
! ** any '#include' references found in the file.

! ** @Constructor Open the specified file for reading and start a counter to
! ** keep track of the number of INLCUDE files that are referenced.  The
! ** %PvxClass(path_resolver)% object will be used to expand the name of each
! ** INCLUDE file.
! ** @param inFile$ The name of file to read
! ** @param inPathResolver A reference to an instance of a %PvxClass(path_resolver)% class
! ** @param + used to expand the name of include files.
 */
def class "file_reader"
    ! ** @TYPE Reference to %PvxClass(obj_tracker)%
    property aTracker

    ! ** Get the end of file status
    ! ** @returns A boolean that is set to TRUE (1) when end of data stream has been reached.
    function getEOF()                                getEOF

    ! ** Read a line of text from the file.
    ! ** @Returns A string containing the text that was retrieved
    function read$()                                readLine

    ! ** Set a flag to disable processing of '#include' references
    ! ** @param inBoolean  (0=False, 1=True)
    function setIgnoreIncludes(inBoolean)            setIgnoreIncludes

    ! ** Get the next line from the text file; strip any $0D$ from line
    function local readRecord(aRec$)                getLine
end def

Generated HTML Documentation

Collection Class documentation


Sample Source - Simple Class

Function Declaration With Table of Codes

The following block of source code shows how to include a table of codes / descriptions as part of the documentation for a function. This is useful for documenting fixed codes with descriptions associated with parameters or returned values for a function.

This block of sample code also shows how overloaded functions can be documented with duplicating information in the source file.

function ReqClient   (dest$, value$)                        Request_Client

function ReqClient   (dest$, value$, path$)                 Request_Client

! ** Send information to Eclipse workbench
! ** @param dest$ Delivery destination for information - value must be "C"
! ** @param value$ Message to write to the console view
! ** @param path$ (Optional) Path to resource referenced by action
! ** @param overwrite (Optional) Overwrite existing value in Bookmark or Problem View (0 = False, 1 = True)
! ** @value heading=Destination Codes
! ** @value B Create a bookmark for resource in the bookmark view
! ** @value C Write a message to the console view
! ** @value P write an entry for resource to the Problem view
! ** @value S write an entry for resource to 'Classic Search' view
function ReqClient   (dest$, value$, path$, overwrite)      Request_Client

Generated HTML Documentation

Collection Class documentation


Design Patterns

A well-designed application should meet its requirements. It should also be adaptable so that when the real-world requirements change, it can also be changed with minimal effort.

Introduction to Object-Oriented Analysis & Design

The following was taken from "Introduction to Object-Oriented Analysis & Design" available for download from the ProvideX web site.

In 1994, four computer scientists (Erich Gamma, Richard Helm, Ralph Johnson, and John Vlissides) authored a ground-breaking book entitled "Design Patterns: Elements of Reusable Object-Oriented Software". In this book, the authors (aka "the Gang of Four" or "GoF") assert that all of the design problems a software engineer faces have been identified and solved. The GoF identify twenty three different patterns, which can be divided into three groups:

  • Creational Patterns for object creation
  • Structural Patterns for the structure and composition of classes
  • Behavioral Patterns for the interactions between classes

Essentially, design patterns are recurring design solutions that may be applied to specific problems. A typical design pattern involves three or more classes. Some patterns are simple and obvious, some are complex and elegant.

Patterns can help software engineers resolve common software problems in a tried-and-true way. A development team that has adapted patterns can easily communicate the intention of their code - it becomes somewhat self-explanatory.

For example, when a developer who is familiar with design patterns encounters an Observer (behavioral pattern) in a program, he or she will not have to wade through the code to determine what it does. The pattern is often easily identified by the naming conventions used in the code, as well as by the intent of the pattern and by the way it works as a known commodity.

Don't confuse design patterns with algorithms or language idioms. A design pattern is a solution that can be applied to a design problem in any object-oriented language. In fact, you are probably using patterns already and may not know it.

The following are the design patterns identified in the original GoF design patterns book.

Creational | Structural | Behavioral
Factory Method (class scope) Abstract Factory Builder Prototype Singleton | Adapter (class scope) Adapter Bridge Composite Decorator Facade Flyweight Proxy | Interpreter (class scope) Chain of Responsibility Command Iterator Mediator Memento Observer State Strategy Visitor

Note: There are also some patterns in common use that do not appear in the list published by the GoF

All design patterns have four characteristics.

  • Name A name that communicates the use of the pattern
  • Problem The problem the pattern will solve
  • Solution The elements and relationships that comprise the pattern
  • Consequences The benefits and costs of the pattern

Observer Design Pattern

The essence of this pattern is that one or more objects (called listeners or observers) are registered to observe an event which is raised (or triggered) by the observed object (subject).

Observer pattern diagram Observer pattern diagram


Overview

The ProvideX Plug-in

The ProvideX Plug-in for Eclipse has been designed to provide an environment that integrates into the existing Eclipse framework and extends that infrastructure to ProvideX developers. This plug-in automatically converts tokenized ProvideX programs into text files and captures any additional control information (passwords, owner codes, and flags) as part of the conversion process. Once a program has been converted into text it can be used with many of the existing capabilities and other plug-ins available in Eclipse. This includes, but is not limited to, various change control systems such as CVS, Subversion, and MKS. The native version tracking that is part of the Eclipse framework can be used to keep track of localized modifications at the workstation.

The plug-in also allows third party collaboration to enhance or extend the capabilities of the plug-in.

Design Patterns

First, we will discuss a bit of OOP history and design methodologies.

Observers

The ability to extend the ProvideX plug-in is based on the observer design pattern. Each new extension is registered and the class initialized during startup of the plug-in. Once each class has been initialized, it can be queried to identify when it is to be invoked during the normal event cycle.

Each class has an update() method that is called when it is triggered. This method will then perform the task required to provide the additional functionality.

Enhancing Plug-in Functionality

The ProvideX plug-in can be enhanced using two different methods, or a combination of both.

Enhance Built-in Event Process

The first mechanism is to add functionality to the existing events that are supplied by the plug-in. These events allow two access points for the external logic to be executed. One is before the normal event logic and the second is after the event logic. A single enhancement can execute logic at either or both points in the event process.

Contributed Tools

The second mechanism is to add an external tool to the 'ProvideX' menu that will provide functionality outside of the plug-in event process. This external tool can manipulate the files within a ProvideX project in Eclipse.

Next Section: Design Patterns


ActionListenerExample

Class ActionListenerExample

This is an example of a simple contributed tool. The only code that is required in this class is the logic that is specific to the action the tool is to perform.

Inherits

AbstractActionListener

Properties

LOCAL theDescription$="Simple Tool Example (no config)"

Methods

FUNCTION actionPerformed(inActionEventID)

This method will be called when the action is triggered from the contributed tools menu.

Parameter | Description
inActionEventID | This is a reference to [Java Class:eventmanager/ExtCommand]
Footer logo


com.pvx.util.progress

Class com.pvx.util.progress

Abstract class to log progress of a contributed tool action; the information will be displayed in a view that will remain open until the user decides to close it.

Info

The sub-class initialization method must set the following variables which will be used to identify the panel. theCaption$, theDescription$ The sub-class initialization method can also enable the 'CANCEL' button on the "Progress Log" panel by calling the method: _obj'enable_cancel() The sub-class must implement a method to perform the task(s) associated with the contributed tool; this method will be executed once the ProcessLog panel has been loaded and initialized. This logic must be implemented in the method: doWork() If the sub-class has enabled the 'CANCEL' button, the tasks performed by the sub-class must check to determine if the user has pressed the 'CANCEL' button and then set a flag that will cause the processing to abort. This logic should be similar to the following example: isCancelled = _obj'checkCancel() The sub-class method can also disable the 'CANCEL' button on the "Progress Log" panel by calling the method: _obj'disable_cancel()

Inherits

*nomads, ecConstant

Known SubClasses

com.pvx.pvxdoc.createDocs, ecSearchLogViewUI, ecStyleCheckRun, stripTrailing_UI

Properties

PROPERTY theCaption$, theDescription$

Set variables used to identify the panel View

PROPERTY screen_id$="PROGRESSLOG"

Set Panel / Library for Progress log

PROPERTY screen_lib$="com.pvx.util.en"

Methods

FUNCTION checkCancel()

Check for user pressing CANCEL button

Returns A simple boolean (0=False, 1=True) to indicate that the cancel button was pressed
FUNCTION createLogFile(aNamePfx$)
FUNCTION createLogFile(aNamePfx$, btnText$)

Create a temporary log file to be updated as the process executes; the log file will be deleted upon exit of task

Parameter | Description
aNamePfx$ | The start of the work file name.
btnText$ | (Optional)The text to use for the label of the 'Special' button when enabled at end of process
Returns A simple boolean (0=False, 1=True) to indicate that the log file was created
FUNCTION disable_cancel()

Method that can be executed by SUB-CLASS to disable the 'Cancel' button

FUNCTION enable_cancel()

Method that is executed as part if initialization in SUB-CLASS to enable the 'Cancel' button

FUNCTION enable_special(sLabel$)

Method to enable the 'Special' button

Parameter | Description
sLabel$ | Label to display on button
FUNCTION writeLog(aString$)
FUNCTION writeLog(aString$, aLogFile$)

Write text to progress log display and log file

Parameter | Description
aString$ | The text to update into the progress log; use SEP character at end of each line for multi-line messages
aLogFile$ | (Optional) The name of an existing log file to write the message
FUNCTION writeLogFile(aString$)
FUNCTION writeLogFile(aString$, aLogFile$)

Write text to log file only

Parameter | Description
aString$ | The text to write to the log file
aLogFile$ | (Optional) The name of an existing log file to write the message; if not included, will use the log file created by _obj'createLogFile() method
FUNCTION LOCAL b_close()

Method that is executed when the 'Close' button is pressed.

FUNCTION LOCAL b_special()

Method that is executed when the 'Special' button is pressed.

FUNCTION LOCAL disable_special()

Method that can be executed by SUB-CLASS to disable the 'Special' button

FUNCTION LOCAL doWork()

This method is called by the PostLoad() method from the com.pvx.util.progress class to perform work for this tool; this tool can use the WriteLog() method to show or update progress as the work is performed

Warning

*** Must be implemented in child class. ***

FUNCTION LOCAL onExit()

Clean-up required for this panel during exit.

FUNCTION LOCAL PostLoad()

NOMADS method that is accessed after the panel has been loaded

FUNCTION LOCAL PreLoad()

NOMADS method that is accessed before the panel is loaded

FUNCTION LOCAL setDescription(aCaption$, aDescription$)

Set description to be displayed for the log

Parameter | Description
aCaption$ | the value to be used for the caption of the view
aDescription | the value to be used to describe the work to be logged
FUNCTION LOCAL updateView()

update information in the view used to display the progress log

FUNCTION LOCAL workDone()

Method that is called to indicate that all work is completed for the task

Properties inherited from: ecConstant

isFALSE, isTRUE, isYES$, isNO$, chkOFF$, chkON$, chkGRAYED$, errOBJECT, msgYES$, msgNO$, msgCANCEL$, msgOK$, msgRETRY$, msgABORT$, msgIGNORE$, msgNOTONFILE$, msgTIMEOUT$, msgDISABLE, msgACTIVE, retFAILURE, retSUCCESS, retNEW, retWARNING, retCANCEL, retYES, retNO, typALPHANUM, typZEROFILL, typCHARNUM, typMASTERNUM, typALPHANUMNF, typMASTERNUMC, typALPHA$, typNUMBERS$, typALPHANUM$, typALPHANUMNF$, typCHARNUM$, typMASTERNUM$, typMASTERNUMCLEN, LastErrorMsg$, LastErrorNum$

Methods inherited from: ecConstant

element$(), isALPHA(), isDATE(), isNUMERIC(), ParseString(), Position(), QUO$()

Footer logo


del_dupe_lines

Class del_dupe_lines

This observer will scan the current source file (in the build process) and remove all lines with duplicate line numbers; if the source file does not have line numbers, this observer will do nothing.

Inherits

EventManagerObserver

Properties

LOCAL theDescription$="Remove lines with duplicate line numbers"

Override values for description / NotificationFlag

LOCAL theNotificationFlag=_pvxConstants'_idePrePostProcess

Methods

FUNCTION update(initPvxState)

The logic to be executed when the observer is triggered. This logic must check the major and minor codes to determine the current event and then decide what action is to be performed.

If this observer is set to watch both Pre-Process and Post-Process states for events, the logic in the 'update' method must check the state of the _pvxState'getArgument(_pvxConstants'_iEventNotificationFlag$) flag to determine the appropriate code to be executed.

Parameter | Description
state | A reference to an object of class PvxState
Footer logo


ecCommon

Class ecCommon

This class provides several common methods to enable access to Eclipse information.

Properties

LOCAL pLookAndFeel$
PROPERTY StageActionPerformed=1
PROPERTY StageProcessPanel=2
PROPERTY StageTaskStart=3
PROPERTY cConsoleFont$

Default Fixed-width font (text plane / console)

PROPERTY cGraphicalFont$

Default Proportional font

Methods

FUNCTION ConfigGuiDisplay()

Standard initialization of graphical environment for the view

FUNCTION ConfigGuiDisplay(allowDialogueWindows)

Standard initialization of graphical environment for the view

Parameter | Description
allowDialogueWindows | A simple boolean to allow dialogue windows to display outside of Eclipse view (0=No, 1=Yes)
FUNCTION GetFontInfo(option$, name$, size)

Get information about the specified system font type

Parameter | Description
option$ | A single letter to identify the font type
name$ | Name of current font of specified type
size | Size of current font of specified type
Returns 0=No Font infomration found, 1=Found font information
Font Type Codes
Value | Description
G | Graphical Font
T | Text plane font
FUNCTION GetInfo$(option$)

Get information about the current Eclipse working environment

Parameter | Description
option$ | A single letter to identify the information required.
Returns The value for the requested information.
Information Codes
Value | Description
E | The current editor resource
N | The number of selected resources in the Navigator View
P | The current project
W | The workspace name
FUNCTION GetPath$(option$)

Get the specified path

Parameter | Description
option$ | A single letter code to identify the path
Returns The value for the path.
Path Identification Codes
Value | Description
O | The location of the output directory for the current project
P | The current project location
S | The location of the source directory for the current project
W | The location of the current workspace
FUNCTION GetWorkspaceRoot$()

Get Workspace Root Path

FUNCTION InitStage(stage)

Perform initialization steps for specified stage; will also check environment variable PP4E_CT_DEBUG for and initiate debug action(s)

Parameter | Description
stage | Contributed tool startup stage
Contributed tool Startup Stage
Value | Description
StageActionPerformed | 1 Action Performed method (in listener)
StageProcessPanel | 2 Process Panel (in ecCommon)
StageTaskStart | 3 Task startup (ecCommonStartup)
FUNCTION isPluginLoaded(aPluginID$)

Check to see if the MAS plug-in has been loaded aPluginID$ The ID of the dependent plug-in to be checked

Returns A simple boolean (0=false, 1=true) to indicate whether the dependent Plug-in has been loaded
FUNCTION OSisWindows()

A simple check to determine if application is executing on a MS-Windows operating system.

Returns A simple boolean to indicate that operating is MS-Windows
FUNCTION Prefs(option$, tag$, value$)

Access / modify preferences stored in the Eclipse Preference store

Parameter | Description
option$ | A code to indication the action to perform
tag$ | The preference (or preference prefix)
value$ | The value to be returned for a preference, or the value to set for the preference, or the maximum number for the preferences to be cleared
Returns See 'Action Code' table
Action Codes
Value | Description
C | Clear a series of preferences that are prefixed by TAG$ and include a numeric counter that starts at one. The return value will be the number of preferences that have been cleared
G | Get the value of the preference. The return value will be a 1 of there is a value.
S | Set the value of the preference. The return value will be a 1 if the assignment was successful.
FUNCTION processPanel(cUI$, cTitle$)
FUNCTION processPanel(cUI$, cTitle$, aDataRec$)

Standard mechanism to process a NOMADS panel in a view (in a separate process)

Parameter | Description
cUI$ | A NOMADS OOP class for the user interface
cTitle$ | The panel title
aDataRec$ | (Optional) A data record (SEP as field separator) to be seprated into variables and passed as arguments to the constructor of the class
FUNCTION Resource(option$, path$)

Get the location of the specified resource

Parameter | Description
option$ | A code to identify the view for the selected resource
path$ | The path of the selected resource is returned in this variable
Returns A simple boolean to indicate that the method succeeded
View Codes
Value | Description
E | The current resource loaded in the editor
N | The resource selected in the Navigator View
FUNCTION runProgram(aProgram$, cTitle$)
FUNCTION runProgram(aProgram$, cTitle$, aDataRec$)
FUNCTION runProgram(aProgram$, cTitle$, aDataRec$, aVarList$)

Standard mechanism to run a program within a view (in a separate process)

Parameter | Description
aProgram$ | The name of a program to execute
cTitle$ | The title for the application window
aDataRec$ | (Optional) A data record to be passed to application program
aVarList$ | (Optional) A list of variables to be assigned the values in aDataRec$
FUNCTION WorkFile$(prefix$, path$, ext$)

Get the name for a work file.

Parameter | Description
prefix$ | A prefix to be used when creating the name for the work file.
path$ | An optional path for the work file; if not specified, the operating system temporary directory will be used
ext$ | An optional file extension to be used for the work file; if none is specified, "tmp" will be used
Returns The full path name of a work file that can be created by the application.
Footer logo


ecStyleCheck

Class ecStyleCheck

This is a special-purpose utility class that can used by developers to enable a style checker to be implemented as part of their development processes. This class does most of the work but is designed to be inherited by a developer-written class to allow developers to decide if this feature is useful and to also allow the developer to override the standard functionality to add hard-coded rules to the style check logic. This allows developers to implement style check logic that cannot be easily defined using the rules file information. A sample developer class has been included in the examples folder.

This utility class is written to be both a "contributed tool" and a "Build Post-Process" listener. When the class is triggered from the "Contributed Tools" menu, it will scan the resource that is selected in the navigation view. When triggered as part of the build process, it will scan the program that is getting processed for the build. In both cases, the source code of the program is checked against a pre-set list of style rules and any discrepancies are reported in the "Problem View".

When accessed as part of the build process, it will only report issues to the problem view. When accessed from the "Contributed Tool" menu, it can also automatically correct some of the issues that are discovered based on the information contained within the style rules.

Inherits

AbstractActionListener, EventManagerObserver

Known SubClasses

simpleStyleCheck

Properties

LOCAL theDescription$="ProvideX Style Check"

Description for this observer/contributed tool

LOCAL styleCheckName$="ecStyleCheck"

Short name for this observer/contributed tool

LOCAL theNotificationFlag=_pvxConstants'_idePrePostProcess

Register the events for this tool

LOCAL lbSepChar$=$09$

Methods

FUNCTION actionPerformed(inActionEventID)

This method will be called when the action is triggered from the contributed tools menu.

Parameter | Description
inActionEventID | This is a reference to [Java Class:eventmanager/ExtCommand]
FUNCTION configPerformed(inActionEventID)

This method will be called when the 'Configure' action is triggered from the contributed tools menu. The code required to implement the configuration action is normally implemented as one or more NOMADS panels that this method will execute.

Parameter | Description
inActionEventID | This is a reference to [Java Class:eventmanager/ExtCommand]
FUNCTION getStyleCheckName$()

Get the name for the style check class

Returns The name of the class
FUNCTION hasConfigAction()

This method is used to check whether a configuration action has been implemented.

Returns True (1) if a configuration action has been implemented
FUNCTION init()

Register this class as an event listener and add it to the list of contributed tools under the ProvideX menu.

FUNCTION update(state)

The logic to be executed when the observer is triggered during the normal event process in the ProvideX event manager. This logic will check the major and minor codes to determine the current event and then decide what action is to be performed.

Parameter | Description
state | A reference to an object of class PvxState
FUNCTION LOCAL loadRules(theRuleFile$)

Load the style rules from the developer properies file.

Parameter | Description
theRuleFile$ | The name of the properties file ti be loaded
FUNCTION LOCAL writeRuleFile(aRuleFile$, theRules$, isSecondaryFile)

save rules back to the rule file(s)

Parameter | Description
theRuleFile$ | The name of the properties file to write
theRules$ | The modified rules to write to the rule file
isSecondaryFile | A simple boolean (0=False, 1=True) to indicate a secondary rule file

Properties inherited from: AbstractActionListener

theDescription$, theNotificationFlag

Properties inherited from: EventManagerObserver

theDescription$, theNotificationFlag

Methods inherited from: AbstractActionListener

actionPerformed(), configPerformed(), getDescription$(), getEventNotificationFlag(), hasConfigAction(), init()

Methods inherited from: EventManagerObserver

getDescription$(), getEventNotificationFlag(), init(), update(), createAlternateSourceFile(), getAlternateSourceFile$()

Footer logo


ecStyleCheckRun

Class ecStyleCheckRun

Inherits

com.pvx.util.progress

Properties

LOCAL lbSepChar$=$09$
PROPERTY hasSecondaryRuleFile * Read Only *

A boolean to identify when there is a secondary rules file in the contributed tools folder

Methods

FUNCTION getRules$()

Get the rules loaded from the specifed rules file

Returns A string containing the rules that were loaded
FUNCTION getSecondaryRuleFilePath$()

Get the full path to the secondary rules file

Returns the full path to the secondary rules file
FUNCTION GetStyleCheckName$()

Get the name for the style check class

Returns The name of the class
FUNCTION loadRules(theRuleFile$)

Load the style rules from properies file; will load from a file in the same location as primary class; and then append any rules found in secondary file in Contributed tools folder

Parameter | Description
theRuleFile$ | The name of the properties file ti be loaded
FUNCTION ProcessFile(theFile$, resetMarks, updateOK)
FUNCTION ProcessFile(theFile$, resetMarks, updateOK, theStatus$)
FUNCTION ProcessFile(theFile$, resetMarks, updateOK, theStatus$, isPvxClass, retSrcFile$)

Process the selected (or current) source file against the style rules and update the problem view with any errors or warnings that are generated.

Parameter | Description
theFile$ | The name of the source file to be processed against the style rules
resetMarks | A boolean flag to indicate whether the current problem view information for this file should be reset before applying the information created by the style check
updateOK | A boolean flag to identify if the source file can be updated as a result of processing the style rules
theStatus$ | (Optional) A string containing the results of the style check (Errors/Warnings)
isPvxClass | (Optional) A boolean flag to indicate if currect file is a ProvideX Class
retSrcFile$ | (Optional) Name of new source file created if option set to replace tags
FUNCTION ProcessNavViewSelections()

Process the selected (or current) source file against the style rules and update the problem view with any errors or warnings that are generated.

Properties inherited from: com.pvx.util.progress

theCaption$,theDescription$, screen_id$, screen_lib$

Methods inherited from: com.pvx.util.progress

checkCancel(), createLogFile(), disable_cancel(), enable_cancel(), enable_special(), writeLog(), writeLogFile(), b_close(), b_special(), disable_special(), doWork(), onExit(), PostLoad(), PreLoad(), setDescription(), updateView(), workDone()

Footer logo


ecStyleCheckUI

Class ecStyleCheckUI

This class is used by the configuration option for EC_StyleCheck contributed tool.

It is the logic that is used for the NOMADS panels used to configure the tool.

Constructor

The constructor for this class retrieves the data from the Eclipse Preference store. If the data does not exist, the default values that are hard-coded into this program will be used.

Parameter | Description
styleCheckName$ | - specify name of StyleCheck class

Inherits

*nomads

Properties

LOCAL prefPfx$="com.pvx.ecStyleCheckUI."
LOCAL lbSepChar$=$09$
PROPERTY rulesModified * Read Only *

This property indidcates whether the rules have been modified

PROPERTY screen_id$="CONFIG_STYLE"

Initial panel to be loaded for the configuration information

PROPERTY screen_lib$="com.pvx.util.en"

The library for the panel definitions

Methods

FUNCTION getOption(inKeyword$)

This method is used to read the options (AutoFix, Escalate).

FUNCTION getOption$(inKeyword$)

This method is used to read the options (RulesState).

Footer logo


ExampleObserver

Class ExampleObserver

This is an example of the observer class. The name of the observer must be unique. It must also be used when identifying this class in the 'classes.txt' file in the./ext folder by adding a line "eventName=ExampleObserver".

The entries in the "classes.txt" file are loaded automatically during start of the ProvideX Event Manager. As each class is successfully loaded, it is added the the observers preference page. This gives the user control of the external observers (if any) that are active.

Inherits

EventManagerObserver

Properties

LOCAL theDescription$="Example observer"
LOCAL theNotificationFlag=_pvxConstants'_idePostProcess

Methods

FUNCTION update(initPvxState)

The logic to be executed when the observer is triggered. This logic must check the major and minor codes to determine the current event and then decide what action is to be performed.

If this observer is set to watch both Pre-Process and Post-Process states for events, the logic in the 'update' method must check the state of the aPvxState'getArgument(_pvxConstants'_iEventNotificationFlag$) flag to determine the appropriate code to be executed.

Parameter | Description
state | A reference to an object of class PvxState
Footer logo


ExampleStyleCheck

Class ExampleStyleCheck

This class is created by an application developer who wishes to enable the SytleCheck capability that is build into the ProvideX plug-in.

The primary purpose of this class is to load the developer-specific rules and to provide additional logic to handle special cases that cannot be described using the standard rules.

Inherits

ecStyleCheck

Properties

LOCAL theDescription$="Generic Style Check"
LOCAL theNotificationFlag=_pvxConstants'_idePostProcess
LOCAL theStyleRules$=MID(PGN, 1, POS(DLM=PGN, -1))+"ExampleStyleCheck_rules.txt"

Methods

FUNCTION configPerformed(inActionEventID)

This method will be called when the 'Configure' action is triggered from the contributed tools menu.

Parameter | Description
inActionEventID | A reference to [Java Class:eventmanager/ExtCommand]
FUNCTION update(state)

The logic to be executed when the observer is triggered during the normal event process in the ProvideX event manager. This logic must check the major and minor codes to determine the current event and then decide what action is to be performed.

Parameter | Description
state | A reference to an object of class PvxState
Footer logo


execModifiedFiles

Class execModifiedFiles

Sample class to show how to perform an action for each file updated by the build process.

This class will be registered as a PostProcess observer and will monitor the following events:

  1. Full Build Start
  2. Incremental build for a single file
  3. Full Build End

These events are triggered when:

  • A file is saved in the editor
  • The build action is selected from the pop-up menu in the editor
  • The build action is selected against one or more selected files in the Navigator View

Inherits

EventManagerObserver

Properties

LOCAL theDescription$="Execute modified files in test environment"
LOCAL theNotificationFlag=_pvxConstants'_idePostProcess

Methods

FUNCTION update(initPvxState)

The logic to create a list of files processed by build, and perform an action for each file

  • Initialize the list of the files when the full build starts
  • In Build Post-Process for each file, add relative path of each output file to the list
  • At end of Full Build, go through the list of files and print relative name to console

Parameter | Description
state | A reference to an object of class PvxState
Footer logo


PvxConstants

Class PvxConstants

This class defines constants to be used to identify actions, events, and values used within the plug-in to maintain a consistent interface between objects.

Build Information

Forcelinenumbers false

Constructor

This class loads all of the constants used by the plugin into a single location. In addition to setting the ProvideX constants, all of the constants used by the Java components are also loaded from the [Java Class:preferences/PreferenceConstants] and [Java Class:eventmanager/EventManager] objects.

Parameter | Description
EventManager | A reference to [Java Class:eventmanager/EventManager] object

Properties

PROPERTY _iPluginID$
PROPERTY _iPluginHelperDir$
PROPERTY event_Desc$
PROPERTY event_Fired$
PROPERTY event_Listnr$
PROPERTY ext_Event$
PROPERTY act_Password$
PROPERTY adding_Resources_to_Src$
PROPERTY StripLines_Prep$
PROPERTY Eclipse_Shutdown$
PROPERTY Export$
PROPERTY Full_Build$
PROPERTY Full_Build_End$
PROPERTY Full_Build_Start$
PROPERTY generic_action$
PROPERTY Host_Is_Ready$
PROPERTY Import$
PROPERTY Import_Export_File$
PROPERTY Import_Export_Properties$
PROPERTY Importing_End$
PROPERTY Importing_Start$
PROPERTY Incremental_Build$
PROPERTY Incremental_Build_Alt_Exe$
PROPERTY Operation_Cancel$
PROPERTY Operation_Success$
PROPERTY PageID$
PROPERTY Preference_Change$
PROPERTY Preference_Page_Button$
PROPERTY Preference_Property$
PROPERTY Preference_New_Value$
PROPERTY Preference_Old_Value$
PROPERTY Project_List$
PROPERTY Project_Location$
PROPERTY Project_Member_Count$
PROPERTY Project_Name$
PROPERTY Removed_Resource_From_Src$
PROPERTY Request_Socket$
PROPERTY Resource_Properties_Changed$
PROPERTY Run_Console$
PROPERTY Run_Designer$
PROPERTY Run_DictMaint$
PROPERTY Run_IT$
PROPERTY Run_NOMADS$
PROPERTY Run_Test_Panel$
PROPERTY NOMADS_blocking$
PROPERTY NOMADS_non_blocking$
PROPERTY Strip_Line_No$
PROPERTY Validate$
PROPERTY Valid$
PROPERTY Invalid$
PROPERTY Load$
PROPERTY Remove$
PROPERTY Name$
PROPERTY Path$
PROPERTY Selected_View$
PROPERTY Build_File_Path$
PROPERTY Buildtype_Convert$
PROPERTY Buildtype_BuildOne$
PROPERTY Buildtype_DataFile$
PROPERTY Buildtype_NomadsLIB$
PROPERTY Buildtype_OtherFile$
PROPERTY Buildtype_SkipFile$
PROPERTY Buildtype_Source_Format$
PROPERTY Buildtype_Skip$
PROPERTY _ibDOAUTOFORMAT$
PROPERTY BuildLog$
PROPERTY BuildType$
PROPERTY Dest$
PROPERTY DomFile$
PROPERTY Flags$
PROPERTY OwnerCode$
PROPERTY pkf_Password$
PROPERTY SrcFile$
PROPERTY LockFile$
PROPERTY event_SrcFile$
PROPERTY Resource_OwnerCode$
PROPERTY Resource_Flags$
PROPERTY Import_SrcFile_Extension$
PROPERTY Import_Formatlist$
PROPERTY Import_Lowercase_Dir$
PROPERTY Import_Lowercase_Vars$
PROPERTY Import_Strip_Line_Label_Prefix$
PROPERTY Import_Strip_Line_no$
PROPERTY Import_Strip_Line_Use_Orig_no$
PROPERTY Import_SuppressLet$
PROPERTY isLine_Numbs_Required$
PROPERTY Output_File_Name$
PROPERTY Project_INI_File$
PROPERTY Project_Output_Directory$
PROPERTY Project_Source_Directory$
PROPERTY p_Password$
PROPERTY p_IsPVXData$
PROPERTY p_IsResource$
PROPERTY p_xml_export$
PROPERTY p_build_files_no_ext$
PROPERTY p_ischecking_file_extions$
PROPERTY Builder_Exe$
PROPERTY Build_Exec_CMD$
PROPERTY Build_Exec_Log$
PROPERTY Build_Exec_Out$
PROPERTY BuildInfoFound$
PROPERTY Project_Root$
PROPERTY PvxCTL$
PROPERTY _ibDebug$
PROPERTY _ibDebugProcessMessages$
PROPERTY _ibDebugLogToConsole$
PROPERTY _ibDebugLog$
PROPERTY _ibDebugSize$
PROPERTY _ibDebug_SC_DumpInfo$
PROPERTY _iBuildDebug$
PROPERTY _iBuildCheckStructure$
PROPERTY _iBuildMaintainCase$
PROPERTY _iBuildDebugTIM$
PROPERTY _iBuildProgress$
PROPERTY _iDisableCstyleComments$
PROPERTY _iShowSizeWarning$
PROPERTY _ibAltStartUp$
PROPERTY _ibBtiEnable$
PROPERTY _ibMasBuildOne$
PROPERTY _ibUseStartUp$
PROPERTY _iEclipseBuilderSocket$
PROPERTY _iOutlineExcludeVars$
PROPERTY _LineNumberInc$
PROPERTY _IRPC_EXE$
PROPERTY _iRPCisOK$
PROPERTY _IRPC_PORT$
PROPERTY _iShowEventParm$
PROPERTY _iShowInvokeCommand$
PROPERTY _iEventNotificationFlag$
PROPERTY _iAllowConsole$
PROPERTY _iSuppressDataPassword$
PROPERTY _ibStripLeadingWhiteSpace$
PROPERTY _ibLogErrorScan$
PROPERTY _ibForceDestinationName$
PROPERTY _ibStringLiteralContinue$
PROPERTY _KeywordConversion$
PROPERTY _AutoKeywordConversion$
PROPERTY _KC_ConvertLabels$
PROPERTY _NOMADS_Default_Suffix$
PROPERTY _NOMADS_Panel_Suppress_VAL$
PROPERTY _NOMADS_Panel_Column$
PROPERTY _NOMADS_Panel_Line$
PROPERTY _NOMADS_Panel_Width$
PROPERTY _NOMADS_Panel_Height$
PROPERTY _NOMADS_Panel_GUI_Style$
PROPERTY _NOMADS_Panel_Grid_Def$
PROPERTY _NOMADS_Object_Name$
PROPERTY _NOMADS_ExtImageDir$
PROPERTY _Cancel$
PROPERTY _bFormattedText$
PROPERTY _bIsOK$
PROPERTY _bPasswordValidate$
PROPERTY _bSaveAsText$
PROPERTY _ideFromStripper$
PROPERTY _iEventCommand$
PROPERTY _ideConvertSource$
PROPERTY _iDefaultTokenPgmExt$
PROPERTY _iStripSourceExtension$
PROPERTY _iAddSourceExtension$
PROPERTY _iPasswordType$
PROPERTY _extObserverEnable$
PROPERTY _extObserverUserDir$
PROPERTY _ProgramBlockComments$
PROPERTY _idePreProcess

Contributed Extension / Tool event notification type: Before event performed

PROPERTY _idePostProcess
Contributed Extension / Tool event notification type: After event performed
PROPERTY _idePrePostProcess
Contributed Extension / Tool event notification type: Before/After event performed
PROPERTY _ideNone
Contributed Extension / Tool event notification type: Not triggered during event process
PROPERTY _iPvxData
PROPERTY _iPvxProgram
PROPERTY _btiUpdateInfo$

Methods

FUNCTION getPvxHelperDir$()

Get the location of the PvxHelper root directory for this system

Returns A string value that contains the root directory of the PvxHelpers on the local file system.
Footer logo


set_copyright_year

Class set_copyright_year

This observer will change the value for copyright year prior to creating a new build of an application.

This program searches for '%(copyright-year)%' within the first 100 characters of the source file and will replace it with the current year. It will then create a temporary file to be used as an alternative source file which will be deleted during the PostProcess of the build by this same observer.

Inherits

EventManagerObserver

Properties

LOCAL theDescription$="Substitute modification year of source file for 'Copyright-year' tag."
LOCAL theNotificationFlag=_pvxConstants'_idePrePostProcess

Methods

FUNCTION update(initPvxState)

The logic to be executed when the observer is triggered.

Parameter | Description
initPvxState | A reference to an object of class PvxState

Properties inherited from: EventManagerObserver

theDescription$, theNotificationFlag

Methods inherited from: EventManagerObserver

getDescription$(), getEventNotificationFlag(), init(), update(), createAlternateSourceFile(), getAlternateSourceFile$()

Footer logo


set_mod_timestamp

Class set_mod_timestamp

This observer will set the modification timestamp of the output file to be the same as the source file.

This program uses the Eclipse IResource class to get and set the timestamps.

Inherits

EventManagerObserver

Properties

LOCAL theDescription$="Set modification timestamp of output file to be the same as source file"
LOCAL theNotificationFlag=_pvxConstants'_idePostProcess

Methods

FUNCTION update(initPvxState)

The logic to be executed when the observer is triggered.

Parameter | Description
state | A reference to an object of class PvxState

Properties inherited from: EventManagerObserver

theDescription$, theNotificationFlag

Methods inherited from: EventManagerObserver

getDescription$(), getEventNotificationFlag(), init(), update(), createAlternateSourceFile(), getAlternateSourceFile$()

Footer logo


showtext

Class showtext

This observer will place a short text message in the console view for every event that is triggered in the workbench. This class will also register as a builder pre/post process listener.

Inherits

EventManagerObserver

Properties

LOCAL theDescription$="Show message in Console"
LOCAL theNotificationFlag=_pvxConstants'_idePrePostProcess

Methods

FUNCTION update(initPvxState)

The logic to "print" text to the Console view

Parameter | Description
state | A reference to an object of class PvxState
Footer logo


simpleStyleCheck

Class simpleStyleCheck

This class is required on each client workstation to enable the StyleCheck capability that is included in the ProvideX plug-in in the class ecStyleCheck.

This class does not extend any of the standard functionality - it is used to define/load a group of style rules as the contributed tool 'simpleStyleCheck'.

Info

The 'masStyleCheck' class (included with the Sage 100 ERP Plug-in) is the same as this class except it is used to define/load a group of style rules as the contributed tool 'masStyleCheck'.

Inherits

ecStyleCheck

Properties

LOCAL styleRulesFile$

the value mid(pgn, 1, pos(dlm=pgn, -1)) + _obj'_Class$ + "_rules.txt" is used to derive the name of the rule file from the name of the style check class

LOCAL theDescription$="Simple rule-based Style Check"

Override Description

Methods

No Methods

Properties inherited from: ecStyleCheck

theDescription$, styleCheckName$, theNotificationFlag, lbSepChar$

Methods inherited from: ecStyleCheck

actionPerformed(), configPerformed(), getStyleCheckName$(), hasConfigAction(), init(), update(), loadRules(), writeRuleFile()

Footer logo


stripTrailing_Listener

Class stripTrailing_Listener

Inherits

AbstractActionListener

Properties

LOCAL theDescription$="Strip trailing white space"
LOCAL cTitle$="Strip Trailing White Space"
LOCAL cUI$="stripTrailing_UI"

Methods

FUNCTION actionPerformed(inActionEventID)

This method will be called when the action is triggered from the contributed tools menu.

Parameter | Description
inActionEventID | This is a reference to [Java Class:eventmanager/ExtCommand]

Properties inherited from: AbstractActionListener

theDescription$, theNotificationFlag

Methods inherited from: AbstractActionListener

actionPerformed(), configPerformed(), getDescription$(), getEventNotificationFlag(), hasConfigAction(), init()

Footer logo


stripTrailing_UI

Class stripTrailing_UI

This class is called by the sct_stripTrailing_Listener to show progress as the files selected in the Navigator view are processed to strip trailing whitespace.

Inherits

com.pvx.util.progress

Properties

LOCAL theCaption$="Strip Trailing Whitespace"

Set the caption for the user interface window

LOCAL theDescription$="Strip trailing white space"

Description to display in progress log for the work performed

Methods

No Methods
Footer logo


toolConfigAndProgress_Config_ui

Class toolConfigAndProgress_Config_ui

Inherits

ecCommonUI

Properties

LOCAL cPrefStorePfx$="toolConfigAndProgress"

[string] prefix to use for data values in Eclipse data store

LOCAL cDataVars$="workDesc$, workUnits, workDelay"

[string] List of fields names of data values managed by form

PROPERTY screen_id$="dConfig"

Initial panel to be loaded for the configuration information

PROPERTY screen_lib$="toolConfigAndProgress.M4L"

The library for the panel definitions

Methods

FUNCTION SetDefaults()

Set default values for fields

Footer logo


toolConfigAndProgress_Listener

Class toolConfigAndProgress_Listener

Inherits

AbstractActionListener

Properties

LOCAL theDescription$="Example - With Config and Progress"

Description to be used for tool in the Contributed Tools list

LOCAL cRunTitle$="Example - WCaP Progress"
LOCAL cRunUI$="toolConfigAndProgress_Run_ui"
LOCAL cConfigTitle$="Example - WCaP Config"
LOCAL cConfigUI$="toolConfigAndProgress_Config_ui"

Methods

FUNCTION actionPerformed(inActionEventID)

This method will be called when the action is triggered from the contributed tools menu.

Parameter | Description
inActionEventID | This is a reference to [Java Class:eventmanager/ExtCommand]
FUNCTION configPerformed(inActionEventID)

This method will be called when the 'Configure' action is triggered from the contributed tools menu. The code required to implement the configuration action is normally implemented as one or more NOMADS panels that this method will execute.

Parameter | Description
inActionEventID | This is a reference to [Java Class:eventmanager/ExtCommand]
FUNCTION hasConfigAction()

This method is used to check whether a configuration action has been implemented.

Returns True (1) if a configuration action has been implemented
Footer logo


toolConfigAndProgress_Run_ui

Class toolConfigAndProgress_Run_ui

Inherits

com.pvx.util.progress

Properties

LOCAL theCaption$="Example - WCaP Progress"

Set the caption for the user interface window

LOCAL theDescription$="Example - WCaP Run Action"

Override Description

LOCAL theNotificationFlag=_pvxConstants'_ideNone

Override NotificationFlag

LOCAL cPrefStorePfx$="toolConfigAndProgress"

[string] prefix to use for data values in Eclipse data store

Methods

No Methods
Footer logo


toolWithConfig

Class toolWithConfig

Inherits

AbstractActionListener

Properties

LOCAL theDescription$="Example - With config"

Description to be used for tool in the Contributed Tools list

Methods

FUNCTION actionPerformed(inActionEventID)

This method will be called when the action is triggered from the contributed tools menu.

Parameter | Description
inActionEventID | This is a reference to [Java Class:eventmanager/ExtCommand]
FUNCTION configPerformed(inActionEventID)

This method will be called when the 'Configure' action is triggered from the contributed tools menu. The code required to implement the configuration action is normally implemented as one or more NOMADS panels that this method will execute.

Parameter | Description
inActionEventID | This is a reference to [Java Class:eventmanager/ExtCommand]
FUNCTION hasConfigAction()

This method is used to check whether a configuration action has been implemented.

Returns True (1) if a configuration action has been implemented
Footer logo


XML_Convert

Class XML_Convert

This is a Post-Process observer that will convert ProvideX data files to/from XML. It will also be registered as a contributed tool and will be added to that list under the 'ProvideX' item on the menu bar.

Inherits

AbstractActionListener, EventManagerObserver

Properties

LOCAL theDescription$="Convert ProvideX keyed files to/from XML"
LOCAL theNotificationFlag=_pvxConstants'_idePostProcess

Methods

FUNCTION actionPerformed(inActionEventID)

This method will be called when the action is triggered from the contributed tools menu.

Parameter | Description
inActionEventID | This is a reference to [Java Class:eventmanager/ExtCommand]
FUNCTION update(initPvxState)

The logic to be executed when the observer is triggered. This logic must check the major and minor codes to determine the current event and then decide what action is to be performed.

Parameter | Description
initPvxState | A reference to an object of class PvxState

Properties inherited from: AbstractActionListener

theDescription$, theNotificationFlag

Properties inherited from: EventManagerObserver

theDescription$, theNotificationFlag

Methods inherited from: AbstractActionListener

actionPerformed(), configPerformed(), getDescription$(), getEventNotificationFlag(), hasConfigAction(), init()

Methods inherited from: EventManagerObserver

getDescription$(), getEventNotificationFlag(), init(), update(), createAlternateSourceFile(), getAlternateSourceFile$()

Footer logo


!

! Copyright (c) 2007-2009 Sage Software Canada Ltd. All Rights Reserved

! $Id: AbstractActionListener.pvc.pvt 3073 2022-06-14 18:24:49Z fmcguirk $

/*

! ** Abstract class for 'ActionListener' classes.

! ** @Constructor This is an abstract class for all event manager observers.

! ** @param init_pvxConstants A reference to %PvxClass(PvxConstants)% object

! ** @param initViewManager A reference to %JavaClass(views/UIManager)% object

 */

def class "AbstractActionListener" create required

    ! Attributes:

    local _pvxConstants,ViewManager,p_Debug,p_DebugVerbosityLevel

    ! ** Description to be used for tool in the list of Contributed Tools access from the ProvideX, Contributed Tools menu item

    local theDescription$="External observer - "+_OBJ'_class$

    ! Set default value for event notification for the observer - Do not register

    local theNotificationFlag=_pvxConstants'_ideNone

    ! A short name for the tool - defaults to the class name

    local theToolShortname$=_OBJ'_class$

    /*

    ! ** This method will be called when the 'Run' action is triggered from the

    ! ** contributed tools menu.  The code associated with this observer must be

    ! ** executed by this method; this code can be the logic for this method or

    ! ** can be in an external program that is accessable in the environment

    ! ** where this observer will be used.

    ! ** @param inActionEventID This is a reference to %JavaClass(eventmanager/ExtCommand)%

     */

     function actionPerformed(inActionEventID)            do_ActionPerformed

    /*

    ! ** This method will be called when the 'Configure' action is triggered from

    ! ** the contributed tools menu.  The code required to implement the configuration

    ! ** action is normally implemented as one or more NOMADS panels that this

    ! ** method will execute.

    ! ** @param inActionEventID This is a reference to %JavaClass(eventmanager/ExtCommand)%

     */

     function configPerformed(inActionEventID)            do_ConfigPerformed

    /*

    ! ** This method is used to describe the purpose of this observer.  The text

    ! ** will be placed on the observers preference page to describe the purpose

    ! ** of this observer.  This description should be limited to no more than 80 characters.

    */

    function getDescription$()                            getDescription

    /*

    ! ** Get the flag that will be used to trigger the 'update()' method during

    ! ** execution of the built-in events for the plug-in.

    ! **

    ! ** If this observer is not a Post-process observer, the return value of this

    ! ** method should be set to one of the following values:

    ! ** @value _pvxConstants'_ideNone           Do not register as an observer

    ! ** @value _pvxConstants'_idePreProcess     Register as a Pre-Process observer

    ! ** @value _pvxConstants'_idePrePostProcess Register as both a Pre-Process and Post-Process observer.

    ! ** @value _pvxConstants'_idePostProcess    Register as a Post-Process observer

     */

    function getEventNotificationFlag()                    getEventNotificationFlag

    /*

    ! ** This method is used to get the short name of this observer.

    ! ** @returns The short name for this observer

    */

    function getToolShortname$()                        getToolShortname

    /*

     ! ** This method must be implemented in the child class when a configuration action has been implemented.

     ! ** @returns True(1) if a configuration has been implemented

     */

    function hasConfigAction()                            hasConfigAction

    ! ** Register this class as an event listener and add it to the list of

    ! ** contributed tools under the ProvideX menu item.

    function init()                                        init

end def

On_Create:

    enter init_pvxConstants,initViewManager

    _pvxConstants=init_pvxConstants, \

    ViewManager=initViewManager

    _pvxPref      = new("PvxPreferences")        ! *** Do NOT drop PvxPreferences - it is a singleton

    if _pvxConstants and _pvxPref {

        p_Debug               = _pvxPref'getBooleanPreference(_pvxConstants'_ibDebug$)

        p_DebugVerbosityLevel = 0, \

        p_DebugVerbosityLevel = abs(int(num(_pvxPref'getStringPreference$(_pvxConstants'_ibDebugVerbosityLevel$),err=*next)))

    }

    return

do_ActionPerformed:

    enter inActionEventID,err=*next

    return 0

do_ConfigPerformed:

    enter inActionEventID,err=*next

    msgbox "There is no configuration required for this option.","Configuration Information"

    return 0

getDescription:

    return theDescription$

getEventNotificationFlag:

    return theNotificationFlag

getToolShortname:

    return theToolShortname$

hasConfigAction:

    return 0

init:

    local EvtmngrFactory,EventManager

    def object EvtmngrFactory,"[wdx]com.pvx.ooadide.eventmanager.EventManagerFactory"

    ! get a handle to the event manager

    EventManager=EvtmngrFactory'getEventManager()

    EventManager'addExtPvxEventListener(_obj, _obj'getDescription$(), _obj'hasConfigAction())

    drop object EvtmngrFactory

    return 1

end


!

! (c) Copyright 2006-2011, Sage Software Canada Ltd. (Ontario, Canada)

! $Id: ActionListenerExample.pvc 84 2009-04-07 20:09:08Z fred.mcguirk $

/*

 * Build information:

! ** @Author Fred McGuirk

! ** @Date Feb 9, 2007

! ** This is an example of a simple contributed tool.  The only code that is required

! ** in this class is the logic that is specific to the action the tool is to perform.

 */

def class "ActionListenerExample"

      like "AbstractActionListener"

      ! Override the value to be the actual description of this observer

     local theDescription$="Simple Tool Example (no config)"

      /*

      ! ** This method will be called when the action is triggered from the

      ! ** contributed tools menu.

      ! **

      ! ** @param inActionEventID This is a reference to %JavaClass(eventmanager/ExtCommand)%

       */

      function actionPerformed(inActionEventID)   do_ActionPerformed

end def

!

do_ActionPerformed:

      enter IExtCommand

      /*

       * Write a short message to the Plug-in debug EventLog

       */

      _eventLog=new("ErrorLogBuilder",_pvxConstants,ViewManager)

      _eventLog'bufferInit()

      _eventLog'bufferAddText("Contributed tool: "+_obj'getDescription$()+$0A$)

      _eventLog'bufferWriteText()

     drop object _eventLog

      ! write a message to the 'Console' view

      aReq=new("pvxrequestclient")

      aReq'print("Contributed tool: "+_obj'getDescription$())

      drop object aReq

      ! Finally, use standard ProvideX message box to display message

      msgbox "Example contributed tool - my work is complete.","Message"

return

end


!

! Copyright (c) 2007-2010 by Sage Software Canada Ltd

def class "ConfigAppserverActionListener"

      like "AbstractActionListener"

      like "EventManagerObserver"

      ! Override values for description

      local theDescription$ = "Configure ProvideX Application Server"

      function Init()                                 init

      function ActionPerformed(inActionEventID)       action_performed

end def

init:

      _OBJ'Init( from "AbstractActionListener" )

return

! executed when selected from contributed tools menu

action_performed:

      local oCommon

      oCommon=new("ecCommon")

      oCommon'runProgram("*appserv/config",theDescription$)

      drop object oCommon

return

end


!

! Copyright (c) 2007-2010 by Sage Software Canada Ltd

def class "ConfigWebserverActionListener"

      like "AbstractActionListener"

      like "EventManagerObserver"

      ! Override values for description

      local theDescription$ = "Configure ProvideX Web Server"

      function Init()                                 init

      function ActionPerformed(inActionEventID)       action_performed

end def

init:

      _OBJ'Init( from "AbstractActionListener" )

return

! executed when selected from contributed tools menu

action_performed:

      local oCommon

      oCommon=new("ecCommon")

      oCommon'runProgram("*web/webcfg",theDescription$)

      drop object oCommon

return

end


!

! (c) Copyright 2010-2013, Sage Software Canada Ltd. (Ontario, Canada)

/*

 * Build information:

! ** @Author Fred McGuirk

! ** This observer will scan the current source file (in the build process) and

! ** remove all lines with duplicate line numbers; if the source file does not

! ** have line numbers, this observer will do nothing.

 */

def class "del_dupe_lines"

       like "EventManagerObserver"

       ! ** Private property to maintain the name of the temporary file that is created

       ! ** during the Pre-Process so that it can be deleted during the Post-Process.

       local tempSourceFile$

       ! ** Override values for description / NotificationFlag

       local theDescription$="Remove lines with duplicate line numbers"

       local theNotificationFlag=_pvxConstants'_idePrePostProcess

       ! ** Internal method to scan source file and remove remark lines with duplicate line numbers

       ! ** @param theSrcFile The source file to be processed

       ! ** @param newSrcFile The modified version of the source file

       ! ** @returns A simple boolean (0=False, 1=True) to indicate if any modifications were made

       function local processFile(theSrcFile$,newSrcFile$)                  processFile

/*

       ! ** The logic to be executed when the observer is triggered.  This logic must

       ! ** check the major and minor codes to determine the current event and then

       ! ** decide what action is to be performed.

       ! **

       ! ** If this observer is set to watch both Pre-Process and Post-Process states

       ! ** for events, the logic in the 'update' method must check the state of the

       ! ** _pvxState'getArgument(_pvxConstants'_iEventNotificationFlag$) flag to

       ! ** determine the appropriate code to be executed.

       ! **

       ! ** @param state A reference to an object of class %PvxClass(PvxState)%

 */

       function update(initPvxState)                                                     update

end def

/*

 * The update routine will be executed by the event manager during the

 * pre/post process logic depending on how this observer registers

 * itself through the getEventNotification() method.

 */

update:

enter aPvxState

       local oPvxUtility,psMajor$,psMinor$,source,tempSourceFile$,enfState,x

       ! Get the Major/Minor codes that identify the current action

       psMajor$=aPvxState'getMajor$(), \

       psMinor$=aPvxState'getMinor$()

       /*

        * This observer is for the program build event only; all other events

        * should be ignored.

        */

       if (psMajor$=_pvxConstants'Incremental_Build$ \

                     or psMajor$=_pvxConstants'Incremental_Build_Alt_Exe$) \

              and psMinor$=_pvxConstants'BuildType_BuildOne$ {

              ! Check the current state of processing for the ProvideX Event Manager

              enfState=aPvxState'getArgumentValue(_pvxConstants'_iEventNotificationFlag$)

              switch enfState

              case _pvxConstants'_idePreProcess

                     ! Get the the source file associated with the current action

                     source$=aPvxState'getArgumentValue$(_pvxConstants'SrcFile$)

                     /*

                      * Get a temporary file to be used as new source

                      */

                     oPvxUtility=new("pvx_utility")

                     tempSourceFile$=oPvxUtility'getWorkFile$("WRK_dup_lines")

                     drop object oPvxUtility

                     ! Create a new temporary file

                     serial tempSourceFile$,err=*next

                     ! Process this Source File to remove remarks and place modified version into the tempSourceFile$

                     isModified=_obj'processFile(source$,tempSourceFile$)

                     if isModified {

                           ! Update task state information to override the source file

                            aPvxState'setArgument(_pvxConstants'SrcFile$,tempSourceFile$)

                     } else {

                           erase tempSourceFile$,err=*next

                           tempSourceFile$=""

                     }

                     break

              case _pvxConstants'_idePostProcess

                     ! erase the temporary source file

                     if not(nul(tempSourceFile$)) {

                           erase tempSourceFile$,err=*next

                           tempSourceFile$=""

                     }

                     break

              end switch

       }

return 0

processFile:

       enter (theSourceFile$),(newSourceFile$),err=*next

       local lastLine,lineFeeds,thisLine,outFN,oPvxUtility,pgmLine$,pr,retVal,srcText$,theType,wrkfile$

       /* Now, to update the source file based on user preferences */

       pr=new("program_reader",theSourceFile$,err=*next)

       if pr {

              theType=pr'getSourceFileType()

              /*

               * Skip any source file that is not a test file or does not have line numbers.

               */

              if theType<>1 or not(pr'hasLineNumbers()) {

                     drop object pr; pr=0

              }

       }

       if pr {

              open lock (hfn,err=*next)newSourceFile$;

              outFN=lfo

              if outFN {

                     lastLine=0

                     oPvxUtility=new("pvx_utility")

                     /*

                      * Read through the source file and check:

                      * - source file is using line numbers

                      * - drop duplicate line number

                      */

                     while not(pr'getEOF())

                           pgmLine$=pr'read$()

                           if not(pr'getEOF()) {

                                  srcText$=pr'getSourceText$()

                                  srcText$=oPvxUtility'stripBlockComments$(srcText$)

                                  /*

                                   * Do NOT replace non-ASCII characters to allow accented

                                   * characters to remain in the final tokenized program; just

                                   * remove known control characters

                                   */

                                  srcText$=sub(srcText$,$09$," ",0) /* Replace all TAB characters */

                                  srcText$=sub(srcText$,$0D$,"",0)  /* Remove all CR characters */

                                  /*

                                   * Keep track of the number of LineFeeds in original source line;

                                   * strip the trailing linefeeds - they will be added back on later

                                   */

                                  lineFeeds=pos($0A$=srcText$,1,0)

                                  srcText$=stp(srcText$,2,$0A$)

                                  if nul(srcText$) {

                                         srcText$=""

                                  } else {

                                         /*

                                          * This logic will assume that the line number is either 4 or 5

                                          * characters in length followed by a space and will therefore

                                          * simply check the first five characters of the source line to

                                          * get the line number.  This logic can be easily changed to

                                          * look for the first space in the line and then use the value

                                          * before the space as the line number.

                                          */

                                         thisLine=num(mid(srcText$,1,5),err=*break)

                                         /*

                                          * Check:

                                          *   - line number ZERO

                                          *   - duplicate line number

                                          * If either condition is true:

                                          *   - Clear Source Text

                                          *   - Set return value to indicate source file has changed

                                          *

                                          * This logic can be easily enhanced to restrict the duplicate

                                          * line number check to only REMARK lines, for exanple by

                                          * capturing the position of the first directive in the source

                                          * line and adding a check in the condition below.

                                          */

                                         if thisLine<1 or thisLine=lastLine {

                                                srcText$="", \

                                                retVal=1

                                         }

                                         if thisLine>0 { lastLine=thisLine }

                                  }

                                  /*

                                   * Add Line Feeds to END of source text to maintain line

                                   * reference count with original source file

                                   */

                                  srcText$+=dim(lineFeeds,$0A$)

                                  write record(outFN)srcText$

                           }

                     wend

                     close (outFN)

                     drop object oPvxUtility; oPvxUtility=0

              }

              drop object pr; pr=0

       }

return retVal

end


!

! (c) Copyright 2006-2009, Sage Software Canada Ltd. (Ontario, Canada)

! *Id: ExampleObserver.pvc 484 2009-12-04 15:23:49Z fred.mcguirk *

/*

 * Build information:

! ** @Author Fred McGuirk

! ** @Date Dec 4, 2006

! ** This is an example of the observer class.

! ** The name of the observer must be unique.  It must also be used when

! ** identifying this class in the 'classes.txt' file in the./ext folder by

! ** adding a line "eventName=ExampleObserver".

! **

! ** The entries in the "classes.txt" file are loaded automatically during start

! ** of the ProvideX Event Manager.  As each class is successfully loaded, it is

! ** added the the observers preference page.  This gives the user control of the

! ** external observers (if any) that are active.

 */

/*

 * The directory 'ext/' must not be included in the name of this class.

 * The directory is in the prefix that has been set by 'ide_events.pvx' so

 * the class will be found using the simple name.

 */

def class "ExampleObserver"

      like "EventManagerObserver"

      ! Override the value to be the actual description of this observer

      local theDescription$="Example observer"

      ! Override Value to register the observer

      local theNotificationFlag=_pvxConstants'_idePostProcess

/*

      ! ** The logic to be executed when the observer is triggered.  This logic must

      ! ** check the major and minor codes to determine the current event and then

      ! ** decide what action is to be performed.

      ! **

      ! ** If this observer is set to watch both Pre-Process and Post-Process states

      ! ** for events, the logic in the 'update' method must check the state of the

      ! ** aPvxState'getArgument(_pvxConstants'_iEventNotificationFlag$) flag to

      ! ** determine the appropriate code to be executed.

      ! ** @param state A reference to an object of class %PvxClass(PvxState)%

 */

      function update(initPvxState)             update

end def

update:

enter aPvxState

      local psMajor$,psMinor$,source,dest$

      ! Get the Major/Minor codes that identify the current action

      psMajor$=aPvxState'getMajor$(), \

      psMinor$=aPvxState'getMinor$()

      /*

       * Turn on the event log to see a list of the arguments for a specific event, or

       * consult the documentation for building external observers for the list of

       * constants that have already been defined for this purpose.

       */

      ! Get the arguments from the current action that this logic will use

      reqSocket$=aPvxState'getArgumentValue$(_pvxConstants'Request_Socket$), \

      source$=aPvxState'getArgumentValue$(_pvxConstants'SrcFile$), \

      dest$=aPvxState'getArgumentValue$(_pvxConstants'Dest$)

      /*

       * It is possible to override or change the value of an existing argument...

       */

      newDest$=dest$+".tmp"

      aPvxState'setArgument(_pvxConstants'Dest$,newDest$)

      /*

       * Add logic to the specific events that this observer is watching

       *

       * This logic can be added using a SWITCH / CASE structure or a simple IF-THEN.

       *

       * In either case, the action is identified by a major and minor combination code.

       * The full list of major/minor codes is listed in the "Plug-in Structure" section

       * of the documentation for "Extending the ProvideX Plug-in".

       *

       * To keep things simple, this example will use an IF-THEN to add new logic to

       * the Incremental Build post routines.

       *

       */

      if (psMajor$=_pvxConstants'Incremental_Build$ or psMajor$=_pvxConstants'Incremental_Build_Alt_Exe$) \

            and psMinor$=_pvxConstants'BuildType_BuildOne$ {

            /*

             * The logic that is added cannot use any user-interaction directives since there

             * is usually no visible ProvideX window where this information can be displayed.

             * Also, the normal build process will be blocked until all processing has been

             * completed; a delay in an observer will affect the entire Eclipse session.

             */

            ! print a message to the CONSOLE view

            aRQ=new("pvxrequestclient",reqSocket$)

            aRQ'print("Hello, world ... in console view")

            drop object aRQ

      }

return 0

end


!

! (c) Copyright 2016, Sage Software Canada Ltd. (Ontario, Canada)

/*

 * Build information:

! ** @Author Fred McGuirk

! ** This class is written to be a "Build Post-Process" listener.

! ** It will create a list of output files (compiled programs) created by the build process and write the list

! ** to the console when the build process is complete.

 */

DEF CLASS "execModifiedFiles"

    LIKE "EventManagerObserver"

    ! ** Description to be used for tool on the Contributed Extensions / Tools Preference Page

    LOCAL theDescription$="SCT - Execute modified files in test environment"

            ! ** Event notification type: Post Event - Checks for post process events

    LOCAL theNotificationFlag=_pvxConstants'_idePostProcess

    ! ** Private property to store the list of files

    LOCAL cProcessedFiles$

    ! ** The logic to create a list of files processed by build, and perform an action for each file

    ! ** @ulist

    ! ** Initialize the list of the files when the full build starts

    ! ** In Build Post-Process for each file, add relative path of each output file to the list

    ! ** At end of Full Build, go through the list of files and print relative name to console

    ! ** @ulist_end

    ! ** @param state A reference to an object of class %PvxClass(PvxState)%

    FUNCTION update(initPvxState)                                UPDATE

END DEF

UPDATE:

    ENTER aPvxState

    LOCAL psMajor$, psMinor$, enfState, numFiles

    ! Get the Major/Minor codes that identify the current action

    psMajor$=aPvxState'getMajor$(), \

    psMinor$=aPvxState'getMinor$()

    ! Get notification state for the event

    enfState=aPvxState'getArgumentValue(_pvxConstants'_iEventNotificationFlag$)

    ! handle ALL events

    SWITCH psMajor$ + "|" + psMinor$

    ! Full Build - Start

    CASE _pvxConstants'Full_Build$ + "|" + _pvxConstants'Full_Build_Start$

        ! Must initialize data for the new build process

        cProcessedFiles$ = ""

        BREAK

    ! Full Build - End

    CASE _pvxConstants'Full_Build$ + "|" + _pvxConstants'Full_Build_End$

        ! check for alternate START_UP program and execute

        altStartPgm$ = aPvxState'getArgumentValue$(_pvxConstants'_ibAltStartUp$);

        IF NOT(NUL(altStartPgm$)) {

            CALL altStartPgm$, ERR=*NEXT

        }

        ! Process all files in the list

        numFiles = pos(","=STP(cProcessedFiles$, 2, ",") + ",", 1, 0)

        DIM theFiles$[1:numFiles]

        READ DATA FROM STP(cProcessedFiles$, 2, ","), SEP="," TO theFiles$[ALL]

        ! Use request client class to write a message to the 'Console' view

        aReq=NEW("pvxrequestclient")

        FOR aFile = 1 TO numFiles

            aReq'print("Process File: " + theFiles$[aFile])

            ! TODO: What should we do with this file?

        NEXT aFile

        ! Clean-up

        cProcessedFiles$ = ""

        DROP OBJECT aReq

        BREAK

    ! Build a ProvideX program

    CASE _pvxConstants'Incremental_Build$ + "|" + _pvxConstants'BuildType_BuildOne$

    CASE _pvxConstants'Incremental_Build_Alt_Exe$ + "|" + _pvxConstants'BuildType_BuildOne$

        ! Get the arguments from the current action that this logic will use

        eventDestFile$   = aPvxState'getArgumentValue$(_pvxConstants'Dest$)

        projectRootDir$  = aPvxState'getArgumentValue$(_pvxConstants'Project_Root$)

        ! Set output folder for project - using fixed value

        projectOutDir$   = projectRootDir$ + dlm + "compiled" + dlm

        ! get relative path for destination file in the output folder

        destFileRelPath$ = MID(eventDestFile$, LEN(projectOutDir$))

        ! TODO: Should we check the file extension before adding to the list?

        ! Add relative path of output file to the list

        cProcessedFiles$ += TBL(NUL(cProcessedFiles$), ",", "") + destFileRelPath$

        BREAK

    END SWITCH

    RETURN 0

END


! simpleStyleCheck.pvc - simple client component for Style Check Contributed Tool
! Copyright (c) 2008-2010 Sage Software Canada Ltd. All Rights Reserved
!
! ** This class is required on each client workstation to enable the SytleCheck
! ** capability that is included in the ProvideX plug-in in the class %PvxClass(ecStyleCheck)%.
! **
! ** This class does not extend any of the standard functionality - simply overrides the
! ** location of the rules file and description of the contributed tool.
! **

def class "simpleStyleCheck" create required
      like "ecStyleCheck"

      ! ** specify the full path to the location of the file that contains the style rules
      local styleRulesFile$=mid(pgn,1,pos(dlm=pgn,-1))+_obj'_Class$+"_rules.txt"
      local theDescription$="Simple rule-based Style Check"

end def

on_create:
      ! Use the method from the parent class to load the rules
      _obj'loadRules(from "ecStyleCheck",styleRulesFile$)
return

end


!

! $Id: set_copyright_year.pvc.pvt 3093 2022-06-16 16:27:03Z fmcguirk $

! (c) Copyright 2006-%(copyright-year)%, Sage Software Canada Ltd. (Ontario, Canada)

/*

 * Build information:

! ** @Author Fred McGuirk

! ** @Date Nov 22, 2007

! ** @OutputFile set_copyright_year.pvc

! ** This observer will change the value for copyright year prior to creating a new

! ** build of an application.

! **

! ** This program searches for '%(copyright-year)%' within the first 100 characters

! ** of the source file and will replace it with the current year.  It will then

! ** create a temporary file to be used as an alternative source file which will be

! ** deleted during the PostProcess of the build by this same observer.

 */

def class "set_copyright_year"

    like "EventManagerObserver"

    ! Override values for description / NotificationFlag

    local theDescription$= \

        "Substitute modification year of source file for 'Copyright-year' tag."

    local theNotificationFlag=_pvxConstants'_idePrePostProcess

    ! ** Private property to track if source file was modified

    local isModified

    /*

    ! ** The logic to be executed when the observer is triggered.

    ! ** @param initPvxState A reference to an object of class %PvxClass(PvxState)%

     */

    function update(initPvxState)                                    update

    /*

    ! ** Private function to do the work; used to keep the example simple

    ! ** @param initPvxState A reference to an object of class %PvxClass(PvxState)%

    ! ** @param outFile$ Name of output file to be created if source  modified

    ! ** @returns [boolean] True if source modified

     */

    function local update_copyright_year(initPvxState,outFile$)        update_copyright_year

end def

/*

 * The update routine will be executed by the event manager during the

 * pre/post process logic depending on how this observer registers

 * itself through the getEventNotification() method.

 */

update:

    enter aPvxState

    local psMajor$,psMinor$,enfState

    ! Get the Major/Minor codes that identify the current action

    psMajor$=aPvxState'getMajor$(), \

    psMinor$=aPvxState'getMinor$()

    ! Get the current state of processing for the ProvideX Event Manager

    enfState=aPvxState'getArgumentValue(_pvxConstants'_iEventNotificationFlag$)

    /*

     * This observer is for the program build event only; all other events

     * should be ignored.

     */

    switch psMajor$ + "|" + psMinor$

    ! Build a ProvideX program

    case _pvxConstants'Incremental_Build$ + "|" + _pvxConstants'BuildType_BuildOne$

    case _pvxConstants'Incremental_Build_Alt_Exe$ + "|" + _pvxConstants'BuildType_BuildOne$

        switch enfState

        case _pvxConstants'_idePreProcess

            isModified = _obj'update_copyright_year(aPvxState, outFile$)

            ! Set the current source file to the new output file

            if isModified {

                _obj'setCurrentSource(aPvxState, outFile$)

            }

            break

        case _pvxConstants'_idePostProcess

            ! write status message

            oReqClient = NEW( "pvxrequestclient")

            oReqClient'print(_obj'getDescription$()+": " + tbl(isModified, "no change", "updated"))

            drop object oReqClient

            break

        end switch

        break

    end switch

return 0

update_copyright_year:

    enter (aPvxState), altSrcFile$

    local retVal, reqSocket$, dest$, source$, sourceFN, fileSize, utcMtime, \

            theFile$, found, x, tempFN, retVal

    /*

     * Read the source file, check the first 100 characters for the

     * copyright year tag, replace with the current year, create a temporary

     * file and write the new source into it.

     */

    source$=aPvxState'getArgumentValue$(_pvxConstants'SrcFile$)

    open input (hfn,isz=1,err=*next)source$;

    sourceFN=lfo

    if sourceFN {

        fileSize=num(fin(sourceFN,"records_used")), \

        utcMtime=num(fin(sourceFN,"UTC_MTime"),err=*next)

        ! Use year from modification time of source file

        if utcMtime>0 then \

            utcMtime=int(utcMtime/86400)

        read (sourceFN,siz=fileSize+1,err=*next)theFile$

        close (sourceFN);

        sourceFN=0

        if not(nul(theFile$)) {

            ! Check the first 1000 characters of the source file for the tag

            found=pos("%(copyright-year)%"=lcs(mid(theFile$,1,1000)))

            if found {

                ! Substitute the modification year in place of the tag

                theFile$= \

                    mid(theFile$,1,found-1)+dte(utcMtime:"%Y")+ \

                    mid(theFile$,found+18)

                /*

                 * Get a temporary file to be used as new source

                 */

                x=new("pvx_utility")

                tempSourceFile$=x'getWorkFile$("WRK_set_copyright_date")

                drop object x

                ! Create a new temporary file

                serial tempSourceFile$,err=*next;

                open lock (hfn,err=*next)tempSourceFile$;

                tempFN=lfo

                ! Update the information for the temporary source file

                if tempFN {

                    ! Write the information to the temporary source file

                    write record (tempFN,err=*next)theFile$;

                    close (tempFN)

                }

                retVal = 1

            }

        }

    }

    return retVal

end


!

! (c) Copyright 2006-%(copyright-year)%, Sage Software Canada Ltd. (Ontario, Canada)

! $Id: set_mod_timestamp.pvc.pvt 2352 2019-03-05 18:03:33Z fmcguirk $

/*

 * Build information:

! ** @Author Fred McGuirk

! ** @Date Nov 22, 2007

! ** @OutputFile set_mod_timestamp.pvc

! ** This observer will set the modification timestamp of the output file to be

! ** the same as the source file.

! **

! ** This program uses the Eclipse IResource class to get and set the timestamps.

 */

def class "set_mod_timestamp"

    like "EventManagerObserver"

    ! Override values for description / NotificationFlag

    local theDescription$= \

        "Set modification timestamp of output file to be the same as source file"

    local theNotificationFlag=_pvxConstants'_idePostProcess

    ! ** Private property to maintain the name of the temporary file that is created

    ! ** during the Pre-Process so that it can be deleted during the Post-Process.

    local tempSourceFile$

/*

    ! ** The logic to be executed when the observer is triggered.

    ! ** @param state A reference to an object of class %PvxClass(PvxState)%

 */

    function update(initPvxState)            update

end def

/*

 * The update routine will be executed by the event manager during the

 * pre/post process logic depending on how this observer registers

 * itself through the getEventNotification() method.

 */

update:

enter aPvxState

    local psMajor$,psMinor$,source,dest$,enfState,x,destObj,fileObj,projObj,sysType$, \

        utcMTime,secondsIntoDay,dayHours,dayMinutes,daySeconds,julDay,theCmd$

    ! Get the Major/Minor codes that identify the current action

    psMajor$=aPvxState'getMajor$(), \

    psMinor$=aPvxState'getMinor$()

    /*

     * This observer is for the program build event only; all other events

     * should be ignored.

     */

    if (psMajor$=_pvxConstants'Incremental_Build$ \

            or psMajor$=_pvxConstants'Incremental_Build_Alt_Exe$) \

        and psMinor$=_pvxConstants'BuildType_BuildOne$ {

        ! Check the current state of processing for the ProvideX Event Manager

        enfState=aPvxState'getArgumentValue(_pvxConstants'_iEventNotificationFlag$)

        switch enfState

        case _pvxConstants'_idePostProcess

            ! Get the arguments from the current action that this logic will use

            eventSourceFile$=aPvxState'getArgumentValue$(_pvxConstants'event_SrcFile$), \

            dest$=aPvxState'getArgumentValue$(_pvxConstants'Dest$)

            ! Get the modification date of the original event source file and

            ! Set the modification date of the output file to be the same

            sysType$=sys

            if pos("LINUX"=ucs(sysType$))>0 then \

                sysType$="Linux"

            switch sysType$

            case "MS-WINDOWS"

                ! Set control values for DLL call

                access_rw=dec(ior($80000000$,$40000000$)), \

                share_rw=1+3, \

                open_existing=3, \

                file_attr_normal=128

                ! Load the MS-Windows 'kernel32.dll' into memory

                ! (since it will be used several times)

                aDLL=dll(addr "kernel32")

                ! Get a handle to the source file

                hSrc=dll(aDLL,"CreateFileA",eventSourceFile$+$00$,access_rw,share_rw,0, \

                        open_existing,file_attr_normal,0)

                dim aSrc$[1:3](8,$00$)

                ! Get creation, access, and modification times for source file

                status=dll(aDLL,"GetFileTime",hSrc,aSrc$[1],aSrc$[2],aSrc$[3])

                ! Close reference to file

                status=dll(aDLL,"CloseHandle",hSrc)

                if status=1 {

                    ! Get a handle to the destination file

                    hDest=dll(aDLL,"CreateFileA",dest$+$00$,access_rw,share_rw,0, \

                            open_existing,file_attr_normal,0)

                    dim aDest$[1:3](8,$00$)

                    ! Get creation, access, and modification times for destination file

                    status=dll(aDLL,"GetFileTime",hDest,aDest$[1],aDest$[2],aDest$[3])

                    ! change the modification time of the destination

                    aDest$[3]=aSrc$[3]

                    ! Set the new times for the destination file

                    status=dll(aDLL,"SetFileTime",hDest,aDest$[1],aDest$[2],aDest$[3])

                    ! Close reference to file

                    status=dll(aDLL,"CloseHandle",hDest)

                }

                ! remove the "kernel32.dll" from memory.

                s=dll(drop aDLL)

                break

            case "Linux"

                open input (hfn,isz=1,err=*break)eventSourceFile$

                utcMTime=num(fin(lfo,"UTC_Mtime",err=*next))

                close (lfo)

                if utcMTime>0 {

                    julDay=int(utcMTime/86400), \

                    secondsIntoDay=utcMTime-(julDay*86400)-tcb(44), \

                    dayHours=int(secondsIntoDay/3600), \

                    dayMinutes=int(secondsIntoDay/60)-(dayHours*60), \

                    daySeconds=secondsIntoDay-dayHours*3600-dayMinutes*60

                    theCmd$="touch -t "+dte(julDay:"%Y%Mz%Dz")+ \

                        str(dayHours:"00")+str(dayMinutes:"00")+ \

                        "."+str(daySeconds:"00")+" "+dest$

                    x=sys(theCmd$)

                }

                break

            end switch

            oReqClient = NEW( "pvxrequestclient")

            oReqClient'print(_obj'getDescription$()+": Complete")

            drop object oReqClient

            break

        end switch

    }

return 0

end


! showtext.pvc

! $Id: showtext.pvc.pvxsrc 32450 2019-09-13 20:56:26Z fmcguirk $

! ** This class is written to be a "Event Pre/Post-Process" listener to print a simple

! ** message to the console the pre/post-process for every event.

def class "showtext"

    like "EventManagerObserver"

    ! ** Description to be used for tool on the Contributed Extensions / Tools Preference Page

    local theDescription$="SCT - Show message in Console"

    ! ** Register the events for this observer (both PreProcess and PostProcess)

    local theNotificationFlag=_pvxConstants'_idePrePostProcess

    /*

    ! ** The logic to be executed when the observer is triggered during the normal event process in the

    ! ** ProvideX event manager.  This logic will check the major and minor codes to determine the

    ! ** current event and then decide what action is to be performed.

    ! ** @param state A reference to an object of class %PvxClass(PvxState)%

     */

    function update(initPvxState)            update

end def

update:

enter aPvxState

    local psMajor$,psMinor$,enfState

    local procPfx$

    ! Get the Major/Minor codes that identify the current action

    psMajor$=aPvxState'getMajor$(), \

    psMinor$=aPvxState'getMinor$()

    ! Get notification state for the event

    enfState=aPvxState'getArgumentValue(_pvxConstants'_iEventNotificationFlag$)

    ! handle ALL events

    switch psMajor$ + "|" + psMinor$

    ! Build a ProvideX program

    case _pvxConstants'Incremental_Build$ + "|" + _pvxConstants'BuildType_BuildOne$

    case _pvxConstants'Incremental_Build_Alt_Exe$ + "|" + _pvxConstants'BuildType_BuildOne$

    ! Build a NOMADS Library

    case _pvxConstants'Incremental_Build$ + "|" + _pvxConstants'Buildtype_NomadsLIB$

    case _pvxConstants'Incremental_Build_Alt_Exe$ + "|" + _pvxConstants'Buildtype_NomadsLIB$

    default

        switch enfState

        case _pvxConstants'_idePreProcess

            procPfx$="pre"

            break

        case _pvxConstants'_idePostProcess

            procPfx$="post"

            break

        end switch

        ! Use request client class to write a message to the 'Console' view

        aReq=new("pvxrequestclient")

        aReq'print("ShowText: A "+procPfx$+"-process for "+psMajor$+"/"+psMinor$)

        drop object aReq

        break

    end switch

return 0

end


! simpleStyleCheck.pvc - simple client component for Style Check Contributed Tool

! Copyright (c) 2008-2010 Sage Software Canada Ltd. All Rights Reserved

!

! ** This class is required on each client workstation to enable the SytleCheck

! ** capability that is included in the ProvideX plug-in in the class %PvxClass(ecStyleCheck)%.

! **

! ** This class does not extend any of the standard functionality - simply overrides the

! ** location of the rules file and description of the contributed tool.

! **

def class "simpleStyleCheck" create required

      like "ecStyleCheck"

      ! ** specify the name of the file that contains the style rules

      ! ** default value: %PvxCode(mid(pgn,1,pos(dlm=pgn,-1))+_obj'_Class$+"_rules.txt")%

     local styleRulesFile$=mid(pgn,1,pos(dlm=pgn,-1))+_obj'_Class$+"_rules.txt"

      ! ** Override Description

      local theDescription$="Simple rule-based Style Check"

end def

on_create:

      ! Use the method from the parent class to load the rules

      _obj'loadRules(from "ecStyleCheck",styleRulesFile$)

return

end


!

! Copyright (c) 2011 Sage Software. All Rights Reserved

! ** @Author fmcguirk

! ** @Date 2011.04.25 18 at 05:00:17 PM EDT

!

def class "stripTrailing_Listener"

      like "AbstractActionListener"

      local theDescription$ = "Strip trailing white space"

      local cTitle$         = "Strip Trailing White Space"

      local cUI$            = "stripTrailing_UI"

      /*

      ! ** This method will be called when the action is triggered from the contributed

      ! ** tools menu.

      ! **

      ! ** @param inActionEventID This is a reference to %JavaClass(eventmanager/ExtCommand)%

       */

      function actionPerformed(inActionEventID)                        do_ActionPerformed

end def

do_ActionPerformed:

enter (IExtCommand)

      local oCommon

      oCommon=new("ecCommon")

      oCommon'processPanel(cUI$,cTitle$)

      drop object oCommon

return

end


!

! $Id: stripTrailing_UI.pvc.pvt 3093 2022-06-16 16:27:03Z fmcguirk $

! Copyright (c) 2011 Sage Software. All Rights Reserved

! ** @Author fmcguirk

! ** @Date 2011.04.25 18 at 04:10:34 PM EDT

/*

! ** This observer will scan the source files selected in the Navigator view and

! ** remove all trailing white space from each source line.

 */

def class "stripTrailing_UI"

    like "com.pvx.util.progress"

    ! ** Set the caption for the user interface window

    local theCaption$         = "Strip Trailing Whitespace"

    ! ** Override Description

    local theDescription$="Strip trailing white space"

    ! ** Override NotificationFlag

    local theNotificationFlag=_pvxConstants'_idePrePostProcess

    ! ** A private method that performs the tasks required by the contributed tool

    function local doWork()                                        do_work

end def

do_work:

    local isModified, oPvxUtility, oResList, oStrip, oUtility, resource, \

        resList, resLocation$, resName$, resPath$, tempWorkFile$, theStatus$

    /* Process resources selected in Navigation View */

    oResList=new("ecWorkspaceResourceReader",2)

    if oResList<>0 {

        resource=oResList'resource_getNext()

        if not(resource) {

            info$=msg("nav_view_no_resource")

            _obj'writeLog(info$)

        }

    } else {

        info$=msg("nav_view_no_resource")

        _obj'writeLog(info$)

    }

    /* Get auto-build state and disable if necessary */

    if resource {

        oPvxUtility=new("pvx_utility")

        oUtility=new("ecUtility")

        autoBuild=oUtility'isAutoBuilding()

        if autoBuild {

            oUtility'setAutoBuilding(0)

        }

        _obj'enable_cancel()

    }

    oStrip = new("stripTrailing")

    while resource<>0

        oResList'resource_getInfo(resource,resName$,resLocation$,resPath$)

        ! Process this Source File to remove remarks and place modified version into the tempSourceFile$

        isModified=oStrip'processFile(resLocation$,altSource$)

        if isModified {

            bEraseOK     = 1, \

            bSkipRefresh = 1

            oUtils = new("pvx_utility")

            oUtils'copyFile(altSource$, resLocation$, bEraseOK, bSkipRefresh)

            drop object oUtils, err=*proceed; oUtils= 0

            theStatus$  = "Updated"

            coReqClient'resource_refresh(resLocation$)

        } else {

            theStatus$  = "No change"

        }

        _obj'writeLog(resName$+"... "+theStatus$)

        ! Allow for CANCEL of processing

        isCancelled = _obj'checkCancel()

        if isCancelled {

            tmpCANCEL = 1

            break

        }

        ! Get the next resource to process

        resource=oResList'resource_getNext()

    wend

    /* Turn auto-build back on, if necessary */

    if autoBuild {

        oUtility'setAutoBuilding(1)

    }

    if oStrip      { drop object oStrip;      oStrip      = 0 }

    if oUtility    { drop object oUtility;    oUtility    = 0 }

    if oPvxUtility { drop object oPvxUtility; oPvxUtility = 0 }

    drop object oResList; oResList=0

return 0

end


! $Id: toolConfigAndProgress_Config_ui.pvc.pvxsrc 41885 2022-03-09 14:56:24Z fmcguirk $

! Description of program

! $Copyright:$

def class "toolConfigAndProgress_Config_ui" create required delete required

    ! Inherits from the following class(es)

    like "ecCommonUI"

    ! Local/Private Properties

    ! ** [object] Reference to local instance of ecCommon

    local coCommon

    ! ** [string] prefix to use for data values in Eclipse data store

    local cPrefStorePfx$ = "toolConfigAndProgress"

    ! ** [string] List of fields names of data values managed by form

    local cDataVars$ = "workDesc$,workUnits,workDelay"

    ! Public Properties

    ! ** Initial panel to be loaded for the configuration information

    property screen_id$="dConfig"

    ! ** The library for the panel definitions

    property screen_lib$="toolConfigAndProgress.M4L"

    ! Public Functions (Methods)

    ! ** Set default values for fields

    function SetDefaults()                            set_defaults

    ! Local/Private Functions (Methods)

    ! ** Method that is executed when the 'Cancel' button is pressed.

    function local bt_cancel()                        bt_cancel

    ! ** Method that is executed when the 'OK' button is pressed.

    function local bt_ok()                            bt_ok

    ! ** Method  called when WorkDesc field changes

    function local ChangeWorkDesc()                   Change_Work_Desc

    ! ** Method  called when WorkDelay field changes

    function local ChangeWorkDelay()                  Change_Work_Delay

    ! ** Method  called when WorkUnits field changes

    function local ChangeWorkUnits()                  Change_Work_Units

    ! ** Method call after panel loaded

    function local PostLoad()                         post_load

end def

On_Create:

    coCommon = new("ecCommon")

    return

on_delete:

    drop object coCommon, err=*proceed; coCommon = 0

    return

bt_cancel:

    exitStatus = 1

    CMD_STR$   = "END"

    return 1

bt_ok:

    ! Save field list and data values to Eclipse preference store

    coCommon'Prefs("Set", cPrefStorePfx$+"_Fields", cDataVars$)

    coCommon'Prefs("Set", cPrefStorePfx$+"_Data", rec(cpl("iolist " + cDataVars$)))

    exitStatus = 1

    CMD_STR$   = "END"

    return 1

Change_Work_Desc:

    ! Perform data checks, if necessary

    return 1

Change_Work_Delay:

    ! Only allow value between 2 and 10

    retVal = (workDelay > 1 and workDelay <= 10)

    return retVal

Change_Work_Units:

    ! Only allow value between 2 and 10

    retVal = (workUnits > 1 and workUnits <= 10)

    return retVal

post_load:

    local dataRec$, dataVars$

    ! Get field list and data to Eclipse preference store

    coCommon'Prefs("Get", cPrefStorePfx$+"_Fields", dataVars$)

    coCommon'Prefs("Get", cPrefStorePfx$+"_Data",   dataRec$)

    ! First, clear expecterd data variable values

    read data from $$ to iol=cpl("iolist " + cDataVars$)

    ! Second, set data values retrieved from Eclipse preference store

    if not(nul(dataRec$)) and not(nul(dataVars$)) {

        read data from dataRec$ to iol=cpl("iolist " + dataVars$)

    }

    return 1

set_defaults:

    local dataVars$, dataRec$

    ! Get field list and data to Eclipse preference store

    coCommon'Prefs("Get", cPrefStorePfx$+"_Fields", dataVars$)

    coCommon'Prefs("Get", cPrefStorePfx$+"_Data",   dataRec$)

    if nul(dataVars$) or nul(dataRec$) {

        dataRec$ = "Work" + SEP + "2" + SEP + "2"

        ! Save field list and data values to Eclipse preference store

        coCommon'Prefs("Set", cPrefStorePfx$+"_Fields", cDataVars$)

        coCommon'Prefs("Set", cPrefStorePfx$+"_Data", dataRec$)

    }

    return 1


! $Id: toolConfigAndProgress_Listener.pvc.pvxsrc 41872 2022-03-05 19:37:44Z fmcguirk $

! Example Contributed Tool: Tool with configuration and progress - Listener

def class "toolConfigAndProgress_Listener" create required

    like "AbstractActionListener"

    ! ** Description to be used for tool in the Contributed Tools list

    local theDescription$ ="Example - With Config and Progress"

    local cRunTitle$      = "Example - WCaP Progress"

    local cRunUI$         = "toolConfigAndProgress_Run_ui"

    local cConfigTitle$   = "Example - WCaP Config"

    local cConfigUI$      = "toolConfigAndProgress_Config_ui"

    ! ** This method will be called when the action is triggered from the contributed tools menu.

    ! ** @param inActionEventID This is a reference to %JavaClass(eventmanager/ExtCommand)%

    function actionPerformed(inActionEventID)                do_ActionPerformed

    ! ** This method will be called when the 'Configure' action is triggered from

    ! ** the contributed tools menu.  The code required to implement the configuration

    ! ** action is normally implemented as one or more NOMADS panels that this

    ! ** method will execute.

    ! **

    ! ** @param inActionEventID This is a reference to %JavaClass(eventmanager/ExtCommand)%

    function configPerformed(inActionEventID)                do_ConfigPerformed

    ! ** This method is used to check whether a configuration action has been implemented.

    ! ** @returns True (1) if a configuration action has been implemented

    function hasConfigAction()                                hasConfigAction

end def

On_Create:

    local oConfig

    ! Set the default stored values

    oConfig = new("toolConfigAndProgress_Config_ui", err=*next)

    if oConfig {

        oConfig'SetDefaults()

        drop object oConfig, err=*proceed; oConfig = 0

    }

    return

do_ActionPerformed:

    enter IExtCommand

    local oCommon

    oCommon=new("ecCommon")

    oCommon'processPanel(cRunUI$, cRunTitle$)

    drop object oCommon

return

do_ConfigPerformed:

    local oCommon

    oCommon=new("ecCommon")

    oCommon'ConfigGuiDisplay()

    oCommon'processPanel(cConfigUI$, cConfigTitle$)

    drop object oCommon

return

hasConfigAction:

    ! Return True (1) since the configuration action logic has been implemented

    return 1

end


! $Id: toolConfigAndProgress_Run_ui.pvc.pvxsrc 42051 2022-03-30 00:12:45Z fmcguirk $

! Example Contributed Tool: Tool with configuration and progress - Run Action UI

def class "toolConfigAndProgress_Run_ui" create required delete required

    like "com.pvx.util.progress"

    ! ** Set the caption for the user interface window

    local theCaption$         = "Example - WCaP Progress"

    ! ** Override Description

    local theDescription$     = "Example - WCaP Run Action"

    ! ** Override NotificationFlag

    local theNotificationFlag = _pvxConstants'_ideNone

    ! ** [object] Reference to local instance of ecCommon

    local coCommon

    ! ** [string] prefix to use for data values in Eclipse data store

    local cPrefStorePfx$ = "toolConfigAndProgress"

    ! ** Method that is executed when the 'Special' button is pressed.

    function local b_special()                            b_special

    ! ** A private method that performs the tasks required by the contributed tool

    function local doWork()                                do_work

end def

On_Create:

    coCommon = new("ecCommon")

    return

On_Delete:

    drop object coCommon, err=*proceed; coCommon = 0

    return

b_special:

    msgbox "Woo Hoo!", "Woo Hoo!", "OK,Top,Beep"

    return

do_work:

    _obj'writeLog("Starting work...")

    ! Get field list and data to Eclipse preference store

    _obj'writeLog("... Load saved configuration data")

    coCommon'Prefs("Get", cPrefStorePfx$+"_Fields", dataVars$)

    coCommon'Prefs("Get", cPrefStorePfx$+"_Data",   dataRec$)

    if not(nul(dataRec$)) and not(nul(dataVars$)) {

        read data from dataRec$ to iol=cpl("iolist " + dataVars$)

    } else {

        workDesc$ = "work"

        workUnits = 4

        workDelay = 2

    }

    _obj'writeLog("... Work Description    : " + workDesc$)

    _obj'writeLog("... Work Units          : " + str(workUnits))

    _obj'writeLog("... Work Delay (seconds): " + str(workDelay))

    ! Disable Cancel of the process

    _obj'disable_cancel()

    if workUnits>0 {

        workUnitAmount = 100 / workUnits

        for loop = 1 to workUnits

            ! Update status

            _obj'writeLog("... " + workDesc$ + " .. " + str(workUnitAmount * loop))

            ! Allow for CANCEL of processing

            isCancelled = _obj'checkCancel()

            if isCancelled {

                break

            }

            ! Enable Cancel of the process

            if loop=1 {

                _obj'enable_cancel()

            } else {

                if loop=workUnits-1 {

                    _obj'disable_cancel()

                }

            }

            ! Pretend to do something

            wait workDelay

        next loop

        if isCancelled {

            _obj'writeLog(workDesc$ + " cancelled for today")

        } else {

            _obj'writeLog(workDesc$ + " complete for another day")

        }

    } else {

        _obj'writeLog(workDesc$ + " no work planned for the day")

    }

    if not(isCancelled) {

        _obj'enable_special("WooHoo!")

    }

    return


!

! Copyright (c) 2011 Sage Software. All Rights Reserved

! ** @Author fmcguirk

! ** @Date 2011.11.29 49 at 01:19:57 PM EST

!

DEF CLASS "toolWithConfig"

    like "AbstractActionListener"

    ! ** Description to be used for tool in the Contributed Tools list

    local theDescription$="Example - With config"

    /*

    ! ** This method will be called when the action is triggered from the contributed

    ! ** tools menu.

    ! **

    ! ** @param inActionEventID This is a reference to %JavaClass(eventmanager/ExtCommand)%

     */

    function actionPerformed(inActionEventID)                do_ActionPerformed

    /*

    ! ** This method will be called when the 'Configure' action is triggered from

    ! ** the contributed tools menu.  The code required to implement the configuration

    ! ** action is normally implemented as one or more NOMADS panels that this

    ! ** method will execute.

    ! **

    ! ** @param inActionEventID This is a reference to %JavaClass(eventmanager/ExtCommand)%

     */

    function configPerformed(inActionEventID)                do_ConfigPerformed

    /*

    ! ** This method is used to check whether a configuration action has been implemented.

    ! ** @returns True (1) if a configuration action has been implemented

     */

    function hasConfigAction()                                hasConfigAction

end def

do_ActionPerformed:

    enter IExtCommand

    ! write a message to the 'Console' view

    aReq=new("pvxrequestclient")

    aReq'print("Contributed tool: " + _obj'getDescription$() + " - Action completed.")

    drop object aReq

    ! Finally, use standard ProvideX message box to display message

    msgbox "Example contributed tool - my work is complete.","Message"                /* *SC-OK* */

return

do_ConfigPerformed:

    ! write a message to the 'Console' view

    aReq=new("pvxrequestclient")

    aReq'print("Contributed tool: " + _obj'getDescription$() + " - Configuration completed.")

    drop object aReq

    msgbox "Example contributed tool - configuration is complete.","Message"        /* *SC-OK* */

return

hasConfigAction:

    ! Return True (1) since the configuration action logic has been implemented

    return 1

end


!

! (c) Copyright 2006, Sage Software Canada Ltd. (Ontario, Canada)

! %Id: XML_Convert.pvc.pvt,v 1.25 2007/05/16 12:54:19 fred.mcguirk Exp %

/*

 * Build information:

! ** @Author Fred McGuirk

! ** @Date Feb 6, 2007

! ** @Password

! ** @Owner

! ** @Flags

! ** @OutputFile XML_Convert.pvc

! ** @ForceLineNumbers  false

! ** This is a Post-Process observer that will convert ProvideX data files to/from XML.  It will also

! ** be registered as a contributed tool and will be added to that list under the 'ProvideX' item on

! ** the menu bar.

! ** @LIKE

! ** @TODO

 */

!

def class "XML_Convert"

      like "EventManagerObserver"

      like "AbstractActionListener"

      /*

      ! ** This method will be called when the action is triggered from the contributed tools menu.

      ! **

      ! ** @param inActionEventID This is a reference to %JavaClass(eventmanager/ExtCommand)%

       */

      function actionPerformed(inActionEventID)   do_ActionPerformed

      ! ** This method is used to describe the purpose of this observer.  The text will be placed on the observers preference page to describe and should be limited to 80 characters (at most).

      function getDescription$()                            getDescription

      /*

      ! ** Get the flag that will be used to trigger the 'update()' method during execution of the built-in events for the plug-in.

      ! **

      ! ** If this observer is not a Post-process observer, the return value of this method should be set to one of the following values:

      ! ** @value _pvxConstants'_ideNone           Do not register as an observer

      ! ** @value _pvxConstants'_idePreProcess     Register as a Pre-Process observer

      ! ** @value _pvxConstants'_idePrePostProcess Register as both a Pre-Process and Post-Process observer.

      ! ** @value _pvxConstants'_idePostProcess    Register as a Post-Process observer

       */

      function getEventNotificationFlag()             getEventNotificationFlag

      ! ** Initialize an observer.

      function init()                                             init

      ! ** The logic to be executed when the observer is triggered.  This logic must check the major and minor codes to determine the current event and then decide what action is to be performed.

      ! **

      ! ** @param initPvxState A reference to an object of class %PvxClass(PvxState)%

      function update(initPvxState)                   update

      /*

      ! ** Convert the specified ProvideX keyed file to XML.

      ! ** @param aFile$ The name of the ProvideX keyed file to be converted.

       */

      function local data2xml(aFile$)                       data2xml

      /*

      ! ** Convert the specified XML file to a ProvideX keyed file.

      ! ** @param theSource$ The name of the XML file to be converted.

       */

      function local xml2 data(theSource$)                   xml2 data

      /*

      ! ** Convert the specified XML file to a ProvideX keyed file.

      ! ** @param theSource$ The name of the XML file to be converted.

      ! ** @param theDest$ The name of the XML file to be converted.

       */

      function local xml2 data(theSource$,theDest$)    xml2 data

end def

init:

      _obj'init(from "AbstractActionListener")

return

do_ActionPerformed:

      enter IExtCommand

      local resPath$,_TMP,_TMP$

      /* define a reference to the java Resource Manager */

      def object resManager,"[wdx]com.pvx.ooadide.eventmanager.ResourceManager"

      /* Create a local reference to the EventLog */

      _eventLog=new("ErrorLogBuilder",_pvxConstants,ViewManager)

      _eventLog'bufferInit()

      _eventLog'bufferAddText("Contributed action: "+_obj'getDescription$()+$0A$)

      /* Get the name of the source resource from the Resource Manager */

      resource = resManager'getSelectedResourceInNavigator()

      if resource<>0 {

            resPath$=resManager'getPathToSelectedResourceInNavigator$()

            if resource'getType()<>resource'FOLDER {

                  _TMP$="", \

                  _TMP=0;

                  open input(hfn,isz=1,err=*next)resPath$;

                  _TMP=lfo;

                  read record (_TMP,ind=0,siz=8,err=*next)_TMP$

                  if _TMP>0 \

                  then close (_TMP)

                  if pos(_TMP$="[Pvxkey][Pvxky2]",8)>0 {

                        _obj'data2xml(resPath$)

                  } else {

                        if lcs(mid(resPath$,-4))=".xml" {

                              _obj'xml2 data(resPath$)

                        }

                  }

                  /* Force a refresh of Navigation view (DEPTH_ONE, DEPTH_INFINITE, DEPTH_ZERO) */

                  resource'refreshLocal(resource'DEPTH_ZERO,*-1)

            }

      }

      drop object resManager

      drop object _eventLog

return

getDescription:

      ! Change the value to be the actual description of this observer

      local theDescription$="Convert ProvideX keyed files to/from XML"

return theDescription$

! get Event Notification Flag

getEventNotificationFlag:

return _pvxConstants'_idePostProcess

update:

enter aPvxState

      /*

       * This observer is triggered when an incremental build is initiated on a

       * data file.

       *

       * If the source file ends with the XML extension, it will be converted to

       * a PVX keyed file.  Otherwise, the file header is read to verify that this

       * is in fact a PVX keyed file and then it is converted to XML.

       */

      /* Get the major/minor codes for this event. */

      psMajor$=aPvxState'getMajor$(), \

      psMinor$=aPvxState'getMinor$()

      /* Get the parameters that were passed into this event. */

      source$=aPvxState'getArgumentValue$(_pvxConstants'SrcFile$), \

      dest$=aPvxState'getArgumentValue$(_pvxConstants'Dest$), \

      domFile$=aPvxState'getArgumentValue$(_pvxConstants'DomFile$), \

      passwd$=aPvxState'getArgumentValue$(_pvxConstants'pkf_Password$), \

      passwd_type$=aPvxState'getArgumentValue$(_pvxConstants'_iPasswordType$)

      /* Create a local reference to the EventLog */

      _eventLog=new("ErrorLogBuilder",_pvxConstants,ViewManager)

      _eventLog'bufferInit()

      _eventLog'bufferAddText("["+psMajor$+"]"+$0A$+"==>"+psMinor$+"<=="+$0A$)

      switch psMajor$

      case _pvxConstants'Incremental_Build$

            switch psMinor$

            /* Convert a ProvideX data file to XML */

            case _pvxConstants'BuildType_DataFile$

                  _obj'data2xml(source$)

                  break

            /* Convert a XML to ProvideX data file */

            case _pvxConstants'BuildType_OtherFile$

                  _obj'xml2 data(source$,dest$)

                  break

            end switch

            break

      end switch

      _eventLog'bufferWriteText()

      drop object _eventLog

return 0

data2xml:

enter source$,err=*return

      /*

       * Convert a ProvideX data file to XML

       *

       * Steps:

       * - Check file header to verify source file is a ProvideX keyed file

       * - Read the resource properties (password)

       * - Convert the file to XML

       * - Tell Eclipse that there is a new resource and copy the properties

       *   of the old resource to the new one

       * - delete the old file; this will cause Eclipse to also delete the resource

       */

      local _eventlog,aMonitor

      _eventLog=new("ErrorLogBuilder",_pvxConstants,ViewManager)

      _eventLog'bufferAddText("  Convert ProvideX Keyed file to XML"+$0A$)

      _TMP$="", \

      _TMP=0;

      open input(hfn,isz=1,err=*next)source$;

      _TMP=lfo;

      read record (_TMP,ind=0,siz=8,err=*next)_TMP$

      if _TMP>0 \

      then close (_TMP)

      /* Must be a ProvideX keyed file - or it is ignored! */

      if pos(_TMP$="[Pvxkey][Pvxky2]",8)>0 \

      {

            /*

             * Create a reference to the Java ResourceManager in eclipse

             */

            def object resManager,"[wdx]com.pvx.ooadide.eventmanager.ResourceManager"

            /* Get the name of the source resource from the Resource Manager */

            file_obj=resManager'getFile(source$)

            file_name$=FILE_OBJ'getName$()

            /* Add an '.xml' extension to the name */

            file_dest$=file_name$+".xml", \

            new_dest$=source$+".xml"

            /*

             * Since a new file is to be created, the properties of the original file

             * (passed as arguments) must be associated with the new file.

             *

             * This is accomplished by telling the java ResourceManager to add the new property

             * and its value to the list of properties for the new file.  Once all processing has

             * been completed for this event, the list will be used to assign (or move) the

             * properties and values.

             */

            resManager'addtoPropertyUpdateList$(new_dest$,_pvxConstants'Output_File_Name$,file_name$)

            resManager'addtoPropertyUpdateList$(new_dest$,_pvxConstants'p_Password$,passwd$)

            drop object resManager

            /*

             * Get a handle to a ProgressMonitor...

             * - first, check for an existing instance of the class which is possible

             *   since the class is a singleton (unique)

             * - if there is already an instance, it is already showing the process of

             *   an event, so this task will not update it

             * - otherwise, since there is no existing monitor, a new one will be created

             *   to show the progress of this task.

             */

            isActive=0

            aMonitor=new("ProgressMonitor",err=*next);

            isActive=1

            if not(isActive) {

                  aMonitor=new("ProgressMonitor","Converting "+source$+" to XML",-1)

                  aMonitor'setTaskDetail("Processing...")

            } else {

                  aMonitor=0

            }

            /* do the conversion */

            call "pvxtoxml.pvx",err=*next,source$,new_dest$,passwd$,passwd_type$,status,aMonitor

            /*

             * if conversion was sucessful, delete original file

             * Otherwise, display failed status and message (reason)

             */

            if not(status) \

            then \

                  erase source$,err=*next;

                  _eventLog'bufferAddText("  ** Success **"+$0A$) \

            else \

                  _eventLog'bufferAddText("  ** Failed **"+$0A$+msg(status)+$0A$)

            ! Finished this file.

            if aMonitor {

                  aMonitor'done()

                  drop object aMonitor

            }

      }

      drop object _eventLog

return

xml2data:

enter source$,err=*next

enter *,dest$,err=*next

      local aKey,aMonitor,aText$,dE,dM,isActive,xDoc,xKeys,xSchema,xTable, \

                  _eventlog,_eraseSrc,domFile$

      if not(nul(source$)) and lcs(mid(source$,-4))=".xml" \

      {

            _eventLog=new("ErrorLogBuilder",_pvxConstants,ViewManager)

            _eventLog'bufferAddText( \

                  "  Convert XML file to ProvideX Keyed file"+$0A$+ \

                  source$+" ==> "+dest$+$0A$ \

                  )

            /*

             * Get a handle to a ProgressMonitor...

             * - first, check for an existing instance of the class which is possible

             *   since the class is a singleton (unique)

             * - if there is already an instance, it is already showing the process of

             *   an event, so this task will not update it

             * - otherwise, since there is no existing monitor, a new one will be created

             *   to show the progress of this task.

             */

            isActive=0

            aMonitor=new("ProgressMonitor",err=*next);

            isActive=1

            if not(isActive) {

                  aMonitor=new("ProgressMonitor","Convert XML to ProvideX Keyed",-1)

                  aMonitor'setTaskDetail("Converting "+source$+"...")

            } else {

                  aMonitor=0

            }

            /*

             * Convert a XML file into a ProvideX keyed file

             */

            if nul(dest$) {

                  dest$=mid(source$,1,len(source$)-4), \

                  _eraseSrc=1

            }

            call "xmltopvx.pvx",err=*next,source$,dest$,status,aMonitor

            /* check to see if conversion was sucessful */

            if not(status) \

            {

                  _eventLog'bufferAddText("  ** Success **"+$0A$)

                  if aMonitor {

                        aMonitor'setTaskDetail("Build DOM information...")

                  }

                  /* Now, create the DOM information for this source file */

                  _eventLog'bufferAddText("  .. Build DOM information"+$0A$)

                  /*

                   * Derive the name of the DOM file from the SOURCE file since the DEST

                   * does not exist as a resource yet.  Must also strip the ".xml" extension

                   * from the DomFile name.

                   */

                  dE=new("domEntity",source$,_pvxConstants'_iPvxData)

                  dM=new("domManager",dE)

                  domFile$=dM'getDOMFile$(), \

                  domFile$=mid(domFile$,1,len(domFile$)-4)

                  call %_PluginDir$+"get_FileInfo.pvx",err=*next,dest$,domFile$,0

                  call %_PluginDir$+"get_DictInfo.pvx",err=*next,dest$,domFile$+".dict",0

                  drop object dM

                  drop object dE

                  if _eraseSrc {

                        erase source$,err=*next

                  }

            } else {

                  _eventLog'bufferAddText("  ** Failed **"+$0A$+msg(status)+$0A$)

            }

            ! Finished this file.

            if aMonitor {

                  aMonitor'done()

                  drop object aMonitor

            }

            drop object _eventLog

      }

return

end